Стартовая страница

Полезные советы для Windows 7 от Nizaury v.3.78.

Полезные советы для Windows 7 - это сборник советов, в котором содержится полезная информация для простого решения ошибок и вопросов, возникающих при работе с Windows 7. Основная цель сборника: Помочь большему количеству пользователей перейти к работе с Windows 7 и уверенно ориентироваться в её среде.

Постоянная ссылка, на обновляющиеся версии сборников. Используйте её для скачивания новых версий.
Альтернативная постоянная ссылка (используйте, если у вас не скачивается по предыдущей).
Информацию о ссылках Вы также можете найти на официальном блоге(сайте) сборника.

Инструкция использования данного справочника

Общий список советов

Перейти к разделу:

Установка

Настройки

Администрирование

Интерфейс

Сети (Интернет и Локальная)

Тонкие настройки

Виртуализация

Твики Реестра

Устранение неполадок

Разное

История версий

Официальный блог(сайт) сборника: http://nizaury.blogspot.com
Гостевая книга на сайте: http://nizaury.blogspot.com/2009/12/blog-post_07.html

E-mail автора сборника: psdw7@delfi.lv


Инструкция использования данного справочника

1) Для полноценной работы со сборником, рекомендуется развернуть его на полный экран.

2) При нажатии на наименование совета в общем списке, Вы перейдете на отдельную страницу данного совета.

3) При нажатии на наименование совета в содержании, Вы перейдете на отдельную страницу данного совета.

4) При нажатии на наименование раздела в содержании, Вы перейдете на отдельную страницу данного раздела.

5) При нажатии на миниобраз изображения, он увеличится.

6) При нажатии на значок [image], а также при нажатии на увеличенное изображение или вне его, изображение закроется.

7) Если в совете несколько изображений, Вы можете переключаться между изображениями нажимая на [image] или [image], находящиеся слева или справа на изображении. Также для смены изображений Вы можете использовать колесо мыши.

8) При нажатии на кнопку "Показать" текст совета откроется на текущей странице.

Здесь расположен пример текста, чтобы Вам было понятно, как работает кнопка Показать/Скрыть.

9) Если текст, который Вам необходимо добавить в reg-файл, bat-файл, cmd-файл или другой файл имеется большое количество строк, то на странице раздела и на главной странице для компактности отображаемой информации появятся полосы прокрутки. Используйте их для перемещение вправо или вниз текста.

Полностью отображенный текст, без вертикальной полосы прокрутки, Вы сможете увидеть на отдельной странице совета.

10) Для выделения, копирования и вставки всего текста из текстового поля (идентичное отображенному выше) сделайте следующее:

10.1) Нажмите правой кнопкой мыши в любом месте текстового поля и выберите пункт Выделить все
10.2) Щелкните правой кнопкой мыши на выделенном тексте и выберите пункт Копировать (текст будет скопирован в буфер обмена)
10.3) Щелкните правой кнопкой мыши в окне текстового редактора и выберите пункт Вставить.

Правила поиска необходимой информации в справочнике.

Если Вам необходимо найти конкретный совет и Вы знаете с какого слова или фразы он начинается, то для его поиска:

1) Перейдите на вкладку Указатель, находящуюся рядом с вкладкой Содержание.
2) Введите ключевое слово или фразу для поиска и нажмите кнопку Вывести.

Если Вам необходимо найти совет, в котором есть искомое слово или фраза, то для его поиска:

1) Перейдите на вкладку Поиск, находящуюся за вкладкой Содержание.
2) Введите ключевое слово или фразу для поиска и нажмите кнопку Разделы.
3) В списке найденных советов, выберите необходимый Вам совет и нажмите кнопку Показать.

Добавление часто используемого совета в список Избранное.

Если Вам необходимо добавить часто используемый совет в Избранное, то для его добавления:

1) Откройте через Содержание, Указатель или Поиск совет, который Вы желаете добавить в Избранное.
2) Перейдите на вкладку Избранное, находящуюся за вкладкой Поиск.
3) Нажмите кнопку Добавить

Дополнительная информация.

При чтении большинства советов следует учитывать, особенности настроек системы, используемой автором сборника.

1) Система работает под управлением встроенной учетной записи администратора.
(Смотрите 11. Включение встроенной учетной записи администратора.)

2) Контроль учетных записей отключен.
(Панель управления -> Учетные записи пользователей -> Изменение параметров контроля учетных записей)

3) В окне Настройка меню "Пуск" (правой кнопкой мыши на кнопку Пуск -> Свойства -> Настроить) изменены настройки:

3.1) Переключатель Администрирование установлен в значение Отображать в меню "Все программы" и "Пуск".
3.2) Переключатель Панель управления установлен в значение Отображать как меню.
3.3) Установлен флажок Команда "Выполнить".

4) Параметры папок настроены следующим образом:

В разделе Щелчки мыши переключатель установлен в значение:
Открывать одним щелчком, выделять указателем -> Подчеркивать подписи значков при наведении.

В разделе Область переходов установлены оба флажка Показать все папки и Автоматически разворачивать до текущей папки.

Назад на главную.


Главная страница

Полезные советы для Windows 7 от Nizaury v.3.78.

Установка

1. Добавление вручную нового устройства (драйвера).

1) Нажмите кнопку Пуск, введите в строке поиска hdwwiz и нажмите Enter. (Win + R -> hdwwiz -> ОК)
2) В открывшемся окне, нажмите Далее (Next)
3) В следующем окне выберите Установка оборудования, выбранного из списка вручную. (Install the hardware that I manually select from a list) и нажмите Далее (Next)
4) Выберите в списке самую верхнюю строчку Показать все устройства (Show all devices) и нажмите Далее (Next)
5) В следующем окне нажмите на кнопку Установить с диска (Install From Disk), в нижнем правом углу.
6) В открывшемся окне нажмите кнопку Обзор (Browse) и укажите путь к файлу драйвера (inf-файл), затем нажмите ОК, а после Далее (Next)
7) Подтвердите желание установить нажатием Далее (Next)

2. Место сохранения обновлений полученных через Центр обновления Windows (Windows Update).

Все обновления, которые Вы скачиваете или устанавливаете через внутреннюю службу Windows Центр обновления Windows (Windows Update) хранятся в папке: C:\Windows\SoftwareDistribution\Download, а также в подпапках внутри неё. После установки обновлений, Вы можете сохранить их себе на компьютер просто скопировав из папки нужный Вам файл. Файлы содержащие в своем названии -express, могут повторно не установиться. Следовательно Вы можете их и не копировать.

3. Определение неизвестного устройства в Диспетчере устройств.

Узнайте VendorID(VEN) или DeviceID(DEV) устройства.

Данные сведения Вы можете узнать воспользовавшись Диспетчером устройств.
1) Откройте Пуск -> Панель управления -> Диспетчер устройств
2) Нажмите правой кнопкой мыши на необходимом Вам устройстве и выберите пункт Свойства
3) Перейдите на вкладку Сведения и в ниспадающем списке выберите ИД оборудования.
4) Зайдите на сайт: http://www.pcidatabase.com и введите одно из найденных Вами значений.

Если в указанной выше вкладке этого нет посмотрите также в вкладках:

Совместимые ИД
Путь к экземпляру устройства
Родитель
Родственные

там тоже это указывается.

4. Где можно найти драйвера, зная VendorID(VEN) или HardwareID(DEV)?

Здесь

5. Во время инсталяции, после копирования файлов, установщик (сама система) виснет.

Она не висит. Попробуйте выбрать другой монитор в персонализации - параметры дисплея. Это бывает, если у видеокарты два выхода. Такое состояние "зависания" может иметь разное время: от 2-3 минут до 25-30.

6. Установка Windows 7 с USB флеш-накопителя (флешки).

Вариант 1. Используя командную строку.

Подготовка USB флеш-накопителя (флешки) для будущей загрузки и установки Windows 7:

1) Подключаете USB флеш-накопитель (флешку) не менее 4 Гб к USB-порту.
2) В строке поиска меню Пуск вводите cmd.exe, щелкаете на найденном правой кнопкой мыши и нажимаете Запуск от имени администратора
3) Запускате утилиту управления дисками diskpart, дожидаетесь приглашения DISKPART>
4) Выполняете команду list disk (отображает список всех дисков ПК)
5) Ищете среди них Ваш диск USB, в моём примере это Disk 2
6) Выполняете команду select disk # (где # – это номер нашего USB-драйва, полученного в предыдущей команде). Для нашего случая – select disk 2. Данная команда указывает diskpart, что все дальнейшие операции будут проводиться с данным диском.
7) Выполняете команду clean (стирает все данные и разделы на USB диске)
8) Выполняете команду create partition primary (создание нового раздела на диске)
9) Выполняете команду select partition 1 (выбор раздела, как дальнейшего объекта для манипуляций)
10) Выполняете команду active – делаете выбранный раздел активным
11) Выполняете команду format fs=NTFS – форматируете раздел в файловую систему NTFS
12) Выполняете команду assign – активируете процесс подключения устройства, получения букв для созданных разделов (если автостарт опция включена – всплывает окно, как будто вы только что подключили USB-драйв)
13) exit – выходите из diskpart в командную строку.

Рисунок 1 из 2

14) Вставляете имеющийся у Вас дистрибутив Windows 7 в дисковод, или монтируете образ в виртуальный диск.
15) Допустим, что он у Вас установлен в дисковод H:, тогда в командной строке (не в diskpart !!!) выполняете команду:

где I: – буква, полученная только что подготовленным USB-драйвом.
Данная команда подменяет на диске I: файлы загрузчика на те, которые необходимы для загрузки Windows 7.
Битность базовой ОС и дистрибутива Windows должны быть одинаковыми .
16) Копируете все файлы с Вашего дистрибутива на Ваш USB флеш-накопитель (флешку). Используйте для этого либо Windows Explorer, либо команду:

Рисунок 2 из 2

Всё, USB-драйв готов. Загружаете ПК с полученного USB флеш-накопителя.

Для ускорения процесса копирования опытные пользователи могут воспользоваться программой RichCopy, она является графической оболочкой команды robocopy, и включает в себя большое количество настроек. В число многочисленных параметров входят сортировка файлов по атрибутам и папкам, предотвращение ошибок, смена атрибутов, тайминг копирования, редактирование отметки о времени, установка количества потоков и размера используемого кэша.

Вариант 2. Используя программу от Microsoft - Windows 7 USB/DVD Download Tool.

1) Скачайте программу Windows 7 USB/DVD Download Tool
2) Установите и запустите программу.
3) Укажите на первом шаге путь к Вашему ISO-файлу и нажмите кнопку Next.
4) Выберите на втором шаге пункт USB Device
5) Нажмите на третьем шаге кнопку Begin copying
6) На четвертом шаге запустится процесс создания установочного загрузочного флеш-диска.
7) По окончании процесса создания закройте программу

Вариант 3. Используя программу стороннего произодителя - UltraISO.

1) Вставьте Ваш флеш-диск в USB-порт.
2) Откройте ISO-образ Windows программой UltraISO

Так:

Щелкните на ISO-файле правой кнопкой мыши и выберите пункт Открыть, используя UltraISO

Или так:

В программе UltraISO в меню Файл нажмите на пункт Открыть, выберите нужный Вам образ Windows 7 и нажмите Открыть.

3) Убедившись, что образ открыт - выберите в меню Самозагрузка пункт Записать образ Жесткого диска
4) В списке Disk Drive:, выберите Ваш флеш-накопитель, в пункте Метод записи: USB-HDD+ и нажмите Записать.
5) В появившемся окне об уничтожении информации Подсказка, нажмите кнопку Да. Дождитесь, когда завершится запись (от 5 до 20 минут).
6) Не вынимая флеш-диска из USB-порта перезагрузите компьютер.
7) Сразу после начала перезапуска нажмите на клавиатуре Delete (Del), чтобы попасть в BIOS.
8) В BIOS установите загрузку в первую очередь с USB-HDD.
9) Сохраните настройки и выйдите из BIOS. Компьютер перезапуститься и начнет загрузку с флеш-накопителя.
10) Сама по себе установка мало чем отличается от установки с загрузочного DVD-диска, но есть один момент. Когда завершится копирование и распаковка файлов, и компьютер в первый раз пойдет на перезагрузку, нужно снова идти в BIOS и ставить обратно приоритет загрузки (по умолчанию с жесткого диска) или вытащить флешку. Иначе, возможно, загрузка снова пойдет с флеш-диска.

7. Интеграция языковых пакетов и обновлений в дистрибутив Windows 7.

Вариант 1 вручную с помощью DISM.

Для работы Вам потребуются программа DISM, входящая в состав Windows 7 и программа UltraISO

Внесение изменений в install.Wim (Для добавления языка в систему, которую Вы установите)
1) Создаете на диске D: папки ISO, Lip, Mount и mWim
2) Распаковываете в папку D:\ISO iso-образ Вашего установочного диска.
3) Изменяете текст файла lang.ini в папке D:\ISO\sources на следующий:

4) Копируете файл языкового пакета lp.cab и все файлы обновлений (MSU и CAB) в папку Lip
5) Создаете в папке D:\Lip папку uLip
6) Перемещаете из папки D:\ISO\Sources в папку D:\mWim файл install.wim
7) Запускаете командную строку от имени администратора (Win+R -> cmd -> ОК)
8) Узнаете номер индекса Вашей Windows 7, используя команду:

9) Монтируете файл install.wim в папку D:\Mount учитывая номер индекса Вашей операционной системы (Например, для Windows 7 Enterprise независимо от разрядности он равен 1, для 32-битной версии Windows 7 Ultimate он равен 5, а для 64-битной версии Windows 7 Ultimate он равен 4), используя команду:

10) Интегрируете языковой пакет и обновления:
Для интеграции языкового пакета введите команду:

Для интеграции обновления, используйте команду аналогичную предыдущей, подставляя вместо lp.cab, наименование интегрируемого обновления. Вот пример интеграции произвольного обновления:

11) Применяете все настройки для русского языка командой:

Примеры запуска команд DISM для установки локальных настроек:

12) Демонтируете образ с сохранением изменений:

Демонтаж без сохранения:

13) Удаляете файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

14) Перемещаете файл install.wim из папки D:\mWim в папку D:\ISO\Sources Внесение изменений в Boot.Wim (Для добавления языка в программу установки запускаемую с установочного DVD или флеш-диска при старте компьютера)
1) Распаковываете lp.cab в папку D:\Lip\uLip

2) Очищаете папку D:\Mount (удаляете из нее любые следы, которые могли остаться от работы с файлом install.wim)
3) Перемещаете из папки D:\ISO\Sources в папку D:\mWim файл boot.wim
4) Монтируете файл boot.wim в папку D:\Mount (индекс указываете 2, так как он соответствует программе установки)

5) Добавляете в boot.wim русский язык:

6) Добавляете в boot.wim файлы лицензий:

7) Изменяете текст файла lang.ini в папке D:\Mount\sources на следующий:

8) Демонтируете файл boot.wim с сохранением:

9) Перемещаете файл boot.wim из папки D:\mWim в папку D:\ISO\Sources Работа с папкой будущего образа. 1) Добавляете русский язык, в программу установки запускаемую в среде Windows или с Live-CD:

2) Добавляете файлы лицензий, в программу установки запускаемую в среде Windows или с Live-CD.:

3) Удаляете с диска D: папки Lip, Mount и mWim
4) Используя программу UltraISO создаете iso-образ установочного диска.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программой DISM Tool. Данная программа позволяет выполнять, все необходимые Вам команды, используя графический интерфейс. С помощью неё Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(используйте пункт Add Packages).

Вариант 2. Используя программу RT Se7en Lite.

Данная программа интегрирует языковой пакет только в будущую систему (install.wim). Программа установки (boot.wim) остается на оригинальном языке.

1) Распакуйте ISO-образ установочного диска (в который Вы собираетесь интегрировать сервисный пакет) в любую папку.
2) Скачайте, установите и запустите программу RT Se7en Lite.
3) Нажмите кнопку Browse и выберите пункт Select OS Path.
4) Укажите путь к папке в которую Вы распаковали ISO-образ установочного диска и нажмите ОК.
5) В появившемся окне List of operating system выберите Вашу редакцию Windows 7 и нажмите ОК.
6) В столбце слева нажмите кнопку Task и в открывшемся окне установите флажок Integration.
7) В столбце слева нажмите кнопку Integration.
8) Перейдите на вкладку Language Packs и нажмите кнопку Add.
9) Укажите путь к Вашему cab-файлу языкового пакета и нажмите Открыть.
10) Нажмите кнопку Apply, а затем кнопку Commit.
11) В окне Do you want to enable ISO bootable task? нажмите Да.
12) Нажмите кнопку Finish, а затем кнопку Да.
13) Используя программу UltraISO создаете iso-образ установочного диска.

Вариант 3 с помощью интегратора

1) Скачайте Интегратор обновлений и языковых пакетов Windows 7
2) Запустите его
3) Укажите (выберите) необходимы вам опции.
4) Нажмите на кнопку Выполнить
5) Дождитесь успешного выполнения и увидите результат.

Вариант 4 с помощью командного файла скрипта.

1) Скачайте LPIntegrator.zip
2) Распакуйте скачанный архив в папку
3) Нажмите правой кнопкой мыши на файле LPIntegrator.bat и щелкните на пункте меню Изменить
4) Измените значение параметра set LANG=ru-RU, на язык интегрируемого языкового пакета, где en-US - для английского языка, de-DE - для немецкого языка и т.д.
5) Сохраните изменения и закройте редактирование.
6) Запустите LPIntegrator.bat
7) Выберите версию Вашего образа Windows 7
8) Распакуйте ISO-образ в папку C:\7Work\DVD или скопируйте туда все файлы Вашего инсталляционного диска.
9) Скопируйте языковой пакет, который Вы хотите интегрировать в папку C:\7Work\LP
10) Скопируйте обновления, которые Вы хотите интегрировать в папку C:\7Work\CABS
11) Нажмите любую клавишу(например, Enter) для продолжения.

8. Добавление и использование новых языков интерфейса в Windows.

Для добавления языков интерфейса необходимо установить дополнительные языковые файлы. После установки языковых файлов можно просматривать текст мастеров, диалоговых окон, меню, разделов справки и прочих элементов Windows на другом языке. Существуют 2 варианта добавления новых языков интерфейса: первый - через Центр обновления Windows(Windows Update), а второй - скачав и установив файл языкового пакета вручную. Перед началом работы измените в Панели Управления (Control Panel) способ просмотра(View by), вместо Категория(Category) на Крупные (Large icons) или Мелкие значки(Small icons).

Вариант1. Через Центр обновления Windows(Windows Update)

1) Откройте Центр обновления Windows

Пуск -> Все программы -> Центр обновления Windows (Start -> All Programs -> Windows Update)
или
Панель управления\Все элементы панели управления\Центр обновления Windows (Control Panel\All Control Panel Items\Windows Update)

1a) Также вы можете нажать Win+R, в поле Выполнить ввести указанную ниже команду и нажать ОК

2) Выберите пункт Необязательных обновлений XX шт. доступны (XX options updates are available)
3) Поставьте флажок напротив нужного Вам языкового пакета (Language Pack) и нажмите ОК

Вариант 2. При наличии файла языка интерфейса lp.cab

1) Заходите в Панель Управления(Control Panel)
2) Открываете Язык и региональные стандарты (Regional and Language)
3) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
4) Нажимаете Установить или удалить язык (Install/uninstall languages...)
4a) Также вы можете нажать Win+R, в поле Выполнить ввести lpksetup и нажать ОК
5) Нажимаете Установить языки интерфейса (Install display languages)
6) Нажимаете кнопку Обзор...(Browse...)
7) Указываете путь к папке с lp.cab и нажимаете ОК
8) Выбираете необходимый Вам язык и нажимаете Далее(Next)

Вариант 3. Установка файла скачанного с сервера Windows Update

Вы можете установить необходимый Вам язык интерфейса, скачав exe-файл по прямой ссылке с сервера Windows Update и просто запустив его.

Смена Вашего языка интерфейса на новый:

1) Заходите в Панель Управления(Control Panel)
1.1) Открываете Язык и региональные стандарты (Regional and Language)
1.1a) Также вы можете нажать Win+R, в поле Выполнить ввести intl.cpl и нажать ОК
1.2) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
2) Выбираете в пункте Выберите язык интерфейса (Choose a display language:) нужный Вам язык и нажимаете ОК
3) Нажимаете кнопку Выйти из системы сейчас (Log off now)
4) В появившемся экране выбираете своего пользователя.
5) В случае необходимости вводите свой пароль и попадаете в Windows на выбранном Вами языке

9. Автоматическое введение ключа при инсталляции Windows.
Создайте файл Autounattend.xml с указанным ниже текстом и скопируйте данный файл в корневую папку и в папку \Sources установочного диска.
Вместо xxxxx-xxxxx-xxxxx-xxxxx-xxxxx введите Ваш ключ.

Вариант 1. Для 32-битных систем.

Если у Вас ключ для Retail или OEM версии, то создайте файл Autounattend.xml следующего содержания:

Если у Вас MAK-ключ, то создайте файл Autounattend.xml следующего содержания:

Вариант 2. Для 64-битных систем.

Если у Вас ключ для Retail или OEM версии, то создайте файл Autounattend.xml следующего содержания:

Если у Вас MAK-ключ, то создайте файл Autounattend.xml следующего содержания:

10. Отключение проверки цифровой подписи драйверов и её добавление в 64-битных Windows 7.

Многие из нас сталкивались с проблемой установки неподписанного драйвера. Например, необходимо поставить драйвер какой-либо программы, но ее драйвер не устанавливается, ибо у него нет цифровой подписи.

В качестве решения Вы можете либо отключить проверку подписи, либо попытаться самостоятельно добавить к нему подпись.

Если Вам необходимо поработать с программой, устанавливающий свой драйвер без перезагрузки системы, то Вы можете загрузиться в специальный режим Windows.
1) Сразу после включения компьютера нажмите F8. Далее Вы попадете либо в меню Дополнительные варианты загрузки, либо в меню выбора диска для загрузки.
2) Вам нужно меню Дополнительные варианты загрузки, поэтому если Вы попали в меню выбора дисков, то выберите диск на котором установлена Ваша Windows и нажмите Enter, а затем быстро нажмите F8 до начала запуска Windows.
3) Выберите пункт Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) и нажмите Enter
Вы загрузитесь в специальный режим Windows, на котором будет только отключена проверка подписи, а все остальные функции будут работать в обычном режиме. После перезагрузки компьютера Вы вернетесь обратно в обычный режим с проверкой драйверов.
Иногда при установке драйвера в этом режиме система может выдать сообщение, что драйвер не подписан, просто закройте его и система нормально установит драйвер.

Чтобы самостоятельно подписать драйвер Вам понадобиться программа Driver Signature Enforcement Overrider(DSEO). Она позволяет создавать свои собственные непроверенные свидетельства. Для нормальной работы программы Контроль учетных записей (User Account Control (UAC)) должен быть выключен.

Скачать:

С официального сайта
С зеркала

1) Запускаете программу и нажимаете Next, а затем Next
2) Выбираете пункт "Enable Test Mode" и нажимаете Next
3) Выбираете пункт "Sign a System File" и нажимаете Next
4) Указываете имя Вашего файла, включая путь к нему и нажимаете Next
Например, если файл драйвера InetLock.sys расположен в каталоге C:\Windows\System32\Drivers, то Вам необходимо указать C:\Windows\System32\Drivers\InetLock.sys. В случае если необходимо подписать несколько файлов, то просто повторите эту процедуру несколько раз.
5) Перезапускаете компьютер
6) Устанавливаете необходимый Вам драйвер и пользуетесь им.

Иногда на рабочем столе возле часов может появиться маленькая надпись, сообщающая версию сборки операционной системы и тот факт, что Вы работаете в тестовом режиме. Для убирания данной надписи воспользуйтесь советом "6. Удаление надписей из правого нижнего угла рабочего стола." из раздела "Тонкие настройки".

Данный режим также как и описанный в предыдущем варианте является штатным методом, предусмотренным Microsoft для тестирования разработчиками новых версий своих драйверов.
Отключить тестовый режим Вы можете просто запустив программу, выбрав пункт "Disable Test Mode" и нажав Next.

Плюсы данных методов в том, что они не изменяют загрузчик системы или какие-либо её системные файлы.

Также Вы можете скачать и установить программу ReadyDriverPlus она добавит небольшое изменение в загрузчик, которое автоматизирует процесс выбора Вами пункта Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) при загрузке.

При правильном указании загрузочной папки Boot, данная программа будет работать у большинства пользователей. В программе ReadyDriverPlus на этапе выбора пути к папке Boot, по умолчанию, указан путь C:\Boot. Так как папка Boot с загрузочными файлами Windows 7 может располагаться не только на диске С:\ , то прежде чем продолжить установку ReadyDriverPlus выясните, где у Вас находится папка Boot.

Папка Boot может располагаться (рекомендации по нахождению):

1) На том же разделе, где у Вас установлена Windows 7

1.1) Откройте Проводник -> Компьютер -> Локальный диск (C:)
1.2) В Панели меню выберите Сервис -> Параметры папок
1.3) Уберите флажок со значения Скрывать защищенные системные файлы
1.4) Установите переключатель в значение Показывать скрытые файлы, папки и диски
1.5) Смотрите в Проводнике, если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

2) На скрытом разделе 100 мегабайт (присвойте ему букву, для его выбора)

2.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
2.2) Введите diskmgmt.msc
2.3) Найдите раздел размером 100 мегабайт. Если у Вас его нет, то читайте о другом месте нахождения папки Boot.
2.4) Так как данный раздел скрыт, то нам для указания его необходимо сделать его видимым. Для этого щелкните на нем правой кнопкой мыши и выберите пункт Изменить букву диска или путь к диску, затем Изменить, назначьте букву(Например: Z) и нажите OK
2.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска, в нашем примере Z:)
2.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

После установки программы ReadyDriverPlus снова пройдите в меню Изменить букву диска или путь к диску, но только выберите пункт Удалить, тем самым Вы сделаете его снова Скрытым

3) На крайнем слева разделе, от того на который установлена Ваша Windows

3.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
3.2) Введите diskmgmt.msc
3.3) Найдите крайний слева раздел, от того на который установлена Ваша Windows
3.4) Если он является активным, то запомните его букву, если он не является активным, то читайте о другом месте нахождения папки Boot.
3.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска)
3.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

4) На другом, являющимся активным разделе жестком диска.

4.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
4.2) Введите diskmgmt.msc
4.3) Найдите раздел жесткого диска являющийся активным
4.4) Запомните его букву
4.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска)
4.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

При установке программы ReadyDriverPlus, на этапе выбора пути к папке Boot, укажите путь к диску, где мы её обнаружили (Например: Z:\Boot или D:\Boot). После установки программы ReadyDriverPlus перезагрузитесь.

В процессе загрузки система даст Вам три секунды для выбора варианта загрузки: обычного или без проверки подписи. Если Вы не будете выбирать обычный режим, то система сама постоянно будет загружать Вас в режим без проверки подписей.

11. Где можно скачать последние обновления для Windows 7?

Компания Microsoft периодически выпускает обновления для Windows 7. Но не все из них включены в Центр обновления Windows (Windows Update) и не все они присутствуют в Каталоге Центра обновления Майкрософт

Все последние версии обновлений, Вы можете скачать:

Без регистрации на сайте: http://kbupdate.info/
Используя регистрацию на форуме http://forum.ru-board.com После регистрации открыть тему Компьютерный форум Ru.Board » Андеграунд » Варезник и отфильтровать по значению Обновления для Microsoft Windows 7.

12. Повышение оценки производительности жесткого диска.
Перед установкой Windows, зайдите в BIOS и укажите режим работы IDE/SATA-контроллера чипсета, как AHCI.

В разных BIOS, опции для настройки режима работы IDE/SATA-контроллера чипсета, могут иметь разные названия. Например:

Configure SATA As
SATA RAID/AHCI Mode
Onboard SATA Type
SATA Controller Mode

Менять режим работы стандартного IDE/SATA-контроллера чипсета необходимо до установки операционной системы.
Если система установлена, простая смена режима в BIOS приведет к появлению «синего экрана смерти».

Для устранения неполадок перед изменением режима SATA загрузочного диска включите драйвер AHCI в реестре. Для этого выполните следующие действия:

1) Закройте все программы Windows.
2) Откройте меню Пуск, в окне Начать поиск введите regedit и нажмите клавишу ВВОД.
3) Если откроется окно Учетные записи пользователей, нажмите кнопку Продолжить.
4) Найдите и выберите один из следующих подразделов реестра:

5) На правой панели щелкните правой кнопкой мыши параметр Start в столбце Имя, затем нажмите Изменить.
6) В поле Значение введите 0 и нажмите кнопку ОК.
7) В меню Файл выберите команду Выход, чтобы закрыть редактор реестра.

13. Автоматическая установка OEM-информации.

Предлагаю Вашему вниманию файл ответов, позволяющий автоматизировать процесс установки Windows путем занесения ответов на вопросы инсталлятора в специальный файл.
Создайте файл Autounattend.xml с указанным ниже текстом и скопируйте данный файл в корневую папку и в папку \Sources установочного диска.

Используемые параметры:

Extend - расширение раздела до размеров всего свободного неразмеченного пространства на диске. Если установлено значение true, раздел будет расширен. Если установлено значение false, необходимо указать размер с помощью параметра Size. Для каждого раздела задается либо значение параметра Extend, либо значение параметра Size, но никак не оба.
Order - порядковый номер операции по созданию раздела на диске. Нумерация начинается с единицы. В примере указано значение 1, т. е. раздел будет создан первым.
Size - размер раздела в мегабайтах.В первый раздел будет установлена Windows 7, поэтому не рекомендуется создавать раздел малого размера.
Type - тип раздела. Можно создать основной (Primary) или дополнительный (Extended) раздел.
Active - назначает раздел активным. Для назначения используется значение true. Так как на основной раздел установится Windows 7, то этот раздел следует назначить активным.
Format - формат файловой системы. Установка Windows 7 возможна только на файловую систему NTFS.
Label - метка тома. Установите по своему усмотрению.
Letter - буква диска. Логично задать для первого раздела букву C.
PartitionID - идентификатор раздела, по сути - его порядковый номер. Нумерация начинается с единицы.
DiskID - идентификатор диска. Значение 0 обозначает первый физический диск
NetworkLocation - задает тип сети, к которой подключается пользователь
WillWipeDisk - удаление всех разделов жесткого диска. Если установлено значение true, все разделы будут удалены.
WillShowUI - отображение интерфейса программы установки. Значение OnError предписывает программе установки отображать интерфейс в случае ошибки.
InputLocale - раскладка клавиатуры.
SystemLocale - язык для программ, не поддерживающих Юникод. Для русской Windows 7 указывается ru-RU, а для английской - en-US.
UILanguage - язык интерфейса операционной системы.
UserLocale - пользовательские параметры отображения чисел, денежных единиц, дат и времени.
Вместо xxxxx-xxxxx-xxxxx-xxxxx-xxxxx введите Ваш ключ.
Для 32-битных систем замените значение processorArchitecture="x64" на processorArchitecture="amd86"

Внимание!!! Предложенный файл ответов в данном совете стирает все разделы и логические диски при установке.

Для редактирования файла Autounattend.xml в графическом режиме воспользуйтесь программой Windows System Image Manager (WSIM), входящей в состав Microsoft Windows AIK.
Если же Вас интересует только, автоматический ввод ключа или OEM-Logo, обратитесь к советам 9 и 14 данного раздела.

14. Автоматическая установка OEM-Logo.

Создайте файл Autounattend.xml с указанным ниже текстом и скопируйте данный файл в корневую папку и в папку \Sources установочного диска.

1) Создайте в папке \Sources установочного диска папки: \$OEM$\$$\SYSTEM32\
2) Скопируйте Ваш файл oemlogo.bmp, содержащий изображение с Вашим логотипом в папку \Sources\$OEM$\$$\System32\oemlogo.bmp установочного диска.
3) Для 64-битных систем замените значение processorArchitecture="x86" на processorArchitecture="amd64"

15. Установка локальных наборов тем и настроек, а также пакетов обновления, предоставленных в виде CAB-файлов.

Чтобы добавить локальный набор тем и настроек в Windows, выполните следующие действия:

1) Найдите локальный набор тем и настроек и скопируйте его в доступное расположение.
2) Запустите командную строку от имени администратора.
2.1) Нажмите кнопку Пуск и в строке поиска введите cmd
2.2) Щелкните правой кнопкой мыши на найденном файле cmd.exe и выберите пункт Запуск от имени администратора
3) В окне командной строки введите следующую команду:

Например, если Вы скопируйте файл Windows-LocalPack-RU-Package.cab в папку «C:\Local Packs», то Вам необходимо будет ввести следующую команду:

Содержимое всех локальных наборов тем и настроек устанавливается в ходе работы программы установки Windows в скрытый каталог "%WINDIR%\globalization\MCT"

Описанным выше способом, можно установить любой пакет обновления, предоставленный в виде CAB-файла.

16. Автоматическая установка обновлений Windows.

Вариант 1. Использование Bat-файла (для MSU и CAB обновлений).

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .bat
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "Update.bat")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

5) Рядом с bat-файлом создайте папки CAB и MSU.
6) Поместите обновления .msu в папку MSU и .cab в папку CAB.
7) Запустите Update.bat и дождитесь закрытия окна командной строки.

Для правильности работы скрипта проверьте у себя соблюдение следующих пунктов:

1) Проверьте разрядность обновлений (х86\х64)
2) В имени файла не должно быть слова EXPRESS, такое обновление копировать бесполезно, оно не установится.
3) Файл Update.bat должен находиться в папке на один уровень выше папок CAB и MSU.

Скачать готовый Update.bat

Вариант 2. Использование программы Windows 7 Update Pack Tool.

Наиболее простым решением для автоматической установки обновлений является программа Windows 7 Update Pack Tool.

Инструкция:

1) Скачайте Windows 7 Update Pack Tool
2) Создайте новую папку. Например: Updates
3) Поместите в неё файл Update.exe
4) Поместите в неё все обновления с расширениями .msu и .cab, которые Вы желаете установить.
5) Создайте внутри Вашей папки Updates папку SpecialUpdates
6) Поместите в папку SpecialUpdates все обновления с расширениями .msi и .exe, которые Вы желаете установить.
7) Запустите файл Update.exe
8) Выберите пункт Install updates. Для этого нажмите на клавиатуре цифру 1 и затем Enter
9) Программа произведет поиск обновлений: .msu и .cab в главной папке, и .msi и .exe в папке SpecialUpdates
10) Нажмите любую клавишу(например: Enter) и программа установит обновления
11) По окончании установки программа напишет список устанавливаемых обновлений и попросит перезагрузки.
12) Перезагрузите компьютер и Вы получите систему с установленными обновлениями.

17. Отключение сообщения "Эта программа, возможно, установлена неправильно".

Если при установке какого-либо приложения Вы решили отменить установку или в случае, когда с приложением были известны какие-либо проблемы совместимости, Windows может отобразить подобное окно:

За данную функцию отвечает "Помощник по совместимости программ". Вы можете отключить его используя следующие варианты:

Вариант 1.

1) В строке поиска меню Пуск или в окне Выполнить (Win+R) введите services.msc и нажмите Enter
2) Щелкните дважды на службу "Служба помощника по совместимости программ" ("Program Compatibility Assistant") или щелкните правой кнопкой мыши на ней и выберите Свойства
3) Измените значение Тип запуска на "Отключено".
4) Нажмите кнопку Остановить ("Stop")

Вариант 2.

1) В строке поиска меню Пуск или в окне Выполнить (Win+R) введите gpedit.msc и нажмите Enter
2) Перейдите в Конфигурация пользователя\Административные шаблоны\Компоненты Windows\Совместимость приложений
3) Щелкните дважды на параметре "Отключение помощника по совместимости программ" или щелкните правой кнопкой мыши на нем и выберите Изменить
4) Выставите значение "Включить".

18. Добавление или замена языка интерфейса в Windows 7 Home или Windows 7 Professional.

На большинстве новых моделей ноутбуков или стационарных компьютеров изначально установлена Windows 7 Home Basic, Windows 7 Home Premium или Windows 7 Professional. Данные версии не поддерживают установку нового языка и его смену, используя стандартные возможности Windows. Если Вам необходимо изменить язык в одной из таких версий Windows 7, то порядок действий следующий.

1) Создайте папку, в которой будут выполняться все промежуточные операции, например C:\Work.
1.1) Откройте Explorer (анг.) или Windows-Explorer (нем.) или Проводник (рус.) и перейдите на диск C:
1.2) Щелкните правой кнопкой мыши и выберите New -> Folder (анг.) или Neu -> Ordner (нем.) или Создать -> Папку (рус.)

2) Создайте папку для языкового файла C:\Lang, куда переложите lp.cab.
Чтобы добыть файл lp.cab из exe-установщика языкового пакета, запустите скаченный exe-файл и когда рядом появится файл lp.cab быстро скопируйте его.

3) Перезагрузите компьютер в Windows Boot Manager (анг.) или Windows-Start-Manager (нем.) или Диспетчер загрузки Windows (рус.), для этого нажмите клавишу F8 после экранов BIOS, но до появления загрузочного экрана системы.
4) В списке установленных систем выберите Windows 7, и еще раз нажмите клавишу F8.
5) В появившемся списке вариантов загрузки Advanced Boot Options (анг.) или Erweiterte Startoptionen (нем.) или Дополнительные варианты загрузки (рус.) выберите первый пункт — Repair Your Computer (анг.) или Computer reparieren (нем.) или Устранение неполадок компьютера (рус.).
6) В списке инструментов выберите командную строку Command Prompt (анг.) или Eingabeaufforderung (нем.) или Командная строка (рус.).
7) Найдите имя диска, где установлена Windows 7. Переходите между дисками, используя C:, D: и т.д. и найдите текущий по содержимому с помощью команды dir.
Для примера предположим, что Вы обнаружили Windows на диске D: . Далее работаем с DISM (Deployment Image Servicing and Management tool).

Далее приводится последовательный алгоритм команд, выполнив которые, вы получите локализованную версию вашей Windows 7.

1) Проверьте список языковых пакетов, установленных в системе.

Параметр /image:d: указывает, что Вы нашли папку Windows и Program files, т.е. установленную Windows 7 на диске D: .
Если в списке пакетов, Вы обнаружили необходимый Вам, содержащий строку 'Client-LanguagePack', то добавлять новый языковой пакет не надо и Вы можете перейти к 3 шагу.
2) Установите новый языковой пакет в систему.

Параметр /scratchdir указывает папку, в которую для обработки будет распаковано содержимое lp.cab.
3) Укажите системе язык, необходимый для использования по умолчанию.

Это может быть любой из установленных в системе языков, например en-US или de-DE.
4) Проверьте установленные языковые параметры:

Если напротив строки Default system UI language: (анг.) или Standardmäßige Benutzeroberflächenschprache des Systems (нем.) или Язык пользовательского интерфейса по умолчанию: (рус.) указан код вашего языка, то закройте окно и перезагрузите компьютер.
5) В Windows 7 запустите командную строку с правами администратора (Нажмите Win+R -> введите cmd -> OK)
6) Смените язык экрана загрузки.

или тот код языка, который нужен.
7) Смените язык менеджера загрузки (вызывается клавишей F8 перед загрузкой Windows)

Внимание: DISM может выдать ошибку доступа в том случае, если вы открывали в командной строке какие-либо папки на разделе с системой. В этом случае сначала верните командную строку в корень этого раздела, выполнив команду cd \ .

19. Проверка установленных версий .NET Framework и установка отсутствующих.

«.NET Framework – всесторонняя и согласованная модель программирования Майкрософт для построения приложений, обладающих превосходным интерфейсом пользователя, прозрачными и безопасными средствами связи, а также возможностью создания разнообразных бизнес-процессов». Платформа .NET Framework используется для разработки и последующего запуска приложений. Если разработчик пишет приложение с использованием одной из версий .NET Framework, то для запуска этого приложения потребуется аналогичная версия .NET Framework на компьютере пользователя.

.NET Framework 1.0 - 1.1

Версия 1.0 практически не используется, в состав ОС не входит.
Версия 1.1 используется редко, в состав ОС не входит. Устанавливать только при необходимости.

Если установка .NET Framework 1.1 и пакета обновления (SP1) завершаться ошибкой, то в ручном режиме данная программа устанавливается так:

1) Создайте на диске С: папку DotNet в корне диска "С" (C:\DotNet).
2) Скачайте в созданную папку Скачать .NET Framework 1.1 Redistributable (dotnetfx.exe) и Service Pack 1 для .NET Framework 1.1 (NDP1.1sp1-KB867460-X86.exe) .
3) Запустите командную строку с правами администратора. (Win+R -> cmd.exe -> OK)
4) Последовательно введите следующие команды и подтвердите выполнение каждой из них клавишей "Enter":

5) Ответьте положительно на вопросы в диалоговых окнах и продолжите ввод команд:

После ввода последней команды начнётся установка. Через несколько минут окна автоматически закроются - установка завершена.

.NET Framework 2.0 - 3.5.1

Версии 2.0 - 3.5.1 являются компонентами Windows 7 (Пуск -> Панель управления -> Программы и компоненты -> Включение и отключение компонентов Windows).

.NET Framework 4.0

Полная версия .NET Framework 4.0 предназначена в первую очередь для разработчиков ПО, клиентский профиль разработан для выполнения клиентских приложений и обеспечения быстрого развёртывания технологий Windows Presentation Foundation (WPF) и Windows Forms. Клиентский профиль распространяется в виде рекомендуемого обновления KB982670.

Скачать .NET Framework 4 (Полная версия)
Скачать .NET Framework 4 (Клиентский профиль)

Проверка наличия установленных версий

Вы можете проверить какие версии .NET Framework установлены в Вашей системе воспользовавшись программой .NET Version Detector

Или открыв ветку системного реестра (Win+R -> regedit -> Ok): HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP

20. Быстрый запуск командной строки из среды предустановки Windows.

Если Вам необходимо быстро воспользоваться окном команд (командной строкой) за пределами основной среды Windows, и у Вас есть установочный DVD или флеш-диск, то Вы можете запустить командную строку сразу из первого окна программы установки Windows. Чтобы выполнить это сделайте следующее:

1) Загрузитесь с установочного DVD или флеш-диска
2) В первом окне нажмите сочетание клавиш Shift+F10.

Откроется окно команд (командная строка) в которой Вы сможете либо ввести необходимую Вам команду, либо запустить необходимую Вам программу.

21. Интегрирование Сервисного Пакета в установочный ISO-образ Windows 7.

Вариант 1. При помощи команды Dism.

1) Создайте папки необходимые для работы (Например, на диске D: папки Temp, SP1, mWim и Mount)
2) Откройте окно команд в папке, где у Вас находится exe-файл сервисного пакета
2.1) Удерживая нажатой клавишу Shift щелкните правой кнопкой мыши на папке в области переходов.
2.2) В контекстном меню выберите пункт Открыть окно команд
3) Распакуйте exe-файл сервисного пакета во временную папку, используя команду:
Для 64-битной версии:

Для 32-битной версии:

4) Закройте окно команд.
5) Откройте в проводнике папку D:\Temp и запустите в ней окно команд как описано в пункте 2.
6) Распакуйте cab-файл KB976932, используя команду:
Для 64-битной версии:

Для 32-битной версии:

7) Закройте окно команд.
8) Откройте в проводнике папку D:\SP1 и запустите в ней окно команд как описано в пункте 2.
9) Распакуйте все cab-файлы языков в папку D:\SP1, поочередно выполнив команды (соглашаясь, если система спросит о перезаписи):

10) После окончания распаковки удалите все cab-файлы языков, используя команду:

11) Распакуйте cab-файл NestedMPPContent.cab в папку D:\SP1, используя команду (соглашаясь, если система спросит о перезаписи):

12) После окончания распаковки удалите cab-файл NestedMPPContent.cab, используя команду:

13) Удалите из папки D:\SP1 файлы cabinet.cablist.ini и old_cabinet.cablist.ini, используя команду:

14) Закройте окно команд.
15) В папке D:\SP1 откройте в любом текстовом редакторе файл update.ses, замените все Absent на Installed и сохраните изменения.
16) В папке D:\SP1 откройте в любом текстовом редакторе файл update.mum, замените allowedOffline="false" на allowedOffline="true" и сохраните изменения.
17) В папке D:\SP1 откройте в любом текстовом редакторе файл Для 64-битной версии: Windows7SP1-KB976933~31bf3856ad364e35~amd64~~6.1.1.17514.mum

или

Для 32-битной версии: Windows7SP1-KB976933~31bf3856ad364e35~x86~~6.1.1.17514.mum, замените allowedOffline="false" на allowedOffline="true" и сохраните изменения.
18) Скопируйте файл install.wim из папки \Sources Вашего установочного ISO-образа в папку D:\mWim
19) Узнаете номер индекса Вашей Windows 7, используя команду:

20) Монтируете файл install.wim в папку D:\Mount учитывая номер индекса (Например, для 64-битной версии Windows 7 Enterprise он равен 1), используя команду:

21) Интегрируете сервисный пакет, используя команду:

22) Демонтируйте образ с сохранением изменений, используя команду:

23) Удалите файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

24) Если Вас устраивает размер получившегося файла install.wim, то замените файл install.wim из папки \Sources Вашего установочного ISO-образа, файлом D:\mWim\install.wim
25) Если Вас не устраивает размер получившегося файла install.wim, то Вы можете осуществить его сжатие.

25.1) Скачайте и установите Windows Automated Installation Kit 2.0 (ссылка) или выше.
25.2) Создайте дополнительную папку необходимую для работы (Например, на диске D: папку Compress)
25.3) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
25.4.1) Если в Вашем install.wim содержится один образ (Например: Windows 7 Enterprise), то введите следующую ниже команду, нажав после ее ввода клавишу Enter:

25.4.2) Если в Вашем install.wim содержится несколько образов (Например: Windows 7 Ultimate), то для создания итогового файла install.wim выполните указанную выше команду для каждого образа, заменяя индекс 1 на соответствующий, и нажимая после ввода каждой из них клавишу Enter.

Например для 32-битной версии Windows 7 Ultimate:

Например для 64-битной версии Windows 7 Ultimate:

26) Замените файл install.wim из папки \Sources Вашего установочного ISO-образа, файлом D:\Compress\install.wim
27) Удалите папки Compress, Mount, mWim, SP1 и Temp.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программой DISM Tool. Данная программа позволяет выполнять, все необходимые Вам команды, используя графический интерфейс. С помощью неё Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(используйте пункт Add Packages).

Вариант 2. Используя программу RT Se7en Lite.

1) Распакуйте ISO-образ установочного диска (в который Вы собираетесь интегрировать сервисный пакет) в любую папку.
2) Скачайте, установите и запустите программу RT Se7en Lite.
3) Нажмите кнопку Browse и выберите пункт Select OS Path.
4) Укажите путь к папке в которую Вы распаковали ISO-образ установочного диска и нажмите ОК.
5) В появившемся окне List of operating system выберите Вашу редакцию Windows 7, установите флажок Slipstream Service Pack и нажмите ОК.
6) В появившемся окне RT Service Pack Slipstream нажмите нопку Browse
7) Укажите путь к exe-файлу сервисного пакета (windows6.1-KB976932-X64.exe или windows6.1-KB976932-X86.exe) и нажмите Открыть.
8) Нажмите кнопку Start и дождитесь завершения.
9) Нажмите кнопку Proceed.
10) В столбце слева нажмите кнопку Task и в открывшемся окне установите флажок ISO Bootable.
11) В столбце слева нажмите кнопку ISO Bootable
12) В ниспадающем меню ----Select a mode---- выберите пункт Create Image
13) В текстовом поле Volume name укажите какое имя для ISO-образа будет использоваться при монтировании.
14) Нажмите кнопку Make ISO для создания ISO-образа установочного диска с интегрированным сервисным пакетом.
15) Введите имя файла и нажмите кнопку Сохранить.

22. Создание установочного образа Windows с двумя видами разрядности (32-битная и 64-битная) в одном iso-образе.
В этом руководстве Вы будете работать с диском D:, но Вы можете выбрать любую букву диска.

Вариант 1. Быстрый и простой способ.

Для создания собственного образа установочного диска Вам потребуется следующее:

Образы:

Windows 7 Ultimate (x86)
Windows 7 Enterprise (x86) (при необходимости)
Windows 7 Ultimate (x64)
Windows 7 Enterprise (x64) (при необходимости)

Программное обеспечение:

Шестнадцатеричный редактор (Например: HxD)
Windows Automated Installation Kit 2.0 (ссылка) или выше.

Этап 1: Упорядочивание файлов.

1) Создайте следующие папки:

D:\AIO\DVD
D:\AIO\ISO
D:\AIO\sourc64
D:\AIO\WIMs

2) Извлеките содержимое образа Windows 7 Ultimate (x86) в папку D:\AIO\DVD
3) Удалите все файлы с расширением .clg и файл ei.cfg из папки D:\AIO\DVD\sources, чтобы разблокировать все x86 версии Windows 7.
4) Переместите install.wim из папки D:\AIO\DVD\sources в папку D:\AIO\WIMs
5) Переименуйте файл install.wim в ULTx86.wim
6) Извлеките файл install.wim из образа Windows 7 Ultimate (x64) в папку D:\AIO\WIMs
7) Переименуйте файл install.wim в ULTx64.wim
8) При необходимости извлеките файлы install.wim из образа Windows 7 Enterprise (x86) и Windows 7 Enterprise (x64) в папку D:\AIO\WIMs, и переименуйте их в ENTx86.wim и ENTx64.wim соответственно.
9) Извлеките содержание папки sources (за исключением install.wim, ei.cfg и всех файлов .clg) из образа Windows 7 Ultimate (x64) в папку D:\AIO\DVD\sourc64.
10) Скопируйте файл setup.exe из корня образа Windows 7 Ultimate (x64) в папку D:\AIO\DVD как setup64.exe

Этап 2. Создание Wim.

Теперь Вы должны создать install.wim (файл, который содержит различные версии Windows), путем экспорта имеющихся у Вас в папке D:\AIO\WIMs образов.

1) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
2) Введите нижеследующие команды, нажимая после ввода каждой из них клавишу Enter:

Примечание: Вы можете пропустить команды для Windows 7 Enterprise, если Вы решили их не включать.

Этап 3: Изменение BCD

Здесь Вы измените файл данных конфигурации загрузки BCD, чтобы добавить консоль восстановления для 64-битной Windows.

1) Запустите командную строку с правами администратора.
2) Перейдите к папке D:\AIO\DVD введя нижеследующие команды, нажимая после ввода каждой из них клавишу Enter:

3) Сделайте копию загрузчика по умолчанию, выполнив команду:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

4) Установите новый загрузчик, чтобы загружать 64-битную PE, выполнив команды:

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

5) Установите время ожидания загрузки по умолчанию:

Этап 4. Добавление поддержки обновлений во время установки для 64-битных систем.

Так как добавление данной возможности в двухразрядную сборку Windows предполагает Hex-редактирование файлов, то минусом здесь является поломка цифровой подписи.
Но это является наиболее простым способом решения проблемы с обновлениями.

1) Откройте файл D:\AIO\DVD\setup64.exe в hex-редакторе.
2) Найдите и замените все значения Юникодовой строки (без учета регистра) с sources\ на sourc64\.
Хотя данное действие сломает подпись, но оно не нарушит работоспособность самой программы, так как обе строки имеют одинаковую длину.
3) Откройте файл D:\AIO\DVD\sourc64\autorun.dll и замените все значения Юникодовой строки (без учета регистра) с sources\setup.exe на sourc64\upg64.cmd
4) Cоздайте в папке D:\AIO\DVD\sourc64 файл названный upg64.cmd, содержащих следующее:

Использование командного файла добавит второй небольшой минус, до начала установки на короткое время появится окно команд.

5) Измените содержание файла autorun.inf в папке D:\AIO\DVD на следующее:

Этап 5: Создание ISO-образа (опционально)

1) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
2) Введите нижеследующую команду и нажмите клавишу Enter:

Указанные здесь параметры:

-u2 - создает файловую системы UDF для образа ISO
-l - метка DVD-диска или образа
-t - устанавливает дату и время для создаваемого ISO-образа
-b - указывает на загрузочный файл образа, который используется для создания загрузочного сектора на DVD-диске или образе.
-h - включает в создаваемый образ все скрытые файлы и папки, расположенные по указанному пути
-m - игнорирует ограничение максимального размера образа.

Готовый файл iso-образа: WIN7_AIO_x86-x64.ISO будет находится в папке D:\AIO\ISO.

Вариант 2. Сложный и долгий способ.

Для создания собственного образа установочного диска Вам потребуется следующее:

Образы:

Windows 7 Enterprise (x86)
Windows 7 Enterprise (x64)

Программное обеспечение:

Windows Automated Installation Kit 2.0 (ссылка) или выше.
Архиватор 7-zip
Текстовый редактор с возможностью сохранения в кодировке 866. (Например: AkelPad)

Этап 1: Подготовка к работе.

1) Создайте указанную ниже структуру папок с подпапками:

D:
│
└─AIO
   │
   ├───DVD
   │    │
   │    └───sources
   │           │
   │           ├───x64
   │           │
   │           └───x86
   ├───WIMs
   ├───ISO
   ├───offline
   └───temp
         ├───x64
         └───x86

2) Скопируйте все папки и все файлы, исключая папку sources из iso-образа Windows 7 Enterprise (64) в папку D:\AIO\DVD
3) Скопируйте содержимое папки sources из iso-образа Windows 7 Enterprise (64) в папку D:\AIO\DVD\sources\x64, исключая файлы:

4) Переместите файл install_Windows 7 ENTERPRISE.clg из папки D:\AIO\DVD\sources\x64 в папку D:\AIO\temp\x64
5) Переместите файл install.wim из папки D:\AIO\DVD\sources\x64 в папку D:\AIO\WIMs
6) Переименуйте файл install.wim в папке D:\AIO\WIMs в ENTx64.wim
7) Извлеките файл install_Windows 7 ENTERPRISE.clg из iso-образа Windows 7 Enterprise (x86) в папку D:\AIO\temp\x86
8) Извлеките файл install.wim из iso-образа Windows 7 Enterprise (x86) в папку D:\AIO\WIMs
9) Переименуйте файл install.wim в папке D:\AIO\WIMs в ENTx86.wim

Этап 2. Создание файла install.wim.

Теперь Вы должны создать install.wim (файл, который содержит различные версии Windows), путем экспорта имеющихся у Вас в папке D:\AIO\WIMs образов.

1) Введите нижеследующие команды, нажимая после ввода каждой из них клавишу Enter:

Этап 3. Создание файлов winpe.wim.

1) В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter:

2) Создайте в папке в D:\AIO\temp\x86 командный файл startnet.cmd:
3) Откройте его в AkelPad добавьте в него нижеследующий текст и сохраните в кодировке 866:

4) Создайте в папке в D:\AIO\temp\x64 командный файл startnet.cmd:
5) Откройте его в AkelPad добавьте в него нижеследующий текст и сохраните в кодировке 866:

6) Смонтируйте файл D:\AIO\temp\x86\winpe.wim, выполнив команду:

7) Скопируйте в папку D:\AIO\offline\Windows\system32 файл startnet.cmd из папки D:\AIO\temp\x86 соглашаясь на замену.
8) Скопируйте файл background_cli.bmp из папки D:\AIO\DVD\sources\x86 в папку D:\AIO\offline\Windows\System32
9) Удалите файл winpe.bmp из папки D:\AIO\offline\Windows\System32
10) Переименуйте файл background_cli.bmp в папке D:\AIO\offline\Windows\System32 на winpe.bmp.
11) Скопируйте файл winpe.bmp из папки D:\AIO\offline\Windows\System32 в папку
D:\AIO\offline\Windows\winsxs\x86_microsoft-windows-winpe-background_31bf3856ad364e35_6.1.760X.XXXXX_none_XXXXXXXXXXXXXXXX
(значения вместо X зависят от версии WAIK) соглашаясь на замену.
12) Демонтируйте образ с сохранением.

13) Удалите файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

14) Смонтируйте файл D:\AIO\temp\x64\winpe.wim, выполнив команду:

15) Скопируйте в папку D:\AIO\offline\Windows\system32 файл startnet.cmd из папки D:\AIO\temp\x64 соглашаясь на замену.
16) Скопируйте файл background_cli.bmp из папки D:\AIO\DVD\sources\x64 в папку D:\AIO\offline\Windows\System32
17) Удалите файл winpe.bmp из папки D:\AIO\offline\Windows\System32
18) Переименуйте файл background_cli.bmp в папке D:\AIO\offline\Windows\System32 на winpe.bmp.
19) Скопируйте файл winpe.bmp из папки D:\AIO\offline\Windows\System32 в папку
D:\AIO\offline\Windows\winsxs\amd64_microsoft-windows-winpe-background_31bf3856ad364e35_6.1.760X.XXXXX_none_XXXXXXXXXXXXXXXX
(значения вместо X зависят от версии WAIK) соглашаясь на замену.
20) Демонтируйте образ с сохранением.

21) Удалите файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

22) Экспортируйте образы winpe:

Этап 4. Создание файлов ответов.

1) Запустите из меню Диспетчер образов системы Windows (расположен в папке Microsoft Windows AIK в меню Пуск)
2) Нажмите в главном меню Файл -> Выбрать образ Windows
3) Выберите файл каталога install_Windows 7 ENTERPRISE.clg из папки D:\AIO\temp\x86
4) Нажмите в главном меню Файл -> Новый файл ответов
5) На панели Образ Windows поочередно щелкая правой кнопкой мыши на указанных ниже компонентах, выберите этап конфигурации (пункт Добавление параметра для прохода 1 WindowsPE):

6) На панели Файл отчетов пройдите:

7) На панели Свойства: SetupUILanguage присвойте параметру UILanguage значение ru-RU
8) На панели Файл отчетов пройдите:

9) На панели Свойства: SetupUILanguage присвойте параметру Key значение /IMAGE/INDEX, а параметру Value значение 1
10) На панели Файл отчетов пройдите:

11) На панели Свойства: InstallFrom присвойте параметру Path значение %diskroot%\sources\install.wim
12) Нажмите в главном меню Файл -> Сохранить файл ответов как и сохраните его как D:\AIO\DVD\sources\install-x86.xml
13) Нажмите в главном меню Файл -> Закрыть файл ответов, а затем Закрыть образ Windows

14) Нажмите в главном меню Файл -> Выбрать образ Windows
15) Выберите файл каталога install_Windows 7 ENTERPRISE.clg из папки D:\AIO\temp\x64
16) Нажмите в главном меню Файл -> Новый файл ответов
17) На панели Образ Windows поочередно щелкая правой кнопкой мыши на указанных ниже компонентах, выберите этап конфигурации (пункт Добавление параметра для прохода 1 WindowsPE):

18) На панели Файл отчетов пройдите:

19) На панели Свойства: SetupUILanguage присвойте параметру UILanguage значение ru-RU
20) На панели Файл отчетов пройдите:

21) На панели Свойства: SetupUILanguage присвойте параметру Key значение /IMAGE/INDEX, а параметру Value значение 2
22) На панели Файл отчетов пройдите:

23) На панели Свойства: InstallFrom присвойте параметру Path значение %diskroot%\sources\install.wim
24) Нажмите в главном меню Файл -> Сохранить файл ответов как и сохраните его как D:\AIO\DVD\sources\install-x64.xml
25) Нажмите в главном меню Файл -> Закрыть файл ответов, а затем Закрыть образ Windows

Этап 5: Добавление в загрузочное меню пункты для выбора разрядности установки.

1) Добавьте в загрузочное меню пункт Установка Windows 7 Enterprise (x86).
В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter:

2) Добавьте в загрузочное меню пункт Установка Windows 7 Enterprise (x64).
В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

3) Установите время ожидания загрузки по умолчанию::

Этап 6: Добавление в загрузочное меню пункты для выбора разрядности среды восстановления.

1) Добавьте файлы сред восстановления системы (winre.wim) для каждой разрядности:

1.1) Откройте с помощью программы 7-zip файл install.wim из папки D:\AIO\DVD\sources
1.2) Скопируйте из папки D:\AIO\DVD\sources\install.wim\1\Windows\System32\Recovery в папку D:\AIO\DVD\sources файл winre.wim.
1.3) Переименуйте файл winre.wim из папки D:\AIO\DVD\sources в winre-x86.wim
1.4) Откройте с помощью программы 7-zip файл install.wim из папки D:\AIO\DVD\sources
1.5) Скопируйте из папки D:\AIO\DVD\sources\install.wim\2\Windows\System32\Recovery в папку D:\AIO\DVD\sources файл winre.wim.
1.6) Переименуйте файл winre.wim из папки D:\AIO\DVD\sources в winre-x64.wim

2) Добавьте новые записи в загрузочное меню для среды восстановления Windows x86:
В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

3) Добавьте новые записи в загрузочное меню для среды восстановления Windows x64:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

(Если в D:\AIO\DVD\boot\ появились файлы BCD.LOG, bcd.LOG1, bcd.LOG2 - их можно удалить)

Этап 7: Создание ISO-образа.

1) Скопируйте bcd из папки D:\AIO\DVD\boot в папку D:\AIO\DVD\efi\microsoft\boot заменяя оригинал.
2) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
3) Введите нижеследующую команду и нажмите клавишу Enter:

Указанные здесь параметры:

-u2 - создает файловую системы UDF для образа ISO
-l - метка DVD-диска или образа
-t - устанавливает дату и время для создаваемого ISO-образа
-b - указывает на загрузочный файл образа, который используется для создания загрузочного сектора на DVD-диске или образе.
-h - включает в создаваемый образ все скрытые файлы и папки, расположенные по указанному пути
-m - игнорирует ограничение максимального размера образа.

Готовый файл iso-образа: WIN7_AIO_x86-x64.ISO будет находится в папке D:\AIO\ISO.

23. Прямые ссылки с официального сайта Microsoft для скачивания сервисного Пакета обновлений 1 (SP1) для Windows 7.

Если Вам необходимо скачать сервисный Пакет обновлений 1 (SP1) для Windows 7, то Вы можете сделать это, воспользовавшись указанными ниже прямыми ссылками с сайта Microsoft.

ISO-образ, содержащий Пакеты обновлений 1 (SP1) для обоих разрядностей Windows 7 (x86 и x64):

http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/7601.17514.101119-1850_Update_Sp_Wave1-GRMSP1.1_DVD.iso

Сервисный Пакет обновлений 1 (SP1) для 32-битной версии Windows 7:

http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/windows6.1-KB976932-X86.exe

Сервисный Пакет обновлений 1 (SP1) для 64-битной версии Windows 7:

http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/windows6.1-KB976932-X64.exe

24. Официальные прямые ссылки на языковые пакеты для Windows 7 и Windows 7 SP1.

По указанным ниже ссылкам Вы сможете скачать языковые пакеты для Windows 7 и языковые пакеты для Windows 7 с установленным сервисным Пакетом обновлений 1 (SP1) напрямую с сайта Microsoft.

Чтобы скачать необходимый Вам языковой пакет нажмите на прямую ссылку напротив выбранного Вами языка.
Также Вы можете самостоятельно вручную сделать полную ссылку. Для этого добавьте к имени файла языкового пакета (независимо от разрядности) указанному в колонке Прямая ссылка место расположения файла:

Для Windows 7:

http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/
Например, если имя файла языкового пакета латышского языка для 64-битной версии Windows 7: windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe, то ссылка будет:

http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe

Для Windows 7 SP1:

http://download.windowsupdate.com/msdownload/update/software/updt/2011/02/
Например, если имя файла языкового пакета латышского языка для 32-битной версии Windows 7 SP1: windows6.1-kb2483139-x86-lv-lv_97b58149699a2e8b02bd7cac720ac0795b51c98b.exe, то ссылка будет:

http://download.windowsupdate.com/msdownload/update/software/updt/2011/02/windows6.1-kb2483139-x86-lv-lv_97b58149699a2e8b02bd7cac720ac0795b51c98b.exe

Официальные языковые пакеты (language packs) для 32-bit (x86) Windows 7:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb972813-x86-ar-sa_210ccc96338a1ff683803eb4034e5f53d6d54c97.exe
Bulgarian | Болгарский | windows6.1-kb972813-x86-bg-bg_2e5d91b00775e0f974d4ec213fc20d470ff6850e.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb972813-x86-zh-cn_ab024143b556395e6638e26712b1e0f3bc031fcf.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb972813-x86-zh-hk_90617b75cfaab716a43e7c082b00490a6d475376.exe
Croatian | Хорватский | windows6.1-kb972813-x86-hr-hr_d8a4131aee5d5de039a3a0dc517ca0c07ebc3472.exe
Czech | Чешский | windows6.1-kb972813-x86-cs-cz_2759680ec6e2f4a7629c7d02b1fbce0a0d410a4e.exe
Danish | Датский | windows6.1-kb972813-x86-da-dk_e1c57a4dcbd336ac73e349a9bb9d30de17ac093f.exe
Dutch | Нидерландский | windows6.1-kb972813-x86-nl-nl_194a2ca7b589e77b0be73b822f77760823183c51.exe
English | Английский | windows6.1-kb972813-x86-en-us_22ee3397a02372681b375ddabf6ffa33662fd500.exe
Estonia | Эстонский | windows6.1-kb972813-x86-et-ee_3a99769fac5d6a11e6616297f842a9074c045699.exe
Finnish | Финский | windows6.1-kb972813-x86-fi-fi_dd1973cc63ab7dea0e5d660af06869a8beefe36a.exe
French | Французский | windows6.1-kb972813-x86-fr-fr_1878fd391b990054787a14b0db4a5db00b793bf1.exe
German | Немецкий | windows6.1-kb972813-x86-de-de_1b86ff9b8f4c517dd341d76f24c74399278b05fc.exe
Greek | Греческий | windows6.1-kb972813-x86-el-gr_1f366d5e4fbde7df89b106821236fc1d3b3c9230.exe
Hebrew | Иврит | windows6.1-kb972813-x86-he-il_a3d6a6ae858f33ffa11a14c2a966e6603c134ef9.exe
Hungarian | Венгерский | windows6.1-kb972813-x86-hu-hu_12feb47da4bb28f60b6a30d379044356581c20f8.exe
Italian | Итальянский | windows6.1-kb972813-x86-it-it_079a3afeb88f14d24a3b4204812225e78c2e0bb8.exe
Japanese | Японский | windows6.1-kb972813-x86-ja-jp_08758c23cc64a53949072d53dd7bf6bbc8b45420.exe
Korean | Корейский | windows6.1-kb972813-x86-ko-kr_bb2de1652c37394be4de87438661b129f8b56908.exe
Latvian | Латышский | windows6.1-kb972813-x86-lv-lv_8b7a0b361dd37f7cd3926f798a79a90d378b18b2.exe
Lithuanian | Литовский | windows6.1-kb972813-x86-lt-lt_7aee9ce232cb46701f479fafdb0aea369ce1ad6a.exe
Norwegian | Норвежский | windows6.1-kb972813-x86-nb-no_d65ea89195cf5f7d3170ccb1db7bae3c157f5b24.exe
Polish | Польский | windows6.1-kb972813-x86-pl-pl_9199018040692bc732a590e9b092a18120d326b2.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb972813-x86-pt-br_0a3fe79820d6d199dd43495d4efa5c40f270e45a.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb972813-x86-pt-pt_4165bd9cd083abd8ddd81986e18b1fd86aab5ce9.exe
Romanian | Румынский | windows6.1-kb972813-x86-ro-ro_e1c324236046eb608e478570cf4396776ff02a72.exe
Russian | Русский | windows6.1-kb972813-x86-ru-ru_f4df4bcb8d3194323f17a086a17f46dd0c9c492a.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb972813-x86-sr-latn-cs_6e049bae4d75b82405b28455e2def0a0d0055a9c.exe
Slovak | Словацкий | windows6.1-kb972813-x86-sk-sk_dd2ce36a7e94fceff650cb892b8c954b8af6025a.exe
Slovenian | Словенский | windows6.1-kb972813-x86-sl-si_17786270766d556ba9bf3693762cb98805df9f50.exe
Spanish | Испанский | windows6.1-kb972813-x86-es-es_1943a073d8f00e387301deb22cd177bf77319ee8.exe
Swedish | Шведский | windows6.1-kb972813-x86-sv-se_687085e8bbdf9c17a668b801f28f7f9c74e7a86a.exe
Thai | Тайский | windows6.1-kb972813-x86-th-th_780885dd42c039d9926ac004c76ba3ba9c30c6d0.exe
Turkish | Турецкий | windows6.1-kb972813-x86-tr-tr_13015cb75811f874c83fdd679beb4c22c930a57c.exe
Ukrainian | Украинский | windows6.1-kb972813-x86-uk-ua_0a467bf14bc4f524c18877f570a20c58e91ceba9.exe

Официальные языковые пакеты (language packs) для 64-bit (x64) Windows 7:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb972813-x64-ar-sa_aaac936bd625c12b607dffea19fab8be9cfa28f6.exe
Bulgarian | Болгарский | windows6.1-kb972813-x64-bg-bg_155634f17868659db4b65cfeff57059b2436515f.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb972813-x64-zh-cn_a649e9af1e28514d48bdc51f7956be08060e54bc.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb972813-x64-zh-hk_d428bc1cca4aea20163936e6687221c0e6b99ec4.exe
Croatian | Хорватский | windows6.1-kb972813-x64-hr-hr_06468f799a1c1f295bc3abbc85c14116e2645122.exe
Czech | Чешский | windows6.1-kb972813-x64-cs-cz_f136df3188c54ff234ca77253fee2cf3e91966b7.exe
Danish | Датский | windows6.1-kb972813-x64-da-dk_2b7590d389ca96af6f367408150cb6bc9aa8f4b4.exe
Dutch | Нидерландский | windows6.1-kb972813-x64-nl-nl_2ac14543f6e46c61ae226d7f0f5aee7f4d500e9f.exe
English | Английский | windows6.1-kb972813-x64-en-us_483a3e51038f1a369bc5b5cdf5fc32df3ea4ad27.exe
Estonian | Эстонский | windows6.1-kb972813-x64-et-ee_3c0479d7049109bcb42fd9ec59d1c65449704687.exe
Finnish | Финский | windows6.1-kb972813-x64-fi-fi_4378f72d1233b00e2bdfc680a13f62ae11ab0fcb.exe
French | Французский | windows6.1-kb972813-x64-fr-fr_0e50cd2ea794e4cdfac861b194d2e996b7bbc8d8.exe
German | Немецкий | windows6.1-kb972813-x64-de-de_399ac15b2d55fd5dea0770d98825d7e75f4ad533.exe
Greek | Греческий | windows6.1-kb972813-x64-el-gr_9ae588ba70896f9100a10cb8ed68a79678d6fc32.exe
Hebrew | Иврит | windows6.1-kb972813-x64-he-il_86c22105bb32269c9c0deaf2710fcb1531a29817.exe
Hungarian | Венгерский | windows6.1-kb972813-x64-hu-hu_e5c47bffe398b9ace42d4326de2646a6172d39b5.exe
Italian | Итальянский | windows6.1-kb972813-x64-it-it_3f0f5d78202e074e17a495beec821e1d326a8e2a.exe
Japanese | Японский | windows6.1-kb972813-x64-ja-jp_9d73b1c1270deacbe7a2329559476a94daddb848.exe
Korean | Корейский | windows6.1-kb972813-x64-ko-kr_e6b3322c3865cfd328d84376e192c4f9d41aa0e6.exe
Latvian | Латышский | windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe
Lithuanian | Литовский | windows6.1-kb972813-x64-lt-lt_ede5a878aae2b0d64e81ff739e950b6f105df580.exe
Norwegian | Норвежский | windows6.1-kb972813-x64-nb-no_1b7f93a0906a62eecd6b200979f8df986a7556f1.exe
Polish | Польский | windows6.1-kb972813-x64-pl-pl_6b228326c2f7ef6406242671600b499746ff3454.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb972813-x64-pt-br_276b65f3b6b2657c8fe936f9841dc1243e02dc7b.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb972813-x64-pt-pt_f8310aa4a73841aec29b3f4e74ecaece56b695e9.exe
Romanian | Румынский | windows6.1-kb972813-x64-ro-ro_810f2d590dd5aac92561eea5884ed1c70f34dbd9.exe
Russian | Русский | windows6.1-kb972813-x64-ru-ru_f0acfc688d609ee45d43cc60c6412a3071a665bd.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb972813-x64-sr-latn-cs_275e0a17cbec543aa1bd7eebc883a1d21c11b514.exe
Slovak | Словацкий | windows6.1-kb972813-x64-sk-sk_15f397de2ceaaff8dbfe670bcc6c013791a297c3.exe
Slovenian | Словенский | windows6.1-kb972813-x64-sl-si_8cfc82e0d15ed94634d3da69674008dc56755b93.exe
Spanish | Испанский | windows6.1-kb972813-x64-es-es_2e593c26d9e23ad8176224a53c68a04f996ee014.exe
Swedish | Шведский | windows6.1-kb972813-x64-sv-se_1f4c415e0f4ca77064d597975f6ac7a9e0b8af63.exe
Thai | Тайский | windows6.1-kb972813-x64-th-th_080c8631d44a53c34ffdab8fd73820572dd87be4.exe
Turkish | Турецкий | windows6.1-kb972813-x64-tr-tr_6bd6660158289e0b5d4b5a7f7fded6e3528a9a04.exe
Ukrainian | Украинский | windows6.1-kb972813-x64-uk-ua_c6c4e44c9d903049a4c60fed9d42effa18f345bd.exe

Официальные языковые пакеты (language packs) для 32-bit (x86) Windows 7 SP1:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb2483139-x86-ar-sa_5add6e4a36127029d431ba98d99708c44ef9b53f.exe
Bulgarian | Болгарский | windows6.1-kb2483139-x86-bg-bg_a8a5013e477366119cfdc5fbda43b904755db450.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb2483139-x86-zh-cn_ae61ea226215f96fc95be33201ffc96755ac7eb5.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb2483139-x86-zh-hk_411a6bb68728f12f5ced712d9a33fee9ebe0b0b3.exe
Croatian | Хорватский | windows6.1-kb2483139-x86-hr-hr_685e217ce007af8005db4726087893d04e19dade.exe
Czech | Чешский | windows6.1-kb2483139-x86-cs-cz_bb5061f4bd24437dd31a3714e1b54318ced7e63a.exe
Danish | Датский | windows6.1-kb2483139-x86-da-dk_67fecaab0a940e2e537bc8dcd8a9ebb8ab4ed102.exe
Dutch | Нидерландский | windows6.1-kb2483139-x86-nl-nl_b7e1c3046b218fb45a665ab5f5ed8a5ea8125760.exe
English | Английский | windows6.1-kb2483139-x86-en-us_783d6dd59e2ec8fb0995a059c9c121795bde46c8.exe
Estonian | Эстонский | windows6.1-kb2483139-x86-et-ee_d0f798de315b696bf560b559f6f90064687c0b7b.exe
Finnish | Финский | windows6.1-kb2483139-x86-fi-fi_5259ca6a22a981dbdee352dde5b8e65c2fddd407.exe
French | Французский | windows6.1-kb2483139-x86-fr-fr_f57427487dfc2f49da67cac22480ab1f48983d22.exe
German | Немецкий | windows6.1-kb2483139-x86-de-de_acb9b88b96d432749ab63bd93423af054d23bf81.exe
Greek | Греческий | windows6.1-kb2483139-x86-el-gr_5aeecda7e1d689a083975128901da8156751dfc5.exe
Hebrew | Иврит | windows6.1-kb2483139-x86-he-il_1849d14777a76c7c5b4ef766490dccc8aed5c56b.exe
Hungarian | Венгерский | windows6.1-kb2483139-x86-hu-hu_a7a5af62c59ab7a4e8cb0f21242b42606b95195b.exe
Italian | Итальянский | windows6.1-kb2483139-x86-it-it_1d54a8d0047674fc1b5b6f41292a0074d9fe3cc5.exe
Japanese | Японский | windows6.1-kb2483139-x86-ja-jp_bc46078938ae9129c7ce86a9c176fa517e4c0a3d.exe
Korean | Корейский | windows6.1-kb2483139-x86-ko-kr_18f213428cc6fde96d8c76c6dd91446348e86ce6.exe
Latvian | Латышский | windows6.1-kb2483139-x86-lv-lv_97b58149699a2e8b02bd7cac720ac0795b51c98b.exe
Lithuanian | Литовский | windows6.1-kb2483139-x86-lt-lt_297c5ee6e98ab646b14f1492716b67cc0970fcd8.exe
Norwegian | Норвежский | windows6.1-kb2483139-x86-nb-no_5bd6fc76ad54b7a232d4ceb4a5f5c7c366bf90b6.exe
Polish | Польский | windows6.1-kb2483139-x86-pl-pl_c460a8c1392d7f3d35d1c0b37e56017d3552d245.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb2483139-x86-pt-br_6e1d337b2fd56669d461e82601aa51004fecbd24.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb2483139-x86-pt-pt_5cc92ef98ed177b2f6bbae3a0420ee2f12764fab.exe
Romanian | Румынский | windows6.1-kb2483139-x86-ro-ro_d8d9b2b4c5c457fe6a7dcb09a5f645cfe77cc30c.exe
Russian | Русский | windows6.1-kb2483139-x86-ru-ru_6532a8f36ad7d15277d5d60da92555f0fbee4daa.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb2483139-x86-sr-latn-cs_e3d9acfcc9f608cf7687bd3b5ee7f0d9658b7bc9.exe
Slovak | Словацкий | windows6.1-kb2483139-x86-sk-sk_4c7b17a6cb292b09bede4c8731ad4f24cd09ab2a.exe
Slovenian | Словенский | windows6.1-kb2483139-x86-sl-si_de7f366819e1c12954557e3e65b7c0f059f49b67.exe
Spanish | Испанский | windows6.1-kb2483139-x86-es-es_6aef75f7d83edaabc2a921a6b157cc7005628286.exe
Swedish | Шведский | windows6.1-kb2483139-x86-sv-se_bd65af75e8995bd865d93c8d8c8a35091499083f.exe
Thai | Тайский | windows6.1-kb2483139-x86-th-th_8248f2b209d65a39ddaeb36e1782fcc0f6664f73.exe
Turkish | Турецкий | windows6.1-kb2483139-x86-tr-tr_228dfa5fbaa4606b17f93d6fcd51c8c85c0f1fd3.exe
Ukrainian | Украинский | windows6.1-kb2483139-x86-uk-ua_7f01db99ad2b2d41598bfc71aaa9bd4be04b6369.exe

Официальные языковые пакеты (language packs) для 64-bit (x64) Windows 7 SP1:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb2483139-x64-ar-sa_f07f2cc7b55b17076eebceea2c2c2826b08b8f63.exe
Bulgarian | Болгарский | windows6.1-kb2483139-x64-bg-bg_e4c9392592ed2d4a8c7ec68270b5140430df197a.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb2483139-x64-zh-cn_2c1884b4fdf6c8e91986369d88bbcaae01c6f187.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb2483139-x64-zh-hk_285282b1e2f750eeed91466918443b657968d977.exe
Croatian | Хорватский | windows6.1-kb2483139-x64-hr-hr_e7c6d648436d81466af331ab1ece07dd22be5fda.exe
Czech | Чешский | windows6.1-kb2483139-x64-cs-cz_1ea5b71d701e2480017b464b6560a2987e0d8971.exe
Danish | Датский | windows6.1-kb2483139-x64-da-dk_d753d19cc1a0fe95aef21548193393c04a6a8024.exe
Dutch | Нидерландский | windows6.1-kb2483139-x64-nl-nl_12c90c70d408b08f51f500d6e974878a5d662398.exe
English | Английский | windows6.1-kb2483139-x64-en-us_9b9c8a867baff2920507fbf1e1b4a158572b9b87.exe
Estonian | Эстонский | windows6.1-kb2483139-x64-et-ee_b4fd94f6e461e21b7eec54d1e379e2807861aea2.exe
Finnish | Финский | windows6.1-kb2483139-x64-fi-fi_223465e1b382484d1d82f8f2ccfcd9ed2f902c76.exe
French | Французский | windows6.1-kb2483139-x64-fr-fr_0f18e2a244dd9ff04664112a82776d2bd2177798.exe
German | Немецкий | windows6.1-kb2483139-x64-de-de_4f4ce6bd38530b4a02199172863b21a0cba13773.exe
Greek | Греческий | windows6.1-kb2483139-x64-el-gr_583791fea2fea71725388a746844d5be6488ca45.exe
Hebrew | Иврит | windows6.1-kb2483139-x64-he-il_617029400059f0847d7d90d4da673ae4ed43ebd9.exe
Hungarian | Венгерский | windows6.1-kb2483139-x64-hu-hu_1c298d99baf7af3d830dcd1e2632eeb65d7ee395.exe
Italian | Итальянский | windows6.1-kb2483139-x64-it-it_6d8223c065d6974d833d0eaa162f3ceb7680850f.exe
Japanese | Японский | windows6.1-kb2483139-x64-ja-jp_aeaf7e9b0b6c2173bf757330017a7f655f1f8715.exe
Korean | Корейский | windows6.1-kb2483139-x64-ko-kr_0ea76f748e3d5309d568147ad1337b2664090944.exe
Latvian | Латышский | windows6.1-kb2483139-x64-lv-lv_3919fb044a307144f1fc55cf4313aff45cde9a46.exe
Lithuanian | Литовский | windows6.1-kb2483139-x64-lt-lt_c894f0a591735553ba68f9fb94b1b85133ca922c.exe
Norwegian | Норвежский | windows6.1-kb2483139-x64-nb-no_78df68604970041a6337b4058a3e5339f79e50b4.exe
Polish | Польский | windows6.1-kb2483139-x64-pl-pl_24d00a966a7a75132c3af5627634483d3e2d01e7.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb2483139-x64-pt-br_f8035731c55d774c95c7c673aedfd42d52479294.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb2483139-x64-pt-pt_78485491088298110a3e78b7a5f95e55ff7808df.exe
Romanian | Румынский | windows6.1-kb2483139-x64-ro-ro_6e7a63541f2cb534dab3db719330fee5cfbb4e0f.exe
Russian | Русский | windows6.1-kb2483139-x64-ru-ru_0587eb296a2f04e0d3699650d39b53ee18b97a79.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb2483139-x64-sr-latn-cs_5f487007933585def54c67087895e74e25e699a9.exe
Slovak | Словацкий | windows6.1-kb2483139-x64-sk-sk_f1fb8a395d7d656649830f4f06496a5311ad572a.exe
Slovenian | Словенский | windows6.1-kb2483139-x64-sl-si_84606ed6bc061c72f756bbc061621b490fb761f7.exe
Spanish | Испанский | windows6.1-kb2483139-x64-es-es_fdbdf4061b960324efb9eedf7106df543ed8ce33.exe
Swedish | Шведский | windows6.1-kb2483139-x64-sv-se_81051fe3083afdb4f2d1d23752c587de9bb35025.exe
Thai | Тайский | windows6.1-kb2483139-x64-th-th_dc9c0cc12ae488ed3e8dcaecb4392eef91ec213b.exe
Turkish | Турецкий | windows6.1-kb2483139-x64-tr-tr_07e7e3b34426fe68be813e911d3843b941a268b7.exe
Ukrainian | Украинский | windows6.1-kb2483139-x64-uk-ua_1ca449545a2bcfdeeed6080768186fc29f163504.exe

Настройки

1. Чтобы сохранялись настройки программ (сайдбара, расположение значков на панели и т.д.).

Нужно установить пароль на учетную запись администратора и работать из под нее.

2. Отображение (скрытие) значков в области уведомлений.

Отобразить значок в области уведомлений можно гораздо проще без использования кнопки Настроить: просто перетащите нужный значок из скрытой области в область уведомлений. Чтобы скрыть значок, перетащите его в скрытую область.

3. Изменение параметров загрузки в Windows 7 (msconfig вместо boot.ini).
Начиная с Windows Vista такого файла больше нет, но Вы можете изменить необходимые Вам для загрузки параметры используя инструмент Конфигурация системы. Окно Конфигурация системы запускается так: Панель управления -> Администрирование -> Конфигурация системы -> Загрузка (или нажав Win+R -> msconfig -> Ok)

Данный инструмент позволяет:
- получить информацию о текущей и загружаемой по умолчанию системах;
- выбрать систему, загружаемую по умолчанию;
- удалить ненужную запись из меню загрузки.
- отредактировать время в секундах (таймаут), по истечении которого будет загружена операционная система, выбранная по умолчанию.
- включить\выключить экран приветствия(Без GUI);
- включить\выключить загрузку стандартных драйверов VGA, вместо драйверов экрана, соответствующих видеооборудованию компьютера(Базовое видео).

А через Дополнительные параметры:

- Число процессоров, используемых при загрузке.
- Максимальный объем памяти в мегабайтах, используемый для моделирования конфигурации с малым объемом памяти.

При помощи окна Конфигурация системы нельзя изменить(но это возможно, при помощи программы Bcdedit):

- наименование существующих записей;
- положение записи в меню загрузки.

Для выбора системы, загружаемой по умолчанию, выберите необходимую Вам операционную систему и нажмите кнопку «Использовать по умолчанию».
Для удаления ненужной записи выберите ее из списка и нажмите кнопку «Удалить».
Для редактирование таймаута, в нужном поле установите желаемое количество секунд.

Для применения, сделанных Вами изменений - перезагрузите компьютер.

4. Принудительная установка числа ядер для старых многоядерных процессоров.

1) Откройте диалоговое меню Выполнить: Пуск -> Выполнить(или Win+R)
2) Введите msconfig и нажмите OK
3) Перейдите на вкладку Загрузка
4) Нажмите Дополнительные параметры
5) Поставьте флажок напротив значения Число процессоров
6) Выберите в активировавшемся ниспадающем меню число ядер Вашего процессора (По умолчанию 1)
Установка меньшего значения, чем количество ядер Вашего процессора не рекомендуется, так как система может продолжить использование указанного Вами числа ядер и после завершения загрузки.
7) Нажмите OK и перезагрузите компьютер

5. Установка временной зоны из командной строки в Windows 7.

В Windows 7 появилась новая утилита командной строки tzutil.exe, позволяющая изменять настройки временной зоны.
Для изменения временной зоны сделайте следующее:

1) Запустите командную строку от имени администратора (Нажмите Win+R -> введите cmd -> нажмите OK)
2) Введите команду:

3) Выберите необходимую Вам временную зону и введите в соответствии с ней команду.

Например, для установки значения временной зоны по Гринвичу выполните команду:

Замените значение между кавычками на необходимое Вам.
tzutil /g - отображает текущие установки временной зоны;
tzutil /? - выводит справку по работе утилиты.

6. Назначение клавиш быстрого вызова для утилиты "Ножницы".

"Ножницы" - это утилита для снятия скриншотов выделенной зоны
Пуск => Все программы=> Стандартные => "Ножницы" => Правый клик мыши=> Свойства
В Свойствах, в поле Быстрый вызов пытаемся набрать любую комбинацию клавиш. Заметим что нам сразу выдаются первые две клавиши Ctrl+Alt+, выбор третьей клавиши за Вами, как Вам удобнее. Например, Ctrl+Alt+S.

7. Отключение (включение) неиспользуемых компонентов Windows.
В Windows существует много дополнительных функций и компонентов. Вы можете просмотреть их и решить для себя какие из них вы будете использовать, а какие нет. Неиспользуемые компоненты можно отключить и, тем самым, немного разгрузить использование ресурсов компьютера системой.
Для просмотра и отключения (включения) дополнительных функций и компонентов, проделайте следующие действия:

1) Откройте Панель управления
2) Откройте оснастку Программы и компоненты
3) Перейдите по ссылке слева "Включение или отключение компонентов Windows"
4) Просмотрите компоненты и снимите флажки с тех, которые включены, но вами не используются

8. Отмена (изменение) ассоциирования типов файлов с определенными программами.

Если вы выбрали неправильную программу в диалоговом окне "Открыть с помощью" и установили параметр "Использовать выбранную программу для всех файлов такого типа". А также если программа удалилась некорректно, оставив в системе ассоциации на себя с поддерживаемыми ею типами файлов. Есть несколько способов это исправить.

Способ 1: Попробуйте ассоциировать нужные файлы с нужными программами используя все тот же диалог "Открыть с помощью"
Способ 2: Панель управления\Все элементы панели управления\Программы по умолчанию\Задать сопоставления "Изменить программу"
Способ 3: Найдите в разделе реестра [HKEY_CLASSES_ROOT] ветку соответствующую расширению файла, удалите ее, а затем откройте в нужной программе.
Способ 4: Используйте утилиту Unassociate File Types, которая позволяет как убрать ассоциацию, так и удалить тип файла из реестра.

9. Отключение всплывающих подсказок.

Отключить всплывающие подсказки можно используя редактор групповой политики.
1) Нажмите Пуск, в поле поиска напишите gpedit.msc и нажмите ОК.
2) Перейдите в раздел Конфигурация пользователя -> Административные шаблоны -> Меню Пуск и Панель задач.
3) Откройте параметр "Удалить всплывающие подсказки для элементов главного меню",
4) Установите переключатель в значение Включить и нажмите ОК.

10. Изменение функции кнопки питания на корпусе вашего компьютера.

По умолчанию кнопка выключения компьютера в Windows 7 находится в состоянии "Завершение работы". Если вы перезагружаете компьютер по несколько раз в день, вам наверное было бы удобнее переключить кнопку выключения в состояние "Перезагрузка". Для этого выполните следующие действия:

1) Щелкните правой кнопкой мыши на кнопку Пуск и выберите пункт меню Свойства.
2) Перейдите на вкладку Меню "Пуск".
3) Переключите значение “Действие кнопки питания” в состояние "Перезагрузка". Также вы можете выбрать функции "Блокировка", "Смена пользователя" и "Завершение сеанса".

11. Быстрый переход к часто используемой папке.

Если вы часто работаете с какими-то 4-мя — 5-ю папками, то их можно быстро прикрепить к кнопке проводника на панели задач. Удерживая кнопку мыши, перетащите папку на панель задач, и она автоматически будет помещена в «Закреплено» кнопки проводника.

12. Редактирование меню загрузки операционных систем при помощи Bcdedit.

bcdedit - инструмент, позволяющий изменить значения загрузчика Windows, а также произвести его(загрузчика) восстановление. Чтобы увидеть предлагаемые системой для изменения параметры: запустите командную строку от имени администратора (Win+R -> cmd -> Ok), наберите в ней bcdedit и нажмите Enter. Все команды, приведенные в данном варианте, необходимо будет запускать в командной строке, запущенной от имени администратора (Win+R -> cmd -> Ok) Также данные команды могут выполняются в командной строке среды восстановления или в командной строке ERD Commander.

Некоторые значения параметров BCD записаны в фигурных скобках – {}. Это идентификаторы – {CLSID}. Любой идентификатор имеет буквенно-цифровой код вида {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}. Стандартные идентификаторы имеют названия, например: {default}, {bootmgr}, {ntldr} и так далее.

Наиболее интересующими нас компонентами являются:

идентификатор – CLSID той или иной записи;
device – показывает раздел, на котором расположены файлы загрузки (это может быть операционная система или папка BOOT);
osdevice – показывает раздел, на котором расположены системные файлы операционной системы. Обычно, значения параметров device и osdevice равны;
path – если device определял раздел диска, который содержит файлы операционной системы, то этот параметр определяет остальной путь к загрузчику операционной системы;
default – показывает ID операционной системы, загружаемой по умолчанию, если операционная система, в которой запустили командную строку, загружается по умолчанию, параметру default присваивается значение {current};
displayorder – показывает порядок, в котором расположены записи о загружаемых системах;
timeout – таймаут(время - по истечении которого будет загружена операционная система), значение показано и устанавливается в секундах;
locale – указывает язык загрузочного меню или меню дополнительных параметров загрузки;
description – показывает название операционной системы, отображающееся в меню загрузки.

Внимание: Если в выполняемой Вами команде, с использованием программы bcdedit.exe, отсутствует параметр /set с дальнейшим указанием идентификатора, то внесенные Вами изменения будут добавлены в Диспетчер загрузки Windows (Windows Boot Manager), а не в Загрузка Windows (Windows Boot Loader)

Перед тем, как начнете вносить необходимые Вам изменения, создайте резервную копию загрузчика. Для этого, создайте на любом диске папку с названием BCDREZ и выполните следующую команду:

где X - буква диска, на котором находится папка BCDREZ.

Если Вы решите вернуть все сделанные Вами изменения к начальным настройкам, то выполните следующую команду:

Для дальнейших примеров, предположим, что наше меню загрузки содержит три записи с идентификаторами {ID1}, {ID2}, {ID3}.

Изменение системы, загружаемой по умолчанию

Введите параметр /default и {ID} той системы, которую Вы хотите загружать по умолчанию. Например, для системы с {ID2} команда:

Данная команда не перемещает запись о системе, загружаемой по умолчанию, на верхнюю строчку меню загрузки.

Изменение расположения записей в меню загрузки

1) Перемещение выбранной записи вверх списка:

2) Перемещение выбранной записи вниз списка:

3) Формирование меню в выбранном порядке:

Изменение таймаута

где XX – время в секундах.

Изменение языка диспетчера загрузки

где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение языка меню дополнительных вариантов загрузки

В связи с тем, что программа восстановления запуска, выполняющаяся из среды восстановления, использует параметры "по-умолчанию", меню дополнительных вариантов загрузки, которое появляется при нажатии F8 после наведения на строку меню с нужной операционной системой, может стать англоязычным. Вернуть необходимый Вам язык, можно выполнив следующую команду:

где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение названия загружаемой системы

После использования среды восстановления, в названии операционной системы появляется надпись - (восстановлено).
Вы также можете исправить значение "Предыдущая версия Windows" на более удобное Вам "Windows XP" или добавить версию и разрядность к текущей(используемой по умолчанию) версии Windows.
Вы можете изменить это указанной ниже командой:

Например:

Изменение буквы раздела, на котором расположена папка операционной системы и ее загрузочные файлы

где X – буква раздела жесткого диска. Обычно значения device и osdevice совпадают.

Добавление новой операционной системы (Windows Vista или Windows 7) в загрузчик.

1) Скопируйте существующую запись текущей системы с новым названием:

2) Дождитесь сообщение «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
3) Измените значения параметров device и osdevice на соответствующие добавляемой операционной системе.

где X – буква диска, на котором находится операционная система. Вместо крестиков, введите значение {ID}, полученное после успешного окончания копирования.
4) Выполните команду, добавляющую новую запись в диспетчер загрузки:

Запись будет добавлена внизу существующего списка.

Удаление записи загрузки системы из BCD и диспетчера загрузки.

Удаление записи об установленной операционной системе из BCD и диспетчера загрузки выполняется с помощью команды bcdedit /delete {ID}. Есть особенность выполнения команды: если в качестве ID указывается известная запись, например {ntldr}, то команда должна выполняться с ключом /f:

Если же ID записывается в буквенно-цифровом коде, ключ /f не нужен.

В случае отсутствия одного из файлов, необходимых для работы с загрузчиком, Вы можете скачать архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe из Windows 7 Ultimate x86/x64)

Для информации:

Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

13. Установка пользовательского разрешения экрана.

У некоторых мониторов разрешение экрана может не соответствовать ни одному из предлагаемых Windows.

Если у Вас установлена видеокарта Nvidia Вы можете добавить своё разрешение экрана одним из указанных способов:

Способ 1.

1) Запустить Панель управления Nvidia.
2) Открыть Дисплей -> Изменение разрешения -> Добавить разрешения... -> Создать пользовательское разрешение
3) Задать нужные Вам параметры, протестировать их и добавить его в список для выбора
4) Выбрать его и использовать.

Способ 2.

Используя реестр добавить нужное Вам разрешение в параметр NV_Modes

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{some number}\0000

Также можете найти другие ветки содержащие параметр NV_Modes и также добавить в них необходимое Вам разрешение экрана.

Способ 3. Перед установкой драйвера.

Откройте файл "nv_disp.inf" в папке C:\NVIDIA\Win7\xxx.xx и найдите значение [nv_commonDisplayModes_addreg]
Под ним в NV_Modes будут все доступные разрешения экрана, добавьте туда свое.

Но бывает что даже после указанных выше манипуляций, новое разрешение не хочет добавляться. В таком случае, для принудительного добавления пользовательского разрешения Вам придется использовать специальные программы. Рекомендую поискать в интернете следующие программы:

PowerStrip - Программа управления параметрами видеоподсистемы вашего компьютера, поддерживается огромное разнообразие видео карт. Это - фактически единственная программа своего рода, которая поддерживает видео карты из многочисленного набора чипсетов и поставщиков, одновременно, под любой операционной системой. Программа спокойно сидит в трее и оттуда обеспечивает доступ к более 500 элементов управления над вашими дисплейными аппаратными средствами, включая цветные инструментальные средства коррекции, установки уровня периода экранной геометрии, и драйверо-независимыми элементами управления часов.

Screen Resolution Manager - Программа, позволяющая каждому пользователю компьютера устанавливать свое разрешение экрана. Помимо разрешения можно настроить глубину цвета, частоту, яркость и контрастность, цветовую гамму и другие настройки, которые автоматически вступят в силу после загрузки профиля определенного пользователя.

14. Создание диска восстановления системы и загрузка с него.

Если у вас есть установочный диск Windows 7, создавать диск восстановления необязательно. Если же установочного диска у вас нет, создать диск восстановления нужно обязательно - он вам рано или поздно пригодится. С установочного диска можно загрузиться в среду восстановления Windows RE.

Создание диска восстановления системы

1) Вставьте чистый компакт-диск в привод.
2) Откройте Пуск -> Панель Управления -> Архивация и восстановление (Backup and Restore)
3) В левой панели щелкните ссылку Создать диск восстановления системы.

Загрузка с диска восстановления системы

1) Вставьте диск восстановления в привод и перезагрузитесь
2) В BIOS должен быть установлен приоритет загрузки с привода. Будет выполнена загрузка в Windows RE.
3) Выберите систему, которую вы хотите восстановить.
4) Установите переключатель Используйте средства восстановления... и нажмите кнопку Далее. Вы увидите окно с вариантами восстановления.

15. Изменение строки в загрузочном меню Windows 7 с "Предыдущая версия Windows" на "Windows ХР".

1) Запустите cmd.exe от имени администратора(Win+R -> cmd -> Ok)
2) Выполните следующие команды, нажимая после введения каждой Enter

16. Перенесение файлов загрузки, при удалении из системы одного из жестких дисков.

Вы решили заменить или продать один из ваших жестких дисков. Прежде чем это сделать, убедитесь что файлы загрузки Windows 7 не содержаться на удаляемом Вами из системы жестком диске.
Windows 7 хранит свои файлы для загрузки на активном диске, который может отличаться от того на котором установлена Windows 7. Файлами загрузки для Windows 7 являются файл bootmgr и хранилище данных конфигурации загрузки BCD (Boot Configuration Data), находящееся в скрытой и системной папке Boot.

При загрузке Windows 7 проверяет соблюдение 3 условий:

- Является ли диск, с которого выполняется загрузка активным;
- Совместима ли Главная Загрузочная Запись (Master Boot Record - MBR) с bootmgr (Диспетчером загрузки Windows);
- Находиться ли файлы загрузки операционной системы на активном диске должны.

В случае не соблюдения одного из условий, загрузка становится невозможной.

Предположим, что Ваша Windows 7 установлена на диск С:, который не активен. Активным является только диск D:, который Вы собираетесь удалить из системы и на котором находятся Файлы загрузки Windows 7, имеющие атрибуты Скрытый и Системный.

В качестве решения предлагаю Вам выполнить перенесение файлов загрузки Windows 7 с активного раздела (удаляемый жесткий диск) на неактивный раздел (остающийся в системе жесткий диск, с присвоением ему атрибута - Активный).

1) Выяснение атрибутов дисков и присвоение остающемуся в системе жесткому диску атрибута Активный.

Способ 1. Используя оснастку "Управление дисками".

1.1.1) Нажмите Win + R, в строке "Выполнить" наберите diskmgmt.msc и нажмите OK
1.1.2) В нижней части окна, где находится графическое представление разделов, найдите том (раздел) на котором установлена Ваша Windows 7 Буква тома здесь, идентична букве диска с Window 7 из Мой Компьютер.
1.1.3) Под буквой тома, размером диска и файловой системой будут указаны атрибуты диска. Посмотрите имеет ли наш том атрибут "Активный". Если да, то Вы сможете спокойно удалить Ваш диск из системы. Если же нет, то Вам необходимо будет присвоить данный атрибут, в соответствии с написанным ниже.
1.1.4) Если Ваша Windows 7 установлена на жесткий диск, разбитый на несколько разделов, то выберите первый слева раздел остающегося у Вас диска, его мы сделаем загрузочным и активным. Если же раздел всего один, то выберите его.
1.1.5) Щелкните правой кнопкой мыши по выбранному разделу и выберите в контекстном меню пункт "Сделать раздел активным". Учтите, что этот раздел должен иметь атрибут "Основной".

Способ 2. Используя командную строку.

1.2.1) Запустите командную строку с правами администратора. Нажмите Win + R, в строке "Выполнить" наберите cmd и нажмите OK.
1.2.2) Последовательно выполните все команды без выхода из командной строки:

где X - номер диска, который предполагается оставить, в списке дисков (команда list disk).

2) Перезапись загрузочного сектора MBR и установка его совместимости с bootmgr:

2.1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe)
2.2) Создайте папку Boot
2.3) Распакуйте скачанный архив и скопируйте файлы Bootsect.exe и Bcdedit.exe, нужной Вам битности в созданную Вами папку Boot.
2.4) Запустите командную строку с правами администратора.

где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /force - принудительно отключает один или несколько томов во время обновления загрузочного кода. Необходим, при наличии в конфигурации 2-х и более жестких дисков.

3) Перенесение BCD (Boot Configuration Data) и файла bootmgr на новый активный раздел:

где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /l - выбор языковых параметров менеджера загрузки. Если ваша система не русскоязычная, используйте другие значения этого ключа, например, для английского языка - en-US, для немецкого - de-DE, и т.д.
- ключ /s - определяет букву тома, назначенную целевому системному разделу, в который копируются файлы среды загрузки. Это раздел, который мы сделали активным. Windows 7 использует текущий загрузочный раздел (в нашем случае - раздел D:) до завершения своей работы. Поэтому применение этого ключа с указанием буквы нового загрузочного раздела (в нашем случае - раздел С:) - обязательно.

17. Способы доступа к элементам Панели управления.

В разных статьях Вы можете увидеть разное описание пути к одинаковым элементам Панели управления. Такое происходит потому что в Windows существует два вида отображения элементов: Категория(элементы сгруппированы по тематикам) и Крупные или Мелкие значки (элементы отображаются полным списком) Имхо, наиболее удобным является Крупные или Мелкие значки(их полный список).

Существует несколько способов доступа к элементам Панели управления:

1) Через меню Пуск.

Для быстрого доступа к элементам Панели управления, рекомендуется добавить в меню Пуск всплывающее меню содержащее все элементы Панели Управления.
1.1) Нажмите правой кнопкой мыши на кнопке Пуск и щелкните на пункте Свойства.
1.2) Нажмите Настроить...
1.3) Промотайте до записи Панель управления.
1.4) Установите значение переключателя под ней в положение Отображать как меню и нажмите OK
Всплывающее меню Панели управления будет отображаться полным списком, независимо от Вашего выбора вида отображения.

2) Через Проводник Windows.

2.1) Запустите Проводник
2.2) В панели меню выберите Сервис и нажмите Параметры папок
2.3) Под надписью Область переходов установите флажок напротив значения Показать все папки и нажмите OK
Теперь Панель управления будет доступна в Проводнике в Области переходов слева. Преимущество данного способа в том что Вы можете работать, как сразу с полным списком элементов: Проводник -> Панель управления -> Все элементы панели управления, так и с отдельными разделами: Проводник -> Панель управления -> Нужный Вам раздел.

3) На рабочем столе.

3.1) Щелкните правой кнопкой мыши на Рабочем столе и нажмите Персонализация
3.2) Щелкните Изменение значков рабочего стола
3.3) Установите флажок напротив Панель управления и нажмите ОК
На Рабочем столе появится ярлык запускающий папку Панель управления. Способ отображения зависит от выбранного Вами значения параметра Просмотр.

4) Добавление или запуск папки Панель управления используя {GUID}

Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

Control Panel.{26EE0668-A00A-44D7-9371-BEB064C98683}

Для её запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win+R) и введите команду:

shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}

5) Запуск элементов Панели управления, используя канонические имена.

Русское название элемента | Английское название элемента | Команда
Панель управления | Control Panel | control
Windows CardSpace | Windows CardSpace | control /name Microsoft.CardSpace
Windows SideShow | Windows SideShow | control /name Microsoft.WindowsSideShow
Автозапуск | AutoPlay | control /name Microsoft.AutoPlay
Автономные файлы | Offline Files | control /name Microsoft.OfflineFiles
Администрирование | Administrative Tools | control /name Microsoft.AdministrativeTools
Архивация и восстановление | Backup and Restore | control /name Microsoft.BackupAndRestore
Биометрические устройства | Biometric Devices | control /name Microsoft.BiometricDevices
Брандмауэр Windows | Windows Firewall | control /name Microsoft.WindowsFirewall
Восстановление | Recovery | control /name Microsoft.Recovery
Гаджеты рабочего стола | Desktop Gadgets | control /name Microsoft.DesktopGadgets
Дата и Время | Date and Time | control /name Microsoft.DateAndTime
Датчик расположения и другие датчики | Location and Other Sensors | control /name Microsoft.LocationAndOtherSensors
Диспетчер устройств | Device Manager | control /name Microsoft.DeviceManager
Диспетчер учетных данных | Credential Manager | control /name Microsoft.CredentialManager
Домашняя группа | HomeGroup | control /name Microsoft.HomeGroup
Защитник Windows | Windows Defender | control /name Microsoft.WindowsDefender
Звук | Sound | control /name Microsoft.Sound
Значки области уведомлений | Notification Area Icons | control /name Microsoft.NotificationAreaIcons
Игровые устройства | Game Controllers | control /name Microsoft.GameControllers
Инфракрасная связь | Infrared | control /name Microsoft.Infrared
Папка "Fonts" | Fonts Folder | control /name Microsoft.Fonts
Параметры индексирования | Indexing Options | control /name Microsoft.IndexingOptions
Параметры папок | Folder Options | control /name Microsoft.FolderOptions
Параметры планшетного компьютера | Tablet PC Settings | control /name Microsoft.TabletPCSettings
Перо и сенсорные устройства | Pen and Touch | control /name Microsoft.PenAndTouch
Персонализация | Personalization | control /name Microsoft.Personalization
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection | control /name Microsoft.RemoteAppAndDesktopConnections
Получение программ | Get Programs | control /name Microsoft.GetPrograms
Приступая к работе | Getting Started | control /name Microsoft.GettingStarted
Программы и компоненты | Programms and Features | control /name Microsoft.ProgramsAndFeatures
Программы по умолчанию | Default Programs | control /name Microsoft.DefaultPrograms
Распознавание речи | Speech Recognition | control /name Microsoft.SpeechRecognition
Расположение по умолчанию | Default Location | control /name Microsoft.DefaultLocation
Родительский контроль | Parental Controls | control /name Microsoft.ParentalControls
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | control /name Microsoft.TaskbarAndStartMenu
Свойства речи | Text to Speech | control /name Microsoft.TextToSpeech
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | control /name Microsoft.iSCSIInitiator
Свойства: Интернет | Internet Properties | control /name Microsoft.InternetOptions
Свойства: Клавиатура | Keyboard Properties | control /name Microsoft.Keyboard
Свойства: Мышь | Mouse Properties | control /name Microsoft.Mouse
Система | System | control /name Microsoft.System
Сканеры и камеры | Scanners and Cameras | control /name Microsoft.ScannersAndCameras
Соседние пользователи | People Near Me | control /name Microsoft.PeopleNearMe
Счетчики и средства производительности | Performance Information and Tools | control /name Microsoft.PerformanceInformationAndTools
Телефон и модем | Phone and Modem | control /name Microsoft.PhoneAndModem
Управление цветом | Color Management | control /name Microsoft.ColorManagement
Устранение неполадок | Troubleshooting | control /name Microsoft.Troubleshooting
Устройства и принтеры | Devices and Printers | control /name Microsoft.DevicesAndPrinters
Учетные записи пользователей | User Accounts | control /name Microsoft.UserAccounts
Центр мобильности Windows | Windows Mobility Center | control /name Microsoft.MobilityCenter
Центр обновления Windows | Windows Update | control /name Microsoft.WindowsUpdate
Центр поддержки | Action Center | control /name Microsoft.ActionCenter
Центр синхронизации | Sync Center | control /name Microsoft.SyncCenter
Центр специальных возможностей | Ease of Access Center | control /name Microsoft.EaseOfAccessCenter
Центр управления сетями и общим доступом | Network and Sharing Center | control /name Microsoft.NetworkAndSharingCenter
Шифрование диска BitLocker | BitLocker Drive Encryption | control /name Microsoft.BitLockerDriveEncryption
Экран (размер текста) | Display (size of text) | control /name Microsoft.Display
Электропитание | Power Options | control /name Microsoft.PowerOptions
Язык и региональные стандарты | Region and Language | control /name Microsoft.RegionAndLanguage

При отсутствии в системе необходимого устройства, драйверов или определенных компонентов, соответствующий ему элемент Панели управления может не запуститься.

18. Отключение значка "Центра поддержки" из области уведомлений на панели задач.

Если во время работы у Вас в трее появился флаг "Центра поддержки", и Вы хотите его убрать, то проделайте следующее.

1) Щелкните правой кнопкой мыши на Панели задач и выберите пункт "Свойства".
2) Нажмите на кнопку "Настроить".
3) Перейдите по ссылке "Включить или выключить системные значки"
4) Установите значение системного значка "Центр поддержки" в "Выкл" и нажмите ОК.

19. Добавление своей программы в утилиту msconfig (Конфигурация системы).

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните с именем mscfgtlc.xml
3) Скопируйте файл в папку C:\Windows\system32\
4) Нажмите кнопку Сохранить

Например:

или

Добавленная Вами программа появится во вкладке Сервис (Tools). Для использования русских букв файл необходимо сохранить файл в кодировке UTF-8. В качестве пути можно указать только файлы из папок Windows или Programm Files включая подпапки.

20. Настройка параметров индексирования для ускорения выполнения поиска в системе.

Операционная система Windows использует индекс для выполнения быстрого поиска наиболее часто используемых файлов. По умолчанию индексируются все самые распространенные файлы на компьютере. Повысить производительность поиска в Windows 7 можно, следующим образом.

Добавление или удаление расположения из индекса.

1) Откройте меню Пуск, введите в строке поиска Параметры индексирования и нажмите Enter.
2) Щелкните Изменить.
3) Установите или снимите флажок с папок в списке Изменение выбранных расположений, которые Вы желаете добавить или удалить для ускорения поиска, а затем нажмите кнопку ОК.
4) Если в списке отображаются не все расположения на компьютере, нажмите кнопку Показать все расположения. (Если в списке отображаются все расположения на компьютере, кнопка Показать все расположения недоступна.) Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
5) Если требуется добавить папку, исключая некоторые вложенные папки, щелкните папку и затем снимите флажки рядом с теми вложенными папками, которые не требуется индексировать. Эти папки будут отображены в столбце «Исключить» в разделе Сводный список выбранных расположений.

Индексировать все файлы на компьютере не рекомендуется, так как если сделать индекс слишком большим или добавить в индекс расположения системных файлов (например, папки «Program Files»), поиск будет выполняться медленно.

Добавление или удаление типа файла из индекса.

1) Откройте меню Пуск, введите в строке поиска Параметры индексирования и нажмите Enter.
2) Щелкните Дополнительно. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
3) Перейдите на вкладку Типы файлов.
4) Снимите флажок с расширений в списке, которые Вы желаете удалить для ускорения поиска.
5) В поле Добавить новое расширение введите расширение имени файла, которые Вы желаете добавить для ускорения поиска, а затем нажмите кнопку Добавить.
6) Установите переключатель в значение Индексировать только свойства при большом количестве выделенных расширений или Индексировать свойства и содержимое файлов при небольшом, а затем нажмите кнопку ОК.

Администрирование

1. Получение полного доступа к файлу или папке.

1) Создайте reg файл
1.1) Скопируйте код в любой текстовый редактор (например, Блокнот).
1.2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "admin.reg")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

2) Примените его
3) Щелкните на файле или папке правой кнопкой мышки и выберите пункт "Стать владельцем и задать полный доступ к объекту"
4) В любых окнах, если они появятся нажимаете Да(Yes)

Скачать готовый reg-файл: Full_access.zip

Если Вам необходимо изменить права доступа, а после использования файла вернуть все права обратно, то Вы можете воспользоваться программой TakeOwnershipEx от Happy Bulldozer, которая обладает следующими возможностями:

  • Получение прав на один или сразу несколько файлов. В диалоге открытия Вы можете выбрать сразу несколько файлов, выделяя их мышкой и удерживая клавишу CTRL или SHIFT. Выбранным файлам в качестве владельца выставляется группа локальных "Администраторов", и предоставляется полный доступ для этой группы.

  • Восстановление прав. Если Вы получили права владельца и полный доступ, утилита запоминает, какие права у файла были до этого, и потом Вы в любой момент можете их вернуть на место.

    • 2. Запуск командной строки от имени (с правами) администратора.

    Если Вы работаете под учетной записью обычного администратора, то командная строка от имени администратора запускается так:

    Вариант 1.

    1) В строке поиска меню Пуск введите команду: cmd.
    2) Щелкните на найденном файле cmd.exe правой кнопкой мыши и выберите пункт Запуск от имени администратора

    Вариант 2.

    В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl+Shift+Enter.

    Вариант 3.

    1) Нажмите кнопку Пуск
    2) Перейдите Все Программы -> Стандартные
    3) Щелкните правой кнопкой мыши на Командная строка и выберите пункт Запуск от имени администратора.

    Если Вы работаете под встроенной учетной записью администратора, то кроме указанных выше вариантов Вы можете использовать еще один вариант:

    Вариант 4.

    1) Запустите диалоговое меню Выполнить. В зависимости от Ваших настроек: Откройте Пуск -> Выполнить или нажмите комбинацию клавиш Win+R.
    2) Введите команду: cmd и нажмите Enter.

    3. Изменение прав доступа и владельца для файла (папки), используя проводник или командную строку.

    Случается, что при работе с файлами или папками Вам бывает необходимо изменить для них владельца и права доступа.

    Смена владельца файла или папки, используя проводник.

    1) Щелкните файл или папку правой кнопкой мыши, выберите команду Свойства и перейдите на вкладку Безопасность.
    2) Нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3) Нажмите кнопку Изменить и выполните одно из следующих действий:

  • Чтобы назначить владельцем пользователя или группу из списка, в окне Изменить владельца на выберите нового владельца и нажмите ОК.
  • Чтобы назначить владельцем пользователя или группу, которых нет в списке:

    • 1) Нажмите кнопку Другие пользователи и группы
    2) Если владельцем необходимо установить службу TrustedInstaller, в качестве имени объекта в поле Введите имена выбираемых объектов (примеры) введите: NT SERVICE\TrustedInstaller и нажмите кнопку ОК.
    3) Если владельцем необходимо другого пользователя или группу, то нажмите кнопку Дополнительно, а затем кнопку Поиск.
    3.1) В результатах поиска выберите необходимую Вам группу или пользователя и нажмите кнопку ОК.

    4) В окне Изменить владельца на: выберите добавленную группу или пользователя.
    5) Чтобы сменить владельца всех субконтейнеров и объектов в папке, установите флажок Заменить владельца субконтейнеров и объектов и нажмите кнопку ОК.

    Изменение разрешений для доступа к файлам и папкам, используя проводник.

    1) Щелкните правой кнопкой мыши файл или папку, для которых нужно задать разрешения, выберите команду Свойства и откройте вкладку Безопасность.
    2) Нажмите кнопку Изменить разрешения и выполните одно из следующих действий:
    2.1) Чтобы изменить разрешения для существующей группы или пользователя, выберите имя этой группы или пользователя и нажмите кнопку Изменить.
    2.1.1) Установите необходимые Вам флажки Разрешить или Запретить напротив каждого разрешения и нажмите кнопку ОК, а затем кнопку Применить.
    2.2) Чтобы изменить разрешения для группы или пользователя, которого нет в списке Элементы разрешений, нажмите кнопку Добавить.

    2.2.1) Если необходимо изменить разрешения для службы TrustedInstaller, в качестве имени объекта в поле Введите имена выбираемых объектов (примеры) введите: NT SERVICE\TrustedInstaller и нажмите кнопку ОК.
    2.2.2) Если необходимо изменить разрешения для другого пользователя или группы, то нажмите кнопку Дополнительно, а затем кнопку Поиск.
    2.2.3) В результатах поиска выберите необходимую Вам группу или пользователя и нажмите кнопку ОК.
    2.2.4) Установите необходимые Вам флажки Разрешить или Запретить напротив каждого разрешения и нажмите кнопку ОК, а затем кнопку Применить.

    2.3) Чтобы удалить группу или пользователя из списка Элементы разрешений, нажмите кнопку Удалить.

    Далее рассказывается как можно изменить разрешения или сменить владельца, используя командную строку запущенную от имени администратора.
    Если после использовании команды, разрешения или владелец не сменятся, то возможно Вам придется зайти в систему под встроенной учётной записью "Администратор" для их выполнения заново.

    Изменение владельца файла (папки) на указанного Вами пользователя, используя командную строку.

    Примеры:

    Параметры:

    /T - операция выполняется для всех соответствующих файлов и каталогов, расположенных в указанных в имени каталогах.
    /C - выполнение операции продолжается при любых файловых ошибках. Сообщения об ошибках по-прежнему выводятся на экран.
    /L - операция выполняется над самой символической ссылкой, а не над ее целевым объектом.
    /Q - команда icacls подавляет сообщения об успешном выполнении.

    Изменение разрешений для файла (папки), используя командную строку.

    Разрешения:

    F - полный доступ
    M - доступ на изменение
    RX - доступ на чтение и выполнение
    R - доступ только на чтение
    W - доступ только на запись
    D - доступ на удаление

    Примеры:

    Об остальных возможностях команды icacls Вы сможете узнать введя команду: icacls /?

    4. Автоматический вход в систему и отключение экрана пользователей при запуске.

    Если вы хотите ускорить процесс загрузки Windows 7, то вы можете настроить автоматический вход в систему. Эта возможность создана для тех ситуаций, когда компьютером пользуется один человек. Настроив автоматический вход, вам не нужно будет вводить пароль каждый раз, когда загружается ваша операционная система.
    Чтобы настроить автоматический вход в Windows 7, сделайте следующее:

    1. Нажмите на клавиатуре Win+R (или пункт Выполнить в меню Пуск).
    2. В появившемся окне введите “control userpasswords2” (без кавычек) и нажмите Enter.
    3. В окне Учетные записи пользователей во вкладке Пользователи выделите свою учетную запись и уберите флажок с “Требовать ввод имени пользователя и пароля”.
    4. Нажмите Принять.
    5. В открывшемся окне Автоматический вход в систему будут три поля - Пользователь, Пароль и Подтверждение. Введите свой пароль в поле Пароль и еще раз - в поле Подтверждение и нажмите ОК.

    Всё. Со следующей перезагрузки системы вам больше не нужно будет вводить свой пароль. Вход в Windows будет происходить автоматически.
    (Возможен побочный эффект: после перезагрузки панель "Quick Launch" не сохраняется - после рестарта её нет.)

    5. Ограничение разрешенных действий для пользователей, имеющих временный доступ к компьютеру.

    Вариант 1.

    1.1) Запустите оснастку Локальные пользователи и группы (Win+R -> lusrmgr.msc -> Ok)
    1.2) Включите встроенную гостевую учетную запись пользователя. Дважды щелкните на профиль Гость, уберите флажок с Отключить учетную запись и нажмите OK.
    1.3) Откройте Панель управления\Все элементы панели управления\Учетные записи пользователей и нажимаете ссылку Управление другой учетной записью.
    При желании, можете поставить на свою учетную запись пароль.
    1.4) Нажмите на учетную запись Гость, а затем нажмите на кнопку Включить.
    1.5) Для перехода в гостевую учетную запись щелкните на стрелочке рядом с Завершение работы и выберите пункт Сменить пользователя. Обратный переход аналогично.

    Вариант 2.

    2.1.1) Запустите оснастку Редактор локальной групповой политики (Win+R -> gpedit.msc -> Ok)
    2.1.2) В Административные шаблоны, дважды щелкните на элементе Все параметры
    2.1.3) Отсортируйте элементы по-названию.
    2.1.4) Включите необходимые Вам параметры начинающиеся со слов Запретить .... Для этого, дважды щелкните на необходимом элементе установите переключатель в значение Включить и нажмите Ок.

    Также в оснастке Редактор локальной групповой политики Вы можете осуществлять контроль за приложениями, на основе создаваемых Вами правил, разрешать или запрещать запуск затрагиваемых файлов, основываясь на их атрибутах. К примеру, можно создать правило, позволяющее запускать все приложения, подписанные конкретным издателем (например, Microsoft) или находящиеся по определеному пути (Например: C:\Program Files\Mozilla Firefox). Для этого Вам необходимо создать Исполняемые правила, используя мастер правил AppLocker.
    Для создания нового правила сделайте следующее:

    2.2.1) Пройдите в Конфигурация компьютера -> Конфигурация Windows -> Параметры безопасности -> Политики управления приложениями -> AppLocker.
    2.2.2) Нажмите на Исполняемые правила
    2.2.3) В меню оснастки Редактор локальной групповой политики нажмите Действие и выберите пункт Создать новое правило..., также Вы можете щелкнуть правой кнопкой мыши в правой части окна и также выбрать из списка пункт Создать новое правило....

    Вариант 3.

    3) Воспользуйтесь программой Deep Freeze или аналогичной ей, данная программа позволяет заморозить текущее состояние системы. С её помощью можно сохранить текущую конфигурацию системы, к которой машина будет автоматически возвращаться после перезагрузки. При этом абсолютно не имеет значения что делает пользователь - устанавливает новые программы, удаляет системные файлы или работает в сети - после перезагрузки вы получите девственно чистую машину.
    Для отключения Deep Freeze надо нажать Ctrl+Shift+Alt+F6 и выбрать Boot Thawed, для удаления Deep Freeze сначала его надо отключить, а потом запустить установочный файл и выбрать Uninstall.

    6. Быстрый запуск программы с правами администратора.

    Удерживайте Ctrl+Shift и нажмите на иконку приложения (у Вашей учетной записи, должны быть права администратора).

    7. Убирание запрещающего значка с папки.

    1) Нажимаете правой кнопкой мыши на папке с которой Вы хотите убрать значок замка и выбираете Свойства
    2) Переходите на вкладку Безопасность
    3) Нажимаете на кнопки Изменить -> Добавить -> Дополнительно -> Поиск
    4) В результатах поиска удерживая нажатой клавишу Ctrl, выбираете следующие имена: система; Администраторы; Прошедшие проверку; и нажимаете Ок
    5) В окне группы или пользователи выбираете система; и ставите флажок на Полный доступ, после выбираете Администраторы; и снова ставите флажок на Полный доступ, а затем выбираете Прошедшие проверку; и также ставите флажок на Полный доступ.
    6) Нажимаете Ок

    При возникновении окон "Ошибка применения безопасности" нажимайте Продолжить.

    Также Вы можете воспользоваться решением предложенным в совете Администрирование: 1. Получение полного доступа к файлу или папке.

    1) Создайте reg-файл(например: admin.reg) как описано в Администрирование: 1. Получение полного доступа к файлу или папке.
    2) Примените его
    3) Щелкните на папке и выберите пункт "Стать владельцем и задать полный доступ к объекту"
    4) В любых окнах, если они появятся нажимаете Да(Yes)

    8. Запуск приложений в Windows 7 c повышенными привилегиями без отключения UAC.

    Многие пользователи считают функцию контроля учётных записей(UAC) в Windows 7 весьма полезной и не отключают её . Но иногда всё же требуется запустить приложение с повышенными правами, а некоторые приложения, такие как, например, Sysinternals Process Explorer или Sysinternals Autoruns, и вовсе лучше всегда запускать с повышенными привилегиями.
    Конечно, Вы можете воспользоваться одним из простых способов, и постоянно щелкать уведомления UAC:

    1) Нажмите правой клавишей мыши по значку нужного приложения и выберите пункт "Запуск от имени администратора"
    2) Нажмите Пуск, в строке поиска наберите нужную команду и нажмите Ctrl+Shift+Enter.
    3) Щелкните правой клавишей мыши по нужному ярлыку и выберите пункт "Свойства". Или перейдите на вкладку "Совместимость" и установите флажок "Выполнять эту программу от имени администратора"

    Есть также и другой способ, через создание высокопривилегированной задачи системного планировщика заданий. Способ немного сложнее предыдущих, но запросы UAC не отображаются.

    1) Запускаете планировщик заданий (Пуск ---> Все программы ---> Стандартные ---> Служебные ---> Планировщик заданий)
    2) Нажимаете "Создать задачу"
    3) Указываете Имя для новой задачи и ставите флажок "Выполнять с наивысшими правами"
    4) Переходите на вкладку Действия, нажимаете "Создать", в следующем окне нажимаем "Обзор"
    5) Указываете путь к нужному приложению и нажимаете "Открыть"
    6) Нажимаете "ОК", затем снова "ОК"
    7) Создайте ярлык на рабочем столе ( Нажмите правую кнопку мыши, выберете "Создать" ---> "Ярлык")
    8) В поле Расположение объекта введите:

    где mytask_admin - имя созданной нами задачи. Если в имеми содержаться робелы, обязательно укажите его в кавычках.
    9) Введите имя ярлыка и нажмите Готово

    Но есть и более легкий способ, создания ярлыка, при запуске которого не отображаются запросы UAC - это использовать приложение Elevated Shortcut.
    Оно автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает на рабочем столе необходимый ярлык. Просто перетащите необходимый исполняемый файл на окно программы Elevated Shortcut.

    Скачать можно здесь или здесь

    9. Перемещение профилей пользователей и изменение путей к ним.

    Указанные в с 1 по 4 вариантах действия, необходимо повторять для каждого профиля. Переместив таким образом все профили, и изменив их пути в реестре, исходные папки можно будет удалить.

    Вариант 1. С помощью компонента Windows - "Профили пользователей".

    Скопируйте профиль пользователя в конечное размещение:

    1) Если папка для профиля существует, перейдите к следующему шагу, при этом используя рекомендации; если папка, в которой будет храниться профиль, не существует, создайте ее, используя рекомендации.

    Рекомендации:

  • Если на компьютере только одна учетная запись, можно присвоить папке профиля имя учетной записи; если учетных записей несколько, лучше всего создать папку верхнего уровня, например, с именем Пользователи, а в нее вложить папки с именами пользователей компьютера, в которых и будут храниться наши профили. Хотя использовать папку верхнего уровня лучше сразу, на случай добавления новых учетных записей;
  • Если конечная папка уже существует и она имеет содержимое, которое необходимо сохранить, ее необходимо скопировать в другое размещение, а затем, после завершения перемещения профилей, переместить это содержимое в папку с профилем пользователя

    • 2) Откройте Система: команда свойства контекстного меню Компьютер или сочетание Windows + Break.
    3) Щелкните Дополнительные параметры системы. Щелкните Продолжить, если появится соответствующий запрос системы контроля учетных записей.
    4) Откройте вкладку Дополнительно.
    5) Щелкните кнопку Параметры в рамке Профили пользователей.
    6) Выберите профиль, который необходимо переместить. Активный профиль не выбирается. Чтобы его можно было выбрать для осуществления необходимых действий, нужно войти под другой учетной записью и иметь права администратора.
    7) Нажмите кнопку Копировать.
    8) Выберите папку, в которой будет находиться профиль, созданную на шаге 1.
    9) Нажмите OK; если выбранная папка не пустая, система выдаст запрос на копирование профиля в нее, так как при этом удаляется все ее содержимое! (не забудьте о рекомендациях!). Нажмите Да.

    Внесите изменения в системный реестр.

    1) Откройте меню Выполнить: Пуск -> Выполнить (либо Win+R)
    2) Введите regedit.exe, нажимаем Enter.
    3) Измените значение параметра ProfileImagePath в ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID, где SID – идентификатор безопасности пользователя, присваивая ему значение пути к папке, в которую был предварительно скопирован профиль. Убедиться в том, что данный ключ содержит ключ к необходимому нам профилю, можно по значению ProfileImagePath, содержащему путь к текущему размещению профиля пользователя.
    Также Вы можете воспользоваться скриптом SIDList.vbs для выяснения, какому аккаунту принадлежит какой SID.
    4) Перезагрузите компьютер.

    Внесение изменений в системный реестр может привести к снижению стабильности и производительности системы или ее отказу, поэтому настоятельно рекомендуется создать резервную копию реестра перед выполнением данной операции. В данном случае удобно воспользоваться экспортом изменяемого ключа или Восстановлением системы.

    Вариант 2. На другой диск вручную.

    1) Запустите оснастку "Локальные пользователи и группы" (Win+R -> lusrmgr.msc -> Ok)
    2) Включите системную запись администратора. Выбираете "Пользователи". В свойствах пользователя "Администратор" снимаете галку "Отключить пользователя". Если же Вы уже работаете в учетной записи Администратор, то создайте новую учетную запись с правами администратора.
    3) Для полного доступа к файлам и папкам перезапустите компьютер, и зайдите под аккаунтом "Администратор" (или под созданным Вами с правами администратора).

    Указанные выше действия необходимы, потому что профиль под которым Вы зайдете, для осуществления необходимых действий не выбирается. Соответственно залогинившись под одним профилем, Вы можете работать только с другими.

    4) Запустите "Проводник" в режиме администратора:
    Щелкните правой кнопкой мыши на иконке Проводника
    Щелкните правой кнопкой мыши на слове Проводник
    Выберите пункт "Запуск от имени администратора"
    5) Создайте на диске D: папку Users.
    6) Поменяйте права на "D:\Users", исходя из прав на системный Users.
    Оставьте только "Чтение и выполнение" для группы "Everyone"(Все), и "Полный доступ" для групп "Administrators" (Администраторы) и "System".
    На вкладке "Разрешения" (Безопастность\Дополнительно\Разрешения\Изменить разрешения) уберите галочку с пункта "Добавить разрешения, наследуемые от родительских объектов" и нажмите на кнопку Добавить(иначе удаляться все группы и Вам придется их прописывать самостоятельно)
    Владелец папки, установите на "Administrators" (Администраторы).
    7) В Проводнике запущенном от имени Администратора скопируйте необходимую Вам папку пользователя в "D:\Users".

    Так как Проводник не умеет копировать "junction" (точки соединения, исполняющие роль символической ссылки одного каталога компьютера на другой каталог), то их придется создавать самостоятельно. Например, "junction" являются папки "Application Data", "Local Settings", "SendTo" и другие.

    8) Запустите командную строку от имени администратора (Win+R -> CMD -> Ok)
    9) Для показа только скрытых файлов введите команду "dir /ah" (без кавычек) и нажмите Enter. Вы увидите примерно следующее:

    10) Создайте аналогичные "Junction" каталоги:

    Способ 1. Вручную для каждого "Junction" каталога.

    1) В командной строке переходите в созданную Вами папку:

    2) И для каждой "Junction" выполняете команду:

    Например:

    Способ 2. Создание bat-файла.

    Если Вам предстоит перенести несколько профилей, то проще будет создать bat-файл, так как "Junction" у Вас скорее всего будут такие же.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .bat
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "profiles.bat")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    В моем случае получился такой, Вы можете создать аналогичный для своих папок (запускаете его из каталога профиля "D:\Users\ВашПрофиль"):

    Если у Вас папки имеют русские названия, то для правильной работы данного bat-файла, надо его сохранять в кодировке CP866 (Блокнот Windows, в ней не сохраняет, используйте для этого программы сторонних производителей например: Akelpad).
    11) Присвойте "Junction" каталогам скрытые и системные атрибуты, как в оригинале.

    Либо, вручную для каждого в командной строке.

    Например:

    Либо, создав bat-файл (запускаете его из каталога профиля "D:\Users\ВашПрофиль"):

    12) Запустите Реестр Windows(Win+R -> regedit -> Enter) и измените значение параметра ProfileImagePath в ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID c "C:\Users\ВашПрофиль" на "D:\Users\ВашПрофиль" , где SID – идентификатор безопасности пользователя, присваивая ему значение пути к папке, в которую был предварительно скопирован профиль. Убедиться в том, что данный ключ содержит ключ к необходимому нам профилю, можно по значению ProfileImagePath, содержащему путь к текущему размещению профиля пользователя. Также Вы можете воспользоваться скриптом SIDList.vbs для выяснения, какому аккаунту принадлежит какой SID.
    13) Переименуйте или удалите каталог профиля в "C:\Users\", чтобы предотвратить к нему запросы.
    14) Перезагрузите компьютер, чтобы Windows подхватила внесенные нами настройки.
    15) Вновь зайдите под аккаунтом Администратор.
    16) Запустите Реестр Windows(Win+R -> regedit -> Enter)
    17) Используя Поиск найдите все строки с путем к папке "C:\Users\ВашПрофиль" и исправьте на "D:\Users\ВашПрофиль" (Чем ближе к чистой установке Вы это сделаете, тем меньше строк Вам придется исправлять).
    18) Поменяйте права на каталог профиля в "D:\Users".
    Установите "Полный доступ" пользователю - владельцу профиля, и "Полный доступ" для групп "Administrators" (Администраторы) и "System".
    На вкладке "Разрешения" (Безопасность\Дополнительно\Разрешения\Изменить разрешения) уберите галочку с пункта "Добавить разрешения, наследуемые от родительских объектов" и нажмите на кнопку Добавить(иначе удаляться все группы и Вам придется их прописывать самостоятельно).
    Владелец папки, установите на "System".
    19) Перезагрузите компьютер, теперь вы можете войти в перемещенный аккаунт и проделать всё указанное выше для другого профиля.

    Вариант 3. При помощи ERD Commander.

    1) Скачиваете утилиту Junction от SysInternals. Она позволяет создавать точки соединения, исполняющие роль символической ссылки одного каталога компьютера на другой каталог.
    2) Копируете junction.exe в C:\Windows\System32
    3) Загружаетесь в Erd Commander.
    4) Выбираете опцию, чтобы реестр не импортировался
    5) Копируете например: "C:\Documents and Settings\ВашПрофиль" в "D:\Users\ВашПрофиль"
    6) После копирования, удаляете "C:\Documents and Settings\ВашПрофиль"
    7) Запускаете командную строку и переходите в папку C:\Windows\System32

    8) После сообщения Sucsess, можете зайти в папку проверяем C:\Documents and Settings\ и увидите там папку ВашПрофиль, только это уже ссылка...

    Вариант 4. При помощи Far Manager.

    1) Скачиваете Far Manager и устанавливаете его.
    2) Входите в систему под другим пользователем с правами администратора
    3) Запускаете Far Manager
    4) Находите нужный профиль пользователя.
    5) Перемещаете папку с ним на другой диск (например, C:\Documents and Settings\ВашПрофиль -> D:\Users\ВашПрофиль).
    6) Устанавливаете на перемещённую папку нужные права и нужного владельца.
    7) Создаёте на исходном разделе символическую связь с новой папкой (Alt+F6).
    8) На новую папку ставите атрибут "Скрытый".

    Вариант 5. Изменение пути к каталогам пользователей при установке Windows.

    Вы можете изменить расположение папки Пользователи (Users), в которой будут храниться профили пользователей, ещё при установке Windows.

    1) Создайте файл Autounattend.xml следующего содержания:
    2) Скопируйте его в папку \Sources установочного диска.
    3) Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.

    10. Отключение отображения имени последнего пользователя.
    Для отключения запоминания имени последнего пользователя отображаемого на экране переключения пользователей.

    1) Нажмите Пуск, в строке поиска введите secpol.msc и нажмите Enter
    2) Раскройте группу Локальные политики и перейдите к разделу Параметры безопасности
    3) Используя двойной щелчок мыши откройте параметр Интерактивный вход в систему: не отображать последнее имя пользователя и выберите состояние Включен
    Этот параметр безопасности определяет, будет ли в экране входа в Windows отображено имя последнего пользователя, выполнившего вход.
    Если эта политика включена, в диалоговом окне входа не будет отображаться имя последнего пользователя, выполнившего вход.
    Если эта политика отключена, отображается имя последнего пользователя, выполнившего вход.

    11. Включение встроенной учетной записи администратора.

    Вариант 1

    1) Запустите оснастку Локальные пользователи и группы (Win+R -> lusrmgr.msc -> Ok)
    2) В меню слева нажмите на папку Пользователи
    3) Щелкните правой кнопкой учетную запись Администратор и выберите Свойства.
    4) Откроется окно Свойства: Администратор.
    5) На вкладке Общие снимите флажок Отключить учетную запись.

    Учетная запись администратора теперь включена.

    Вариант 2

    1) Нажмите кнопку Пуск
    2) Введите в строке поиска cmd
    3) Щелкните правой кнопкой мыши ярлык командной строки и выберите пункт Запуск от имени администратора

    Для включения встроенной учетной записи Администратор в русской версии Windows используйте команду

    В системе с английской локализацией встроенная учетная запись администратора называется Administrator, поэтому команда будет выглядеть так:

    Чтобы переключиться на данную учетную запись: нажмите на кнопку Пуск, нажмите на стрелочку рядом с Завершение работы и выберите Сменить пользователя.

    12. Изменение фонового рисунка в экране авторизации пользователей.

    Вариант 1. Вручную используя реестр Windows.

    1) Создайте ключ типа DWORD с названием OEMBackground в ветке реестра

    2) Присвойте ему значение 1 (1 означает, что функция включена, 0 - выключена)
    3) Создайте в папке %windir%\system32\oobe\ папку info, а в ней папку backgrounds (%windir%\system32\oobe\info\backgrounds)
    4) Поместите сюда свой файл
    5) Переименуйте его в необходимое имя (зависит от разрешения монитора):

    background768x1280.jpg
    background900x1440.jpg
    background960x1280.jpg
    background1024x1280.jpg
    background1280x1024.jpg
    background1024x768.jpg
    background1280x960.jpg
    background1600x1200.jpg
    background1440x900.jpg
    background1920x1200.jpg
    background1280x768.jpg
    background1360x768.jpg
    backgroundDefault.jpg - в случае нестандартного расширения монитора

    Размер изображений не должен превышать 256Кб.
    Если же изображение не может быть загружено по иным причинам (неверное соотношение сторон, размер и т.д.), загружается стандартное изображение из файла imagesres.dll.

    Вариант 2. Автоматически используя специальную программу.

    1) Скачайте архив программы tweakslogon.zip
    2) Разархивируйте файл в любую папку и запустите TweaksLogon.exe
    3) Нажмите на кнопку Change Logon Screen.
    4) В открывшемся окне выберите изображение и нажмите Открыть (Open)
    5) Если Ваше изображение больше 245 кб, то программа предложит Вам его сжать. Нажмите Да (Yes)
    6) Если Вы уже меняли с помощью данной программы фоновый рисунок, то программа сообщит вам об этом. Нажмите Ок

    Чтобы вернуть стандартный фоновый рисунок нажмите кнопку Revert to Default Logon Screen.

    13. Установка службы TrustedInstaller в качестве владельца папки или файла.

    У многих системных папок и файлов владельцем, имеющим права доступа на запись/удаление является служба TrustedInstaller. Конечно Вы можете задать права себе, если Вы являетесь администратором на компьютере, но это может привести к неполадкам в работе. Например, если Вы измените владельца папки winsxs для доступа к ней и не вернете обратно права TrustedInstaller, то некоторые программы могут не запуститься.

    Если Вы удалили ее из групп и пользователей в свойствах папки (файла) на вкладке Безопасность, то чтобы вернуть обратно в качестве владельца службу TrustedInstaller Вам необходимо сделать следующее:

    1) Щелкните правой кнопкой на папке (файле) и выберите пункт Свойства.
    2) Перейдите на вкладку Безопасность и нажмите кнопку Дополнительно.
    3) В открывшемся окне перейдите на вкладку Владелец и нажмите кнопку Изменить...
    4) Нажмите кнопку Другие пользователи или группы... , в текстовом поле введите NT SERVICE\TrustedInstaller и нажмите ОК.
    5) В окне Изменить владельца на: выберите TrustedInstaller и нажмите ОК.
    Если необходимо также изменить владельца вложенных папок, то перед нажатием на кнопку ОК установите флажок Заменить владельца подконтейнеров и объектов.

    Также Вам необходимо добавить службу TrustedInstaller в список групп и пользователей, имеющих доступ к папке (файлу).

    1) Щелкните правой кнопкой на папке (файле) и выберите пункт Свойства.
    2) Перейдите на вкладку Безопасность
    3) Нажмите кнопку Изменить..., а в открывшемся окне кнопку Добавить... .
    4) В текстовом поле введите NT SERVICE\TrustedInstaller и нажмите ОК.
    5) Установите флажок в колонке Разрешить напротив разрешения Полный доступ
    6) Нажмите на кнопки ОК.

    14. Изменение пароля или новой учетной записи администратора, используя средства восстановления системы.

    Чтобы сбросить пароль учётной записи администратора (или создать новую) без использования дополнительных программ, Вам понадобится либо установочный диск Windows 7, либо диск восстановления системы, либо LiveCD с Windows PE.

    Часть №1 - Настройка запуска командной строки перед экраном входа в Windows.

    1) Загрузитесь с установочного диска Windows 7 или с диска восстановления.
    2) Откройте командную строку Восстановление системы -> Далее -> Командная строка.
    3) Запустите редактор реестра. В командной строке наберите regedit и нажмите Enter.
    4) Выделите раздел HKEY_LOCAL_MACHINE и выберите пункт Загрузить куст в меню Файл.
    5) Перейдите на диск, где установлена Windows 7, и откройте файл: C:\Windows\System32\config\SYSTEM
    6) Введите произвольное имя для загружаемого раздела. Например: NewAdmin.
    7) Перейдите в раздел HKEY_LOCAL_MACHINE\NewAdmin\Setup
    8) Измените значение параметров (Щелчок правой кнопкой мыши на параметре -> Изменить):
    8.1) Для параметра CmdLine введите значение cmd.exe и нажмите ОК.
    8.2) Для параметра SetupType измените значение с 0 на 2 и нажмите ОК.
    9) Выделите раздел NewAdmin в HKEY_LOCAL_MACHINEи выберите пункт Выгрузить куст в меню Файл.
    10) Извлеките установочный диск или диск восстановления системы, закройте редактор реестра и командную строку, нажмите Перезагрузка в окне параметров восстановления.

    Часть №2 - Создание нового пароля или новой учетной записи администратора.

    Создание нового пароля.

    1) Продолжайте обычный вход в Windows 7 и перед входом в систему Вы увидите окно командной строки.
    2) Введите команду net user, чтобы отобразить все имеющиеся учётные записи.
    3) Для создания нового пароля введите следующую команду и подтвердите её выполнение клавишей Enter:

    Если имя или пароль содержат пробелы, вводите их в "кавычках".

    Создание новой учётной записи.

    Если у Вас отсутствует учетная запись администратора, то для ее создания введите приведенные ниже команды, нажимая после каждой клавишу Enter.

    Для русской (локализованной) Windows:

    1) Создание нового пользователя.

    2) Добавление пользователя в группу Администраторы (Administrators).

    3) Удаление пользователя из группы Пользователи (Users).

    Для английской Windows:

    1) Создание нового пользователя.

    2) Добавление пользователя в группу Администраторы (Administrators).

    3) Удаление пользователя из группы Пользователи (Users).

    По окончании ввода закройте окно командной строки. Используйте созданную учетную запись для входа в Windows.

    15. Определение процесса которому принадлежит текущее окно.

    1) Скачайте Process Explorer.zip
    2) Разархивируйте в любую папку и запустите программу procexp.exe.
    3) На панели инструментов Process Explorer нажмите левой кнопкой мыши на "значок-прицел".
    4) Не отпуская левой кнопки мыши, наведите "прицел" на интересующее Вас окно.
    5) Отпустите кнопку мыши и программа Process Explorer, выделит принадлежащий окну процесс (по умолчанию синим цветом).

    16. Удаление данных о серийном номере из системы для предотвращения его хищения.

    Если Вы имеете твердую или надежную электронную копию серийного номера установленной Windows 7, то для предотвращения его хищения Вы можете удалить информацию о нем из системы. Для этого у вашей учётной записи должны быть права Администратора.

    1) Запустите командную строку от имени администратора
    1.1) В строке поиска меню "Пуск" наберите cmd.exe и нажмите Ctrl+Shift+Enter (или Win+R -> cmd -> ОК)
    2) Введите указанную ниже команду и нажмите Enter.

    Здесь slmgr.vbs - скрипт обслуживания подсистемы Software License Manager, управления лицензированием программного обеспечения.
    Опция cpky символизирует Clear Product Key.

    17. Создание точки восстановления системы при старте системы без использования апплета "Защита системы".

    Если Вам необходимо создать точку восстановления системы при старте системы не используя апплет "Защита системы", то Вы можете создать указанного ниже содержания скрипт и добавить ярлык для него в автозагрузку.

    В фоновом режиме без вывода сообщений и окон:

    С выводом окна для введения наименования для точки восстановления:

    1) Скопируйте выбранный Вами код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .vbs в любой папке (Например, на диске C:)
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "crp.vbs")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    5) Создайте ярлык для созданного Вами файла скрипта в Автозагрузку.
    5.1) Удерживая нажатой клавишу Alt перетяните иконку файла скрипта в папку Автозагрузка в меню Пуск.

    18. Запуск программ с правами администратора без выдачи уведомлений Контроля Учетных Записей.

    Если Вам необходимо часто запускать какую-либо программу от имени администратора при включенном Контроле Учетных Записей и Вы не собираетесь его полностью отключать, то Вы можете воспользоваться программой Elevated Shortcut.

    Это приложение, автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает необходимый ярлык. Программа, запущенная таким ярлыком, выполняется с привилегиями администратора, но запускается без запроса UAC (Контроля учётных записей). Elevated Shortcut предназначена для пользователей, считающих функцию контроля учётных записей(UAC) в Windows 7 полезной и которым требуется запускать какое-либо приложение всегда с повышенными правами (Sysinternals Process Explorer, например).
    Существует следующие варианты создания ярлыка:

    Вариант 1.

    1) Открываете Пуск -> Все программы -> Elevated Shortcut и запускаете программу.
    2) В появившемся окне Контроля Учетных Записей нажмите кнопку Да
    3) В зависимости от выбранного Вами языка интерфейса (из ниспадающего списка в нижнем левом углу) нажмите Создать ярлык (New Shortcut)
    4) Укажите в текстовом поле Файл на который будет создан ярлык (Target Path) - путь к запускаемому файлу программы или путь к иконке для нее.
    5) Укажите в текстовом поле Папка в которую поместить ярлык (Folder to store shortcut) - путь, где будет сохранен ярлык.
    6) Если для запуска необходим какой-нибудь параметр, то введите его в текстовое поле Параметры командной строки (Command line arguments)
    7) Нажмите ОК и ещё раз ОК и закройте программу.

    Вариант 2.

    1) Нажимаете правой кнопкой мыши на файле, для которого Вы желаете добавить ярлык.
    2) В появившемся окне Контроля Учетных Записей нажмите кнопку Да
    3) Укажите в текстовом поле Папка в которую поместить ярлык (Folder to store shortcut) - путь, где будет сохранен ярлык.
    4) Если для запуска необходим какой-нибудь параметр, то введите его в текстовое поле Параметры командной строки (Command line arguments)
    5) Нажмите ОК и ещё раз ОК и закройте программу.

    19. Запрещение запуска Диспетчера задач.

    1) Запустите редактор системных политик: Пуск -> Выполнить -> gpedit.msc (Win+R -> gpedit.msc -> ОК).
    2) Слева в дереве политик выберите Конфигурация пользователя -> Административные шаблоны -> Система -> Варианты действий после нажатия CTRL+ALT+DEL.
    3) В правом окне щелкните на Удалить диспетчер задач и выберите пункт Изменить
    4) Установите переключатель в значение Включить и нажмите ОК.
    5) Перезагрузите компьютер.

    20. Добавление своей иконки в список рисунков учетных записей.

    По умолчанию рисунки учетных записей располагаются в следующей папке:
    C:\ProgramData\Microsoft\User Account Pictures\Default Pictures
    Вы можете поместить в нее свое изображение и оно будет отображаться автоматически при выборе параметра изменения рисунка учетной записи в оснастке "Учетные записи пользователей". При этом рисунок должен быть в формате .bmp и иметь размер 128x128 пикселей.

    21. Отключение кэширования экскизов.

    Если у Вас включено отображение скрытых файлов в Windows, то обычно в папке с изображениями находится файл Thumbs.db. Данный файл используется операционной системой для хранения эскизов изображений папки для режима Эскизы страниц Проводника. Thumbs.db создаётся в каждой папке, которая содержит изображения, при первом отображении её содержимого.
    Thumbs.db является скрытым файлом, и обычно не виден в Проводнике, и может содержать эскизы уже удалённых изображений. Поэтому, он может быть случайно передан постороннему лицу, которое может узнать компрометирующую информацию.

    Чтобы отключить кэширование экскизов в скрытых файлах Thumbs.db, в версиях Windows 7: "Профессиональная", "Корпоративная", "Максимальная", выполните следующие действия:

    1) В строке поиска меню Пуск введите gpedit.msc и нажмите Enter
    2) В запустившимся Редакторе групповых политик выберите раздел Конфигурация пользователя
    3) Откройте Административные шаблоны -> Компоненты Windows -> Проводник Windows
    4) В панели справа найдите политику Отключить кэширование экскизов в скрытых файлах thumbs.db.
    5) Дважды щелкните на ней, чтобы открыть ее Свойства
    6) В открывшимся окне установите переключатель в значение Включить.
    7) Нажмите ОК

    Чтобы отключить кэширование экскизов в скрытых файлах Thumbs.db, в версиях Windows 7: "Домашняя базовая" и "Домашняя расширенная", выполните следующие действия:

    1) Запустите редактор реестра (Win+R->regedit->ОК)
    2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) В меню Правка выберите Создать -> Параметр DWORD (32 бита).
    4) Задайте имя параметра NoThumbnailCache
    5) Дважды щелкните на данном параметре и введите значение 1.
    6) Закройте редактор реестра и перезапустите компьютер.

    22. Поиск приложений автоматически загружающихся при запуске компьютера.

    Если у Вас при запуске Windows запускается какое-либо приложение, которое Вы хотите удалить из автозагрузки, то Вы можете либо проанализировать объекты находящиеся Пуск -> Все программы -> Автозагрузка и указанные ниже разделы реестра:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run (текущий пользователь)
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce (текущий пользователь, запуск один раз)
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run (все пользователи)
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз)
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run (текущий пользователь, только 64-бит версия)
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз, только 64-бит версия)

    Но есть более лучший способ, позволяющий сделать более тщательный анализ автоматически запускаемых приложений - воспользоваться программой AutoRuns созданной Марком Руссиновичем.

    Данная программа проверяет большее количество мест, из которых происходит автозапуск программ.

    Просто запустите средство Autoruns, и оно покажет, какие приложения настроены на автоматический запуск, а также представит полный список разделов реестра и каталогов файловой системы, которые могут использоваться для задания автоматического запуска. Элементы, которые показывает программа Autoruns, принадлежат к нескольким категориям: объекты, автоматически запускаемые при входе в систему, дополнительные компоненты проводника, дополнительные компоненты Internet Explorer (включая объекты модулей поддержки обозревателя (BHO)), библиотеки DLL инициализации приложений, подмены элементов, объекты, исполняемые на ранних стадиях загрузки, библиотеки DLL уведомлений Winlogon, службы Windows и многоуровневые поставщики услуг Winsock. Чтобы просмотреть автоматически запускаемые объекты требуемой категории, достаточно выбрать нужную вкладку.

    Параметр Hide Signed Microsoft Entries (Не показывать элементы с цифровой подписью Microsoft) из раздела меню Options позволяет сосредоточить внимание на автоматически запускаемых элементах сторонних производителей, если такие элементы были добавлены в систему. Кроме того, можно просматривать объекты, настроенные на автоматический запуск для других учетных записей, имеющихся в системе.

    Для просмотра свойств исполняемого объекта, настроенного на автоматический запуск, необходимо выделить этот объект и воспользоваться пунктом меню или кнопкой панели инструментов Properties (Свойства). Если в системе запущена программа Process Explorer, а выделенный исполняемый файл используется каким-либо активным процессом, то при выборе в меню Entry (Элемент) пункта Process Explorer (Process Explorer) откроется диалоговое окно свойств процесса, использующего выделенный объект.

    Чтобы перейти к разделу реестра или каталогу файловой системы, который отображается в окне программы, либо к настройке объекта, запускаемого автоматически, достаточно выделить нужный элемент и воспользоваться командой меню или кнопкой панели инструментов Jump to (Перейти к).

    Чтобы отключить объект, запускаемый автоматически, нужно снять соответствующий ему флажок. Удалить такой объект можно с помощью команды меню или кнопки панели инструментов Delete (Удалить).

    Чтобы просмотреть автоматически запускаемые элементы для учетных записей других пользователей, достаточно выбрать нужный пункт меню User (Пользователь).

    23. Отслеживание приложений, создающих неизвестные файлы на диске.

    Если у Вас на диске постоянно какая-либо программа записывает непонятные файлы, то Вы можете определить создающее их приложение, воспользовавшись утилитой от Microsoft: Process Monitor.

    1) Запустите программу Process Monitor
    Так как программа отслеживает несколько типов системной активности (реестр, файловую систему, сеть и процессы), то Вам необходимо оставить только включенной активность файловой системы.
    2) Оставьте на Панели инструментов включенным значок Show File System Activity, и отключите значки Show Registry Activity, Show Network Activity и Show Process and Tread Activity, Show Profiling Events
    3) Примените фильтр, чтобы отсеять необходимые Вам значения. Для запуска фильтра нажмите сочетание клавиш CTRL+L.
    4) В первом ниспадающем списке выберите значение Path - обозначает путь к искомому файлу (имя файла также учитывается).
    5) Во втором ниспадающем списке выберите значение contains - условие, учитывая которое будет производится отсеивание, в данном случае обозначает «содержит» (перев. с англ.)
    Также Вы можете, выбрать вариант begins with (начинается с) или ends with (заканчивается на).
    6) В текстовом поле введите либо желаемое имя файла, либо имя папки, где создаются неизвестные файлы.
    7) В последнем ниспадающем списке выберите значение Include - указывает фильтру, что заданные условия должны быть включены в результаты отсеивания.
    8) Нажмите кнопку Add, чтобы добавить фильтр в список и ОК, чтобы применить фильтр.

    Если полученных результатов очень много, то Вы можете добавить дополнительные фильтры, либо указав какие действия надо отслеживать, либо исключив определенные процессы.
    Примеры дополнительных фильтров:

    Process Name – Is – Имя процесса – Exclude.
    Operation – Is – CreateFile – Include

    Интерфейс

    Интерфейс - Внешний вид.

    1. Изменение размера иконки на рабочем столе.

    1) Щелкните правой кнопкой мыши на рабочем столе.
    2) Откройте пункт Вид и выберите размер: Крупные значки; Обычные значки; Мелкие значки;
    или удерживая нажатой клавишу Сtrl прокрутите колесо мыши.

    2. Управление заготовками положений размеров окон.

    Чтобы легко управлять заготовками положений размеров окон (любых) просто кликните на активное окно и жмите:(win+влево,вниз,вправо,вверх).

    3. Где скачать и как установить дополнительные темы для Windows 7?

    Скачать дополнительные темы для Вашей Windows 7 Вы можете на официальной странице тем от Microsoft: Персонализация компьютера
    После скачивания понравившейся Вам темы, нажмите на скачавшийся themepack-файл и Windows автоматически его установит.
    Также дополнительные темы и обои для Windows находятся в скрытой папке - C:\Windows\Globalization\MCT.

    Вы можете разблокировать 5 дополнительных тем, поочередно запустив их.
    Для этого, запустите диалоговое окно "Выполнить" (Win + R) и наберите в нем:
    C:\Windows\Globalization\MCT\MCT-AU\Theme\AU.theme
    C:\Windows\Globalization\MCT\MCT-CA\Theme\CA.theme
    C:\Windows\Globalization\MCT\MCT-GB\Theme\GB.theme
    C:\Windows\Globalization\MCT\MCT-US\Theme\US.theme
    C:\Windows\Globalization\MCT\MCT-ZA\Theme\ZA.theme

    4. Изменение ширины меню Пуск.

    Открываете с помощью Restorator или PE Explorer файл C:\Windows\Resources\Themes\Aero\ru-RU\aero.msstyles.mui и изменяете значения в строковой таблице в строках с 113 по 121 включительно, делаете их такими же, как в C:\Windows\Resources\Themes\Aero\en-US\aero.msstyles.mui

    5. Добавление эффекта прозрачности окнам в Windows.

    Вариант 1.

    Включить прозрачный эффект можно при помощи небольшого скрипта: HideBlur Tool for Windows 7

    Инструкция:

    1. Распакуйте и запустите файл "Patch Blur x86.bat". Если у вас x64 битная версия, запустите файл "Patch Blur x64.bat".
    2. Это займет немного времени и вы увидите окно без эффекта матовости.
    3. Если захотите вернуть эффект матовости, запустите файл "Enable Blur.bat". А если снова захотите убрать матовость запустите файл "Disable Blur.bat".
    4. Если вы решите восстановить системные файлы запустите файл "Unpatch Blur.bat".
    Изменения становятся видимыми после перезагрузки.

    Сайт автора скрипта

    Вариант 2.

    1) Скачайте архив TrueTransparency.zip
    2) Распакуйте его и запустите файл TrueTransparency.exe
    3) На панели задач появится значок программы. Щелкните на нем правой кнопкой мыши.
    4) Выберите нужный язык в всплывающем меню Language(Языки), в меню Skins (Внешний вид) выберите одну из предложенных тем прозрачности.

    Также Вы можете воспользоваться решением предложенным в совете 16. Добавление функций окна Персонализация в Windows 7 Starter и Windows 7 Home Basic. из раздела Интерфейс - Внешний вид.

    6. Принудительное включение эффекта Aero Glass.

    Вариант 1.

    1) Нажмите Win+R и введите regedit
    2) Установите следующие значения в реестре:

    Готовый reg-файл enableaero.reg
    3) Перезапустите "Диспетчер сеансов диспетчера окон рабочего стола" из command prompt, запущенного с правами администратора:

    Вариант 2.

    1) Скачайте утилиту UxStyle
    2) Распакуйте скачанный архив и в зависимости от разрядности установите необходимую Вам версию.
    3) Смените оформление системы на классическую тему:
    В Windows 7 Starter и Windows 7 Home Basic: Меню "Пуск" -> Панель управления -> Экран -> Изменить цветовую схему
    В остальных версиях Windows 7: Правой кнопкой мыши на Рабочем столе -> Персонализация
    4) Откройте папку C:\windows\Resources\Themes\Aero\
    5) Задайте полный доступ к файлу aero.msstyle (можете воспользоваться советом: Администрирование: 1. Получение полного доступа к файлу или папке.)
    6) Переименуйте aero.msstyle в aero.bak
    7) Скачайте модифицированный файл aero.msstyle и поместите его вместо переименованного.
    8) Смените оформление на стандартную тему Windows 7.

    7. Улучшение качества передачи цветов монитором.

    Windows 7 предлагает новый мастер калибровки экрана (Display Colour Calibration Wizard), который поможет Вам должным образом установить настройки цвета, яркости и контраста, а ClearType tuner сделает текст резким и контрастным. Для вызова средства калибровки цветов монитора сделайте следующее:

    1) Нажмите кнопку Пуск
    2) В строке поиска введите dccw.exe и нажмите клавишу Enter.

    Вы можете запустить калибровку цветов и другим способом:

    1) Откройте Пуск -> Панель управления
    2) Перейдите по ссылкам Оформление и персонализация -> Экран
    3) В левой области выберите пункт Калибровка цветов.

    8. Включение Flip3D — отображение окон под углом.

    1. Щелкните правой кнопкой мыши по рабочему столу, выберите Создать и затем Ярлык.
    2. В поле "Укажите расположение объекта" введите следующее: RunDll32 DwmApi #105 и нажмите Далее.
    3. Наберите имя вашего будущего (например, Flip3D) ярлыка и нажмите Готово.

    Для переключения между окнами в режиме Flip3D, Вы можете использовать комбинацию клавиш Win+Tab.

    9. Расширение функциональности часов в трее или изменение их вида.

    Скачайте программу Stoic Joker's T-Clock x32/x64. Данная программа позволяет вам расширить функциональность часов в трее или изменить внешний вид часов в трее. Вы сможете добавить секунды к часам, изменить внешний вид часов, даты или добавить созданные вами значки для запуска конкретных приложений в трей.

    10. Добавление дополнительных операций к окнам.

    К сожалению, многие разработчики не столь тщательно занимаются интерфейсом своих программ. Часто бывает, что у довольно хорошей программами неудачный интерфейс. Отсутствуют какие-либо нужные вам кнопки. А бывает вам надо сравнить два окна или скопировать из одного в другое, а для этого необходимо поместить окно поверх других. Вот тут вам и поможет данная программа.

    Добавляет дополнительные функции для окон:
    • свернуть при запуске/деактивации, развернуть при запуске, закрыть при запуске, изменить положение/размер (например: в пикселях) при запуске
    • зафиксировать положение/размер (например: в пикселях), изменить приоритет выполнения при запуске/деактивации;
    • cвернуть в область уведомлений, поверх других окон, позади остальных, прозрачность, через дополнительные кнопки заголовка окна
    • и многие другие.
    Скачать программу

    11. Добавление командной строке эффекта прозрачности - Aero Glass.

    Для добавления командной строке эффекта прозрачности (Aero Glass) сделайте следующее:

    1) Скачайте архив: Glass_CMD.zip
    2) Распакуйте его и запустите исполняемый файл минискрипта Glass CMD.exe.
    3) Запустите командную строку(Win+R -> CMD ->Ok) и увидите эффект прозрачности (Aero Glass).
    Для использования данного эффекта скрипт Glass CMD.exe должен быть запущен. При закрытии Glass CMD.exe эффект прозрачности пропадет.
    При желании Вы можете добавить данный скрипт-программу в папку Автозагрузка в меню Пуск.
    Если Вы не хотите, чтобы в области уведомлений (трее) отображался значок скрипта, то в файле Settings.ini, который идет в архиве в комплекте с исполняемым файлом скрипта, установите значение параметра HideTrayIcon равным 1.

    12. Определение цветового кода любой точки экрана на мониторе.

    Для того чтобы узнать цветовой код любой точки экрана на Вашем мониторе скачайте и установите небольшую, но функциональную программу ColorPic.

    Данная программа абсолютно бесплатна и Вы можете скачать её с официального сайта: http://www.iconico.com/colorpic/index.aspx

    Мощные средства для регулировки цвета позволяют Вам с легкостью менять индивидуальные цвета. С помощью четырех графических миксеров Вы сможете регулировать RGB, оттенки, насыщенность и код цвета. У Вас будет возможность просматривать CMYK печатные коды цвета, а для идеальной точности использовать увеличитель экрана. Вы сможете сохранять множество цветовых палитр для их использования в любом приложении.

    Содержащийся в программе раздел "Mixer" предоставляет Вам четыре мощных графических способа для анализа и изменения выбранного цвета. Цвета могут быть выбраны из любых шестиугольных форм, измененных миксером или настроенных шестью индивидуальными слайдерами для оттенков, насыщенности, кода и красных, зеленых и голубых цветовых компонентов. ColorPic также делает отчеты для регулировки голубого, пурпурного, желтого и черного цветовых кодов.

    Кроме того, ColorPic также предлагает возможность увеличения, предоставляя Вам супер детальную картинку при выборе цвета. Программа имеет простой в использовании слайдер для увеличения, который позволяет Вам выбирать или разовую пробу или 3x3 или 5x5 средний цвет из любого места на Вашем экране.

    Будучи неоценимым средством для любого графического дизайнера или веб-разработчика и будучи постоянно самым популярным бесплатным цветоподборщиком в сети, самая последняя версия ColorPic предлагает мощные средства для выбора цвета, которые до сих пор доступны только в дорогих приложениях.

    Использовать программу очень просто:

    1) Запускаете программу
    2) Наводите курсор в то место, цвет которого желаете узнать.
    3) Нажимаете Ctrl+G и в первой ячейке сохраняется информация о цвете.
    4) Затем выделяете следующую ячейку и проделываете указанное выше для определения другого цвета.

    13. Создание темы оформления с использованием RSS-обоев.

    В интернете существует много программ позволяющих менять картинки на рабочем столе, автоматически скачивая их из интернета. Но Вам необязательно скачивать дополнительную программу, так как возможность обновления фона рабочего стола используя интернет имеется в самой Windows. Для этого Вам необходимо создать новую тему для Windows со ссылкой на RSS ленту, в качестве новостей транслирующую картинки.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).

    2) Замените {themename} на название темы (Например: RSS Wallpapers), а вместо {rssfeedurl} впишите адрес ленты, транслирующей картинки.

    Например:

    http://feeds.feedburner.com/bingimages
    http://api.flickr.com/services/feeds/photos_public.gne
    http://feeds.nationalgeographic.com/ng/News/News_Main
    http://mlewallpapers.com/4x3_rss.php

    3) Нажмите CTRL+S и сохраните файл с любым именем и расширением .theme. Например: RSS_Wallpappers.theme
    4) Щелкните два раза по получившемуся файлу.
    5) В окне Подписаться на RSS канал?(Subscribe to RSS Feed?) выберите пункт Загружать вложения (Download Attachments).

    Многие RSS ленты рекомендуют (хотя и необязательно) в Панель управления\Оформление и персонализация\Персонализация\Фоновый рисунок рабочего стола установить положение изображения По центру.

    Готовые 4 схемы Вы можете скачать по ссылке: rssthemes.zip

    14. Изменение фонового рисунка рабочего стола в Windows 7 Starter.

    Вариант 1. Вручную используя реестр Windows.

    1) Запустите Редактор реестра. Откройте меню Пуск, введите в строке поиска regedit и нажмите Enter (или Win+R -> regedit -> OK).
    2) Откройте ветку HKEY_CURRENT_USER\Control Panel\Desktop
    3) Щелкните правой кнопкой мыши на папке Desktop в древовидном списке слева, и нажмите пункт "Разрешения..."

    4.1) Если Вы первый раз изменяете фоновое изображение:

    4.1.1) Нажмите кнопку Дополнительно
    4.1.2) Перейдите на вкладку Владелец, выделите свое имя в окне Изменить владельца на: и нажмите кнопку Применить
    4.1.3) Перейдите на вкладку Разрешения и уберите флажок Добавить разрешения, наследуемые от родительских объектов. В случае запроса системой дальнейшего действия нажимаете кнопку Удалить.
    4.1.4) Нажмите поочередно кнопки Добавить... -> Дополнительно... -> Поиск
    4.1.5) В результатах поиска выберите Все и нажмите кнопку "OK", и еще раз "ОК".
    4.1.6) В окне Элемент разрешения для "Desktop" напротив значения Полный доступ установите флажок в столбце Разрешить и нажмите несколько раз кнопки ОК.

    4.2) Если Вы во второй раз изменяете фоновое изображение или если у Вас в "Группы и Пользователи" уже есть группа "Все" и Вы являетесь владельцем объекта:

    4.2.1) Выделите группу Все, нажав на нее.
    4.2.2) В части окна Разрешения для группы "Все" установите флажок Полный доступ в столбике Разрешить и нажимаете ОК.

    5) Найдите строковый параметр Wallpaper и дважды щелкните на нем.
    6) Введите путь к изображению, которое Вы хотите использовать как обои рабочего стола и нажмите ОК.
    7) По умолчанию, положение изображения устанавливается По центру, если Вам необходимо другое положение, то дополнительно измените:

    Параметр TileWallpaper на значение 1, чтобы Замостить изображение.
    Параметр WallpaperStyle на значение 2, чтобы Растянуть изображение.

    8) Щелкните правой кнопкой мыши на папке Desktop в древовидном списке слева, и нажмите пункт "Разрешения..."
    9) Выделите группу Все, нажав на нее.
    10) Уберите флажок в столбце Разрешить напротив значения Полный доступ и нажмите кнопку ОК.
    Если Вы не уберете данный флажок, то система установит стандартные обои рабочего стола.
    11) Перезайдите в систему или перезагрузите компьютер.

    Вариант 2. Автоматически используя специальную программу.

    1) Скачайте архив программы Starter Background Changer.zip
    2) Разархивируйте файл в любую папку и установите нужную Вам языковую версию программы.
    3) Нажмите правой кнопкой мыши на рабочем столе и выберите в контекстном меню пункт Персонализация (Personalize)
    4) Нажмите кнопку Обзор... (Browse...).
    5) Выберите необходимое Вам изображение и нажмите кнопку Открыть (Open).
    6) Выберите положение рисунка и нажмите Применить (Apply), чтобы установить рисунок не выходя из программы или ОК, чтобы установить рисунок и выйти их программы.
    7) Чтобы установить стандартное изображение выберите в ниспадающем меню Фоновый рисунок Windows по умолчанию и нажмите кнопку ОК.

    15. Изменение размера окон предпросмотра на панели задач.

    Если Вам необходимо изменить размер окон предпросмотра, расстояние между ними, размер бордюра и время задержки, то в этом Вам поможет программа Windows 7 Taskbar Thumbnail Customizer.

    1) Скачайте программу Windows 7 Taskbar Thumbnail Customizer

    2) Настройте параметры программы в соответствие с Вашими запросами.

    Maximum Size - максимальный размер окна предпросмотра
    Minimum Size - минимальный размер окна предпросмотра

    X Spacing - расстояние между окнами предпросмотра по-горизонтали
    Y Spacing - расстояние между окнами предпросмотра по-вертикали

    Top Margin - размер верхнего бордюра
    Bottom Margin - размер нижнего бордюра
    Left Margin - размер левого бордюра
    Right Margin - размер правого бордюра

    Delay Time - время задержки до появления окна предпросмотра

    16. Добавление функций окна Персонализация в Windows 7 Starter и Windows 7 Home Basic.

    1) Скачайте утилиту UxStyle
    2) Распакуйте скачанный архив и в зависимости от разрядности установите необходимую Вам версию.
    3) Смените оформление системы на классическую тему:
    В Windows 7 Starter и Windows 7 Home Basic: Меню "Пуск" -> Панель управления -> Экран -> Изменить цветовую схему
    В остальных версиях Windows 7: Правой кнопкой мыши на Рабочем столе -> Персонализация
    4) Откройте папку C:\windows\Resources\Themes\Aero\
    5) Задайте полный доступ к файлу aero.msstyle (можете воспользоваться советом: Администрирование: 1. Получение полного доступа к файлу или папке.)
    6) Переименуйте aero.msstyle в aero.bak
    7) Скачайте пропатченный файл aero.msstyle и поместите его вместо переименованного.
    8) Смените оформление на стандартную тему Windows 7.
    9) Скачайте и установите программу Personalization Panel (Для интеграции в меню рабочего стола выберите Обычная установка)
    10) В Windows 7 Home Basic нажмите правой кнопкой мыши на рабочем столе, выберите пункт Персонализация и нажмите на ссылку Цвет окна.
    11) В открывшемся окне нажмите на ссылку Показать или скрыть настройку цветов. и установите переключатель Windows 7 [Patched]
    12) Ползунком измените интенсивность цвета (степень прозрачности) и нажмите кнопку Сохранить изменения.

    В Windows 7 Starter панель позволяет менять обои только при запуске от имени администратора. Если у пользователя этих прав нет, или он нажал "Нет" в ответ на запрос UAC, функция смены обоев недоступна - программа функционирует в ОГРАНИЧЕННОМ режиме. Кроме того, если у пользователя есть права администратора, он меняет обои на нестандартные, а затем запускает программу в ОГРАНИЧЕННОМ режиме, смена экранной заставки может не работать, так как смена обоев меняет права на системный реестр, запрещая пользователю ниже, чем администратор, запись в него. Для корректной смены заставки в ОГРАНИЧЕННОМ режиме необходимо, чтобы стояли стандартные обои. В обычном режиме работы панели (от имени администратора) в Windows 7 Starter таких ограничений нет.

    1. Windows 7 [Patched]

    Используйте если у вас установлена пропатченная тема(Вы установили UxStyle и заменили aero.msstyle). Окна Windows 7 Home Basic будут использовать оформление Aero Glass и эффект прозрачности.

    2. Windows 7 стандратный

    Используйте если у вас установлена непропатченная тема. Не используйте с патченными темами - пропадет эффект прозрачности и окна будут заливаться черным цветом.

    Также Вы можете cкачать Пакет Personalization Panel для Windows 7 Starter и Home Basic с темами и автопатчем.
    Данный пакет автоматически выполнит следующие действия:

    • Автоматически установит патченные версии файлов для поддержки сторонних тем.
    • Автоматически установит тему Windows 7 c Aero для систем Windows 7 Домашняя базовая. Это обычная системная тема, только в ней разлочена прозрачность.
    • Установит набор из 12 базовых тем для систем Windows 7 Домашняя базовая и Windows 7 Начальная.
    • В системах Windows 7 Домашняя базовая установит 10 тем Aero.
    Внимание! Перед установкой пакета надо удалить программу UxStyle. Если вы этого не сделаете, пакет не установится.

    17. Замена фона папки в проводнике.

    Проще всего для замены фона в папке использовать следующие программы:

    Windows 7 Folder Background Changer

    1) Запустите программу Windows 7 Folder Background Changer
    2) Нажмите кнопку Browse и выберите фоновое изображение
    3) Нажмите Change Background Image, чтобы установить фоновое изображение или кнопку Remove Background Image, чтобы убрать фоновое изображение.
    4) Для изменения фонового изображения во вложенных папках, установите флажок Apply To Sub Folders.

    AveFolderBG: для 32-бит; для 64-бит - данная программа добавляет дополнительную вкладку в свойства каждой папки.

    1) Установите программу используя файл install.bat
    2) Перезапустите Windows или перезайдите в систему.
    3) Щелкните правой кнопкой мыши и выберите Свойства
    4) Перейдите на вкладку Folder Background
    5) Нажмите кнопку Set Image, выбираете изображение и нажимаете Открыть. Для удаления изображения используйте кнопку Remove Image.
    6) Для изменения фонового изображения во вложенных папках, установите флажок Apply to subfolders also.
    7) Нажмите кнопку Применить или ОК.

    18. Сохранение созданной Вами схемы указателей мыши в файл, для дальнейшего использования.

    Созданные Вами схемы для указателей мыши прописываются в реестре.
    Если Вы желаете сохранить созданную Вами тему для дальнейшего применения после переустановки, то сделайте следующее:

    1) Откройте Пуск -> Панель управления -> Мышь
    2) Перейдите на вкладку Указатели
    3) В окне Настройка измените необходимые Вам курсоры.
    4) Нажмите кнопку Сохранить как, введите название сохраняемой темы и нажмите ОК.
    5) В окне Свойства:Мышь снова нажмите ОК.
    6) Запустите редактор реестра (Win+R -> regedit -> ОК)
    7) Откройте раздел HKEY_CURRENT_USER\Control Panel\Cursors\Schemes
    8) Экспортируйте данный раздел в reg-файл.
    8.1) В главном меню выберите Файл -> экспорт
    9) Задайте имя файла и нажмите кнопку Сохранить.

    Система создаст reg-файл, который Вы сможете использовать в дальнейшем. Например, после переустановки Windows.
    Если при создании схемы для указателей Вы использовали файлы отсутствующие в системе, то после переустановки Windows, перед применением reg-файла скопируйте их в те же месторасположения.

    19. Добавление отображения эскизов и детальной информации для файлов .mkv в проводнике Windows.

    Скачайте и установите DivX Plus Tech Preview.

    Данная программа добавляет поддержку MKV-файлов в проводник Windows, так что Вы сможете просматривать их эскизы в Windows Explorer. Также Вам станут доступны детальные сведения о файле.

    Положительной особенностью является тот факт, что DivX Plus Tech Preview работает с любыми пакетами кодеков (K-Lite или Shark).

    Интерфейс - Взаимодействие.

    1. Открытие диспетчера задач, одной комбинацией клавиш, а не ctrl+alt+del и клик по пункту.

    Вариант 1

    Нажмите комбинацию клавиш Ctrl+Shift+Esc.

    Вариант 2

    Щелкните правой кнопкой на панели задач и выберите пункт Запустить диспетчер задач (Start Task Manager).

    2. Использование средней кнопки мыши при работе с панелью задач.

    Если щелкнуть средней кнопкой мышки на приложении в панели задач, откроется новое окно приложения. А если же средней кнопкой щелкнуть на окошке превью, которое всплывает над иконой программы, то это закроет данную программу или окно.

    3. Перезапуск Проводника или рабочего стола.

    Вариант 1. Только клавиатура.

    1) Нажмите комбинацию клавиш Ctrl+Esc
    2) Нажмите стрелку вправо (→)
    3) Нажмите комбинацию клавиш Ctrl+Shift+F10 или Ctrl+Shift+Menu
    4) Нажатием стрелочки вниз перейдите на пункт Выход из проводника (Exit Explorer) и нажмите Enter.
    5) Нажмите последовательно: Alt, затем стрелку вниз (↓) и нажмите Enter.
    6) Введите команду explorer и нажмите клавишу Enter.

    Вариант 2. Частичное использование Диспетчера задач.

    1) Откройте меню Пуск
    2) Удерживая нажатым комбинацию клавиш Ctrl+Shift, щелкните правой кнопкой мыши кнопку Завершение работы (Shut Down).
    3) В контекстном меню выберите пункт Выход из проводника (Exit Explorer).
    4) Нажмите комбинацию клавиш Ctrl+Shift+Esc
    5) Нажмите Файл -> Новая задача (Выполнить...) или в английской версии File -> New Task (Run...)
    6) Введите команду explorer и нажмите кнопку ОК

    Вариант 3. Полное использование Диспетчера задач.

    1) Откройте Диспетчер задач (Task Manager)
    1.1) Щелкните правой кнопкой мыши пустую область на панели задач и выберите команду Запустить диспетчер задач или нажмите сочетание клавиш Ctrl+Shift+Esc
    2) Перейдите на вкладку Процессы (Processes)
    3) Щелкните правой кнопкой мыши на процесс explorer.exe и выберите пункт Завершить процесс (End Process). Если у Вас несколько процессов с таким названием, то повторите данное действие для каждого процесса explorer.exe.
    4) Нажмите Файл -> Новая задача (Выполнить...) или в английской версии File -> New Task (Run...)
    5) Введите команду explorer и нажмите кнопку ОК
    5) Введите команду explorer и нажмите кнопку ОК

    4. Запуск команд Windows Shell, используя названия и {GUID} объектов.

    Microsoft Windows Shell - интерпретатор команд операционной системы (ОС), обеспечивающий интерфейс для взаимодействия пользователя с функциями системы. Позволяет получить доступ к диалоговым окнам, к файловой системе, запускать программы и изменять системные настройки.
    Для быстрого перехода к компонентам Windows используется команда shell.
    GUID (Globally Unique Identifier) — статистически уникальный 128-битный идентификатор. Использование GUID гарантирует, что две версии одного компонента могут иметь одно и то же имя, но быть отличимыми по GUID. Microsoft применяет GUID в качестве идентификаторов для большого количества своих объектов. Зная GUID Вы сможете открыть многие компоненты Windows: элементы Панели управления, системные папки, различные программы и настройки.

    Для запуска любого из объектов Windows, используя {GUID}, применяется команда:

    где {GUID} - идентификатор {GUID} нужного Вам объекта. Например, для запуска Панели управления наберите команду:

    Вы можете поискать нужные Вам {GUID} в разделе реестра HKEY_CLASSES_ROOT\CLSID или воспользоваться таблицей №1.

    Таблица №1.

    Русское название элемента | Английское название элемента | Команда
Flip 3D (Win+Tab) | Flip 3D (Win+Tab) | Shell:::{3080F90E-D7AD-11D9-BD98-0000947B0257}
Fusion Cache | Fusion Cache | Shell:::{1D2680C9-0E2A-469d-B787-065558BC7D43}
Internet Explorer | Internet Explorer | Shell:::{871C5380-42A0-1069-A2EA-08002B30309D}
Microsoft Outlook | Microsoft Outlook | Shell:::{2559a1f5-21d7-11d4-bdaf-00c04f60b9f0}
Windows CardSpace | Windows CardSpace | Shell:::{78CB147A-98EA-4AA6-B0DF-C8681F69341C}
Windows SideShow | Windows SideShow | Shell:::{E95A4861-D57A-4be1-AD0F-35267E261739}
Автозапуск | AutoPlay | Shell:::{9C60DE1E-E5FC-40f4-A487-460851A8D915}
Автономные файлы | Offline Files | Shell:::{D24F75AA-4F2B-4D07-A3C4-469B3D9030C4}
Администрирование | Administrative Tools | Shell:::{D20EA4E1-3957-11d2-A40B-0C5020524153}
Архивация и восстановление | Backup and Restore | Shell:::{B98A2BEA-7D42-4558-8BD1-832F41BAC6FD}
Библиотеки | Libraries | Shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Биометрические устройства | Biometric Devices | Shell:::{0142e4d0-fb7a-11dc-ba4a-000ffe7ab428}
Брандмауэр Windows | Windows Firewall | Shell:::{4026492F-2F69-46B8-B9BF-5654FC07E423}
Восстановление | Recovery | Shell:::{9FE63AFD-59CF-4419-9775-ABCC3849F861}
Восстановление системы | System Restore | Shell:::{3f6bc534-dfa1-4ab4-ae54-ef25a74e0107}
Все задачи | All Tasks | Shell:::{ED7BA470-8E54-465E-825C-99712043E01C}
Все элементы панели управления | All Control Panel Items | Shell:::{21EC2020-3AEA-1069-A2DD-08002B30309D}
Выполнить | Run | Shell:::{2559a1f3-21d7-11d4-bdaf-00c04f60b9f0}
Гаджеты рабочего стола | Desktop Gadgets | Shell:::{37efd44d-ef8d-41b1-940d-96973a50e9e0}
Дата и Время | Date and Time | Shell:::{E2E7934B-DCE5-43C4-9576-7FE4F75E7480}
Датчик расположения и другие датчики | Location and Other Sensors | Shell:::{E9950154-C418-419e-A90A-20C5287AE24B}
Диспетчер устройств | Device Manager | Shell:::{74246bfc-4c96-11d0-abef-0020af6b0b7a}
Диспетчер учетных данных | Credential Manager | Shell:::{1206F5F1-0569-412C-8FEC-3204630DFB70}
Домашняя группа | HomeGroup | Shell:::{67CA7650-96E6-4FDD-BB43-A8E774F73A57}
Домашняя группа - папка | HomeGroup folder | Shell:::{6785BFAC-9D2D-4be5-B7E2-59937E8FB80A}
Защитник Windows | Windows Defender | Shell:::{D8559EB9-20C0-410E-BEDA-7ED416AECC2A}
Звук | Sound | Shell:::{F2DDFC82-8F12-4CDD-B7DC-D4FE1425AA4D}
Значки области уведомлений | Notification Area Icons | Shell:::{05d7b0f4-2121-4eff-bf6b-ed3f69b894d9}
Игровые устройства | Game Controllers | Shell:::{259EF4B1-E6C9-4176-B574-481532C9BCE8}
Игры | Games | Shell:::{ED228FDF-9EA8-4870-83b1-96b02CFE0D52}
Избранное | Favorites | Shell:::{323CA680-C24D-4099-B94D-446DD2D7249E}
Инфракрасная связь | Infrared | Shell:::{A0275511-0E86-4ECA-97C2-ECD8F1221D08}
Карта сети | Network Map | Shell:::{E7DE9B1A-7533-4556-9484-B26FB486475E}
Компоненты Windows | Windows Features | Shell:::{67718415-c450-4f3c-bf8a-b487642dc39b}
Компьютер | Computer | Shell:::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина | Recycle Bin | Shell:::{645FF040-5081-101B-9F08-00AA002F954E}
Мои Документы | My Documents | Shell:::{450D8FBA-AD25-11D0-98A8-0800361B1103}
Настройка доступа программ и умолчаний | Set Program access and Windows defaults | Shell:::{2559a1f7-21d7-11d4-bdaf-00c04f60b9f0}
Недавние места | Recent Places | Shell:::{22877a6d-37a1-461a-91b0-dbda5aaebc99}
Общие | Public | Shell:::{4336a54d-038b-4685-ab02-99bb52d3fb8b}
Панель управления (заданного Вами вида) | Control Panel | Shell:::{5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}
Панель управления (Категория) | Control Panel (Category) | Shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}
Параметры индексирования | Indexing Options | Shell:::{87D66A43-7B11-4A28-9811-C86EE395ACF7}
Параметры папок | Folder Options | Shell:::{6DFD7C5C-2451-11d3-A299-00C04F8EF6AF}
Параметры планшетного компьютера | Tablet PC Settings | Shell:::{80F3F1D5-FECA-45F3-BC32-752C152E456E}
Параметры шрифта | Font settings | Shell:::{93412589-74D4-4E4E-AD0E-E0CB621440FD}
Переносные устройства | Portable Devices | Shell:::{35786D3C-B075-49b9-88DD-029876E11C01}
Перо и сенсорные устройства | Pen and Touch | Shell:::{F82DF8F7-8B9F-442E-A48C-818EA735FF9B}
Персонализация | Personalization | Shell:::{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection | Shell:::{241D7C96-F8BF-4F85-B01F-E2B043341A4B}
Поиск Windows | Search | Shell:::{2559a1f0-21d7-11d4-bdaf-00c04f60b9f0}
Получение программ | Get Programs | Shell:::{15eae92e-f17a-4431-9f28-805e482dafd4}
Принтеры | Printers | Shell:::{2227A280-3AEA-1069-A2DE-08002B30309D}
Приступая к работе | Getting Started | Shell:::{CB1B7F8C-C50A-4176-B604-9E24DEE8D4D1}
Программы и компоненты | Programms and Features | Shell:::{7b81be6a-ce2b-4676-a29e-eb907a5126c5}
Программы по умолчанию | Default Programs | Shell:::{17cd9488-1228-4b2f-88ce-4298e93e0966}
Рабочий стол | Desktop | Shell:::{3080F90D-D7AD-11D9-BD98-0000947B0257}
Распознавание речи | Speech Recognition | Shell:::{58E3C745-D971-4081-9034-86E34B30836A}
Расположение по умолчанию | Default Location | Shell:::{00C6D95F-329C-409a-81D7-C46C66EA7F33}
Родительский контроль | Parental Controls | Shell:::{96AE8D84-A250-4520-95A5-A47A7E3C548B}
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | Shell:::{0DF44EAA-FF21-4412-828E-260A8728E7F1}
Свойства речи | Text to Speech | Shell:::{D17D1D6D-CC3F-4815-8FE3-607E7D5D10B3}
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | Shell:::{A304259D-52B8-4526-8B1A-A1D6CECC8243}
Свойства: Интернет | Internet Properties | Shell:::{A3DD4F92-658A-410F-84FD-6FBBBEF2FFFE}
Свойства: Клавиатура | Keyboard Properties | Shell:::{725BE8F7-668E-4C7B-8F90-46BDB0936430}
Свойства: Мышь | Mouse Properties | Shell:::{6C8EEC18-8D75-41B2-A177-8831D59D2D50}
Сетевые подключения | Network Connections | Shell:::{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сетевые подключения в Области уведомления | Network Connections in Notification area | Shell:::{38A98528-6CBF-4CA9-8DC0-B1E1D10F7B1B}
Сеть | Network | Shell:::{208D2C60-3AEA-1069-A2D7-08002B30309D}
Система | System | Shell:::{BB06C0E4-D293-4f75-8A90-CB05B6477EEE}
Сканеры и камеры | Scanners and Cameras | Shell:::{00f2886f-cd64-4fc9-8ec5-30ef6cdbe8c3}
Соседние пользователи | People Near Me | Shell:::{5224F545-A443-4859-BA23-7B5A95BDC8EF}
Справка и Поддержка | Windows Help and Support | Shell:::{2559a1f1-21d7-11d4-bdaf-00c04f60b9f0}
Счетчики и средства производительности | Performance Information and Tools | Shell:::{78F3955E-3B90-4184-BD14-5397C15F1EFC}
Телефон и модем | Phone and Modem | Shell:::{40419485-C444-4567-851A-2DD7BFA1684D}
Управление беспроводными сетями | Manage Wireless networks | Shell:::{1FA9085F-25A2-489B-85D4-86326EEDCD87}
Управление цветом | Color Management | Shell:::{B2C761C6-29BC-4f19-9251-E6195265BAF1}
Установленные обновления | Installed Updates | Shell:::{d450a8a1-9568-45c7-9c0e-b4f9fb4537bd}
Устранение неполадок | Troubleshooting | Shell:::{C58C4893-3BE0-4B45-ABB5-A63E4B8C8651}
Устройства Bluetooth | Bluetooth Devices | Shell:::{28803F59-3A75-4058-995F-4EE5503B023C}
Устройства и принтеры | Devices and Printers | Shell:::{A8A91A66-3A7D-4424-8D24-04E180695C7A}
Учетные записи пользователей | User Accounts | Shell:::{60632754-c523-4b62-b45c-4172da012619}
Центр мобильности Windows | Windows Mobility Center | Shell:::{5ea4f148-308c-46d7-98a9-49041b1dd468}
Центр обновления Windows | Windows Update | Shell:::{36eef7db-88ad-4e81-ad49-0e313f0c35f8}
Центр поддержки | Action Center | Shell:::{BB64F8A7-BEE7-4E1A-AB8D-7D8273F7FDB6}
Центр синхронизации | Sync Center | Shell:::{9C73F5E5-7AE7-4E32-A8E8-8D23B85255BF}
Центр специальных возможностей | Ease of Access Center | Shell:::{D555645E-D4F8-4c29-A827-D93C859C4F2A}
Центр управления сетями и общим доступом | Network and Sharing Center | Shell:::{8E908FC9-BECC-40f6-915B-F4CA0E70D03D}
Шифрование диска BitLocker | BitLocker Drive Encryption | Shell:::{D9EF8727-CAC2-4e60-809E-86F80A666C91}
Экран (размер текста) | Display (size of text) | Shell:::{C555438B-3C23-4769-A71F-B6D3D9B6053A}
Электропитание | Power Options | Shell:::{025A5937-A6BE-4686-A844-36FE4BEC8B6D}
Язык и региональные стандарты | Region and Language | Shell:::{62D8ED13-C9D0-4CE8-A914-47DD628FB1B0}

    Для некоторых системных папок, Вы можете создать их копии, в любом, необходимом для Вас месте. Такие папки не будут занимать место на диске, а будут служить символическими ссылками на оригинальные. Для создания такой папки-ссылки:

    1) Создайте в любом нужном Вам месте новую папку (Щелчок ПКМ -> Создать -> Папку)
    2) Переименуйте её следующим образом:

    Все задачи - All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}
    Администрирование - Administrative Tools.{D20EA4E1-3957-11d2-A40B-0C5020524153}
    Библиотеки - Libraries.{031E4825-7B94-4dc3-B131-E946B44C8DD5}
    Компьютер - Computer.{20D04FE0-3AEA-1069-A2D8-08002B30309D}
    Корзина - Recycle Bin.{645FF040-5081-101B-9F08-00AA002F954E}
    Персонализация - Personalize.{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
    Принтеры - Printers and Faxes.{2227A280-3AEA-1069-A2DE-08002B30309D}
    Программы - Programs Folder.{7BE9D83C-A729-4D97-B5A7-1B7313C39E0A}
    Сетевые подключения - Network Connections.{7007ACC7-3202-11D1-AAD2-00805FC1270E}
    Сеть (WORKGROUP) - Network Places.{208D2C60-3AEA-1069-A2D7-08002B30309D}
    Учетные записи пользователей - User Accounts.{60632754-c523-4b62-b45c-4172da012619}

    Принцип запуска команд Shell, используя имя объектов, намного легче. Данный способ не требует от Вас знания большого количества цифр и букв, и позволяет снизить величину ошибок при наборе команды. Его основное применение - открытие системных папок.

    Например, для быстрого перехода в папку Панели Быстрого Запуска, которая присутствует в Windows, но не добавлена на Панель Задач, достаточно написать команду shell:Quick Launch. При выполнении команды будет в проводнике будет открыта папка: C:\Users\%UserName%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

    Для запуска любого из объектов Windows, используя его имя, применяется команда:

    Вы можете найти нужные Вам имена объектов в разделах ветки реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\FolderDescriptions или воспользоваться таблицей №2.

    Таблица №2.

    Имя программы или папки | Адрес папки | Команда
32-разрядный Internet Explorer | C:\Program Files\Internet Explorer или C:\Program Files (x86)\Internet Explorer | shell:InternetFolder
Common Files (в 32-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommon
Common Files (в 64-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommonX64
Common Files (в 64-битной Windows 7) | C:\Program Files (x86)\Common Files | shell:ProgramFilesCommonX86
Cookies | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies | shell:Cookies
Credentials | C:\Users\User-Name\AppData\Roaming\Microsoft\Credentials | shell:CredentialManager
Crypto | C:\Users\User-Name\AppData\Roaming\Microsoft\Crypto | shell:CryptoKeys
DeviceMetadataStore | C:\ProgramData\Microsoft\Windows\DeviceMetadataStore | shell:Device Metadata Store
Documents | C:\Users\Public\Documents | shell:Common Documents
Fonts (шрифты) | C:\Windows\Fonts | shell:Fonts
Gadgets | C:\Program Files\Windows Sidebar\Gadgets | shell:default Gadgets
Gadgets | C:\Users\User-Name\AppData\Local\Microsoft\WindowsSidebar\Gadgets | shell:Gadgets
GameExplorer | C:\ProgramData\Microsoft\Windows\GameExplorer | shell:PublicGameTasks
GameExplorer (Обозреватель игр) | C:\Users\User-Name\AppData\Local\Microsoft\Windows\GameExplorer | shell:GameTasks
History | C:\Users\User-Name\AppData\Local\Microsoft\Windows\History | shell:History
ImplicitAppShortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\ImplicitAppShortcuts | shell:ImplicitAppShortcuts
Local | C:\Users\User-Name\AppData\Local | shell:Local AppData
LocalLow | C:\Users\User-Name\AppData\LocalLow | shell:LocalAppDataLow
Low | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies\Low | shell:Cookies\Low
Network Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\NetworkShortcuts | shell:NetHood
Printer Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\PrinterShortcuts | shell:PrintHood
Program Files | C:\Program Files | shell:ProgramFiles
Program Files (x86) (в 64-битной Windows 7) | C:\Program Files (x86) | shell:ProgramFilesX86
Program Files (в 64-битной Windows 7) | C:\Program Files | shell:ProgramFilesX64
ProgramData | C:\ProgramData | shell:Common AppData
Protect | C:\Users\User-Name\AppData\Roaming\Microsoft\Protect | shell:dpapiKeys
Quick Launch (Быстрый запуск) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch | shell:Quick Launch
Resources (содержит темы Windows) | C:\Windows\Resources | shell:ResourceDir
Ringtones | C:\ProgramData\Microsoft\Windows\Ringtones | shell:CommonRingtones
Roaming | C:\Users\User-Name\AppData\Roaming | shell:AppData
SendTo (элементы контекстного меню Отправить) | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\SendTo | shell:SendTo
System32 | C:\Windows\System32 | shell:System
SystemCertificates | C:\Users\User-Name\AppData\Roaming\Microsoft\SystemCertificates | shell:SystemCertificates
SysWOW64 | C:\Windows\SysWOW64 | shell:SystemX86
Templates | C:\ProgramData\Microsoft\Windows\Templates | shell:Common Templates
Templates | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Templates | shell:Templates
Temporary Internet Files | C:\Users\User-Name\AppData\Local\Microsoft\Windows\TemporaryInternet Files | shell:Cache
User Pinned (Закрепленные элементы) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch\User Pinned | shell:User Pinned
User-Name (файлы Вашей учетной записи) | C:\Users\User-Name | shell:UsersFilesFolder
User-Name (Ваш учетный профиль) | C:\Users\User-Name | shell:Profile
Windows (главная папка системы) | C:\Windows | shell:Windows
Автозагрузка | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup | shell:Common Startup
Автозагрузка | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup | shell:Startup
Администрирование | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Administrative Tools
Администрирование | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Common Administrative Tools
Библиотеки | Библиотеки | shell:Libraries
Библиотеки | Библиотеки | shell:UsersLibrariesFolder
Видео | Библиотеки\Видео | shell:VideosLibrary
Временная папка для записи | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Burn\Burn | shell:CD Burning
Все элементы панели управления | Панель управления\Все элементы панели управления | shell:ControlPanelFolder
Главное меню | C:\ProgramData\Microsoft\Windows\Start Menu | shell:Common Start Menu
Главное меню | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu | shell:Start Menu
Документы | Библиотеки\Документы | shell:DocumentsLibrary
Домашняя группа | Домашняя группа | shell:HomeGroupFolder
Загрузки | C:\Users\User-Name\Downloads | shell:downloads
Згрузки | C:\Users\Public\Downloads | shell:CommonDownloads
Игры | Игры | shell:Games
Избранное | C:\Users\User-Name\Favorites | shell:Favorites
Изображения | C:\Users\Public\Pictures | shell:CommonPictures
Изображения | C:\Users\User-Name\Pictures | shell:My Pictures
Изображения | Библиотеки\Изображения | shell:PicturesLibrary
Компьютер | Компьютер | shell:MyComputerFolder
Контакты | C:\Users\User-Name\Contacts | shell:Contacts
Конфликты | Панель управления\Все элементы панели управления\Центрсинхронизации\Конфликты | shell:ConflictFolder
Корзина | Корзина | shell:RecycleBinFolder
Мои видеозаписи | C:\Users\User-Name\Videos | shell:CommonVideo
Мои видеозаписи | C:\Users\User-Name\Videos | shell:My Video
Мои документы | C:\Users\User-Name\Documents | shell:Personal
Моя Музыка | C:\Users\Public\Music | shell:CommonMusic
Моя музыка | C:\Users\User-Name\Music | shell:My Music
Музыка | Библиотеки\Музыка | shell:MusicLibrary
Настройка синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Настройка синхронизации | shell:SyncSetupFolder
Недавние документы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Recent | shell:Recent
Образцы видео | C:\Users\Public\Videos\Sample Videos | shell:SampleVideos
Образцы изображений | C:\Users\Public\Pictures\Sample Pictures | shell:SamplePictures
Образцы музыки | C:\Users\Public\Music\Sample Music | shell:SampleMusic
Общие | C:\Users\Public | shell:Public
Папка с рингтонами Windows 7 | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Ringtones | shell:Ringtones
Поиск Windows | search-ms: | shell:SearchHomeFolder
Поиски (информация о поисках) | C:\Users\User-Name\Searches | shell:Searches
Получение программ | Панель управления\Все элементы панели управления\Получение программ | shell:AddNewProgramsFolder
Пользователи | C:\Users | shell:UserProfiles
Принтеры | Все элементы панели управления\Принтеры | shell:PrintersFolder
Программы | C:\ProgramData\Microsoft\Windows\Start Menu\Programs | shell:Common Programs
Программы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu\Programs | shell:Programs
Программы и компоненты | Панель управления\Все элементы панели управления\Программы и компоненты | shell:ChangeRemoveProgramsFolder
Рабочий стол | C:\Users\Public\Desktop | shell:Common Desktop
Рабочий стол | C:\Users\User-Name\Desktop | shell:desktop
Результаты синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Результаты синхронизации | shell:SyncResultsFolder
Сетевые подключения | Панель управления\Все элементы панели управления\Сетевые подключения | shell:ConnectionsFolder
Сеть | Сеть | shell:NetworkPlacesFolder
Сохраненные игры | C:\Users\User-Name\Saved Games | shell:SavedGames
Ссылки | C:\Users\User-Name\Links | shell:Links
Установленные обновления | Программы и компоненты\Установленные обновления | shell:AppUpdatesFolder
Центр синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации | shell:SyncCenterFolder

    Для упрощения работы с командами Windows Shell Вы можете скачать небольшую бесплатную программу Shell Dump.
    Данная программа проанализирует Ваш реестр и отобразит список команд, которые Вы можете использовать. Вам всего лишь достаточно выбрать команду и нажать кнопку Run для ее запуска.

    5. Включение и отключение Области переходов.

    Область переходов – это специальная панель (дерево папок), которая находится слева в каждой папке.
    Она выполняет функцию командной оболочки, обеспечивая быстрый доступ к папкам, которые содержат нужные файлы. Быстрое выполнение различных операций – таких, как копирование, удаление, архивирование файлов и папок, открытие сохраненного запроса поиска.
    При большом числе файлов на экране, иногда необходимо отключить "Область переходов", для увеличения одновременно отображаемых файлов.

    Включить или отключить Область переходов можно так:

    1) Нажмите вверху слева Упорядочить->Представление
    2) Поставьте или уберите галочку в пункте Область переходов

    6. Использование переменных окружения для быстрого перехода к системным папкам.

    Чтобы узнать какие из них присутствуют в Вашей системе запустите cmd.exe и в нем команду set. Получите полный список переменных окружения Вашей Windows.

    %AllUsersProfile% - C:\ProgramData
    %AppData% - C:\Users\%UserName%\AppData\Roaming
    %CommonFavorites% - C:\Documents and Settings\All Users\Избранное
    %CommonFiles% - C:\Program Files\Common Files
    %CommonProgramFiles% - C:\Program Files\Common Files
    %CommonProgramFiles(x86)% - C:\Program Files (x86)\Common Files
    %ComSpec% - Запустит cmd.exe из папки, в которой будет употреблен
    %HomePath% - C:\Users\Administrator
    %LOCALAPPDATA% - C:\Users\%UserName%\AppData\Local
    %ProgramData% - C:\ProgramData
    %ProgramFiles% - C:\Program Files
    %ProgramFiles(x86)% - C:\Program Files (x86)
    %PSModulePath% - C:\Windows\System32\WindowsPowerShell\v1.0\Modules
    %SystemDir% - C:\Windows\System32
    %SystemDrive% - C:\
    %SystemRoot% - C:\Windows
    %Temp% - C:\Documents and Settings\%UserName%\Local Settings\Temp; C:\Users\%UserName%\AppData\Local\Temp
    %Tmp% - C:\Users\%UserName%\AppData\Local\Temp
    %UserProfile% - C:\Users\%UserName%
    %windir% - C:\Windows

    Если Вы решите создать собственную переменную типа:
    %MyFolder%=C:\MyFolder

    1) Пройдите:
    Компьютер -> Свойства -> Дополнительные параметры системы ->Дополнительно -> Переменные среды
    2) Нажмите Создать...
    3) Укажите Имя переменной и Значение переменной
    4) Нажмите на каждое Ок
    5) Перезагрузите компьютер (иначе она не будет работать)

    7. Использование флажков для выделения (выбора) файлов и папок.

    В Windows есть удобная возможность помечать для выделения файлы и папки с использованием флажков (чекбоксов). Это удобнее чем выделять объекты удерживая Ctrl, но эта функция отключена по умолчанию. Для ее включения проделайте следующее:
    Откройте Проводник и нажмите один раз клавишу Alt - таким образом мы инициализируем отображение стандартного меню вверху окна проводника, которое скрыто по умолчанию.
    Запустите Пуск\Панель Управления\Параметры Папок и перейдите на вкладку Вид
    Отметьте параметр "Использовать флажки для выбора элементов" и нажмите ОК
    Теперь слева возле каждого файла и папки появилась возможность отметить их поставив флажок, а в заголовках колонок сортировки можно поставить флажок для выделения всех объектов открытой папки.

    8. Объединение нескольких различных приложений(папок или иконок) в один значок на Панели задач.

    Одним из самых явных изменений в Windows 7 является новая панель задач, в которой вместо кнопок отображаются иконки, и все окна приложения объединяются под одну кнопку. Со временем, когда на компьютере установлено много программ, на панели задач начинает не хватать места для кнопок. Исправить это можно с помощью бесплатной программы 7Stacks.

    Она создает подменю для кнопок, позволяя отсортировать программы по разделам – игры, программы для интернета, и т.д.

    Порядок действий:

    1) Создайте папку
    2) Сложите в нее ярлыки приложений, необходимых Вам в создаваемом меню.
    3) Запустите 7Stacks
    4) Выберите созданную Вами папку
    5) Настройте оформление и создайте ярлык на рабочем столе.
    6) Перетащите данный ярлык в панель задач.

    9. Сворачивание всех неактивных окон, кроме текущего активного, используя Aero Shake.

    В интерфейс Windows Aero добавлена новая функция Aero Shake, позволяющая свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти» влево-вправо.

    10. Закрытие всех запущенных приложений одним кликом.

    Утилита под названием Close All Windows позволяет закрыть все работающие приложения с помощью всего одного клика. Она не требует установки и не использует ресурсов, так как посылает только команду "Закрыть" всем действующим приложениям.

    1) Скачиваете с официального сайта программу CloseAll
    2) Распаковывайте архив в удобное Вам место для использования.
    3) Перемещаете файл CloseAll.exe на панель задач, если у вас 64-битная система то файл CloseAll.exe берете из папки x64.

    Для удобства использования программы Вы можете назначить ей клавишу быстрого вызова и добавить исключения для программ, которые закрываться не будут:

    1) Щелкаете правой кнопкой мыши на иконке в панели задач
    2) Щелкаете правой кнопкой мыши на "Close All Windows" и нажимаете Свойства
    3) В поле Быстрый вызов нажмите нужное сочетание клавиш, для сопоставления выбранной комбинации с программой.
    4) В поле Объект добавьте -x="программа.exe"
    Вы можете добавить несколько программ разделив их "|", например:

    5) Нажмите Ок для сохранения настроек.

    11. Открытие командной строки из конкретной папки.

    1)Нажмите на клавиатуре клавишу Shift.
    2) Удерживая ее нажатой, щелкните правой кнопкой мыши на папке из которой Вы желаете открыть командную строку.
    3) В контекстном меню нажмите пункт Открыть окно команд (“Open Command Window Here”).

    12. Закрепление конкретной папки на панели задач Windows 7.

    Если Вы перетащите папку на панель задач, то она закрепится во всплывающем списке (подменю) Проводника. Чтобы закрепить отдельно папку на панели задач сделайте следующее:

    1) Щелкните правой кнопкой мыши на рабочем столе и выберите Создать -> Ярлык.
    2) В поле Расположение объекта введите:

    (вместо C:\MyFolder введите фактический адрес прикрепляемой папки).
    3) В поле Имя ярлыка введите название папки (в нашем случае это MyFolder) и нажмите Готово.
    4) Щелкните правой кнопкой по созданному ярлыку и в появившемся контекстном меню выберите пункт Закрепить на панели задач.

    Примечание. Каждая закрепленная папка будет открываться в отдельном процессе.

    13. Настройка списка элементов, отображаемых в диалоговом окне открытия и сохранения файлов Windows.

    1) Щелкните на кнопке Пуск
    2) В строке поиска введите gpedit.msc и нажмите клавишу Enter.
    3) Откройте узел Конфигурация пользователя ->Административные шаблоны -> Компоненты Windows -> Проводник Windows -> Общее диалоговое окно открытия файлов.
    4) Дважды щелкните на политике Элементы, отображаемые в панели мест.
    5) Щелкните на переключателе Включить.
    6) Используйте текстовые поля Элемент 1 — Элемент 5 для ввода путей к папкам, которые требуется отображать в панели мест. Ими могут быть локальные или сетевые папки.
    7) Щелкните на кнопке OK, чтобы ввести политику в действие.

    14. Запуск программы с параметрами командной строки из контекстного меню Проводника.

    Чтобы запустить программу с параметрами - обычно Вам необходимо: либо создать ярлык к программе и при создании указать параметры, либо Пуск -> Открыть (Win+R) ввести программу, указав путь к ней и затем дописать параметры.
    Всё это проще позволит сделать программа ExecParm. Данная программа является позволяет запускать исполняемые(.exe, .com) и командные файлы(.cmd, .bat) с параметрами, используя расширение встраиваемое в контекстное меню Проводника. Чтобы его использовать Вам сделайте следующее:

    1) Скачайте архив программы ExecParm с необходимой разрядностью: 32-битная, 64-битная .
    2) Распакуйте архив в любую папку.
    3) Откройте папку с распакованным содержимым. В ней будут три файла: ExecParm.txt, Execparm.dll, Execparm.inf)
    4) Щелкните правой кнопкой мыши по файлу Execparm.inf и выберите Установить
    Данное действие добавит пункт в контекстное меню для запуска приложения с параметрами.
    5) Щелкните правой кнопкой по исполняемому файлу и выберите в контекстном меню пункт Execute With Parameters...
    6) Введите необходимые параметры для запуска программы и нажмите ОК.

    15. Отображение часто используемых команд для диалогового окна "Выполнить" в меню Пуск.

    1) Откройте папку содержащую файл shell32.dll.mui

    Для 32-битной версии: C:\Windows\System32\ru-RU
    Для 64-битной версии(также): C:\Windows\SysWOW64\ru-RU

    2) Задайте полный доступ к файлу shell32.dll.mui для этого воспользуйтесь советом Администрирование: 1. Получение полного доступа к файлу или папке.
    3) Скачайте архив Patch_ExtendedRun.zip и распакуйте его в любую папку.
    4) Щелкните на exe-файле правой кнопкой мыши и выберите пункт Запуск от имени администратора.
    5) Нажмите кнопку Start для применения патча.

    Внимание: Памятку устанавливать только на оригинальные ОС, работоспособность на различного рода сборках не гарантируется.
    Новые версии Вы можете скачать по ссылке: Windows 7 Памятка

    16. Быстрая вставка путей к файлу или папке в окно команд Windows 7.

    Наиболее часто используемым способом вставки путей к файлу или папке в окно команд Windows (окно командной строки) является следующее:

    1) Выделяете в адресной строке проводника путь к папке.
    2) Щелкаете на выделенном правой кнопкой мыши и выбираете Копировать.
    3) Щелкаете по заголовку окна команд правой кнопкой мыши и выбираете в контекстном меню пункты Изменить -> Вставить
    А если необходимо еще добавить имя и расширение файла, то:
    4) Щелкаете по файлу правой кнопкой мыши и выбираете Переименовать.
    5) Выделяете имя и расширение файла, щелкаете на выделенном правой кнопкой мыши и выбираете Копировать.
    6) Щелкаете по заголовку окна команд правой кнопкой мыши и выбираете в контекстном меню пункты Изменить -> Вставить

    В Windows 7 существуют более быстрые способы сделать это:

    Способ 1.

    1) Удерживая нажатой клавишу Shift щелкните правой кнопкой мыши на папке или файле, путь к которому Вы желаете добавить в окно команд Windows (окно командной строки).
    2) В контекстном меню выберите пункт Копировать как путь (“Copy as path”).
    3) Щелкните внутри окна команд и выберите пункт Вставить.

    Способ 2.

    Перетащите файл или папку (путь к которому Вы желаете добавить) напрямую внутрь окна команд Windows.

    Примечание: Окно из которого вы перетаскиваете файл или папку в окно команд, должно иметь более высокие или одинаковые права и разрешения, чем само окно команд.

    17. Запуск командной строки из "Диспетчера задач" без ввода команды CMD.

    1) Запустите Диспетчер задач нажав на клавиатуре комбинацию клавиш Ctrl+Shift+Esc.
    2) Удерживая нажатой клавишу Ctrl выберите в главном меню пункт Файл и щелкните -> Новая задача (Выполнить...)

    Примечание:

    Если у Вас включен Контроль учётных записей (UAC) или Диспетчер задач запущен в ограниченной учётной записи, окно команд откроется без прав администратора.
    Если у Вас отключен Контроль учётных записей (UAC) или Диспетчер задач запущен с правами администратора, окно команд откроется с правами администратора.

    18. Изменение действий осуществляемых системой при использовании щелчков мыши.

    Если Вы привыкли к поведению мыши в браузере, то Вы можете переключить режим используемый при щелчке мышью в системе на идентичный. Для этого выполните следующие действия:

    1) Откройте Панель управления в режиме просмотра всех элементов: Пуск -> Панель управления\Все элементы панели управления
    2) Запустите Параметры папок
    3) На вкладке Общие установите значение переключателя в
    Открывать одним щелчком, выделять указателем -> Подчеркивать подписи значков при наведении
    4) Нажмите ОК.

    19. Команды для распаковки *.cab, *.exe, *.msi, *.msp и *.msu файлов от Microsoft.

    Приведенные в примерах команды подразумевают, что Вы запустили окно команд из папки, где находится сам файл.
    Чтобы запустить окно команд из папки, где расположен исходный файл, удерживая нажатой клавишу Shift щелкните правой кнопкой мыши на папке и выберите пункт Открыть окно команд.

    Microsoft Cabinet File (.cab):

    Команда для запуска:

    Пример:

    Microsoft Hotfix Installer (.exe):

    Команда для запуска:

    Пример:

    Windows Installer Package (.msi):

    Команда для запуска:

    Пример:

    Microsoft Update Standalone Package (.msu):

    Команда для запуска:

    Пример:

    Microsoft Patch File (.msp)

    Скачайте программу MSI Extractor, распакуйте архив и скопируйте файл msix.exe в папку C:\Windows\System32

    Команда для запуска:

    Пример:

    20. Быстрое открытие ещё одной копии приложения.

    Если у вас уже открыто какое-либо приложение и вы хотите быстро открыть его вторую копию, то удерживая клавишу Shift просто нажмите на иконку данного приложения на Панели задач. И вместо переключения в существующее окно будет открыта новая копия этого приложения. Того же эффекта можно добиться кликнув по иконке приложения на Панели задач, средней кнопкой мыши.

    21. Размещение любого окна Windows поверх других.

    При работе с огромным количеством открытых окон, документов, таблиц и программ очень часто хочется, чтобы окно оставалось поверх всех открытых окон (OnTop) даже при потере фокуса. Для этого можно использовать программу DeskPins.

    Программа предназначена для того, чтобы закреплять любые приложения поверх всех окон Windows. Нужно просто перетащить кнопку с иконки программы на заголовок того окна, которое нужно закрепить, и нажать кнопку мыши — теперь закрепленное окно всегда будет на самом верху. Закреплять и откреплять активные окна можно с помощью горячих клавиш, есть также возможность автоматического закрепления окон. Нажимаете Ctrl+F12 и окно становится OnTop по отношению ко всем открытым.

    22. Ввод пароля в окне смены пользователей при отсутствии необходимой раскладки клавиатуры.

    Если Вы задали пароль на русском языке в английской Windows или пароль на русском языке в русской Windows, то Вы можете столкнуться с ситуацией, когда невозможно ввести пароль в окне смены пользователей, по причине отсутствия необходимой раскладки клавиатуры.

    В таком случае для ввода пароля Вы можете воспользоваться ASCII символами.

    Для ввода буквы из другой раскладки клавиатуры Вам необходимо удерживая нажатой клавишу Alt ввести номер клавиши.
    Например для ввода английской буквы t в русской раскладке клавиатуры:

    1) Нажмите и удерживайте клавишу Alt
    2) Введите 0 (ноль) и сразу за ним 116
    3) Отпустите клавишу Alt, и вы увидите результат.

    или

    для ввода русской буквы т в английской раскладке клавиатуры:

    1) Нажмите и удерживайте клавишу Alt
    2) Введите 0 (ноль) и сразу за ним 242
    3) Отпустите клавишу Alt, и вы увидите результат. Таблица ASCII символов для русской и английской клавиатуры приведена ниже.

    Таблицы ASCII для кодовой страницы Windows 1251

    Кириллица | Значение | Латиница | Значение
А | 192 | A | 65
Б | 193 | B | 66
В | 194 | C | 67
Г | 195 | D | 68
Д | 196 | E | 69
Е | 197 | F | 70
Ж | 198 | G | 71
З | 199 | H | 72
И | 200 | I | 73
Й | 201 | J | 74
К | 202 | K | 75
Л | 203 | L | 76
М | 204 | M | 77
Н | 205 | N | 78
О | 206 | O | 79
П | 207 | P | 80
Р | 208 | Q | 81
С | 209 | R | 82
Т | 210 | S | 83
У | 211 | T | 84
Ф | 212 | U | 85
Х | 213 | V | 86
Ц | 214 | W | 87
Ч | 215 | X | 88
Ш | 216 | Y | 89
Щ | 217 | Z | 90
Ъ | 218 | a | 97
Ы | 219 | b | 98
Ь | 220 | c | 99
Э | 221 | d | 100
Ю | 222 | e | 101
Я | 223 | f | 102
а | 224 | g | 103
б | 225 | h | 104
в | 226 | i | 105
г | 227 | j | 106
д | 228 | k | 107
е | 229 | l | 108
ж | 230 | m | 109
з | 231 | n | 110
и | 232 | o | 111
й | 233 | p | 112
к | 234 | q | 113
л | 235 | r | 114
м | 236 | s | 115
н | 237 | t | 116
о | 238 | u | 117
п | 239 | v | 118
р | 240 | w | 119
с | 241 | x | 120
т | 242 | y | 121
у | 243 | z | 122
ф | 244 |  |
х | 245 |  |
ц | 246 |  |
ч | 247 |  |
ш | 248 |  |
щ | 249 |  |
ъ | 250 |  |
ы | 251 |  |
ь | 252 |  |
э | 253 |  |
ю | 254 |  |
я | 255 |  |

    23. Установка положения курсора в диалоговом окне на кнопке, выбираемой по умолчанию.

    Для многих пользователей весьма удобным считается, чтобы курсор мыши при открытии диалогового окна занимал позицию на кнопке Открыть, Сохранить или аналогичной по умолчанию. Данное действие позволяет Вам сэкономить время необходимое для наведения курсора.

    1) Откройте Панель управления -> Мышь
    2) Перейдите на вкладку Параметры указателя
    3) В графе "Исходное положение в диалоговом окне" установите флажок "На кнопке, выбираемой по умолчанию"
    4) Нажмите ОК.

    24. Уточнение даты и времени загрузки системы.

    Вариант 1.

    Если Вам необходимо узнать дату и время установки Windows на компьютер или дату и время когда компьютер был запущен, то сделайте следующее:

    1) Запустите командную строку с правами администратора.
    Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl+Shift+Enter.
    2) Введите команду systeminfo

    В графе с одноименным названием Вы найдете необходимое Вам значение.

    Вариант 2.

    1) Скачайте с сайта Microsoft программу uptime.exe (http://support.microsoft.com/kb/232243)
    2) Скопируйте ее в папку C:\Windows\System32
    3) Запустите командную строку с правами администратора.
    Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl+Shift+Enter.
    4) Введите команду uptime.exe.

    Вариант 3.

    Скачайте и установите специальный гаджет.

    systemuptime_sevengadgets.ru.zip

    Сети (Интернет и Локальная)

    1. Смена поиска по умолчанию в Mozilla Firefox.

    Бывает, что программы без вашего спроса меняют в Firefox поисковик по умолчанию на свой. Чтобы его заменить сделайте следующее:

    1) Пишете в адресной строке Firefox такой адрес: "about:config", без кавычек
    2) Подтверждаете, что будете осторожны, получаете доступ к многочисленным настройкам Firefox и находите среди них параметр keyword.url
    3) Меняете его значение (без кавычек) на:

    "http://www.google.com/search?&q=" - Google.Com
    "http://yandex.ru/yandsearch?text=" - Yandex.Ru
    "http://www.bing.com/search?q=" - Bing.Com

    2. Добавление ссылки Поиск в Интернете при использовании поиска в меню Пуск.

    В Windows Vista была предложена новая функция. При наборе текста в поле поиска меню Пуск, прямо над окном поиска появлялась ссылка "Поиск в Интернете". При её нажатии набранный текст посылался напрямую в браузер, используемый по умолчанию для поиска.
    В Windows 7 данная функция по умолчанию отключена. Microsoft удалила его из меню "Пуск". Чтобы включить "Поиск в Интернете" через меню «Пуск» необходимо проделать следующие действия.

    1) Откройте диалоговое меню Выполнить (Win+R)
    2) Введите gpedit.msc.
    3) Перейдите в раздел Конфигурация пользователя -> Административные шаблоны -> «Меню «Пуск» и панель задач».
    4) Нажмите правой кнопкой мыши на строке Добавить ссылку «Поиск в интернете» в меню «Пуск» и выберете пункт «Изменить».
    5) В открывшемся окне установите переключатель в значение «Включить».
    6) Нажмите «OK» и закройте Редактор локальной групповой политики.

    Также Вы можете создать reg-файл, выполняющий данную функцию или скачать и применить уже готовый. После применения перезайдите в систему или перезагрузите компьютер.

    Готовый файл: AddSearchInternetLinkInStartMenu.zip

    3. Объединение или удаление сетевых размещений (подключений).

    1) Щелкните правой кнопкой мыши на значок Сеть на панели задач и выберите пункт Центр управления сетями и общим доступом
    2) Если у Вас отсутствует данный значок, то нажмите комбинацию клавиш Win+R -> введите команду

    и нажмите OK
    3) Нажмите на значке (дом, офис или скамейка - зависит от типа выбранной Вами сети)
    4) В открывшемся окне Настройка свойств сети нажмите на ссылку Объединение или удаление сетевых размещений.
    5) Выделите сетевое размещение или несколько сетевых размещений, которые Вы хотите слить в единое сетевое размещение или которые Вы хотите удалить.
    Используемые подключения нельзя удалить или слить, для их слияния или удаления Вам необходимо отключится от сети.
    6) Нажмите кнопку Слияние или Удаление, во всплывшем окне нажмите кнопку Да.

    4. Автоматическое подключение к ADSL-интернету при запуске Windows.

    1) Откройте Панель управления\Все элементы панели управления\Центр управления сетями и общим доступом.
    2) Нажмите ссылку Изменение параметров адаптера.
    3) Щелкните правой кнопкой мыши на Вашем ADSL-соединении и выберите пункт Свойства.
    4) Перейдите на вкладку Параметры и снимите флажки Отображать ход подключения, Запрашивать имя, пароль, сертификат и т.д..
    5) Нажмите кнопку ОК.
    6) Щелкните правой кнопкой мыши на Вашем ADSL-соединении и выберите пункт Создать ярлык.
    7) В диалоговом окне нажмите Да и у Вас на рабочем столе появится ярлык ADSL-соединения.
    8) Откройте Пуск -> Все программы .
    9) Нажмите правой кнопкой мыши на Автозагрузка и выберите пункт Открыть.
    10) Переместите ярлык созданного Вами ADSL-соединения с рабочего стола в открывшуюся папку Автозагрузка.

    5. Автоматическое VPN-подключение к интернет при запуске Windows.

    Вариант 1

    Вы можете добавить задачу в Планировщик заданий.
    1) Откройте планировщик задний
    1.1) Откройте меню Пуск -> Панель управления -> Администрирование -> Планировщик заданий или в строке поиска меню Пуск введите taskschd.msc и нажмите Enter.
    2) Нажмите Создать задачу...
    3) На вкладке Общие введите в поле Имя - Имя подключения
    4) Перейдите на вкладку Триггеры и нажмите кнопку Создать...
    5) Выберите в ниспадающем списке напротив пункта Начать задачу: значение При входе в систему и нажмите ОК.
    6) Перейдите на вкладку Действия и нажмите кнопку Создать...
    7) Выберите в ниспадающем списке напротив пункта Действие: значение Запуск программы.
    8) Введите в поле Программа или сценарий: команду rasdial "имя подключения" login password
    вместо "имя подключения" - укажите название Вашего подключения к интернету
    вместо login - укажите Ваш логин(имя пользователя) для подключения к интернету
    вместо password - укажите Ваш пароль для подключения к интернету
    9) Нажмите кнопку ОК.
    10) Перейдите на вкладку Параметры
    11) Поставьте флажки напротив:
    Немедленно запускать задачу, если пропущен плановый запуск
    При сбое выполнения перезапускать через 1 мин.
    Количество попыток перезапуска 99.
    12) Уберите флажок Останавливать задачу выполняемую дольше и нажмите ОК.

    Вариант 2

    1) Скачайте и распакуйте в любую папку файл connect.zip, содержащий скрипт для соединения с интернетом.
    2) Щелкните правой кнопкой мыши на файле connect.bat и нажмите Изменить
    3) Измените название подключения, логин(имя пользователя) и пароль в соответствии с Вашими настройками и сохраните файл.
    4) Скачайте архив со скриптом скрытого запуска:
    hs_exec.zip - для использования командного bat-файла, содержащего скрипт запуска
    hide_programm.zip - для использования яваскрипта, содержащего скрипт запуска
    5) Распакуйте архив в ту же самую папку, где у Вас находится файл connect.bat
    6) Добавьте в папку автозагрузки (Пуск -> Все программы ->Автозагрузка) ярлык (не сам файл скрипта) для hide_programm.js в случае использования яваскрипта, либо для load.bat в случае использования командного bat-файла.

    Вариант 3

    1) Создайте командный bat-файл (Например: Connect.bat) следующего содержания:

    вместо "имя подключения" - укажите название вашего подключения к интернету
    вместо login - укажите Ваш логин(имя пользователя) для подключения к интернету
    вместо password - укажите Ваш пароль для подключения к интернету

    2) Добавьте ярлык (не сам файл скрипта) на файл connect.bat в папку автозагрузки (Пуск -> Все программы ->Автозагрузка)

    Внимание: "имя подключения" должно быть на английском иначе может быть ошибка 623.

    6. Отключение запроса пароля при использовании папки общего доступа.

    Даже если Вы не устанавливали пароль для папки общего доступа, система может у Вас его запросить.

    Для отключения данного запроса сделайте следующее:

    1) Откройте Панель управления\Все элементы панели управления\Центр управления сетями и общим доступом
    2) Нажмите на ссылку Изменить дополнительные параметры общего доступа
    3) В графе Общий доступ с парольной защитой установите переключатель на значение Отключить общий доступ с парольной защитой.

    7. Просмотр исходного кода любой страницы в интернете.

    Очень многие страницы в интернете любят скрывать свой код или блокировать копирование. Но это легко можно решить. Данный метод позволяет узнать любой код зашифрованный криптографами или измененный обфускаторами.

    В Firefox

    Установите расширение Web Developer.
    Затем в меню Web Developer -> Код -> Сгенерированный код.
    Если исходный код был зашифрован, то промотайте вниз и увидите реальный код. Если код не был зашифрован, то увидете его сразу.
    Вы можете сохранить его либо скопировав в буфер обмена и вставив в нужное место, либо Файл -> Сохранить страницу как -> page.htm

    В Internet Explorer

    Меню Сервис -> Средства разработчика
    Можете нажать на стрелочку и выбрать нужный элемент на странице и увидите его код или нажать на значок дискетки и сохранить исходный код в текстовый файл, а затем скопировать из него в html.

    8. Восстановление пропавшего звука в интернет браузерах.

    1) Проверьте уровень громкости в самом Flash плеере.

    2) Удалите полностью, а затем поставьте заново:
    2.1) Adobe Flash Player. Uninstall: http://kb2.adobe.com/cps/141/tn_14157.html Install: http://get.adobe.com/flashplayer/otherversions/
    2.2) Кодеки в системе (K-lite codeck pack, Shark007 Windows 7 Codecs или др.)
    2.3) Браузеры.
    2.4) Драйвера звуковой карты

    3) В Internet Explorer, проверьте стоит ли у Вас флажок в пункте "Воспроизводить звуки на веб-страницах" Сервис -> Свойства обозревателя -> Дополнительно -> Раздел Мультимедиа.

    4) Проверьте, установлен ли запуск службы Windows Audio Автоматически.
    Панель Управления -> Администрирование -> Службы -> двойной щелчок на Windows Audio -> Тип запуска: Автоматически
    Затем нажмите Остановить, потом Запустить.

    5) Запустите редактор реестра (Win+R -> regedit)
    Перейдите к ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32
    Проверьте значение строкового(String) параметра wavemapper. Его значение должно быть msacm32.drv. Если данного параметра нет, то создайте его.

    9. Сохранение интернет соединения при переключении между пользователями.

    При создании нового интернет подключения поставьте флажок на "Разрешить использовать это подключение другим пользователям".
    Установление галочки в уже созданном подключении может работать некорректно в некоторых VPN соединениях.

    По умолчанию при переключении между пользователями Windows сбрасывает dial-up и некоторые виды других соединений. Можно изменить это поведение следующим образом.

    1) Запускаете редактор реестра (Win+R -> Regedit -> OK)
    2) Открываете ветку реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters
    3) Щелкните правой кнопкой мыши на Dword-параметр KeepRASConnections, выберите Изменить и присвойте параметру значение 1
    4) Закройте Regedit и завершите текущий сеанс для вступления изменений в силу

    Если Вы хотите, чтобы соединения сбрасывались, то используйте значение 0 или удалите этот параметр.

    10. Перемещение HOST, LMHOST и других файлов из Windows\System32\drivers\etc в другое место.

    Если вы хотите переместить файлы из Windows\System32\drivers\etc в другое место (например, по соображениям безопасности) из папки Windows\System32\drivers\etc, то для этого Вам необходимо выполнить следующее:
    1) Скопируйте файлы в новое место
    2) Запустите редактор реестра (Win+R -> regedit -> Ok).
    3) Откройте ветку HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
    4) Измените значение параметра DataBasePath на новый путь к папке
    5) Перезагрузитесь и удалите файлы из %SystemRoot%\System32\drivers\etc

    11. Поиск на веб-сайтах из Проводника (Windows Explorer).

    Windows 7 теперь позволяет вести поиск на веб-сайтах из Windows Explorer (Проводника). Данный поиск основан на спецификации OpenSearch.
    Чтобы добавить в Windows провайдер OpenSearch, нужно предоставить файл определения в формате OSDX. Этот формат позволяет указывать описательную информацию наряду с необходимыми URL и другими параметрами.
    Эти файлы сопоставляются с Windows Explorer и добавляются в папку Searches: C:\Users\{USER}\Searches.
    Чтобы создать файл OSDX, нужно предоставить URL для вызова и имя провайдера.

    1) Откройте текстовый редактор. (Например, Блокнот)
    2) Скопируйте и вставьте в него следующий текст:

    3) В меню программы нажмите Файл и выберите пункт Сохранить.
    3.1) В открывшемся окне укажите место сохранения файла.
    3.2) Укажите имя файла и расширение .osdx и обязательно в кодировке UTF-8 (Например: Сохраните его как Bing.osdx)
    3.3) Выберите тип файла: Все файлы (*.*).

    Дважды щелкните по получившемуся osdx-файлу для внесения дополнений в систему.

    Чтобы искать на добавленном Вами веб-сайте из Проводника:

    1) Запустите Проводник (Explorer)
    2) Откройте папку C:\Users\{USER}\Searches, для чего просто введите %UserProfile%\Searches и нажмите Enter.
    3) Выберите установленный Вами поиск, в строке поиска укажите значение для поиска и нажмите Enter.
    4) Если Вы хотите, чтобы при нажатии на результат поиска в проводнике показывались найденная страница, то нажмите на значок включения Области преварительного просмотра (находится, в верхней правой части экрана перед значком вопроса)

    Вы можете скачать уже готовые файлы определения (.osdx) по ссылке: OSDX.zip

    12. Смена динамического IP-адреса, для обхода времени ожидания на файлообменниках.

    Многие файлообменники и программы для скачивания разделяют обычных пользователей по IP адресу. Если Вы не используйте прокси-сервера и при каждом подключении к интернету провайдер дает Вам новый IP адрес, то это означает что у Вас динамический адрес и Вы можете создать командный файл разрывал бы связь и снова соединялся с интернетом. В итоге у вас будет новый адрес и для файлообменника Вы будете уже новым клиентом.
    Данная возможность позволит Вам обойти ограничение по времени и качать без ожиданий.

    Инструкция по созданию командного файла:

    1) Откройте любой текстовый редактор (Например, Блокнот).
    2) Откройте меню Пуск -> Все программы -> Стандартные -> Блокнот (или нажмите сочетание клавиш Win+R -> введите notepad -> нажмите ОК)
    3) Скопируйте необходимый Вам код в окно программы Блокнот.
    4) В меню программы нажмите Файл и выберите пункт Сохранить.
    В открывшемся окне:
    5) Укажите место сохранения файла.
    6) Укажите имя файла и расширение .bat (Например: reconnect.bat)
    7) Выберите тип файла: Все файлы (*.*).
    8) Для смены IP-адреса запустите созданный Вами командный файл просто щелкнув на нем.

    Вариант 1. Внешний динамический адрес, прямое подключение по локальной сети.

    Вариант 2. Внешний динамический адрес, подключение через модем или через USB-ADSL.

    Способ 1.

    Чтобы узнать имя требуемого интерфейса:
    1) Запустите командную строку от имени администратора (Win+R -> cmd -> OK)
    2) Введите указанную ниже команду и нажмите Enter:

    Способ 2.

    Вариант 3. Внешний динамический адрес, подключение через LAN-ADSL или через роутеры.

    Способ 1.

    где:
    192.168.1.1 - Ваш IP-адрес (модема)
    LOGIN - логин к модему
    PASS - пароль к модему

    Способ 2.

    Скачиваете и устанавливаете программу Router Control, а файл reconnect.bat создаете в папке программы.

    13. Включение и настройка общего доступа к файлам и папкам.

    В Windows 7 папка «Общее» заменена на отдельные общие папки для каждого типа файлов: Общие документы, Общие рисунки, Общая музыка или Общее видео. В Проводнике Вы можете попасть в них через Библиотеки, открыв папку Документы, Рисунки, Музыка или Видео, а затем папку Общие документы, Общие рисунки, Общая музыка или Общее видео.

    Предоставление общего доступа к файлам или папкам, находящимся в Общих папках с использованием домашней группы.

    1) Нажмите кнопку Пуск и откройте Панель управления.
    2) Установите режим просмотра "Крупные значки" и запустите компонент Центр управления сетями и общим доступом.
    3) Щелкните Выбор домашней группы и параметров общего доступа.
    4) Нажмите на кнопку Создать домашнюю группу
    5) Выберите элементы, к которым нужно предоставить общий доступ и нажмите кнопку Далее.
    6) В окне с паролем для добавления других компьютеров к домашней группе нажмите кнопку Готово.
    7) Нажмите на ссылку Изменить дополнительные параметры общего доступа
    8) В графе Общий доступ с парольной защитой установите переключатель в значение Отключить общий доступ с парольной защитой.
    9) Нажмите на кнопку Сохранить изменения и закройте окно настроек.

    Предоставление общего доступа к любым файлам или папкам без перемещения их в Общие папки с использованием домашней группы.

    I. Настройка конкретных папок или файла для общего доступа.

    1) Перейдите в место размещения файла или папки, к которым необходимо предоставить общий доступ.
    2) Щелкните файл или папку правой кнопкой мыши и выберите пункт Общий доступ –> Конкретные пользователи
    3) Введите имя или нажмите стрелку вниз и в всплывающем меню выберите Все, а затем нажмите кнопку Добавить
    4) Напротив имени Все установите необходимый Вам Уровень разрешений:
    Чтение - Пользователи могут открывать файл, но им не разрешается изменять или удалять его.
    Чтение и запись - Пользователи могут открывать, изменять и удалять файл.
    5) Нажмите кнопку Общий доступ. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
    6) Нажмите правой кнопкой мышки на папке и выберите Копировать ссылку. Ваша ссылка будет скопирована в буфер обмена. Теперь вставьте ссылку в сообщение электронной почты, мгновенное сообщение или другую программу, или же сохраните в блокноте.
    7) По завершении нажмите кнопку Готово.

    II. Настройка портов для общего доступа.

    1) Откройте Пуск -> Панель управления -> Система и безопасность и запустите Брандмауэр Windows.
    2) Нажмите ссылку Дополнительные параметры, чтобы добавить новые правила для Firewall.
    3) В открывшемся окне, в меню слева, выберите Правила для входящих подключений
    4) В меню справа нажмите кнопку Создать правило….
    5) В открывшемся окне, установите переключатель на тип правила Для порта и нажмите кнопку Далее.
    6) Установите переключатель на Протокол TCP.
    7) В текстовое поле напротив Определенные локальные порты: впишите через запятую 139, 445 и нажмите кнопку Далее.
    8) В следующем окне оставьте установленное по умолчанию значение Разрешить подключение и нажмите кнопку Далее.
    9) В окне выбора профилей снова нажмите кнопку Далее.
    10) Введите имя и описание Вашего правила. Например: Shared Folders (TSP ports).
    11) Нажмите кнопку Готово.

    Повторите действия указанные в пунктах с 4) по 11) для типа протокола UDP.
    В 6) пункте инструкции установите переключатель на Протокол UDP, в 7) пункте впишите порты 137, 138, а имя задайте Shared Folders (UDP ports).

    III. Отключение запроса пароля.

    1) Щелкните правой кнопкой мыши на значок сетевого подключения на панели задачи и выберите пункт Центр управления сетями и общим доступом.
    2) Просмотрите Ваши активные сети. Тип сетевого размещения используемого для разрешения взаимодействия с другими компьютерами должен быть установлен как Домашняя сеть. Для смены типа сетевого размещения на Домашняя сеть:
    2.1) Нажмите мышкой по имеющейся у Вас надписи Сеть предприятия или Общественная сеть
    2.2) В открывшемся окне выберите Домашняя сеть и нажмите кнопку Закрыть .
    Если тип Вашего сетевого размещения уже установлен как Домашняя сеть, то Вам менять его не нужно.
    3) Нажмите на ссылку Изменить дополнительные параметры общего доступа
    4) В графе Общий доступ с парольной защитой установите переключатель в значение Отключить общий доступ с парольной защитой.
    5) Нажмите на кнопку Сохранить изменения и закройте окно настроек.

    Предоставление общего доступа к файлам и папкам, находящимся в Общих папках без использования домашней группы.

    1) Нажмите кнопку Пуск и откройте Панель управления.
    2) Установите режим просмотра "Крупные значки" и запустите компонент Центр управления сетями и общим доступом.
    3) Щелкните Изменить дополнительные параметры общего доступа в левой области
    4) Установите переключатели в следующие параметры:

    - Включить сетевое обнаружение.
    - Включить общий доступ к файлам и принтерам
    - Включить общий доступ, чтобы сетевые пользователи могли читать и записывать файлы в общих папках (делает доступными папки "Общие документы", "Общая музыка", "Общие рисунки" и "Общее видео")
    - Отключить общий доступ с парольной защитой

    Примечания

    Для включения общего доступа с парольной защитой, необходимо иметь две совершенно одинаковые учетные записи и пароли пользователя на обоих компьютерах.
    Если имя пользователя и пароль, с которыми выполнен вход в систему, отличаются от зарегистрированного на другом компьютере, к которому осуществляется попытка доступа, возможно, будет запрошена информация для входа в систему.
    Если на другом компьютере разрешен доступ всем в сети, автоматическое подключение будет предоставлено с правами гостя. Это означает, что доступ будет предоставлен только к файлам в общих папках.

    Если при предоставлении общего доступа у Вас возникают проблемы, то Вы можете использовать средство устранения неполадок для автоматического поиска и устранения некоторых распространенных проблем.

    1) Запустите командную строку с правами администратора или нажмите Win+R
    1.1) Откройте Пуск -> Все программы -> Стандартные
    1.2) Щелкните правой кнопкой мыши на Командная строка и выберите Запуск от имени администратора
    2) Введите следующую команду и нажмите Enter:

    3) Нажмите кнопку Далее и следуйте инструкциям средства устранения неполадок.

    14. Автоматическая загрузка последних версий драйверов и реалистичных значков для подключенных устройств.

    1) Откройте Пуск -> Панель управления -> Устройства и принтеры.
    2) Щелкните правой кнопкой мыши имя компьютера и выберите пункт Параметры установки устройств.
    3) Выберите пункт Да, делать это автоматически (рекомендуется) и нажмите кнопку Сохранить изменения.

    Windows сохранит фирменные значки производителя для подключенных Вами устройств в папку:

    %LOCALAPPDATA%\Microsoft\Device Metadata\dmrccache\

    Внутри папки, в соответствии с вашим регионом (например, en-US), должны располагаться отдельные папки содержащие в названии GUID для каждого устройства с соответствующими метаданными. Иконка будет находится в папке DeviceInformation каждого устройства.

    15. Вычисление сайтов посещаемых пользователем в приватном режиме просмотра браузера.

    Приватный режим посещения сайтов в браузерах не сохраняет на компьютере куки-файлы, временные файлы Интернета, журнал просмотра и другие сведения.
    Но не смотря на это вся информация о посещенных сайтах в интернете и присутствующих на данном сайте компонентах сохраняется в кэше сопоставления имен клиентов.
    В нем хранится такая информация, как IP адрес и имя домена, на основе которых можно вычислить адрес посещаемого сайта. Для просмотра данного кэша не требуются права администратора на компьютере.

    Для отображения кэша сопоставления имен клиентов выполните следующее:

    1) Запустите командную строку нажмите кнопку Пуск и выберите Все программы, Стандартные и Командная строка (Win+R -> cmd -> OK) .
    2) Введите команду и нажмите Enter:

    Чтобы была пауза после отображения каждого экрана выходных данных команды, введите:

    3) Если Вам необходимо сохранить данную информацию в текстовый файл выполните команду:

    Данные будут сохранены в файл DNScache.txt на диск C: .

    Для сбрасывания данных кэша сопоставления имен клиентов выполните следующее:

    1) Запустите командную строку нажмите кнопку Пуск и выберите Все программы, Стандартные и Командная строка (Win+R -> cmd -> OK) .
    2) Введите команду и нажмите Enter::

    16. Месторасположение кэша браузера и его просмотр.

    Каждый браузер по умолчанию сохраняет содержимое веб-страниц (изображения, flash-ролики, видео, аудио и др.), просмотренных вами на жёсткий диск в кэш, во избежание их повторной загрузки.

    Microsoft's Internet Explorer

    Кэш для данного браузера хранится в отдельных профайлах для каждого пользователя по адресу:

    С:\Documents and Settings\Имя_пользователя\Local Settings\Temporary Internet Files\Content.IE5\

    Для открытия данной папки Вам необходимо задать права доступа к ней, для этого воспользуйтесь советом Администрирование: 1. Получение полного доступа к файлу или папке.

    Внутри директории \Content.IE5 содержаться дополнительные папки со "случайно" сгенерированными именами, в которых храниться информация о посещение того или иного веб ресурса, а в файле index.dat, в котором и содержится интересующая нас информация. Файл index.dat для просмотра можно открыть программой Index.dat Analyzer.
    Для сканирования содержимого index.dat файлов нажмите кнопку Quick rescan for index.dat files.

    Также Вы можете открыть Свойства обозревателя, в графе История просмотра нажать Параметры, а затем кнопку Показать файлы.

    Mozilla Firefox

    Mozilla Firefox использует особый алгоритм кэширования страниц. Папка, в которой храниться интересующая Вас информация:

    C:\Documents and Settings\Имя_пользователя\AppData\Local\Mozilla\Firefox\Profiles\Имя_профиля\Cache

    Для открытия данной папки Вам необходимо задать права доступа к ней, для этого воспользуйтесь советом Администрирование: 1. Получение полного доступа к файлу или папке.

    Для просмотра кэша: Откройте новую вкладку, наберите в адресной строке about:cache?device=disk и нажмите Enter.

    Opera

    Кэш для данного браузера хранится в отдельных подпапках по адресу:

    C:\Documents and Settings\Имя_пользователя\AppData\Local\Opera\Opera\cache

    Для просмотра кэша: Откройте новую вкладку, наберите в адресной строке opera:cache и нажмите Enter.

    Также Вы можете скачать и использовать для просмотра кэша браузеров Internet Explorer, Mozilla Firefox или Opera программу Cache View Plus. Данная программа позволяет Вам напрямую (в режиме предпросмотра) увидеть файлы находящиеся в кэше файлы в соответствии с их типом: изображения, видео, звуки, swf-файлы.

    17. Отключение автоматической отправки сведений на сервера корпорации Microsoft, собранных программой улучшения качества программного обеспечения.

    В корпорации Microsoft существует программа улучшения качества программного обеспечения, которая собирает сведения о продуктах Microsoft, а также ограниченные данные о произведенных независимыми компаниями приложениях, которые взаимодействуют с продуктами Microsoft и отсылает их на сервера Microsoft.

    Более подробно о ней Вы можете прочитать на сайте: http://www.microsoft.com/products/ceip/ru-ru/default.mspx

    Если Вы не желаете участвовать в данной программе, то сделайте следующее:

    1) В строке поиска меню Пуск введите команду gpedit.msc и нажмите Enter.
    2) Перейдите до папки:

    3) Щелкните правой кнопкой мыши на Отключить программу по улучшению качества программного обеспечения Windows и выберите пункт Изменить.
    4) Установите переключатель в значение Включить и нажмите кнопку OK.

    18. Добавление индикатора сетевой активности на панель задач.

    Значок Сеть в области уведомлений на панели задач при наведении на него отображает всего лишь текущее подключение и не мигает при наличии сетевой активности.
    Если Вы желаете добавить значок в область уведомлений, позволяющий увидеть размер входящего и исходящего траффика, а также просмотреть статистику подключения, то Вы можете скачать небольшую бесплатную программу Network Activity Indicator, максимально приближенную к интерфейсу Windows.

    Если Вы желаете заменить стандартную иконку Сеть на иконку данной программы, то проделайте следующее:

    1) Зайдите на сайт: http://www.itsamples.com/network-activity-indicator.html
    2) Скачайте программу Network Activity Indicator и язык интерфейса к ней.
    3) Распакуйте программу и язык интерфейса для программы в одну и ту же папку.
    4) Откройте папку, куда Вы распаковали программу и запустите файл NetworkIndicator.exe
    5) Нажмите правой кнопкой мыши на иконку программы и выберите пункт Настройки
    6) Установите флажки:
    Отображать UDP пакеты
    Отображать ICMP пакеты
    Запускать при старте Windows
    Показывать неактивную иконку если интерфейс отсоединен.
    Использовать иконки Vista
    7) Нажмите кнопку Применить.
    8) Щелкните правой кнопкой мыши на панели задач и выберите пункт Свойства.
    9) В графе Область уведомлений щелкните на кнопку Настроить...
    10) Нажмите на ссылку Включить или выключить системные значки.
    11) Напротив значка Сеть из ниспадающего списка выберите Выкл.
    12) Нажмите ОК и еще раз ОК.

    19. Создание ярлыка для запуска Internet Explorer в режиме приватного просмотра.

    1) Щелкните правой кнопкой мыши на свободном месте рабочего стола, и выберите Создать -> Ярлык.

    2) Для 32-битных Windows 7:

    2.1) В поле Укажите расположение объекта введите:

    2.2) Переходите к пункту 4.

    3) Для 64-битных Windows 7:

    3.1) Чтобы использовать 32-битную версию Internet Explorer, в поле Укажите расположение объекта введите:

    3.2) Чтобы использовать 64-битную версию Internet Explorer, в поле Укажите расположение объекта введите:

    4) Нажмите кнопку Далее.
    5) В поле Введите имя ярлыка напишите Internet Explorer (просмотр InPrivate) и нажмите кнопку Готово. (Примечание: Вы можете указать любое имя для ярлыка.)
    6) Теперь Вы можете переместить созданный Вами ярлык в любое удобное для Вас место. Например, Вы можете закрепить ярлык в панели задач.

    20. Создание ярлыка в папке Компьютер для просмотра часто используемого ftp как одного из дисков.

    1) В проводнике или в меню Пуск щелкните правой кнопкой мыши на Компьютер
    2) Выберите в списке пункт Подключить сетевой диск
    3) Нажмите ссылку Подключение к сайту, на котором можно хранить документы и изображения.
    4) В открывшем окне нажмите кнопку Далее, а затем снова кнопку Далее.
    5) В текстовом поле введите имя ftp-сервера и нажмите кнопку Далее.

    Например: ftp://ftp.mozilla.org/pub/firefox/

    6) Уберите флажок "Анонимный вход" и введите имя пользователя и нажмите кнопку Далее.
    Если для входа не нужна идентификация пользователя, то оставьте флажок "Анонимный вход" установленным.
    7) Введите имя для отображаемого ярлыка в проводнике и нажмите Далее.
    8) Для завершения создания ярлыка нажмите кнопку Готово.

    21. Быстрая очистка истории обзора Internet Explorer при помощи специально созданного ярлыка.

    Если Вы используете браузер Internet Explorer, то для очистки истории обзора(временных файлов, кэша, паролей и др.) Вы делаете следующее:

    1) В Internet Explorer открываете Свойства обозревателя.
    Если у Вас включена Строка меню, то данный пункт расположен в меню Сервис, если Строка меню отключена, то нажимаете на значок шестеренки.
    2) На вкладке Общие в графе История просмотра нажимаете кнопку Удалить... .
    3) Устанавливаете необходимые флажки и нажимаете кнопку Удалить.

    Чтобы ускорить данный процесс Вы можете создать специальный ярлык для очистки определенных данных из истории просмотра Internet Explorer на рабочем столе.

    1) Щелкните по рабочему столу правой кнопкой мыши, выберите команды "Создать" - "Ярлык".
    2) В текстовом поле введите необходимую Вам команду для запуска.

    Удаление истории посещений (журнала):

    Удаление Cookies:

    Удаление временных файлов/веб страниц:

    Удаление данных веб-форм:

    Удаление паролей:

    Полное удаление всей истории:

    Полное удаление всей истории и данных надстроек браузера:

    3) Нажмите кнопку Далее
    4) Укажите имя для ярлыка и нажмите Готово.

    Так же можно комбинировать номера, суммируя их.
    Например:

    Это удалит временные файлы (+8) и журнал посещений (+1).

    Тонкие настройки

    1. Отключение "гибернации" для исправления ошибки BSOD и получения дополнительного места на жестком диске.

    Бывает при выходе из режима гибернации многие видят только черный экран или ошибку BSOD. После чего приходится выключать кнопкой питания и включать заново. Одним из решений в такой ситуации является отключение гибернации.

    1) Запустите командную строку с правами администратора
    1.1) В строке поиска в меню Пуск введите cmd
    1.2) Щелкните на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора
    2) Введите команду и нажмите Enter:

    Чтобы выключить гибернацию:

    Чтобы включить:

    Отключение гибернации также приведет к тому, что файл hiberfil.sys, расположенный в корне диска на котором у вас установлена Windows автоматически удалится, освобождая дополнительное пространство на накопителе.

    2. Удаление значка "Центр поддержки" из области уведомлений на панели задач.

    1) Щелкните правой кнопкой мыши на свободное место на панели задач и нажмите пункт Свойства
    2) Нажмите кнопку Настроить...
    3) Щелкните по ссылке Включить или выключить системные значки
    4) Напротив надписи Центр поддержки выберите из ниспадающего списка значение Выкл нажмите ОК.

    3. Удаление текста под значком ярлыка или файла.

    1) Щелкните правой кнопкой мыши на иконке и нажмите Переименовать.
    2) Удерживая нажатой клавишу Alt, напечатайте на цифровой клавиатуре подряд цифры 2, 5 и 5 (Alt+255).
    Данная комбинация позволяет добавить невидимый символ в название ярлыка или файла.
    Для переименования несколько ярлыков, добавляйте к каждому следующему дополнительно Alt+255, отпуская клавишу Alt после каждого введения числа 255.
    Так для переименования второго ярлыка, Вам потребуется ввести Alt+255, Alt+255, для третьего Alt+255, Alt+255, Alt+255 и т.д..

    4. Создание (восстановление) панели быстрого запуска (Quick Launch).

    1) Щелкните правой кнопкой мыши по панели задач и наведите курсор на Панели (Toolbars )
    2) Нажмите на пункт Создать панель инструментов... (New Toolbar)
    3) Введите путь к папке: %appdata%\Microsoft\Internet Explorer\Quick Launch и нажмите клавишу Enter.
    4) Нажмите кнопку Выбор папки (Select Folder).
    5) Щелкните правой кнопкой мыши по панели задач и уберите флажок Закрепить панель задач.
    6) Щелкните левой кнопкой мыши на панели Quick Launch и не отпуская клавиши перетащите панель в левую сторону.
    7) Щелкните правой кнопкой мыши на панели Quick Launch и уберите флажки Показывать подписи и Показывать заголовок.
    8) Щелкните правой кнопкой мыши по панели задач и поставьте флажок Закрепить панель задач.

    5. Разблокирование файла используемого какой-либо программой для действий с ним.

    Если при попытке удаления, переименования или перемещения файла или папки системой выдается сообщение, что данное действие произвести невозможно, так как файл (папка) используется другим приложением, то для разблокировки используемого файла (папки) Вы можете воспользоваться замечательной утилитой Unlocker. Программа является дополнением к Проводнику Windows, ее вызов осуществляется через контекстное меню, вызываемое нажатием правой кнопкой мыши на файле (папке).

    Инструкция:

    1) В соответствии с разрядностью Вашего Windows cкачайте и установите программу Unlocker
    2) Нажмите правой кнопкой на файле и в контекстном меню выберите Unlocker.
    3) Выберите необходимое Вам действие и нажмите на кнопку Разблокировать Все.

    Для замены защищенного файла Windows сделайте следующее:

    1) Скопируйте файл(ы) для дальнейшей замены в буфер обмена.
    2) С помощью инструкции выше, удалите заменяемый(е) Вами файл(ы).
    3) После удаления файла(ов), вставьте заранее скопированный(е) файл(ы) (Сделать это надо в первые секунды после удаления, так как система может восстановить файл из кэша)
    4) Перезайдите в систему или перезагрузите компьютер.
    P.S. Если после перезагрузки, некоторые (или все) изменения не вступили в силу, удалите содержимое папки C:\Windows\rescache и в случае необходимости проделайте описанное выше ещё раз.

    6. Удаление надписей из правого нижнего угла рабочего стола.

    Чтобы удалить водяные знаки на рабочем столе, такие как "Пробная копия", "Только для тестов", "Тестовый режим", воспользуйтесь одним из предложенных вариантов.

    Вариант 1.

    1) Откройте с помощью Restorator или PE Explorer файлы:

    C:\Windows\System32\ru-RU\user32.dll.mui
    C:\Windows\System32\en-US\user32.dll.mui

    2) В разделе Строковая таблица (String) удалите строчки с 715 по 718 включительно и строки 737 и 738 .

    715 %wsWindows %ws
    716 %ws Сборка %ws
    717 Пробная копия.
    718 Только для тестов.

    737 Ваша копия Windows не является подлинной
    738 Тестовый режим

    3) Перезагрузите компьютер.
    Если после перезагрузки надписи не исчезли, то Вам необходимо перестроить кэш MUI.
    4) Нажмите кнопку Пуск и в строке поиска введите cmd
    5) Щелкните правой кнопкой мыши на найденной программе и выберите пункт Запуск от имени администратора
    6) Введите команду: mcbuilder и нажмите Enter
    7) Перезагрузите компьютер.

    Вариант 2.

    1) Скачайте архив RemoveWatermark_20090509.zip и распакуйте его в любую папку.
    2) Выберите патч исходя из разрядности установленной у Вас Windows:
    Для 32-бит(x86): RemoveWatermarkX86.exe
    Для 64-бит(x64): RemoveWatermarkX64.exe

    3) Нажмите правой кнопкой мыши на exe-файл и выберите пункт "Запуск от имени администратора"
    4) Нажмите клавишу "Y" для подтверждения.
    Резервная копия "user32.dll.mui" будет сохранена как \Windows\System32\en-US\user32.dll.mui.backup.
    Строка "en-US" зависит от языка Вашей системы.
    5) Дождитесь окончания патча и перезагрузите компьютер.
    6) Если надписи после перезагрузки остались на Вашем рабочем столе, то Вам надо перестроить кэш MUI. Для этого:
    6.1) Нажмите правой кнопкой мыши на exe-файл и выберите пункт "Запуск от имени администратора"
    6.2) Нажмите клавишу "R" для подтверждения.
    6.3) Дождитесь окончания перестройки кэша, а затем перезагрузите компьютер.

    7. Смена названия операционной системы из Максимальная на Ultimate.

    Открываете с помощью Restorator или PE Explorer файл C:\Windows\Branding\Basebrd\ru-RU\basebrd.dll.mui и правите в нем название операционной системы из Максимальная на Ultimate. Также можно скопировать файл basebrd.dll.mui из папки C:\Windows\Branding\Basebrd\en-US\ в папку C:\Windows\Branding\Basebrd\ru-RU\ если данной папки нет, то файлы можно скачать тут: для x86, для x64

    8. Использование всей оперативной памяти в 32-битных Windows.

    Данная программа добавляет второе ядро для загрузки операционной системы: ntkr128g.exe
    Статьи (на английском), объясняющие причины использования 32-битными системами меньше памяти чем установлено и помогающие понять принцип работы данной программы:

    http://support.microsoft.com/kb/978610
    http://www.geoffchappell.com/viewer.htm?doc=notes/windows/license/memory.htm

    1) Скачайте ReadyFor4GB от deepxw.
    2) Распакуйте его в любую папку и запустите ReadyFor4GB.exe

    Рисунок 1 из 10

    3) Нажмите на кнопку Check, затем на кнопку Apply.

    Рисунок 2 из 10

    4) Нажмите на кнопку Да (Yes) для пропатчивания ntkrnlpa.exe

    Рисунок 3 из 10

    5) Нажмите на кнопку ОК для подтверждения места сохранения файла ntkr128g.exe

    Рисунок 4 из 10

    6) Закройте окно программы ReadyFor4GB.
    7) Нажмите правой кнопкой мыши на файл AddBootMenu.cmd и выберите пункт Запуск от имени администратора
    8) Нажмите клавишу "Y" для подтверждения или клавишу "Q" для выхода, и нажмите Enter.

    Рисунок 5 из 10

    9) Дождитесь окончания работы скрипта и закройте программу.

    Рисунок 6 из 10

    10) Нажмите правой кнопкой мыши на файл RemoveWatermarkX86.exe и выберите пункт Запуск от имени администратора

    Рисунок 7 из 10

    11) Нажмите клавишу "Y" для подтверждения.

    Рисунок 8 из 10

    Резервная копия "user32.dll.mui" будет сохранена как \Windows\System32\en-US\user32.dll.mui.backup.
    Строка "en-US" зависит от языка Вашей системы.
    12) Дождитесь окончания патча и перезагрузите компьютер.
    13) Компьютер перезагрузится, покажет Диспетчер загрузки Windows (Windows Boot Manager) и загрузит Microsoft Windows [128GB with ntkr128g.exe]

    Рисунок 9 из 10

    14) Если надпись "Тестовый режим" после перезагрузки осталась на Вашем рабочем столе, то Вам надо перестроить кэш MUI. Для этого:
    14.1) Нажмите правой кнопкой мыши на файл RemoveWatermarkX86.exe и выберите пункт Запуск от имени администратора
    14.2) Нажмите клавишу "R" для подтверждения.

    Рисунок 10 из 10

    14.3) Дождитесь окончания перестройки кэша, а затем перезагрузите компьютер.

    Примечание:

    П.1) Файлы обязательно запускать от имени администратора, и только в операционной системе Windows 7 x86 (32-Bit).
    П.2) Для удаления записи о другой Windows из диспетчера загрузки:
    П.2.1) Запустите Конфигурация системы: Панель управления -> Администрирование -> Конфигурация системы (или нажав Win+R -> msconfig -> Ok)
    П.2.2) Перейдите на вкладку Загрузка.
    П.2.3) Выделите пункт загрузки, который Вы желаете удалить и нажмите кнопку Удалить.
    П.3) Если после применения патча у Вас по-прежнему показывает значение менее 4 Гб, то Вы можете скачать готовый файл ntkr128g.exe и скопировать его в папку C:\Windows\System32:

    http://file.qip.ru/file/1C7BVO4j/ntkr128g.html

    Если и после этого у Вас не появится 4 гб памяти, то видимо Ваша оперативная память не отдает доступ к необходимым адресам памяти.
    Следовательно для использования полностью всей оперативной памяти рекомендую Вам установить 64-битную Windows.

    9. Изменение папки открываемой по умолчанию в Проводнике.

    Настраиваем нажатие на кнопку Проводник (Windows Explorer), чтобы оно приводило в указанную Вами папку, вместо Libraries.

    1) Нажмите правой кнопкой мыши на значок Проводника в Панели задач.
    2) Нажмите правой кнопкой мыши на Проводник
    3) Нажмите левой кнопкой мыши на Свойства
    4) Измените поле Объект (Target) на %SystemRoot%\explorer.exe /n, /e, С:\My Folder
    где C:\My Folder - путь к Вашей папке.
    Для запуска папки Компьютер измените на значение: %SystemRoot%\explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
    Чтобы это изменение затронуло и ссылку в меню Пуск, то вам потребуется изменить поле Объект в свойствах ярлыка Проводник в папке Стандартные (Accessories) из меню Пуск.
    Комбинация клавиш Win+E откроет Проводник в «Компьютере»

    10. Добавление или прямой запуск папки Все задачи (Расширенная Панель Управления).

    Для быстрого доступа разработчиков и тестеров ко всем системным задачам в бета версиях Windows, была создана специальная папка Все задачи, содержащая Список задач всех программ. В финальных версиях Windows её так и не убрали, а поэтому и Вы можете воспользоваться ею для быстрого доступа к нужной Вам задаче.

    Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

    All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}

    Также Вы можете запустить её напрямую. Для запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win+R) и введите команду:

    shell:::{ED7BA470-8E54-465E-825C-99712043E01C}

    11. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows.
    Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
    Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

    1) Нажмите кнопку "Пуск",
    2) Перейдите в "Панель управления" и там выберите "Центр специальных возможностей".
    3) Выберите параметр "Использование компьютера без экрана" или "Облегчение сосредоточения"
    4) Находите «Как долго должны оставаться открытыми диалоговые окна уведомлений Windows?» и выставляете из выпадающего списка то время, которое Вам нужно.

    В выпадающем списке выберите подходящее для Вас значение.

    12. Использование рисунков из вложенных папок в окне "Фоновый рисунок рабочего стола".

    У многих пользователей есть папка, в которой они хранят различные необходимые им изображения. Назовем её, для примера, Pictures. Внутри этой папки, часто находятся вложенные папки, с разной тематикой рисунков.

    Если в настройках фонового рисунка рабочего стола, вызываемых:
    1) ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола
    2) Пуск\Панель управления\Все элементы панели управления\Персонализация\Фоновый рисунок рабочего стола
    Вы попытаетесь указать вашу папку Pictures, то далее увидите либо рисунки, находящиеся только в ней, либо надпись: «Нет элементов, удовлетворяющих условиям поиска», если в самой папке Pictures не будет рисунков. Так как подпапки поддерживаются только в системной папке C:\Windows\Web\Wallpaper, используемой Windows для хранения фоновых рисунков рабочего стола по умолчанию.

    Если же Вы хотите использовать собственную папку, с вложенными в неё подпапками и не менять значение системной папки находящийся в реестре(Win+R –> Regedit –> OK) по адресу:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\knownfolders\0\Windows Wallpapers\MergeFolders
    cо значения %SystemRoot%\web\wallpaper на Ваше собственное, к примеру: D:\Nickname\Pictures, то есть нужный Вам вариант решения.

    Вы можете создать новую библиотеку и добавить в неё Ваши папками.

    1) Открываете папку Библиотеки. У кого она удалена из проводника, тот может открыть её введя в адресную строку Windows Explorer:

    2) Нажимаете ПКМ -> Создать -> Библиотека
    3) Переименовываете её. Например: Обои для рабочего стола
    4) Щелкаете ПКМ и выбираете Свойства
    5) Добавляете отдельно каждую папку
    6) В графе Оптимизировать эту библиотеку: выбираете Изображения
    7) Нажимаете применить, затем Ок.
    8) После этого открываем раздел Персонализация –> Фон рабочего стола -> и в меню Расположение изображения с помощью кнопки Обзор... указываем путь к только что созданной нами библиотеке.

    Внимание: Вы можете спокойно удалить созданную Вами библиотеку из общего списка библиотек, что никак не повлияет на Ваши файлы. Однако если Вы удалите любой файл из папки, созданной Вами библиотеки- он также удалиться из системы(из той папки, в которой он находится).

    Для облегчения работы с библиотеками Вы можете воспользоваться программой Librarian. Librarian - это утилита управления библиотеками Windows 7.

    Программа расширяет стандартный функционал Windows 7 в области управления библиотеками.

    Её ключевые возможности:
    - Создание библиотеки из произвольного набора папок.
    - Смена значка библиотеки на выбранный пользователем. Вы можете задач значок библиотеки, используя стандартный диалог Windows, вызываемый при смене значка ярлыка.
    - Переименование библиотеки.
    - Указание типа содержимого новой или редактируемой библиотеки.
    - Смена папки, используемой по умолчанию для сохранения файлов в библиотеку.
    - Управление отображением библиотеки в панели навигации проводника.
    - Отображение библиотеки в виде XML-файла.
    - Отображение системного диалога папок, включенных в библиотеку.

    Скачать данную программу можно здесь или здесь

    13. Увеличение скорости работы USB-мыши, с помощью повышения опросов USB-порта.
    Вы любите играть в игры, где важна быстрота реакции, но Ваша USB-мышь не относится к классу игровых мышек - просто увеличьте частоту опросов USB мыши. Например: игровая мышь Logitech G7 имеет частоту опроса равную 530 MHz, а обычная 125 MHz.

    Для установки необходимы права локального администратора.

    1) Скачайте архив MouseRate.zip и распакуйте его в папку.
    2) Откройте папку Direct Input Mouse Rate и в ней запустите программу dimr.exe
    3) Подвигайте максимально быстро курсором Вашей мыши по экрану.
    4) Запомните значение из графы Peak - это максимальная величина опросов Вашей мышки.
    5) Откройте папку HIDUSBF
    6) Нажмите правой кнопкой мыши на файл HIDUSBF.INF и выберите пункт Установить.
    7) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
    8) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

    Если у Вас появится сообщение о неподписанных драйверах - не волнуйтесь, все нормально. Подпишем его программой Driver Signature Enforcement Overrider, о которой упоминалось в совете Как добавить подпись к драйверам? из раздела Установка. На время её работы UAC(Контроль учетных записей пользователей) в Windows должен быть отключен.

    1) Запустите файл dseo13b.exe из папки Driver Signature Enforcement Overrider и выберите там "Enable Test Mode".
    2) Перезапустите компьютер.
    3) После перезапуска снова откройте файл dseo13b.exe и выберите "Sign a system file".
    4) В окне пропишите: "C:\Windows\System32\Drivers\HIDUSBF.sys". Если вы сделали это правильно, то вы увидите сообщение: "Система была подписана успешно" ("The system file has been signed succesfully")
    5) Снова перезапустите компьютер.
    6) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
    7) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

    14. Перемещение системных папок и изменение их путей.

    Перенос системных папок лучше сделать сразу после установки Windows, до установки программ и драйверов, т.к. при установке драйверов и в особенности программ будут создаваться каталоги и ярлыки в эти самые системные папки. Если Вы используете для хранения файлов системные папки, то перенос системных папок пользователя на не системный диск, поможет Вам сохранить свои файлы. В случае сбоя Windows, при её переустановке заданные по умолчанию системные папки будут затерты полностью, со всеми находящимися в них файлами. Но если Вы зададите свои пути к системным папкам, то всё их содержимое останется целым.

    Раньше в предыдущих версиях Windows, чтобы переместить какую-либо системную папку или изменить её путь, Вам надо было править нужное Вам значение в одной из следующих веток реестра:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    Компания Microsoft понимая, что многие пользователи могут захотеть переместить свои системные папки, упростила пользователям эту задачу, избавив их от надобности редактировать реестр. Для перемещения системных папок и изменения их путей продеайте следующее:

    1) Создайте новую папку, желательно с аналогичным перемещаемой папке наименованием.
    2) Откройте в Windows Explorer: Рабочий стол\Ваш Профиль (Например: Рабочий стол\Администратор)
    3) Щелкните правой кнопкой мыши на название папки, которую Вы собираетесь переместить (Например: Мои Документы) и выберите Свойства.
    4) Откройте вкладку Расположение
    5) Нажмите кнопку Переместить и укажите путь к созданной Вами новой папке
    6) Далее система спросит Вас: Переместить все файлы из старого расположения в новое? (Рекомендуемый ответ - Да)
    7) Соглашаетесь с новыми параметрами применяя их и выходите.
    8) Перезагружаете Компьютер.

    15. Скрытие выбранных дисков из окна папки "Компьютер".

    Если Вы используйте флэш-диск для ускорения работы системы (ReadyBoost) или у Вас установлен картридер который Вы используйте для чтения только одного типа карт, то у Вас может появится желание скрыть выбранные Вами диски из папки Компьютер. Чтобы сделать это Вы можете воспользоваться одним из предложенных ниже вариантов.

    Вариант 1.

    1) Откройте меню Пуск, введите в строке поиска gpedit.msc и нажмите Enter. (Win+R -> gpedit.msc )
    2) Перейдите по пути слева Конфигурация пользователя -> Административные шаблоны -> Компоненты Windows -> Проводник Windows..
    3) Щелкните дважды по параметру Скрыть выбранные диски из окна "Мой компьютер".
    4) Установите переключатель на значение Включить.
    5) В раскрывающемся списке выберите одну из предложенных комбинаций и нажмите ОК.

    Вариант 2.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр NoDrives типа DWORD
    4) Значение данного параметра обрабатывается Windows в двоичной системе исчисления, но указывается в реестре в десятичной или шестнадцатеричной.
    Для расчета двоичного значения воспользуйтесь таблицей.

    Z | Y | X | W | V | U | T | S | R | Q | P | O | N | M | L | K | J | I | H | G | F | E | D | C | B | A
0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0

    В данной таблице каждой букве соответствует цифра, которая может быть либо единицей, либо нулём. Единица означает "скрыть диск", ноль - "показать диск".
    Для получения числа в двоичной системе исчисления замените для диска который Вы желаете скрыть цифру 0 на цифру 1.

    Например, для скрытия дисков A, B, F, G заменив цифры с 0 на 1 получится следующий вид:

    Z | Y | X | W | V | U | T | S | R | Q | P | O | N | M | L | K | J | I | H | G | F | E | D | C | B | A
0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 1 | 0 | 0 | 0 | 1 | 1

    Так как значение параметра формируется Windows в двоичной системе исчисления, а для добавления в реестр Вам необходимо данное значение в шестнадцатиричной или десятиричной системе, то для преобразования значения из одной системы исчисления в другую воспользуйтесь калькулятором Windows.

    5) Запустите Калькулятор (Пуск -> Все программы -> Стандартные)
    6) В меню программы нажмите Вид и выберите значение Программист
    7) Установите переключатель в значение Bin
    8) Введите значение полученное с помощью таблицы. В моем примере это число 1100011.
    9) Установите переключатель в значение Dec
    10) Скопируйте полученное число(Правка -> Копировать или Ctrl+C) в буфер обмена или запомните его. В моем примере 99.
    11) Закройте калькулятор и вернитесь в редактор реестра.
    12) Измените значение параметра NoDrives на полученное Вами в калькуляторе значение.

    12.1) Щелкните правой кнопкой мыши по параметру и выберите пункт Изменить...
    12.2) Установите переключатель на значение Десятичная
    12.3) В текстовое поле введите запомненное Вами число из калькулятора или нажмите Ctrl+V, если Вы копировали в буфер обмена.

    16. Добавление элементов в контекстное меню "Отправить".

    При попытке открыть более 15 элементов сразу используя меню, вызываемое правой кнопкой мыши в Проводнике, пункт меню Открыть пропадет. Если Вам необходимо открыть большее количество элементов одновременно, то Вы можете сделать это добавив нужную Вам программу в контекстное меню "Отправить".
    Чтобы добавить свою программу в контекстное меню "Отправить". Сделайте следующее:

    1) Откройте папку C:\Users\UserName\AppData\Roaming\Microsoft\Windows\SendTo , где UserName - Ваше имя пользователя.
    Также Вы можете открыть данную папку так:
    1.1) В адресной строке Проводника введите команду shell:SendTo и нажмите Enter.
    1.2) Нажмите Win+R, введите команду shell:SendTo и нажмите Enter.
    2) Создайте в открывшейся папке ярлык для необходимой Вам программы:
    2.1) Используйте меню, вызываемое правой кнопкой мыши. Создать -> Ярлык -> Укажите расположение программы -> Введите имя ярлыка
    2.2) Удерживая нажатой клавишу Alt скопируйте Вашу программу в вышеуказанную папку и переименуйте ярлык.

    17. Быстрое добавление своего ярлыка папки или программы в папку Компьютер.

    Скопируйте необходимый Вам ярлык в папку C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Windows\Network Shortcuts
    где Имя пользователя - это имя Вашей учетной записи (Например: Администратор).

    18. Замена элементов в диалоговом окне открытия/сохранения файлов.

    Вы можете заменить стандартные папки из диалогового окна открытия/сохранения файлов на указанные Вами.

    1) Откройте меню Пуск
    2) В строке поиска введите gpedit.msc
    3) Откройте папку Конфигурация пользователя\Административные шаблоны\Компоненты Windows\Проводник Windows.\Общее диалоговое окно открытия файлов
    4) Сделайте двойной щелчок мышью на Элементы, отображаемые в панели мест
    5) Установите переключатель на значение Включить
    6) Введите в текстовых полях напротив Элементов, пути к папкам и нажмите ОК.
    Для добавления папки Рабочий стол необходимо ввести: shell:desktop

    19. Изменение настроек режима самовосстановления для повышения производительности Windows.

    Если Вы периодически, не реже раза в неделю, делаете проверку файловой системы и пустого дискового пространства используя утилиту CHKDSK, то возможно Вас заинтересует изменение настроек режима самовосстановления. Это изменение позволит Вам повысить производительность Вашей операционной системы, путем высвобождения ресурсов затрачиваемых на данный режим.

    1) Запустите командную строку (Win+R -> cmd -> OK)
    1.1) Нажмите кнопку Пуск и введите в строке поиска cmd
    1.2) Щелкните правой кнопкой мыши на найденном файле и выберите пункт "Запуск от имени администратора"
    2) Проверьте состояние функции самовосстановления, для этого введите в командной строке и нажмите Enter:

    Где ИМЯ_ДИСКА - буква присвоенная жесткому диску или одному из его разделов. Например:

    3) Включите режим отображения системой BSOD (синего экрана смерти) при обнаружении программой CHKDSK ошибки. Данное действие необходимо для получения возможности смены режима самовосстановления. Введите в командной строке и нажмите Enter:

    4) Перезагрузите компьютер.
    5) Снова запустите командную строку от имени администратора.
    6) Переключите режим общего восстановления, в режим однократной проверки ошибок при первом случае повреждения. Для этого введите в командной строке и нажмите Enter:

    7) Отключите режим отображения системой BSOD (синего экрана смерти) при обнаружении программой CHKDSK ошибки. Для этого введите в командной строке и нажмите Enter:

    8) Перезагрузите компьютер.

    Вы можете отключить функцию самовосстановления как у отдельных дисков (разделов), так и у всех сразу, повторив приведенный выше порядок действий для каждого из них. Данное решение работает только с дисками отформатированными в файловую систему NTFS.

    Внимание. Побочным эффектом при выборочном отключении проверки (на отдельных дисках) может быть срабатывание защитного антивирусного программного обеспечения.

    20. Изменение стандартной мелодии запуска Windows 7.

    В предыдущих версий Windows, стандартная мелодия запуска находилась в папке C:\Windows\Media.
    В операционной системе Windows 7 стандартная мелодия запуска содержится в файле библиотеки: imageres.dll, находящемся в папке C:\Windows\System32
    Для изменения данного файла воспользуйтесь программами: Restorator или PE Explorer.
    Перед изменением файла убедитесь, что у Вас очищена папка C:\Windows\rescache

    В программе PE Explorer:

    1) Откройте файл imageres.dll
    2) Нажмите комбинацию клавиш Ctrl+R или перейдите в меню View -> Resources
    3) Откройте папку WAVE, щелкните правой кнопкой мыши на ресурс 5080 и выберите пункт Edit Resource
    4) В открывшемся окне нажмите комбинацию клавиш Ctrl+O или на значок папки со стрелочкой.
    5) Выберите мелодию в формате WAV для замены, после нажмите ОК, а затем Yes

    В программе Restorator:

    1) Откройте файл imageres.dll
    2) Откройте папку WAVE и перетяните на ресурс 5080 файл, которым Вы хотите заменить мелодию запуска.
    3) Сохраните внесенные изменения нажав Ctrl+S

    21. Отключение Журналирования для ускорения работы диска и освобождения дискового пространства.

    Чтобы отключить журналирования для диска, сделайте следующее:

    1) Запустите командную строку (Win+R -> cmd -> OK)
    2) Введите в командной строке:

    где H: - буква диска для которго необходимо отключить журналирование.

    Если возникнет необходимость включить журналирование опять, то сделать сделайте следующее:

    1) Запустите командную строку (Win+R -> cmd -> OK)
    2) Введите в командной строке:

    22. Распределение файла подкачки между несколькими жесткими дисками для увеличения производительности системы.

    Файл подкачки (Pagefile.sys) — это скрытый файл на жестком диске компьютера, который используется системой Windows по принципу оперативной памяти. Файл подкачки и физическая память вместе составляют виртуальную память. По умолчанию Windows хранит файл подкачки в разделе, в котором установлена операционная система.
    Рекомендуемый размер файла подкачки должен быть примерно в 1,5 - 3 раза больше общего объема оперативной памяти.

    Если у вас установлено 2 (или более) жестких диска,то для повышения быстродействия работы системы оптимальным решением будет создание одного файла подкачки в загрузочном разделе, а второго — в разделе, который используется реже (на другом жестком диске, если такой имеется). Кроме того, для второго файла подкачки по возможности лучше всего отвести отдельный раздел, где нет других данных и системных файлов. Система в первую очередь использует файл подкачки из менее загруженного раздела (а не файл подкачки из загрузочного раздела, количество обращений к которому намного больше).

    По умолчанию система использует файл подкачки динамически, то есть размер файла изменяется автоматически, в зависимости от текущей потребности операционной системы. В большинстве же случаев наилучшая производительность системы достигается при статическом размере файла подкачки, так как это не требуется каждый раз изменять размер файла подкачки, что снижает его фрагментацию.

    Учитывая описанное выше сделайте следующее:

    1) Откройте Панель управления -> Система.
    2) Слева в списке нажмите ссылку Дополнительные параметры системы.
    3) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
    4) Откройте вкладку Дополнительно и в разделе Виртуальная память нажмите кнопку Изменить.
    5) Снимите флажок Автоматически выбирать объем файла подкачки.
    6) Выберите диск, на котором Вы хотите создать файл подкачки.
    7) Установите переключатель в значение Указать размер
    8) Введите в поля Исходный размер (МБ) и Максимальный размер (МБ) одинаковые размеры создаваемого файла подкачки в мегабайтах, равного величине в 1,5 - 3 раза больше общего объема оперативной памяти.
    9) Нажмите кнопку Задать,
    10) Выберите следующий диск и проделайте указанные выше операции, после чего нажмите кнопку ОК.
    11) Перезагрузите компьютер.

    23. Регистрация необходимых и выгрузка из памяти неиспользуемых библиотек (dll-файлов).

    Чтобы загрузить в память определенную библиотеку (dll-файл) Вам необходимо ее зарегистрировать. Для того, чтобы это сделать введите команду:

    Если dll-файл расположен в системной папке (System32), то:

    Например:

    Если dll-файл расположен не в системной папке, то:

    Например:

    Чтобы выгрузить из памяти определенную библиотеку (dll-файл) Вам необходимо отменить ее регистрацию.

    Если dll-файл расположен в системной папке (System32), то:

    Например:

    Если dll-файл расположен не в системной папке, то:

    Например:

    Если Вам необходимо освободить часть оперативной памяти, то Вы можно сделать это добавив в реестр параметр, отвечающий за автоматическую выгрузку из памяти неиспользуемых библиотек.

    1) Запустите редактор реестра (Win+R->regedit->ОК)
    2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer
    3) В меню Правка выберите Создать -> Параметр DWORD (32 бита).
    4) Задайте имя параметра AlwaysUnloadDll
    5) Дважды щелкните на данном параметре и введите значение 1.
    6) Закройте редактор реестра и перезапустите компьютер.

    Виртуализация

    1. Работа с виртуальными жесткими дисками (VHD-файлами) в Windows 7.

    VHD (Virtual Hard Disk) - это формат файлов, используемых виртуальными машинами для эмуляции жесткого диска. Вы сможете создать себе виртуальный диск и использовать его для хранения виртуальных операционных систем, программ и других файлов в одном файле-образе, который можно открыть различными программами виртуализации или виртуальными машинами. Виртуальные жесткие диски позволяют нескольким операционным системам одновременно находиться на одном компьютере.

    Вариант 1. Работа с виртуальными дисками используя графический интерфейс.

    Создание виртуального жесткого диска.

    1) Откройте меню Пуск.
    2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win+R) введите diskmgmt.msc и нажмите Enter.
    3) Откроется оснастка "Управление дисками". В панели меню выберите пункт Действие и нажмите на Создать виртуальный жесткий диск

    Рисунок 1 из 13

    4) В открывшемся окне укажите:

    Рисунок 2 из 13

    4.1) Имя файла и его расположение. Вы можете как написать это вручную, так и нажав на кнопку Обзор и воспользовавшись диалоговым окном Просмотр файлов виртуального диска
    4.2) Размер виртуального диска. Возле текстового поля, в которое нужно ввести размер диска, присутствует раскрывающийся список, где можно выбрать размер жесткого диска. Доступные значения – мегабайты, гигабайты и терабайты. Создайте размер не меньше 20 ГБ.
    4.3) Тип виртуального диска. Динамически расширяемый дисковый образ обеспечивает объем пространства, необходимый для хранения данных.
    Размер VHD-файла в момент создания диска небольшой, но увеличивается по мере добавления данных на диск. Распределение данных осуществляется в блоках. При удалении данных с виртуального жесткого диска размер VHD-файла автоматически не уменьшается. Фиксированный размер создает VHD-файл, размер которого задается при создании виртуального жесткого диска. Размер VHD-файла остается постоянным независимо от объема хранимых данных.
    5) Нажмите на кнопку «ОК».

    Чтобы диспетчер локальных дисков смог получить доступ к созданному Вами виртуальному диску его необходимо инициализировать и создать на нем простой том. Для этого также используется оснастка "Управление дисками".

    Инициализация виртуального жесткого диска.

    1) Найдите Ваш виртуальный диск и щелкните на нем правой кнопкой мыши
    2) Нажмите на пункт Инициализировать диск

    Рисунок 3 из 13

    3) Выберите стиль разделов - MBR и нажмите OK

    Рисунок 4 из 13

    Создание простого тома на виртуальном жестком диске.

    После того как Вы проинициализировали Ваш виртуальный диск, на нем необходимо создать простой том.

    1) Найдите Ваш виртуальный диск и щелкните на нераспределенной области справа от него
    2) Нажмите на пункт Создать простой том

    Рисунок 5 из 13

    3) В первом диалоге Мастера создания простого тома нажмите на кнопку Далее
    4) В диалоге указания размера тома, укажите размер будущего тома в мегабайтах и нажмите на кнопку Далее

    Рисунок 6 из 13

    5) В диалоге Назначение буквы диска или пути укажите букву для будущего диска и нажмите на кнопку Далее

    Рисунок 7 из 13

    6) В диалоге Форматирование раздела укажите нужную файловую систему, размер кластера, название диска и установите флажок возле опции Быстрое форматирование - для того, чтобы диск был сразу отформатирован. После чего нажмите на кнопку Далее

    Рисунок 8 из 13

    7) Для принятия всех настроенных параметров в диалоге Завершение мастера создания простого тома нажмите на кнопку Готово.
    8) Виртуальный диск появится в таблице дисков. В оснастке управления дисками, значок виртуального диска визуально отличается от значков физических дисков. В проводнике Windows виртуальные диски выглядят так же, как и физические.

    Рисунок 9 из 13

    Присоединение виртуального жесткого диска.

    Если у Вас уже имеется созданный виртуальный жесткий диск, то Вы также можете присоединить его в оснастке "Управление дисками".

    1) Откройте меню Пуск.
    2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win+R) введите diskmgmt.msc и нажмите Enter.
    3) В панели меню выберите пункт Действие и нажмите на Присоединить виртуальный жесткий диск.

    Рисунок 10 из 13

    4) Укажите расположение для виртуального жесткого диска на компьютере и нажмите OK Указать расположение Вы можете либо введя значение вручную, либо нажав на кнопку Обзор, и используя диалоговое окно Просмотр файлов виртуального диска. Если Вам не нужно записывать данные на диск, то в этом диалоге можно установить флажок Только для чтения.

    Рисунок 11 из 13

    Отсоединение (удаление) виртуального жесткого диска.

    1) Найдите виртуальный диск, который хотите отсоединить, нажмите на нем правой кнопкой мыши
    2) Нажмите на пункт Отсоединить виртуальный жесткий диск

    Рисунок 12 из 13

    3) Если Вы желаете отсоединить виртуальный диск без удаления его из системы, то нажмите OK. Для полного удаления диска из системы, отметьте Удалить виртуальный диск после удаления диска и после этого нажмите OK.

    Рисунок 13 из 13

    Вариант 2. Работа с виртуальными дисками используя программу Diskpart в командной строке.

    Создание виртуального жесткого диска.

    1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
    2) В командной строке наберите Diskpart и нажмите Enter
    Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
    3) Для создания виртуального диска воспользуйтесь командой Create Vdisk. Синтаксис команды следующий:

    Где:

    File=<"имя_файла"> - Указание полного пути и имени файла виртуального диска.
    Maximum=<n> - Максимальное дисковое пространство, предоставляемое виртуальным диском, заданное в мегабайтах (МБ).
    [Type={Fixed|Expandable}] - Используется для указания формата виртуального диска. Существует два значения для данного параметра:
    Fixed создает файл виртуального диска фиксированного размера;
    Expandable создает динамически расширяемый образ виртуального диска.
    [Source=<"имя_файла">] - Путь к существующему файлу виртуального диска для предварительного заполнения нового файла виртуального диска. При использовании параметра Source данные из исходного файла виртуального диска копируются блок за блоком в создаваемый файл виртуального диска. Если Вы при копировании динамического диска не укажете параметр Type=Expandable, то копия будет создана максимального размера выделенного для исходного диска, независимо от его текущего размера.

    Примеры использования команды:

    Рисунок 1 из 3

    Присоединение виртуального жесткого диска.

    1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
    2) В командной строке наберите Diskpart и нажмите Enter Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
    3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk. Синтаксис команды следующий:

    Пример использования команды:

    4) Для присоединения выбранного виртуального диска воспользуйтесь командой Attach Vdisk. Синтаксис команды следующий:

    [Readonly] - Присоединяет виртуальный диск в режиме только для чтения. Любая операция записи приведет к возникновению ошибки ввода-вывода устройства.
    [Usefilesd] - Указывает, что для виртуального диска следует использовать дескриптор безопасности самого виртуального файла. Если параметр не указан, то у диска не будет явно заданного дескриптора безопасности, если не был также задан параметр SD=(строка SDDL).
    [SD=<строка sddl>] - Задает дескриптор безопасности в формате SDDL. По умолчанию дескриптор безопасности обеспечивает доступ, аналогичный любому физическому диску. Дополнительные сведения о формате строки SDDL см. в справке по команде Create Vdisk.

    Примеры использования команды:

    Рисунок 2 из 3

    Отсоединение виртуального жесткого диска.

    1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
    2) В командной строке наберите Diskpart и нажмите Enter
    Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
    3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk.
    4) Для отсоединения выбранного виртуального диска воспользуйтесь командой Detach Vdisk.

    Рисунок 3 из 3

    2. Создание загрузочного образа ISO Windows 7 из VHD-образа + интеграция LIP.

    Для работы нам потребуются программа DISM, входящая в состав Windows 7, либо включенная в WAIK, GimageX (русская старая) или GimageX (английская новая), WinImage и ERD Commander для x86 или x64

    Вариант 1

    1) Создайте на диске C: папки DVD, VHD, Lip, Mount, Temp и mWim
    2) Запускаете утилиту WinImage, открываете в ней VHD-образ. В открывшемся диалоге щелкаете ОК. Выделяете справа все файлы и щелкаете на выделенном правой кнопкой. Выбираете Extract, затем щелкаете Browse и выбираете папку VHD. Чуть ниже выбираете Extract with pathname. Ждете завершения процесса распаковки. Если появится ошибка, просто нажимаете продолжить.

    Рисунок 1 из 5

    3) Распакуйте образ дистрибутива(ваш ISO), с помощью программы архиватора 7zip в папку C:\DVD
    4) Скопируете в папку C:\Lip файл lp.cab и создайте в ней подпапку uLip
    5) Запустите командную строку от имени администратора (Win+R -> cmd -> Ok)
    6) Распакуйте lp.cab в папку C:\Lip\uLip выполнив в консоли команду:

    7) При помощи GimageX узнаете индекс Ultimate

    Рисунок 2 из 5

    8) Экспортируйте из файла install.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 5 для x86 или 4 для x64) как install.wim

    Рисунок 3 из 5

    9) При помощи GimageX узнаете индекс Microsoft Windows Setup (x64)

    Рисунок 4 из 5

    10) Экспортируйте из файла boot.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 2) как boot.wim

    Рисунок 5 из 5

    11) Перезагрузите компьютер.
    Примечание: Комманды DISM Вы можете также выполнять в командной строке ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
    12) Запустите командную строку от имени администратора (Win+R -> cmd -> Ok)
    13) Монтируете файл C:\mWim\install.wim в папку C:\Mount выполнив в консоли команду:

    14) Интегрируете LIP в install.wim

    15) Применяете все настройки для русского языка командой:

    16) Копируете все файлы и папки из C:\VHD в C:\Mount, кроме папки C:\VHD\Boot и файла C:\VHD\bootmgr (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer)
    17) Демонтируете install.wim с сохранением изменений из C:\Mount:

    18) Монтируете файл C:\mWim\boot.wim в папку C:\Mount

    19) Добавляете в boot.wim русский язык:

    20) Добавляете в boot.wim файлы лицензий:

    21) Правите текст файла (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\Mount\sources\lang.ini

    22) Демонтируете boot.wim с сохранением изменений из C:\Mount:

    23) Правите текст файла (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\lang.ini, в котором должно быть следующее:

    24) Заменяете файл (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\install.wim в дистрибутиве, файлом C:\mWim\install.wim
    25) Заменяете файл (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\boot.wim в дистрибутиве, файлом C:\mWim\boot.wim
    26) Перезагружаетесь в Windows
    27) Открываете с помощью UltraISO образ дистрибутива. Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
    28) Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
    29) Сохраняете в другое место или под другим именем.

    Вариант 2

    1) Открываете меню Пуск, в поле поиска пишите diskmgmt.msc и нажимаете Enter
    2) В верхнем меню нажимаете Действие -> Присоединить виртуальный жесткий диск.
    3) Указываете местонахождение VHD-образа, жмете ОК

    Рисунок 1 из 2

    4) Выбираете нужную вам букву для данного диска
    5) Установите Windows AIK
    6) Запустите программу GImageX и укажите в параметрах как на рисунке:

    Source: - путь к виртуальному диску
    Destination - путь куда будет сохранен готовый install.wim файл
    Name - Имя образа (Windows 7 Ultimate)
    Description - Описание образа (Windows 7 Ultimate)
    Compression - Сжатие полученного install.wim файла (Maximum)

    Рисунок 2 из 2

    7) Открываете с помощью UltraISO образ дистрибутива Windows 7
    8) Удаляете в папке \Sources файл install.wim
    9) Добавляете созданный вами новый install.wim вместо старого.
    10) Сохраняете образ под новым именем.
    11) Записываете образ на USB флеш-накопитель (флешку) или DVD.

    Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программой DISM Tool. Данная программа позволяет выполнять, все необходимые Вам команды, используя графический интерфейс. С помощью неё Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(используйте пункт Add Packages).

    3. Установка и загрузка Windows 7 из VHD-файла.

    Вариант 1

    Первое, что потребуется - это сам VHD-образ. Второе - необходимо подготовить логический диск. Вы можете воспользоваться любым диском, на котором не установлено никакой другой операционной системы, и на котором имеется 15-25 Гб свободного места. Третье, это утилита WinImage.

    1) Запускаете утилиту WinImage.
    2) Открываете в Winimage Ваш VHD-образ.
    3) В открывшемся диалоге нажимаете ОК.
    4) Выделяете справа все файлы
    5) Нажимаете на выделенном правой кнопкой мыши и выбираете Extract
    6) Нажимаете Browse и выбираете предварительно подготовленный диск.
    7) Ниже выбираете Extract with pathname. Ждете завершения процесса распаковки.
    8) После завершения распаковки скачиваете утилиту EasyBCD.
    9) В окне приложения нажимаете Add/Remove Entries
    10) В поле Add entries выбираете имя для Вашей новой ОС (к примеру, Windows 7 - VHD)
    11) Указываете тип (Windows Vista/7)
    12) Выбираете диск, на который Вы извлекли содержимое образа.
    13) Нажимаете Add entry, а затем вверху нажимаете Save. В списке ОС теперь должно быть два пункта.
    14) Заходите в раздел Change Settings
    15) Выбираете в качестве ОС, загружаемой по умолчанию, Windows 7 - VHD.
    16) Нажимаете Save settings и перезагружаете компьютер.

    Вариант 2 как основная система.

    1) Создаем папку VHD на любом разделе диска. Открываем VHD-образ утилитой WinImage, выделяем справа все файлы и щелкаем на выделенном правой кнопкой. Выбираем Extract, затем щелкаем Browse и выбираем папку VHD. Незабываем выбрать Extract with pathname. Ждем завершения распаковки.
    2) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
    3) Выбираем Micosoft Diagnostics and Recovery Toolset -> Explorer и удаляем все файлы с диска C:\ (Диск с уже установленной Windows 7). Процесс может быть длительным, ждите.
    4) Переносим все файлы из папки VHD на диск C:/. Папка VHD-> выделяем все файлы-> щелкаем правой кнопкой-> параметр move to-> выбираем диск С:\
    5) Удаляем папку VHD.
    6) Перезагружаемся снова в ERD. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажимаем repair and restart (исправить и перезагрузиться).
    7) Радуемся установленной Windows 7.

    Вариант 3 как вторая система.

    Способ 1. Автоматически.

    1) Создайте папку VHD на любом разделе диска.
    2) Откройте VHD-образ утилитой WinImage.
    3) Выделите справа все файлы, щелкните на выделенном правой кнопкой мыши и выберите Extract.
    4) Щелкните Browse и выберите папку VHD. Не забудьте выбрать Extract with pathname. Дождитесь завершения распаковки.
    5) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. (Создание образа ERD описано в разделе Разное в совете №9.)
    6) Выберите Micosoft Diagnostics and Recovery Toolset -> Explorer и удалите все файлы с диска C:\ (Диск с уже установленной Windows 7). Процесс может быть длительным, ждите.
    7) Перенесите все файлы из папки VHD на диск C:/. Папка VHD -> выделите все файлы -> щелкните правой кнопкой -> параметр move to -> выберите диск С:\
    8) Удалите папку VHD.
    9) Перезагрузитесь снова в ERD Commander. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажмите repair and restart (исправить и перезагрузиться).
    10) После перезагрузки нам станет доступен выбор из двух ОС. Нас интересует вторая Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено). Выберите её и ждите пока закончится настройка системы.
    В процессе, компьютер будет два раза перезагружен, не забывайте после каждой перезагрузки выбирать вторую ОС Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено).
    11) Если загружаетесь через Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено) , то диск с основной ОС будет недоступен (при загрузке через основную ОС диски доступны все). Если хотите сделать этот диск доступным, воспользуйтесь встроенной утилитой Disk Management (Выполнить -> compmgmt.msc). Открыв Disk Management, Вы увидите что у раздела с основной ОС не назначена буква. Щелкните правой кнопкой мыши на диске, выберите Change Drive Letter and Paths, нажмите Add, выберите любую букву для диска, ОК, диск доступен.

    Способ 2. В ручную без Winimage, при помощи программы Bcedit.

    Для данного способа используйте программу bcedit, входящую в состав средств Windows или средств Восстановления.

    1) Запустите командную строку от имени администратора в Windows или в командной строке средств Восстановления, или в Erd Commander (при запуске необходимо выбрать текущую систему). Все дальнейшие команды вводите в командной строке.
    2) При помощи указанной команды, скопируйте существующую запись текущей системы с новым названием:

    3) Дожидаетесь сообщения «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
    Указанный в данном сообщении буквенно-цифровой код, подставляйте в команды, указанные ниже вместо {ID}:
    4) Укажите раздел, на котором расположены файлы загрузки (device) и раздел, на котором расположены системные файлы операционной системы (osdevice). Так как у нас виртуальный диск, то значения параметров device и osdevice будут равны.

    где X:\DIR\filename.vhd – полный путь к файлу VHD и указание имени файла.
    5) Для форсирования автоматического определения в Windows диска через соответствующий уровень абстракции — Hardware Abstraction Layer (разрешать ли операционной системе ускоренное автоматическое определение версии HAL и файла ядра при загрузке), выполните следующую команду:

    6)Установите добавленную систему на последнее место в списке загрузок

    7) Перезагрузите компьютер

    Если посмотреть на диски, присутствующие в системе, будет видно, что помимо виртуального диска на 16 Гб (обведен оранжевым), с которого, собственно, загружена Windows 7, также присутствуют второй раздел виртуального диска на 200 Мб под системные файлы и реальный(!) жесткий диск, установленный на компьютере. Если открыть диск, где ранее располагался vhd-файл, то можно обнаружить, что его размер увеличился до тех самых 16Гб, причем размер этот теперь строго ограничен.

    Некоторые сайты также советуют внести в листинг menu.lst(должен появится при загрузке компьютера) следующие изменения:

    4. Установка Windows 7 на виртуальный диск в VHD-файл.

    Установив систему на виртуальный диск, в один VHD-файл, Вы получаете такие преимущества по сравнению с обычной системой:
    - сможете сделать копию операционной системы просто скопировав VHD-файл
    - сможете тестировать бета версии программ, не беспокоясь за систему
    - сможете изучать систему, экспериментировать с реестром, не боясь её испортить.

    1) Вставьте установочный диск Windows 7 в привод, загрузитесь с него
    2) Доходите до шага мастера установки, где Вас просят выбрать или создать тот раздел диска, на который будет установлена Windows 7.
    3) Нажмите комбинацию клавиш "Shift+F10".
    Это сочетание клавиш предоставит доступ к командной строке. Напечатайте в ней Diskpart и нажмите Enter.
    Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
    3) Введите в DISKPART следующую команду:

    Она означает - создать файл win7.vhd расширяемого типа, максимальный размер ограничить 30 Гигабайтами. Замените E: на имя диска, на котором вы хотите хранить создаваемый файл.

    4) Смонтируйте VHD-файл, чтобы он был доступен программе установки:

    5) После успешного выполнения всех операций, набираете команду exit для выхода из утилиты diskpart, и еще раз команду exit – уже в приглашении CMD.EXE для закрытия командной строки.

    Рисунок 1 из 2

    6) Вы снова окажетесь в окне Выберите раздел для установки.
    7) Нажмите кнопку Обновить, расположенную под списком дисков и Вы увидите Ваш новый диск
    8) Так как на нем ещё нет разделов, то будет написано Незанятое место на диске...
    9) Выберите его и нажмите Настройка диска
    10) Щелкните на кнопке "Создать", укажите объем создаваемого радела и щелкните на кнопке "Применить".
    11) Ещё раз убедитесь, что Вы выбрали созданный Вами виртуальный диск и нажмите Далее, игнорируя предупреждение: Невозможно установить Windows на диск...

    Рисунок 2 из 2

    Процесс установки Windows 7 на раздел VHD-диска продолжится так, как будто это обычный логический раздел жесткого диска. При этом будет не только установлена новая ОС, но и подменен загрузчик на "физическом" системном разделе для успешного старта с VHD. При установке Windows 7 на "чистую" систему, мастер установки автоматически создаст на диске системный раздел в 100МБ, на котором помещается загрузчик, а уже для самой системы создаст отдельный раздел.

    5. Конвертирование тома жесткого диска в VHD-файл.

    Для создания VHD-файлов из томов жесткого диска, Вам необходимо воспользоваться утилитой Disk2vhd. Она позволяет создать VHD-образ прямо с запущенной операционной системы. Для своей работы, программа использует Модуль теневого копирования тома (Volume Snapshot), являющийся функцией используемой операционной системой для создания последовательных снимков томов на определенный момент времени. Таким образом, Вы сможете создать VHD-файл прямо на том же разделе, который в него упаковываете. При создании VHD-файла, программа включает в него только системный том и исключает разделы с данными.

    Созданный утилитой виртуальный диск может быть подключен к виртуальной машине как IDE-диск. Не используйте VHD-файл, для загрузки через менеджер загрузки Windows 7 на реальной машине. Windows специальным образом подписывает жесткие диски, и присваивает VHD-диску новый уникальный идентификатор. При попытке загрузки с VHD система выдаст ошибку об отсутствии загрузочного диска или просто перезагрузится без уведомления пользователя. Но при использовании данного VHD-образа в Virtual PC, система отлично стартует и работает.

    Для работы с Вашим VHD-файлом Вы также можете использовать оснастку Управление дисками (diskmgmt.msc).
    Если снимаете образ системного диска, и у вас есть раздел восстановления (System Reserved), не забудьте включить его в VHD-образ, так как без него система не загрузится. Для создания VHD-файла сделайте следующее:

    1) Скачайте программу Disk2vhd
    2) Разархивируйте скачанный архив и запустите Disk2vhd
    3) В поле под VHD File name укажите путь и имя создаваемого Вами VHD-файла.
    4) Установите флажки напротив томов жесткого диска, которые необходимо включить в создаваемый Вами VHD-файл.
    5) Нажмите Create

    Для создания скриптов утилита поддерживает командную строку:

    Укажите какие тома необходимо включить в VHD-файл или используйте * для конвертирования всех томов.

    6. Конвертирование DVD-образа Windows 7 в VHD-файл.

    Для конвертирования DVD-образа Windows 7 в VHD-файл, Вам потребуются Набор автоматической установки Windows (AIK) для Windows 7 (Размер скачиваемого файла 1,25 ГБ и инструмент командной строки WIM2VHD

    WIM2VHD - это сценарий Windows Scripting Host, предназначенный для использования в командной строке и позволяющий создать аппаратно-независимый VHD-файл из инсталляционного диска Windows 7, при инициализации которого система минует стадию начальной загрузки и распаковки файлов и будет готова к определению оборудования компьютера, на котором она запущена.

    Суть метода заключается в преобразовании файла install.wim в VHD-файл.

    1) Установите Набор автоматической установки Windows (AIK) для Windows 7
    2) Поместите скаченный файл WIM2VHD.WSF в папку C:\Program Files\Windows AIK\Tools\x86\, если используете 32-разрядную систему, или в C:\Program Files\Windows AIK\Tools\amd64\, если 64-разрядную.
    3) Запустите командную строку с правами администратора, для чего нажмите "Пуск", в поле поиска введите cmd.exe и нажмите Ctrl+Shift+Enter.
    4) Перейдите в папку со скриптом используя команду CD . Например:

    Для 32-битной Windows:

    Для 64-битной Windows:

    Измените пути на соответствующие Вашей системе.

    5) Запустите скрипт wim2vhd. Для этого, введите в командной строке следующее:

    Командная строка расшифровывается так:
    Взять файл h:\sources\install.wim, и редакцию Ultimate преобразовать в e:\vhd\win7.vhd

    Рисунок 1 из 1

    7) Для подключения полученного VHD-файла к имеющемуся загрузчику Windows 7, используйте команду:

    Команда дублирует загрузочную запись текущей запущенной Windows 7. Вместо "Windows 7 Virtual" Вы можете написать любое значение.

    8) Bcdedit выведет на экран {GUID} только что созданной записи-дубликата - скопируйте его в буфер обмена и используйте для внесения VHD-файла в опции загрузки:

    Для информации: Работа скрипта WIM2VHD базируется на использовании утилиты imagex.exe из WAIK. Другие примеры использования скрипта WIM2VHD описаны здесь.

    7. Включение Aero Glass в Windows на Virtual PC.

    1. Установить Windows 7 на компьютер, к которому вы будете отдалённо получать доступ (VM).
    2. Установить Windows 7 на компьютер, с которого вы будете отдалённо получать доступ (host).
    3. Сборка Windows 7 на обоих должна быть одинаковой, чтобы всё работало корректно.
    4. Компьютер, к которому вы будете получать доступ, должен иметь графический адаптер, поддерживающий Glass, который должен быть включен.
    5. Установить Сетевое соединение между двумя компьютерами.

    На VM нужно активировать Remote Desktop (не забудьте разрешить доступ приложения в Брандмауэре)
    С компьютера host запустите Remote Desktop, введите имя или IP адрес VM. Если вы хотите настроить размер окна, глубину цвета, скорость соединения, то заходите в соответствующие настройки.
    Нажмите Connect и вводите логин.

    Сессия Remote Desktop стартует, и рабочий стол VM будет показывать DWM эффекты.

    В итоге, это не совсем Glass, но этот эффект возможно сделать так, чтобы он выглядел, как Glass, используя разработки команды Remote Desktop.

    8. Установка Windows 7 в виртуальную машину VirtualBox.

    VirtualBox - специальная программа для создания в памяти ПК виртуальных компьютеров. Каждый виртуальный компьютер может содержать произвольный набор виртуальных устройств и отдельную операционную систему. Область применения виртуальных компьютеров очень широка - от выполнения функций по тестированию ПО до создания целых сетей, которые легко масштабировать, распределять нагрузку и защищать. VirtualBox распространяется бесплатно, с открытым исходным кодом.

    1) Скачайте последнюю версию программы VirtualBox с официального сайта: http://www.virtualbox.org/wiki/Downloads
    2) Установите ее на свой компьютер.

    2.1) Запустите установщик; В первом окне нажмите Next
    2.2) Выберите необходимые Вам компоненты для установки и нажмите пункт Next.
    2.3) Нажмите Next, а затем Yes для начала установки.
    2.4) Нажмите на кнопку Install. Внимание: После нажатия кнопки Install произойдет разрыв связи с сетью (как локальной, так и Интернет)
    2.5) В появляющихся окнах Установить программное обеспечение для данного устройства? нажмите на кнопку Установить
    2.6) В последнем окне оставьте флажок, чтобы приступить к созданию виртуальной машины сразу или уберите флажок для создания виртуальной машины позднее. Нажмите кнопку Finish. Если Вы убрали флажок, то для запуска программы воспользуйтесь значком на рабочем столе.

    3) В главном окне программы нажмите на кнопке Создать. Откроется Мастер создания новой виртуальной машины. Нажмите кнопку Вперед.
    4) Введите имя виртуальной машины, в разделе Тип ОС установите значения:
    Операционная система: Microsoft Windows
    Версия: Windows 7.
    Нажмите кнопку Вперед.

    Рисунок 1 из 9

    5) Введите размер оперативной памяти, выделяемый для виртуальной машины.
    Внимание: Память будет выделяться из физической памяти установленной в Вашем компьютере. Не устанавливайте память ниже 512 Мегабайт и выше 50% от размера установленной физической памяти. Нажмите кнопку Вперед.
    6) Выберите загрузочный виртуальный жесткий диск. Установите переключатель в значение: Создать новый жесткий диск. Нажмите кнопку Вперед.

    Рисунок 2 из 9

    7) Откроется Мастер создания нового виртуального диска. Нажмите кнопку Вперед.
    8) Выберите тип виртуального жесткого диска. Динамический образ изначально займет немного места, и будет расширяться постепенно. Фиксированный образ сразу создаст диск указанного размера - это может занять продолжительное время. Нажмите кнопку Вперед.

    Рисунок 3 из 9

    9) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\.VirtualBox.
    Выберите размер виртуального жесткого диска. (По умолчанию 20 Гигабайт). Нажмите кнопку Вперед.

    Рисунок 4 из 9

    10) Нажмите на кнопку Готово и Вы вернетесь в предыдущее окно, где будут указаны параметры создаваемой Вами виртуальной машины. Нажмите на кнопку Финиш в окне Итог, и Вы создадите новую виртуальную машину.

    Виртуальная машина для установки на нее Windows 7 создана.

    Рисунок 5 из 9

    11) Перед началом установки Windows 7 на Вашу виртуальную машину ее необходимо настроить. Для настройки Вашей виртуальной машины нажмите на кнопку Свойства.
    12) В разделе настроек из списка слева выберите Дисплей. Установите размер видеопамяти, доступной для виртуальной машины не менее 26 Мегабайт. Поставьте флажки для элементов настроек Включить 3D-ускорение и Включить 2D-ускорение видео.

    Рисунок 6 из 9

    13) В разделе настроек из списка слева выберите Носители.
    14) Нажмите значок DVD-диска рядом с ниспадающим меню в графе Атрибуты.

    Рисунок 7 из 9

    Если у Вас установочный диск Windows 7 записан на DVD-диск, то вставьте его в DVD-привод и выберите привод с соответствующей буквой. Также установите флажок для Разрешить прямой доступ.
    Если у Вас установочный диск Windows 7 имеется в виде ISO-образа, то выберите пункт Выбрать образ оптического диска... нажмите на значок папки, чтобы открыть Менеджер виртуальных носителей
    15) В окне Выберите образ оптического диска выберите файл образа и нажмите Открыть. 16) Ваш образ добавится в дерево настроек Носители информации. Нажмите кнопку OK.

    Рисунок 8 из 9

    17) Вы окажетесь в основном окне программы. Нажмите на кнопку Старт
    18) Если появятся информационные окна, то нажмите в них на кнопку OK
    19) Щелкните кнопкой мыши внутри экрана виртуальной машины, и в информационном окне нажмите на кнопку Захватить
    20) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
    21) После завершения установки Windows 7 на виртуальную машину, VirtualBox сразу запустит Вам Windows 7 внутри виртуальной машины.

    22) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Right Control.
    Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Дополнения гостевой ОС. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Устройства -> Установить Дополнения гостевой ОС

    Рисунок 9 из 9

    23) Во всплывшем окне Автозапуск нажмите VBoxWindowsAdditions.exe и установите программу.
    23.1) В появляющихся окнах контроля учетных записей нажмите Да.
    23.2) Для перехода к каждому последующему шагу нажмите Next, для установки кнопку Install, для завершения Finish.
    23.3) В появляющихся окнах Установить программное обеспечение для данного устройства? нажмите на кнопку Установить
    24) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Машина -> Закрыть -> Выключить машину.
    25) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Старт.

    9. Установка Windows 7 в виртуальную машину Microsoft Virtual PC.
    Microsoft Virtual PC - это мощная программа, которая позволяет эмулировать на одном компьютере работу сразу нескольких виртуальных машин. Каждая из таких машин может находиться под управлением своей собственной операционной системы (Windows любой версии, Netware, Linux, Solaris и т.д.), выполнять уникальную задачу, иметь собственную конфигурацию и т.д.

    1) Скачайте последнюю версию программы Virtual PC с официального сайта:
    http://www.microsoft.com/downloads/details.aspx?familyid=28c97d22-6eb8-4a09-a7f7-f6c7a1f000b5&displaylang=en
    2) Установите программу. Внимание программа установки без предупреждения выключит соединение с сетью (как локальной, так и Интернет).
    3) Скачайте и установите обновление KB958162.msp для Virtual PC
    4) Запустите программу. Нажмите кнопку Пуск -> Все программы -> Microsoft Virtual PC
    5) В окне с надписью: "You are not running on a supported operating system" нажмите ОК.
    6) В окне New Virtual Machine Wizard нажмите кнопку Next. Данное окно Вы также можете запустить нажав кнопку New в Virtual PC Console или в меню File выбрать New Virtual Machine Wizard.

    Рисунок 1 из 7

    7) Установите переключатель на Create a Virtual Machine. Нажмите кнопку Next.

    Рисунок 2 из 7

    8) Выберите имя и расположение для файла Вашей виртуальной машины. По умолчанию имя файла New Virtual Machine, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\Documents\My Virtual Machines. Нажмите кнопку Next.
    9) Выберите тип операционной системы. В связи с отсутствием пункта Windows 7 в Virtual PC, выберите Windows Vista или Other. Нажмите кнопку Next.

    Рисунок 3 из 7

    10) Установите переключатель на Adjusting the RAM. Выберите необходимое Вам количество оперативной памяти выделяемое виртуальной машине, не менее 512 Мегабайт. Нажмите кнопку Next.

    Рисунок 4 из 7

    11) Установите переключатель на A new virtual hard disk, чтобы создать новый виртуальный образ. Нажмите кнопку Next.
    12) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, к котрой добавлено Hard Disk, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке:
    C:\Users\UserName\Documents\My Virtual Machines\ИмяВиртуальнойМашины\
    Укажите величину создаваемого вами виртуального жесткого диска в мегабайтах. Рекомендую указать 20480 Мб (20 Гб). Для информации: 1 Гб = 1024 Мб. Нажмите кнопку Next.

    Рисунок 5 из 7

    13) Нажмите кнопку Finish, для создания виртуальной машины. Вы снова окажетесь в окне Virtual PC Console.
    14) Выберите созданную Вами виртуальную машину и нажмите кнопку Start
    15) Виртуальная машина начнет свою работу и остановится с сообщением: Reboot and Select proper Boot device or Insert Boot Media in selected Boot device, поскольку отсутствует инсталляционный диск с Windows 7. Выберите команду CD>Capture CD Image и укажите образ ISO с Windows 7.

    Рисунок 6 из 7

    16) Перезагрузите виртуальную машину, выбрав команду Action -> Ctrl+Alt+Del или нажав Правый Alt+DEL в окне виртуальной машины.
    17) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
    18) После завершения установки Windows 7 на виртуальную машину, Microsoft Virtual PC сразу запустит Вам Windows 7 внутри виртуальной машины.
    19) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Right Alt.
    Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Virtual Machine Additions. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Action –> Install or Update Virtual Machine Additions и нажмите Continue.

    Рисунок 7 из 7

    20) Во всплывшем окне Автозапуск нажмите Setup.exe и установите программу.
    21) Нажмите Yes по окончанию установки Virtual Machine Additions и виртуальная машина перезагрузится.
    22) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Action -> Close -> Turn Off и нажмите OK.
    23) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Start.

    10. Установка Windows 7 в виртуальную машину VMware Workstation.
    VMware Workstation — популярная программа для виртуализации систем. VMware Workstation является массивным решением для разработчиков программного обеспечения и системных админов, создающих и тестирующих полно-комплексные сетевые приложения класса серверов, работающие в разнообразных средах.

    1) Заходите на страницу официального сайта для скачивания программы: http://downloads.vmware.com/d/
    2) Нажимаете на ссылку VMware Workstation
    3) На открывшейся странице выбираете для скачивания VMware Workstation X.X.X for Windows (где X.X.X - номер версии)
    4) Щелкаете на кнопке Download рядом с Workstation for Windows 32-bit and 64-bit with VMware Tools.
    5) Нажимаете на кнопку Register и заполняете регистрационную форму и нажимаете Continue
    6) Внизу EULA соглашения нажимаете Yes и оказываетесь на странице загрузки. Программа бесплатна для полнофункционального использования 30 дней. По истечении данного срока Вам необходимо её зарегистрировать.
    7) Скачиваете Workstation for Windows 32-bit and 64-bit Main installation file with Tools. В отличие от других виртуальных машин, программа установки VMware Workstation имеет размер более 500 Мегабайт.
    8) Установите программу. Перезапустите компьютер, для этого в последнем окне программы нажмите Restart Now или нажмите Restart Later и перезапустите вручную позже.
    9) Запустите программу. Установите переключатель на Yes, I accept the terms in the license agreement и нажмите OK
    10) В главном окне программы нажмите на значок New Vitual Machine.

    Рисунок 1 из 6

    11) Установите переключатель на Typical (recommended). Нажмите кнопку Next.

    Рисунок 2 из 6

    12) Установите переключатель на Installer disk image file (iso). Нажмите кнопку Browse и укажите путь к ISO-образу Windows 7. Нажмите кнопку Next.

    Рисунок 3 из 6

    13) Укажите свой инсталляционный код Windows 7, имя пользователя и пароль и нажмите кнопку Next. Если Вы решили ввести эти данные позже, то после нажатия кнопки Next, нажмите на кнопку Yes.
    14) Выберите имя и расположение для файла Вашей виртуальной машины. Нажмите кнопку Next.

    Рисунок 4 из 6

    15) Задайте размер Вашего виртуального жесткого диска в гигабайтах.

    Рисунок 5 из 6

    16) Нажмите кнопку Finish, для создания виртуальной машины.
    17) В окне VMware Workstation Activation нажмите Enter Serial Number, чтобы ввести имеющийся у Вас серийный номер. Если у Вас нет серийного номера, то Вы можете получить серийный номер на 30 дней для полнофункционального тестирования программы: https://www.vmware.com/tryvmware/?p=workstation&lp=default
    18) После введения пробного номера во всплывшем окне Register your version of VMware Workstation now! нажмите кнопку Register
    19) В главном окне программы перейдите на вкладку с названием Вашей виртуальной машины (по умолчанию Windows 7) и нажмите ссылку Power on this virtual machine.

    Рисунок 6 из 6

    20) В отличие от других виртуальных машин установка Windows 7 начнется сама и большую часть установки VMware Workstation выполнит автоматически, Ваше участие в процессе установки Windows 7 почти не потребуется.
    21) После завершения установки Windows 7 на виртуальную машину, VMware Workstation сразу запустит Вам Windows 7 внутри виртуальной машины.
    22) Сразу после запуска VMware Workstation самостоятельно установит Вам дополнительные инструменты VMware Tools, а также в случае наличия у Вас подключения к Интернет самостоятельно установит все необходимые драйвера.
    23) Используйте комбинацию клавиш Ctrl+G для разблокировки одновременного использования мыши как в виртуальной системе, так и в основной.
    24) Чтобы выключить виртуальную машину, завершите работу в виртуальной Windows 7 как в обычной Windows. Пуск -> Завершение работы.
    25) Чтобы запустить установленную Windows 7 в основном окне программы в колонке слева выберите наименование Вашей операционной системы. В открывшейся вкладке с названием Вашей виртуальной машины (по умолчанию Windows 7) нажмите ссылку Power on this virtual machine.

    11. Создание общей папки для виртуальной и основной Windows в VirtualBox.

    Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VirtualBox и хостовой (реальной) Windows 7, сделайте следующее:

    1) В меню запущенной виртуальной машины откройте Устройства -> Общие папки

    Рисунок 1 из 4

    2) Нажмите на клавиатуре кнопку Insert, либо нажмите на значок папки с плюсом.

    Рисунок 2 из 4

    3) Установите флажок для параметра Создать постоянную папку.
    4) В ниспадающем меню рядом с текстом Путь к папке выберите пункт Другой....
    5) Укажите путь к Вашей папке и нажмите на каждую кнопку ОК.

    Рисунок 3 из 4

    Если Вы хотите, чтобы гостевая ОС автоматически подключала данную папку в процессе загрузки поставьте флажок у Авто-подключение.
    Если Вы хотите, чтобы общая папка была постоянной для данной машины установите флажок у Создать постоянную папку, иначе выбранная общая папка будет временной.
    6) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Сеть -> VBOXSVR -> Ваша папка

    Рисунок 4 из 4

    12. Создание общей папки для виртуальной и основной Windows в Microsoft Virtual PC.
    Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину Microsoft Virtual PC и хостовой (реальной) Windows 7, сделайте следующее:

    1) В меню запущенной виртуальной машины откройте Edit -> Settings или нажмите сочетание клавиш: правый Alt+E

    Рисунок 1 из 4

    2) Выберите в списке Shared Folders и нажмите кнопку Share Folder...

    Рисунок 2 из 4

    3) Установите флажок на Share Every Time, укажите Вашу общую папку и установите букву диска в виде которого будет отображаться папка в виртуальной Windows, затем нажмите OK.

    Рисунок 3 из 4

    4) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Компьютер -> Отключенное сетевое устройство (назначенная вами буква диска)

    Рисунок 4 из 4

    13. Создание общей папки для виртуальной и основной Windows в VMware Workstation.
    Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VMware Workstation и хостовой (реальной) Windows 7, сделайте следующее:

    1) В вкладке с названием Вашей виртуальной машины (по умолчанию Windows 7) перейдите на вкладку Options.
    2) Сделайте двойной щелчок на папке Shared Folders

    Рисунок 1 из 4

    3) Установите переключатель на Always enabled.

    Рисунок 2 из 4

    4) Нажмите кнопку Add..., а затем кнопку Next.
    5) Нажмите кнопку Browse. Укажите путь к Вашей общей папке в хостовой (реальной) Windows 7 и ее имя в виртуальной Windows, затем нажмите OK.

    Рисунок 3 из 4

    6) Нажмите кнопку Next, а затем кнопку Finish. Выйдите из опций нажав на OK.
    7) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Сеть -> vmware-host -> Shared Folders -> Ваша папка

    Рисунок 4 из 4

    14. Запуск старых 16-битных приложений и DOS-игр в Windows, используя программу DosBox.

    Для запуска старых 16-битных приложений и DOS-игр в Windows, Вы можете использовать программную среду DosBox. Чтобы Вам легче было в ней работать Вы можете воспользоваться одной из предлагаемых на сайте графических оболочек.

    1) Скачайте и установите графическую оболочку D-Fend Reloaded
    2) Нажмите Файл -> Настройки программы.
    3) Перейдите на вкладку Язык в Пользовательский интерфейс и установите значения параметров в соответствии с языковыми требованиями программы, которую Вы собираетесь запустить и нажмите ОК.
    4) Чтобы добавить новое 16-битное приложение (DOS-игру), просто перетащите мышкой ZIP-архив с программой или распакованную папку с файлами приложения (игры) в окно программы.
    5) В зависимости от выбранного Вами действия, появится окно Импорт архива или окно Импорт папки.
    6) В данном окне нажмите ОК и профиль для данной игры добавится в программу, чтобы Вы могли в любой момент запустить её.
    7) Нажмите правой кнопкой мыши на созданном профиле игры и выбираете пункт Запустить настройку.
    8) Настройте параметры запуска игры и выйдите из программы настройки.
    9) Нажмите правой кнопкой мыши на созданном профиле игры и выбираете пункт Запустить программу.

    Дополнения:

    Переключение между экранным и оконным режимами осуществляется комбинацией клавиш Alt+Tab.
    Звуковую карту указывать Sound Blaster/Sound Blaster Pro
    Иногда для выхода приходится в ручную вводить команду Exit и нажимать Enter.

    15. Отключение синхронизации времени с хостовой системой в виртуальной машине VirtualBox.

    Если в виртуальной Windows Вам необходиомо, чтобы при запуске виртуальной системы была установлена уже прошедшая дата и виртуальная машина не синхронизировала данные с основной системой, то выполните указанные ниже действия.

    1) Выйдите из виртуальной машины и закройте приложение VirtualBox.
    2) Откройте окно команд из папки, куда установлена программа и в которой находится утилита VBoxManage.exe.
    Для этого щелкните правой кнопкой мыши по паке, удерживая нажатой клавишу Shift и выберите Открыть окно команд.
    3) Введите указанную ниже команду:

    Где: <name> - имя Вашей виртуальной машины, а <-msec> - разница в миллисекундах между текущей датой и той, что требуется. Указанное значение будет постоянно отматываться назад.

    Для получения необходимого Вам значения в милисекундах воспользуйтесь утилитой Date Offset Calculator

    16. Отключение синхронизации времени с хостовой системой в виртуальной машине Microsoft Virtual PC.

    Если в виртуальной Windows Вам необходиомо, чтобы при запуске виртуальной системы была установлена уже прошедшая дата и виртуальная машина не синхронизировала данные с основной системой, то выполните указанные ниже действия.

    1) Выйдите из виртуальной машины и закройте приложение Microsoft Virtual PC.
    2) Откройте в любом текстовом редакторе файл конфигурации Вашей виртуальной машины.
    Данный файл расположен в той же папке, где и созданная Вами виртуальная машина (С:\Users\ИмяПользователя\AppData\Local\Microsoft\Windows Virtual PC\Virtual Machines) и имеет расширение .vmс
    3) Найдите тег </microsoft> и вставьте перед ним нижеследующий текст:

    4) Найдите тег </bios> и вставьте перед ним нижеследующий текст:

    В итоге у Вас должно получиться примерно так:

    Если у Вас уже имеются указанные разделы, но значения параметров установлены true, то просто измените их на false.

    5) Сохраните файл и запустите Virtual PC.
    6) Зайдите в BIOS виртуальной машины, и установите необходимую Вам дату и время, и после перезагрузки/выключения машины они не будут синхронизированы с хостовой системой.

    17. Отключение синхронизации времени с хостовой системой в виртуальной машине VMware Workstation.

    Если в виртуальной Windows Вам необходиомо, чтобы при запуске виртуальной системы была установлена уже прошедшая дата и виртуальная машина не синхронизировала данные с основной системой, то выполните указанные ниже действия.

    1) Выйдите из виртуальной машины и закройте приложение VMware Workstation.
    2) Откройте в любом текстовом редакторе файл конфигурации Вашей виртуальной машины.
    Данный файл расположен в той же папке, где и созданная Вами виртуальная машина (C:\Users\ИмяПользователя\Documents\Virtual Machines) и имеет расширение .vmx
    3) Добавьте в конце файла нижеследующие строки:

    Параметры с первого до предпоследнего отключают синхронизацию времени с хостовой машиной при различных операциях.
    Последний параметр rtc.startTime определяет дату в биосе при запуске машины. Его значение – это требуемая дата в формате Unix Timestamp, равняется количеству секунд прошедших с полночи с 31 декабря 1969 года на 1 января 1970 года до необходимой Вам даты и времени.

    Для получения необходимого Вам значения скачайте программу конвертер: Unix Timestamp Converter Unix Timestamp Converter или воспользуйтесь онлайн конвертером: Unix Time Convertion

    4) Сохраните файл и перезапустите VMware Workstation.

    Внимание: После внесения изменений проверьте отсутствие дублирующихся строк, иначе машина не запустится.

    Твики Реестра

    Твики Реестра - Общие.

    1. Запуск программы "Редактор реестра", создание и применение reg-файла.

    Запуск программы "Редактор реестра":

    Вариант 1.

    1.1) Откройте меню Пуск -> Все программы -> Стандартные -> Выполнить (или нажмите сочетание клавиш Win+R)
    1.2) Введите команду regedit и нажмите ОК

    Вариант 2.

    2.1) Откройте меню Пуск
    2.2) В строке поиска введите regedit и нажмите Enter

    Вариант 3.

    3.1) Запустите Проводник Windows (Explorer)
    3.2) Откройте папку C:\Windows и дважды щелкните по файлу regedit.exe

    Создание reg-файла.

    Вариант 1.

    1.1) Откройте Блокнот (Notepad).
    1.1.1) Откройте меню Пуск -> Все программы -> Стандартные -> Блокнот (или нажмите сочетание клавиш Win+R -> введите notepad -> нажмите ОК).
    1.2) Скопируйте необходимый Вам код в окно программы Блокнот.
    1.3) В меню программы нажмите Файл и выберите пункт Сохранить.
    1.4) В открывшемся окне:
    1.4.1) Укажите место сохранения файла.
    1.4.2) Укажите имя файла и расширение .reg (Например: Demo.reg)
    1.4.3) Выберите тип файла: Все файлы (*.*).

    Внимание:
    Если Вы оставите тип файла: Текстовые файлы (*.txt), то имя файла обязательно нужно взять в кавычки. (Например: "Demo.reg")

    1.5) Нажмите на кнопку Сохранить.

    Вариант 2.

    Если у Вас убран флажок Скрывать расширения для зарегистрированных типов файлов в Параметры папок (Панель управления\Оформление и персонализация\Параметры папок -> Вкладка Вид), то Вы можете создать reg-файл следующим способом:

    2.1) В папке, где Вы хотите создать reg-файл, щелкните правой кнопкой мыши.
    2.2) Во всплывшем меню выберите Создать -> Текстовый документ.
    2.3) Сотрите имя и расширение файла .txt, укажите необходимое Вам имя файла и расширение .reg, нажмите клавишу Enter, а затем кнопку Да.
    2.4) Щелкните на созданном Вами файле правой кнопкой мыши и выберите пункт Изменить.
    2.5) Скопируйте необходимый Вам код в окно программы Блокнот.
    2.6) Нажмите сочетание клавиш CTRL+S.

    Вариант 3.

    3.1) Возьмите любой готовый reg-файл.
    3.2) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить.
    3.3) Скопируйте необходимый Вам код в окно программы Блокнот.
    3.4) В меню программы нажмите Файл и выберите пункт Сохранить Как.
    3.5) В открывшемся окне:
    3.5.1) Укажите место сохранения файла.
    3.5.2) Укажите имя файла и расширение .reg (Например: Demo.reg)
    3.5.3) Выберите тип файла: Все файлы (*.*).
    3.6) Нажмите на кнопку Сохранить.

    Применение reg-файла.

    Вариант 1.

    1) Щелкните два раза левой кнопкой мыши на reg-файле и нажмите кнопку Да.

    Вариант 2.

    2.1) Щелкните правой кнопкой мыши на reg-файле.
    2.2) Выберите пункт Слияние и нажмите кнопку Да.

    2. Создание и переименование раздела или параметра, а также изменение параметра в редакторе реестра.
    Вы запустили программу "Редактор реестра" как описано в Запуск программы "Редактор реестра", создание и применение reg-файла.. Используя дерево папок открыли нужный Вам раздел, и теперь, Вам необходимо создать, переименовать параметр (раздел), либо изменить значение параметра реестра. Существует несколько способов сделать это.

    Создание раздела или параметра в редакторе реестра.

    Вариант 1.

    1) Щелкните в главном меню пункт Правка.
    2) Наведите курсор мыши на пункт меню Создать.
    3) В раскрывающемся меню выберите раздел или тип параметра, который Вы желаете добавить.

    Вариант 2.

    1) Щелкните правой кнопкой мыши в любом пустом месте области параметров (правая часть окна).
    2) Наведите курсор мыши на пункт меню Создать.
    3) В раскрывающемся меню выберите раздел или тип параметра, который Вы желаете добавить.

    Переименование раздела или параметра в редакторе реестра.

    Вариант 1.

    1) Выберите раздел или параметр, который Вы желаете переименовать.
    2) Щелкните в главном меню пункт Правка, а затем на пункт Переименовать.

    Вариант 2.

    1) Щелкните правой кнопкой мыши на раздел или параметр, который Вы желаете переименовать.
    2) Щелкните левой кнопкой мыши на пункт Переименовать.

    Изменение значения параметра в редакторе реестра.

    Вариант 1.

    1) Выберите параметр, который Вы желаете изменить.
    2) Щелкните в главном меню пункт Правка, а затем на пункт Изменить.

    Вариант 2.

    1) Щелкните правой кнопкой мыши на параметр, который Вы желаете изменить.
    2) Щелкните левой кнопкой мыши на пункт Изменить

    Вариант 3.

    Щелкните дважды на параметре, который Вы желаете изменить.

    3. Аббревиатуры используемые для обозначения веток реестра.

    Для обозначения пути к разделу или ключу реестра могут использоваться следующие аббревиатуры:

    Наименование раздела | Используемая аббревиатура
HKEY_CLASSES_ROOT | HKCR
HKEY_CURRENT_USER | HKCU
HKEY_LOCAL_MACHINE | HKLM
HKEY_USERS | HKU
HKEY_CURRENT_CONFIG | HKCC

    4. Быстрый переход в необходимый раздел реестра.

    Если для работы с реестром Вы предпочитаете не использовать программы: RegEditX, Registry Workshop или Reg Organizer, то для быстрого перехода в необходимый Вам раздел реестра Вы можете воспользоваться одним из указанных ниже вариантов.

    Вариант 1.

    1) Скачайте маленькую бесплатную утилиту от Microsoft: RegJump
    2) Распакуйте архив в любую папку и скопируйте файл regjump.exe в папку C:\Windows\System32
    3) Теперь любую ветку реестра можно открыть прямо из диалогового меню Выполнить или из строки поиска в меню Пуск.
    3.1) В диалоговом меню Выполнить (Win+R), либо в строке поиска из меню Пуск введите команду regjump и путь к разделу, указав его в кавычках.

    Например:

    3.2) Нажмите клавишу Enter, при вводе из окна Выполнить или Shift+Enter при вводе в строку поиска:

    Вариант 2

    1) Создайте специальный скрипт.

    1.1) Скопируйте указанный код в любой текстовый редактор (например, Блокнот).
    1.2) Нажмите Ctrl+S и сохраните файл с любым именем и расширением .vbs
    1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "regkey.vbs")
    1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    2) Переместите созданный Вами скрипт в любую удобную Вам папку.
    Теперь для открытия раздела реестра:
    3) Скопируйте в буфер обмена(Ctrl+C или Щелчок правой кнопкой мыши -> Копировать) необходимую Вам ветку реестра.
    4) Щелкните на созданный Вами скрипт-файл.

    Минусом использования данного скрипта является отсутствие поддержки аббревиатур.

    5. Отключение вывода диалогового окна при применении reg-файла.

    При запуске reg-файла, система выводит диалоговое окно в котором пользователь должен подтвердить достоверность источника, откуда получены импортируемые в реестр сведения. Для отключения данного окна выполните указанные ниже действия:

    1) Запустите редактор реестра (Win+R -> regedit -> ОК)
    2) Откройте раздел реестра HKEY_CLASSES_ROOT\regfile\shell\open\command
    3) Дважды щелкните на параметре По умолчанию и введите значение:

    4) Закройте редактор реестра и перезапустите компьютер.

    Минусом данного решения является то, что помимо указанного диалогового окна запроса подтверждения, также не будет выводиться окно об успешном импортировании в реестр данных.

    Твики Реестра - Администрирование и Безопасность.

    1. Получение полного доступа к разделу реестра, используя программу regedit или командную строку.

    Для поддержания безопасности системы, после внесения изменений в реестр верните исходные права и восстановите владельца.

    Изменение разрешений и владельца для получения полного доступа к разделу реестра.

    1) Нажмите кнопку Пуск и введите в строке поиска regedit
    2) Щелкните на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора.
    3) Откройте раздел реестра, права которого Вы желаете изменить.
    4) В списке слева, щелкните на данном разделе реестра правой кнопкой мыши и выберите пункт Разрешения.
    5) Щелкните левой кнопкой мыши на группу Администраторы:
    6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.
    7) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    8) Щелкните левой кнопкой мыши на свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    9) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    Восстановление настроек, если владельцем являлись служба TrustedInstaller или учетная запись Система.

    1) Щелкните правой кнопкой мыши на разделе реестра, права которого Вы желаете восстановить и выберите пункт Разрешения.
    2) Щелкните левой кнопкой мыши на группу Администраторы:
    3) Снимите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку Применить.
    4) Нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    5) Нажмите кнопку Другие пользователи или группы... и в качестве имени объекта в текстовом поле введите:
  • NT SERVICE\TrustedInstaller , если владельцем являлась служба TrustedInstaller
  • система , если владельцем являлась учетная запись Система (в английской Windows 7 нужно вводить System)
    • 6) В окне Изменить владельца на: выберите TrustedInstaller или система .
    7) Установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.

    Далее рассказывается как можно изменить разрешения, используя командную строку запущенную от имени администратора.
    Если после использовании команды, разрешения не сменятся, то возможно Вам придется зайти в систему под встроенной учётной записью "Администратор" для их выполнения заново.

    Изменение разрешений используя командную строку.

    1) Создайте в любом месте txt-файл (Например в папке D:\Reg создайте файл regperm.txt)
    2) Добавьте в данный файл разделы реестра и присваиваемые им разрешения в следующем формате:

    где куст – имя куста реестра, раздел – имя раздела реестра, а [разрешения] – двоичный числовой формат разрешений.

    Обозначения используемые для кустов реестра:

    Наименование куста реестра | Следует указывать
HKEY_CLASSES_ROOT | \Registry\machine\software\classes
HKEY_CURRENT_USER | \Registry\user\user_sid где user_sid — идентификатор безопасности пользователя.
HKEY_LOCAL_MACHINE | \Registry\machine
HKEY_USERS | \Registry\user
HKEY_CURRENT_CONFIG | \Registry\machine\SYSTEM\CurrentControlSet\Hardware Profiles\0001

    Если Вы не знаете свой SID, то узнать его Вы сможете введя в командной строке команду:

    Двоичные числовые представления разрешений имеют следующий вид (выборочно):

    Значение | Задаваемое разрешение
1 | Администратор, полный доступ
2 | Администратор, чтение
3 | Администратор, чтение и запись
4 | Администратор, чтение, запись и удаление
5 | СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ, полный доступ
6 | СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ, чтение и запись
7 | Все, полный доступ
8 | Все, чтение
9 | Все, чтение и запись
10 | Все, чтение, запись и удаление
11 | Опытные пользователи, полный доступ
12 | Опытные пользователи, чтение и запись
13 | Опытные пользователи, чтение, запись и удаление
17 | Система, полный доступ
18 | Система, чтение и запись
19 | Система, чтение

    Пример:

    Чтобы задать полный доступ группам и пользователям Администратор, СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ и Система для раздела реестра:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer в txt-файл необходимо добавить

    3) В командной строке запущенной от имени администратора (Win+R -> cmd -> OK) выполните команду:

    Например:

    2. Удаление сведений об использованном USB-флэш диске.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку:

    Здесь Вы увидите список разделов, обозначающих подключаемые когда-либо флеш-диски к Вашей системе.
    3) Найдите раздел соответствующий, флеш диску, упоминание о котором Вы хотите удалить из реестра. (Например: Disk&Ven_Corsair&Prod_Flash_Voyager&Rev_1100)

    4) Откройте данный раздел.
    Путь к данной ветке, в моем примере:

    5) В данной ветке Вы увидите подраздел (Например: AB00000000005136&0)
    Путь к данной ветке, в моем примере:

    6) Откройте ветку реестра:

    7) Отрывая поочередно каждый из разделов данной ветки, найдите подраздел содержащий в названии AB00000000005136
    Путь к данной ветке, в моем примере:

    8) Удалите найденные в результате анализа ветки реестра. В моем примере, необходимо удалить следующие ветки:

    9) Перезагрузите компьютер.

    3. Удаление программ в Безопасном Режиме, использующих установщик Windows Installer.

    В большинстве случаев при попытке удаления программы в Безопасном Режиме, если программа не использует собственный инсталлятор (Например: Winamp) Вы получите предупреждающее сообщение:

    Для включения возможности удаления программ в Безопасном Режиме сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal
    3) Создайте здесь раздел MSIService
    4) Присвойте строковому параметру По умолчанию значение Service.
    5) Перезагрузите компьютер.

    4. Отмена ограничения использования команд в контекстном меню, при выделении более 15 файлов.

    Как известно, при выделении более 15 файлов команды контекстного меню, такие как "Открыть/Печать/Редактировать" становятся недоступны.
    Для отмены данного ограничения проделайте следующее:

    1) Запустите редактор реестра ( Win+R -> regedit -> OK)
    2) Откройте ветку HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
    3) Создайте в ней параметр MultipleInvokePromptMinimum типа DWORD.
    4) Установите значение данного параметра равным 16.

    Для уменьшения количества файлов на которых действует ограничение применения команд, введите значение от 1 до 15.
    При выделении файлов выше выбранного Вами значения команды в контекстном меню применяться не будут. При указании значения 0 произойдет полное отключение команд, включая команду "Открыть".

    5. Отключение проверки подписи для загруженных программ.

    Избавляет от этого:

    1) Откройте Панель управления -> Свойства обозревателя -> вкладка Дополнительно
    2) Уберите флажок "Проверка подписи для загруженных программ" и поставьте флажок "Разрешать выполнение или установку программы, имеющую недопустимую подпись".
    3) Создайте и примените reg-файл следующего содержания.

    6. Удаление устаревших значков из области уведомления панели задач.

    После установки/запуска программ, которые размещаются в области уведомлений, данный список все время растет.
    С помощью следующего твика реестра, можно оставить в текущем диалоге отображаться только те значки, которые расположены в области уведомлений на данный момент.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

    Скачать готовый reg-файл Вы можете по ссылке: Clean_TrayNotify.zip

    7. Очистка истории расположений фонов рабочего стола в Windows 7.

    В окне настроек фонового рисунка рабочего стола (ПКМ на рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) есть пункт Расположение изображения, содержащий список папок, в которых хранятся картинки, которые можно использовать в качестве обоев рабочего стола. По умолчанию в этом списке всегда есть указания на четыре папки:

    1. Фоны рабочего стола Windows;
    2. Библиотека изображений;
    3. Самые популярные фотографии;
    4. Сплошные цвета.

    Если Вы добавляете картинку из папки, которой нет в списке, то она(папка) автоматически добавится в данный список. Со временем, этот список будет увеличиваться, дополняясь новыми папками. При чём, в списке будут указаны папки, которых на диске физически уже нет, а запись о них осталась.

    Чтобы очистить список Расположение изображения от ненужных записей и оставить только стандартные названия, нужно в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\Images удалить все параметры ID под номерами от 0 до 9, которые содержат в зашифрованном виде пути нахождения изображений, выбранных пользователем.

    Теперь при повторном открытии окна настроек фонового рисунка рабочего стола (ПКМ на рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) в пункте Расположение изображения Вы увидите список, содержащий только записи по умолчанию.

    8. Удаление папки Общие Документы и пользовательского профиля Общие.

    Для спокойного удаления папки Общие Документы и пользовательского профиля Общие указанные ниже действия рекомендуется выполнять на чистой установленной системе. Если же у Вас система уже установлена, и на ней уже установлены программы, то прежде чем выполнять инструкции ниже скопируйте все папки из C:\Users\Public\* в C:\Users\ВашПрофиль\*

    Вариант 1.

    1) Запустите редактор реестра ( Win+R -> regedit -> OK)
    2) Откройте ветку

    3) Затем нажмите правой кнопкой мыши на правой панели и выберите Создать -> Параметр "DWORD".
    4) Дайте этому параметру имя NoSharedDocuments и присвойте ему значение 1
    5) Перезагрузите компьютер

    Вариант 2.

    1) Пройдите к ветке реестра

    2) Удалите следующую ветку:

    3) Пройдите к ветке реестра

    4) Удалите следующую ветку(если есть):

    Вариант 3.

    1) Откройте Панель управления\Все элементы панели управления\Система(или Пуск -> Компьютер -> Свойства)
    2) Откройте Дополнительные параметры системы
    3) Пройдите на вкладку Имя Компьютера и нажмите Идентификация...
    4) Выберите пункт Компьютер предназначен для домашнего использования.
    5) Нажмите Далее, затем Готово, затем Ок
    6) Перезагрузите компьютер

    После того, как воспользуйтесь решением одного из вариантов проделайте следующие действия:

    1) В ветке реестра:

    замените значения с C:\Users\Public\ на C:\Users\ВашПрофиль\

    2) В ветке реестра:

    замените значения с %PUBLIC%\ на %USERPROFILE%\

    3) Удалите папки (если они остались):

    Диск С: -> Пользователи -> Общие (C:\Users\Public\)
    Библиотеки -> Документы -> Общие Документы

    Внимание: Если не хотите, чтобы у Вас на рабочем столе появились дублирующиеся иконки файлов, не устанавливайте значение параметра Common Desktop, идентичное рабочему столу Вашего профиля. Например, вместо C:\Users\ВашПрофиль\Desktop укажите C:\Users\ВашПрофиль\Public\Desktop, а вместо %USERPROFILE%\Desktop укажите %USERPROFILE%\Public\Desktop.

    9. Запрет запуска контекстного меню Проводника при нажатии правой кнопкой мыши.

    1) Запустите редактор реестра (Regedit).
    2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр DWORD
    4) Переименуйте его в NoViewContextMenu
    5) Измените значение на 1.
    6) Перезагрузите компьютер.

    Вы можете также создать и применить reg-файл следующего содержания:

    10. Удаление пункта меню Файл из Проводника.

    1) Запустите редактор реестра (Regedit).
    2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр DWORD
    4) Переименуйте его в NoFileMenu
    5) Измените значение на 1.
    6) Перезагрузите компьютер.

    Вы можете также создать и применить reg-файл следующего содержания:

    Данный пункт будет также удален из всех мест, использующих оболочку Windows

    11. Запрещение запуска программ.

    1) Запустите редактор реестра (Regedit).
    2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр DWORD
    4) Переименуйте его в RestrictRun
    5) Измените значение на 1.
    6) Перезагрузите компьютер.
    7) Создайте подраздел с аналогичным именем RestrictRun
    8) Создайте в разделе (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictRun) список разрешенных к запуску программ для текущего пользователя.
    8.1) Создайте строковые(String) параметры
    8.2) Укажите названия для создаваемый строковых параметров, начиная с 1 и далее
    8.3) Установите в значениях параметров пути к Вашим приложениям и их имена. Файлы должны указываться с расширением. Например:

    1 REG_SZ regedit.exe
    2 REG_SZ calc.exe
    3 REG_SZ Iexplore.exe

    Не забудьте указать файл regedit.exe, чтобы Вы могли зайти в него и отменить установленные Вами ограничения!
    Для сброса ограничения на запуск программ надо установить значение ключа RestrictRun в 0 или удалить его.

    Если Вы забыли указать regedit.exe в списке или не создали подраздел RestrictRun, чтобы запретить запуск всех программ. Для отмены запрета проделайте следующее:

    1) Перезапустите компьютер.
    2) До начала запуска Windows нажмите на клавишу F8 и выберите пункт Безопасный режим с поддержкой командной строки
    3) В командной строке введите regedit и нажмите Enter.
    4) Пройдите в ветку HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    5) Удалите ключ RestrictRun или установите его значение на 0.

    12. Удаление записей из истории диалогового окна "Выполнить".

    Если Вы используете диалоговое окно "Выполнить" в меню "Пуск" (Win+R), то для удаления записей из его истории проделайте следующее.

    1) Запустите редактор реестра: Win+R --> regedit
    2) Откройте следующую ветку реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU

    Команды, введенные вами ранее, хранятся в виде значений параметров a,b,c,d и так далее используя буквы английского алфавита.

    3) Для удаления записи - удалите параметр с ненужной командой, и она пропадет из истории диалога "Выполнить".

    13. Удаление/восстановление предупреждающего окна о внесении изменений в msconfig(Конфигурация системы).

    При внесении изменений в утилиту msconfig (Конфигурация системы), появляется окно Настройка системы, в котором Вам предлагается на выбор: либо перезагрузить компьютер, либо выйти без перезагрузки.

    Чтобы отключить данное предупреждение установите флажок Больше не показывать это предупреждение, и окно больше появляться не будет.

    Для восстановления данного окна:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKCU\Software\Microsoft\Shared Tools\MsConfig
    3) Удалите параметр NoRebootUI.

    14. Удаление лишних записей из утилиты msconfig (Конфигурация системы).

    Если в окне утилиты msconfig (Конфигурация системы) скопилось много записей и Вы хотели бы удалить ненужные. То сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKLM\SOFTWARE\Microsoft\Shared Tools\MSConfig
    3) Просмотрите все подразделы данной ветки и удалите ненужные Вам записи.
    4) Также записи могут храниться в файле mscfgtlc.xml, находящимся в папке C:\Windows\system32\. В 64-битных Windows данный файл также находится в папке C:\Windows\SysWOW64\.
    5) Откройте данный файл Блокнотом, удалите ненужные записи и сохраните. Если Вы хотите удалить все лишние записи, то просто удалите файл mscfgtlc.xml.

    15. Отключение напоминания о необходимости перезагрузки после установки обновлений.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU.
    3) Создайте параметр NoAutoRebootWithLoggedOnUsers типа DWORD и присвойте ему значение 1.

    или

    откройте диалоговое меню Выполнить (Win+R) и введите команду:

    Для вступления изменений в силу перезайдите в систему или перезагрузите компьютер.

    16. Запуск нескольких копий редактора реестра одновременно.

    Пользователи, которые работают с редактором реестра Windows наверняка сталкивались с ситуацией, когда необходимо сверить содержимое веток реестра. Весьма удобно было бы открыть два редактора реестра, разместить их рядом и сравнить. Однако при повторной попытке запуска программы, система переключает Вас на открытое окно программы. Запуск с удерживанием клавиши Shift тоже не работает.

    Для запуска второй копии редактора реестра:

    1) Откройте диалоговое меню "Выполнить" (Win+R)
    2) Введите команду regedit, используя параметр -m и нажмите Enter.

    17. Дополнительные параметры для настройки функций "Защита системы" и "Восстановление системы".

    В Windows 7 для функций "Защита системы" и "Восстановление системы" существуют дополнительные настройки, которые скрыты от обычных пользователей. Чтобы их изменить Вам необходимо создать соответствующий настройке параметр в реестре.

    1) Откройте диалоговое меню "Выполнить" (Win+R)
    2) Введите команду regedit и нажмите Enter.
    3) Откройте раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore\Cfg
    4) Создайте параметр типа DWORD с именем из списка указанного ниже
    5) Щелкните правой кнопкой мыши на созданном параметре и выберите пункт Изменить.
    6) Установите переключатель в положение Десятичная и введите необходимое Вам значение.

    DiskPersent - указывает, какой объем дискового пространства в процентах будет использовать система для точек восстановления.

    CompressionBurst - указывает время сжатия данных в секундах при простое системы. При простое системы в течение времени, указанного в данном параметре System Restore будет упаковывать данные, после чего прекратит свою работу до следующего периода простоя системы.

    DSMin - указывает минимальное количество свободного дискового пространства, которое требуется System Restore. В случае уменьшения свободного дискового пространства до указанного размера точки восстановления системы перестанут создаваться.

    1 день(сутки) равен 86400 секунд, 1 час равен 3600 секунд, 1 минута равна 60 секунд.

    RPGlobalInterval - указывает количество времени в секундах, в течение которого System Restore ожидает перед созданием новой контрольной точки.

    RPLifeInterval - указывает время в секундах, в течение которого будут храниться точки восстановления перед удалением их с компьютера.

    RPSessionlnterval - указывает количество времени в секундах, в течение которого System Restore ожидает перед созданием новой системной контрольной точки при включенном компьютере. Значением по умолчанию является ноль, что означает, что эта функция выключена. Вы можете установить свое значение (например, интервал в один час), чтобы программа создавала контрольные точки автоматически через заданный интервал.

    ThawInterval - указывает количество времени в секундах, в течение которого System Restore ожидает перед тем, как возобновить свою работу после того, как появилось достаточное количество дискового пространства.

    Твики Реестра - Настройки и Интерфейс.

    1. Включение скрытых настроек электропитания.

    Чтобы настроить в Windows 7 параметры электропитания, необходимо открыть Панель управления\Система и безопасность\Электропитание. Там можно выбрать нужный план электропитания и при необходимости более детально настроить параметры, перейдя в Настройка плана электропитания -> Изменить дополнительные параметры питания.
    Однако более детально настроить параметры электропитания помогает консольная утилита Powercfg. Но работать в командной строке, разбираясь с каждым параметром может занять продолжительное время. Для того чтобы функции предоставляемые powercfg стали доступны Вам в графической оболочке, необходимо внести некоторые изменения в ветке реестра:

    В данной ветке содержатся разделы, отвечающие за определенную группу настроек.
    Например, раздел 0012ee47-9041-4b5d-9b77-535fba8b1442 относится к настройкам управления питанием жесткого диска, а 54533251-82be-4824-96c1-47b60b740d00 к настройкам управления питанием процессора.
    В свою очередь, в каждом из данных разделов есть подразделы, отвечающие за какую-либо настройку электропитания. Описание каждой из настроек указано в значении параметра Description, а её отображение в графической оболочке в значении параметра Attributes. По умолчанию, многие настройки имеют значение параметра Attributes равное «1», для того, чтобы необходимая Вам настройка был виден в графической оболочке, необходимо заменить его на «0». Доступные для отображения настройки, на ноутбуке и стационарном компьютере могут отличаться, в связи с особенностью их систем электропитания.

    Для отображения политики простоя устройств, создайте и примените reg-файл следующего содержания:

    Для отображения скрытых параметров по настройке работы жесткого диска, создайте и примените reg-файл следующего содержания:

    Для отображения скрытых параметров по настройке кнопок питания, создайте и примените reg-файл следующего содержания:

    Для отображения скрытых параметров по настройке управления питания процессора, создайте и примените reg-файл следующего содержания:

    Импортированное значение реестра позволяет увидеть только малую часть параметров, доступных для настройки управлением процессора. Всего их более 30.

    Для отображения скрытых параметров по настройке спящего режима, создайте и примените reg-файл следующего содержания:

    Для отображения скрытых параметров по настройке экрана, создайте и примените reg-файл следующего содержания:

    Также к этому разделу относится настройка параметров графического адаптера, но доступность конкретных настроек будет определяется драйвером.

    У себя в системе я обнаружил 54 скрытых настройки электропитания. Для включения сразу всех скрытых настроек электропитания: экспортируйте всю ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings в reg-файл. Отредактируйте полученный reg-файл: оставьте в нем только наименование веток реестра и их параметры Attributes и присвойте им значения «0».
    Также Вы можете скачать и применить, готовый reg-файл PowerSettings.reg

    2. Добавление классического всплывающего меню Программы (Programs) в меню Пуск.

    Для быстрого доступа к элементам списка Все программы (All Programs), Вы можете добавить его как всплывающее меню взамен меню Избранное (Favorites) или меню Файлы для загрузки (Downloads)

    Вариант 1. Вместо меню Файлы для загрузки (Downloads).

    Если Вы для загрузки файлов из интернета используете собственную папку или сохраняете на Рабочий стол, а также в качестве интернет-браузера используете Internet Explorer, то Вам подойдет данный вариант.

    1) Включите меню Файлы для загрузки (Downloads)
    1.1) Щелкните правой кнопкой мыши на кнопке Пуск, затем нажмите Свойства (Properties).
    1.2) Откройте вкладку Меню "Пуск" (Start Menu) и нажмите кнопку Настроить (Customize)
    1.3) Прокрутите список до пункта Файлы для загрузки (Downloads)
    1.4) Установите переключатель в значение Отображать как меню (Display as a menu), затем нажмите OK.
    2) Нажмите кнопку Пуск, в поле поиска введите regedit и нажмите Enter.
    3) Откройте ветку:

    4) Щелкните дважды на параметр Favorites и замените текущий путь на этот:

    5) Откройте ветку:

    6) Щелкните дважды на параметр Favorites и замените текущий путь на этот:

    7) Закройте regedit, и перезагрузите Ваш компьютер.

    Вариант 2. Вместо меню Избранное (Favorites)

    Если Вы для загрузки файлов из интернета используете собственную папку или сохраняете на Рабочий стол, а также в качестве интернет-браузера используете Internet Explorer, то Вам подойдет данный вариант.

    1) Включите меню Файлы для загрузки (Downloads)
    1.1) Щелкните правой кнопкой мыши на кнопке Пуск, затем нажмите Свойства (Properties).
    1.2) Откройте вкладку Меню "Пуск" (Start Menu) и нажмите кнопку Настроить (Customize)
    1.3) Прокрутите список до пункта Файлы для загрузки (Downloads)
    1.4) Установите переключатель в значение Отображать как меню (Display as a menu), затем нажмите OK.
    2) Нажмите кнопку Пуск, в поле поиска введите regedit и нажмите Enter.
    3) Откройте ветку:

    4) Щелкните дважды на параметр {374DE290-123F-4565-9164-39C4925E467B} и замените текущий путь на этот:

    5) Откройте ветку:

    6) Щелкните дважды на параметр {374DE290-123F-4565-9164-39C4925E467B} и замените текущий путь на этот:

    7) Закройте regedit, и перезагрузите Ваш компьютер.

    Теперь, когда Вы нажмете Пуск, в правой его части Вы увидите меню Программы (Programs), наподобие меню в предыдущих версиях Windows.

    Для исключения дублирования, Вы также можете убрать стандартный пункт меню Все программы (All Programs) из меню Пуск.
    Для этого создайте и примените reg-файл следующего содержания:

    Для возвращения стандартного пункта меню Все программы (All Programs) из меню Пуск.
    Для этого создайте и примените reg-файл следующего содержания:

    3. Добавление функции произвольного выравнивания иконок в Проводнике.

    В Windows 7 возможность отключения автоматического выравнивания иконок в Проводнике недоступна. В контекстном меню "Вид" в Проводнике, пункт "Упорядочить значки автоматически" отсутствует, соответственно Вы не можете располагать значки произвольным образом.
    Предложенный ниже твик включает возможность произвольного выравнивания иконок в Проводнике и добавляет в контекстное меню "Вид" в Проводнике пункты "Выравнивать автоматически" и "Выровнять по сетке".
    В виду сложившейся необходимости, для работы данного твика режимы "Плитка" и "Содержимое" были объединены в режим "Расширенная плитка".

    Чтобы воспользоваться твиком Вы можете скачать и применить готовое решение: disable-auto-arrange.zip

    disableautoarrange.reg - reg-файл вносящий изменения в контекстное меню Проводника
    undo.reg - reg-файл возвращающий все настройки Проводника "по умолчанию".

    Также Вы можете создать данные reg-файлы самостоятельно.

    Для внесения изменений создайте и примените reg-файл следующего содержания:

    Для отмены изменений создайте и примените reg-файл следующего содержания:

    4. Использование Windows Media Player х64 по умолчанию (для Windows 7 х64).

    Microsoft до сих пор использует 32-битную версию Windows Media Player в 64-битной версии ОС, но есть способ это изменить.
    Преимущество использования WMP х64 заключается лишь в том, что установив 64-битную версию кодеков, вы получите гораздо более чистую и легко управляемую систему.

    1) Запустите меню Выполнить(Win+R) или командную строку от имени Администратора
    2) Введите команду

    (команда чувствительна к регистру)
    3) Откройте редактор реестра: Win+R --> regedit
    4) Перейдите к ветке

    и кликните два раза по значению Path
    5) Измените

    на

    6) Закройте реестр и наслаждайтесь Windows Media Player х64

    Готовые bat-файлы Вы можете скачать по ссылке: Windows_Media_Player_x64.zip

    5. Настройка диалога переключения между окнами ("Alt"+"Tab").

    1) Запустите Редактор Реестра (Win+R -> Regedit -> Ok)
    2) Откройте ветку реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab, если она отсутствует, то создайте её (щелкните на папке Explorer правой кнопкой мыши, выберите Создать -> Раздел и назовите её AltTab).
    В данной папке создайте или измените указанные ниже параметры. Все параметры, которые будут создаваться или изменятся имеют тип REG_DWORD. Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

    Для создания твика, воспользуйтесь инструкцией:

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Параметры, отвечающие за количество отображаемых столбцов и строк

    Columns - данный параметр отвечает за количество столбцов, из которых состоит диалог переключения между окнами.
    Rows - данный параметр отвечает за количество строк, из которых состоит диалог переключения между окнами.

    Пример твика реестра с использованием этих параметров:

    Параметры, отвечающие за отступы в диалоге переключения между окнами

    Упомянутые ниже параметры указываются в пикселях.

    TopMarginPx - величина верхнего поля, добавляемого в диалог
    SideMarginPx - величина бокового поля, добавляемого в диалог
    BottomMarginPx - величина нижнего поля, добавляемого в диалог
    MinWidthPx - минимальная возможная ширина диалога AltTab
    ThumbSpacingXPx - интервал между эскизами смежных окон по горизонтали
    ThumbSpacingYPx - интервал между эскизами смежных окон по вертикали

    Пример твика реестра с использованием этих параметров:

    Параметры, отвечающие за значки эскизов окон

    Упомянутые ниже параметры указываются в пикселях.

    OverlayIconDXPx - величина смещения значка, вправо от эскиза окна
    OverlayIconDYPx - величина смещения значка, вниз от эскиза окна
    OverlayIconPx - размер значков, отображаемых в правом нижнем углу эскиза окна в диалоге переключения между окнами

    Пример твика реестра с использованием этих параметров:

    Параметры, отвечающие за размер эскизов окон и заголовок диалога переключения между окнами

    Упомянутые ниже параметры указываются в пикселях.
    MaxThumbSizePx - максимальный размер эскизов окон
    MinThumbSizePcent - минимальный размер эскизов окон в процентах, относительно максимального размера установленного в MaxThumbSizePx
    TextButtomPx - высота заголовка диалога переключения между окнами

    Пример твика реестра с использованием этих параметров:

    Параметры, изменяющие задержку времени в отображении диалога и управляющие его прозрачностью

    FadeOut_ms - количество миллисекунд, в течении которого окно будет исчезать
    FadeIn_ms - количество миллисекунд, в течении которого окно будет появляться
    FadeOutThreshold_ms Используется для мгновенного исчезновения диалога(присвойте данному параметру значение 0x1000).

    StartAlpha - начальная прозрачность диалога переключения между окнами
    FinalAlpha - конечная прозрачность диалога переключения между окнами

    Пример твика реестра с использованием этих параметров:

    Для включения классического диалога переключения между окнами, используемого в предыдущих версиях Windows при нажатии Alt+Tab, создайте DWORD-параметр AltTabSettings в ветви реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer и присвойте данному параметру значение 1.

    6. Настройка диалогового окна "Выбор программы".

    Когда Вы щелкаете на файле с незарегистрированным в системе расширением, то появляется окно “Выбор программы”, в котором вам предлагается выбрать из предложенного списка программу, способную обработать неизвестный тип файла.
    В данном окне по умолчанию установлен флажок “Использовать выбранную программу для всех файлов такого типа”. Чтобы убрать флажок и заблокировать возможность его установки, Вам необходимо изменить запись в реестре.

    1) Запустите редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте раздел HKEY_CLASSES_ROOT\Unknown\shell\opendlg\command
    3) Измените значение параметра По умолчанию (Default)

    Список программ, которые выводятся в диалоговом окне выбора программы, формируется при помощи списка подразделов раздела HKEY_CLASSES_ROOT\Applications.
    В данном разделе вы можете видеть, что имена подразделов соответствуют именам программ, установленных на вашем компьютере. Если вы хотите, чтобы какая-то из этих программ никогда не выводилась в диалоговом окне выбора программы, то в подразделе этой программы создайте строковый параметр NoOpenWith без какого-либо значения.

    7. Включение окна выбора начальных параметров при запуске проигрывателя Windows Media.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Удалите полностью следующую ветку реестра со всем содержимым:

    Вместо XXXXXX-XXXXXX-XXXXXX-XXXX у Вас будет собственное значение.
    Например: S-1-5-21-83440259-2036283413-1691820529-1000 или S-1-5-21-2717813001-1445373200-4062485642-500

    3) Перезайдите в систему или перезагрузите компьютер.

    8. Изменение действия по умолчанию при перетаскивании файлов между папками в Проводнике.

    При перетаскивании любого файла между двумя папками-окнами Проводника, в Windows 7 по умолчанию выполняется его перемещение. Вы можете самостоятельно настроить действие, которое будет выполняться при перетаскивании файла между папками: копирование; перемещение; создание ярлыка.

    Действие по умолчанию при перетаскивании конкретного типа файлов.

    1) Запустите редактор реестра (Win+R -> regedit -> ОК)
    2) Перейдите в раздел HKEY_CLASSES_ROOT
    3) Найдите раздел интересующего Вас расширения. Для примера возьмем раздел .exe:
    4) Обратите внимание на значение параметра По умолчанию, которое служит идентификатором расширения.
    Для .exe файла данным значением будет exefile, следовательно все параметры необходимо создавать в разделе с идентичным именем.
    5) Перейдите в ветку HKEY_CLASSES_ROOT\exefile.
    6) Создайте новый параметр типа DWORD (32 бита) c именем DefaultDropEffect
    7) Щелкните правой кнопкой мыши по параметру DefaultDropEffect и выберите пункт Изменить...
    8) В текстовом поле Значение: задайте необходимое Вам значение:

    1 - копирование;
    2 - перемещение;
    4 - создание ярлыка.

    Действие по умолчанию для всех файлов при перетаскивании.

    1) Запустите редактор реестра (Win+R -> regedit -> ОК)
    2) Откройте ветку HKEY_CLASSES_ROOT\*.
    3) Создайте новый параметр типа DWORD c именем DefaultDropEffect
    4) Создайте новый параметр типа DWORD (32 бита) c именем DefaultDropEffect
    5) Щелкните правой кнопкой мыши по параметру DefaultDropEffect и выберите пункт Изменить...
    6) В текстовом поле Значение: задайте необходимое Вам значение:

    1 - копирование;
    2 - перемещение;
    4 - создание ярлыка.

    9. Отключение пункта "Исправление неполадок совместимости" из контекстного меню ярлыков и исполняемых файлов.

    Для отключения пункта "Исправление неполадок совместимости" из контекстного меню ярлыков и исполняемых файлов создайте и примените reg-файл следующего содержания:

    Для возвращения пункта "Исправление неполадок совместимости" обратно, создайте и примените reg-файл следующего содержания:

    10. Удаление и восстановление стрелок на ярлыках Windows.

    Готовые файлы для убирания стрелок вы можете скачать по ссылке:
    Shortcut_Arrows.zip
    1) Распакуйте и откройте папку нужного вам варианта
    2) Для удаления стрелок с ярлыков запустите Remove_Shortcut_Arrow.bat или Remove_Shortcut_Arrow.reg
    3) Для восстановления стрелок на ярлыках запустите Restore_Shortcut_Arrow.bat или Restore_Shortcut_Arrow.reg

    Вариант 1

    Для удаления стрелок с ярлыков:

    1) Запустите диалоговое окно "Выполнить" (Win + R)
    2) Скопируйте код указанный ниже и нажмите OK

    Для восстановления стрелок на ярлыках:

    Или в ручную удалите данную ветку.

    Вариант 2

    Для удаления стрелок с ярлыков:

    1) Создайте пустой файл иконки назовите его Blank.ico
    2) Скопируйте его в папку C:\Windows
    3) Запустите диалоговое окно "Выполнить" (Win + R)
    4) Скопируйте код указанный ниже и нажмите OK

    Для восстановления стрелок на ярлыках:

    1) Удалите файл Blank.ico из папки C:\Windows
    2) Запустите диалоговое окно "Выполнить" (Win + R)
    3) Скопируйте код указанный ниже и нажмите OK

    Или в ручную удалите данную ветку.

    Побочным эффектом при использовании данного варианта является, появление черных квадратиков вместо стрелочек, если в папке Windows у Вас будет отсутствовать файл Blank.ico.

    Вариант 3

    1) Скопируйте текст в блокнот.
    2) Сохраните как Remove_Shortcut_Arrow.reg (для удаления) или Restore_Shortcut_Arrow.reg (для восстановления).
    3) Выполните файл, чтобы его содержание было внесено в реестр.
    4) Обратите внимание на знак минуса в команде "IsShortCut"=-. Вокруг него нет кавычек. Эта команда удаляет значение IsShortCut и сам ключ IsShortCut. Если вы введёте команду "IsShortCut"="-", то тогда ключ удалён не будет, а его значение поменяется на минус. "IsNotShortCut"="" создаёт ключ и присваивает ему нулевое значение.

    Файл .reg для удаления стрелок с ярлыков

    Файл .reg для восстановления стрелок на ярлыках

    Побочным эффектом при использовании данного варианта является, исчезновение пункта "Закрепить программу в панели задач". Если Вам необходимо будет закрепить какую-либо программу в Панели задач, то воспользуйтесь reg-файлом для восстановления стрелок на ярлыках, закрепите программу, а затем снова воспользуйтесь reg-файлом для удаления стрелок с ярлыков.

    11. Удаление папок из Рабочего стола в области переходов проводника.

    Если Вы хотите, удалить папки из рабочего стола в области переходов проводника, воспользуйтесь одним из предложенных ниже вариантов.

    Вариант 1

    1) Нажмите Win+R
    2) Введите regedit и нажмите Ок
    3) Пройдите к ветке реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace
    4) Сделайте себе её экспорт, на случай восстановления(ПКМ на данной ветке-Экспортировать).
    5) Удалите следующие ветки:

    Favorites(Избранное) | {323CA680-C24D-4099-B94D-446DD2D7249E}
Libraries(Библиотеки) | {031E4825-7B94-4dc3-B131-E946B44C8DD5}
Homegroup(Домашняя группа) | {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}
Shared Documents(Общие Документы) | {59031a47-3f72-44a7-89c5-5595fe6b30ee}
Computer(Компьютер) | {20D04FE0-3AEA-1069-A2D8-08002B30309D}
Network(Сеть) | {F02C1A0D-BE21-4350-88B0-7367FC96EF3C}
Control Panel(Панель управления) | {26EE0668-A00A-44D7-9371-BEB064C98683}
Recycle Bin(Корзина) | {645FF040-5081-101B-9F08-00AA002F954E}

    Вариант 2

    Создайте и примените reg-файлы следующего содержания:

    Для удаления Favorites(Избранное):

    Для восстановления Favorites(Избранное) по умолчанию:

    Для удаления Libraries(Библиотеки):

    Для восстановления Libraries(Библиотеки) по умолчанию:

    Для удаления Homegroup(Домашняя группа):

    Для восстановления Homegroup(Домашняя группа) по умолчанию:

    Для удаления Computer(Компьютер):

    Для восстановления Computer(Компьютер) по умолчанию:

    Для удаления Network(Сеть):

    Для восстановления Network(Сеть) по умолчанию:

    Для удаления Recycle Bin(Корзина):

    Для восстановления Recycle Bin(Корзина) по умолчанию:

    12. Отключение суффикса "-Ярлык" при создании новых ярлыков.

    1) Запустите редактор реестра (Regedit).
    2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
    3) В правой части окна, дважды щелкните на параметр реестра "link".
    4) Измените значение на 00 00 00 00.
    5) Перезагрузите компьютер.

    Вы можете также создать и применить reg-файл следующего содержания:

    13. Отключение всплывающих подсказок для элeмeнтoв paбoчeгo cтoлa.

    1) Запустите редактор реестра (Regedit).
    2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    3) В правой части окна, дважды щелкните на параметр реестра "ShowInfoTip".
    4) Измените значение на 0.
    5) Перезагрузите компьютер.

    Вы можете также создать и применить reg-файл следующего содержания:

    14. Отключение диалога "Не удалось открыть файл".

    Если системе не знаком тип файла, который вы пытаетесь открыть, то сначала выводится диалоговое окно для поиска программы в интернете.

    Система предлагает Вам:

    Поиск соответствия в интернете. Если вы выберите этот вариант, то запускается веб-служба
    shell. windows. com/fileassoc/0409/xml/redir. asp? Ext=fb2 (пример для случая с FB2-файлом).
    Выбор программы из списка установленных программ. Открывает окно выбора программы для открытия файла на локальном компьютере.

    Для того чтобы не выводить окно для поиска файла в интернете, а сразу открывать окно выбора программы, воспользуйтесь одним из предложенных решений:

    1) Откройте редактор реестра (Win+R -> regedit)
    2) Перейдите к ветке этого создайте параметр HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте DWORD-параметр NoInternetOpenWith и установите его значение равным 1.

    или

    1) Нажмите кнопку "Пуск", и в строке поиска напечатайте cmd.exe.
    2) Щелкните на найденной программе правой кнопкой мыши и нажмите Запуск от имени администратора
    3) В командой строке напечатайте следующее:

    15. Максимально возможное отключение сглаживания шрифтов (ClearType) в Windows 7.

    Если Вы хотите максимально возможно отключить использование ClearType в aero-темах Windows 7, то Вам необходимо сделать следующее.

    Вариант 1.

    1) Отключите ClearType в системе.
    1.1) Откройте Панель управления -> Шрифты -> Настройка текста ClearType
    1.2) Снимите флажок "Включить ClearType".
    2) Отключите сглаживание любого типа шрифта.
    2.1) Откройте Панель управления -> Система -> Дополнительные параметры системы
    2.2) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры
    2.3) На вкладке Визуальные эффекты в списке снимите флажок Сгладить неровности экранных шрифтов
    3) Измените шрифт элементов окна.
    3.1) Откройте Панель управления -> Персонализация -> Цвет окна ->Дополнительные параметры оформления
    3.2) Установите для всех элементов вместо шрифта Segoe UI любой другой шрифт. Например: Tahoma; для всех элементов установите размер 8, для элементов "Заголовок активного окна" и "Заголовок неактивного окна", оставьте размер 9.
    4) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    5) Откройте ветку: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts
    6) Удалите присвоенные значения для указанных ниже параметров:

    Для изменения значения параметра щелкните на необходимом Вам параметре правой кнопкой мыши и нажмите Изменить.

    7) Откройте ветку: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes
    8) Создайте строковый (String) параметр с именем Segoe UI
    9) Щелкните на нем правой кнопкой мыши и нажмите Изменить.
    10) Установите значение параметра Tahoma и нажмите ОК.
    11) Перезагрузите компьютер.

    Примечание:

    П.1) Если крупный шрифт покажется Вам с нечеткими краями установите снятый флажок Сгладить неровности экранных шрифтов обратно.
    П.2) Если шрифт в проводнике и панели задач кажется расплывчатым, измените в ветке HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes значение параметра Segoe UI с Tahoma на MS Sans Serif
    П.3) При выборе шрифтов Tahoma или MS Sans Serif в калькуляторе пропадает изображение стрелки на клавише стереть последнюю цифру.
    П.4) Указанные действия применимы для 100% размера шрифта. Если у Вас стоит увеличение масштаба шрифта (чаще у широкоформатных мониторов), то проделайте следующее:
    П.4.1) Верните масштаб шрифта в 100% значение.
    П.4.2) Примените указанное в данном совете решение, включая перезагрузку.
    П.4.3) Установите необходимый Вам масштаб

    Вы можете скачать готовые reg-файлы, которые выполняют описанные выше действия: ClearType_on-off.zip
    Описание содержимого архива:

    ClearType-off.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов включен.
    ClearType_off+FS.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов отключен.
    ClearType_off+font.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов включен, изменен шрифт на MS Sans Serif.
    ClearType_off+FS+font.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов отключен, изменен шрифт на MS Sans Serif.
    ClearType-restore.reg - Восстановить исходные значения по умолчанию.

    Вариант 2. Ручная установка и удаление Windows Aero (Tahoma Font).

    Главным плюсом в отличие от предыдущего варианта является полное удаление привязки системы к шрифту Segoe UI и наличие изображения стрелки в калькуляторе.

    Установка Windows Aero (Tahoma Font).

    1) Скачайте и распакуйте в любую папку файл Windows Aero (Tahoma Font).zip
    2) Откройте папку Manual и в соответствии с разрядностью Вашей системы запустите Universal Theme Patcher. Данное действие позволит использовать Вам неподписанные темы.
    3) Нажмите кнопку Да (Yes), а затем напротив каждого из файлов кнопку Patch.
    4) Переключите интерфейс Вашей системы на классическую тему.
    5) Откройте папку C:\Windows\Resources\Themes\Aero\. Задайте полный доступ к файлу aero.msstyles для этого воспользуйтесь советом Администрирование: 1. Получение полного доступа к файлу или папке.
    6) Переименуйте файл aero.msstyles в aero.msstyles.backup.
    7) Скопируйте модифицированный файл aero.msstyles из папки Manual в папку C:\Windows\Resources\Themes\Aero\.
    8) Примените reg-файл "NoSegoe - Tahoma.reg".
    9) Откройте Панель управления -> Шрифты -> Настройка текста ClearType и снимите флажок "Включить ClearType". Нажмите несколько раз кнопку Далее, а затем кнопку Готово.
    10) Перезагрузите компьютер.
    11) Переключите обратно на Aero-тему.

    Удаление Windows Aero (Tahoma Font).

    1) Переключите интерфейс Вашей системы на классическую тему.
    2) Откройте папку C:\Windows\Resources\Themes\Aero\. Задайте полный доступ к файлу aero.msstyles для этого воспользуйтесь советом Администрирование: 1. Получение полного доступа к файлу или папке.
    3) Удалите файл aero.msstyles
    4) Переименуйте файл aero.msstyles.backup обратно в aero.msstyles.
    5) Откройте папку Manual из папки, где распакован архив и примените reg-файл "NoSegoe - Restore Segoe UI.reg".
    6) В соответствии с разрядностью Вашей системы запустите Universal Theme Patcher. Данное действие позволит использовать Вам неподписанные темы.
    7) Нажмите кнопку Да (Yes), а затем напротив каждого из файлов кнопку Restore.
    8) Откройте Панель управления -> Шрифты -> Настройка текста ClearType и установите флажок "Включить ClearType". Нажмите несколько раз кнопку Далее, а затем кнопку Готово.
    9) Перезагрузите компьютер.
    10) Переключите обратно на Aero-тему.

    Вариант 3. Автоматическая установка Windows Aero (Tahoma Font).

    Установка Windows Aero (Tahoma Font).

    1) Скачайте и распакуйте в любую папку файл Windows Aero (Tahoma Font).zip
    2) Откройте папку Auto.
    3) Нажмите правой кнопкой мыши на файле Windows Aero (Tahoma Font).exe и выберите пункт Запуск от имени администратора
    4) Нажмите клавишу Next в первом окне, во втором окне установите переключатель в значение I accept the agreement и нажмите кнопку Next.
    5) В окне Information также нажмите кнопку Next.
    6) В окне Select Components установите все флажки и нажмите кнопку Next.
    7) В окне Ready to Install нажмите кнопку Install и запустится установка.
    8) В окне Windows Aero (Tahoma Font) Setup информирующем о переключении интерфейса на классическую тему нажмите кнопку ОК.
    9) После того как программа переключится на классическую тему вернитесь обратно в программу.
    10) В окне Windows Aero (Tahoma Font) Setup информирующем о необходимости нажатия кнопки Yes при запуске скриптов для данной программы нажмите кнопку ОК.
    11) Установите переключатель в значение Yes, restart the computer now и нажмите кнопку Finish.
    12) Компьютер перезагрузится и если у Вас включен Контроль учетных записей (UAC), то в окнах предлагающих запустить Microsoft Windows Based Script Host нажмите кнопку Да (Yes).

    Удаление Windows Aero (Tahoma Font).

    1) Откройте Панель управления -> Программы и компоненты и щелкните на Windows Aero (Tahoma Font)
    2) В появившемся окне нажмите Да, а в следующем ОК.
    3) В окне Windows Aero (Tahoma Font) Setup информирующем о необходимости нажатия кнопки Yes при запуске скриптов для данной программы нажмите кнопку ОК.
    4) В окне предлагающем перезапустить компьютер нажмите Да
    5) Компьютер перезагрузится и если у Вас включен Контроль учетных записей (UAC), то в окнах предлагающих запустить Microsoft Windows Based Script Host нажмите кнопку Да (Yes).

    Примечание:

    П. Если после установки или удаления программа не переключила обратно на Вашу aero-тему, то сделайте это вручную.

    16. Изменение набора кнопок на панели проводника Windows 7.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    На панели проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами для хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения набора кнопок во всех папках проводника добавьте или удалите кнопки во все шаблоны.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для изменения отображаемых кнопок сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку необходимого Вам шаблона.
    Например: для добавления или удаления кнопки в обычную папку использующую шаблон типа папки «Общие элементы» откройте:

    А для добавления или удаления кнопки в папку «Общие элементы», входящей в Библиотеки откройте:

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

    4.1) Откройте необходимый из указанных подразделов, если Вы изменяете набор кнопок в шаблонах Библиотек и/или в шаблонах поиска результатов в них.
    4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать -> Раздел.)

    TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
    TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

    5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Изменить.
    6) Добавьте к существующим значениям необходимые или удалите ненужные.
    Порядок значений в списке соответствует порядку отображения кнопок на панели. Значения отделяются друг от друга точкой с запятой (;).
    Например: Windows.Copy;Windows.Paste;Windows.Delete;

    Список возможных кнопок для добавления Вы можете узнать из названий подразделов в ветке реестра:

    В таблице ниже указаны значения наиболее часто используемых кнопок.

    Кнопка | Действие | Использование
Windows.burn | Записать на оптический диск | TasksItemsSelected
Windows.closewindow | Закрыть (окно) <ALT+F4> | TasksItemsSelected, TasksNoItemsSelected
Windows.copy | Вырезать <CTRL+C> | TasksItemsSelected
Windows.cut | Копировать <CTRL+X> | TasksItemsSelected
Windows.delete | Удалить <Del> | TasksItemsSelected
Windows.email | Электронная почта | TasksItemsSelected
Windows.folderoptions | Параметры папок и поиска | TasksNoItemsSelected
Windows.includeinlibrary | Включить в библиотеку | TasksItemsSelected
Windows.layout | Представление (вкл. и выкл. областей проводника) | TasksNoItemsSelected
Windows.librarypane | Область библиотек (под панелью кнопок) | TasksNoItemsSelected
Windows.menubar | Строка меню (ALT) | TasksNoItemsSelected
Windows.navpane | Область переходов | TasksNoItemsSelected
Windows.newfolder | Создать новую папку | TasksNoItemsSelected
Windows.paste | Вставить (CTRL+V) | TasksItemsSelected, TasksNoItemsSelected
Windows.previewpane | Область сведений | TasksNoItemsSelected
Windows.print | Печать | TasksItemsSelected
Windows.properties | Свойства (файла, папки, библиотеки) <ALT+Enter> | TasksItemsSelected, TasksNoItemsSelected
Windows.readingpane | Область предпросмотра <Alt+P> | TasksNoItemsSelected
Windows.redo | Вернуть (возврат последнего отмененного действия) <CTRL+Y> | TasksNoItemsSelected
Windows.removeproperties | Удалить свойства (файла, папки, библиотеки) | TasksItemsSelected, TasksNoItemsSelected
Windows.rename | Переименовать <F2> | TasksItemsSelected
Windows.selectall | Выделить все <CTRL+A> | TasksNoItemsSelected
Windows.separator | Разделитель (кнопка без подписи и действия) | TasksItemsSelected, TasksNoItemsSelected
Windows.Share | Общий доступ | TasksItemsSelected
Windows.slideshow | Показ слайдов | TasksItemsSelected, TasksNoItemsSelected
Windows.undo | Отменить <CTRL+Z> | TasksNoItemsSelected

    17. Изменение состава меню "Упорядочить" на панели Проводника Windows 7.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    На панели проводника почти везде присутствуют кнопка Упорядочить, при нажатии на которую появляется меню с определенным набором выполняемых команд и подменю Представление.

    Для изменения пунктов отображающихся в данном меню сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку:

    Для внесения изменений в меню Упорядочить:

    Для внесения изменений в меню Представление:

    3) Задайте полные права на доступ к выбранному разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Щелкните правой кнопкой мыши на параметре SubCommands и выберите Изменить.
    5) Добавьте к существующим значениям необходимые или удалите ненужные.
    Порядок значений в списке соответствует порядку отображения пунктов списка. Значения отделяются друг от друга точкой с запятой (;) , символ | означает разделитель меню, после него также ставится точка с запятой.

    Список значений параметра SubCommands для меню Упорядочить по умолчанию:

    Список значений параметра SubCommands для подменю Упорядочить по умолчанию:

    Список пунктов возможных для добавления Вы можете узнать из названий подразделов в ветке реестра:

    В таблице ниже указаны значения наиболее часто используемых пунктов.

    Кнопка | Действие | Использование
Windows.burn | Записать на оптический диск | TasksItemsSelected
Windows.closewindow | Закрыть (окно) <ALT+F4> | TasksItemsSelected, TasksNoItemsSelected
Windows.copy | Вырезать <CTRL+C> | TasksItemsSelected
Windows.cut | Копировать <CTRL+X> | TasksItemsSelected
Windows.delete | Удалить <Del> | TasksItemsSelected
Windows.email | Электронная почта | TasksItemsSelected
Windows.folderoptions | Параметры папок и поиска | TasksNoItemsSelected
Windows.includeinlibrary | Включить в библиотеку | TasksItemsSelected
Windows.layout | Представление (вкл. и выкл. областей проводника) | TasksNoItemsSelected
Windows.librarypane | Область библиотек (под панелью кнопок) | TasksNoItemsSelected
Windows.menubar | Строка меню (ALT) | TasksNoItemsSelected
Windows.navpane | Область переходов | TasksNoItemsSelected
Windows.newfolder | Создать новую папку | TasksNoItemsSelected
Windows.paste | Вставить (CTRL+V) | TasksItemsSelected, TasksNoItemsSelected
Windows.previewpane | Область сведений | TasksNoItemsSelected
Windows.print | Печать | TasksItemsSelected
Windows.properties | Свойства (файла, папки, библиотеки) <ALT+Enter> | TasksItemsSelected, TasksNoItemsSelected
Windows.readingpane | Область предпросмотра <Alt+P> | TasksNoItemsSelected
Windows.redo | Вернуть (возврат последнего отмененного действия) <CTRL+Y> | TasksNoItemsSelected
Windows.removeproperties | Удалить свойства (файла, папки, библиотеки) | TasksItemsSelected, TasksNoItemsSelected
Windows.rename | Переименовать <F2> | TasksItemsSelected
Windows.selectall | Выделить все <CTRL+A> | TasksNoItemsSelected
Windows.separator | Разделитель (кнопка без подписи и действия) | TasksItemsSelected, TasksNoItemsSelected
Windows.Share | Общий доступ | TasksItemsSelected
Windows.slideshow | Показ слайдов | TasksItemsSelected, TasksNoItemsSelected
Windows.undo | Отменить <CTRL+Z> | TasksNoItemsSelected

    18. Изменение отображаемых по умолчанию свойств для файла в проводнике.

    При выделении файла в проводнике, система отображает в области сведений соответствующую ему информацию. Также сведения отображаются при наведении на него курсора мыши или на вкладке Подробно в окне Свойства, вызываемом из контекстного меню.

    Для настройки сведений, отображаемых для файла в проводнике, сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте раздел соответствующий наименованию необходимого Вам расширения файла в указанных ниже ветках реестра:

    2.1) чтобы изменить отображаемые сведения для всех пользователей на компьютере (если Вы администратор компьютера):

    2.2) чтобы изменить отображаемые сведения для текущей записи:

    Например, для расширения .mp3 откройте:

    3) Измените значения параметров:

    InfoTip - отвечает за информацию отображаемую во всплывающей подсказке
    PreviewDetails - отвечает за информацию отображаемую в области сведений проводника
    FullDetails - отвечает за информацию отображаемую во вкладке Подробно в Свойствах файла

    4) Щелкните правой кнопкой мыши на выбранном параметре и выберите Изменить.
    5) После слова prop: добавьте к существующим значениям необходимые или удалите ненужные.
    Порядок значений в списке соответствует порядку отображения пунктов в системе. Значения отделяются друг от друга точкой с запятой.

    Например, для файлов с расширением .mp3 Вы можете выставить значение:

    В таблице ниже, указаны значения наиболее часто используемых значений данных параметров.

    Наименование значения параметра | Отображаемое значение
System.Audio.ChannelCount | Каналы, количество
System.Audio.EncodingBitrate | Скорость потока
System.Audio.EncodingBitrate | Скорость потока
System.Audio.SampleRate | Частота дискретизации
System.Author | Авторы
System.Comment | Комментарии
System.ComputerName | Компьютер
System.Copyright | Авторские права
System.DateCreated | Дата создания
System.DateModified | Дата изменения
System.FileAttributes | Атрибуты
System.FileOwner | Владелец
System.Image.BitDepth | Глубина цвета
System.Image.Dimensions | Размеры
System.Image.HorizontalResolution | Горизонтальное разрешение
System.Image.HorizontalSize | Ширина
System.Image.ResolutionUnit | Единица разрешения
System.Image.VerticalResolution | Разрешение по вертикали
System.Image.VerticalSize | Высота
System.ItemFolderPathDisplay | Путь к папке
System.ItemNameDisplay | Имя
System.ItemType | Тип элемента
System.Keywords | Ключевые слова
System.Media.DateEncoded | Дата создания мультимедиа
System.Media.Duration | Продолжительность
System.Media.SubTitle | Субтитры
System.Media.Year | Год
System.Music.Artist | Участвующие исполнители
System.Music.Genre | Жанр
System.Photo.DateTaken | Дата съемки
System.PropGroup.Audio | Группа Аудио
System.PropGroup.Content | Группа Содержание
System.PropGroup.Description | Группа Описание
System.PropGroup.FileSystem | Группа Файл
System.PropGroup.Image | Группа Изображение
System.PropGroup.Media | Группа Носитель
System.PropGroup.Origin | Группа Источник
System.PropGroup.Video | Группа Видео
System.Rating | Оценка
System.SharedWith | Общий доступ
System.Size | Размер
System.Subject | Тема
System.Title | Название
System.Video.EncodingBitrate | Скорость передачи данных
System.Video.FrameHeight | Высота кадра
System.Video.FrameRate | Частота кадров
System.Video.FrameWidth | Ширина кадра
System.Video.TotalBitrate | Общая скорость потока

    19. Изменение используемых по умолчанию столбцов в проводнике для папок, при выборе отображения в виде таблицы.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    При выборе в проводнике вида отображения Таблица, система показывает определенные столбцы. Вы можете настроить для любой папки свой собственный набор столбцов, щелкнув правой кнопкой мыши на любом из них и во всплывающем меню выбрав пункт Подробнее..., если же Вам необходимо изменить столбцы отображаемые по умолчанию, то Вам необходимо внести соответствующие изменения в реестр.

    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами для хранения файлов, измените набор столбцов в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения набора столбцов во всех папках проводника добавьте или удалите значения во всех шаблонах.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для настройки столбцов, используемых по умолчанию в проводнике, сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку необходимого Вам шаблона.
    Например: для добавления или удаления столбцев в обычной папке использующей шаблон типа папки «Музыка» откройте:

    А для добавления или удаления столбцев в папке «Музыка», входящей в Библиотеки откройте:

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TopViews
    5) Поочередно открывая подразделы типа {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX} измените значения параметра ColumnList (щелчок правой кнопкой мыши на параметре -> Изменить) стоящие после слова prop: .
    6) Для включения необходимого Вам столбца измените значение стоящее перед ним на 0. Цифра 0 перед указанным Вами параметром сообщит системе, что данный столбец необходимо отобразить. Если необходимый Вам столбец отсутствует, то Вы можете добавить его самостоятельно, указав перед ним цифру 0. Значения отделяются друг от друга точкой с запятой (;). Например: для изменения столбцов как на рисунке, в начале совета значение параметра ColumnList примет вид:

    В таблице ниже, указаны значения наиболее часто используемых значений данного параметра.

    Наименование значения параметра | Отображаемое значение
System.Audio.ChannelCount | Каналы, количество
System.Audio.EncodingBitrate | Скорость потока
System.Audio.EncodingBitrate | Скорость потока
System.Audio.SampleRate | Частота дискретизации
System.Author | Авторы
System.Comment | Комментарии
System.ComputerName | Компьютер
System.Copyright | Авторские права
System.DateCreated | Дата создания
System.DateModified | Дата изменения
System.FileAttributes | Атрибуты
System.FileOwner | Владелец
System.Image.BitDepth | Глубина цвета
System.Image.Dimensions | Размеры
System.Image.HorizontalResolution | Горизонтальное разрешение
System.Image.HorizontalSize | Ширина
System.Image.ResolutionUnit | Единица разрешения
System.Image.VerticalResolution | Разрешение по вертикали
System.Image.VerticalSize | Высота
System.ItemFolderPathDisplay | Путь к папке
System.ItemNameDisplay | Имя
System.ItemType | Тип элемента
System.Keywords | Ключевые слова
System.Media.DateEncoded | Дата создания мультимедиа
System.Media.Duration | Продолжительность
System.Media.SubTitle | Субтитры
System.Media.Year | Год
System.Music.Artist | Участвующие исполнители
System.Music.Genre | Жанр
System.Photo.DateTaken | Дата съемки
System.PropGroup.Audio | Группа Аудио
System.PropGroup.Content | Группа Содержание
System.PropGroup.Description | Группа Описание
System.PropGroup.FileSystem | Группа Файл
System.PropGroup.Image | Группа Изображение
System.PropGroup.Media | Группа Носитель
System.PropGroup.Origin | Группа Источник
System.PropGroup.Video | Группа Видео
System.Rating | Оценка
System.SharedWith | Общий доступ
System.Size | Размер
System.Subject | Тема
System.Title | Название
System.Video.EncodingBitrate | Скорость передачи данных
System.Video.FrameHeight | Высота кадра
System.Video.FrameRate | Частота кадров
System.Video.FrameWidth | Ширина кадра
System.Video.TotalBitrate | Общая скорость потока

    7) Перезагрузите компьютер
    8) Для папок из библиотек, щелкните правой кнопкой мыши внутри основной папки (Видео, Документы, Изображения, Музыка) выберите Упорядочить -> Очистить изменения
    9) Для обычных папок измените шаблон на другой вид в Свойства -> Настройка, а затем верните обратно.
    10) Также очистите в реестре указанный ниже раздел, удалив все папки кроме AllFolders.

    Очистка данного раздела реестра удалит все настройки для папок сделанные пользователями, до применения данного совета.

    20. Изменение пунктов контекстного меню "Сортировка" используемых по умолчанию в проводнике.
    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    При нажатии правой кнопки мыши в любой папке в проводнике, система показывает контекстное меню. В данном меню есть пункт Сортировка, содержащий свое собственное меню. Вы можете настроить для любой папки свой собственный вид меню Сортировка, выбрав в нем пункт Подробнее..., если же Вам необходимо изменить вид данного меню отображаемый по умолчанию для всех папок, то Вам необходимо внести соответствующие изменения в реестр.

    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами для хранения файлов, измените вид меню Сортировка в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения набора пунктов во всех папках проводника добавьте или удалите значения во всех шаблонах.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для настройки меню Сортировка, используемого по умолчанию в проводнике, сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку необходимого Вам шаблона.
    Например: для добавления или удаления пунктов в меню Сортировка для обычной папки использующей шаблон типа папки «Музыка» откройте:

    А для добавления или удаления пунктов в меню Сортировка для папки «Музыка», входящей в Библиотеки откройте:

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TopViews
    5) Поочередно открывая подразделы типа {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX} измените значения параметра SortByList (щелчок правой кнопкой мыши на параметре -> Изменить) стоящие после слова prop: .
    6) Добавьте к существующим значениям необходимые или удалите ненужные.
    Порядок значений в списке соответствует порядку отображения пунктов в меню. Значения отделяются друг от друга точкой с запятой (;).
    Например:

    В таблице ниже, указаны значения наиболее часто используемых значений данного параметра.

    Наименование значения параметра | Отображаемое значение
System.Audio.ChannelCount | Каналы, количество
System.Audio.EncodingBitrate | Скорость потока
System.Audio.EncodingBitrate | Скорость потока
System.Audio.SampleRate | Частота дискретизации
System.Author | Авторы
System.Comment | Комментарии
System.ComputerName | Компьютер
System.Copyright | Авторские права
System.DateCreated | Дата создания
System.DateModified | Дата изменения
System.FileAttributes | Атрибуты
System.FileOwner | Владелец
System.Image.BitDepth | Глубина цвета
System.Image.Dimensions | Размеры
System.Image.HorizontalResolution | Горизонтальное разрешение
System.Image.HorizontalSize | Ширина
System.Image.ResolutionUnit | Единица разрешения
System.Image.VerticalResolution | Разрешение по вертикали
System.Image.VerticalSize | Высота
System.ItemFolderPathDisplay | Путь к папке
System.ItemNameDisplay | Имя
System.ItemType | Тип элемента
System.Keywords | Ключевые слова
System.Media.DateEncoded | Дата создания мультимедиа
System.Media.Duration | Продолжительность
System.Media.SubTitle | Субтитры
System.Media.Year | Год
System.Music.Artist | Участвующие исполнители
System.Music.Genre | Жанр
System.Photo.DateTaken | Дата съемки
System.PropGroup.Audio | Группа Аудио
System.PropGroup.Content | Группа Содержание
System.PropGroup.Description | Группа Описание
System.PropGroup.FileSystem | Группа Файл
System.PropGroup.Image | Группа Изображение
System.PropGroup.Media | Группа Носитель
System.PropGroup.Origin | Группа Источник
System.PropGroup.Video | Группа Видео
System.Rating | Оценка
System.SharedWith | Общий доступ
System.Size | Размер
System.Subject | Тема
System.Title | Название
System.Video.EncodingBitrate | Скорость передачи данных
System.Video.FrameHeight | Высота кадра
System.Video.FrameRate | Частота кадров
System.Video.FrameWidth | Ширина кадра
System.Video.TotalBitrate | Общая скорость потока

    21. Запрещение подмены функции кнопки "Завершения работы" при необходимости обновления системы.

    При наличии обновлений, ожидающих установки, на кнопке завершения работы Windows появляется значок со щитом.

    Если не применить данный твик реестра, то когда имеются обновления, доступные для установки, при выборе в меню Пуск команды Завершение работы по умолчанию выберется действие - Установить обновления и завершить работу.
    Чтобы отключить данную функцию в диалоговом окне Завершение работы Windows и отобразить по умолчанию параметр, выбранный при последнем выключении (Гибернация, Перезагрузка и т. д.), вне зависимости от доступности параметра Установить обновления и завершить работу в списке создайте и примените reg-файл следующего содержания:

    22. Постоянное отображение команд "Открыть окно команд" и "Копировать как путь" в контекстном меню проводника.

    Если Вы будете удерживать клавишу Shift при нажатии правой кнопки мыши, то в контекстном меню появятся дополнительные пункты Открыть командную строку и Копировать как путь.

    Чтобы пункт Открыть командную строку отображался без нажатия Shift создайте и примените нижеследующий reg-файл:

    Чтобы заставить пункт Открыть командную строку снова отображаться только при нажатии Shift создайте и примените нижеследующий reg-файл:

    Чтобы пункт Копировать как путь отображался без нажатия Shift создайте и примените нижеследующий reg-файл:

    Минус такого решения - появляющееся на доли секунды окно командной строки.

    Чтобы заставить пункт Копировать как путь снова отображаться только при нажатии Shift создайте и примените нижеследующий reg-файл:

    Если Вам не нравится появляющееся на долю секунды окно командной строки, то Вы можете воспользоваться утилитой NirCmd
    Данная утилита позволяет выполнять команды командной строки без отображения окна команд.
    Для отображения пункта Копировать как путь без нажатия Shift, сделайте следующее:

    1) Скачайте утилиту NirCmd в соответствии с разрядностью Вашей Windows
    2) Распакуйте скаченный zip-архив в папку C:\NirCmd
    3) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    4) Откройте раздел HKEY_CLASSES_ROOT\AllFilesystemObjects\shell\CopyAsPath\Command
    5) Измените значение параметра По умолчанию на:

    23. Добавление произвольного системного ActiveX-элемента в Рабочий стол области переходов проводника.

    По умолчанию в проводнике отображается определенный набор объектов ActiveX: Избранное, Библиотеки, Компьютер и Сеть или более расширенный, если у Вас в настройках элемента Параметры папок установлен флажок Показать все папки.

    Чтобы добавить какой-либо из системных объектов в область переходов, Вам необходимо знать его статистически уникальный 128-битный идентификатор - {GUID}.
    Список всех идентификаторов ({GUID}) находится в разделе реестра: HKEY_CLASSES_ROOT\CLSID\{GUID}. Из данного списка в в область переходов, добавить Вы можете, те ActiveX-объекты, которые имеют интерфейс IShellFolder (интерфейс для объектов, расширяющих пространство имен оболочки). Данный факт определяется наличием в {GUID} разделе реестра подраздела ShellFolder.
    Для экономии времени, необходимого на поиск нужного элемента Вы можете воспользоваться утилитой CSLID Dump, позволяющей получить список всех ActiveX-объектов, имеющих IShellFolder интерфейс.

    1) Скачайте CSLID Dump, распакуйте архив и запустите программу.
    2) Найдите в CLSID Dump, необходимый Вам {GUID} ActiveX-объекта и откройте его в реестре:
    2.1) Нажмите в самой программе на кнопку Open Regedit
    или
    2.2) Запустите редактор реестра (Win+R -> regedit -> ОК) и откройте раздел

    где вместо {GUID} вставьте найденное Вами значение.
    3) Откройте в данном разделе подраздел ShellFolder.

    Например: элементу "Все задачи" соответствует {GUID} равный {ED7BA470-8E54-465E-825C-99712043E01C}, следовательно необходимо открыть:

    4) Задайте полные права на доступ к разделу HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder.

    4.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    4.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    4.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    4.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    4.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    5) Если в разделе HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder присутствует строковый параметр WantsParseDisplayName, то удалите его.
    6) Если в разделе HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder отсутствует строковый параметр PinToNameSpaceTree, то создайте его с пустым значением.

    Включите отображение объекта для перечисления.

    7) Если необходимо, измените значение параметра Attributes таким образом, чтобы третья цифра стала равна 0. Например: вместо 20100004 задайте 20000004 .

    Добавьте Ваш ActiveX-объект в пространство имен Рабочего стола.

    8) Перейдите в раздел:

    9) Создайте здесь подраздел с названием идентичным Вашему {GUID}. Например:

    Разрешите отображение Вашего объекта только в области переходов проводника, исключая отображение его на Рабочем столе.

    11) Перейдите в раздел:

    12) Создайте здесь DWORD-параметр с названием идентичным Вашему {GUID} и задайте ему значение равное 1.
    13) Закройте редактор реестра.
    14) Выйдите из системы и войдите в неё заново или перезагрузите компьютер.

    Описанным выше способом, Вы можете добавить почти любой из ActiveX-объектов имеющих интерфейс IShellFolder.

    24. Изменение вида приглашения в командной строке.

    Вы можете изменить вид приглашения для командной строки. Как правило используется формат типа C:\> (текущий диск и угловая скобка).

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте раздел HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
    3) Создайте PROMPT типа REG_EXPAND_SZ (расширяемый строковый параметр)
    4) Присвойте ему любое из следующих значений (значения можно объединять):

    $B - | (вертикальная черта)
    $D - текущая дата
    $G - > (знак больше)
    $L - < (знак меньше)
    $N - текущий диск
    $P - текущий диск и путь
    $Q - = (знак равно)
    $T - текущее время
    $V - версия Windows
    $$ - $ (знак доллара)
    $A - & (амперсанд)
    $C - ( (левая скобка)
    $F - ) (правая скобка)
    $S - пробел
    [%computername%] - имя Вашего компьютера
    $_ - переход к началу новой строки экрана

    5) Перезагрузите компьютер.

    Например при введении знгачения:

    Вы увидите строку наподобие:

    25. Изменение языка интерфейса установленного по умолчанию (язык системы), для возможности его удаления или правильного определения программами.

    Иногда бывает, если у Вас установлена английская версия и сверху русский языковой пакет, то некоторые программы, имеющие встроенную функцию определения языка могут некорректно определить язык Вашей системы и автоматически запускаться с английским языком интерфейса.
    Также, если Вы решите удалить английский язык из системы после установки сверху русского языкового пакета, то система не позволит Вам этого сделать. Это происходит потому, что для Windows английский язык - это язык системы или язык интерфейса установленный по умолчанию, а русский язык - дополнительный язык интерфейса.

    Чтобы переключить язык интерфейса установленного по умолчанию создайте и примените reg-файл, после чего перезагрузите компьютер.

    Чтобы установить русский язык, в качестве языка используемого по умолчанию (язык системы):

    Чтобы установить английский язык, в качестве языка используемого по умолчанию (язык системы):

    26. Настройка вида, используемого по умолчанию для папок в проводнике и в диалоговом окне "Открыть/Сохранить файл".

    При нажатии правой кнопки мыши в любой папке в проводнике, система показывает контекстное меню. В данном меню есть пункт Вид, используя который Вы можете настроить для любой папки свой собственный вид. Но если же Вам необходимо изменить вид папки используемый по умолчанию для всех папок, то Вам необходимо внести соответствующие изменения в реестр.

    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами для хранения файлов, измените значения в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения вида папок по умолчанию во всех папках проводника добавьте или удалите значения во всех шаблонах.

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для настройки используемого по умолчанию вида папки, сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) В зависимости от того, для чего Вы хотите настроить используемый по умолчанию вид папки, откройте соответствующий раздел реестра.

    Для использования по умолчанию в проводнике:

    Для использования по умолчанию в стандартном диалоге "Открыть/Сохранить файл":

    3) Создайте раздел, соответствующий GUID выбранного Вами шаблона. Например, для настройки вида папок использующих наиболее часто встречающийся шаблон "Общие элементы" создайте:

    Для использования по умолчанию в проводнике:

    Для использования по умолчанию в стандартном диалоге "Открыть/Сохранить файл":

    4) Создайте в данном разделе три параметра DWORD: IconSize,LogicalViewMode и Mode и задайте им значения в соответствии с нижеследующей таблицей. Для удобства использования значения предоставлены в двух системах исчисления.

    Вид папки: | Система исчисления | IconSize | LogicalViewMode | Mode
Огромные значки | Десятичная | 256 | 3 | 1
 | Шестнадцатеричная | 100 | 3 | 1
Крупные значки | Десятичная | 96 | 3 | 1
 | Шестнадцатеричная | 60 | 3 | 1
Обычные значки | Десятичная | 48 | 3 | 1
 | Шестнадцатеричная | 30 | 3 | 1
Мелкие значки | Десятичная | 16 | 3 | 1
 | Шестнадцатеричная | 10 | 3 | 1
Список | Десятичная | 16 | 4 | 3
 | Шестнадцатеричная | 10 | 4 | 3
Таблица | Десятичная | 16 | 1 | 4
 | Шестнадцатеричная | 10 | 1 | 4
Плитка | Десятичная | 48 | 2 | 6
 | Шестнадцатеричная | 30 | 2 | 6
Содержимое | Десятичная | 32 | 5 | 8
 | Шестнадцатеричная | 20 | 5 | 8

    Например, чтобы установить вид папки Крупные значки создайте DWORD-параметры IconSize=60, LogicalViewMode=3 и Mode=1.

    5) Перезагрузите компьютер или перезайдите в систему.

    Примечание:

    Если Вы ранее в проводнике вручную изменяли вид для какой-либо папки, то система записала Ваши изменения в реестр, и чтобы желаемый Вами вид папки установился также и в них, то Вам необходимо, выполнить на выбор одно из предложенных действий:

    1) Удалить из раздела HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags все папки, кроме AllFolders
    2) Изменить параметры Mode, LogicalViewMode и IconSize на необходимые Вам значения в разделах:

    где XXX - номер папки (раздела), в который записаны значения измененных Вами параметров.
    {GUID} - данный GUID соответствует типу папки.

    27. Удаление открываемых путей из истории в адресной строке проводника.

    Когда Вы вводите путь в адресную строку проводника, то он сохраняется в журнал расположений. И если Вы в дальнейшем нажмете на стрелку вниз в конце адресной строки, то откроется список предыдущих расположений.
    Если Вам необходимо его очистить,то Вы можете либо полностью стереть историю открываемых путей или удалить отдельные записи.

    Чтобы очистить всю Вашу историю посещений в проводнике, щелкните правой кнопкой мыши на адресной строке и выберите из меню пункт Удалить журнал.

    Чтобы удалить отдельные записи:

    1) Запустите редактор реестра (Win+R->regedit->ОК)
    2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\TypedPaths
    3) Удалите параметры, в которых содержатся ненужные вам пути.
    4) Перезайдите в систему или закройте все процессы проводника и запустите его снова.

    28. Добавление отображения логотипа и сопутствующей информации.

    1) Создайте рисунок с нужным Вам логотипом.
    2) Сохраните его с разрешением 120x120 в формате .bmp (Например, в папке C:\Windows\System32 под именем OEMLogo.bmp).
    3) Запустите редактор реестра (Win+R -> regedit -> OK)
    4) Откройте раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\OEMInformation
    5) Создайте строковые параметры с необходимыми Вам значениями. Например:

    Model - Название модели
    Manufacturer - Название фирмы
    SupportPhone - Телефон поддержки
    SupportURL - Адрес сайта службы поддержки
    SupportHours - Время работы тех.поддержки
    Logo - Путь к Вашему логотипу.

    6) Перезагрузите компьютер.

    Также Вы можете создать и применить reg-файл.

    Пример:

    Твики Реестра - Дополнительная функциональность.

    1. Распаковка Хотфиксов(обновлений Microsoft с расширением EXE) из контекстного меню.

    Для распаковки инсталляций, удобно пользоваться Universal Extractor-ом, но последняя версия не все хотфиксы от MS распаковывает правильно и приходится пользоваться другими методами. Одним из вариантов является добавление в контекстное меню команды Unpack HotFix.
    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Чтобы добавить данный пункт в контекстное меню, создайте следующий reg-файл:

    Например, при распаковке Windows6.1-KB917607-x64.exe, на выходе получаем папку Windows6.1-KB917607-x64.exe_unpacked с извлечёнными файлами.
    Минус один - команда Unpack HotFix встраивается в контекстное меню всех exe-файлов, а не только файлов от Microsoft.

    Чтобы удалить данный пункт из контекстного меню, создайте следующий reg-файл:

    Готовые reg-файлы Вы можете скачать по ссылке: Unpack_HotFix.zip

    2. Добавление пункта "Открыть в блокноте" в контекстное меню файлов.

    1) Создайте reg-файл.
    1.1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    1.2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "Notepad.reg")
    1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    2) Примените полученный reg-файл. Щелкните на нем дважды и нажми кнопку Да.

    3. Добавление системных ярлыков в папку Компьютер.

    Создайте и примените reg-файлы следующего содержания:

    Администрирование

    Корзина

    Панель управления

    Принтеры и факсы

    Учетные записи пользователей

    4. Добавление произвольной команды в контекстное меню рабочего стола.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "fix.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    5) Примените его.

    Вместо Название команды укажите необходимое Вам название пункта, которое будет отображаться в контекстном меню. Например: Панель управления
    Вместо выполняемая команда укажите какая команда должна быть запущена при нажатии созданного Вами пункта в контекстном меню. Например: control
    Вместо путь к значку иконки укажите путь к иконке, отображаемой рядом с Вашим пунктом в контекстном меню.
    Вместо Расположение укажите месторасположение Вашего пункта в контекстном меню. Top - вверху, Bottom - внизу.

    Описанным выше способом можно добавить практически любую команду.
    Например, reg-файл для добавления пункта Панель управления в контекстное меню рабочего стола будет выглядеть так:

    5. Распаковка файлов и директорий из CAB-архивов (а так же упаковка в CAB-архивов) из контекстного меню "Отправить".
    Reg-файл добавляет в расширенное меню оболочки функции для упаковки и распаковки CAB. С папками, в пути к которым есть пробелы и спецсимволы, к сожалению, не работает.

    6. Добавление пункта "Удалить содержимое папки" в контекстное меню.

    Как добавить в контекстное меню папки команду для удаления содержимого папки без удаления самой папки? Вы можете создать себе пункт Удалить содержимое папки в контекстном меню и Вам достаточно будет его только выбрать. Вам не придется открывать папку, выделять все файлы и нажимать на клавишу Delete.

    Вариант 1.

    1) Запустите редактор реестра: Win+R -> regedit -> Ok
    2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
    3) Создайте в ней раздел DeleteFolderContent
    4) Создайте в нем строковый(String) параметр MUIVerb со строкой Удалить содержимое папки.
    5) В разделе DeleteFolderContent создайте подраздел command
    6) Измените значение параметра (По умолчанию) раздела command на следующее:

    Вариант 2.

    1) Запустите редактор реестра: Win+R -> regedit -> Ok
    2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
    3) Создайте в ней раздел Удалить содержимое папки
    4) В разделе Удалить содержимое папки создайте подраздел command
    6) Измените значение параметра (По умолчанию) раздела command на следующее:

    Вариант 3.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Вы можете скачать готовые reg-файлы: DeleteFolderContent.zip

    7. Добавление пунктов "Копировать в папку" и "Переместить в папку" в контекстное меню.

    По какой-то неизвестной причине, разработчики Microsoft решили не включать в контекстное меню Проводника пункты Копировать в папку (Copy To) и Переместить в папку (Move To). Используя их, можно легко и быстро скопировать или переместить файл или папку. Для этого, достаточно выбрать желаемое место их размещения в соответствующем диалоговом окне. Для того, чтобы добавить эти команды в контекстное меню, достаточно создать, соответствующие им параметры в реестре.

    Вариант 1

    1) Запустите Редактор Реестра (нажмите копку «Пуск» (Start), введите regedit в строке «Найти программы и файлы» и нажмите Enter).
    2) Откройте ветку реестра HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers
    3) Создайте в ней раздел со следующим именем (включая фигурные скобки):
    Для добавления в контекстное меню пункта Копировать в папку

    Для добавления в контекстное меню пункта Переместить в папку

    4) Нажмите Enter
    5) Перезагрузите Проводник Windows (Windows Explorer) или перезайдите в систему, и данные пункты появятся в контекстном меню.

    Вариант 2

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    8. Добавление своего ярлыка папки или программы в папку Компьютер.

    Если Вы часто пользуйтесь какой-либо программой, то помимо добавления её значка на рабочий стол, Вы также можете добавить его в папку Компьютер. Поскольку скопировать напрямую или создать ярлык в данной папке нельзя, то предлагаю Вам решение, как это возможно осуществить.

    1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот):

    2) Скачайте программу Microsoft Exchange Server GUID Generator
    3) Распакуйте архив и запустите программу (GUIDGEN.EXE)
    4) Установите переключатель на значение Registry Format
    5) Нажмите на кнопку New GUID, и программа сгенерирует Вам новый GUID
    6) Нажмите на кнопку Copy, и программа скопирует его в буфер обмена
    7) Вставьте вместо {GUID}, сгенерированный программой GUID.
    Теперь у Вас вместо {GUID}, должен быть цифровой идентификатор, например: {FF4A6226-C00B-409e-88A6-6C401C52BD98}
    8) Замените значения "Наименование папки или программы", "Путь к иконке для ярлыка" и "Путь к папке или файлу программы" на необходимые Вам.
    8) Замените значения "Наименование папки или программы", "Путь к иконке для ярлыка" и "Путь к папке или файлу программы" на необходимые Вам.
    Внимание! При указывании пути к иконке и файлу объекта слэш должен быть двойным.
    Например, если путь к программе: C:\MyProgram\MyProgram.exe, то необходимо указать его как: C:\\MyProgram\\MyProgram.exe
    Так как, чаще всего икона программы встроена в саму программу, то значения "Путь к иконке для ярлыка" и "Путь к папке или файлу программы" могут совпадать.
    9) При добавлении ярлыка папки измените "Путь к иконке для ярлыка" на %SystemRoot%\\system32\\SHELL32.dll,4
    А значение "Путь к папке или файлу программы" на explorer /n, /e, C:\\ВашаПапка
    10) После указания всех необходимых значений, нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    10.1) Если Вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "GUID.reg")
    10.2) Если Вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    11) Примените получившийся reg-файл.

    Пример reg-файла для добавления программы WinDjView в папку Компьютер:

    Пример reg-файла для добавления папки Downloads в папку Компьютер:

    В итоге Вы получите тот же самый эффект, что был упомянут в совете 3 раздела "Твики Реестра - Дополнительная функциональность".

    9. Добавление в контекстное меню DLL- или OCX-файлов пунктов "Регистрация" и "Отмена регистрации".

    Если вам часто приходится работать с ocx-файлами или с dll-файлами, которые требуют регистрации в реестре с помощью Regsvr32.exe, то будет гораздо удобнее внести соответствующую запись в реестр, чем каждый раз использовать командную строку для каждого файла.

    Запустите редактор реестра (Win+R -> regedit -> Ok )

    Создание пункта "Регистрация" в меню DLL- или OCX-файлов.

    1) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell и HKEY_CLASSES_ROOT\dllfile\Shell
    2) Создайте раздел Регистрация, а в нем подраздел command
    3) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell\Регистрация\command и HKEY_CLASSES_ROOT\dllfile\Shell\Регистрация\command присвойте строковому параметру По умолчанию значение: regsvr32.exe "%1"

    Создание пункта "Отмена регистрации" в меню DLL- или OCX-файлов.

    1) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell и HKEY_CLASSES_ROOT\dllfile\Shell
    2) Создайте раздел Отмена регистрации, а в нем подраздел command
    3) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell\Отмена регистрации\command и HKEY_CLASSES_ROOT\dllfile\Shell\Отмена регистрации\command присвойте строковому параметру По умолчанию значение: regsvr32.exe /u "%1"

    Теперь при нажатии правой кнопкой мыши на DLL- или OCX-файле, в меню появятся пункты "Регистрация" и "Отмена регистрации".

    Также Вы можете создать reg-файл следующего содержания или скачать готовый Dll_Ocx_register-unregister.reg

    10. Увеличение кэша памяти для вида папок.

    Можно увеличить количество папок, для которых Windows будет запоминать настройки вида.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell
    3) Создайте параметр DWORD BagMRU Size и присвоить ему десятичное значение, например, 20000.

    Также Вы можете создать reg-файл.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: " folder_cache.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    11. Добавление опций "Выполнить", "Поиск" и "Очистить корзину" в контекстное меню.

    Для быстрого доступа к необходимой Вам системной опции, Вы можете добавить её в контекстное меню рабочего стола. Чтобы это осуществить, Вам необходимо создать и применить reg-файл следующего содержания.

    Добавление пункта Выполнить для вызова одноименного диалогового меню.

    Добавление пункта Поиск для вызова одноименного окна.

    Добавление пункта Очистить корзину.

    Готовые reg-файлы для добавления и удаления Вы можете скачать по ссылке: options in context menu.zip

    12. Создание меню с ярлыками избранных приложений в контекстном меню рабочего стола.

    Рисунок 1 из 3

    Добавление ссылок на избранные программы в контекстное меню рабочего стола Windows сводится к двум частям:

    Часть 1. Создание каскадных меню в контекстном и добавление ярлыков.
    Часть 2. Добавление функциональности ярлыкам путем их регистрации.

    Часть 1. Создание контекстных меню и добавление ярлыков.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_CLASSES_ROOT\DesktopBackground\Shell
    3) Создайте в данной ветке новый раздел. Нажмите правой кнопкой мыши на ключе "Shell" и выберите "Создать -> Раздел". (Например, Menu1)
    4) Выберите только что созданный раздел "Menu1" и в правой части окна создайте 4 строковых параметра:

    Icon - в значении данного параметра следует указать путь к значку меню.
    Position - данный параметр определяет позицию каскадного меню в контекстном. По умолчанию это середина контекстного меню, но Вы можете выбрать значения Top (сверху) или Bottom (снизу).
    MUIVerb - имя каскадного меню, которое будет отображаться в контекстном меню. Например, "Мои программы", "Браузеры" и т.д.
    SubCommands - содержит список команд, разделенных точкой с запятой (;). Эти команды будут показаны в каскадном меню. Вы не можете напрямую добавить ярлык приложения. Сначала в этом списке Вам нужно дать команде имя, а после этого зарегистрировать ее согласно инструкции во второй части статьи.

    Предположим, что Вы уже создали каскадное меню "Браузеры", и теперь Вы хотите добавить в него ярлыки Internet Explorer и Mozilla Firefox. В таком случае Вам нужно параметру SubCommands задать значение:

    Параметры Icon и Position Вы можете и не создавать, а вот MUIVerb и SubCommands — обязательны.

    Рисунок 2 из 3

    Часть 2. Добавление функциональности ярлыкам путем их регистрации.

    Как только Вы добавите ярлыки программ в каскадное меню, Вам необходимо будет их зарегистрировать следующим образом:

    1) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\CommandStore\Shell
    2) Создайте для каждой из команд, указанных ранее в строковом параметре SubCommands, собственный одноименный раздел. В нашем примере мы использовали две команды: firefox и iexplore, поэтому нам нужно создать два раздела с такими же именами.
    3) Выберите созданный раздел и в правой части окна редактора реестра задайте параметру Default (По умолчанию) имя, которые Вы хотите видеть в каскадном меню. Например, введите сюда Internet Explorer (для раздела iexplore) или Mozilla Firefox (для раздела firefox).
    4) Если Вы хотите добавить ярлыку иконку, создайте новый строковой параметр с именем Icon и установите его значением путь к EXE файлу приложения или любой другой иконке.
    Например, чтобы показать иконку Internet Explorer, Вы должны задать параметру Icon значение C:\Program Files\Internet Explorer\iexplore.exe
    5) В каждом из только что созданных разделов создайте новый раздел и назовите его command.
    Выберите его и в правой части окна установите значением Default (По умолчанию) путь к EXE-файлу необходимой программы. Например, если ярлык должен открывать Internet Explorer, то для должно быть установлено значение C:\Program Files\Internet Explorer\iexplore.exe

    Рисунок 3 из 3

    Готовый reg-файл контекстное меню рабочего стола (из описанного примера):

    Примечание: Если Вы хотите удалить созданное каскадное меню, просто удалите ключи, созданные Вами ключи из реестра.

    13. Ускорение выключения компьютера.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\
    3) Найдите параметр WaitToKillServiceTimeout
    4) Измените его значение на необходимое Вам. Данный параметр отвечает за задержку перед выключением.
    По умолчанию установлено значение (20000)=20 сек., но вы можете установить его значение, намного меньше номинального (минимум 100), и система будет закрываться намного быстрее.
    Рекомендуемые значения (2000-5000)=2-5 сек. (меньше не рекомендуется, иначе система будет понимать неадекватно отсутсвие откликов от служб, и завершать их в "неподходящий" момент времени, например когда они сохраняют свои последние настройки).

    14. Ускорение анимации всплывающего меню в меню Пуск.

    Если Вы желаете изменить время задержки до показа всплывающего меню в меню Пуск, проделайте следующее:

    1)Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
    2) Откройте раздел HKEY_CURRENT_USER\Control Panel\Desktop
    3) Создайте в нем(или измените) параметр MenuShowDelay
    4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
    5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
    6) Выберите желательное значение от 1 до 4000, означающее задержку в миллисекундах, до показа всплывающего меню в меню Пуск.
    7) Закройте regedit и перезагрузите систему.

    15. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows (реестр).

    Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
    Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

    1) Запустите редактор реестра (Нажмите Win+R, введите команду regedit.exe и нажмите Ок)
    2) Пройдите по следующему пути: HKEY_CURRENT_USER\Control Panel\Accessibility
    3) Измените значение параметра MessageDuration.

    16. Настройка параметров всплывающих эскизов окон в панели задач.

    Изменив несколько настроек в реестре Вы сможете придать своим всплывающим эскизам окон больше эффективности в работе.

    1) Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
    2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    3) Создайте в нем(или измените) параметры:

    ExtendedUIHoverTime - Задержка до появления всплывающего эскиза окна на экране, после наведения курсора мыши на иконку в панели задач.
    ThumbnailLivePreviewHoverTime - Задержка до появления окна программы, после наведения курсора мыши на всплывший эскиз окна.

    4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
    5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
    6) В графе Система исчисления установите значение параметра на Десятичная.
    7) Введите необходимое Вам значение. Значение 1000 = 1 секунде.

    8) Откройте в реестре раздел: HKEY_CLASSES_ROOT\SystemFileAssociations\image
    9) Сделайте двойной щелчок на параметре Treatment - Данный параметр изменяет вид бордюра всплывающего эскиза окна.
    10) Выберите необходимое Вам значение:

    0 - Без бордюра
    1 - Бордюр с тенью
    2 - Фоторамка (по умолчанию)
    3 - Видеорамка

    11) Закройте regedit и перезагрузите систему.

    17. Настройка скорости отображения рабочего стола при наведении курсора мыши в угол экрана.

    Когда Вы наводите курсор на крайнюю кнопку, находящуюся за часами на панели задач (обычно правый нижний угол экрана), система показывает Вам рабочий стол. При желании Вы можете ускорить или замедлить данный процесс.

    1) Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
    2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    3) Измените значение параметра DesktopLivePreviewHoverTime. Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
    4) В графе Система исчисления установите значение параметра на Десятичная.
    5) Введите необходимое Вам значение. Значение 1000 = 1 секунде.
    6) Закройте regedit, перезайдите в систему или перезагрузите систему.

    18. Добавление кнопки запуска необходимой программы на панель проводника Windows 7.

    Рисунок 1 из 2

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    На панели проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами для хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок.
    Для добавления кнопки запуска необходимой программы во все папки проводника - добавьте кнопку во все шаблоны.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для добавления кнопки запуска необходимой программы сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку необходимого Вам шаблона.
    Например: для добавления кнопки в обычную папку использующую шаблон типа папки «Общие элементы» откройте:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{5c4f28b5-f869-4e84-8e60-f11db97c5cc7}

    А для добавления кнопки в папку «Общие элементы», входящей в Библиотеки откройте:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{5f4eab9a-6833-4f61-899d-31cf46979d49}

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

    4.1) Откройте необходимый из указанных подразделов, если Вы добавляете кнопку в шаблоны Библиотек и/или в шаблонах поиска результатов в них.
    4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать -> Раздел.)

    TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
    TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

    5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Удалить.
    Выполняя данное действие Вы отказываетесь от набора стандартных кнопок, но позволяете использовать произвольные кнопки.

    6) В разделе TasksItemsSelected создайте подраздел с именем 0. Он будет содержать в себе параметры первой кнопки (отсчет начинается с нуля), все последующие кнопки должны создаваться в разделах 1, 2, и т.д.

    7) В разделе 0 создайте подраздел с уникальным GUID. (Например: {422299D4-C2DD-4e24-AAAB-FED22CC8E8DE})
    7.1) Скачайте и распакуйте архив GUIDGen.zip
    7.2) Запустите программу GUIDGEN.EXE, установите переключатель на Registry Format и нажмите кнопку New GUID, а затем Copy.

    8) Щелкните созданный раздел с уникальным GUID и создайте в нем два строковых параметра:

    Title – определяет название кнопки
    InfoTip – определяет название всплывающей подсказки к кнопке

    9) В разделе с уникальным GUID последовательно создайте подразделы:

    shell
    InvokeTask
    command

    10) В разделе command дважды щелкните параметр (По умолчанию) и измените его значение на путь к программе, которую Вы хотите запустить.

    Рисунок 2 из 2

    Примечание:

    Если Вы добавляете программу для открытия в ней файлов, то после указания пути к программе добавьте параметр %*
    Параметр %* указывает программе, что необходимо использовать одновременно несколько параметров: путь к отображаемой папке(%0) и путь к выделенному объекту(%1).
    Если Вы добавляете программу которая должна просто запускаться, без открытия в ней файлов, то параметр добавлять не надо.

    19. Добавление кнопки "Открыть в текстовом редакторе" на панель проводника Windows 7.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    На панели проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами для хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок.
    Для добавления кнопки "Открыть в текстовом редакторе" во все папки проводника - добавьте кнопку во все шаблоны.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для добавления кнопки "Открыть в текстовом редакторе" сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку необходимого Вам шаблона.
    Например: для добавления кнопки в обычную папку использующую шаблон типа папки «Документы» откройте:

    А для добавления кнопки в папку ««Документы»», входящей в Библиотеки откройте:

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

    4.1) Откройте необходимый из указанных подразделов, если Вы добавляете кнопку в шаблоны Библиотек и/или в шаблонах поиска результатов в них.
    4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать -> Раздел.)

    TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
    TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

    5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Удалить.
    Выполняя данное действие Вы отказываетесь от набора стандартных кнопок, но позволяете использовать произвольные кнопки.

    6) В разделе TasksItemsSelected создайте подраздел с именем 0. Он будет содержать в себе параметры первой кнопки (отсчет начинается с нуля), все последующие кнопки должны создаваться в разделах 1, 2, и т.д.

    7) В разделе 0 создайте подраздел с уникальным GUID. (Например: {433399D4-C2DD-4e24-AAAB-FED22CC8E8DE})
    7.1) Скачайте и распакуйте архив GUIDGen.zip
    7.2) Запустите программу GUIDGEN.EXE, установите переключатель на Registry Format и нажмите кнопку New GUID, а затем Copy.

    8) Щелкните созданный раздел с уникальным GUID и создайте в нем два строковых параметра:

    Title – определяет название кнопки
    InfoTip – определяет название всплывающей подсказки к кнопке

    9) В разделе с уникальным GUID последовательно создайте подразделы:

    shell
    InvokeTask
    command

    10) Скачайте файл архив со скриптом texteditor.zip и распакуйте его в любую папку. (Например: C:\Scripts)

    10.1) Вы можете создать его самостоятельно. Для этого скопируйте нижеследующий текст в текстовый редактор и сохраните файл с именем texteditor и расширением *.js .

    11) В разделе command дважды щелкните параметр (По умолчанию) и измените его значение на путь к скрипту:

    Примечание:

    Параметр %* указывает программе, что необходимо использовать одновременно несколько параметров: путь к отображаемой папке(%0) и путь к выделенному объекту(%1).

    20. Добавление кнопок "Копировать в папку" и "Переместить в папку" на панель проводника Windows 7.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    На панели проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами для хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок.
    Для добавления кнопок "Копировать в папку" и "Переместить в папку" во все папки проводника - добавьте кнопки во все шаблоны.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для добавления кнопок "Копировать в папку" и "Переместить в папку" сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку необходимого Вам шаблона.
    Например: для добавления кнопки в обычную папку использующую шаблон типа папки «Общие элементы» откройте:

    А для добавления кнопки в папку «Общие элементы», входящей в Библиотеки откройте:

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

    4.1) Откройте необходимый из указанных подразделов, если Вы добавляете кнопку в шаблоны Библиотек и/или в шаблонах поиска результатов в них.
    4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать -> Раздел.)

    TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
    TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

    5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Удалить.
    Выполняя данное действие Вы отказываетесь от набора стандартных кнопок, но позволяете использовать произвольные кнопки.

    6) В разделе TasksItemsSelected создайте подраздел с именем 0. Он будет содержать в себе параметры первой кнопки (отсчет начинается с нуля), все последующие кнопки должны создаваться в разделах 1, 2, и т.д.

    7) В разделе 0 создайте подраздел с уникальным GUID. (Например: {455599D4-C2DD-4e24-AAAB-FED22CC8E8DE})
    7.1) Скачайте и распакуйте архив GUIDGen.zip
    7.2) Запустите программу GUIDGEN.EXE, установите переключатель на Registry Format и нажмите кнопку New GUID, а затем Copy.

    8) Щелкните созданный раздел с уникальным GUID и создайте в нем два строковых параметра:

    Title – определяет название кнопки
    InfoTip – определяет название всплывающей подсказки к кнопке

    9) В разделе с уникальным GUID последовательно создайте подразделы:

    shell
    InvokeTask
    command

    10) Скачайте файл архив со скриптом ExplorerBarUtilities.zip и распакуйте его в любую папку. (Например: C:\Scripts)

    11) В разделе command дважды щелкните параметр (По умолчанию) и измените его значение на путь к скрипту: Для создания кнопки "Копировать в папку" измените значение на:

    Для создания кнопки "Переместить в папку" измените значение на:

    Примечание:

    Параметр %* указывает программе, что необходимо использовать одновременно несколько параметров: путь к отображаемой папке(%0) и путь к выделенному объекту(%1).

    21. Добавление собственной папки в Рабочий стол области переходов проводника.

    Если Вы часто пользуйтесь какой-либо папкой, то Вы можете добавить ее в Рабочий стол области переходов проводника. Поскольку копирование папки напрямую или создание ярлыка на рабочем столе не добавляет её в область переходов, то предлагаю Вам решение, как это возможно осуществить.

    1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот):

    2) Скачайте программу Microsoft Exchange Server GUID Generator
    3) Распакуйте архив и запустите программу (GUIDGEN.EXE)
    4) Установите переключатель на значение Registry Format
    5) Нажмите на кнопку New GUID, и программа сгенерирует Вам новый GUID
    6) Нажмите на кнопку Copy, и программа скопирует его в буфер обмена
    7) Вставьте вместо {GUID}, сгенерированный программой GUID.
    Теперь у Вас вместо {GUID}, должен быть цифровой идентификатор, например: {1a51a488-17d4-4169-a212-a2cf152268b6}
    8) Замените значения "Название папки" и "Путь к папке" на необходимые Вам.
    Внимание! При указывании пути к папке слеш должен быть двойным.
    Например, если путь к папке: C:\My Folder\Downloads, то необходимо указать его как: C:\\My Folder\\Downloads
    9) После указания всех необходимых значений, нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    9.1) Если Вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "GUID.reg")
    9.2) Если Вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    10) Примените получившийся reg-файл.

    Пример reg-файла для добавления папки Downloads в Рабочий стол области переходов проводника.

    22. Скрытие апплетов отображаемых в Панели управления.

    Существует много способов, чтобы скрыть элементы в Панели Управления. Ниже приводятся, наиболее часто используемые.

    1) Создайте reg-файл используя шаблон в одном из предложенных ниже вариантов.
    2) Примените его.
    3) Перезагрузите систему.

    Вариант 1. Показать все кроме.

    Созданный reg-файл позволяет Вам отобразить все апплеты в Панели управления, исключая те которые добавлены в ветку: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowCpl
    Чтобы исключить определенные апплеты из Панели управления, создайте в данном разделе строковые параметры (REG_SZ).
    Имена параметров должны быть - непрерывные номера начинающиеся с 1: 1, 2, 3, …
    Значения - имя апплета точно таким же, как оно отображается в Панели Управления в зависимости от выбранного языка интерфейса. Пример reg-файла для русской Windows:

    Пример reg-файла для английской Windows:

    Вариант 2. Скрыть все кроме.

    Созданный reg-файл позволяет Вам скрыть все апплеты в Панели управления, исключая те которые добавлены в ветку: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictCpl
    Чтобы отобразить определенные апплеты в Панели управления, создайте в данном разделе строковые параметры (REG_SZ).
    Имена параметров должны быть непрерывные - номера начинающиеся с 1: 1, 2, 3, …
    Значения - имя апплета точно таким же, как оно отображается в Панели Управления в зависимости от выбранного языка интерфейса. Пример reg-файла для русской Windows:

    Пример reg-файла для английской Windows:

    Русское название элемента | Английское название элемента
Windows CardSpace | Windows CardSpace
Windows SideShow | Windows SideShow
Автозапуск | AutoPlay
Автономные файлы | Offline Files
Администрирование | Administrative Tools
Архивация и восстановление | Backup and Restore
Биометрические устройства | Biometric Devices
Брандмауэр Windows | Windows Firewall
Восстановление | Recovery
Гаджеты рабочего стола | Desktop Gadgets
Дата и Время | Date and Time
Датчик расположения и другие датчики | Location and Other Sensors
Диспетчер устройств | Device Manager
Диспетчер учетных данных | Credential Manager
Домашняя группа | HomeGroup
Защитник Windows | Windows Defender
Звук | Sound
Значки области уведомлений | Notification Area Icons
Игровые устройства | Game Controllers
Инфракрасная связь | Infrared
Клавиатура | Keyboard
Мышь | Mouse
Панель задач и меню ''Пуск'' (кавычки два раза одинарные) | Taskbar and Start Menu
Параметры индексирования | Indexing Options
Параметры папок | Folder Options
Параметры планшетного компьютера | Tablet PC Settings
Перо и сенсорные устройства | Pen and Touch
Персонализация | Personalization
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection
Получение программ | Get Programs
Приступая к работе | Getting Started
Программы и компоненты | Programms and Features
Программы по умолчанию | Default Programs
Распознавание речи | Speech Recognition
Расположение по умолчанию | Default Location
Родительский контроль | Parental Controls
Свойства обозревателя | Internet Options
Система | System
Сканеры и камеры | Scanners and Cameras
Счетчики и средства производительности | Performance Information and Tools
Телефон и модем | Phone and Modem
Управление цветом | Color Management
Устранение неполадок | Troubleshooting
Устройства и принтеры | Devices and Printers
Учетные записи пользователей | User Accounts
Центр мобильности Windows | Windows Mobility Center
Центр обновления Windows | Windows Update
Центр поддержки | Action Center
Центр синхронизации | Sync Center
Центр специальных возможностей | Ease of Access Center
Центр управления сетями и общим доступом | Network and Sharing Center
Шифрование диска BitLocker | BitLocker Drive Encryption
Шрифты | Fonts
Экран | Display
Электропитание | Power Options
Язык и региональные стандарты | Region and Language

    23. Увеличение пространства, отведенного в NTFS для главной таблицы файлов.

    В ядре файловой системы NTFS содержится файл, который называется главной таблицей файлов (MFT). MFT (Master File Table) — главная файловая таблица (база данных), в которой хранится информация о содержимом тома с файловой системой NTFS, представляющая собой таблицу, строки которой соответствуют файлам тома, а столбцы — атрибутам файлов.
    Поскольку средства дефрагментации томов NTFS не могут перемещать записи MFT, а также из-за того, что значительная фрагментация MFT может негативно влиять на быстродействие системы, NTFS резервирует для MFT дисковое пространство, чтобы по мере увеличения размера MFT подвергался минимальной фрагментации.
    По мере появления новых файлов в томе NTFS в файл MFT добавляются новые записи, и, таким образом, размер MFT увеличивается. При удалении файлов из тома NTFS соответствующие записи в файле MFT помечаются как свободные и могут использоваться повторно, однако размер MFT при этом не сокращается. Таким образом, дисковое пространство, используемое этими записями, остается недоступным.
    При переполнении зоны MFT пространство для новых записей MFT начинает выделяться из незарезервированного дискового пространства, что снова приводит к фрагментации MFT.

    Существует параметр реестра, позволяющий увеличить (зарезервировать) пространство, отведенное в NTFS для основной таблицы файлов. Для его добавления выполните следующие действия:

    1) Запустите редактор реестра (Win+R->regedit->ОК)
    2) Откройте раздел реестра HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem
    3) В меню Правка выберите Создать -> Параметр DWORD (32 бита).
    4) Задайте имя параметра NtfsMftZoneReservation
    5) Дважды щелкните на данном параметре и введите необходимое Вам значение от 1 до 4.
    6) Закройте редактор реестра и перезапустите компьютер.

    Если на ваших разделах NTFS мало файлов, но они большого размера, то наилучшим значением созданного параметра будет 1.
    Если у Вас среднее количество файлов на диске, то оптимальным значением является 2, если же их большое количество, то значение 3.
    Значение 4 (максимальное значение) следует использовать только в случае, если у вас на диске очень большое количество файлов.

    24. Увеличение процессорного времени, выделяемого программе, работающей на переднем плане.

    Для начала убедитесь, что параметр Распределение времени процессора настроен на оптимизацию работы программ. Для этого:

    1) Откройте меню Пуск
    2) Нажмите правой кнопкой мыши на пункт Компьютер и выберите Свойства
    3) В списке слева нажмите на ссылку Дополнительные параметры системы
    4) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
    5) Откройте вкладку Дополнительно и в разделе Распределение времени процессора установите переключатель в значение: программ.

    Теперь Вам необходимо изменить количество квантов выделяемых программе, работающей на переднем плане.
    Квантом называется единица процессорного времени, выделяемая конкретной программе для работы. По истечении квантов, выделенных одной программе, управление будет передано другой программе, ожидающей в очереди (а программа, которая только что работала, будет помещена в конец очереди) — и эта программа будет работать до тех пор, пока не истекут кванты, выделенные для нее. После этого управление перейдет следующей программе из очереди.
    Особенностью Windows является увеличенное количество квантов, которое выделяется программе, работающей в данный момент на переднем плане. То есть, программа переднего плана будет работать быстрее всех программ, работающих в данный момент в фоновом режиме.
    Так реализована многозадачность операционной системы Windows.

    Для изменения количества квантов, выделяемых программе, работающей на переднем плане, сделайте следующее:

    1) Запустите редактор реестра (Win+R->regedit->ОК)
    2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\PriorityControl
    3) Дважды щелкните на DWORD-параметре Win32PrioritySeparation и введите необходимое Вам значение.
    4) Закройте редактор реестра и перезапустите компьютер.

    По умолчанию значение равно 2.
    Максимальное значение равно 26 в шестнадцатеричной системе исчисления или 38 в десятичной системе.
    Необходимое Вам значение выясняется экспериментальным путем.
    Не ставьте сразу большое значение, постепенно увеличивайте значение пока не найдете оптимальное.
    Например: На одних машинах улучшения в работе системы с программами будут видны при максимальном значении 26, на других же оптимальным значением может оказаться 12.

    25. Отключение выгрузки драйверов режима ядра и системного кода режима ядра из оперативной памяти на диск.

    Если у Вас на компьютере большое количество оперативной памяти, то приложения будут быстрее откликаться на Ваши действия, если драйвера режима ядра и системный код режима ядра будут оставаться в оперативной памяти.

    За данное действие отвечает параметр реестра DisablePagingExecutive, который определяет, могут ли драйвера режима ядра и системный код режима ядра быть выгружены из оперативной памяти на диск, когда они не используется.

    Значение 0 указывает, что при необходимости драйвера режима ядра и системный код режима ядра могут быть выгружены из оперативной памяти на диск, когда они не используется.
    Значение 1 указывает, что драйвера режима ядра и системный код режима ядра должны оставаться в оперативной памяти.

    Для изменения данного параметра сделайте следующее:

    1) Запустите редактор реестра (Win+R->regedit->ОК)
    2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
    3) Дважды щелкните на параметре DisablePagingExecutive и введите значение 1.
    4) Закройте редактор реестра и перезапустите компьютер.

    Если же у Вас такой параметр отсутствует, то создайте в данном разделе реестра DWORD-параметр с указанным именем и значением.

    26. Удаление пункта "Восстановить прежнюю версию" из контекстного меню проводника.

    Чтобы удалить пункт "Восстановить прежнюю версию" из контекстного меню проводника, сделайте следующее:

    1) Запустите редактор реестра (Win+R->regedit->ОК)
    2) Откройте раздел реестра: HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\
    3) Удалите раздел {596AB062-B4D2-4215-9F74-E9109B0A8153}
    4) Откройте раздел реестра: HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers\
    5) Удалите раздел {596AB062-B4D2-4215-9F74-E9109B0A8153}
    6) Закройте все процессы проводника и запустите его заново или перезайдите в систему.

    Твики Реестра - Устройства и Сети.

    1. Автоматическое VPN-подключение к интернет при запуске Windows (реестр).

    1. Создайте ваше VPN-подключение, но не подключайтесь к интернету или если подключились, то не отключайтесь от интернета до окончания описанных ниже действий.
    2. В реестре Windows (Пуск->Выполнить->"regedit") найдите следующую ветку:

    (если хотите сделать автозапуск только для текущего пользователя) или

    (если хотите сделать автозапуск для всех пользователей)
    В этой ветке создайте "строковый параметр" (правой кнопкой мыши -> «Создать» -> «строковый параметр») с произвольным именем.
    2. В качестве значения созданного параметра внесите строку вида:

    3. Закройте реестр и перезагрузите компьютер.

    2. Конвертирование reg файлов в inf формат из контекстного меню, с помощью утилиты.

    1) Скачайте утилиту Reg2inf (необходим Framework 2 или 3)
    2) Скопируйте её в C:\Windows\System32
    3) Создайте и примените reg-файл следующего содержания:

    В контекстное меню reg-файлов добавится пункт reg2inf при нажатии которого созданный Вами reg-файл переконвертируется в inf-файл. Например, файл test.reg переконвертируется в test.reg.inf

    3. Включение клавиш-индикаторов Num Lock, Caps Lock, Scroll Lock при загрузке.

    Если у Вас при входе в систему выключен переключатель клавиатуры Num Lock, то для его включения сделайте следующее.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_CURRENT_USER\Control Panel\Keyboard
    3) Щелкните на параметре InitialKeyboardIndicators правой кнопкой мыши и нажмите Изменить.
    4) Выберите и установите необходимое Вам значение.

    0 – все переключатели выключены.
    1 – Caps Lock включен.
    2 – Num Lock включен.
    3 – Caps Lock и Num Lock включены.
    4 – Scroll Lock включен.
    5 – Caps Lock и Scroll Lock включены.
    6 – Num Lock и Scroll Lock включены.
    7 – Caps Lock, Num Lock и Scroll Lock включены.

    Если же Вам необходимо изменить состояние клавиш-индикаторов до входа в систему, в экране приветствия, то для управления ими измените значение параметра InitialKeyboardIndicators в разделе HKEY_USERS\.DEFAULT\Control Panel\Keyboard

    4. Отмена автозапуска для носителей и устройств.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр DWORD с именем NoDriveTypeAutoRun

    Допустимые значения ключа:

    0x1 - отключить автозапуск на приводах неизвестных типов
    0x4 - отключить автозапуск съемных устройств
    0x8 - отключить автозапуск НЕсъемных устройств
    0x10 - отключить автозапуск сетевых дисков
    0x20 - отключить автозапуск CD-приводов
    0x40 - отключить автозапуск RAM-дисков
    0x80 - отключить автозапуск на приводах неизвестных типов
    0xFF - отключить автозапуск вообще всех дисков.

    Также параметр NoDriveTypeAutoRun автоматически добавляется в реестр при установке программы VMware Workstation, используемой для создания виртуальной машины.

    5. Уменьшение фрагментируемости больших файлов на диске.

    Для того чтобы операционная система при записи файла на диск сначала нашла для него наиболее подходящее по размеру место и поместила его туда, как можно меньше дробя на части сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem
    3) Создайте DWORD-параметр ContigFileAllocSize
    4) Щелкните на нем правой кнопкой мыши и выберите Изменить.
    5) Установите значение 00000200 и нажмите Ок

    Данный параметр определяет максимальный размер нефрагментируемого блока данных на диске. При желании размер такого блока можно еще увеличить. Данная настройка может быть очень полезной при работе с мультимедиа (уменьшается нагрузка на диск и процессор при записи и воспроизведении видео или звуковых файлов).
    Эта настройка полезна тем, у кого много файлов большого размера, при большом количестве маленьких файлов - она становится менее актуальной.

    6. Изменение состояния встроенного динамика персонального компьютера.

    1) Запустите редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_CURRENT_USER\Control Panel\Sound
    3) Измените значение параметра Beep на "No" чтобы отключить и на "Yes" чтобы включить.

    Также Вы можете включить/отключить его в Диспетчере устройств:

    1) Откройте меню Пуск -> Панель управления и запустите Диспетчер устройств
    2) В меню Вид установите флажок на Показать скрытые устройства
    3) Откройте Драйверы несамонастраиваемых устройств
    4) Щелкните правой кнопкой мыши на Beep и выберите пункт Свойства
    5) Перейдите на вкладку Драйвер и установите тип автозагрузки на Отключено чтобы отключить и на Авто чтобы включить.
    6) Для изменения текущего состояния нажмите на Остановить чтобы отключить и на Запустить чтобы включить.
    7) Нажмите кнопку ОК для применения настроек.

    7. Переназначение гнезд звуковой карты Realtek используя реестр.
    На некоторых материнских платах, отсутствует возможность переназначения гнезд встроенной звуковой карты Realtek. А это значит, что каждое гнездо четко привязано к определенному устройству и определяется только автоматически при включении его в гнездо.
    Например, если Вы включите Микрофон или Наушники в гнездо, предназначенное для устройства Боковые динамики, то Realtek будет по-прежнему считать, что у Вас подключены Боковые динамики, а не Микрофон или Наушники.
    Однако из данной ситуации есть выход. Вы можете переназначить гнезда вручную, при помощи реестра.

    1) Установите драйвера звуковой карты
    2) Запустите редактор реестра (Win+К -> regedit -> Ok)
    3) Пройдите к папке

    4) Откройте папку Drv6278_DevType_0888_SS10438357 или с аналогичным названием (DrvXXXX_DevType_XXXX_SSXXXXXXXX, где вместо X могут быть любые цифры, зависящие от версии драйвера и номера вашего устройства)
    5) Создайте двоичный параметр(Binary-Параметр) задаете ему необходимое имя и значение из списка указанного ниже или отредактируйте уже имеющийся.

    Рисунок 1 из 2

    Имя(вставлять без кавычек):

    "Pin01" = Заднее зеленое гнездо
    "Pin02" = Заднее черное гнездо
    "Pin03" = Заднее коричневое гнездо
    "Pin04" = Заднее серое гнездо
    "Pin05" = Заднее розовое гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Микрофон)
    "Pin07" = Заднее синее гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Линейный вход)

    "Pin06" = Переднее розовое гнездо
    "Pin08" = Переднее зеленое гнездо

    Значение(вставлять без кавычек):

    "00 00 00 00" = Линейный вход
    "01 00 00 00" = Микрофон
    "02 00 00 00" = Наушники
    "04 00 00 00" = Передние динамики
    "05 00 00 00" = Тыловые динамики
    "06 00 00 00" = Центральный канал/Сабвуфер
    "07 00 00 00" = Боковые динамики

    Если у Вас после перезагрузки компьютера сбрасываются настройки, то сразу после изменения настроек установите значение параметра ChannelConfig равным 00 00 00 00

    Также вы можете создать reg-файл наподобие указанного ниже, заменив значения на необходимые:

    Drv6278_DevType_0888_SS10438357 - на версию вашего драйвера
    (имя папки по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\)
    Pin04 - на любое значение из списка Имя
    hex:02,00,00,00 - на любое значение из списка Значение(просто исправьте 2 на соответствующую цифру) Reg-файл для настройки устройства Наушники вместо устройства Боковые динамики

    Рисунок 2 из 2

    8. Замена компонента Устройства и принтеры в Панели управления на папку Принтеры.

    1) Откройте Редактор групповой локальной политики (Win+R -> gpedit.msc - Ok)
    2) Перейдите в раздел Конфигурация пользователя\Административные шаблоны\Панель управления.
    3) Выберите команду Скрыть указанные элементы панели управления
    4) Установите переключатель в значение Включить.
    5) Нажмите на кнопку Показать.
    6) Добавьте новую запись: Microsoft.DevicesAndPrinters и нажмите Ok.
    7) Запустите редактор реестра (Win+R -> regedit.exe -> Ok).
    8) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace
    9) Создайте в ней новый раздел {2227a280-3aea-1069-a2de-08002b30309d}.
    10) Присвойте параметру По умолчанию значение - Принтеры (Printers).

    Данную папку Вы сможете увидеть в Панели управления в контекстном меню Пуск, если у Вас установлено значение "Отображать как меню" или при просмотре полного списка всех элементов при её открытии.

    9. Удаление цифры при пересоздании адаптера сети в Диспетчере устройств.

    Вариант 1

    1) Удалите драйвер сетевого адаптера
    2) В ветке реестра

    установите значение адаптера сети на 0.
    3) Создайте драйвер сетевого адаптера

    Вариант 2

    1) Удалите драйвер сетевого адаптера
    2) В ветке реестра

    удалите ваш сетевой адаптер.
    3) Создайте драйвер сетевого адаптера.

    10. Отключение или переназначение клавишы Caps Lock.

    Если вы не используете клавишу Caps Lock по назначению, то вы можете отключить или переназначить клавишу, путем редактирования параметра реестра. Для этого необходимо изменить значение параметра Scancode Map, который расположен в разделе реестра

    Ниже представлены reg-файлы для переназначения и отключения клавиши Caps Lock.

    Клавиша Caps Lock будет выполнять действие клавиши Ctrl

    Клавиша Caps Lock будет выполнять действие клавиши Shift

    Отключает Caps Lock и переназначает действие клавиши Scroll Lock на выполнение Caps Lock

    Отключает клавишу Caps Lock

    Отменяет все предыдущие переназначения клавиш(возвращает значение по умолчанию)

    11. Отключение USB порта после Безопасного извлечения устройства.

    Если Вы присоединили USB-устройство к компьютеру с запущенной Windows 7, а затем Отключаете устройство в "Диспетчере устройств" или в "Безопасное Извлечение устройств и дисков", используя иконку в системном трее, то Вы можете наблюдать один из следующих симптомов:
  • USB-устройство показывает продолжающееся признаки деятельности (такие, как остающийся гореть LED-индикатор)
  • USB-устройство продолжает получать USB-пакеты и продолжает потреблять энергию соответствующую состоянию активного устройства.
  • Физическое отсоединение Отключенного или Безопасно Удаленного USB-устройства может, в некоторых случаях, вызывать ошибку в активной передаче на другое USB-устройство.

    • Чтобы исправить данную ошибку Вам необходимо сделать следующее:

    Для определенного устройства.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags
    3) Откройте в данной ветке раздел соответствующий, подключенному к Вашему компьютеру USB-устройству.
    4) Если неоходимого Вам раздела нет, то создайте его.

    4.1) Щелкните правой кнопкой мыши на usbflags
    4.2) Выберите пункты Создать -> Раздел
    4.3) Задайте имя нового раздела в следующем виде: vvvvpppprrrr
    где vvvv - 4-значный шестнадцатеричный номер, обозначающий Vendor ID устройства
    pppp - 4-значный шестнадцатеричный номер, обозначающий Product ID устройства
    rrrr - 4-значный бинарно-закодированный десятиричный номер, обозначающий Revision number устройства

    Данные сведения Вы можете узнать воспользовавшись Диспетчером устройств.
    4.3.1) Откройте Пуск -> Панель управления -> Диспетчер устройств
    4.3.2) Нажмите правой кнопкой мыши на необходимом Вам устройстве и выберите пункт Свойства
    4.3.3) Перейдите на вкладку Сведения и в ниспадающем списке выберите ИД оборудования.

    5) Создайте в открытом разделе HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\usbflags\vvvvpppprrrr параметр DWORD (32 бита) с именем DisableOnSoftRemove
    6) Щелкните правой кнопкой мыши по параметру DisableOnSoftRemove и выберите пункт Изменить...
    7) В текстовом поле Значение: введите 1 и нажмите ОК.

    Для всех устройств:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\usbhub\hubg Если данной ветки нет, то создайте ее.
    3) Щелкните правой кнопкой мыши и создайте параметр DWORD (32 бита) с именем DisableOnSoftRemove
    4) Щелкните правой кнопкой мыши по параметру DisableOnSoftRemove и выберите пункт Изменить...
    5) В текстовом поле Значение: введите 1 и нажмите ОК.

    12. Отключение сообщения: "Хотите выполнить проверку и исправление ошибок на ..." для съемных дисков.

    Вариант 1

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\AutoCheckSelect
    3) Щелкните на параметре CheckedValue правой кнопкой мыши и нажмите Изменить.
    4) Установите значение 0 и нажмите ОК

    Вариант 2

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
    3) Щелкните на параметре BootExecute правой кнопкой мыши и нажмите Изменить.
    4) По умолчанию значение данного параметра должно быть autocheck autochk *.
    * означает, что все диски выбраны для проверки. Чтобы добавить исключение проверки для определенного диска, добавьте перед звездочкой параметр /K:<Буква_диска>. Параметр /K отключает проверку диска при его автозапуске. Например для съемного диска H: значение ключа BootExecute примет вид:

    Если Вы желаете добавить несколько дисков в исключения (например: H и I диски), то значение ключа BootExecute примет вид:

    Вариант 3

    1) Откройте меню Пуск
    2) Введите в диалоговом окне Выполнить (Win+R) или в строке поиска команду msconfig и нажмите Enter.
    3) Перейдите на вкладку Службы и уберите флажок: Определение оборудования оболочки
    4) Откройте меню Пуск
    5) Введите в диалоговом окне Выполнить (Win+R) или в строке поиска команду services.msc и нажмите Enter.
    6) В открывшейся оснастке Службы щелкаете правой кнопкой мыши на Определение оборудования оболочки и выбираете пункт Свойства
    7) Выбираете Тип запуска - Отключена и нажимаете кнопку Остановить
    8) Нажимаете ОК.

    Данное действие также отключит автозагрузку со съемных носителей.

    Устранение неполадок

    Устранение неполадок - Администрирование и Интерфейс.

    1. Компьютер не видит локальный диск с предыдущей ОС или диск отображается без буквы.

    1) Щелкните правой кнопкой мыши на Компьютер (например в меню Пуск) и выберите Управление.
    2) В левом окне выберите Управление дисками
    3) Посередине вверху посмотрите, какие из томов не имеют букву.
    Если среди томов присутствует раздел размером 200 МБ, то Вы ему букву не изменяете.
    4) Присвойте букву тому диску, в котором находится предыдущая Windows (смотрим по размеру). Для этого щелкните на нем правой кнопкой мыши и в контекстном меню выберите пункт Изменить букву диска или путь к диску.
    5) Нажмите Добавить, выберите букву и нажмите OK.
    6) Через несколько секунд должно открыться окно автозапуска диска. А сам диск появится в Компьютере.
    7) Откройте Панель управления -> Параметры папок
    8) Перейдите на вкладку Вид и проверьте установлен ли флажок Отображать буквы дисков, если нет, то установите его.

    2. Решение проблемы с анимацией DWM (Desktop Window Manager).

    1) Нажимаете "Пуск" на панели задач
    2) Нажимаете правой кнопкой на Компьютер
    3) Выбираете Свойства -> Дополнительные параметры системы
    4) В открытом окне выбираете вкладку Дополнительно-Быстродействие-Параметры
    5) На вкладке Визуальные эффекты, уберите галочку - Анимация окон при свертывании и развертывании.

    3. Решение проблемы с доступом к wim-файлу при работе с программой Dism.

    При возникновении ошибок с доступом при работе с wim файлом в программе DISM, Вы можете воспользоваться одним из предложенных вариантов.

    Вариант 1. Новые имена папок.

    1) В командной строке запущенной от имени администратора (Win+R -> cmd -> OK), выполните следующую команду:

    2) Создаете новую папку для wim-файла и переместите в нее Ваш wim-файл. (Например: вместо текущей папки mWim, создайте новую mWim1)
    3) Создайте новую папку, куда Вы будете монтировать Ваш wim-файл для работы. (Например: вместо текущей папки Mount, создайте новую Mount1)
    4) Продолжайте работу с новыми папками.

    Вариант 2. Старые имена папок.

    1) В командной строке запущенной от имени администратора (Win+R -> cmd -> OK), выполните следующую команду:

    2) Переместите Ваш wim-файл в любую другую папку.
    3) Удалите папки, которые Вы использовали для wim-файла и монтирования индекса.
    4) Создайте заново папки с теми же названиями.
    5) Верните wim-файл обратно.
    6) Продолжайте работу с теми же папками, что и раньше.

    4. Очистка или изменение размера кэша иконок, для решения проблем с их отображением.

    Удаление кэша эскизов может понадобиться при возникновении проблем с их отображением. После удаления кэша эскизов они вновь будут записаны при обращении к папкам с обрабатываемыми типами файлов, таким образом пересоздастся кэш и возможно удастся решить проблему с отображением некоторых эскизов.
    Для очистки кэша эскизов сделайте следующее.

    1) Нажмите комбинацию клавиш Win+R, в поле Открыть напишите cleanmgr и нажмите OK.
    2) Выберите диск на который у Вас установлена Windows (по умолчанию C:) и после оценки объема места, которое можно освободить, отметьте Эскизы и нажмите OK
    3) В проводнике откройте папку %USERPROFILE%\AppData\Local\ и удалите файл IconCache.db

    Вы можете сделать это автоматически используя программу Rebuild Icon Cache

    Также Вы можете создать и применить reg-файл:

    5. Причины перехода цветовой схемы на упрощенный стиль.

    Отображение сообщения об отключении некоторых визуальных элементов, таких как прозрачность рамки окна, или о замене цветовой схемы на упрощенный стиль может быть вызвано одной из следующих причин:

    1) Запущенная программа несовместима с темами Aero. В этом случае некоторые визуальные элементы автоматически отключаются. После завершения работы такой программы отключенные визуальные элементы автоматически включаются.
    2) Возможно, уровень заряда батареи переносного компьютера очень низкий. Темы Aero или прозрачность окон в системе Windows могут быть отключены для экономии энергии батареи.
    3) Было изменение конфигурации оборудования компьютера или разрешения экрана. После изменения разрешения экрана, параметров видеокарты или монитора компьютер, возможно, больше не соответствует минимальным требованиям для запуска тем Aero.
    4) Недостаточный объем памяти компьютера для выполнения всех запущенных программ и использования темы Aero.

    Если ОС Windows автоматически изменила тему на упрощенный стиль, но необходимо вернуться к теме Aero, закройте несколько окон, чтобы освободить память, а затем выполните следующие действия:

    1) Используйте "Запуск средства устранения неполадок интерфейса Aero".
    1.1) Откройте меню Пуск и введите команду в строке поиска, щелкните на ней и нажмите Enter
    или
    1.2) Нажмите Win+R и введите команду в диалоговом окне Выполнить

    2) Нажмите Далее

    6. Выбор настроек во время установки для предотвращения замены русских букв знаками вопросов.

    На начальном этапе установки выводится окно, содержащее три строчки.
    Первая строчка - язык, на котором работает система (английский US или русский RU). При возможности выберите русский.
    Вторая строчка - месторасположение компьютера, для выбора страны (от Афганистана и до Ямайки). Выберите страну - Russian Federation.
    Третья строчка - язык раскладки клавиатуры по умолчанию. При выборе во второй строчке страны (РФ), здесь автоматически устанавливается русский. Вы можете выбрать здесь любой используемый Вами язык раскладки клавиатуры.

    7. Решение проблемы с неправильным отображением русских букв.

    1.1) Запустите редактор реестра: Win+R -> regedit -> Ok или введите regedit в строке поиска меню Пуск и нажмите Enter.
    1.2) Откройте ветку реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage
    1.3) Измените значение параметра 1252 с "c_1252.nls" на "c_1251.nls"
    1.4) Откройте папку C:\WINDOWS\system32\ и найдите файлы c_1251.nls и c_1252.nls и задайте полный доступ к данным файлам.
    1.5) Переименуйте файл c_1252.nls в c_1252.bak.
    1.6) Создайте здесь же копию файла c_1251.nls.
    1.6.1) Щелкните правой кнопкой мыши на файле и выберите Копировать.
    1.6.2) Щелкните правой кнопкой мыши в пустом месте папки C:\WINDOWS\system32\ и выберите Вставить.
    1.7) Переименуйте c_1251 - копия.nls в c_1252.nls. В итоге файл c_1252.nls, должен быть переименованной копией c_1251.nls
    1.8) Перезагрузите компьютер.

    Если у Вас установлена Русская Windows или Английская+русский MUI, то проделайте также следующее:

    2.1) Запустите редактор реестра: Win+R -> regedit -> Ok или введите regedit в строке поика меню Пуск и нажмите Enter.
    2.2) Откройте ветку реестра HKEY_CURRENT_USER\Control Panel\International
    2.3) Проверьте значение параметров Locale и LocaleName
    Параметр Locale должен иметь значение 00000419, а параметр LocaleName должен иметь значение ru-RU
    2.4) Если значения параметров другие: дважды щелкните на параметре, который необходимо изменить, введите необходимое значение параметра и нажмите OK.
    2.5) Перезагрузите компьютер.

    3.1) Откройте Язык и региональные стандарты.
    Пуск -> Панель управления -> Язык и региональные стандарты (или Win+R -> control /name Microsoft.RegionAndLanguage -> Ок)
    3.2) Перейдите на вкладку Дополнительно. Можете сразу открыть её: Win+R -> control intl.cpl,,3 -> Ок
    3.3) В блоке Язык программ, не поддерживающих Юникод нажмите на кнопку Изменить язык системы
    3.4) Выберите язык системы Русский (Россия) и нажмите ОК.

    8. Запись последовательности действий пользователя для анализа их разработчиком.

    Одной из встроенных диагностических утилит, чтобы отсылать отчеты об ошибках является "Средство записи действий по воспроизведению неполадок".
    Эта функция, которая позволяет пользователям записывать свои действия в любом используемом приложении и предоставлять подробное представление действий со снимками экрана с соответствующими комментариями.
    Для того, чтобы открыть приложение "Средство записи действий по воспроизведению неполадок" нужно нажать на кнопку меню «Пуск» и в поле поиска ввести psr.
    Для того, чтобы начать запись действий, с которыми возникают проблемы или вопросы нужно просто нажать на кнопку "Начать запись". После этого можно выполнять любые действия с операционной системой и установленными приложениями для воспроизведения проблемы.
    Чтобы приостановить на время запись действий, необходимо нажать на кнопку "Приостановить запись".
    Для того, чтобы снова возобновить запись действий нажимаем на кнопку "Возобновить запись".
    Сразу после остановки записи откроется диалоговое окно "Сохранить как", в котором нужно ввести имя файла и нажать на кнопку "Сохранить". После выполнения этих действий файл будет сохранен в указанной директории с расширением ZIP.

    9. Решение проблемы с выходом из спящего/ждущего режима в черный экран.

    Если при попытке выходе из спящего/ждущего режима Вы попадаете в черный экран или в BSOD (синий экран смерти) Вы можете попробовать несколько способов. Первым делом, скачайте и установите более новые версии драйверов для Вашей видеокарты, чем те что у Вас есть.

    Вариант 1. Изменение настроек BIOS:

    1) Во времени загрузки зайдите в BIOS (для этого нажмите клавишу Delete после начала загрузки компьютера)
    2) В BIOS пройдите на вкладку Power
    3) Попробуйте изменить значение параметра Suspend Mode (Auto, S1 (POS) Only, S3 Only) названия может отличаться, ищите похожие со значениями S1, S3.
    4) Также попробуйте включить\отключить ACPI 2.0 Support -> Enabled\Disabled

    Вариант 2. Запрет вывода из спящего режима используя USB мышь или USB клавиатуру.

    Некоторые USB-устройства неправильно поддерживают спящий режим Windows. Два основных устройства с помощью которых Вы можете выйти из спящего режима - это клавиатура и мышь. Одно из них может блокировать Вам выход, в таком случае ему надо просто запретить это делать. Внимание: Не запрещайте одновременно клавиатуре и мыши, иначе Вы не сможете выйти из него.

    1) Запустите Диспетчер устройств. Для этого пройдите в Пуск -> Выполнить (или Win+R) -> devmgmt.msc -> OK
    2) В Диспетчере устройств разверните узел Мыши и иные указывающие устройства или Клавиатуры
    3) Щелкните правой кнопкой на USB-мышь или USB-клавиатуру и выберите пункт Свойства.
    4) Откройте вкладку Управление электропитанием.
    5) Снимите флажок Разрешить устройству вывод компьютера из спящего режима и нажмите кнопку ОК.

    Вариант 3. Отключение спящего/ждущего режима.

    1) Пройдите в Пуск -> Выполнить (Win+R) -> powercfg.cpl -> OK
    2) Выберите слева пункт Настройка перехода в спящий режим
    3) Присвойте обоим параметрам: Отключать дисплей и Переводить компьютер в спящий режим, значение - Никогда.
    Также можно отключить и функцию сна. Выберите пункт "Изменить дополнительные параметры питания". Найдите в окне режим Сон, разверните Сон после и установите значение находящихся там параметров на Никогда
    Если несмотря на проделанное выше, компьютер по прежнему продолжает отключаться, то Вам необходимо выполнить ещё некоторые действия:
    4) Скачайте reg-файл PowerSettings.reg и примените его.
    5) Откройте вкладку Сон
    6) Установите следующие значения параметрам, открыв их вкладки:
    6.1) Сон после - значение равным 0, оно идентично значению Никогда
    6.2) Разрешить политику требуемую системой - значение Да (это предотвратит автоматический переход в ждущий режим)
    6.3) Разрешить таймеры пробуждения - Включить (позволит автоматически выводить компьютер из спящего режима при помощи заданных событий)
    7) Если у Вас одно из устройств USB например мышь, а второе клавиатура PS/2, то Вы можете отключать USB порт на время работы спящего режима.
    Откройте вкладку Параметры USB, а в ней вкладку Параметр временного отключения USB-порта и установите значение в Разрешено.
    8) Нажмите OK

    10. Восстановление загрузки Windows 7 без установочного диска.

    Вариант 1. Автоматически - при помощи среды восстановления Windows RE в Windows 7.

    Во время установки Windows 7 на жестком диске автоматически создается служебный раздел, обеспечивающий доступ в среду восстановления Windows RE (Recovery Environment). Используя данный служебный раздел, Вы можете:

    - загрузиться в среду восстановления с жесткого диска
    - создать компакт-диск, содержащий среду восстановления

    1) Выполните загрузку в среду восстановления с жесткого диска или диска восстановления системы.
    Для того чтобы войти в меню Дополнительные варианты загрузки, нажмите F8 после включения компьютера (но до загрузки операционной системы).
    2) Выберите первый пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter.
    3) Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи.
    4) Введите пароль администратора. После ввода пароля вы увидите окно с вариантами восстановления.
    5) Выберите пункт Восстановление запуска(Startup repair), также иногда может помочь пункт Восстановление системы (System Restore), позволяющий вернуться к точке, созданной до возникновения проблемы.

    Вариант 2. Восстановление вручную, с созданием мультизагрузочного меню.

    Здесь главное - это добраться до командной строки для введения дальнейших команд.

    1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe)
    2) Создайте папку Boot
    3) Распакуйте скачанный архив и скопируйте файлы Bootsect.exe и Bcdedit.exe, нужной Вам битности в созданную Вами папку Boot.
    4) Запустите среду необходимую для работы:
    5) Загрузитесь в Windows, установленную на другой диск или в среду восстановления (На жестком диске запускается нажатием, клавиши F8. Если клавиша F8 используется материнской платой, после выбора диска нажмите F8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter)
    6) Запустите командную строку.
    В Windows: Win+R -> cmd -> Ok.
    В среде восстановления: Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи. Введите пароль администратора. Выберите пункт Командная строка (Command Prompt)

    Далее все команды вводимые в командную строку будут одинаковы как в Windows, так и в среде восстановления.

    1) Windows 7 использует усовершенствованный метод загрузки - хранилище данных конфигурации загрузки. Это хранилище содержит все сведения обо всех операционных системах, установленных на компьютере. Следовательно, загрузчики более ранних операционных систем Windows, не могут быть использованы для ее запуска. Итак, для восстановления, загрузочного сектор Windows 7, перезаписываем загрузочный сектор на всех разделах:

    где Х - буква диска, на котором содержится программа Bootsect.exe
    2) Если у Вас вторая система Windows XP, то Вам необходимо выполнить ещё ряд действий:

    Создайте в хранилище загрузки Windows 7 - хранилище для загрузки Windows XP.

    Если же система откажется это делать, значит данное хранилище уже создано, поэтому необходимо его только переименовать:

    Далее укажите загрузчику Windows 7 устройство расположения файлов загрузки Windows XP:

    Затем укажите загрузчику Windows 7 путь к загрузчику Windows XP:

    После добавьте строчку о выборе Windows XP в меню загрузки и расположив ее под остальными:

    Также для работы с загрузчиками, Вы можете воспользоваться программой EasyBCD, позволяющей выполнять указанные выше действия, используя графический интерфейс.

    Для информации:

    Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
    Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

    Вариант 3. Восстановление вручную, при помощи bootrec.exe.

    1) Загрузитесь в среду восстановления (На жестком диске запускается нажатием, клавиши F8. Если клавиша F8 используется материнской платой, после выбора диска нажмите F8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter)
    2) Выберите операционную систему, которую необходимо восстановить, и нажмите "Next"("Далее").
    3) В окне Опции системы восстановления (System Recovery Options) выберите пункт Командная строка (Command Prompt).
    4) Откроется окно интерпретатора командной строки cmd.exe, где следует ввести:

    Параметр /FixMbr записывает в системный раздел основную загрузочную запись, совместимую с Windows 7. Этот параметр не перезаписывает существующую таблицу разделов. Данный параметр следует использовать для устранения проблем, связанных с повреждением основной загрузочной записи, или если необходимо удалить из основной загрузочной записи нестандартный код.

    Параметр /FixBoot записывает в системный раздел новый загрузочный сектор с использованием загрузочного сектора, совместимого с Windows 7. Этот параметр следует использовать, если выполняется хотя бы одно из перечисленных ниже условий.

    - Загрузочный сектор Windows 7 был заменен нестандартным загрузочным сектором
    - Загрузочный сектор поврежден
    - После установки Windows 7 на компьютер была установлена более ранняя версия операционной системы Windows. В данном случае для запуска компьютера вместо диспетчера загрузки Windows (Bootmgr.exe) используется загрузчик Windows NT (NTLDR).

    Параметр /RebuildBcd выполняет поиск установленных операционных систем, совместимых с Windows 7, на всех дисках. Кроме того, этот параметр позволяет выбрать установленные системы, которые необходимо добавить в хранилище данных конфигурации загрузки. Этот параметр следует использовать в том случае, если необходимо выполнить полную перестройку данных конфигурации загрузки.

    Если Вы не запомнили необходимого Вам значения Вы можете просто ввести:

    и утилита выведет справку по доступным ключам командной строки.

    11. Восстановление стандартного анимированного экрана загрузки Windows 7.

    В некоторых случаях новый экран загрузки произвольно заменяется старым в стиле Vista. Чаще всего это происходит, после неудачно внесенных различного рода изменений в загрузчик ОС. Предлагаю Вам простые и действенные решения:

    Вариант 1

    Выполнить - C:\Windows\System32\sysprep\sysprep.exe выбрать OOBE и ОК.

    Вариант 2

    1. Откройте командную строку от имени администратора: Пуск -> Выполнить (или Win+R) -> cmd -> Ok
    2. В открытом окне консоли введите команду:

    Обратите внимание, что вышеуказанная команда предусмотрена для английской версии Windows, поэтому если вы используете другую языковую версию, необходимо заменить "en-US" на языковой идентификатор используемой вами версии.
    3. Закройте окно командной строки.
    4. Перезагрузите Ваш компьютер.

    Вариант 3

    1) Откройте диалоговое меню Выполнить: Пуск -> Выполнить (или Win+R)
    2) В открытом окне консоли введите команду: msconfig и нажмите OK
    3) Перейдите на вкладку "Загрузка" и проверьте не установлен ли флажок напротив значения "Без GUI". Если флажок установлен - снимите его.
    4) Закройте окно Конфигурации системы.
    5) Перезагрузите компьютер

    12. Получение полного доступа к NTFS-томам, системному реестру, параметрам настройки и драйверам в случае тотального повреждения существующей на диске ОС или для перезаписи исправлений к русификации поверх оригинальных файлов?

    Для этой функции можно использовать программу Microsoft ERD Commander входящую в состав Microsoft Diagnostics and Recovery Toolset.
    Вы можете создать свой загрузочный образ на основе имеющегося у вас дистрибутива или скачать готовый образ Microsoft ERD Commander.
    Программа для создания своего образа, на основе дистрибутива Windows 7. Запускается только в Windows 7.

    ERD Commander для x86 или x64

    13. Моргание игр в режиме OpenGL.

    Переименуйте файлы: ..\windows\system32\glu.dll в glu32.dll ..\windows\system32\opengl.dll в opengl32.dll

    14. Исправление невозможности запуска службы Центра обеспечения безопасности.

    1) Отключены компоненты от которых зависит данная служба.

    1.1) Откройте: Администрирование -> Службы
    1.2) Проверьте включены ли следующие службы:

    - Инструментарий управления Windows
    - Удаленный вызов процедур (RPC)
    - Модуль запуска процессов DCOM-сервера
    - Сопоставитель конечных точек RPC

    2) Восстановите начальные параметры в реестре, используя значения с компьютера, на котором данная служба работает.

    2.1) Загрузите и примените готовый reg-файл. wscsvc.zip

    15. Исправление отсутствия компонентов в окне "Включение или отключение компонентов Windows".

    1.1) Запустите редактор реестра: Win+R -> regedit -> Ok
    1.2) Откройте ветку реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows
    1.3) Измените значение параметра CSDVersion на 0.
    1.4) Перезагрузите компьютер

    2) В соответствии с разрядностью и языком Вашей Windows, скачайте и установите обновление KB947821:

    Windows6.1-KB947821-v5-x86.msu
    Windows6.1-KB947821-v5-x64.msu

    16. Исправление невозможности изменения настроек User Account Control (UAC).

    В разделе Панели управления Системы и безопасность Вы можете изменить параметры контроля учетных записей User Account Control (UAC).
    Если у Вас при работе в диалоговом окне Параметры управления учетными записями пользователей после перемещения ползунка управления и нажатия кнопки ОК или клавиши Enter, диалоговое окно не закрывается, и/или не вносятся никакие изменения, то вероятнее всего у Вас произошел сбой Реестра.
    Вы можете восстановить нормальную работу User Account Control (UAC) одним из 2 способов.

    Вариант 1. С помощью специального дополнения от Microsoft.

    Скачайте и запустите файл: fixit_kb978591.diagcab

    Вариант 2. При помощи созданного Вами reg-файла.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).

    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "UAC.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    5) Примените полученный файл UAC.reg (Двойной щелчок -> Да)

    Готовый reg-файл Вы можете скачать по ссылке: uac_repair.zip.

    17. Диагностика проблемы высокой загрузки процессора и частых обращений к жесткому диску при запуске или выключении Windows.

    Чтобы определить какая программа или драйвер больше всего загружает Ваш процессор, Вам понадобиться программа от Microsoft - Windows Performance Tools Kit и в дополнение к ней программа XPerfUI от Richard Macdonald, при координации Microsoft.

    1) В соответствии с Вашей разрядностью, скачиваете архив: для x86 или для x64
    2) Устанавливаете программу Windows Performance Tools Kit
    3) Копируйте файл XPerfUI.exe в папку с установленной программой и запускаете его.

    4) Используя всплывающее меню открываете Tools -> Trace Session -> Boot Trace
    5) В блоке Trace Type выбираете, для какого действия Вы хотите провести диагностику: Boot (для анализа запуска) или Shutdown (для анализа выключения)
    6) В блоке Trace Flags устанавливаете переключатель на значение Base, дополнительно отмечаете пункты CSWITCH, DRIVERS, POWER
    7) В поле Result path указываете путь, куда будет сохранен результат анализа. (Например: C:\Temp )
    8) Нажмите кнопку Start для начала диагностики.

    Рисунок 1 из 2

    Компьютер перезагрузится.
    9) Если Вы выбрали Boot (для анализа запуска), то после перезапуска системы, программа запустит трассировку (процесс пошагового выполнения программы) для данного действия и сохранит результаты в указанную Вами папку.
    Если Вы выбрали Shutdown (для анализа выключения), то после перезапуска системы, программа запустит трассировку, снова перезапустит компьютер, снова запустит трассировку и сохранит результаты в указанную Вами папку.

    10) Запускаете программу Performance Analyzer. В появившемся окне нажимаете кнопку Да.
    Пуск -> Все программы -> Microsoft Windows Performance Toolkit -> Performance Analyzer
    или файл xperfview.exe из папки, где установлена программа.
    11) Открываете в окне программы (File -> Open) etl-файл, являющийся созданным в процессе трассировки log-файлом с результатами анализа. Местом нахождения etl-файла будет папка, указанная Вами при запуске трассировки.
    12) Программа загрузит графики.
    13) В меню программы нажимаете Graphs и ставите флажок CPU Sampling by Process.
    14) В меню программы нажимаете Trace и ставите флажок Load Symbols.
    15) Находите график CPU Sampling by Process.
    16) Чтобы вывести сводную таблицу, нажимаете на нем правой кнокой мыши и выбираете пункт Summary Table
    Процесс с наибольшим значением Weight и будет тем самым процессом, который забирает ресурсы процессора при загрузке или выключении. При нажатии на значок +, рядом с наименованием процесса Вы сможете узнать какой именно файл потребляет больше всего ресурсов процессора.

    Рисунок 2 из 2

    17) Также Вы можете посмотреть какая программа больше всего делает обращений к жесткому диску. Для этого найдите график Disk I/O в основном окне графиков программы, нажмите на нем правой кнопкой мыши и выберите пункт Summary Table. Процесс с наибольшим значением Service Time и будет тем самым процессом, который больше всего делает обращений к жесткому диску.

    18. Устранение проблемы открытия папок в отдельном окне, при установленном положении переключателя "Открывать папки в одном и том же окне".

    1) Нажмите Пуск и введите в строке поиска cmd.exe
    2) Нажмите на найденном правой кнопкой мыши и выберите пункт "Запуск от имени Администратора".
    3) Поочередно введите команды, после написания каждой нажмите Enter.

    19. Удаление лишних пунктов из Диспетчера загрузки Windows.

    1) Нажмите кнопку Пуск
    2) Наберите в строке поиска msconfig и нажмите Enter
    3) Перейдите на вкладку Загрузка
    4) Выделите строку которую Вы желаете удалить и нажмите кнопку Удалить
    5) Нажмите кнопку ОК и перезагрузите компьютер

    20. Извлечение файлов Windows 7 из установочного DVD и замена ими поврежденных системных файлов.

    Если у Вас в Windows появились поврежденные системные файлы, то Вам нет необходимости сразу переустанавливать Windows, так как Вы можете просто восстановить поврежденный файл используя DVD-диск или образ установочного диска. Вам всего лишь надо удалить имеющийся системный файл и заменить его извлеченным.

    Инструкция восстановления системных файлов:

    1) Извлеките из установочного диска необходимый файл.
    2) Удалите поврежденный файл.
    3) Скопируйте на место удаленного файла извлеченный.
    4) Перезагрузите компьютер.

    Извлечение файлов с диска Windows 7.

    Вариант 1. При помощи программы DISM.

    Подключение образа в DISM.

    1) Вставьте установочный диск Windows 7 в DVD-привод, или смонтируйте ISO-образ.
    2) Откройте папку sources и скопируйте из нее файл install.wim на диск D.
    Внимание: в качестве папки для подключения образа install.wim НЕЛЬЗЯ использовать корень диска C (тот на котором установлена Windows), так как install.wim содержит системные папки Windows, Program Files, Program Data, Users и др.
    3) Создайте папку на диске D и назовите ее, например, Image. В эту папку будет подключен образ install.wim.
    4) Откройте Пуск > Все программы > Стандартные, щелкните правой кнопкой мыши по значку командной строки и выберите Запуск от имени администратора.
    5) Выполните команду:

    Пояснения:

    dism – встроенная в Windows 7 утилита командной строки, позволяющая подключать образы WIM и управлять ими.
    Параметр /Mount-Wim подключает файл WIM.
    Параметр /WimFile позволяет указать расположение и имя файла WIM, который нужно подключить.
    Параметр /name позволяет указать название выпуска Windows 7, который будет смонтирован.
    Параметр /MountDir: указывает папку, в которую будет смонтирован образ WIM.

    6) Дождитесь, пока образ подключится. Это может занять несколько минут.
    7) Откройте папку D:\Image, найдите в ней (в папках) нужный файл и скопируйте его в любое место на жестком диске.

    После копирования нужных файлов образ можно отключить.

    Отключение образа в DISM.

    1) Закройте все папки и файлы.
    2) Откройте Пуск > Все программы > Стандартные, щелкните правой кнопкой мыши по значку командной строки и выберите Запуск от имени администратора.
    3) Выполните команду:

    Пояснения:

    Параметр /Unmount-Wim отключает образ.
    Параметр /MountDir: указывает папку, в которую смонтирован образ, который нужно отключить.
    Параметр /discard отменяет все внесенные в образ изменения.

    4) Дождитесь отключения образа.
    5) Удалите папку Image и файл install.wim с диска D.

    Вариант 2. При помощи программы 7Zip.

    1) Скачайте и установите программу 7Zip
    2) Cмонтируете образ лицензионного диска с Windows 7 или вставьте установочный DVD-диск.
    3) Используя программу 7Zip откройте файл H:\sources\install.wim
    где (H:) - буква диска с установкой Windows
    4) Откройте в данном файле папку, соответствующую идентичной в системе.
    5) Скопируйте файл(простым переносом из программы 7Zip) в идентичную папку в реальной системе.

    Способы удаления:

    1) Обычное удаление.
    Просто нажмите правой кнопкой мыши на файле и выберите пункт Удалить.

    2.1) Скачайте и установите программу Unlocker
    2.2) Нажмите правой кнопкой мыши на файле и выберите пункт Unlocker.
    2.3) В выпадающем меню выберите пункт Удалить и нажмите на кнопку Разблокировать все.

    3) Удаление в безопасном режиме.
    3.1) Перезагрузите компьютер в безопасный режим(нажмите f4 в начале загрузки компьютера до начала загрузки системы).
    3.2) Нажмите правой кнопкой мыши на файле и выберите пункт Удалить.

    4) Загрузитесь в ERD Commander
    4.1) Для сопоставления букв дисков целевой операционной системе нажмите Да (Yes).
    4.2) В окне выбора опреационной системы не выбирайте никакую систему(должно сняться выделение с какой-либо системы) и нажмите кнопку Далее (Next).
    4.3) Нажмите Micosoft Diagnostics and Recovery Toolset -> Explorer
    4.4) Откройте папку файла, нажмите правой кнопкой мыши на нем и выберите пункт Удалить.

    21. Настройка периодичности создания точек восстановления системы.

    Чтобы изменить периодичность создания точек восстановления сделайте следующее:

    1) Запустите Планировщик заданий. Пуск -> Панель управления -> Администрирование -> Планировщик заданий

    2) В дереве слева откройте Библиотека планировщика задач -> Microsoft -> Windows -> SystemRestore

    3) Щелкните правой кнопкой мыши в верхнем среднем окне на файл SR и выберите Свойства.

    4) В открывшемся окне перейдите на вкладку Триггеры.

    5) Нажмите Создать и задайте необходимые Вам временные параметры, либо выберите уже имеющийся триггер (Например, Ежедневно) и нажмите Изменить. Для удаления созданых триггеров выберите его и нажмите Удалить.

    6) Нажмите на ОК для принятия изменений.

    22. Восстановление веток реестра из резервных копий службы System Restore в Windows 7.

    Большая часть системного реестра находится в следующих местах:

    Раздел HKEY_CURRENT_USER - в файле C:\Users\ИМЯ_ПОЛЬЗОВАТЕЛЯ\NTUSER.dat.
    Все остальные разделы - C:\Windows\system32\config

    Если Вам необходимо восстановить какую-то определенную часть системного реестра Windows 7 или Вы хотите посмотреть, какие значения имел определенный ключ, некоторое время назад, то Вам необходимо сделать следующее:

    Для примера, получим доступ к предыдущим значениям ключа HKEY_LOCAL_MACHINE\SOFTWARE.

    1) Откройте папку C:\Windows\system32. Найдите в ней директорию Config.
    2) Щелкните по папке Config правой кнопкой мыши, выберите пункт меню Свойства и перейдите на вкладку Предыдущие версии.
    3) Два раза щелкните по папке, относящейся к интересующей вас дате. Вы увидите перечень файлов, для которых доступна предыдущая версия. В данном случае нас интересует файл SOFTWARE, так как именно в нем хранятся ключи раздела HKEY_LOCAL_MACHINE\SOFTWARE.
    4) Скопируйте файл в любое удобное вам место, перетащив его в открытое окно Проводника, либо выбрав команду Копировать из контекстного меню файла SOFTWARE.
    Предположим, вы поместили его в корень диска D:.
    5) Запустите редактор реестра (Пуск -> Выполнить -> regedit.exe), установите курсор на корневой ключ HKEY_LOCAL_MACHINE и выполните команду главного меню Файл -> Загрузить куст...
    6) Задайте имя, под которым будет смонтирован файл D:\SOFTWARE (Например: oldsoftware)
    7) Доступ к значениям ключей и разделов реестра будет возможен по пути HKEY_LOCAL_MACHINE\oldsoftware.
    8) Смонтированный куст представляет собой предыдущую версию HKEY_LOCAL_MACHINE\Software, где Вы можете посмотреть предыдущие значения нужных ключей.
    Если значения Вам необходимо поместить в рабочий реестр системы, переходите к следующему пункту.
    9) Найдите интересующий Вас ключ или параметр, и экспортируйте его в reg-файл:
    10) Выделите ключ, и в его контекстном меню выберите команду Экспортировать.
    11) Отредактируйте только что экспортированный файл Блокнотом, заменив все вхождения "\oldsoftware\" на "\SOFTWARE\".
    12) Сохраните reg-файл и двойным щелчком мыши по нему импортируйте его в текущий реестр операционной системы.

    23. Использование "чистой загрузки" для устранения неполадок в работе Windows.

    "Чистая загрузка" - это безопасный режим, в котором компьютер запускается с минимальным количеством работающих программ и служб. Если при запуске компьютера в безопасном режиме ошибок не возникает, это означает, что проблема вызвана одной из программ или служб автозагрузки. В режиме "чистой загрузки" компьютер запускается с отключенными программами и службами автозагрузки, которые затем включаются и отключаются по одной до тех пор, пока источник проблемы не будет локализован.

    Действие 1. "Чистая загрузка" системы

    1) Войдите в систему с учетной записью, имеющей права администратора.
    2) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter, чтобы запустить Конфигурация системы.
    3) На вкладке Общие установите переключатель на Выборочный запуск
    4) Снимите флажок Загружать элементы автозагрузки. (Флажок Использовать оригинальную конфигурацию загрузки недоступен.)
    5) Перейдите на вкладку Службы
    6) Установите флажок Не отображать службы Майкрософт и нажмите кнопку Отключить все.
    7) Нажмите кнопку ОК и щелкните Перезагрузка.

    Действие 2. Включите половину служб.

    1) Войдите в систему с учетной записью, имеющей права администратора.
    2) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter, чтобы запустить Конфигурация системы.
    3) Откройте вкладку Службы и установите флажок Не отображать службы Майкрософт.
    4) Установите флажки для половины служб в списке Службы.
    5) Нажмите кнопку ОК и щелкните Перезагрузка.

    Действие 3. Определите возможную причину неисправности.

    Если неисправность осталась, повторите действия 1 и 2. В действии 2 снимите в списке Службы установленные флажки.
    Если проблема исчезла, повторите действия 1 и 2. В действии 2 установите половину из еще не установленных флажков в списке Службы. Повторяйте эти действия, пока не будут установлены все флажки.
    Если в списке Службы осталась выбранной только одна служба и проблема по-прежнему наблюдается, то именно эта служба ее и вызывает.
    Если проблема вызвана одной из служб, перейдите к действию 6, в противоположном случае продолжайте поиск неисправности перейдя к действию 4.

    Действие 4. Разрешите запуск половины элементов списка автозагрузки.

    1) Выполните чистую загрузку, повторив действие 1.
    2) Откройте вкладку Автозагрузка и установите флажки для половины элементов списка элементов автозагрузки.
    3) Нажмите кнопку ОК и щелкните Перезагрузка.

    Действие 5. Определите возможную причину неисправности.

    Если неисправность осталась, повторите действия 1 и 4. В действии 4 снимите в списке элементов автозагрузки установленные флажки.
    Если проблема исчезла, повторите действия 1 и 4. В действии 4 установите половину из еще не установленных флажков в списке элементов автозагрузки. Повторяйте эти действия, пока не будут установлены все флажки.
    Если в списке элементов автозагрузки остался только один элемент и проблема по-прежнему наблюдается, то именно этот элемент ее и вызывает.
    Если проблема вызвана одним из элементов автозагрузки, перейдите к действию 6.
    Если неполадка не вызвана ни одним из элементов автозагрузки, вероятнее всего, ее вызывает одна из служб Майкрософт. Чтобы определить, какая именно служба вызывает неполадку, повторите действия 1 и 2, не устанавливая флажок Не отображать службы Майкрософт в действии 2.

    Действие 6. Устраните проблему.

    Определив программу или службу, являющуюся причиной проблемы сделайте одно из предложенным действий:

    1) Установите более новую версию программы или удалите текущую.
    2) Обратитесь к разработчикам программы в службу поддержки.
    3) Используя Конфигурация системы снимите флажок проблемного элемента в списке Службы или в списке элементов автозагрузки.
    4) Запустите командную строку (Win+R -> cmd -> ОК) и выполните команду sfc /scannow

    Действие 7. Перезагрузите систему в обычнй режим Windows.

    Завершив устранение неполадок, для перезагрузки в обычнй режим Windows выполните описанные далее действия:

    1) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter, чтобы запустить Конфигурация системы.
    2) На вкладке Общие установите переключатель на Обычный запуск
    3) Нажмите кнопку ОК и щелкните Перезагрузка.

    24. Определение устройства выведшего Windows 7 из спящего режима.

    Если уходя от компьютера Вы оставили его в спящем режиме, а вернувшись обнаружили что он включен (разбужен), то для определения устройства выведшего Windows из спящего режима сделайте следующее:

    1) Запустите командную строку от имени Администратора: Win+R -> cmd -> ОК.
    2) Введите команду: powercfg -lastwake и нажмите ОК.
    3) Результатом работы данной программы будет указание на идентификатор устройства.

    Чтобы узнать, что это за устройство:

    4) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    5) Откройте ветку: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\.
    6) Найдите искомое Вами устройство, согласно полученному при выполнении powercfg результату.
    Наименование устройства будет отображено в найденном Вами ключе в параметре DeviceDesc

    25. Устранение неполадок с поиском и индексированием.

    Если результаты поиска отображаются не полностью, а также поиск в системе происходит медленно независимо от установленных настроек, то сделайте следующее:

    1) Откройте меню Пуск, введите в строке поиска Устранение неполадок и нажмите Enter.
    2) Нажмите кнопку Просмотр всех категорий, а затем выберите раздел Поиск и индексирование.
    3) Нажмите кнопку Далее, затем в диалоговых окнах выбирайте ответы для уточнения имеющейся у Вас проблемы и нажимайте соответствующие кнопки.

    Если файлы из индексированной папки не отображаются в результатах поиска, то сделайте следующее:

    Причиной могут быть параметры безопасности, установленные для этой папки. Для индексирования папки и ее содержимого для нее необходимо установить разрешение система. Для большинства папок данное разрешение уже настроено, но в некоторых случаях разрешение система для папки может отсутствовать.

    Добавление для папки разрешения система.

    1) Щелкните папку правой кнопкой мыши, выберите пункт Свойства и откройте вкладку Безопасность.
    2) Если вариант система не отображается в списке Группы или пользователи, щелкните Изменить.
    3) Щелкните Добавить, введите в открывшемся окне система, затем щелкните Проверить имена.
    4) В разделе Введите имена выбираемых объектов щелкните система, затем нажимайте кнопку ОК, пока не будут закрыты все открытые диалоговые окна.
    5) Откройте меню Пуск, введите в строке поиска Параметры индексирования и нажмите Enter.
    6) Щелкните Дополнительно. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
    7) В диалоговом окне Дополнительно перейдите на вкладку Параметры индексирования, а затем нажмите кнопку Перестроить. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.

    Перестроение индекса может занять несколько часов, и до тех пор пока индекс не будет перестроен, результаты поиска могут быть неполными.

    26. Исправление проблемы, когда автоматически не обновляется значок корзины, после ее очистки.

    Вариант 1.

    1) Запустите текстовый редактор, например «Блокнот».
    2) Скопируйте в него текст указанный ниже:

    3) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3.1) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DefaultIcon.reg")
    3.2) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    4) Примените полученный reg-файл. Щелкните на нем дважды и нажми кнопку Да, а затем ОК.

    Вариант 2.

    1) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Персонализация.
    2) Нажмите ссылку Изменение значков рабочего стола.
    3) Выберите значок Корзина (полная) и нажмите кнопку Сменить значок.
    4) В диалоговом окне Смена значка, выберите значок полной корзины и нажмите кнопку ОК.
    5) Выберите значок Корзина (пустая) и нажмите кнопку Сменить значок.
    6) В диалоговом окне Смена значка, выберите значок пустой корзины и нажмите кнопку ОК.
    7) В диалоговом окне Параметры значков рабочего стола нажмите кнопку ОК.

    27. Исправление ошибки из журнала событий: "Не удается найти описание для идентификатора события 1904 из источника HHCTRL.".

    При запуске и использовании (чтение, переход по страницам) в Windows файла справки с расширением *.CHM в журнале событий может появляться сообщение:
    "Не удается найти описание для идентификатора события 1904 из источника HHCTRL.".
    Это происходит из-за неправильного задания уровня безопасности системой для Местной интрасети в контейнере файла-справки.

    Чтобы узнать появляется ли у Вас данная ошибка:

    1) Откройте оснастку Просмотр событий
    1.1) В строке поиска меню Пуск введите команду eventvwr.msc и нажмите Enter
    или
    1.2) Пройдите Панель управления\Все элементы панели управления\Администрирование и откройте Просмотр событий.
    2) Слева в древовидном списке оснастки Просмотр событий перейдите Просмотр событий (Локальный) -> Журналы Windows -> Приложение
    3) В центральном окне будут описаны события произошедшие при работе с программами.

    Для исправления данной ошибки, создайте и примените reg-файл следующего содержания:

    28. Перезагрузка в Безопасный Режим при отсутствии данного пункта в меню Диспетчера загрузки.

    Если у Вас в меню Диспетчера загрузки (вызывается нажатием клавиши F8 до появления экрана с логотипом Windows) отсутствует пункт для запуска Безопасного режима, то Вы можете попробовать перезагрузиться в Безопасный режим используя утилиту Windows - Настройка системы, для этого:

    1) В строке поиска меню Пуск введите команду: msconfig
    2) Перейдите на вкладку Загрузка
    3) Установите флажок напротив пункта Безопасный режим.
    4) Установите переключатель в нужное значение:

    Минимальная - загрузка графического интерфейса пользователя ОС Windows (Проводника Windows) в безопасном режиме с запуском только самых важных системных служб. Сетевые компоненты отключены.
    Другая оболочка - загрузка командной строки Windows в безопасном режиме с запуском только самых важных системных служб. Сетевые компоненты и графический интерфейс пользователя отключены.
    Восстановление Active Directory - загрузка графического интерфейса пользователя Windows в безопасном режиме с запуском только самых важных системных служб и службы каталогов Active Directory.
    Сеть - загрузка графического интерфейса пользователя Windows в безопасном режиме с запуском только самых важных системных служб. Сетевые компоненты включены.

    5) Установите необходимые флажки:

    Без GUI - во время загрузки Windows экран приветствия не отображается.
    Журнал загрузки - вся информация, касающаяся процесса загрузки, сохранится в файле %SystemRoot%\Ntbtlog.txt.
    Базовое видео - загрузка графического интерфейса пользователя Windows в минимальном режиме VGA. В этом режиме загружаются стандартные драйверы VGA вместо драйверов экрана, соответствующих видеооборудованию компьютера. Установка данного пункта позволяет загрузиться в безопасный режим при проблемах с драйверами видеокарты.
    Информация об ОС - отображает имена загружаемых драйверов в процессе загрузки системы. Устанавливайте, если желаете самостоятельно определить проблемный драйвер или библиотеку мешающие загрузке.

    6) Нажмите в текущем окне ОK, затем во всплывшем окне нажмите Перезагрузка.

    29. Исправление ошибки 4201, возникающей при попытке запуска службы Журнал событий Windows (Windows Event Log).

    Вариант 1.

    1) В соответствии с разрядностью Вашего Windows скачайте и установите программу Unlocker
    2) В проводнике откройте папку C:\Windows\System32\LogFiles\WMI
    3) Нажмите правой кнопкой на папке RtBackup и в контекстном меню выберите пункт Unlocker.
    4) В ниспадающем списке выберите пункт Удалить и нажмите на кнопку Разблокировать Все
    5) Перезагрузите компьютер
    6) Запустите службу Журнал событий Windows.

    Вариант 2.

    1) Перезагрузитесь в безопасный режим с полным отключением всех служб (для этого воспользуйтесь утилитой msconfig)
    2) Откройте папку C:\Windows\System32\LogFiles\WMI
    3) Удалите подпапку RtBackup со всем его содержимым.
    Если необходимо, то задайте перед удалением для данной папки полные права. Иногда помогает сначала удаление файлов из папки, а затем самой папки.
    4) Перезагрузитесь обратно в нормальный режим.
    5) Запустите службу Журнал событий Windows.

    Устранение неполадок - Рабочий стол, Проводник, Панель задач.

    1. Исправление исчезновения панели быстрого запуска после перезагрузки.

    Если Вы создаете панель быстрого запуска, но после перезагрузки она исчезает, то попробуйте любое из предложенных ниже решений.

    1) Попробуйте создать панель быстрого запуска со значением отличающимся от Вашего:

    %userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch
    %appdata%\Microsoft\Internet Explorer\Quick Launch
    C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

    2) Установите ползунок контроля учетных записей (UAC) в предпоследнее значение.

    3) Создайте и добавьте в реестр следующий reg-файл:

    4) Откройте C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer
    Добавьте на вкладке Свойства -> Безопасность пользователя Все и задайте ему полный доступ.

    5) В диалоговом окне Выполнить из меню Пуск (Win+R) введите команду control userpasswords2 и нажмите Enter.
    Поставьте флажок на "Требовать ввод имени пользователя и пароля"

    6) В диалоговом окне Выполнить из меню Пуск (Win+R) введите команду gpedit.msc и нажмите Enter.
    Откройте Конфигурация пользователя -> Административные Шаблоны -> Меню "Пуск" и панель задач
    Измените параметр политики Отображение панели быстрый запуск на панели задач на значение Включить.

    7) Закройте Языковую панель и установите вместо неё Punto Switcher.

    2. Исправление сбоев возникающих при установке, обновлении или удалении программы с помощью установщика Windows (msiexec.exe).

    Вариант 1

    1) Перейдите Пуск->Все программы->Стандартные
    2) Щелкните правой кнопкой мыши на пункт Командная строка и нажмите Запуск от имени Администратора
    3) Скопируйте следующую строчку в окно команд и нажмите Enter:

    Вариант 2

    1) Откройте меню Пуск, введите в строке поиска regedit и нажмите Enter.
    2) Перейдите в раздел HKLM\SOFTWARE\Microsoft\SQMClient\Windows
    3) Щелкните правой кнопкой мыши на разделе DisabledSessions и нажмите Удалить.

    3. Восстановление пункта "Выполнить" в меню "Пуск".

    Если у Вас отмечен пункт Команда "Выполнить" в "Настройка меню Пуск" (На кнопке Пуск нажмите правую кнопку мыши и выберите пункт Свойства, нажмите кнопку Настроить), а меню "Выполнить" не показывает Вы можете восстановить его так:
    1) В Меню "Пуск" в строке поиска наберите gpedit.msc и откройте найденный файл gpedit.msc (Редактор групповых политик)
    2) В левой части открывшегося окна пройти к вкладке:
    Политика "Локальный компьютер"\Конфигурация пользователя\Административные шаблоны\Меню «Пуск» и панель задач
    3) Выделите в правой части строку Добавить команду "Выполнить" в меню "Пуск"
    4) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

    4. Убирание появляющейся в меню Пуск полоски, пропадающей при повторном открытии.

    Данная ошибка исправлена в Сервисном Пакете 1 (Service Pack 1).

    1) Переключаете язык интерфейса в английскую версию Windows: Панель управления->Язык и Региональные Стандарты->Языки и Клавиатуры->Язык интерфейса->выбираете английский
    2) Перелогиниваетесь или перезапускаете компьютер
    3) Задаёте полный доступ к файлу aero.msstyles.mui из папки C:\Windows\Resources\Themes\Aero\ru-RU
    4) Копируете с заменой aero.msstyles.mui из C:\Windows\Resources\Themes\Aero\en-US в C:\Windows\Resources\Themes\Aero\ru-RU
    5) Возвращаете язык интерфейса на русский
    Для тех у кого изначально русская, выкладываю данный файл отдельно для x64: aero.msstyles.mui и для x86: aero.msstyles.mui

    Также Вы можете скачать и запустить от имени Администратора готовый патч: MenuFix_Rus_x86_x64_Final.rar
    После его применения понадобиться перезагрузить компьютер.

    5. Восстановление ассоциации для *.cpl файлов.

    Если какая-нибудь программа сбила Вам ассоциацию приложения Windows c файлами *.cpl.

    1) Щелкните правой кнопкой мыши на любом файле *.cpl и выберите Свойства
    2) На вкладке Общие напротив надписи Приложение нажмите кнопку Изменить.
    3) В открывшемся окне нажмите кнопку Обзор
    4) Зайдите в папку C:\Windows\System32 и выберите файл control.exe
    5) Нажмите ОК

    6. Исправление вылета проводника при нажатии правой кнопки мыши на файле или папке.

    Скачайте небольшую утилиту ShellExView: с официального сайта или с зеркала.

    Вариант 1.

    Оптимальным решением проблемы может быть отключение расширения оболочки CmdLineExt.dll.
    1) Запустите ShellExView.
    2) Найдите среди выведенных ею расширений оболочки - расширение с именем CmdLineContextMenu Class
    3) Выделите и нажмите клавишу F7 или через контекстное меню выберите опцию Disable Selected Items.
    4) Перезагрузите компьютер.

    или

    1) Нажмите Пуск -> Выполнить (Win+R)
    2) Введите команду regsvr32 /u CmdLineExt.dll и нажмите ОК.
    3) Перезагрузите компьютер.

    Вариант 2.

    1) Запустите ShellExView.
    2) Сделайте сортировку по столбцу Type (щелкните мышкой на названии столбца). Вас будут интересовать записи, где Type = Context Menu, а в столбце File Extensions есть звездочка.
    3) Отключайте записи по очереди, начав с расширений, не принадлежащих Microsoft. Отключение выполняется щелчком правой кнопкой мыши -> Disable Selected Items или клавишей F7.
    4) Отключив запись, проверьте работу проводника.

    Если вы отключили все расширения, но проблема не решилась, то в командной строке (Win+R -> cmd -> OK) введите sfc /scannow и нажмите Enter.
    Если данное действие не возымеет успеха, то перезагрузитесь в безопасный режим Windows.
    Если в безопасном режиме данная проблема пропадает, тогда всё нормально, значит, проблема вызвана одной из установленных у вас программ, драйверов, кодеков или служб и Вам придется вручную искать причину вызвавшую сбой. Удалять по одной программе, отключать по одной службе или откатываться к предыдущим версиям установленных драйверов, либо используя точки восстановления возвращаться к предыдущим состояниям системы и наблюдать на каком этапе исчезла ошибка.

    7. Восстановление исчезнувшей языковой панели.

    Исчезновение языковой панели, чаще всего происходит после использования чистильщика или оптимизатора системы.
    Перед использованием одного из предложенных вариантов, сделайте следующее:

    1) Откройте редактор реестра (Win+R -> regedit -> OK )
    2) Проверьте, не добавлен ли запрет на запуск языковой панели в следующую папку реестра:

    3) Проверьте, присутствует ли в реестре ветки:

    Region and Language

    Keyboard

    4) Проверьте значение параметров, в ветке реестра:

    – значение REG_SZ-параметра AppName должно быть ctfmon.exe
    – значение REG_SZ-параметра AppPath должно быть С:\Windows\system32.

    Вариант 1

    1) Идете в Панель управления - Язык и региональные стандарты
    2) Делаете все по пунктам на скриншотах.

    Рисунок 1 из 2

    Установите переключатель на значение Закреплена в панели задач и отметьте флажок Отображать текстовые метки на языковой панели и нажмите OK
    3) Щелкаете правой кнопкой на панели задач, выбираете Свойства.
    4) В пункте Область уведомлений щелкаем кнопку Настроить

    Рисунок 2 из 2

    5) В открывшемся окне поставьте флажок напротив "Всегда показывать все значки и уведомления на панели задач" и нажмите OK

    Вариант 2

    В контекстном меню панели задач уберите флажок со значения Закрепить панель задач, расширьте границы для всех панелей, а затем снова поставьте флажок напротив Закрепить панель задач.

    Вариант 3

    Найдите файл ctfmon.exe и добавьте его в Автозагрузку или создайте reg-файл со следующим содержанием:

    Вариант 4

    1) Откройте Языки и службы текстового ввода
    Так:

    1.1.1) Откройте Пуск->Выполнить (или нажмите на клавиатуре Win+R)
    1.1.2) Ввести: RunDll32.exe shell32.dll,Control_RunDLL C:\Windows\system32\input.dll
    1.1.3) Нажать OK

    Или так:

    1.2.1) Открыть Панель управления\Часы, язык и регион
    1.2.2) Нажать на ссылку Смена раскладки клавиатуры или других способов ввода
    1.2.3) Нажать на кнопку Изменить клавиатуру
    2) На вкладке Общие удалите все раскладки клавиатуры кроме Английский
    3) На вкладке Языковая панель снимите все флажки и установите переключатель в значение Скрыта
    4) Выгрузите вручную библиотеки.
    4.1) Откройте Пуск->Выполнить (или нажмите на клавиатуре Win+R)
    4.2) Выполните поочередно команды:

    5) Перезагрузите компьютер.
    6) Откройте Языки и службы текстового ввода
    7) На вкладке Общие добавьте нужные Вам раскладки клавиатуры
    8) На вкладке Языковая панель установите переключатель в значение Закреплена в панели задач и установите флажок напротив пункта Отображать текстовые метки на языковой панели.
    9) Нажмите OK.

    Как альтернативный вариант можете установить программу Punto Switcher, она добавляет собственную языковую панель и функцию автоматического переключения раскладки при неправильном её выборе.

    8. Исправление ошибки, когда папки "Недавние места" и "Недавние документы" пустые.

    1) Щелкните правой кнопкой мыши на кнопке Пуск и нажмите на Свойства
    2) Установите флажки напротив пунктов:
    "Хранить и отображать список недавно открывшихся программ в меню "Пуск"
    "Хранить и отображать список недавно открывшихся элементов в меню "Пуск" и на панели задач"
    3) Нажмите OK.

    9. Удаление появившейся на рабочем столе папки "Недавние места".

    1) Удалите папку C:\Users\Default\AppData\Roaming\Microsoft\Windows\Recent
    2) Перезагрузите компьютер или перезапустите систему
    3) Зайдите в C:\Users\Default\AppData\Roaming\Microsoft\Windows\
    4) Если Windows 7 не восстановил папку Recent заново, создайте её самостоятельно.

    10. Решение ошибки "Отсутствует исполняющее ядро для расширения имени файла js"
    Иногда какое-то приложение может изменить ассоциацию к файлам ".js" (Например, текстовый редактор, использующий скрипты).
    Что может привести к ошибке "Отсутствует исполняющее ядро для расширения имени файла js".
    Переустановка Java от Sun Microsystems или компонентов с сайта Майкрософт, не всегда исправляет эту ошибку.

    Необходимо восстановить через реестр значение по умолчанию "JSFile" .

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    5) Запустите reg-файл.

    11. Гаджеты или их настройки отказываются запускаться.

    Для нормального функционирования гаджетов рекомендуется не отключать полностью контроль учетных записей (UAC), а выставить минимальный уровень.
    Если Вам необходима работа гаджетов при отключенном контроле учетных записей (UAC):

    1) Создайте reg-файл указанного ниже содержания.

    2) Примените его и перезагрузите компьютер.

    или

    1) Запустите командную строку от имени Администратора (Win+R -> cmd -> ОК)
    2) По очереди введите команды указанные ниже, нажимая после введения каждой Enter:

    12. Восстановление пункта "Закрепить программу в панели задач".

    Если у вас пропал пункт "Закрепить программу в панели задач":
    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    13. Пользовательские папки отображаются обычными иконками.

    Если у вас пользовательские папки, такие как Документы, Изображения и т.п., отображаются в проводнике с обычными иконками, как и любые другие папки, то это может быть вызвано отсутствием или повреждением файлов desktop.ini, расположенных в таких папках. Или же эти файлы имеют неправильные атрибуты.
    Если файл desktop.ini присутствует в папке, его атрибуты должны быть Скрытый и Только чтение.
    В случае если файла desktop.ini нет в папке, его необходимо создать с указанным ниже содержимым и с указанными выше атрибутами.
    Для вступления в силу изменений необходимо завершение сеанса или перезагрузка.

    Содержимое файлов desktop.ini для стандартных пользовательских папок

    Документы

    Изображения

    Музыка

    Видео

    Поиски

    Загрузка

    Избранное

    Контакты

    Рабочий стол

    Ссылки

    Сохраненные игры

    Общий рабочий стол

    Общие документы

    Общая музыка

    Общие изображения

    Общее видео

    14. Исправление проблемы, с дублированием ярлыков на рабочем столе.

    Если при создании, копировании или перемещении на рабочий стол любого документа/ярлыка/папки, после обновления экрана или перезагрузки компьютера, у Вас появляются их дубликаты (точная копия, без (2) в названии), то это означает, что Ваш собственный рабочий стол и общий рабочий стол прописаны в реестре в одной папке. Данная проблема решается указанием для них отдельных отличающихся между собою папок.

    1) Запустите Редактор реестра. Для этого в строке поиска в меню Пуск введите regedit и нажмите Enter
    2) Откройте раздел: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
    3) Измените значение параметра Common Desktop на одно из предложенных ниже:

    C:\Users\Public\Desktop - значение Windows по умолчанию
    C:\Users\ВашПрофиль\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок.

    4) Откройте раздел: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
    5) Измените значение параметра Common Desktop на одно из предложенных ниже:

    %Public%\Desktop - значение Windows по умолчанию
    %USERPROFILE%\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок.

    15. Восстановление поиска в Проводнике и в меню Пуск.

    1) Используя Реестр (Win+R -> regedit)
    1.1) Откройте ветку реестра:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    1.2) В случае обнаружения параметра NoFind, удалите его.

    2) Используя Панель управления
    2.1) Откройте Панель управления\Программы\Программы и компоненты
    2.2) Запустите "Включение и отключение компонентов Windows" (или Win+R -> OptionalFeatures.exe)
    2.3) Проверьте, включен ли у Вас компонент Windows Search (Поиск Windows).

    3) Используя Редактор локальной групповой политики.
    3.1) В диалоговом окне Выполнить из меню Пуск (Win+R) введите команду gpedit.msc и нажмите Enter.
    3.2) Откройте Конфигурация пользователя -> Административные Шаблоны -> Меню "Пуск" и панель задач
    3.3) Измените следующие параметры политики на значение Не задана:

    - Добавить ссылку "Поиск в Интернете" в меню "Пуск"
    - Удалить ссылку "Поиск" из меню "Пуск"

    16. Исправление всплывающей подсказки оказывающейся за панелью задач Windows.

    Если у Вас возникает ошибка, когда всплывающая подсказка оказывается за панелью задач Windows, и её видно частично или совсем не видно, то Вы можете воспользоваться небольшой программой ToolTipFixer, которая исправляет эту ошибку, возвращая на место всплывающую подсказку.

    Скачайте и установите ToolTipFixer

    17. Решение проблемы пропадания значков в панели задач.

    Это происходит потому, что загружаемые программы пытаются установить иконки раньше, чем explorer успевает инициировать трей. Для установки задержки запуска программ, Вы можете воспользоваться менеджером автозагрузки Startup Delayer.

    В дополнение к программе воспользуйтесь твиком реестра.

    Скачайте и примените его: tray_icons.reg

    18. Удаление ярлыков на отсутствующие в системе элементы в папке "Недавние места".
    Для удаления ярлыков на отсутствующие в системе элементы из папки "Недавние места" предлагаю Вам следующие варианты решения.

    Вариант 1.

    1) Откройте в проводнике папку Недавние документы (%AppData%\Microsoft\Windows\Recent)
    Просьба не путать с папкой Недавние места (это другая папка)
    2) Щелкните правой кнопкой мыши ярлык на отсутствующий в системе элемент(папку или файл) и выберите пункт Удалить.
    3) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Обновить. Данное действие необходимо, чтобы убрать появившуюся на рабочем столе папку Недавние места.

    Вариант 2.

    Для его выполнения необходима программа Registry Workshop - заменяющая стандартный редактор реестра.

    1) Запустите Registry Workshop
    2) Нажмите Search (Поиск) -> Find...(Поиск...)
    3) В открывшемся окне установите переключатель на Search in key: (В разделе:)
    4) Введите HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RecentDocs
    5) В текстовом поле Find what: (Запрос:) введите наименование отсутствующего в системе элемента (папки или файла)
    6) Нажмите кнопку Find (Поиск)
    7) Выделите найденное с помощью левой кнопки мыши или нажмите комбинацию клавиш Ctrl+A, чтобы выделить все.
    8) Щелкните на выделенном правой кнопкой мыши и выберите пункт Delete From Registry (Удалить из реестра)

    19. При загрузке Windows автоматически открывается окно Проводника.

    Варианты решений:

    1) Открыть Пуск - Панель управления - Параметры папок - убрать флажок "Восстанавливать прежние окна папок при входе в систему".
    2) В командной строке (Win+R -> cmd -> OK) введите sfc /scannow и нажмите Enter
    3) Создайте и примените reg-файл:

    20. Восстановление запуска Exe-файлов в системе.

    Данные проблема связана с изменением какой-нибудь программой в реестре параметров отвечающих за ассоциации exe-файлов.
    Для устранения данной проблемы попробуйте один из следующих вариантов.

    Вариант 1.

    1) Откройте папку C:\Windows\System32
    2) Сделайте копию файла regedt32.exe
    3) Переименуйте данную копию в regedt32.com
    4) Щелкните на данном файле правой кнопкой мыши и выберите Запуск от имени администратора.
    5) Откройте ветку HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe
    6) Удалите раздел UserChoice

    Вариант 2.

    1) Скачайте файл exefix_win7.zip
    2) Разархивируйте его и примените reg-файл.

    или же создайте самостоятельно в блокноте reg-файл следующего содержания:

    21. Исправление ошибки проводника "Не удалось найти этот элемент".

    Если у Вас возникает данная ошибка, то скорее всего у Вас сбились описания папок. Для их восстановления:

    1) Скачайте файл FolderDescriptions.zip
    2) Распакуйте его в любую папку.
    3) В соответствии с разрядностью Вашей Windows примените reg-файл, восстанавливающий настройки описания папок в изначальные.
    4) Перезагрузите компьютер.

    22. Исправление появляющегося окна предупреждения системы безопасности "Неизвестный издатель", при открытии программы из меню Пуск.

    1) Запустите командную строку от имени Администратора
    (Нажмите Пуск -> в строке поиска введите cmd -> щелкните правой кнопкой мыши по найденному файлу cmd.exe -> выберите пункт Запуск от имени Администратора)
    2) Поочередно введите команды, нажимая для их выполнения клавишу Enter:

    23. Если у вас при запуске файлов *.chm неправильно определяется кодировка.

    Если при создании *.chm файла принудительно не указать на каждой странице кодировку, то при его чтении у некоторых людей могут возникнуть трудности с определением кодировки. Для решения данной проблемы:

    1) Закройте *.chm файл
    2) Зайдите в Internet Explorer
    3) Нажмите правую кнопку мыши
    4) В появившемся меню наведите указатель на слово Кодировка и поставьте галочку напротив пункта Автовыбор
    5) Запустите ваш *.chm и система сама определит кодировку.

    24. Перестали запускаться анимированые обои. Ошибка:"Windows DreamScene can only run when Windows Aero scheme is selected."

    Вероятно, аэро - отключено.
    Щелкаете правой кнопкой на монитор - Персонализация - выберите тему с прозрачными окнами (они вверху).
    Или C:\Windows\Resources\Themes выбрать aero.

    25. Создание ярлыка и комбинации клавиш для закрытия зависших приложений и перезапуска Проводника.

    Создание ярлыка и комбинации клавиш для закрытия зависших приложений.

    1) Щелкните по рабочему столу и выберите во всплывшем меню Создать -> Ярлык.
    2) В поле Укажите расположение объекта введите команду

    3) Щелкните правой кнопкой мыши на ярлыке и выберите Свойства
    4) В поле Быстрый вызов назначьте комбинацию клавиш для использования.

    Создание ярлыка и комбинации клавиш для перезапуска Проводника.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).

    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .cmd. Например: restart_explorer.cmd
    3) Щелкните по рабочему столу и выберите во всплывшем меню Создать -> Ярлык.
    4) В поле Укажите расположение объекта выберите созданный Вами командный файл.
    5) Щелкните правой кнопкой мыши на ярлыке и выберите Свойства
    6) В поле Быстрый вызов назначьте комбинацию клавиш для использования.

    26. Восстановление в всплывающем меню "Создать" пункта "Папку".

    Если у Вас из всплывающего меню Создать находящегося в основном контекстном меню(вызывается нажатием правой кнопки мыши) пропал пункт Папку, то Вы можете скачать и применить reg-файл содержащий изначальные настройки для данного пункта меню в реестре.

    Чтобы применение reg-файла прошло успешно, воспользуйтесь небольшой инструкцией:

    1) Измените разрешения (установите полный доступ) и владельца для раздела реестра: HKEY_CLASSES_ROOT\CLSID\{11dbb47c-a525-400b-9e80-a54615a090c0}

    1.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    1.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    1.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    1.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    1.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    2) Скачайте и примените reg-файл. NewFolderFix.zip
    3) Перезагрузите компьютер. Для желающих создать данный reg-файл самостоятельно его текст:

    27. Исправление отсутствия в папке Все программы из меню Пуск папки "Стандартные".

    Для исправления данной ситуации Вам необходимо создать новый профиль и скопировать из него необходимые папки.

    1) В строке поиска меню Пуск введите lusrmgr.msc и нажмите Enter.
    2) Перейдите в папку Пользователи
    3) Щелкните правой кнопкой мыши в средней части окна и выберите Новый пользователь.
    4) Введите любое имя пользователя (Например: Demo) и снимите флажок "Требовать смены пароля при следующем входе в систему"
    5) Нажмите Создать, а когда кнопка станет не активной нажмите Закрыть.
    6) Выйдите из системы и войдите в систему, используя только что созданную учётную запись.
    7) Выйдите из системы и войдите в систему, используя Вашу учётную запись.
    8) Откройте Проводник введите в адресной строке указанный ниже адрес папки и нажмите Enter.

    где Demo - имя созданной Вами учетной записи.
    9) Щелкните правой кнопкой мыши на папке Стандартные (Accessories) и выберите пункт Копировать
    10) Откройте Проводник введите в адресной строке указанный ниже адрес папки и нажмите Enter.

    где UserName - имя Вашей учетной записи (его можно узнать открыв папку C:\Users).
    11) Щелкните правой кнопкой мыши в пустой части окна данной папки и выберите пункт Вставить
    12) Перезагрузите компьютер.

    Для удаления созданной Вами учетной записи пользователя:

    1) В строке поиска меню Пуск введите lusrmgr.msc и нажмите Enter.
    2) Перейдите в папку Пользователи
    3) Щелкните правой кнопкой мыши в списке на имя созданной Вами учетной записи и выберите пункт Удалить
    4) Нажмите во всплывшем окне кнопку Да и выйдите из оснастки "Локальные пользователи и группы"
    5) Откройте в проводнике папку C:\Users и удалите папку с именем созданной Вами учетной записи.

    Устранение неполадок - Устройства и BSOD.

    1. При использовании сторонних плееров для видео, выкидывает в BSOD.

    Данную проблему можно решишь, если установить в расширенных настройках видео: Режим рендеринга или фильтр рендеринга для DirectShow Video на "Улучшенный обработчик видео" или "Enhanced Video Renderer" (EVR).

    В Media Player Classic данный параметр находится View - Options - Playback - Output - Directshow Video - EVR.
    В Bsplayer Pro данный параметр находится Опции - Настройки - Видео - Вывод видео - Режим рендеринга - EVR (Enhanced Video Renderer).

    2. В папке "Компьютер" не отображаются DVD-дисководы.

    Уберите флажок в Панель управления-Параметры папок-Вид "Скрыть пустые диски в папке "Компьютер""

    3. В Windows и Nero не стираются диски DVD RW и CD RW.

    Если при попытке стереть данные диски вы получаете ответ "Не перезаписываемый диск" или "Диск защищён от записи". По всей видимости была сделана метка на диске и программы определяют его как DVD-R. Чтобы убрать эту метку зайдите в Alcohol 120% и уберите метки в пунктах Сервис -> Настройки -> Эмуляция -> Игнорировать тип носителя, в Daemon Tools Спрятать CD-R.
    Значение этой опции: Bынудить дpугиe пpoгpaммы нe oпpeдeлять зaпиcывaeмый тип диcкa, пpинимaя eгo зa CD-ROM или DVD-ROM.
    После этого заново сотрите эти диски в Alcohol 120% или в Daemon Tools.

    4. Определение драйвера, вызвавшего BSOD.

    Включение записи дампов памяти

    1) Нажимаете комбинацию клавиш Win+Pause
    2) Щелкаете ссылку Дополнительные параметры системы
    3) Переходите на вкладку Дополнительно
    4) Нажимаете кнопку Параметры в Загрузка и восстановление

    Рисунок 1 из 2

    5) По умолчанию они будут сохраняться в папку %SystemRoot%\Minidump

    Рисунок 2 из 2

    Анализ дампа памяти и определение драйвера, вызвавшего ошибку:

    Вариант 1

    1) Загрузите и установите Debugging Tools for Windows.
    2) Загрузите командный файл kdfe.cmd (Kernel Debugger Front End) со скриптом для облегчения анализа дамп-файлов, создаваемых Windows при STOP ошибках (BSoD), оригинальный его код взят на ресурсе sysadmins.ru.
    3) Распакуйте архив в любую папку.
    Примечание: Если папка Debugging Tools for Windows находиться у вас не в папке Program Files, то в файле kdfe.cmd необходимо указать другой путь к папке, в которую установлены средства Debugging Tools for Windows.
    Путь к папке указан после параметра set dbgpath=
    4) Откройте командную строку и перейдите в папку, в которую вы распаковали kdfe.cmd.
    5) Запустите файл, указав в качестве параметра путь к файлу дампа памяти (в примере ниже файл называется Mini1110307-01.dmp)

    6) Дождитесь завершения анализа. По окончании вы увидите драйвер, послуживший причиной ошибки.

    Вариант 2

    1) Скачиваете утилиту BlueScreenView.
    2) Устанавливаете BlueScreenView.
    3) Распаковываете bluescreenview_russian.zip и кладете файл bluescreenview_lng.ini в туже папку куда установлена BlueScreenView.
    4) Запускаете BlueScreenView.

    Поиск дампов производится в папке %systemroot%\Minidump, также можно настроить и собственную папку (Options –> Advanced).
    Для найденных дампов памяти утилита отображает:
    • В верхней панели – название файла, дату создания, название стоп-ошибки, код ошибки, параметры, а также драйвер, предположительно вызвавший проблему (Caused By Driver).
    • В нижней панели – (в зависимости от настроек в Options –> Lower Pane Mode) все драйверы, загруженные во время ошибки, или только драйверы, найденные в стеке. Среди всех драйверов - на розовом фоне отображаются предположительно вызвавшие проблему драйверы. Также, утилита может отображать синий экран, очень похожий на тот, который все так любят.
    Примечание: При определении драйвера не нужно полагаться только на имя файла в столбце Caused by Driver. Следует рассмотреть драйверы в нижней панели (или только выделенные розовым цветом, если включено отображение всех драйверов), в первую очередь обращая внимание на несистемные драйверы.

    5. Расшифровка значений ошибок синего экрана смерти (BSOD) и способы их устранения.

    Если у Вас появляется какая-либо ошибка синего экрана смерти, и Вы задумываетесь из-за чего же она произошла, то Вы можете:

    1) Скачать подборку наиболее часто встречающихся ошибок и способов устранения многих из них: BSOD.rar
    2) Почитать на форуме Oszone.net темы входящие в состав темы: Устранение критических ошибок Windows

    6. В Windows x64 стало показывать меньше памяти, чем есть.

    Зайдите:
    Панель управления->Администрирование->Конфигурация системы>вкладка Загрузка->Дополнительные параметры
    Проверьте максимум памяти. Или уберите галочку или поставьте нужное вам значение.

    Также посмотрите значение функций в BIOS:

    1. HPET Mode должно быть 64-bit (если есть такая функция)
    или
    2. Memory Remap Feature должно быть Enabled
    3. Memory Hole должно быть Disabled

    7. Windows зависает после перезагрузки с ошибкой Verifying DMI Pool Data.

    Попробуйте следующие варианты решений:

    1) Попробуйте установить другую сборку или версию Windows 7.
    2) Сбросьте настройки BIOS в стандартные и установите Windows заново.
    3) Обнулите на материнской плате CMOS: либо переустановив и вернув перемычку, либо нажав на кнопку сброса на материнской плате.
    4) Установите в списке загрузок с жестких дисков в BIOS, приоритет загрузки Вашего диска с Windows 7 на первое место.
    5) Подключите диск выделенный для Windows 7, как Primary Master.

    8. Восстановление работы дополнительных клавиш на мультимедиа-клавиатуре.
    Если на Вашей мультимедиа или офисной клавиатуре перестали работать дополнительные клавиши расширяющие её функциональность, то сделайте следующее.
    Во-первых, проверьте установлено ли у Вас программное обеспечение с диска идущего в комплекте к клавиатуре или с официального сайта.
    Если же оно установлено, то одной из наиболее часто встречающихся причин может быть остановка службы Доступ к HID-устройствам.

    1) Зайдите в Панель управления\Система и безопасность\Администрирование и запустите Службы или
    Нажмите кнопку Пуск, щелкните в поле Начать поиск, введите services.msc и нажмите клавишу Enter.
    2) Проверьте указано ли в колонке Состояние, напротив службы Доступ к HID-устройствам значение: Работает
    Если данная служба отключена и не работает, сделайте следующее:
    3) Нажмите на ней правой кнопкой мыши и в появившемся меню выберите Свойства
    4) Для запуска службы нажмите на кнопку Запустить
    5) Также Вы можете установить Тип запуска: Автоматически, и система будет автоматически запускать данную службу при старте Windows.
    6) Перейдите на вкладку Восстановление и установите действия выполняющиеся при первом или втором сбое, а также при последующих сбоях на значение Перезапуск службы и нажмите OK.

    9. Исправление появившихся красных крестиков на значках локальных дисков.

    1) Откройте Панель Управления -> Диспетчер Устройств
    1.1) Проверьте включены ли все IDE ATA/ATAPI контроллеры
    1.2) Проверьте включены ли все Дисковые устройства
    2) Если есть общий доступ, попробуйте его отключить
    Щелкните ПКМ на диске -> Общий доступ -> Расширенная настройка общего доступа... -> Расширенная настройка...
    3) Почистите кэш иконок: для этого в папке %USERPROFILE%\AppData\Local\ удалите файл IconCache.db
    4) Воспользуйтесь специальными утилитами для оптимизации работы компьютера. Например:
    4.1.) TuneUp Utilities

    4.1.1) В колонке Customize Windows нажимаете All functions и выбираете Change Windows appearance
    4.1.2) В меню слева в списке группы Icons выбираете Repair
    4.1.3) Нажмите на кнопку Reload Icons, а после на кнопку Repair Icon Cache

    4.2) Windows 7 Manager

    4.2.1) В меню слева во вкладке Information выберите Repair Center
    4.2.2) В меню слева в Repair Center нажмите Icon Repair
    4.2.3) В разделе Rebuild Icon Cache нажмите Rebuild

    10. Восстановление автозапуска для всех типов приводов и устройств.
    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    5) Запустите reg-файл.

    Также параметр NoDriveTypeAutoRun автоматически добавляется в реестр при установке программы VMware Workstation, используемой для создания виртуальной машины.

    11. Исправление ошибок 0x0000007A, 0x00000077 или 0x000000F4 для SATA дисков после выхода из ждущего или спящего режимов.
    На подготовку к работе жесткого диска отводится 10 секунд. Если накопитель не успеет за это время сообщить о своей работоспособности, то операционная система воспримет это как ошибку. Такое может происходить с винчестерами с интерфейсом SATA. Для устранения данной ошибки Microsoft выпустила обновление KB977178. Если же в вашей системе на базе Windows 7 подобных ошибок не возникает, то устанавливать исправление не рекомендуется.
    Скачать исправление KB977178 : для x86 или для x64

    12. Cистема находит Bluetooth-адаптер, а Bluetooth-устройства его не обнаруживают.

    1) Нажмите Win+R (или Пуск -> Выполнить)
    2) Введите команду:

    или

    и нажмите Параметры Bluetooth

    3) Установите необходимые Вам настройки.

    Чтобы сделать компьютер обнаруживаемым устройствами с поддержкой Bluetooth, установите флажок Разрешить устройствам Bluetooth обнаруживать этот компьютер.
    Чтобы разрешить добавление устройств с поддержкой Bluetooth на компьютер, установите флажок Разрешить устройствам Bluetooth подключаться к этому компьютеру.
    Чтобы получать уведомления о попытках устройств с поддержкой Bluetooth подключиться к компьютеру, установите флажок Оповещать при подключении нового устройства Bluetooth.

    13. Восстановление значка "Безопасное извлечение устройства".

    1.1) Создайте и импортируйте в реестр reg-файл указанного ниже содержания. После чего перезагрузите компьютер.

    1.2) Перезайдите в систему или перезагрузите компьютер.

    2) Откройте Пуск -> Выполнить (Win+R) и запустите поочередно следующие команды

    3.1) Щелкните по рабочему столу и выберите во всплывшем меню Создать -> Ярлык.
    3.2) В поле Укажите расположение объекта введите команду

    3.3) Перенесите созданный Вами ярлык на панель задач, чтобы закрепить его там.

    Также Вы можете просто запустить окно "Безопасное извлечение устройства" введя команду в диалоговом окне Выполнить (Win+R) :

    14. Решение проблемы пропадания места на системном жестком диске.

    Прежде всего выполните проверку жесткого диска, если дело окажется в ошибках, то система поможет Вам их исправить:

    1) Нажимаете кнопку Пуск и в строке поиска вводите cmd
    2) Нажимаете правой кнопкой мыши на найденной команде и выбираете "Запустить от имени Администратора"
    3) Вводите команду SFC /scannow и нажимаете Enter

    Для увеличения свободного пространства Вы можете сделать следующее:

    1) Запустите Очистка диска. Нажимаете кнопку Пуск -> Все программы -> Стандартные -> Служебные.
    1.1) На вкладке Очистка диска Вы можете удалить временные файлы
    1.2) На вкладке Дополнительно Вы можете удалить все точки восстановления, кроме самой последней.

    2) Отключите функцию создания точек восстановления или уменьшите размер используемого дискового пространства.
    2.1) Нажмите кнопку Пуск
    2.2) Щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства (Панель управления\Система и безопасность\Система)
    2.3) Слева нажмите ссылку Защита системы
    2.4) В открывшемся окне нажмите кнопку Настроить
    2.5) Отключите защиту системы или измените используемый ею размер дискового пространства.

    4) Отключите режим гибернации.
    Запустите командную строку с правами администратора (Win+R -> cmd -> Ok) и выполните в ней команду: powercfg /h off

    5) Измените размер файла подкачки.
    5.1) Нажмите кнопку Пуск
    5.2) Щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства (Панель управления\Система и безопасность\Система)
    5.3) Слева нажмите ссылку Дополнительные параметры системы
    5.4) В разделе Быстродействие нажмите кнопку Параметры
    5.5) Перейдите на вкладку Дополнительно и нажмите кнопку Изменить

    6) Очистите папку кэша C:\Windows\rescache
    7) Очистите временные папки (карантин) используемой Вами системы защиты (Norton, Kaspersky, Eset 32 и др.), в некоторых стоит отключить трассировки.
    8) Скачайте программу Scanner by Steffen Gerlach для анализа содержимого жестких дисков. Эта программа поможет Вам увидеть, какая папка или файл занимает большую часть вашего диска.

    15. Windows не определяет второй жесткий диск после установки.

    Данное действие иногда происходит по причине неправильной установки скрытого раздела System Reserved (Зарезервировано системой).
    Например, если у Вас один жесткий диск, то Windows 7 при инсталляции выделяет скрытый раздел System Reserved (Зарезервировано системой) для защиты загрузочных файлов операционной системы.
    Если во время инсталляции были подключены два жестких диска, то иногда Windows может некорректно определить второй жесткий диск и использовать его как скрытый раздел System Reserved (Зарезервировано системой). В результате чего, у него будет отсутствовать буква диска.

    Для добавления буквы диска сделайте следующее:

    1) Запустите оснастку Управление дисками: Открываете меню Пуск, в поле поиска пишите diskmgmt.msc и нажимаете Enter
    2) Находите Ваш диск, у него будет отсутствовать буква диска.
    3) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить букву диска или путь к диску.
    4) В открывшемся окне нажимаете кнопку Добавить выбираете необходимую Вам букву и нажимаете ОК.

    Если диск не появился в Проводнике(Windows Explorer), то перезагрузите компьютер.

    16. Не переименовывается диск (не меняется метка тома) в Windows 7.

    Данная проблема может возникнуть, в результате появления в корне диска файла или папки с именем "Autorun.inf".
    Если Вы не создавали его самостоятельно для защиты от вирусов использующих автозапуск, то файл (папка) мог создаться какой-либо программой.
    Для исправления данной проблемы сделайте следующее:

    1) Откройте Пуск - Панель управления и запустите "Параметры папок"
    2) Перейдите на вкладку "Вид" и установите переключатель отвечающий за "Скрытые файлы и папки" в значение "Показывать скрытые папки, файлы и диски".
    3) Удалите в корне диска файл или папку с именем "Autorun.inf".
    4) Перезагрузите компьютер.
    5) Измените метку диска (Win+R - label.exe - OK)
    Если же Вы создали файл "Autorun.inf" сами, то просто добавьте в него следующее:

    Вместо Метка тома подставьте необходимое Вам значение.

    17. Отключение отображения внутренних жестких дисков в "Безопасное извлечение устройств и дисков".
    В Windows 7 система использует универсальный драйвер как для SATA (интерфейс подключения внутренних устройств), так и eSATA (интерфейс подключения внешних устройств).
    Поэтому, независимо от того к которому из них подключен жесткий диск система определяет поддерживает ли устройство функцию извлечения "на лету".
    Если Ваша система использует режим AHCI, то в списке Безопасное извлечение устройств и дисков на панели задач появятся Ваши жесткие диски. Это обусловлено функциональными особенностями AHCI режима, а именно функцией "горячей" замены (HotPlug), означающей возможность извлечения оборудования в компьютерной системе во время работы.
    Если Вы не используете мобильное шасси (Mobile Rack) для внутренних жестких дисков и не планируете их извлекать, то Вы можете отключить их отображение в списке Безопасное извлечение устройств и дисков.

    Вариант 1. Установите родные драйвера для чипсета к которому подключены жесткие диски. Например для чипсета Intel, драйвера для технология хранения Intel® Rapid.

    Вариант 2. Укажите системе, что устройство должно использовать внутренний порт. В диалоговом меню Выполнить (Win+R) или в командной строке запущенной от имени администратора () введите команду:

    Где (n)- номер контроллера, на котором висит диск, а (N) - номер канала. В большинстве случаев по умолчанию это 0 в обоих случаях.

    Повторите данное действие для каждого диска, заменив значения на необходимые. Номер контроллера в большинстве случаев по умолчанию равен 0 для каждого из Ваших дисков. Номер канала Вы можете посмотреть в диспетчере устройств, на вкладке Сведения, в свойствах Вашего жесткого диска. Значения каналов имеют порядковые номера, начинающиеся с цифры 0.
    Например, если у Вас 2 жестких диска, то Вам, скорее всего, нужно будет ввести следующие команды:

    Вариант 3. Использование стороннего программного обеспечения.

    1) Скачайте и установите программу USB Safely Remove. Данная программа заменит встроенную в Windows функцию Безопасное извлечение устройств и дисков на собственную утилиту.
    2) Для того, чтобы иконка пряталась, когда нет ни одного подключенного устройства, включите опцию "Hide icon when there are no devices to be stopped". Она располагается на закладке настроек "Look and Feel".

    18. Проверка драйверов для выявления неполадок в работе Windows.

    Если Вы предполагаете, что какой-либо из драйверов работает некорректно или, проанализировав дамп памяти, Вы определили драйвер вызвавший ошибку, то для более тщательной проверки работы драйверов Вы можете самостоятельно выполнить проверку драйверов с помощью встроенного в операционную систему средства проверки Verifier.exe.

    Проверка неподписанных драйверов.

    1) В строке поиска меню Пуск введите verifier и нажмите Enter.
    2) Выберите пункт Создать нестандартные параметры (для кода программ) и нажмите кнопку Далее.
    3) Установите переключатель в значение Выбрать отдельные параметры из полного списка и нажмите кнопку Далее.
    4) Отметьте все флажки кроме флажка Имитация нехватки ресурсов и нажмите кнопку Далее.
    5) Установите переключатель в значение Автоматически выбирать неподписанные драйверы и нажмите кнопку Далее.

    Если неподписанные драйверы обнаружены, система отобразит Вам их список, в котором будут указаны файлы драйверов и их описание. Причем найденные драйвера могут принадлежать как устройствам, так и приложениям. Не закрывайте пока окно средства проверки драйверов и не нажимайте никаких кнопок.

    Дальше возможно три варианта предпринимаемых Вами действий.

    Вариант 1. Обновление программы или драйвера.

    6) Посетите сайт производителя устройства или автора программы и скачайте более новую версию.
    7) Переустановите программу или обновите драйвер.
    8) После обновления приложения или драйвера закройте окно средства проверки драйверов, нажав кнопку Отмена.
    9) Перезагрузите компьютер и продолжайте работу в операционной системе.
    Если в системе не возникают ошибки связанной с данным драйвером, значит обновление драйвера или программы устранило её.

    Вариант 2. Удаление программы или драйвера.

    6.1) Удалите программу, которой принадлежит данный драйвер.
    6.1.1) Откройте Панель управления\Все элементы панели управления\Программы и компоненты и удалите приложение, которому принадлежит драйвер.
    Перед удалением программы убедитесь, что у Вас присутствует ее установочный диск или ее установка сохранена у Вас на диске.

    6.2) Удалите драйвер в Диспетчере устройств.
    6.2.1) В меню Пуск щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства.
    6.2.2) Нажмите в списке слева на Диспетчер устройств.
    6.2.3) В Диспетчере устройств найдите устройство, щелкните по нему правой кнопкой мыши и выберите из контекстного меню пункт Свойства.
    6.2.4) Перейдите на вкладку Драйвер и нажмите кнопку Удалить.

    7) После удаления приложения или драйвера закройте окно средства проверки драйверов, нажав кнопку Отмена.
    8) Перезагрузите компьютер и продолжайте работу в операционной системе.

    Если в системе не возникают ошибки связанной с данным драйвером, значит удаление драйвера или программы устранило её.

    Вариант 3. Проверка неподписанных драйверов.

    Внимание! После проверки неподписанных драйверов система может не загрузиться (прежде чем переходить к дальнейшим действиям, прочтите данный вариант до конца).

    6) Нажмите кнопку Готово и перезагрузите компьютер.

    Если же после перезагрузки появился синий экран с ошибкой, проблемный драйвер определен - его название будет включено в сообщение об ошибке. В таком случае:

    7) Перезагрузите компьютер
    8) До начала запуска Windows нажмите на клавишу F8. При появлении окна выбора дисков: выберите диск на котором у Вас установлена Windows, нажмите Enter, а затем сразу F8.
    9) Выберите пункт Безопасный режим
    10) Откройте диалоговое меню Выполнить: Пуск -> Выполнить или нажмите комбинацию Win+R
    11) Введите команду verifier.exe /reset и нажмите Enter.

    Если система загрузилась в обычном режиме, проверка неподписанных драйверов завершилась успешно - они не являются источником проблем.

    Проверка подписанных драйверов.

    1) В строке поиска меню Пуск введите verifier и нажмите Enter.
    2) Выберите пункт Создать нестандартные параметры (для кода программ) и нажмите кнопку Далее.
    3) Установите переключатель в значение Выбрать отдельные параметры из полного списка и нажмите кнопку Далее.
    4) Отметьте все флажки кроме флажка Имитация нехватки ресурсов и нажмите кнопку Далее.
    5) Установите переключатель в значение Выбрать имя драйвера из списка и нажмите кнопку Далее.
    6) Нажмите на заголовок колонки Поставщик для сортировки драйверов по их поставщику.
    7) Выберите первые 10-15 драйверов установив напротив них флажки в колонке Проверить.
    Не выбирайте все драйверы сразу, так как их проверка займет много времени и ресурсов системы.
    8) Нажмите кнопку Готово и перезагрузите компьютер. Если система загрузилась в обычном режиме, проверка выбранных драйверов завершилась успешно - они не являются источником проблем. В таком случае повторите описанные выше действия выбрав следующие 10-15 драйверов.

    Если же после перезагрузки появился синий экран с ошибкой, проблемный драйвер определен - его название будет включено в сообщение об ошибке. В таком случае:

    1) Перезагрузите компьютер
    2) До начала запуска Windows нажмите на клавишу F8. При появлении окна выбора дисков: выберите диск на котором у Вас установлена Windows, нажмите Enter, а затем сразу F8.
    3) Выберите пункт Безопасный режим
    4) Откройте диалоговое меню Выполнить: Пуск -> Выполнить или нажмите комбинацию Win+R
    5) Введите команду verifier.exe /reset и нажмите Enter. Если проверка всех драйверов завершилась успешно, то скорее всего, драйверы не являются причиной критической ошибки, возникающей в Вашей системе.

    19. При установке Windows, в окне выбора раздела на диске создается раздел с нулевым размером.

    В случае появления, при установке Windows, в окне выбора раздела на диске - пункта: Незанятое место на диске 0. Полный размер 0.0МБ, свободно 0.0МБ, выполните указанные ниже действия:

    Если у Вас несколько дисков, то для выполнения указанной ниже инструкции оставьте подключенным только тот диск, для которого создается нулевой раздел. Остальные диски отключите.

    1) Установите в BIOS режим для дисков на IDE.

    Если Вы не можете войти в BIOS для изменения настроек (из-за того что компьютер висит), тогда: 1.1) Выключите компьютер, отсоедините SATA-кабель от диска
    1.2) Включите компьютер и измените режим.
    1.3) Выключите компьютер, подсоедините SATA-кабель к диску
    1.4) Включите компьютер

    2) Загрузитесь с Вашего Windows 7 DVD, выберите Установить.
    3) Когда Вы окажетесь в окне выбора раздела для установки Windows, удалите все возможные разделы на диске. (Не обращая внимания, на то, что остались не удаленными нулевые разделы.)
    4) Выйдите из программы установки Windows. Не продолжайте.
    5) Перезапустите компьютер. При желании измените в BIOS режим для дисков с IDE на AHCI.
    6) Опять загрузитесь с Вашего Windows 7 DVD, и снова выберите Установить.
    7) Когда Вы окажетесь в окне выбора раздела для установки Windows, разделов с 0 размером быть не должно.
    8) Укажите все доступное пространство для создание одного раздела.
    9) Продолжите установку как обычно.

    Устранение неполадок - Локальная сеть и Интернет

    1. Невозможно переместить Временные файлы Интернета на другой логический диск (D:\Cash).

    Установите, как минимум, пониженный уровень UAC.

    2. Если гаджет погоды пишет service unavailable for your region.

    Для нормальной работы гаджетов не отключайте UAC полностью, а ставьте на минимум.
    Если отключить UAC совсем (крайне нижнее положение - Never Notify), то гаджеты могут пропасть.
    А панель настройки гаджетов может стать недоступной.

    Вариант 1

    Завершите процесс sidebar.exe и перезапустите его (правой кнопкой мыши на рабочем столе --> Gadgets)

    Также добавьте в папке %WINDIR%\system32\driverc\etc в файл hosts следующие строки:

    Вариант 2

    Если перезапуск не помогает, то вы можете поставить другой гаджет погоды, например: AccuWeather.com® Forecast Gadget или HTC Home

    3. В Windows Update при попытке обновления появляется error 80072ee7.

    Если во время проверки наличия обновлений Центр обновления Windows выдает сообщение об ошибке 80072ee7, возможно, следует изменить или удалить статические IP-адреса для службы Центра обновления Windows . Адреса хранятся в файле операционной системы Hosts.

    IP-адрес для службы Центра обновления Windows может изменяться во время каждой проверки наличия обновлений, однако некоторые программы-надстройки Windows добавляют в файл Hosts статические адреса. Статический IP-адрес для службы Центра обновления Windows не позволит компьютеру получать обновления.

    Удаление статического IP-адреса для веб-сайта службы Центра обновления Windows

    1. Откройте компонент Компьютер. Для этого нажмите кнопку Пуск и выберите пункт Компьютер.
    2. Дважды щелкните значок локального жесткого диска, на котором установлена система Windows (обычно диск С).
    3. Дважды щелкните папку Windows, а затем - папку System32.
    4. Дважды щелкните папку драйверы, а затем - папку и т. д..
    5. В папке etc щелкните правой кнопкой мыши файл hosts и нажмите Открыть. После того как вам будет предложено выбрать программу, с помощью которой следует открывать данный файл, выберите Блокнот.
    6. Проверьте, стоит ли в файле hosts знак # около всех записей IP-адресов и имен узлов Центра обновления Windows. Если это не так, вставьте значок # или удалите запись целиком.
    7. Откройте меню Файл, выберите команду Сохранить и повторно выполните проверку наличия обновлений.

    4. Решение проблемы с punkbuster на Windows 7.

    Вариант 1.

    Решение проблемы вылетов игр (Например: COD 5 и Battlefield 2) с ошибкой: punkbuster kiked player *** for 0 minets. RESTRICTION: unknow windows APL function 131132 (131131, 131134, 131136).
    1) Обновите PunkBuster:
    1.1) Скачайте программу обновления PunkBuster
    1.2) Установите программу и запустите ее.
    1.3) Добавьте туда игру, для которой нужно обновить punkbuster и нажмите check for updates. По завершению появится сообщение об окончании обновления.
    2) Откройте папки C:\Windows\System32 (для х86) и/или C:\Windows\SysWOW64 (для х64)
    3) Установите в свойствах файлов PnkBstrA.exe и PnkBstrB.exe совместимость с Windows XP или Windows Vista и уровень прав администратора. (PnkBstrB.exe еще есть в папке с игрой. Например: C:\Users\*username*\AppData\Local\PunkBuster\BF2\pb).

    Вариант 2.

    1) Откройте папки C:\Windows\System32 (для х86) и/или C:\Windows\SysWOW64 (для х64)
    2) Установите в свойствах файлов PnkBstrA.exe и PnkBstrB.exe совместимость с Windows XP или Windows Vista и уровень прав администратора.
    3) На рабочем столе создайте bat-файл со следующим содержанием:

    4) Запускайте данный bat-файл перед запуском игр.

    5. Исправление длительного времени задержки (лагов) в компьютерных сетях.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\
    3) Найдите в ней раздел соответствующий интерфейсу, по которому у Вас работает интернет. Если Вы его не нашли, то дальнейшие действия произведите во всех разделах.
    4) Создайте DWORD-параметр и назовите его TcpAckFrequency
    5) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить
    6) Установите значение переключателя на Шестнадцатеричное, введите значение параметра 1 и нажмите ОК.
    7) Откройте Пуск -> Панель управления -> Программы и Компоненты
    8) В меню слева нажмите ссылку Включение и отключение компонентов Windows.
    9) Найдите пункт Сервер очереди сообщений Майкрософт (MSMQ) (Microsoft Message Queue (MSMQ) Server) и установите на нем флажок. Также установите флажки на всех компонентах внутри.

    10) Перезагрузите компьютер.
    11) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    12) Откройте ветку: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters
    13) Создайте DWORD-параметр и назовите его TCPNoDelay
    14) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить
    15) Установите значение переключателя на Шестнадцатеричное, введите значение параметра 1 и нажмите ОК.

    6. При вызове справки пишет "Internet Explorer не удается загрузить / из help".

    При вызове справки "Справка и поддержка" появляется сообщение об ошибке:

    Это может происходить по причине неправильного сопоставления программам типа файлов .xml
    Для исправления ошибки скопируйте код в новый текстовый файл, сохраните его, присвоив расширение .reg, запустите и согласитесь с внесением изменений в реестр.

    7. Если при VPN соединении через bat-файл у вас появляется ошибка 623.

    Переименуйте имя соединения на английский язык и всё должно заработать.

    8. Не работают обновления, в центре обновления Windows надпись: Некоторые параметры задаёт системный администратор.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate]
    3) Удалите параметр DisableWindowsUpdateAccess
    4) Закройте Редактор реестра и перезагрузите компьютер.

    9. Сетевой адаптер отключает сеть через каждые 5 минут.

    1) Запустите Диспетчер устройств (Win+R -> devmgmt.msc -> ОК)
    1.1) Откройте меню Пуск
    1.2) Нажмите правой кнопкой на Компьютер и выберите пункт Свойства (Панель управления\Все элементы панели управления\Система)
    1.3) Нажмите на ссылку Диспетчер устройств
    2) Откройте Сетевые адаптеры
    3) Щелкните правой кнопкой мыши на Вашем сетевом адаптере и выберите пункт Свойства
    4) Перейдите на вкладку Управление электропитанием
    5) Уберите флажок Разрешить отключение этого устройства для экономии энергии.

    10. Восстановление иконок html-файлов, при использовании Mozilla Firefox.
    Для восстановления иконок html-файлов - создайте и примените reg-файл следующего содержания.

    11. Устранение "Ошибки 711".

    Вариант 1.

    Эта ошибка может возникнуть, если не запущены все или некоторые из перечисленных ниже служб.

    Диспетчер автоматических подключений удаленного доступа
    Диспетчер подключений удаленного доступа
    Телефония

    Для устранения этой ошибки выполните следующие действия для каждой из указанных выше служб.

    1) Нажмите кнопку Пуск
    2) Откройте Панель управления -> Администрирование -> Службы (или Win+R -> services.msc)
    3) Щелкните правой кнопкой мыши на одну из указанных выше служб и затем щелкните Свойства.
    4) На вкладке Общие в пункте Тип запуска выберите вариант Вручную.
    5) Нажмите Применить, а затем нажмите Запустить.

    Вариант 2.

    Загрузитесь из Erd Commander (или любого LiveCD) и переименуйте папку ..\Windows\System32\Logfiles в Logfiles.old

    Вариант 3.

    Щелкните правой кнопкой мыши на папке Windows и выберите Свойства, перейдите на вкладку Безопасность, проверьте, чтобы в окне группы и пользователи обязательно были: "СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ", "система" и "TrustedInstaller" с разрешением полного доступа, дополнительно могут быть "Administrators", "Users"

    Вариант 4.

    1) Откройте меню Пуск и в строке поиска введите cmd
    2) Щелкните правой кнопкой мыши на найденном файле и выберите строку "Запуск от имени администратора"
    3) Введите указанную ниже команду и нажмите Enter:

    12. Исправление ошибки Internet Explorer: "Internet Explorer has stopped working".

    Вариант 1.

    1) Нажмите кнопку Пуск
    2) Откройте Панель управления и запустите Свойства обозревателя
    3) Перейдите на вкладку Дополнительно
    4) Нажмите кнопку Сброс...
    5) Прочитайте информационное сообщение и нажмите кнопку Сброс

    Вариант 2.

    1) Нажмите кнопку Пуск
    2) Откройте Панель управления и запустите Свойства обозревателя
    3) Перейдите на вкладку Безопасность
    4) Уберите флажок Включить защищенный режим.
    5) Перезапустите Internet Explorer (если он был запущен).

    Вариант 3.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKLM\SOFTWARE\Microsoft\SQMClient\Windows\DisabledSessions
    3) Удалите все параметры, кроме параметра (По умолчанию)

    Вариант 4.

    1) Откройте меню Пуск.
    2) В строке поиска введите gpedit.msc и нажмите Enter
    3) Перейдите к Конфигурация компьютера\Административные шаблоны\Система\Управление связью через Интернет\Параметры связи через интернет
    4) Щелкните дважды левой кнопкой мыши на Отключить программу по улучшению качества программного обеспечения Windows.
    5) Установите переключатель в значение Включить и нажмите ОK.

    13. Удаление временных файлов обновлений(+очистка журнала обновлений) для устранения ошибок, возникающих в Центре обновления Windows.

    Если во время установки или проверки наличия обновлений Центр обновления Windows выдает Вам сообщения об ошибках, то возможно Вам необходимо удалить временные файлы, которые используются Windows для определения обновлений для компьютера.
    Внимание: Удаление временных файлов обновлений, также приведет к удалению журнала Центра обновления Windows.

    1) Остановите службу Центр обновления Windows
    1.1) Откройте Пуск -> Панель управления -> Администрирование -> Службы. Щелкните на службе Центр обновления Windows правой кнопкой мыши и выберите пункт Остановить.
    или
    1.2) Введите в командной строке (Win+R -> cmd -> ОК) команду net stop wuauserv и нажмите Enter.

    2) Удалите временные файлы обновлений, для этого полностью удалите содержимое папок:

    %systemroot%\SoftwareDistribution\DataStore
    %systemroot%\SoftwareDistribution\Download

    3) Запустите службу Центр обновления Windows
    3.1) Откройте Пуск -> Панель управления -> Администрирование -> Службы. Щелкните на службе Центр обновления Windows правой кнопкой мыши и выберите пункт Запустить.
    или
    3.2) Введите в командной строке (Win+R -> cmd -> ОК) команду net start wuauserv и нажмите Enter.

    14. Не получается включить сетевое обнаружение в дополнительных параметрах общего доступа.

    1) Откройте Панель управления\Сеть и Интернет\Центр управления сетями и общим доступом
    2) Измените расположение для сети на Домашняя сеть щелкнув на ссылку Общественная сеть под Вашим подключением.
    3) Откройте Панель управления -> Администрирование -> Службы и проверьте включены ли у Вас службы

    4) Некоторые антивирусные программы также могут блокировать данные действия. Попробуйте отключить антивирусное обеспечение, затем измените настройку и проверьте сохранятся ли настройки.

    15. Восстановление в Mozilla Firefox 4 окна "Выход из Firefox" с кнопками "Сохранить и Выйти", "Выйти" и "Отмена".

    1) В главном меню откройте Инструменты -> Настройки
    2) На вкладке Основные в разделе Запуск установите значение "При запуске Firefox: Показывать домашнюю страницу" и нажмите ОК.
    3) В адрессной строке введите about:config и нажмите Enter.
    4) В строке Фильтр введите browser.showQuitWarning
    5) Дважды щелкните на найденном параметре, чтобы его значение переключилось на true.

    16. Ftp-сервер при вводе адреса в проводнике открывается в Internet Explorer.

    1) В Internet Explorer откройте Свойства обозревателя.
    Если у Вас включена Строка меню, то данный пункт расположен в меню Сервис, если Строка меню отключена, то нажмите на значок шестеренки.
    2) Перейдите на вкладку Дополнительно
    3) Установите флажок: Разрешить просмотр FTP-папок (за пределами Internet Explorer)

    Разное

    1. Сравнение версий Windows 7.

    Функция / Редакция | Начальная | Домашняя базовая | Домашняя расширенная | Профессиональная | Корпоративная | Максимальная
 | Продажа только по OEM-лицензиям | Продажа в розницу и по OEM-лицензиям (только на развивающихся рынках, включая российский) | Продажа в розницу и по OEM-лицензиям | Продажа в розницу, по OEM и корпоративным лицензиям | Продажа только под корпоративными лицензиями | Продажа в розницу и по OEM-лицензиям
Окончание поддержки | 13.01.2015 | 13.01.2015 | 13.01.2015 | 13.01.2020 | 13.01.2020 | 13.01.2015
Наличие 64-битной версии | Нет | Да | Да | Да | Да | Да
Максимальный размер оперативной памяти (для 64-битных версий) | 2 Гб (для 32-битной версии) | 8 Гб | 16 Гб | 128 Гб | 128 Гб | 128 Гб
Центр восстановления Windows | Нет поддержки домена | Нет поддержки домена | Нет поддержки домена | Да | Да | Да
Функция «Домашняя группа» (создание и присоединение к группе) | Только присоединение | Только присоединение | Да | Да | Да | Да
Интерфейс Windows Aero | Нет | Только базовая тема оформления | Да | Да | Да | Да
Поддержка нескольких мониторов | Нет | Да | Да | Да | Да | Да
Быстрое переключение между пользователями | Нет | Да | Да | Да | Да | Да
Возможность смены фонового рисунка рабочего стола | Нет | Да | Да | Да | Да | Да
Диспетчер рабочего стола | Нет | Да | Да | Да | Да | Да
Центр мобильности Windows | Нет | Да | Да | Да | Да | Да
Multitouch и улучшенное распознавание рукописного ввода | Нет | Нет | Да | Да | Да | Да
Windows Media Center | Нет | Нет | Да | Да | Да | Да
Дополнительные игры | Нет | Нет | Да | Отключены по умолчанию | Отключены по умолчанию | Да
Эмулятор Windows XP(Windows XP Mode) | Нет | Нет | Нет | Да | Да | Да
EFS (система шифрования данных) | Нет | Нет | Нет | Да | Да | Да
Печать с учетом информации о местоположении | Нет | Нет | Нет | Да | Да | Да
Возможность выступать в качестве хост-компьютера Удаленного рабочего стола | Нет | Нет | Нет | Да | Да | Да
Подключение к домену | Нет | Нет | Нет | Да | Да | Да
Возможность даунгрейда до Vista или XP | Нет | Нет | Нет | Да | Да | Да
Поддержка нескольких процессоров | Нет | Нет | Нет | Да | Да | Да
AppLocker | Нет | Нет | Нет | Нет | Да | Да
BitLocker и BitLocker To Go | Нет | Нет | Нет | Нет | Да | Да
Branch Cache | Нет | Нет | Нет | Нет | Да | Да
DirectAccess | Нет | Нет | Нет | Нет | Да | Да
Подсистема для запуска Unix-приложений | Нет | Нет | Нет | Нет | Да | Да
Мультиязычная пользовательская среда | Нет | Нет | Нет | Нет | Да | Да
Загрузка с VHD (файла-образа Microsoft Virtual PC) | Нет | Нет | Нет | Нет | Да | Да
Запуск оснастки lusrmgr.msc (Local Users and Groups) | Нет | Нет | Нет | Да | Да | Да
Запуск оснастки gpedit.msc (Local Group Policy Editor) | Нет | Нет | Нет | Да | Да | Да
Запуск оснастки secpol.msc (Local Security Policy) | Нет | Нет | Нет | Да | Да | Да

    Windows Aero — анимация окон при открытии, закрытии, сворачивании, восстановления окна, делающая работу с операционной системой более понятной. Прозрачные элементы окон с размывкой заднего плана позволяют пользователю сконцентрироваться только на содержимом активного окна. Компоненты Windows Aero:

    Aero Glass — прозрачные (с размывкой заднего плана) заголовки и панели в окнах.
    Windows Flip — новый вид меню Alt + Tab, в котором показываются эскизы открытых окон и их значки.
    Windows Flip 3D — замена Alt + Tab, вызываемая сочетанием Win + Tab, теперь все окна выстраиваются в ряд в 3D. При помощи стрелок клавиатуры или колесика мышки можно прокручивать окна.
    Aero Shake — позволяет свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти».
    Aero Peek — позволяет отображать уменьшенные копии окон при наведении мыши на значок панели задач, переключаться между окнами приложения простым кликом по значку, перетаскивать и фиксировать на панели задач различные окна и приложения, просматривать рабочий стол одним наведением в специальную область экрана и многое другое.
    Aero Snap — позволяет движением мыши разворачивать окно на полэкрана, весь экран или только по вертикальной оси.

    Диспетчер рабочего стола (англ. Desktop Window Manager, DWM), ранее Desktop Compositing Engine, DCE — система графического интерфейса рабочего стола в Windows Vista и Windows 7, который используется в графическом интерфейсе Windows Aero.

    Центр мобильности Windows — объединяет настройки мобильного ПК в одном месте для обеспечения быстрого доступа к ним. Из одного и того же местоположения можно выполнять различные операции, например регулировать громкость мобильного ПК, проверять состояние беспроводного сетевого подключения или настраивать яркость дисплея.

    Мультитач (англ. multitouch или multi-touch) — технология, по которой сенсорный экран или тачпад отслеживает одновременно несколько точек нажатия. Например, сближая пальцы рук, можно уменьшить картинку на дисплее, а раздвигая — увеличить. Кроме того, мультитач-экраны позволяют работать с устройством одновременно нескольким пользователям.

    Windows Media Center (кодовое имя Freestyle) является приложением для проигрывания мультимедиаконтента (музыки, изображений и потокового телевидения) на домашнем медиацентре.

    Encrypting File System (EFS) — система шифрования данных, реализующая шифрование на уровне файлов. Данная система предоставляет возможность «прозрачного шифрования» данных, хранящихся на разделах с файловой системой NTFS для защиты потенциально конфиденциальных данных от несанкционированного доступа при физическом доступе к компьютеру и дискам.

    Домен Windows — группа компьютеров одной сети, имеющих единый центр (который называется контроллером домена), использующий единую базу пользователей (то есть учётные записи находятся не на каждом в отдельности компьютере, а на контроллере домена, т.н. сетевой вход в систему), единую групповую и локальную политики, единые параметры безопасности (применимо к томам с файловой системой NTFS), ограничение времени работы учётной записи и прочие параметры, значительно упрощающие работу системного администратора организации, если в ней эксплуатируется большое число компьютеров.

    AppLocker — расширенная версия политик ограниченного использования программ. Позволяет разрешать или запрещать запуск программ при определенных условиях. Например, "Разрешить запуск Adobe Acrobat версии выше 7.0".

    BitLocker и BitLocker To Go — позволяет защитить все данные, от документов до паролей, путем шифрования всего диска, на котором хранятся системные файлы Windows и данные пользователей. BitLocker используется для встроенных дисков, BitLocker To Go - для съемных запоминающих устройств, таких как внешние жесткие диски и USB-устройства флэш-памяти.

    BranchCache — это технология кэширования на ресурсах локальной сети данных, расположенных на удаленных серверах. Если пользователю в локальной сети потребуется файл, который уже был загружен кем-то из пользователей его сети, — он сможет получить его из локального кэш-хранилища, а не использовать канал с ограниченной пропускной способностью.

    DirectAccess — обеспечивает доступ пользователей к корпоративной сети при наличии выхода в Интернет. В отличие от большинства традиционных VPN соединений, которые должны быть запущены и прерваны явно действиями пользователя, подключения DirectAccess создаются автоматически компьютером, на котором работает пользователь.

    Подсистема для UNIX-приложений — представляет собой многопользовательскую среду UNIX, которая предоставляет инструментарий и библиотеки API переноса приложений для работы на компьютерах под управлением операционной системы Windows.

    Загрузка с VHD-файла — использование для загрузки операционной системы Windows - VHD-файла, содержащего в себе виртуальную операционную систему имеющую полную структуру и содержание сходные с жестким диском.

    Мультиязычная пользовательская среда (MUI) — Выбор нужного языка интерфейса и возможность переключения между 35 доступными языками.

    2. Открытие файлов справки с расширением .hlp.

    Начиная с Windows Vista, компания Майкрософт отменила поддержку открытия данного типа файлов, с использованием системной программы WinHlp32.exe. Для открытия данного типа файлов установите обновление Windows6.1-KB917607-x86.msu или Windows6.1-KB917607-x64.msu, в зависимости от разрядности.
    Официальная ссылка: здесь

    3. Список программ Windows, запускаемых в диалоговом окне Выполнить.

    Диалоговое окно Выполнить используется в Windows для открытия программы, папки или документа. Оно позволяет создать задание для запуска с правами администратора. Самые известные команды выполняемые в окне Выполнить это cmd (Командная строка) и regedit (Редактор реестра). Зная точное названия команды Вы можете запустить любое системное приложения или оснастку Windows.
    Диалоговое меню Выполнить запускается либо Пуск -> Выполнить, либо нажатием клавиатуре Win+R.
    Для выполнения команды введите её название и нажмите Enter.

    Русское название элемента | Английское название элемента | Команда
Ftp-протокол (командная строка) | Ftp-protocol (command prompt) | ftp
Iexpress Wizard (не переведена) | Iexpress Wizard | iexpress
Internet Explorer | Internet Explorer | iexplore
Paint | Paint | mspaint
Wordpad | Wordpad | write
Администратор источников данных ODBC | ODBC Data Source Administrator | odbcad32
Администрирование | Administrative Tools | control admintools
Архивация и восстановление | Backup and Restore | sdclt
Блокнот | Notepad | notepad
Брандмауэр Windows | Windows Firewall | firewall.cpl
Включение и отключение компонентов Windows | Turn Windows features on or off | OptionalFeatures.exe
Восстановление системы | System Restore | rstrui
Выйти из системы | Log Out Of Windows | logoff
Дата и Время | Date and Time | timedate.cpl
Дефрагментация диска | Disk Defragmenter | dfrgui
Диспетчер авторизации | Authorization Manager | azman.msc
Диспетчер задач Windows | Windows Task Manager | taskmgr
Диспетчер проверки драйверов | Driver Verifier Manager | verifier
Диспетчер устройств | Device Manager | devmgmt.msc
Диспетчер устройств | Device Manager | hdwwiz.cpl
Дополнительные часы | Additional Clocks | control timedate.cpl,,1
Завершение работы Windows | Shuts Down Windows | shutdown /s
Записки | Sticky Note | StikyNot
Защита БД учетных записей Windows | Securing the Windows Account Database | syskey
Звук | Sound | mmsys.cpl
Звуки (звуковая схема) | Sounds (sound theme) | control mmsys.cpl,,2
Звукозапись | Sound Recorder | soundrecorder
Игровые устройства | Game Controllers | joy.cpl
Инициализация оборудования безопасности для TPM | Initialize the TMP security hardware | TpmInit
Калибровка цветов экрана | Display Color Calibration | dccw
Калькулятор | Calculator | calc
Командная строка | Command Prompt | cmd
Компоненты Windows | Windows Features | OptionalFeatures
Консоль управления(MMC) | Microsoft Management Console | mmc
Конфигурация системы | System Configuration | msconfig
Локальная политика безопас{}ности | Local Security Policy | secpol.msc
Локальные пользователи и группы | Local Users and Groups | lusrmgr.msc
Мастер загрузки изображений Windows | Windows Picture Acquisition Wizard | wiaacmgr
Мастер создания общих ресурсов | Create A Shared Folder Wizard | shrpubw
Мастер установки драйверов устройств | Driver Package Installer | dpinst
Мастер установки оборудования | Add Hardware Wizard | hdwwiz
Микшер громкости | Sound Volume | sndvol
Монитор ресурсов | Resource Monitor | resmon
Настройка доступа программ и умолчаний | Set Program Access and Computer Defaults | control appwiz.cpl,,3
Настройка Контроля Учетных Записей | User Account Control Settings | UserAccountControlSettings
Ножницы | Snipping Tool | snippingtool
Общие папки | Shared Folders | fsmgmt.msc
Очистка диска | Disk Cleanup Utility | cleanmgr
Панель управления | Control Panel | control
Папка "Fonts" | Fonts Folder | fonts
Папка "Загрузки" | "Downloads" Folder | Downloads
Параметры папок | Folder Options | control folders
Перезагрузка | Restart Windows | shutdown /r
Перенос принтеров | Printer Migration | PrintBrmUi
Перо и сенсорные устройства | Pen and Touch | TabletPC.cpl
Персонализация | Personalization | control desktop
Планировщик заданий | Task Sheduler | control schedtasks
Подключение к удаленному рабочему столу | Remote Desktop Connection | mstsc
Получение программ | Get Programs | control appwiz.cpl,,1
Проверка диска | Check Disk Utility | chkdsk
Проверка и восстановление системных файлов | System File Checker (Scan and Repair) | sfc /scannow
Проверка подписи файла | File Signature Verification | sigverif
Проводник | Windows Explorer | explorer
Проводник: C:\ | Windows Explorer: C:\ | \
Проводник: С:\Users\Ваше_имя | Windows Explorer: С:\Users\Your_name | .
Проводник: С:\Users\ | Windows Explorer: С:\Users\ | ..
Программа DiskPart | Disk Partition Manager | diskpart
Программы и компоненты | Programms and Features | appwiz.cpl
Просмотр событий | Event Viewer | eventvwr.msc
Разрешение экрана | Screen Resolution | desk.cpl
Редактор личных знаков | Private Character Editor | eudcedit
Редактор локальной групповой политики | Local Group Policy Editor | gpedit.msc
Редактор реестра | Registry Editor | regedit
Редактор реестра | Registry Editor | regedt32
Редактор титульных страниц факсов | Fax Cover Sheet Editor | fxscover
Результирующая политика | Resultant Set of Policy | rsop.msc
Сведения о системе | System Information | msinfo32
Свойства системы | System Properties | sysdm.cpl
Свойства системы: Дополнительно | System Properties: Advanced | SystemPropertiesAdvanced
Свойства системы: Защита системы | System Properties: System Protection | SystemPropertiesProtection
Свойства системы: Оборудование | System Properties: Hardware | SystemPropertiesHardware
Свойства системы: Удаленный доступ | System Properties: Remote | SystemPropertiesRemote
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | iscsicpl
Свойства: Интернет | Internet Properties | inetcpl.cpl
Свойства: Клавиатура | Keyboard Properties | control keyboard
Свойства: Мышь | Mouse Properties | control mouse
Свойства: Мышь | Mouse Properties | main.cpl
Свойства: Мышь: Параметры указателя | Mouse Properties: Pointer Options | control main.cpl,,2
Свойства: Мышь: Указатели (схема) | Mouse Properties: Pointers | control main.cpl,,1
Сертификаты | Sertificates | certmgr.msc
Сетевые подключения | Network Connections | control netconnections
Сетевые подключения | Network Connections | ncpa.cpl
Системный монитор | Performance Monitor | perfmon
Служба индексирования | Indexing Service | ciadv.msc
Службы | Services | services.msc
Службы компонентов | Component Services | dcomcnfg
Службы компонентов | Component Services | comexp.msc
Совместимость программы | Program Compatibility | msdt.exe -id PCWDiagnostic
Создать диск восстановления системы | Create a system repair disk | recdisc
Соседние пользователи | People Near Me | collab.cpl
Сохранение имен пользователей и паролей | Stored User Names and Passwords | credwiz
Средство диагностики DirectX | Direct X Troubleshooter | dxdiag
Средство диагностики службы технической поддержки | Microsoft Support Diagnostic Tool | msdt
Средство калибровки дигитайзера | Ditilizer Calibration Tool | tabcal
Средство настройки текста ClearType | ClearType Text Tuner | cttune
Средство просмотра XPS | XPS Viewer | xpsrchvw
Стредство записи действий по воспроизведению неполадок | Problem Steps Recorder | psr
Таблица символов | Character Map | charmap
Телефон и модем | Phone and Modem | telephon.cpl
Удаленный помощник Windows | Windows Remote Assistance | msra
Управление дисками | Disk Management | diskmgmt.msc
Управление компьютером | Computer Management | compmgmt.msc
Управление печатью | Print Management | printmanagement.msc
Управление цветом | Color Management | colorcpl
Установка или удаление языков интерфейса | Install or uninstall display languages | lpksetup
Устройства и принтеры | Devices and Printers | control printers
Учетные записи пользователей | User Accounts | Netplwiz
Цвет и внешний вид окна | Window Color and Appearance | control color
Центр мобильности Windows | Windows Mobility Center | mblctr
Центр поддержки | Action Center | wscui.cpl
Центр синхронизации | Sync Center | mobsync
Центр специальных возможностей | Ease of Access Center | utilman
Шифрующая файловая система (EFS) | Encryption File System | rekeywiz
Шрифты (добавление или удаление) | Fonts | control fonts
Экран (размер текста) | Display (size of text) | dpiscaling
Экранная клавиатура | On-Screen Keyboard | osk
Экранная лупа | Magnifier | magnify
Экранный диктор | Microsoft Narrator | narrator
Электропитание | Power Options | powercfg.cpl
Электропитание: Дополнительные параметры | Power Options: Advanced Settings | control powercfg.cpl,,1
Элемент управления WMI | Windows Management Infrastructure | wmimgmt.msc
Язык и региональные стандарты | Region and Language | intl.cpl
Язык и региональные стандарты: Дополнительно | Region and Language: Administrative | control intl.cpl,,3
Язык и региональные стандарты: Языки и клавиатуры | Region and Language: Keyboards and Languages | control intl.cpl,,2

    Если какой-либо из элементов списка не запускается, то скорее всего это означает что он неустановлен. Многие из компонентов Windows можно установить в Пуск -> Панель Управления -> Программы и Компоненты -> Включение и отключение компонентов Windows

    4. Список клавиатурных сокращений.

    Основные:

    Alt+Tab - Переключение между окнами
    Win+Tab - Переключение между окнами в режиме Flip3D
    Win+Up - Развернуть окно
    Win+Down - Восстановить / Минимизировать окно
    Win+Left - Прикрепить окно к левому краю экрана
    Win+Right - Прикрепить окно к правому краю экрана
    Win+Shift+Left - Переключиться на левый монитор
    Win+Shift+Right - Переключиться на правый монитор
    Win+Home - Минимизировать / Восстановить все неактивные окна
    Win+Break(или Pause) - Запустить элемент Система из Панели Управления (пункт Свойства при нажатии правой кнопкой мыши на Компьютер в меню Пуск)
    Win+Space - Показать рабочий стол
    Win+B - Переход в область уведомлений(трей)
    Win+D - Свернуть окна или восстановить все окна
    Win+E - Запустить Проводник(Explorer)
    Win+F - Запустить встроенный диалог поиска Windows
    Win+Ctrl+F - Запустить Поиск по компьютеру из домена
    Win+F1 - Запустить встроенный диалог Windows: Справка и Поддержка
    Win+G - Отобразить гаджеты поверх всех окон
    Win+L - Блокировка рабочей станции(текущего сеанса пользователя)
    Win+M - Минимизировать все окна
    Win+P - Отобразить дополнительные опции дисплея (расширить рабочий стол на 2 монитор и т.п.)
    Win+R - Запустить диалоговое окно Выполнить
    Win+Т - Выбрать первый элемент в панели задач (Повторное нажатие переключает на следующий элемент, Win+Shift+T - прокручивает в обратном порядке)
    Win+U - Запустить Центр специальных возможностей (Ease of Access Center)
    Win+X - Запустить Mobility Center
    Win+цифра- Запустить приложение с панели задач (Win+1 запускает первое приложения слева, Win+2, второе, и т.к.)
    Win + "+" - Увеличить масштаб
    Win + "-" - Уменьшить масштаб
    Ctrl + колесо мыши (вверх\вниз) на рабочем столе - увеличить\уменьшить иконки рабочего стола.

    В Проводнике (Explorer):
    Alt+P - Показать / Скрыть Область предпросмотра

    Панель задач:
    Shift + щелчок на иконке - Открыть новое окно приложения
    Ctrl + Shift + щелчок по иконке - Открыть новое окно приложения с привилегиями администратора
    Shift + щелчок правой кнопкой на иконке - Показать меню приложения
    Shift + щелчок правой кнопкой на группе иконок - Показать меню, восстановить все / свернуть все / Закрыть все
    Ctrl + щелчок по группе иконок - Развернуть все окна группы

    5. Перезагрузка компьютера в безопасный режим без использования клавиатуры.

    Для того, чтобы перезагрузиться в Безопасный режим достаточно во время загрузки нажать клавишу F8 и выбрать пункт Safe Mode. А чтобы вернуться обратно в Нормальный режим достаточно всего лишь перезагрузить компьютер (не нажимая F8) и система вернется в своё стандартное состояние.
    Но на некоторых материнских платах клавиша F8 используется для выбора физического устройства, с которого должен начать загрузку компьютер.
    В этом случае необходимо выбрать жесткий диск, на котором установлена операционная система. После нажатия клавиши Enter необходимо сразу же снова нажимать клавишу F8 до тех пор, пока на экране не появится меню выбора вариантов загрузки ОС Windows. Вы должны успеть сделать это довольно быстро, а иначе начнется обычная загрузка Windows.
    Если же нет желания играть на скорость, есть более легкий вариант решения:

    1) Откройте Конфигурация системы (Пуск -> Выполнить -> msconfig -> Ok или Win+R -> msconfig -> Ok)
    2) Перейдите на вкладку Загрузка
    3) Поставьте галочку напротив значения Безопасный режим в разделе Параметры загрузки
    4) Нажмите Ok и перезагрузите компьютер.
    5) Чтобы вернуться обратно в Нормальный режим: находясь в Безопасном режиме уберите данную галочку и перезагрузите компьютер.

    6. Определение букв назначенных дискам в среде восстановления или среде предустановки.

    Загрузившись в среду восстановления или в среду предустановки Windows, Вы можете столкнуться с необходимостью определения буквы диска. Например, чтобы запустить приложения с флэш-диска или проверить диск на наличие ошибок.

    Виртуальному диску создаваемому в среде восстановления или среде предустановки всегда соответствует буква Х:, а для определения букв остальных дисков Вы можете выбрать одно из предложенных решений.

    Вариант 1. По размеру и типу диска.

    1) Перейдите в папку X:\Sources; для этого в командной строке введите указанную ниже команду и нажмите Enter:

    2) Запустите Блокнот (Notepad); для этого в командной строке введите указанную ниже команду и нажмите Enter:

    3) В главном меню блокнота выберите Файл -> Открыть (или нажмите сочетание клавиш Ctrl+O) 4) Щелкните на значок Компьютер в области переходов слева

    Примечание: Для лучшего отображения содержимого папки Компьютер, дважды щелкните по заголовку окна, чтобы его развернуть.

    Вариант 2. По содержимому папки.

    Также Вы можете определить буквы дисков напрямую из командной строки.

    1) Переходите с диска на диск вводя его букву и нажимая Enter. Например:

    Если Вам необходимо перейти к предполагаемой папке на диске, то переключайтесь используя команду:

    Например:

    2) Для отображения содержимого диска(папки) вводите команду:

    7. Автоматическое переключение русской и английской раскладок клавиатуры.
    Часто бывает, что напечатав какой-то текст, вы поднимаете глаза на монитор и вместо слова "Программа" видите слово "Ghjuhfvvf".
    Для того чтобы сохранить ваше терпение и нервы, существуют две замечательные программы: Punto Switcher(если вы в основном работаете с русской или английской клавиатурой) и Key Switcher(если вы работаете с несколькими европейскими языками).

    Данные программы предназначены для автоматического переключения между различными раскладками клавиатуры в операционных системах семейства Microsoft Windows.
    Основное назначение данных программ — увеличение продуктивности и удобства при работе с компьютером. Работая в фоновом режиме, они проводят статистический анализ последовательностей вводимых символов слова, и, если сочетание букв оказывается нетипичным для языка, на котором вводятся символы, то переключают язык ввода, заменяя текст исправленным.
    Каждая из программ является отдельным законченным продуктом и не требует запуска другой.

    8. Удаление Windows 7 без форматирования раздела и без потери данных.

    Для удаления Windows 7 описанным здесь способом вам потребуются:

    а) ERD Commander;
    б) Установочный диск Windows 7;

    Шаг I. Удаление загрузочной информации Windows 7.

    1) Загрузитесь в ERD Commader и вставьте установочный диск Windows 7 в свой DVD-привод.
    2) Запустите Command Prompt
    3) В открывшемся окне введите команду

    Где, E: - Буква вашего DVD-привода, а C: - Буква вашего жесткого диска, с которого удаляется Windows 7

    Шаг II. Удаление файлов и папок Windows 7.

    1) Запустите Micosoft Diagnostics and Recovery Toolset -> Explorer
    2) Как в обычном Explorer, тем же способом удалите следующие папки:
    • PerfLogs
    • Users
    • Windows
    • Recycle.Bin
    • Documents and Settings
    • ProgramData
    • Recovery

    9. Создание образа и использование ERD Commander (необходим для получения полного доступа к файлам и папкам).

    Скачиваете и устанавливаете сборщик образа ERD Commander для x86 или x64
    Запускаете Пуск -> Все программы -> Microsoft Diagnostics and Recovery Toolset -> Мастер создания загрузочных носителей ERD Commander

    По инструкции ниже создаете свой образ ERD Commander:

    1) Монтируете образ дистрибутива Windows 7 в виртуальный дисковод
    2) На вкладке Выбор образа загрузки указываете наш смонтированный виртуальный диск Windows 7

    Рисунок 1 из 3

    3) Щелкаете Ок, затем несколько раз кнопку Далее
    4) На вкладке Выбор программных средств снова нажимаете Далее
    5) В Мастер анализа сбоев выбираете Найти средства отладки для Windows в восстанавливаемой системе ...

    Рисунок 2 из 3

    6) На вкладке Загрузка определения автономного средства проверки системы Далее выбираете Нет, загрузить определения вручную позднее, затем Далее
    7) На вкладке Дополнительные драйверы добавьте драйвера в образ, если необходимо, затем Далее
    8) На вкладке Дополнительные файлы добавьте файлы в образ, если необходимо, затем Далее
    9) На вкладке Создание образа загрузки укажите куда сохранить готовый образ ISO.
    10) Оставляете галочку на пункте Записать готовый образ с помощью следующего устройства записи компакт-дисков, вставляете чистый диск в дисковод или убираете галочку с данного пункта, для дальнейшей записи на USB флеш-накопитель (флешку) и нажимаете Далее.

    Рисунок 3 из 3

    На USB флеш-накопитель (флешку) образ записывается через программу UltraISO так:
    1) Открываете образ в UltraISO.
    2) Выбираете Самозагрузка -> Записать образ жесткого диска...
    3) Нажимаете Записать

    11) Перезагружаемся в ERD Commander.
    12) Would you like to initialize network connectivity in the background?
    Если собираетесь восстанавливать настройки сети (Интернет или Локальной) выбираете Yes жмете Enter, если не собираетесь, то выбираете No и жмете Enter
    13) Would you like to remap the drive letters to match the mappings from the target operating system?
    Для сопоставления букв дисков целевой операционной системе выбираете Yes и жмете Enter, в противоположном случае выбираете No и жмете Enter
    14) Select a keyboard input method
    Выбираете нужную раскладку, нажимаете Next
    15) В окне для выбора операционной системы:

    Для работы с восстановительными программами Windows, выбирате пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. И выбираете вашу операционную систему.

    Для работы с системными файлами и папками(удаление, переименование или их замена) не выбираете никакую систему(должно сняться выделение с какой-либо системы). Для этого выберите пункт: Restore your computer using a system image that you created earlier, а затем снова выберите пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. и выделение само снимется.
    16) Нажимаете Next.

    10. Активация Windows 7 по телефону, используя лицензионный ключ.

    1) В меню Пуск нажмите правой кнопкой мыши на Компьютер и выберите пункт Свойства.
    2) Нажмите на ссылку Изменить ключ продукта
    3) Введите лицензионный ключ: XXXXX-XXXXX-XXXXX-XXXXX-XXXXX .
    4) Нажмите Активировать.
    5) Немного подождите, а затем выберите Другие способы активации - Активация по телефону. Выберите свой регион.
    6) Позвоните по бесплатному номеру (можно через программу Skype) .
    7) Робот начнет перечислять варианты активации.
    8) Нажмите на телефоне 1 (Активировать продукт Майкрософт).
    9) На вопрос на скольких компьютерах установлен продукт, нажмите 1.
    10) Когда вас попросят ввести код, введите. В ответ робот продиктует 8 блоков по 6 цифр (каждый блок дважды для проверки).
    11) Внесите цифры в окно активации.
    12) Нажмите Далее. Интернет, может быть отключен (без разницы).
    Windows 7 активирована.

    11. Быстрое переключение с одного монитора на другой или с монитора на проектор.

    Данное действие осуществляется нажатием клавиш Win+P. Вы также можете запустить DisplaySwitch.exe и выбрать предпочитаемый дисплей. Вызов данной утилиты не будет иметь результатов, если к компьютеру подключен только один монитор.

    12. Где можно скачать справочник от Microsoft, содержащий полное описание утилит командной строки?

    Вы можете скачать справочник от Microsoft (на английском языке), содержащий полное описание утилит командной строки.

    1) Перейдите по ссылке http://www.microsoft.com/downloads/en/details.aspx?FamilyID=5fb255ff-72da-4b08-a504-1b10266cf72a
    2) Нажмите Download.

    13. Уточнение времени работы компьютера с момента последней загрузки.

    Вариант 1.

    Если Вам необходимо узнать сколько времени работает Ваш компьютер с момента последней загрузки, то Вы можете создать скрипт-файл и запускать его при необходимости.

    1) Скопируйте указанный выше код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .vbs в любой папке (Например, на диске C:)
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "crp.vbs")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Чтобы узнать сколько времени работает компьютер, просто запустите созданный Вами скрипт, как обычную программу.

    Вариант 2.

    Скачайте и установите специальный гаджет.

    systemuptime_sevengadgets.ru.zip

    14. Автоматическая очистка временных папок при выходе из Windows.

    Чтобы не чистить вручную временные папки: C:\Users\Administrator\AppData\Local\Temp или C:\Users\YourNickname\AppData\Local\Temp и C:\Windows\Temp, Вы можете автоматизировать данный процесс при выходе из системы.

    1) Создайте командный файл сценария:

    Инструкция:

    1. Скопируйте код в любой текстовый редактор (например, Блокнот).
    2. Нажмите CTRL+S и сохраните файл с любым именем и расширением .cmd
    3. Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "tempdirclean.cmd")
    4. Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    2) Скопируйте его для удобства в корневую папку диска С:
    3) Запустите редактор групповых политик: Пуск -> Выполнить -> gpedit.msc или Win+R -> gpedit.msc
    4) Откройте ветвь Конфигурация пользователя > Конфигурация Windows > Сценарии (вход/выход из системы).
    5) В правой части два раза кликните по параметру Выход из системы или нажмите правую кнопку мыши и выберите пункт Свойства.
    6) Нажмите кнопку Добавить, укажите месторасположение созданного Вами командного файла c:\tempdirclean.cmd
    7) Нажмите Ок, затем снова Ок
    Теперь при выходе из системы, а также при завершении работы временные папки очистятся автоматически.

    Внимание: Если по указанной выше схеме Вы добавите командный файл сценария в свойства параметра Выход из системы, находящийся в ветке Конфигурация компьютера > Конфигурация Windows > Сценарии (запуск/завершение), то пользовательская временная папка очищена не будет, а очистится только временная папка самой Windows.

    Готовый CMD-файл Вы можете скачать по ссылке: tempdirclean.zip

    15. Где в Windows 7 хранятся значки (иконки)?

    Если Вы хотите использовать одну из иконок (значков) Windows 7, то большую их часть Вы можете найти в следующих файлах:

    C:\Windows\System32\shell32.dll
    C:\Windows\System32\imageres.dll

    Для извлечения необходимой Вам иконки:

    1) Откройте один из предложенных файлов, с помощью программы Restorator.
    2) В панели Дерево ресурсов откройте папку Иконка
    3) Выберите любую из понравившихся Вам иконок.
    4) В панели Дерево ресурсов щелкните правой кнопкой мыши на данном ресурсе и выберите Извлечь... > Извлечь как "имя_ресурса.ico"
    5) Выберите папку для извлечения и нажмите Сохранить

    Вы также можете извлечь все иконки сразу, для этого:
    6) В панели Дерево ресурсов щелкните правой кнопкой мыши на папке Иконка и выберите Извлечь... > Извлечь все как тип "Иконка"
    7) Выберите папку для извлечения и нажмите OK

    16. Извлечение загрузочного MS-DOS образа из файла diskcopy.dll и дальнейшая работа с ним.

    Многие используя в Windows функцию Форматировать, замечали пункт Создание загрузочного диска MS-DOS. Он используется для создания загрузочного диска MS-DOS на определенных типах устройств, для других же типов устройств он заблокирован.
    Выясняя откуда Windows берет образ MS-DOS для записи, я узнал что он содержится в файле diskcopy.dll. Но тут появился другой вопрос, а как его оттуда извлечь? Предлагаю Вам несколько способов его извлечения.

    Способ 1 Использование редакторов ресурсов.

    Открываете файл diskcopy.dll любым редактором ресурсов и извлекаете(сохраняете) ресурс 1 из папки BINFILE как diskcopy.img

    Способ 2 Программа Disk Extract

    1) Указываете в поле File(s) to search and extract byte sequence (wildcards *.* accepted) - файл для поиска и извлечения необходимого количества байтов: C:\Windows\System32\diskcopy.dll
    2) Указываете в поле Byte sequence to find - с какого байта искать: EB3C90
    3) Указываете в поле Bytes to copy - сколько байт скопировать: 1474560
    4) Указываете в поле Save as - куда и под каким именем сохранить (например так): D:\Temp\diskcopy\diskcopy.img
    5) Нажимаете на кнопку Play
    6) В появившемся окне Confirm нажимаете Yes

    Способ 3 Программа GETBTDSK со скриптом

    Запускаете файл GETBTDSK.bat и получаете в итоге готовый файл diskcopy.img
    Некоторые антивирусные программы могут воспринять попытку её обращения к системному файлу как разновидность вируса, поэтому для работы скрипта либо изолируйте файл GETBTDSK.EXE, или папку где он находится из поиска антивирусной программой, либо воспользуйтесь первым способом.

    Хорошо, образ мы извлекли и у нас есть готовый файл diskcopy.img. Что же дальше, спросите Вы. А дальше, Вы можете:

    1) Распаковать полученный файл с помощью программы архиватора 7zip и дальше работать с файлами по-своему усмотрению.

    2) Записать загрузочный MS-DOS образ diskcopy.img на USB флеш-накопитель (флешку).

    1. Открываете файл diskcopy.img в программе UltraISO
    2. Выбираете Самозагрузка -> Записать образ жесткого диска...
    3. Метод записи оставляете USB-HDD+
    4. Нажимаете Записать

    Чтобы не искать в интернете эти программы, Вы можете скачать архив с ними: msdosboot.zip

    17. Термины и сокращения используемые Microsoft для маркировки своих продуктов.

    Скачивая какой-либо продукт Microsoft в интернете, помимо его названия Вы можете увидеть дополнительные обозначения в наименовании. Если Вам интересно, что означает "CTP", "Escrow", "LDR", "RC", "RTM" и тому подобное - предлагаю Вам, расшифровку особо часто встречающихся из них.

    BBT - Basic Block Tools или Binary Profile Feedback Optimization framework
    BBT - пакет инструментов оптимизации, помогающий уменьшить требования к рабочему набору Win32 приложения. Для этого применяется дополнительный статический анализ и эвристика кода. Также в результате мониторинга потока выполнения программы происходит интеграция профиля данных. Для дополнительной компрессии страниц памяти, BBT реорганизовывает статистические данные и секции ресурсов.
    BBT - специальный анализатор, оптимизирующий величину кода, путем игнорирования не используемой части, и архивации оставшейся.
    Другое значение BBT - это “Black Box Testing”, тестирование "чёрного ящика" или что-то в этом духе.

    BVT - Build Verification Test
    Небольшой набор тестов, проверяющих уровень качества сборки, на этапе её создания. Например, BVT для Блокнота может выглядеть как: "Запустить, напечатать текст, сохранить, выйти". Если сборка не проходит данный тест, то во избежание дальнейших ошибок при тестировании, она отправляется на доработку. Порядок действий BVT редко меняется, а результаты - тщательно контролируются.

    CPP - Customer Preview Program
    Программа предварительного ознакомления.

    CTP - Community Technology Preview
    Предварительный технологический релиз для сообщества, впервые использован для сборки Vista build 5219, так называемый январский CTP.

    DNSRV - .NET (DotNet) Server
    Раннее кодовое имя Windows Server 2003.

    EBS - Essential Business Server
    Серверное решение от Microsoft, имеет в своей основе ядро Windows Small Business Server 2008, ориентировано на рынок среднего бизнеса.

    EDW - External Developer Workstation
    Этот термин, использовался во времена разработки Windows Vista, для обозначения сборок выпущенных между RC и RTM сборками.

    Escrow
    Сборки, не имеющие серьёзных ошибок. Они, как правило, становятся в итоге Релиз-кандидатами или RTM (после того, как сборка подписана к выпуску).

    Exit Criteria
    Набор тестов, проверяющих наиболее важные аспекты корректной работы основных функций приложения. Как выглядит тот или иной тест, определяется командой-разработчиком функции, результаты прохождения теста должны точно совпадать с ожидаемыми. Полное прохождение таких тестов ознаменует переход к следующему этапу разработки.

    FBL - Feature build lab
    Группа разработки какого-либо функционала.

    FVT - Feature Verification Tests
    Тоже самое, что и BVT, только для конкретной функции.

    GA - General Availability
    Означает, что програмное обеспечение доступно на основном рынке через Интернет или на каком-либо физическом носителе.

    GDR - General Distribution Release
    Используется для обновлений и хотфиксов, содержащих только заплатки критических ошибок и исправления, влияющие на стабильность.

    HSBS - Home and Small Business Server

    IDS - Internal Developer Server

    IDW - Internal Developer Workstation

    IDX - Internal Developer Client/Server

    LCTP - Limited Community Technology Preview
    Ограниченный предварительный технологический релиз.

    LDR - Limited Distribution Release
    Используется для обновлений и хотфиксов, содержащих “прочие” исправления, как правило, для ошибок, возникающих у весьма специфической группы пользователей.

    MMS - Mid-Market Server
    Раннее название Essential Business Server.

    QFE - Quick Fix Engineering
    Аналогично LDR.

    QHSV - Q Home Server
    Раннее название Windows Home Server.

    RC - Release Candidate
    Качество сборки на данной стадии разработки наиболее близко к стабильному, критические ошибки уже исправлены, однако, в ходе текущего тестирования могут быть найдены новые ошибки.

    RDP - Rapid Deployment Program

    RTM - Release To Manufacturing
    Стабильная сборка, прошедшая все стадии тестирования, в которой исправлены все найденные ошибки, и готовая к применению.

    RTW - Release To Web
    Это RTM, предназначенный для распространения через Интернет.

    SBS - Small Business Server

    Self host
    Сброки, прошедшие тесты Exit Criteria tests, готовые к более глубокому тестированию.

    Self test
    Сборки, прошедшие BVT и FVT тесты.

    Self toast
    Сборки, не прошедшие BVT.
    Sign-off
    Подписание, означает, что функция/продукт готова к продаже.

    TAP - Technology Adoption Program
    Программа технологического утверждения, в ходе которого собираются отзывы тестеров, в качестве которых могут выступать и заказчики компании.

    TP - Technical Preview

    VBL - Virtual Build Lab
    Термин обозначает группу разработчиков объединенных в виртуальную лабораторию.

    WHS - Windows Home Server

    WSSG - Windows Server Solutions Group

    WSUS - Windows Server Update Services

    18. Удаление установленного обновления.
    Если Вы установили обновление в Windows, для добавления дополнительной функции, а оно Вам не понравилось, то Вы можете спокойно его удалить.
    Для удаления любого обновления сделайте следующее:

    1) Откройте Панель управления\Программы
    2) Нажмите на ссылку Просмотр установленных обновлений
    3) Нажмите правой кнопкой на любом обновлении, которое желаете удалить и щелкните на появившемся слове Удалить.
    4) В случае необходимости, перезагрузите компьютер.

    19. Создание значков управления состоянием компьютера.

    Для быстрого изменения состояния системы Вы можете создать на рабочем столе ярлыки позволяющие изменить его одним нажатием мыши.

    Для создания ярлыков выполните следующие действия:
    1) Нажмите правую клавишу мыши на рабочем столе, выберите пункт меню Создать -> Ярлык
    2) В поле Укажите расположение объекта введите необходимую команду для создания ярлыка и нажмите OK.

    Блокировка компьютера

    Выход из системы

    Завершение работы

    Перезагрузка

    Сон

    20. Копирование текста из окон сообщений и всплывающих оповещений в буфер обмена.

    Текст из окна сообщения Windows выделить для копирования невозможно, так как он заблокирован. Но Вы можете скопировать данный текст в буфер обмена.
    Для того чтобы это нажмите комбинацию клавиш Ctrl+C, а затем вставьте текст из буфера в любой текстовый редактор используя комбинацию клавиш Ctrl+V. Окно, текст которого нужно скопировать, должно быть активным.
    Например, попробуйте закрыть окно оснастки Службы при открытом окне свойств отдельной службы, и Вы увидите одно из таких сообщений Windows.

    21. Удаление данных без возможности восстановления.

    При удалении файла или папки, не происходит полного физического удаления информации, очищается лишь только «оглавление» файловой системы. С помощью утилиты cipher возможно частичное решение этой проблемы, так как существует возможность выполнить очистку свободного места на диске затиранием её.
    Место, занимаемое содержимым папки, будет перезаписано нулями, потом единицами, а после этого - набором случайных символов в каждом секторе.

    Для полного удаления данных:

    1) Удалите необходимые файлы или папки из Вашего каталога, которые должны быть затерты.
    2) Запустите командную строку с правами администратора
    2.1) Нажмите кнопку Пуск
    2.2) В строке поиска введите cmd
    2.3) Щелкните на найденной программе правой кнопкой мыши и выберите Запуск от имени администратора
    3) В командной строке введите:

    каталог - путь к любой папке на разделе подлежащим очистке. (Например: cipher /w:c:\temp) Если Вы удалили папку или файл из корня диска, то Вы можете указать в качестве пути только букву диска. (Например: cipher /w:c:\)

    22. Выполнение дефрагментации дисков в Windows 7 используя командную строку.

    В Windows существует программа Дефрагментация диска. Данная программа производит упорядочение фрагментированной информации для более эффективной работы дисков и дисководов. Программа дефрагментации диска работает по заданному расписанию, но можно запускать анализ и дефрагментацию дисков вручную. В программе Вы можете увидеть время прошлого запуска, уровень фрагментированности дисков и запланированное время следующего запуска.
    Если Вы не отключали планировщик заданий, значение уровня фрагментированности дисков будет равно 0%, а при нажатии кнопки Анализировать диск система покажет уровень фрагментированности не более 10%. При желании Вы можете запустить дефрагментацию вручную нажав кнопку Дефрагментация диска или настроить запуск по расписанию, в удобное для Вас время.

    Графический интерфейс программы Вы можете запустить: Пуск -> Все программы -> Стандартные -> Служебные. Однако он весьма ограничен в возможностях, и их хватит начинающему или малоопытному пользователю, если же Вы продвинутый или опытный пользователь, то Вам будет интересен командный режим данной программы.

    1) Нажмите кнопку Пуск и в строке поиска наберите cmd
    2) Нажмите на найденной программе правой кнопкой мыши и выберите пункт Запуск от имени администратора.
    3) Вы можете запустить утилиту defrag.exe используя следующие параметры командной строки:

    Параметр | Описание
/A | Анализирует указанный том. Логично выполнить анализ перед ручной дефрагментацией. В результатах будет сказано, каким разделам она нужна.
/C | Выполняет операцию на всех томах. Этот параметр избавляет от необходимости перечислять все буквы разделов при анализе или дефрагментации.
/E | Выполняет операцию на всех томах, кроме указанных. Еще один параметр, экономящий время.
/H | Выполняет операцию с обычным приоритетом (по умолчанию используется низкий). Ускоряет процесс дефрагментации, но может замедлить работу других приложений, обращающихся к диску в это время.
/M | Выполняет операцию на всех томах одновременно в фоновом режиме. Стандартное поведение дефрагментатора – последовательная работа над томами.
/T | Отслеживает текущую операцию на указанном томе.
/U | Выводит прогресс текущей операции на указанном томе в процентном отношении.
/V | Выводит подробный отчет о томах, их фрагментированности, файлах и папках, а также о свободном пространстве и MFT.
/X | Объединяет свободное пространство на указанных томах.
/R | Выполняет частичную дефрагментацию (поведение по умолчанию), пытаясь объединять только фрагменты размером менее 64 Мб.
/W | Выполняет полную дефрагментацию, пытаясь объединять любые фрагменты вне зависимости от их размера.
/F | Выполняет принудительную дефрагментацию, даже если на диске недостаточно свободного пространства.

    Примеры команд

    Команда | Описание
defrag /A /C /U /V | Анализирует фрагментированность всех разделов, отображая ход операции, и выводит подробный отчет.
defrag C: /W /V | Выполняет полную дефрагментацию раздела C, а затем выводит подробный отчет.
defrag C: /E /H /F | Выполняет дефрагментацию всех разделов кроме C с обычным приоритетом вне зависимости от количества свободного пространства на них.

    23. Уменьшение размера файла изображения без потери качества.

    Если у Вас хранится большое количество файлов изображений на компьютере или Вы добавляете изображения в текстовые документы или Вы размещаете их в интернете, то данный совет поможет Вам уменьшить занимаемое ими место без потери качества.

    1) Скачайте и разархивируйте в любую удобную Вам папку архив PictureBeaver.zip
    2) Выделите необходимый Вам файл-изображение, группу файлов или папку с изображениями
    3) Перетащите выделенное на файл optimize.wsf.
    4) Откроется окно командной строки (процесс действий в окне отображаться не будет), по завершении процесса оптимизации оно само закроется .
    5) Результаты появятся в той же папке, где и Ваши исходные файлы изображений. Оптимизированные файлы изображений будут в папке (папках) Optimized, отчёт о сэкономленном объеме в файле Optimization Report.html

    Данный скрипт для оптимизации использует программы:

    gifsicle - для оптимизации GIF изображений
    jpegtran - для оптимизации JPG изображений
    optipng - для оптимизации PNG изображений

    24. Где можно скачать последнюю версию DirectX?

    Официальный сайт для скачивания последних версий DirectX находится по ссылке ниже:

    Официальный сайт DirectX
    Полная версия: DirectX End-User Runtimes
    Web версия(обновляется раньше, чем полная): DirectX End-User Runtime Web Installer

    25. Запуск программы с определенной датой без изменения системных настроек.

    Если Вы являетесь разработчиком программного обеспечения и по истечении тестового периода работы Ваша программа должна прекратить работу по причине выхода финальной версии или же Вам просто интересно как будет работать программа при изменении даты, то Вам нет необходимости изменять настройки системы.

    Для запуска программы с определенной датой в прошлом или будущем Вы можете скачать программу RunAsDate

    Вы можете запустить необходимую Вам программу непосредственно из программы RunAsDate или же создать ярлык для запуска с Рабочего Стола.

    26. Изменение атрибутов и времени/даты создания, изменения и открытия (доступа) файла.

    Если Вам необходимо изменить дату создания, дату изменения и дату открытия (доступа) файла, то для этого Вы можете воспользоваться программой BulkFileChanger, которую Вы можете скачать здесь.

    Чтобы изменить атрибуты и/или любую из указанных времени/дат, сделайте следующее:

    1) Добавьте Ваш файл в программу.
    1.1) Воспользуйтесь методом тащи-и-бросай (drag-and-drop), просто перекиньте Ваш файл на окно программы.
    или
    1.2) В главном меню выберите Файл -> Добавить файлы (клавиша F2), выберите файл(ы) для добавления и нажмите Открыть.

    2) Выделите файл(ы) и в главном меню выберите Действия -> Изменить время/атрибуты (клавиша F6)
    3) Установите необходимые атрибуты и/или время/дату файла и нажмите кнопку Выполнить.

    Примечание. Если Вы не живете в Великобритании, Гренландии, Ирландии, Исландии, Португалии или Канарских островах, то не забудьте снять флажок Время указано по Гринвичу.

    27. Список всех обновлений вошедших в SP1 с краткими объяснениями и ссылками.

    Если Вам необходимо узнать какие обновления вошли в Сервисный пакет обновлений 1, то Вы можете скачать с сайта Microsoft документ в котором описаны все обновления вошедшие в него, и также даны краткие пояснения и ссылки на страницы самих обновлений.

    Скачать: Hotfixes and Security Updates included in Windows 7 and Windows Server 2008 R2 Service Pack 1.xls

    Файл при запуске откроется на странице Legal Disclaimer, для прочтения кратких пояснений к каждому вошедшему в SP1 обновлению и уточнения принадлежащих им ссылок перейдите в xls-файле на страницу Update List.

    28. Список горячих клавиш, используемых в окне команд Windows 7.

    В окне командной строки также как и в других окнах Windows существует набор используемых горячих клавиш, которые Вы можете использовать.

    Стрелка вверх - переход к раннее введенной команде.
    Последовательно нажимая стрелку вверх, в командной строке будет появляться предыдущая введенная команда.

    Стрелка вниз - переход к позднее введенной команде.
    Перейдя стрелкой вверх к самой первой команде, можно вернуться к последней нажимая стрелку вниз.

    ESC - очистка строки ввода.
    При нажатии стрелок для перемещения, переход по истории команд продолжится с того же места, где Вы остановились.

    Tab - автозавершение названия файла/папки.
    Пример: Если находясь в корне диска C:, Вы введете команду cd prog и нажмете клавишу Tab, то у Вас автоматически отобразится cd "Program Files".
    При наличии объектов с одинаково начинающимися названиями нажимайте Tab, до появления необходимого значения. Подстановка имен происходит в алфавитном порядке.
    Если в 64-битной системе, учитывая предыдущий пример, Вы нажмете клавишу Tab снова, то у Вас автоматически отобразится cd "Program Files (x86)".

    F1 - побуквенный ввод выбранной команды из истории команд.

    F2 - скопировать в строку ввода часть командной строки, выбранной в истории, от начала строки до указанного Вами символа.
    Копируется именно выбранная команда стрелочками, а не тот текст, что введен в данный момент.

    Пример работы:
    Выберите в истории, необходимую команду. Для примера: cd "Program Files"
    Нажмите ESC. Строка очистится.
    Нажмите F2. В появившемся диалоге нажмите m. В строке отобразится: cd "Progra

    F3 - вставка текущей команды из истории.

    F4 - удаление до указанного символа в текущем набранном тексте

    F5 - вставка предыдущей команды из истории.

    F7 - отображение нумерованного списка историю команд.

    F8 - аналог клавиши "Стрелка вверх".

    F9 - ввод команды из истории команд по ее номеру. Под номером понимается цифра, присвоенная команде в списке, отображаемом по F7.

    Alt+F7 - очистка истории команд.

    Ctrl+C - прекращение выполнения текущего командного файла или консольного приложения.


Установка

1. Добавление вручную нового устройства (драйвера).

1) Нажмите кнопку Пуск, введите в строке поиска hdwwiz и нажмите Enter. (Win + R -> hdwwiz -> ОК)
2) В открывшемся окне, нажмите Далее (Next)
3) В следующем окне выберите Установка оборудования, выбранного из списка вручную. (Install the hardware that I manually select from a list) и нажмите Далее (Next)
4) Выберите в списке самую верхнюю строчку Показать все устройства (Show all devices) и нажмите Далее (Next)
5) В следующем окне нажмите на кнопку Установить с диска (Install From Disk), в нижнем правом углу.
6) В открывшемся окне нажмите кнопку Обзор (Browse) и укажите путь к файлу драйвера (inf-файл), затем нажмите ОК, а после Далее (Next)
7) Подтвердите желание установить нажатием Далее (Next)

2. Место сохранения обновлений полученных через Центр обновления Windows (Windows Update).

Все обновления, которые Вы скачиваете или устанавливаете через внутреннюю службу Windows Центр обновления Windows (Windows Update) хранятся в папке: C:\Windows\SoftwareDistribution\Download, а также в подпапках внутри неё. После установки обновлений, Вы можете сохранить их себе на компьютер просто скопировав из папки нужный Вам файл. Файлы содержащие в своем названии -express, могут повторно не установиться. Следовательно Вы можете их и не копировать.

3. Определение неизвестного устройства в Диспетчере устройств.

Узнайте VendorID(VEN) или DeviceID(DEV) устройства.

Данные сведения Вы можете узнать воспользовавшись Диспетчером устройств.
1) Откройте Пуск -> Панель управления -> Диспетчер устройств
2) Нажмите правой кнопкой мыши на необходимом Вам устройстве и выберите пункт Свойства
3) Перейдите на вкладку Сведения и в ниспадающем списке выберите ИД оборудования.
4) Зайдите на сайт: http://www.pcidatabase.com и введите одно из найденных Вами значений.

Если в указанной выше вкладке этого нет посмотрите также в вкладках:

Совместимые ИД
Путь к экземпляру устройства
Родитель
Родственные

там тоже это указывается.

4. Где можно найти драйвера, зная VendorID(VEN) или HardwareID(DEV)?

Здесь

5. Во время инсталяции, после копирования файлов, установщик (сама система) виснет.

Она не висит. Попробуйте выбрать другой монитор в персонализации - параметры дисплея. Это бывает, если у видеокарты два выхода. Такое состояние "зависания" может иметь разное время: от 2-3 минут до 25-30.

6. Установка Windows 7 с USB флеш-накопителя (флешки).

Вариант 1. Используя командную строку.

Подготовка USB флеш-накопителя (флешки) для будущей загрузки и установки Windows 7:

1) Подключаете USB флеш-накопитель (флешку) не менее 4 Гб к USB-порту.
2) В строке поиска меню Пуск вводите cmd.exe, щелкаете на найденном правой кнопкой мыши и нажимаете Запуск от имени администратора
3) Запускате утилиту управления дисками diskpart, дожидаетесь приглашения DISKPART>
4) Выполняете команду list disk (отображает список всех дисков ПК)
5) Ищете среди них Ваш диск USB, в моём примере это Disk 2
6) Выполняете команду select disk # (где # – это номер нашего USB-драйва, полученного в предыдущей команде). Для нашего случая – select disk 2. Данная команда указывает diskpart, что все дальнейшие операции будут проводиться с данным диском.
7) Выполняете команду clean (стирает все данные и разделы на USB диске)
8) Выполняете команду create partition primary (создание нового раздела на диске)
9) Выполняете команду select partition 1 (выбор раздела, как дальнейшего объекта для манипуляций)
10) Выполняете команду active – делаете выбранный раздел активным
11) Выполняете команду format fs=NTFS – форматируете раздел в файловую систему NTFS
12) Выполняете команду assign – активируете процесс подключения устройства, получения букв для созданных разделов (если автостарт опция включена – всплывает окно, как будто вы только что подключили USB-драйв)
13) exit – выходите из diskpart в командную строку.

Рисунок 1 из 2

14) Вставляете имеющийся у Вас дистрибутив Windows 7 в дисковод, или монтируете образ в виртуальный диск.
15) Допустим, что он у Вас установлен в дисковод H:, тогда в командной строке (не в diskpart !!!) выполняете команду:

где I: – буква, полученная только что подготовленным USB-драйвом.
Данная команда подменяет на диске I: файлы загрузчика на те, которые необходимы для загрузки Windows 7.
Битность базовой ОС и дистрибутива Windows должны быть одинаковыми .
16) Копируете все файлы с Вашего дистрибутива на Ваш USB флеш-накопитель (флешку). Используйте для этого либо Windows Explorer, либо команду:

Рисунок 2 из 2

Всё, USB-драйв готов. Загружаете ПК с полученного USB флеш-накопителя.

Для ускорения процесса копирования опытные пользователи могут воспользоваться программой RichCopy, она является графической оболочкой команды robocopy, и включает в себя большое количество настроек. В число многочисленных параметров входят сортировка файлов по атрибутам и папкам, предотвращение ошибок, смена атрибутов, тайминг копирования, редактирование отметки о времени, установка количества потоков и размера используемого кэша.

Вариант 2. Используя программу от Microsoft - Windows 7 USB/DVD Download Tool.

1) Скачайте программу Windows 7 USB/DVD Download Tool
2) Установите и запустите программу.
3) Укажите на первом шаге путь к Вашему ISO-файлу и нажмите кнопку Next.
4) Выберите на втором шаге пункт USB Device
5) Нажмите на третьем шаге кнопку Begin copying
6) На четвертом шаге запустится процесс создания установочного загрузочного флеш-диска.
7) По окончании процесса создания закройте программу

Вариант 3. Используя программу стороннего произодителя - UltraISO.

1) Вставьте Ваш флеш-диск в USB-порт.
2) Откройте ISO-образ Windows программой UltraISO

Так:

Щелкните на ISO-файле правой кнопкой мыши и выберите пункт Открыть, используя UltraISO

Или так:

В программе UltraISO в меню Файл нажмите на пункт Открыть, выберите нужный Вам образ Windows 7 и нажмите Открыть.

3) Убедившись, что образ открыт - выберите в меню Самозагрузка пункт Записать образ Жесткого диска
4) В списке Disk Drive:, выберите Ваш флеш-накопитель, в пункте Метод записи: USB-HDD+ и нажмите Записать.
5) В появившемся окне об уничтожении информации Подсказка, нажмите кнопку Да. Дождитесь, когда завершится запись (от 5 до 20 минут).
6) Не вынимая флеш-диска из USB-порта перезагрузите компьютер.
7) Сразу после начала перезапуска нажмите на клавиатуре Delete (Del), чтобы попасть в BIOS.
8) В BIOS установите загрузку в первую очередь с USB-HDD.
9) Сохраните настройки и выйдите из BIOS. Компьютер перезапуститься и начнет загрузку с флеш-накопителя.
10) Сама по себе установка мало чем отличается от установки с загрузочного DVD-диска, но есть один момент. Когда завершится копирование и распаковка файлов, и компьютер в первый раз пойдет на перезагрузку, нужно снова идти в BIOS и ставить обратно приоритет загрузки (по умолчанию с жесткого диска) или вытащить флешку. Иначе, возможно, загрузка снова пойдет с флеш-диска.

7. Интеграция языковых пакетов и обновлений в дистрибутив Windows 7.

Вариант 1 вручную с помощью DISM.

Для работы Вам потребуются программа DISM, входящая в состав Windows 7 и программа UltraISO

Внесение изменений в install.Wim (Для добавления языка в систему, которую Вы установите)
1) Создаете на диске D: папки ISO, Lip, Mount и mWim
2) Распаковываете в папку D:\ISO iso-образ Вашего установочного диска.
3) Изменяете текст файла lang.ini в папке D:\ISO\sources на следующий:

4) Копируете файл языкового пакета lp.cab и все файлы обновлений (MSU и CAB) в папку Lip
5) Создаете в папке D:\Lip папку uLip
6) Перемещаете из папки D:\ISO\Sources в папку D:\mWim файл install.wim
7) Запускаете командную строку от имени администратора (Win+R -> cmd -> ОК)
8) Узнаете номер индекса Вашей Windows 7, используя команду:

9) Монтируете файл install.wim в папку D:\Mount учитывая номер индекса Вашей операционной системы (Например, для Windows 7 Enterprise независимо от разрядности он равен 1, для 32-битной версии Windows 7 Ultimate он равен 5, а для 64-битной версии Windows 7 Ultimate он равен 4), используя команду:

10) Интегрируете языковой пакет и обновления:
Для интеграции языкового пакета введите команду:

Для интеграции обновления, используйте команду аналогичную предыдущей, подставляя вместо lp.cab, наименование интегрируемого обновления. Вот пример интеграции произвольного обновления:

11) Применяете все настройки для русского языка командой:

Примеры запуска команд DISM для установки локальных настроек:

12) Демонтируете образ с сохранением изменений:

Демонтаж без сохранения:

13) Удаляете файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

14) Перемещаете файл install.wim из папки D:\mWim в папку D:\ISO\Sources Внесение изменений в Boot.Wim (Для добавления языка в программу установки запускаемую с установочного DVD или флеш-диска при старте компьютера)
1) Распаковываете lp.cab в папку D:\Lip\uLip

2) Очищаете папку D:\Mount (удаляете из нее любые следы, которые могли остаться от работы с файлом install.wim)
3) Перемещаете из папки D:\ISO\Sources в папку D:\mWim файл boot.wim
4) Монтируете файл boot.wim в папку D:\Mount (индекс указываете 2, так как он соответствует программе установки)

5) Добавляете в boot.wim русский язык:

6) Добавляете в boot.wim файлы лицензий:

7) Изменяете текст файла lang.ini в папке D:\Mount\sources на следующий:

8) Демонтируете файл boot.wim с сохранением:

9) Перемещаете файл boot.wim из папки D:\mWim в папку D:\ISO\Sources Работа с папкой будущего образа. 1) Добавляете русский язык, в программу установки запускаемую в среде Windows или с Live-CD:

2) Добавляете файлы лицензий, в программу установки запускаемую в среде Windows или с Live-CD.:

3) Удаляете с диска D: папки Lip, Mount и mWim
4) Используя программу UltraISO создаете iso-образ установочного диска.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программой DISM Tool. Данная программа позволяет выполнять, все необходимые Вам команды, используя графический интерфейс. С помощью неё Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(используйте пункт Add Packages).

Вариант 2. Используя программу RT Se7en Lite.

Данная программа интегрирует языковой пакет только в будущую систему (install.wim). Программа установки (boot.wim) остается на оригинальном языке.

1) Распакуйте ISO-образ установочного диска (в который Вы собираетесь интегрировать сервисный пакет) в любую папку.
2) Скачайте, установите и запустите программу RT Se7en Lite.
3) Нажмите кнопку Browse и выберите пункт Select OS Path.
4) Укажите путь к папке в которую Вы распаковали ISO-образ установочного диска и нажмите ОК.
5) В появившемся окне List of operating system выберите Вашу редакцию Windows 7 и нажмите ОК.
6) В столбце слева нажмите кнопку Task и в открывшемся окне установите флажок Integration.
7) В столбце слева нажмите кнопку Integration.
8) Перейдите на вкладку Language Packs и нажмите кнопку Add.
9) Укажите путь к Вашему cab-файлу языкового пакета и нажмите Открыть.
10) Нажмите кнопку Apply, а затем кнопку Commit.
11) В окне Do you want to enable ISO bootable task? нажмите Да.
12) Нажмите кнопку Finish, а затем кнопку Да.
13) Используя программу UltraISO создаете iso-образ установочного диска.

Вариант 3 с помощью интегратора

1) Скачайте Интегратор обновлений и языковых пакетов Windows 7
2) Запустите его
3) Укажите (выберите) необходимы вам опции.
4) Нажмите на кнопку Выполнить
5) Дождитесь успешного выполнения и увидите результат.

Вариант 4 с помощью командного файла скрипта.

1) Скачайте LPIntegrator.zip
2) Распакуйте скачанный архив в папку
3) Нажмите правой кнопкой мыши на файле LPIntegrator.bat и щелкните на пункте меню Изменить
4) Измените значение параметра set LANG=ru-RU, на язык интегрируемого языкового пакета, где en-US - для английского языка, de-DE - для немецкого языка и т.д.
5) Сохраните изменения и закройте редактирование.
6) Запустите LPIntegrator.bat
7) Выберите версию Вашего образа Windows 7
8) Распакуйте ISO-образ в папку C:\7Work\DVD или скопируйте туда все файлы Вашего инсталляционного диска.
9) Скопируйте языковой пакет, который Вы хотите интегрировать в папку C:\7Work\LP
10) Скопируйте обновления, которые Вы хотите интегрировать в папку C:\7Work\CABS
11) Нажмите любую клавишу(например, Enter) для продолжения.

8. Добавление и использование новых языков интерфейса в Windows.

Для добавления языков интерфейса необходимо установить дополнительные языковые файлы. После установки языковых файлов можно просматривать текст мастеров, диалоговых окон, меню, разделов справки и прочих элементов Windows на другом языке. Существуют 2 варианта добавления новых языков интерфейса: первый - через Центр обновления Windows(Windows Update), а второй - скачав и установив файл языкового пакета вручную. Перед началом работы измените в Панели Управления (Control Panel) способ просмотра(View by), вместо Категория(Category) на Крупные (Large icons) или Мелкие значки(Small icons).

Вариант1. Через Центр обновления Windows(Windows Update)

1) Откройте Центр обновления Windows

Пуск -> Все программы -> Центр обновления Windows (Start -> All Programs -> Windows Update)
или
Панель управления\Все элементы панели управления\Центр обновления Windows (Control Panel\All Control Panel Items\Windows Update)

1a) Также вы можете нажать Win+R, в поле Выполнить ввести указанную ниже команду и нажать ОК

2) Выберите пункт Необязательных обновлений XX шт. доступны (XX options updates are available)
3) Поставьте флажок напротив нужного Вам языкового пакета (Language Pack) и нажмите ОК

Вариант 2. При наличии файла языка интерфейса lp.cab

1) Заходите в Панель Управления(Control Panel)
2) Открываете Язык и региональные стандарты (Regional and Language)
3) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
4) Нажимаете Установить или удалить язык (Install/uninstall languages...)
4a) Также вы можете нажать Win+R, в поле Выполнить ввести lpksetup и нажать ОК
5) Нажимаете Установить языки интерфейса (Install display languages)
6) Нажимаете кнопку Обзор...(Browse...)
7) Указываете путь к папке с lp.cab и нажимаете ОК
8) Выбираете необходимый Вам язык и нажимаете Далее(Next)

Вариант 3. Установка файла скачанного с сервера Windows Update

Вы можете установить необходимый Вам язык интерфейса, скачав exe-файл по прямой ссылке с сервера Windows Update и просто запустив его.

Смена Вашего языка интерфейса на новый:

1) Заходите в Панель Управления(Control Panel)
1.1) Открываете Язык и региональные стандарты (Regional and Language)
1.1a) Также вы можете нажать Win+R, в поле Выполнить ввести intl.cpl и нажать ОК
1.2) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
2) Выбираете в пункте Выберите язык интерфейса (Choose a display language:) нужный Вам язык и нажимаете ОК
3) Нажимаете кнопку Выйти из системы сейчас (Log off now)
4) В появившемся экране выбираете своего пользователя.
5) В случае необходимости вводите свой пароль и попадаете в Windows на выбранном Вами языке

9. Автоматическое введение ключа при инсталляции Windows.
Создайте файл Autounattend.xml с указанным ниже текстом и скопируйте данный файл в корневую папку и в папку \Sources установочного диска.
Вместо xxxxx-xxxxx-xxxxx-xxxxx-xxxxx введите Ваш ключ.

Вариант 1. Для 32-битных систем.

Если у Вас ключ для Retail или OEM версии, то создайте файл Autounattend.xml следующего содержания:

Если у Вас MAK-ключ, то создайте файл Autounattend.xml следующего содержания:

Вариант 2. Для 64-битных систем.

Если у Вас ключ для Retail или OEM версии, то создайте файл Autounattend.xml следующего содержания:

Если у Вас MAK-ключ, то создайте файл Autounattend.xml следующего содержания:

10. Отключение проверки цифровой подписи драйверов и её добавление в 64-битных Windows 7.

Многие из нас сталкивались с проблемой установки неподписанного драйвера. Например, необходимо поставить драйвер какой-либо программы, но ее драйвер не устанавливается, ибо у него нет цифровой подписи.

В качестве решения Вы можете либо отключить проверку подписи, либо попытаться самостоятельно добавить к нему подпись.

Если Вам необходимо поработать с программой, устанавливающий свой драйвер без перезагрузки системы, то Вы можете загрузиться в специальный режим Windows.
1) Сразу после включения компьютера нажмите F8. Далее Вы попадете либо в меню Дополнительные варианты загрузки, либо в меню выбора диска для загрузки.
2) Вам нужно меню Дополнительные варианты загрузки, поэтому если Вы попали в меню выбора дисков, то выберите диск на котором установлена Ваша Windows и нажмите Enter, а затем быстро нажмите F8 до начала запуска Windows.
3) Выберите пункт Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) и нажмите Enter
Вы загрузитесь в специальный режим Windows, на котором будет только отключена проверка подписи, а все остальные функции будут работать в обычном режиме. После перезагрузки компьютера Вы вернетесь обратно в обычный режим с проверкой драйверов.
Иногда при установке драйвера в этом режиме система может выдать сообщение, что драйвер не подписан, просто закройте его и система нормально установит драйвер.

Чтобы самостоятельно подписать драйвер Вам понадобиться программа Driver Signature Enforcement Overrider(DSEO). Она позволяет создавать свои собственные непроверенные свидетельства. Для нормальной работы программы Контроль учетных записей (User Account Control (UAC)) должен быть выключен.

Скачать:

С официального сайта
С зеркала

1) Запускаете программу и нажимаете Next, а затем Next
2) Выбираете пункт "Enable Test Mode" и нажимаете Next
3) Выбираете пункт "Sign a System File" и нажимаете Next
4) Указываете имя Вашего файла, включая путь к нему и нажимаете Next
Например, если файл драйвера InetLock.sys расположен в каталоге C:\Windows\System32\Drivers, то Вам необходимо указать C:\Windows\System32\Drivers\InetLock.sys. В случае если необходимо подписать несколько файлов, то просто повторите эту процедуру несколько раз.
5) Перезапускаете компьютер
6) Устанавливаете необходимый Вам драйвер и пользуетесь им.

Иногда на рабочем столе возле часов может появиться маленькая надпись, сообщающая версию сборки операционной системы и тот факт, что Вы работаете в тестовом режиме. Для убирания данной надписи воспользуйтесь советом "6. Удаление надписей из правого нижнего угла рабочего стола." из раздела "Тонкие настройки".

Данный режим также как и описанный в предыдущем варианте является штатным методом, предусмотренным Microsoft для тестирования разработчиками новых версий своих драйверов.
Отключить тестовый режим Вы можете просто запустив программу, выбрав пункт "Disable Test Mode" и нажав Next.

Плюсы данных методов в том, что они не изменяют загрузчик системы или какие-либо её системные файлы.

Также Вы можете скачать и установить программу ReadyDriverPlus она добавит небольшое изменение в загрузчик, которое автоматизирует процесс выбора Вами пункта Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) при загрузке.

При правильном указании загрузочной папки Boot, данная программа будет работать у большинства пользователей. В программе ReadyDriverPlus на этапе выбора пути к папке Boot, по умолчанию, указан путь C:\Boot. Так как папка Boot с загрузочными файлами Windows 7 может располагаться не только на диске С:\ , то прежде чем продолжить установку ReadyDriverPlus выясните, где у Вас находится папка Boot.

Папка Boot может располагаться (рекомендации по нахождению):

1) На том же разделе, где у Вас установлена Windows 7

1.1) Откройте Проводник -> Компьютер -> Локальный диск (C:)
1.2) В Панели меню выберите Сервис -> Параметры папок
1.3) Уберите флажок со значения Скрывать защищенные системные файлы
1.4) Установите переключатель в значение Показывать скрытые файлы, папки и диски
1.5) Смотрите в Проводнике, если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

2) На скрытом разделе 100 мегабайт (присвойте ему букву, для его выбора)

2.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
2.2) Введите diskmgmt.msc
2.3) Найдите раздел размером 100 мегабайт. Если у Вас его нет, то читайте о другом месте нахождения папки Boot.
2.4) Так как данный раздел скрыт, то нам для указания его необходимо сделать его видимым. Для этого щелкните на нем правой кнопкой мыши и выберите пункт Изменить букву диска или путь к диску, затем Изменить, назначьте букву(Например: Z) и нажите OK
2.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска, в нашем примере Z:)
2.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

После установки программы ReadyDriverPlus снова пройдите в меню Изменить букву диска или путь к диску, но только выберите пункт Удалить, тем самым Вы сделаете его снова Скрытым

3) На крайнем слева разделе, от того на который установлена Ваша Windows

3.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
3.2) Введите diskmgmt.msc
3.3) Найдите крайний слева раздел, от того на который установлена Ваша Windows
3.4) Если он является активным, то запомните его букву, если он не является активным, то читайте о другом месте нахождения папки Boot.
3.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска)
3.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

4) На другом, являющимся активным разделе жестком диска.

4.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
4.2) Введите diskmgmt.msc
4.3) Найдите раздел жесткого диска являющийся активным
4.4) Запомните его букву
4.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска)
4.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

При установке программы ReadyDriverPlus, на этапе выбора пути к папке Boot, укажите путь к диску, где мы её обнаружили (Например: Z:\Boot или D:\Boot). После установки программы ReadyDriverPlus перезагрузитесь.

В процессе загрузки система даст Вам три секунды для выбора варианта загрузки: обычного или без проверки подписи. Если Вы не будете выбирать обычный режим, то система сама постоянно будет загружать Вас в режим без проверки подписей.

11. Где можно скачать последние обновления для Windows 7?

Компания Microsoft периодически выпускает обновления для Windows 7. Но не все из них включены в Центр обновления Windows (Windows Update) и не все они присутствуют в Каталоге Центра обновления Майкрософт

Все последние версии обновлений, Вы можете скачать:

Без регистрации на сайте: http://kbupdate.info/
Используя регистрацию на форуме http://forum.ru-board.com После регистрации открыть тему Компьютерный форум Ru.Board » Андеграунд » Варезник и отфильтровать по значению Обновления для Microsoft Windows 7.

12. Повышение оценки производительности жесткого диска.

Перед установкой Windows, зайдите в BIOS и укажите режим работы IDE/SATA-контроллера чипсета, как AHCI.

В разных BIOS, опции для настройки режима работы IDE/SATA-контроллера чипсета, могут иметь разные названия. Например:

Configure SATA As
SATA RAID/AHCI Mode
Onboard SATA Type
SATA Controller Mode

Менять режим работы стандартного IDE/SATA-контроллера чипсета необходимо до установки операционной системы.
Если система установлена, простая смена режима в BIOS приведет к появлению «синего экрана смерти».

Для устранения неполадок перед изменением режима SATA загрузочного диска включите драйвер AHCI в реестре. Для этого выполните следующие действия:

1) Закройте все программы Windows.
2) Откройте меню Пуск, в окне Начать поиск введите regedit и нажмите клавишу ВВОД.
3) Если откроется окно Учетные записи пользователей, нажмите кнопку Продолжить.
4) Найдите и выберите один из следующих подразделов реестра:

5) На правой панели щелкните правой кнопкой мыши параметр Start в столбце Имя, затем нажмите Изменить.
6) В поле Значение введите 0 и нажмите кнопку ОК.
7) В меню Файл выберите команду Выход, чтобы закрыть редактор реестра.

13. Автоматическая установка OEM-информации.

Предлагаю Вашему вниманию файл ответов, позволяющий автоматизировать процесс установки Windows путем занесения ответов на вопросы инсталлятора в специальный файл.
Создайте файл Autounattend.xml с указанным ниже текстом и скопируйте данный файл в корневую папку и в папку \Sources установочного диска.

Используемые параметры:

Extend - расширение раздела до размеров всего свободного неразмеченного пространства на диске. Если установлено значение true, раздел будет расширен. Если установлено значение false, необходимо указать размер с помощью параметра Size. Для каждого раздела задается либо значение параметра Extend, либо значение параметра Size, но никак не оба.
Order - порядковый номер операции по созданию раздела на диске. Нумерация начинается с единицы. В примере указано значение 1, т. е. раздел будет создан первым.
Size - размер раздела в мегабайтах.В первый раздел будет установлена Windows 7, поэтому не рекомендуется создавать раздел малого размера.
Type - тип раздела. Можно создать основной (Primary) или дополнительный (Extended) раздел.
Active - назначает раздел активным. Для назначения используется значение true. Так как на основной раздел установится Windows 7, то этот раздел следует назначить активным.
Format - формат файловой системы. Установка Windows 7 возможна только на файловую систему NTFS.
Label - метка тома. Установите по своему усмотрению.
Letter - буква диска. Логично задать для первого раздела букву C.
PartitionID - идентификатор раздела, по сути - его порядковый номер. Нумерация начинается с единицы.
DiskID - идентификатор диска. Значение 0 обозначает первый физический диск
NetworkLocation - задает тип сети, к которой подключается пользователь
WillWipeDisk - удаление всех разделов жесткого диска. Если установлено значение true, все разделы будут удалены.
WillShowUI - отображение интерфейса программы установки. Значение OnError предписывает программе установки отображать интерфейс в случае ошибки.
InputLocale - раскладка клавиатуры.
SystemLocale - язык для программ, не поддерживающих Юникод. Для русской Windows 7 указывается ru-RU, а для английской - en-US.
UILanguage - язык интерфейса операционной системы.
UserLocale - пользовательские параметры отображения чисел, денежных единиц, дат и времени.
Вместо xxxxx-xxxxx-xxxxx-xxxxx-xxxxx введите Ваш ключ.
Для 32-битных систем замените значение processorArchitecture="x64" на processorArchitecture="amd86"

Внимание!!! Предложенный файл ответов в данном совете стирает все разделы и логические диски при установке.

Для редактирования файла Autounattend.xml в графическом режиме воспользуйтесь программой Windows System Image Manager (WSIM), входящей в состав Microsoft Windows AIK.
Если же Вас интересует только, автоматический ввод ключа или OEM-Logo, обратитесь к советам 9 и 14 данного раздела.

14. Автоматическая установка OEM-Logo.

Создайте файл Autounattend.xml с указанным ниже текстом и скопируйте данный файл в корневую папку и в папку \Sources установочного диска.

1) Создайте в папке \Sources установочного диска папки: \$OEM$\$$\SYSTEM32\
2) Скопируйте Ваш файл oemlogo.bmp, содержащий изображение с Вашим логотипом в папку \Sources\$OEM$\$$\System32\oemlogo.bmp установочного диска.
3) Для 64-битных систем замените значение processorArchitecture="x86" на processorArchitecture="amd64"

15. Установка локальных наборов тем и настроек, а также пакетов обновления, предоставленных в виде CAB-файлов.

Чтобы добавить локальный набор тем и настроек в Windows, выполните следующие действия:

1) Найдите локальный набор тем и настроек и скопируйте его в доступное расположение.
2) Запустите командную строку от имени администратора.
2.1) Нажмите кнопку Пуск и в строке поиска введите cmd
2.2) Щелкните правой кнопкой мыши на найденном файле cmd.exe и выберите пункт Запуск от имени администратора
3) В окне командной строки введите следующую команду:

Например, если Вы скопируйте файл Windows-LocalPack-RU-Package.cab в папку «C:\Local Packs», то Вам необходимо будет ввести следующую команду:

Содержимое всех локальных наборов тем и настроек устанавливается в ходе работы программы установки Windows в скрытый каталог "%WINDIR%\globalization\MCT"

Описанным выше способом, можно установить любой пакет обновления, предоставленный в виде CAB-файла.

16. Автоматическая установка обновлений Windows.

Вариант 1. Использование Bat-файла (для MSU и CAB обновлений).

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .bat
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "Update.bat")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

5) Рядом с bat-файлом создайте папки CAB и MSU.
6) Поместите обновления .msu в папку MSU и .cab в папку CAB.
7) Запустите Update.bat и дождитесь закрытия окна командной строки.

Для правильности работы скрипта проверьте у себя соблюдение следующих пунктов:

1) Проверьте разрядность обновлений (х86\х64)
2) В имени файла не должно быть слова EXPRESS, такое обновление копировать бесполезно, оно не установится.
3) Файл Update.bat должен находиться в папке на один уровень выше папок CAB и MSU.

Скачать готовый Update.bat

Вариант 2. Использование программы Windows 7 Update Pack Tool.

Наиболее простым решением для автоматической установки обновлений является программа Windows 7 Update Pack Tool.

Инструкция:

1) Скачайте Windows 7 Update Pack Tool
2) Создайте новую папку. Например: Updates
3) Поместите в неё файл Update.exe
4) Поместите в неё все обновления с расширениями .msu и .cab, которые Вы желаете установить.
5) Создайте внутри Вашей папки Updates папку SpecialUpdates
6) Поместите в папку SpecialUpdates все обновления с расширениями .msi и .exe, которые Вы желаете установить.
7) Запустите файл Update.exe
8) Выберите пункт Install updates. Для этого нажмите на клавиатуре цифру 1 и затем Enter
9) Программа произведет поиск обновлений: .msu и .cab в главной папке, и .msi и .exe в папке SpecialUpdates
10) Нажмите любую клавишу(например: Enter) и программа установит обновления
11) По окончании установки программа напишет список устанавливаемых обновлений и попросит перезагрузки.
12) Перезагрузите компьютер и Вы получите систему с установленными обновлениями.

17. Отключение сообщения "Эта программа, возможно, установлена неправильно".

Если при установке какого-либо приложения Вы решили отменить установку или в случае, когда с приложением были известны какие-либо проблемы совместимости, Windows может отобразить подобное окно:

За данную функцию отвечает "Помощник по совместимости программ". Вы можете отключить его используя следующие варианты:

Вариант 1.

1) В строке поиска меню Пуск или в окне Выполнить (Win+R) введите services.msc и нажмите Enter
2) Щелкните дважды на службу "Служба помощника по совместимости программ" ("Program Compatibility Assistant") или щелкните правой кнопкой мыши на ней и выберите Свойства
3) Измените значение Тип запуска на "Отключено".
4) Нажмите кнопку Остановить ("Stop")

Вариант 2.

1) В строке поиска меню Пуск или в окне Выполнить (Win+R) введите gpedit.msc и нажмите Enter
2) Перейдите в Конфигурация пользователя\Административные шаблоны\Компоненты Windows\Совместимость приложений
3) Щелкните дважды на параметре "Отключение помощника по совместимости программ" или щелкните правой кнопкой мыши на нем и выберите Изменить
4) Выставите значение "Включить".

18. Добавление или замена языка интерфейса в Windows 7 Home или Windows 7 Professional.

На большинстве новых моделей ноутбуков или стационарных компьютеров изначально установлена Windows 7 Home Basic, Windows 7 Home Premium или Windows 7 Professional. Данные версии не поддерживают установку нового языка и его смену, используя стандартные возможности Windows. Если Вам необходимо изменить язык в одной из таких версий Windows 7, то порядок действий следующий.

1) Создайте папку, в которой будут выполняться все промежуточные операции, например C:\Work.
1.1) Откройте Explorer (анг.) или Windows-Explorer (нем.) или Проводник (рус.) и перейдите на диск C:
1.2) Щелкните правой кнопкой мыши и выберите New -> Folder (анг.) или Neu -> Ordner (нем.) или Создать -> Папку (рус.)

2) Создайте папку для языкового файла C:\Lang, куда переложите lp.cab.
Чтобы добыть файл lp.cab из exe-установщика языкового пакета, запустите скаченный exe-файл и когда рядом появится файл lp.cab быстро скопируйте его.

3) Перезагрузите компьютер в Windows Boot Manager (анг.) или Windows-Start-Manager (нем.) или Диспетчер загрузки Windows (рус.), для этого нажмите клавишу F8 после экранов BIOS, но до появления загрузочного экрана системы.
4) В списке установленных систем выберите Windows 7, и еще раз нажмите клавишу F8.
5) В появившемся списке вариантов загрузки Advanced Boot Options (анг.) или Erweiterte Startoptionen (нем.) или Дополнительные варианты загрузки (рус.) выберите первый пункт — Repair Your Computer (анг.) или Computer reparieren (нем.) или Устранение неполадок компьютера (рус.).
6) В списке инструментов выберите командную строку Command Prompt (анг.) или Eingabeaufforderung (нем.) или Командная строка (рус.).
7) Найдите имя диска, где установлена Windows 7. Переходите между дисками, используя C:, D: и т.д. и найдите текущий по содержимому с помощью команды dir.
Для примера предположим, что Вы обнаружили Windows на диске D: . Далее работаем с DISM (Deployment Image Servicing and Management tool).

Далее приводится последовательный алгоритм команд, выполнив которые, вы получите локализованную версию вашей Windows 7.

1) Проверьте список языковых пакетов, установленных в системе.

Параметр /image:d: указывает, что Вы нашли папку Windows и Program files, т.е. установленную Windows 7 на диске D: .
Если в списке пакетов, Вы обнаружили необходимый Вам, содержащий строку 'Client-LanguagePack', то добавлять новый языковой пакет не надо и Вы можете перейти к 3 шагу.
2) Установите новый языковой пакет в систему.

Параметр /scratchdir указывает папку, в которую для обработки будет распаковано содержимое lp.cab.
3) Укажите системе язык, необходимый для использования по умолчанию.

Это может быть любой из установленных в системе языков, например en-US или de-DE.
4) Проверьте установленные языковые параметры:

Если напротив строки Default system UI language: (анг.) или Standardmäßige Benutzeroberflächenschprache des Systems (нем.) или Язык пользовательского интерфейса по умолчанию: (рус.) указан код вашего языка, то закройте окно и перезагрузите компьютер.
5) В Windows 7 запустите командную строку с правами администратора (Нажмите Win+R -> введите cmd -> OK)
6) Смените язык экрана загрузки.

или тот код языка, который нужен.
7) Смените язык менеджера загрузки (вызывается клавишей F8 перед загрузкой Windows)

Внимание: DISM может выдать ошибку доступа в том случае, если вы открывали в командной строке какие-либо папки на разделе с системой. В этом случае сначала верните командную строку в корень этого раздела, выполнив команду cd \ .

19. Проверка установленных версий .NET Framework и установка отсутствующих.

«.NET Framework – всесторонняя и согласованная модель программирования Майкрософт для построения приложений, обладающих превосходным интерфейсом пользователя, прозрачными и безопасными средствами связи, а также возможностью создания разнообразных бизнес-процессов». Платформа .NET Framework используется для разработки и последующего запуска приложений. Если разработчик пишет приложение с использованием одной из версий .NET Framework, то для запуска этого приложения потребуется аналогичная версия .NET Framework на компьютере пользователя.

.NET Framework 1.0 - 1.1

Версия 1.0 практически не используется, в состав ОС не входит.
Версия 1.1 используется редко, в состав ОС не входит. Устанавливать только при необходимости.

Если установка .NET Framework 1.1 и пакета обновления (SP1) завершаться ошибкой, то в ручном режиме данная программа устанавливается так:

1) Создайте на диске С: папку DotNet в корне диска "С" (C:\DotNet).
2) Скачайте в созданную папку Скачать .NET Framework 1.1 Redistributable (dotnetfx.exe) и Service Pack 1 для .NET Framework 1.1 (NDP1.1sp1-KB867460-X86.exe) .
3) Запустите командную строку с правами администратора. (Win+R -> cmd.exe -> OK)
4) Последовательно введите следующие команды и подтвердите выполнение каждой из них клавишей "Enter":

5) Ответьте положительно на вопросы в диалоговых окнах и продолжите ввод команд:

После ввода последней команды начнётся установка. Через несколько минут окна автоматически закроются - установка завершена.

.NET Framework 2.0 - 3.5.1

Версии 2.0 - 3.5.1 являются компонентами Windows 7 (Пуск -> Панель управления -> Программы и компоненты -> Включение и отключение компонентов Windows).

.NET Framework 4.0

Полная версия .NET Framework 4.0 предназначена в первую очередь для разработчиков ПО, клиентский профиль разработан для выполнения клиентских приложений и обеспечения быстрого развёртывания технологий Windows Presentation Foundation (WPF) и Windows Forms. Клиентский профиль распространяется в виде рекомендуемого обновления KB982670.

Скачать .NET Framework 4 (Полная версия)
Скачать .NET Framework 4 (Клиентский профиль)

Проверка наличия установленных версий

Вы можете проверить какие версии .NET Framework установлены в Вашей системе воспользовавшись программой .NET Version Detector

Или открыв ветку системного реестра (Win+R -> regedit -> Ok): HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP

20. Быстрый запуск командной строки из среды предустановки Windows.

Если Вам необходимо быстро воспользоваться окном команд (командной строкой) за пределами основной среды Windows, и у Вас есть установочный DVD или флеш-диск, то Вы можете запустить командную строку сразу из первого окна программы установки Windows. Чтобы выполнить это сделайте следующее:

1) Загрузитесь с установочного DVD или флеш-диска
2) В первом окне нажмите сочетание клавиш Shift+F10.

Откроется окно команд (командная строка) в которой Вы сможете либо ввести необходимую Вам команду, либо запустить необходимую Вам программу.

21. Интегрирование Сервисного Пакета в установочный ISO-образ Windows 7.

Вариант 1. При помощи команды Dism.

1) Создайте папки необходимые для работы (Например, на диске D: папки Temp, SP1, mWim и Mount)
2) Откройте окно команд в папке, где у Вас находится exe-файл сервисного пакета
2.1) Удерживая нажатой клавишу Shift щелкните правой кнопкой мыши на папке в области переходов.
2.2) В контекстном меню выберите пункт Открыть окно команд
3) Распакуйте exe-файл сервисного пакета во временную папку, используя команду:
Для 64-битной версии:

Для 32-битной версии:

4) Закройте окно команд.
5) Откройте в проводнике папку D:\Temp и запустите в ней окно команд как описано в пункте 2.
6) Распакуйте cab-файл KB976932, используя команду:
Для 64-битной версии:

Для 32-битной версии:

7) Закройте окно команд.
8) Откройте в проводнике папку D:\SP1 и запустите в ней окно команд как описано в пункте 2.
9) Распакуйте все cab-файлы языков в папку D:\SP1, поочередно выполнив команды (соглашаясь, если система спросит о перезаписи):

10) После окончания распаковки удалите все cab-файлы языков, используя команду:

11) Распакуйте cab-файл NestedMPPContent.cab в папку D:\SP1, используя команду (соглашаясь, если система спросит о перезаписи):

12) После окончания распаковки удалите cab-файл NestedMPPContent.cab, используя команду:

13) Удалите из папки D:\SP1 файлы cabinet.cablist.ini и old_cabinet.cablist.ini, используя команду:

14) Закройте окно команд.
15) В папке D:\SP1 откройте в любом текстовом редакторе файл update.ses, замените все Absent на Installed и сохраните изменения.
16) В папке D:\SP1 откройте в любом текстовом редакторе файл update.mum, замените allowedOffline="false" на allowedOffline="true" и сохраните изменения.
17) В папке D:\SP1 откройте в любом текстовом редакторе файл Для 64-битной версии: Windows7SP1-KB976933~31bf3856ad364e35~amd64~~6.1.1.17514.mum

или

Для 32-битной версии: Windows7SP1-KB976933~31bf3856ad364e35~x86~~6.1.1.17514.mum, замените allowedOffline="false" на allowedOffline="true" и сохраните изменения.
18) Скопируйте файл install.wim из папки \Sources Вашего установочного ISO-образа в папку D:\mWim
19) Узнаете номер индекса Вашей Windows 7, используя команду:

20) Монтируете файл install.wim в папку D:\Mount учитывая номер индекса (Например, для 64-битной версии Windows 7 Enterprise он равен 1), используя команду:

21) Интегрируете сервисный пакет, используя команду:

22) Демонтируйте образ с сохранением изменений, используя команду:

23) Удалите файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

24) Если Вас устраивает размер получившегося файла install.wim, то замените файл install.wim из папки \Sources Вашего установочного ISO-образа, файлом D:\mWim\install.wim
25) Если Вас не устраивает размер получившегося файла install.wim, то Вы можете осуществить его сжатие.

25.1) Скачайте и установите Windows Automated Installation Kit 2.0 (ссылка) или выше.
25.2) Создайте дополнительную папку необходимую для работы (Например, на диске D: папку Compress)
25.3) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
25.4.1) Если в Вашем install.wim содержится один образ (Например: Windows 7 Enterprise), то введите следующую ниже команду, нажав после ее ввода клавишу Enter:

25.4.2) Если в Вашем install.wim содержится несколько образов (Например: Windows 7 Ultimate), то для создания итогового файла install.wim выполните указанную выше команду для каждого образа, заменяя индекс 1 на соответствующий, и нажимая после ввода каждой из них клавишу Enter.

Например для 32-битной версии Windows 7 Ultimate:

Например для 64-битной версии Windows 7 Ultimate:

26) Замените файл install.wim из папки \Sources Вашего установочного ISO-образа, файлом D:\Compress\install.wim
27) Удалите папки Compress, Mount, mWim, SP1 и Temp.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программой DISM Tool. Данная программа позволяет выполнять, все необходимые Вам команды, используя графический интерфейс. С помощью неё Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(используйте пункт Add Packages).

Вариант 2. Используя программу RT Se7en Lite.

1) Распакуйте ISO-образ установочного диска (в который Вы собираетесь интегрировать сервисный пакет) в любую папку.
2) Скачайте, установите и запустите программу RT Se7en Lite.
3) Нажмите кнопку Browse и выберите пункт Select OS Path.
4) Укажите путь к папке в которую Вы распаковали ISO-образ установочного диска и нажмите ОК.
5) В появившемся окне List of operating system выберите Вашу редакцию Windows 7, установите флажок Slipstream Service Pack и нажмите ОК.
6) В появившемся окне RT Service Pack Slipstream нажмите нопку Browse
7) Укажите путь к exe-файлу сервисного пакета (windows6.1-KB976932-X64.exe или windows6.1-KB976932-X86.exe) и нажмите Открыть.
8) Нажмите кнопку Start и дождитесь завершения.
9) Нажмите кнопку Proceed.
10) В столбце слева нажмите кнопку Task и в открывшемся окне установите флажок ISO Bootable.
11) В столбце слева нажмите кнопку ISO Bootable
12) В ниспадающем меню ----Select a mode---- выберите пункт Create Image
13) В текстовом поле Volume name укажите какое имя для ISO-образа будет использоваться при монтировании.
14) Нажмите кнопку Make ISO для создания ISO-образа установочного диска с интегрированным сервисным пакетом.
15) Введите имя файла и нажмите кнопку Сохранить.

22. Создание установочного образа Windows с двумя видами разрядности (32-битная и 64-битная) в одном iso-образе.
В этом руководстве Вы будете работать с диском D:, но Вы можете выбрать любую букву диска.

Вариант 1. Быстрый и простой способ.

Для создания собственного образа установочного диска Вам потребуется следующее:

Образы:

Windows 7 Ultimate (x86)
Windows 7 Enterprise (x86) (при необходимости)
Windows 7 Ultimate (x64)
Windows 7 Enterprise (x64) (при необходимости)

Программное обеспечение:

Шестнадцатричный редактор (Например: HxD)
Windows Automated Installation Kit 2.0 (ссылка) или выше.

Этап 1: Упорядочивание файлов.

1) Создайте следующие папки:

D:\AIO\DVD
D:\AIO\ISO
D:\AIO\sourc64
D:\AIO\WIMs

2) Извлеките содержимое образа Windows 7 Ultimate (x86) в папку D:\AIO\DVD
3) Удалите все файлы с расширением .clg и файл ei.cfg из папки D:\AIO\DVD\sources, чтобы разблокировать все x86 версии Windows 7.
4) Переместите install.wim из папки D:\AIO\DVD\sources в папку D:\AIO\WIMs
5) Переименуйте файл install.wim в ULTx86.wim
6) Извлеките файл install.wim из образа Windows 7 Ultimate (x64) в папку D:\AIO\WIMs
7) Переименуйте файл install.wim в ULTx64.wim
8) При необходимости извлеките файлы install.wim из образа Windows 7 Enterprise (x86) и Windows 7 Enterprise (x64) в папку D:\AIO\WIMs, и переименуйте их в ENTx86.wim и ENTx64.wim соответственно.
9) Извлеките содержание папки sources (за исключением install.wim, ei.cfg и всех файлов .clg) из образа Windows 7 Ultimate (x64) в папку D:\AIO\DVD\sourc64.
10) Скопируйте файл setup.exe из корня образа Windows 7 Ultimate (x64) в папку D:\AIO\DVD как setup64.exe

Этап 2. Создание Wim.

Теперь Вы должны создать install.wim (файл, который содержит различные версии Windows), путем экспорта имеющихся у Вас в папке D:\AIO\WIMs образов.

1) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
2) Введите нижеследующие команды, нажимая после ввода каждой из них клавишу Enter:

Примечание: Вы можете пропустить команды для Windows 7 Enterprise, если Вы решили их не включать.

Этап 3: Изменение BCD

Здесь Вы измените файл данных конфигурации загрузки BCD, чтобы добавить консоль восстановления для 64-битной Windows.

1) Запустите командную строку с правами администратора.
2) Перейдите к папке D:\AIO\DVD введя нижеследующие команды, нажимая после ввода каждой из них клавишу Enter:

3) Сделайте копию загрузчика по умолчанию, выполнив команду:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

4) Установите новый загрузчик, чтобы загружать 64-битную PE, выполнив команды:

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

5) Установите время ожидания загрузки по умолчанию:

Этап 4. Добавление поддержки обновлений во время установки для 64-битных систем.

Так как добавление данной возможности в двуразрядную сборку Windows предполагает Hex-редактирование файлов, то минусом здесь является поломка цифровой подписи.
Но это является наиболее простым способом решения проблемы с обновлениями.

1) Откройте файл D:\AIO\DVD\setup64.exe в hex-редакторе.
2) Найдите и замените все значения Юникодовой строки (без учета регистра) с sources\ на sourc64\.
Хотя данное действие сломает подпись, но оно не нарушит работоспособность самой программы, так как обе строки имеют одинаковую длину.
3) Откройте файл D:\AIO\DVD\sourc64\autorun.dll и замените все значения Юникодовой строки (без учета регистра) с sources\setup.exe на sourc64\upg64.cmd
4) Cоздайте в папке D:\AIO\DVD\sourc64 файл названный upg64.cmd, содержащих следующее:

Использование командного файла добавит второй небольшой минус, до начала установки на короткое время появится окно команд.

5) Измените содержание файла autorun.inf в папке D:\AIO\DVD на следующее:

Этап 5: Создание ISO-образа (опционально)

1) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
2) Введите нижеследующую команду и нажмите клавишу Enter:

Указанные здесь параметры:

-u2 - создает файловую системы UDF для образа ISO
-l - метка DVD-диска или образа
-t - устанавливает дату и время для создаваемого ISO-образа
-b - указывает на загрузочный файл образа, который используется для создания загрузочного сектора на DVD-диске или образе.
-h - включает в создаваемый образ все скрытые файлы и папки, расположенные по указанному пути
-m - игнорирует ограничение максимального размера образа.

Готовый файл iso-образа: WIN7_AIO_x86-x64.ISO будет находится в папке D:\AIO\ISO.

Вариант 2. Сложный и долгий способ.

Для создания собственного образа установочного диска Вам потребуется следующее:

Образы:

Windows 7 Enterprise (x86)
Windows 7 Enterprise (x64)

Программное обеспечение:

Windows Automated Installation Kit 2.0 (ссылка) или выше.
Архиватор 7-zip
Текстовый редактор с возможностью сохранения в кодировке 866. (Например: AkelPad)

Этап 1: Подготовка к работе.

1) Создайте указанную ниже структуру папок с подпапками:

D:
│
└─AIO
   │
   ├───DVD
   │    │
   │    └───sources
   │           │
   │           ├───x64
   │           │
   │           └───x86
   ├───WIMs
   ├───ISO
   ├───offline
   └───temp
         ├───x64
         └───x86

2) Скопируйте все папки и все файлы, исключая папку sources из iso-образа Windows 7 Enterprise (64) в папку D:\AIO\DVD
3) Скопируйте содержимое папки sources из iso-образа Windows 7 Enterprise (64) в папку D:\AIO\DVD\sources\x64, исключая файлы:

4) Переместите файл install_Windows 7 ENTERPRISE.clg из папки D:\AIO\DVD\sources\x64 в папку D:\AIO\temp\x64
5) Переместите файл install.wim из папки D:\AIO\DVD\sources\x64 в папку D:\AIO\WIMs
6) Переименуйте файл install.wim в папке D:\AIO\WIMs в ENTx64.wim
7) Извлеките файл install_Windows 7 ENTERPRISE.clg из iso-образа Windows 7 Enterprise (x86) в папку D:\AIO\temp\x86
8) Извлеките файл install.wim из iso-образа Windows 7 Enterprise (x86) в папку D:\AIO\WIMs
9) Переименуйте файл install.wim в папке D:\AIO\WIMs в ENTx86.wim

Этап 2. Создание файла install.wim.

Теперь Вы должны создать install.wim (файл, который содержит различные версии Windows), путем экспорта имеющихся у Вас в папке D:\AIO\WIMs образов.

1) Введите нижеследующие команды, нажимая после ввода каждой из них клавишу Enter:

Этап 3. Создание файлов winpe.wim.

1) В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter:

2) Создайте в папке в D:\AIO\temp\x86 командный файл startnet.cmd:
3) Откройте его в AkelPad добавьте в него нижеследующий текст и сохраните в кодировке 866:

4) Создайте в папке в D:\AIO\temp\x64 командный файл startnet.cmd:
5) Откройте его в AkelPad добавьте в него нижеследующий текст и сохраните в кодировке 866:

6) Смонтируйте файл D:\AIO\temp\x86\winpe.wim, выполнив команду:

7) Скопируйте в папку D:\AIO\offline\Windows\system32 файл startnet.cmd из папки D:\AIO\temp\x86 соглашаясь на замену.
8) Скопируйте файл background_cli.bmp из папки D:\AIO\DVD\sources\x86 в папку D:\AIO\offline\Windows\System32
9) Удалите файл winpe.bmp из папки D:\AIO\offline\Windows\System32
10) Переименуйте файл background_cli.bmp в папке D:\AIO\offline\Windows\System32 на winpe.bmp.
11) Скопируйте файл winpe.bmp из папки D:\AIO\offline\Windows\System32 в папку
D:\AIO\offline\Windows\winsxs\x86_microsoft-windows-winpe-background_31bf3856ad364e35_6.1.760X.XXXXX_none_XXXXXXXXXXXXXXXX
(значения вместо X зависят от версии WAIK) соглашаясь на замену.
12) Демонтируйте образ с сохранением.

13) Удалите файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

14) Смонтируйте файл D:\AIO\temp\x64\winpe.wim, выполнив команду:

15) Скопируйте в папку D:\AIO\offline\Windows\system32 файл startnet.cmd из папки D:\AIO\temp\x64 соглашаясь на замену.
16) Скопируйте файл background_cli.bmp из папки D:\AIO\DVD\sources\x64 в папку D:\AIO\offline\Windows\System32
17) Удалите файл winpe.bmp из папки D:\AIO\offline\Windows\System32
18) Переименуйте файл background_cli.bmp в папке D:\AIO\offline\Windows\System32 на winpe.bmp.
19) Скопируйте файл winpe.bmp из папки D:\AIO\offline\Windows\System32 в папку
D:\AIO\offline\Windows\winsxs\amd64_microsoft-windows-winpe-background_31bf3856ad364e35_6.1.760X.XXXXX_none_XXXXXXXXXXXXXXXX
(значения вместо X зависят от версии WAIK) соглашаясь на замену.
20) Демонтируйте образ с сохранением.

21) Удалите файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

22) Экспортируйте образы winpe:

Этап 4. Создание файлов ответов.

1) Запустите из меню Диспетчер образов системы Windows (расположен в папке Microsoft Windows AIK в меню Пуск)
2) Нажмите в главном меню Файл -> Выбрать образ Windows
3) Выберите файл каталога install_Windows 7 ENTERPRISE.clg из папки D:\AIO\temp\x86
4) Нажмите в главном меню Файл -> Новый файл ответов
5) На панели Образ Windows поочередно щелкая правой кнопкой мыши на указанных ниже компонентах, выберите этап конфигурации (пункт Добавление параметра для прохода 1 WindowsPE):

6) На панели Файл отчетов пройдите:

7) На панели Свойства: SetupUILanguage присвойте параметру UILanguage значение ru-RU
8) На панели Файл отчетов пройдите:

9) На панели Свойства: SetupUILanguage присвойте параметру Key значение /IMAGE/INDEX, а параметру Value значение 1
10) На панели Файл отчетов пройдите:

11) На панели Свойства: InstallFrom присвойте параметру Path значение %diskroot%\sources\install.wim
12) Нажмите в главном меню Файл -> Сохранить файл ответов как и сохраните его как D:\AIO\DVD\sources\install-x86.xml
13) Нажмите в главном меню Файл -> Закрыть файл ответов, а затем Закрыть образ Windows

14) Нажмите в главном меню Файл -> Выбрать образ Windows
15) Выберите файл каталога install_Windows 7 ENTERPRISE.clg из папки D:\AIO\temp\x64
16) Нажмите в главном меню Файл -> Новый файл ответов
17) На панели Образ Windows поочередно щелкая правой кнопкой мыши на указанных ниже компонентах, выберите этап конфигурации (пункт Добавление параметра для прохода 1 WindowsPE):

18) На панели Файл отчетов пройдите:

19) На панели Свойства: SetupUILanguage присвойте параметру UILanguage значение ru-RU
20) На панели Файл отчетов пройдите:

21) На панели Свойства: SetupUILanguage присвойте параметру Key значение /IMAGE/INDEX, а параметру Value значение 2
22) На панели Файл отчетов пройдите:

23) На панели Свойства: InstallFrom присвойте параметру Path значение %diskroot%\sources\install.wim
24) Нажмите в главном меню Файл -> Сохранить файл ответов как и сохраните его как D:\AIO\DVD\sources\install-x64.xml
25) Нажмите в главном меню Файл -> Закрыть файл ответов, а затем Закрыть образ Windows

Этап 5: Добавление в загрузочное меню пункты для выбора разрядности установки.

1) Добавьте в загрузочное меню пункт Установка Windows 7 Enterprise (x86).
В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter:

2) Добавьте в загрузочное меню пункт Установка Windows 7 Enterprise (x64).
В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

3) Установите время ожидания загрузки по умолчанию::

Этап 6: Добавление в загрузочное меню пункты для выбора разрядности среды восстановления.

1) Добавьте файлы сред восстановления системы (winre.wim) для каждой разрядности:

1.1) Откройте с помощью программы 7-zip файл install.wim из папки D:\AIO\DVD\sources
1.2) Скопируйте из папки D:\AIO\DVD\sources\install.wim\1\Windows\System32\Recovery в папку D:\AIO\DVD\sources файл winre.wim.
1.3) Переименуйте файл winre.wim из папки D:\AIO\DVD\sources в winre-x86.wim
1.4) Откройте с помощью программы 7-zip файл install.wim из папки D:\AIO\DVD\sources
1.5) Скопируйте из папки D:\AIO\DVD\sources\install.wim\2\Windows\System32\Recovery в папку D:\AIO\DVD\sources файл winre.wim.
1.6) Переименуйте файл winre.wim из папки D:\AIO\DVD\sources в winre-x64.wim

2) Добавьте новые записи в загрузочное меню для среды восстановления Windows x86:
В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

3) Добавьте новые записи в загрузочное меню для среды восстановления Windows x64:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

(Если в D:\AIO\DVD\boot\ появились файлы BCD.LOG, bcd.LOG1, bcd.LOG2 - их можно удалить)

Этап 7: Создание ISO-образа.

1) Скопируйте bcd из папки D:\AIO\DVD\boot в папку D:\AIO\DVD\efi\microsoft\boot заменяя оригинал.
2) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
3) Введите нижеследующую команду и нажмите клавишу Enter:

Указанные здесь параметры:

-u2 - создает файловую системы UDF для образа ISO
-l - метка DVD-диска или образа
-t - устанавливает дату и время для создаваемого ISO-образа
-b - указывает на загрузочный файл образа, который используется для создания загрузочного сектора на DVD-диске или образе.
-h - включает в создаваемый образ все скрытые файлы и папки, расположенные по указанному пути
-m - игнорирует ограничение максимального размера образа.

Готовый файл iso-образа: WIN7_AIO_x86-x64.ISO будет находится в папке D:\AIO\ISO.

23. Прямые ссылки с официального сайта Microsoft для скачивания сервисного Пакета обновлений 1 (SP1) для Windows 7.

Если Вам необходимо скачать сервисный Пакет обновлений 1 (SP1) для Windows 7, то Вы можете сделать это, воспользовавшись указанными ниже прямыми ссылками с сайта Microsoft.

ISO-образ, содержащий Пакеты обновлений 1 (SP1) для обоих разрядностей Windows 7 (x86 и x64):

http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/7601.17514.101119-1850_Update_Sp_Wave1-GRMSP1.1_DVD.iso

Сервисный Пакет обновлений 1 (SP1) для 32-битной версии Windows 7:

http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/windows6.1-KB976932-X86.exe

Сервисный Пакет обновлений 1 (SP1) для 64-битной версии Windows 7:

http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/windows6.1-KB976932-X64.exe

24. Официальные прямые ссылки на языковые пакеты для Windows 7 и Windows 7 SP1.

По указанным ниже ссылкам Вы сможете скачать языковые пакеты для Windows 7 и языковые пакеты для Windows 7 с установленным сервисным Пакетом обновлений 1 (SP1) напрямую с сайта Microsoft.

Чтобы скачать необходимый Вам языковой пакет нажмите на прямую ссылку напротив выбранного Вами языка.
Также Вы можете самостоятельно вручную сделать полную ссылку. Для этого добавьте к имени файла языкового пакета (независимо от разрядности) указанному в колонке Прямая ссылка место расположения файла:

Для Windows 7:

http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/
Например, если имя файла языкового пакета латышского языка для 64-битной версии Windows 7: windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe, то ссылка будет:

http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe

Для Windows 7 SP1:

http://download.windowsupdate.com/msdownload/update/software/updt/2011/02/
Например, если имя файла языкового пакета латышского языка для 32-битной версии Windows 7 SP1: windows6.1-kb2483139-x86-lv-lv_97b58149699a2e8b02bd7cac720ac0795b51c98b.exe, то ссылка будет:

http://download.windowsupdate.com/msdownload/update/software/updt/2011/02/windows6.1-kb2483139-x86-lv-lv_97b58149699a2e8b02bd7cac720ac0795b51c98b.exe

Официальные языковые пакеты (language packs) для 32-bit (x86) Windows 7:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb972813-x86-ar-sa_210ccc96338a1ff683803eb4034e5f53d6d54c97.exe
Bulgarian | Болгарский | windows6.1-kb972813-x86-bg-bg_2e5d91b00775e0f974d4ec213fc20d470ff6850e.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb972813-x86-zh-cn_ab024143b556395e6638e26712b1e0f3bc031fcf.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb972813-x86-zh-hk_90617b75cfaab716a43e7c082b00490a6d475376.exe
Croatian | Хорватский | windows6.1-kb972813-x86-hr-hr_d8a4131aee5d5de039a3a0dc517ca0c07ebc3472.exe
Czech | Чешский | windows6.1-kb972813-x86-cs-cz_2759680ec6e2f4a7629c7d02b1fbce0a0d410a4e.exe
Danish | Датский | windows6.1-kb972813-x86-da-dk_e1c57a4dcbd336ac73e349a9bb9d30de17ac093f.exe
Dutch | Нидерландский | windows6.1-kb972813-x86-nl-nl_194a2ca7b589e77b0be73b822f77760823183c51.exe
English | Английский | windows6.1-kb972813-x86-en-us_22ee3397a02372681b375ddabf6ffa33662fd500.exe
Estonia | Эстонский | windows6.1-kb972813-x86-et-ee_3a99769fac5d6a11e6616297f842a9074c045699.exe
Finnish | Финский | windows6.1-kb972813-x86-fi-fi_dd1973cc63ab7dea0e5d660af06869a8beefe36a.exe
French | Французский | windows6.1-kb972813-x86-fr-fr_1878fd391b990054787a14b0db4a5db00b793bf1.exe
German | Немецкий | windows6.1-kb972813-x86-de-de_1b86ff9b8f4c517dd341d76f24c74399278b05fc.exe
Greek | Греческий | windows6.1-kb972813-x86-el-gr_1f366d5e4fbde7df89b106821236fc1d3b3c9230.exe
Hebrew | Иврит | windows6.1-kb972813-x86-he-il_a3d6a6ae858f33ffa11a14c2a966e6603c134ef9.exe
Hungarian | Венгерский | windows6.1-kb972813-x86-hu-hu_12feb47da4bb28f60b6a30d379044356581c20f8.exe
Italian | Итальянский | windows6.1-kb972813-x86-it-it_079a3afeb88f14d24a3b4204812225e78c2e0bb8.exe
Japanese | Японский | windows6.1-kb972813-x86-ja-jp_08758c23cc64a53949072d53dd7bf6bbc8b45420.exe
Korean | Корейский | windows6.1-kb972813-x86-ko-kr_bb2de1652c37394be4de87438661b129f8b56908.exe
Latvian | Латышский | windows6.1-kb972813-x86-lv-lv_8b7a0b361dd37f7cd3926f798a79a90d378b18b2.exe
Lithuanian | Литовский | windows6.1-kb972813-x86-lt-lt_7aee9ce232cb46701f479fafdb0aea369ce1ad6a.exe
Norwegian | Норвежский | windows6.1-kb972813-x86-nb-no_d65ea89195cf5f7d3170ccb1db7bae3c157f5b24.exe
Polish | Польский | windows6.1-kb972813-x86-pl-pl_9199018040692bc732a590e9b092a18120d326b2.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb972813-x86-pt-br_0a3fe79820d6d199dd43495d4efa5c40f270e45a.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb972813-x86-pt-pt_4165bd9cd083abd8ddd81986e18b1fd86aab5ce9.exe
Romanian | Румынский | windows6.1-kb972813-x86-ro-ro_e1c324236046eb608e478570cf4396776ff02a72.exe
Russian | Русский | windows6.1-kb972813-x86-ru-ru_f4df4bcb8d3194323f17a086a17f46dd0c9c492a.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb972813-x86-sr-latn-cs_6e049bae4d75b82405b28455e2def0a0d0055a9c.exe
Slovak | Словацкий | windows6.1-kb972813-x86-sk-sk_dd2ce36a7e94fceff650cb892b8c954b8af6025a.exe
Slovenian | Словенский | windows6.1-kb972813-x86-sl-si_17786270766d556ba9bf3693762cb98805df9f50.exe
Spanish | Испанский | windows6.1-kb972813-x86-es-es_1943a073d8f00e387301deb22cd177bf77319ee8.exe
Swedish | Шведский | windows6.1-kb972813-x86-sv-se_687085e8bbdf9c17a668b801f28f7f9c74e7a86a.exe
Thai | Тайский | windows6.1-kb972813-x86-th-th_780885dd42c039d9926ac004c76ba3ba9c30c6d0.exe
Turkish | Турецкий | windows6.1-kb972813-x86-tr-tr_13015cb75811f874c83fdd679beb4c22c930a57c.exe
Ukrainian | Украинский | windows6.1-kb972813-x86-uk-ua_0a467bf14bc4f524c18877f570a20c58e91ceba9.exe

Официальные языковые пакеты (language packs) для 64-bit (x64) Windows 7:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb972813-x64-ar-sa_aaac936bd625c12b607dffea19fab8be9cfa28f6.exe
Bulgarian | Болгарский | windows6.1-kb972813-x64-bg-bg_155634f17868659db4b65cfeff57059b2436515f.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb972813-x64-zh-cn_a649e9af1e28514d48bdc51f7956be08060e54bc.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb972813-x64-zh-hk_d428bc1cca4aea20163936e6687221c0e6b99ec4.exe
Croatian | Хорватский | windows6.1-kb972813-x64-hr-hr_06468f799a1c1f295bc3abbc85c14116e2645122.exe
Czech | Чешский | windows6.1-kb972813-x64-cs-cz_f136df3188c54ff234ca77253fee2cf3e91966b7.exe
Danish | Датский | windows6.1-kb972813-x64-da-dk_2b7590d389ca96af6f367408150cb6bc9aa8f4b4.exe
Dutch | Нидерландский | windows6.1-kb972813-x64-nl-nl_2ac14543f6e46c61ae226d7f0f5aee7f4d500e9f.exe
English | Английский | windows6.1-kb972813-x64-en-us_483a3e51038f1a369bc5b5cdf5fc32df3ea4ad27.exe
Estonian | Эстонский | windows6.1-kb972813-x64-et-ee_3c0479d7049109bcb42fd9ec59d1c65449704687.exe
Finnish | Финский | windows6.1-kb972813-x64-fi-fi_4378f72d1233b00e2bdfc680a13f62ae11ab0fcb.exe
French | Французский | windows6.1-kb972813-x64-fr-fr_0e50cd2ea794e4cdfac861b194d2e996b7bbc8d8.exe
German | Немецкий | windows6.1-kb972813-x64-de-de_399ac15b2d55fd5dea0770d98825d7e75f4ad533.exe
Greek | Греческий | windows6.1-kb972813-x64-el-gr_9ae588ba70896f9100a10cb8ed68a79678d6fc32.exe
Hebrew | Иврит | windows6.1-kb972813-x64-he-il_86c22105bb32269c9c0deaf2710fcb1531a29817.exe
Hungarian | Венгерский | windows6.1-kb972813-x64-hu-hu_e5c47bffe398b9ace42d4326de2646a6172d39b5.exe
Italian | Итальянский | windows6.1-kb972813-x64-it-it_3f0f5d78202e074e17a495beec821e1d326a8e2a.exe
Japanese | Японский | windows6.1-kb972813-x64-ja-jp_9d73b1c1270deacbe7a2329559476a94daddb848.exe
Korean | Корейский | windows6.1-kb972813-x64-ko-kr_e6b3322c3865cfd328d84376e192c4f9d41aa0e6.exe
Latvian | Латышский | windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe
Lithuanian | Литовский | windows6.1-kb972813-x64-lt-lt_ede5a878aae2b0d64e81ff739e950b6f105df580.exe
Norwegian | Норвежский | windows6.1-kb972813-x64-nb-no_1b7f93a0906a62eecd6b200979f8df986a7556f1.exe
Polish | Польский | windows6.1-kb972813-x64-pl-pl_6b228326c2f7ef6406242671600b499746ff3454.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb972813-x64-pt-br_276b65f3b6b2657c8fe936f9841dc1243e02dc7b.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb972813-x64-pt-pt_f8310aa4a73841aec29b3f4e74ecaece56b695e9.exe
Romanian | Румынский | windows6.1-kb972813-x64-ro-ro_810f2d590dd5aac92561eea5884ed1c70f34dbd9.exe
Russian | Русский | windows6.1-kb972813-x64-ru-ru_f0acfc688d609ee45d43cc60c6412a3071a665bd.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb972813-x64-sr-latn-cs_275e0a17cbec543aa1bd7eebc883a1d21c11b514.exe
Slovak | Словацкий | windows6.1-kb972813-x64-sk-sk_15f397de2ceaaff8dbfe670bcc6c013791a297c3.exe
Slovenian | Словенский | windows6.1-kb972813-x64-sl-si_8cfc82e0d15ed94634d3da69674008dc56755b93.exe
Spanish | Испанский | windows6.1-kb972813-x64-es-es_2e593c26d9e23ad8176224a53c68a04f996ee014.exe
Swedish | Шведский | windows6.1-kb972813-x64-sv-se_1f4c415e0f4ca77064d597975f6ac7a9e0b8af63.exe
Thai | Тайский | windows6.1-kb972813-x64-th-th_080c8631d44a53c34ffdab8fd73820572dd87be4.exe
Turkish | Турецкий | windows6.1-kb972813-x64-tr-tr_6bd6660158289e0b5d4b5a7f7fded6e3528a9a04.exe
Ukrainian | Украинский | windows6.1-kb972813-x64-uk-ua_c6c4e44c9d903049a4c60fed9d42effa18f345bd.exe

Официальные языковые пакеты (language packs) для 32-bit (x86) Windows 7 SP1:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb2483139-x86-ar-sa_5add6e4a36127029d431ba98d99708c44ef9b53f.exe
Bulgarian | Болгарский | windows6.1-kb2483139-x86-bg-bg_a8a5013e477366119cfdc5fbda43b904755db450.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb2483139-x86-zh-cn_ae61ea226215f96fc95be33201ffc96755ac7eb5.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb2483139-x86-zh-hk_411a6bb68728f12f5ced712d9a33fee9ebe0b0b3.exe
Croatian | Хорватский | windows6.1-kb2483139-x86-hr-hr_685e217ce007af8005db4726087893d04e19dade.exe
Czech | Чешский | windows6.1-kb2483139-x86-cs-cz_bb5061f4bd24437dd31a3714e1b54318ced7e63a.exe
Danish | Датский | windows6.1-kb2483139-x86-da-dk_67fecaab0a940e2e537bc8dcd8a9ebb8ab4ed102.exe
Dutch | Нидерландский | windows6.1-kb2483139-x86-nl-nl_b7e1c3046b218fb45a665ab5f5ed8a5ea8125760.exe
English | Английский | windows6.1-kb2483139-x86-en-us_783d6dd59e2ec8fb0995a059c9c121795bde46c8.exe
Estonian | Эстонский | windows6.1-kb2483139-x86-et-ee_d0f798de315b696bf560b559f6f90064687c0b7b.exe
Finnish | Финский | windows6.1-kb2483139-x86-fi-fi_5259ca6a22a981dbdee352dde5b8e65c2fddd407.exe
French | Французский | windows6.1-kb2483139-x86-fr-fr_f57427487dfc2f49da67cac22480ab1f48983d22.exe
German | Немецкий | windows6.1-kb2483139-x86-de-de_acb9b88b96d432749ab63bd93423af054d23bf81.exe
Greek | Греческий | windows6.1-kb2483139-x86-el-gr_5aeecda7e1d689a083975128901da8156751dfc5.exe
Hebrew | Иврит | windows6.1-kb2483139-x86-he-il_1849d14777a76c7c5b4ef766490dccc8aed5c56b.exe
Hungarian | Венгерский | windows6.1-kb2483139-x86-hu-hu_a7a5af62c59ab7a4e8cb0f21242b42606b95195b.exe
Italian | Итальянский | windows6.1-kb2483139-x86-it-it_1d54a8d0047674fc1b5b6f41292a0074d9fe3cc5.exe
Japanese | Японский | windows6.1-kb2483139-x86-ja-jp_bc46078938ae9129c7ce86a9c176fa517e4c0a3d.exe
Korean | Корейский | windows6.1-kb2483139-x86-ko-kr_18f213428cc6fde96d8c76c6dd91446348e86ce6.exe
Latvian | Латышский | windows6.1-kb2483139-x86-lv-lv_97b58149699a2e8b02bd7cac720ac0795b51c98b.exe
Lithuanian | Литовский | windows6.1-kb2483139-x86-lt-lt_297c5ee6e98ab646b14f1492716b67cc0970fcd8.exe
Norwegian | Норвежский | windows6.1-kb2483139-x86-nb-no_5bd6fc76ad54b7a232d4ceb4a5f5c7c366bf90b6.exe
Polish | Польский | windows6.1-kb2483139-x86-pl-pl_c460a8c1392d7f3d35d1c0b37e56017d3552d245.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb2483139-x86-pt-br_6e1d337b2fd56669d461e82601aa51004fecbd24.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb2483139-x86-pt-pt_5cc92ef98ed177b2f6bbae3a0420ee2f12764fab.exe
Romanian | Румынский | windows6.1-kb2483139-x86-ro-ro_d8d9b2b4c5c457fe6a7dcb09a5f645cfe77cc30c.exe
Russian | Русский | windows6.1-kb2483139-x86-ru-ru_6532a8f36ad7d15277d5d60da92555f0fbee4daa.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb2483139-x86-sr-latn-cs_e3d9acfcc9f608cf7687bd3b5ee7f0d9658b7bc9.exe
Slovak | Словацкий | windows6.1-kb2483139-x86-sk-sk_4c7b17a6cb292b09bede4c8731ad4f24cd09ab2a.exe
Slovenian | Словенский | windows6.1-kb2483139-x86-sl-si_de7f366819e1c12954557e3e65b7c0f059f49b67.exe
Spanish | Испанский | windows6.1-kb2483139-x86-es-es_6aef75f7d83edaabc2a921a6b157cc7005628286.exe
Swedish | Шведский | windows6.1-kb2483139-x86-sv-se_bd65af75e8995bd865d93c8d8c8a35091499083f.exe
Thai | Тайский | windows6.1-kb2483139-x86-th-th_8248f2b209d65a39ddaeb36e1782fcc0f6664f73.exe
Turkish | Турецкий | windows6.1-kb2483139-x86-tr-tr_228dfa5fbaa4606b17f93d6fcd51c8c85c0f1fd3.exe
Ukrainian | Украинский | windows6.1-kb2483139-x86-uk-ua_7f01db99ad2b2d41598bfc71aaa9bd4be04b6369.exe

Официальные языковые пакеты (language packs) для 64-bit (x64) Windows 7 SP1:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb2483139-x64-ar-sa_f07f2cc7b55b17076eebceea2c2c2826b08b8f63.exe
Bulgarian | Болгарский | windows6.1-kb2483139-x64-bg-bg_e4c9392592ed2d4a8c7ec68270b5140430df197a.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb2483139-x64-zh-cn_2c1884b4fdf6c8e91986369d88bbcaae01c6f187.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb2483139-x64-zh-hk_285282b1e2f750eeed91466918443b657968d977.exe
Croatian | Хорватский | windows6.1-kb2483139-x64-hr-hr_e7c6d648436d81466af331ab1ece07dd22be5fda.exe
Czech | Чешский | windows6.1-kb2483139-x64-cs-cz_1ea5b71d701e2480017b464b6560a2987e0d8971.exe
Danish | Датский | windows6.1-kb2483139-x64-da-dk_d753d19cc1a0fe95aef21548193393c04a6a8024.exe
Dutch | Нидерландский | windows6.1-kb2483139-x64-nl-nl_12c90c70d408b08f51f500d6e974878a5d662398.exe
English | Английский | windows6.1-kb2483139-x64-en-us_9b9c8a867baff2920507fbf1e1b4a158572b9b87.exe
Estonian | Эстонский | windows6.1-kb2483139-x64-et-ee_b4fd94f6e461e21b7eec54d1e379e2807861aea2.exe
Finnish | Финский | windows6.1-kb2483139-x64-fi-fi_223465e1b382484d1d82f8f2ccfcd9ed2f902c76.exe
French | Французский | windows6.1-kb2483139-x64-fr-fr_0f18e2a244dd9ff04664112a82776d2bd2177798.exe
German | Немецкий | windows6.1-kb2483139-x64-de-de_4f4ce6bd38530b4a02199172863b21a0cba13773.exe
Greek | Греческий | windows6.1-kb2483139-x64-el-gr_583791fea2fea71725388a746844d5be6488ca45.exe
Hebrew | Иврит | windows6.1-kb2483139-x64-he-il_617029400059f0847d7d90d4da673ae4ed43ebd9.exe
Hungarian | Венгерский | windows6.1-kb2483139-x64-hu-hu_1c298d99baf7af3d830dcd1e2632eeb65d7ee395.exe
Italian | Итальянский | windows6.1-kb2483139-x64-it-it_6d8223c065d6974d833d0eaa162f3ceb7680850f.exe
Japanese | Японский | windows6.1-kb2483139-x64-ja-jp_aeaf7e9b0b6c2173bf757330017a7f655f1f8715.exe
Korean | Корейский | windows6.1-kb2483139-x64-ko-kr_0ea76f748e3d5309d568147ad1337b2664090944.exe
Latvian | Латышский | windows6.1-kb2483139-x64-lv-lv_3919fb044a307144f1fc55cf4313aff45cde9a46.exe
Lithuanian | Литовский | windows6.1-kb2483139-x64-lt-lt_c894f0a591735553ba68f9fb94b1b85133ca922c.exe
Norwegian | Норвежский | windows6.1-kb2483139-x64-nb-no_78df68604970041a6337b4058a3e5339f79e50b4.exe
Polish | Польский | windows6.1-kb2483139-x64-pl-pl_24d00a966a7a75132c3af5627634483d3e2d01e7.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb2483139-x64-pt-br_f8035731c55d774c95c7c673aedfd42d52479294.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb2483139-x64-pt-pt_78485491088298110a3e78b7a5f95e55ff7808df.exe
Romanian | Румынский | windows6.1-kb2483139-x64-ro-ro_6e7a63541f2cb534dab3db719330fee5cfbb4e0f.exe
Russian | Русский | windows6.1-kb2483139-x64-ru-ru_0587eb296a2f04e0d3699650d39b53ee18b97a79.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb2483139-x64-sr-latn-cs_5f487007933585def54c67087895e74e25e699a9.exe
Slovak | Словацкий | windows6.1-kb2483139-x64-sk-sk_f1fb8a395d7d656649830f4f06496a5311ad572a.exe
Slovenian | Словенский | windows6.1-kb2483139-x64-sl-si_84606ed6bc061c72f756bbc061621b490fb761f7.exe
Spanish | Испанский | windows6.1-kb2483139-x64-es-es_fdbdf4061b960324efb9eedf7106df543ed8ce33.exe
Swedish | Шведский | windows6.1-kb2483139-x64-sv-se_81051fe3083afdb4f2d1d23752c587de9bb35025.exe
Thai | Тайский | windows6.1-kb2483139-x64-th-th_dc9c0cc12ae488ed3e8dcaecb4392eef91ec213b.exe
Turkish | Турецкий | windows6.1-kb2483139-x64-tr-tr_07e7e3b34426fe68be813e911d3843b941a268b7.exe
Ukrainian | Украинский | windows6.1-kb2483139-x64-uk-ua_1ca449545a2bcfdeeed6080768186fc29f163504.exe


1. Добавление вручную нового устройства (драйвера).

1) Нажмите кнопку Пуск, введите в строке поиска hdwwiz и нажмите Enter. (Win + R -> hdwwiz -> ОК)
2) В открывшемся окне, нажмите Далее (Next)
3) В следующем окне выберите Установка оборудования, выбранного из списка вручную. (Install the hardware that I manually select from a list) и нажмите Далее (Next)
4) Выберите в списке самую верхнюю строчку Показать все устройства (Show all devices) и нажмите Далее (Next)
5) В следующем окне нажмите на кнопку Установить с диска (Install From Disk), в нижнем правом углу.
6) В открывшемся окне нажмите кнопку Обзор (Browse) и укажите путь к файлу драйвера (inf-файл), затем нажмите ОК, а после Далее (Next)
7) Подтвердите желание установить нажатием Далее (Next)

Назад на страницу раздела Установка.


2. Место сохранения обновлений полученных через Центр обновления Windows (Windows Update).

Все обновления, которые Вы скачиваете или устанавливаете через внутреннюю службу Windows Центр обновления Windows (Windows Update) хранятся в папке: C:\Windows\SoftwareDistribution\Download, а также в подпапках внутри неё. После установки обновлений, Вы можете сохранить их себе на компьютер просто скопировав из папки нужный Вам файл. Файлы содержащие в своем названии -express, могут повторно не установиться. Следовательно Вы можете их и не копировать.

Назад на страницу раздела Установка.


3. Определение неизвестного устройства в Диспетчере устройств.

Узнайте VendorID(VEN) или DeviceID(DEV) устройства.

Данные сведения Вы можете узнать воспользовавшись Диспетчером устройств.
1) Откройте Пуск -> Панель управления -> Диспетчер устройств
2) Нажмите правой кнопкой мыши на необходимом Вам устройстве и выберите пункт Свойства
3) Перейдите на вкладку Сведения и в ниспадающем списке выберите ИД оборудования.
4) Зайдите на сайт: http://www.pcidatabase.com и введите одно из найденных Вами значений.

Если в указанной выше вкладке этого нет посмотрите также в вкладках:

Совместимые ИД
Путь к экземпляру устройства
Родитель
Родственные

там тоже это указывается.

Назад на страницу раздела Установка.


4. Где можно найти драйвера, зная VendorID(VEN) или HardwareID(DEV)?

Здесь

Назад на страницу раздела Установка.


5. Во время инсталяции, после копирования файлов, установщик (сама система) виснет.

Она не висит. Попробуйте выбрать другой монитор в персонализации - параметры дисплея. Это бывает, если у видеокарты два выхода. Такое состояние "зависания" может иметь разное время: от 2-3 минут до 25-30.

Назад на страницу раздела Установка.


6. Установка Windows 7 с USB флеш-накопителя (флешки).

Вариант 1. Используя командную строку.

Подготовка USB флеш-накопителя (флешки) для будущей загрузки и установки Windows 7:

1) Подключаете USB флеш-накопитель (флешку) не менее 4 Гб к USB-порту.
2) В строке поиска меню Пуск вводите cmd.exe, щелкаете на найденном правой кнопкой мыши и нажимаете Запуск от имени администратора
3) Запускате утилиту управления дисками diskpart, дожидаетесь приглашения DISKPART>
4) Выполняете команду list disk (отображает список всех дисков ПК)
5) Ищете среди них Ваш диск USB, в моём примере это Disk 2
6) Выполняете команду select disk # (где # – это номер нашего USB-драйва, полученного в предыдущей команде). Для нашего случая – select disk 2. Данная команда указывает diskpart, что все дальнейшие операции будут проводиться с данным диском.
7) Выполняете команду clean (стирает все данные и разделы на USB диске)
8) Выполняете команду create partition primary (создание нового раздела на диске)
9) Выполняете команду select partition 1 (выбор раздела, как дальнейшего объекта для манипуляций)
10) Выполняете команду active – делаете выбранный раздел активным
11) Выполняете команду format fs=NTFS – форматируете раздел в файловую систему NTFS
12) Выполняете команду assign – активируете процесс подключения устройства, получения букв для созданных разделов (если автостарт опция включена – всплывает окно, как будто вы только что подключили USB-драйв)
13) exit – выходите из diskpart в командную строку.

14) Вставляете имеющийся у Вас дистрибутив Windows 7 в дисковод, или монтируете образ в виртуальный диск.
15) Допустим, что он у Вас установлен в дисковод H:, тогда в командной строке (не в diskpart !!!) выполняете команду:

где I: – буква, полученная только что подготовленным USB-драйвом.
Данная команда подменяет на диске I: файлы загрузчика на те, которые необходимы для загрузки Windows 7.
Битность базовой ОС и дистрибутива Windows должны быть одинаковыми .
16) Копируете все файлы с Вашего дистрибутива на Ваш USB флеш-накопитель (флешку). Используйте для этого либо Windows Explorer, либо команду:

Всё, USB-драйв готов. Загружаете ПК с полученного USB флеш-накопителя.

Для ускорения процесса копирования опытные пользователи могут воспользоваться программой RichCopy, она является графической оболочкой команды robocopy, и включает в себя большое количество настроек. В число многочисленных параметров входят сортировка файлов по атрибутам и папкам, предотвращение ошибок, смена атрибутов, тайминг копирования, редактирование отметки о времени, установка количества потоков и размера используемого кэша.

Вариант 2. Используя программу от Microsoft - Windows 7 USB/DVD Download Tool.

1) Скачайте программу Windows 7 USB/DVD Download Tool
2) Установите и запустите программу.
3) Укажите на первом шаге путь к Вашему ISO-файлу и нажмите кнопку Next.
4) Выберите на втором шаге пункт USB Device
5) Нажмите на третьем шаге кнопку Begin copying
6) На четвертом шаге запустится процесс создания установочного загрузочного флеш-диска.
7) По окончании процесса создания закройте программу.

Вариант 3. Используя программу стороннего произодителя - UltraISO.

1) Вставьте Ваш флеш-диск в USB-порт.
2) Откройте ISO-образ Windows программой UltraISO

Так:

Щелкните на ISO-файле правой кнопкой мыши и выберите пункт Открыть, используя UltraISO

Или так:

В программе UltraISO в меню Файл нажмите на пункт Открыть, выберите нужный Вам образ Windows 7 и нажмите Открыть.

3) Убедившись, что образ открыт - выберите в меню Самозагрузка пункт Записать образ Жесткого диска
4) В списке Disk Drive:, выберите Ваш флеш-накопитель, в пункте Метод записи: USB-HDD+ и нажмите Записать.
5) В появившемся окне об уничтожении информации Подсказка, нажмите кнопку Да. Дождитесь, когда завершится запись (от 5 до 20 минут).
6) Не вынимая флеш-диска из USB-порта перезагрузите компьютер.
7) Сразу после начала перезапуска нажмите на клавиатуре Delete (Del), чтобы попасть в BIOS.
8) В BIOS установите загрузку в первую очередь с USB-HDD.
9) Сохраните настройки и выйдите из BIOS. Компьютер перезапуститься и начнет загрузку с флеш-накопителя.
10) Сама по себе установка мало чем отличается от установки с загрузочного DVD-диска, но есть один момент. Когда завершится копирование и распаковка файлов, и компьютер в первый раз пойдет на перезагрузку, нужно снова идти в BIOS и ставить обратно приоритет загрузки (по умолчанию с жесткого диска) или вытащить флешку. Иначе, возможно, загрузка снова пойдет с флеш-диска.

Назад на страницу раздела Установка.


7. Интеграция языковых пакетов и обновлений в дистрибутив Windows 7.

Вариант 1 вручную с помощью DISM.

Для работы Вам потребуются программа DISM, входящая в состав Windows 7 и программа UltraISO

Внесение изменений в install.Wim (Для добавления языка в систему, которую Вы установите)
1) Создаете на диске D: папки ISO, Lip, Mount и mWim
2) Распаковываете в папку D:\ISO iso-образ Вашего установочного диска.
3) Изменяете текст файла lang.ini в папке D:\ISO\sources на следующий:

4) Копируете файл языкового пакета lp.cab и все файлы обновлений (MSU и CAB) в папку Lip
5) Создаете в папке D:\Lip папку uLip
6) Перемещаете из папки D:\ISO\Sources в папку D:\mWim файл install.wim
7) Запускаете командную строку от имени администратора (Win+R -> cmd -> ОК)
8) Узнаете номер индекса Вашей Windows 7, используя команду:

9) Монтируете файл install.wim в папку D:\Mount учитывая номер индекса Вашей операционной системы (Например, для Windows 7 Enterprise независимо от разрядности он равен 1, для 32-битной версии Windows 7 Ultimate он равен 5, а для 64-битной версии Windows 7 Ultimate он равен 4), используя команду:

10) Интегрируете языковой пакет и обновления:
Для интеграции языкового пакета введите команду:

Для интеграции обновления, используйте команду аналогичную предыдущей, подставляя вместо lp.cab, наименование интегрируемого обновления. Вот пример интеграции произвольного обновления:

11) Применяете все настройки для русского языка командой:

Примеры запуска команд DISM для установки локальных настроек:

12) Демонтируете образ с сохранением изменений:

Демонтаж без сохранения:

13) Удаляете файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

14) Перемещаете файл install.wim из папки D:\mWim в папку D:\ISO\Sources Внесение изменений в Boot.Wim (Для добавления языка в программу установки запускаемую с установочного DVD или флеш-диска при старте компьютера)
1) Распаковываете lp.cab в папку D:\Lip\uLip

2) Очищаете папку D:\Mount (удаляете из нее любые следы, которые могли остаться от работы с файлом install.wim)
3) Перемещаете из папки D:\ISO\Sources в папку D:\mWim файл boot.wim
4) Монтируете файл boot.wim в папку D:\Mount (индекс указываете 2, так как он соответствует программе установки)

5) Добавляете в boot.wim русский язык:

6) Добавляете в boot.wim файлы лицензий:

7) Изменяете текст файла lang.ini в папке D:\Mount\sources на следующий:

8) Демонтируете файл boot.wim с сохранением:

9) Перемещаете файл boot.wim из папки D:\mWim в папку D:\ISO\Sources Работа с папкой будущего образа. 1) Добавляете русский язык, в программу установки запускаемую в среде Windows или с Live-CD:

2) Добавляете файлы лицензий, в программу установки запускаемую в среде Windows или с Live-CD.:

3) Удаляете с диска D: папки Lip, Mount и mWim
4) Используя программу UltraISO создаете iso-образ установочного диска.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программой DISM Tool. Данная программа позволяет выполнять, все необходимые Вам команды, используя графический интерфейс. С помощью неё Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(используйте пункт Add Packages).

Вариант 2. Используя программу RT Se7en Lite.

Данная программа интегрирует языковой пакет только в будущую систему (install.wim). Программа установки (boot.wim) остается на оригинальном языке. 1) Распакуйте ISO-образ установочного диска (в который Вы собираетесь интегрировать сервисный пакет) в любую папку.
2) Скачайте, установите и запустите программу RT Se7en Lite.
3) Нажмите кнопку Browse и выберите пункт Select OS Path.
4) Укажите путь к папке в которую Вы распаковали ISO-образ установочного диска и нажмите ОК.
5) В появившемся окне List of operating system выберите Вашу редакцию Windows 7 и нажмите ОК.
6) В столбце слева нажмите кнопку Task и в открывшемся окне установите флажок Integration.
7) В столбце слева нажмите кнопку Integration.
8) Перейдите на вкладку Language Packs и нажмите кнопку Add.
9) Укажите путь к Вашему cab-файлу языкового пакета и нажмите Открыть.
10) Нажмите кнопку Apply, а затем кнопку Commit.
11) В окне Do you want to enable ISO bootable task? нажмите Да.
12) Нажмите кнопку Finish, а затем кнопку Да.
13) Используя программу UltraISO создаете iso-образ установочного диска.

Вариант 3 с помощью интегратора

1) Скачайте Интегратор обновлений и языковых пакетов Windows 7
2) Запустите его
3) Укажите (выберите) необходимы вам опции.
4) Нажмите на кнопку Выполнить
5) Дождитесь успешного выполнения и увидите результат.

Вариант 4 с помощью командного файла скрипта.

1) Скачайте LPIntegrator.zip
2) Распакуйте скачанный архив в папку
3) Нажмите правой кнопкой мыши на файле LPIntegrator.bat и щелкните на пункте меню Изменить
4) Измените значение параметра set LANG=ru-RU, на язык интегрируемого языкового пакета, где en-US - для английского языка, de-DE - для немецкого языка и т.д.
5) Сохраните изменения и закройте редактирование.
6) Запустите LPIntegrator.bat
7) Выберите версию Вашего образа Windows 7
8) Распакуйте ISO-образ в папку C:\7Work\DVD или скопируйте туда все файлы Вашего инсталляционного диска.
9) Скопируйте языковой пакет, который Вы хотите интегрировать в папку C:\7Work\LP
10) Скопируйте обновления, которые Вы хотите интегрировать в папку C:\7Work\CABS
11) Нажмите любую клавишу(например, Enter) для продолжения.

Назад на страницу раздела Установка.


8. Добавление и использование новых языков интерфейса в Windows.

Для добавления языков интерфейса необходимо установить дополнительные языковые файлы. После установки языковых файлов можно просматривать текст мастеров, диалоговых окон, меню, разделов справки и прочих элементов Windows на другом языке. Существуют 2 варианта добавления новых языков интерфейса: первый - через Центр обновления Windows(Windows Update), а второй - скачав и установив файл языкового пакета вручную. Перед началом работы измените в Панели Управления (Control Panel) способ просмотра(View by), вместо Категория(Category) на Крупные (Large icons) или Мелкие значки(Small icons).

Вариант1. Через Центр обновления Windows(Windows Update)

1) Откройте Центр обновления Windows
Пуск -> Все программы -> Центр обновления Windows (Start -> All Programs -> Windows Update)
или
Панель управления\Все элементы панели управления\Центр обновления Windows (Control Panel\All Control Panel Items\Windows Update)

1a) Также вы можете нажать Win+R, в поле Выполнить ввести указанную ниже комманду и нажать ОК

2) Выберите пункт Необязательных обновлений XX шт. доступны (XX options updates are available)
3) Поставьте флажок напротив нужного Вам языкового пакета (Language Pack) и нажмите ОК

Вариант 2. При наличии файла языка интерфейса lp.cab

1) Заходите в Панель Управления(Control Panel)
2) Открываете Язык и региональные стандарты (Regional and Language)
3) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
4) Нажимаете Установить или удалить язык (Install/uninstall languages...)
4a) Также вы можете нажать Win+R, в поле Выполнить ввести lpksetup и нажать ОК
5) Нажимаете Установить языки интерфейса (Install display languages)
6) Нажимаете кнопку Обзор...(Browse...)
7) Указываете путь к папке с lp.cab и нажимаете ОК
8) Выбираете необходимый Вам язык и нажимаете Далее(Next)

Вариант 3. Установка файла скачанного с сервера Windows Update

Вы можете установить необходимый Вам язык интерфейса, скачав exe-файл по прямой ссылке с сервера Windows Update и просто запустив его.

Смена Вашего языка интерфейса на новый:

1) Заходите в Панель Управления(Control Panel)
1.1) Открываете Язык и региональные стандарты (Regional and Language)
1.1a) Также вы можете нажать Win+R, в поле Выполнить ввести intl.cpl и нажать ОК
1.2) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
2) Выбираете в пункте Выберите язык интерфейса (Choose a display language:) нужный Вам язык и нажимаете ОК
3) Нажимаете кнопку Выйти из системы сейчас (Log off now)
4) В появившемся экране выбираете своего пользователя.
5) В случае необходимости вводите свой пароль и попадаете в Windows на выбранном Вами языке

Назад на страницу раздела Установка.


9. Автоматическое введение ключа при инсталляции Windows.

Создайте файл Autounattend.xml с указанным ниже текстом и скопируйте данный файл в корневую папку и в папку \Sources установочного диска.
Вместо xxxxx-xxxxx-xxxxx-xxxxx-xxxxx введите Ваш ключ.

Вариант 1. Для 32-битных систем.

Если у Вас ключ для Retail или OEM версии, то создайте файл Autounattend.xml следующего содержания:

Если у Вас MAK-ключ, то создайте файл Autounattend.xml следующего содержания:

Вариант 2. Для 64-битных систем.

Если у Вас ключ для Retail или OEM версии, то создайте файл Autounattend.xml следующего содержания:

Если у Вас MAK-ключ, то создайте файл Autounattend.xml следующего содержания:

Назад на страницу раздела Установка.


10. Отключение проверки цифровой подписи драйверов и её добавление в 64-битных Windows 7.

Многие из нас сталкивались с проблемой установки неподписанного драйвера. Например, необходимо поставить драйвер какой-либо программы, но ее драйвер не устанавливается, ибо у него нет цифровой подписи.

В качестве решения Вы можете либо отключить проверку подписи, либо попытаться самостоятельно добавить к нему подпись.

Если Вам необходимо поработать с программой, устанавливающий свой драйвер без перезагрузки системы, то Вы можете загрузиться в специальный режим Windows.
1) Сразу после включения компьютера нажмите F8. Далее Вы попадете либо в меню Дополнительные варианты загрузки, либо в меню выбора диска для загрузки.
2) Вам нужно меню Дополнительные варианты загрузки, поэтому если Вы попали в меню выбора дисков, то выберите диск на котором установлена Ваша Windows и нажмите Enter, а затем быстро нажмите F8 до начала запуска Windows.
3) Выберите пункт Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) и нажмите Enter
Вы загрузитесь в специальный режим Windows, на котором будет только отключена проверка подписи, а все остальные функции будут работать в обычном режиме. После перезагрузки компьютера Вы вернетесь обратно в обычный режим с проверкой драйверов.
Иногда при установке драйвера в этом режиме система может выдать сообщение, что драйвер не подписан, просто закройте его и система нормально установит драйвер.

Чтобы самостоятельно подписать драйвер Вам понадобиться программа Driver Signature Enforcement Overrider(DSEO). Она позволяет создавать свои собственные непроверенные свидетельства. Для нормальной работы программы Контроль учетных записей (User Account Control (UAC)) должен быть выключен.

Скачать:

С официального сайта
С зеркала

1) Запускаете программу и нажимаете Next, а затем Next
2) Выбираете пункт "Enable Test Mode" и нажимаете Next
3) Выбираете пункт "Sign a System File" и нажимаете Next
4) Указываете имя Вашего файла, включая путь к нему и нажимаете Next
Например, если файл драйвера InetLock.sys расположен в каталоге C:\Windows\System32\Drivers, то Вам необходимо указать C:\Windows\System32\Drivers\InetLock.sys. В случае если необходимо подписать несколько файлов, то просто повторите эту процедуру несколько раз.
5) Перезапускаете компьютер
6) Устанавливаете необходимый Вам драйвер и пользуетесь им.

Иногда на рабочем столе возле часов может появиться маленькая надпись, сообщающая версию сборки операционной системы и тот факт, что Вы работаете в тестовом режиме. Для убирания данной надписи воспользуйтесь советом "6. Удаление надписей из правого нижнего угла рабочего стола." из раздела "Тонкие настройки".

Данный режим также как и описанный в предыдущем варианте является штатным методом, предусмотренным Microsoft для тестирования разработчиками новых версий своих драйверов.
Отключить тестовый режим Вы можете просто запустив программу, выбрав пункт "Disable Test Mode" и нажав Next.

Плюсы данных методов в том, что они не изменяют загрузчик системы или какие-либо её системные файлы.

Также Вы можете скачать и установить программу ReadyDriverPlus она добавит небольшое изменение в загрузчик, которое автоматизирует процесс выбора Вами пункта Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) при загрузке.

При правильном указании загрузочной папки Boot, данная программа будет работать у большинства пользователей. В программе ReadyDriverPlus на этапе выбора пути к папке Boot, по умолчанию, указан путь C:\Boot. Так как папка Boot с загрузочными файлами Windows 7 может располагаться не только на диске С:\ , то прежде чем продолжить установку ReadyDriverPlus выясните, где у Вас находится папка Boot.

Папка Boot может располагаться (рекомендации по нахождению):

1) На том же разделе, где у Вас установлена Windows 7

1.1) Откройте Проводник -> Компьютер -> Локальный диск (C:)
1.2) В Панели меню выберите Сервис -> Параметры папок
1.3) Уберите флажок со значения Скрывать защищенные системные файлы
1.4) Установите переключатель в значение Показывать скрытые файлы, папки и диски
1.5) Смотрите в Проводнике, если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

2) На скрытом разделе 100 мегабайт (присвойте ему букву, для его выбора)

2.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
2.2) Введите diskmgmt.msc
2.3) Найдите раздел размером 100 мегабайт. Если у Вас его нет, то читайте о другом месте нахождения папки Boot.
2.4) Так как данный раздел скрыт, то нам для указания его необходимо сделать его видимым. Для этого щелкните на нем правой кнопкой мыши и выберите пункт Изменить букву диска или путь к диску, затем Изменить, назначьте букву(Например: Z) и нажите OK
2.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска, в нашем примере Z:)
2.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

После установки программы ReadyDriverPlus снова пройдите в меню Изменить букву диска или путь к диску, но только выберите пункт Удалить, тем самым Вы сделаете его снова Скрытым

3) На крайнем слева разделе, от того на который установлена Ваша Windows

3.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
3.2) Введите diskmgmt.msc
3.3) Найдите крайний слева раздел, от того на который установлена Ваша Windows
3.4) Если он является активным, то запомните его букву, если он не является активным, то читайте о другом месте нахождения папки Boot.
3.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска)
3.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

4) На другом, являющимся активным разделе жестком диска.

4.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win+R
4.2) Введите diskmgmt.msc
4.3) Найдите раздел жесткого диска являющийся активным
4.4) Запомните его букву
4.5) Откройте Проводник -> Компьютер -> Локальный диск (буква диска)
4.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriverPlus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

При установке программы ReadyDriverPlus, на этапе выбора пути к папке Boot, укажите путь к диску, где мы её обнаружили (Например: Z:\Boot или D:\Boot). После установки программы ReadyDriverPlus перезагрузитесь.

В процессе загрузки система даст Вам три секунды для выбора варианта загрузки: обычного или без проверки подписи. Если Вы не будете выбирать обычный режим, то система сама постоянно будет загружать Вас в режим без проверки подписей.

Назад на страницу раздела Установка.


11. Где можно скачать последние обновления для Windows 7?

Компания Microsoft периодически выпускает обновления для Windows 7. Но не все из них включены в Центр обновления Windows (Windows Update) и не все они присутствуют в Каталоге Центра обновления Майкрософт

Все последние версии обновлений, Вы можете скачать:

Без регистрации на сайте: http://kbupdate.info/
Используя регистрацию на форуме http://forum.ru-board.com После регистрации открыть тему Компьютерный форум Ru.Board » Андеграунд » Варезник и отфильтровать по значению Обновления для Microsoft Windows 7.

Назад на страницу раздела Установка.


12. Повышение оценки производительности жесткого диска.

Перед установкой Windows, зайдите в BIOS и укажите режим работы IDE/SATA-контроллера чипсета, как AHCI.

В разных BIOS, опции для настройки режима работы IDE/SATA-контроллера чипсета, могут иметь разные названия. Например:

Configure SATA As
SATA RAID/AHCI Mode
Onboard SATA Type
SATA Controller Mode

Менять режим работы стандартного IDE/SATA-контроллера чипсета необходимо до установки операционной системы.
Если система установлена, простая смена режима в BIOS приведет к появлению «синего экрана смерти».

Для устранения неполадок перед изменением режима SATA загрузочного диска включите драйвер AHCI в реестре. Для этого выполните следующие действия:

1) Закройте все программы Windows.
2) Откройте меню Пуск, в окне Начать поиск введите regedit и нажмите клавишу ВВОД.
3) Если откроется окно Учетные записи пользователей, нажмите кнопку Продолжить.
4) Найдите и выберите один из следующих подразделов реестра:

5) На правой панели щелкните правой кнопкой мыши параметр Start в столбце Имя, затем нажмите Изменить.
6) В поле Значение введите 0 и нажмите кнопку ОК.
7) В меню Файл выберите команду Выход, чтобы закрыть редактор реестра.

Назад на страницу раздела Установка.


13. Автоматическая установка OEM-информации.

Предлагаю Вашему вниманию файл ответов, позволяющий автоматизировать процесс установки Windows путем занесения ответов на вопросы инсталлятора в специальный файл.
Создайте файл Autounattend.xml с указанным ниже текстом и скопируйте данный файл в корневую папку и в папку \Sources установочного диска.

Используемые параметры:

Extend - расширение раздела до размеров всего свободного неразмеченного пространства на диске. Если установлено значение true, раздел будет расширен. Если установлено значение false, необходимо указать размер с помощью параметра Size. Для каждого раздела задается либо значение параметра Extend, либо значение параметра Size, но никак не оба.
Order - порядковый номер операции по созданию раздела на диске. Нумерация начинается с единицы. В примере указано значение 1, т. е. раздел будет создан первым.
Size - размер раздела в мегабайтах.В первый раздел будет установлена Windows 7, поэтому не рекомендуется создавать раздел малого размера.
Type - тип раздела. Можно создать основной (Primary) или дополнительный (Extended) раздел.
Active - назначает раздел активным. Для назначения используется значение true. Так как на основной раздел установится Windows 7, то этот раздел следует назначить активным.
Format - формат файловой системы. Установка Windows 7 возможна только на файловую систему NTFS.
Label - метка тома. Установите по своему усмотрению.
Letter - буква диска. Логично задать для первого раздела букву C.
PartitionID - идентификатор раздела, по сути - его порядковый номер. Нумерация начинается с единицы.
DiskID - идентификатор диска. Значение 0 обозначает первый физический диск
NetworkLocation - задает тип сети, к которой подключается пользователь
WillWipeDisk - удаление всех разделов жесткого диска. Если установлено значение true, все разделы будут удалены.
WillShowUI - отображение интерфейса программы установки. Значение OnError предписывает программе установки отображать интерфейс в случае ошибки.
InputLocale - раскладка клавиатуры.
SystemLocale - язык для программ, не поддерживающих Юникод. Для русской Windows 7 указывается ru-RU, а для английской - en-US.
UILanguage - язык интерфейса операционной системы.
UserLocale - пользовательские параметры отображения чисел, денежных единиц, дат и времени.
Вместо xxxxx-xxxxx-xxxxx-xxxxx-xxxxx введите Ваш ключ.
Для 32-битных систем замените значение processorArchitecture="x64" на processorArchitecture="amd86"

Внимание!!! Предложенный файл ответов в данном совете стирает все разделы и логические диски при установке.

Для редактирования файла Autounattend.xml в графическом режиме воспользуйтесь программой Windows System Image Manager (WSIM), входящей в состав Microsoft Windows AIK.
Если же Вас интересует только, автоматический ввод ключа или OEM-Logo, обратитесь к советам 9 и 14 данного раздела.

Назад на страницу раздела Установка.


14. Автоматическая установка OEM-Logo.

Создайте файл Autounattend.xml с указанным ниже текстом и скопируйте данный файл в корневую папку и в папку \Sources установочного диска.

1) Создайте в папке \Sources установочного диска папки: \$OEM$\$$\SYSTEM32\
2) Скопируйте Ваш файл oemlogo.bmp, содержащий изображение с Вашим логотипом в папку \Sources\$OEM$\$$\System32\oemlogo.bmp установочного диска.
3) Для 64-битных систем замените значение processorArchitecture="x86" на processorArchitecture="amd64"

Назад на страницу раздела Установка.


15. Установка локальных наборов тем и настроек, а также пакетов обновления, предоставленных в виде CAB-файлов.

Чтобы добавить локальный набор тем и настроек в Windows, выполните следующие действия:

1) Найдите локальный набор тем и настроек и скопируйте его в доступное расположение.
2) Запустите командную строку от имени администратора.
2.1) Нажмите кнопку Пуск и в строке поиска введите cmd
2.2) Щелкните правой кнопкой мыши на найденном файле cmd.exe и выберите пункт Запуск от имени администратора
3) В окне командной строки введите следующую команду:

Например, если Вы скопируйте файл Windows-LocalPack-RU-Package.cab в папку «C:\Local Packs», то Вам необходимо будет ввести следующую команду:

Содержимое всех локальных наборов тем и настроек устанавливается в ходе работы программы установки Windows в скрытый каталог "%WINDIR%\globalization\MCT"

Описанным выше способом, можно установить любой пакет обновления, предоставленный в виде CAB-файла.

Назад на страницу раздела Установка.


16. Автономная установка обновлений Windows.

16. Автоматическая установка обновлений Windows.

Вариант 1. Использование Bat-файла (для MSU и CAB обновлений).

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .bat
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "Update.bat")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

5) Рядом с bat-файлом создайте папки CAB и MSU.
6) Поместите обновления .msu в папку MSU и .cab в папку CAB.
7) Запустите Update.bat и дождитесь закрытия окна командной строки.

Для правильности работы скрипта проверьте у себя соблюдение следующих пунктов:

1) Проверьте разрядность обновлений (х86\х64)
2) В имени файла не должно быть слова EXPRESS, такое обновление копировать бесполезно, оно не установится.
3) Файл Update.bat должен находиться в папке на один уровень выше папок CAB и MSU.

Скачать готовый Update.bat

Вариант 2. Использование программы Windows 7 Update Pack Tool.

Наиболее простым решением для автоматической установки обновлений является программа Windows 7 Update Pack Tool.

Инструкция:

1) Скачайте Windows 7 Update Pack Tool
2) Создайте новую папку. Например: Updates
3) Поместите в неё файл Update.exe
4) Поместите в неё все обновления с расширениями .msu и .cab, которые Вы желаете установить.
5) Создайте внутри Вашей папки Updates папку SpecialUpdates
6) Поместите в папку SpecialUpdates все обновления с расширениями .msi и .exe, которые Вы желаете установить.
7) Запустите файл Update.exe
8) Выберите пункт Install updates. Для этого нажмите на клавиатуре цифру 1 и затем Enter
9) Программа произведет поиск обновлений: .msu и .cab в главной папке, и .msi и .exe в папке SpecialUpdates
10) Нажмите любую клавишу(например: Enter) и программа установит обновления
11) По окончании установки программа напишет список устанавливаемых обновлений и попросит перезагрузки.
12) Перезагрузите компьютер и Вы получите систему с установленными обновлениями.

Назад на страницу раздела Установка.


17. Отключение сообщения "Эта программа, возможно, установлена неправильно".

Если при установке какого-либо приложения Вы решили отменить установку или в случае, когда с приложением были известны какие-либо проблемы совместимости, Windows может отобразить подобное окно:

За данную функцию отвечает "Помощник по совместимости программ". Вы можете отключить его используя следующие варианты:

Вариант 1.

1) В строке поиска меню Пуск или в окне Выполнить (Win+R) введите services.msc и нажмите Enter
2) Щелкните дважды на службу "Служба помощника по совместимости программ" ("Program Compatibility Assistant") или щелкните правой кнопкой мыши на ней и выберите Свойства
3) Измените значение Тип запуска на "Отключено".
4) Нажмите кнопку Остановить ("Stop")

Вариант 2.

1) В строке поиска меню Пуск или в окне Выполнить (Win+R) введите gpedit.msc и нажмите Enter
2) Перейдите в Конфигурация пользователя\Административные шаблоны\Компоненты Windows\Совместимость приложений
3) Щелкните дважды на параметре "Отключение помощника по совместимости программ" или щелкните правой кнопкой мыши на нем и выберите Изменить
4) Выставите значение "Включить".

Назад на страницу раздела Установка.


18. Добавление или замена языка интерфейса в Windows 7 Home или Windows 7 Professional.

На большинстве новых моделей ноутбуков или стационарных компьютеров изначально установлена Windows 7 Home Basic, Windows 7 Home Premium или Windows 7 Professional. Данные версии не поддерживают установку нового языка и его смену, используя стандартные возможности Windows. Если Вам необходимо изменить язык в одной из таких версий Windows 7, то порядок действий следующий.

1) Создайте папку, в которой будут выполняться все промежуточные операции, например C:\Work.
1.1) Откройте Explorer (анг.) или Windows-Explorer (нем.) или Проводник (рус.) и перейдите на диск C:
1.2) Щелкните правой кнопкой мыши и выберите New -> Folder (анг.) или Neu -> Ordner (нем.) или Создать -> Папку (рус.)

2) Создайте папку для языкового файла C:\Lang, куда переложите lp.cab.
Чтобы добыть файл lp.cab из exe-установщика языкового пакета, запустите скаченный exe-файл и когда рядом появится файл lp.cab быстро скопируйте его.

3) Перезагрузите компьютер в Windows Boot Manager (анг.) или Windows-Start-Manager (нем.) или Диспетчер загрузки Windows (рус.), для этого нажмите клавишу F8 после экранов BIOS, но до появления загрузочного экрана системы.
4) В списке установленных систем выберите Windows 7, и еще раз нажмите клавишу F8.
5) В появившемся списке вариантов загрузки Advanced Boot Options (анг.) или Erweiterte Startoptionen (нем.) или Дополнительные варианты загрузки (рус.) выберите первый пункт — Repair Your Computer (анг.) или Computer reparieren (нем.) или Устранение неполадок компьютера (рус.).
6) В списке инструментов выберите командную строку Command Prompt (анг.) или Eingabeaufforderung (нем.) или Командная строка (рус.).
7) Найдите имя диска, где установлена Windows 7. Переходите между дисками, используя C:, D: и т.д. и найдите текущий по содержимому с помощью команды dir.
Для примера предположим, что Вы обнаружили Windows на диске D: . Далее работаем с DISM (Deployment Image Servicing and Management tool).

Далее приводится последовательный алгоритм команд, выполнив которые, вы получите локализованную версию вашей Windows 7.

1) Проверьте список языковых пакетов, установленных в системе.

Параметр /image:d: указывает, что Вы нашли папку Windows и Program files, т.е. установленную Windows 7 на диске D: .
Если в списке пакетов, Вы обнаружили необходимый Вам, содержащий строку 'Client-LanguagePack', то добавлять новый языковой пакет не надо и Вы можете перейти к 3 шагу.
2) Установите новый языковой пакет в систему.

Параметр /scratchdir указывает папку, в которую для обработки будет распаковано содержимое lp.cab.
3) Укажите системе язык, необходимый для использования по умолчанию.

Это может быть любой из установленных в системе языков, например en-US или de-DE.
4) Проверьте установленные языковые параметры:

Если напротив строки Default system UI language: (анг.) или Standardmäßige Benutzeroberflächenschprache des Systems (нем.) или Язык пользовательского интерфейса по умолчанию: (рус.) указан код вашего языка, то закройте окно и перезагрузите компьютер.
5) В Windows 7 запустите командную строку с правами администратора (Нажмите Win+R -> введите cmd -> OK)
6) Смените язык экрана загрузки.

или тот код языка, который нужен.
7) Смените язык менеджера загрузки (вызывается клавишей F8 перед загрузкой Windows)

Внимание: DISM может выдать ошибку доступа в том случае, если вы открывали в командной строке какие-либо папки на разделе с системой. В этом случае сначала верните командную строку в корень этого раздела, выполнив команду cd \ .

Назад на страницу раздела Установка.


19. Проверка установленных версий .NET Framework и установка отсутствующих.

«.NET Framework – всесторонняя и согласованная модель программирования Майкрософт для построения приложений, обладающих превосходным интерфейсом пользователя, прозрачными и безопасными средствами связи, а также возможностью создания разнообразных бизнес-процессов». Платформа .NET Framework используется для разработки и последующего запуска приложений. Если разработчик пишет приложение с использованием одной из версий .NET Framework, то для запуска этого приложения потребуется аналогичная версия .NET Framework на компьютере пользователя.

.NET Framework 1.0 - 1.1

Версия 1.0 практически не используется, в состав ОС не входит.
Версия 1.1 используется редко, в состав ОС не входит. Устанавливать только при необходимости.

Если установка .NET Framework 1.1 и пакета обновления (SP1) завершаться ошибкой, то в ручном режиме данная программа устанавливается так:

1) Создайте на диске С: папку DotNet в корне диска "С" (C:\DotNet).
2) Скачайте в созданную папку Скачать .NET Framework 1.1 Redistributable (dotnetfx.exe) и Service Pack 1 для .NET Framework 1.1 (NDP1.1sp1-KB867460-X86.exe) .
3) Запустите командную строку с правами администратора. (Win+R -> cmd.exe -> OK)
4) Последовательно введите следующие команды и подтвердите выполнение каждой из них клавишей "Enter":

5) Ответьте положительно на вопросы в диалоговых окнах и продолжите ввод команд:

После ввода последней команды начнётся установка. Через несколько минут окна автоматически закроются - установка завершена.

.NET Framework 2.0 - 3.5.1

Версии 2.0 - 3.5.1 являются компонентами Windows 7 (Пуск -> Панель управления -> Программы и компоненты -> Включение и отключение компонентов Windows).

.NET Framework 4.0

Полная версия .NET Framework 4.0 предназначена в первую очередь для разработчиков ПО, клиентский профиль разработан для выполнения клиентских приложений и обеспечения быстрого развёртывания технологий Windows Presentation Foundation (WPF) и Windows Forms. Клиентский профиль распространяется в виде рекомендуемого обновления KB982670.

Скачать .NET Framework 4 (Полная версия)
Скачать .NET Framework 4 (Клиентский профиль)

Проверка наличия установленных версий

Вы можете проверить какие версии .NET Framework установлены в Вашей системе воспользовавшись программой .NET Version Detector

Или открыв ветку системного реестра (Win+R -> regedit -> Ok): HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP

Назад на страницу раздела Установка.


20. Быстрый запуск командной строки из среды предустановки Windows.

Если Вам необходимо быстро воспользоваться окном команд (командной строкой) за пределами основной среды Windows, и у Вас есть установочный DVD или флеш-диск, то Вы можете запустить командную строку сразу из первого окна программы установки Windows. Чтобы выполнить это сделайте следующее:

1) Загрузитесь с установочного DVD или флеш-диска
2) В первом окне нажмите сочетание клавиш Shift+F10.

Откроется окно команд (командная строка) в которой Вы сможете либо ввести необходимую Вам команду, либо запустить необходимую Вам программу.

Назад на страницу раздела Установка.


21. Интегрирование Сервисного Пакета в установочный ISO-образ Windows 7.

Вариант 1. При помощи команды Dism.

1) Создайте папки необходимые для работы (Например, на диске D: папки Temp, SP1, mWim и Mount)
2) Откройте окно команд в папке, где у Вас находится exe-файл сервисного пакета
2.1) Удерживая нажатой клавишу Shift щелкните правой кнопкой мыши на папке в области переходов.
2.2) В контекстном меню выберите пункт Открыть окно команд
3) Распакуйте exe-файл сервисного пакета во временную папку, используя команду:
Для 64-битной версии:

Для 32-битной версии:

4) Закройте окно команд.
5) Откройте в проводнике папку D:\Temp и запустите в ней окно команд как описано в пункте 2.
6) Распакуйте cab-файл KB976932, используя команду:
Для 64-битной версии:

Для 32-битной версии:

7) Закройте окно команд.
8) Откройте в проводнике папку D:\SP1 и запустите в ней окно команд как описано в пункте 2.
9) Распакуйте все cab-файлы языков в папку D:\SP1, поочередно выполнив команды (соглашаясь, если система спросит о перезаписи):

10) После окончания распаковки удалите все cab-файлы языков, используя команду:

11) Распакуйте cab-файл NestedMPPContent.cab в папку D:\SP1, используя команду (соглашаясь, если система спросит о перезаписи):

12) После окончания распаковки удалите cab-файл NestedMPPContent.cab, используя команду:

13) Удалите из папки D:\SP1 файлы cabinet.cablist.ini и old_cabinet.cablist.ini, используя команду:

14) Закройте окно комманд.
15) В папке D:\SP1 откройте в любом текстовом редакторе файл update.ses, замените все Absent на Installed и сохраните изменения.
16) В папке D:\SP1 откройте в любом текстовом редакторе файл update.mum, замените allowedOffline="false" на allowedOffline="true" и сохраните изменения.
17) В папке D:\SP1 откройте в любом текстовом редакторе файл Для 64-битной версии: Windows7SP1-KB976933~31bf3856ad364e35~amd64~~6.1.1.17514.mum

или

Для 32-битной версии: Windows7SP1-KB976933~31bf3856ad364e35~x86~~6.1.1.17514.mum, замените allowedOffline="false" на allowedOffline="true" и сохраните изменения.
18) Скопируйте файл install.wim из папки \Sources Вашего установочного ISO-образа в папку D:\mWim
19) Узнаете номер индекса Вашей Windows 7, используя команду:

20) Монтируете файл install.wim в папку D:\Mount учитывая номер индекса (Например, для 64-битной версии Windows 7 Enterprise он равен 1), используя команду:

21) Интегрируете сервисный пакет, используя команду:

22) Демонтируйте образ с сохранением изменений, используя команду:

23) Удалите файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

24) Если Вас устраивает размер получившегося файла install.wim, то замените файл install.wim из папки \Sources Вашего установочного ISO-образа, файлом D:\mWim\install.wim
25) Если Вас не устраивает размер получившегося файла install.wim, то Вы можете осуществить его сжатие.

25.1) Скачайте и установите Windows Automated Installation Kit 2.0 (ссылка) или выше.
25.2) Создайте дополнительную папку необходимую для работы (Например, на диске D: папку Compress)
25.3) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
25.4.1) Если в Вашем install.wim содержится один образ (Например: Windows 7 Enterprise), то введите следующую ниже команду, нажав после ее ввода клавишу Enter:

25.4.2) Если в Вашем install.wim содержится несколько образов (Например: Windows 7 Ultimate), то для создания итогового файла install.wim выполните указанную выше команду для каждого образа, заменяя индекс 1 на соответствующий, и нажимая после ввода каждой из них клавишу Enter.

Например для 32-битной версии Windows 7 Ultimate:

Например для 64-битной версии Windows 7 Ultimate:

26) Замените файл install.wim из папки \Sources Вашего установочного ISO-образа, файлом D:\Compress\install.wim
27) Удалите папки Compress, Mount, mWim, SP1 и Temp.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программой DISM Tool. Данная программа позволяет выполнять, все необходимые Вам команды, используя графический интерфейс. С помощью неё Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(используйте пункт Add Packages).

Вариант 2. Используя программу RT Se7en Lite.

1) Распакуйте ISO-образ установочного диска (в который Вы собираетесь интегрировать сервисный пакет) в любую папку.
2) Скачайте, установите и запустите программу RT Se7en Lite.
3) Нажмите кнопку Browse и выберите пункт Select OS Path.
4) Укажите путь к папке в которую Вы распаковали ISO-образ установочного диска и нажмите ОК.
5) В появившемся окне List of operating system выберите Вашу редакцию Windows 7, установите флажок Slipstream Service Pack и нажмите ОК.
6) В появившемся окне RT Service Pack Slipstream нажмите нопку Browse
7) Укажите путь к exe-файлу сервисного пакета (windows6.1-KB976932-X64.exe или windows6.1-KB976932-X86.exe) и нажмите Открыть.
8) Нажмите кнопку Start и дождитесь завершения.
9) Нажмите кнопку Proceed.
10) В столбце слева нажмите кнопку Task и в открывшемся окне установите флажок ISO Bootable.
11) В столбце слева нажмите кнопку ISO Bootable
12) В ниспадающем меню ----Select a mode---- выберите пункт Create Image
13) В текстовом поле Volume name укажите какое имя для ISO-образа будет использоваться при монтировании.
14) Нажмите кнопку Make ISO для создания ISO-образа установочного диска с интегрированным сервисным пакетом.
15) Введите имя файла и нажмите кнопку Сохранить.

Назад на страницу раздела Установка.


22. Создание установочного образа Windows с двумя видами разрядности (32-битная и 64-битная) в одном iso-образе.

В этом руководстве Вы будете работать с диском D:, но Вы можете выбрать любую букву диска.

Вариант 1. Быстрый и простой способ.

Для создания собственного образа установочного диска Вам потребуется следующее:

Образы:

Windows 7 Ultimate (x86)
Windows 7 Enterprise (x86) (при необходимости)
Windows 7 Ultimate (x64)
Windows 7 Enterprise (x64) (при необходимости)

Программное обеспечение:

Шестнадцатеричный редактор (Например: HxD)
Windows Automated Installation Kit 2.0 (ссылка) или выше.

Этап 1: Упорядочивание файлов.

1) Создайте следующие папки:

D:\AIO\DVD
D:\AIO\ISO
D:\AIO\sourc64
D:\AIO\WIMs

2) Извлеките содержимое образа Windows 7 Ultimate (x86) в папку D:\AIO\DVD
3) Удалите все файлы с расширением .clg и файл ei.cfg из папки D:\AIO\DVD\sources, чтобы разблокировать все x86 версии Windows 7.
4) Переместите install.wim из папки D:\AIO\DVD\sources в папку D:\AIO\WIMs
5) Переименуйте файл install.wim в ULTx86.wim
6) Извлеките файл install.wim из образа Windows 7 Ultimate (x64) в папку D:\AIO\WIMs
7) Переименуйте файл install.wim в ULTx64.wim
8) При необходимости извлеките файлы install.wim из образа Windows 7 Enterprise (x86) и Windows 7 Enterprise (x64) в папку D:\AIO\WIMs, и переименуйте их в ENTx86.wim и ENTx64.wim соответственно.
9) Извлеките содержание папки sources (за исключением install.wim, ei.cfg и всех файлов .clg) из образа Windows 7 Ultimate (x64) в папку D:\AIO\DVD\sourc64.
10) Скопируйте файл setup.exe из корня образа Windows 7 Ultimate (x64) в папку D:\AIO\DVD как setup64.exe

Этап 2. Создание Wim.

Теперь Вы должны создать install.wim (файл, который содержит различные версии windows), путем экспорта имеющихся у Вас в папке D:\AIO\WIMs образов.

1) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
2) Введите нижеследующие команды, нажимая после ввода каждой из них клавишу Enter:

Примечание: Вы можете пропустить команды для Windows 7 Enterprise, если Вы решили их не включать.

Этап 3: Изменение BCD

Здесь Вы измените файл данных конфигурации загрузки BCD, чтобы добавить консоль восстановления для 64-битной Windows.

1) Запустите командную строку с правами администратора.
2) Перейдите к папке D:\AIO\DVD введя нижеследующие команды, нажимая после ввода каждой из них клавишу Enter:

3) Сделайте копию загрузчика по умолчанию, выполнив команду:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

4) Установите новый загрузчик, чтобы загружать 64-битную PE, выполнив команды:

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

5) Установите время ожидания загрузки по умолчанию:

Этап 4. Добавление поддержки обновлений во время установки для 64-битных систем.

Так как добавление данной возможности в двухразрядную сборку Windows предполагает Hex-редактирование файлов, то минусом здесь является поломка цифровой подписи.
Но это является наиболее простым способом решения проблемы с обновлениями.

1) Откройте файл D:\AIO\DVD\setup64.exe в hex-редакторе.
2) Найдите и замените все значения Юникодовой строки (без учета регистра) с sources\ на sourc64\.
Хотя данное действие сломает подпись, но оно не нарушит работоспособность самой программы, так как обе строки имеют одинаковую длину.
3) Откройте файл D:\AIO\DVD\sourc64\autorun.dll и замените все значения Юникодовой строки (без учета регистра) с sources\setup.exe на sourc64\upg64.cmd
4) Cоздайте в папке D:\AIO\DVD\sourc64 файл названный upg64.cmd, содержащих следующее:

Использование командного файла добавит второй небольшой минус, до начала установки на короткое время появится окно команд.

5) Измените содержание файла autorun.inf в папке D:\AIO\DVD на следующее:

Этап 5: Создание ISO-образа (опционально)

1) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
2) Введите нижеследующую команду и нажмите клавишу Enter:

Указанные здесь параметры:

-u2 - создает файловую системы UDF для образа ISO
-l - метка DVD-диска или образа
-t - устанавливает дату и время для создаваемого ISO-образа
-b - указывает на загрузочный файл образа, который используется для создания загрузочного сектора на DVD-диске или образе.
-h - включает в создаваемый образ все скрытые файлы и папки, расположенные по указанному пути
-m - игнорирует ограничение максимального размера образа.

Готовый файл iso-образа: WIN7_AIO_x86-x64.ISO будет находится в папке D:\AIO\ISO.

Вариант 2. Сложный и долгий способ.

Для создания собственного образа установочного диска Вам потребуется следующее:

Образы:

Windows 7 Enterprise (x86)
Windows 7 Enterprise (x64)

Программное обеспечение:

Windows Automated Installation Kit 2.0 (ссылка) или выше.
Архиватор 7-zip
Текстовый редактор с возможностью сохранения в кодировке 866. (Например: AkelPad)

Этап 1: Подготовка к работе.

1) Создайте указанную ниже структуру папок с подпапками:

D:
│
└─AIO
   │
   ├───DVD
   │    │
   │    └───sources
   │           │
   │           ├───x64
   │           │
   │           └───x86
   ├───WIMs
   ├───ISO
   ├───offline
   └───temp
         ├───x64
         └───x86

2) Скопируйте все папки и все файлы, исключая папку sources из iso-образа Windows 7 Enterprise (64) в папку D:\AIO\DVD
3) Скопируйте содержимое папки sources из iso-образа Windows 7 Enterprise (64) в папку D:\AIO\DVD\sources\x64, исключая файлы:

4) Переместите файл install_Windows 7 ENTERPRISE.clg из папки D:\AIO\DVD\sources\x64 в папку D:\AIO\temp\x64
5) Переместите файл install.wim из папки D:\AIO\DVD\sources\x64 в папку D:\AIO\WIMs
6) Переименуйте файл install.wim в папке D:\AIO\WIMs в ENTx64.wim
7) Извлеките файл install_Windows 7 ENTERPRISE.clg из iso-образа Windows 7 Enterprise (x86) в папку D:\AIO\temp\x86
8) Извлеките файл install.wim из iso-образа Windows 7 Enterprise (x86) в папку D:\AIO\WIMs
9) Переименуйте файл install.wim в папке D:\AIO\WIMs в ENTx86.wim

Этап 2. Создание файла install.wim.

Теперь Вы должны создать install.wim (файл, который содержит различные версии Windows), путем экспорта имеющихся у Вас в папке D:\AIO\WIMs образов.

1) Введите нижеследующие команды, нажимая после ввода каждой из них клавишу Enter:

Этап 3. Создание файлов winpe.wim.

1) В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter:

2) Создайте в папке в D:\AIO\temp\x86 командный файл startnet.cmd:
3) Откройте его в AkelPad добавьте в него нижеследующий текст и сохраните в кодировке 866:

4) Создайте в папке в D:\AIO\temp\x64 командный файл startnet.cmd:
5) Откройте его в AkelPad добавьте в него нижеследующий текст и сохраните в кодировке 866:

6) Смонтируйте файл D:\AIO\temp\x86\winpe.wim, выполнив команду:

7) Скопируйте в папку D:\AIO\offline\Windows\system32 файл startnet.cmd из папки D:\AIO\temp\x86 соглашаясь на замену.
8) Скопируйте файл background_cli.bmp из папки D:\AIO\DVD\sources\x86 в папку D:\AIO\offline\Windows\System32
9) Удалите файл winpe.bmp из папки D:\AIO\offline\Windows\System32
10) Переименуйте файл background_cli.bmp в папке D:\AIO\offline\Windows\System32 на winpe.bmp.
11) Скопируйте файл winpe.bmp из папки D:\AIO\offline\Windows\System32 в папку
D:\AIO\offline\Windows\winsxs\x86_microsoft-windows-winpe-background_31bf3856ad364e35_6.1.760X.XXXXX_none_XXXXXXXXXXXXXXXX
(значения вместо X зависят от версии WAIK) соглашаясь на замену.
12) Демонтируйте образ с сохранением.

13) Удалите файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

14) Смонтируйте файл D:\AIO\temp\x64\winpe.wim, выполнив команду:

15) Скопируйте в папку D:\AIO\offline\Windows\system32 файл startnet.cmd из папки D:\AIO\temp\x64 соглашаясь на замену.
16) Скопируйте файл background_cli.bmp из папки D:\AIO\DVD\sources\x64 в папку D:\AIO\offline\Windows\System32
17) Удалите файл winpe.bmp из папки D:\AIO\offline\Windows\System32
18) Переименуйте файл background_cli.bmp в папке D:\AIO\offline\Windows\System32 на winpe.bmp.
19) Скопируйте файл winpe.bmp из папки D:\AIO\offline\Windows\System32 в папку
D:\AIO\offline\Windows\winsxs\amd64_microsoft-windows-winpe-background_31bf3856ad364e35_6.1.760X.XXXXX_none_XXXXXXXXXXXXXXXX
(значения вместо X зависят от версии WAIK) соглашаясь на замену.
20) Демонтируйте образ с сохранением.

21) Удалите файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

22) Экспортируйте образы winpe:

Этап 4. Создание файлов ответов.

1) Запустите из меню Диспетчер образов системы Windows (расположен в папке Microsoft Windows AIK в меню Пуск)
2) Нажмите в главном меню Файл -> Выбрать образ Windows
3) Выберите файл каталога install_Windows 7 ENTERPRISE.clg из папки D:\AIO\temp\x86
4) Нажмите в главном меню Файл -> Новый файл ответов
5) На панели Образ Windows поочередно щелкая правой кнопкой мыши на указанных ниже компонентах, выберите этап конфигурации (пункт Добавление параметра для прохода 1 WindowsPE):

6) На панели Файл отчетов пройдите:

7) На панели Свойства: SetupUILanguage присвойте параметру UILanguage значение ru-RU
8) На панели Файл отчетов пройдите:

9) На панели Свойства: SetupUILanguage присвойте параметру Key значение /IMAGE/INDEX, а параметру Value значение 1
10) На панели Файл отчетов пройдите:

11) На панели Свойства: InstallFrom присвойте параметру Path значение %diskroot%\sources\install.wim
12) Нажмите в главном меню Файл -> Сохранить файл ответов как и сохраните его как D:\AIO\DVD\sources\install-x86.xml
13) Нажмите в главном меню Файл -> Закрыть файл ответов, а затем Закрыть образ Windows

14) Нажмите в главном меню Файл -> Выбрать образ Windows
15) Выберите файл каталога install_Windows 7 ENTERPRISE.clg из папки D:\AIO\temp\x64
16) Нажмите в главном меню Файл -> Новый файл ответов
17) На панели Образ Windows поочередно щелкая правой кнопкой мыши на указанных ниже компонентах, выберите этап конфигурации (пункт Добавление параметра для прохода 1 WindowsPE):

18) На панели Файл отчетов пройдите:

19) На панели Свойства: SetupUILanguage присвойте параметру UILanguage значение ru-RU
20) На панели Файл отчетов пройдите:

21) На панели Свойства: SetupUILanguage присвойте параметру Key значение /IMAGE/INDEX, а параметру Value значение 2
22) На панели Файл отчетов пройдите:

23) На панели Свойства: InstallFrom присвойте параметру Path значение %diskroot%\sources\install.wim
24) Нажмите в главном меню Файл -> Сохранить файл ответов как и сохраните его как D:\AIO\DVD\sources\install-x64.xml
25) Нажмите в главном меню Файл -> Закрыть файл ответов, а затем Закрыть образ Windows

Этап 5: Добавление в загрузочное меню пункты для выбора разрядности установки.

1) Добавьте в загрузочное меню пункт Установка Windows 7 Enterprise (x86).
В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter:

2) Добавьте в загрузочное меню пункт Установка Windows 7 Enterprise (x64).
В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

3) Установите время ожидания загрузки по умолчанию::

Этап 6: Добавление в загрузочное меню пункты для выбора разрядности среды восстановления.

1) Добавьте файлы сред восстановления системы (winre.wim) для каждой разрядности:

1.1) Откройте с помощью программы 7-zip файл install.wim из папки D:\AIO\DVD\sources
1.2) Скопируйте из папки D:\AIO\DVD\sources\install.wim\1\Windows\System32\Recovery в папку D:\AIO\DVD\sources файл winre.wim.
1.3) Переименуйте файл winre.wim из папки D:\AIO\DVD\sources в winre-x86.wim
1.4) Откройте с помощью программы 7-zip файл install.wim из папки D:\AIO\DVD\sources
1.5) Скопируйте из папки D:\AIO\DVD\sources\install.wim\2\Windows\System32\Recovery в папку D:\AIO\DVD\sources файл winre.wim.
1.6) Переименуйте файл winre.wim из папки D:\AIO\DVD\sources в winre-x64.wim

2) Добавьте новые записи в загрузочное меню для среды восстановления Windows x86:
В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

3) Добавьте новые записи в загрузочное меню для среды восстановления Windows x64:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

(Если в D:\AIO\DVD\boot\ появились файлы BCD.LOG, bcd.LOG1, bcd.LOG2 - их можно удалить)

Этап 7: Создание ISO-образа.

1) Скопируйте bcd из папки D:\AIO\DVD\boot в папку D:\AIO\DVD\efi\microsoft\boot заменяя оригинал.
2) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
3) Введите нижеследующую команду и нажмите клавишу Enter:

Указанные здесь параметры:

-u2 - создает файловую системы UDF для образа ISO
-l - метка DVD-диска или образа
-t - устанавливает дату и время для создаваемого ISO-образа
-b - указывает на загрузочный файл образа, который используется для создания загрузочного сектора на DVD-диске или образе.
-h - включает в создаваемый образ все скрытые файлы и папки, расположенные по указанному пути
-m - игнорирует ограничение максимального размера образа.

Готовый файл iso-образа: WIN7_AIO_x86-x64.ISO будет находится в папке D:\AIO\ISO.

Назад на страницу раздела Установка.


23. Прямые ссылки с официального сайта Microsoft для скачивания сервисного Пакета обновлений 1 (SP1) для Windows 7.

Если Вам необходимо скачать сервисный Пакет обновлений 1 (SP1) для Windows 7, то Вы можете сделать это, воспользовавшись указанными ниже прямыми ссылками с сайта Microsoft.

ISO-образ, содержащий Пакеты обновлений 1 (SP1) для обоих разрядностей Windows 7 (x86 и x64):

http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/7601.17514.101119-1850_Update_Sp_Wave1-GRMSP1.1_DVD.iso

Сервисный Пакет обновлений 1 (SP1) для 32-битной версии Windows 7:

http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/windows6.1-KB976932-X86.exe

Сервисный Пакет обновлений 1 (SP1) для 64-битной версии Windows 7:

http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/windows6.1-KB976932-X64.exe

Назад на страницу раздела Установка.


24. Официальные прямые ссылки на языковые пакеты для Windows 7 и Windows 7 SP1.

По указанным ниже ссылкам Вы сможете скачать языковые пакеты для Windows 7 и языковые пакеты для Windows 7 с установленным сервисным Пакетом обновлений 1 (SP1) напрямую с сайта Microsoft.

Чтобы скачать необходимый Вам языковой пакет нажмите на прямую ссылку напротив выбранного Вами языка.
Также Вы можете самостоятельно вручную сделать полную ссылку. Для этого добавьте к имени файла языкового пакета (независимо от разрядности) указанному в колонке Прямая ссылка место расположения файла:

Для Windows 7:

http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/
Например, если имя файла языкового пакета латышского языка для 64-битной версии Windows 7: windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe, то ссылка будет:

http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe

Для Windows 7 SP1:

http://download.windowsupdate.com/msdownload/update/software/updt/2011/02/
Например, если имя файла языкового пакета латышского языка для 32-битной версии Windows 7 SP1: windows6.1-kb2483139-x86-lv-lv_97b58149699a2e8b02bd7cac720ac0795b51c98b.exe, то ссылка будет:

http://download.windowsupdate.com/msdownload/update/software/updt/2011/02/windows6.1-kb2483139-x86-lv-lv_97b58149699a2e8b02bd7cac720ac0795b51c98b.exe

Официальные языковые пакеты (language packs) для 32-bit (x86) Windows 7:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb972813-x86-ar-sa_210ccc96338a1ff683803eb4034e5f53d6d54c97.exe
Bulgarian | Болгарский | windows6.1-kb972813-x86-bg-bg_2e5d91b00775e0f974d4ec213fc20d470ff6850e.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb972813-x86-zh-cn_ab024143b556395e6638e26712b1e0f3bc031fcf.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb972813-x86-zh-hk_90617b75cfaab716a43e7c082b00490a6d475376.exe
Croatian | Хорватский | windows6.1-kb972813-x86-hr-hr_d8a4131aee5d5de039a3a0dc517ca0c07ebc3472.exe
Czech | Чешский | windows6.1-kb972813-x86-cs-cz_2759680ec6e2f4a7629c7d02b1fbce0a0d410a4e.exe
Danish | Датский | windows6.1-kb972813-x86-da-dk_e1c57a4dcbd336ac73e349a9bb9d30de17ac093f.exe
Dutch | Нидерландский | windows6.1-kb972813-x86-nl-nl_194a2ca7b589e77b0be73b822f77760823183c51.exe
English | Английский | windows6.1-kb972813-x86-en-us_22ee3397a02372681b375ddabf6ffa33662fd500.exe
Estonia | Эстонский | windows6.1-kb972813-x86-et-ee_3a99769fac5d6a11e6616297f842a9074c045699.exe
Finnish | Финский | windows6.1-kb972813-x86-fi-fi_dd1973cc63ab7dea0e5d660af06869a8beefe36a.exe
French | Французский | windows6.1-kb972813-x86-fr-fr_1878fd391b990054787a14b0db4a5db00b793bf1.exe
German | Немецкий | windows6.1-kb972813-x86-de-de_1b86ff9b8f4c517dd341d76f24c74399278b05fc.exe
Greek | Греческий | windows6.1-kb972813-x86-el-gr_1f366d5e4fbde7df89b106821236fc1d3b3c9230.exe
Hebrew | Иврит | windows6.1-kb972813-x86-he-il_a3d6a6ae858f33ffa11a14c2a966e6603c134ef9.exe
Hungarian | Венгерский | windows6.1-kb972813-x86-hu-hu_12feb47da4bb28f60b6a30d379044356581c20f8.exe
Italian | Итальянский | windows6.1-kb972813-x86-it-it_079a3afeb88f14d24a3b4204812225e78c2e0bb8.exe
Japanese | Японский | windows6.1-kb972813-x86-ja-jp_08758c23cc64a53949072d53dd7bf6bbc8b45420.exe
Korean | Корейский | windows6.1-kb972813-x86-ko-kr_bb2de1652c37394be4de87438661b129f8b56908.exe
Latvian | Латышский | windows6.1-kb972813-x86-lv-lv_8b7a0b361dd37f7cd3926f798a79a90d378b18b2.exe
Lithuanian | Литовский | windows6.1-kb972813-x86-lt-lt_7aee9ce232cb46701f479fafdb0aea369ce1ad6a.exe
Norwegian | Норвежский | windows6.1-kb972813-x86-nb-no_d65ea89195cf5f7d3170ccb1db7bae3c157f5b24.exe
Polish | Польский | windows6.1-kb972813-x86-pl-pl_9199018040692bc732a590e9b092a18120d326b2.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb972813-x86-pt-br_0a3fe79820d6d199dd43495d4efa5c40f270e45a.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb972813-x86-pt-pt_4165bd9cd083abd8ddd81986e18b1fd86aab5ce9.exe
Romanian | Румынский | windows6.1-kb972813-x86-ro-ro_e1c324236046eb608e478570cf4396776ff02a72.exe
Russian | Русский | windows6.1-kb972813-x86-ru-ru_f4df4bcb8d3194323f17a086a17f46dd0c9c492a.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb972813-x86-sr-latn-cs_6e049bae4d75b82405b28455e2def0a0d0055a9c.exe
Slovak | Словацкий | windows6.1-kb972813-x86-sk-sk_dd2ce36a7e94fceff650cb892b8c954b8af6025a.exe
Slovenian | Словенский | windows6.1-kb972813-x86-sl-si_17786270766d556ba9bf3693762cb98805df9f50.exe
Spanish | Испанский | windows6.1-kb972813-x86-es-es_1943a073d8f00e387301deb22cd177bf77319ee8.exe
Swedish | Шведский | windows6.1-kb972813-x86-sv-se_687085e8bbdf9c17a668b801f28f7f9c74e7a86a.exe
Thai | Тайский | windows6.1-kb972813-x86-th-th_780885dd42c039d9926ac004c76ba3ba9c30c6d0.exe
Turkish | Турецкий | windows6.1-kb972813-x86-tr-tr_13015cb75811f874c83fdd679beb4c22c930a57c.exe
Ukrainian | Украинский | windows6.1-kb972813-x86-uk-ua_0a467bf14bc4f524c18877f570a20c58e91ceba9.exe

Официальные языковые пакеты (language packs) для 64-bit (x64) Windows 7:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb972813-x64-ar-sa_aaac936bd625c12b607dffea19fab8be9cfa28f6.exe
Bulgarian | Болгарский | windows6.1-kb972813-x64-bg-bg_155634f17868659db4b65cfeff57059b2436515f.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb972813-x64-zh-cn_a649e9af1e28514d48bdc51f7956be08060e54bc.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb972813-x64-zh-hk_d428bc1cca4aea20163936e6687221c0e6b99ec4.exe
Croatian | Хорватский | windows6.1-kb972813-x64-hr-hr_06468f799a1c1f295bc3abbc85c14116e2645122.exe
Czech | Чешский | windows6.1-kb972813-x64-cs-cz_f136df3188c54ff234ca77253fee2cf3e91966b7.exe
Danish | Датский | windows6.1-kb972813-x64-da-dk_2b7590d389ca96af6f367408150cb6bc9aa8f4b4.exe
Dutch | Нидерландский | windows6.1-kb972813-x64-nl-nl_2ac14543f6e46c61ae226d7f0f5aee7f4d500e9f.exe
English | Английский | windows6.1-kb972813-x64-en-us_483a3e51038f1a369bc5b5cdf5fc32df3ea4ad27.exe
Estonian | Эстонский | windows6.1-kb972813-x64-et-ee_3c0479d7049109bcb42fd9ec59d1c65449704687.exe
Finnish | Финский | windows6.1-kb972813-x64-fi-fi_4378f72d1233b00e2bdfc680a13f62ae11ab0fcb.exe
French | Французский | windows6.1-kb972813-x64-fr-fr_0e50cd2ea794e4cdfac861b194d2e996b7bbc8d8.exe
German | Немецкий | windows6.1-kb972813-x64-de-de_399ac15b2d55fd5dea0770d98825d7e75f4ad533.exe
Greek | Греческий | windows6.1-kb972813-x64-el-gr_9ae588ba70896f9100a10cb8ed68a79678d6fc32.exe
Hebrew | Иврит | windows6.1-kb972813-x64-he-il_86c22105bb32269c9c0deaf2710fcb1531a29817.exe
Hungarian | Венгерский | windows6.1-kb972813-x64-hu-hu_e5c47bffe398b9ace42d4326de2646a6172d39b5.exe
Italian | Итальянский | windows6.1-kb972813-x64-it-it_3f0f5d78202e074e17a495beec821e1d326a8e2a.exe
Japanese | Японский | windows6.1-kb972813-x64-ja-jp_9d73b1c1270deacbe7a2329559476a94daddb848.exe
Korean | Корейский | windows6.1-kb972813-x64-ko-kr_e6b3322c3865cfd328d84376e192c4f9d41aa0e6.exe
Latvian | Латышский | windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe
Lithuanian | Литовский | windows6.1-kb972813-x64-lt-lt_ede5a878aae2b0d64e81ff739e950b6f105df580.exe
Norwegian | Норвежский | windows6.1-kb972813-x64-nb-no_1b7f93a0906a62eecd6b200979f8df986a7556f1.exe
Polish | Польский | windows6.1-kb972813-x64-pl-pl_6b228326c2f7ef6406242671600b499746ff3454.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb972813-x64-pt-br_276b65f3b6b2657c8fe936f9841dc1243e02dc7b.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb972813-x64-pt-pt_f8310aa4a73841aec29b3f4e74ecaece56b695e9.exe
Romanian | Румынский | windows6.1-kb972813-x64-ro-ro_810f2d590dd5aac92561eea5884ed1c70f34dbd9.exe
Russian | Русский | windows6.1-kb972813-x64-ru-ru_f0acfc688d609ee45d43cc60c6412a3071a665bd.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb972813-x64-sr-latn-cs_275e0a17cbec543aa1bd7eebc883a1d21c11b514.exe
Slovak | Словацкий | windows6.1-kb972813-x64-sk-sk_15f397de2ceaaff8dbfe670bcc6c013791a297c3.exe
Slovenian | Словенский | windows6.1-kb972813-x64-sl-si_8cfc82e0d15ed94634d3da69674008dc56755b93.exe
Spanish | Испанский | windows6.1-kb972813-x64-es-es_2e593c26d9e23ad8176224a53c68a04f996ee014.exe
Swedish | Шведский | windows6.1-kb972813-x64-sv-se_1f4c415e0f4ca77064d597975f6ac7a9e0b8af63.exe
Thai | Тайский | windows6.1-kb972813-x64-th-th_080c8631d44a53c34ffdab8fd73820572dd87be4.exe
Turkish | Турецкий | windows6.1-kb972813-x64-tr-tr_6bd6660158289e0b5d4b5a7f7fded6e3528a9a04.exe
Ukrainian | Украинский | windows6.1-kb972813-x64-uk-ua_c6c4e44c9d903049a4c60fed9d42effa18f345bd.exe

Официальные языковые пакеты (language packs) для 32-bit (x86) Windows 7 SP1:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb2483139-x86-ar-sa_5add6e4a36127029d431ba98d99708c44ef9b53f.exe
Bulgarian | Болгарский | windows6.1-kb2483139-x86-bg-bg_a8a5013e477366119cfdc5fbda43b904755db450.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb2483139-x86-zh-cn_ae61ea226215f96fc95be33201ffc96755ac7eb5.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb2483139-x86-zh-hk_411a6bb68728f12f5ced712d9a33fee9ebe0b0b3.exe
Croatian | Хорватский | windows6.1-kb2483139-x86-hr-hr_685e217ce007af8005db4726087893d04e19dade.exe
Czech | Чешский | windows6.1-kb2483139-x86-cs-cz_bb5061f4bd24437dd31a3714e1b54318ced7e63a.exe
Danish | Датский | windows6.1-kb2483139-x86-da-dk_67fecaab0a940e2e537bc8dcd8a9ebb8ab4ed102.exe
Dutch | Нидерландский | windows6.1-kb2483139-x86-nl-nl_b7e1c3046b218fb45a665ab5f5ed8a5ea8125760.exe
English | Английский | windows6.1-kb2483139-x86-en-us_783d6dd59e2ec8fb0995a059c9c121795bde46c8.exe
Estonian | Эстонский | windows6.1-kb2483139-x86-et-ee_d0f798de315b696bf560b559f6f90064687c0b7b.exe
Finnish | Финский | windows6.1-kb2483139-x86-fi-fi_5259ca6a22a981dbdee352dde5b8e65c2fddd407.exe
French | Французский | windows6.1-kb2483139-x86-fr-fr_f57427487dfc2f49da67cac22480ab1f48983d22.exe
German | Немецкий | windows6.1-kb2483139-x86-de-de_acb9b88b96d432749ab63bd93423af054d23bf81.exe
Greek | Греческий | windows6.1-kb2483139-x86-el-gr_5aeecda7e1d689a083975128901da8156751dfc5.exe
Hebrew | Иврит | windows6.1-kb2483139-x86-he-il_1849d14777a76c7c5b4ef766490dccc8aed5c56b.exe
Hungarian | Венгерский | windows6.1-kb2483139-x86-hu-hu_a7a5af62c59ab7a4e8cb0f21242b42606b95195b.exe
Italian | Итальянский | windows6.1-kb2483139-x86-it-it_1d54a8d0047674fc1b5b6f41292a0074d9fe3cc5.exe
Japanese | Японский | windows6.1-kb2483139-x86-ja-jp_bc46078938ae9129c7ce86a9c176fa517e4c0a3d.exe
Korean | Корейский | windows6.1-kb2483139-x86-ko-kr_18f213428cc6fde96d8c76c6dd91446348e86ce6.exe
Latvian | Латышский | windows6.1-kb2483139-x86-lv-lv_97b58149699a2e8b02bd7cac720ac0795b51c98b.exe
Lithuanian | Литовский | windows6.1-kb2483139-x86-lt-lt_297c5ee6e98ab646b14f1492716b67cc0970fcd8.exe
Norwegian | Норвежский | windows6.1-kb2483139-x86-nb-no_5bd6fc76ad54b7a232d4ceb4a5f5c7c366bf90b6.exe
Polish | Польский | windows6.1-kb2483139-x86-pl-pl_c460a8c1392d7f3d35d1c0b37e56017d3552d245.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb2483139-x86-pt-br_6e1d337b2fd56669d461e82601aa51004fecbd24.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb2483139-x86-pt-pt_5cc92ef98ed177b2f6bbae3a0420ee2f12764fab.exe
Romanian | Румынский | windows6.1-kb2483139-x86-ro-ro_d8d9b2b4c5c457fe6a7dcb09a5f645cfe77cc30c.exe
Russian | Русский | windows6.1-kb2483139-x86-ru-ru_6532a8f36ad7d15277d5d60da92555f0fbee4daa.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb2483139-x86-sr-latn-cs_e3d9acfcc9f608cf7687bd3b5ee7f0d9658b7bc9.exe
Slovak | Словацкий | windows6.1-kb2483139-x86-sk-sk_4c7b17a6cb292b09bede4c8731ad4f24cd09ab2a.exe
Slovenian | Словенский | windows6.1-kb2483139-x86-sl-si_de7f366819e1c12954557e3e65b7c0f059f49b67.exe
Spanish | Испанский | windows6.1-kb2483139-x86-es-es_6aef75f7d83edaabc2a921a6b157cc7005628286.exe
Swedish | Шведский | windows6.1-kb2483139-x86-sv-se_bd65af75e8995bd865d93c8d8c8a35091499083f.exe
Thai | Тайский | windows6.1-kb2483139-x86-th-th_8248f2b209d65a39ddaeb36e1782fcc0f6664f73.exe
Turkish | Турецкий | windows6.1-kb2483139-x86-tr-tr_228dfa5fbaa4606b17f93d6fcd51c8c85c0f1fd3.exe
Ukrainian | Украинский | windows6.1-kb2483139-x86-uk-ua_7f01db99ad2b2d41598bfc71aaa9bd4be04b6369.exe

Официальные языковые пакеты (language packs) для 64-bit (x64) Windows 7 SP1:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb2483139-x64-ar-sa_f07f2cc7b55b17076eebceea2c2c2826b08b8f63.exe
Bulgarian | Болгарский | windows6.1-kb2483139-x64-bg-bg_e4c9392592ed2d4a8c7ec68270b5140430df197a.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb2483139-x64-zh-cn_2c1884b4fdf6c8e91986369d88bbcaae01c6f187.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb2483139-x64-zh-hk_285282b1e2f750eeed91466918443b657968d977.exe
Croatian | Хорватский | windows6.1-kb2483139-x64-hr-hr_e7c6d648436d81466af331ab1ece07dd22be5fda.exe
Czech | Чешский | windows6.1-kb2483139-x64-cs-cz_1ea5b71d701e2480017b464b6560a2987e0d8971.exe
Danish | Датский | windows6.1-kb2483139-x64-da-dk_d753d19cc1a0fe95aef21548193393c04a6a8024.exe
Dutch | Нидерландский | windows6.1-kb2483139-x64-nl-nl_12c90c70d408b08f51f500d6e974878a5d662398.exe
English | Английский | windows6.1-kb2483139-x64-en-us_9b9c8a867baff2920507fbf1e1b4a158572b9b87.exe
Estonian | Эстонский | windows6.1-kb2483139-x64-et-ee_b4fd94f6e461e21b7eec54d1e379e2807861aea2.exe
Finnish | Финский | windows6.1-kb2483139-x64-fi-fi_223465e1b382484d1d82f8f2ccfcd9ed2f902c76.exe
French | Французский | windows6.1-kb2483139-x64-fr-fr_0f18e2a244dd9ff04664112a82776d2bd2177798.exe
German | Немецкий | windows6.1-kb2483139-x64-de-de_4f4ce6bd38530b4a02199172863b21a0cba13773.exe
Greek | Греческий | windows6.1-kb2483139-x64-el-gr_583791fea2fea71725388a746844d5be6488ca45.exe
Hebrew | Иврит | windows6.1-kb2483139-x64-he-il_617029400059f0847d7d90d4da673ae4ed43ebd9.exe
Hungarian | Венгерский | windows6.1-kb2483139-x64-hu-hu_1c298d99baf7af3d830dcd1e2632eeb65d7ee395.exe
Italian | Итальянский | windows6.1-kb2483139-x64-it-it_6d8223c065d6974d833d0eaa162f3ceb7680850f.exe
Japanese | Японский | windows6.1-kb2483139-x64-ja-jp_aeaf7e9b0b6c2173bf757330017a7f655f1f8715.exe
Korean | Корейский | windows6.1-kb2483139-x64-ko-kr_0ea76f748e3d5309d568147ad1337b2664090944.exe
Latvian | Латышский | windows6.1-kb2483139-x64-lv-lv_3919fb044a307144f1fc55cf4313aff45cde9a46.exe
Lithuanian | Литовский | windows6.1-kb2483139-x64-lt-lt_c894f0a591735553ba68f9fb94b1b85133ca922c.exe
Norwegian | Норвежский | windows6.1-kb2483139-x64-nb-no_78df68604970041a6337b4058a3e5339f79e50b4.exe
Polish | Польский | windows6.1-kb2483139-x64-pl-pl_24d00a966a7a75132c3af5627634483d3e2d01e7.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb2483139-x64-pt-br_f8035731c55d774c95c7c673aedfd42d52479294.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb2483139-x64-pt-pt_78485491088298110a3e78b7a5f95e55ff7808df.exe
Romanian | Румынский | windows6.1-kb2483139-x64-ro-ro_6e7a63541f2cb534dab3db719330fee5cfbb4e0f.exe
Russian | Русский | windows6.1-kb2483139-x64-ru-ru_0587eb296a2f04e0d3699650d39b53ee18b97a79.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb2483139-x64-sr-latn-cs_5f487007933585def54c67087895e74e25e699a9.exe
Slovak | Словацкий | windows6.1-kb2483139-x64-sk-sk_f1fb8a395d7d656649830f4f06496a5311ad572a.exe
Slovenian | Словенский | windows6.1-kb2483139-x64-sl-si_84606ed6bc061c72f756bbc061621b490fb761f7.exe
Spanish | Испанский | windows6.1-kb2483139-x64-es-es_fdbdf4061b960324efb9eedf7106df543ed8ce33.exe
Swedish | Шведский | windows6.1-kb2483139-x64-sv-se_81051fe3083afdb4f2d1d23752c587de9bb35025.exe
Thai | Тайский | windows6.1-kb2483139-x64-th-th_dc9c0cc12ae488ed3e8dcaecb4392eef91ec213b.exe
Turkish | Турецкий | windows6.1-kb2483139-x64-tr-tr_07e7e3b34426fe68be813e911d3843b941a268b7.exe
Ukrainian | Украинский | windows6.1-kb2483139-x64-uk-ua_1ca449545a2bcfdeeed6080768186fc29f163504.exe

Назад на страницу раздела Установка.


Настройки

1. Чтобы сохранялись настройки программ (сайдбара, расположение значков на панели и т.д.).

Нужно установить пароль на учетную запись администратора и работать из под нее.

2. Отображение (скрытие) значков в области уведомлений.

Отобразить значок в области уведомлений можно гораздо проще без использования кнопки Настроить: просто перетащите нужный значок из скрытой области в область уведомлений. Чтобы скрыть значок, перетащите его в скрытую область.

3. Изменение параметров загрузки в Windows 7 (msconfig вместо boot.ini).
Начиная с Windows Vista такого файла больше нет, но Вы можете изменить необходимые Вам для загрузки параметры используя инструмент Конфигурация системы. Окно Конфигурация системы запускается так: Панель управления -> Администрирование -> Конфигурация системы -> Загрузка (или нажав Win+R -> msconfig -> Ok)

Данный инструмент позволяет:
- получить информацию о текущей и загружаемой по умолчанию системах;
- выбрать систему, загружаемую по умолчанию;
- удалить ненужную запись из меню загрузки.
- отредактировать время в секундах (таймаут), по истечении которого будет загружена операционная система, выбранная по умолчанию.
- включить\выключить экран приветствия(Без GUI);
- включить\выключить загрузку стандартных драйверов VGA, вместо драйверов экрана, соответствующих видеооборудованию компьютера(Базовое видео).

А через Дополнительные параметры:

- Число процессоров, используемых при загрузке.
- Максимальный объем памяти в мегабайтах, используемый для моделирования конфигурации с малым объемом памяти.

При помощи окна Конфигурация системы нельзя изменить(но это возможно, при помощи программы Bcdedit):

- наименование существующих записей;
- положение записи в меню загрузки.

Для выбора системы, загружаемой по умолчанию, выберите необходимую Вам операционную систему и нажмите кнопку «Использовать по умолчанию».
Для удаления ненужной записи выберите ее из списка и нажмите кнопку «Удалить».
Для редактирование таймаута, в нужном поле установите желаемое количество секунд.

Для применения, сделанных Вами изменений - перезагрузите компьютер.

4. Принудительная установка числа ядер для старых многоядерных процессоров.

1) Откройте диалоговое меню Выполнить: Пуск -> Выполнить(или Win+R)
2) Введите msconfig и нажмите OK
3) Перейдите на вкладку Загрузка
4) Нажмите Дополнительные параметры
5) Поставьте флажок напротив значения Число процессоров
6) Выберите в активировавшемся ниспадающем меню число ядер Вашего процессора (По умолчанию 1)
Установка меньшего значения, чем количество ядер Вашего процессора не рекомендуется, так как система может продолжить использование указанного Вами числа ядер и после завершения загрузки.
7) Нажмите OK и перезагрузите компьютер

5. Установка временной зоны из командной строки в Windows 7.

В Windows 7 появилась новая утилита командной строки tzutil.exe, позволяющая изменять настройки временной зоны.
Для изменения временной зоны сделайте следующее:

1) Запустите командную строку от имени администратора (Нажмите Win+R -> введите cmd -> нажмите OK)
2) Введите команду:

3) Выберите необходимую Вам временную зону и введите в соответствии с ней команду.

Например, для установки значения временной зоны по Гринвичу выполните команду:

Замените значение между кавычками на необходимое Вам.
tzutil /g - отображает текущие установки временной зоны;
tzutil /? - выводит справку по работе утилиты.

6. Назначение клавиш быстрого вызова для утилиты "Ножницы".

"Ножницы" - это утилита для снятия скриншотов выделенной зоны
Пуск => Все программы=> Стандартные => "Ножницы" => Правый клик мыши=> Свойства
В Свойствах, в поле Быстрый вызов пытаемся набрать любую комбинацию клавиш. Заметим что нам сразу выдаются первые две клавиши Ctrl+Alt+, выбор третьей клавиши за Вами, как Вам удобнее. Например, Ctrl+Alt+S.

7. Отключение (включение) неиспользуемых компонентов Windows.
В Windows существует много дополнительных функций и компонентов. Вы можете просмотреть их и решить для себя какие из них вы будете использовать, а какие нет. Неиспользуемые компоненты можно отключить и, тем самым, немного разгрузить использование ресурсов компьютера системой.
Для просмотра и отключения (включения) дополнительных функций и компонентов, проделайте следующие действия:

1) Откройте Панель управления
2) Откройте оснастку Программы и компоненты
3) Перейдите по ссылке слева "Включение или отключение компонентов Windows"
4) Просмотрите компоненты и снимите флажки с тех, которые включены, но вами не используются

8. Отмена (изменение) ассоциирования типов файлов с определенными программами.

Если вы выбрали неправильную программу в диалоговом окне "Открыть с помощью" и установили параметр "Использовать выбранную программу для всех файлов такого типа". А также если программа удалилась некорректно, оставив в системе ассоциации на себя с поддерживаемыми ею типами файлов. Есть несколько способов это исправить.

Способ 1: Попробуйте ассоциировать нужные файлы с нужными программами используя все тот же диалог "Открыть с помощью"
Способ 2: Панель управления\Все элементы панели управления\Программы по умолчанию\Задать сопоставления "Изменить программу"
Способ 3: Найдите в разделе реестра [HKEY_CLASSES_ROOT] ветку соответствующую расширению файла, удалите ее, а затем откройте в нужной программе.
Способ 4: Используйте утилиту Unassociate File Types, которая позволяет как убрать ассоциацию, так и удалить тип файла из реестра.

9. Отключение всплывающих подсказок.

Отключить всплывающие подсказки можно используя редактор групповой политики.

1) Нажмите Пуск, в поле поиска напишите gpedit.msc и нажмите ОК.
2) Перейдите в раздел Конфигурация пользователя -> Административные шаблоны -> Меню Пуск и Панель задач.
3) Откройте параметр "Удалить всплывающие подсказки для элементов главного меню",
4) Установите переключатель в значение Включить и нажмите ОК.

10. Изменение функции кнопки питания на корпусе вашего компьютера.

По умолчанию кнопка выключения компьютера в Windows 7 находится в состоянии "Завершение работы". Если вы перезагружаете компьютер по несколько раз в день, вам наверное было бы удобнее переключить кнопку выключения в состояние "Перезагрузка". Для этого выполните следующие действия:

1) Щелкните правой кнопкой мыши на кнопку Пуск и выберите пункт меню Свойства.
2) Перейдите на вкладку Меню "Пуск".
3) Переключите значение “Действие кнопки питания” в состояние "Перезагрузка". Также вы можете выбрать функции "Блокировка", "Смена пользователя" и "Завершение сеанса".

11. Быстрый переход к часто используемой папке.

Если вы часто работаете с какими-то 4-мя — 5-ю папками, то их можно быстро прикрепить к кнопке проводника на панели задач. Удерживая кнопку мыши, перетащите папку на панель задач, и она автоматически будет помещена в «Закреплено» кнопки проводника.

12. Редактирование меню загрузки операционных систем при помощи Bcdedit.

bcdedit - инструмент, позволяющий изменить значения загрузчика Windows, а также произвести его(загрузчика) восстановление. Чтобы увидеть предлагаемые системой для изменения параметры: запустите командную строку от имени администратора (Win+R -> cmd -> Ok), наберите в ней bcdedit и нажмите Enter. Все команды, приведенные в данном варианте, необходимо будет запускать в командной строке, запущенной от имени администратора (Win+R -> cmd -> Ok) Также данные команды могут выполняются в командной строке среды восстановления или в командной строке ERD Commander.

Некоторые значения параметров BCD записаны в фигурных скобках – {}. Это идентификаторы – {CLSID}. Любой идентификатор имеет буквенно-цифровой код вида {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}. Стандартные идентификаторы имеют названия, например: {default}, {bootmgr}, {ntldr} и так далее.

Наиболее интересующими нас компонентами являются:

идентификатор – CLSID той или иной записи;
device – показывает раздел, на котором расположены файлы загрузки (это может быть операционная система или папка BOOT);
osdevice – показывает раздел, на котором расположены системные файлы операционной системы. Обычно, значения параметров device и osdevice равны;
path – если device определял раздел диска, который содержит файлы операционной системы, то этот параметр определяет остальной путь к загрузчику операционной системы;
default – показывает ID операционной системы, загружаемой по умолчанию, если операционная система, в которой запустили командную строку, загружается по умолчанию, параметру default присваивается значение {current};
displayorder – показывает порядок, в котором расположены записи о загружаемых системах;
timeout – таймаут(время - по истечении которого будет загружена операционная система), значение показано и устанавливается в секундах;
locale – указывает язык загрузочного меню или меню дополнительных параметров загрузки;
description – показывает название операционной системы, отображающееся в меню загрузки.

Внимание: Если в выполняемой Вами команде, с использованием программы bcdedit.exe, отсутствует параметр /set с дальнейшим указанием идентификатора, то внесенные Вами изменения будут добавлены в Диспетчер загрузки Windows (Windows Boot Manager), а не в Загрузка Windows (Windows Boot Loader)

Перед тем, как начнете вносить необходимые Вам изменения, создайте резервную копию загрузчика. Для этого, создайте на любом диске папку с названием BCDREZ и выполните следующую команду:

где X - буква диска, на котором находится папка BCDREZ.

Если Вы решите вернуть все сделанные Вами изменения к начальным настройкам, то выполните следующую команду:

Для дальнейших примеров, предположим, что наше меню загрузки содержит три записи с идентификаторами {ID1}, {ID2}, {ID3}.

Изменение системы, загружаемой по умолчанию

Введите параметр /default и {ID} той системы, которую Вы хотите загружать по умолчанию. Например, для системы с {ID2} команда:

Данная команда не перемещает запись о системе, загружаемой по умолчанию, на верхнюю строчку меню загрузки.

Изменение расположения записей в меню загрузки

1) Перемещение выбранной записи вверх списка:

2) Перемещение выбранной записи вниз списка:

3) Формирование меню в выбранном порядке:

Изменение таймаута

где XX – время в секундах.

Изменение языка диспетчера загрузки

где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение языка меню дополнительных вариантов загрузки

В связи с тем, что программа восстановления запуска, выполняющаяся из среды восстановления, использует параметры "по-умолчанию", меню дополнительных вариантов загрузки, которое появляется при нажатии F8 после наведения на строку меню с нужной операционной системой, может стать англоязычным. Вернуть необходимый Вам язык, можно выполнив следующую команду:

где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение названия загружаемой системы

После использования среды восстановления, в названии операционной системы появляется надпись - (восстановлено).
Вы также можете исправить значение "Предыдущая версия Windows" на более удобное Вам "Windows XP" или добавить версию и разрядность к текущей(используемой по умолчанию) версии Windows.
Вы можете изменить это указанной ниже командой:

Например:

Изменение буквы раздела, на котором расположена папка операционной системы и ее загрузочные файлы

где X – буква раздела жесткого диска. Обычно значения device и osdevice совпадают.

Добавление новой операционной системы (Windows Vista или Windows 7) в загрузчик.

1) Скопируйте существующую запись текущей системы с новым названием:

2) Дождитесь сообщение «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
3) Измените значения параметров device и osdevice на соответствующие добавляемой операционной системе.

где X – буква диска, на котором находится операционная система. Вместо крестиков, введите значение {ID}, полученное после успешного окончания копирования.
4) Выполните команду, добавляющую новую запись в диспетчер загрузки:

Запись будет добавлена внизу существующего списка.

Удаление записи загрузки системы из BCD и диспетчера загрузки.

Удаление записи об установленной операционной системе из BCD и диспетчера загрузки выполняется с помощью команды bcdedit /delete {ID}. Есть особенность выполнения команды: если в качестве ID указывается известная запись, например {ntldr}, то команда должна выполняться с ключом /f:

Если же ID записывается в буквенно-цифровом коде, ключ /f не нужен.

В случае отсутствия одного из файлов, необходимых для работы с загрузчиком, Вы можете скачать архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe из Windows 7 Ultimate x86/x64)

Для информации:

Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

13. Установка пользовательского разрешения экрана.

У некоторых мониторов разрешение экрана может не соответствовать ни одному из предлагаемых Windows.

Если у Вас установлена видеокарта Nvidia Вы можете добавить своё разрешение экрана одним из указанных способов:

Способ 1.

1) Запустить Панель управления Nvidia.
2) Открыть Дисплей -> Изменение разрешения -> Добавить разрешения... -> Создать пользовательское разрешение
3) Задать нужные Вам параметры, протестировать их и добавить его в список для выбора
4) Выбрать его и использовать.

Способ 2.

Используя реестр добавить нужное Вам разрешение в параметр NV_Modes

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{some number}\0000

Также можете найти другие ветки содержащие параметр NV_Modes и также добавить в них необходимое Вам разрешение экрана.

Способ 3. Перед установкой драйвера.

Откройте файл "nv_disp.inf" в папке C:\NVIDIA\Win7\xxx.xx и найдите значение [nv_commonDisplayModes_addreg]
Под ним в NV_Modes будут все доступные разрешения экрана, добавьте туда свое.

Но бывает что даже после указанных выше манипуляций, новое разрешение не хочет добавляться. В таком случае, для принудительного добавления пользовательского разрешения Вам придется использовать специальные программы. Рекомендую поискать в интернете следующие программы:

PowerStrip - Программа управления параметрами видеоподсистемы вашего компьютера, поддерживается огромное разнообразие видео карт. Это - фактически единственная программа своего рода, которая поддерживает видео карты из многочисленного набора чипсетов и поставщиков, одновременно, под любой операционной системой. Программа спокойно сидит в трее и оттуда обеспечивает доступ к более 500 элементов управления над вашими дисплейными аппаратными средствами, включая цветные инструментальные средства коррекции, установки уровня периода экранной геометрии, и драйверо-независимыми элементами управления часов.

Screen Resolution Manager - Программа, позволяющая каждому пользователю компьютера устанавливать свое разрешение экрана. Помимо разрешения можно настроить глубину цвета, частоту, яркость и контрастность, цветовую гамму и другие настройки, которые автоматически вступят в силу после загрузки профиля определенного пользователя.

14. Создание диска восстановления системы и загрузка с него.

Если у вас есть установочный диск Windows 7, создавать диск восстановления необязательно. Если же установочного диска у вас нет, создать диск восстановления нужно обязательно - он вам рано или поздно пригодится. С установочного диска можно загрузиться в среду восстановления Windows RE.

Создание диска восстановления системы

1) Вставьте чистый компакт-диск в привод.
2) Откройте Пуск -> Панель Управления -> Архивация и восстановление (Backup and Restore)
3) В левой панели щелкните ссылку Создать диск восстановления системы.

Загрузка с диска восстановления системы

1) Вставьте диск восстановления в привод и перезагрузитесь
2) В BIOS должен быть установлен приоритет загрузки с привода. Будет выполнена загрузка в Windows RE.
3) Выберите систему, которую вы хотите восстановить.
4) Установите переключатель Используйте средства восстановления... и нажмите кнопку Далее. Вы увидите окно с вариантами восстановления.

15. Изменение строки в загрузочном меню Windows 7 с "Предыдущая версия Windows" на "Windows ХР".

1) Запустите cmd.exe от имени администратора(Win+R -> cmd -> Ok)
2) Выполните следующие команды, нажимая после введения каждой Enter

16. Перенесение файлов загрузки, при удалении из системы одного из жестких дисков.

Вы решили заменить или продать один из ваших жестких дисков. Прежде чем это сделать, убедитесь что файлы загрузки Windows 7 не содержаться на удаляемом Вами из системы жестком диске.
Windows 7 хранит свои файлы для загрузки на активном диске, который может отличаться от того на котором установлена Windows 7. Файлами загрузки для Windows 7 являются файл bootmgr и хранилище данных конфигурации загрузки BCD (Boot Configuration Data), находящееся в скрытой и системной папке Boot.

При загрузке Windows 7 проверяет соблюдение 3 условий:

- Является ли диск, с которого выполняется загрузка активным;
- Совместима ли Главная Загрузочная Запись (Master Boot Record - MBR) с bootmgr (Диспетчером загрузки Windows);
- Находиться ли файлы загрузки операционной системы на активном диске должны.

В случае не соблюдения одного из условий, загрузка становится невозможной.

Предположим, что Ваша Windows 7 установлена на диск С:, который не активен. Активным является только диск D:, который Вы собираетесь удалить из системы и на котором находятся Файлы загрузки Windows 7, имеющие атрибуты Скрытый и Системный.

В качестве решения предлагаю Вам выполнить перенесение файлов загрузки Windows 7 с активного раздела (удаляемый жесткий диск) на неактивный раздел (остающийся в системе жесткий диск, с присвоением ему атрибута - Активный).

1) Выяснение атрибутов дисков и присвоение остающемуся в системе жесткому диску атрибута Активный.

Способ 1. Используя оснастку "Управление дисками".

1.1.1) Нажмите Win + R, в строке "Выполнить" наберите diskmgmt.msc и нажмите OK
1.1.2) В нижней части окна, где находится графическое представление разделов, найдите том (раздел) на котором установлена Ваша Windows 7 Буква тома здесь, идентична букве диска с Window 7 из Мой Компьютер.
1.1.3) Под буквой тома, размером диска и файловой системой будут указаны атрибуты диска. Посмотрите имеет ли наш том атрибут "Активный". Если да, то Вы сможете спокойно удалить Ваш диск из системы. Если же нет, то Вам необходимо будет присвоить данный атрибут, в соответствии с написанным ниже.
1.1.4) Если Ваша Windows 7 установлена на жесткий диск, разбитый на несколько разделов, то выберите первый слева раздел остающегося у Вас диска, его мы сделаем загрузочным и активным. Если же раздел всего один, то выберите его.
1.1.5) Щелкните правой кнопкой мыши по выбранному разделу и выберите в контекстном меню пункт "Сделать раздел активным". Учтите, что этот раздел должен иметь атрибут "Основной".

Способ 2. Используя командную строку.

1.2.1) Запустите командную строку с правами администратора. Нажмите Win + R, в строке "Выполнить" наберите cmd и нажмите OK.
1.2.2) Последовательно выполните все команды без выхода из командной строки:

где X - номер диска, который предполагается оставить, в списке дисков (команда list disk).

2) Перезапись загрузочного сектора MBR и установка его совместимости с bootmgr:

2.1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe)
2.2) Создайте папку Boot
2.3) Распакуйте скачанный архив и скопируйте файлы Bootsect.exe и Bcdedit.exe, нужной Вам битности в созданную Вами папку Boot.
2.4) Запустите командную строку с правами администратора.

где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /force - принудительно отключает один или несколько томов во время обновления загрузочного кода. Необходим, при наличии в конфигурации 2-х и более жестких дисков.

3) Перенесение BCD (Boot Configuration Data) и файла bootmgr на новый активный раздел:

где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /l - выбор языковых параметров менеджера загрузки. Если ваша система не русскоязычная, используйте другие значения этого ключа, например, для английского языка - en-US, для немецкого - de-DE, и т.д.
- ключ /s - определяет букву тома, назначенную целевому системному разделу, в который копируются файлы среды загрузки. Это раздел, который мы сделали активным. Windows 7 использует текущий загрузочный раздел (в нашем случае - раздел D:) до завершения своей работы. Поэтому применение этого ключа с указанием буквы нового загрузочного раздела (в нашем случае - раздел С:) - обязательно.

17. Способы доступа к элементам Панели управления.

В разных статьях Вы можете увидеть разное описание пути к одинаковым элементам Панели управления. Такое происходит потому что в Windows существует два вида отображения элементов: Категория(элементы сгруппированы по тематикам) и Крупные или Мелкие значки (элементы отображаются полным списком) Имхо, наиболее удобным является Крупные или Мелкие значки(их полный список).

Существует несколько способов доступа к элементам Панели управления:

1) Через меню Пуск.

Для быстрого доступа к элементам Панели управления, рекомендуется добавить в меню Пуск всплывающее меню содержащее все элементы Панели Управления.
1.1) Нажмите правой кнопкой мыши на кнопке Пуск и щелкните на пункте Свойства.
1.2) Нажмите Настроить...
1.3) Промотайте до записи Панель управления.
1.4) Установите значение переключателя под ней в положение Отображать как меню и нажмите OK
Всплывающее меню Панели управления будет отображаться полным списком, независимо от Вашего выбора вида отображения.

2) Через Проводник Windows.

2.1) Запустите Проводник
2.2) В панели меню выберите Сервис и нажмите Параметры папок
2.3) Под надписью Область переходов установите флажок напротив значения Показать все папки и нажмите OK
Теперь Панель управления будет доступна в Проводнике в Области переходов слева. Преимущество данного способа в том что Вы можете работать, как сразу с полным списком элементов: Проводник -> Панель управления -> Все элементы панели управления, так и с отдельными разделами: Проводник -> Панель управления -> Нужный Вам раздел.

3) На рабочем столе.

3.1) Щелкните правой кнопкой мыши на Рабочем столе и нажмите Персонализация
3.2) Щелкните Изменение значков рабочего стола
3.3) Установите флажок напротив Панель управления и нажмите ОК
На Рабочем столе появится ярлык запускающий папку Панель управления. Способ отображения зависит от выбранного Вами значения параметра Просмотр.

4) Добавление или запуск папки Панель управления используя {GUID}

Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

Control Panel.{26EE0668-A00A-44D7-9371-BEB064C98683}

Для её запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win+R) и введите команду:

shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}

5) Запуск элементов Панели управления, используя канонические имена.

Русское название элемента | Английское название элемента | Команда
Панель управления | Control Panel | control
Windows CardSpace | Windows CardSpace | control /name Microsoft.CardSpace
Windows SideShow | Windows SideShow | control /name Microsoft.WindowsSideShow
Автозапуск | AutoPlay | control /name Microsoft.AutoPlay
Автономные файлы | Offline Files | control /name Microsoft.OfflineFiles
Администрирование | Administrative Tools | control /name Microsoft.AdministrativeTools
Архивация и восстановление | Backup and Restore | control /name Microsoft.BackupAndRestore
Биометрические устройства | Biometric Devices | control /name Microsoft.BiometricDevices
Брандмауэр Windows | Windows Firewall | control /name Microsoft.WindowsFirewall
Восстановление | Recovery | control /name Microsoft.Recovery
Гаджеты рабочего стола | Desktop Gadgets | control /name Microsoft.DesktopGadgets
Дата и Время | Date and Time | control /name Microsoft.DateAndTime
Датчик расположения и другие датчики | Location and Other Sensors | control /name Microsoft.LocationAndOtherSensors
Диспетчер устройств | Device Manager | control /name Microsoft.DeviceManager
Диспетчер учетных данных | Credential Manager | control /name Microsoft.CredentialManager
Домашняя группа | HomeGroup | control /name Microsoft.HomeGroup
Защитник Windows | Windows Defender | control /name Microsoft.WindowsDefender
Звук | Sound | control /name Microsoft.Sound
Значки области уведомлений | Notification Area Icons | control /name Microsoft.NotificationAreaIcons
Игровые устройства | Game Controllers | control /name Microsoft.GameControllers
Инфракрасная связь | Infrared | control /name Microsoft.Infrared
Папка "Fonts" | Fonts Folder | control /name Microsoft.Fonts
Параметры индексирования | Indexing Options | control /name Microsoft.IndexingOptions
Параметры папок | Folder Options | control /name Microsoft.FolderOptions
Параметры планшетного компьютера | Tablet PC Settings | control /name Microsoft.TabletPCSettings
Перо и сенсорные устройства | Pen and Touch | control /name Microsoft.PenAndTouch
Персонализация | Personalization | control /name Microsoft.Personalization
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection | control /name Microsoft.RemoteAppAndDesktopConnections
Получение программ | Get Programs | control /name Microsoft.GetPrograms
Приступая к работе | Getting Started | control /name Microsoft.GettingStarted
Программы и компоненты | Programms and Features | control /name Microsoft.ProgramsAndFeatures
Программы по умолчанию | Default Programs | control /name Microsoft.DefaultPrograms
Распознавание речи | Speech Recognition | control /name Microsoft.SpeechRecognition
Расположение по умолчанию | Default Location | control /name Microsoft.DefaultLocation
Родительский контроль | Parental Controls | control /name Microsoft.ParentalControls
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | control /name Microsoft.TaskbarAndStartMenu
Свойства речи | Text to Speech | control /name Microsoft.TextToSpeech
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | control /name Microsoft.iSCSIInitiator
Свойства: Интернет | Internet Properties | control /name Microsoft.InternetOptions
Свойства: Клавиатура | Keyboard Properties | control /name Microsoft.Keyboard
Свойства: Мышь | Mouse Properties | control /name Microsoft.Mouse
Система | System | control /name Microsoft.System
Сканеры и камеры | Scanners and Cameras | control /name Microsoft.ScannersAndCameras
Соседние пользователи | People Near Me | control /name Microsoft.PeopleNearMe
Счетчики и средства производительности | Performance Information and Tools | control /name Microsoft.PerformanceInformationAndTools
Телефон и модем | Phone and Modem | control /name Microsoft.PhoneAndModem
Управление цветом | Color Management | control /name Microsoft.ColorManagement
Устранение неполадок | Troubleshooting | control /name Microsoft.Troubleshooting
Устройства и принтеры | Devices and Printers | control /name Microsoft.DevicesAndPrinters
Учетные записи пользователей | User Accounts | control /name Microsoft.UserAccounts
Центр мобильности Windows | Windows Mobility Center | control /name Microsoft.MobilityCenter
Центр обновления Windows | Windows Update | control /name Microsoft.WindowsUpdate
Центр поддержки | Action Center | control /name Microsoft.ActionCenter
Центр синхронизации | Sync Center | control /name Microsoft.SyncCenter
Центр специальных возможностей | Ease of Access Center | control /name Microsoft.EaseOfAccessCenter
Центр управления сетями и общим доступом | Network and Sharing Center | control /name Microsoft.NetworkAndSharingCenter
Шифрование диска BitLocker | BitLocker Drive Encryption | control /name Microsoft.BitLockerDriveEncryption
Экран (размер текста) | Display (size of text) | control /name Microsoft.Display
Электропитание | Power Options | control /name Microsoft.PowerOptions
Язык и региональные стандарты | Region and Language | control /name Microsoft.RegionAndLanguage

При отсутствии в системе необходимого устройства, драйверов или определенных компонентов, соответствующий ему элемент Панели управления может не запуститься.

18. Отключение значка "Центра поддержки" из области уведомлений на панели задач.

Если во время работы у Вас в трее появился флаг "Центра поддержки", и Вы хотите его убрать, то проделайте следующее.

1) Щелкните правой кнопкой мыши на Панели задач и выберите пункт "Свойства".
2) Нажмите на кнопку "Настроить".
3) Перейдите по ссылке "Включить или выключить системные значки"
4) Установите значение системного значка "Центр поддержки" в "Выкл" и нажмите ОК.

19. Добавление своей программы в утилиту msconfig (Конфигурация системы).

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните с именем mscfgtlc.xml
3) Скопируйте файл в папку C:\Windows\system32\
4) Нажмите кнопку Сохранить

Например:

или

Добавленная Вами программа появится во вкладке Сервис (Tools). Для использования русских букв файл необходимо сохранить файл в кодировке UTF-8. В качестве пути можно указать только файлы из папок Windows или Programm Files включая подпапки.

20. Настройка параметров индексирования для ускорения выполнения поиска в системе.

Операционная система Windows использует индекс для выполнения быстрого поиска наиболее часто используемых файлов. По умолчанию индексируются все самые распространенные файлы на компьютере. Повысить производительность поиска в Windows 7 можно, следующим образом.

Добавление или удаление расположения из индекса.

1) Откройте меню Пуск, введите в строке поиска Параметры индексирования и нажмите Enter.
2) Щелкните Изменить.
3) Установите или снимите флажок с папок в списке Изменение выбранных расположений, которые Вы желаете добавить или удалить для ускорения поиска, а затем нажмите кнопку ОК.
4) Если в списке отображаются не все расположения на компьютере, нажмите кнопку Показать все расположения. (Если в списке отображаются все расположения на компьютере, кнопка Показать все расположения недоступна.) Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
5) Если требуется добавить папку, исключая некоторые вложенные папки, щелкните папку и затем снимите флажки рядом с теми вложенными папками, которые не требуется индексировать. Эти папки будут отображены в столбце «Исключить» в разделе Сводный список выбранных расположений.

Индексировать все файлы на компьютере не рекомендуется, так как если сделать индекс слишком большим или добавить в индекс расположения системных файлов (например, папки «Program Files»), поиск будет выполняться медленно.

Добавление или удаление типа файла из индекса.

1) Откройте меню Пуск, введите в строке поиска Параметры индексирования и нажмите Enter.
2) Щелкните Дополнительно. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
3) Перейдите на вкладку Типы файлов.
4) Снимите флажок с расширений в списке, которые Вы желаете удалить для ускорения поиска.
5) В поле Добавить новое расширение введите расширение имени файла, которые Вы желаете добавить для ускорения поиска, а затем нажмите кнопку Добавить.
6) Установите переключатель в значение Индексировать только свойства при большом количестве выделенных расширений или Индексировать свойства и содержимое файлов при небольшом, а затем нажмите кнопку ОК.


1. Чтобы сохранялись настройки программ (сайдбара, расположение значков на панели и т.д.).

Нужно установить пароль на учетную запись администратора и работать из под нее.

Назад на страницу раздела Настройки.


2. Отображение (скрытие) значков в области уведомлений.

Отобразить значок в области уведомлений можно гораздо проще без использования кнопки Настроить: просто перетащите нужный значок из скрытой области в область уведомлений. Чтобы скрыть значок, перетащите его в скрытую область.

Назад на страницу раздела Настройки.


3. Изменение параметров загрузки в Windows 7 (msconfig вместо boot.ini).

Начиная с Windows Vista такого файла больше нет, но Вы можете изменить необходимые Вам для загрузки параметры используя инструмент Конфигурация системы. Окно Конфигурация системы запускается так: Панель управления -> Администрирование -> Конфигурация системы -> Загрузка (или нажав Win+R -> msconfig -> Ok)

Данный инструмент позволяет:
- получить информацию о текущей и загружаемой по умолчанию системах;
- выбрать систему, загружаемую по умолчанию;
- удалить ненужную запись из меню загрузки.
- отредактировать время в секундах (таймаут), по истечении которого будет загружена операционная система, выбранная по умолчанию.
- включить\выключить экран приветствия(Без GUI);
- включить\выключить загрузку стандартных драйверов VGA, вместо драйверов экрана, соответствующих видеооборудованию компьютера(Базовое видео).

А через Дополнительные параметры:

- Число процессоров, используемых при загрузке.
- Максимальный объем памяти в мегабайтах, используемый для моделирования конфигурации с малым объемом памяти.

При помощи окна Конфигурация системы нельзя изменить(но это возможно, при помощи программы Bcdedit):

- наименование существующих записей;
- положение записи в меню загрузки.

Для выбора системы, загружаемой по умолчанию, выберите необходимую Вам операционную систему и нажмите кнопку «Использовать по умолчанию».
Для удаления ненужной записи выберите ее из списка и нажмите кнопку «Удалить».
Для редактирование таймаута, в нужном поле установите желаемое количество секунд.

Для применения, сделанных Вами изменений - перезагрузите компьютер.

Назад на страницу раздела Настройки.


4. Принудительная установка числа ядер для старых многоядерных процессоров.

1) Откройте диалоговое меню Выполнить: Пуск -> Выполнить(или Win+R)
2) Введите msconfig и нажмите OK
3) Перейдите на вкладку Загрузка
4) Нажмите Дополнительные параметры
5) Поставьте флажок напротив значения Число процессоров
6) Выберите в активировавшемся ниспадающем меню число ядер Вашего процессора (По умолчанию 1)
Установка меньшего значения, чем количество ядер Вашего процессора не рекомендуется, так как система может продолжить использование указанного Вами числа ядер и после завершения загрузки.
7) Нажмите OK и перезагрузите компьютер

Назад на страницу раздела Настройки.


5. Установка временной зоны из командной строки в Windows 7.

В Windows 7 появилась новая утилита командной строки tzutil.exe, позволяющая изменять настройки временной зоны.
Для изменения временной зоны сделайте следующее:

1) Запустите командную строку от имени администратора (Нажмите Win+R -> введите cmd -> нажмите OK)
2) Введите команду:

3) Выберите необходимую Вам временную зону и введите в соответствии с ней команду.

Например, для установки значения временной зоны по Гринвичу выполните команду:

Замените значение между кавычками на необходимое Вам.
tzutil /g - отображает текущие установки временной зоны;
tzutil /? - выводит справку по работе утилиты.

Назад на страницу раздела Настройки.


6. Назначение клавиш быстрого вызова для утилиты "Ножницы".

"Ножницы" - это утилита для снятия скриншотов выделенной зоны
Пуск => Все программы=> Стандартные => "Ножницы" => Правый клик мыши=> Свойства
В Свойствах, в поле Быстрый вызов пытаемся набрать любую комбинацию клавиш. Заметим что нам сразу выдаются первые две клавиши Ctrl+Alt+, выбор третьей клавиши за Вами, как Вам удобнее. Например, Ctrl+Alt+S.

Назад на страницу раздела Настройки.


7. Отключение(включение) неиспользуемых компонентов Windows.

В Windows существует много дополнительных функций и компонентов. Вы можете просмотреть их и решить для себя какие из них вы будете использовать, а какие нет. Неиспользуемые компоненты можно отключить и, тем самым, немного разгрузить использование ресурсов компьютера системой.
Для просмотра и отключения (включения) дополнительных функций и компонентов, проделайте следующие действия:

1) Откройте Панель управления
2) Откройте оснастку Программы и компоненты
3) Перейдите по ссылке слева "Включение или отключение компонентов Windows"
4) Просмотрите компоненты и снимите флажки с тех, которые включены, но вами не используются

Назад на страницу раздела Настройки.


8. Отмена (изменение) ассоциирования типов файлов с определенными программами.

Если вы выбрали неправильную программу в диалоговом окне "Открыть с помощью" и установили параметр "Использовать выбранную программу для всех файлов такого типа". А также если программа удалилась некорректно, оставив в системе ассоциации на себя с поддерживаемыми ею типами файлов. Есть несколько способов это исправить.

Способ 1: Попробуйте ассоциировать нужные файлы с нужными программами используя все тот же диалог "Открыть с помощью"
Способ 2: Панель управления\Все элементы панели управления\Программы по умолчанию\Задать сопоставления "Изменить программу"
Способ 3: Найдите в разделе реестра [HKEY_CLASSES_ROOT] ветку соответствующую расширению файла, удалите ее, а затем откройте в нужной программе.
Способ 4: Используйте утилиту Unassociate File Types, которая позволяет как убрать ассоциацию, так и удалить тип файла из реестра.

Назад на страницу раздела Настройки.


9. Отключение всплывающих подсказок.

Отключить всплывающие подсказки можно используя редактор групповой политики.

1) Нажмите Пуск, в поле поиска напишите gpedit.msc и нажмите ОК.
2) Перейдите в раздел Конфигурация пользователя -> Административные шаблоны -> Меню Пуск и Панель задач.
3) Откройте параметр "Удалить всплывающие подсказки для элементов главного меню",
4) Установите переключатель в значение Включить и нажмите ОК.

Назад на страницу раздела Настройки.


10. Изменение функции кнопки питания на корпусе вашего компьютера.

По умолчанию кнопка выключения компьютера в Windows 7 находится в состоянии "Завершение работы". Если вы перезагружаете компьютер по несколько раз в день, вам наверное было бы удобнее переключить кнопку выключения в состояние "Перезагрузка". Для этого выполните следующие действия:

1) Щелкните правой кнопкой мыши на кнопку Пуск и выберите пункт меню Свойства.
2) Перейдите на вкладку Меню "Пуск".
3) Переключите значение “Действие кнопки питания” в состояние "Перезагрузка". Также вы можете выбрать функции "Блокировка", "Смена пользователя" и "Завершение сеанса".

Назад на страницу раздела Настройки.


11. Быстрый переход к часто используемой папке.

Если вы часто работаете с какими-то 4-мя — 5-ю папками, то их можно быстро прикрепить к кнопке проводника на панели задач. Удерживая кнопку мыши, перетащите папку на панель задач, и она автоматически будет помещена в «Закреплено» кнопки проводника.

Назад на страницу раздела Настройки.


12. Редактирование меню загрузки операционных систем при помощи Bcdedit.

bcdedit - инструмент, позволяющий изменить значения загрузчика Windows, а также произвести его(загрузчика) восстановление. Чтобы увидеть предлагаемые системой для изменения параметры: запустите командную строку от имени администратора (Win+R -> cmd -> Ok), наберите в ней bcdedit и нажмите Enter. Все команды, приведенные в данном варианте, необходимо будет запускать в командной строке, запущенной от имени администратора (Win+R -> cmd -> Ok) Также данные команды могут выполняются в командной строке среды восстановления или в командной строке ERD Commander.

Некоторые значения параметров BCD записаны в фигурных скобках – {}. Это идентификаторы – {CLSID}. Любой идентификатор имеет буквенно-цифровой код вида {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}. Стандартные идентификаторы имеют названия, например: {default}, {bootmgr}, {ntldr} и так далее.

Наиболее интересующими нас компонентами являются:

идентификатор – CLSID той или иной записи;
device – показывает раздел, на котором расположены файлы загрузки (это может быть операционная система или папка BOOT);
osdevice – показывает раздел, на котором расположены системные файлы операционной системы. Обычно, значения параметров device и osdevice равны;
path – если device определял раздел диска, который содержит файлы операционной системы, то этот параметр определяет остальной путь к загрузчику операционной системы;
default – показывает ID операционной системы, загружаемой по умолчанию, если операционная система, в которой запустили командную строку, загружается по умолчанию, параметру default присваивается значение {current};
displayorder – показывает порядок, в котором расположены записи о загружаемых системах;
timeout – таймаут(время - по истечении которого будет загружена операционная система), значение показано и устанавливается в секундах;
locale – указывает язык загрузочного меню или меню дополнительных параметров загрузки;
description – показывает название операционной системы, отображающееся в меню загрузки.

Внимание: Если в выполняемой Вами команде, с использованием программы bcdedit.exe, отсутствует параметр /set с дальнейшим указанием идентификатора, то внесенные Вами изменения будут добавлены в Диспетчер загрузки Windows (Windows Boot Manager), а не в Загрузка Windows (Windows Boot Loader)

Перед тем, как начнете вносить необходимые Вам изменения, создайте резервную копию загрузчика. Для этого, создайте на любом диске папку с названием BCDREZ и выполните следующую команду:

где X - буква диска, на котором находится папка BCDREZ.

Если Вы решите вернуть все сделанные Вами изменения к начальным настройкам, то выполните следующую команду:

Для дальнейших примеров, предположим, что наше меню загрузки содержит три записи с идентификаторами {ID1}, {ID2}, {ID3}.

Изменение системы, загружаемой по умолчанию

Введите параметр /default и {ID} той системы, которую Вы хотите загружать по умолчанию. Например, для системы с {ID2} команда:

Данная команда не перемещает запись о системе, загружаемой по умолчанию, на верхнюю строчку меню загрузки.

Изменение расположения записей в меню загрузки

1) Перемещение выбранной записи вверх списка:

2) Перемещение выбранной записи вниз списка:

3) Формирование меню в выбранном порядке:

Изменение таймаута

где XX – время в секундах.

Изменение языка диспетчера загрузки

где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение языка меню дополнительных вариантов загрузки

В связи с тем, что программа восстановления запуска, выполняющаяся из среды восстановления, использует параметры "по-умолчанию", меню дополнительных вариантов загрузки, которое появляется при нажатии F8 после наведения на строку меню с нужной операционной системой, может стать англоязычным. Вернуть необходимый Вам язык, можно выполнив следующую команду:

где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение названия загружаемой системы

После использования среды восстановления, в названии операционной системы появляется надпись - (восстановлено).
Вы также можете исправить значение "Предыдущая версия Windows" на более удобное Вам "Windows XP" или добавить версию и разрядность к текущей(используемой по умолчанию) версии Windows.
Вы можете изменить это указанной ниже командой:

Например:

Изменение буквы раздела, на котором расположена папка операционной системы и ее загрузочные файлы

где X – буква раздела жесткого диска. Обычно значения device и osdevice совпадают.

Добавление новой операционной системы (Windows Vista или Windows 7) в загрузчик.

1) Скопируйте существующую запись текущей системы с новым названием:

2) Дождитесь сообщение «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
3) Измените значения параметров device и osdevice на соответствующие добавляемой операционной системе.

где X – буква диска, на котором находится операционная система. Вместо крестиков, введите значение {ID}, полученное после успешного окончания копирования.
4) Выполните команду, добавляющую новую запись в диспетчер загрузки:

Запись будет добавлена внизу существующего списка.

Удаление записи загрузки системы из BCD и диспетчера загрузки.

Удаление записи об установленной операционной системе из BCD и диспетчера загрузки выполняется с помощью команды bcdedit /delete {ID}. Есть особенность выполнения команды: если в качестве ID указывается известная запись, например {ntldr}, то команда должна выполняться с ключом /f:

Если же ID записывается в буквенно-цифровом коде, ключ /f не нужен.

В случае отсутствия одного из файлов, необходимых для работы с загрузчиком, Вы можете скачать архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe из Windows 7 Ultimate x86/x64)

Для информации:

Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

Назад на страницу раздела Настройки.


13. Установка пользовательского разрешения экрана.

У некоторых мониторов разрешение экрана может не соответствовать ни одному из предлагаемых Windows.

Если у Вас установлена видеокарта Nvidia Вы можете добавить своё разрешение экрана одним из указанных способов:

Способ 1.

1) Запустить Панель управления Nvidia.
2) Открыть Дисплей -> Изменение разрешения -> Добавить разрешения... -> Создать пользовательское разрешение
3) Задать нужные Вам параметры, протестировать их и добавить его в список для выбора
4) Выбрать его и использовать.

Способ 2.

Используя реестр добавить нужное Вам разрешение в параметр NV_Modes

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{some number}\0000

Также можете найти другие ветки содержащие параметр NV_Modes и также добавить в них необходимое Вам разрешение экрана.

Способ 3. Перед установкой драйвера.

Откройте файл "nv_disp.inf" в папке C:\NVIDIA\Win7\xxx.xx и найдите значение [nv_commonDisplayModes_addreg]
Под ним в NV_Modes будут все доступные разрешения экрана, добавьте туда свое.

Но бывает что даже после указанных выше манипуляций, новое разрешение не хочет добавляться. В таком случае, для принудительного добавления пользовательского разрешения Вам придется использовать специальные программы. Рекомендую поискать в интернете следующие программы:

PowerStrip - Программа управления параметрами видеоподсистемы вашего компьютера, поддерживается огромное разнообразие видео карт. Это - фактически единственная программа своего рода, которая поддерживает видео карты из многочисленного набора чипсетов и поставщиков, одновременно, под любой операционной системой. Программа спокойно сидит в трее и оттуда обеспечивает доступ к более 500 элементов управления над вашими дисплейными аппаратными средствами, включая цветные инструментальные средства коррекции, установки уровня периода экранной геометрии, и драйверо-независимыми элементами управления часов.

Screen Resolution Manager - Программа, позволяющая каждому пользователю компьютера устанавливать свое разрешение экрана. Помимо разрешения можно настроить глубину цвета, частоту, яркость и контрастность, цветовую гамму и другие настройки, которые автоматически вступят в силу после загрузки профиля определенного пользователя.

Назад на страницу раздела Настройки.


14. Создание диска восстановления системы и загрузка с него.

Если у вас есть установочный диск Windows 7, создавать диск восстановления необязательно. Если же установочного диска у вас нет, создать диск восстановления нужно обязательно - он вам рано или поздно пригодится. С установочного диска можно загрузиться в среду восстановления Windows RE.

Создание диска восстановления системы

1) Вставьте чистый компакт-диск в привод.
2) Откройте Пуск -> Панель Управления -> Архивация и восстановление (Backup and Restore)
3) В левой панели щелкните ссылку Создать диск восстановления системы.

Загрузка с диска восстановления системы

1) Вставьте диск восстановления в привод и перезагрузитесь
2) В BIOS должен быть установлен приоритет загрузки с привода. Будет выполнена загрузка в Windows RE.
3) Выберите систему, которую вы хотите восстановить.
4) Установите переключатель Используйте средства восстановления... и нажмите кнопку Далее. Вы увидите окно с вариантами восстановления.

Назад на страницу раздела Настройки.


15. Изменение строки в загрузочном меню Windows 7 с "Предыдущая версия Windows" на "Windows ХР".

1) Запустите cmd.exe от имени администратора(Win+R -> cmd -> Ok)
2) Выполните следующие команды, нажимая после введения каждой Enter

Назад на страницу раздела Настройки.


16. Перенесение файлов загрузки, при удалении из системы одного из жестких дисков.

Вы решили заменить или продать один из ваших жестких дисков. Прежде чем это сделать, убедитесь что файлы загрузки Windows 7 не содержаться на удаляемом Вами из системы жестком диске.
Windows 7 хранит свои файлы для загрузки на активном диске, который может отличаться от того на котором установлена Windows 7. Файлами загрузки для Windows 7 являются файл bootmgr и хранилище данных конфигурации загрузки BCD (Boot Configuration Data), находящееся в скрытой и системной папке Boot.

При загрузке Windows 7 проверяет соблюдение 3 условий:

- Является ли диск, с которого выполняется загрузка активным;
- Совместима ли Главная Загрузочная Запись (Master Boot Record - MBR) с bootmgr (Диспетчером загрузки Windows);
- Находиться ли файлы загрузки операционной системы на активном диске должны.

В случае не соблюдения одного из условий, загрузка становится невозможной.

Предположим, что Ваша Windows 7 установлена на диск С:, который не активен. Активным является только диск D:, который Вы собираетесь удалить из системы и на котором находятся Файлы загрузки Windows 7, имеющие атрибуты Скрытый и Системный.

В качестве решения предлагаю Вам выполнить перенесение файлов загрузки Windows 7 с активного раздела (удаляемый жесткий диск) на неактивный раздел (остающийся в системе жесткий диск, с присвоением ему атрибута - Активный).

1) Выяснение атрибутов дисков и присвоение остающемуся в системе жесткому диску атрибута Активный.

Способ 1. Используя оснастку "Управление дисками".

1.1.1) Нажмите Win + R, в строке "Выполнить" наберите diskmgmt.msc и нажмите OK
1.1.2) В нижней части окна, где находится графическое представление разделов, найдите том (раздел) на котором установлена Ваша Windows 7 Буква тома здесь, идентична букве диска с Window 7 из Мой Компьютер.
1.1.3) Под буквой тома, размером диска и файловой системой будут указаны атрибуты диска. Посмотрите имеет ли наш том атрибут "Активный". Если да, то Вы сможете спокойно удалить Ваш диск из системы. Если же нет, то Вам необходимо будет присвоить данный атрибут, в соответствии с написанным ниже.
1.1.4) Если Ваша Windows 7 установлена на жесткий диск, разбитый на несколько разделов, то выберите первый слева раздел остающегося у Вас диска, его мы сделаем загрузочным и активным. Если же раздел всего один, то выберите его.
1.1.5) Щелкните правой кнопкой мыши по выбранному разделу и выберите в контекстном меню пункт "Сделать раздел активным". Учтите, что этот раздел должен иметь атрибут "Основной".

Способ 2. Используя командную строку.

1.2.1) Запустите командную строку с правами администратора. Нажмите Win + R, в строке "Выполнить" наберите cmd и нажмите OK.
1.2.2) Последовательно выполните все команды без выхода из командной строки:

где X - номер диска, который предполагается оставить, в списке дисков (команда list disk).

2) Перезапись загрузочного сектора MBR и установка его совместимости с bootmgr:

2.1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe)
2.2) Создайте папку Boot
2.3) Распакуйте скачанный архив и скопируйте файлы Bootsect.exe и Bcdedit.exe, нужной Вам битности в созданную Вами папку Boot.
2.4) Запустите командную строку с правами администратора.

где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /force - принудительно отключает один или несколько томов во время обновления загрузочного кода. Необходим, при наличии в конфигурации 2-х и более жестких дисков.

3) Перенесение BCD (Boot Configuration Data) и файла bootmgr на новый активный раздел:

где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /l - выбор языковых параметров менеджера загрузки. Если ваша система не русскоязычная, используйте другие значения этого ключа, например, для английского языка - en-US, для немецкого - de-DE, и т.д.
- ключ /s - определяет букву тома, назначенную целевому системному разделу, в который копируются файлы среды загрузки. Это раздел, который мы сделали активным. Windows 7 использует текущий загрузочный раздел (в нашем случае - раздел D:) до завершения своей работы. Поэтому применение этого ключа с указанием буквы нового загрузочного раздела (в нашем случае - раздел С:) - обязательно.

Назад на страницу раздела Настройки.


17. Способы доступа к элементам Панели управления.

В разных статьях Вы можете увидеть разное описание пути к одинаковым элементам Панели управления. Такое происходит потому что в Windows существует два вида отображения элементов: Категория(элементы сгруппированы по тематикам) и Крупные или Мелкие значки (элементы отображаются полным списком) Имхо, наиболее удобным является Крупные или Мелкие значки(их полный список).

Существует несколько способов доступа к элементам Панели управления:

1) Через меню Пуск.

Для быстрого доступа к элементам Панели управления, рекомендуется добавить в меню Пуск всплывающее меню содержащее все элементы Панели Управления.
1.1) Нажмите правой кнопкой мыши на кнопке Пуск и щелкните на пункте Свойства.
1.2) Нажмите Настроить...
1.3) Промотайте до записи Панель управления.
1.4) Установите значение переключателя под ней в положение Отображать как меню и нажмите OK
Всплывающее меню Панели управления будет отображаться полным списком, независимо от Вашего выбора вида отображения.

2) Через Проводник Windows.

2.1) Запустите Проводник
2.2) В панели меню выберите Сервис и нажмите Параметры папок
2.3) Под надписью Область переходов установите флажок напротив значения Показать все папки и нажмите OK
Теперь Панель управления будет доступна в Проводнике в Области переходов слева. Преимущество данного способа в том что Вы можете работать, как сразу с полным списком элементов: Проводник -> Панель управления -> Все элементы панели управления, так и с отдельными разделами: Проводник -> Панель управления -> Нужный Вам раздел.

3) На рабочем столе.

3.1) Щелкните правой кнопкой мыши на Рабочем столе и нажмите Персонализация
3.2) Щелкните Изменение значков рабочего стола
3.3) Установите флажок напротив Панель управления и нажмите ОК
На Рабочем столе появится ярлык запускающий папку Панель управления. Способ отображения зависит от выбранного Вами значения параметра Просмотр.

4) Добавление или запуск папки Панель управления используя {GUID}

Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

Control Panel.{26EE0668-A00A-44D7-9371-BEB064C98683}

Для её запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win+R) и введите команду:

shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}

5) Запуск элементов Панели управления, используя канонические имена.

Русское название элемента | Английское название элемента | Команда
Панель управления | Control Panel | control
Windows CardSpace | Windows CardSpace | control /name Microsoft.CardSpace
Windows SideShow | Windows SideShow | control /name Microsoft.WindowsSideShow
Автозапуск | AutoPlay | control /name Microsoft.AutoPlay
Автономные файлы | Offline Files | control /name Microsoft.OfflineFiles
Администрирование | Administrative Tools | control /name Microsoft.AdministrativeTools
Архивация и восстановление | Backup and Restore | control /name Microsoft.BackupAndRestore
Биометрические устройства | Biometric Devices | control /name Microsoft.BiometricDevices
Брандмауэр Windows | Windows Firewall | control /name Microsoft.WindowsFirewall
Восстановление | Recovery | control /name Microsoft.Recovery
Гаджеты рабочего стола | Desktop Gadgets | control /name Microsoft.DesktopGadgets
Дата и Время | Date and Time | control /name Microsoft.DateAndTime
Датчик расположения и другие датчики | Location and Other Sensors | control /name Microsoft.LocationAndOtherSensors
Диспетчер устройств | Device Manager | control /name Microsoft.DeviceManager
Диспетчер учетных данных | Credential Manager | control /name Microsoft.CredentialManager
Домашняя группа | HomeGroup | control /name Microsoft.HomeGroup
Защитник Windows | Windows Defender | control /name Microsoft.WindowsDefender
Звук | Sound | control /name Microsoft.Sound
Значки области уведомлений | Notification Area Icons | control /name Microsoft.NotificationAreaIcons
Игровые устройства | Game Controllers | control /name Microsoft.GameControllers
Инфракрасная связь | Infrared | control /name Microsoft.Infrared
Папка "Fonts" | Fonts Folder | control /name Microsoft.Fonts
Параметры индексирования | Indexing Options | control /name Microsoft.IndexingOptions
Параметры папок | Folder Options | control /name Microsoft.FolderOptions
Параметры планшетного компьютера | Tablet PC Settings | control /name Microsoft.TabletPCSettings
Перо и сенсорные устройства | Pen and Touch | control /name Microsoft.PenAndTouch
Персонализация | Personalization | control /name Microsoft.Personalization
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection | control /name Microsoft.RemoteAppAndDesktopConnections
Получение программ | Get Programs | control /name Microsoft.GetPrograms
Приступая к работе | Getting Started | control /name Microsoft.GettingStarted
Программы и компоненты | Programms and Features | control /name Microsoft.ProgramsAndFeatures
Программы по умолчанию | Default Programs | control /name Microsoft.DefaultPrograms
Распознавание речи | Speech Recognition | control /name Microsoft.SpeechRecognition
Расположение по умолчанию | Default Location | control /name Microsoft.DefaultLocation
Родительский контроль | Parental Controls | control /name Microsoft.ParentalControls
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | control /name Microsoft.TaskbarAndStartMenu
Свойства речи | Text to Speech | control /name Microsoft.TextToSpeech
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | control /name Microsoft.iSCSIInitiator
Свойства: Интернет | Internet Properties | control /name Microsoft.InternetOptions
Свойства: Клавиатура | Keyboard Properties | control /name Microsoft.Keyboard
Свойства: Мышь | Mouse Properties | control /name Microsoft.Mouse
Система | System | control /name Microsoft.System
Сканеры и камеры | Scanners and Cameras | control /name Microsoft.ScannersAndCameras
Соседние пользователи | People Near Me | control /name Microsoft.PeopleNearMe
Счетчики и средства производительности | Performance Information and Tools | control /name Microsoft.PerformanceInformationAndTools
Телефон и модем | Phone and Modem | control /name Microsoft.PhoneAndModem
Управление цветом | Color Management | control /name Microsoft.ColorManagement
Устранение неполадок | Troubleshooting | control /name Microsoft.Troubleshooting
Устройства и принтеры | Devices and Printers | control /name Microsoft.DevicesAndPrinters
Учетные записи пользователей | User Accounts | control /name Microsoft.UserAccounts
Центр мобильности Windows | Windows Mobility Center | control /name Microsoft.MobilityCenter
Центр обновления Windows | Windows Update | control /name Microsoft.WindowsUpdate
Центр поддержки | Action Center | control /name Microsoft.ActionCenter
Центр синхронизации | Sync Center | control /name Microsoft.SyncCenter
Центр специальных возможностей | Ease of Access Center | control /name Microsoft.EaseOfAccessCenter
Центр управления сетями и общим доступом | Network and Sharing Center | control /name Microsoft.NetworkAndSharingCenter
Шифрование диска BitLocker | BitLocker Drive Encryption | control /name Microsoft.BitLockerDriveEncryption
Экран (размер текста) | Display (size of text) | control /name Microsoft.Display
Электропитание | Power Options | control /name Microsoft.PowerOptions
Язык и региональные стандарты | Region and Language | control /name Microsoft.RegionAndLanguage

При отсутствии в системе необходимого устройства, драйверов или определенных компонентов, соответствующий ему элемент Панели управления может не запуститься.

Назад на страницу раздела Настройки.


18. Отключение значка "Центра поддержки" из области уведомлений на панели задач.

Если во время работы у Вас в трее появился флаг "Центра поддержки", и Вы хотите его убрать, то проделайте следующее.

1) Щелкните правой кнопкой мыши на Панели задач и выберите пункт "Свойства".
2) Нажмите на кнопку "Настроить".
3) Перейдите по ссылке "Включить или выключить системные значки"
4) Установите значение системного значка "Центр поддержки" в "Выкл" и нажмите ОК.

Назад на страницу раздела Настройки.


19. Добавление своей программы в утилиту msconfig (Конфигурация системы).

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните с именем mscfgtlc.xml
3) Скопируйте файл в папку C:\Windows\system32\
4) Нажмите кнопку Сохранить

Например:

или

Добавленная Вами программа появится во вкладке Сервис (Tools). Для использования русских букв файл необходимо сохранить файл в кодировке UTF-8. В качестве пути можно указать только файлы из папок Windows или Programm Files включая подпапки.

Назад на страницу раздела Настройки.


20. Настройка параметров индексирования для ускорения выполнения поиска в системе.

Операционная система Windows использует индекс для выполнения быстрого поиска наиболее часто используемых файлов. По умолчанию индексируются все самые распространенные файлы на компьютере. Повысить производительность поиска в Windows 7 можно, следующим образом.

Добавление или удаление расположения из индекса.

1) Откройте меню Пуск, введите в строке поиска Параметры индексирования и нажмите Enter.
2) Щелкните Изменить.
3) Установите или снимите флажок с папок в списке Изменение выбранных расположений, которые Вы желаете добавить или удалить для ускорения поиска, а затем нажмите кнопку ОК.
4) Если в списке отображаются не все расположения на компьютере, нажмите кнопку Показать все расположения. (Если в списке отображаются все расположения на компьютере, кнопка Показать все расположения недоступна.) Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
5) Если требуется добавить папку, исключая некоторые вложенные папки, щелкните папку и затем снимите флажки рядом с теми вложенными папками, которые не требуется индексировать. Эти папки будут отображены в столбце «Исключить» в разделе Сводный список выбранных расположений.

Индексировать все файлы на компьютере не рекомендуется, так как если сделать индекс слишком большим или добавить в индекс расположения системных файлов (например, папки «Program Files»), поиск будет выполняться медленно.

Добавление или удаление типа файла из индекса.

1) Откройте меню Пуск, введите в строке поиска Параметры индексирования и нажмите Enter.
2) Щелкните Дополнительно. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
3) Перейдите на вкладку Типы файлов.
4) Снимите флажок с расширений в списке, которые Вы желаете удалить для ускорения поиска.
5) В поле Добавить новое расширение введите расширение имени файла, которые Вы желаете добавить для ускорения поиска, а затем нажмите кнопку Добавить.
6) Установите переключатель в значение Индексировать только свойства при большом количестве выделенных расширений или Индексировать свойства и содержимое файлов при небольшом, а затем нажмите кнопку ОК.

Назад на страницу раздела Настройки.


Администрирование

1. Получение полного доступа к файлу или папке.

1) Создайте reg файл
1.1) Скопируйте код в любой текстовый редактор (например, Блокнот).
1.2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "admin.reg")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

2) Примените его
3) Щелкните на файле или папке правой кнопкой мышки и выберите пункт "Стать владельцем и задать полный доступ к объекту"
4) В любых окнах, если они появятся нажимаете Да(Yes)

Скачать готовый reg-файл: Full_access.zip

Если Вам необходимо изменить права доступа, а после использования файла вернуть все права обратно, то Вы можете воспользоваться программой TakeOwnershipEx от Happy Bulldozer, которая обладает следующими возможностями:

  • Получение прав на один или сразу несколько файлов. В диалоге открытия Вы можете выбрать сразу несколько файлов, выделяя их мышкой и удерживая клавишу CTRL или SHIFT. Выбранным файлам в качестве владельца выставляется группа локальных "Администраторов", и предоставляется полный доступ для этой группы.

  • Восстановление прав. Если Вы получили права владельца и полный доступ, утилита запоминает, какие права у файла были до этого, и потом Вы в любой момент можете их вернуть на место.

    • 2. Запуск командной строки от имени (с правами) администратора.

    Если Вы работаете под учетной записью обычного администратора, то командная строка от имени администратора запускается так:

    Вариант 1.

    1) В строке поиска меню Пуск введите команду: cmd.
    2) Щелкните на найденном файле cmd.exe правой кнопкой мыши и выберите пункт Запуск от имени администратора

    Вариант 2.

    В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl+Shift+Enter.

    Вариант 3.

    1) Нажмите кнопку Пуск
    2) Перейдите Все Программы -> Стандартные
    3) Щелкните правой кнопкой мыши на Командная строка и выберите пункт Запуск от имени администратора.

    Если Вы работаете под встроенной учетной записью администратора, то кроме указанных выше вариантов Вы можете использовать еще один вариант:

    Вариант 4.

    1) Запустите диалоговое меню Выполнить. В зависимости от Ваших настроек: Откройте Пуск -> Выполнить или нажмите комбинацию клавиш Win+R.
    2) Введите команду: cmd и нажмите Enter.

    3. Изменение прав доступа и владельца для файла (папки), используя проводник или командную строку.

    Случается, что при работе с файлами или папками Вам бывает необходимо изменить для них владельца и права доступа.

    Смена владельца файла или папки, используя проводник.

    1) Щелкните файл или папку правой кнопкой мыши, выберите команду Свойства и перейдите на вкладку Безопасность.
    2) Нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3) Нажмите кнопку Изменить и выполните одно из следующих действий:

  • Чтобы назначить владельцем пользователя или группу из списка, в окне Изменить владельца на выберите нового владельца и нажмите ОК.
  • Чтобы назначить владельцем пользователя или группу, которых нет в списке:

    • 1) Нажмите кнопку Другие пользователи и группы
    2) Если владельцем необходимо установить службу TrustedInstaller, в качестве имени объекта в поле Введите имена выбираемых объектов (примеры) введите: NT SERVICE\TrustedInstaller и нажмите кнопку ОК.
    3) Если владельцем необходимо другого пользователя или группу, то нажмите кнопку Дополнительно, а затем кнопку Поиск.
    3.1) В результатах поиска выберите необходимую Вам группу или пользователя и нажмите кнопку ОК.

    4) В окне Изменить владельца на: выберите добавленную группу или пользователя.
    5) Чтобы сменить владельца всех субконтейнеров и объектов в папке, установите флажок Заменить владельца субконтейнеров и объектов и нажмите кнопку ОК.

    Изменение разрешений для доступа к файлам и папкам, используя проводник.

    1) Щелкните правой кнопкой мыши файл или папку, для которых нужно задать разрешения, выберите команду Свойства и откройте вкладку Безопасность.
    2) Нажмите кнопку Изменить разрешения и выполните одно из следующих действий:
    2.1) Чтобы изменить разрешения для существующей группы или пользователя, выберите имя этой группы или пользователя и нажмите кнопку Изменить.
    2.1.1) Установите необходимые Вам флажки Разрешить или Запретить напротив каждого разрешения и нажмите кнопку ОК, а затем кнопку Применить.
    2.2) Чтобы изменить разрешения для группы или пользователя, которого нет в списке Элементы разрешений, нажмите кнопку Добавить.

    2.2.1) Если необходимо изменить разрешения для службы TrustedInstaller, в качестве имени объекта в поле Введите имена выбираемых объектов (примеры) введите: NT SERVICE\TrustedInstaller и нажмите кнопку ОК.
    2.2.2) Если необходимо изменить разрешения для другого пользователя или группы, то нажмите кнопку Дополнительно, а затем кнопку Поиск.
    2.2.3) В результатах поиска выберите необходимую Вам группу или пользователя и нажмите кнопку ОК.
    2.2.4) Установите необходимые Вам флажки Разрешить или Запретить напротив каждого разрешения и нажмите кнопку ОК, а затем кнопку Применить.

    2.3) Чтобы удалить группу или пользователя из списка Элементы разрешений, нажмите кнопку Удалить.

    Далее рассказывается как можно изменить разрешения или сменить владельца, используя командную строку запущенную от имени администратора.
    Если после использовании команды, разрешения или владелец не сменятся, то возможно Вам придется зайти в систему под встроенной учётной записью "Администратор" для их выполнения заново.

    Изменение владельца файла (папки) на указанного Вами пользователя, используя командную строку.

    Примеры:

    Параметры:

    /T - операция выполняется для всех соответствующих файлов и каталогов, расположенных в указанных в имени каталогах.
    /C - выполнение операции продолжается при любых файловых ошибках. Сообщения об ошибках по-прежнему выводятся на экран.
    /L - операция выполняется над самой символической ссылкой, а не над ее целевым объектом.
    /Q - команда icacls подавляет сообщения об успешном выполнении.

    Изменение разрешений для файла (папки), используя командную строку.

    Разрешения:

    F - полный доступ
    M - доступ на изменение
    RX - доступ на чтение и выполнение
    R - доступ только на чтение
    W - доступ только на запись
    D - доступ на удаление

    Примеры:

    Об остальных возможностях команды icacls Вы сможете узнать введя команду: icacls /?

    4. Автоматический вход в систему и отключение экрана пользователей при запуске.

    Если вы хотите ускорить процесс загрузки Windows 7, то вы можете настроить автоматический вход в систему. Эта возможность создана для тех ситуаций, когда компьютером пользуется один человек. Настроив автоматический вход, вам не нужно будет вводить пароль каждый раз, когда загружается ваша операционная система.
    Чтобы настроить автоматический вход в Windows 7, сделайте следующее:

    1. Нажмите на клавиатуре Win+R (или пункт Выполнить в меню Пуск).
    2. В появившемся окне введите “control userpasswords2” (без кавычек) и нажмите Enter.
    3. В окне Учетные записи пользователей во вкладке Пользователи выделите свою учетную запись и уберите флажок с “Требовать ввод имени пользователя и пароля”.
    4. Нажмите Принять.
    5. В открывшемся окне Автоматический вход в систему будут три поля - Пользователь, Пароль и Подтверждение. Введите свой пароль в поле Пароль и еще раз - в поле Подтверждение и нажмите ОК.

    Всё. Со следующей перезагрузки системы вам больше не нужно будет вводить свой пароль. Вход в Windows будет происходить автоматически.
    (Возможен побочный эффект: после перезагрузки панель "Quick Launch" не сохраняется - после рестарта её нет.)

    5. Ограничение разрешенных действий для пользователей, имеющих временный доступ к компьютеру.

    Вариант 1.

    1.1) Запустите оснастку Локальные пользователи и группы (Win+R -> lusrmgr.msc -> Ok)
    1.2) Включите встроенную гостевую учетную запись пользователя. Дважды щелкните на профиль Гость, уберите флажок с Отключить учетную запись и нажмите OK.
    1.3) Откройте Панель управления\Все элементы панели управления\Учетные записи пользователей и нажимаете ссылку Управление другой учетной записью.
    При желании, можете поставить на свою учетную запись пароль.
    1.4) Нажмите на учетную запись Гость, а затем нажмите на кнопку Включить.
    1.5) Для перехода в гостевую учетную запись щелкните на стрелочке рядом с Завершение работы и выберите пункт Сменить пользователя. Обратный переход аналогично.

    Вариант 2.

    2.1.1) Запустите оснастку Редактор локальной групповой политики (Win+R -> gpedit.msc -> Ok)
    2.1.2) В Административные шаблоны, дважды щелкните на элементе Все параметры
    2.1.3) Отсортируйте элементы по-названию.
    2.1.4) Включите необходимые Вам параметры начинающиеся со слов Запретить .... Для этого, дважды щелкните на необходимом элементе установите переключатель в значение Включить и нажмите Ок.

    Также в оснастке Редактор локальной групповой политики Вы можете осуществлять контроль за приложениями, на основе создаваемых Вами правил, разрешать или запрещать запуск затрагиваемых файлов, основываясь на их атрибутах. К примеру, можно создать правило, позволяющее запускать все приложения, подписанные конкретным издателем (например, Microsoft) или находящиеся по определеному пути (Например: C:\Program Files\Mozilla Firefox). Для этого Вам необходимо создать Исполняемые правила, используя мастер правил AppLocker.
    Для создания нового правила сделайте следующее:

    2.2.1) Пройдите в Конфигурация компьютера -> Конфигурация Windows -> Параметры безопасности -> Политики управления приложениями -> AppLocker.
    2.2.2) Нажмите на Исполняемые правила
    2.2.3) В меню оснастки Редактор локальной групповой политики нажмите Действие и выберите пункт Создать новое правило..., также Вы можете щелкнуть правой кнопкой мыши в правой части окна и также выбрать из списка пункт Создать новое правило....

    Вариант 3.

    3) Воспользуйтесь программой Deep Freeze или аналогичной ей, данная программа позволяет заморозить текущее состояние системы. С её помощью можно сохранить текущую конфигурацию системы, к которой машина будет автоматически возвращаться после перезагрузки. При этом абсолютно не имеет значения что делает пользователь - устанавливает новые программы, удаляет системные файлы или работает в сети - после перезагрузки вы получите девственно чистую машину.
    Для отключения Deep Freeze надо нажать Ctrl+Shift+Alt+F6 и выбрать Boot Thawed, для удаления Deep Freeze сначала его надо отключить, а потом запустить установочный файл и выбрать Uninstall.

    6. Быстрый запуск программы с правами администратора.

    Удерживайте Ctrl+Shift и нажмите на иконку приложения (у Вашей учетной записи, должны быть права администратора).

    7. Убирание запрещающего значка с папки.

    1) Нажимаете правой кнопкой мыши на папке с которой Вы хотите убрать значок замка и выбираете Свойства
    2) Переходите на вкладку Безопасность
    3) Нажимаете на кнопки Изменить -> Добавить -> Дополнительно -> Поиск
    4) В результатах поиска удерживая нажатой клавишу Ctrl, выбираете следующие имена: система; Администраторы; Прошедшие проверку; и нажимаете Ок
    5) В окне группы или пользователи выбираете система; и ставите флажок на Полный доступ, после выбираете Администраторы; и снова ставите флажок на Полный доступ, а затем выбираете Прошедшие проверку; и также ставите флажок на Полный доступ.
    6) Нажимаете Ок

    При возникновении окон "Ошибка применения безопасности" нажимайте Продолжить.

    Также Вы можете воспользоваться решением предложенным в совете Администрирование: 1. Получение полного доступа к файлу или папке.

    1) Создайте reg-файл(например: admin.reg) как описано в Администрирование: 1. Получение полного доступа к файлу или папке.
    2) Примените его
    3) Щелкните на папке и выберите пункт "Стать владельцем и задать полный доступ к объекту"
    4) В любых окнах, если они появятся нажимаете Да(Yes)

    8. Запуск приложений в Windows 7 c повышенными привилегиями без отключения UAC.

    Многие пользователи считают функцию контроля учётных записей(UAC) в Windows 7 весьма полезной и не отключают её . Но иногда всё же требуется запустить приложение с повышенными правами, а некоторые приложения, такие как, например, Sysinternals Process Explorer или Sysinternals Autoruns, и вовсе лучше всегда запускать с повышенными привилегиями.
    Конечно, Вы можете воспользоваться одним из простых способов, и постоянно щелкать уведомления UAC:

    1) Нажмите правой клавишей мыши по значку нужного приложения и выберите пункт "Запуск от имени администратора"
    2) Нажмите Пуск, в строке поиска наберите нужную команду и нажмите Ctrl+Shift+Enter.
    3) Щелкните правой клавишей мыши по нужному ярлыку и выберите пункт "Свойства". Или перейдите на вкладку "Совместимость" и установите флажок "Выполнять эту программу от имени администратора"

    Есть также и другой способ, через создание высокопривилегированной задачи системного планировщика заданий. Способ немного сложнее предыдущих, но запросы UAC не отображаются.

    1) Запускаете планировщик заданий (Пуск ---> Все программы ---> Стандартные ---> Служебные ---> Планировщик заданий)
    2) Нажимаете "Создать задачу"
    3) Указываете Имя для новой задачи и ставите флажок "Выполнять с наивысшими правами"
    4) Переходите на вкладку Действия, нажимаете "Создать", в следующем окне нажимаем "Обзор"
    5) Указываете путь к нужному приложению и нажимаете "Открыть"
    6) Нажимаете "ОК", затем снова "ОК"
    7) Создайте ярлык на рабочем столе ( Нажмите правую кнопку мыши, выберете "Создать" ---> "Ярлык")
    8) В поле Расположение объекта введите:

    где mytask_admin - имя созданной нами задачи. Если в имеми содержаться робелы, обязательно укажите его в кавычках.
    9) Введите имя ярлыка и нажмите Готово

    Но есть и более легкий способ, создания ярлыка, при запуске которого не отображаются запросы UAC - это использовать приложение Elevated Shortcut.
    Оно автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает на рабочем столе необходимый ярлык. Просто перетащите необходимый исполняемый файл на окно программы Elevated Shortcut.

    Скачать можно здесь или здесь

    9. Перемещение профилей пользователей и изменение путей к ним.

    Указанные в с 1 по 4 вариантах действия, необходимо повторять для каждого профиля. Переместив таким образом все профили, и изменив их пути в реестре, исходные папки можно будет удалить.

    Вариант 1. С помощью компонента Windows - "Профили пользователей".

    Скопируйте профиль пользователя в конечное размещение:

    1) Если папка для профиля существует, перейдите к следующему шагу, при этом используя рекомендации; если папка, в которой будет храниться профиль, не существует, создайте ее, используя рекомендации.

    Рекомендации:

  • Если на компьютере только одна учетная запись, можно присвоить папке профиля имя учетной записи; если учетных записей несколько, лучше всего создать папку верхнего уровня, например, с именем Пользователи, а в нее вложить папки с именами пользователей компьютера, в которых и будут храниться наши профили. Хотя использовать папку верхнего уровня лучше сразу, на случай добавления новых учетных записей;
  • Если конечная папка уже существует и она имеет содержимое, которое необходимо сохранить, ее необходимо скопировать в другое размещение, а затем, после завершения перемещения профилей, переместить это содержимое в папку с профилем пользователя

    • 2) Откройте Система: команда свойства контекстного меню Компьютер или сочетание Windows + Break.
    3) Щелкните Дополнительные параметры системы. Щелкните Продолжить, если появится соответствующий запрос системы контроля учетных записей.
    4) Откройте вкладку Дополнительно.
    5) Щелкните кнопку Параметры в рамке Профили пользователей.
    6) Выберите профиль, который необходимо переместить. Активный профиль не выбирается. Чтобы его можно было выбрать для осуществления необходимых действий, нужно войти под другой учетной записью и иметь права администратора.
    7) Нажмите кнопку Копировать.
    8) Выберите папку, в которой будет находиться профиль, созданную на шаге 1.
    9) Нажмите OK; если выбранная папка не пустая, система выдаст запрос на копирование профиля в нее, так как при этом удаляется все ее содержимое! (не забудьте о рекомендациях!). Нажмите Да.

    Внесите изменения в системный реестр.

    1) Откройте меню Выполнить: Пуск -> Выполнить (либо Win+R)
    2) Введите regedit.exe, нажимаем Enter.
    3) Измените значение параметра ProfileImagePath в ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID, где SID – идентификатор безопасности пользователя, присваивая ему значение пути к папке, в которую был предварительно скопирован профиль. Убедиться в том, что данный ключ содержит ключ к необходимому нам профилю, можно по значению ProfileImagePath, содержащему путь к текущему размещению профиля пользователя.
    Также Вы можете воспользоваться скриптом SIDList.vbs для выяснения, какому аккаунту принадлежит какой SID.
    4) Перезагрузите компьютер.

    Внесение изменений в системный реестр может привести к снижению стабильности и производительности системы или ее отказу, поэтому настоятельно рекомендуется создать резервную копию реестра перед выполнением данной операции. В данном случае удобно воспользоваться экспортом изменяемого ключа или Восстановлением системы.

    Вариант 2. На другой диск вручную.

    1) Запустите оснастку "Локальные пользователи и группы" (Win+R -> lusrmgr.msc -> Ok)
    2) Включите системную запись администратора. Выбираете "Пользователи". В свойствах пользователя "Администратор" снимаете галку "Отключить пользователя". Если же Вы уже работаете в учетной записи Администратор, то создайте новую учетную запись с правами администратора.
    3) Для полного доступа к файлам и папкам перезапустите компьютер, и зайдите под аккаунтом "Администратор" (или под созданным Вами с правами администратора).

    Указанные выше действия необходимы, потому что профиль под которым Вы зайдете, для осуществления необходимых действий не выбирается. Соответственно залогинившись под одним профилем, Вы можете работать только с другими.

    4) Запустите "Проводник" в режиме администратора:
    Щелкните правой кнопкой мыши на иконке Проводника
    Щелкните правой кнопкой мыши на слове Проводник
    Выберите пункт "Запуск от имени администратора"
    5) Создайте на диске D: папку Users.
    6) Поменяйте права на "D:\Users", исходя из прав на системный Users.
    Оставьте только "Чтение и выполнение" для группы "Everyone"(Все), и "Полный доступ" для групп "Administrators" (Администраторы) и "System".
    На вкладке "Разрешения" (Безопастность\Дополнительно\Разрешения\Изменить разрешения) уберите галочку с пункта "Добавить разрешения, наследуемые от родительских объектов" и нажмите на кнопку Добавить(иначе удаляться все группы и Вам придется их прописывать самостоятельно)
    Владелец папки, установите на "Administrators" (Администраторы).
    7) В Проводнике запущенном от имени Администратора скопируйте необходимую Вам папку пользователя в "D:\Users".

    Так как Проводник не умеет копировать "junction" (точки соединения, исполняющие роль символической ссылки одного каталога компьютера на другой каталог), то их придется создавать самостоятельно. Например, "junction" являются папки "Application Data", "Local Settings", "SendTo" и другие.

    8) Запустите командную строку от имени администратора (Win+R -> CMD -> Ok)
    9) Для показа только скрытых файлов введите команду "dir /ah" (без кавычек) и нажмите Enter. Вы увидите примерно следующее:

    10) Создайте аналогичные "Junction" каталоги:

    Способ 1. Вручную для каждого "Junction" каталога.

    1) В командной строке переходите в созданную Вами папку:

    2) И для каждой "Junction" выполняете команду:

    Например:

    Способ 2. Создание bat-файла.

    Если Вам предстоит перенести несколько профилей, то проще будет создать bat-файл, так как "Junction" у Вас скорее всего будут такие же.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .bat
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "profiles.bat")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    В моем случае получился такой, Вы можете создать аналогичный для своих папок (запускаете его из каталога профиля "D:\Users\ВашПрофиль"):

    Если у Вас папки имеют русские названия, то для правильной работы данного bat-файла, надо его сохранять в кодировке CP866 (Блокнот Windows, в ней не сохраняет, используйте для этого программы сторонних производителей например: Akelpad).
    11) Присвойте "Junction" каталогам скрытые и системные атрибуты, как в оригинале.

    Либо, вручную для каждого в командной строке.

    Например:

    Либо, создав bat-файл (запускаете его из каталога профиля "D:\Users\ВашПрофиль"):

    12) Запустите Реестр Windows(Win+R -> regedit -> Enter) и измените значение параметра ProfileImagePath в ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID c "C:\Users\ВашПрофиль" на "D:\Users\ВашПрофиль" , где SID – идентификатор безопасности пользователя, присваивая ему значение пути к папке, в которую был предварительно скопирован профиль. Убедиться в том, что данный ключ содержит ключ к необходимому нам профилю, можно по значению ProfileImagePath, содержащему путь к текущему размещению профиля пользователя. Также Вы можете воспользоваться скриптом SIDList.vbs для выяснения, какому аккаунту принадлежит какой SID.
    13) Переименуйте или удалите каталог профиля в "C:\Users\", чтобы предотвратить к нему запросы.
    14) Перезагрузите компьютер, чтобы Windows подхватила внесенные нами настройки.
    15) Вновь зайдите под аккаунтом Администратор.
    16) Запустите Реестр Windows(Win+R -> regedit -> Enter)
    17) Используя Поиск найдите все строки с путем к папке "C:\Users\ВашПрофиль" и исправьте на "D:\Users\ВашПрофиль" (Чем ближе к чистой установке Вы это сделаете, тем меньше строк Вам придется исправлять).
    18) Поменяйте права на каталог профиля в "D:\Users".
    Установите "Полный доступ" пользователю - владельцу профиля, и "Полный доступ" для групп "Administrators" (Администраторы) и "System".
    На вкладке "Разрешения" (Безопасность\Дополнительно\Разрешения\Изменить разрешения) уберите галочку с пункта "Добавить разрешения, наследуемые от родительских объектов" и нажмите на кнопку Добавить(иначе удаляться все группы и Вам придется их прописывать самостоятельно).
    Владелец папки, установите на "System".
    19) Перезагрузите компьютер, теперь вы можете войти в перемещенный аккаунт и проделать всё указанное выше для другого профиля.

    Вариант 3. При помощи ERD Commander.

    1) Скачиваете утилиту Junction от SysInternals. Она позволяет создавать точки соединения, исполняющие роль символической ссылки одного каталога компьютера на другой каталог.
    2) Копируете junction.exe в C:\Windows\System32
    3) Загружаетесь в Erd Commander.
    4) Выбираете опцию, чтобы реестр не импортировался
    5) Копируете например: "C:\Documents and Settings\ВашПрофиль" в "D:\Users\ВашПрофиль"
    6) После копирования, удаляете "C:\Documents and Settings\ВашПрофиль"
    7) Запускаете командную строку и переходите в папку C:\Windows\System32

    8) После сообщения Sucsess, можете зайти в папку проверяем C:\Documents and Settings\ и увидите там папку ВашПрофиль, только это уже ссылка...

    Вариант 4. При помощи Far Manager.

    1) Скачиваете Far Manager и устанавливаете его.
    2) Входите в систему под другим пользователем с правами администратора
    3) Запускаете Far Manager
    4) Находите нужный профиль пользователя.
    5) Перемещаете папку с ним на другой диск (например, C:\Documents and Settings\ВашПрофиль -> D:\Users\ВашПрофиль).
    6) Устанавливаете на перемещённую папку нужные права и нужного владельца.
    7) Создаёте на исходном разделе символическую связь с новой папкой (Alt+F6).
    8) На новую папку ставите атрибут "Скрытый".

    Вариант 5. Изменение пути к каталогам пользователей при установке Windows.

    Вы можете изменить расположение папки Пользователи (Users), в которой будут храниться профили пользователей, ещё при установке Windows.

    1) Создайте файл Autounattend.xml следующего содержания:
    2) Скопируйте его в папку \Sources установочного диска.
    3) Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.

    10. Отключение отображения имени последнего пользователя.
    Для отключения запоминания имени последнего пользователя отображаемого на экране переключения пользователей.

    1) Нажмите Пуск, в строке поиска введите secpol.msc и нажмите Enter
    2) Раскройте группу Локальные политики и перейдите к разделу Параметры безопасности
    3) Используя двойной щелчок мыши откройте параметр Интерактивный вход в систему: не отображать последнее имя пользователя и выберите состояние Включен
    Этот параметр безопасности определяет, будет ли в экране входа в Windows отображено имя последнего пользователя, выполнившего вход.
    Если эта политика включена, в диалоговом окне входа не будет отображаться имя последнего пользователя, выполнившего вход.
    Если эта политика отключена, отображается имя последнего пользователя, выполнившего вход.

    11. Включение встроенной учетной записи администратора.

    Вариант 1

    1) Запустите оснастку Локальные пользователи и группы (Win+R -> lusrmgr.msc -> Ok)
    2) В меню слева нажмите на папку Пользователи
    3) Щелкните правой кнопкой учетную запись Администратор и выберите Свойства.
    4) Откроется окно Свойства: Администратор.
    5) На вкладке Общие снимите флажок Отключить учетную запись.

    Учетная запись администратора теперь включена.

    Вариант 2

    1) Нажмите кнопку Пуск
    2) Введите в строке поиска cmd
    3) Щелкните правой кнопкой мыши ярлык командной строки и выберите пункт Запуск от имени администратора

    Для включения встроенной учетной записи Администратор в русской версии Windows используйте команду

    В системе с английской локализацией встроенная учетная запись администратора называется Administrator, поэтому команда будет выглядеть так:

    Чтобы переключиться на данную учетную запись: нажмите на кнопку Пуск, нажмите на стрелочку рядом с Завершение работы и выберите Сменить пользователя.

    12. Изменение фонового рисунка в экране авторизации пользователей.

    Вариант 1. Вручную используя реестр Windows.

    1) Создайте ключ типа DWORD с названием OEMBackground в ветке реестра

    2) Присвойте ему значение 1 (1 означает, что функция включена, 0 - выключена)
    3) Создайте в папке %windir%\system32\oobe\ папку info, а в ней папку backgrounds (%windir%\system32\oobe\info\backgrounds)
    4) Поместите сюда свой файл
    5) Переименуйте его в необходимое имя (зависит от разрешения монитора):

    background768x1280.jpg
    background900x1440.jpg
    background960x1280.jpg
    background1024x1280.jpg
    background1280x1024.jpg
    background1024x768.jpg
    background1280x960.jpg
    background1600x1200.jpg
    background1440x900.jpg
    background1920x1200.jpg
    background1280x768.jpg
    background1360x768.jpg
    backgroundDefault.jpg - в случае нестандартного расширения монитора

    Размер изображений не должен превышать 256Кб.
    Если же изображение не может быть загружено по иным причинам (неверное соотношение сторон, размер и т.д.), загружается стандартное изображение из файла imagesres.dll.

    Вариант 2. Автоматически используя специальную программу.

    1) Скачайте архив программы tweakslogon.zip
    2) Разархивируйте файл в любую папку и запустите TweaksLogon.exe
    3) Нажмите на кнопку Change Logon Screen.
    4) В открывшемся окне выберите изображение и нажмите Открыть (Open)
    5) Если Ваше изображение больше 245 кб, то программа предложит Вам его сжать. Нажмите Да (Yes)
    6) Если Вы уже меняли с помощью данной программы фоновый рисунок, то программа сообщит вам об этом. Нажмите Ок

    Чтобы вернуть стандартный фоновый рисунок нажмите кнопку Revert to Default Logon Screen.

    13. Установка службы TrustedInstaller в качестве владельца папки или файла.

    У многих системных папок и файлов владельцем, имеющим права доступа на запись/удаление является служба TrustedInstaller. Конечно Вы можете задать права себе, если Вы являетесь администратором на компьютере, но это может привести к неполадкам в работе. Например, если Вы измените владельца папки winsxs для доступа к ней и не вернете обратно права TrustedInstaller, то некоторые программы могут не запуститься.

    Если Вы удалили ее из групп и пользователей в свойствах папки (файла) на вкладке Безопасность, то чтобы вернуть обратно в качестве владельца службу TrustedInstaller Вам необходимо сделать следующее:

    1) Щелкните правой кнопкой на папке (файле) и выберите пункт Свойства.
    2) Перейдите на вкладку Безопасность и нажмите кнопку Дополнительно.
    3) В открывшемся окне перейдите на вкладку Владелец и нажмите кнопку Изменить...
    4) Нажмите кнопку Другие пользователи или группы... , в текстовом поле введите NT SERVICE\TrustedInstaller и нажмите ОК.
    5) В окне Изменить владельца на: выберите TrustedInstaller и нажмите ОК.
    Если необходимо также изменить владельца вложенных папок, то перед нажатием на кнопку ОК установите флажок Заменить владельца подконтейнеров и объектов.

    Также Вам необходимо добавить службу TrustedInstaller в список групп и пользователей, имеющих доступ к папке (файлу).

    1) Щелкните правой кнопкой на папке (файле) и выберите пункт Свойства.
    2) Перейдите на вкладку Безопасность
    3) Нажмите кнопку Изменить..., а в открывшемся окне кнопку Добавить... .
    4) В текстовом поле введите NT SERVICE\TrustedInstaller и нажмите ОК.
    5) Установите флажок в колонке Разрешить напротив разрешения Полный доступ
    6) Нажмите на кнопки ОК.

    14. Изменение пароля или новой учетной записи администратора, используя средства восстановления системы.

    Чтобы сбросить пароль учётной записи администратора (или создать новую) без использования дополнительных программ, Вам понадобится либо установочный диск Windows 7, либо диск восстановления системы, либо LiveCD с Windows PE.

    Часть №1 - Настройка запуска командной строки перед экраном входа в Windows.

    1) Загрузитесь с установочного диска Windows 7 или с диска восстановления.
    2) Откройте командную строку Восстановление системы -> Далее -> Командная строка.
    3) Запустите редактор реестра. В командной строке наберите regedit и нажмите Enter.
    4) Выделите раздел HKEY_LOCAL_MACHINE и выберите пункт Загрузить куст в меню Файл.
    5) Перейдите на диск, где установлена Windows 7, и откройте файл: C:\Windows\System32\config\SYSTEM
    6) Введите произвольное имя для загружаемого раздела. Например: NewAdmin.
    7) Перейдите в раздел HKEY_LOCAL_MACHINE\NewAdmin\Setup
    8) Измените значение параметров (Щелчок правой кнопкой мыши на параметре -> Изменить):
    8.1) Для параметра CmdLine введите значение cmd.exe и нажмите ОК.
    8.2) Для параметра SetupType измените значение с 0 на 2 и нажмите ОК.
    9) Выделите раздел NewAdmin в HKEY_LOCAL_MACHINEи выберите пункт Выгрузить куст в меню Файл.
    10) Извлеките установочный диск или диск восстановления системы, закройте редактор реестра и командную строку, нажмите Перезагрузка в окне параметров восстановления.

    Часть №2 - Создание нового пароля или новой учетной записи администратора.

    Создание нового пароля.

    1) Продолжайте обычный вход в Windows 7 и перед входом в систему Вы увидите окно командной строки.
    2) Введите команду net user, чтобы отобразить все имеющиеся учётные записи.
    3) Для создания нового пароля введите следующую команду и подтвердите её выполнение клавишей Enter:

    Если имя или пароль содержат пробелы, вводите их в "кавычках".

    Создание новой учётной записи.

    Если у Вас отсутствует учетная запись администратора, то для ее создания введите приведенные ниже команды, нажимая после каждой клавишу Enter.

    Для русской (локализованной) Windows:

    1) Создание нового пользователя.

    2) Добавление пользователя в группу Администраторы (Administrators).

    3) Удаление пользователя из группы Пользователи (Users).

    Для английской Windows:

    1) Создание нового пользователя.

    2) Добавление пользователя в группу Администраторы (Administrators).

    3) Удаление пользователя из группы Пользователи (Users).

    По окончании ввода закройте окно командной строки. Используйте созданную учетную запись для входа в Windows.

    15. Определение процесса которому принадлежит текущее окно.

    1) Скачайте Process Explorer.zip
    2) Разархивируйте в любую папку и запустите программу procexp.exe.
    3) На панели инструментов Process Explorer нажмите левой кнопкой мыши на "значок-прицел".
    4) Не отпуская левой кнопки мыши, наведите "прицел" на интересующее Вас окно.
    5) Отпустите кнопку мыши и программа Process Explorer, выделит принадлежащий окну процесс (по умолчанию синим цветом).

    16. Удаление данных о серийном номере из системы для предотвращения его хищения.

    Если Вы имеете твердую или надежную электронную копию серийного номера установленной Windows 7, то для предотвращения его хищения Вы можете удалить информацию о нем из системы. Для этого у вашей учётной записи должны быть права Администратора.

    1) Запустите командную строку от имени администратора
    1.1) В строке поиска меню "Пуск" наберите cmd.exe и нажмите Ctrl+Shift+Enter (или Win+R -> cmd -> ОК)
    2) Введите указанную ниже команду и нажмите Enter.

    Здесь slmgr.vbs - скрипт обслуживания подсистемы Software License Manager, управления лицензированием программного обеспечения.
    Опция cpky символизирует Clear Product Key.

    17. Создание точки восстановления системы при старте системы без использования апплета "Защита системы".

    Если Вам необходимо создать точку восстановления системы при старте системы не используя апплет "Защита системы", то Вы можете создать указанного ниже содержания скрипт и добавить ярлык для него в автозагрузку.

    В фоновом режиме без вывода сообщений и окон:

    С выводом окна для введения наименования для точки восстановления:

    1) Скопируйте выбранный Вами код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .vbs в любой папке (Например, на диске C:)
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "crp.vbs")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    5) Создайте ярлык для созданного Вами файла скрипта в Автозагрузку.
    5.1) Удерживая нажатой клавишу Alt перетяните иконку файла скрипта в папку Автозагрузка в меню Пуск.

    18. Запуск программ с правами администратора без выдачи уведомлений Контроля Учетных Записей.

    Если Вам необходимо часто запускать какую-либо программу от имени администратора при включенном Контроле Учетных Записей и Вы не собираетесь его полностью отключать, то Вы можете воспользоваться программой Elevated Shortcut.

    Это приложение, автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает необходимый ярлык. Программа, запущенная таким ярлыком, выполняется с привилегиями администратора, но запускается без запроса UAC (Контроля учётных записей). Elevated Shortcut предназначена для пользователей, считающих функцию контроля учётных записей(UAC) в Windows 7 полезной и которым требуется запускать какое-либо приложение всегда с повышенными правами (Sysinternals Process Explorer, например).
    Существует следующие варианты создания ярлыка:

    Вариант 1.

    1) Открываете Пуск -> Все программы -> Elevated Shortcut и запускаете программу.
    2) В появившемся окне Контроля Учетных Записей нажмите кнопку Да
    3) В зависимости от выбранного Вами языка интерфейса (из ниспадающего списка в нижнем левом углу) нажмите Создать ярлык (New Shortcut)
    4) Укажите в текстовом поле Файл на который будет создан ярлык (Target Path) - путь к запускаемому файлу программы или путь к иконке для нее.
    5) Укажите в текстовом поле Папка в которую поместить ярлык (Folder to store shortcut) - путь, где будет сохранен ярлык.
    6) Если для запуска необходим какой-нибудь параметр, то введите его в текстовое поле Параметры командной строки (Command line arguments)
    7) Нажмите ОК и ещё раз ОК и закройте программу.

    Вариант 2.

    1) Нажимаете правой кнопкой мыши на файле, для которого Вы желаете добавить ярлык.
    2) В появившемся окне Контроля Учетных Записей нажмите кнопку Да
    3) Укажите в текстовом поле Папка в которую поместить ярлык (Folder to store shortcut) - путь, где будет сохранен ярлык.
    4) Если для запуска необходим какой-нибудь параметр, то введите его в текстовое поле Параметры командной строки (Command line arguments)
    5) Нажмите ОК и ещё раз ОК и закройте программу.

    19. Запрещение запуска Диспетчера задач.

    1) Запустите редактор системных политик: Пуск -> Выполнить -> gpedit.msc (Win+R -> gpedit.msc -> ОК).
    2) Слева в дереве политик выберите Конфигурация пользователя -> Административные шаблоны -> Система -> Варианты действий после нажатия CTRL+ALT+DEL.
    3) В правом окне щелкните на Удалить диспетчер задач и выберите пункт Изменить
    4) Установите переключатель в значение Включить и нажмите ОК.
    5) Перезагрузите компьютер.

    20. Добавление своей иконки в список рисунков учетных записей.

    По умолчанию рисунки учетных записей располагаются в следующей папке:
    C:\ProgramData\Microsoft\User Account Pictures\Default Pictures
    Вы можете поместить в нее свое изображение и оно будет отображаться автоматически при выборе параметра изменения рисунка учетной записи в оснастке "Учетные записи пользователей". При этом рисунок должен быть в формате .bmp и иметь размер 128x128 пикселей.

    21. Отключение кэширования экскизов.

    Если у Вас включено отображение скрытых файлов в Windows, то обычно в папке с изображениями находится файл Thumbs.db. Данный файл используется операционной системой для хранения эскизов изображений папки для режима Эскизы страниц Проводника. Thumbs.db создаётся в каждой папке, которая содержит изображения, при первом отображении её содержимого.
    Thumbs.db является скрытым файлом, и обычно не виден в Проводнике, и может содержать эскизы уже удалённых изображений. Поэтому, он может быть случайно передан постороннему лицу, которое может узнать компрометирующую информацию.

    Чтобы отключить кэширование экскизов в скрытых файлах Thumbs.db, в версиях Windows 7: "Профессиональная", "Корпоративная", "Максимальная", выполните следующие действия:

    1) В строке поиска меню Пуск введите gpedit.msc и нажмите Enter
    2) В запустившимся Редакторе групповых политик выберите раздел Конфигурация пользователя
    3) Откройте Административные шаблоны -> Компоненты Windows -> Проводник Windows
    4) В панели справа найдите политику Отключить кэширование экскизов в скрытых файлах thumbs.db.
    5) Дважды щелкните на ней, чтобы открыть ее Свойства
    6) В открывшимся окне установите переключатель в значение Включить.
    7) Нажмите ОК

    Чтобы отключить кэширование экскизов в скрытых файлах Thumbs.db, в версиях Windows 7: "Домашняя базовая" и "Домашняя расширенная", выполните следующие действия:

    1) Запустите редактор реестра (Win+R->regedit->ОК)
    2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) В меню Правка выберите Создать -> Параметр DWORD (32 бита).
    4) Задайте имя параметра NoThumbnailCache
    5) Дважды щелкните на данном параметре и введите значение 1.
    6) Закройте редактор реестра и перезапустите компьютер.

    22. Поиск приложений автоматически загружающихся при запуске компьютера.

    Если у Вас при запуске Windows запускается какое-либо приложение, которое Вы хотите удалить из автозагрузки, то Вы можете либо проанализировать объекты находящиеся Пуск -> Все программы -> Автозагрузка и указанные ниже разделы реестра:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run (текущий пользователь)
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce (текущий пользователь, запуск один раз)
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run (все пользователи)
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз)
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run (текущий пользователь, только 64-бит версия)
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз, только 64-бит версия)

    Но есть более лучший способ, позволяющий сделать более тщательный анализ автоматически запускаемых приложений - воспользоваться программой AutoRuns созданной Марком Руссиновичем.

    Данная программа проверяет большее количество мест, из которых происходит автозапуск программ.

    Просто запустите средство Autoruns, и оно покажет, какие приложения настроены на автоматический запуск, а также представит полный список разделов реестра и каталогов файловой системы, которые могут использоваться для задания автоматического запуска. Элементы, которые показывает программа Autoruns, принадлежат к нескольким категориям: объекты, автоматически запускаемые при входе в систему, дополнительные компоненты проводника, дополнительные компоненты Internet Explorer (включая объекты модулей поддержки обозревателя (BHO)), библиотеки DLL инициализации приложений, подмены элементов, объекты, исполняемые на ранних стадиях загрузки, библиотеки DLL уведомлений Winlogon, службы Windows и многоуровневые поставщики услуг Winsock. Чтобы просмотреть автоматически запускаемые объекты требуемой категории, достаточно выбрать нужную вкладку.

    Параметр Hide Signed Microsoft Entries (Не показывать элементы с цифровой подписью Microsoft) из раздела меню Options позволяет сосредоточить внимание на автоматически запускаемых элементах сторонних производителей, если такие элементы были добавлены в систему. Кроме того, можно просматривать объекты, настроенные на автоматический запуск для других учетных записей, имеющихся в системе.

    Для просмотра свойств исполняемого объекта, настроенного на автоматический запуск, необходимо выделить этот объект и воспользоваться пунктом меню или кнопкой панели инструментов Properties (Свойства). Если в системе запущена программа Process Explorer, а выделенный исполняемый файл используется каким-либо активным процессом, то при выборе в меню Entry (Элемент) пункта Process Explorer (Process Explorer) откроется диалоговое окно свойств процесса, использующего выделенный объект.

    Чтобы перейти к разделу реестра или каталогу файловой системы, который отображается в окне программы, либо к настройке объекта, запускаемого автоматически, достаточно выделить нужный элемент и воспользоваться командой меню или кнопкой панели инструментов Jump to (Перейти к).

    Чтобы отключить объект, запускаемый автоматически, нужно снять соответствующий ему флажок. Удалить такой объект можно с помощью команды меню или кнопки панели инструментов Delete (Удалить).

    Чтобы просмотреть автоматически запускаемые элементы для учетных записей других пользователей, достаточно выбрать нужный пункт меню User (Пользователь).

    23. Отслеживание приложений, создающих неизвестные файлы на диске.

    Если у Вас на диске постоянно какая-либо программа записывает непонятные файлы, то Вы можете определить создающее их приложение, воспользовавшись утилитой от Microsoft: Process Monitor.

    1) Запустите программу Process Monitor
    Так как программа отслеживает несколько типов системной активности (реестр, файловую систему, сеть и процессы), то Вам необходимо оставить только включенной активность файловой системы.
    2) Оставьте на Панели инструментов включенным значок Show File System Activity, и отключите значки Show Registry Activity, Show Network Activity и Show Process and Tread Activity, Show Profiling Events
    3) Примените фильтр, чтобы отсеять необходимые Вам значения. Для запуска фильтра нажмите сочетание клавиш CTRL+L.
    4) В первом ниспадающем списке выберите значение Path - обозначает путь к искомому файлу (имя файла также учитывается).
    5) Во втором ниспадающем списке выберите значение contains - условие, учитывая которое будет производится отсеивание, в данном случае обозначает «содержит» (перев. с англ.)
    Также Вы можете, выбрать вариант begins with (начинается с) или ends with (заканчивается на).
    6) В текстовом поле введите либо желаемое имя файла, либо имя папки, где создаются неизвестные файлы.
    7) В последнем ниспадающем списке выберите значение Include - указывает фильтру, что заданные условия должны быть включены в результаты отсеивания.
    8) Нажмите кнопку Add, чтобы добавить фильтр в список и ОК, чтобы применить фильтр.

    Если полученных результатов очень много, то Вы можете добавить дополнительные фильтры, либо указав какие действия надо отслеживать, либо исключив определенные процессы.
    Примеры дополнительных фильтров:

    Process Name – Is – Имя процесса – Exclude.
    Operation – Is – CreateFile – Include


1. Получение полного доступа к файлу или папке.

1) Создайте reg файл
1.1) Скопируйте код в любой текстовый редактор (например, Блокнот).
1.2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "admin.reg")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

2) Примените его
3) Щелкните на файле или папке правой кнопкой мышки и выберите пункт "Стать владельцем и задать полный доступ к объекту"
4) В любых окнах, если они появятся нажимаете Да(Yes)

Скачать готовый reg-файл: Full_access.zip

Если Вам необходимо изменить права доступа, а после использования файла вернуть все права обратно, то Вы можете воспользоваться программой TakeOwnershipEx от Happy Bulldozer, которая обладает следующими возможностями:

  • Получение прав на один или сразу несколько файлов. В диалоге открытия Вы можете выбрать сразу несколько файлов, выделяя их мышкой и удерживая клавишу CTRL или SHIFT. Выбранным файлам в качестве владельца выставляется группа локальных "Администраторов", и предоставляется полный доступ для этой группы.

  • Восстановление прав. Если Вы получили права владельца и полный доступ, утилита запоминает, какие права у файла были до этого, и потом Вы в любой момент можете их вернуть на место.

    • Назад на страницу раздела Администрирование.


2. Запуск командной строки от имени (с правами) администратора.

Если Вы работаете под учетной записью обычного администратора, то командная строка от имени администратора запускается так:

Вариант 1.

1) В строке поиска меню Пуск введите команду: cmd.
2) Щелкните на найденном файле cmd.exe правой кнопкой мыши и выберите пункт Запуск от имени администратора

Вариант 2.

В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl+Shift+Enter.

Вариант 3.

1) Нажмите кнопку Пуск
2) Перейдите Все Программы -> Стандартные
3) Щелкните правой кнопкой мыши на Командная строка и выберите пункт Запуск от имени администратора.

Если Вы работаете под встроенной учетной записью администратора, то кроме указанных выше вариантов Вы можете использовать еще один вариант:

Вариант 4.

1) Запустите диалоговое меню Выполнить. В зависимости от Ваших настроек: Откройте Пуск -> Выполнить или нажмите комбинацию клавиш Win+R.
2) Введите команду: cmd и нажмите Enter.

Назад на страницу раздела Администрирование.


3. Изменение прав доступа и владельца для файла (папки), используя проводник или командную строку.

Случается, что при работе с файлами или папками Вам бывает необходимо изменить для них владельца и права доступа.

Смена владельца файла или папки, используя проводник.

1) Щелкните файл или папку правой кнопкой мыши, выберите команду Свойства и перейдите на вкладку Безопасность.
2) Нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
3) Нажмите кнопку Изменить и выполните одно из следующих действий:

  • Чтобы назначить владельцем пользователя или группу из списка, в окне Изменить владельца на выберите нового владельца и нажмите ОК.
  • Чтобы назначить владельцем пользователя или группу, которых нет в списке:

    • 1) Нажмите кнопку Другие пользователи и группы
    2) Если владельцем необходимо установить службу TrustedInstaller, в качестве имени объекта в поле Введите имена выбираемых объектов (примеры) введите: NT SERVICE\TrustedInstaller и нажмите кнопку ОК.
    3) Если владельцем необходимо другого пользователя или группу, то нажмите кнопку Дополнительно, а затем кнопку Поиск.
    3.1) В результатах поиска выберите необходимую Вам группу или пользователя и нажмите кнопку ОК.

    4) В окне Изменить владельца на: выберите добавленную группу или пользователя.
    5) Чтобы сменить владельца всех субконтейнеров и объектов в папке, установите флажок Заменить владельца субконтейнеров и объектов и нажмите кнопку ОК.

    Изменение разрешений для доступа к файлам и папкам, используя проводник.

    1) Щелкните правой кнопкой мыши файл или папку, для которых нужно задать разрешения, выберите команду Свойства и откройте вкладку Безопасность.
    2) Нажмите кнопку Изменить разрешения и выполните одно из следующих действий:
    2.1) Чтобы изменить разрешения для существующей группы или пользователя, выберите имя этой группы или пользователя и нажмите кнопку Изменить.
    2.1.1) Установите необходимые Вам флажки Разрешить или Запретить напротив каждого разрешения и нажмите кнопку ОК, а затем кнопку Применить.
    2.2) Чтобы изменить разрешения для группы или пользователя, которого нет в списке Элементы разрешений, нажмите кнопку Добавить.

    2.2.1) Если необходимо изменить разрешения для службы TrustedInstaller, в качестве имени объекта в поле Введите имена выбираемых объектов (примеры) введите: NT SERVICE\TrustedInstaller и нажмите кнопку ОК.
    2.2.2) Если необходимо изменить разрешения для другого пользователя или группы, то нажмите кнопку Дополнительно, а затем кнопку Поиск.
    2.2.3) В результатах поиска выберите необходимую Вам группу или пользователя и нажмите кнопку ОК.
    2.2.4) Установите необходимые Вам флажки Разрешить или Запретить напротив каждого разрешения и нажмите кнопку ОК, а затем кнопку Применить.

    2.3) Чтобы удалить группу или пользователя из списка Элементы разрешений, нажмите кнопку Удалить.

    Далее рассказывается как можно изменить разрешения или сменить владельца, используя командную строку запущенную от имени администратора.
    Если после использовании команды, разрешения или владелец не сменятся, то возможно Вам придется зайти в систему под встроенной учётной записью "Администратор" для их выполнения заново.

    Изменение владельца файла (папки) на указанного Вами пользователя, используя командную строку.

    Примеры:

    Параметры:

    /T - операция выполняется для всех соответствующих файлов и каталогов, расположенных в указанных в имени каталогах.
    /C - выполнение операции продолжается при любых файловых ошибках. Сообщения об ошибках по-прежнему выводятся на экран.
    /L - операция выполняется над самой символической ссылкой, а не над ее целевым объектом.
    /Q - команда icacls подавляет сообщения об успешном выполнении.

    Изменение разрешений для файла (папки), используя командную строку.

    Разрешения:

    F - полный доступ
    M - доступ на изменение
    RX - доступ на чтение и выполнение
    R - доступ только на чтение
    W - доступ только на запись
    D - доступ на удаление

    Примеры:

    Об остальных возможностях команды icacls Вы сможете узнать введя команду: icacls /?

    Назад на страницу раздела Администрирование.


4. Автоматический вход в систему и отключение экрана пользователей при запуске.

Если вы хотите ускорить процесс загрузки Windows 7, то вы можете настроить автоматический вход в систему. Эта возможность создана для тех ситуаций, когда компьютером пользуется один человек. Настроив автоматический вход, вам не нужно будет вводить пароль каждый раз, когда загружается ваша операционная система.
Чтобы настроить автоматический вход в Windows 7, сделайте следующее:

1. Нажмите на клавиатуре Win+R (или пункт Выполнить в меню Пуск).
2. В появившемся окне введите “control userpasswords2” (без кавычек) и нажмите Enter.
3. В окне Учетные записи пользователей во вкладке Пользователи выделите свою учетную запись и уберите флажок с “Требовать ввод имени пользователя и пароля”.
4. Нажмите Принять.
5. В открывшемся окне Автоматический вход в систему будут три поля - Пользователь, Пароль и Подтверждение. Введите свой пароль в поле Пароль и еще раз - в поле Подтверждение и нажмите ОК.

Всё. Со следующей перезагрузки системы вам больше не нужно будет вводить свой пароль. Вход в Windows будет происходить автоматически.
(Возможен побочный эффект: после перезагрузки панель "Quick Launch" не сохраняется - после рестарта её нет.)

Назад на страницу раздела Администрирование.


5. Ограничение разрешенных действий для пользователей, имеющих временный доступ к компьютеру.

Вариант 1.

1.1) Запустите оснастку Локальные пользователи и группы (Win+R -> lusrmgr.msc -> Ok)
1.2) Включите встроенную гостевую учетную запись пользователя. Дважды щелкните на профиль Гость, уберите флажок с Отключить учетную запись и нажмите OK.
1.3) Откройте Панель управления\Все элементы панели управления\Учетные записи пользователей и нажимаете ссылку Управление другой учетной записью.
При желании, можете поставить на свою учетную запись пароль.
1.4) Нажмите на учетную запись Гость, а затем нажмите на кнопку Включить.
1.5) Для перехода в гостевую учетную запись щелкните на стрелочке рядом с Завершение работы и выберите пункт Сменить пользователя. Обратный переход аналогично.

Вариант 2.

2.1.1) Запустите оснастку Редактор локальной групповой политики (Win+R -> gpedit.msc -> Ok)
2.1.2) В Административные шаблоны, дважды щелкните на элементе Все параметры
2.1.3) Отсортируйте элементы по-названию.
2.1.4) Включите необходимые Вам параметры начинающиеся со слов Запретить .... Для этого, дважды щелкните на необходимом элементе установите переключатель в значение Включить и нажмите Ок.

Также в оснастке Редактор локальной групповой политики Вы можете осуществлять контроль за приложениями, на основе создаваемых Вами правил, разрешать или запрещать запуск затрагиваемых файлов, основываясь на их атрибутах. К примеру, можно создать правило, позволяющее запускать все приложения, подписанные конкретным издателем (например, Microsoft) или находящиеся по определеному пути (Например: C:\Program Files\Mozilla Firefox). Для этого Вам необходимо создать Исполняемые правила, используя мастер правил AppLocker.
Для создания нового правила сделайте следующее:

2.2.1) Пройдите в Конфигурация компьютера -> Конфигурация Windows -> Параметры безопасности -> Политики управления приложениями -> AppLocker.
2.2.2) Нажмите на Исполняемые правила
2.2.3) В меню оснастки Редактор локальной групповой политики нажмите Действие и выберите пункт Создать новое правило..., также Вы можете щелкнуть правой кнопкой мыши в правой части окна и также выбрать из списка пункт Создать новое правило....

Вариант 3.

3) Воспользуйтесь программой Deep Freeze или аналогичной ей, данная программа позволяет заморозить текущее состояние системы. С её помощью можно сохранить текущую конфигурацию системы, к которой машина будет автоматически возвращаться после перезагрузки. При этом абсолютно не имеет значения что делает пользователь - устанавливает новые программы, удаляет системные файлы или работает в сети - после перезагрузки вы получите девственно чистую машину.
Для отключения Deep Freeze надо нажать Ctrl+Shift+Alt+F6 и выбрать Boot Thawed, для удаления Deep Freeze сначала его надо отключить, а потом запустить установочный файл и выбрать Uninstall.

Назад на страницу раздела Администрирование.


6. Быстрый запуск программы с правами администратора.

Удерживайте Ctrl+Shift и нажмите на иконку приложения (у Вашей учетной записи, должны быть права администратора).

Назад на страницу раздела Администрирование.


7. Убирание запрещающего значка с папки.

1) Нажимаете правой кнопкой мыши на папке с которой Вы хотите убрать значок замка и выбираете Свойства
2) Переходите на вкладку Безопасность
3) Нажимаете на кнопки Изменить -> Добавить -> Дополнительно -> Поиск
4) В результатах поиска удерживая нажатой клавишу Ctrl, выбираете следующие имена: система; Администраторы; Прошедшие проверку; и нажимаете Ок
5) В окне группы или пользователи выбираете система; и ставите флажок на Полный доступ, после выбираете Администраторы; и снова ставите флажок на Полный доступ, а затем выбираете Прошедшие проверку; и также ставите флажок на Полный доступ.
6) Нажимаете Ок

При возникновении окон "Ошибка применения безопасности" нажимайте Продолжить.

Также Вы можете воспользоваться решением предложенным в совете Администрирование: 1. Получение полного доступа к файлу или папке.

1) Создайте reg-файл(например: admin.reg) как описано в Администрирование: 1. Получение полного доступа к файлу или папке.
2) Примените его
3) Щелкните на папке и выберите пункт "Стать владельцем и задать полный доступ к объекту"
4) В любых окнах, если они появятся нажимаете Да(Yes)

Назад на страницу раздела Администрирование.


8. Запуск приложений в Windows 7 c повышенными привилегиями без отключения UAC.

Многие пользователи считают функцию контроля учётных записей(UAC) в Windows 7 весьма полезной и не отключают её . Но иногда всё же требуется запустить приложение с повышенными правами, а некоторые приложения, такие как, например, Sysinternals Process Explorer или Sysinternals Autoruns, и вовсе лучше всегда запускать с повышенными привилегиями.
Конечно, Вы можете воспользоваться одним из простых способов, и постоянно щелкать уведомления UAC:

1) Нажмите правой клавишей мыши по значку нужного приложения и выберите пункт "Запуск от имени администратора"
2) Нажмите Пуск, в строке поиска наберите нужную команду и нажмите Ctrl+Shift+Enter.
3) Щелкните правой клавишей мыши по нужному ярлыку и выберите пункт "Свойства". Или перейдите на вкладку "Совместимость" и установите флажок "Выполнять эту программу от имени администратора"

Есть также и другой способ, через создание высокопривилегированной задачи системного планировщика заданий. Способ немного сложнее предыдущих, но запросы UAC не отображаются.

1) Запускаете планировщик заданий (Пуск ---> Все программы ---> Стандартные ---> Служебные ---> Планировщик заданий)
2) Нажимаете "Создать задачу"
3) Указываете Имя для новой задачи и ставите флажок "Выполнять с наивысшими правами"
4) Переходите на вкладку Действия, нажимаете "Создать", в следующем окне нажимаем "Обзор"
5) Указываете путь к нужному приложению и нажимаете "Открыть"
6) Нажимаете "ОК", затем снова "ОК"
7) Создайте ярлык на рабочем столе ( Нажмите правую кнопку мыши, выберете "Создать" ---> "Ярлык")
8) В поле Расположение объекта введите:

где mytask_admin - имя созданной нами задачи. Если в имеми содержаться робелы, обязательно укажите его в кавычках.
9) Введите имя ярлыка и нажмите Готово

Но есть и более легкий способ, создания ярлыка, при запуске которого не отображаются запросы UAC - это использовать приложение Elevated Shortcut.
Оно автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает на рабочем столе необходимый ярлык. Просто перетащите необходимый исполняемый файл на окно программы Elevated Shortcut.

Скачать можно здесь или здесь

Назад на страницу раздела Администрирование.


9. Перемещение профилей пользователей и изменение путей к ним.

Указанные в с 1 по 4 вариантах действия, необходимо повторять для каждого профиля. Переместив таким образом все профили, и изменив их пути в реестре, исходные папки можно будет удалить.

Вариант 1. С помощью компонента Windows - "Профили пользователей".

Скопируйте профиль пользователя в конечное размещение:

1) Если папка для профиля существует, перейдите к следующему шагу, при этом используя рекомендации; если папка, в которой будет храниться профиль, не существует, создайте ее, используя рекомендации.

Рекомендации:

  • Если на компьютере только одна учетная запись, можно присвоить папке профиля имя учетной записи; если учетных записей несколько, лучше всего создать папку верхнего уровня, например, с именем Пользователи, а в нее вложить папки с именами пользователей компьютера, в которых и будут храниться наши профили. Хотя использовать папку верхнего уровня лучше сразу, на случай добавления новых учетных записей;
  • Если конечная папка уже существует и она имеет содержимое, которое необходимо сохранить, ее необходимо скопировать в другое размещение, а затем, после завершения перемещения профилей, переместить это содержимое в папку с профилем пользователя

    • 2) Откройте Система: команда свойства контекстного меню Компьютер или сочетание Windows + Break.
    3) Щелкните Дополнительные параметры системы. Щелкните Продолжить, если появится соответствующий запрос системы контроля учетных записей.
    4) Откройте вкладку Дополнительно.
    5) Щелкните кнопку Параметры в рамке Профили пользователей.
    6) Выберите профиль, который необходимо переместить. Активный профиль не выбирается. Чтобы его можно было выбрать для осуществления необходимых действий, нужно войти под другой учетной записью и иметь права администратора.
    7) Нажмите кнопку Копировать.
    8) Выберите папку, в которой будет находиться профиль, созданную на шаге 1.
    9) Нажмите OK; если выбранная папка не пустая, система выдаст запрос на копирование профиля в нее, так как при этом удаляется все ее содержимое! (не забудьте о рекомендациях!). Нажмите Да.

    Внесите изменения в системный реестр.

    1) Откройте меню Выполнить: Пуск -> Выполнить (либо Win+R)
    2) Введите regedit.exe, нажимаем Enter.
    3) Измените значение параметра ProfileImagePath в ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID, где SID – идентификатор безопасности пользователя, присваивая ему значение пути к папке, в которую был предварительно скопирован профиль. Убедиться в том, что данный ключ содержит ключ к необходимому нам профилю, можно по значению ProfileImagePath, содержащему путь к текущему размещению профиля пользователя.
    Также Вы можете воспользоваться скриптом SIDList.vbs для выяснения, какому аккаунту принадлежит какой SID.
    4) Перезагрузите компьютер.

    Внесение изменений в системный реестр может привести к снижению стабильности и производительности системы или ее отказу, поэтому настоятельно рекомендуется создать резервную копию реестра перед выполнением данной операции. В данном случае удобно воспользоваться экспортом изменяемого ключа или Восстановлением системы.

    Вариант 2. На другой диск вручную.

    1) Запустите оснастку "Локальные пользователи и группы" (Win+R -> lusrmgr.msc -> Ok)
    2) Включите системную запись администратора. Выбираете "Пользователи". В свойствах пользователя "Администратор" снимаете галку "Отключить пользователя". Если же Вы уже работаете в учетной записи Администратор, то создайте новую учетную запись с правами администратора.
    3) Для полного доступа к файлам и папкам перезапустите компьютер, и зайдите под аккаунтом "Администратор" (или под созданным Вами с правами администратора).

    Указанные выше действия необходимы, потому что профиль под которым Вы зайдете, для осуществления необходимых действий не выбирается. Соответственно залогинившись под одним профилем, Вы можете работать только с другими.

    4) Запустите "Проводник" в режиме администратора:
    Щелкните правой кнопкой мыши на иконке Проводника
    Щелкните правой кнопкой мыши на слове Проводник
    Выберите пункт "Запуск от имени администратора"
    5) Создайте на диске D: папку Users.
    6) Поменяйте права на "D:\Users", исходя из прав на системный Users.
    Оставьте только "Чтение и выполнение" для группы "Everyone"(Все), и "Полный доступ" для групп "Administrators" (Администраторы) и "System".
    На вкладке "Разрешения" (Безопастность\Дополнительно\Разрешения\Изменить разрешения) уберите галочку с пункта "Добавить разрешения, наследуемые от родительских объектов" и нажмите на кнопку Добавить(иначе удаляться все группы и Вам придется их прописывать самостоятельно)
    Владелец папки, установите на "Administrators" (Администраторы).
    7) В Проводнике запущенном от имени Администратора скопируйте необходимую Вам папку пользователя в "D:\Users".

    Так как Проводник не умеет копировать "junction" (точки соединения, исполняющие роль символической ссылки одного каталога компьютера на другой каталог), то их придется создавать самостоятельно. Например, "junction" являются папки "Application Data", "Local Settings", "SendTo" и другие.

    8) Запустите командную строку от имени администратора (Win+R -> CMD -> Ok)
    9) Для показа только скрытых файлов введите команду "dir /ah" (без кавычек) и нажмите Enter. Вы увидите примерно следующее:

    10) Создайте аналогичные "Junction" каталоги:

    Способ 1. Вручную для каждого "Junction" каталога.

    1) В командной строке переходите в созданную Вами папку:

    2) И для каждой "Junction" выполняете команду:

    Например:

    Способ 2. Создание bat-файла.

    Если Вам предстоит перенести несколько профилей, то проще будет создать bat-файл, так как "Junction" у Вас скорее всего будут такие же.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .bat
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "profiles.bat")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    В моем случае получился такой, Вы можете создать аналогичный для своих папок (запускаете его из каталога профиля "D:\Users\ВашПрофиль"):

    Если у Вас папки имеют русские названия, то для правильной работы данного bat-файла, надо его сохранять в кодировке CP866 (Блокнот Windows, в ней не сохраняет, используйте для этого программы сторонних производителей например: Akelpad).
    11) Присвойте "Junction" каталогам скрытые и системные атрибуты, как в оригинале.

    Либо, вручную для каждого в командной строке.

    Например:

    Либо, создав bat-файл (запускаете его из каталога профиля "D:\Users\ВашПрофиль"):

    12) Запустите Реестр Windows(Win+R -> regedit -> Enter) и измените значение параметра ProfileImagePath в ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID c "C:\Users\ВашПрофиль" на "D:\Users\ВашПрофиль" , где SID – идентификатор безопасности пользователя, присваивая ему значение пути к папке, в которую был предварительно скопирован профиль. Убедиться в том, что данный ключ содержит ключ к необходимому нам профилю, можно по значению ProfileImagePath, содержащему путь к текущему размещению профиля пользователя. Также Вы можете воспользоваться скриптом SIDList.vbs для выяснения, какому аккаунту принадлежит какой SID.
    13) Переименуйте или удалите каталог профиля в "C:\Users\", чтобы предотвратить к нему запросы.
    14) Перезагрузите компьютер, чтобы Windows подхватила внесенные нами настройки.
    15) Вновь зайдите под аккаунтом Администратор.
    16) Запустите Реестр Windows(Win+R -> regedit -> Enter)
    17) Используя Поиск найдите все строки с путем к папке "C:\Users\ВашПрофиль" и исправьте на "D:\Users\ВашПрофиль" (Чем ближе к чистой установке Вы это сделаете, тем меньше строк Вам придется исправлять).
    18) Поменяйте права на каталог профиля в "D:\Users".
    Установите "Полный доступ" пользователю - владельцу профиля, и "Полный доступ" для групп "Administrators" (Администраторы) и "System".
    На вкладке "Разрешения" (Безопасность\Дополнительно\Разрешения\Изменить разрешения) уберите галочку с пункта "Добавить разрешения, наследуемые от родительских объектов" и нажмите на кнопку Добавить(иначе удаляться все группы и Вам придется их прописывать самостоятельно).
    Владелец папки, установите на "System".
    19) Перезагрузите компьютер, теперь вы можете войти в перемещенный аккаунт и проделать всё указанное выше для другого профиля.

    Вариант 3. При помощи ERD Commander.

    1) Скачиваете утилиту Junction от SysInternals. Она позволяет создавать точки соединения, исполняющие роль символической ссылки одного каталога компьютера на другой каталог.
    2) Копируете junction.exe в C:\Windows\System32
    3) Загружаетесь в Erd Commander.
    4) Выбираете опцию, чтобы реестр не импортировался
    5) Копируете например: "C:\Documents and Settings\ВашПрофиль" в "D:\Users\ВашПрофиль"
    6) После копирования, удаляете "C:\Documents and Settings\ВашПрофиль"
    7) Запускаете командную строку и переходите в папку C:\Windows\System32

    8) После сообщения Sucsess, можете зайти в папку проверяем C:\Documents and Settings\ и увидите там папку ВашПрофиль, только это уже ссылка...

    Вариант 4. При помощи Far Manager.

    1) Скачиваете Far Manager и устанавливаете его.
    2) Входите в систему под другим пользователем с правами администратора
    3) Запускаете Far Manager
    4) Находите нужный профиль пользователя.
    5) Перемещаете папку с ним на другой диск (например, C:\Documents and Settings\ВашПрофиль -> D:\Users\ВашПрофиль).
    6) Устанавливаете на перемещённую папку нужные права и нужного владельца.
    7) Создаёте на исходном разделе символическую связь с новой папкой (Alt+F6).
    8) На новую папку ставите атрибут "Скрытый".

    Вариант 5. Изменение пути к каталогам пользователей при установке Windows.

    Вы можете изменить расположение папки Пользователи (Users), в которой будут храниться профили пользователей, ещё при установке Windows.

    1) Создайте файл Autounattend.xml следующего содержания:
    2) Скопируйте его в папку \Sources установочного диска.
    3) Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.

    Назад на страницу раздела Администрирование.


10. Отключение отображения имени последнего пользователя.

Для отключения запоминания имени последнего пользователя отображаемого на экране переключения пользователей.

1) Нажмите Пуск, в строке поиска введите secpol.msc и нажмите Enter
2) Раскройте группу Локальные политики и перейдите к разделу Параметры безопасности
3) Используя двойной щелчок мыши откройте параметр Интерактивный вход в систему: не отображать последнее имя пользователя и выберите состояние Включен
Этот параметр безопасности определяет, будет ли в экране входа в Windows отображено имя последнего пользователя, выполнившего вход.
Если эта политика включена, в диалоговом окне входа не будет отображаться имя последнего пользователя, выполнившего вход.
Если эта политика отключена, отображается имя последнего пользователя, выполнившего вход.

Назад на страницу раздела Администрирование.


11. Включение встроенной учетной записи администратора.

Вариант 1

1) Запустите оснастку Локальные пользователи и группы (Win+R -> lusrmgr.msc -> Ok)
2) В меню слева нажмите на папку Пользователи
3) Щелкните правой кнопкой учетную запись Администратор и выберите Свойства.
4) Откроется окно Свойства: Администратор.
5) На вкладке Общие снимите флажок Отключить учетную запись.

Учетная запись администратора теперь включена.

Вариант 2

1) Нажмите кнопку Пуск
2) Введите в строке поиска cmd
3) Щелкните правой кнопкой мыши ярлык командной строки и выберите пункт Запуск от имени администратора

Для включения встроенной учетной записи Администратор в русской версии Windows используйте команду

В системе с английской локализацией встроенная учетная запись администратора называется Administrator, поэтому команда будет выглядеть так:

Чтобы переключиться на данную учетную запись: нажмите на кнопку Пуск, нажмите на стрелочку рядом с Завершение работы и выберите Сменить пользователя.

Назад на страницу раздела Администрирование.


12. Изменение фонового рисунка в экране авторизации пользователей.

Вариант 1. Вручную используя реестр Windows.

1) Создайте ключ типа DWORD с названием OEMBackground в ветке реестра

2) Присвойте ему значение 1 (1 означает, что функция включена, 0 - выключена)
3) Создайте в папке %windir%\system32\oobe\ папку info, а в ней папку backgrounds (%windir%\system32\oobe\info\backgrounds)
4) Поместите сюда свой файл
5) Переименуйте его в необходимое имя (зависит от разрешения монитора):

background768x1280.jpg
background900x1440.jpg
background960x1280.jpg
background1024x1280.jpg
background1280x1024.jpg
background1024x768.jpg
background1280x960.jpg
background1600x1200.jpg
background1440x900.jpg
background1920x1200.jpg
background1280x768.jpg
background1360x768.jpg
backgroundDefault.jpg - в случае нестандартного расширения монитора

Размер изображений не должен превышать 256Кб.
Если же изображение не может быть загружено по иным причинам (неверное соотношение сторон, размер и т.д.), загружается стандартное изображение из файла imagesres.dll.

Вариант 2. Автоматически используя специальную программу.

1) Скачайте архив программы tweakslogon.zip
2) Разархивируйте файл в любую папку и запустите TweaksLogon.exe
3) Нажмите на кнопку Change Logon Screen.
4) В открывшемся окне выберите изображение и нажмите Открыть (Open)
5) Если Ваше изображение больше 245 кб, то программа предложит Вам его сжать. Нажмите Да (Yes)
6) Если Вы уже меняли с помощью данной программы фоновый рисунок, то программа сообщит вам об этом. Нажмите Ок Чтобы вернуть стандартный фоновый рисунок нажмите кнопку Revert to Default Logon Screen.

Назад на страницу раздела Администрирование.


13. Установка службы TrustedInstaller в качестве владельца папки или файла.

У многих системных папок и файлов владельцем, имеющим права доступа на запись/удаление является служба TrustedInstaller. Конечно Вы можете задать права себе, если Вы являетесь администратором на компьютере, но это может привести к неполадкам в работе. Например, если Вы измените владельца папки winsxs для доступа к ней и не вернете обратно права TrustedInstaller, то некоторые программы могут не запуститься.

Если Вы удалили ее из групп и пользователей в свойствах папки (файла) на вкладке Безопасность, то чтобы вернуть обратно в качестве владельца службу TrustedInstaller Вам необходимо сделать следующее:

1) Щелкните правой кнопкой на папке (файле) и выберите пункт Свойства.
2) Перейдите на вкладку Безопасность и нажмите кнопку Дополнительно.
3) В открывшемся окне перейдите на вкладку Владелец и нажмите кнопку Изменить...
4) Нажмите кнопку Другие пользователи или группы... , в текстовом поле введите NT SERVICE\TrustedInstaller и нажмите ОК.
5) В окне Изменить владельца на: выберите TrustedInstaller и нажмите ОК.
Если необходимо также изменить владельца вложенных папок, то перед нажатием на кнопку ОК установите флажок Заменить владельца подконтейнеров и объектов.

Также Вам необходимо добавить службу TrustedInstaller в список групп и пользователей, имеющих доступ к папке (файлу).

1) Щелкните правой кнопкой на папке (файле) и выберите пункт Свойства.
2) Перейдите на вкладку Безопасность
3) Нажмите кнопку Изменить..., а в открывшемся окне кнопку Добавить... .
4) В текстовом поле введите NT SERVICE\TrustedInstaller и нажмите ОК.
5) Установите флажок в колонке Разрешить напротив разрешения Полный доступ
6) Нажмите на кнопки ОК.

Назад на страницу раздела Администрирование.


14. Изменение пароля или создание новой учетной записи администратора, используя средства восстановления системы.

Чтобы сбросить пароль учётной записи администратора (или создать новую) без использования дополнительных программ, Вам понадобится либо установочный диск Windows 7, либо диск восстановления системы, либо LiveCD с Windows PE.

Часть №1 - Настройка запуска командной строки перед экраном входа в Windows.

1) Загрузитесь с установочного диска Windows 7 или с диска восстановления.
2) Откройте командную строку Восстановление системы -> Далее -> Командная строка.
3) Запустите редактор реестра. В командной строке наберите regedit и нажмите Enter.
4) Выделите раздел HKEY_LOCAL_MACHINE и выберите пункт Загрузить куст в меню Файл.
5) Перейдите на диск, где установлена Windows 7, и откройте файл: C:\Windows\System32\config\SYSTEM
6) Введите произвольное имя для загружаемого раздела. Например: NewAdmin.
7) Перейдите в раздел HKEY_LOCAL_MACHINE\NewAdmin\Setup
8) Измените значение параметров (Щелчок правой кнопкой мыши на параметре -> Изменить):
8.1) Для параметра CmdLine введите значение cmd.exe и нажмите ОК.
8.2) Для параметра SetupType измените значение с 0 на 2 и нажмите ОК.
9) Выделите раздел NewAdmin в HKEY_LOCAL_MACHINEи выберите пункт Выгрузить куст в меню Файл.
10) Извлеките установочный диск или диск восстановления системы, закройте редактор реестра и командную строку, нажмите Перезагрузка в окне параметров восстановления.

Часть №2 - Создание нового пароля или новой учетной записи администратора.

Создание нового пароля.

1) Продолжайте обычный вход в Windows 7 и перед входом в систему Вы увидите окно командной строки.
2) Введите команду net user, чтобы отобразить все имеющиеся учётные записи.
3) Для создания нового пароля введите следующую команду и подтвердите её выполнение клавишей Enter:

Если имя или пароль содержат пробелы, вводите их в "кавычках".

Создание новой учётной записи.

Если у Вас отсутствует учетная запись администратора, то для ее создания введите приведенные ниже команды, нажимая после каждой клавишу Enter.

Для русской (локализованной) Windows:

1) Создание нового пользователя.

2) Добавление пользователя в группу Администраторы (Administrators).

3) Удаление пользователя из группы Пользователи (Users).

Для английской Windows:

1) Создание нового пользователя.

2) Добавление пользователя в группу Администраторы (Administrators).

3) Удаление пользователя из группы Пользователи (Users).

По окончании ввода закройте окно командной строки. Используйте созданную учетную запись для входа в Windows.

Назад на страницу раздела Администрирование.


15. Определение процесса которому принадлежит текущее окно.

1) Скачайте Process Explorer.zip
2) Разархивируйте в любую папку и запустите программу procexp.exe.
3) На панели инструментов Process Explorer нажмите левой кнопкой мыши на "значок-прицел".
4) Не отпуская левой кнопки мыши, наведите "прицел" на интересующее Вас окно.
5) Отпустите кнопку мыши и программа Process Explorer, выделит принадлежащий окну процесс (по умолчанию синим цветом).

Назад на страницу раздела Администрирование.


16. Удаление данных о серийном номере из системы для предотвращения его хищения.

Если Вы имеете твердую или надежную электронную копию серийного номера установленной Windows 7, то для предотвращения его хищения Вы можете удалить информацию о нем из системы. Для этого у вашей учётной записи должны быть права Администратора.

1) Запустите командную строку от имени администратора
1.1) В строке поиска меню "Пуск" наберите cmd.exe и нажмите Ctrl+Shift+Enter (или Win+R -> cmd -> ОК)
2) Введите указанную ниже команду и нажмите Enter.

Здесь slmgr.vbs - скрипт обслуживания подсистемы Software License Manager, управления лицензированием программного обеспечения.
Опция cpky символизирует Clear Product Key.

Назад на страницу раздела Администрирование.


17. Создание точки восстановления системы при старте системы без использования апплета "Защита системы".

Если Вам необходимо создать точку восстановления системы при старте системы не используя апплет "Защита системы", то Вы можете создать указанного ниже содержания скрипт и добавить ярлык для него в автозагрузку.

В фоновом режиме без вывода сообщений и окон:

С выводом окна для введения наименования для точки восстановления:

1) Скопируйте выбранный Вами код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .vbs в любой папке (Например, на диске C:)
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "crp.vbs")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Создайте ярлык для созданного Вами файла скрипта в Автозагрузку.
5.1) Удерживая нажатой клавишу Alt перетяните иконку файла скрипта в папку Автозагрузка в меню Пуск.

Назад на страницу раздела Администрирование.


18. Запуск программ с правами администратора без выдачи уведомлений Контроля Учетных Записей.

Если Вам необходимо часто запускать какую-либо программу от имени администратора при включенном Контроле Учетных Записей и Вы не собираетесь его полностью отключать, то Вы можете воспользоваться программой Elevated Shortcut.

Это приложение, автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает необходимый ярлык. Программа, запущенная таким ярлыком, выполняется с привилегиями администратора, но запускается без запроса UAC (Контроля учётных записей). Elevated Shortcut предназначена для пользователей, считающих функцию контроля учётных записей(UAC) в Windows 7 полезной и которым требуется запускать какое-либо приложение всегда с повышенными правами (Sysinternals Process Explorer, например).
Существует следующие варианты создания ярлыка:

Вариант 1.

1) Открываете Пуск -> Все программы -> Elevated Shortcut и запускаете программу.
2) В появившемся окне Контроля Учетных Записей нажмите кнопку Да
3) В зависимости от выбранного Вами языка интерфейса (из ниспадающего списка в нижнем левом углу) нажмите Создать ярлык (New Shortcut)
4) Укажите в текстовом поле Файл на который будет создан ярлык (Target Path) - путь к запускаемому файлу программы или путь к иконке для нее.
5) Укажите в текстовом поле Папка в которую поместить ярлык (Folder to store shortcut) - путь, где будет сохранен ярлык.
6) Если для запуска необходим какой-нибудь параметр, то введите его в текстовое поле Параметры командной строки (Command line arguments)
7) Нажмите ОК и ещё раз ОК и закройте программу.

Вариант 2.

1) Нажимаете правой кнопкой мыши на файле, для которого Вы желаете добавить ярлык.
2) В появившемся окне Контроля Учетных Записей нажмите кнопку Да
3) Укажите в текстовом поле Папка в которую поместить ярлык (Folder to store shortcut) - путь, где будет сохранен ярлык.
4) Если для запуска необходим какой-нибудь параметр, то введите его в текстовое поле Параметры командной строки (Command line arguments)
5) Нажмите ОК и ещё раз ОК и закройте программу.

Назад на страницу раздела Администрирование.


19. Запрещение запуска Диспетчера задач.

1) Запустите редактор системных политик: Пуск -> Выполнить -> gpedit.msc (Win+R -> gpedit.msc -> ОК).
2) Слева в дереве политик выберите Конфигурация пользователя -> Административные шаблоны -> Система -> Варианты действий после нажатия CTRL+ALT+DEL.
3) В правом окне щелкните на Удалить диспетчер задач и выберите пункт Изменить
4) Установите переключатель в значение Включить и нажмите ОК.
5) Перезагрузите компьютер.

Назад на страницу раздела Администрирование.


20. Добавление своей иконки в список рисунков учетных записей.

По умолчанию рисунки учетных записей располагаются в следующей папке:
C:\ProgramData\Microsoft\User Account Pictures\Default Pictures
Вы можете поместить в нее свое изображение и оно будет отображаться автоматически при выборе параметра изменения рисунка учетной записи в оснастке "Учетные записи пользователей". При этом рисунок должен быть в формате .bmp и иметь размер 128x128 пикселей.

Назад на страницу раздела Администрирование.


21. Отключение кэширования экскизов.

Если у Вас включено отображение скрытых файлов в Windows, то обычно в папке с изображениями находится файл Thumbs.db. Данный файл используется операционной системой для хранения эскизов изображений папки для режима Эскизы страниц Проводника. Thumbs.db создаётся в каждой папке, которая содержит изображения, при первом отображении её содержимого.
Thumbs.db является скрытым файлом, и обычно не виден в Проводнике, и может содержать эскизы уже удалённых изображений. Поэтому, он может быть случайно передан постороннему лицу, которое может узнать компрометирующую информацию.

Чтобы отключить кэширование экскизов в скрытых файлах Thumbs.db, в версиях Windows 7: "Профессиональная", "Корпоративная", "Максимальная", выполните следующие действия:

1) В строке поиска меню Пуск введите gpedit.msc и нажмите Enter
2) В запустившимся Редакторе групповых политик выберите раздел Конфигурация пользователя
3) Откройте Административные шаблоны -> Компоненты Windows -> Проводник Windows
4) В панели справа найдите политику Отключить кэширование экскизов в скрытых файлах thumbs.db.
5) Дважды щелкните на ней, чтобы открыть ее Свойства
6) В открывшимся окне установите переключатель в значение Включить.
7) Нажмите ОК

Чтобы отключить кэширование экскизов в скрытых файлах Thumbs.db, в версиях Windows 7: "Домашняя базовая" и "Домашняя расширенная", выполните следующие действия:

1) Запустите редактор реестра (Win+R->regedit->ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) В меню Правка выберите Создать -> Параметр DWORD (32 бита).
4) Задайте имя параметра NoThumbnailCache
5) Дважды щелкните на данном параметре и введите значение 1.
6) Закройте редактор реестра и перезапустите компьютер.

Назад на страницу раздела Администрирование.


22. Поиск приложений автоматически загружающихся при запуске компьютера.

Если у Вас при запуске Windows запускается какое-либо приложение, которое Вы хотите удалить из автозагрузки, то Вы можете либо проанализировать объекты находящиеся Пуск -> Все программы -> Автозагрузка и указанные ниже разделы реестра:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run (текущий пользователь)
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce (текущий пользователь, запуск один раз)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run (все пользователи)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run (текущий пользователь, только 64-бит версия)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз, только 64-бит версия)

Но есть более лучший способ, позволяющий сделать более тщательный анализ автоматически запускаемых приложений - воспользоваться программой AutoRuns созданной Марком Руссиновичем.

Данная программа проверяет большее количество мест, из которых происходит автозапуск программ.

Просто запустите средство Autoruns, и оно покажет, какие приложения настроены на автоматический запуск, а также представит полный список разделов реестра и каталогов файловой системы, которые могут использоваться для задания автоматического запуска. Элементы, которые показывает программа Autoruns, принадлежат к нескольким категориям: объекты, автоматически запускаемые при входе в систему, дополнительные компоненты проводника, дополнительные компоненты Internet Explorer (включая объекты модулей поддержки обозревателя (BHO)), библиотеки DLL инициализации приложений, подмены элементов, объекты, исполняемые на ранних стадиях загрузки, библиотеки DLL уведомлений Winlogon, службы Windows и многоуровневые поставщики услуг Winsock. Чтобы просмотреть автоматически запускаемые объекты требуемой категории, достаточно выбрать нужную вкладку.

Параметр Hide Signed Microsoft Entries (Не показывать элементы с цифровой подписью Microsoft) из раздела меню Options позволяет сосредоточить внимание на автоматически запускаемых элементах сторонних производителей, если такие элементы были добавлены в систему. Кроме того, можно просматривать объекты, настроенные на автоматический запуск для других учетных записей, имеющихся в системе.

Для просмотра свойств исполняемого объекта, настроенного на автоматический запуск, необходимо выделить этот объект и воспользоваться пунктом меню или кнопкой панели инструментов Properties (Свойства). Если в системе запущена программа Process Explorer, а выделенный исполняемый файл используется каким-либо активным процессом, то при выборе в меню Entry (Элемент) пункта Process Explorer (Process Explorer) откроется диалоговое окно свойств процесса, использующего выделенный объект.

Чтобы перейти к разделу реестра или каталогу файловой системы, который отображается в окне программы, либо к настройке объекта, запускаемого автоматически, достаточно выделить нужный элемент и воспользоваться командой меню или кнопкой панели инструментов Jump to (Перейти к).

Чтобы отключить объект, запускаемый автоматически, нужно снять соответствующий ему флажок. Удалить такой объект можно с помощью команды меню или кнопки панели инструментов Delete (Удалить).

Чтобы просмотреть автоматически запускаемые элементы для учетных записей других пользователей, достаточно выбрать нужный пункт меню User (Пользователь).

Назад на страницу раздела Администрирование.


23. Отслеживание приложений, создающих неизвестные файлы на диске.

Если у Вас на диске постоянно какая-либо программа записывает непонятные файлы, то Вы можете определить создающее их приложение, воспользовавшись утилитой от Microsoft: Process Monitor.

1) Запустите программу Process Monitor
Так как программа отслеживает несколько типов системной активности (реестр, файловую систему, сеть и процессы), то Вам необходимо оставить только включенной активность файловой системы.
2) Оставьте на Панели инструментов включенным значок Show File System Activity, и отключите значки Show Registry Activity, Show Network Activity и Show Process and Tread Activity, Show Profiling Events
3) Примените фильтр, чтобы отсеять необходимые Вам значения. Для запуска фильтра нажмите сочетание клавиш CTRL+L.
4) В первом ниспадающем списке выберите значение Path - обозначает путь к искомому файлу (имя файла также учитывается).
5) Во втором ниспадающем списке выберите значение contains - условие, учитывая которое будет производится отсеивание, в данном случае обозначает «содержит» (перев. с англ.)
Также Вы можете, выбрать вариант begins with (начинается с) или ends with (заканчивается на).
6) В текстовом поле введите либо желаемое имя файла, либо имя папки, где создаются неизвестные файлы.
7) В последнем ниспадающем списке выберите значение Include - указывает фильтру, что заданные условия должны быть включены в результаты отсеивания.
8) Нажмите кнопку Add, чтобы добавить фильтр в список и ОК, чтобы применить фильтр.

Если полученных результатов очень много, то Вы можете добавить дополнительные фильтры, либо указав какие действия надо отслеживать, либо исключив определенные процессы.
Примеры дополнительных фильтров:

Process Name – Is – Имя процесса – Exclude.
Operation – Is – CreateFile – Include

Назад на страницу раздела Администрирование.


Интерфейс

Интерфейс - Внешний вид.

1. Изменение размера иконки на рабочем столе.

1) Щелкните правой кнопкой мыши на рабочем столе.
2) Откройте пункт Вид и выберите размер: Крупные значки; Обычные значки; Мелкие значки;
или удерживая нажатой клавишу Сtrl прокрутите колесо мыши.

2. Управление заготовками положений размеров окон.

Чтобы легко управлять заготовками положений размеров окон (любых) просто кликните на активное окно и жмите:(win+влево,вниз,вправо,вверх).

3. Где скачать и как установить дополнительные темы для Windows 7?

Скачать дополнительные темы для Вашей Windows 7 Вы можете на официальной странице тем от Microsoft: Персонализация компьютера
После скачивания понравившейся Вам темы, нажмите на скачавшийся themepack-файл и Windows автоматически его установит.
Также дополнительные темы и обои для Windows находятся в скрытой папке - C:\Windows\Globalization\MCT.

Вы можете разблокировать 5 дополнительных тем, поочередно запустив их.
Для этого, запустите диалоговое окно "Выполнить" (Win + R) и наберите в нем:
C:\Windows\Globalization\MCT\MCT-AU\Theme\AU.theme
C:\Windows\Globalization\MCT\MCT-CA\Theme\CA.theme
C:\Windows\Globalization\MCT\MCT-GB\Theme\GB.theme
C:\Windows\Globalization\MCT\MCT-US\Theme\US.theme
C:\Windows\Globalization\MCT\MCT-ZA\Theme\ZA.theme

4. Изменение ширины меню Пуск.

Открываете с помощью Restorator или PE Explorer файл C:\Windows\Resources\Themes\Aero\ru-RU\aero.msstyles.mui и изменяете значения в строковой таблице в строках с 113 по 121 включительно, делаете их такими же, как в C:\Windows\Resources\Themes\Aero\en-US\aero.msstyles.mui

5. Добавление эффекта прозрачности окнам в Windows.

Вариант 1.

Включить прозрачный эффект можно при помощи небольшого скрипта: HideBlur Tool for Windows 7

Инструкция:

1. Распакуйте и запустите файл "Patch Blur x86.bat". Если у вас x64 битная версия, запустите файл "Patch Blur x64.bat".
2. Это займет немного времени и вы увидите окно без эффекта матовости.
3. Если захотите вернуть эффект матовости, запустите файл "Enable Blur.bat". А если снова захотите убрать матовость запустите файл "Disable Blur.bat".
4. Если вы решите восстановить системные файлы запустите файл "Unpatch Blur.bat".
Изменения становятся видимыми после перезагрузки.

Сайт автора скрипта

Вариант 2.

1) Скачайте архив TrueTransparency.zip
2) Распакуйте его и запустите файл TrueTransparency.exe
3) На панели задач появится значок программы. Щелкните на нем правой кнопкой мыши.
4) Выберите нужный язык в всплывающем меню Language(Языки), в меню Skins (Внешний вид) выберите одну из предложенных тем прозрачности.

Также Вы можете воспользоваться решением предложенным в совете 16. Добавление функций окна Персонализация в Windows 7 Starter и Windows 7 Home Basic. из раздела Интерфейс - Внешний вид.

6. Принудительное включение эффекта Aero Glass.

Вариант 1.

1) Нажмите Win+R и введите regedit
2) Установите следующие значения в реестре:

Готовый reg-файл enableaero.reg
3) Перезапустите "Диспетчер сеансов диспетчера окон рабочего стола" из command prompt, запущенного с правами администратора:

Вариант 2.

1) Скачайте утилиту UxStyle
2) Распакуйте скачанный архив и в зависимости от разрядности установите необходимую Вам версию.
3) Смените оформление системы на классическую тему:
В Windows 7 Starter и Windows 7 Home Basic: Меню "Пуск" -> Панель управления -> Экран -> Изменить цветовую схему
В остальных версиях Windows 7: Правой кнопкой мыши на Рабочем столе -> Персонализация
4) Откройте папку C:\windows\Resources\Themes\Aero\
5) Задайте полный доступ к файлу aero.msstyle (можете воспользоваться советом: Администрирование: 1. Получение полного доступа к файлу или папке.)
6) Переименуйте aero.msstyle в aero.bak
7) Скачайте модифицированный файл aero.msstyle и поместите его вместо переименованного.
8) Смените оформление на стандартную тему Windows 7.

7. Улучшение качества передачи цветов монитором.

Windows 7 предлагает новый мастер калибровки экрана (Display Colour Calibration Wizard), который поможет Вам должным образом установить настройки цвета, яркости и контраста, а ClearType tuner сделает текст резким и контрастным. Для вызова средства калибровки цветов монитора сделайте следующее:

1) Нажмите кнопку Пуск
2) В строке поиска введите dccw.exe и нажмите клавишу Enter.

Вы можете запустить калибровку цветов и другим способом:

1) Откройте Пуск -> Панель управления
2) Перейдите по ссылкам Оформление и персонализация -> Экран
3) В левой области выберите пункт Калибровка цветов.

8. Включение Flip3D — отображение окон под углом.

1. Щелкните правой кнопкой мыши по рабочему столу, выберите Создать и затем Ярлык.
2. В поле "Укажите расположение объекта" введите следующее: RunDll32 DwmApi #105 и нажмите Далее.
3. Наберите имя вашего будущего (например, Flip3D) ярлыка и нажмите Готово.

Для переключения между окнами в режиме Flip3D, Вы можете использовать комбинацию клавиш Win+Tab.

9. Расширение функциональности часов в трее или изменение их вида.

Скачайте программу Stoic Joker's T-Clock x32/x64. Данная программа позволяет вам расширить функциональность часов в трее или изменить внешний вид часов в трее. Вы сможете добавить секунды к часам, изменить внешний вид часов, даты или добавить созданные вами значки для запуска конкретных приложений в трей.

10. Добавление дополнительных операций к окнам.

К сожалению, многие разработчики не столь тщательно занимаются интерфейсом своих программ. Часто бывает, что у довольно хорошей программами неудачный интерфейс. Отсутствуют какие-либо нужные вам кнопки. А бывает вам надо сравнить два окна или скопировать из одного в другое, а для этого необходимо поместить окно поверх других. Вот тут вам и поможет данная программа.

Добавляет дополнительные функции для окон:
  • свернуть при запуске/деактивации, развернуть при запуске, закрыть при запуске, изменить положение/размер (например: в пикселях) при запуске
  • зафиксировать положение/размер (например: в пикселях), изменить приоритет выполнения при запуске/деактивации;
  • cвернуть в область уведомлений, поверх других окон, позади остальных, прозрачность, через дополнительные кнопки заголовка окна
  • и многие другие.
Скачать программу

11. Добавление командной строке эффекта прозрачности - Aero Glass.

Для добавления командной строке эффекта прозрачности (Aero Glass) сделайте следующее:

1) Скачайте архив: Glass_CMD.zip
2) Распакуйте его и запустите исполняемый файл минискрипта Glass CMD.exe.
3) Запустите командную строку(Win+R -> CMD ->Ok) и увидите эффект прозрачности (Aero Glass).
Для использования данного эффекта скрипт Glass CMD.exe должен быть запущен. При закрытии Glass CMD.exe эффект прозрачности пропадет.
При желании Вы можете добавить данный скрипт-программу в папку Автозагрузка в меню Пуск.
Если Вы не хотите, чтобы в области уведомлений (трее) отображался значок скрипта, то в файле Settings.ini, который идет в архиве в комплекте с исполняемым файлом скрипта, установите значение параметра HideTrayIcon равным 1.

12. Определение цветового кода любой точки экрана на мониторе.

Для того чтобы узнать цветовой код любой точки экрана на Вашем мониторе скачайте и установите небольшую, но функциональную программу ColorPic.

Данная программа абсолютно бесплатна и Вы можете скачать её с официального сайта: http://www.iconico.com/colorpic/index.aspx

Мощные средства для регулировки цвета позволяют Вам с легкостью менять индивидуальные цвета. С помощью четырех графических миксеров Вы сможете регулировать RGB, оттенки, насыщенность и код цвета. У Вас будет возможность просматривать CMYK печатные коды цвета, а для идеальной точности использовать увеличитель экрана. Вы сможете сохранять множество цветовых палитр для их использования в любом приложении.

Содержащийся в программе раздел "Mixer" предоставляет Вам четыре мощных графических способа для анализа и изменения выбранного цвета. Цвета могут быть выбраны из любых шестиугольных форм, измененных миксером или настроенных шестью индивидуальными слайдерами для оттенков, насыщенности, кода и красных, зеленых и голубых цветовых компонентов. ColorPic также делает отчеты для регулировки голубого, пурпурного, желтого и черного цветовых кодов.

Кроме того, ColorPic также предлагает возможность увеличения, предоставляя Вам супер детальную картинку при выборе цвета. Программа имеет простой в использовании слайдер для увеличения, который позволяет Вам выбирать или разовую пробу или 3x3 или 5x5 средний цвет из любого места на Вашем экране.

Будучи неоценимым средством для любого графического дизайнера или веб-разработчика и будучи постоянно самым популярным бесплатным цветоподборщиком в сети, самая последняя версия ColorPic предлагает мощные средства для выбора цвета, которые до сих пор доступны только в дорогих приложениях.

Использовать программу очень просто:

1) Запускаете программу
2) Наводите курсор в то место, цвет которого желаете узнать.
3) Нажимаете Ctrl+G и в первой ячейке сохраняется информация о цвете.
4) Затем выделяете следующую ячейку и проделываете указанное выше для определения другого цвета.

13. Создание темы оформления с использованием RSS-обоев.

В интернете существует много программ позволяющих менять картинки на рабочем столе, автоматически скачивая их из интернета. Но Вам необязательно скачивать дополнительную программу, так как возможность обновления фона рабочего стола используя интернет имеется в самой Windows. Для этого Вам необходимо создать новую тему для Windows со ссылкой на RSS ленту, в качестве новостей транслирующую картинки.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).

2) Замените {themename} на название темы (Например: RSS Wallpapers), а вместо {rssfeedurl} впишите адрес ленты, транслирующей картинки.

Например:

http://feeds.feedburner.com/bingimages
http://api.flickr.com/services/feeds/photos_public.gne
http://feeds.nationalgeographic.com/ng/News/News_Main
http://mlewallpapers.com/4x3_rss.php

3) Нажмите CTRL+S и сохраните файл с любым именем и расширением .theme. Например: RSS_Wallpappers.theme
4) Щелкните два раза по получившемуся файлу.
5) В окне Подписаться на RSS канал?(Subscribe to RSS Feed?) выберите пункт Загружать вложения (Download Attachments).

Многие RSS ленты рекомендуют (хотя и необязательно) в Панель управления\Оформление и персонализация\Персонализация\Фоновый рисунок рабочего стола установить положение изображения По центру.

Готовые 4 схемы Вы можете скачать по ссылке: rssthemes.zip

14. Изменение фонового рисунка рабочего стола в Windows 7 Starter.

Вариант 1. Вручную используя реестр Windows.

1) Запустите Редактор реестра. Откройте меню Пуск, введите в строке поиска regedit и нажмите Enter (или Win+R -> regedit -> OK).
2) Откройте ветку HKEY_CURRENT_USER\Control Panel\Desktop
3) Щелкните правой кнопкой мыши на папке Desktop в древовидном списке слева, и нажмите пункт "Разрешения..."

4.1) Если Вы первый раз изменяете фоновое изображение:

4.1.1) Нажмите кнопку Дополнительно
4.1.2) Перейдите на вкладку Владелец, выделите свое имя в окне Изменить владельца на: и нажмите кнопку Применить
4.1.3) Перейдите на вкладку Разрешения и уберите флажок Добавить разрешения, наследуемые от родительских объектов. В случае запроса системой дальнейшего действия нажимаете кнопку Удалить.
4.1.4) Нажмите поочередно кнопки Добавить... -> Дополнительно... -> Поиск
4.1.5) В результатах поиска выберите Все и нажмите кнопку "OK", и еще раз "ОК".
4.1.6) В окне Элемент разрешения для "Desktop" напротив значения Полный доступ установите флажок в столбце Разрешить и нажмите несколько раз кнопки ОК.

4.2) Если Вы во второй раз изменяете фоновое изображение или если у Вас в "Группы и Пользователи" уже есть группа "Все" и Вы являетесь владельцем объекта:

4.2.1) Выделите группу Все, нажав на нее.
4.2.2) В части окна Разрешения для группы "Все" установите флажок Полный доступ в столбике Разрешить и нажимаете ОК.

5) Найдите строковый параметр Wallpaper и дважды щелкните на нем.
6) Введите путь к изображению, которое Вы хотите использовать как обои рабочего стола и нажмите ОК.
7) По умолчанию, положение изображения устанавливается По центру, если Вам необходимо другое положение, то дополнительно измените:

Параметр TileWallpaper на значение 1, чтобы Замостить изображение.
Параметр WallpaperStyle на значение 2, чтобы Растянуть изображение.

8) Щелкните правой кнопкой мыши на папке Desktop в древовидном списке слева, и нажмите пункт "Разрешения..."
9) Выделите группу Все, нажав на нее.
10) Уберите флажок в столбце Разрешить напротив значения Полный доступ и нажмите кнопку ОК.
Если Вы не уберете данный флажок, то система установит стандартные обои рабочего стола.
11) Перезайдите в систему или перезагрузите компьютер.

Вариант 2. Автоматически используя специальную программу.

1) Скачайте архив программы Starter Background Changer.zip
2) Разархивируйте файл в любую папку и установите нужную Вам языковую версию программы.
3) Нажмите правой кнопкой мыши на рабочем столе и выберите в контекстном меню пункт Персонализация (Personalize)
4) Нажмите кнопку Обзор... (Browse...).
5) Выберите необходимое Вам изображение и нажмите кнопку Открыть (Open).
6) Выберите положение рисунка и нажмите Применить (Apply), чтобы установить рисунок не выходя из программы или ОК, чтобы установить рисунок и выйти их программы.
7) Чтобы установить стандартное изображение выберите в ниспадающем меню Фоновый рисунок Windows по умолчанию и нажмите кнопку ОК.

15. Изменение размера окон предпросмотра на панели задач.

Если Вам необходимо изменить размер окон предпросмотра, расстояние между ними, размер бордюра и время задержки, то в этом Вам поможет программа Windows 7 Taskbar Thumbnail Customizer.

1) Скачайте программу Windows 7 Taskbar Thumbnail Customizer

2) Настройте параметры программы в соответствие с Вашими запросами.

Maximum Size - максимальный размер окна предпросмотра
Minimum Size - минимальный размер окна предпросмотра

X Spacing - расстояние между окнами предпросмотра по-горизонтали
Y Spacing - расстояние между окнами предпросмотра по-вертикали

Top Margin - размер верхнего бордюра
Bottom Margin - размер нижнего бордюра
Left Margin - размер левого бордюра
Right Margin - размер правого бордюра

Delay Time - время задержки до появления окна предпросмотра

16. Добавление функций окна Персонализация в Windows 7 Starter и Windows 7 Home Basic.

1) Скачайте утилиту UxStyle
2) Распакуйте скачанный архив и в зависимости от разрядности установите необходимую Вам версию.
3) Смените оформление системы на классическую тему:
В Windows 7 Starter и Windows 7 Home Basic: Меню "Пуск" -> Панель управления -> Экран -> Изменить цветовую схему
В остальных версиях Windows 7: Правой кнопкой мыши на Рабочем столе -> Персонализация
4) Откройте папку C:\windows\Resources\Themes\Aero\
5) Задайте полный доступ к файлу aero.msstyle (можете воспользоваться советом: Администрирование: 1. Получение полного доступа к файлу или папке.)
6) Переименуйте aero.msstyle в aero.bak
7) Скачайте пропатченный файл aero.msstyle и поместите его вместо переименованного.
8) Смените оформление на стандартную тему Windows 7.
9) Скачайте и установите программу Personalization Panel (Для интеграции в меню рабочего стола выберите Обычная установка)
10) В Windows 7 Home Basic нажмите правой кнопкой мыши на рабочем столе, выберите пункт Персонализация и нажмите на ссылку Цвет окна.
11) В открывшемся окне нажмите на ссылку Показать или скрыть настройку цветов. и установите переключатель Windows 7 [Patched]
12) Ползунком измените интенсивность цвета (степень прозрачности) и нажмите кнопку Сохранить изменения.

В Windows 7 Starter панель позволяет менять обои только при запуске от имени администратора. Если у пользователя этих прав нет, или он нажал "Нет" в ответ на запрос UAC, функция смены обоев недоступна - программа функционирует в ОГРАНИЧЕННОМ режиме. Кроме того, если у пользователя есть права администратора, он меняет обои на нестандартные, а затем запускает программу в ОГРАНИЧЕННОМ режиме, смена экранной заставки может не работать, так как смена обоев меняет права на системный реестр, запрещая пользователю ниже, чем администратор, запись в него. Для корректной смены заставки в ОГРАНИЧЕННОМ режиме необходимо, чтобы стояли стандартные обои. В обычном режиме работы панели (от имени администратора) в Windows 7 Starter таких ограничений нет.

1. Windows 7 [Patched]

Используйте если у вас установлена пропатченная тема(Вы установили UxStyle и заменили aero.msstyle). Окна Windows 7 Home Basic будут использовать оформление Aero Glass и эффект прозрачности.

2. Windows 7 стандратный

Используйте если у вас установлена непропатченная тема. Не используйте с патченными темами - пропадет эффект прозрачности и окна будут заливаться черным цветом.

Также Вы можете cкачать Пакет Personalization Panel для Windows 7 Starter и Home Basic с темами и автопатчем.
Данный пакет автоматически выполнит следующие действия:

  • Автоматически установит патченные версии файлов для поддержки сторонних тем.
  • Автоматически установит тему Windows 7 c Aero для систем Windows 7 Домашняя базовая. Это обычная системная тема, только в ней разлочена прозрачность.
  • Установит набор из 12 базовых тем для систем Windows 7 Домашняя базовая и Windows 7 Начальная.
  • В системах Windows 7 Домашняя базовая установит 10 тем Aero.
Внимание! Перед установкой пакета надо удалить программу UxStyle. Если вы этого не сделаете, пакет не установится.

17. Замена фона папки в проводнике.

Проще всего для замены фона в папке использовать следующие программы:

Windows 7 Folder Background Changer

1) Запустите программу Windows 7 Folder Background Changer
2) Нажмите кнопку Browse и выберите фоновое изображение
3) Нажмите Change Background Image, чтобы установить фоновое изображение или кнопку Remove Background Image, чтобы убрать фоновое изображение.
4) Для изменения фонового изображения во вложенных папках, установите флажок Apply To Sub Folders.

AveFolderBG: для 32-бит; для 64-бит - данная программа добавляет дополнительную вкладку в свойства каждой папки.

1) Установите программу используя файл install.bat
2) Перезапустите Windows или перезайдите в систему.
3) Щелкните правой кнопкой мыши и выберите Свойства
4) Перейдите на вкладку Folder Background
5) Нажмите кнопку Set Image, выбираете изображение и нажимаете Открыть. Для удаления изображения используйте кнопку Remove Image.
6) Для изменения фонового изображения во вложенных папках, установите флажок Apply to subfolders also.
7) Нажмите кнопку Применить или ОК.

18. Сохранение созданной Вами схемы указателей мыши в файл, для дальнейшего использования.

Созданные Вами схемы для указателей мыши прописываются в реестре.
Если Вы желаете сохранить созданную Вами тему для дальнейшего применения после переустановки, то сделайте следующее:

1) Откройте Пуск -> Панель управления -> Мышь
2) Перейдите на вкладку Указатели
3) В окне Настройка измените необходимые Вам курсоры.
4) Нажмите кнопку Сохранить как, введите название сохраняемой темы и нажмите ОК.
5) В окне Свойства:Мышь снова нажмите ОК.
6) Запустите редактор реестра (Win+R -> regedit -> ОК)
7) Откройте раздел HKEY_CURRENT_USER\Control Panel\Cursors\Schemes
8) Экспортируйте данный раздел в reg-файл.
8.1) В главном меню выберите Файл -> экспорт
9) Задайте имя файла и нажмите кнопку Сохранить.

Система создаст reg-файл, который Вы сможете использовать в дальнейшем. Например, после переустановки Windows.
Если при создании схемы для указателей Вы использовали файлы отсутствующие в системе, то после переустановки Windows, перед применением reg-файла скопируйте их в те же месторасположения.

19. Добавление отображения эскизов и детальной информации для файлов .mkv в проводнике Windows.

Скачайте и установите DivX Plus Tech Preview.

Данная программа добавляет поддержку MKV-файлов в проводник Windows, так что Вы сможете просматривать их эскизы в Windows Explorer. Также Вам станут доступны детальные сведения о файле.

Положительной особенностью является тот факт, что DivX Plus Tech Preview работает с любыми пакетами кодеков (K-Lite или Shark).

Интерфейс - Взаимодействие.

1. Открытие диспетчера задач, одной комбинацией клавиш, а не ctrl+alt+del и клик по пункту.

Вариант 1

Нажмите комбинацию клавиш Ctrl+Shift+Esc.

Вариант 2

Щелкните правой кнопкой на панели задач и выберите пункт Запустить диспетчер задач (Start Task Manager).

2. Использование средней кнопки мыши при работе с панелью задач.

Если щелкнуть средней кнопкой мышки на приложении в панели задач, откроется новое окно приложения. А если же средней кнопкой щелкнуть на окошке превью, которое всплывает над иконой программы, то это закроет данную программу или окно.

3. Перезапуск Проводника или рабочего стола.

Вариант 1. Только клавиатура.

1) Нажмите комбинацию клавиш Ctrl+Esc
2) Нажмите стрелку вправо (→)
3) Нажмите комбинацию клавиш Ctrl+Shift+F10 или Ctrl+Shift+Menu
4) Нажатием стрелочки вниз перейдите на пункт Выход из проводника (Exit Explorer) и нажмите Enter.
5) Нажмите последовательно: Alt, затем стрелку вниз (↓) и нажмите Enter.
6) Введите команду explorer и нажмите клавишу Enter.

Вариант 2. Частичное использование Диспетчера задач.

1) Откройте меню Пуск
2) Удерживая нажатым комбинацию клавиш Ctrl+Shift, щелкните правой кнопкой мыши кнопку Завершение работы (Shut Down).
3) В контекстном меню выберите пункт Выход из проводника (Exit Explorer).
4) Нажмите комбинацию клавиш Ctrl+Shift+Esc
5) Нажмите Файл -> Новая задача (Выполнить...) или в английской версии File -> New Task (Run...)
6) Введите команду explorer и нажмите кнопку ОК

Вариант 3. Полное использование Диспетчера задач.

1) Откройте Диспетчер задач (Task Manager)
1.1) Щелкните правой кнопкой мыши пустую область на панели задач и выберите команду Запустить диспетчер задач или нажмите сочетание клавиш Ctrl+Shift+Esc
2) Перейдите на вкладку Процессы (Processes)
3) Щелкните правой кнопкой мыши на процесс explorer.exe и выберите пункт Завершить процесс (End Process). Если у Вас несколько процессов с таким названием, то повторите данное действие для каждого процесса explorer.exe.
4) Нажмите Файл -> Новая задача (Выполнить...) или в английской версии File -> New Task (Run...)
5) Введите команду explorer и нажмите кнопку ОК
5) Введите команду explorer и нажмите кнопку ОК

4. Запуск команд Windows Shell, используя названия и {GUID} объектов.

Microsoft Windows Shell - интерпретатор команд операционной системы (ОС), обеспечивающий интерфейс для взаимодействия пользователя с функциями системы. Позволяет получить доступ к диалоговым окнам, к файловой системе, запускать программы и изменять системные настройки.
Для быстрого перехода к компонентам Windows используется команда shell.
GUID (Globally Unique Identifier) — статистически уникальный 128-битный идентификатор. Использование GUID гарантирует, что две версии одного компонента могут иметь одно и то же имя, но быть отличимыми по GUID. Microsoft применяет GUID в качестве идентификаторов для большого количества своих объектов. Зная GUID Вы сможете открыть многие компоненты Windows: элементы Панели управления, системные папки, различные программы и настройки.

Для запуска любого из объектов Windows, используя {GUID}, применяется команда:

где {GUID} - идентификатор {GUID} нужного Вам объекта. Например, для запуска Панели управления наберите команду:

Вы можете поискать нужные Вам {GUID} в разделе реестра HKEY_CLASSES_ROOT\CLSID или воспользоваться таблицей №1.

Таблица №1.

Русское название элемента | Английское название элемента | Команда
Flip 3D (Win+Tab) | Flip 3D (Win+Tab) | Shell:::{3080F90E-D7AD-11D9-BD98-0000947B0257}
Fusion Cache | Fusion Cache | Shell:::{1D2680C9-0E2A-469d-B787-065558BC7D43}
Internet Explorer | Internet Explorer | Shell:::{871C5380-42A0-1069-A2EA-08002B30309D}
Microsoft Outlook | Microsoft Outlook | Shell:::{2559a1f5-21d7-11d4-bdaf-00c04f60b9f0}
Windows CardSpace | Windows CardSpace | Shell:::{78CB147A-98EA-4AA6-B0DF-C8681F69341C}
Windows SideShow | Windows SideShow | Shell:::{E95A4861-D57A-4be1-AD0F-35267E261739}
Автозапуск | AutoPlay | Shell:::{9C60DE1E-E5FC-40f4-A487-460851A8D915}
Автономные файлы | Offline Files | Shell:::{D24F75AA-4F2B-4D07-A3C4-469B3D9030C4}
Администрирование | Administrative Tools | Shell:::{D20EA4E1-3957-11d2-A40B-0C5020524153}
Архивация и восстановление | Backup and Restore | Shell:::{B98A2BEA-7D42-4558-8BD1-832F41BAC6FD}
Библиотеки | Libraries | Shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Биометрические устройства | Biometric Devices | Shell:::{0142e4d0-fb7a-11dc-ba4a-000ffe7ab428}
Брандмауэр Windows | Windows Firewall | Shell:::{4026492F-2F69-46B8-B9BF-5654FC07E423}
Восстановление | Recovery | Shell:::{9FE63AFD-59CF-4419-9775-ABCC3849F861}
Восстановление системы | System Restore | Shell:::{3f6bc534-dfa1-4ab4-ae54-ef25a74e0107}
Все задачи | All Tasks | Shell:::{ED7BA470-8E54-465E-825C-99712043E01C}
Все элементы панели управления | All Control Panel Items | Shell:::{21EC2020-3AEA-1069-A2DD-08002B30309D}
Выполнить | Run | Shell:::{2559a1f3-21d7-11d4-bdaf-00c04f60b9f0}
Гаджеты рабочего стола | Desktop Gadgets | Shell:::{37efd44d-ef8d-41b1-940d-96973a50e9e0}
Дата и Время | Date and Time | Shell:::{E2E7934B-DCE5-43C4-9576-7FE4F75E7480}
Датчик расположения и другие датчики | Location and Other Sensors | Shell:::{E9950154-C418-419e-A90A-20C5287AE24B}
Диспетчер устройств | Device Manager | Shell:::{74246bfc-4c96-11d0-abef-0020af6b0b7a}
Диспетчер учетных данных | Credential Manager | Shell:::{1206F5F1-0569-412C-8FEC-3204630DFB70}
Домашняя группа | HomeGroup | Shell:::{67CA7650-96E6-4FDD-BB43-A8E774F73A57}
Домашняя группа - папка | HomeGroup folder | Shell:::{6785BFAC-9D2D-4be5-B7E2-59937E8FB80A}
Защитник Windows | Windows Defender | Shell:::{D8559EB9-20C0-410E-BEDA-7ED416AECC2A}
Звук | Sound | Shell:::{F2DDFC82-8F12-4CDD-B7DC-D4FE1425AA4D}
Значки области уведомлений | Notification Area Icons | Shell:::{05d7b0f4-2121-4eff-bf6b-ed3f69b894d9}
Игровые устройства | Game Controllers | Shell:::{259EF4B1-E6C9-4176-B574-481532C9BCE8}
Игры | Games | Shell:::{ED228FDF-9EA8-4870-83b1-96b02CFE0D52}
Избранное | Favorites | Shell:::{323CA680-C24D-4099-B94D-446DD2D7249E}
Инфракрасная связь | Infrared | Shell:::{A0275511-0E86-4ECA-97C2-ECD8F1221D08}
Карта сети | Network Map | Shell:::{E7DE9B1A-7533-4556-9484-B26FB486475E}
Компоненты Windows | Windows Features | Shell:::{67718415-c450-4f3c-bf8a-b487642dc39b}
Компьютер | Computer | Shell:::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина | Recycle Bin | Shell:::{645FF040-5081-101B-9F08-00AA002F954E}
Мои Документы | My Documents | Shell:::{450D8FBA-AD25-11D0-98A8-0800361B1103}
Настройка доступа программ и умолчаний | Set Program access and Windows defaults | Shell:::{2559a1f7-21d7-11d4-bdaf-00c04f60b9f0}
Недавние места | Recent Places | Shell:::{22877a6d-37a1-461a-91b0-dbda5aaebc99}
Общие | Public | Shell:::{4336a54d-038b-4685-ab02-99bb52d3fb8b}
Панель управления (заданного Вами вида) | Control Panel | Shell:::{5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}
Панель управления (Категория) | Control Panel (Category) | Shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}
Параметры индексирования | Indexing Options | Shell:::{87D66A43-7B11-4A28-9811-C86EE395ACF7}
Параметры папок | Folder Options | Shell:::{6DFD7C5C-2451-11d3-A299-00C04F8EF6AF}
Параметры планшетного компьютера | Tablet PC Settings | Shell:::{80F3F1D5-FECA-45F3-BC32-752C152E456E}
Параметры шрифта | Font settings | Shell:::{93412589-74D4-4E4E-AD0E-E0CB621440FD}
Переносные устройства | Portable Devices | Shell:::{35786D3C-B075-49b9-88DD-029876E11C01}
Перо и сенсорные устройства | Pen and Touch | Shell:::{F82DF8F7-8B9F-442E-A48C-818EA735FF9B}
Персонализация | Personalization | Shell:::{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection | Shell:::{241D7C96-F8BF-4F85-B01F-E2B043341A4B}
Поиск Windows | Search | Shell:::{2559a1f0-21d7-11d4-bdaf-00c04f60b9f0}
Получение программ | Get Programs | Shell:::{15eae92e-f17a-4431-9f28-805e482dafd4}
Принтеры | Printers | Shell:::{2227A280-3AEA-1069-A2DE-08002B30309D}
Приступая к работе | Getting Started | Shell:::{CB1B7F8C-C50A-4176-B604-9E24DEE8D4D1}
Программы и компоненты | Programms and Features | Shell:::{7b81be6a-ce2b-4676-a29e-eb907a5126c5}
Программы по умолчанию | Default Programs | Shell:::{17cd9488-1228-4b2f-88ce-4298e93e0966}
Рабочий стол | Desktop | Shell:::{3080F90D-D7AD-11D9-BD98-0000947B0257}
Распознавание речи | Speech Recognition | Shell:::{58E3C745-D971-4081-9034-86E34B30836A}
Расположение по умолчанию | Default Location | Shell:::{00C6D95F-329C-409a-81D7-C46C66EA7F33}
Родительский контроль | Parental Controls | Shell:::{96AE8D84-A250-4520-95A5-A47A7E3C548B}
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | Shell:::{0DF44EAA-FF21-4412-828E-260A8728E7F1}
Свойства речи | Text to Speech | Shell:::{D17D1D6D-CC3F-4815-8FE3-607E7D5D10B3}
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | Shell:::{A304259D-52B8-4526-8B1A-A1D6CECC8243}
Свойства: Интернет | Internet Properties | Shell:::{A3DD4F92-658A-410F-84FD-6FBBBEF2FFFE}
Свойства: Клавиатура | Keyboard Properties | Shell:::{725BE8F7-668E-4C7B-8F90-46BDB0936430}
Свойства: Мышь | Mouse Properties | Shell:::{6C8EEC18-8D75-41B2-A177-8831D59D2D50}
Сетевые подключения | Network Connections | Shell:::{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сетевые подключения в Области уведомления | Network Connections in Notification area | Shell:::{38A98528-6CBF-4CA9-8DC0-B1E1D10F7B1B}
Сеть | Network | Shell:::{208D2C60-3AEA-1069-A2D7-08002B30309D}
Система | System | Shell:::{BB06C0E4-D293-4f75-8A90-CB05B6477EEE}
Сканеры и камеры | Scanners and Cameras | Shell:::{00f2886f-cd64-4fc9-8ec5-30ef6cdbe8c3}
Соседние пользователи | People Near Me | Shell:::{5224F545-A443-4859-BA23-7B5A95BDC8EF}
Справка и Поддержка | Windows Help and Support | Shell:::{2559a1f1-21d7-11d4-bdaf-00c04f60b9f0}
Счетчики и средства производительности | Performance Information and Tools | Shell:::{78F3955E-3B90-4184-BD14-5397C15F1EFC}
Телефон и модем | Phone and Modem | Shell:::{40419485-C444-4567-851A-2DD7BFA1684D}
Управление беспроводными сетями | Manage Wireless networks | Shell:::{1FA9085F-25A2-489B-85D4-86326EEDCD87}
Управление цветом | Color Management | Shell:::{B2C761C6-29BC-4f19-9251-E6195265BAF1}
Установленные обновления | Installed Updates | Shell:::{d450a8a1-9568-45c7-9c0e-b4f9fb4537bd}
Устранение неполадок | Troubleshooting | Shell:::{C58C4893-3BE0-4B45-ABB5-A63E4B8C8651}
Устройства Bluetooth | Bluetooth Devices | Shell:::{28803F59-3A75-4058-995F-4EE5503B023C}
Устройства и принтеры | Devices and Printers | Shell:::{A8A91A66-3A7D-4424-8D24-04E180695C7A}
Учетные записи пользователей | User Accounts | Shell:::{60632754-c523-4b62-b45c-4172da012619}
Центр мобильности Windows | Windows Mobility Center | Shell:::{5ea4f148-308c-46d7-98a9-49041b1dd468}
Центр обновления Windows | Windows Update | Shell:::{36eef7db-88ad-4e81-ad49-0e313f0c35f8}
Центр поддержки | Action Center | Shell:::{BB64F8A7-BEE7-4E1A-AB8D-7D8273F7FDB6}
Центр синхронизации | Sync Center | Shell:::{9C73F5E5-7AE7-4E32-A8E8-8D23B85255BF}
Центр специальных возможностей | Ease of Access Center | Shell:::{D555645E-D4F8-4c29-A827-D93C859C4F2A}
Центр управления сетями и общим доступом | Network and Sharing Center | Shell:::{8E908FC9-BECC-40f6-915B-F4CA0E70D03D}
Шифрование диска BitLocker | BitLocker Drive Encryption | Shell:::{D9EF8727-CAC2-4e60-809E-86F80A666C91}
Экран (размер текста) | Display (size of text) | Shell:::{C555438B-3C23-4769-A71F-B6D3D9B6053A}
Электропитание | Power Options | Shell:::{025A5937-A6BE-4686-A844-36FE4BEC8B6D}
Язык и региональные стандарты | Region and Language | Shell:::{62D8ED13-C9D0-4CE8-A914-47DD628FB1B0}

Для некоторых системных папок, Вы можете создать их копии, в любом, необходимом для Вас месте. Такие папки не будут занимать место на диске, а будут служить символическими ссылками на оригинальные. Для создания такой папки-ссылки:

1) Создайте в любом нужном Вам месте новую папку (Щелчок ПКМ -> Создать -> Папку)
2) Переименуйте её следующим образом:

Все задачи - All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}
Администрирование - Administrative Tools.{D20EA4E1-3957-11d2-A40B-0C5020524153}
Библиотеки - Libraries.{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Компьютер - Computer.{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина - Recycle Bin.{645FF040-5081-101B-9F08-00AA002F954E}
Персонализация - Personalize.{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Принтеры - Printers and Faxes.{2227A280-3AEA-1069-A2DE-08002B30309D}
Программы - Programs Folder.{7BE9D83C-A729-4D97-B5A7-1B7313C39E0A}
Сетевые подключения - Network Connections.{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сеть (WORKGROUP) - Network Places.{208D2C60-3AEA-1069-A2D7-08002B30309D}
Учетные записи пользователей - User Accounts.{60632754-c523-4b62-b45c-4172da012619}

Принцип запуска команд Shell, используя имя объектов, намного легче. Данный способ не требует от Вас знания большого количества цифр и букв, и позволяет снизить величину ошибок при наборе команды. Его основное применение - открытие системных папок.

Например, для быстрого перехода в папку Панели Быстрого Запуска, которая присутствует в Windows, но не добавлена на Панель Задач, достаточно написать команду shell:Quick Launch. При выполнении команды будет в проводнике будет открыта папка: C:\Users\%UserName%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

Для запуска любого из объектов Windows, используя его имя, применяется команда:

Вы можете найти нужные Вам имена объектов в разделах ветки реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\FolderDescriptions или воспользоваться таблицей №2.

Таблица №2.

Имя программы или папки | Адрес папки | Команда
32-разрядный Internet Explorer | C:\Program Files\Internet Explorer или C:\Program Files (x86)\Internet Explorer | shell:InternetFolder
Common Files (в 32-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommon
Common Files (в 64-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommonX64
Common Files (в 64-битной Windows 7) | C:\Program Files (x86)\Common Files | shell:ProgramFilesCommonX86
Cookies | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies | shell:Cookies
Credentials | C:\Users\User-Name\AppData\Roaming\Microsoft\Credentials | shell:CredentialManager
Crypto | C:\Users\User-Name\AppData\Roaming\Microsoft\Crypto | shell:CryptoKeys
DeviceMetadataStore | C:\ProgramData\Microsoft\Windows\DeviceMetadataStore | shell:Device Metadata Store
Documents | C:\Users\Public\Documents | shell:Common Documents
Fonts (шрифты) | C:\Windows\Fonts | shell:Fonts
Gadgets | C:\Program Files\Windows Sidebar\Gadgets | shell:default Gadgets
Gadgets | C:\Users\User-Name\AppData\Local\Microsoft\WindowsSidebar\Gadgets | shell:Gadgets
GameExplorer | C:\ProgramData\Microsoft\Windows\GameExplorer | shell:PublicGameTasks
GameExplorer (Обозреватель игр) | C:\Users\User-Name\AppData\Local\Microsoft\Windows\GameExplorer | shell:GameTasks
History | C:\Users\User-Name\AppData\Local\Microsoft\Windows\History | shell:History
ImplicitAppShortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\ImplicitAppShortcuts | shell:ImplicitAppShortcuts
Local | C:\Users\User-Name\AppData\Local | shell:Local AppData
LocalLow | C:\Users\User-Name\AppData\LocalLow | shell:LocalAppDataLow
Low | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies\Low | shell:Cookies\Low
Network Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\NetworkShortcuts | shell:NetHood
Printer Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\PrinterShortcuts | shell:PrintHood
Program Files | C:\Program Files | shell:ProgramFiles
Program Files (x86) (в 64-битной Windows 7) | C:\Program Files (x86) | shell:ProgramFilesX86
Program Files (в 64-битной Windows 7) | C:\Program Files | shell:ProgramFilesX64
ProgramData | C:\ProgramData | shell:Common AppData
Protect | C:\Users\User-Name\AppData\Roaming\Microsoft\Protect | shell:dpapiKeys
Quick Launch (Быстрый запуск) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch | shell:Quick Launch
Resources (содержит темы Windows) | C:\Windows\Resources | shell:ResourceDir
Ringtones | C:\ProgramData\Microsoft\Windows\Ringtones | shell:CommonRingtones
Roaming | C:\Users\User-Name\AppData\Roaming | shell:AppData
SendTo (элементы контекстного меню Отправить) | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\SendTo | shell:SendTo
System32 | C:\Windows\System32 | shell:System
SystemCertificates | C:\Users\User-Name\AppData\Roaming\Microsoft\SystemCertificates | shell:SystemCertificates
SysWOW64 | C:\Windows\SysWOW64 | shell:SystemX86
Templates | C:\ProgramData\Microsoft\Windows\Templates | shell:Common Templates
Templates | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Templates | shell:Templates
Temporary Internet Files | C:\Users\User-Name\AppData\Local\Microsoft\Windows\TemporaryInternet Files | shell:Cache
User Pinned (Закрепленные элементы) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch\User Pinned | shell:User Pinned
User-Name (файлы Вашей учетной записи) | C:\Users\User-Name | shell:UsersFilesFolder
User-Name (Ваш учетный профиль) | C:\Users\User-Name | shell:Profile
Windows (главная папка системы) | C:\Windows | shell:Windows
Автозагрузка | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup | shell:Common Startup
Автозагрузка | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup | shell:Startup
Администрирование | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Administrative Tools
Администрирование | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Common Administrative Tools
Библиотеки | Библиотеки | shell:Libraries
Библиотеки | Библиотеки | shell:UsersLibrariesFolder
Видео | Библиотеки\Видео | shell:VideosLibrary
Временная папка для записи | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Burn\Burn | shell:CD Burning
Все элементы панели управления | Панель управления\Все элементы панели управления | shell:ControlPanelFolder
Главное меню | C:\ProgramData\Microsoft\Windows\Start Menu | shell:Common Start Menu
Главное меню | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu | shell:Start Menu
Документы | Библиотеки\Документы | shell:DocumentsLibrary
Домашняя группа | Домашняя группа | shell:HomeGroupFolder
Загрузки | C:\Users\User-Name\Downloads | shell:downloads
Згрузки | C:\Users\Public\Downloads | shell:CommonDownloads
Игры | Игры | shell:Games
Избранное | C:\Users\User-Name\Favorites | shell:Favorites
Изображения | C:\Users\Public\Pictures | shell:CommonPictures
Изображения | C:\Users\User-Name\Pictures | shell:My Pictures
Изображения | Библиотеки\Изображения | shell:PicturesLibrary
Компьютер | Компьютер | shell:MyComputerFolder
Контакты | C:\Users\User-Name\Contacts | shell:Contacts
Конфликты | Панель управления\Все элементы панели управления\Центрсинхронизации\Конфликты | shell:ConflictFolder
Корзина | Корзина | shell:RecycleBinFolder
Мои видеозаписи | C:\Users\User-Name\Videos | shell:CommonVideo
Мои видеозаписи | C:\Users\User-Name\Videos | shell:My Video
Мои документы | C:\Users\User-Name\Documents | shell:Personal
Моя Музыка | C:\Users\Public\Music | shell:CommonMusic
Моя музыка | C:\Users\User-Name\Music | shell:My Music
Музыка | Библиотеки\Музыка | shell:MusicLibrary
Настройка синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Настройка синхронизации | shell:SyncSetupFolder
Недавние документы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Recent | shell:Recent
Образцы видео | C:\Users\Public\Videos\Sample Videos | shell:SampleVideos
Образцы изображений | C:\Users\Public\Pictures\Sample Pictures | shell:SamplePictures
Образцы музыки | C:\Users\Public\Music\Sample Music | shell:SampleMusic
Общие | C:\Users\Public | shell:Public
Папка с рингтонами Windows 7 | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Ringtones | shell:Ringtones
Поиск Windows | search-ms: | shell:SearchHomeFolder
Поиски (информация о поисках) | C:\Users\User-Name\Searches | shell:Searches
Получение программ | Панель управления\Все элементы панели управления\Получение программ | shell:AddNewProgramsFolder
Пользователи | C:\Users | shell:UserProfiles
Принтеры | Все элементы панели управления\Принтеры | shell:PrintersFolder
Программы | C:\ProgramData\Microsoft\Windows\Start Menu\Programs | shell:Common Programs
Программы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu\Programs | shell:Programs
Программы и компоненты | Панель управления\Все элементы панели управления\Программы и компоненты | shell:ChangeRemoveProgramsFolder
Рабочий стол | C:\Users\Public\Desktop | shell:Common Desktop
Рабочий стол | C:\Users\User-Name\Desktop | shell:desktop
Результаты синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Результаты синхронизации | shell:SyncResultsFolder
Сетевые подключения | Панель управления\Все элементы панели управления\Сетевые подключения | shell:ConnectionsFolder
Сеть | Сеть | shell:NetworkPlacesFolder
Сохраненные игры | C:\Users\User-Name\Saved Games | shell:SavedGames
Ссылки | C:\Users\User-Name\Links | shell:Links
Установленные обновления | Программы и компоненты\Установленные обновления | shell:AppUpdatesFolder
Центр синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации | shell:SyncCenterFolder

Для упрощения работы с командами Windows Shell Вы можете скачать небольшую бесплатную программу Shell Dump.
Данная программа проанализирует Ваш реестр и отобразит список команд, которые Вы можете использовать. Вам всего лишь достаточно выбрать команду и нажать кнопку Run для ее запуска.

5. Включение и отключение Области переходов.

Область переходов – это специальная панель (дерево папок), которая находится слева в каждой папке.
Она выполняет функцию командной оболочки, обеспечивая быстрый доступ к папкам, которые содержат нужные файлы. Быстрое выполнение различных операций – таких, как копирование, удаление, архивирование файлов и папок, открытие сохраненного запроса поиска.
При большом числе файлов на экране, иногда необходимо отключить "Область переходов", для увеличения одновременно отображаемых файлов.

Включить или отключить Область переходов можно так:

1) Нажмите вверху слева Упорядочить->Представление
2) Поставьте или уберите галочку в пункте Область переходов

6. Использование переменных окружения для быстрого перехода к системным папкам.

Чтобы узнать какие из них присутствуют в Вашей системе запустите cmd.exe и в нем команду set. Получите полный список переменных окружения Вашей Windows.

%AllUsersProfile% - C:\ProgramData
%AppData% - C:\Users\%UserName%\AppData\Roaming
%CommonFavorites% - C:\Documents and Settings\All Users\Избранное
%CommonFiles% - C:\Program Files\Common Files
%CommonProgramFiles% - C:\Program Files\Common Files
%CommonProgramFiles(x86)% - C:\Program Files (x86)\Common Files
%ComSpec% - Запустит cmd.exe из папки, в которой будет употреблен
%HomePath% - C:\Users\Administrator
%LOCALAPPDATA% - C:\Users\%UserName%\AppData\Local
%ProgramData% - C:\ProgramData
%ProgramFiles% - C:\Program Files
%ProgramFiles(x86)% - C:\Program Files (x86)
%PSModulePath% - C:\Windows\System32\WindowsPowerShell\v1.0\Modules
%SystemDir% - C:\Windows\System32
%SystemDrive% - C:\
%SystemRoot% - C:\Windows
%Temp% - C:\Documents and Settings\%UserName%\Local Settings\Temp; C:\Users\%UserName%\AppData\Local\Temp
%Tmp% - C:\Users\%UserName%\AppData\Local\Temp
%UserProfile% - C:\Users\%UserName%
%windir% - C:\Windows

Если Вы решите создать собственную переменную типа:
%MyFolder%=C:\MyFolder

1) Пройдите:
Компьютер -> Свойства -> Дополнительные параметры системы ->Дополнительно -> Переменные среды
2) Нажмите Создать...
3) Укажите Имя переменной и Значение переменной
4) Нажмите на каждое Ок
5) Перезагрузите компьютер (иначе она не будет работать)

7. Использование флажков для выделения (выбора) файлов и папок.

В Windows есть удобная возможность помечать для выделения файлы и папки с использованием флажков (чекбоксов). Это удобнее чем выделять объекты удерживая Ctrl, но эта функция отключена по умолчанию. Для ее включения проделайте следующее:
Откройте Проводник и нажмите один раз клавишу Alt - таким образом мы инициализируем отображение стандартного меню вверху окна проводника, которое скрыто по умолчанию.
Запустите Пуск\Панель Управления\Параметры Папок и перейдите на вкладку Вид
Отметьте параметр "Использовать флажки для выбора элементов" и нажмите ОК
Теперь слева возле каждого файла и папки появилась возможность отметить их поставив флажок, а в заголовках колонок сортировки можно поставить флажок для выделения всех объектов открытой папки.

8. Объединение нескольких различных приложений(папок или иконок) в один значок на Панели задач.

Одним из самых явных изменений в Windows 7 является новая панель задач, в которой вместо кнопок отображаются иконки, и все окна приложения объединяются под одну кнопку. Со временем, когда на компьютере установлено много программ, на панели задач начинает не хватать места для кнопок. Исправить это можно с помощью бесплатной программы 7Stacks.

Она создает подменю для кнопок, позволяя отсортировать программы по разделам – игры, программы для интернета, и т.д.

Порядок действий:

1) Создайте папку
2) Сложите в нее ярлыки приложений, необходимых Вам в создаваемом меню.
3) Запустите 7Stacks
4) Выберите созданную Вами папку
5) Настройте оформление и создайте ярлык на рабочем столе.
6) Перетащите данный ярлык в панель задач.

9. Сворачивание всех неактивных окон, кроме текущего активного, используя Aero Shake.

В интерфейс Windows Aero добавлена новая функция Aero Shake, позволяющая свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти» влево-вправо.

10. Закрытие всех запущенных приложений одним кликом.

Утилита под названием Close All Windows позволяет закрыть все работающие приложения с помощью всего одного клика. Она не требует установки и не использует ресурсов, так как посылает только команду "Закрыть" всем действующим приложениям.

1) Скачиваете с официального сайта программу CloseAll
2) Распаковывайте архив в удобное Вам место для использования.
3) Перемещаете файл CloseAll.exe на панель задач, если у вас 64-битная система то файл CloseAll.exe берете из папки x64.

Для удобства использования программы Вы можете назначить ей клавишу быстрого вызова и добавить исключения для программ, которые закрываться не будут:

1) Щелкаете правой кнопкой мыши на иконке в панели задач
2) Щелкаете правой кнопкой мыши на "Close All Windows" и нажимаете Свойства
3) В поле Быстрый вызов нажмите нужное сочетание клавиш, для сопоставления выбранной комбинации с программой.
4) В поле Объект добавьте -x="программа.exe"
Вы можете добавить несколько программ разделив их "|", например:

5) Нажмите Ок для сохранения настроек.

11. Открытие командной строки из конкретной папки.

1)Нажмите на клавиатуре клавишу Shift.
2) Удерживая ее нажатой, щелкните правой кнопкой мыши на папке из которой Вы желаете открыть командную строку.
3) В контекстном меню нажмите пункт Открыть окно команд (“Open Command Window Here”).

12. Закрепление конкретной папки на панели задач Windows 7.

Если Вы перетащите папку на панель задач, то она закрепится во всплывающем списке (подменю) Проводника. Чтобы закрепить отдельно папку на панели задач сделайте следующее:

1) Щелкните правой кнопкой мыши на рабочем столе и выберите Создать -> Ярлык.
2) В поле Расположение объекта введите:

(вместо C:\MyFolder введите фактический адрес прикрепляемой папки).
3) В поле Имя ярлыка введите название папки (в нашем случае это MyFolder) и нажмите Готово.
4) Щелкните правой кнопкой по созданному ярлыку и в появившемся контекстном меню выберите пункт Закрепить на панели задач.

Примечание. Каждая закрепленная папка будет открываться в отдельном процессе.

13. Настройка списка элементов, отображаемых в диалоговом окне открытия и сохранения файлов Windows.

1) Щелкните на кнопке Пуск
2) В строке поиска введите gpedit.msc и нажмите клавишу Enter.
3) Откройте узел Конфигурация пользователя ->Административные шаблоны -> Компоненты Windows -> Проводник Windows -> Общее диалоговое окно открытия файлов.
4) Дважды щелкните на политике Элементы, отображаемые в панели мест.
5) Щелкните на переключателе Включить.
6) Используйте текстовые поля Элемент 1 — Элемент 5 для ввода путей к папкам, которые требуется отображать в панели мест. Ими могут быть локальные или сетевые папки.
7) Щелкните на кнопке OK, чтобы ввести политику в действие.

14. Запуск программы с параметрами командной строки из контекстного меню Проводника.

Чтобы запустить программу с параметрами - обычно Вам необходимо: либо создать ярлык к программе и при создании указать параметры, либо Пуск -> Открыть (Win+R) ввести программу, указав путь к ней и затем дописать параметры.
Всё это проще позволит сделать программа ExecParm. Данная программа является позволяет запускать исполняемые(.exe, .com) и командные файлы(.cmd, .bat) с параметрами, используя расширение встраиваемое в контекстное меню Проводника. Чтобы его использовать Вам сделайте следующее:

1) Скачайте архив программы ExecParm с необходимой разрядностью: 32-битная, 64-битная .
2) Распакуйте архив в любую папку.
3) Откройте папку с распакованным содержимым. В ней будут три файла: ExecParm.txt, Execparm.dll, Execparm.inf)
4) Щелкните правой кнопкой мыши по файлу Execparm.inf и выберите Установить
Данное действие добавит пункт в контекстное меню для запуска приложения с параметрами.
5) Щелкните правой кнопкой по исполняемому файлу и выберите в контекстном меню пункт Execute With Parameters...
6) Введите необходимые параметры для запуска программы и нажмите ОК.

15. Отображение часто используемых команд для диалогового окна "Выполнить" в меню Пуск.

1) Откройте папку содержащую файл shell32.dll.mui

Для 32-битной версии: C:\Windows\System32\ru-RU
Для 64-битной версии(также): C:\Windows\SysWOW64\ru-RU

2) Задайте полный доступ к файлу shell32.dll.mui для этого воспользуйтесь советом Администрирование: 1. Получение полного доступа к файлу или папке.
3) Скачайте архив Patch_ExtendedRun.zip и распакуйте его в любую папку.
4) Щелкните на exe-файле правой кнопкой мыши и выберите пункт Запуск от имени администратора.
5) Нажмите кнопку Start для применения патча.

Внимание: Памятку устанавливать только на оригинальные ОС, работоспособность на различного рода сборках не гарантируется.
Новые версии Вы можете скачать по ссылке: Windows 7 Памятка

16. Быстрая вставка путей к файлу или папке в окно команд Windows 7.

Наиболее часто используемым способом вставки путей к файлу или папке в окно команд Windows (окно командной строки) является следующее:

1) Выделяете в адресной строке проводника путь к папке.
2) Щелкаете на выделенном правой кнопкой мыши и выбираете Копировать.
3) Щелкаете по заголовку окна команд правой кнопкой мыши и выбираете в контекстном меню пункты Изменить -> Вставить
А если необходимо еще добавить имя и расширение файла, то:
4) Щелкаете по файлу правой кнопкой мыши и выбираете Переименовать.
5) Выделяете имя и расширение файла, щелкаете на выделенном правой кнопкой мыши и выбираете Копировать.
6) Щелкаете по заголовку окна команд правой кнопкой мыши и выбираете в контекстном меню пункты Изменить -> Вставить

В Windows 7 существуют более быстрые способы сделать это:

Способ 1.

1) Удерживая нажатой клавишу Shift щелкните правой кнопкой мыши на папке или файле, путь к которому Вы желаете добавить в окно команд Windows (окно командной строки).
2) В контекстном меню выберите пункт Копировать как путь (“Copy as path”).
3) Щелкните внутри окна команд и выберите пункт Вставить.

Способ 2.

Перетащите файл или папку (путь к которому Вы желаете добавить) напрямую внутрь окна команд Windows.

Примечание: Окно из которого вы перетаскиваете файл или папку в окно команд, должно иметь более высокие или одинаковые права и разрешения, чем само окно команд.

17. Запуск командной строки из "Диспетчера задач" без ввода команды CMD.

1) Запустите Диспетчер задач нажав на клавиатуре комбинацию клавиш Ctrl+Shift+Esc.
2) Удерживая нажатой клавишу Ctrl выберите в главном меню пункт Файл и щелкните -> Новая задача (Выполнить...)

Примечание:

Если у Вас включен Контроль учётных записей (UAC) или Диспетчер задач запущен в ограниченной учётной записи, окно команд откроется без прав администратора.
Если у Вас отключен Контроль учётных записей (UAC) или Диспетчер задач запущен с правами администратора, окно команд откроется с правами администратора.

18. Изменение действий осуществляемых системой при использовании щелчков мыши.

Если Вы привыкли к поведению мыши в браузере, то Вы можете переключить режим используемый при щелчке мышью в системе на идентичный. Для этого выполните следующие действия:

1) Откройте Панель управления в режиме просмотра всех элементов: Пуск -> Панель управления\Все элементы панели управления
2) Запустите Параметры папок
3) На вкладке Общие установите значение переключателя в
Открывать одним щелчком, выделять указателем -> Подчеркивать подписи значков при наведении
4) Нажмите ОК.

19. Команды для распаковки *.cab, *.exe, *.msi, *.msp и *.msu файлов от Microsoft.

Приведенные в примерах команды подразумевают, что Вы запустили окно команд из папки, где находится сам файл.
Чтобы запустить окно команд из папки, где расположен исходный файл, удерживая нажатой клавишу Shift щелкните правой кнопкой мыши на папке и выберите пункт Открыть окно команд.

Microsoft Cabinet File (.cab):

Команда для запуска:

Пример:

Microsoft Hotfix Installer (.exe):

Команда для запуска:

Пример:

Windows Installer Package (.msi):

Команда для запуска:

Пример:

Microsoft Update Standalone Package (.msu):

Команда для запуска:

Пример:

Microsoft Patch File (.msp)

Скачайте программу MSI Extractor, распакуйте архив и скопируйте файл msix.exe в папку C:\Windows\System32

Команда для запуска:

Пример:

20. Быстрое открытие ещё одной копии приложения.

Если у вас уже открыто какое-либо приложение и вы хотите быстро открыть его вторую копию, то удерживая клавишу Shift просто нажмите на иконку данного приложения на Панели задач. И вместо переключения в существующее окно будет открыта новая копия этого приложения. Того же эффекта можно добиться кликнув по иконке приложения на Панели задач, средней кнопкой мыши.

21. Размещение любого окна Windows поверх других.

При работе с огромным количеством открытых окон, документов, таблиц и программ очень часто хочется, чтобы окно оставалось поверх всех открытых окон (OnTop) даже при потере фокуса. Для этого можно использовать программу DeskPins.

Программа предназначена для того, чтобы закреплять любые приложения поверх всех окон Windows. Нужно просто перетащить кнопку с иконки программы на заголовок того окна, которое нужно закрепить, и нажать кнопку мыши — теперь закрепленное окно всегда будет на самом верху. Закреплять и откреплять активные окна можно с помощью горячих клавиш, есть также возможность автоматического закрепления окон. Нажимаете Ctrl+F12 и окно становится OnTop по отношению ко всем открытым.

22. Ввод пароля в окне смены пользователей при отсутствии необходимой раскладки клавиатуры.

Если Вы задали пароль на русском языке в английской Windows или пароль на русском языке в русской Windows, то Вы можете столкнуться с ситуацией, когда невозможно ввести пароль в окне смены пользователей, по причине отсутствия необходимой раскладки клавиатуры.

В таком случае для ввода пароля Вы можете воспользоваться ASCII символами.

Для ввода буквы из другой раскладки клавиатуры Вам необходимо удерживая нажатой клавишу Alt ввести номер клавиши.
Например для ввода английской буквы t в русской раскладке клавиатуры:

1) Нажмите и удерживайте клавишу Alt
2) Введите 0 (ноль) и сразу за ним 116
3) Отпустите клавишу Alt, и вы увидите результат.

или

для ввода русской буквы т в английской раскладке клавиатуры:

1) Нажмите и удерживайте клавишу Alt
2) Введите 0 (ноль) и сразу за ним 242
3) Отпустите клавишу Alt, и вы увидите результат. Таблица ASCII символов для русской и английской клавиатуры приведена ниже.

Таблицы ASCII для кодовой страницы Windows 1251

Кириллица | Значение | Латиница | Значение
А | 192 | A | 65
Б | 193 | B | 66
В | 194 | C | 67
Г | 195 | D | 68
Д | 196 | E | 69
Е | 197 | F | 70
Ж | 198 | G | 71
З | 199 | H | 72
И | 200 | I | 73
Й | 201 | J | 74
К | 202 | K | 75
Л | 203 | L | 76
М | 204 | M | 77
Н | 205 | N | 78
О | 206 | O | 79
П | 207 | P | 80
Р | 208 | Q | 81
С | 209 | R | 82
Т | 210 | S | 83
У | 211 | T | 84
Ф | 212 | U | 85
Х | 213 | V | 86
Ц | 214 | W | 87
Ч | 215 | X | 88
Ш | 216 | Y | 89
Щ | 217 | Z | 90
Ъ | 218 | a | 97
Ы | 219 | b | 98
Ь | 220 | c | 99
Э | 221 | d | 100
Ю | 222 | e | 101
Я | 223 | f | 102
а | 224 | g | 103
б | 225 | h | 104
в | 226 | i | 105
г | 227 | j | 106
д | 228 | k | 107
е | 229 | l | 108
ж | 230 | m | 109
з | 231 | n | 110
и | 232 | o | 111
й | 233 | p | 112
к | 234 | q | 113
л | 235 | r | 114
м | 236 | s | 115
н | 237 | t | 116
о | 238 | u | 117
п | 239 | v | 118
р | 240 | w | 119
с | 241 | x | 120
т | 242 | y | 121
у | 243 | z | 122
ф | 244 |  |
х | 245 |  |
ц | 246 |  |
ч | 247 |  |
ш | 248 |  |
щ | 249 |  |
ъ | 250 |  |
ы | 251 |  |
ь | 252 |  |
э | 253 |  |
ю | 254 |  |
я | 255 |  |

23. Установка положения курсора в диалоговом окне на кнопке, выбираемой по умолчанию.

Для многих пользователей весьма удобным считается, чтобы курсор мыши при открытии диалогового окна занимал позицию на кнопке Открыть, Сохранить или аналогичной по умолчанию. Данное действие позволяет Вам сэкономить время необходимое для наведения курсора.

1) Откройте Панель управления -> Мышь
2) Перейдите на вкладку Параметры указателя
3) В графе "Исходное положение в диалоговом окне" установите флажок "На кнопке, выбираемой по умолчанию"
4) Нажмите ОК.

24. Уточнение даты и времени загрузки системы.

Вариант 1.

Если Вам необходимо узнать дату и время установки Windows на компьютер или дату и время когда компьютер был запущен, то сделайте следующее:

1) Запустите командную строку с правами администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl+Shift+Enter.
2) Введите команду systeminfo

В графе с одноименным названием Вы найдете необходимое Вам значение.

Вариант 2.

1) Скачайте с сайта Microsoft программу uptime.exe (http://support.microsoft.com/kb/232243)
2) Скопируйте ее в папку C:\Windows\System32
3) Запустите командную строку с правами администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl+Shift+Enter.
4) Введите команду uptime.exe.

Вариант 3.

Скачайте и установите специальный гаджет.

systemuptime_sevengadgets.ru.zip


1. Изменение размера иконки на рабочем столе.

1) Щелкните правой кнопкой мыши на рабочем столе.
2) Откройте пункт Вид и выберите размер: Крупные значки; Обычные значки; Мелкие значки;
или удерживая нажатой клавишу Сtrl прокрутите колесо мыши.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


2. Управление заготовками положений размеров окон.

Чтобы легко управлять заготовками положений размеров окон (любых) просто кликните на активное окно и жмите:(win+влево,вниз,вправо,вверх).

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


3. Где скачать и как установить дополнительные темы для Windows 7?

Скачать дополнительные темы для Вашей Windows 7 Вы можете на официальной странице тем от Microsoft: Персонализация компьютера
После скачивания понравившейся Вам темы, нажмите на скачавшийся themepack-файл и Windows автоматически его установит.
Также дополнительные темы и обои для Windows находятся в скрытой папке - C:\Windows\Globalization\MCT.

Вы можете разблокировать 5 дополнительных тем, поочередно запустив их.
Для этого, запустите диалоговое окно "Выполнить" (Win + R) и наберите в нем:
C:\Windows\Globalization\MCT\MCT-AU\Theme\AU.theme
C:\Windows\Globalization\MCT\MCT-CA\Theme\CA.theme
C:\Windows\Globalization\MCT\MCT-GB\Theme\GB.theme
C:\Windows\Globalization\MCT\MCT-US\Theme\US.theme
C:\Windows\Globalization\MCT\MCT-ZA\Theme\ZA.theme

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


4. Изменение ширины меню Пуск.

Открываете с помощью Restorator или PE Explorer файл C:\Windows\Resources\Themes\Aero\ru-RU\aero.msstyles.mui и изменяете значения в строковой таблице в строках с 113 по 121 включительно, делаете их такими же, как в C:\Windows\Resources\Themes\Aero\en-US\aero.msstyles.mui

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


5. Добавление эффекта прозрачности окнам в Windows.

Вариант 1.

Включить прозрачный эффект можно при помощи небольшого скрипта: HideBlur Tool for Windows 7

Инструкция:

1. Распакуйте и запустите файл "Patch Blur x86.bat". Если у вас x64 битная версия, запустите файл "Patch Blur x64.bat".
2. Это займет немного времени и вы увидите окно без эффекта матовости.
3. Если захотите вернуть эффект матовости, запустите файл "Enable Blur.bat". А если снова захотите убрать матовость запустите файл "Disable Blur.bat".
4. Если вы решите восстановить системные файлы запустите файл "Unpatch Blur.bat".
Изменения становятся видимыми после перезагрузки.

Сайт автора скрипта

Вариант 2.

1) Скачайте архив TrueTransparency.zip
2) Распакуйте его и запустите файл TrueTransparency.exe
3) На панели задач появится значок программы. Щелкните на нем правой кнопкой мыши.
4) Выберите нужный язык в всплывающем меню Language(Языки), в меню Skins (Внешний вид) выберите одну из предложенных тем прозрачности.
Также Вы можете воспользоваться решением предложенным в совете 16. Добавление функций окна Персонализация в Windows 7 Starter и Windows 7 Home Basic. из раздела Интерфейс - Внешний вид.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


6. Принудительное включение эффекта Aero Glass.

Вариант 1.

1) Нажмите Win+R и введите regedit
2) Установите следующие значения в реестре:

Готовый reg-файл enableaero.reg
3) Перезапустите "Диспетчер сеансов диспетчера окон рабочего стола" из command prompt, запущенного с правами администратора:

Вариант 2.

1) Скачайте утилиту UxStyle
2) Распакуйте скачанный архив и в зависимости от разрядности установите необходимую Вам версию.
3) Смените оформление системы на классическую тему:
В Windows 7 Starter и Windows 7 Home Basic: Меню "Пуск" -> Панель управления -> Экран -> Изменить цветовую схему
В остальных версиях Windows 7: Правой кнопкой мыши на Рабочем столе -> Персонализация
4) Откройте папку C:\windows\Resources\Themes\Aero\
5) Задайте полный доступ к файлу aero.msstyle (можете воспользоваться советом: Администрирование: 1. Получение полного доступа к файлу или папке.)
6) Переименуйте aero.msstyle в aero.bak
7) Скачайте модифицированный файл aero.msstyle и поместите его вместо переименованного.
8) Смените оформление на стандартную тему Windows 7.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


7. Улучшение качества передачи цветов монитором.

Windows 7 предлагает новый мастер калибровки экрана (Display Colour Calibration Wizard), который поможет Вам должным образом установить настройки цвета, яркости и контраста, а ClearType tuner сделает текст резким и контрастным. Для вызова средства калибровки цветов монитора сделайте следующее:

1) Нажмите кнопку Пуск
2) В строке поиска введите dccw.exe и нажмите клавишу Enter.

Вы можете запустить калибровку цветов и другим способом:

1) Откройте Пуск -> Панель управления
2) Перейдите по ссылкам Оформление и персонализация -> Экран
3) В левой области выберите пункт Калибровка цветов.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


8. Включение Flip3D — отображение окон под углом.

1. Щелкните правой кнопкой мыши по рабочему столу, выберите Создать и затем Ярлык.
2. В поле "Укажите расположение объекта" введите следующее: RunDll32 DwmApi #105 и нажмите Далее.
3. Наберите имя вашего будущего (например, Flip3D) ярлыка и нажмите Готово.

Для переключения между окнами в режиме Flip3D, Вы можете использовать комбинацию клавиш Win+Tab.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


9. Расширение функциональности часов в трее или изменение их вида.

Скачайте программу Stoic Joker's T-Clock x32/x64. Данная программа позволяет вам расширить функциональность часов в трее или изменить внешний вид часов в трее. Вы сможете добавить секунды к часам, изменить внешний вид часов, даты или добавить созданные вами значки для запуска конкретных приложений в трей.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


10. Добавление дополнительных операций к окнам.

К сожалению, многие разработчики не столь тщательно занимаются интерфейсом своих программ. Часто бывает, что у довольно хорошей программами неудачный интерфейс. Отсутствуют какие-либо нужные вам кнопки. А бывает вам надо сравнить два окна или скопировать из одного в другое, а для этого необходимо поместить окно поверх других. Вот тут вам и поможет данная программа.

Добавляет дополнительные функции для окон:
  • свернуть при запуске/деактивации, развернуть при запуске, закрыть при запуске, изменить положение/размер (например: в пикселях) при запуске
  • зафиксировать положение/размер (например: в пикселях), изменить приоритет выполнения при запуске/деактивации;
  • свернуть в область уведомлений, поверх других окон, позади остальных, прозрачность, через дополнительные кнопки заголовка окна
  • и многие другие.
Скачать программу

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


11. Добавление командной строке эффекта прозрачности - Aero Glass.

Для добавления командной строке эффекта прозрачности (Aero Glass) сделайте следующее:

1) Скачайте архив: Glass_CMD.zip
2) Распакуйте его и запустите исполняемый файл минискрипта Glass CMD.exe.
3) Запустите командную строку(Win+R -> CMD ->Ok) и увидите эффект прозрачности (Aero Glass).
Для использования данного эффекта скрипт Glass CMD.exe должен быть запущен. При закрытии Glass CMD.exe эффект прозрачности пропадет.
При желании Вы можете добавить данный скрипт-программу в папку Автозагрузка в меню Пуск.
Если Вы не хотите, чтобы в области уведомлений (трее) отображался значок скрипта, то в файле Settings.ini, который идет в архиве в комплекте с исполняемым файлом скрипта, установите значение параметра HideTrayIcon равным 1.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


12. Определение цветового кода любой точки экрана на мониторе.

Для того чтобы узнать цветовой код любой точки экрана на Вашем мониторе скачайте и установите небольшую, но функциональную программу ColorPic.

Данная программа абсолютно бесплатна и Вы можете скачать её с официального сайта: http://www.iconico.com/colorpic/index.aspx

Мощные средства для регулировки цвета позволяют Вам с легкостью менять индивидуальные цвета. С помощью четырех графических миксеров Вы сможете регулировать RGB, оттенки, насыщенность и код цвета. У Вас будет возможность просматривать CMYK печатные коды цвета, а для идеальной точности использовать увеличитель экрана. Вы сможете сохранять множество цветовых палитр для их использования в любом приложении.

Содержащийся в программе раздел "Mixer" предоставляет Вам четыре мощных графических способа для анализа и изменения выбранного цвета. Цвета могут быть выбраны из любых шестиугольных форм, измененных миксером или настроенных шестью индивидуальными слайдерами для оттенков, насыщенности, кода и красных, зеленых и голубых цветовых компонентов. ColorPic также делает отчеты для регулировки голубого, пурпурного, желтого и черного цветовых кодов.

Кроме того, ColorPic также предлагает возможность увеличения, предоставляя Вам супер детальную картинку при выборе цвета. Программа имеет простой в использовании слайдер для увеличения, который позволяет Вам выбирать или разовую пробу или 3x3 или 5x5 средний цвет из любого места на Вашем экране.

Будучи неоценимым средством для любого графического дизайнера или веб-разработчика и будучи постоянно самым популярным бесплатным цветоподборщиком в сети, самая последняя версия ColorPic предлагает мощные средства для выбора цвета, которые до сих пор доступны только в дорогих приложениях.

Использовать программу очень просто:

1) Запускаете программу
2) Наводите курсор в то место, цвет которого желаете узнать.
3) Нажимаете Ctrl+G и в первой ячейке сохраняется информация о цвете.
4) Затем выделяете следующую ячейку и проделываете указанное выше для определения другого цвета.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


13. Создание темы оформления с использованием RSS-обоев.

В интернете существует много программ позволяющих менять картинки на рабочем столе, автоматически скачивая их из интернета. Но Вам необязательно скачивать дополнительную программу, так как возможность обновления фона рабочего стола используя интернет имеется в самой Windows. Для этого Вам необходимо создать новую тему для Windows со ссылкой на RSS ленту, в качестве новостей транслирующую картинки.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).

2) Замените {themename} на название темы (Например: RSS Wallpapers), а вместо {rssfeedurl} впишите адрес ленты, транслирующей картинки.

Например:

http://feeds.feedburner.com/bingimages
http://api.flickr.com/services/feeds/photos_public.gne
http://feeds.nationalgeographic.com/ng/News/News_Main
http://mlewallpapers.com/4x3_rss.php

3) Нажмите CTRL+S и сохраните файл с любым именем и расширением .theme. Например: RSS_Wallpappers.theme
4) Щелкните два раза по получившемуся файлу.
5) В окне Подписаться на RSS канал?(Subscribe to RSS Feed?) выберите пункт Загружать вложения (Download Attachments).

Многие RSS ленты рекомендуют (хотя и необязательно) в Панель управления\Оформление и персонализация\Персонализация\Фоновый рисунок рабочего стола установить положение изображения По центру.

Готовые 4 схемы Вы можете скачать по ссылке: rssthemes.zip

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


14. Изменение фонового рисунка рабочего стола в Windows 7 Starter.

Вариант 1. Вручную используя реестр Windows.

1) Запустите Редактор реестра. Откройте меню Пуск, введите в строке поиска regedit и нажмите Enter (или Win+R -> regedit -> OK).
2) Откройте ветку HKEY_CURRENT_USER\Control Panel\Desktop
3) Щелкните правой кнопкой мыши на папке Desktop в древовидном списке слева, и нажмите пункт "Разрешения..."

4.1) Если Вы первый раз изменяете фоновое изображение:

4.1.1) Нажмите кнопку Дополнительно
4.1.2) Перейдите на вкладку Владелец, выделите свое имя в окне Изменить владельца на: и нажмите кнопку Применить
4.1.3) Перейдите на вкладку Разрешения и уберите флажок Добавить разрешения, наследуемые от родительских объектов. В случае запроса системой дальнейшего действия нажимаете кнопку Удалить.
4.1.4) Нажмите поочередно кнопки Добавить... -> Дополнительно... -> Поиск
4.1.5) В результатах поиска выберите Все и нажмите кнопку "OK", и еще раз "ОК".
4.1.6) В окне Элемент разрешения для "Desktop" напротив значения Полный доступ установите флажок в столбце Разрешить и нажмите несколько раз кнопки ОК.

4.2) Если Вы во второй раз изменяете фоновое изображение или если у Вас в "Группы и Пользователи" уже есть группа "Все" и Вы являетесь владельцем объекта:

4.2.1) Выделите группу Все, нажав на нее.
4.2.2) В части окна Разрешения для группы "Все" установите флажок Полный доступ в столбике Разрешить и нажимаете ОК.

5) Найдите строковый параметр Wallpaper и дважды щелкните на нем.
6) Введите путь к изображению, которое Вы хотите использовать как обои рабочего стола и нажмите ОК.
7) По умолчанию, положение изображения устанавливается По центру, если Вам необходимо другое положение, то дополнительно измените:

Параметр TileWallpaper на значение 1, чтобы Замостить изображение.
Параметр WallpaperStyle на значение 2, чтобы Растянуть изображение.

8) Щелкните правой кнопкой мыши на папке Desktop в древовидном списке слева, и нажмите пункт "Разрешения..."
9) Выделите группу Все, нажав на нее.
10) Уберите флажок в столбце Разрешить напротив значения Полный доступ и нажмите кнопку ОК.
Если Вы не уберете данный флажок, то система установит стандартные обои рабочего стола.
11) Перезайдите в систему или перезагрузите компьютер.

Вариант 2. Автоматически используя специальную программу.

1) Скачайте архив программы Starter Background Changer.zip
2) Разархивируйте файл в любую папку и установите нужную Вам языковую версию программы.
3) Нажмите правой кнопкой мыши на рабочем столе и выберите в контекстном меню пункт Персонализация (Personalize)
4) Нажмите кнопку Обзор... (Browse...).
5) Выберите необходимое Вам изображение и нажмите кнопку Открыть (Open).
6) Выберите положение рисунка и нажмите Применить (Apply), чтобы установить рисунок не выходя из программы или ОК, чтобы установить рисунок и выйти их программы.
7) Чтобы установить стандартное изображение выберите в ниспадающем меню Фоновый рисунок Windows по умолчанию и нажмите кнопку ОК.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


15. Изменение размера окон предпросмотра на панели задач.

Если Вам необходимо изменить размер окон предпросмотра, расстояние между ними, размер бордюра и время задержки, то в этом Вам поможет программа Windows 7 Taskbar Thumbnail Customizer.

1) Скачайте программу Windows 7 Taskbar Thumbnail Customizer

2) Настройте параметры программы в соответствие с Вашими запросами.

Maximum Size - максимальный размер окна предпросмотра
Minimum Size - минимальный размер окна предпросмотра

X Spacing - расстояние между окнами предпросмотра по-горизонтали
Y Spacing - расстояние между окнами предпросмотра по-вертикали

Top Margin - размер верхнего бордюра
Bottom Margin - размер нижнего бордюра
Left Margin - размер левого бордюра
Right Margin - размер правого бордюра

Delay Time - время задержки до появления окна предпросмотра

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


16. Добавление функций окна Персонализация в Windows 7 Starter и Windows 7 Home Basic.

1) Скачайте утилиту UxStyle
2) Распакуйте скачанный архив и в зависимости от разрядности установите необходимую Вам версию.
3) Смените оформление системы на классическую тему:
В Windows 7 Starter и Windows 7 Home Basic: Меню "Пуск" -> Панель управления -> Экран -> Изменить цветовую схему
В остальных версиях Windows 7: Правой кнопкой мыши на Рабочем столе -> Персонализация
4) Откройте папку C:\windows\Resources\Themes\Aero\
5) Задайте полный доступ к файлу aero.msstyle (можете воспользоваться советом: Администрирование: 1. Получение полного доступа к файлу или папке.)
6) Переименуйте aero.msstyle в aero.bak
7) Скачайте пропатченный файл aero.msstyle и поместите его вместо переименованного.
8) Смените оформление на стандартную тему Windows 7.
9) Скачайте и установите программу Personalization Panel (Для интеграции в меню рабочего стола выберите Обычная установка)
10) В Windows 7 Home Basic нажмите правой кнопкой мыши на рабочем столе, выберите пункт Персонализация и нажмите на ссылку Цвет окна.
11) В открывшемся окне нажмите на ссылку Показать или скрыть настройку цветов. и установите переключатель Windows 7 [Patched]
12) Ползунком измените интенсивность цвета (степень прозрачности) и нажмите кнопку Сохранить изменения.

В Windows 7 Starter панель позволяет менять обои только при запуске от имени администратора. Если у пользователя этих прав нет, или он нажал "Нет" в ответ на запрос UAC, функция смены обоев недоступна - программа функционирует в ОГРАНИЧЕННОМ режиме. Кроме того, если у пользователя есть права администратора, он меняет обои на нестандартные, а затем запускает программу в ОГРАНИЧЕННОМ режиме, смена экранной заставки может не работать, так как смена обоев меняет права на системный реестр, запрещая пользователю ниже, чем администратор, запись в него. Для корректной смены заставки в ОГРАНИЧЕННОМ режиме необходимо, чтобы стояли стандартные обои. В обычном режиме работы панели (от имени администратора) в Windows 7 Starter таких ограничений нет.

1. Windows 7 [Patched]

Используйте если у вас установлена пропатченная тема(Вы установили UxStyle и заменили aero.msstyle). Окна Windows 7 Home Basic будут использовать оформление Aero Glass и эффект прозрачности.

2. Windows 7 стандратный

Используйте если у вас установлена непропатченная тема. Не используйте с патченными темами - пропадет эффект прозрачности и окна будут заливаться черным цветом.

Также Вы можете cкачать Пакет Personalization Panel для Windows 7 Starter и Home Basic с темами и автопатчем.
Данный пакет автоматически выполнит следующие действия:

  • Автоматически установит патченные версии файлов для поддержки сторонних тем.
  • Автоматически установит тему Windows 7 c Aero для систем Windows 7 Домашняя базовая. Это обычная системная тема, только в ней разлочена прозрачность.
  • Установит набор из 12 базовых тем для систем Windows 7 Домашняя базовая и Windows 7 Начальная.
  • В системах Windows 7 Домашняя базовая установит 10 тем Aero.
Внимание! Перед установкой пакета надо удалить программу UxStyle. Если вы этого не сделаете, пакет не установится.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


17. Замена фона папки в проводнике.

Проще всего для замены фона в папке использовать следующие программы:

Windows 7 Folder Background Changer

1) Запустите программу Windows 7 Folder Background Changer
2) Нажмите кнопку Browse и выберите фоновое изображение
3) Нажмите Change Background Image, чтобы установить фоновое изображение или кнопку Remove Background Image, чтобы убрать фоновое изображение.
4) Для изменения фонового изображения во вложенных папках, установите флажок Apply To Sub Folders.

AveFolderBG: для 32-бит; для 64-бит - данная программа добавляет дополнительную вкладку в свойства каждой папки.

1) Установите программу используя файл install.bat
2) Перезапустите Windows или перезайдите в систему.
3) Щелкните правой кнопкой мыши и выберите Свойства
4) Перейдите на вкладку Folder Background
5) Нажмите кнопку Set Image, выбираете изображение и нажимаете Открыть. Для удаления изображения используйте кнопку Remove Image.
6) Для изменения фонового изображения во вложенных папках, установите флажок Apply to subfolders also.
7) Нажмите кнопку Применить или ОК.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


18. Сохранение созданной Вами схемы указателей мыши в файл, для дальнейшего использования.

Созданные Вами схемы для указателей мыши прописываются в реестре.
Если Вы желаете сохранить созданную Вами тему для дальнейшего применения после переустановки, то сделайте следующее:

1) Откройте Пуск -> Панель управления -> Мышь
2) Перейдите на вкладку Указатели
3) В окне Настройка измените необходимые Вам курсоры.
4) Нажмите кнопку Сохранить как, введите название сохраняемой темы и нажмите ОК.
5) В окне Свойства:Мышь снова нажмите ОК.
6) Запустите редактор реестра (Win+R -> regedit -> ОК)
7) Откройте раздел HKEY_CURRENT_USER\Control Panel\Cursors\Schemes
8) Экспортируйте данный раздел в reg-файл.
8.1) В главном меню выберите Файл -> экспорт
9) Задайте имя файла и нажмите кнопку Сохранить.

Система создаст reg-файл, который Вы сможете использовать в дальнейшем. Например, после переустановки Windows.
Если при создании схемы для указателей Вы использовали файлы отсутствующие в системе, то после переустановки Windows, перед применением reg-файла скопируйте их в те же месторасположения.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


19. Добавление отображения эскизов и детальной информации для файлов .mkv в проводнике Windows.

Скачайте и установите DivX Plus Tech Preview.

Данная программа добавляет поддержку MKV-файлов в проводник Windows, так что Вы сможете просматривать их эскизы в Windows Explorer. Также Вам станут доступны детальные сведения о файле.

Положительной особенностью является тот факт, что DivX Plus Tech Preview работает с любыми пакетами кодеков (K-Lite или Shark).

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Внешний вид.


1. Открытие диспетчера задач, одной комбинацией клавиш, а не ctrl+alt+del и клик по пункту.

Вариант 1

Нажмите комбинацию клавиш Ctrl+Shift+Esc.

Вариант 2

Щелкните правой кнопкой на панели задач и выберите пункт Запустить диспетчер задач (Start Task Manager).

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


2. Использование средней кнопки мыши при работе с панелью задач.

Если щелкнуть средней кнопкой мышки на приложении в панели задач, откроется новое окно приложения. А если же средней кнопкой щелкнуть на окошке превью, которое всплывает над иконой программы, то это закроет данную программу или окно.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


3. Перезапуск Проводника или рабочего стола.

Вариант 1. Только клавиатура.

1) Нажмите комбинацию клавиш Ctrl+Esc
2) Нажмите стрелку вправо (→)
3) Нажмите комбинацию клавиш Ctrl+Shift+F10 или Ctrl+Shift+Menu
4) Нажатием стрелочки вниз перейдите на пункт Выход из проводника (Exit Explorer) и нажмите Enter.
5) Нажмите последовательно: Alt, затем стрелку вниз (↓) и нажмите Enter.
6) Введите команду explorer и нажмите клавишу Enter.

Вариант 2. Частичное использование Диспетчера задач.

1) Откройте меню Пуск
2) Удерживая нажатым комбинацию клавиш Ctrl+Shift, щелкните правой кнопкой мыши кнопку Завершение работы (Shut Down).
3) В контекстном меню выберите пункт Выход из проводника (Exit Explorer).
4) Нажмите комбинацию клавиш Ctrl+Shift+Esc
5) Нажмите Файл -> Новая задача (Выполнить...) или в английской версии File -> New Task (Run...)
6) Введите команду explorer и нажмите кнопку ОК

Вариант 3. Полное использование Диспетчера задач.

1) Откройте Диспетчер задач (Task Manager)
1.1) Щелкните правой кнопкой мыши пустую область на панели задач и выберите команду Запустить диспетчер задач или нажмите сочетание клавиш Ctrl+Shift+Esc
2) Перейдите на вкладку Процессы (Processes)
3) Щелкните правой кнопкой мыши на процесс explorer.exe и выберите пункт Завершить процесс (End Process). Если у Вас несколько процессов с таким названием, то повторите данное действие для каждого процесса explorer.exe.
4) Нажмите Файл -> Новая задача (Выполнить...) или в английской версии File -> New Task (Run...)
5) Введите команду explorer и нажмите кнопку ОК

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


4. Запуск команд Windows Shell, используя названия и {GUID} объектов.

Microsoft Windows Shell - интерпретатор команд операционной системы (ОС), обеспечивающий интерфейс для взаимодействия пользователя с функциями системы. Позволяет получить доступ к диалоговым окнам, к файловой системе, запускать программы и изменять системные настройки.
Для быстрого перехода к компонентам Windows используется команда shell.
GUID (Globally Unique Identifier) — статистически уникальный 128-битный идентификатор. Использование GUID гарантирует, что две версии одного компонента могут иметь одно и то же имя, но быть отличимыми по GUID. Microsoft применяет GUID в качестве идентификаторов для большого количества своих объектов. Зная GUID Вы сможете открыть многие компоненты Windows: элементы Панели управления, системные папки, различные программы и настройки.

Для запуска любого из объектов Windows, используя {GUID}, применяется команда:

где {GUID} - идентификатор {GUID} нужного Вам объекта. Например, для запуска Панели управления наберите команду:

Вы можете поискать нужные Вам {GUID} в разделе реестра HKEY_CLASSES_ROOT\CLSID или воспользоваться таблицей №1.

Таблица №1.

Русское название элемента | Английское название элемента | Команда
Flip 3D (Win+Tab) | Flip 3D (Win+Tab) | Shell:::{3080F90E-D7AD-11D9-BD98-0000947B0257}
Fusion Cache | Fusion Cache | Shell:::{1D2680C9-0E2A-469d-B787-065558BC7D43}
Internet Explorer | Internet Explorer | Shell:::{871C5380-42A0-1069-A2EA-08002B30309D}
Microsoft Outlook | Microsoft Outlook | Shell:::{2559a1f5-21d7-11d4-bdaf-00c04f60b9f0}
Windows CardSpace | Windows CardSpace | Shell:::{78CB147A-98EA-4AA6-B0DF-C8681F69341C}
Windows SideShow | Windows SideShow | Shell:::{E95A4861-D57A-4be1-AD0F-35267E261739}
Автозапуск | AutoPlay | Shell:::{9C60DE1E-E5FC-40f4-A487-460851A8D915}
Автономные файлы | Offline Files | Shell:::{D24F75AA-4F2B-4D07-A3C4-469B3D9030C4}
Администрирование | Administrative Tools | Shell:::{D20EA4E1-3957-11d2-A40B-0C5020524153}
Архивация и восстановление | Backup and Restore | Shell:::{B98A2BEA-7D42-4558-8BD1-832F41BAC6FD}
Библиотеки | Libraries | Shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Биометрические устройства | Biometric Devices | Shell:::{0142e4d0-fb7a-11dc-ba4a-000ffe7ab428}
Брандмауэр Windows | Windows Firewall | Shell:::{4026492F-2F69-46B8-B9BF-5654FC07E423}
Восстановление | Recovery | Shell:::{9FE63AFD-59CF-4419-9775-ABCC3849F861}
Восстановление системы | System Restore | Shell:::{3f6bc534-dfa1-4ab4-ae54-ef25a74e0107}
Все задачи | All Tasks | Shell:::{ED7BA470-8E54-465E-825C-99712043E01C}
Все элементы панели управления | All Control Panel Items | Shell:::{21EC2020-3AEA-1069-A2DD-08002B30309D}
Выполнить | Run | Shell:::{2559a1f3-21d7-11d4-bdaf-00c04f60b9f0}
Гаджеты рабочего стола | Desktop Gadgets | Shell:::{37efd44d-ef8d-41b1-940d-96973a50e9e0}
Дата и Время | Date and Time | Shell:::{E2E7934B-DCE5-43C4-9576-7FE4F75E7480}
Датчик расположения и другие датчики | Location and Other Sensors | Shell:::{E9950154-C418-419e-A90A-20C5287AE24B}
Диспетчер устройств | Device Manager | Shell:::{74246bfc-4c96-11d0-abef-0020af6b0b7a}
Диспетчер учетных данных | Credential Manager | Shell:::{1206F5F1-0569-412C-8FEC-3204630DFB70}
Домашняя группа | HomeGroup | Shell:::{67CA7650-96E6-4FDD-BB43-A8E774F73A57}
Домашняя группа - папка | HomeGroup folder | Shell:::{6785BFAC-9D2D-4be5-B7E2-59937E8FB80A}
Защитник Windows | Windows Defender | Shell:::{D8559EB9-20C0-410E-BEDA-7ED416AECC2A}
Звук | Sound | Shell:::{F2DDFC82-8F12-4CDD-B7DC-D4FE1425AA4D}
Значки области уведомлений | Notification Area Icons | Shell:::{05d7b0f4-2121-4eff-bf6b-ed3f69b894d9}
Игровые устройства | Game Controllers | Shell:::{259EF4B1-E6C9-4176-B574-481532C9BCE8}
Игры | Games | Shell:::{ED228FDF-9EA8-4870-83b1-96b02CFE0D52}
Избранное | Favorites | Shell:::{323CA680-C24D-4099-B94D-446DD2D7249E}
Инфракрасная связь | Infrared | Shell:::{A0275511-0E86-4ECA-97C2-ECD8F1221D08}
Карта сети | Network Map | Shell:::{E7DE9B1A-7533-4556-9484-B26FB486475E}
Компоненты Windows | Windows Features | Shell:::{67718415-c450-4f3c-bf8a-b487642dc39b}
Компьютер | Computer | Shell:::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина | Recycle Bin | Shell:::{645FF040-5081-101B-9F08-00AA002F954E}
Мои Документы | My Documents | Shell:::{450D8FBA-AD25-11D0-98A8-0800361B1103}
Настройка доступа программ и умолчаний | Set Program access and Windows defaults | Shell:::{2559a1f7-21d7-11d4-bdaf-00c04f60b9f0}
Недавние места | Recent Places | Shell:::{22877a6d-37a1-461a-91b0-dbda5aaebc99}
Общие | Public | Shell:::{4336a54d-038b-4685-ab02-99bb52d3fb8b}
Панель управления (заданного Вами вида) | Control Panel | Shell:::{5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}
Панель управления (Категория) | Control Panel (Category) | Shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}
Параметры индексирования | Indexing Options | Shell:::{87D66A43-7B11-4A28-9811-C86EE395ACF7}
Параметры папок | Folder Options | Shell:::{6DFD7C5C-2451-11d3-A299-00C04F8EF6AF}
Параметры планшетного компьютера | Tablet PC Settings | Shell:::{80F3F1D5-FECA-45F3-BC32-752C152E456E}
Параметры шрифта | Font settings | Shell:::{93412589-74D4-4E4E-AD0E-E0CB621440FD}
Переносные устройства | Portable Devices | Shell:::{35786D3C-B075-49b9-88DD-029876E11C01}
Перо и сенсорные устройства | Pen and Touch | Shell:::{F82DF8F7-8B9F-442E-A48C-818EA735FF9B}
Персонализация | Personalization | Shell:::{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection | Shell:::{241D7C96-F8BF-4F85-B01F-E2B043341A4B}
Поиск Windows | Search | Shell:::{2559a1f0-21d7-11d4-bdaf-00c04f60b9f0}
Получение программ | Get Programs | Shell:::{15eae92e-f17a-4431-9f28-805e482dafd4}
Принтеры | Printers | Shell:::{2227A280-3AEA-1069-A2DE-08002B30309D}
Приступая к работе | Getting Started | Shell:::{CB1B7F8C-C50A-4176-B604-9E24DEE8D4D1}
Программы и компоненты | Programms and Features | Shell:::{7b81be6a-ce2b-4676-a29e-eb907a5126c5}
Программы по умолчанию | Default Programs | Shell:::{17cd9488-1228-4b2f-88ce-4298e93e0966}
Рабочий стол | Desktop | Shell:::{3080F90D-D7AD-11D9-BD98-0000947B0257}
Распознавание речи | Speech Recognition | Shell:::{58E3C745-D971-4081-9034-86E34B30836A}
Расположение по умолчанию | Default Location | Shell:::{00C6D95F-329C-409a-81D7-C46C66EA7F33}
Родительский контроль | Parental Controls | Shell:::{96AE8D84-A250-4520-95A5-A47A7E3C548B}
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | Shell:::{0DF44EAA-FF21-4412-828E-260A8728E7F1}
Свойства речи | Text to Speech | Shell:::{D17D1D6D-CC3F-4815-8FE3-607E7D5D10B3}
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | Shell:::{A304259D-52B8-4526-8B1A-A1D6CECC8243}
Свойства: Интернет | Internet Properties | Shell:::{A3DD4F92-658A-410F-84FD-6FBBBEF2FFFE}
Свойства: Клавиатура | Keyboard Properties | Shell:::{725BE8F7-668E-4C7B-8F90-46BDB0936430}
Свойства: Мышь | Mouse Properties | Shell:::{6C8EEC18-8D75-41B2-A177-8831D59D2D50}
Сетевые подключения | Network Connections | Shell:::{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сетевые подключения в Области уведомления | Network Connections in Notification area | Shell:::{38A98528-6CBF-4CA9-8DC0-B1E1D10F7B1B}
Сеть | Network | Shell:::{208D2C60-3AEA-1069-A2D7-08002B30309D}
Система | System | Shell:::{BB06C0E4-D293-4f75-8A90-CB05B6477EEE}
Сканеры и камеры | Scanners and Cameras | Shell:::{00f2886f-cd64-4fc9-8ec5-30ef6cdbe8c3}
Соседние пользователи | People Near Me | Shell:::{5224F545-A443-4859-BA23-7B5A95BDC8EF}
Справка и Поддержка | Windows Help and Support | Shell:::{2559a1f1-21d7-11d4-bdaf-00c04f60b9f0}
Счетчики и средства производительности | Performance Information and Tools | Shell:::{78F3955E-3B90-4184-BD14-5397C15F1EFC}
Телефон и модем | Phone and Modem | Shell:::{40419485-C444-4567-851A-2DD7BFA1684D}
Управление беспроводными сетями | Manage Wireless networks | Shell:::{1FA9085F-25A2-489B-85D4-86326EEDCD87}
Управление цветом | Color Management | Shell:::{B2C761C6-29BC-4f19-9251-E6195265BAF1}
Установленные обновления | Installed Updates | Shell:::{d450a8a1-9568-45c7-9c0e-b4f9fb4537bd}
Устранение неполадок | Troubleshooting | Shell:::{C58C4893-3BE0-4B45-ABB5-A63E4B8C8651}
Устройства Bluetooth | Bluetooth Devices | Shell:::{28803F59-3A75-4058-995F-4EE5503B023C}
Устройства и принтеры | Devices and Printers | Shell:::{A8A91A66-3A7D-4424-8D24-04E180695C7A}
Учетные записи пользователей | User Accounts | Shell:::{60632754-c523-4b62-b45c-4172da012619}
Центр мобильности Windows | Windows Mobility Center | Shell:::{5ea4f148-308c-46d7-98a9-49041b1dd468}
Центр обновления Windows | Windows Update | Shell:::{36eef7db-88ad-4e81-ad49-0e313f0c35f8}
Центр поддержки | Action Center | Shell:::{BB64F8A7-BEE7-4E1A-AB8D-7D8273F7FDB6}
Центр синхронизации | Sync Center | Shell:::{9C73F5E5-7AE7-4E32-A8E8-8D23B85255BF}
Центр специальных возможностей | Ease of Access Center | Shell:::{D555645E-D4F8-4c29-A827-D93C859C4F2A}
Центр управления сетями и общим доступом | Network and Sharing Center | Shell:::{8E908FC9-BECC-40f6-915B-F4CA0E70D03D}
Шифрование диска BitLocker | BitLocker Drive Encryption | Shell:::{D9EF8727-CAC2-4e60-809E-86F80A666C91}
Экран (размер текста) | Display (size of text) | Shell:::{C555438B-3C23-4769-A71F-B6D3D9B6053A}
Электропитание | Power Options | Shell:::{025A5937-A6BE-4686-A844-36FE4BEC8B6D}
Язык и региональные стандарты | Region and Language | Shell:::{62D8ED13-C9D0-4CE8-A914-47DD628FB1B0}

Для некоторых системных папок, Вы можете создать их копии, в любом, необходимом для Вас месте. Такие папки не будут занимать место на диске, а будут служить символическими ссылками на оригинальные. Для создания такой папки-ссылки:

1) Создайте в любом нужном Вам месте новую папку (Щелчок ПКМ -> Создать -> Папку)
2) Переименуйте её следующим образом:

Все задачи - All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}
Администрирование - Administrative Tools.{D20EA4E1-3957-11d2-A40B-0C5020524153}
Библиотеки - Libraries.{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Компьютер - Computer.{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина - Recycle Bin.{645FF040-5081-101B-9F08-00AA002F954E}
Персонализация - Personalize.{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Принтеры - Printers and Faxes.{2227A280-3AEA-1069-A2DE-08002B30309D}
Программы - Programs Folder.{7BE9D83C-A729-4D97-B5A7-1B7313C39E0A}
Сетевые подключения - Network Connections.{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сеть (WORKGROUP) - Network Places.{208D2C60-3AEA-1069-A2D7-08002B30309D}
Учетные записи пользователей - User Accounts.{60632754-c523-4b62-b45c-4172da012619}

Принцип запуска команд Shell, используя имя объектов, намного легче. Данный способ не требует от Вас знания большого количества цифр и букв, и позволяет снизить величину ошибок при наборе команды. Его основное применение - открытие системных папок.

Например, для быстрого перехода в папку Панели Быстрого Запуска, которая присутствует в Windows, но не добавлена на Панель Задач, достаточно написать команду shell:Quick Launch. При выполнении команды будет в проводнике будет открыта папка: C:\Users\%UserName%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

Для запуска любого из объектов Windows, используя его имя, применяется команда:

Вы можете найти нужные Вам имена объектов в разделах ветки реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\FolderDescriptions или воспользоваться таблицей №2.

Таблица №2.

Имя программы или папки | Адрес папки | Команда
32-разрядный Internet Explorer | C:\Program Files\Internet Explorer или C:\Program Files (x86)\Internet Explorer | shell:InternetFolder
Common Files (в 32-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommon
Common Files (в 64-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommonX64
Common Files (в 64-битной Windows 7) | C:\Program Files (x86)\Common Files | shell:ProgramFilesCommonX86
Cookies | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies | shell:Cookies
Credentials | C:\Users\User-Name\AppData\Roaming\Microsoft\Credentials | shell:CredentialManager
Crypto | C:\Users\User-Name\AppData\Roaming\Microsoft\Crypto | shell:CryptoKeys
DeviceMetadataStore | C:\ProgramData\Microsoft\Windows\DeviceMetadataStore | shell:Device Metadata Store
Documents | C:\Users\Public\Documents | shell:Common Documents
Fonts (шрифты) | C:\Windows\Fonts | shell:Fonts
Gadgets | C:\Program Files\Windows Sidebar\Gadgets | shell:default Gadgets
Gadgets | C:\Users\User-Name\AppData\Local\Microsoft\WindowsSidebar\Gadgets | shell:Gadgets
GameExplorer | C:\ProgramData\Microsoft\Windows\GameExplorer | shell:PublicGameTasks
GameExplorer (Обозреватель игр) | C:\Users\User-Name\AppData\Local\Microsoft\Windows\GameExplorer | shell:GameTasks
History | C:\Users\User-Name\AppData\Local\Microsoft\Windows\History | shell:History
ImplicitAppShortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\ImplicitAppShortcuts | shell:ImplicitAppShortcuts
Local | C:\Users\User-Name\AppData\Local | shell:Local AppData
LocalLow | C:\Users\User-Name\AppData\LocalLow | shell:LocalAppDataLow
Low | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies\Low | shell:Cookies\Low
Network Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\NetworkShortcuts | shell:NetHood
Printer Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\PrinterShortcuts | shell:PrintHood
Program Files | C:\Program Files | shell:ProgramFiles
Program Files (x86) (в 64-битной Windows 7) | C:\Program Files (x86) | shell:ProgramFilesX86
Program Files (в 64-битной Windows 7) | C:\Program Files | shell:ProgramFilesX64
ProgramData | C:\ProgramData | shell:Common AppData
Protect | C:\Users\User-Name\AppData\Roaming\Microsoft\Protect | shell:dpapiKeys
Quick Launch (Быстрый запуск) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch | shell:Quick Launch
Resources (содержит темы Windows) | C:\Windows\Resources | shell:ResourceDir
Ringtones | C:\ProgramData\Microsoft\Windows\Ringtones | shell:CommonRingtones
Roaming | C:\Users\User-Name\AppData\Roaming | shell:AppData
SendTo (элементы контекстного меню Отправить) | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\SendTo | shell:SendTo
System32 | C:\Windows\System32 | shell:System
SystemCertificates | C:\Users\User-Name\AppData\Roaming\Microsoft\SystemCertificates | shell:SystemCertificates
SysWOW64 | C:\Windows\SysWOW64 | shell:SystemX86
Templates | C:\ProgramData\Microsoft\Windows\Templates | shell:Common Templates
Templates | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Templates | shell:Templates
Temporary Internet Files | C:\Users\User-Name\AppData\Local\Microsoft\Windows\TemporaryInternet Files | shell:Cache
User Pinned (Закрепленные элементы) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch\User Pinned | shell:User Pinned
User-Name (файлы Вашей учетной записи) | C:\Users\User-Name | shell:UsersFilesFolder
User-Name (Ваш учетный профиль) | C:\Users\User-Name | shell:Profile
Windows (главная папка системы) | C:\Windows | shell:Windows
Автозагрузка | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup | shell:Common Startup
Автозагрузка | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup | shell:Startup
Администрирование | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Administrative Tools
Администрирование | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Common Administrative Tools
Библиотеки | Библиотеки | shell:Libraries
Библиотеки | Библиотеки | shell:UsersLibrariesFolder
Видео | Библиотеки\Видео | shell:VideosLibrary
Временная папка для записи | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Burn\Burn | shell:CD Burning
Все элементы панели управления | Панель управления\Все элементы панели управления | shell:ControlPanelFolder
Главное меню | C:\ProgramData\Microsoft\Windows\Start Menu | shell:Common Start Menu
Главное меню | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu | shell:Start Menu
Документы | Библиотеки\Документы | shell:DocumentsLibrary
Домашняя группа | Домашняя группа | shell:HomeGroupFolder
Загрузки | C:\Users\User-Name\Downloads | shell:downloads
Згрузки | C:\Users\Public\Downloads | shell:CommonDownloads
Игры | Игры | shell:Games
Избранное | C:\Users\User-Name\Favorites | shell:Favorites
Изображения | C:\Users\Public\Pictures | shell:CommonPictures
Изображения | C:\Users\User-Name\Pictures | shell:My Pictures
Изображения | Библиотеки\Изображения | shell:PicturesLibrary
Компьютер | Компьютер | shell:MyComputerFolder
Контакты | C:\Users\User-Name\Contacts | shell:Contacts
Конфликты | Панель управления\Все элементы панели управления\Центрсинхронизации\Конфликты | shell:ConflictFolder
Корзина | Корзина | shell:RecycleBinFolder
Мои видеозаписи | C:\Users\User-Name\Videos | shell:CommonVideo
Мои видеозаписи | C:\Users\User-Name\Videos | shell:My Video
Мои документы | C:\Users\User-Name\Documents | shell:Personal
Моя Музыка | C:\Users\Public\Music | shell:CommonMusic
Моя музыка | C:\Users\User-Name\Music | shell:My Music
Музыка | Библиотеки\Музыка | shell:MusicLibrary
Настройка синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Настройка синхронизации | shell:SyncSetupFolder
Недавние документы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Recent | shell:Recent
Образцы видео | C:\Users\Public\Videos\Sample Videos | shell:SampleVideos
Образцы изображений | C:\Users\Public\Pictures\Sample Pictures | shell:SamplePictures
Образцы музыки | C:\Users\Public\Music\Sample Music | shell:SampleMusic
Общие | C:\Users\Public | shell:Public
Папка с рингтонами Windows 7 | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Ringtones | shell:Ringtones
Поиск Windows | search-ms: | shell:SearchHomeFolder
Поиски (информация о поисках) | C:\Users\User-Name\Searches | shell:Searches
Получение программ | Панель управления\Все элементы панели управления\Получение программ | shell:AddNewProgramsFolder
Пользователи | C:\Users | shell:UserProfiles
Принтеры | Все элементы панели управления\Принтеры | shell:PrintersFolder
Программы | C:\ProgramData\Microsoft\Windows\Start Menu\Programs | shell:Common Programs
Программы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu\Programs | shell:Programs
Программы и компоненты | Панель управления\Все элементы панели управления\Программы и компоненты | shell:ChangeRemoveProgramsFolder
Рабочий стол | C:\Users\Public\Desktop | shell:Common Desktop
Рабочий стол | C:\Users\User-Name\Desktop | shell:desktop
Результаты синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Результаты синхронизации | shell:SyncResultsFolder
Сетевые подключения | Панель управления\Все элементы панели управления\Сетевые подключения | shell:ConnectionsFolder
Сеть | Сеть | shell:NetworkPlacesFolder
Сохраненные игры | C:\Users\User-Name\Saved Games | shell:SavedGames
Ссылки | C:\Users\User-Name\Links | shell:Links
Установленные обновления | Программы и компоненты\Установленные обновления | shell:AppUpdatesFolder
Центр синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации | shell:SyncCenterFolder

Для упрощения работы с командами Windows Shell Вы можете скачать небольшую бесплатную программу Shell Dump.
Данная программа проанализирует Ваш реестр и отобразит список команд, которые Вы можете использовать. Вам всего лишь достаточно выбрать команду и нажать кнопку Run для ее запуска.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


5. Включение и отключение Области переходов.

"Область переходов" – это специальная панель (дерево папок), которая находится слева в каждой папке.
Она выполняет функцию командной оболочки, обеспечивая быстрый доступ к папкам, которые содержат нужные файлы. Быстрое выполнение различных операций – таких, как копирование, удаление, архивирование файлов и папок, открытие сохраненного запроса поиска.
При большом числе файлов на экране, иногда необходимо отключить "Область переходов", для увеличения одновременно отображаемых файлов.

Включить или отключить "Область переходов" можно так:

1) Нажмите вверху слева Упорядочить->Представление
2) Поставьте или уберите галочку в пункте "Область переходов"

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


6. Использование переменных окружения для быстрого перехода к системным папкам.

Чтобы узнать какие из них присутствуют в Вашей системе запустите cmd.exe и в нем команду set. Получите полный список переменных окружения Вашей Windows.

%AllUsersProfile% - C:\ProgramData
%AppData% - C:\Users\%UserName%\AppData\Roaming
%CommonFavorites% - C:\Documents and Settings\All Users\Избранное
%CommonFiles% - C:\Program Files\Common Files
%CommonProgramFiles% - C:\Program Files\Common Files
%CommonProgramFiles(x86)% - C:\Program Files (x86)\Common Files
%ComSpec% - Запустит cmd.exe из папки, в которой будет употреблен
%HomePath% - C:\Users\Administrator
%LOCALAPPDATA% - C:\Users\%UserName%\AppData\Local
%ProgramData% - C:\ProgramData
%ProgramFiles% - C:\Program Files
%ProgramFiles(x86)% - C:\Program Files (x86)
%PSModulePath% - C:\Windows\System32\WindowsPowerShell\v1.0\Modules
%SystemDir% - C:\Windows\System32
%SystemDrive% - C:\
%SystemRoot% - C:\Windows
%Temp% - C:\Documents and Settings\%UserName%\Local Settings\Temp; C:\Users\%UserName%\AppData\Local\Temp
%Tmp% - C:\Users\%UserName%\AppData\Local\Temp
%UserProfile% - C:\Users\%UserName%
%windir% - C:\Windows

Если Вы решите создать собственную переменную типа:
%MyFolder%=C:\MyFolder

1) Пройдите:
Компьютер -> Свойства -> Дополнительные параметры системы ->Дополнительно -> Переменные среды
2) Нажмите Создать...
3) Укажите Имя переменной и Значение переменной
4) Нажмите на каждое Ок
5) Перезагрузите компьютер (иначе она не будет работать)

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


7. Использование флажков для выделения (выбора) файлов и папок.

В Windows есть удобная возможность помечать для выделения файлы и папки с использованием флажков (чекбоксов). Это удобнее чем выделять объекты удерживая Ctrl, но эта функция отключена по умолчанию. Для ее включения проделайте следующее:
Откройте Проводник и нажмите один раз клавишу Alt - таким образом мы инициализируем отображение стандартного меню вверху окна проводника, которое скрыто по умолчанию.
Запустите Пуск\Панель Управления\Параметры Папок и перейдите на вкладку Вид
Отметьте параметр "Использовать флажки для выбора элементов" и нажмите ОК
Теперь слева возле каждого файла и папки появилась возможность отметить их поставив флажок, а в заголовках колонок сортировки можно поставить флажок для выделения всех объектов открытой папки.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


8. Объединение нескольких различных приложений(папок или иконок) в один значок на Панели задач.

Одним из самых явных изменений в Windows 7 является новая панель задач, в которой вместо кнопок отображаются иконки, и все окна приложения объединяются под одну кнопку. Со временем, когда на компьютере установлено много программ, на панели задач начинает не хватать места для кнопок. Исправить это можно с помощью бесплатной программы 7Stacks.

Она создает подменю для кнопок, позволяя отсортировать программы по разделам – игры, программы для интернета, и т.д.

Порядок действий:

1) Создайте папку
2) Сложите в нее ярлыки приложений, необходимых Вам в создаваемом меню.
3) Запустите 7Stacks
4) Выберите созданную Вами папку
5) Настройте оформление и создайте ярлык на рабочем столе.
6) Перетащите данный ярлык в панель задач.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


9. Сворачивание всех неактивных окон, кроме текущего активного, используя Aero Shake.

В интерфейс Windows Aero добавлена новая функция Aero Shake, позволяющая свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти» влево-вправо.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


10. Закрытие всех запущенных приложений одним кликом.

Утилита под названием Close All Windows позволяет закрыть все работающие приложения с помощью всего одного клика. Она не требует установки и не использует ресурсов, так как посылает только команду "Закрыть" всем действующим приложениям.

1) Скачиваете с официального сайта программу CloseAll
2) Распаковывайте архив в удобное Вам место для использования.
3) Перемещаете файл CloseAll.exe на панель задач, если у вас 64-битная система то файл CloseAll.exe берете из папки x64.

Для удобства использования программы Вы можете назначить ей клавишу быстрого вызова и добавить исключения для программ, которые закрываться не будут:

1) Щелкаете правой кнопкой мыши на иконке в панели задач
2) Щелкаете правой кнопкой мыши на "Close All Windows" и нажимаете Свойства
3) В поле Быстрый вызов нажмите нужное сочетание клавиш, для сопоставления выбранной комбинации с программой.
4) В поле Объект добавьте -x="программа.exe"
Вы можете добавить несколько программ разделив их "|", например:

5) Нажмите Ок для сохранения настроек.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


11. Открытие командной строки из конкретной папки.

1)Нажмите на клавиатуре клавишу Shift.
2) Удерживая ее нажатой, щелкните правой кнопкой мыши на папке из которой Вы желаете открыть командную строку.
3) В контекстном меню нажмите пункт Открыть окно команд (“Open Command Window Here”).

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


12. Закрепление конкретной папки на панели задач Windows 7.

Если Вы перетащите папку на панель задач, то она закрепится во всплывающем списке (подменю) Проводника. Чтобы закрепить отдельно папку на панели задач сделайте следующее:

1) Щелкните правой кнопкой мыши на рабочем столе и выберите Создать -> Ярлык.
2) В поле Расположение объекта введите:

(вместо C:\MyFolder введите фактический адрес прикрепляемой папки).
3) В поле Имя ярлыка введите название папки (в нашем случае это MyFolder) и нажмите Готово.
4) Щелкните правой кнопкой по созданному ярлыку и в появившемся контекстном меню выберите пункт Закрепить на панели задач.

Примечание. Каждая закрепленная папка будет открываться в отдельном процессе.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


13. Настройка списка элементов, отображаемых в диалоговом окне открытия и сохранения файлов Windows.

1) Щелкните на кнопке Пуск
2) В строке поиска введите gpedit.msc и нажмите клавишу Enter.
3) Откройте узел Конфигурация пользователя ->Административные шаблоны -> Компоненты Windows -> Проводник Windows -> Общее диалоговое окно открытия файлов.
4) Дважды щелкните на политике Элементы, отображаемые в панели мест.
5) Щелкните на переключателе Включить.
6) Используйте текстовые поля Элемент 1 — Элемент 5 для ввода путей к папкам, которые требуется отображать в панели мест. Ими могут быть локальные или сетевые папки.
7) Щелкните на кнопке OK, чтобы ввести политику в действие.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


14. Запуск программы с параметрами командной строки из контекстного меню Проводника.

Чтобы запустить программу с параметрами - обычно Вам необходимо: либо создать ярлык к программе и при создании указать параметры, либо Пуск -> Открыть (Win+R) ввести программу, указав путь к ней и затем дописать параметры.
Всё это проще позволит сделать программа ExecParm. Данная программа является позволяет запускать исполняемые(.exe, .com) и командные файлы(.cmd, .bat) с параметрами, используя расширение встраиваемое в контекстное меню Проводника. Чтобы его использовать Вам сделайте следующее:

1) Скачайте архив программы ExecParm с необходимой разрядностью: 32-битная, 64-битная .
2) Распакуйте архив в любую папку.
3) Откройте папку с распакованным содержимым. В ней будут три файла: ExecParm.txt, Execparm.dll, Execparm.inf)
4) Щелкните правой кнопкой мыши по файлу Execparm.inf и выберите Установить
Данное действие добавит пункт в контекстное меню для запуска приложения с параметрами.
5) Щелкните правой кнопкой по исполняемому файлу и выберите в контекстном меню пункт Execute With Parameters...
6) Введите необходимые параметры для запуска программы и нажмите ОК.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


15. Отображение часто используемых команд для диалогового окна "Выполнить" в меню Пуск.

1) Откройте папку содержащую файл shell32.dll.mui

Для 32-битной версии: C:\Windows\System32\ru-RU
Для 64-битной версии(также): C:\Windows\SysWOW64\ru-RU

2) Задайте полный доступ к файлу shell32.dll.mui для этого воспользуйтесь советом Администрирование: 1. Получение полного доступа к файлу или папке.
3) Скачайте архив Patch_ExtendedRun.zip и распакуйте его в любую папку.
4) Щелкните на exe-файле правой кнопкой мыши и выберите пункт Запуск от имени администратора.
5) Нажмите кнопку Start для применения патча.

Внимание: Памятку устанавливать только на оригинальные ОС, работоспособность на различного рода сборках не гарантируется.
Новые версии Вы можете скачать по ссылке: Windows 7 Памятка

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


16. Быстрая вставка путей к файлу или папке в окно команд Windows 7.

Наиболее часто используемым способом вставки путей к файлу или папке в окно команд Windows (окно командной строки) является следующее:

1) Выделяете в адресной строке проводника путь к папке.
2) Щелкаете на выделенном правой кнопкой мыши и выбираете Копировать.
3) Щелкаете по заголовку окна команд правой кнопкой мыши и выбираете в контекстном меню пункты Изменить -> Вставить
А если необходимо еще добавить имя и расширение файла, то:
4) Щелкаете по файлу правой кнопкой мыши и выбираете Переименовать.
5) Выделяете имя и расширение файла, щелкаете на выделенном правой кнопкой мыши и выбираете Копировать.
6) Щелкаете по заголовку окна команд правой кнопкой мыши и выбираете в контекстном меню пункты Изменить -> Вставить

В Windows 7 существуют более быстрые способы сделать это:

Способ 1.

1) Удерживая нажатой клавишу Shift щелкните правой кнопкой мыши на папке или файле, путь к которому Вы желаете добавить в окно команд Windows (окно командной строки).
2) В контекстном меню выберите пункт Копировать как путь (“Copy as path”).
3) Щелкните внутри окна команд и выберите пункт Вставить.

Способ 2.

Перетащите файл или папку (путь к которому Вы желаете добавить) напрямую внутрь окна команд Windows.

Примечание: Окно из которого вы перетаскиваете файл или папку в окно команд, должно иметь более высокие или одинаковые права и разрешения, чем само окно команд.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


17. Запуск командной строки из "Диспетчера задач" без ввода команды CMD.

1) Запустите Диспетчер задач нажав на клавиатуре комбинацию клавиш Ctrl+Shift+Esc.
2) Удерживая нажатой клавишу Ctrl выберите в главном меню пункт Файл и щелкните -> Новая задача (Выполнить...)

Примечание:

Если у Вас включен Контроль учётных записей (UAC) или Диспетчер задач запущен в ограниченной учётной записи, окно команд откроется без прав администратора.
Если у Вас отключен Контроль учётных записей (UAC) или Диспетчер задач запущен с правами администратора, окно команд откроется с правами администратора.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


18. Изменение действий осуществляемых системой при использовании щелчков мыши.

Если Вы привыкли к поведению мыши в браузере, то Вы можете переключить режим используемый при щелчке мышью в системе на идентичный. Для этого выполните следующие действия:

1) Откройте Панель управления в режиме просмотра всех элементов: Пуск -> Панель управления\Все элементы панели управления
2) Запустите Параметры папок
3) На вкладке Общие установите значение переключателя в
Открывать одним щелчком, выделять указателем -> Подчеркивать подписи значков при наведении
4) Нажмите ОК.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


19. Команды для распаковки *.cab, *.exe, *.msi, *.msp и *.msu файлов от Microsoft.

Приведенные в примерах команды подразумевают, что Вы запустили окно команд из папки, где находится сам файл.
Чтобы запустить окно команд из папки, где расположен исходный файл, удерживая нажатой клавишу Shift щелкните правой кнопкой мыши на папке и выберите пункт Открыть окно команд.

Microsoft Cabinet File (.cab):

Команда для запуска:

Пример:

Microsoft Hotfix Installer (.exe):

Команда для запуска:

Пример:

Windows Installer Package (.msi):

Команда для запуска:

Пример:

Microsoft Update Standalone Package (.msu):

Команда для запуска:

Пример:

Microsoft Patch File (.msp)

Скачайте программу MSI Extractor, распакуйте архив и скопируйте файл msix.exe в папку C:\Windows\System32

Команда для запуска:

Пример:

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


20. Быстрое открытие ещё одной копии приложения.

Если у вас уже открыто какое-либо приложение и вы хотите быстро открыть его вторую копию, то удерживая клавишу Shift просто нажмите на иконку данного приложения на Панели задач. И вместо переключения в существующее окно будет открыта новая копия этого приложения. Того же эффекта можно добиться кликнув по иконке приложения на Панели задач, средней кнопкой мыши.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


21. Размещение любого окна Windows поверх других.

При работе с огромным количеством открытых окон, документов, таблиц и программ очень часто хочется, чтобы окно оставалось поверх всех открытых окон (OnTop) даже при потере фокуса. Для этого можно использовать программу DeskPins.

Программа предназначена для того, чтобы закреплять любые приложения поверх всех окон Windows. Нужно просто перетащить кнопку с иконки программы на заголовок того окна, которое нужно закрепить, и нажать кнопку мыши — теперь закрепленное окно всегда будет на самом верху. Закреплять и откреплять активные окна можно с помощью горячих клавиш, есть также возможность автоматического закрепления окон. Нажимаете Ctrl+F12 и окно становится OnTop по отношению ко всем открытым.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


22. Ввод пароля в окне смены пользователей при отсутствии необходимой раскладки клавиатуры.

Если Вы задали пароль на русском языке в английской Windows или пароль на русском языке в русской Windows, то Вы можете столкнуться с ситуацией, когда невозможно ввести пароль в окне смены пользователей, по причине отсутствия необходимой раскладки клавиатуры.

В таком случае для ввода пароля Вы можете воспользоваться ASCII символами.

Для ввода буквы из другой раскладки клавиатуры Вам необходимо удерживая нажатой клавишу Alt ввести номер клавиши.
Например для ввода английской буквы t в русской раскладке клавиатуры:

1) Нажмите и удерживайте клавишу Alt
2) Введите 0 (ноль) и сразу за ним 116
3) Отпустите клавишу Alt, и вы увидите результат.

или

для ввода русской буквы т в английской раскладке клавиатуры:

1) Нажмите и удерживайте клавишу Alt
2) Введите 0 (ноль) и сразу за ним 242
3) Отпустите клавишу Alt, и вы увидите результат. Таблица ASCII символов для русской и английской клавиатуры приведена ниже.

Таблицы ASCII для кодовой страницы Windows 1251

Кириллица | Значение | Латиница | Значение
А | 192 | A | 65
Б | 193 | B | 66
В | 194 | C | 67
Г | 195 | D | 68
Д | 196 | E | 69
Е | 197 | F | 70
Ж | 198 | G | 71
З | 199 | H | 72
И | 200 | I | 73
Й | 201 | J | 74
К | 202 | K | 75
Л | 203 | L | 76
М | 204 | M | 77
Н | 205 | N | 78
О | 206 | O | 79
П | 207 | P | 80
Р | 208 | Q | 81
С | 209 | R | 82
Т | 210 | S | 83
У | 211 | T | 84
Ф | 212 | U | 85
Х | 213 | V | 86
Ц | 214 | W | 87
Ч | 215 | X | 88
Ш | 216 | Y | 89
Щ | 217 | Z | 90
Ъ | 218 | a | 97
Ы | 219 | b | 98
Ь | 220 | c | 99
Э | 221 | d | 100
Ю | 222 | e | 101
Я | 223 | f | 102
а | 224 | g | 103
б | 225 | h | 104
в | 226 | i | 105
г | 227 | j | 106
д | 228 | k | 107
е | 229 | l | 108
ж | 230 | m | 109
з | 231 | n | 110
и | 232 | o | 111
й | 233 | p | 112
к | 234 | q | 113
л | 235 | r | 114
м | 236 | s | 115
н | 237 | t | 116
о | 238 | u | 117
п | 239 | v | 118
р | 240 | w | 119
с | 241 | x | 120
т | 242 | y | 121
у | 243 | z | 122
ф | 244 |  |
х | 245 |  |
ц | 246 |  |
ч | 247 |  |
ш | 248 |  |
щ | 249 |  |
ъ | 250 |  |
ы | 251 |  |
ь | 252 |  |
э | 253 |  |
ю | 254 |  |
я | 255 |  |

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


23. Установка положения курсора в диалоговом окне на кнопке, выбираемой по умолчанию.

Для многих пользователей весьма удобным считается, чтобы курсор мыши при открытии диалогового окна занимал позицию на кнопке Открыть, Сохранить или аналогичной по умолчанию. Данное действие позволяет Вам сэкономить время необходимое для наведения курсора.

1) Откройте Панель управления -> Мышь
2) Перейдите на вкладку Параметры указателя
3) В графе "Исходное положение в диалоговом окне" установите флажок "На кнопке, выбираемой по умолчанию"
4) Нажмите ОК.

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


24. Уточнение даты и времени загрузки системы.

Вариант 1.

Если Вам необходимо узнать дату и время установки Windows на компьютер или дату и время когда компьютер был запущен, то сделайте следующее:

1) Запустите командную строку с правами администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl+Shift+Enter.
2) Введите команду systeminfo

В графе с одноименным названием Вы найдете необходимое Вам значение.

Вариант 2.

1) Скачайте с сайта Microsoft программу uptime.exe (http://support.microsoft.com/kb/232243)
2) Скопируйте ее в папку C:\Windows\System32
3) Запустите командную строку с правами администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl+Shift+Enter.
4) Введите команду uptime.exe.

Вариант 3.

Скачайте и установите специальный гаджет.

systemuptime_sevengadgets.ru.zip

Назад на страницу раздела Интерфейс.
Назад на страницу подраздела Интерфейс - Взаимодействие.


Сети (Интернет и Локальная)

1. Смена поиска по умолчанию в Mozilla Firefox.

Бывает, что программы без вашего спроса меняют в Firefox поисковик по умолчанию на свой. Чтобы его заменить сделайте следующее:

1) Пишете в адресной строке Firefox такой адрес: "about:config", без кавычек
2) Подтверждаете, что будете осторожны, получаете доступ к многочисленным настройкам Firefox и находите среди них параметр keyword.url
3) Меняете его значение (без кавычек) на:

"http://www.google.com/search?&q=" - Google.Com
"http://yandex.ru/yandsearch?text=" - Yandex.Ru
"http://www.bing.com/search?q=" - Bing.Com

2. Добавление ссылки Поиск в Интернете при использовании поиска в меню Пуск.

В Windows Vista была предложена новая функция. При наборе текста в поле поиска меню Пуск, прямо над окном поиска появлялась ссылка "Поиск в Интернете". При её нажатии набранный текст посылался напрямую в браузер, используемый по умолчанию для поиска.
В Windows 7 данная функция по умолчанию отключена. Microsoft удалила его из меню "Пуск". Чтобы включить "Поиск в Интернете" через меню «Пуск» необходимо проделать следующие действия.

1) Откройте диалоговое меню Выполнить (Win+R)
2) Введите gpedit.msc.
3) Перейдите в раздел Конфигурация пользователя -> Административные шаблоны -> «Меню «Пуск» и панель задач».
4) Нажмите правой кнопкой мыши на строке Добавить ссылку «Поиск в интернете» в меню «Пуск» и выберете пункт «Изменить».
5) В открывшемся окне установите переключатель в значение «Включить».
6) Нажмите «OK» и закройте Редактор локальной групповой политики.

Также Вы можете создать reg-файл, выполняющий данную функцию или скачать и применить уже готовый. После применения перезайдите в систему или перезагрузите компьютер.

Готовый файл: AddSearchInternetLinkInStartMenu.zip

3. Объединение или удаление сетевых размещений (подключений).

1) Щелкните правой кнопкой мыши на значок Сеть на панели задач и выберите пункт Центр управления сетями и общим доступом
2) Если у Вас отсутствует данный значок, то нажмите комбинацию клавиш Win+R -> введите команду

и нажмите OK
3) Нажмите на значке (дом, офис или скамейка - зависит от типа выбранной Вами сети)
4) В открывшемся окне Настройка свойств сети нажмите на ссылку Объединение или удаление сетевых размещений.
5) Выделите сетевое размещение или несколько сетевых размещений, которые Вы хотите слить в единое сетевое размещение или которые Вы хотите удалить.
Используемые подключения нельзя удалить или слить, для их слияния или удаления Вам необходимо отключится от сети.
6) Нажмите кнопку Слияние или Удаление, во всплывшем окне нажмите кнопку Да.

4. Автоматическое подключение к ADSL-интернету при запуске Windows.

1) Откройте Панель управления\Все элементы панели управления\Центр управления сетями и общим доступом.
2) Нажмите ссылку Изменение параметров адаптера.
3) Щелкните правой кнопкой мыши на Вашем ADSL-соединении и выберите пункт Свойства.
4) Перейдите на вкладку Параметры и снимите флажки Отображать ход подключения, Запрашивать имя, пароль, сертификат и т.д..
5) Нажмите кнопку ОК.
6) Щелкните правой кнопкой мыши на Вашем ADSL-соединении и выберите пункт Создать ярлык.
7) В диалоговом окне нажмите Да и у Вас на рабочем столе появится ярлык ADSL-соединения.
8) Откройте Пуск -> Все программы .
9) Нажмите правой кнопкой мыши на Автозагрузка и выберите пункт Открыть.
10) Переместите ярлык созданного Вами ADSL-соединения с рабочего стола в открывшуюся папку Автозагрузка.

5. Автоматическое VPN-подключение к интернет при запуске Windows.

Вариант 1

Вы можете добавить задачу в Планировщик заданий.
1) Откройте планировщик задний
1.1) Откройте меню Пуск -> Панель управления -> Администрирование -> Планировщик заданий или в строке поиска меню Пуск введите taskschd.msc и нажмите Enter.
2) Нажмите Создать задачу...
3) На вкладке Общие введите в поле Имя - Имя подключения
4) Перейдите на вкладку Триггеры и нажмите кнопку Создать...
5) Выберите в ниспадающем списке напротив пункта Начать задачу: значение При входе в систему и нажмите ОК.
6) Перейдите на вкладку Действия и нажмите кнопку Создать...
7) Выберите в ниспадающем списке напротив пункта Действие: значение Запуск программы.
8) Введите в поле Программа или сценарий: команду rasdial "имя подключения" login password
вместо "имя подключения" - укажите название Вашего подключения к интернету
вместо login - укажите Ваш логин(имя пользователя) для подключения к интернету
вместо password - укажите Ваш пароль для подключения к интернету
9) Нажмите кнопку ОК.
10) Перейдите на вкладку Параметры
11) Поставьте флажки напротив:
Немедленно запускать задачу, если пропущен плановый запуск
При сбое выполнения перезапускать через 1 мин.
Количество попыток перезапуска 99.
12) Уберите флажок Останавливать задачу выполняемую дольше и нажмите ОК.

Вариант 2

1) Скачайте и распакуйте в любую папку файл connect.zip, содержащий скрипт для соединения с интернетом.
2) Щелкните правой кнопкой мыши на файле connect.bat и нажмите Изменить
3) Измените название подключения, логин(имя пользователя) и пароль в соответствии с Вашими настройками и сохраните файл.
4) Скачайте архив со скриптом скрытого запуска:
hs_exec.zip - для использования командного bat-файла, содержащего скрипт запуска
hide_programm.zip - для использования яваскрипта, содержащего скрипт запуска
5) Распакуйте архив в ту же самую папку, где у Вас находится файл connect.bat
6) Добавьте в папку автозагрузки (Пуск -> Все программы ->Автозагрузка) ярлык (не сам файл скрипта) для hide_programm.js в случае использования яваскрипта, либо для load.bat в случае использования командного bat-файла.

Вариант 3

1) Создайте командный bat-файл (Например: Connect.bat) следующего содержания:

вместо "имя подключения" - укажите название вашего подключения к интернету
вместо login - укажите Ваш логин(имя пользователя) для подключения к интернету
вместо password - укажите Ваш пароль для подключения к интернету

2) Добавьте ярлык (не сам файл скрипта) на файл connect.bat в папку автозагрузки (Пуск -> Все программы ->Автозагрузка)

Внимание: "имя подключения" должно быть на английском иначе может быть ошибка 623.

6. Отключение запроса пароля при использовании папки общего доступа.

Даже если Вы не устанавливали пароль для папки общего доступа, система может у Вас его запросить.

Для отключения данного запроса сделайте следующее:

1) Откройте Панель управления\Все элементы панели управления\Центр управления сетями и общим доступом
2) Нажмите на ссылку Изменить дополнительные параметры общего доступа
3) В графе Общий доступ с парольной защитой установите переключатель на значение Отключить общий доступ с парольной защитой.

7. Просмотр исходного кода любой страницы в интернете.

Очень многие страницы в интернете любят скрывать свой код или блокировать копирование. Но это легко можно решить. Данный метод позволяет узнать любой код зашифрованный криптографами или измененный обфускаторами.

В Firefox

Установите расширение Web Developer.
Затем в меню Web Developer -> Код -> Сгенерированный код.
Если исходный код был зашифрован, то промотайте вниз и увидите реальный код. Если код не был зашифрован, то увидете его сразу.
Вы можете сохранить его либо скопировав в буфер обмена и вставив в нужное место, либо Файл -> Сохранить страницу как -> page.htm

В Internet Explorer

Меню Сервис -> Средства разработчика
Можете нажать на стрелочку и выбрать нужный элемент на странице и увидите его код или нажать на значок дискетки и сохранить исходный код в текстовый файл, а затем скопировать из него в html.

8. Восстановление пропавшего звука в интернет браузерах.

1) Проверьте уровень громкости в самом Flash плеере.

2) Удалите полностью, а затем поставьте заново:
2.1) Adobe Flash Player. Uninstall: http://kb2.adobe.com/cps/141/tn_14157.html Install: http://get.adobe.com/flashplayer/otherversions/
2.2) Кодеки в системе (K-lite codeck pack, Shark007 Windows 7 Codecs или др.)
2.3) Браузеры.
2.4) Драйвера звуковой карты

3) В Internet Explorer, проверьте стоит ли у Вас флажок в пункте "Воспроизводить звуки на веб-страницах" Сервис -> Свойства обозревателя -> Дополнительно -> Раздел Мультимедиа.

4) Проверьте, установлен ли запуск службы Windows Audio Автоматически.
Панель Управления -> Администрирование -> Службы -> двойной щелчок на Windows Audio -> Тип запуска: Автоматически
Затем нажмите Остановить, потом Запустить.

5) Запустите редактор реестра (Win+R -> regedit)
Перейдите к ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32
Проверьте значение строкового(String) параметра wavemapper. Его значение должно быть msacm32.drv. Если данного параметра нет, то создайте его.

9. Сохранение интернет соединения при переключении между пользователями.

При создании нового интернет подключения поставьте флажок на "Разрешить использовать это подключение другим пользователям".
Установление галочки в уже созданном подключении может работать некорректно в некоторых VPN соединениях.

По умолчанию при переключении между пользователями Windows сбрасывает dial-up и некоторые виды других соединений. Можно изменить это поведение следующим образом.

1) Запускаете редактор реестра (Win+R -> Regedit -> OK)
2) Открываете ветку реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters
3) Щелкните правой кнопкой мыши на Dword-параметр KeepRASConnections, выберите Изменить и присвойте параметру значение 1
4) Закройте Regedit и завершите текущий сеанс для вступления изменений в силу

Если Вы хотите, чтобы соединения сбрасывались, то используйте значение 0 или удалите этот параметр.

10. Перемещение HOST, LMHOST и других файлов из Windows\System32\drivers\etc в другое место.

Если вы хотите переместить файлы из Windows\System32\drivers\etc в другое место (например, по соображениям безопасности) из папки Windows\System32\drivers\etc, то для этого Вам необходимо выполнить следующее:
1) Скопируйте файлы в новое место
2) Запустите редактор реестра (Win+R -> regedit -> Ok).
3) Откройте ветку HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
4) Измените значение параметра DataBasePath на новый путь к папке
5) Перезагрузитесь и удалите файлы из %SystemRoot%\System32\drivers\etc

11. Поиск на веб-сайтах из Проводника (Windows Explorer).

Windows 7 теперь позволяет вести поиск на веб-сайтах из Windows Explorer (Проводника). Данный поиск основан на спецификации OpenSearch.
Чтобы добавить в Windows провайдер OpenSearch, нужно предоставить файл определения в формате OSDX. Этот формат позволяет указывать описательную информацию наряду с необходимыми URL и другими параметрами.
Эти файлы сопоставляются с Windows Explorer и добавляются в папку Searches: C:\Users\{USER}\Searches.
Чтобы создать файл OSDX, нужно предоставить URL для вызова и имя провайдера.

1) Откройте текстовый редактор. (Например, Блокнот)
2) Скопируйте и вставьте в него следующий текст:

3) В меню программы нажмите Файл и выберите пункт Сохранить.
3.1) В открывшемся окне укажите место сохранения файла.
3.2) Укажите имя файла и расширение .osdx и обязательно в кодировке UTF-8 (Например: Сохраните его как Bing.osdx)
3.3) Выберите тип файла: Все файлы (*.*).

Дважды щелкните по получившемуся osdx-файлу для внесения дополнений в систему.

Чтобы искать на добавленном Вами веб-сайте из Проводника:

1) Запустите Проводник (Explorer)
2) Откройте папку C:\Users\{USER}\Searches, для чего просто введите %UserProfile%\Searches и нажмите Enter.
3) Выберите установленный Вами поиск, в строке поиска укажите значение для поиска и нажмите Enter.
4) Если Вы хотите, чтобы при нажатии на результат поиска в проводнике показывались найденная страница, то нажмите на значок включения Области предварительного просмотра (находится, в верхней правой части экрана перед значком вопроса)

Вы можете скачать уже готовые файлы определения (.osdx) по ссылке: OSDX.zip

12. Смена динамического IP-адреса, для обхода времени ожидания на файлообменниках.

Многие файлообменники и программы для скачивания разделяют обычных пользователей по IP адресу. Если Вы не используйте прокси-сервера и при каждом подключении к интернету провайдер дает Вам новый IP адрес, то это означает что у Вас динамический адрес и Вы можете создать командный файл разрывал бы связь и снова соединялся с интернетом. В итоге у вас будет новый адрес и для файлообменника Вы будете уже новым клиентом.
Данная возможность позволит Вам обойти ограничение по времени и качать без ожиданий.

Инструкция по созданию командного файла:

1) Откройте любой текстовый редактор (Например, Блокнот).
2) Откройте меню Пуск -> Все программы -> Стандартные -> Блокнот (или нажмите сочетание клавиш Win+R -> введите notepad -> нажмите ОК)
3) Скопируйте необходимый Вам код в окно программы Блокнот.
4) В меню программы нажмите Файл и выберите пункт Сохранить.
В открывшемся окне:
5) Укажите место сохранения файла.
6) Укажите имя файла и расширение .bat (Например: reconnect.bat)
7) Выберите тип файла: Все файлы (*.*).
8) Для смены IP-адреса запустите созданный Вами командный файл просто щелкнув на нем.

Вариант 1. Внешний динамический адрес, прямое подключение по локальной сети.

Вариант 2. Внешний динамический адрес, подключение через модем или через USB-ADSL.

Способ 1.

Чтобы узнать имя требуемого интерфейса:
1) Запустите командную строку от имени администратора (Win+R -> cmd -> OK)
2) Введите указанную ниже команду и нажмите Enter:

Способ 2.

Вариант 3. Внешний динамический адрес, подключение через LAN-ADSL или через роутеры.

Способ 1.

где:
192.168.1.1 - Ваш IP-адрес (модема)
LOGIN - логин к модему
PASS - пароль к модему

Способ 2.

Скачиваете и устанавливаете программу Router Control, а файл reconnect.bat создаете в папке программы.

13. Включение и настройка общего доступа к файлам и папкам.

В Windows 7 папка «Общее» заменена на отдельные общие папки для каждого типа файлов: Общие документы, Общие рисунки, Общая музыка или Общее видео. В Проводнике Вы можете попасть в них через Библиотеки, открыв папку Документы, Рисунки, Музыка или Видео, а затем папку Общие документы, Общие рисунки, Общая музыка или Общее видео.

Предоставление общего доступа к файлам или папкам, находящимся в Общих папках с использованием домашней группы.

1) Нажмите кнопку Пуск и откройте Панель управления.
2) Установите режим просмотра "Крупные значки" и запустите компонент Центр управления сетями и общим доступом.
3) Щелкните Выбор домашней группы и параметров общего доступа.
4) Нажмите на кнопку Создать домашнюю группу
5) Выберите элементы, к которым нужно предоставить общий доступ и нажмите кнопку Далее.
6) В окне с паролем для добавления других компьютеров к домашней группе нажмите кнопку Готово.
7) Нажмите на ссылку Изменить дополнительные параметры общего доступа
8) В графе Общий доступ с парольной защитой установите переключатель в значение Отключить общий доступ с парольной защитой.
9) Нажмите на кнопку Сохранить изменения и закройте окно настроек.

Предоставление общего доступа к любым файлам или папкам без перемещения их в Общие папки с использованием домашней группы.

I. Настройка конкретных папок или файла для общего доступа.

1) Перейдите в место размещения файла или папки, к которым необходимо предоставить общий доступ.
2) Щелкните файл или папку правой кнопкой мыши и выберите пункт Общий доступ –> Конкретные пользователи
3) Введите имя или нажмите стрелку вниз и в всплывающем меню выберите Все, а затем нажмите кнопку Добавить
4) Напротив имени Все установите необходимый Вам Уровень разрешений:
Чтение - Пользователи могут открывать файл, но им не разрешается изменять или удалять его.
Чтение и запись - Пользователи могут открывать, изменять и удалять файл.
5) Нажмите кнопку Общий доступ. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
6) Нажмите правой кнопкой мышки на папке и выберите Копировать ссылку. Ваша ссылка будет скопирована в буфер обмена. Теперь вставьте ссылку в сообщение электронной почты, мгновенное сообщение или другую программу, или же сохраните в блокноте.
7) По завершении нажмите кнопку Готово.

II. Настройка портов для общего доступа.

1) Откройте Пуск -> Панель управления -> Система и безопасность и запустите Брандмауэр Windows.
2) Нажмите ссылку Дополнительные параметры, чтобы добавить новые правила для Firewall.
3) В открывшемся окне, в меню слева, выберите Правила для входящих подключений
4) В меню справа нажмите кнопку Создать правило….
5) В открывшемся окне, установите переключатель на тип правила Для порта и нажмите кнопку Далее.
6) Установите переключатель на Протокол TCP.
7) В текстовое поле напротив Определенные локальные порты: впишите через запятую 139, 445 и нажмите кнопку Далее.
8) В следующем окне оставьте установленное по умолчанию значение Разрешить подключение и нажмите кнопку Далее.
9) В окне выбора профилей снова нажмите кнопку Далее.
10) Введите имя и описание Вашего правила. Например: Shared Folders (TSP ports).
11) Нажмите кнопку Готово.

Повторите действия указанные в пунктах с 4) по 11) для типа протокола UDP.
В 6) пункте инструкции установите переключатель на Протокол UDP, в 7) пункте впишите порты 137, 138, а имя задайте Shared Folders (UDP ports).

III. Отключение запроса пароля.

1) Щелкните правой кнопкой мыши на значок сетевого подключения на панели задачи и выберите пункт Центр управления сетями и общим доступом.
2) Просмотрите Ваши активные сети. Тип сетевого размещения используемого для разрешения взаимодействия с другими компьютерами должен быть установлен как Домашняя сеть. Для смены типа сетевого размещения на Домашняя сеть:
2.1) Нажмите мышкой по имеющейся у Вас надписи Сеть предприятия или Общественная сеть
2.2) В открывшемся окне выберите Домашняя сеть и нажмите кнопку Закрыть .
Если тип Вашего сетевого размещения уже установлен как Домашняя сеть, то Вам менять его не нужно.
3) Нажмите на ссылку Изменить дополнительные параметры общего доступа
4) В графе Общий доступ с парольной защитой установите переключатель в значение Отключить общий доступ с парольной защитой.
5) Нажмите на кнопку Сохранить изменения и закройте окно настроек.

Предоставление общего доступа к файлам и папкам, находящимся в Общих папках без использования домашней группы.

1) Нажмите кнопку Пуск и откройте Панель управления.
2) Установите режим просмотра "Крупные значки" и запустите компонент Центр управления сетями и общим доступом.
3) Щелкните Изменить дополнительные параметры общего доступа в левой области
4) Установите переключатели в следующие параметры:

- Включить сетевое обнаружение.
- Включить общий доступ к файлам и принтерам
- Включить общий доступ, чтобы сетевые пользователи могли читать и записывать файлы в общих папках (делает доступными папки "Общие документы", "Общая музыка", "Общие рисунки" и "Общее видео")
- Отключить общий доступ с парольной защитой

Примечания

Для включения общего доступа с парольной защитой, необходимо иметь две совершенно одинаковые учетные записи и пароли пользователя на обоих компьютерах.
Если имя пользователя и пароль, с которыми выполнен вход в систему, отличаются от зарегистрированного на другом компьютере, к которому осуществляется попытка доступа, возможно, будет запрошена информация для входа в систему.
Если на другом компьютере разрешен доступ всем в сети, автоматическое подключение будет предоставлено с правами гостя. Это означает, что доступ будет предоставлен только к файлам в общих папках.

Если при предоставлении общего доступа у Вас возникают проблемы, то Вы можете использовать средство устранения неполадок для автоматического поиска и устранения некоторых распространенных проблем.

1) Запустите командную строку с правами администратора или нажмите Win+R
1.1) Откройте Пуск -> Все программы -> Стандартные
1.2) Щелкните правой кнопкой мыши на Командная строка и выберите Запуск от имени администратора
2) Введите следующую команду и нажмите Enter:

3) Нажмите кнопку Далее и следуйте инструкциям средства устранения неполадок.

14. Автоматическая загрузка последних версий драйверов и реалистичных значков для подключенных устройств.

1) Откройте Пуск -> Панель управления -> Устройства и принтеры.
2) Щелкните правой кнопкой мыши имя компьютера и выберите пункт Параметры установки устройств.
3) Выберите пункт Да, делать это автоматически (рекомендуется) и нажмите кнопку Сохранить изменения.

Windows сохранит фирменные значки производителя для подключенных Вами устройств в папку:

%LOCALAPPDATA%\Microsoft\Device Metadata\dmrccache\

Внутри папки, в соответствии с вашим регионом (например, en-US), должны располагаться отдельные папки содержащие в названии GUID для каждого устройства с соответствующими метаданными. Иконка будет находится в папке DeviceInformation каждого устройства.

15. Вычисление сайтов посещаемых пользователем в приватном режиме просмотра браузера.

Приватный режим посещения сайтов в браузерах не сохраняет на компьютере куки-файлы, временные файлы Интернета, журнал просмотра и другие сведения.
Но не смотря на это вся информация о посещенных сайтах в интернете и присутствующих на данном сайте компонентах сохраняется в кэше сопоставления имен клиентов.
В нем хранится такая информация, как IP адрес и имя домена, на основе которых можно вычислить адрес посещаемого сайта. Для просмотра данного кэша не требуются права администратора на компьютере.

Для отображения кэша сопоставления имен клиентов выполните следующее:

1) Запустите командную строку нажмите кнопку Пуск и выберите Все программы, Стандартные и Командная строка (Win+R -> cmd -> OK) .
2) Введите команду и нажмите Enter:

Чтобы была пауза после отображения каждого экрана выходных данных команды, введите:

3) Если Вам необходимо сохранить данную информацию в текстовый файл выполните команду:

Данные будут сохранены в файл DNScache.txt на диск C: .

Для сбрасывания данных кэша сопоставления имен клиентов выполните следующее:

1) Запустите командную строку нажмите кнопку Пуск и выберите Все программы, Стандартные и Командная строка (Win+R -> cmd -> OK) .
2) Введите команду и нажмите Enter::

16. Месторасположение кэша браузера и его просмотр.

Каждый браузер по умолчанию сохраняет содержимое веб-страниц (изображения, flash-ролики, видео, аудио и др.), просмотренных вами на жёсткий диск в кэш, во избежание их повторной загрузки.

Microsoft's Internet Explorer

Кэш для данного браузера хранится в отдельных профайлах для каждого пользователя по адресу:

С:\Documents and Settings\Имя_пользователя\Local Settings\Temporary Internet Files\Content.IE5\

Для открытия данной папки Вам необходимо задать права доступа к ней, для этого воспользуйтесь советом Администрирование: 1. Получение полного доступа к файлу или папке.

Внутри директории \Content.IE5 содержаться дополнительные папки со "случайно" сгенерированными именами, в которых храниться информация о посещение того или иного веб ресурса, а в файле index.dat, в котором и содержится интересующая нас информация. Файл index.dat для просмотра можно открыть программой Index.dat Analyzer.
Для сканирования содержимого index.dat файлов нажмите кнопку Quick rescan for index.dat files.

Также Вы можете открыть Свойства обозревателя, в графе История просмотра нажать Параметры, а затем кнопку Показать файлы.

Mozilla Firefox

Mozilla Firefox использует особый алгоритм кэширования страниц. Папка, в которой храниться интересующая Вас информация:

C:\Documents and Settings\Имя_пользователя\AppData\Local\Mozilla\Firefox\Profiles\Имя_профиля\Cache

Для открытия данной папки Вам необходимо задать права доступа к ней, для этого воспользуйтесь советом Администрирование: 1. Получение полного доступа к файлу или папке.

Для просмотра кэша: Откройте новую вкладку, наберите в адресной строке about:cache?device=disk и нажмите Enter.

Opera

Кэш для данного браузера хранится в отдельных подпапках по адресу:

C:\Documents and Settings\Имя_пользователя\AppData\Local\Opera\Opera\cache

Для просмотра кэша: Откройте новую вкладку, наберите в адресной строке opera:cache и нажмите Enter.

Также Вы можете скачать и использовать для просмотра кэша браузеров Internet Explorer, Mozilla Firefox или Opera программу Cache View Plus. Данная программа позволяет Вам напрямую (в режиме предпросмотра) увидеть файлы находящиеся в кэше файлы в соответствии с их типом: изображения, видео, звуки, swf-файлы.

17. Отключение автоматической отправки сведений на сервера корпорации Microsoft, собранных программой улучшения качества программного обеспечения.

В корпорации Microsoft существует программа улучшения качества программного обеспечения, которая собирает сведения о продуктах Microsoft, а также ограниченные данные о произведенных независимыми компаниями приложениях, которые взаимодействуют с продуктами Microsoft и отсылает их на сервера Microsoft.

Более подробно о ней Вы можете прочитать на сайте: http://www.microsoft.com/products/ceip/ru-ru/default.mspx

Если Вы не желаете участвовать в данной программе, то сделайте следующее:

1) В строке поиска меню Пуск введите команду gpedit.msc и нажмите Enter.
2) Перейдите до папки:

3) Щелкните правой кнопкой мыши на Отключить программу по улучшению качества программного обеспечения Windows и выберите пункт Изменить.
4) Установите переключатель в значение Включить и нажмите кнопку OK.

18. Добавление индикатора сетевой активности на панель задач.

Значок Сеть в области уведомлений на панели задач при наведении на него отображает всего лишь текущее подключение и не мигает при наличии сетевой активности.
Если Вы желаете добавить значок в область уведомлений, позволяющий увидеть размер входящего и исходящего траффика, а также просмотреть статистику подключения, то Вы можете скачать небольшую бесплатную программу Network Activity Indicator, максимально приближенную к интерфейсу Windows.

Если Вы желаете заменить стандартную иконку Сеть на иконку данной программы, то проделайте следующее:

1) Зайдите на сайт: http://www.itsamples.com/network-activity-indicator.html
2) Скачайте программу Network Activity Indicator и язык интерфейса к ней.
3) Распакуйте программу и язык интерфейса для программы в одну и ту же папку.
4) Откройте папку, куда Вы распаковали программу и запустите файл NetworkIndicator.exe
5) Нажмите правой кнопкой мыши на иконку программы и выберите пункт Настройки
6) Установите флажки:
Отображать UDP пакеты
Отображать ICMP пакеты
Запускать при старте Windows
Показывать неактивную иконку если интерфейс отсоединен.
Использовать иконки Vista
7) Нажмите кнопку Применить.
8) Щелкните правой кнопкой мыши на панели задач и выберите пункт Свойства.
9) В графе Область уведомлений щелкните на кнопку Настроить...
10) Нажмите на ссылку Включить или выключить системные значки.
11) Напротив значка Сеть из ниспадающего списка выберите Выкл.
12) Нажмите ОК и еще раз ОК.

19. Создание ярлыка для запуска Internet Explorer в режиме приватного просмотра.

1) Щелкните правой кнопкой мыши на свободном месте рабочего стола, и выберите Создать -> Ярлык.

2) Для 32-битных Windows 7:

2.1) В поле Укажите расположение объекта введите:

2.2) Переходите к пункту 4.

3) Для 64-битных Windows 7:

3.1) Чтобы использовать 32-битную версию Internet Explorer, в поле Укажите расположение объекта введите:

3.2) Чтобы использовать 64-битную версию Internet Explorer, в поле Укажите расположение объекта введите:

4) Нажмите кнопку Далее.
5) В поле Введите имя ярлыка напишите Internet Explorer (просмотр InPrivate) и нажмите кнопку Готово. (Примечание: Вы можете указать любое имя для ярлыка.)
6) Теперь Вы можете переместить созданный Вами ярлык в любое удобное для Вас место. Например, Вы можете закрепить ярлык в панели задач.

20. Создание ярлыка в папке Компьютер для просмотра часто используемого ftp как одного из дисков.

1) В проводнике или в меню Пуск щелкните правой кнопкой мыши на Компьютер
2) Выберите в списке пункт Подключить сетевой диск
3) Нажмите ссылку Подключение к сайту, на котором можно хранить документы и изображения.
4) В открывшем окне нажмите кнопку Далее, а затем снова кнопку Далее.
5) В текстовом поле введите имя ftp-сервера и нажмите кнопку Далее.

Например: ftp://ftp.mozilla.org/pub/firefox/

6) Уберите флажок "Анонимный вход" и введите имя пользователя и нажмите кнопку Далее.
Если для входа не нужна идентификация пользователя, то оставьте флажок "Анонимный вход" установленным.
7) Введите имя для отображаемого ярлыка в проводнике и нажмите Далее.
8) Для завершения создания ярлыка нажмите кнопку Готово.

21. Быстрая очистка истории обзора Internet Explorer при помощи специально созданного ярлыка.

Если Вы используете браузер Internet Explorer, то для очистки истории обзора(временных файлов, кэша, паролей и др.) Вы делаете следующее:

1) В Internet Explorer открываете Свойства обозревателя.
Если у Вас включена Строка меню, то данный пункт расположен в меню Сервис, если Строка меню отключена, то нажимаете на значок шестеренки.
2) На вкладке Общие в графе История просмотра нажимаете кнопку Удалить... .
3) Устанавливаете необходимые флажки и нажимаете кнопку Удалить.

Чтобы ускорить данный процесс Вы можете создать специальный ярлык для очистки определенных данных из истории просмотра Internet Explorer на рабочем столе.

1) Щелкните по рабочему столу правой кнопкой мыши, выберите команды "Создать" - "Ярлык".
2) В текстовом поле введите необходимую Вам команду для запуска.

Удаление истории посещений (журнала):

Удаление Cookies:

Удаление временных файлов/веб страниц:

Удаление данных веб-форм:

Удаление паролей:

Полное удаление всей истории:

Полное удаление всей истории и данных надстроек браузера:

3) Нажмите кнопку Далее
4) Укажите имя для ярлыка и нажмите Готово.

Так же можно комбинировать номера, суммируя их.
Например:

Это удалит временные файлы (+8) и журнал посещений (+1).


1. Смена поиска по умолчанию в Mozilla Firefox.

Бывает, что программы без вашего спроса меняют в Firefox поисковик по умолчанию на свой. Чтобы его заменить сделайте следующее:

1) Пишете в адресной строке Firefox такой адрес: "about:config", без кавычек
2) Подтверждаете, что будете осторожны, получаете доступ к многочисленным настройкам Firefox и находите среди них параметр keyword.url
3) Меняете его значение (без кавычек) на:

"http://www.google.com/search?&q=" - Google.Com
"http://yandex.ru/yandsearch?text=" - Yandex.Ru
"http://www.bing.com/search?q=" - Bing.Com

Назад на страницу раздела Сети (Интернет и Локальная).


2. Добавление ссылки Поиск в Интернете при использовании поиска в меню Пуск.

В Windows Vista была предложена новая функция. При наборе текста в поле поиска меню Пуск, прямо над окном поиска появлялась ссылка "Поиск в Интернете". При её нажатии набранный текст посылался напрямую в браузер, используемый по умолчанию для поиска.
В Windows 7 данная функция по умолчанию отключена. Microsoft удалила его из меню "Пуск". Чтобы включить "Поиск в Интернете" через меню «Пуск» необходимо проделать следующие действия.

1) Откройте диалоговое меню Выполнить (Win+R)
2) Введите gpedit.msc.
3) Перейдите в раздел Конфигурация пользователя -> Административные шаблоны -> «Меню «Пуск» и панель задач».
4) Нажмите правой кнопкой мыши на строке Добавить ссылку «Поиск в интернете» в меню «Пуск» и выберете пункт «Изменить».
5) В открывшемся окне установите переключатель в значение «Включить».
6) Нажмите «OK» и закройте Редактор локальной групповой политики.

Также Вы можете создать reg-файл, выполняющий данную функцию или скачать и применить уже готовый. После применения перезайдите в систему или перезагрузите компьютер.

Готовый файл: AddSearchInternetLinkInStartMenu.zip

Назад на страницу раздела Сети (Интернет и Локальная).


3. Объединение или удаление сетевых размещений (подключений).

1) Щелкните правой кнопкой мыши на значок Сеть на панели задач и выберите пункт Центр управления сетями и общим доступом
2) Если у Вас отсутствует данный значок, то нажмите комбинацию клавиш Win+R -> введите команду

и нажмите OK
3) Нажмите на значке (дом, офис или скамейка - зависит от типа выбранной Вами сети)
4) В открывшемся окне Настройка свойств сети нажмите на ссылку Объединение или удаление сетевых размещений.
5) Выделите сетевое размещение или несколько сетевых размещений, которые Вы хотите слить в единое сетевое размещение или которые Вы хотите удалить.
Используемые подключения нельзя удалить или слить, для их слияния или удаления Вам необходимо отключится от сети.
6) Нажмите кнопку Слияние или Удаление, во всплывшем окне нажмите кнопку Да.

Назад на страницу раздела Сети (Интернет и Локальная).


4. Автоматическое подключение к ADSL-интернету при запуске Windows.

1) Откройте Панель управления\Все элементы панели управления\Центр управления сетями и общим доступом.
2) Нажмите ссылку Изменение параметров адаптера.
3) Щелкните правой кнопкой мыши на Вашем ADSL-соединении и выберите пункт Свойства.
4) Перейдите на вкладку Параметры и снимите флажки Отображать ход подключения, Запрашивать имя, пароль, сертификат и т.д..
5) Нажмите кнопку ОК.
6) Щелкните правой кнопкой мыши на Вашем ADSL-соединении и выберите пункт Создать ярлык.
7) В диалоговом окне нажмите Да и у Вас на рабочем столе появится ярлык ADSL-соединения.
8) Откройте Пуск -> Все программы .
9) Нажмите правой кнопкой мыши на Автозагрузка и выберите пункт Открыть.
10) Переместите ярлык созданного Вами ADSL-соединения с рабочего стола в открывшуюся папку Автозагрузка.

Назад на страницу раздела Сети (Интернет и Локальная).


5. Автоматическое VPN-подключение к интернет при запуске Windows.

Вариант 1

Вы можете добавить задачу в Планировщик заданий.
1) Откройте планировщик задний
1.1) Откройте меню Пуск -> Панель управления -> Администрирование -> Планировщик заданий или в строке поиска меню Пуск введите taskschd.msc и нажмите Enter.
2) Нажмите Создать задачу...
3) На вкладке Общие введите в поле Имя - Имя подключения
4) Перейдите на вкладку Триггеры и нажмите кнопку Создать...
5) Выберите в ниспадающем списке напротив пункта Начать задачу: значение При входе в систему и нажмите ОК.
6) Перейдите на вкладку Действия и нажмите кнопку Создать...
7) Выберите в ниспадающем списке напротив пункта Действие: значение Запуск программы.
8) Введите в поле Программа или сценарий: команду rasdial "имя подключения" login password
вместо "имя подключения" - укажите название Вашего подключения к интернету
вместо login - укажите Ваш логин(имя пользователя) для подключения к интернету
вместо password - укажите Ваш пароль для подключения к интернету
9) Нажмите кнопку ОК.
10) Перейдите на вкладку Параметры
11) Поставьте флажки напротив:
Немедленно запускать задачу, если пропущен плановый запуск
При сбое выполнения перезапускать через 1 мин.
Количество попыток перезапуска 99.
12) Уберите флажок Останавливать задачу выполняемую дольше и нажмите ОК.

Вариант 2

1) Скачайте и распакуйте в любую папку файл connect.zip, содержащий скрипт для соединения с интернетом.
2) Щелкните правой кнопкой мыши на файле connect.bat и нажмите Изменить
3) Измените название подключения, логин(имя пользователя) и пароль в соответствии с Вашими настройками и сохраните файл.
4) Скачайте архив со скриптом скрытого запуска:
hs_exec.zip - для использования командного bat-файла, содержащего скрипт запуска
hide_programm.zip - для использования яваскрипта, содержащего скрипт запуска
5) Распакуйте архив в ту же самую папку, где у Вас находится файл connect.bat
6) Добавьте в папку автозагрузки (Пуск -> Все программы ->Автозагрузка) ярлык (не сам файл скрипта) для hide_programm.js в случае использования яваскрипта, либо для load.bat в случае использования командного bat-файла.

Вариант 3

1) Создайте командный bat-файл (Например: Connect.bat) следующего содержания:

вместо "имя подключения" - укажите название вашего подключения к интернету
вместо login - укажите Ваш логин(имя пользователя) для подключения к интернету
вместо password - укажите Ваш пароль для подключения к интернету

2) Добавьте ярлык (не сам файл скрипта) на файл connect.bat в папку автозагрузки (Пуск -> Все программы ->Автозагрузка)

Внимание: "имя подключения" должно быть на английском иначе может быть ошибка 623.

Назад на страницу раздела Сети (Интернет и Локальная).


6. Отключение запроса пароля при использовании папки общего доступа.

Даже если Вы не устанавливали пароль для папки общего доступа, система может у Вас его запросить.

Для отключения данного запроса сделайте следующее:

1) Откройте Панель управления\Все элементы панели управления\Центр управления сетями и общим доступом
2) Нажмите на ссылку Изменить дополнительные параметры общего доступа
3) В графе Общий доступ с парольной защитой установите переключатель на значение Отключить общий доступ с парольной защитой.

Назад на страницу раздела Сети (Интернет и Локальная).


7. Просмотр исходного кода любой страницы в интернете.

Очень многие страницы в интернете любят скрывать свой код или блокировать копирование. Но это легко можно решить. Данный метод позволяет узнать любой код зашифрованный криптографами или измененный обфускаторами.

В Firefox

Установите расширение Web Developer.
Затем в меню Web Developer -> Код -> Сгенерированный код.
Если исходный код был зашифрован, то промотайте вниз и увидите реальный код. Если код не был зашифрован, то увидете его сразу.
Вы можете сохранить его либо скопировав в буфер обмена и вставив в нужное место, либо Файл -> Сохранить страницу как -> page.htm

В Internet Explorer

Меню Сервис -> Средства разработчика
Можете нажать на стрелочку и выбрать нужный элемент на странице и увидите его код или нажать на значок дискетки и сохранить исходный код в текстовый файл, а затем скопировать из него в html.

Назад на страницу раздела Сети (Интернет и Локальная).


8. Восстановление пропавшего звука в интернет браузерах.

1) Проверьте уровень громкости в самом Flash плеере.

2) Удалите полностью, а затем поставьте заново:
2.1) Adobe Flash Player. Uninstall: http://kb2.adobe.com/cps/141/tn_14157.html Install: http://get.adobe.com/flashplayer/otherversions/
2.2) Кодеки в системе (K-lite codeck pack, Shark007 Windows 7 Codecs или др.)
2.3) Браузеры.
2.4) Драйвера звуковой карты

3) В Internet Explorer, проверьте стоит ли у Вас флажок в пункте "Воспроизводить звуки на веб-страницах" Сервис -> Свойства обозревателя -> Дополнительно -> Раздел Мультимедиа.

4) Проверьте, установлен ли запуск службы Windows Audio Автоматически.
Панель Управления -> Администрирование -> Службы -> двойной щелчок на Windows Audio -> Тип запуска: Автоматически
Затем нажмите Остановить, потом Запустить.

5) Запустите редактор реестра (Win+R -> regedit)
Перейдите к ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32
Проверьте значение строкового(String) параметра wavemapper. Его значение должно быть msacm32.drv. Если данного параметра нет, то создайте его.

Назад на страницу раздела Сети (Интернет и Локальная).


9. Сохранение интернет соединения при переключении между пользователями.

При создании нового интернет подключения поставьте флажок на "Разрешить использовать это подключение другим пользователям".
Установление галочки в уже созданном подключении может работать некорректно в некоторых VPN соединениях.

По умолчанию при переключении между пользователями Windows сбрасывает dial-up и некоторые виды других соединений. Можно изменить это поведение следующим образом.

1) Запускаете редактор реестра (Win+R -> Regedit -> OK)
2) Открываете ветку реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters
3) Щелкните правой кнопкой мыши на Dword-параметр KeepRASConnections, выберите Изменить и присвойте параметру значение 1
4) Закройте Regedit и завершите текущий сеанс для вступления изменений в силу

Если Вы хотите, чтобы соединения сбрасывались, то используйте значение 0 или удалите этот параметр.

Назад на страницу раздела Сети (Интернет и Локальная).


10. Перемещение HOST, LMHOST и других файлов из Windows\System32\drivers\etc в другое место.

Если вы хотите переместить файлы из Windows\System32\drivers\etc в другое место (например, по соображениям безопасности) из папки Windows\System32\drivers\etc, то для этого Вам необходимо выполнить следующее:
1) Скопируйте файлы в новое место
2) Запустите редактор реестра (Win+R -> regedit -> Ok).
3) Откройте ветку HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
4) Измените значение параметра DataBasePath на новый путь к папке
5) Перезагрузитесь и удалите файлы из %SystemRoot%\System32\drivers\etc

Назад на страницу раздела Сети (Интернет и Локальная).


11. Поиск на веб-сайтах из Проводника (Windows Explorer).

Windows 7 теперь позволяет вести поиск на веб-сайтах из Windows Explorer (Проводника). Данный поиск основан на спецификации OpenSearch.
Чтобы добавить в Windows провайдер OpenSearch, нужно предоставить файл определения в формате OSDX. Этот формат позволяет указывать описательную информацию наряду с необходимыми URL и другими параметрами.
Эти файлы сопоставляются с Windows Explorer и добавляются в папку Searches: C:\Users\{USER}\Searches.
Чтобы создать файл OSDX, нужно предоставить URL для вызова и имя провайдера.

1) Откройте текстовый редактор. (Например, Блокнот)
2) Скопируйте и вставьте в него следующий текст:

3) В меню программы нажмите Файл и выберите пункт Сохранить.
3.1) В открывшемся окне укажите место сохранения файла.
3.2) Укажите имя файла и расширение .osdx и обязательно в кодировке UTF-8 (Например: Сохраните его как Bing.osdx)
3.3) Выберите тип файла: Все файлы (*.*).

Дважды щелкните по получившемуся osdx-файлу для внесения дополнений в систему.

Чтобы искать на добавленном Вами веб-сайте из Проводника:

1) Запустите Проводник (Explorer)
2) Откройте папку C:\Users\{USER}\Searches, для чего просто введите %UserProfile%\Searches и нажмите Enter.
3) Выберите установленный Вами поиск, в строке поиска укажите значение для поиска и нажмите Enter.
4) Если Вы хотите, чтобы при нажатии на результат поиска в проводнике показывались найденная страница, то нажмите на значок включения Области предварительного просмотра (находится, в верхней правой части экрана перед значком вопроса)

Вы можете скачать уже готовые файлы определения (.osdx) по ссылке: OSDX.zip

Назад на страницу раздела Сети (Интернет и Локальная).


12. Смена динамического IP-адреса, для обхода времени ожидания на файлообменниках.

Многие файлообменники и программы для скачивания разделяют обычных пользователей по IP адресу. Если Вы не используйте прокси-сервера и при каждом подключении к интернету провайдер дает Вам новый IP адрес, то это означает что у Вас динамический адрес и Вы можете создать командный файл разрывал бы связь и снова соединялся с интернетом. В итоге у вас будет новый адрес и для файлообменника Вы будете уже новым клиентом.
Данная возможность позволит Вам обойти ограничение по времени и качать без ожиданий.

Инструкция по созданию командного файла:

1) Откройте любой текстовый редактор (Например, Блокнот).
2) Откройте меню Пуск -> Все программы -> Стандартные -> Блокнот (или нажмите сочетание клавиш Win+R -> введите notepad -> нажмите ОК)
3) Скопируйте необходимый Вам код в окно программы Блокнот.
4) В меню программы нажмите Файл и выберите пункт Сохранить.
В открывшемся окне:
5) Укажите место сохранения файла.
6) Укажите имя файла и расширение .bat (Например: reconnect.bat)
7) Выберите тип файла: Все файлы (*.*).
8) Для смены IP-адреса запустите созданный Вами командный файл просто щелкнув на нем.

Вариант 1. Внешний динамический адрес, прямое подключение по локальной сети.

Вариант 2. Внешний динамический адрес, подключение через модем или через USB-ADSL.

Способ 1.

Чтобы узнать имя требуемого интерфейса:
1) Запустите командную строку от имени администратора (Win+R -> cmd -> OK)
2) Введите указанную ниже команду и нажмите Enter:

Способ 2.

Вариант 3. Внешний динамический адрес, подключение через LAN-ADSL или через роутеры.

Способ 1.

где:
192.168.1.1 - Ваш IP-адрес (модема)
LOGIN - логин к модему
PASS - пароль к модему

Способ 2.

Скачиваете и устанавливаете программу Router Control, а файл reconnect.bat создаете в папке программы.

Назад на страницу раздела Сети (Интернет и Локальная).


13. Включение и настройка общего доступа к файлам и папкам.

В Windows 7 папка «Общее» заменена на отдельные общие папки для каждого типа файлов: Общие документы, Общие рисунки, Общая музыка или Общее видео. В Проводнике Вы можете попасть в них через Библиотеки, открыв папку Документы, Рисунки, Музыка или Видео, а затем папку Общие документы, Общие рисунки, Общая музыка или Общее видео.

Предоставление общего доступа к файлам или папкам, находящимся в Общих папках с использованием домашней группы.

1) Нажмите кнопку Пуск и откройте Панель управления.
2) Установите режим просмотра "Крупные значки" и запустите компонент Центр управления сетями и общим доступом.
3) Щелкните Выбор домашней группы и параметров общего доступа.
4) Нажмите на кнопку Создать домашнюю группу
5) Выберите элементы, к которым нужно предоставить общий доступ и нажмите кнопку Далее.
6) В окне с паролем для добавления других компьютеров к домашней группе нажмите кнопку Готово.
7) Нажмите на ссылку Изменить дополнительные параметры общего доступа
8) В графе Общий доступ с парольной защитой установите переключатель в значение Отключить общий доступ с парольной защитой.
9) Нажмите на кнопку Сохранить изменения и закройте окно настроек.

Предоставление общего доступа к любым файлам или папкам без перемещения их в Общие папки с использованием домашней группы.

I. Настройка конкретных папок или файла для общего доступа.

1) Перейдите в место размещения файла или папки, к которым необходимо предоставить общий доступ.
2) Щелкните файл или папку правой кнопкой мыши и выберите пункт Общий доступ –> Конкретные пользователи
3) Введите имя или нажмите стрелку вниз и в всплывающем меню выберите Все, а затем нажмите кнопку Добавить
4) Напротив имени Все установите необходимый Вам Уровень разрешений:
Чтение - Пользователи могут открывать файл, но им не разрешается изменять или удалять его.
Чтение и запись - Пользователи могут открывать, изменять и удалять файл.
5) Нажмите кнопку Общий доступ. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
6) Нажмите правой кнопкой мышки на папке и выберите Копировать ссылку. Ваша ссылка будет скопирована в буфер обмена. Теперь вставьте ссылку в сообщение электронной почты, мгновенное сообщение или другую программу, или же сохраните в блокноте.
7) По завершении нажмите кнопку Готово.

II. Настройка портов для общего доступа.

1) Откройте Пуск -> Панель управления -> Система и безопасность и запустите Брандмауэр Windows.
2) Нажмите ссылку Дополнительные параметры, чтобы добавить новые правила для Firewall.
3) В открывшемся окне, в меню слева, выберите Правила для входящих подключений
4) В меню справа нажмите кнопку Создать правило….
5) В открывшемся окне, установите переключатель на тип правила Для порта и нажмите кнопку Далее.
6) Установите переключатель на Протокол TCP.
7) В текстовое поле напротив Определенные локальные порты: впишите через запятую 139, 445 и нажмите кнопку Далее.
8) В следующем окне оставьте установленное по умолчанию значение Разрешить подключение и нажмите кнопку Далее.
9) В окне выбора профилей снова нажмите кнопку Далее.
10) Введите имя и описание Вашего правила. Например: Shared Folders (TSP ports).
11) Нажмите кнопку Готово.

Повторите действия указанные в пунктах с 4) по 11) для типа протокола UDP.
В 6) пункте инструкции установите переключатель на Протокол UDP, в 7) пункте впишите порты 137, 138, а имя задайте Shared Folders (UDP ports).

III. Отключение запроса пароля.

1) Щелкните правой кнопкой мыши на значок сетевого подключения на панели задачи и выберите пункт Центр управления сетями и общим доступом.
2) Просмотрите Ваши активные сети. Тип сетевого размещения используемого для разрешения взаимодействия с другими компьютерами должен быть установлен как Домашняя сеть. Для смены типа сетевого размещения на Домашняя сеть:
2.1) Нажмите мышкой по имеющейся у Вас надписи Сеть предприятия или Общественная сеть
2.2) В открывшемся окне выберите Домашняя сеть и нажмите кнопку Закрыть .
Если тип Вашего сетевого размещения уже установлен как Домашняя сеть, то Вам менять его не нужно.
3) Нажмите на ссылку Изменить дополнительные параметры общего доступа
4) В графе Общий доступ с парольной защитой установите переключатель в значение Отключить общий доступ с парольной защитой.
5) Нажмите на кнопку Сохранить изменения и закройте окно настроек.

Предоставление общего доступа к файлам и папкам, находящимся в Общих папках без использования домашней группы.

1) Нажмите кнопку Пуск и откройте Панель управления.
2) Установите режим просмотра "Крупные значки" и запустите компонент Центр управления сетями и общим доступом.
3) Щелкните Изменить дополнительные параметры общего доступа в левой области
4) Установите переключатели в следующие параметры:

- Включить сетевое обнаружение.
- Включить общий доступ к файлам и принтерам
- Включить общий доступ, чтобы сетевые пользователи могли читать и записывать файлы в общих папках (делает доступными папки "Общие документы", "Общая музыка", "Общие рисунки" и "Общее видео")
- Отключить общий доступ с парольной защитой

Примечания

Для включения общего доступа с парольной защитой, необходимо иметь две совершенно одинаковые учетные записи и пароли пользователя на обоих компьютерах.
Если имя пользователя и пароль, с которыми выполнен вход в систему, отличаются от зарегистрированного на другом компьютере, к которому осуществляется попытка доступа, возможно, будет запрошена информация для входа в систему.
Если на другом компьютере разрешен доступ всем в сети, автоматическое подключение будет предоставлено с правами гостя. Это означает, что доступ будет предоставлен только к файлам в общих папках.

Если при предоставлении общего доступа у Вас возникают проблемы, то Вы можете использовать средство устранения неполадок для автоматического поиска и устранения некоторых распространенных проблем.

1) Запустите командную строку с правами администратора или нажмите Win+R
1.1) Откройте Пуск -> Все программы -> Стандартные
1.2) Щелкните правой кнопкой мыши на Командная строка и выберите Запуск от имени администратора
2) Введите следующую команду и нажмите Enter:

3) Нажмите кнопку Далее и следуйте инструкциям средства устранения неполадок.

Назад на страницу раздела Сети (Интернет и Локальная).


14. Автоматическая загрузка последних версий драйверов и реалистичных значков для подключенных устройств.

1) Откройте Пуск -> Панель управления -> Устройства и принтеры.
2) Щелкните правой кнопкой мыши имя компьютера и выберите пункт Параметры установки устройств.
3) Выберите пункт Да, делать это автоматически (рекомендуется) и нажмите кнопку Сохранить изменения.

Windows сохранит фирменные значки производителя для подключенных Вами устройств в папку:

%LOCALAPPDATA%\Microsoft\Device Metadata\dmrccache\

Внутри папки, в соответствии с вашим регионом (например, en-US), должны располагаться отдельные папки содержащие в названии GUID для каждого устройства с соответствующими метаданными. Иконка будет находится в папке DeviceInformation каждого устройства.

Назад на страницу раздела Сети (Интернет и Локальная).


15. Вычисление сайтов посещаемых пользователем в приватном режиме просмотра браузера.

Приватный режим посещения сайтов в браузерах не сохраняет на компьютере куки-файлы, временные файлы Интернета, журнал просмотра и другие сведения.
Но не смотря на это вся информация о посещенных сайтах в интернете и присутствующих на данном сайте компонентах сохраняется в кэше сопоставления имен клиентов.
В нем хранится такая информация, как IP адрес и имя домена, на основе которых можно вычислить адрес посещаемого сайта. Для просмотра данного кэша не требуются права администратора на компьютере.

Для отображения кэша сопоставления имен клиентов выполните следующее:

1) Запустите командную строку нажмите кнопку Пуск и выберите Все программы, Стандартные и Командная строка (Win+R -> cmd -> OK) .
2) Введите команду и нажмите Enter:

Чтобы была пауза после отображения каждого экрана выходных данных команды, введите:

3) Если Вам необходимо сохранить данную информацию в текстовый файл выполните команду:

Данные будут сохранены в файл DNScache.txt на диск C: .

Для сбрасывания данных кэша сопоставления имен клиентов выполните следующее:

1) Запустите командную строку нажмите кнопку Пуск и выберите Все программы, Стандартные и Командная строка (Win+R -> cmd -> OK) .
2) Введите команду и нажмите Enter::

Назад на страницу раздела Сети (Интернет и Локальная).


16. Месторасположение кэша браузера и его просмотр.

Каждый браузер по умолчанию сохраняет содержимое веб-страниц (изображения, flash-ролики, видео, аудио и др.), просмотренных вами на жёсткий диск в кэш, во избежание их повторной загрузки.

Microsoft's Internet Explorer

Кэш для данного браузера хранится в отдельных профайлах для каждого пользователя по адресу:

С:\Documents and Settings\Имя_пользователя\Local Settings\Temporary Internet Files\Content.IE5\

Для открытия данной папки Вам необходимо задать права доступа к ней, для этого воспользуйтесь советом Администрирование: 1. Получение полного доступа к файлу или папке.

Внутри директории \Content.IE5 содержаться дополнительные папки со "случайно" сгенерированными именами, в которых храниться информация о посещение того или иного веб ресурса, а в файле index.dat, в котором и содержится интересующая нас информация. Файл index.dat для просмотра можно открыть программой Index.dat Analyzer.
Для сканирования содержимого index.dat файлов нажмите кнопку Quick rescan for index.dat files.

Также Вы можете открыть Свойства обозревателя, в графе История просмотра нажать Параметры, а затем кнопку Показать файлы.

Mozilla Firefox

Mozilla Firefox использует особый алгоритм кэширования страниц. Папка, в которой храниться интересующая Вас информация:

C:\Documents and Settings\Имя_пользователя\AppData\Local\Mozilla\Firefox\Profiles\Имя_профиля\Cache

Для открытия данной папки Вам необходимо задать права доступа к ней, для этого воспользуйтесь советом Администрирование: 1. Получение полного доступа к файлу или папке.

Для просмотра кэша: Откройте новую вкладку, наберите в адресной строке about:cache?device=disk и нажмите Enter.

Opera

Кэш для данного браузера хранится в отдельных подпапках по адресу:

C:\Documents and Settings\Имя_пользователя\AppData\Local\Opera\Opera\cache

Для просмотра кэша: Откройте новую вкладку, наберите в адресной строке opera:cache и нажмите Enter.

Также Вы можете скачать и использовать для просмотра кэша браузеров Internet Explorer, Mozilla Firefox или Opera программу Cache View Plus. Данная программа позволяет Вам напрямую (в режиме предпросмотра) увидеть файлы находящиеся в кэше файлы в соответствии с их типом: изображения, видео, звуки, swf-файлы.

Назад на страницу раздела Сети (Интернет и Локальная).


17. Отключение автоматической отправки сведений на сервера корпорации Microsoft, собранных программой улучшения качества программного обеспечения.

В корпорации Microsoft существует программа улучшения качества программного обеспечения, которая собирает сведения о продуктах Microsoft, а также ограниченные данные о произведенных независимыми компаниями приложениях, которые взаимодействуют с продуктами Microsoft и отсылает их на сервера Microsoft.

Более подробно о ней Вы можете прочитать на сайте: http://www.microsoft.com/products/ceip/ru-ru/default.mspx

Если Вы не желаете участвовать в данной программе, то сделайте следующее:

1) В строке поиска меню Пуск введите команду gpedit.msc и нажмите Enter.
2) Перейдите до папки:

3) Щелкните правой кнопкой мыши на Отключить программу по улучшению качества программного обеспечения Windows и выберите пункт Изменить.
4) Установите переключатель в значение Включить и нажмите кнопку OK.

Назад на страницу раздела Сети (Интернет и Локальная).


18. Добавление индикатора сетевой активности на панель задач.

Значок Сеть в области уведомлений на панели задач при наведении на него отображает всего лишь текущее подключение и не мигает при наличии сетевой активности.
Если Вы желаете добавить значок в область уведомлений, позволяющий увидеть размер входящего и исходящего траффика, а также просмотреть статистику подключения, то Вы можете скачать небольшую бесплатную программу Network Activity Indicator, максимально приближенную к интерфейсу Windows.

Если Вы желаете заменить стандартную иконку Сеть на иконку данной программы, то проделайте следующее:

1) Зайдите на сайт: http://www.itsamples.com/network-activity-indicator.html
2) Скачайте программу Network Activity Indicator и язык интерфейса к ней.
3) Распакуйте программу и язык интерфейса для программы в одну и ту же папку.
4) Откройте папку, куда Вы распаковали программу и запустите файл NetworkIndicator.exe
5) Нажмите правой кнопкой мыши на иконку программы и выберите пункт Настройки
6) Установите флажки:
Отображать UDP пакеты
Отображать ICMP пакеты
Запускать при старте Windows
Показывать неактивную иконку если интерфейс отсоединен.
Использовать иконки Vista
7) Нажмите кнопку Применить.
8) Щелкните правой кнопкой мыши на панели задач и выберите пункт Свойства.
9) В графе Область уведомлений щелкните на кнопку Настроить...
10) Нажмите на ссылку Включить или выключить системные значки.
11) Напротив значка Сеть из ниспадающего списка выберите Выкл.
12) Нажмите ОК и еще раз ОК.

Назад на страницу раздела Сети (Интернет и Локальная).


19. Создание ярлыка для запуска Internet Explorer в режиме приватного просмотра.

1) Щелкните правой кнопкой мыши на свободном месте рабочего стола, и выберите Создать -> Ярлык.

2) Для 32-битных Windows 7:

2.1) В поле Укажите расположение объекта введите:

2.2) Переходите к пункту 4.

3) Для 64-битных Windows 7:

3.1) Чтобы использовать 32-битную версию Internet Explorer, в поле Укажите расположение объекта введите:

3.2) Чтобы использовать 64-битную версию Internet Explorer, в поле Укажите расположение объекта введите:

4) Нажмите кнопку Далее.
5) В поле Введите имя ярлыка напишите Internet Explorer (просмотр InPrivate) и нажмите кнопку Готово. (Примечание: Вы можете указать любое имя для ярлыка.)
6) Теперь Вы можете переместить созданный Вами ярлык в любое удобное для Вас место. Например, Вы можете закрепить ярлык в панели задач.

Назад на страницу раздела Сети (Интернет и Локальная).


20. Создание ярлыка в папке Компьютер для просмотра часто используемого ftp как одного из дисков.

1) В проводнике или в меню Пуск щелкните правой кнопкой мыши на Компьютер
2) Выберите в списке пункт Подключить сетевой диск
3) Нажмите ссылку Подключение к сайту, на котором можно хранить документы и изображения.
4) В открывшем окне нажмите кнопку Далее, а затем снова кнопку Далее.
5) В текстовом поле введите имя ftp-сервера и нажмите кнопку Далее.

Например: ftp://ftp.mozilla.org/pub/firefox/

6) Уберите флажок "Анонимный вход" и введите имя пользователя и нажмите кнопку Далее.
Если для входа не нужна идентификация пользователя, то оставьте флажок "Анонимный вход" установленным.
7) Введите имя для отображаемого ярлыка в проводнике и нажмите Далее.
8) Для завершения создания ярлыка нажмите кнопку Готово.

Назад на страницу раздела Сети (Интернет и Локальная).


21. Быстрая очистка истории обзора Internet Explorer при помощи специально созданного ярлыка.

Если Вы используете браузер Internet Explorer, то для очистки истории обзора(временных файлов, кэша, паролей и др.) Вы делаете следующее:

1) В Internet Explorer открываете Свойства обозревателя.
Если у Вас включена Строка меню, то данный пункт расположен в меню Сервис, если Строка меню отключена, то нажимаете на значок шестеренки.
2) На вкладке Общие в графе История просмотра нажимаете кнопку Удалить... .
3) Устанавливаете необходимые флажки и нажимаете кнопку Удалить.

Чтобы ускорить данный процесс Вы можете создать специальный ярлык для очистки определенных данных из истории просмотра Internet Explorer на рабочем столе.

1) Щелкните по рабочему столу правой кнопкой мыши, выберите команды "Создать" - "Ярлык".
2) В текстовом поле введите необходимую Вам команду для запуска.

Удаление истории посещений (журнала):

Удаление Cookies:

Удаление временных файлов/веб страниц:

Удаление данных веб-форм:

Удаление паролей:

Полное удаление всей истории:

Полное удаление всей истории и данных надстроек браузера:

3) Нажмите кнопку Далее
4) Укажите имя для ярлыка и нажмите Готово.

Так же можно комбинировать номера, суммируя их.
Например:

Это удалит временные файлы (+8) и журнал посещений (+1).

Назад на страницу раздела Сети (Интернет и Локальная).


Тонкие настройки

1. Отключение "гибернации" для исправления ошибки BSOD и получения дополнительного места на жестком диске.

Бывает при выходе из режима гибернации многие видят только черный экран или ошибку BSOD. После чего приходится выключать кнопкой питания и включать заново. Одним из решений в такой ситуации является отключение гибернации.

1) Запустите командную строку с правами администратора
1.1) В строке поиска в меню Пуск введите cmd
1.2) Щелкните на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора
2) Введите команду и нажмите Enter:

Чтобы выключить гибернацию:

Чтобы включить:

Отключение гибернации также приведет к тому, что файл hiberfil.sys, расположенный в корне диска на котором у вас установлена Windows автоматически удалится, освобождая дополнительное пространство на накопителе.

2. Удаление значка "Центр поддержки" из области уведомлений на панели задач.

1) Щелкните правой кнопкой мыши на свободное место на панели задач и нажмите пункт Свойства
2) Нажмите кнопку Настроить...
3) Щелкните по ссылке Включить или выключить системные значки
4) Напротив надписи Центр поддержки выберите из ниспадающего списка значение Выкл нажмите ОК.

3. Удаление текста под значком ярлыка или файла.

1) Щелкните правой кнопкой мыши на иконке и нажмите Переименовать.
2) Удерживая нажатой клавишу Alt, напечатайте на цифровой клавиатуре подряд цифры 2, 5 и 5 (Alt+255).
Данная комбинация позволяет добавить невидимый символ в название ярлыка или файла.
Для переименования несколько ярлыков, добавляйте к каждому следующему дополнительно Alt+255, отпуская клавишу Alt после каждого введения числа 255.
Так для переименования второго ярлыка, Вам потребуется ввести Alt+255, Alt+255, для третьего Alt+255, Alt+255, Alt+255 и т.д..

4. Создание (восстановление) панели быстрого запуска (Quick Launch).

1) Щелкните правой кнопкой мыши по панели задач и наведите курсор на Панели (Toolbars )
2) Нажмите на пункт Создать панель инструментов... (New Toolbar)
3) Введите путь к папке: %appdata%\Microsoft\Internet Explorer\Quick Launch и нажмите клавишу Enter.
4) Нажмите кнопку Выбор папки (Select Folder).
5) Щелкните правой кнопкой мыши по панели задач и уберите флажок Закрепить панель задач.
6) Щелкните левой кнопкой мыши на панели Quick Launch и не отпуская клавиши перетащите панель в левую сторону.
7) Щелкните правой кнопкой мыши на панели Quick Launch и уберите флажки Показывать подписи и Показывать заголовок.
8) Щелкните правой кнопкой мыши по панели задач и поставьте флажок Закрепить панель задач.

5. Разблокирование файла используемого какой-либо программой для действий с ним.

Если при попытке удаления, переименования или перемещения файла или папки системой выдается сообщение, что данное действие произвести невозможно, так как файл (папка) используется другим приложением, то для разблокировки используемого файла (папки) Вы можете воспользоваться замечательной утилитой Unlocker. Программа является дополнением к Проводнику Windows, ее вызов осуществляется через контекстное меню, вызываемое нажатием правой кнопкой мыши на файле (папке).

Инструкция:

1) В соответствии с разрядностью Вашего Windows cкачайте и установите программу Unlocker
2) Нажмите правой кнопкой на файле и в контекстном меню выберите Unlocker.
3) Выберите необходимое Вам действие и нажмите на кнопку Разблокировать Все.

Для замены защищенного файла Windows сделайте следующее:

1) Скопируйте файл(ы) для дальнейшей замены в буфер обмена.
2) С помощью инструкции выше, удалите заменяемый(е) Вами файл(ы).
3) После удаления файла(ов), вставьте заранее скопированный(е) файл(ы) (Сделать это надо в первые секунды после удаления, так как система может восстановить файл из кэша)
4) Перезайдите в систему или перезагрузите компьютер.
P.S. Если после перезагрузки, некоторые (или все) изменения не вступили в силу, удалите содержимое папки C:\Windows\rescache и в случае необходимости проделайте описанное выше ещё раз.

6. Удаление надписей из правого нижнего угла рабочего стола.

Чтобы удалить водяные знаки на рабочем столе, такие как "Пробная копия", "Только для тестов", "Тестовый режим", воспользуйтесь одним из предложенных вариантов.

Вариант 1.

1) Откройте с помощью Restorator или PE Explorer файлы:

C:\Windows\System32\ru-RU\user32.dll.mui
C:\Windows\System32\en-US\user32.dll.mui

2) В разделе Строковая таблица (String) удалите строчки с 715 по 718 включительно и строки 737 и 738 .

715 %wsWindows %ws
716 %ws Сборка %ws
717 Пробная копия.
718 Только для тестов.

737 Ваша копия Windows не является подлинной
738 Тестовый режим

3) Перезагрузите компьютер.
Если после перезагрузки надписи не исчезли, то Вам необходимо перестроить кэш MUI.
4) Нажмите кнопку Пуск и в строке поиска введите cmd
5) Щелкните правой кнопкой мыши на найденной программе и выберите пункт Запуск от имени администратора
6) Введите команду: mcbuilder и нажмите Enter
7) Перезагрузите компьютер.

Вариант 2.

1) Скачайте архив RemoveWatermark_20090509.zip и распакуйте его в любую папку.
2) Выберите патч исходя из разрядности установленной у Вас Windows:
Для 32-бит(x86): RemoveWatermarkX86.exe
Для 64-бит(x64): RemoveWatermarkX64.exe

3) Нажмите правой кнопкой мыши на exe-файл и выберите пункт "Запуск от имени администратора"
4) Нажмите клавишу "Y" для подтверждения.
Резервная копия "user32.dll.mui" будет сохранена как \Windows\System32\en-US\user32.dll.mui.backup.
Строка "en-US" зависит от языка Вашей системы.
5) Дождитесь окончания патча и перезагрузите компьютер.
6) Если надписи после перезагрузки остались на Вашем рабочем столе, то Вам надо перестроить кэш MUI. Для этого:
6.1) Нажмите правой кнопкой мыши на exe-файл и выберите пункт "Запуск от имени администратора"
6.2) Нажмите клавишу "R" для подтверждения.
6.3) Дождитесь окончания перестройки кэша, а затем перезагрузите компьютер.

7. Смена названия операционной системы из Максимальная на Ultimate.

Открываете с помощью Restorator или PE Explorer файл C:\Windows\Branding\Basebrd\ru-RU\basebrd.dll.mui и правите в нем название операционной системы из Максимальная на Ultimate. Также можно скопировать файл basebrd.dll.mui из папки C:\Windows\Branding\Basebrd\en-US\ в папку C:\Windows\Branding\Basebrd\ru-RU\ если данной папки нет, то файлы можно скачать тут: для x86, для x64

8. Использование всей оперативной памяти в 32-битных Windows.

Данная программа добавляет второе ядро для загрузки операционной системы: ntkr128g.exe
Статьи (на английском), объясняющие причины использования 32-битными системами меньше памяти чем установлено и помогающие понять принцип работы данной программы:

http://support.microsoft.com/kb/978610
http://www.geoffchappell.com/viewer.htm?doc=notes/windows/license/memory.htm

1) Скачайте ReadyFor4GB от deepxw.
2) Распакуйте его в любую папку и запустите ReadyFor4GB.exe

Рисунок 1 из 10

3) Нажмите на кнопку Check, затем на кнопку Apply.

Рисунок 2 из 10

4) Нажмите на кнопку Да (Yes) для пропатчивания ntkrnlpa.exe

Рисунок 3 из 10

5) Нажмите на кнопку ОК для подтверждения места сохранения файла ntkr128g.exe

Рисунок 4 из 10

6) Закройте окно программы ReadyFor4GB.
7) Нажмите правой кнопкой мыши на файл AddBootMenu.cmd и выберите пункт Запуск от имени администратора
8) Нажмите клавишу "Y" для подтверждения или клавишу "Q" для выхода, и нажмите Enter.

Рисунок 5 из 10

9) Дождитесь окончания работы скрипта и закройте программу.

Рисунок 6 из 10

10) Нажмите правой кнопкой мыши на файл RemoveWatermarkX86.exe и выберите пункт Запуск от имени администратора

Рисунок 7 из 10

11) Нажмите клавишу "Y" для подтверждения.

Рисунок 8 из 10

Резервная копия "user32.dll.mui" будет сохранена как \Windows\System32\en-US\user32.dll.mui.backup.
Строка "en-US" зависит от языка Вашей системы.
12) Дождитесь окончания патча и перезагрузите компьютер.
13) Компьютер перезагрузится, покажет Диспетчер загрузки Windows (Windows Boot Manager) и загрузит Microsoft Windows [128GB with ntkr128g.exe]

Рисунок 9 из 10

14) Если надпись "Тестовый режим" после перезагрузки осталась на Вашем рабочем столе, то Вам надо перестроить кэш MUI. Для этого:
14.1) Нажмите правой кнопкой мыши на файл RemoveWatermarkX86.exe и выберите пункт Запуск от имени администратора
14.2) Нажмите клавишу "R" для подтверждения.

Рисунок 10 из 10

14.3) Дождитесь окончания перестройки кэша, а затем перезагрузите компьютер.

Примечание:

П.1) Файлы обязательно запускать от имени администратора, и только в операционной системе Windows 7 x86 (32-Bit).
П.2) Для удаления записи о другой Windows из диспетчера загрузки:
П.2.1) Запустите Конфигурация системы: Панель управления -> Администрирование -> Конфигурация системы (или нажав Win+R -> msconfig -> Ok)
П.2.2) Перейдите на вкладку Загрузка.
П.2.3) Выделите пункт загрузки, который Вы желаете удалить и нажмите кнопку Удалить.
П.3) Если после применения патча у Вас по-прежнему показывает значение менее 4 Гб, то Вы можете скачать готовый файл ntkr128g.exe и скопировать его в папку C:\Windows\System32:

http://file.qip.ru/file/1C7BVO4j/ntkr128g.html

Если и после этого у Вас не появится 4 гб памяти, то видимо Ваша оперативная память не отдает доступ к необходимым адресам памяти.
Следовательно для использования полностью всей оперативной памяти рекомендую Вам установить 64-битную Windows.

9. Изменение папки открываемой по умолчанию в Проводнике.

Настраиваем нажатие на кнопку Проводник (Windows Explorer), чтобы оно приводило в указанную Вами папку, вместо Libraries.

1) Нажмите правой кнопкой мыши на значок Проводника в Панели задач.
2) Нажмите правой кнопкой мыши на Проводник
3) Нажмите левой кнопкой мыши на Свойства
4) Измените поле Объект (Target) на %SystemRoot%\explorer.exe /n, /e, С:\My Folder
где C:\My Folder - путь к Вашей папке.
Для запуска папки Компьютер измените на значение: %SystemRoot%\explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Чтобы это изменение затронуло и ссылку в меню Пуск, то вам потребуется изменить поле Объект в свойствах ярлыка Проводник в папке Стандартные (Accessories) из меню Пуск.
Комбинация клавиш Win+E откроет Проводник в «Компьютере»

10. Добавление или прямой запуск папки Все задачи (Расширенная Панель Управления).

Для быстрого доступа разработчиков и тестеров ко всем системным задачам в бета версиях Windows, была создана специальная папка Все задачи, содержащая Список задач всех программ. В финальных версиях Windows её так и не убрали, а поэтому и Вы можете воспользоваться ею для быстрого доступа к нужной Вам задаче.

Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}

Также Вы можете запустить её напрямую. Для запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win+R) и введите команду:

shell:::{ED7BA470-8E54-465E-825C-99712043E01C}

11. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows.
Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Нажмите кнопку "Пуск",
2) Перейдите в "Панель управления" и там выберите "Центр специальных возможностей".
3) Выберите параметр "Использование компьютера без экрана" или "Облегчение сосредоточения"
4) Находите «Как долго должны оставаться открытыми диалоговые окна уведомлений Windows?» и выставляете из выпадающего списка то время, которое Вам нужно.

В выпадающем списке выберите подходящее для Вас значение.

12. Использование рисунков из вложенных папок в окне "Фоновый рисунок рабочего стола".

У многих пользователей есть папка, в которой они хранят различные необходимые им изображения. Назовем её, для примера, Pictures. Внутри этой папки, часто находятся вложенные папки, с разной тематикой рисунков.

Если в настройках фонового рисунка рабочего стола, вызываемых:
1) ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола
2) Пуск\Панель управления\Все элементы панели управления\Персонализация\Фоновый рисунок рабочего стола
Вы попытаетесь указать вашу папку Pictures, то далее увидите либо рисунки, находящиеся только в ней, либо надпись: «Нет элементов, удовлетворяющих условиям поиска», если в самой папке Pictures не будет рисунков. Так как подпапки поддерживаются только в системной папке C:\Windows\Web\Wallpaper, используемой Windows для хранения фоновых рисунков рабочего стола по умолчанию.

Если же Вы хотите использовать собственную папку, с вложенными в неё подпапками и не менять значение системной папки находящийся в реестре(Win+R –> Regedit –> OK) по адресу:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\knownfolders\0\Windows Wallpapers\MergeFolders
cо значения %SystemRoot%\web\wallpaper на Ваше собственное, к примеру: D:\Nickname\Pictures, то есть нужный Вам вариант решения.

Вы можете создать новую библиотеку и добавить в неё Ваши папками.

1) Открываете папку Библиотеки. У кого она удалена из проводника, тот может открыть её введя в адресную строку Windows Explorer:

2) Нажимаете ПКМ -> Создать -> Библиотека
3) Переименовываете её. Например: Обои для рабочего стола
4) Щелкаете ПКМ и выбираете Свойства
5) Добавляете отдельно каждую папку
6) В графе Оптимизировать эту библиотеку: выбираете Изображения
7) Нажимаете применить, затем Ок.
8) После этого открываем раздел Персонализация –> Фон рабочего стола -> и в меню Расположение изображения с помощью кнопки Обзор... указываем путь к только что созданной нами библиотеке.

Внимание: Вы можете спокойно удалить созданную Вами библиотеку из общего списка библиотек, что никак не повлияет на Ваши файлы. Однако если Вы удалите любой файл из папки, созданной Вами библиотеки- он также удалиться из системы(из той папки, в которой он находится).

Для облегчения работы с библиотеками Вы можете воспользоваться программой Librarian. Librarian - это утилита управления библиотеками Windows 7.

Программа расширяет стандартный функционал Windows 7 в области управления библиотеками.

Её ключевые возможности:
- Создание библиотеки из произвольного набора папок.
- Смена значка библиотеки на выбранный пользователем. Вы можете задач значок библиотеки, используя стандартный диалог Windows, вызываемый при смене значка ярлыка.
- Переименование библиотеки.
- Указание типа содержимого новой или редактируемой библиотеки.
- Смена папки, используемой по умолчанию для сохранения файлов в библиотеку.
- Управление отображением библиотеки в панели навигации проводника.
- Отображение библиотеки в виде XML-файла.
- Отображение системного диалога папок, включенных в библиотеку.

Скачать данную программу можно здесь или здесь

13. Увеличение скорости работы USB-мыши, с помощью повышения опросов USB-порта.

Вы любите играть в игры, где важна быстрота реакции, но Ваша USB-мышь не относится к классу игровых мышек - просто увеличьте частоту опросов USB мыши. Например: игровая мышь Logitech G7 имеет частоту опроса равную 530 MHz, а обычная 125 MHz.

Для установки необходимы права локального администратора.

1) Скачайте архив MouseRate.zip и распакуйте его в папку.
2) Откройте папку Direct Input Mouse Rate и в ней запустите программу dimr.exe
3) Подвигайте максимально быстро курсором Вашей мыши по экрану.
4) Запомните значение из графы Peak - это максимальная величина опросов Вашей мышки.
5) Откройте папку HIDUSBF
6) Нажмите правой кнопкой мыши на файл HIDUSBF.INF и выберите пункт Установить.
7) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
8) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

Если у Вас появится сообщение о неподписанных драйверах - не волнуйтесь, все нормально. Подпишем его программой Driver Signature Enforcement Overrider, о которой упоминалось в совете Как добавить подпись к драйверам? из раздела Установка. На время её работы UAC(Контроль учетных записей пользователей) в Windows должен быть отключен.

1) Запустите файл dseo13b.exe из папки Driver Signature Enforcement Overrider и выберите там "Enable Test Mode".
2) Перезапустите компьютер.
3) После перезапуска снова откройте файл dseo13b.exe и выберите "Sign a system file".
4) В окне пропишите: "C:\Windows\System32\Drivers\HIDUSBF.sys". Если вы сделали это правильно, то вы увидите сообщение: "Система была подписана успешно" ("The system file has been signed succesfully")
5) Снова перезапустите компьютер.
6) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
7) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

14. Перемещение системных папок и изменение их путей.

Перенос системных папок лучше сделать сразу после установки Windows, до установки программ и драйверов, т.к. при установке драйверов и в особенности программ будут создаваться каталоги и ярлыки в эти самые системные папки. Если Вы используете для хранения файлов системные папки, то перенос системных папок пользователя на не системный диск, поможет Вам сохранить свои файлы. В случае сбоя Windows, при её переустановке заданные по умолчанию системные папки будут затерты полностью, со всеми находящимися в них файлами. Но если Вы зададите свои пути к системным папкам, то всё их содержимое останется целым.

Раньше в предыдущих версиях Windows, чтобы переместить какую-либо системную папку или изменить её путь, Вам надо было править нужное Вам значение в одной из следующих веток реестра:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Компания Microsoft понимая, что многие пользователи могут захотеть переместить свои системные папки, упростила пользователям эту задачу, избавив их от надобности редактировать реестр. Для перемещения системных папок и изменения их путей продеайте следующее:

1) Создайте новую папку, желательно с аналогичным перемещаемой папке наименованием.
2) Откройте в Windows Explorer: Рабочий стол\Ваш Профиль (Например: Рабочий стол\Администратор)
3) Щелкните правой кнопкой мыши на название папки, которую Вы собираетесь переместить (Например: Мои Документы) и выберите Свойства.
4) Откройте вкладку Расположение
5) Нажмите кнопку Переместить и укажите путь к созданной Вами новой папке
6) Далее система спросит Вас: Переместить все файлы из старого расположения в новое? (Рекомендуемый ответ - Да)
7) Соглашаетесь с новыми параметрами применяя их и выходите.
8) Перезагружаете Компьютер.

15. Скрытие выбранных дисков из окна папки "Компьютер".

Если Вы используйте флэш-диск для ускорения работы системы (ReadyBoost) или у Вас установлен картридер который Вы используйте для чтения только одного типа карт, то у Вас может появится желание скрыть выбранные Вами диски из папки Компьютер. Чтобы сделать это Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1.

1) Откройте меню Пуск, введите в строке поиска gpedit.msc и нажмите Enter. (Win+R -> gpedit.msc )
2) Перейдите по пути слева Конфигурация пользователя -> Административные шаблоны -> Компоненты Windows -> Проводник Windows..
3) Щелкните дважды по параметру Скрыть выбранные диски из окна "Мой компьютер".
4) Установите переключатель на значение Включить.
5) В раскрывающемся списке выберите одну из предложенных комбинаций и нажмите ОК.

Вариант 2.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр NoDrives типа DWORD
4) Значение данного параметра обрабатывается Windows в двоичной системе исчисления, но указывается в реестре в десятичной или шестнадцатеричной.
Для расчета двоичного значения воспользуйтесь таблицей.

Z | Y | X | W | V | U | T | S | R | Q | P | O | N | M | L | K | J | I | H | G | F | E | D | C | B | A
0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0

В данной таблице каждой букве соответствует цифра, которая может быть либо единицей, либо нулём. Единица означает "скрыть диск", ноль - "показать диск".
Для получения числа в двоичной системе исчисления замените для диска который Вы желаете скрыть цифру 0 на цифру 1.

Например, для скрытия дисков A, B, F, G заменив цифры с 0 на 1 получится следующий вид:

Z | Y | X | W | V | U | T | S | R | Q | P | O | N | M | L | K | J | I | H | G | F | E | D | C | B | A
0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 1 | 0 | 0 | 0 | 1 | 1

Так как значение параметра формируется Windows в двоичной системе исчисления, а для добавления в реестр Вам необходимо данное значение в шестнадцатиричной или десятиричной системе, то для преобразования значения из одной системы исчисления в другую воспользуйтесь калькулятором Windows.

5) Запустите Калькулятор (Пуск -> Все программы -> Стандартные)
6) В меню программы нажмите Вид и выберите значение Программист
7) Установите переключатель в значение Bin
8) Введите значение полученное с помощью таблицы. В моем примере это число 1100011.
9) Установите переключатель в значение Dec
10) Скопируйте полученное число(Правка -> Копировать или Ctrl+C) в буфер обмена или запомните его. В моем примере 99.
11) Закройте калькулятор и вернитесь в редактор реестра.
12) Измените значение параметра NoDrives на полученное Вами в калькуляторе значение.

12.1) Щелкните правой кнопкой мыши по параметру и выберите пункт Изменить...
12.2) Установите переключатель на значение Десятичная
12.3) В текстовое поле введите запомненное Вами число из калькулятора или нажмите Ctrl+V, если Вы копировали в буфер обмена.

16. Добавление элементов в контекстное меню "Отправить".

При попытке открыть более 15 элементов сразу используя меню, вызываемое правой кнопкой мыши в Проводнике, пункт меню Открыть пропадет. Если Вам необходимо открыть большее количество элементов одновременно, то Вы можете сделать это добавив нужную Вам программу в контекстное меню "Отправить".
Чтобы добавить свою программу в контекстное меню "Отправить". Сделайте следующее:

1) Откройте папку C:\Users\UserName\AppData\Roaming\Microsoft\Windows\SendTo , где UserName - Ваше имя пользователя.
Также Вы можете открыть данную папку так:
1.1) В адресной строке Проводника введите команду shell:SendTo и нажмите Enter.
1.2) Нажмите Win+R, введите команду shell:SendTo и нажмите Enter.
2) Создайте в открывшейся папке ярлык для необходимой Вам программы:
2.1) Используйте меню, вызываемое правой кнопкой мыши. Создать -> Ярлык -> Укажите расположение программы -> Введите имя ярлыка
2.2) Удерживая нажатой клавишу Alt скопируйте Вашу программу в вышеуказанную папку и переименуйте ярлык.

17. Быстрое добавление своего ярлыка папки или программы в папку Компьютер.

Скопируйте необходимый Вам ярлык в папку C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Windows\Network Shortcuts
где Имя пользователя - это имя Вашей учетной записи (Например: Администратор).

18. Замена элементов в диалоговом окне открытия/сохранения файлов.

Вы можете заменить стандартные папки из диалогового окна открытия/сохранения файлов на указанные Вами.

1) Откройте меню Пуск
2) В строке поиска введите gpedit.msc
3) Откройте папку Конфигурация пользователя\Административные шаблоны\Компоненты Windows\Проводник Windows.\Общее диалоговое окно открытия файлов
4) Сделайте двойной щелчок мышью на Элементы, отображаемые в панели мест
5) Установите переключатель на значение Включить
6) Введите в текстовых полях напротив Элементов, пути к папкам и нажмите ОК.
Для добавления папки Рабочий стол необходимо ввести: shell:desktop

19. Изменение настроек режима самовосстановления для повышения производительности Windows.

Если Вы периодически, не реже раза в неделю, делаете проверку файловой системы и пустого дискового пространства используя утилиту CHKDSK, то возможно Вас заинтересует изменение настроек режима самовосстановления. Это изменение позволит Вам повысить производительность Вашей операционной системы, путем высвобождения ресурсов затрачиваемых на данный режим.

1) Запустите командную строку (Win+R -> cmd -> OK)
1.1) Нажмите кнопку Пуск и введите в строке поиска cmd
1.2) Щелкните правой кнопкой мыши на найденном файле и выберите пункт "Запуск от имени администратора"
2) Проверьте состояние функции самовосстановления, для этого введите в командной строке и нажмите Enter:

Где ИМЯ_ДИСКА - буква присвоенная жесткому диску или одному из его разделов. Например:

3) Включите режим отображения системой BSOD (синего экрана смерти) при обнаружении программой CHKDSK ошибки. Данное действие необходимо для получения возможности смены режима самовосстановления. Введите в командной строке и нажмите Enter:

4) Перезагрузите компьютер.
5) Снова запустите командную строку от имени администратора.
6) Переключите режим общего восстановления, в режим однократной проверки ошибок при первом случае повреждения. Для этого введите в командной строке и нажмите Enter:

7) Отключите режим отображения системой BSOD (синего экрана смерти) при обнаружении программой CHKDSK ошибки. Для этого введите в командной строке и нажмите Enter:

8) Перезагрузите компьютер.

Вы можете отключить функцию самовосстановления как у отдельных дисков (разделов), так и у всех сразу, повторив приведенный выше порядок действий для каждого из них. Данное решение работает только с дисками отформатированными в файловую систему NTFS.

Внимание. Побочным эффектом при выборочном отключении проверки (на отдельных дисках) может быть срабатывание защитного антивирусного программного обеспечения.

20. Изменение стандартной мелодии запуска Windows 7.

В предыдущих версий Windows, стандартная мелодия запуска находилась в папке C:\Windows\Media.
В операционной системе Windows 7 стандартная мелодия запуска содержится в файле библиотеки: imageres.dll, находящемся в папке C:\Windows\System32
Для изменения данного файла воспользуйтесь программами: Restorator или PE Explorer.
Перед изменением файла убедитесь, что у Вас очищена папка C:\Windows\rescache

В программе PE Explorer:

1) Откройте файл imageres.dll
2) Нажмите комбинацию клавиш Ctrl+R или перейдите в меню View -> Resources
3) Откройте папку WAVE, щелкните правой кнопкой мыши на ресурс 5080 и выберите пункт Edit Resource
4) В открывшемся окне нажмите комбинацию клавиш Ctrl+O или на значок папки со стрелочкой.
5) Выберите мелодию в формате WAV для замены, после нажмите ОК, а затем Yes

В программе Restorator:

1) Откройте файл imageres.dll
2) Откройте папку WAVE и перетяните на ресурс 5080 файл, которым Вы хотите заменить мелодию запуска.
3) Сохраните внесенные изменения нажав Ctrl+S

21. Отключение Журналирования для ускорения работы диска и освобождения дискового пространства.

Чтобы отключить журналирования для диска, сделайте следующее:

1) Запустите командную строку (Win+R -> cmd -> OK)
2) Введите в командной строке:

где H: - буква диска для которго необходимо отключить журналирование.

Если возникнет необходимость включить журналирование опять, то сделать сделайте следующее:

1) Запустите командную строку (Win+R -> cmd -> OK)
2) Введите в командной строке:

22. Распределение файла подкачки между несколькими жесткими дисками для увеличения производительности системы.

Файл подкачки (Pagefile.sys) — это скрытый файл на жестком диске компьютера, который используется системой Windows по принципу оперативной памяти. Файл подкачки и физическая память вместе составляют виртуальную память. По умолчанию Windows хранит файл подкачки в разделе, в котором установлена операционная система.
Рекомендуемый размер файла подкачки должен быть примерно в 1,5 - 3 раза больше общего объема оперативной памяти.

Если у вас установлено 2 (или более) жестких диска,то для повышения быстродействия работы системы оптимальным решением будет создание одного файла подкачки в загрузочном разделе, а второго — в разделе, который используется реже (на другом жестком диске, если такой имеется). Кроме того, для второго файла подкачки по возможности лучше всего отвести отдельный раздел, где нет других данных и системных файлов. Система в первую очередь использует файл подкачки из менее загруженного раздела (а не файл подкачки из загрузочного раздела, количество обращений к которому намного больше).

По умолчанию система использует файл подкачки динамически, то есть размер файла изменяется автоматически, в зависимости от текущей потребности операционной системы. В большинстве же случаев наилучшая производительность системы достигается при статическом размере файла подкачки, так как это не требуется каждый раз изменять размер файла подкачки, что снижает его фрагментацию.

Учитывая описанное выше сделайте следующее:

1) Откройте Панель управления -> Система.
2) Слева в списке нажмите ссылку Дополнительные параметры системы.
3) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
4) Откройте вкладку Дополнительно и в разделе Виртуальная память нажмите кнопку Изменить.
5) Снимите флажок Автоматически выбирать объем файла подкачки.
6) Выберите диск, на котором Вы хотите создать файл подкачки.
7) Установите переключатель в значение Указать размер
8) Введите в поля Исходный размер (МБ) и Максимальный размер (МБ) одинаковые размеры создаваемого файла подкачки в мегабайтах, равного величине в 1,5 - 3 раза больше общего объема оперативной памяти.
9) Нажмите кнопку Задать,
10) Выберите следующий диск и проделайте указанные выше операции, после чего нажмите кнопку ОК.
11) Перезагрузите компьютер.

23. Регистрация необходимых и выгрузка из памяти неиспользуемых библиотек (dll-файлов).

Чтобы загрузить в память определенную библиотеку (dll-файл) Вам необходимо ее зарегистрировать. Для того, чтобы это сделать введите команду:

Если dll-файл расположен в системной папке (System32), то:

Например:

Если dll-файл расположен не в системной папке, то:

Например:

Чтобы выгрузить из памяти определенную библиотеку (dll-файл) Вам необходимо отменить ее регистрацию.

Если dll-файл расположен в системной папке (System32), то:

Например:

Если dll-файл расположен не в системной папке, то:

Например:

Если Вам необходимо освободить часть оперативной памяти, то Вы можно сделать это добавив в реестр параметр, отвечающий за автоматическую выгрузку из памяти неиспользуемых библиотек.

1) Запустите редактор реестра (Win+R->regedit->ОК)
2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer
3) В меню Правка выберите Создать -> Параметр DWORD (32 бита).
4) Задайте имя параметра AlwaysUnloadDll
5) Дважды щелкните на данном параметре и введите значение 1.
6) Закройте редактор реестра и перезапустите компьютер.


1. Отключение "гибернации" для исправления ошибки BSOD и получения дополнительного места на жестком диске.

Бывает при выходе из режима гибернации многие видят только черный экран или ошибку BSOD. После чего приходится выключать кнопкой питания и включать заново. Одним из решений в такой ситуации является отключение гибернации.

1) Запустите командную строку с правами администратора
1.1) В строке поиска в меню Пуск введите cmd
1.2) Щелкните на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора
2) Введите команду и нажмите Enter:

Чтобы выключить гибернацию:

Чтобы включить:

Отключение гибернации также приведет к тому, что файл hiberfil.sys, расположенный в корне диска на котором у вас установлена Windows автоматически удалится, освобождая дополнительное пространство на накопителе.

Назад на страницу раздела Тонкие настройки.


2. Удаление значка "Центр поддержки" из области уведомлений на панели задач.

1) Щелкните правой кнопкой мыши на свободное место на панели задач и нажмите пункт Свойства
2) Нажмите кнопку Настроить...
3) Щелкните по ссылке Включить или выключить системные значки
4) Напротив надписи Центр поддержки выберите из ниспадающего списка значение Выкл нажмите ОК.

Назад на страницу раздела Тонкие настройки.


3. Удаление текста под значком ярлыка или файла.

1) Щелкните правой кнопкой мыши на иконке и нажмите Переименовать.
2) Удерживая нажатой клавишу Alt, напечатайте на цифровой клавиатуре подряд цифры 2, 5 и 5 (Alt+255).
Данная комбинация позволяет добавить невидимый символ в название ярлыка или файла.
Для переименования несколько ярлыков, добавляйте к каждому следующему дополнительно Alt+255, отпуская клавишу Alt после каждого введения числа 255.
Так для переименования второго ярлыка, Вам потребуется ввести Alt+255, Alt+255, для третьего Alt+255, Alt+255, Alt+255 и т.д..

Назад на страницу раздела Тонкие настройки.


4. Создание (восстановление) панели быстрого запуска (Quick Launch).

1) Щелкните правой кнопкой мыши по панели задач и наведите курсор на Панели (Toolbars )
2) Нажмите на пункт Создать панель инструментов... (New Toolbar)
3) Введите путь к папке: %appdata%\Microsoft\Internet Explorer\Quick Launch и нажмите клавишу Enter.
4) Нажмите кнопку Выбор папки (Select Folder).
5) Щелкните правой кнопкой мыши по панели задач и уберите флажок Закрепить панель задач.
6) Щелкните левой кнопкой мыши на панели Quick Launch и не отпуская клавиши перетащите панель в левую сторону.
7) Щелкните правой кнопкой мыши на панели Quick Launch и уберите флажки Показывать подписи" и Показывать заголовок.
8) Щелкните правой кнопкой мыши по панели задач и поставьте флажок Закрепить панель задач.

Назад на страницу раздела Тонкие настройки.


5. Разблокирование файла используемого какой-либо программой для действий с ним.

Если при попытке удаления, переименования или перемещения файла или папки системой выдается сообщение, что данное действие произвести невозможно, так как файл (папка) используется другим приложением, то для разблокировки используемого файла (папки) Вы можете воспользоваться замечательной утилитой Unlocker. Программа является дополнением к Проводнику Windows, ее вызов осуществляется через контекстное меню, вызываемое нажатием правой кнопкой мыши на файле (папке).

Инструкция:

1) В соответствии с разрядностью Вашего Windows cкачайте и установите программу Unlocker
2) Нажмите правой кнопкой на файле и в контекстном меню выберите Unlocker.
3) Выберите необходимое Вам действие и нажмите на кнопку Разблокировать Все.

Для замены защищенного файла Windows сделайте следующее:

1) Скопируйте файл(ы) для дальнейшей замены в буфер обмена.
2) С помощью инструкции выше, удалите заменяемый(е) Вами файл(ы).
3) После удаления файла(ов), вставьте заранее скопированный(е) файл(ы) (Сделать это надо в первые секунды после удаления, так как система может восстановить файл из кэша)
4) Перезайдите в систему или перезагрузите компьютер.
P.S. Если после перезагрузки, некоторые (или все) изменения не вступили в силу, удалите содержимое папки C:\Windows\rescache и в случае необходимости проделайте описанное выше ещё раз.

Назад на страницу раздела Тонкие настройки.


6. Удаление надписей из правого нижнего угла рабочего стола.

Чтобы удалить водяные знаки на рабочем столе, такие как "Пробная копия", "Только для тестов", "Тестовый режим", воспользуйтесь одним из предложенных вариантов.

Вариант 1.

1) Откройте с помощью Restorator или PE Explorer файлы:

C:\Windows\System32\ru-RU\user32.dll.mui
C:\Windows\System32\en-US\user32.dll.mui

2) В разделе Строковая таблица (String) удалите строчки с 715 по 718 включительно и строки 737 и 738 .

715 %wsWindows %ws
716 %ws Сборка %ws
717 Пробная копия.
718 Только для тестов.

737 Ваша копия Windows не является подлинной
738 Тестовый режим

3) Перезагрузите компьютер.
Если после перезагрузки надписи не исчезли, то Вам необходимо перестроить кэш MUI.
4) Нажмите кнопку Пуск и в строке поиска введите cmd
5) Щелкните правой кнопкой мыши на найденной программе и выберите пункт Запуск от имени администратора
6) Введите команду: mcbuilder и нажмите Enter
7) Перезагрузите компьютер.

Вариант 2.

1) Скачайте архив RemoveWatermark_20090509.zip и распакуйте его в любую папку.
2) Выберите патч исходя из разрядности установленной у Вас Windows:
Для 32-бит(x86): RemoveWatermarkX86.exe
Для 64-бит(x64): RemoveWatermarkX64.exe

3) Нажмите правой кнопкой мыши на exe-файл и выберите пункт "Запуск от имени администратора"
4) Нажмите клавишу "Y" для подтверждения.
Резервная копия "user32.dll.mui" будет сохранена как \Windows\System32\en-US\user32.dll.mui.backup.
Строка "en-US" зависит от языка Вашей системы.
5) Дождитесь окончания патча и перезагрузите компьютер.
6) Если надписи после перезагрузки остались на Вашем рабочем столе, то Вам надо перестроить кэш MUI. Для этого:
6.1) Нажмите правой кнопкой мыши на exe-файл и выберите пункт "Запуск от имени администратора"
6.2) Нажмите клавишу "R" для подтверждения.
6.3) Дождитесь окончания перестройки кэша, а затем перезагрузите компьютер.

Назад на страницу раздела Тонкие настройки.


7. Смена названия операционной системы из Максимальная на Ultimate.

Открываете с помощью Restorator или PE Explorer файл C:\Windows\Branding\Basebrd\ru-RU\basebrd.dll.mui и правите в нем название операционной системы из Максимальная на Ultimate. Также можно скопировать файл basebrd.dll.mui из папки C:\Windows\Branding\Basebrd\en-US\ в папку C:\Windows\Branding\Basebrd\ru-RU\ если данной папки нет, то файлы можно скачать тут: для x86, для x64

Назад на страницу раздела Тонкие настройки.


8. Использование всей оперативной памяти в 32-битных Windows.

Данная программа добавляет второе ядро для загрузки операционной системы: ntkr128g.exe
Статьи (на английском), объясняющие причины использования 32-битными системами меньше памяти чем установлено и помогающие понять принцип работы данной программы:

http://support.microsoft.com/kb/978610
http://www.geoffchappell.com/viewer.htm?doc=notes/windows/license/memory.htm

1) Скачайте ReadyFor4GB от deepxw.
2) Распакуйте его в любую папку и запустите ReadyFor4GB.exe

3) Нажмите на кнопку Check, затем на кнопку Apply.

4) Нажмите на кнопку Да (Yes) для пропатчивания ntkrnlpa.exe

5) Нажмите на кнопку ОК для подтверждения места сохранения файла ntkr128g.exe

6) Закройте окно программы ReadyFor4GB.
7) Нажмите правой кнопкой мыши на файл AddBootMenu.cmd и выберите пункт Запуск от имени администратора
8) Нажмите клавишу "Y" для подтверждения или клавишу "Q" для выхода, и нажмите Enter.

9) Дождитесь окончания работы скрипта и закройте программу.

10) Нажмите правой кнопкой мыши на файл RemoveWatermarkX86.exe и выберите пункт Запуск от имени администратора

11) Нажмите клавишу "Y" для подтверждения.

Резервная копия "user32.dll.mui" будет сохранена как \Windows\System32\en-US\user32.dll.mui.backup.
Строка "en-US" зависит от языка Вашей системы.
12) Дождитесь окончания патча и перезагрузите компьютер.
13) Компьютер перезагрузится, покажет Диспетчер загрузки Windows (Windows Boot Manager) и загрузит Microsoft Windows [128GB with ntkr128g.exe]

14) Если надпись "Тестовый режим" после перезагрузки осталась на Вашем рабочем столе, то Вам надо перестроить кэш MUI. Для этого:
14.1) Нажмите правой кнопкой мыши на файл RemoveWatermarkX86.exe и выберите пункт Запуск от имени администратора
14.2) Нажмите клавишу "R" для подтверждения.

14.3) Дождитесь окончания перестройки кэша, а затем перезагрузите компьютер.

Примечание:

П.1) Файлы обязательно запускать от имени администратора, и только в операционной системе Windows 7 x86 (32-Bit).
П.2) Для удаления записи о другой Windows из диспетчера загрузки:
П.2.1) Запустите Конфигурация системы: Панель управления -> Администрирование -> Конфигурация системы (или нажав Win+R -> msconfig -> Ok)
П.2.2) Перейдите на вкладку Загрузка.
П.2.3) Выделите пункт загрузки, который Вы желаете удалить и нажмите кнопку Удалить.
П.3) Если после применения патча у Вас по-прежнему показывает значение менее 4 Гб, то Вы можете скачать готовый файл ntkr128g.exe и скопировать его в папку C:\Windows\System32:

http://file.qip.ru/file/1C7BVO4j/ntkr128g.html

Если и после этого у Вас не появится 4 гб памяти, то видимо Ваша оперативная память не отдает доступ к необходимым адресам памяти.
Следовательно для использования полностью всей оперативной памяти рекомендую Вам установить 64-битную Windows.

Назад на страницу раздела Тонкие настройки.


9. Изменение папки открываемой по умолчанию в Проводнике.

Настраиваем нажатие на кнопку Проводник (Windows Explorer), чтобы оно приводило в указанную Вами папку, вместо Libraries.

1) Нажмите правой кнопкой мыши на значок Проводника в Панели задач.
2) Нажмите правой кнопкой мыши на Проводник
3) Нажмите левой кнопкой мыши на Свойства
4) Измените поле Объект (Target) на %SystemRoot%\explorer.exe /n, /e, С:\My Folder
где C:\My Folder - путь к Вашей папке.
Для запуска папки Компьютер измените на значение: %SystemRoot%\explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Чтобы это изменение затронуло и ссылку в меню Пуск, то вам потребуется изменить поле Объект в свойствах ярлыка Проводник в папке Стандартные (Accessories) из меню Пуск.
Комбинация клавиш Win+E откроет Проводник в «Компьютере»

Назад на страницу раздела Тонкие настройки.


10. Добавление или прямой запуск папки Все задачи (для разработчиков и тестеров), и других системных папок.

10. Добавление или прямой запуск папки Все задачи (для разработчиков и тестеров).

Для быстрого доступа разработчиков и тестеров ко всем системным задачам в бета версиях Windows, была создана специальная папка Все задачи, содержащая Список задач всех программ. В финальных версиях Windows её так и не убрали, а поэтому и Вы можете воспользоваться ею для быстрого доступа к нужной Вам задаче.

Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}

Также Вы можете запустить её напрямую. Для запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win+R) и введите команду:

shell:::{ED7BA470-8E54-465E-825C-99712043E01C}

Назад на страницу раздела Тонкие настройки.


11. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows.

Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Нажмите кнопку "Пуск",
2) Перейдите в "Панель управления" и там выберите "Центр специальных возможностей".
3) Выберите параметр "Использование компьютера без экрана" или "Облегчение сосредоточения"
4) Находите «Как долго должны оставаться открытыми диалоговые окна уведомлений Windows?» и выставляете из выпадающего списка то время, которое Вам нужно.

В выпадающем списке выберите подходящее для Вас значение.

Назад на страницу раздела Тонкие настройки.


12. Использование рисунков из вложенных папок в окне "Фоновый рисунок рабочего стола".

У многих пользователей есть папка, в которой они хранят различные необходимые им изображения. Назовем её, для примера, Pictures. Внутри этой папки, часто находятся вложенные папки, с разной тематикой рисунков.

Если в настройках фонового рисунка рабочего стола, вызываемых:
1) ПКМ на Рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола
2) Пуск\Панель управления\Все элементы панели управления\Персонализация\Фоновый рисунок рабочего стола
Вы попытаетесь указать вашу папку Pictures, то далее увидите либо рисунки, находящиеся только в ней, либо надпись: «Нет элементов, удовлетворяющих условиям поиска», если в самой папке Pictures не будет рисунков. Так как подпапки поддерживаются только в системной папке C:\Windows\Web\Wallpaper, используемой Windows для хранения фоновых рисунков рабочего стола по умолчанию.

Если же Вы хотите использовать собственную папку, с вложенными в неё подпапками и не менять значение системной папки находящийся в реестре(Win+R –> Regedit –> OK) по адресу:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\knownfolders\0\Windows Wallpapers\MergeFolders
cо значения %SystemRoot%\web\wallpaper на Ваше собственное, к примеру: D:\Nickname\Pictures, то есть нужный Вам вариант решения.

Вы можете создать новую библиотеку и добавить в неё Ваши папками.

1) Открываете папку Библиотеки. У кого она удалена из проводника, тот может открыть её введя в адресную строку Windows Explorer:

2) Нажимаете ПКМ -> Создать -> Библиотека
3) Переименовываете её. Например: Обои для рабочего стола
4) Щелкаете ПКМ и выбираете Свойства
5) Добавляете отдельно каждую папку
6) В графе Оптимизировать эту библиотеку: выбираете Изображения
7) Нажимаете применить, затем Ок.
8) После этого открываем раздел Персонализация –> Фон рабочего стола -> и в меню Расположение изображения с помощью кнопки Обзор... указываем путь к только что созданной нами библиотеке.

Внимание: Вы можете спокойно удалить созданную Вами библиотеку из общего списка библиотек, что никак не повлияет на Ваши файлы. Однако если Вы удалите любой файл из папки, созданной Вами библиотеки- он также удалиться из системы(из той папки, в которой он находится).

Для облегчения работы с библиотеками Вы можете воспользоваться программой Librarian. Librarian - это утилита управления библиотеками Windows 7.

Программа расширяет стандартный функционал Windows 7 в области управления библиотеками.

Её ключевые возможности:
- Создание библиотеки из произвольного набора папок.
- Смена значка библиотеки на выбранный пользователем. Вы можете задач значок библиотеки, используя стандартный диалог Windows, вызываемый при смене значка ярлыка.
- Переименование библиотеки.
- Указание типа содержимого новой или редактируемой библиотеки.
- Смена папки, используемой по умолчанию для сохранения файлов в библиотеку.
- Управление отображением библиотеки в панели навигации проводника.
- Отображение библиотеки в виде XML-файла.
- Отображение системного диалога папок, включенных в библиотеку.

Скачать данную программу можно здесь или здесь

Назад на страницу раздела Тонкие настройки.


13. Увеличение скорости работы USB-мыши, с помощью повышения опросов USB-порта.

Вы любите играть в игры, где важна быстрота реакции, но Ваша USB-мышь не относится к классу игровых мышек - просто увеличьте частоту опросов USB мыши. Например: игровая мышь Logitech G7 имеет частоту опроса равную 530 MHz, а обычная 125 MHz.

Для установки необходимы права локального администратора.

1) Скачайте архив MouseRate.zip и распакуйте его в папку.
2) Откройте папку Direct Input Mouse Rate и в ней запустите программу dimr.exe
3) Подвигайте максимально быстро курсором Вашей мыши по экрану.
4) Запомните значение из графы Peak - это максимальная величина опросов Вашей мышки.
5) Откройте папку HIDUSBF
6) Нажмите правой кнопкой мыши на файл HIDUSBF.INF и выберите пункт Установить.
7) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
8) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

Если у Вас появится сообщение о неподписанных драйверах - не волнуйтесь, все нормально. Подпишем его программой Driver Signature Enforcement Overrider, о которой упоминалось в совете Как добавить подпись к драйверам? из раздела Установка. На время её работы UAC(Контроль учетных записей пользователей) в Windows должен быть отключен.

1) Запустите файл dseo13b.exe из папки Driver Signature Enforcement Overrider и выберите там "Enable Test Mode".
2) Перезапустите компьютер.
3) После перезапуска снова откройте файл dseo13b.exe и выберите "Sign a system file".
4) В окне пропишите: "C:\Windows\System32\Drivers\HIDUSBF.sys". Если вы сделали это правильно, то вы увидите сообщение: "Система была подписана успешно" ("The system file has been signed succesfully")
5) Снова перезапустите компьютер.
6) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
7) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

Назад на страницу раздела Тонкие настройки.


14. Перемещение системных папок и изменение их путей.

Перенос системных папок лучше сделать сразу после установки Windows, до установки программ и драйверов, т.к. при установке драйверов и в особенности программ будут создаваться каталоги и ярлыки в эти самые системные папки. Если Вы используете для хранения файлов системные папки, то перенос системных папок пользователя на не системный диск, поможет Вам сохранить свои файлы. В случае сбоя Windows, при её переустановке заданные по умолчанию системные папки будут затерты полностью, со всеми находящимися в них файлами. Но если Вы зададите свои пути к системным папкам, то всё их содержимое останется целым.

Раньше в предыдущих версиях Windows, чтобы переместить какую-либо системную папку или изменить её путь, Вам надо было править нужное Вам значение в одной из следующих веток реестра:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Компания Microsoft понимая, что многие пользователи могут захотеть переместить свои системные папки, упростила пользователям эту задачу, избавив их от надобности редактировать реестр. Для перемещения системных папок и изменения их путей продеайте следующее:

1) Создайте новую папку, желательно с аналогичным перемещаемой папке наименованием.
2) Откройте в Windows Explorer: Рабочий стол\Ваш Профиль (Например: Рабочий стол\Администратор)
3) Щелкните правой кнопкой мыши на название папки, которую Вы собираетесь переместить (Например: Мои Документы) и выберите Свойства.
4) Откройте вкладку Расположение
5) Нажмите кнопку Переместить и укажите путь к созданной Вами новой папке
6) Далее система спросит Вас: Переместить все файлы из старого расположения в новое? (Рекомендуемый ответ - Да)
7) Соглашаетесь с новыми параметрами применяя их и выходите.
8) Перезагружаете Компьютер.

Назад на страницу раздела Тонкие настройки.


15. Скрытие выбранных дисков из окна папки "Компьютер".

Если Вы используйте флэш-диск для ускорения работы системы (ReadyBoost) или у Вас установлен картридер который Вы используйте для чтения только одного типа карт, то у Вас может появится желание скрыть выбранные Вами диски из папки Компьютер. Чтобы сделать это Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1.

1) Откройте меню Пуск, введите в строке поиска gpedit.msc и нажмите Enter. (Win+R -> gpedit.msc )
2) Перейдите по пути слева Конфигурация пользователя -> Административные шаблоны -> Компоненты Windows -> Проводник Windows..
3) Щелкните дважды по параметру Скрыть выбранные диски из окна "Мой компьютер".
4) Установите переключатель на значение Включить.
5) В раскрывающемся списке выберите одну из предложенных комбинаций и нажмите ОК.

Вариант 2.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр NoDrives типа DWORD
4) Значение данного параметра обрабатывается Windows в двоичной системе исчисления, но указывается в реестре в десятичной или шестнадцатеричной.
Для расчета двоичного значения воспользуйтесь таблицей.

Z | Y | X | W | V | U | T | S | R | Q | P | O | N | M | L | K | J | I | H | G | F | E | D | C | B | A
0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0

В данной таблице каждой букве соответствует цифра, которая может быть либо единицей, либо нулём. Единица означает "скрыть диск", ноль - "показать диск".
Для получения числа в двоичной системе исчисления замените для диска который Вы желаете скрыть цифру 0 на цифру 1.

Например, для скрытия дисков A, B, F, G заменив цифры с 0 на 1 получится следующий вид:

Z | Y | X | W | V | U | T | S | R | Q | P | O | N | M | L | K | J | I | H | G | F | E | D | C | B | A
0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 1 | 0 | 0 | 0 | 1 | 1

Так как значение параметра формируется Windows в двоичной системе исчисления, а для добавления в реестр Вам необходимо данное значение в шестнадцатиричной или десятиричной системе, то для преобразования значения из одной системы исчисления в другую воспользуйтесь калькулятором Windows.

5) Запустите Калькулятор (Пуск -> Все программы -> Стандартные)
6) В меню программы нажмите Вид и выберите значение Программист
7) Установите переключатель в значение Bin
8) Введите значение полученное с помощью таблицы. В моем примере это число 1100011.
9) Установите переключатель в значение Dec
10) Скопируйте полученное число(Правка -> Копировать или Ctrl+C) в буфер обмена или запомните его. В моем примере 99.
11) Закройте калькулятор и вернитесь в редактор реестра.
12) Измените значение параметра NoDrives на полученное Вами в калькуляторе значение.

12.1) Щелкните правой кнопкой мыши по параметру и выберите пункт Изменить...
12.2) Установите переключатель на значение Десятичная
12.3) В текстовое поле введите запомненное Вами число из калькулятора или нажмите Ctrl+V, если Вы копировали в буфер обмена.

Назад на страницу раздела Тонкие настройки.


16. Добавление элементов в контекстное меню "Отправить".

При попытке открыть более 15 элементов сразу используя меню, вызываемое правой кнопкой мыши в Проводнике, пункт меню Открыть пропадет. Если Вам необходимо открыть большее количество элементов одновременно, то Вы можете сделать это добавив нужную Вам программу в контекстное меню "Отправить".
Чтобы добавить свою программу в контекстное меню "Отправить". Сделайте следующее:

1) Откройте папку C:\Users\UserName\AppData\Roaming\Microsoft\Windows\SendTo , где UserName - Ваше имя пользователя.
Также Вы можете открыть данную папку так:
1.1) В адресной строке Проводника введите команду shell:SendTo и нажмите Enter.
1.2) Нажмите Win+R, введите команду shell:SendTo и нажмите Enter.
2) Создайте в открывшейся папке ярлык для необходимой Вам программы:
2.1) Используйте меню, вызываемое правой кнопкой мыши. Создать -> Ярлык -> Укажите расположение программы -> Введите имя ярлыка
2.2) Удерживая нажатой клавишу Alt скопируйте Вашу программу в вышеуказанную папку и переименуйте ярлык.

Назад на страницу раздела Тонкие настройки.


17. Быстрое добавление своего ярлыка папки или программы в папку Компьютер.

Скопируйте необходимый Вам ярлык в папку C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Windows\Network Shortcuts
где Имя пользователя - это имя Вашей учетной записи (Например: Администратор).

Назад на страницу раздела Тонкие настройки.


18. Замена элементов в диалоговом окне открытия/сохранения файлов.

Вы можете заменить стандартные папки из диалогового окна открытия/сохранения файлов на указанные Вами.

1) Откройте меню Пуск
2) В строке поиска введите gpedit.msc
3) Откройте папку Конфигурация пользователя\Административные шаблоны\Компоненты Windows\Проводник Windows.\Общее диалоговое окно открытия файлов
4) Сделайте двойной щелчок мышью на Элементы, отображаемые в панели мест
5) Установите переключатель на значение Включить
6) Введите в текстовых полях напротив Элементов, пути к папкам и нажмите ОК.
Для добавления папки Рабочий стол необходимо ввести: shell:desktop

Назад на страницу раздела Тонкие настройки.


19. Изменение настроек режима самовосстановления для повышения производительности Windows.

Если Вы периодически, не реже раза в неделю, делаете проверку файловой системы и пустого дискового пространства используя утилиту CHKDSK, то возможно Вас заинтересует изменение настроек режима самовосстановления. Это изменение позволит Вам повысить производительность Вашей операционной системы, путем высвобождения ресурсов затрачиваемых на данный режим.

1) Запустите командную строку (Win+R -> cmd -> OK)
1.1) Нажмите кнопку Пуск и введите в строке поиска cmd
1.2) Щелкните правой кнопкой мыши на найденном файле и выберите пункт "Запуск от имени администратора"
2) Проверьте состояние функции самовосстановления, для этого введите в командной строке и нажмите Enter:

Где ИМЯ_ДИСКА - буква присвоенная жесткому диску или одному из его разделов. Например:

3) Включите режим отображения системой BSOD (синего экрана смерти) при обнаружении программой CHKDSK ошибки. Данное действие необходимо для получения возможности смены режима самовосстановления. Введите в командной строке и нажмите Enter:

4) Перезагрузите компьютер.
5) Снова запустите командную строку от имени администратора.
6) Переключите режим общего восстановления, в режим однократной проверки ошибок при первом случае повреждения. Для этого введите в командной строке и нажмите Enter:

7) Отключите режим отображения системой BSOD (синего экрана смерти) при обнаружении программой CHKDSK ошибки. Для этого введите в командной строке и нажмите Enter:

8) Перезагрузите компьютер.

Вы можете отключить функцию самовосстановления как у отдельных дисков (разделов), так и у всех сразу, повторив приведенный выше порядок действий для каждого из них. Данное решение работает только с дисками отформатированными в файловую систему NTFS.

Внимание. Побочным эффектом при выборочном отключении проверки (на отдельных дисках) может быть срабатывание защитного антивирусного программного обеспечения.

Назад на страницу раздела Тонкие настройки.


20. Изменение стандартной мелодии запуска Windows 7.

В предыдущих версий Windows, стандартная мелодия запуска находилась в папке C:\Windows\Media.
В операционной системе Windows 7 стандартная мелодия запуска содержится в файле библиотеки: imageres.dll, находящемся в папке C:\Windows\System32
Для изменения данного файла воспользуйтесь программами: Restorator или PE Explorer.
Перед изменением файла убедитесь, что у Вас очищена папка C:\Windows\rescache

В программе PE Explorer:

1) Откройте файл imageres.dll
2) Нажмите комбинацию клавиш Ctrl+R или перейдите в меню View -> Resources
3) Откройте папку WAVE, щелкните правой кнопкой мыши на ресурс 5080 и выберите пункт Edit Resource
4) В открывшемся окне нажмите комбинацию клавиш Ctrl+O или на значок папки со стрелочкой.
5) Выберите мелодию в формате WAV для замены, после нажмите ОК, а затем Yes

В программе Restorator:

1) Откройте файл imageres.dll
2) Откройте папку WAVE и перетяните на ресурс 5080 файл, которым Вы хотите заменить мелодию запуска.
3) Сохраните внесенные изменения нажав Ctrl+S

Назад на страницу раздела Тонкие настройки.


21. Отключение Журналирования для ускорения работы диска и освобождения дискового пространства.

Чтобы отключить журналирования для диска, сделайте следующее:

1) Запустите командную строку (Win+R -> cmd -> OK)
2) Введите в командной строке:

где H: - буква диска для которго необходимо отключить журналирование.

Если возникнет необходимость включить журналирование опять, то сделать сделайте следующее:

1) Запустите командную строку (Win+R -> cmd -> OK)
2) Введите в командной строке:

Назад на страницу раздела Тонкие настройки.


22. Распределение файла подкачки между несколькими жесткими дисками для увеличения производительности системы.

Файл подкачки (Pagefile.sys) — это скрытый файл на жестком диске компьютера, который используется системой Windows по принципу оперативной памяти. Файл подкачки и физическая память вместе составляют виртуальную память. По умолчанию Windows хранит файл подкачки в разделе, в котором установлена операционная система.
Рекомендуемый размер файла подкачки должен быть примерно в 1,5 - 3 раза больше общего объема оперативной памяти.

Если у вас установлено 2 (или более) жестких диска,то для повышения быстродействия работы системы оптимальным решением будет создание одного файла подкачки в загрузочном разделе, а второго — в разделе, который используется реже (на другом жестком диске, если такой имеется). Кроме того, для второго файла подкачки по возможности лучше всего отвести отдельный раздел, где нет других данных и системных файлов. Система в первую очередь использует файл подкачки из менее загруженного раздела (а не файл подкачки из загрузочного раздела, количество обращений к которому намного больше).

По умолчанию система использует файл подкачки динамически, то есть размер файла изменяется автоматически, в зависимости от текущей потребности операционной системы. В большинстве же случаев наилучшая производительность системы достигается при статическом размере файла подкачки, так как это не требуется каждый раз изменять размер файла подкачки, что снижает его фрагментацию.

Учитывая описанное выше сделайте следующее:

1) Откройте Панель управления -> Система.
2) Слева в списке нажмите ссылку Дополнительные параметры системы.
3) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
4) Откройте вкладку Дополнительно и в разделе Виртуальная память нажмите кнопку Изменить.
5) Снимите флажок Автоматически выбирать объем файла подкачки.
6) Выберите диск, на котором Вы хотите создать файл подкачки.
7) Установите переключатель в значение Указать размер
8) Введите в поля Исходный размер (МБ) и Максимальный размер (МБ) одинаковые размеры создаваемого файла подкачки в мегабайтах, равного величине в 1,5 - 3 раза больше общего объема оперативной памяти.
9) Нажмите кнопку Задать,
10) Выберите следующий диск и проделайте указанные выше операции, после чего нажмите кнопку ОК.
11) Перезагрузите компьютер.

Назад на страницу раздела Тонкие настройки.


23. Регистрация необходимых и выгрузка из памяти неиспользуемых библиотек (dll-файлов).

Чтобы загрузить в память определенную библиотеку (dll-файл) Вам необходимо ее зарегистрировать. Для того, чтобы это сделать введите команду:

Если dll-файл расположен в системной папке (System32), то:

Например:

Если dll-файл расположен не в системной папке, то:

Например:

Чтобы выгрузить из памяти определенную библиотеку (dll-файл) Вам необходимо отменить ее регистрацию.

Если dll-файл расположен в системной папке (System32), то:

Например:

Если dll-файл расположен не в системной папке, то:

Например:

Если Вам необходимо освободить часть оперативной памяти, то Вы можно сделать это добавив в реестр параметр, отвечающий за автоматическую выгрузку из памяти неиспользуемых библиотек.

1) Запустите редактор реестра (Win+R->regedit->ОК)
2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer
3) В меню Правка выберите Создать -> Параметр DWORD (32 бита).
4) Задайте имя параметра AlwaysUnloadDll
5) Дважды щелкните на данном параметре и введите значение 1.
6) Закройте редактор реестра и перезапустите компьютер.

Назад на страницу раздела Тонкие настройки.


Виртуализация

1. Работа с виртуальными жесткими дисками (VHD-файлами) в Windows 7.

VHD (Virtual Hard Disk) - это формат файлов, используемых виртуальными машинами для эмуляции жесткого диска. Вы сможете создать себе виртуальный диск и использовать его для хранения виртуальных операционных систем, программ и других файлов в одном файле-образе, который можно открыть различными программами виртуализации или виртуальными машинами. Виртуальные жесткие диски позволяют нескольким операционным системам одновременно находиться на одном компьютере.

Вариант 1. Работа с виртуальными дисками используя графический интерфейс.

Создание виртуального жесткого диска.

1) Откройте меню Пуск.
2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win+R) введите diskmgmt.msc и нажмите Enter.
3) Откроется оснастка "Управление дисками". В панели меню выберите пункт Действие и нажмите на Создать виртуальный жесткий диск

Рисунок 1 из 13

4) В открывшемся окне укажите:

Рисунок 2 из 13

4.1) Имя файла и его расположение. Вы можете как написать это вручную, так и нажав на кнопку Обзор и воспользовавшись диалоговым окном Просмотр файлов виртуального диска
4.2) Размер виртуального диска. Возле текстового поля, в которое нужно ввести размер диска, присутствует раскрывающийся список, где можно выбрать размер жесткого диска. Доступные значения – мегабайты, гигабайты и терабайты. Создайте размер не меньше 20 ГБ.
4.3) Тип виртуального диска. Динамически расширяемый дисковый образ обеспечивает объем пространства, необходимый для хранения данных.
Размер VHD-файла в момент создания диска небольшой, но увеличивается по мере добавления данных на диск. Распределение данных осуществляется в блоках. При удалении данных с виртуального жесткого диска размер VHD-файла автоматически не уменьшается. Фиксированный размер создает VHD-файл, размер которого задается при создании виртуального жесткого диска. Размер VHD-файла остается постоянным независимо от объема хранимых данных.
5) Нажмите на кнопку «ОК».

Чтобы диспетчер локальных дисков смог получить доступ к созданному Вами виртуальному диску его необходимо инициализировать и создать на нем простой том. Для этого также используется оснастка "Управление дисками".

Инициализация виртуального жесткого диска.

1) Найдите Ваш виртуальный диск и щелкните на нем правой кнопкой мыши
2) Нажмите на пункт Инициализировать диск

Рисунок 3 из 13

3) Выберите стиль разделов - MBR и нажмите OK

Рисунок 4 из 13

Создание простого тома на виртуальном жестком диске.

После того как Вы проинициализировали Ваш виртуальный диск, на нем необходимо создать простой том.

1) Найдите Ваш виртуальный диск и щелкните на нераспределенной области справа от него
2) Нажмите на пункт Создать простой том

Рисунок 5 из 13

3) В первом диалоге Мастера создания простого тома нажмите на кнопку Далее
4) В диалоге указания размера тома, укажите размер будущего тома в мегабайтах и нажмите на кнопку Далее

Рисунок 6 из 13

5) В диалоге Назначение буквы диска или пути укажите букву для будущего диска и нажмите на кнопку Далее

Рисунок 7 из 13

6) В диалоге Форматирование раздела укажите нужную файловую систему, размер кластера, название диска и установите флажок возле опции Быстрое форматирование - для того, чтобы диск был сразу отформатирован. После чего нажмите на кнопку Далее

Рисунок 8 из 13

7) Для принятия всех настроенных параметров в диалоге Завершение мастера создания простого тома нажмите на кнопку Готово.
8) Виртуальный диск появится в таблице дисков. В оснастке управления дисками, значок виртуального диска визуально отличается от значков физических дисков. В проводнике Windows виртуальные диски выглядят так же, как и физические.

Рисунок 9 из 13

Присоединение виртуального жесткого диска.

Если у Вас уже имеется созданный виртуальный жесткий диск, то Вы также можете присоединить его в оснастке "Управление дисками".

1) Откройте меню Пуск.
2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win+R) введите diskmgmt.msc и нажмите Enter.
3) В панели меню выберите пункт Действие и нажмите на Присоединить виртуальный жесткий диск.

Рисунок 10 из 13

4) Укажите расположение для виртуального жесткого диска на компьютере и нажмите OK Указать расположение Вы можете либо введя значение вручную, либо нажав на кнопку Обзор, и используя диалоговое окно Просмотр файлов виртуального диска. Если Вам не нужно записывать данные на диск, то в этом диалоге можно установить флажок Только для чтения.

Рисунок 11 из 13

Отсоединение (удаление) виртуального жесткого диска.

1) Найдите виртуальный диск, который хотите отсоединить, нажмите на нем правой кнопкой мыши
2) Нажмите на пункт Отсоединить виртуальный жесткий диск

Рисунок 12 из 13

3) Если Вы желаете отсоединить виртуальный диск без удаления его из системы, то нажмите OK. Для полного удаления диска из системы, отметьте Удалить виртуальный диск после удаления диска и после этого нажмите OK.

Рисунок 13 из 13

Вариант 2. Работа с виртуальными дисками используя программу Diskpart в командной строке.

Создание виртуального жесткого диска.

1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
2) В командной строке наберите Diskpart и нажмите Enter
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для создания виртуального диска воспользуйтесь командой Create Vdisk. Синтаксис команды следующий:

Где:

File=<"имя_файла"> - Указание полного пути и имени файла виртуального диска.
Maximum=<n> - Максимальное дисковое пространство, предоставляемое виртуальным диском, заданное в мегабайтах (МБ).
[Type={Fixed|Expandable}] - Используется для указания формата виртуального диска. Существует два значения для данного параметра:
Fixed создает файл виртуального диска фиксированного размера;
Expandable создает динамически расширяемый образ виртуального диска.
[Source=<"имя_файла">] - Путь к существующему файлу виртуального диска для предварительного заполнения нового файла виртуального диска. При использовании параметра Source данные из исходного файла виртуального диска копируются блок за блоком в создаваемый файл виртуального диска. Если Вы при копировании динамического диска не укажете параметр Type=Expandable, то копия будет создана максимального размера выделенного для исходного диска, независимо от его текущего размера.

Примеры использования команды:

Рисунок 1 из 3

Присоединение виртуального жесткого диска.

1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
2) В командной строке наберите Diskpart и нажмите Enter Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk. Синтаксис команды следующий:

Пример использования команды:

4) Для присоединения выбранного виртуального диска воспользуйтесь командой Attach Vdisk. Синтаксис команды следующий:

[Readonly] - Присоединяет виртуальный диск в режиме только для чтения. Любая операция записи приведет к возникновению ошибки ввода-вывода устройства.
[Usefilesd] - Указывает, что для виртуального диска следует использовать дескриптор безопасности самого виртуального файла. Если параметр не указан, то у диска не будет явно заданного дескриптора безопасности, если не был также задан параметр SD=(строка SDDL).
[SD=<строка sddl>] - Задает дескриптор безопасности в формате SDDL. По умолчанию дескриптор безопасности обеспечивает доступ, аналогичный любому физическому диску. Дополнительные сведения о формате строки SDDL см. в справке по команде Create Vdisk.

Примеры использования команды:

Рисунок 2 из 3

Отсоединение виртуального жесткого диска.

1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
2) В командной строке наберите Diskpart и нажмите Enter
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk.
4) Для отсоединения выбранного виртуального диска воспользуйтесь командой Detach Vdisk.

Рисунок 3 из 3

2. Создание загрузочного образа ISO Windows 7 из VHD-образа + интеграция LIP.

Для работы нам потребуются программа DISM, входящая в состав Windows 7, либо включенная в WAIK, GimageX (русская старая) или GimageX (английская новая), WinImage и ERD Commander для x86 или x64

Вариант 1

1) Создайте на диске C: папки DVD, VHD, Lip, Mount, Temp и mWim
2) Запускаете утилиту WinImage, открываете в ней VHD-образ. В открывшемся диалоге щелкаете ОК. Выделяете справа все файлы и щелкаете на выделенном правой кнопкой. Выбираете Extract, затем щелкаете Browse и выбираете папку VHD. Чуть ниже выбираете Extract with pathname. Ждете завершения процесса распаковки. Если появится ошибка, просто нажимаете продолжить.

Рисунок 1 из 5

3) Распакуйте образ дистрибутива(ваш ISO), с помощью программы архиватора 7zip в папку C:\DVD
4) Скопируете в папку C:\Lip файл lp.cab и создайте в ней подпапку uLip
5) Запустите командную строку от имени администратора (Win+R -> cmd -> Ok)
6) Распакуйте lp.cab в папку C:\Lip\uLip выполнив в консоли команду:

7) При помощи GimageX узнаете индекс Ultimate

Рисунок 2 из 5

8) Экспортируйте из файла install.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 5 для x86 или 4 для x64) как install.wim

Рисунок 3 из 5

9) При помощи GimageX узнаете индекс Microsoft Windows Setup (x64)

Рисунок 4 из 5

10) Экспортируйте из файла boot.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 2) как boot.wim

Рисунок 5 из 5

11) Перезагрузите компьютер.
Примечание: Комманды DISM Вы можете также выполнять в командной строке ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
12) Запустите командную строку от имени администратора (Win+R -> cmd -> Ok)
13) Монтируете файл C:\mWim\install.wim в папку C:\Mount выполнив в консоли команду:

14) Интегрируете LIP в install.wim

15) Применяете все настройки для русского языка командой:

16) Копируете все файлы и папки из C:\VHD в C:\Mount, кроме папки C:\VHD\Boot и файла C:\VHD\bootmgr (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer)
17) Демонтируете install.wim с сохранением изменений из C:\Mount:

18) Монтируете файл C:\mWim\boot.wim в папку C:\Mount

19) Добавляете в boot.wim русский язык:

20) Добавляете в boot.wim файлы лицензий:

21) Правите текст файла (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\Mount\sources\lang.ini

22) Демонтируете boot.wim с сохранением изменений из C:\Mount:

23) Правите текст файла (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\lang.ini, в котором должно быть следующее:

24) Заменяете файл (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\install.wim в дистрибутиве, файлом C:\mWim\install.wim
25) Заменяете файл (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\boot.wim в дистрибутиве, файлом C:\mWim\boot.wim
26) Перезагружаетесь в Windows
27) Открываете с помощью UltraISO образ дистрибутива. Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
28) Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
29) Сохраняете в другое место или под другим именем.

Вариант 2

1) Открываете меню Пуск, в поле поиска пишите diskmgmt.msc и нажимаете Enter
2) В верхнем меню нажимаете Действие -> Присоединить виртуальный жесткий диск.
3) Указываете местонахождение VHD-образа, жмете ОК

Рисунок 1 из 2

4) Выбираете нужную вам букву для данного диска
5) Установите Windows AIK
6) Запустите программу GImageX и укажите в параметрах как на рисунке:

Source: - путь к виртуальному диску
Destination - путь куда будет сохранен готовый install.wim файл
Name - Имя образа (Windows 7 Ultimate)
Description - Описание образа (Windows 7 Ultimate)
Compression - Сжатие полученного install.wim файла (Maximum)

Рисунок 2 из 2

7) Открываете с помощью UltraISO образ дистрибутива Windows 7
8) Удаляете в папке \Sources файл install.wim
9) Добавляете созданный вами новый install.wim вместо старого.
10) Сохраняете образ под новым именем.
11) Записываете образ на USB флеш-накопитель (флешку) или DVD.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программой DISM Tool. Данная программа позволяет выполнять, все необходимые Вам команды, используя графический интерфейс. С помощью неё Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(используйте пункт Add Packages).

3. Установка и загрузка Windows 7 из VHD-файла.

Вариант 1

Первое, что потребуется - это сам VHD-образ. Второе - необходимо подготовить логический диск. Вы можете воспользоваться любым диском, на котором не установлено никакой другой операционной системы, и на котором имеется 15-25 Гб свободного места. Третье, это утилита WinImage.

1) Запускаете утилиту WinImage.
2) Открываете в Winimage Ваш VHD-образ.
3) В открывшемся диалоге нажимаете ОК.
4) Выделяете справа все файлы
5) Нажимаете на выделенном правой кнопкой мыши и выбираете Extract
6) Нажимаете Browse и выбираете предварительно подготовленный диск.
7) Ниже выбираете Extract with pathname. Ждете завершения процесса распаковки.
8) После завершения распаковки скачиваете утилиту EasyBCD.
9) В окне приложения нажимаете Add/Remove Entries
10) В поле Add entries выбираете имя для Вашей новой ОС (к примеру, Windows 7 - VHD)
11) Указываете тип (Windows Vista/7)
12) Выбираете диск, на который Вы извлекли содержимое образа.
13) Нажимаете Add entry, а затем вверху нажимаете Save. В списке ОС теперь должно быть два пункта.
14) Заходите в раздел Change Settings
15) Выбираете в качестве ОС, загружаемой по умолчанию, Windows 7 - VHD.
16) Нажимаете Save settings и перезагружаете компьютер.

Вариант 2 как основная система.

1) Создайте папку VHD на любом разделе диска.
2) Откройте VHD-образ утилитой WinImage.
3) Выделите справа все файлы, щелкните на выделенном правой кнопкой мыши и выберите Extract.
4) Щелкните Browse и выберите папку VHD. Не забудьте выбрать Extract with pathname. Дождитесь завершения распаковки.
5) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. (Создание образа ERD описано в разделе Разное в совете №9.)
6) Выберите Micosoft Diagnostics and Recovery Toolset -> Explorer и удалите все файлы с диска C:\ (Диск с уже установленной Windows 7). Процесс может быть длительным, ждите.
7) Перенесите все файлы из папки VHD на диск C:/. Папка VHD -> выделите все файлы -> щелкните правой кнопкой -> параметр move to -> выберите диск С:\
8) Удалите папку VHD.
9) Перезагрузитесь снова в ERD Commander. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажмите repair and restart (исправить и перезагрузиться).

Вариант 3 как вторая система.

Способ 1. Автоматически.

1) Создайте папку VHD на любом разделе диска.
2) Откройте VHD-образ утилитой WinImage.
3) Выделите справа все файлы, щелкните на выделенном правой кнопкой мыши и выберите Extract.
4) Щелкните Browse и выберите папку VHD. Не забудьте выбрать Extract with pathname. Дождитесь завершения распаковки.
5) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. (Создание образа ERD описано в разделе Разное в совете №9.)
6) Выберите Micosoft Diagnostics and Recovery Toolset -> Explorer и удалите все файлы с диска C:\ (Диск с уже установленной Windows 7). Процесс может быть длительным, ждите.
7) Перенесите все файлы из папки VHD на диск C:/. Папка VHD -> выделите все файлы -> щелкните правой кнопкой -> параметр move to -> выберите диск С:\
8) Удалите папку VHD.
9) Перезагрузитесь снова в ERD Commander. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажмите repair and restart (исправить и перезагрузиться).
10) После перезагрузки нам станет доступен выбор из двух ОС. Нас интересует вторая Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено). Выберите её и ждите пока закончится настройка системы.
В процессе, компьютер будет два раза перезагружен, не забывайте после каждой перезагрузки выбирать вторую ОС Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено).
11) Если загружаетесь через Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено) , то диск с основной ОС будет недоступен (при загрузке через основную ОС диски доступны все). Если хотите сделать этот диск доступным, воспользуйтесь встроенной утилитой Disk Management (Выполнить -> compmgmt.msc). Открыв Disk Management, Вы увидите что у раздела с основной ОС не назначена буква. Щелкните правой кнопкой мыши на диске, выберите Change Drive Letter and Paths, нажмите Add, выберите любую букву для диска, ОК, диск доступен.

Способ 2. В ручную без Winimage, при помощи программы Bcedit.

Для данного способа используйте программу bcedit, входящую в состав средств Windows или средств Восстановления.

1) Запустите командную строку от имени администратора в Windows или в командной строке средств Восстановления, или в Erd Commander (при запуске необходимо выбрать текущую систему). Все дальнейшие команды вводите в командной строке.
2) При помощи указанной команды, скопируйте существующую запись текущей системы с новым названием:

3) Дожидаетесь сообщения «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
Указанный в данном сообщении буквенно-цифровой код, подставляйте в команды, указанные ниже вместо {ID}:
4) Укажите раздел, на котором расположены файлы загрузки (device) и раздел, на котором расположены системные файлы операционной системы (osdevice). Так как у нас виртуальный диск, то значения параметров device и osdevice будут равны.

где X:\DIR\filename.vhd – полный путь к файлу VHD и указание имени файла.
5) Для форсирования автоматического определения в Windows диска через соответствующий уровень абстракции — Hardware Abstraction Layer (разрешать ли операционной системе ускоренное автоматическое определение версии HAL и файла ядра при загрузке), выполните следующую команду:

6)Установите добавленную систему на последнее место в списке загрузок

7) Перезагрузите компьютер

Если посмотреть на диски, присутствующие в системе, будет видно, что помимо виртуального диска на 16 Гб (обведен оранжевым), с которого, собственно, загружена Windows 7, также присутствуют второй раздел виртуального диска на 200 Мб под системные файлы и реальный(!) жесткий диск, установленный на компьютере. Если открыть диск, где ранее располагался vhd-файл, то можно обнаружить, что его размер увеличился до тех самых 16Гб, причем размер этот теперь строго ограничен.

Некоторые сайты также советуют внести в листинг menu.lst(должен появится при загрузке компьютера) следующие изменения:

4. Установка Windows 7 на виртуальный диск в VHD-файл.

Установив систему на виртуальный диск, в один VHD-файл, Вы получаете такие преимущества по сравнению с обычной системой:
- сможете сделать копию операционной системы просто скопировав VHD-файл
- сможете тестировать бета версии программ, не беспокоясь за систему
- сможете изучать систему, экспериментировать с реестром, не боясь её испортить.

1) Вставьте установочный диск Windows 7 в привод, загрузитесь с него
2) Доходите до шага мастера установки, где Вас просят выбрать или создать тот раздел диска, на который будет установлена Windows 7.
3) Нажмите комбинацию клавиш "Shift+F10".
Это сочетание клавиш предоставит доступ к командной строке. Напечатайте в ней Diskpart и нажмите Enter.
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Введите в DISKPART следующую команду:

Она означает - создать файл win7.vhd расширяемого типа, максимальный размер ограничить 30 Гигабайтами. Замените E: на имя диска, на котором вы хотите хранить создаваемый файл.

4) Смонтируйте VHD-файл, чтобы он был доступен программе установки:

5) После успешного выполнения всех операций, набираете команду exit для выхода из утилиты diskpart, и еще раз команду exit – уже в приглашении CMD.EXE для закрытия командной строки.

Рисунок 1 из 2

6) Вы снова окажетесь в окне Выберите раздел для установки.
7) Нажмите кнопку Обновить, расположенную под списком дисков и Вы увидите Ваш новый диск
8) Так как на нем ещё нет разделов, то будет написано Незанятое место на диске...
9) Выберите его и нажмите Настройка диска
10) Щелкните на кнопке "Создать", укажите объем создаваемого радела и щелкните на кнопке "Применить".
11) Ещё раз убедитесь, что Вы выбрали созданный Вами виртуальный диск и нажмите Далее, игнорируя предупреждение: Невозможно установить Windows на диск...

Рисунок 2 из 2

Процесс установки Windows 7 на раздел VHD-диска продолжится так, как будто это обычный логический раздел жесткого диска. При этом будет не только установлена новая ОС, но и подменен загрузчик на "физическом" системном разделе для успешного старта с VHD. При установке Windows 7 на "чистую" систему, мастер установки автоматически создаст на диске системный раздел в 100МБ, на котором помещается загрузчик, а уже для самой системы создаст отдельный раздел.

5. Конвертирование тома жесткого диска в VHD-файл.

Для создания VHD-файлов из томов жесткого диска, Вам необходимо воспользоваться утилитой Disk2vhd. Она позволяет создать VHD-образ прямо с запущенной операционной системы. Для своей работы, программа использует Модуль теневого копирования тома (Volume Snapshot), являющийся функцией используемой операционной системой для создания последовательных снимков томов на определенный момент времени. Таким образом, Вы сможете создать VHD-файл прямо на том же разделе, который в него упаковываете. При создании VHD-файла, программа включает в него только системный том и исключает разделы с данными.

Созданный утилитой виртуальный диск может быть подключен к виртуальной машине как IDE-диск. Не используйте VHD-файл, для загрузки через менеджер загрузки Windows 7 на реальной машине. Windows специальным образом подписывает жесткие диски, и присваивает VHD-диску новый уникальный идентификатор. При попытке загрузки с VHD система выдаст ошибку об отсутствии загрузочного диска или просто перезагрузится без уведомления пользователя. Но при использовании данного VHD-образа в Virtual PC, система отлично стартует и работает.

Для работы с Вашим VHD-файлом Вы также можете использовать оснастку Управление дисками (diskmgmt.msc).
Если снимаете образ системного диска, и у вас есть раздел восстановления (System Reserved), не забудьте включить его в VHD-образ, так как без него система не загрузится. Для создания VHD-файла сделайте следующее:

1) Скачайте программу Disk2vhd
2) Разархивируйте скачанный архив и запустите Disk2vhd
3) В поле под VHD File name укажите путь и имя создаваемого Вами VHD-файла.
4) Установите флажки напротив томов жесткого диска, которые необходимо включить в создаваемый Вами VHD-файл.
5) Нажмите Create

Для создания скриптов утилита поддерживает командную строку:

Укажите какие тома необходимо включить в VHD-файл или используйте * для конвертирования всех томов.

6. Конвертирование DVD-образа Windows 7 в VHD-файл.

Для конвертирования DVD-образа Windows 7 в VHD-файл, Вам потребуются Набор автоматической установки Windows (AIK) для Windows 7 (Размер скачиваемого файла 1,25 ГБ и инструмент командной строки WIM2VHD

WIM2VHD - это сценарий Windows Scripting Host, предназначенный для использования в командной строке и позволяющий создать аппаратно-независимый VHD-файл из инсталляционного диска Windows 7, при инициализации которого система минует стадию начальной загрузки и распаковки файлов и будет готова к определению оборудования компьютера, на котором она запущена.

Суть метода заключается в преобразовании файла install.wim в VHD-файл.

1) Установите Набор автоматической установки Windows (AIK) для Windows 7
2) Поместите скаченный файл WIM2VHD.WSF в папку C:\Program Files\Windows AIK\Tools\x86\, если используете 32-разрядную систему, или в C:\Program Files\Windows AIK\Tools\amd64\, если 64-разрядную.
3) Запустите командную строку с правами администратора, для чего нажмите "Пуск", в поле поиска введите cmd.exe и нажмите Ctrl+Shift+Enter.
4) Перейдите в папку со скриптом используя команду CD . Например:

Для 32-битной Windows:

Для 64-битной Windows:

Измените пути на соответствующие Вашей системе.

5) Запустите скрипт wim2vhd. Для этого, введите в командной строке следующее:

Командная строка расшифровывается так:
Взять файл h:\sources\install.wim, и редакцию Ultimate преобразовать в e:\vhd\win7.vhd

Рисунок 1 из 1

7) Для подключения полученного VHD-файла к имеющемуся загрузчику Windows 7, используйте команду:

Команда дублирует загрузочную запись текущей запущенной Windows 7. Вместо "Windows 7 Virtual" Вы можете написать любое значение.

8) Bcdedit выведет на экран {GUID} только что созданной записи-дубликата - скопируйте его в буфер обмена и используйте для внесения VHD-файла в опции загрузки:

Для информации: Работа скрипта WIM2VHD базируется на использовании утилиты imagex.exe из WAIK. Другие примеры использования скрипта WIM2VHD описаны здесь.

7. Включение Aero Glass в Windows на Virtual PC.

1. Установить Windows 7 на компьютер, к которому вы будете отдалённо получать доступ (VM).
2. Установить Windows 7 на компьютер, с которого вы будете отдалённо получать доступ (host).
3. Сборка Windows 7 на обоих должна быть одинаковой, чтобы всё работало корректно.
4. Компьютер, к которому вы будете получать доступ, должен иметь графический адаптер, поддерживающий Glass, который должен быть включен.
5. Установить Сетевое соединение между двумя компьютерами.

На VM нужно активировать Remote Desktop (не забудьте разрешить доступ приложения в Брандмауэре)
С компьютера host запустите Remote Desktop, введите имя или IP адрес VM. Если вы хотите настроить размер окна, глубину цвета, скорость соединения, то заходите в соответствующие настройки.
Нажмите Connect и вводите логин.

Сессия Remote Desktop стартует, и рабочий стол VM будет показывать DWM эффекты.

В итоге, это не совсем Glass, но этот эффект возможно сделать так, чтобы он выглядел, как Glass, используя разработки команды Remote Desktop.

8. Установка Windows 7 в виртуальную машину VirtualBox.

VirtualBox - специальная программа для создания в памяти ПК виртуальных компьютеров. Каждый виртуальный компьютер может содержать произвольный набор виртуальных устройств и отдельную операционную систему. Область применения виртуальных компьютеров очень широка - от выполнения функций по тестированию ПО до создания целых сетей, которые легко масштабировать, распределять нагрузку и защищать. VirtualBox распространяется бесплатно, с открытым исходным кодом.

1) Скачайте последнюю версию программы VirtualBox с официального сайта: http://www.virtualbox.org/wiki/Downloads
2) Установите ее на свой компьютер.

2.1) Запустите установщик; В первом окне нажмите Next
2.2) Выберите необходимые Вам компоненты для установки и нажмите пункт Next.
2.3) Нажмите Next, а затем Yes для начала установки.
2.4) Нажмите на кнопку Install. Внимание: После нажатия кнопки Install произойдет разрыв связи с сетью (как локальной, так и Интернет)
2.5) В появляющихся окнах Установить программное обеспечение для данного устройства? нажмите на кнопку Установить
2.6) В последнем окне оставьте флажок, чтобы приступить к созданию виртуальной машины сразу или уберите флажок для создания виртуальной машины позднее. Нажмите кнопку Finish. Если Вы убрали флажок, то для запуска программы воспользуйтесь значком на рабочем столе.

3) В главном окне программы нажмите на кнопке Создать. Откроется Мастер создания новой виртуальной машины. Нажмите кнопку Вперед.
4) Введите имя виртуальной машины, в разделе Тип ОС установите значения:
Операционная система: Microsoft Windows
Версия: Windows 7.
Нажмите кнопку Вперед.

Рисунок 1 из 9

5) Введите размер оперативной памяти, выделяемый для виртуальной машины.
Внимание: Память будет выделяться из физической памяти установленной в Вашем компьютере. Не устанавливайте память ниже 512 Мегабайт и выше 50% от размера установленной физической памяти. Нажмите кнопку Вперед.
6) Выберите загрузочный виртуальный жесткий диск. Установите переключатель в значение: Создать новый жесткий диск. Нажмите кнопку Вперед.

Рисунок 2 из 9

7) Откроется Мастер создания нового виртуального диска. Нажмите кнопку Вперед.
8) Выберите тип виртуального жесткого диска. Динамический образ изначально займет немного места, и будет расширяться постепенно. Фиксированный образ сразу создаст диск указанного размера - это может занять продолжительное время. Нажмите кнопку Вперед.

Рисунок 3 из 9

9) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\.VirtualBox.
Выберите размер виртуального жесткого диска. (По умолчанию 20 Гигабайт). Нажмите кнопку Вперед.

Рисунок 4 из 9

10) Нажмите на кнопку Готово и Вы вернетесь в предыдущее окно, где будут указаны параметры создаваемой Вами виртуальной машины. Нажмите на кнопку Финиш в окне Итог, и Вы создадите новую виртуальную машину.

Виртуальная машина для установки на нее Windows 7 создана.

Рисунок 5 из 9

11) Перед началом установки Windows 7 на Вашу виртуальную машину ее необходимо настроить. Для настройки Вашей виртуальной машины нажмите на кнопку Свойства.
12) В разделе настроек из списка слева выберите Дисплей. Установите размер видеопамяти, доступной для виртуальной машины не менее 26 Мегабайт. Поставьте флажки для элементов настроек Включить 3D-ускорение и Включить 2D-ускорение видео.

Рисунок 6 из 9

13) В разделе настроек из списка слева выберите Носители.
14) Нажмите значок DVD-диска рядом с ниспадающим меню в графе Атрибуты.

Рисунок 7 из 9

Если у Вас установочный диск Windows 7 записан на DVD-диск, то вставьте его в DVD-привод и выберите привод с соответствующей буквой. Также установите флажок для Разрешить прямой доступ.
Если у Вас установочный диск Windows 7 имеется в виде ISO-образа, то выберите пункт Выбрать образ оптического диска... нажмите на значок папки, чтобы открыть Менеджер виртуальных носителей
15) В окне Выберите образ оптического диска выберите файл образа и нажмите Открыть. 16) Ваш образ добавится в дерево настроек Носители информации. Нажмите кнопку OK.

Рисунок 8 из 9

17) Вы окажетесь в основном окне программы. Нажмите на кнопку Старт
18) Если появятся информационные окна, то нажмите в них на кнопку OK
19) Щелкните кнопкой мыши внутри экрана виртуальной машины, и в информационном окне нажмите на кнопку Захватить
20) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
21) После завершения установки Windows 7 на виртуальную машину, VirtualBox сразу запустит Вам Windows 7 внутри виртуальной машины.

22) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Right Control.
Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Дополнения гостевой ОС. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Устройства -> Установить Дополнения гостевой ОС

Рисунок 9 из 9

23) Во всплывшем окне Автозапуск нажмите VBoxWindowsAdditions.exe и установите программу.
23.1) В появляющихся окнах контроля учетных записей нажмите Да.
23.2) Для перехода к каждому последующему шагу нажмите Next, для установки кнопку Install, для завершения Finish.
23.3) В появляющихся окнах Установить программное обеспечение для данного устройства? нажмите на кнопку Установить
24) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Машина -> Закрыть -> Выключить машину.
25) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Старт.

9. Установка Windows 7 в виртуальную машину Microsoft Virtual PC.
Microsoft Virtual PC - это мощная программа, которая позволяет эмулировать на одном компьютере работу сразу нескольких виртуальных машин. Каждая из таких машин может находиться под управлением своей собственной операционной системы (Windows любой версии, Netware, Linux, Solaris и т.д.), выполнять уникальную задачу, иметь собственную конфигурацию и т.д.

1) Скачайте последнюю версию программы Virtual PC с официального сайта:
http://www.microsoft.com/downloads/details.aspx?familyid=28c97d22-6eb8-4a09-a7f7-f6c7a1f000b5&displaylang=en
2) Установите программу. Внимание программа установки без предупреждения выключит соединение с сетью (как локальной, так и Интернет).
3) Скачайте и установите обновление KB958162.msp для Virtual PC
4) Запустите программу. Нажмите кнопку Пуск -> Все программы -> Microsoft Virtual PC
5) В окне с надписью: "You are not running on a supported operating system" нажмите ОК.
6) В окне New Virtual Machine Wizard нажмите кнопку Next. Данное окно Вы также можете запустить нажав кнопку New в Virtual PC Console или в меню File выбрать New Virtual Machine Wizard.

Рисунок 1 из 7

7) Установите переключатель на Create a Virtual Machine. Нажмите кнопку Next.

Рисунок 2 из 7

8) Выберите имя и расположение для файла Вашей виртуальной машины. По умолчанию имя файла New Virtual Machine, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\Documents\My Virtual Machines. Нажмите кнопку Next.
9) Выберите тип операционной системы. В связи с отсутствием пункта Windows 7 в Virtual PC, выберите Windows Vista или Other. Нажмите кнопку Next.

Рисунок 3 из 7

10) Установите переключатель на Adjusting the RAM. Выберите необходимое Вам количество оперативной памяти выделяемое виртуальной машине, не менее 512 Мегабайт. Нажмите кнопку Next.

Рисунок 4 из 7

11) Установите переключатель на A new virtual hard disk, чтобы создать новый виртуальный образ. Нажмите кнопку Next.
12) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, к котрой добавлено Hard Disk, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке:
C:\Users\UserName\Documents\My Virtual Machines\ИмяВиртуальнойМашины\
Укажите величину создаваемого вами виртуального жесткого диска в мегабайтах. Рекомендую указать 20480 Мб (20 Гб). Для информации: 1 Гб = 1024 Мб. Нажмите кнопку Next.

Рисунок 5 из 7

13) Нажмите кнопку Finish, для создания виртуальной машины. Вы снова окажетесь в окне Virtual PC Console.
14) Выберите созданную Вами виртуальную машину и нажмите кнопку Start
15) Виртуальная машина начнет свою работу и остановится с сообщением: Reboot and Select proper Boot device or Insert Boot Media in selected Boot device, поскольку отсутствует инсталляционный диск с Windows 7. Выберите команду CD>Capture CD Image и укажите образ ISO с Windows 7.

Рисунок 6 из 7

16) Перезагрузите виртуальную машину, выбрав команду Action -> Ctrl+Alt+Del или нажав Правый Alt+DEL в окне виртуальной машины.
17) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
18) После завершения установки Windows 7 на виртуальную машину, Microsoft Virtual PC сразу запустит Вам Windows 7 внутри виртуальной машины.
19) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Right Alt.
Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Virtual Machine Additions. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Action –> Install or Update Virtual Machine Additions и нажмите Continue.

Рисунок 7 из 7

20) Во всплывшем окне Автозапуск нажмите Setup.exe и установите программу.
21) Нажмите Yes по окончанию установки Virtual Machine Additions и виртуальная машина перезагрузится.
22) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Action -> Close -> Turn Off и нажмите OK.
23) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Start.

10. Установка Windows 7 в виртуальную машину VMware Workstation.
VMware Workstation — популярная программа для виртуализации систем. VMware Workstation является массивным решением для разработчиков программного обеспечения и системных админов, создающих и тестирующих полно-комплексные сетевые приложения класса серверов, работающие в разнообразных средах.

1) Заходите на страницу официального сайта для скачивания программы: http://downloads.vmware.com/d/
2) Нажимаете на ссылку VMware Workstation
3) На открывшейся странице выбираете для скачивания VMware Workstation X.X.X for Windows (где X.X.X - номер версии)
4) Щелкаете на кнопке Download рядом с Workstation for Windows 32-bit and 64-bit with VMware Tools.
5) Нажимаете на кнопку Register и заполняете регистрационную форму и нажимаете Continue
6) Внизу EULA соглашения нажимаете Yes и оказываетесь на странице загрузки. Программа бесплатна для полнофункционального использования 30 дней. По истечении данного срока Вам необходимо её зарегистрировать.
7) Скачиваете Workstation for Windows 32-bit and 64-bit Main installation file with Tools. В отличие от других виртуальных машин, программа установки VMware Workstation имеет размер более 500 Мегабайт.
8) Установите программу. Перезапустите компьютер, для этого в последнем окне программы нажмите Restart Now или нажмите Restart Later и перезапустите вручную позже.
9) Запустите программу. Установите переключатель на Yes, I accept the terms in the license agreement и нажмите OK
10) В главном окне программы нажмите на значок New Vitual Machine.

Рисунок 1 из 6

11) Установите переключатель на Typical (recommended). Нажмите кнопку Next.

Рисунок 2 из 6

12) Установите переключатель на Installer disk image file (iso). Нажмите кнопку Browse и укажите путь к ISO-образу Windows 7. Нажмите кнопку Next.

Рисунок 3 из 6

13) Укажите свой инсталляционный код Windows 7, имя пользователя и пароль и нажмите кнопку Next. Если Вы решили ввести эти данные позже, то после нажатия кнопки Next, нажмите на кнопку Yes.
14) Выберите имя и расположение для файла Вашей виртуальной машины. Нажмите кнопку Next.

Рисунок 4 из 6

15) Задайте размер Вашего виртуального жесткого диска в гигабайтах.

Рисунок 5 из 6

16) Нажмите кнопку Finish, для создания виртуальной машины.
17) В окне VMware Workstation Activation нажмите Enter Serial Number, чтобы ввести имеющийся у Вас серийный номер. Если у Вас нет серийного номера, то Вы можете получить серийный номер на 30 дней для полнофункционального тестирования программы: https://www.vmware.com/tryvmware/?p=workstation&lp=default
18) После введения пробного номера во всплывшем окне Register your version of VMware Workstation now! нажмите кнопку Register
19) В главном окне программы перейдите на вкладку с названием Вашей виртуальной машины (по умолчанию Windows 7) и нажмите ссылку Power on this virtual machine.

Рисунок 6 из 6

20) В отличие от других виртуальных машин установка Windows 7 начнется сама и большую часть установки VMware Workstation выполнит автоматически, Ваше участие в процессе установки Windows 7 почти не потребуется.
21) После завершения установки Windows 7 на виртуальную машину, VMware Workstation сразу запустит Вам Windows 7 внутри виртуальной машины.
22) Сразу после запуска VMware Workstation самостоятельно установит Вам дополнительные инструменты VMware Tools, а также в случае наличия у Вас подключения к Интернет самостоятельно установит все необходимые драйвера.
23) Используйте комбинацию клавиш Ctrl+G для разблокировки одновременного использования мыши как в виртуальной системе, так и в основной.
24) Чтобы выключить виртуальную машину, завершите работу в виртуальной Windows 7 как в обычной Windows. Пуск -> Завершение работы.
25) Чтобы запустить установленную Windows 7 в основном окне программы в колонке слева выберите наименование Вашей операционной системы. В открывшейся вкладке с названием Вашей виртуальной машины (по умолчанию Windows 7) нажмите ссылку Power on this virtual machine.

11. Создание общей папки для виртуальной и основной Windows в VirtualBox.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VirtualBox и хостовой (реальной) Windows 7, сделайте следующее:

1) В меню запущенной виртуальной машины откройте Устройства -> Общие папки

Рисунок 1 из 4

2) Нажмите на клавиатуре кнопку Insert, либо нажмите на значок папки с плюсом.

Рисунок 2 из 4

3) Установите флажок для параметра Создать постоянную папку.
4) В ниспадающем меню рядом с текстом Путь к папке выберите пункт Другой....
5) Укажите путь к Вашей папке и нажмите на каждую кнопку ОК.

Рисунок 3 из 4

Если Вы хотите, чтобы гостевая ОС автоматически подключала данную папку в процессе загрузки поставьте флажок у Авто-подключение.
Если Вы хотите, чтобы общая папка была постоянной для данной машины установите флажок у Создать постоянную папку, иначе выбранная общая папка будет временной.
6) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Сеть -> VBOXSVR -> Ваша папка

Рисунок 4 из 4

12. Создание общей папки для виртуальной и основной Windows в Microsoft Virtual PC.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину Microsoft Virtual PC и хостовой (реальной) Windows 7, сделайте следующее:

1) В меню запущенной виртуальной машины откройте Edit -> Settings или нажмите сочетание клавиш: правый Alt+E

Рисунок 1 из 4

2) Выберите в списке Shared Folders и нажмите кнопку Share Folder...

Рисунок 2 из 4

3) Установите флажок на Share Every Time, укажите Вашу общую папку и установите букву диска в виде которого будет отображаться папка в виртуальной Windows, затем нажмите OK.

Рисунок 3 из 4

4) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Компьютер -> Отключенное сетевое устройство (назначенная вами буква диска)

Рисунок 4 из 4

13. Создание общей папки для виртуальной и основной Windows в VMware Workstation.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VMware Workstation и хостовой (реальной) Windows 7, сделайте следующее:

1) В вкладке с названием Вашей виртуальной машины (по умолчанию Windows 7) перейдите на вкладку Options.
2) Сделайте двойной щелчок на папке Shared Folders

Рисунок 1 из 4

3) Установите переключатель на Always enabled.

Рисунок 2 из 4

4) Нажмите кнопку Add..., а затем кнопку Next.
5) Нажмите кнопку Browse. Укажите путь к Вашей общей папке в хостовой (реальной) Windows 7 и ее имя в виртуальной Windows, затем нажмите OK.

Рисунок 3 из 4

6) Нажмите кнопку Next, а затем кнопку Finish. Выйдите из опций нажав на OK.
7) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Сеть -> vmware-host -> Shared Folders -> Ваша папка

Рисунок 4 из 4

14. Запуск старых 16-битных приложений и DOS-игр в Windows, используя программу DosBox.

Для запуска старых 16-битных приложений и DOS-игр в Windows, Вы можете использовать программную среду DosBox. Чтобы Вам легче было в ней работать Вы можете воспользоваться одной из предлагаемых на сайте графических оболочек.

1) Скачайте и установите графическую оболочку D-Fend Reloaded
2) Нажмите Файл -> Настройки программы.
3) Перейдите на вкладку Язык в Пользовательский интерфейс и установите значения параметров в соответствии с языковыми требованиями программы, которую Вы собираетесь запустить и нажмите ОК.
4) Чтобы добавить новое 16-битное приложение (DOS-игру), просто перетащите мышкой ZIP-архив с программой или распакованную папку с файлами приложения (игры) в окно программы.
5) В зависимости от выбранного Вами действия, появится окно Импорт архива или окно Импорт папки.
6) В данном окне нажмите ОК и профиль для данной игры добавится в программу, чтобы Вы могли в любой момент запустить её.
7) Нажмите правой кнопкой мыши на созданном профиле игры и выбираете пункт Запустить настройку.
8) Настройте параметры запуска игры и выйдите из программы настройки.
9) Нажмите правой кнопкой мыши на созданном профиле игры и выбираете пункт Запустить программу.

Дополнения:

Переключение между экранным и оконным режимами осуществляется комбинацией клавиш Alt+Tab.
Звуковую карту указывать Sound Blaster/Sound Blaster Pro
Иногда для выхода приходится в ручную вводить команду Exit и нажимать Enter.

15. Отключение синхронизации времени с хостовой системой в виртуальной машине VirtualBox.

Если в виртуальной Windows Вам необходиомо, чтобы при запуске виртуальной системы была установлена уже прошедшая дата и виртуальная машина не синхронизировала данные с основной системой, то выполните указанные ниже действия.

1) Выйдите из виртуальной машины и закройте приложение VirtualBox.
2) Откройте окно команд из папки, куда установлена программа и в которой находится утилита VBoxManage.exe.
Для этого щелкните правой кнопкой мыши по паке, удерживая нажатой клавишу Shift и выберите Открыть окно команд.
3) Введите указанную ниже команду:

Где: <name> - имя Вашей виртуальной машины, а <-msec> - разница в миллисекундах между текущей датой и той, что требуется. Указанное значение будет постоянно отматываться назад.

Для получения необходимого Вам значения в милисекундах воспользуйтесь утилитой Date Offset Calculator

16. Отключение синхронизации времени с хостовой системой в виртуальной машине Microsoft Virtual PC.

Если в виртуальной Windows Вам необходиомо, чтобы при запуске виртуальной системы была установлена уже прошедшая дата и виртуальная машина не синхронизировала данные с основной системой, то выполните указанные ниже действия.

1) Выйдите из виртуальной машины и закройте приложение Microsoft Virtual PC.
2) Откройте в любом текстовом редакторе файл конфигурации Вашей виртуальной машины.
Данный файл расположен в той же папке, где и созданная Вами виртуальная машина (С:\Users\ИмяПользователя\AppData\Local\Microsoft\Windows Virtual PC\Virtual Machines) и имеет расширение .vmс
3) Найдите тег </microsoft> и вставьте перед ним нижеследующий текст:

4) Найдите тег </bios> и вставьте перед ним нижеследующий текст:

В итоге у Вас должно получиться примерно так:

Если у Вас уже имеются указанные разделы, но значения параметров установлены true, то просто измените их на false.

5) Сохраните файл и запустите Virtual PC.
6) Зайдите в BIOS виртуальной машины, и установите необходимую Вам дату и время, и после перезагрузки/выключения машины они не будут синхронизированы с хостовой системой.

17. Отключение синхронизации времени с хостовой системой в виртуальной машине VMware Workstation.

Если в виртуальной Windows Вам необходиомо, чтобы при запуске виртуальной системы была установлена уже прошедшая дата и виртуальная машина не синхронизировала данные с основной системой, то выполните указанные ниже действия.

1) Выйдите из виртуальной машины и закройте приложение VMware Workstation.
2) Откройте в любом текстовом редакторе файл конфигурации Вашей виртуальной машины.
Данный файл расположен в той же папке, где и созданная Вами виртуальная машина (C:\Users\ИмяПользователя\Documents\Virtual Machines) и имеет расширение .vmx
3) Добавьте в конце файла нижеследующие строки:

Параметры с первого до предпоследнего отключают синхронизацию времени с хостовой машиной при различных операциях.
Последний параметр rtc.startTime определяет дату в биосе при запуске машины. Его значение – это требуемая дата в формате Unix Timestamp, равняется количеству секунд прошедших с полночи с 31 декабря 1969 года на 1 января 1970 года до необходимой Вам даты и времени.

Для получения необходимого Вам значения скачайте программу конвертер: Unix Timestamp Converter Unix Timestamp Converter или воспользуйтесь онлайн конвертером: Unix Time Convertion

4) Сохраните файл и перезапустите VMware Workstation.

Внимание: После внесения изменений проверьте отсутствие дублирующихся строк, иначе машина не запустится.


1. Работа с виртуальными жесткими дисками (VHD-файлами) в Windows 7.

VHD (Virtual Hard Disk) - это формат файлов, используемых виртуальными машинами для эмуляции жесткого диска. Вы сможете создать себе виртуальный диск и использовать его для хранения виртуальных операционных систем, программ и других файлов в одном файле-образе, который можно открыть различными программами виртуализации или виртуальными машинами. Виртуальные жесткие диски позволяют нескольким операционным системам одновременно находиться на одном компьютере.

Вариант 1. Работа с виртуальными дисками используя графический интерфейс.

Создание виртуального жесткого диска.

1) Откройте меню Пуск.
2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win+R) введите diskmgmt.msc и нажмите Enter.
3) Откроется оснастка "Управление дисками". В панели меню выберите пункт Действие и нажмите на Создать виртуальный жесткий диск

4) В открывшемся окне укажите:

4.1) Имя файла и его расположение. Вы можете как написать это вручную, так и нажав на кнопку Обзор и воспользовавшись диалоговым окном Просмотр файлов виртуального диска
4.2) Размер виртуального диска. Возле текстового поля, в которое нужно ввести размер диска, присутствует раскрывающийся список, где можно выбрать размер жесткого диска. Доступные значения – мегабайты, гигабайты и терабайты. Создайте размер не меньше 20 ГБ.
4.3) Тип виртуального диска. Динамически расширяемый дисковый образ обеспечивает объем пространства, необходимый для хранения данных.
Размер VHD-файла в момент создания диска небольшой, но увеличивается по мере добавления данных на диск. Распределение данных осуществляется в блоках. При удалении данных с виртуального жесткого диска размер VHD-файла автоматически не уменьшается. Фиксированный размер создает VHD-файл, размер которого задается при создании виртуального жесткого диска. Размер VHD-файла остается постоянным независимо от объема хранимых данных.
5) Нажмите на кнопку «ОК».

Чтобы диспетчер локальных дисков смог получить доступ к созданному Вами виртуальному диску его необходимо инициализировать и создать на нем простой том. Для этого также используется оснастка "Управление дисками".

Инициализация виртуального жесткого диска.

1) Найдите Ваш виртуальный диск и щелкните на нем правой кнопкой мыши
2) Нажмите на пункт Инициализировать диск

3) Выберите стиль разделов - MBR и нажмите OK

Создание простого тома на виртуальном жестком диске.

После того как Вы проинициализировали Ваш виртуальный диск, на нем необходимо создать простой том.

1) Найдите Ваш виртуальный диск и щелкните на нераспределенной области справа от него
2) Нажмите на пункт Создать простой том

3) В первом диалоге Мастера создания простого тома нажмите на кнопку Далее
4) В диалоге указания размера тома, укажите размер будущего тома в мегабайтах и нажмите на кнопку Далее

5) В диалоге Назначение буквы диска или пути укажите букву для будущего диска и нажмите на кнопку Далее

6) В диалоге Форматирование раздела укажите нужную файловую систему, размер кластера, название диска и установите флажок возле опции Быстрое форматирование - для того, чтобы диск был сразу отформатирован. После чего нажмите на кнопку Далее

7) Для принятия всех настроенных параметров в диалоге Завершение мастера создания простого тома нажмите на кнопку Готово.
8) Виртуальный диск появится в таблице дисков. В оснастке управления дисками, значок виртуального диска визуально отличается от значков физических дисков. В проводнике Windows виртуальные диски выглядят так же, как и физические.

Присоединение виртуального жесткого диска.

Если у Вас уже имеется созданный виртуальный жесткий диск, то Вы также можете присоединить его в оснастке "Управление дисками".

1) Откройте меню Пуск.
2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win+R) введите diskmgmt.msc и нажмите Enter.
3) В панели меню выберите пункт Действие и нажмите на Присоединить виртуальный жесткий диск.

4) Укажите расположение для виртуального жесткого диска на компьютере и нажмите OK Указать расположение Вы можете либо введя значение вручную, либо нажав на кнопку Обзор, и используя диалоговое окно Просмотр файлов виртуального диска. Если Вам не нужно записывать данные на диск, то в этом диалоге можно установить флажок Только для чтения.

Отсоединение (удаление) виртуального жесткого диска.

1) Найдите виртуальный диск, который хотите отсоединить, нажмите на нем правой кнопкой мыши
2) Нажмите на пункт Отсоединить виртуальный жесткий диск

3) Если Вы желаете отсоединить виртуальный диск без удаления его из системы, то нажмите OK. Для полного удаления диска из системы, отметьте Удалить виртуальный диск после удаления диска и после этого нажмите OK.

Вариант 2. Работа с виртуальными дисками используя программу Diskpart в командной строке.

Создание виртуального жесткого диска.

1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
2) В командной строке наберите Diskpart и нажмите Enter
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для создания виртуального диска воспользуйтесь командой Create Vdisk. Синтаксис команды следующий:

Где:

File=<"имя_файла"> - Указание полного пути и имени файла виртуального диска.
Maximum=<n> - Максимальное дисковое пространство, предоставляемое виртуальным диском, заданное в мегабайтах (МБ).
[Type={Fixed|Expandable}] - Используется для указания формата виртуального диска. Существует два значения для данного параметра:
Fixed создает файл виртуального диска фиксированного размера;
Expandable создает динамически расширяемый образ виртуального диска.
[Source=<"имя_файла">] - Путь к существующему файлу виртуального диска для предварительного заполнения нового файла виртуального диска. При использовании параметра Source данные из исходного файла виртуального диска копируются блок за блоком в создаваемый файл виртуального диска. Если Вы при копировании динамического диска не укажете параметр Type=Expandable, то копия будет создана максимального размера выделенного для исходного диска, независимо от его текущего размера.

Примеры использования команды:

Присоединение виртуального жесткого диска.

1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
2) В командной строке наберите Diskpart и нажмите Enter Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk. Синтаксис команды следующий:

Пример использования команды:

4) Для присоединения выбранного виртуального диска воспользуйтесь командой Attach Vdisk. Синтаксис команды следующий:

[Readonly] - Присоединяет виртуальный диск в режиме только для чтения. Любая операция записи приведет к возникновению ошибки ввода-вывода устройства.
[Usefilesd] - Указывает, что для виртуального диска следует использовать дескриптор безопасности самого виртуального файла. Если параметр не указан, то у диска не будет явно заданного дескриптора безопасности, если не был также задан параметр SD=(строка SDDL).
[SD=<строка sddl>] - Задает дескриптор безопасности в формате SDDL. По умолчанию дескриптор безопасности обеспечивает доступ, аналогичный любому физическому диску. Дополнительные сведения о формате строки SDDL см. в справке по команде Create Vdisk.

Примеры использования команды:

Отсоединение виртуального жесткого диска.

1) Запустите командную строку от имени администратора (Нажмите Win+R -> наберите cmd -> нажмите OK)
2) В командной строке наберите Diskpart и нажмите Enter
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk.
4) Для отсоединения выбранного виртуального диска воспользуйтесь командой Detach Vdisk.

Назад на страницу раздела Виртуализация.


2. Создание загрузочного образа ISO Windows 7 из VHD-образа + интеграция LIP.

Для работы нам потребуются программа DISM, входящая в состав Windows 7, либо включенная в WAIK, GimageX (русская старая) или GimageX (английская новая), WinImage и ERD Commander для x86 или x64

Вариант 1

1) Создайте на диске C: папки DVD, VHD, Lip, Mount, Temp и mWim
2) Запускаете утилиту WinImage, открываете в ней VHD-образ. В открывшемся диалоге щелкаете ОК. Выделяете справа все файлы и щелкаете на выделенном правой кнопкой. Выбираете Extract, затем щелкаете Browse и выбираете папку VHD. Чуть ниже выбираете Extract with pathname. Ждете завершения процесса распаковки. Если появится ошибка, просто нажимаете продолжить.

3) Распакуйте образ дистрибутива(ваш ISO), с помощью программы архиватора 7zip в папку C:\DVD
4) Скопируете в папку C:\Lip файл lp.cab и создайте в ней подпапку uLip
5) Запустите командную строку от имени администратора (Win+R -> cmd -> Ok)
6) Распакуйте lp.cab в папку C:\Lip\uLip выполнив в консоли команду:

7) При помощи GimageX узнаете индекс Ultimate

8) Экспортируйте из файла install.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 5 для x86 или 4 для x64) как install.wim

9) При помощи GimageX узнаете индекс Microsoft Windows Setup (x64)

10) Экспортируйте из файла boot.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 2) как boot.wim

11) Перезагрузите компьютер.
Примечание: Комманды DISM Вы можете также выполнять в командной строке ERD Commander, чтобы не думать о проблемах доступа к папкам. Создание образа ERD описано в разделе Разное в совете №9.
12) Запустите командную строку от имени администратора (Win+R -> cmd -> Ok)
13) Монтируете файл C:\mWim\install.wim в папку C:\Mount выполнив в консоли команду:

14) Интегрируете LIP в install.wim

15) Применяете все настройки для русского языка командой:

16) Копируете все файлы и папки из C:\VHD в C:\Mount, кроме папки C:\VHD\Boot и файла C:\VHD\bootmgr (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer)
17) Демонтируете install.wim с сохранением изменений из C:\Mount:

18) Монтируете файл C:\mWim\boot.wim в папку C:\Mount

19) Добавляете в boot.wim русский язык:

20) Добавляете в boot.wim файлы лицензий:

21) Правите текст файла (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\Mount\sources\lang.ini

22) Демонтируете boot.wim с сохранением изменений из C:\Mount:

23) Правите текст файла (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\lang.ini, в котором должно быть следующее:

24) Заменяете файл (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\install.wim в дистрибутиве, файлом C:\mWim\install.wim
25) Заменяете файл (Если Вы в Erd Commander, то через Micosoft Diagnostics and Recovery Toolset -> Explorer) C:\DVD\sources\boot.wim в дистрибутиве, файлом C:\mWim\boot.wim
26) Перезагружаетесь в Windows
27) Открываете с помощью UltraISO образ дистрибутива. Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
28) Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
29) Сохраняете в другое место или под другим именем.

Вариант 2

1) Открываете меню Пуск, в поле поиска пишите diskmgmt.msc и нажимаете Enter
2) В верхнем меню нажимаете Действие -> Присоединить виртуальный жесткий диск.
3) Указываете местонахождение VHD-образа, жмете ОК

4) Выбираете нужную вам букву для данного диска
5) Установите Windows AIK
6) Запустите программу GImageX и укажите в параметрах как на рисунке:

Source: - путь к виртуальному диску
Destination - путь куда будет сохранен готовый install.wim файл
Name - Имя образа (Windows 7 Ultimate)
Description - Описание образа (Windows 7 Ultimate)
Compression - Сжатие полученного install.wim файла (Maximum)

7) Открываете с помощью UltraISO образ дистрибутива Windows 7
8) Удаляете в папке \Sources файл install.wim
9) Добавляете созданный вами новый install.wim вместо старого.
10) Сохраняете образ под новым именем.
11) Записываете образ на USB флеш-накопитель (флешку) или DVD.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программой DISM Tool. Данная программа позволяет выполнять, все необходимые Вам команды, используя графический интерфейс. С помощью неё Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(используйте пункт Add Packages).

Назад на страницу раздела Виртуализация.


3. Установка и загрузка Windows 7 из VHD-файла.

Вариант 1

Первое, что потребуется - это сам VHD-образ. Второе - необходимо подготовить логический диск. Вы можете воспользоваться любым диском, на котором не установлено никакой другой операционной системы, и на котором имеется 15-25 Гб свободного места. Третье, это утилита WinImage.

1) Запускаете утилиту WinImage.
2) Открываете в Winimage Ваш VHD-образ.
3) В открывшемся диалоге нажимаете ОК.
4) Выделяете справа все файлы
5) Нажимаете на выделенном правой кнопкой мыши и выбираете Extract
6) Нажимаете Browse и выбираете предварительно подготовленный диск.
7) Ниже выбираете Extract with pathname. Ждете завершения процесса распаковки.
8) После завершения распаковки скачиваете утилиту EasyBCD.
9) В окне приложения нажимаете Add/Remove Entries
10) В поле Add entries выбираете имя для Вашей новой ОС (к примеру, Windows 7 - VHD)
11) Указываете тип (Windows Vista/7)
12) Выбираете диск, на который Вы извлекли содержимое образа.
13) Нажимаете Add entry, а затем вверху нажимаете Save. В списке ОС теперь должно быть два пункта.
14) Заходите в раздел Change Settings
15) Выбираете в качестве ОС, загружаемой по умолчанию, Windows 7 - VHD.
16) Нажимаете Save settings и перезагружаете компьютер.

Вариант 2 как основная система.

1) Создайте папку VHD на любом разделе диска.
2) Откройте VHD-образ утилитой WinImage.
3) Выделите справа все файлы, щелкните на выделенном правой кнопкой мыши и выберите Extract.
4) Щелкните Browse и выберите папку VHD. Не забудьте выбрать Extract with pathname. Дождитесь завершения распаковки.
5) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. (Создание образа ERD описано в разделе Разное в совете №9.)
6) Выберите Micosoft Diagnostics and Recovery Toolset -> Explorer и удалите все файлы с диска C:\ (Диск с уже установленной Windows 7). Процесс может быть длительным, ждите.
7) Перенесите все файлы из папки VHD на диск C:/. Папка VHD -> выделите все файлы -> щелкните правой кнопкой -> параметр move to -> выберите диск С:\
8) Удалите папку VHD.
9) Перезагрузитесь снова в ERD Commander. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажмите repair and restart (исправить и перезагрузиться).

Вариант 3 как вторая система.

Способ 1. Автоматически.

1) Создайте папку VHD на любом разделе диска.
2) Откройте VHD-образ утилитой WinImage.
3) Выделите справа все файлы, щелкните на выделенном правой кнопкой мыши и выберите Extract.
4) Щелкните Browse и выберите папку VHD. Не забудьте выбрать Extract with pathname. Дождитесь завершения распаковки.
5) Перезагрузите компьютер в ERD Commander, чтобы не думать о проблемах доступа к папкам. (Создание образа ERD описано в разделе Разное в совете №9.)
6) Выберите Micosoft Diagnostics and Recovery Toolset -> Explorer и удалите все файлы с диска C:\ (Диск с уже установленной Windows 7). Процесс может быть длительным, ждите.
7) Перенесите все файлы из папки VHD на диск C:/. Папка VHD -> выделите все файлы -> щелкните правой кнопкой -> параметр move to -> выберите диск С:\
8) Удалите папку VHD.
9) Перезагрузитесь снова в ERD Commander. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажмите repair and restart (исправить и перезагрузиться).
10) После перезагрузки нам станет доступен выбор из двух ОС. Нас интересует вторая Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено). Выберите её и ждите пока закончится настройка системы.
В процессе, компьютер будет два раза перезагружен, не забывайте после каждой перезагрузки выбирать вторую ОС Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено).
11) Если загружаетесь через Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено) , то диск с основной ОС будет недоступен (при загрузке через основную ОС диски доступны все). Если хотите сделать этот диск доступным, воспользуйтесь встроенной утилитой Disk Management (Выполнить -> compmgmt.msc). Открыв Disk Management, Вы увидите что у раздела с основной ОС не назначена буква. Щелкните правой кнопкой мыши на диске, выберите Change Drive Letter and Paths, нажмите Add, выберите любую букву для диска, ОК, диск доступен.

Способ 2. В ручную без Winimage, при помощи программы Bcedit.

Для данного способа используйте программу bcedit, входящую в состав средств Windows или средств Восстановления.

1) Запустите командную строку от имени администратора в Windows или в командной строке средств Восстановления, или в Erd Commander (при запуске необходимо выбрать текущую систему). Все дальнейшие команды вводите в командной строке.
2) При помощи указанной команды, скопируйте существующую запись текущей системы с новым названием:

3) Дожидаетесь сообщения «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
Указанный в данном сообщении буквенно-цифровой код, подставляйте в команды, указанные ниже вместо {ID}:
4) Укажите раздел, на котором расположены файлы загрузки (device) и раздел, на котором расположены системные файлы операционной системы (osdevice). Так как у нас виртуальный диск, то значения параметров device и osdevice будут равны.

где X:\DIR\filename.vhd – полный путь к файлу VHD и указание имени файла.
5) Для форсирования автоматического определения в Windows диска через соответствующий уровень абстракции — Hardware Abstraction Layer (разрешать ли операционной системе ускоренное автоматическое определение версии HAL и файла ядра при загрузке), выполните следующую команду:

6)Установите добавленную систему на последнее место в списке загрузок

7) Перезагрузите компьютер

Если посмотреть на диски, присутствующие в системе, будет видно, что помимо виртуального диска на 16 Гб (обведен оранжевым), с которого, собственно, загружена Windows 7, также присутствуют второй раздел виртуального диска на 200 Мб под системные файлы и реальный(!) жесткий диск, установленный на компьютере. Если открыть диск, где ранее располагался vhd-файл, то можно обнаружить, что его размер увеличился до тех самых 16Гб, причем размер этот теперь строго ограничен.

Некоторые сайты также советуют внести в листинг menu.lst(должен появится при загрузке компьютера) следующие изменения:

Назад на страницу раздела Виртуализация.


4. Установка Windows 7 на виртуальный диск в VHD-файл.

Установив систему на виртуальный диск, в один VHD-файл, Вы получаете такие преимущества по сравнению с обычной системой:
- сможете сделать копию операционной системы просто скопировав VHD-файл
- сможете тестировать бета версии программ, не беспокоясь за систему
- сможете изучать систему, экспериментировать с реестром, не боясь её испортить.

1) Вставьте установочный диск Windows 7 в привод, загрузитесь с него
2) Доходите до шага мастера установки, где Вас просят выбрать или создать тот раздел диска, на который будет установлена Windows 7.
3) Нажмите комбинацию клавиш "Shift+F10".
Это сочетание клавиш предоставит доступ к командной строке. Напечатайте в ней Diskpart и нажмите Enter.
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Введите в DISKPART следующую команду:

Она означает - создать файл win7.vhd расширяемого типа, максимальный размер ограничить 30 Гигабайтами. Замените E: на имя диска, на котором вы хотите хранить создаваемый файл.

4) Смонтируйте VHD-файл, чтобы он был доступен программе установки:

5) После успешного выполнения всех операций, набираете команду exit для выхода из утилиты diskpart, и еще раз команду exit – уже в приглашении CMD.EXE для закрытия командной строки.

6) Вы снова окажетесь в окне Выберите раздел для установки.
7) Нажмите кнопку Обновить, расположенную под списком дисков и Вы увидите Ваш новый диск
8) Так как на нем ещё нет разделов, то будет написано Незанятое место на диске...
9) Выберите его и нажмите Настройка диска
10) Щелкните на кнопке "Создать", укажите объем создаваемого радела и щелкните на кнопке "Применить".
11) Ещё раз убедитесь, что Вы выбрали созданный Вами виртуальный диск и нажмите Далее, игнорируя предупреждение: Невозможно установить Windows на диск...

Процесс установки Windows 7 на раздел VHD-диска продолжится так, как будто это обычный логический раздел жесткого диска. При этом будет не только установлена новая ОС, но и подменен загрузчик на "физическом" системном разделе для успешного старта с VHD. При установке Windows 7 на "чистую" систему, мастер установки автоматически создаст на диске системный раздел в 100МБ, на котором помещается загрузчик, а уже для самой системы создаст отдельный раздел.

Назад на страницу раздела Виртуализация.


5. Конвертирование тома жесткого диска в VHD-файл.

Для создания VHD-файлов из томов жесткого диска, Вам необходимо воспользоваться утилитой Disk2vhd. Она позволяет создать VHD-образ прямо с запущенной операционной системы. Для своей работы, программа использует Модуль теневого копирования тома (Volume Snapshot), являющийся функцией используемой операционной системой для создания последовательных снимков томов на определенный момент времени. Таким образом, Вы сможете создать VHD-файл прямо на том же разделе, который в него упаковываете. При создании VHD-файла, программа включает в него только системный том и исключает разделы с данными.

Созданный утилитой виртуальный диск может быть подключен к виртуальной машине как IDE-диск. Не используйте VHD-файл, для загрузки через менеджер загрузки Windows 7 на реальной машине. Windows специальным образом подписывает жесткие диски, и присваивает VHD-диску новый уникальный идентификатор. При попытке загрузки с VHD система выдаст ошибку об отсутствии загрузочного диска или просто перезагрузится без уведомления пользователя. Но при использовании данного VHD-образа в Virtual PC, система отлично стартует и работает.

Для работы с Вашим VHD-файлом Вы также можете использовать оснастку Управление дисками (diskmgmt.msc).
Если снимаете образ системного диска, и у вас есть раздел восстановления (System Reserved), не забудьте включить его в VHD-образ, так как без него система не загрузится. Для создания VHD-файла сделайте следующее:

1) Скачайте программу Disk2vhd
2) Разархивируйте скачанный архив и запустите Disk2vhd
3) В поле под VHD File name укажите путь и имя создаваемого Вами VHD-файла.
4) Установите флажки напротив томов жесткого диска, которые необходимо включить в создаваемый Вами VHD-файл.
5) Нажмите Create

Для создания скриптов утилита поддерживает командную строку:

Укажите какие тома необходимо включить в VHD-файл или используйте * для конвертирования всех томов.

Назад на страницу раздела Виртуализация.


6. Конвертирование DVD-образа Windows 7 в VHD-файл.

Для конвертирования DVD-образа Windows 7 в VHD-файл, Вам потребуются Набор автоматической установки Windows (AIK) для Windows 7 (Размер скачиваемого файла 1,25 ГБ и инструмент командной строки WIM2VHD

WIM2VHD - это сценарий Windows Scripting Host, предназначенный для использования в командной строке и позволяющий создать аппаратно-независимый VHD-файл из инсталляционного диска Windows 7, при инициализации которого система минует стадию начальной загрузки и распаковки файлов и будет готова к определению оборудования компьютера, на котором она запущена.

Суть метода заключается в преобразовании файла install.wim в VHD-файл.

1) Установите Набор автоматической установки Windows (AIK) для Windows 7
2) Поместите скаченный файл WIM2VHD.WSF в папку C:\Program Files\Windows AIK\Tools\x86\, если используете 32-разрядную систему, или в C:\Program Files\Windows AIK\Tools\amd64\, если 64-разрядную.
3) Запустите командную строку с правами администратора, для чего нажмите "Пуск", в поле поиска введите cmd.exe и нажмите Ctrl+Shift+Enter.
4) Перейдите в папку со скриптом используя команду CD . Например:

Для 32-битной Windows:

Для 64-битной Windows:

Измените пути на соответствующие Вашей системе.

5) Запустите скрипт wim2vhd. Для этого, введите в командной строке следующее:

Командная строка расшифровывается так:
Взять файл h:\sources\install.wim, и редакцию Ultimate преобразовать в e:\vhd\win7.vhd

6) Дождитесь окончания операции.

7) Для подключения полученного VHD-файла к имеющемуся загрузчику Windows 7, используйте команду:

Команда дублирует загрузочную запись текущей запущенной Windows 7. Вместо "Windows 7 Virtual" Вы можете написать любое значение.

8) Bcdedit выведет на экран {GUID} только что созданной записи-дубликата - скопируйте его в буфер обмена и используйте для внесения VHD-файла в опции загрузки:

Для информации: Работа скрипта WIM2VHD базируется на использовании утилиты imagex.exe из WAIK. Другие примеры использования скрипта WIM2VHD описаны здесь.

Назад на страницу раздела Виртуализация.


7. Включение Aero Glass в Windows на Virtual PC.

1. Установить Windows 7 на компьютер, к которому вы будете отдалённо получать доступ (VM).
2. Установить Windows 7 на компьютер, с которого вы будете отдалённо получать доступ (host).
3. Сборка Windows 7 на обоих должна быть одинаковой, чтобы всё работало корректно.
4. Компьютер, к которому вы будете получать доступ, должен иметь графический адаптер, поддерживающий Glass, который должен быть включен.
5. Установить Сетевое соединение между двумя компьютерами.

На VM нужно активировать Remote Desktop (не забудьте разрешить доступ приложения в Брандмауэре)
С компьютера host запустите Remote Desktop, введите имя или IP адрес VM. Если вы хотите настроить размер окна, глубину цвета, скорость соединения, то заходите в соответствующие настройки.
Нажмите Connect и вводите логин.

Сессия Remote Desktop стартует, и рабочий стол VM будет показывать DWM эффекты.

В итоге, это не совсем Glass, но этот эффект возможно сделать так, чтобы он выглядел, как Glass, используя разработки команды Remote Desktop.

Назад на страницу раздела Виртуализация.


8. Установка Windows 7 в виртуальную машину VirtualBox.

VirtualBox - специальная программа для создания в памяти ПК виртуальных компьютеров. Каждый виртуальный компьютер может содержать произвольный набор виртуальных устройств и отдельную операционную систему. Область применения виртуальных компьютеров очень широка - от выполнения функций по тестированию ПО до создания целых сетей, которые легко масштабировать, распределять нагрузку и защищать. VirtualBox распространяется бесплатно, с открытым исходным кодом.

1) Скачайте последнюю версию программы VirtualBox с официального сайта: http://www.virtualbox.org/wiki/Downloads
2) Установите ее на свой компьютер.

2.1) Запустите установщик; В первом окне нажмите Next
2.2) Выберите необходимые Вам компоненты для установки и нажмите пункт Next.
2.3) Нажмите Next, а затем Yes для начала установки.
2.4) Нажмите на кнопку Install. Внимание: После нажатия кнопки Install произойдет разрыв связи с сетью (как локальной, так и Интернет)
2.5) В появляющихся окнах Установить программное обеспечение для данного устройства? нажмите на кнопку Установить
2.6) В последнем окне оставьте флажок, чтобы приступить к созданию виртуальной машины сразу или уберите флажок для создания виртуальной машины позднее. Нажмите кнопку Finish. Если Вы убрали флажок, то для запуска программы воспользуйтесь значком на рабочем столе.

3) В главном окне программы нажмите на кнопке Создать. Откроется Мастер создания новой виртуальной машины. Нажмите кнопку Вперед.
4) Введите имя виртуальной машины, в разделе Тип ОС установите значения:
Операционная система: Microsoft Windows
Версия: Windows 7.
Нажмите кнопку Вперед.

5) Введите размер оперативной памяти, выделяемый для виртуальной машины.
Внимание: Память будет выделяться из физической памяти установленной в Вашем компьютере. Не устанавливайте память ниже 512 Мегабайт и выше 50% от размера установленной физической памяти. Нажмите кнопку Вперед.
6) Выберите загрузочный виртуальный жесткий диск. Установите переключатель в значение: Создать новый жесткий диск. Нажмите кнопку Вперед.

7) Откроется Мастер создания нового виртуального диска. Нажмите кнопку Вперед.
8) Выберите тип виртуального жесткого диска. Динамический образ изначально займет немного места, и будет расширяться постепенно. Фиксированный образ сразу создаст диск указанного размера - это может занять продолжительное время. Нажмите кнопку Вперед.

9) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\.VirtualBox.
Выберите размер виртуального жесткого диска. (По умолчанию 20 Гигабайт). Нажмите кнопку Вперед.

10) Нажмите на кнопку Готово и Вы вернетесь в предыдущее окно, где будут указаны параметры создаваемой Вами виртуальной машины. Нажмите на кнопку Финиш в окне Итог, и Вы создадите новую виртуальную машину.

Виртуальная машина для установки на нее Windows 7 создана.

11) Перед началом установки Windows 7 на Вашу виртуальную машину ее необходимо настроить. Для настройки Вашей виртуальной машины нажмите на кнопку Свойства.
12) В разделе настроек из списка слева выберите Дисплей. Установите размер видеопамяти, доступной для виртуальной машины не менее 26 Мегабайт. Поставьте флажки для элементов настроек Включить 3D-ускорение и Включить 2D-ускорение видео.

13) В разделе настроек из списка слева выберите Носители.
14) Нажмите значок DVD-диска рядом с ниспадающим меню в графе Атрибуты.

Если у Вас установочный диск Windows 7 записан на DVD-диск, то вставьте его в DVD-привод и выберите привод с соответствующей буквой. Также установите флажок для Разрешить прямой доступ.
Если у Вас установочный диск Windows 7 имеется в виде ISO-образа, то выберите пункт Выбрать образ оптического диска... нажмите на значок папки, чтобы открыть Менеджер виртуальных носителей
15) В окне Выберите образ оптического диска выберите файл образа и нажмите Открыть. 16) Ваш образ добавится в дерево настроек Носители информации. Нажмите кнопку OK.

17) Вы окажетесь в основном окне программы. Нажмите на кнопку Старт
18) Если появятся информационные окна, то нажмите в них на кнопку OK
19) Щелкните кнопкой мыши внутри экрана виртуальной машины, и в информационном окне нажмите на кнопку Захватить
20) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
21) После завершения установки Windows 7 на виртуальную машину, VirtualBox сразу запустит Вам Windows 7 внутри виртуальной машины.

22) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Right Control.
Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Дополнения гостевой ОС. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Устройства -> Установить Дополнения гостевой ОС

23) Во всплывшем окне Автозапуск нажмите VBoxWindowsAdditions.exe и установите программу.
23.1) В появляющихся окнах контроля учетных записей нажмите Да.
23.2) Для перехода к каждому последующему шагу нажмите Next, для установки кнопку Install, для завершения Finish.
23.3) В появляющихся окнах Установить программное обеспечение для данного устройства? нажмите на кнопку Установить
24) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Машина -> Закрыть -> Выключить машину.
25) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Старт.

Назад на страницу раздела Виртуализация.


9. Установка Windows 7 в виртуальную машину Microsoft Virtual PC.

Microsoft Virtual PC - это мощная программа, которая позволяет эмулировать на одном компьютере работу сразу нескольких виртуальных машин. Каждая из таких машин может находиться под управлением своей собственной операционной системы (Windows любой версии, Netware, Linux, Solaris и т.д.), выполнять уникальную задачу, иметь собственную конфигурацию и т.д.

1) Скачайте последнюю версию программы Virtual PC с официального сайта:
http://www.microsoft.com/downloads/details.aspx?familyid=28c97d22-6eb8-4a09-a7f7-f6c7a1f000b5&displaylang=en
2) Установите программу. Внимание программа установки без предупреждения выключит соединение с сетью (как локальной, так и Интернет).
3) Скачайте и установите обновление KB958162.msp для Virtual PC
4) Запустите программу. Нажмите кнопку Пуск -> Все программы -> Microsoft Virtual PC
5) В окне с надписью: "You are not running on a supported operating system" нажмите ОК.
6) В окне New Virtual Machine Wizard нажмите кнопку Next. Данное окно Вы также можете запустить нажав кнопку New в Virtual PC Console или в меню File выбрать New Virtual Machine Wizard.

7) Установите переключатель на Create a Virtual Machine. Нажмите кнопку Next.

8) Выберите имя и расположение для файла Вашей виртуальной машины. По умолчанию имя файла New Virtual Machine, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\Documents\My Virtual Machines. Нажмите кнопку Next.
9) Выберите тип операционной системы. В связи с отсутствием пункта Windows 7 в Virtual PC, выберите Windows Vista или Other. Нажмите кнопку Next.

10) Установите переключатель на Adjusting the RAM. Выберите необходимое Вам количество оперативной памяти выделяемое виртуальной машине, не менее 512 Мегабайт. Нажмите кнопку Next.

11) Установите переключатель на A new virtual hard disk, чтобы создать новый виртуальный образ. Нажмите кнопку Next.
12) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, к котрой добавлено Hard Disk, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке:
C:\Users\UserName\Documents\My Virtual Machines\ИмяВиртуальнойМашины\
Укажите величину создаваемого вами виртуального жесткого диска в мегабайтах. Рекомендую указать 20480 Мб (20 Гб). Для информации: 1 Гб = 1024 Мб. Нажмите кнопку Next.

13) Нажмите кнопку Finish, для создания виртуальной машины. Вы снова окажетесь в окне Virtual PC Console.
14) Выберите созданную Вами виртуальную машину и нажмите кнопку Start
15) Виртуальная машина начнет свою работу и остановится с сообщением: Reboot and Select proper Boot device or Insert Boot Media in selected Boot device, поскольку отсутствует инсталляционный диск с Windows 7. Выберите команду CD>Capture CD Image и укажите образ ISO с Windows 7.

16) Перезагрузите виртуальную машину, выбрав команду Action -> Ctrl+Alt+Del или нажав Правый Alt+DEL в окне виртуальной машины.
17) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
18) После завершения установки Windows 7 на виртуальную машину, Microsoft Virtual PC сразу запустит Вам Windows 7 внутри виртуальной машины.
19) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Right Alt.
Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Virtual Machine Additions. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Action –> Install or Update Virtual Machine Additions и нажмите Continue.

20) Во всплывшем окне Автозапуск нажмите Setup.exe и установите программу.
21) Нажмите Yes по окончанию установки Virtual Machine Additions и виртуальная машина перезагрузится.
22) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Action -> Close -> Turn Off и нажмите OK.
23) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Start.

Назад на страницу раздела Виртуализация.


10. Установка Windows 7 в виртуальную машину VMware Workstation.

VMware Workstation — популярная программа для виртуализации систем. VMware Workstation является массивным решением для разработчиков программного обеспечения и системных админов, создающих и тестирующих полно-комплексные сетевые приложения класса серверов, работающие в разнообразных средах.

1) Заходите на страницу официального сайта для скачивания программы: http://downloads.vmware.com/d/
2) Нажимаете на ссылку VMware Workstation
3) На открывшейся странице выбираете для скачивания VMware Workstation X.X.X for Windows (где X.X.X - номер версии)
4) Щелкаете на кнопке Download рядом с Workstation for Windows 32-bit and 64-bit with VMware Tools.
5) Нажимаете на кнопку Register и заполняете регистрационную форму и нажимаете Continue
6) Внизу EULA соглашения нажимаете Yes и оказываетесь на странице загрузки. Программа бесплатна для полнофункционального использования 30 дней. По истечении данного срока Вам необходимо её зарегистрировать.
7) Скачиваете Workstation for Windows 32-bit and 64-bit Main installation file with Tools. В отличие от других виртуальных машин, программа установки VMware Workstation имеет размер более 500 Мегабайт.
8) Установите программу. Перезапустите компьютер, для этого в последнем окне программы нажмите Restart Now или нажмите Restart Later и перезапустите вручную позже.
9) Запустите программу. Установите переключатель на Yes, I accept the terms in the license agreement и нажмите OK
10) В главном окне программы нажмите на значок New Vitual Machine.

11) Установите переключатель на Typical (recommended). Нажмите кнопку Next.

12) Установите переключатель на Installer disk image file (iso). Нажмите кнопку Browse и укажите путь к ISO-образу Windows 7. Нажмите кнопку Next.

13) Укажите свой инсталляционный код Windows 7, имя пользователя и пароль и нажмите кнопку Next. Если Вы решили ввести эти данные позже, то после нажатия кнопки Next, нажмите на кнопку Yes.
14) Выберите имя и расположение для файла Вашей виртуальной машины. Нажмите кнопку Next.

15) Задайте размер Вашего виртуального жесткого диска в гигабайтах.

16) Нажмите кнопку Finish, для создания виртуальной машины.
17) В окне VMware Workstation Activation нажмите Enter Serial Number, чтобы ввести имеющийся у Вас серийный номер. Если у Вас нет серийного номера, то Вы можете получить серийный номер на 30 дней для полнофункционального тестирования программы: https://www.vmware.com/tryvmware/?p=workstation&lp=default
18) После введения пробного номера во всплывшем окне Register your version of VMware Workstation now! нажмите кнопку Register
19) В главном окне программы перейдите на вкладку с названием Вашей виртуальной машины (по умолчанию Windows 7) и нажмите ссылку Power on this virtual machine.

20) В отличие от других виртуальных машин установка Windows 7 начнется сама и большую часть установки VMware Workstation выполнит автоматически, Ваше участие в процессе установки Windows 7 почти не потребуется.
21) После завершения установки Windows 7 на виртуальную машину, VMware Workstation сразу запустит Вам Windows 7 внутри виртуальной машины.
22) Сразу после запуска VMware Workstation самостоятельно установит Вам дополнительные инструменты VMware Tools, а также в случае наличия у Вас подключения к Интернет самостоятельно установит все необходимые драйвера.
23) Используйте комбинацию клавиш Ctrl+G для разблокировки одновременного использования мыши как в виртуальной системе, так и в основной.
24) Чтобы выключить виртуальную машину, завершите работу в виртуальной Windows 7 как в обычной Windows. Пуск -> Завершение работы.
25) Чтобы запустить установленную Windows 7 в основном окне программы в колонке слева выберите наименование Вашей операционной системы. В открывшейся вкладке с названием Вашей виртуальной машины (по умолчанию Windows 7) нажмите ссылку Power on this virtual machine.

Назад на страницу раздела Виртуализация.


11. Создание общей папки для виртуальной и основной Windows в VirtualBox.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VirtualBox и хостовой (реальной) Windows 7, сделайте следующее:

1) В меню запущенной виртуальной машины откройте Устройства -> Общие папки

2) Нажмите на клавиатуре кнопку Insert, либо нажмите на значок папки с плюсом.

3) Установите флажок для параметра Создать постоянную папку.
4) В ниспадающем меню рядом с текстом Путь к папке выберите пункт Другой....
5) Укажите путь к Вашей папке и нажмите на каждую кнопку ОК.

Если Вы хотите, чтобы гостевая ОС автоматически подключала данную папку в процессе загрузки поставьте флажок у Авто-подключение.
Если Вы хотите, чтобы общая папка была постоянной для данной машины установите флажок у Создать постоянную папку, иначе выбранная общая папка будет временной.
6) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Сеть -> VBOXSVR -> Ваша папка

Назад на страницу раздела Виртуализация.


12. Создание общей папки для виртуальной и основной Windows в Microsoft Virtual PC.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину Microsoft Virtual PC и хостовой (реальной) Windows 7, сделайте следующее:

1) В меню запущенной виртуальной машины откройте Edit -> Settings или нажмите сочетание клавиш: правый Alt+E

2) Выберите в списке Shared Folders и нажмите кнопку Share Folder...

3) Установите флажок на Share Every Time, укажите Вашу общую папку и установите букву диска в виде которого будет отображаться папка в виртуальной Windows, затем нажмите OK.

4) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Компьютер -> Отключенное сетевое устройство (назначенная вами буква диска)

Назад на страницу раздела Виртуализация.


13. Создание общей папки для виртуальной и основной Windows в VMware Workstation.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VMware Workstation и хостовой (реальной) Windows 7, сделайте следующее:

1) В вкладке с названием Вашей виртуальной машины (по умолчанию Windows 7) перейдите на вкладку Options.
2) Сделайте двойной щелчок на папке Shared Folders

3) Установите переключатель на Always enabled.

4) Нажмите кнопку Add..., а затем кнопку Next.
5) Нажмите кнопку Browse. Укажите путь к Вашей общей папке в хостовой (реальной) Windows 7 и ее имя в виртуальной Windows, затем нажмите OK.

6) Нажмите кнопку Next, а затем кнопку Finish. Выйдите из опций нажав на OK.
7) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник -> Сеть -> vmware-host -> Shared Folders -> Ваша папка

Назад на страницу раздела Виртуализация.


14. Запуск старых 16-битных приложений и DOS-игр в Windows, используя программу DosBox.

Для запуска старых 16-битных приложений и DOS-игр в Windows, Вы можете использовать программную среду DosBox. Чтобы Вам легче было в ней работать Вы можете воспользоваться одной из предлагаемых на сайте графических оболочек.

1) Скачайте и установите графическую оболочку D-Fend Reloaded
2) Нажмите Файл -> Настройки программы.
3) Перейдите на вкладку Язык в Пользовательский интерфейс и установите значения параметров в соответствии с языковыми требованиями программы, которую Вы собираетесь запустить и нажмите ОК.
4) Чтобы добавить новое 16-битное приложение (DOS-игру), просто перетащите мышкой ZIP-архив с программой или распакованную папку с файлами приложения (игры) в окно программы.
5) В зависимости от выбранного Вами действия, появится окно Импорт архива или окно Импорт папки.
6) В данном окне нажмите ОК и профиль для данной игры добавится в программу, чтобы Вы могли в любой момент запустить её.
7) Нажмите правой кнопкой мыши на созданном профиле игры и выбираете пункт Запустить настройку.
8) Настройте параметры запуска игры и выйдите из программы настройки.
9) Нажмите правой кнопкой мыши на созданном профиле игры и выбираете пункт Запустить программу.

Дополнения:

Переключение между экранным и оконным режимами осуществляется комбинацией клавиш Alt+Tab.
Звуковую карту указывать Sound Blaster/Sound Blaster Pro
Иногда для выхода приходится в ручную вводить команду Exit и нажимать Enter.

Назад на страницу раздела Виртуализация.


15. Отключение синхронизации времени с хостовой системой в виртуальной машине VirtualBox.

Если в виртуальной Windows Вам необходиомо, чтобы при запуске виртуальной системы была установлена уже прошедшая дата и виртуальная машина не синхронизировала данные с основной системой, то выполните указанные ниже действия.

1) Выйдите из виртуальной машины и закройте приложение VirtualBox.
2) Откройте окно команд из папки, куда установлена программа и в которой находится утилита VBoxManage.exe.
Для этого щелкните правой кнопкой мыши по паке, удерживая нажатой клавишу Shift и выберите Открыть окно команд.
3) Введите указанную ниже команду:

Где: <name> - имя Вашей виртуальной машины, а <-msec> - разница в миллисекундах между текущей датой и той, что требуется. Указанное значение будет постоянно отматываться назад.

Для получения необходимого Вам значения в милисекундах воспользуйтесь утилитой Date Offset Calculator

Назад на страницу раздела Виртуализация.


16. Отключение синхронизации времени с хостовой системой в виртуальной машине Microsoft Virtual PC.

Если в виртуальной Windows Вам необходиомо, чтобы при запуске виртуальной системы была установлена уже прошедшая дата и виртуальная машина не синхронизировала данные с основной системой, то выполните указанные ниже действия.

1) Выйдите из виртуальной машины и закройте приложение Microsoft Virtual PC.
2) Откройте в любом текстовом редакторе файл конфигурации Вашей виртуальной машины.
Данный файл расположен в той же папке, где и созданная Вами виртуальная машина (С:\Users\ИмяПользователя\AppData\Local\Microsoft\Windows Virtual PC\Virtual Machines) и имеет расширение .vmс
3) Найдите тег </microsoft> и вставьте перед ним нижеследующий текст:

4) Найдите тег </bios> и вставьте перед ним нижеследующий текст:

В итоге у Вас должно получиться примерно так:

Если у Вас уже имеются указанные разделы, но значения параметров установлены true, то просто измените их на false.

5) Сохраните файл и запустите Virtual PC.
6) Зайдите в BIOS виртуальной машины, и установите необходимую Вам дату и время, и после перезагрузки/выключения машины они не будут синхронизированы с хостовой системой.

Назад на страницу раздела Виртуализация.


17. Отключение синхронизации времени с хостовой системой в виртуальной машине VMware Workstation.

Если в виртуальной Windows Вам необходиомо, чтобы при запуске виртуальной системы была установлена уже прошедшая дата и виртуальная машина не синхронизировала данные с основной системой, то выполните указанные ниже действия.

1) Выйдите из виртуальной машины и закройте приложение VMware Workstation.
2) Откройте в любом текстовом редакторе файл конфигурации Вашей виртуальной машины.
Данный файл расположен в той же папке, где и созданная Вами виртуальная машина (C:\Users\ИмяПользователя\Documents\Virtual Machines) и имеет расширение .vmx
3) Добавьте в конце файла нижеследующие строки:

Параметры с первого до предпоследнего отключают синхронизацию времени с хостовой машиной при различных операциях.
Последний параметр rtc.startTime определяет дату в биосе при запуске машины. Его значение – это требуемая дата в формате Unix Timestamp, равняется количеству секунд прошедших с полночи с 31 декабря 1969 года на 1 января 1970 года до необходимой Вам даты и времени.

Для получения необходимого Вам значения скачайте программу конвертер: Unix Timestamp Converter Unix Timestamp Converter или воспользуйтесь онлайн конвертером: Unix Time Convertion

4) Сохраните файл и перезапустите VMware Workstation.

Внимание: После внесения изменений проверьте отсутствие дублирующихся строк, иначе машина не запустится.

Назад на страницу раздела Виртуализация.


Твики Реестра

Твики Реестра - Общие.

1. Запуск программы "Редактор реестра", создание и применение reg-файла.

Запуск программы "Редактор реестра":

Вариант 1.

1.1) Откройте меню Пуск -> Все программы -> Стандартные -> Выполнить (или нажмите сочетание клавиш Win+R)
1.2) Введите команду regedit и нажмите ОК

Вариант 2.

2.1) Откройте меню Пуск
2.2) В строке поиска введите regedit и нажмите Enter

Вариант 3.

3.1) Запустите Проводник Windows (Explorer)
3.2) Откройте папку C:\Windows и дважды щелкните по файлу regedit.exe

Создание reg-файла.

Вариант 1.

1.1) Откройте Блокнот (Notepad).
1.1.1) Откройте меню Пуск -> Все программы -> Стандартные -> Блокнот (или нажмите сочетание клавиш Win+R -> введите notepad -> нажмите ОК).
1.2) Скопируйте необходимый Вам код в окно программы Блокнот.
1.3) В меню программы нажмите Файл и выберите пункт Сохранить.
1.4) В открывшемся окне:
1.4.1) Укажите место сохранения файла.
1.4.2) Укажите имя файла и расширение .reg (Например: Demo.reg)
1.4.3) Выберите тип файла: Все файлы (*.*).

Внимание:
Если Вы оставите тип файла: Текстовые файлы (*.txt), то имя файла обязательно нужно взять в кавычки. (Например: "Demo.reg")

1.5) Нажмите на кнопку Сохранить.

Вариант 2.

Если у Вас убран флажок Скрывать расширения для зарегистрированных типов файлов в Параметры папок (Панель управления\Оформление и персонализация\Параметры папок -> Вкладка Вид), то Вы можете создать reg-файл следующим способом:

2.1) В папке, где Вы хотите создать reg-файл, щелкните правой кнопкой мыши.
2.2) Во всплывшем меню выберите Создать -> Текстовый документ.
2.3) Сотрите имя и расширение файла .txt, укажите необходимое Вам имя файла и расширение .reg, нажмите клавишу Enter, а затем кнопку Да.
2.4) Щелкните на созданном Вами файле правой кнопкой мыши и выберите пункт Изменить.
2.5) Скопируйте необходимый Вам код в окно программы Блокнот.
2.6) Нажмите сочетание клавиш CTRL+S.

Вариант 3.

3.1) Возьмите любой готовый reg-файл.
3.2) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить.
3.3) Скопируйте необходимый Вам код в окно программы Блокнот.
3.4) В меню программы нажмите Файл и выберите пункт Сохранить Как.
3.5) В открывшемся окне:
3.5.1) Укажите место сохранения файла.
3.5.2) Укажите имя файла и расширение .reg (Например: Demo.reg)
3.5.3) Выберите тип файла: Все файлы (*.*).
3.6) Нажмите на кнопку Сохранить.

Применение reg-файла.

Вариант 1.

1) Щелкните два раза левой кнопкой мыши на reg-файле и нажмите кнопку Да.

Вариант 2.

2.1) Щелкните правой кнопкой мыши на reg-файле.
2.2) Выберите пункт Слияние и нажмите кнопку Да.

2. Создание и переименование раздела или параметра, а также изменение параметра в редакторе реестра.
Вы запустили программу "Редактор реестра" как описано в Запуск программы "Редактор реестра", создание и применение reg-файла.. Используя дерево папок открыли нужный Вам раздел, и теперь, Вам необходимо создать, переименовать параметр (раздел), либо изменить значение параметра реестра. Существует несколько способов сделать это.

Создание раздела или параметра в редакторе реестра.

Вариант 1.

1) Щелкните в главном меню пункт Правка.
2) Наведите курсор мыши на пункт меню Создать.
3) В раскрывающемся меню выберите раздел или тип параметра, который Вы желаете добавить.

Вариант 2.

1) Щелкните правой кнопкой мыши в любом пустом месте области параметров (правая часть окна).
2) Наведите курсор мыши на пункт меню Создать.
3) В раскрывающемся меню выберите раздел или тип параметра, который Вы желаете добавить.

Переименование раздела или параметра в редакторе реестра.

Вариант 1.

1) Выберите раздел или параметр, который Вы желаете переименовать.
2) Щелкните в главном меню пункт Правка, а затем на пункт Переименовать.

Вариант 2.

1) Щелкните правой кнопкой мыши на раздел или параметр, который Вы желаете переименовать.
2) Щелкните левой кнопкой мыши на пункт Переименовать.

Изменение значения параметра в редакторе реестра.

Вариант 1.

1) Выберите параметр, который Вы желаете изменить.
2) Щелкните в главном меню пункт Правка, а затем на пункт Изменить.

Вариант 2.

1) Щелкните правой кнопкой мыши на параметр, который Вы желаете изменить.
2) Щелкните левой кнопкой мыши на пункт Изменить

Вариант 3.

Щелкните дважды на параметре, который Вы желаете изменить.

3. Аббревиатуры используемые для обозначения веток реестра.

Для обозначения пути к разделу или ключу реестра могут использоваться следующие аббревиатуры:

Наименование раздела | Используемая аббревиатура
HKEY_CLASSES_ROOT | HKCR
HKEY_CURRENT_USER | HKCU
HKEY_LOCAL_MACHINE | HKLM
HKEY_USERS | HKU
HKEY_CURRENT_CONFIG | HKCC

4. Быстрый переход в необходимый раздел реестра.

Если для работы с реестром Вы предпочитаете не использовать программы: RegEditX, Registry Workshop или Reg Organizer, то для быстрого перехода в необходимый Вам раздел реестра Вы можете воспользоваться одним из указанных ниже вариантов.

Вариант 1.

1) Скачайте маленькую бесплатную утилиту от Microsoft: RegJump
2) Распакуйте архив в любую папку и скопируйте файл regjump.exe в папку C:\Windows\System32
3) Теперь любую ветку реестра можно открыть прямо из диалогового меню Выполнить или из строки поиска в меню Пуск.
3.1) В диалоговом меню Выполнить (Win+R), либо в строке поиска из меню Пуск введите команду regjump и путь к разделу, указав его в кавычках.

Например:

3.2) Нажмите клавишу Enter, при вводе из окна Выполнить или Shift+Enter при вводе в строку поиска:

Вариант 2

1) Создайте специальный скрипт.

1.1) Скопируйте указанный код в любой текстовый редактор (например, Блокнот).
1.2) Нажмите Ctrl+S и сохраните файл с любым именем и расширением .vbs
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "regkey.vbs")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
2) Переместите созданный Вами скрипт в любую удобную Вам папку.
Теперь для открытия раздела реестра:
3) Скопируйте в буфер обмена(Ctrl+C или Щелчок правой кнопкой мыши -> Копировать) необходимую Вам ветку реестра.
4) Щелкните на созданный Вами скрипт-файл.

Минусом использования данного скрипта является отсутствие поддержки аббревиатур.

5. Отключение вывода диалогового окна при применении reg-файла.

При запуске reg-файла, система выводит диалоговое окно в котором пользователь должен подтвердить достоверность источника, откуда получены импортируемые в реестр сведения. Для отключения данного окна выполните указанные ниже действия:

1) Запустите редактор реестра (Win+R -> regedit -> ОК)
2) Откройте раздел реестра HKEY_CLASSES_ROOT\regfile\shell\open\command
3) Дважды щелкните на параметре По умолчанию и введите значение:

4) Закройте редактор реестра и перезапустите компьютер.

Минусом данного решения является то, что помимо указанного диалогового окна запроса подтверждения, также не будет выводиться окно об успешном импортировании в реестр данных.

Твики Реестра - Администрирование и Безопасность.

1. Получение полного доступа к разделу реестра, используя программу regedit или командную строку.

Для поддержания безопасности системы, после внесения изменений в реестр верните исходные права и восстановите владельца.

Изменение разрешений и владельца для получения полного доступа к разделу реестра.

1) Нажмите кнопку Пуск и введите в строке поиска regedit
2) Щелкните на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора.
3) Откройте раздел реестра, права которого Вы желаете изменить.
4) В списке слева, щелкните на данном разделе реестра правой кнопкой мыши и выберите пункт Разрешения.
5) Щелкните левой кнопкой мыши на группу Администраторы:
6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.
7) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
8) Щелкните левой кнопкой мыши на свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
9) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

Восстановление настроек, если владельцем являлись служба TrustedInstaller или учетная запись Система.

1) Щелкните правой кнопкой мыши на разделе реестра, права которого Вы желаете восстановить и выберите пункт Разрешения.
2) Щелкните левой кнопкой мыши на группу Администраторы:
3) Снимите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку Применить.
4) Нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
5) Нажмите кнопку Другие пользователи или группы... и в качестве имени объекта в текстовом поле введите:
  • NT SERVICE\TrustedInstaller , если владельцем являлась служба TrustedInstaller
  • система , если владельцем являлась учетная запись Система (в английской Windows 7 нужно вводить System)
    • 6) В окне Изменить владельца на: выберите TrustedInstaller или система .
    7) Установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.

    Далее рассказывается как можно изменить разрешения, используя командную строку запущенную от имени администратора.
    Если после использовании команды, разрешения не сменятся, то возможно Вам придется зайти в систему под встроенной учётной записью "Администратор" для их выполнения заново.

    Изменение разрешений используя командную строку.

    1) Создайте в любом месте txt-файл (Например в папке D:\Reg создайте файл regperm.txt)
    2) Добавьте в данный файл разделы реестра и присваиваемые им разрешения в следующем формате:

    где куст – имя куста реестра, раздел – имя раздела реестра, а [разрешения] – двоичный числовой формат разрешений.

    Обозначения используемые для кустов реестра:

    Наименование куста реестра | Следует указывать
HKEY_CLASSES_ROOT | \Registry\machine\software\classes
HKEY_CURRENT_USER | \Registry\user\user_sid где user_sid — идентификатор безопасности пользователя.
HKEY_LOCAL_MACHINE | \Registry\machine
HKEY_USERS | \Registry\user
HKEY_CURRENT_CONFIG | \Registry\machine\SYSTEM\CurrentControlSet\Hardware Profiles\0001

    Если Вы не знаете свой SID, то узнать его Вы сможете введя в командной строке команду:

    Двоичные числовые представления разрешений имеют следующий вид (выборочно):

    Значение | Задаваемое разрешение
1 | Администратор, полный доступ
2 | Администратор, чтение
3 | Администратор, чтение и запись
4 | Администратор, чтение, запись и удаление
5 | СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ, полный доступ
6 | СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ, чтение и запись
7 | Все, полный доступ
8 | Все, чтение
9 | Все, чтение и запись
10 | Все, чтение, запись и удаление
11 | Опытные пользователи, полный доступ
12 | Опытные пользователи, чтение и запись
13 | Опытные пользователи, чтение, запись и удаление
17 | Система, полный доступ
18 | Система, чтение и запись
19 | Система, чтение

    Пример:

    Чтобы задать полный доступ группам и пользователям Администратор, СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ и Система для раздела реестра:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer в txt-файл необходимо добавить

    3) В командной строке запущенной от имени администратора (Win+R -> cmd -> OK) выполните команду:

    Например:

    2. Удаление сведений об использованном USB-флэш диске.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку:

    Здесь Вы увидите список разделов, обозначающих подключаемые когда-либо флеш-диски к Вашей системе.
    3) Найдите раздел соответствующий, флеш диску, упоминание о котором Вы хотите удалить из реестра. (Например: Disk&Ven_Corsair&Prod_Flash_Voyager&Rev_1100)

    4) Откройте данный раздел.
    Путь к данной ветке, в моем примере:

    5) В данной ветке Вы увидите подраздел (Например: AB00000000005136&0)
    Путь к данной ветке, в моем примере:

    6) Откройте ветку реестра:

    7) Отрывая поочередно каждый из разделов данной ветки, найдите подраздел содержащий в названии AB00000000005136
    Путь к данной ветке, в моем примере:

    8) Удалите найденные в результате анализа ветки реестра. В моем примере, необходимо удалить следующие ветки:

    9) Перезагрузите компьютер.

    3. Удаление программ в Безопасном Режиме, использующих установщик Windows Installer.

    В большинстве случаев при попытке удаления программы в Безопасном Режиме, если программа не использует собственный инсталлятор (Например: Winamp) Вы получите предупреждающее сообщение:

    Для включения возможности удаления программ в Безопасном Режиме сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal
    3) Создайте здесь раздел MSIService
    4) Присвойте строковому параметру По умолчанию значение Service.
    5) Перезагрузите компьютер.

    4. Отмена ограничения использования команд в контекстном меню, при выделении более 15 файлов.

    Как известно, при выделении более 15 файлов команды контекстного меню, такие как "Открыть/Печать/Редактировать" становятся недоступны.
    Для отмены данного ограничения проделайте следующее:

    1) Запустите редактор реестра ( Win+R -> regedit -> OK)
    2) Откройте ветку HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
    3) Создайте в ней параметр MultipleInvokePromptMinimum типа DWORD.
    4) Установите значение данного параметра равным 16.

    Для уменьшения количества файлов на которых действует ограничение применения команд, введите значение от 1 до 15.
    При выделении файлов выше выбранного Вами значения команды в контекстном меню применяться не будут. При указании значения 0 произойдет полное отключение команд, включая команду "Открыть".

    5. Отключение проверки подписи для загруженных программ.

    Избавляет от этого:

    1) Откройте Панель управления -> Свойства обозревателя -> вкладка Дополнительно
    2) Уберите флажок "Проверка подписи для загруженных программ" и поставьте флажок "Разрешать выполнение или установку программы, имеющую недопустимую подпись".
    3) Создайте и примените reg-файл следующего содержания.

    6. Удаление устаревших значков из области уведомления панели задач.

    После установки/запуска программ, которые размещаются в области уведомлений, данный список все время растет.
    С помощью следующего твика реестра, можно оставить в текущем диалоге отображаться только те значки, которые расположены в области уведомлений на данный момент.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

    Скачать готовый reg-файл Вы можете по ссылке: Clean_TrayNotify.zip

    7. Очистка истории расположений фонов рабочего стола в Windows 7.

    В окне настроек фонового рисунка рабочего стола (ПКМ на рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) есть пункт Расположение изображения, содержащий список папок, в которых хранятся картинки, которые можно использовать в качестве обоев рабочего стола. По умолчанию в этом списке всегда есть указания на четыре папки:

    1. Фоны рабочего стола Windows;
    2. Библиотека изображений;
    3. Самые популярные фотографии;
    4. Сплошные цвета.

    Если Вы добавляете картинку из папки, которой нет в списке, то она(папка) автоматически добавится в данный список. Со временем, этот список будет увеличиваться, дополняясь новыми папками. При чём, в списке будут указаны папки, которых на диске физически уже нет, а запись о них осталась.

    Чтобы очистить список Расположение изображения от ненужных записей и оставить только стандартные названия, нужно в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\Images удалить все параметры ID под номерами от 0 до 9, которые содержат в зашифрованном виде пути нахождения изображений, выбранных пользователем.

    Теперь при повторном открытии окна настроек фонового рисунка рабочего стола (ПКМ на рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) в пункте Расположение изображения Вы увидите список, содержащий только записи по умолчанию.

    8. Удаление папки Общие Документы и пользовательского профиля Общие.

    Для спокойного удаления папки Общие Документы и пользовательского профиля Общие указанные ниже действия рекомендуется выполнять на чистой установленной системе. Если же у Вас система уже установлена, и на ней уже установлены программы, то прежде чем выполнять инструкции ниже скопируйте все папки из C:\Users\Public\* в C:\Users\ВашПрофиль\*

    Вариант 1.

    1) Запустите редактор реестра ( Win+R -> regedit -> OK)
    2) Откройте ветку

    3) Затем нажмите правой кнопкой мыши на правой панели и выберите Создать -> Параметр "DWORD".
    4) Дайте этому параметру имя NoSharedDocuments и присвойте ему значение 1
    5) Перезагрузите компьютер

    Вариант 2.

    1) Пройдите к ветке реестра

    2) Удалите следующую ветку:

    3) Пройдите к ветке реестра

    4) Удалите следующую ветку(если есть):

    Вариант 3.

    1) Откройте Панель управления\Все элементы панели управления\Система(или Пуск -> Компьютер -> Свойства)
    2) Откройте Дополнительные параметры системы
    3) Пройдите на вкладку Имя Компьютера и нажмите Идентификация...
    4) Выберите пункт Компьютер предназначен для домашнего использования.
    5) Нажмите Далее, затем Готово, затем Ок
    6) Перезагрузите компьютер

    После того, как воспользуйтесь решением одного из вариантов проделайте следующие действия:

    1) В ветке реестра:

    замените значения с C:\Users\Public\ на C:\Users\ВашПрофиль\

    2) В ветке реестра:

    замените значения с %PUBLIC%\ на %USERPROFILE%\

    3) Удалите папки (если они остались):

    Диск С: -> Пользователи -> Общие (C:\Users\Public\)
    Библиотеки -> Документы -> Общие Документы

    Внимание: Если не хотите, чтобы у Вас на рабочем столе появились дублирующиеся иконки файлов, не устанавливайте значение параметра Common Desktop, идентичное рабочему столу Вашего профиля. Например, вместо C:\Users\ВашПрофиль\Desktop укажите C:\Users\ВашПрофиль\Public\Desktop, а вместо %USERPROFILE%\Desktop укажите %USERPROFILE%\Public\Desktop.

    9. Запрет запуска контекстного меню Проводника при нажатии правой кнопкой мыши.

    1) Запустите редактор реестра (Regedit).
    2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр DWORD
    4) Переименуйте его в NoViewContextMenu
    5) Измените значение на 1.
    6) Перезагрузите компьютер.

    Вы можете также создать и применить reg-файл следующего содержания:

    10. Удаление пункта меню Файл из Проводника.

    1) Запустите редактор реестра (Regedit).
    2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр DWORD
    4) Переименуйте его в NoFileMenu
    5) Измените значение на 1.
    6) Перезагрузите компьютер.

    Вы можете также создать и применить reg-файл следующего содержания:

    Данный пункт будет также удален из всех мест, использующих оболочку Windows

    11. Запрещение запуска программ.

    1) Запустите редактор реестра (Regedit).
    2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр DWORD
    4) Переименуйте его в RestrictRun
    5) Измените значение на 1.
    6) Перезагрузите компьютер.
    7) Создайте подраздел с аналогичным именем RestrictRun
    8) Создайте в разделе (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictRun) список разрешенных к запуску программ для текущего пользователя.
    8.1) Создайте строковые(String) параметры
    8.2) Укажите названия для создаваемый строковых параметров, начиная с 1 и далее
    8.3) Установите в значениях параметров пути к Вашим приложениям и их имена. Файлы должны указываться с расширением. Например:

    1 REG_SZ regedit.exe
    2 REG_SZ calc.exe
    3 REG_SZ Iexplore.exe

    Не забудьте указать файл regedit.exe, чтобы Вы могли зайти в него и отменить установленные Вами ограничения!
    Для сброса ограничения на запуск программ надо установить значение ключа RestrictRun в 0 или удалить его.

    Если Вы забыли указать regedit.exe в списке или не создали подраздел RestrictRun, чтобы запретить запуск всех программ. Для отмены запрета проделайте следующее:

    1) Перезапустите компьютер.
    2) До начала запуска Windows нажмите на клавишу F8 и выберите пункт Безопасный режим с поддержкой командной строки
    3) В командной строке введите regedit и нажмите Enter.
    4) Пройдите в ветку HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    5) Удалите ключ RestrictRun или установите его значение на 0.

    12. Удаление записей из истории диалогового окна "Выполнить".

    Если Вы используете диалоговое окно "Выполнить" в меню "Пуск" (Win+R), то для удаления записей из его истории проделайте следующее.

    1) Запустите редактор реестра: Win+R --> regedit
    2) Откройте следующую ветку реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU

    Команды, введенные вами ранее, хранятся в виде значений параметров a,b,c,d и так далее используя буквы английского алфавита.

    3) Для удаления записи - удалите параметр с ненужной командой, и она пропадет из истории диалога "Выполнить".

    13. Удаление/восстановление предупреждающего окна о внесении изменений в msconfig(Конфигурация системы).

    При внесении изменений в утилиту msconfig (Конфигурация системы), появляется окно Настройка системы, в котором Вам предлагается на выбор: либо перезагрузить компьютер, либо выйти без перезагрузки.

    Чтобы отключить данное предупреждение установите флажок Больше не показывать это предупреждение, и окно больше появляться не будет.

    Для восстановления данного окна:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKCU\Software\Microsoft\Shared Tools\MsConfig
    3) Удалите параметр NoRebootUI.

    14. Удаление лишних записей из утилиты msconfig (Конфигурация системы).

    Если в окне утилиты msconfig (Конфигурация системы) скопилось много записей и Вы хотели бы удалить ненужные. То сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKLM\SOFTWARE\Microsoft\Shared Tools\MSConfig
    3) Просмотрите все подразделы данной ветки и удалите ненужные Вам записи.
    4) Также записи могут храниться в файле mscfgtlc.xml, находящимся в папке C:\Windows\system32\. В 64-битных Windows данный файл также находится в папке C:\Windows\SysWOW64\.
    5) Откройте данный файл Блокнотом, удалите ненужные записи и сохраните. Если Вы хотите удалить все лишние записи, то просто удалите файл mscfgtlc.xml.

    15. Отключение напоминания о необходимости перезагрузки после установки обновлений.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU.
    3) Создайте параметр NoAutoRebootWithLoggedOnUsers типа DWORD и присвойте ему значение 1.

    или

    откройте диалоговое меню Выполнить (Win+R) и введите команду:

    Для вступления изменений в силу перезайдите в систему или перезагрузите компьютер.

    16. Запуск нескольких копий редактора реестра одновременно.

    Пользователи, которые работают с редактором реестра Windows наверняка сталкивались с ситуацией, когда необходимо сверить содержимое веток реестра. Весьма удобно было бы открыть два редактора реестра, разместить их рядом и сравнить. Однако при повторной попытке запуска программы, система переключает Вас на открытое окно программы. Запуск с удерживанием клавиши Shift тоже не работает.

    Для запуска второй копии редактора реестра:

    1) Откройте диалоговое меню "Выполнить" (Win+R)
    2) Введите команду regedit, используя параметр -m и нажмите Enter.

    17. Дополнительные параметры для настройки функций "Защита системы" и "Восстановление системы".

    В Windows 7 для функций "Защита системы" и "Восстановление системы" существуют дополнительные настройки, которые скрыты от обычных пользователей. Чтобы их изменить Вам необходимо создать соответствующий настройке параметр в реестре.

    1) Откройте диалоговое меню "Выполнить" (Win+R)
    2) Введите команду regedit и нажмите Enter.
    3) Откройте раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore\Cfg
    4) Создайте параметр типа DWORD с именем из списка указанного ниже
    5) Щелкните правой кнопкой мыши на созданном параметре и выберите пункт Изменить.
    6) Установите переключатель в положение Десятичная и введите необходимое Вам значение.

    DiskPersent - указывает, какой объем дискового пространства в процентах будет использовать система для точек восстановления.

    CompressionBurst - указывает время сжатия данных в секундах при простое системы. При простое системы в течение времени, указанного в данном параметре System Restore будет упаковывать данные, после чего прекратит свою работу до следующего периода простоя системы.

    DSMin - указывает минимальное количество свободного дискового пространства, которое требуется System Restore. В случае уменьшения свободного дискового пространства до указанного размера точки восстановления системы перестанут создаваться.

    1 день(сутки) равен 86400 секунд, 1 час равен 3600 секунд, 1 минута равна 60 секунд.

    RPGlobalInterval - указывает количество времени в секундах, в течение которого System Restore ожидает перед созданием новой контрольной точки.

    RPLifeInterval - указывает время в секундах, в течение которого будут храниться точки восстановления перед удалением их с компьютера.

    RPSessionlnterval - указывает количество времени в секундах, в течение которого System Restore ожидает перед созданием новой системной контрольной точки при включенном компьютере. Значением по умолчанию является ноль, что означает, что эта функция выключена. Вы можете установить свое значение (например, интервал в один час), чтобы программа создавала контрольные точки автоматически через заданный интервал.

    ThawInterval - указывает количество времени в секундах, в течение которого System Restore ожидает перед тем, как возобновить свою работу после того, как появилось достаточное количество дискового пространства.

    Твики Реестра - Настройки и Интерфейс.

    1. Включение скрытых настроек электропитания.

    Чтобы настроить в Windows 7 параметры электропитания, необходимо открыть Панель управления\Система и безопасность\Электропитание. Там можно выбрать нужный план электропитания и при необходимости более детально настроить параметры, перейдя в Настройка плана электропитания -> Изменить дополнительные параметры питания.
    Однако более детально настроить параметры электропитания помогает консольная утилита Powercfg. Но работать в командной строке, разбираясь с каждым параметром может занять продолжительное время. Для того чтобы функции предоставляемые powercfg стали доступны Вам в графической оболочке, необходимо внести некоторые изменения в ветке реестра:

    В данной ветке содержатся разделы, отвечающие за определенную группу настроек.
    Например, раздел 0012ee47-9041-4b5d-9b77-535fba8b1442 относится к настройкам управления питанием жесткого диска, а 54533251-82be-4824-96c1-47b60b740d00 к настройкам управления питанием процессора.
    В свою очередь, в каждом из данных разделов есть подразделы, отвечающие за какую-либо настройку электропитания. Описание каждой из настроек указано в значении параметра Description, а её отображение в графической оболочке в значении параметра Attributes. По умолчанию, многие настройки имеют значение параметра Attributes равное «1», для того, чтобы необходимая Вам настройка был виден в графической оболочке, необходимо заменить его на «0». Доступные для отображения настройки, на ноутбуке и стационарном компьютере могут отличаться, в связи с особенностью их систем электропитания.

    Для отображения политики простоя устройств, создайте и примените reg-файл следующего содержания:

    Для отображения скрытых параметров по настройке работы жесткого диска, создайте и примените reg-файл следующего содержания:

    Для отображения скрытых параметров по настройке кнопок питания, создайте и примените reg-файл следующего содержания:

    Для отображения скрытых параметров по настройке управления питания процессора, создайте и примените reg-файл следующего содержания:

    Импортированное значение реестра позволяет увидеть только малую часть параметров, доступных для настройки управлением процессора. Всего их более 30.

    Для отображения скрытых параметров по настройке спящего режима, создайте и примените reg-файл следующего содержания:

    Для отображения скрытых параметров по настройке экрана, создайте и примените reg-файл следующего содержания:

    Также к этому разделу относится настройка параметров графического адаптера, но доступность конкретных настроек будет определяется драйвером.

    У себя в системе я обнаружил 54 скрытых настройки электропитания. Для включения сразу всех скрытых настроек электропитания: экспортируйте всю ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings в reg-файл. Отредактируйте полученный reg-файл: оставьте в нем только наименование веток реестра и их параметры Attributes и присвойте им значения «0».
    Также Вы можете скачать и применить, готовый reg-файл PowerSettings.reg

    2. Добавление классического всплывающего меню Программы (Programs) в меню Пуск.

    Для быстрого доступа к элементам списка Все программы (All Programs), Вы можете добавить его как всплывающее меню взамен меню Избранное (Favorites) или меню Файлы для загрузки (Downloads)

    Вариант 1. Вместо меню Файлы для загрузки (Downloads).

    Если Вы для загрузки файлов из интернета используете собственную папку или сохраняете на Рабочий стол, а также в качестве интернет-браузера используете Internet Explorer, то Вам подойдет данный вариант.

    1) Включите меню Файлы для загрузки (Downloads)
    1.1) Щелкните правой кнопкой мыши на кнопке Пуск, затем нажмите Свойства (Properties).
    1.2) Откройте вкладку Меню "Пуск" (Start Menu) и нажмите кнопку Настроить (Customize)
    1.3) Прокрутите список до пункта Файлы для загрузки (Downloads)
    1.4) Установите переключатель в значение Отображать как меню (Display as a menu), затем нажмите OK.
    2) Нажмите кнопку Пуск, в поле поиска введите regedit и нажмите Enter.
    3) Откройте ветку:

    4) Щелкните дважды на параметр {374DE290-123F-4565-9164-39C4925E467B} и замените текущий путь на этот:

    5) Откройте ветку:

    6) Щелкните дважды на параметр {374DE290-123F-4565-9164-39C4925E467B} и замените текущий путь на этот:

    7) Закройте regedit, и перезагрузите Ваш компьютер.

    Вариант 2. Вместо меню Избранное (Favorites)

    Если Вы в качестве интернет-браузера используете альтернативный браузер: Mozilla Firefox, Opera или Google Chrome, то Вам подойдет данный вариант.

    1) Установите любой понравившийся Вам браузер Mozilla Firefox, Opera или Google Chrome
    2) При его установке импортируйте закладки из Internet Explorer(если необходимо)
    3) Включите меню Избранное (Favorites)
    3.1) Щелкните правой кнопкой мыши на кнопке Пуск, затем нажмите Свойства (Properties).
    3.2) Откройте вкладку Меню "Пуск" (Start Menu) и нажмите кнопку Настроить (Customize)
    3.3) Прокрутите список до пункта Избранное (Favorites) и установите на него флажок, затем нажмите OK.
    4) Нажмите кнопку Пуск, в поле поиска введите regedit и нажмите Enter.
    5) Откройте ветку:

    6) Щелкните дважды на параметр Favorites и замените текущий путь на этот:

    7) Откройте ветку:

    8) Щелкните дважды на параметр Favorites и замените текущий путь на этот:

    9) Закройте regedit, и перезагрузите Ваш компьютер.

    Теперь, когда Вы нажмете Пуск, в правой его части Вы увидите меню Программы (Programs), наподобие меню в предыдущих версиях Windows.

    Для исключения дублирования, Вы также можете убрать стандартный пункт меню Все программы (All Programs) из меню Пуск.
    Для этого создайте и примените reg-файл следующего содержания:

    Для возвращения стандартного пункта меню Все программы (All Programs) из меню Пуск.
    Для этого создайте и примените reg-файл следующего содержания:

    3. Добавление функции произвольного выравнивания иконок в Проводнике.

    В Windows 7 возможность отключения автоматического выравнивания иконок в Проводнике недоступна. В контекстном меню "Вид" в Проводнике, пункт "Упорядочить значки автоматически" отсутствует, соответственно Вы не можете располагать значки произвольным образом.
    Предложенный ниже твик включает возможность произвольного выравнивания иконок в Проводнике и добавляет в контекстное меню "Вид" в Проводнике пункты "Выравнивать автоматически" и "Выровнять по сетке".
    В виду сложившейся необходимости, для работы данного твика режимы "Плитка" и "Содержимое" были объединены в режим "Расширенная плитка".

    Чтобы воспользоваться твиком Вы можете скачать и применить готовое решение: disable-auto-arrange.zip

    disableautoarrange.reg - reg-файл вносящий изменения в контекстное меню Проводника
    undo.reg - reg-файл возвращающий все настройки Проводника "по умолчанию".

    Также Вы можете создать данные reg-файлы самостоятельно.

    Для внесения изменений создайте и примените reg-файл следующего содержания:

    Для отмены изменений создайте и примените reg-файл следующего содержания:

    4. Использование Windows Media Player х64 по умолчанию (для Windows 7 х64).

    Microsoft до сих пор использует 32-битную версию Windows Media Player в 64-битной версии ОС, но есть способ это изменить.
    Преимущество использования WMP х64 заключается лишь в том, что установив 64-битную версию кодеков, вы получите гораздо более чистую и легко управляемую систему.

    1) Запустите меню Выполнить(Win+R) или командную строку от имени Администратора
    2) Введите команду

    (команда чувствительна к регистру)
    3) Откройте редактор реестра: Win+R --> regedit
    4) Перейдите к ветке

    и кликните два раза по значению Path
    5) Измените

    на

    6) Закройте реестр и наслаждайтесь Windows Media Player х64

    Готовые bat-файлы Вы можете скачать по ссылке: Windows_Media_Player_x64.zip

    5. Настройка диалога переключения между окнами ("Alt"+"Tab").

    1) Запустите Редактор Реестра (Win+R -> Regedit -> Ok)
    2) Откройте ветку реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab, если она отсутствует, то создайте её (щелкните на папке Explorer правой кнопкой мыши, выберите Создать -> Раздел и назовите её AltTab).
    В данной папке создайте или измените указанные ниже параметры. Все параметры, которые будут создаваться или изменятся имеют тип REG_DWORD. Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

    Для создания твика, воспользуйтесь инструкцией:

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Параметры, отвечающие за количество отображаемых столбцов и строк

    Columns - данный параметр отвечает за количество столбцов, из которых состоит диалог переключения между окнами.
    Rows - данный параметр отвечает за количество строк, из которых состоит диалог переключения между окнами.

    Пример твика реестра с использованием этих параметров:

    Параметры, отвечающие за отступы в диалоге переключения между окнами

    Упомянутые ниже параметры указываются в пикселях.

    TopMarginPx - величина верхнего поля, добавляемого в диалог
    SideMarginPx - величина бокового поля, добавляемого в диалог
    BottomMarginPx - величина нижнего поля, добавляемого в диалог
    MinWidthPx - минимальная возможная ширина диалога AltTab
    ThumbSpacingXPx - интервал между эскизами смежных окон по горизонтали
    ThumbSpacingYPx - интервал между эскизами смежных окон по вертикали

    Пример твика реестра с использованием этих параметров:

    Параметры, отвечающие за значки эскизов окон

    Упомянутые ниже параметры указываются в пикселях.

    OverlayIconDXPx - величина смещения значка, вправо от эскиза окна
    OverlayIconDYPx - величина смещения значка, вниз от эскиза окна
    OverlayIconPx - размер значков, отображаемых в правом нижнем углу эскиза окна в диалоге переключения между окнами

    Пример твика реестра с использованием этих параметров:

    Параметры, отвечающие за размер эскизов окон и заголовок диалога переключения между окнами

    Упомянутые ниже параметры указываются в пикселях.
    MaxThumbSizePx - максимальный размер эскизов окон
    MinThumbSizePcent - минимальный размер эскизов окон в процентах, относительно максимального размера установленного в MaxThumbSizePx
    TextButtomPx - высота заголовка диалога переключения между окнами

    Пример твика реестра с использованием этих параметров:

    Параметры, изменяющие задержку времени в отображении диалога и управляющие его прозрачностью

    FadeOut_ms - количество миллисекунд, в течении которого окно будет исчезать
    FadeIn_ms - количество миллисекунд, в течении которого окно будет появляться
    FadeOutThreshold_ms Используется для мгновенного исчезновения диалога(присвойте данному параметру значение 0x1000).

    StartAlpha - начальная прозрачность диалога переключения между окнами
    FinalAlpha - конечная прозрачность диалога переключения между окнами

    Пример твика реестра с использованием этих параметров:

    Для включения классического диалога переключения между окнами, используемого в предыдущих версиях Windows при нажатии Alt+Tab, создайте DWORD-параметр AltTabSettings в ветви реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer и присвойте данному параметру значение 1.

    6. Настройка диалогового окна "Выбор программы".

    Когда Вы щелкаете на файле с незарегистрированным в системе расширением, то появляется окно “Выбор программы”, в котором вам предлагается выбрать из предложенного списка программу, способную обработать неизвестный тип файла.
    В данном окне по умолчанию установлен флажок “Использовать выбранную программу для всех файлов такого типа”. Чтобы убрать флажок и заблокировать возможность его установки, Вам необходимо изменить запись в реестре.

    1) Запустите редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте раздел HKEY_CLASSES_ROOT\Unknown\shell\opendlg\command
    3) Измените значение параметра По умолчанию (Default)

    Список программ, которые выводятся в диалоговом окне выбора программы, формируется при помощи списка подразделов раздела HKEY_CLASSES_ROOT\Applications.
    В данном разделе вы можете видеть, что имена подразделов соответствуют именам программ, установленных на вашем компьютере. Если вы хотите, чтобы какая-то из этих программ никогда не выводилась в диалоговом окне выбора программы, то в подразделе этой программы создайте строковый параметр NoOpenWith без какого-либо значения.

    7. Включение окна выбора начальных параметров при запуске проигрывателя Windows Media.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Удалите полностью следующую ветку реестра со всем содержимым:

    Вместо XXXXXX-XXXXXX-XXXXXX-XXXX у Вас будет собственное значение.
    Например: S-1-5-21-83440259-2036283413-1691820529-1000 или S-1-5-21-2717813001-1445373200-4062485642-500

    3) Перезайдите в систему или перезагрузите компьютер.

    8. Изменение действия по умолчанию при перетаскивании файлов между папками в Проводнике.

    При перетаскивании любого файла между двумя папками-окнами Проводника, в Windows 7 по умолчанию выполняется его перемещение. Вы можете самостоятельно настроить действие, которое будет выполняться при перетаскивании файла между папками: копирование; перемещение; создание ярлыка.

    Действие по умолчанию при перетаскивании конкретного типа файлов.

    1) Запустите редактор реестра (Win+R -> regedit -> ОК)
    2) Перейдите в раздел HKEY_CLASSES_ROOT
    3) Найдите раздел интересующего Вас расширения. Для примера возьмем раздел .exe:
    4) Обратите внимание на значение параметра По умолчанию, которое служит идентификатором расширения.
    Для .exe файла данным значением будет exefile, следовательно все параметры необходимо создавать в разделе с идентичным именем.
    5) Перейдите в ветку HKEY_CLASSES_ROOT\exefile.
    6) Создайте новый параметр типа DWORD (32 бита) c именем DefaultDropEffect
    7) Щелкните правой кнопкой мыши по параметру DefaultDropEffect и выберите пункт Изменить...
    8) В текстовом поле Значение: задайте необходимое Вам значение:

    1 - копирование;
    2 - перемещение;
    4 - создание ярлыка.

    Действие по умолчанию для всех файлов при перетаскивании.

    1) Запустите редактор реестра (Win+R -> regedit -> ОК)
    2) Откройте ветку HKEY_CLASSES_ROOT\*.
    3) Создайте новый параметр типа DWORD c именем DefaultDropEffect
    4) Создайте новый параметр типа DWORD (32 бита) c именем DefaultDropEffect
    5) Щелкните правой кнопкой мыши по параметру DefaultDropEffect и выберите пункт Изменить...
    6) В текстовом поле Значение: задайте необходимое Вам значение:

    1 - копирование;
    2 - перемещение;
    4 - создание ярлыка.

    9. Отключение пункта "Исправление неполадок совместимости" из контекстного меню ярлыков и исполняемых файлов.

    Для отключения пункта "Исправление неполадок совместимости" из контекстного меню ярлыков и исполняемых файлов создайте и примените reg-файл следующего содержания:

    Для возвращения пункта "Исправление неполадок совместимости" обратно, создайте и примените reg-файл следующего содержания:

    10. Удаление и восстановление стрелок на ярлыках Windows.

    Готовые файлы для убирания стрелок вы можете скачать по ссылке:
    Shortcut_Arrows.zip
    1) Распакуйте и откройте папку нужного вам варианта
    2) Для удаления стрелок с ярлыков запустите Remove_Shortcut_Arrow.bat или Remove_Shortcut_Arrow.reg
    3) Для восстановления стрелок на ярлыках запустите Restore_Shortcut_Arrow.bat или Restore_Shortcut_Arrow.reg

    Вариант 1

    Для удаления стрелок с ярлыков:

    1) Запустите диалоговое окно "Выполнить" (Win + R)
    2) Скопируйте код указанный ниже и нажмите OK

    Для восстановления стрелок на ярлыках:

    Или в ручную удалите данную ветку.

    Вариант 2

    Для удаления стрелок с ярлыков:

    1) Создайте пустой файл иконки назовите его Blank.ico
    2) Скопируйте его в папку C:\Windows
    3) Запустите диалоговое окно "Выполнить" (Win + R)
    4) Скопируйте код указанный ниже и нажмите OK

    Для восстановления стрелок на ярлыках:

    1) Удалите файл Blank.ico из папки C:\Windows
    2) Запустите диалоговое окно "Выполнить" (Win + R)
    3) Скопируйте код указанный ниже и нажмите OK

    Или в ручную удалите данную ветку.

    Побочным эффектом при использовании данного варианта является, появление черных квадратиков вместо стрелочек, если в папке Windows у Вас будет отсутствовать файл Blank.ico.

    Вариант 3

    1) Скопируйте текст в блокнот.
    2) Сохраните как Remove_Shortcut_Arrow.reg (для удаления) или Restore_Shortcut_Arrow.reg (для восстановления).
    3) Выполните файл, чтобы его содержание было внесено в реестр.
    4) Обратите внимание на знак минуса в команде "IsShortCut"=-. Вокруг него нет кавычек. Эта команда удаляет значение IsShortCut и сам ключ IsShortCut. Если вы введёте команду "IsShortCut"="-", то тогда ключ удалён не будет, а его значение поменяется на минус. "IsNotShortCut"="" создаёт ключ и присваивает ему нулевое значение.

    Файл .reg для удаления стрелок с ярлыков

    Файл .reg для восстановления стрелок на ярлыках

    Побочным эффектом при использовании данного варианта является, исчезновение пункта "Закрепить программу в панели задач". Если Вам необходимо будет закрепить какую-либо программу в Панели задач, то воспользуйтесь reg-файлом для восстановления стрелок на ярлыках, закрепите программу, а затем снова воспользуйтесь reg-файлом для удаления стрелок с ярлыков.

    11. Удаление папок из Рабочего стола в области переходов проводника.

    Если Вы хотите, удалить папки из рабочего стола в области переходов проводника, воспользуйтесь одним из предложенных ниже вариантов.

    Вариант 1

    1) Нажмите Win+R
    2) Введите regedit и нажмите Ок
    3) Пройдите к ветке реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace
    4) Сделайте себе её экспорт, на случай восстановления(ПКМ на данной ветке-Экспортировать).
    5) Удалите следующие ветки:

    Favorites(Избранное) | {323CA680-C24D-4099-B94D-446DD2D7249E}
Libraries(Библиотеки) | {031E4825-7B94-4dc3-B131-E946B44C8DD5}
Homegroup(Домашняя группа) | {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}
Shared Documents(Общие Документы) | {59031a47-3f72-44a7-89c5-5595fe6b30ee}
Computer(Компьютер) | {20D04FE0-3AEA-1069-A2D8-08002B30309D}
Network(Сеть) | {F02C1A0D-BE21-4350-88B0-7367FC96EF3C}
Control Panel(Панель управления) | {26EE0668-A00A-44D7-9371-BEB064C98683}
Recycle Bin(Корзина) | {645FF040-5081-101B-9F08-00AA002F954E}

    Вариант 2

    Создайте и примените reg-файлы следующего содержания:

    Для удаления Favorites(Избранное):

    Для восстановления Favorites(Избранное) по умолчанию:

    Для удаления Libraries(Библиотеки):

    Для восстановления Libraries(Библиотеки) по умолчанию:

    Для удаления Homegroup(Домашняя группа):

    Для восстановления Homegroup(Домашняя группа) по умолчанию:

    Для удаления Computer(Компьютер):

    Для восстановления Computer(Компьютер) по умолчанию:

    Для удаления Network(Сеть):

    Для восстановления Network(Сеть) по умолчанию:

    Для удаления Recycle Bin(Корзина):

    Для восстановления Recycle Bin(Корзина) по умолчанию:

    12. Отключение суффикса "-Ярлык" при создании новых ярлыков.

    1) Запустите редактор реестра (Regedit).
    2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
    3) В правой части окна, дважды щелкните на параметр реестра "link".
    4) Измените значение на 00 00 00 00.
    5) Перезагрузите компьютер.

    Вы можете также создать и применить reg-файл следующего содержания:

    13. Отключение всплывающих подсказок для элeмeнтoв paбoчeгo cтoлa.

    1) Запустите редактор реестра (Regedit).
    2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    3) В правой части окна, дважды щелкните на параметр реестра "ShowInfoTip".
    4) Измените значение на 0.
    5) Перезагрузите компьютер.

    Вы можете также создать и применить reg-файл следующего содержания:

    14. Отключение диалога "Не удалось открыть файл".

    Если системе не знаком тип файла, который вы пытаетесь открыть, то сначала выводится диалоговое окно для поиска программы в интернете.

    Система предлагает Вам:

    Поиск соответствия в интернете. Если вы выберите этот вариант, то запускается веб-служба
    shell. windows. com/fileassoc/0409/xml/redir. asp? Ext=fb2 (пример для случая с FB2-файлом).
    Выбор программы из списка установленных программ. Открывает окно выбора программы для открытия файла на локальном компьютере.

    Для того чтобы не выводить окно для поиска файла в интернете, а сразу открывать окно выбора программы, воспользуйтесь одним из предложенных решений:

    1) Откройте редактор реестра (Win+R -> regedit)
    2) Перейдите к ветке этого создайте параметр HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте DWORD-параметр NoInternetOpenWith и установите его значение равным 1.

    или

    1) Нажмите кнопку "Пуск", и в строке поиска напечатайте cmd.exe.
    2) Щелкните на найденной программе правой кнопкой мыши и нажмите Запуск от имени администратора
    3) В командой строке напечатайте следующее:

    15. Максимально возможное отключение сглаживания шрифтов (ClearType) в Windows 7.

    Если Вы хотите максимально возможно отключить использование ClearType в aero-темах Windows 7, то Вам необходимо сделать следующее.

    Вариант 1.

    1) Отключите ClearType в системе.
    1.1) Откройте Панель управления -> Шрифты -> Настройка текста ClearType
    1.2) Снимите флажок "Включить ClearType".
    2) Отключите сглаживание любого типа шрифта.
    2.1) Откройте Панель управления -> Система -> Дополнительные параметры системы
    2.2) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры
    2.3) На вкладке Визуальные эффекты в списке снимите флажок Сгладить неровности экранных шрифтов
    3) Измените шрифт элементов окна.
    3.1) Откройте Панель управления -> Персонализация -> Цвет окна ->Дополнительные параметры оформления
    3.2) Установите для всех элементов вместо шрифта Segoe UI любой другой шрифт. Например: Tahoma; для всех элементов установите размер 8, для элементов "Заголовок активного окна" и "Заголовок неактивного окна", оставьте размер 9.
    4) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    5) Откройте ветку: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts
    6) Удалите присвоенные значения для указанных ниже параметров:

    Для изменения значения параметра щелкните на необходимом Вам параметре правой кнопкой мыши и нажмите Изменить.

    7) Откройте ветку: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes
    8) Создайте строковый (String) параметр с именем Segoe UI
    9) Щелкните на нем правой кнопкой мыши и нажмите Изменить.
    10) Установите значение параметра Tahoma и нажмите ОК.
    11) Перезагрузите компьютер.

    Примечание:

    П.1) Если крупный шрифт покажется Вам с нечеткими краями установите снятый флажок Сгладить неровности экранных шрифтов обратно.
    П.2) Если шрифт в проводнике и панели задач кажется расплывчатым, измените в ветке HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes значение параметра Segoe UI с Tahoma на MS Sans Serif
    П.3) При выборе шрифтов Tahoma или MS Sans Serif в калькуляторе пропадает изображение стрелки на клавише стереть последнюю цифру.
    П.4) Указанные действия применимы для 100% размера шрифта. Если у Вас стоит увеличение масштаба шрифта (чаще у широкоформатных мониторов), то проделайте следующее:
    П.4.1) Верните масштаб шрифта в 100% значение.
    П.4.2) Примените указанное в данном совете решение, включая перезагрузку.
    П.4.3) Установите необходимый Вам масштаб

    Вы можете скачать готовые reg-файлы, которые выполняют описанные выше действия: ClearType_on-off.zip
    Описание содержимого архива:

    ClearType-off.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов включен.
    ClearType_off+FS.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов отключен.
    ClearType_off+font.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов включен, изменен шрифт на MS Sans Serif.
    ClearType_off+FS+font.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов отключен, изменен шрифт на MS Sans Serif.
    ClearType-restore.reg - Восстановить исходные значения по умолчанию.

    Вариант 2. Ручная установка и удаление Windows Aero (Tahoma Font).

    Главным плюсом в отличие от предыдущего варианта является полное удаление привязки системы к шрифту Segoe UI и наличие изображения стрелки в калькуляторе.

    Установка Windows Aero (Tahoma Font).

    1) Скачайте и распакуйте в любую папку файл Windows Aero (Tahoma Font).zip
    2) Откройте папку Manual и в соответствии с разрядностью Вашей системы запустите Universal Theme Patcher. Данное действие позволит использовать Вам неподписанные темы.
    3) Нажмите кнопку Да (Yes), а затем напротив каждого из файлов кнопку Patch.
    4) Переключите интерфейс Вашей системы на классическую тему.
    5) Откройте папку C:\Windows\Resources\Themes\Aero\. Задайте полный доступ к файлу aero.msstyles для этого воспользуйтесь советом Администрирование: 1. Получение полного доступа к файлу или папке.
    6) Переименуйте файл aero.msstyles в aero.msstyles.backup.
    7) Скопируйте модифицированный файл aero.msstyles из папки Manual в папку C:\Windows\Resources\Themes\Aero\.
    8) Примените reg-файл "NoSegoe - Tahoma.reg".
    9) Откройте Панель управления -> Шрифты -> Настройка текста ClearType и снимите флажок "Включить ClearType". Нажмите несколько раз кнопку Далее, а затем кнопку Готово.
    10) Перезагрузите компьютер.
    11) Переключите обратно на Aero-тему.

    Удаление Windows Aero (Tahoma Font).

    1) Переключите интерфейс Вашей системы на классическую тему.
    2) Откройте папку C:\Windows\Resources\Themes\Aero\. Задайте полный доступ к файлу aero.msstyles для этого воспользуйтесь советом Администрирование: 1. Получение полного доступа к файлу или папке.
    3) Удалите файл aero.msstyles
    4) Переименуйте файл aero.msstyles.backup обратно в aero.msstyles.
    5) Откройте папку Manual из папки, где распакован архив и примените reg-файл "NoSegoe - Restore Segoe UI.reg".
    6) В соответствии с разрядностью Вашей системы запустите Universal Theme Patcher. Данное действие позволит использовать Вам неподписанные темы.
    7) Нажмите кнопку Да (Yes), а затем напротив каждого из файлов кнопку Restore.
    8) Откройте Панель управления -> Шрифты -> Настройка текста ClearType и установите флажок "Включить ClearType". Нажмите несколько раз кнопку Далее, а затем кнопку Готово.
    9) Перезагрузите компьютер.
    10) Переключите обратно на Aero-тему.

    Вариант 3. Автоматическая установка Windows Aero (Tahoma Font).

    Установка Windows Aero (Tahoma Font).

    1) Скачайте и распакуйте в любую папку файл Windows Aero (Tahoma Font).zip
    2) Откройте папку Auto.
    3) Нажмите правой кнопкой мыши на файле Windows Aero (Tahoma Font).exe и выберите пункт Запуск от имени администратора
    4) Нажмите клавишу Next в первом окне, во втором окне установите переключатель в значение I accept the agreement и нажмите кнопку Next.
    5) В окне Information также нажмите кнопку Next.
    6) В окне Select Components установите все флажки и нажмите кнопку Next.
    7) В окне Ready to Install нажмите кнопку Install и запустится установка.
    8) В окне Windows Aero (Tahoma Font) Setup информирующем о переключении интерфейса на классическую тему нажмите кнопку ОК.
    9) После того как программа переключится на классическую тему вернитесь обратно в программу.
    10) В окне Windows Aero (Tahoma Font) Setup информирующем о необходимости нажатия кнопки Yes при запуске скриптов для данной программы нажмите кнопку ОК.
    11) Установите переключатель в значение Yes, restart the computer now и нажмите кнопку Finish.
    12) Компьютер перезагрузится и если у Вас включен Контроль учетных записей (UAC), то в окнах предлагающих запустить Microsoft Windows Based Script Host нажмите кнопку Да (Yes).

    Удаление Windows Aero (Tahoma Font).

    1) Откройте Панель управления -> Программы и компоненты и щелкните на Windows Aero (Tahoma Font)
    2) В появившемся окне нажмите Да, а в следующем ОК.
    3) В окне Windows Aero (Tahoma Font) Setup информирующем о необходимости нажатия кнопки Yes при запуске скриптов для данной программы нажмите кнопку ОК.
    4) В окне предлагающем перезапустить компьютер нажмите Да
    5) Компьютер перезагрузится и если у Вас включен Контроль учетных записей (UAC), то в окнах предлагающих запустить Microsoft Windows Based Script Host нажмите кнопку Да (Yes).

    Примечание:

    П. Если после установки или удаления программа не переключила обратно на Вашу aero-тему, то сделайте это вручную.

    16. Изменение набора кнопок на панели проводника Windows 7.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    На панели проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами для хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения набора кнопок во всех папках проводника добавьте или удалите кнопки во все шаблоны.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для изменения отображаемых кнопок сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку необходимого Вам шаблона.
    Например: для добавления или удаления кнопки в обычную папку использующую шаблон типа папки «Общие элементы» откройте:

    А для добавления или удаления кнопки в папку «Общие элементы», входящей в Библиотеки откройте:

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

    4.1) Откройте необходимый из указанных подразделов, если Вы изменяете набор кнопок в шаблонах Библиотек и/или в шаблонах поиска результатов в них.
    4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать -> Раздел.)

    TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
    TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

    5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Изменить.
    6) Добавьте к существующим значениям необходимые или удалите ненужные.
    Порядок значений в списке соответствует порядку отображения кнопок на панели. Значения отделяются друг от друга точкой с запятой (;).
    Например: Windows.Copy;Windows.Paste;Windows.Delete;

    Список возможных кнопок для добавления Вы можете узнать из названий подразделов в ветке реестра:

    В таблице ниже указаны значения наиболее часто используемых кнопок.

    Кнопка | Действие | Использование
Windows.burn | Записать на оптический диск | TasksItemsSelected
Windows.closewindow | Закрыть (окно) <ALT+F4> | TasksItemsSelected, TasksNoItemsSelected
Windows.copy | Вырезать <CTRL+C> | TasksItemsSelected
Windows.cut | Копировать <CTRL+X> | TasksItemsSelected
Windows.delete | Удалить <Del> | TasksItemsSelected
Windows.email | Электронная почта | TasksItemsSelected
Windows.folderoptions | Параметры папок и поиска | TasksNoItemsSelected
Windows.includeinlibrary | Включить в библиотеку | TasksItemsSelected
Windows.layout | Представление (вкл. и выкл. областей проводника) | TasksNoItemsSelected
Windows.librarypane | Область библиотек (под панелью кнопок) | TasksNoItemsSelected
Windows.menubar | Строка меню (ALT) | TasksNoItemsSelected
Windows.navpane | Область переходов | TasksNoItemsSelected
Windows.newfolder | Создать новую папку | TasksNoItemsSelected
Windows.paste | Вставить (CTRL+V) | TasksItemsSelected, TasksNoItemsSelected
Windows.previewpane | Область сведений | TasksNoItemsSelected
Windows.print | Печать | TasksItemsSelected
Windows.properties | Свойства (файла, папки, библиотеки) <ALT+Enter> | TasksItemsSelected, TasksNoItemsSelected
Windows.readingpane | Область предпросмотра <Alt+P> | TasksNoItemsSelected
Windows.redo | Вернуть (возврат последнего отмененного действия) <CTRL+Y> | TasksNoItemsSelected
Windows.removeproperties | Удалить свойства (файла, папки, библиотеки) | TasksItemsSelected, TasksNoItemsSelected
Windows.rename | Переименовать <F2> | TasksItemsSelected
Windows.selectall | Выделить все <CTRL+A> | TasksNoItemsSelected
Windows.separator | Разделитель (кнопка без подписи и действия) | TasksItemsSelected, TasksNoItemsSelected
Windows.Share | Общий доступ | TasksItemsSelected
Windows.slideshow | Показ слайдов | TasksItemsSelected, TasksNoItemsSelected
Windows.undo | Отменить <CTRL+Z> | TasksNoItemsSelected

    17. Изменение состава меню "Упорядочить" на панели Проводника Windows 7.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    На панели проводника почти везде присутствуют кнопка Упорядочить, при нажатии на которую появляется меню с определенным набором выполняемых команд и подменю Представление.

    Для изменения пунктов отображающихся в данном меню сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку:

    Для внесения изменений в меню Упорядочить:

    Для внесения изменений в меню Представление:

    3) Задайте полные права на доступ к выбранному разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Щелкните правой кнопкой мыши на параметре SubCommands и выберите Изменить.
    5) Добавьте к существующим значениям необходимые или удалите ненужные.
    Порядок значений в списке соответствует порядку отображения пунктов списка. Значения отделяются друг от друга точкой с запятой (;) , символ | означает разделитель меню, после него также ставится точка с запятой.

    Список значений параметра SubCommands для меню Упорядочить по умолчанию:

    Список значений параметра SubCommands для подменю Упорядочить по умолчанию:

    Список пунктов возможных для добавления Вы можете узнать из названий подразделов в ветке реестра:

    В таблице ниже указаны значения наиболее часто используемых пунктов.

    Кнопка | Действие | Использование
Windows.burn | Записать на оптический диск | TasksItemsSelected
Windows.closewindow | Закрыть (окно) <ALT+F4> | TasksItemsSelected, TasksNoItemsSelected
Windows.copy | Вырезать <CTRL+C> | TasksItemsSelected
Windows.cut | Копировать <CTRL+X> | TasksItemsSelected
Windows.delete | Удалить <Del> | TasksItemsSelected
Windows.email | Электронная почта | TasksItemsSelected
Windows.folderoptions | Параметры папок и поиска | TasksNoItemsSelected
Windows.includeinlibrary | Включить в библиотеку | TasksItemsSelected
Windows.layout | Представление (вкл. и выкл. областей проводника) | TasksNoItemsSelected
Windows.librarypane | Область библиотек (под панелью кнопок) | TasksNoItemsSelected
Windows.menubar | Строка меню (ALT) | TasksNoItemsSelected
Windows.navpane | Область переходов | TasksNoItemsSelected
Windows.newfolder | Создать новую папку | TasksNoItemsSelected
Windows.paste | Вставить (CTRL+V) | TasksItemsSelected, TasksNoItemsSelected
Windows.previewpane | Область сведений | TasksNoItemsSelected
Windows.print | Печать | TasksItemsSelected
Windows.properties | Свойства (файла, папки, библиотеки) <ALT+Enter> | TasksItemsSelected, TasksNoItemsSelected
Windows.readingpane | Область предпросмотра <Alt+P> | TasksNoItemsSelected
Windows.redo | Вернуть (возврат последнего отмененного действия) <CTRL+Y> | TasksNoItemsSelected
Windows.removeproperties | Удалить свойства (файла, папки, библиотеки) | TasksItemsSelected, TasksNoItemsSelected
Windows.rename | Переименовать <F2> | TasksItemsSelected
Windows.selectall | Выделить все <CTRL+A> | TasksNoItemsSelected
Windows.separator | Разделитель (кнопка без подписи и действия) | TasksItemsSelected, TasksNoItemsSelected
Windows.Share | Общий доступ | TasksItemsSelected
Windows.slideshow | Показ слайдов | TasksItemsSelected, TasksNoItemsSelected
Windows.undo | Отменить <CTRL+Z> | TasksNoItemsSelected

    18. Изменение отображаемых по умолчанию свойств для файла в проводнике.

    При выделении файла в проводнике, система отображает в области сведений соответствующую ему информацию. Также сведения отображаются при наведении на него курсора мыши или на вкладке Подробно в окне Свойства, вызываемом из контекстного меню.

    Для настройки сведений, отображаемых для файла в проводнике, сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте раздел соответствующий наименованию необходимого Вам расширения файла в указанных ниже ветках реестра:

    2.1) чтобы изменить отображаемые сведения для всех пользователей на компьютере (если Вы администратор компьютера):

    2.2) чтобы изменить отображаемые сведения для текущей записи:

    Например, для расширения .mp3 откройте:

    3) Измените значения параметров:

    InfoTip - отвечает за информацию отображаемую во всплывающей подсказке
    PreviewDetails - отвечает за информацию отображаемую в области сведений проводника
    FullDetails - отвечает за информацию отображаемую во вкладке Подробно в Свойствах файла

    4) Щелкните правой кнопкой мыши на выбранном параметре и выберите Изменить.
    5) После слова prop: добавьте к существующим значениям необходимые или удалите ненужные.
    Порядок значений в списке соответствует порядку отображения пунктов в системе. Значения отделяются друг от друга точкой с запятой.

    Например, для файлов с расширением .mp3 Вы можете выставить значение:

    В таблице ниже, указаны значения наиболее часто используемых значений данных параметров.

    Наименование значения параметра | Отображаемое значение
System.Audio.ChannelCount | Каналы, количество
System.Audio.EncodingBitrate | Скорость потока
System.Audio.EncodingBitrate | Скорость потока
System.Audio.SampleRate | Частота дискретизации
System.Author | Авторы
System.Comment | Комментарии
System.ComputerName | Компьютер
System.Copyright | Авторские права
System.DateCreated | Дата создания
System.DateModified | Дата изменения
System.FileAttributes | Атрибуты
System.FileOwner | Владелец
System.Image.BitDepth | Глубина цвета
System.Image.Dimensions | Размеры
System.Image.HorizontalResolution | Горизонтальное разрешение
System.Image.HorizontalSize | Ширина
System.Image.ResolutionUnit | Единица разрешения
System.Image.VerticalResolution | Разрешение по вертикали
System.Image.VerticalSize | Высота
System.ItemFolderPathDisplay | Путь к папке
System.ItemNameDisplay | Имя
System.ItemType | Тип элемента
System.Keywords | Ключевые слова
System.Media.DateEncoded | Дата создания мультимедиа
System.Media.Duration | Продолжительность
System.Media.SubTitle | Субтитры
System.Media.Year | Год
System.Music.Artist | Участвующие исполнители
System.Music.Genre | Жанр
System.Photo.DateTaken | Дата съемки
System.PropGroup.Audio | Группа Аудио
System.PropGroup.Content | Группа Содержание
System.PropGroup.Description | Группа Описание
System.PropGroup.FileSystem | Группа Файл
System.PropGroup.Image | Группа Изображение
System.PropGroup.Media | Группа Носитель
System.PropGroup.Origin | Группа Источник
System.PropGroup.Video | Группа Видео
System.Rating | Оценка
System.SharedWith | Общий доступ
System.Size | Размер
System.Subject | Тема
System.Title | Название
System.Video.EncodingBitrate | Скорость передачи данных
System.Video.FrameHeight | Высота кадра
System.Video.FrameRate | Частота кадров
System.Video.FrameWidth | Ширина кадра
System.Video.TotalBitrate | Общая скорость потока

    19. Изменение используемых по умолчанию столбцов в проводнике для папок, при выборе отображения в виде таблицы.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    При выборе в проводнике вида отображения Таблица, система показывает определенные столбцы. Вы можете настроить для любой папки свой собственный набор столбцов, щелкнув правой кнопкой мыши на любом из них и во всплывающем меню выбрав пункт Подробнее..., если же Вам необходимо изменить столбцы отображаемые по умолчанию, то Вам необходимо внести соответствующие изменения в реестр.

    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами для хранения файлов, измените набор столбцов в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения набора столбцов во всех папках проводника добавьте или удалите значения во всех шаблонах.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для настройки столбцов, используемых по умолчанию в проводнике, сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку необходимого Вам шаблона.
    Например: для добавления или удаления столбцев в обычной папке использующей шаблон типа папки «Музыка» откройте:

    А для добавления или удаления столбцев в папке «Музыка», входящей в Библиотеки откройте:

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TopViews
    5) Поочередно открывая подразделы типа {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX} измените значения параметра ColumnList (щелчок правой кнопкой мыши на параметре -> Изменить) стоящие после слова prop: .
    6) Для включения необходимого Вам столбца измените значение стоящее перед ним на 0. Цифра 0 перед указанным Вами параметром сообщит системе, что данный столбец необходимо отобразить. Если необходимый Вам столбец отсутствует, то Вы можете добавить его самостоятельно, указав перед ним цифру 0. Значения отделяются друг от друга точкой с запятой (;). Например: для изменения столбцов как на рисунке, в начале совета значение параметра ColumnList примет вид:

    В таблице ниже, указаны значения наиболее часто используемых значений данного параметра.

    Наименование значения параметра | Отображаемое значение
System.Audio.ChannelCount | Каналы, количество
System.Audio.EncodingBitrate | Скорость потока
System.Audio.EncodingBitrate | Скорость потока
System.Audio.SampleRate | Частота дискретизации
System.Author | Авторы
System.Comment | Комментарии
System.ComputerName | Компьютер
System.Copyright | Авторские права
System.DateCreated | Дата создания
System.DateModified | Дата изменения
System.FileAttributes | Атрибуты
System.FileOwner | Владелец
System.Image.BitDepth | Глубина цвета
System.Image.Dimensions | Размеры
System.Image.HorizontalResolution | Горизонтальное разрешение
System.Image.HorizontalSize | Ширина
System.Image.ResolutionUnit | Единица разрешения
System.Image.VerticalResolution | Разрешение по вертикали
System.Image.VerticalSize | Высота
System.ItemFolderPathDisplay | Путь к папке
System.ItemNameDisplay | Имя
System.ItemType | Тип элемента
System.Keywords | Ключевые слова
System.Media.DateEncoded | Дата создания мультимедиа
System.Media.Duration | Продолжительность
System.Media.SubTitle | Субтитры
System.Media.Year | Год
System.Music.Artist | Участвующие исполнители
System.Music.Genre | Жанр
System.Photo.DateTaken | Дата съемки
System.PropGroup.Audio | Группа Аудио
System.PropGroup.Content | Группа Содержание
System.PropGroup.Description | Группа Описание
System.PropGroup.FileSystem | Группа Файл
System.PropGroup.Image | Группа Изображение
System.PropGroup.Media | Группа Носитель
System.PropGroup.Origin | Группа Источник
System.PropGroup.Video | Группа Видео
System.Rating | Оценка
System.SharedWith | Общий доступ
System.Size | Размер
System.Subject | Тема
System.Title | Название
System.Video.EncodingBitrate | Скорость передачи данных
System.Video.FrameHeight | Высота кадра
System.Video.FrameRate | Частота кадров
System.Video.FrameWidth | Ширина кадра
System.Video.TotalBitrate | Общая скорость потока

    7) Перезагрузите компьютер
    8) Для папок из библиотек, щелкните правой кнопкой мыши внутри основной папки (Видео, Документы, Изображения, Музыка) выберите Упорядочить -> Очистить изменения
    9) Для обычных папок измените шаблон на другой вид в Свойства -> Настройка, а затем верните обратно.
    10) Также очистите в реестре указанный ниже раздел, удалив все папки кроме AllFolders.

    Очистка данного раздела реестра удалит все настройки для папок сделанные пользователями, до применения данного совета.

    20. Изменение пунктов контекстного меню "Сортировка" используемых по умолчанию в проводнике.
    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    При нажатии правой кнопки мыши в любой папке в проводнике, система показывает контекстное меню. В данном меню есть пункт Сортировка, содержащий свое собственное меню. Вы можете настроить для любой папки свой собственный вид меню Сортировка, выбрав в нем пункт Подробнее..., если же Вам необходимо изменить вид данного меню отображаемый по умолчанию для всех папок, то Вам необходимо внести соответствующие изменения в реестр.

    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами для хранения файлов, измените вид меню Сортировка в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения набора пунктов во всех папках проводника добавьте или удалите значения во всех шаблонах.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для настройки меню Сортировка, используемого по умолчанию в проводнике, сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку необходимого Вам шаблона.
    Например: для добавления или удаления пунктов в меню Сортировка для обычной папки использующей шаблон типа папки «Музыка» откройте:

    А для добавления или удаления пунктов в меню Сортировка для папки «Музыка», входящей в Библиотеки откройте:

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TopViews
    5) Поочередно открывая подразделы типа {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX} измените значения параметра SortByList (щелчок правой кнопкой мыши на параметре -> Изменить) стоящие после слова prop: .
    6) Добавьте к существующим значениям необходимые или удалите ненужные.
    Порядок значений в списке соответствует порядку отображения пунктов в меню. Значения отделяются друг от друга точкой с запятой (;).
    Например:

    В таблице ниже, указаны значения наиболее часто используемых значений данного параметра.

    Наименование значения параметра | Отображаемое значение
System.Audio.ChannelCount | Каналы, количество
System.Audio.EncodingBitrate | Скорость потока
System.Audio.EncodingBitrate | Скорость потока
System.Audio.SampleRate | Частота дискретизации
System.Author | Авторы
System.Comment | Комментарии
System.ComputerName | Компьютер
System.Copyright | Авторские права
System.DateCreated | Дата создания
System.DateModified | Дата изменения
System.FileAttributes | Атрибуты
System.FileOwner | Владелец
System.Image.BitDepth | Глубина цвета
System.Image.Dimensions | Размеры
System.Image.HorizontalResolution | Горизонтальное разрешение
System.Image.HorizontalSize | Ширина
System.Image.ResolutionUnit | Единица разрешения
System.Image.VerticalResolution | Разрешение по вертикали
System.Image.VerticalSize | Высота
System.ItemFolderPathDisplay | Путь к папке
System.ItemNameDisplay | Имя
System.ItemType | Тип элемента
System.Keywords | Ключевые слова
System.Media.DateEncoded | Дата создания мультимедиа
System.Media.Duration | Продолжительность
System.Media.SubTitle | Субтитры
System.Media.Year | Год
System.Music.Artist | Участвующие исполнители
System.Music.Genre | Жанр
System.Photo.DateTaken | Дата съемки
System.PropGroup.Audio | Группа Аудио
System.PropGroup.Content | Группа Содержание
System.PropGroup.Description | Группа Описание
System.PropGroup.FileSystem | Группа Файл
System.PropGroup.Image | Группа Изображение
System.PropGroup.Media | Группа Носитель
System.PropGroup.Origin | Группа Источник
System.PropGroup.Video | Группа Видео
System.Rating | Оценка
System.SharedWith | Общий доступ
System.Size | Размер
System.Subject | Тема
System.Title | Название
System.Video.EncodingBitrate | Скорость передачи данных
System.Video.FrameHeight | Высота кадра
System.Video.FrameRate | Частота кадров
System.Video.FrameWidth | Ширина кадра
System.Video.TotalBitrate | Общая скорость потока

    21. Запрещение подмены функции кнопки "Завершения работы" при необходимости обновления системы.

    При наличии обновлений, ожидающих установки, на кнопке завершения работы Windows появляется значок со щитом.

    Если не применить данный твик реестра, то когда имеются обновления, доступные для установки, при выборе в меню Пуск команды Завершение работы по умолчанию выберется действие - Установить обновления и завершить работу.
    Чтобы отключить данную функцию в диалоговом окне Завершение работы Windows и отобразить по умолчанию параметр, выбранный при последнем выключении (Гибернация, Перезагрузка и т. д.), вне зависимости от доступности параметра Установить обновления и завершить работу в списке создайте и примените reg-файл следующего содержания:

    22. Постоянное отображение команд "Открыть окно команд" и "Копировать как путь" в контекстном меню проводника.

    Если Вы будете удерживать клавишу Shift при нажатии правой кнопки мыши, то в контекстном меню появятся дополнительные пункты Открыть командную строку и Копировать как путь.

    Чтобы пункт Открыть командную строку отображался без нажатия Shift создайте и примените нижеследующий reg-файл:

    Чтобы заставить пункт Открыть командную строку снова отображаться только при нажатии Shift создайте и примените нижеследующий reg-файл:

    Чтобы пункт Копировать как путь отображался без нажатия Shift создайте и примените нижеследующий reg-файл:

    Минус такого решения - появляющееся на доли секунды окно командной строки.

    Чтобы заставить пункт Копировать как путь снова отображаться только при нажатии Shift создайте и примените нижеследующий reg-файл:

    Если Вам не нравится появляющееся на долю секунды окно командной строки, то Вы можете воспользоваться утилитой NirCmd
    Данная утилита позволяет выполнять команды командной строки без отображения окна команд.
    Для отображения пункта Копировать как путь без нажатия Shift, сделайте следующее:

    1) Скачайте утилиту NirCmd в соответствии с разрядностью Вашей Windows
    2) Распакуйте скаченный zip-архив в папку C:\NirCmd
    3) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    4) Откройте раздел HKEY_CLASSES_ROOT\AllFilesystemObjects\shell\CopyAsPath\Command
    5) Измените значение параметра По умолчанию на:

    23. Добавление произвольного системного ActiveX-элемента в Рабочий стол области переходов проводника.

    По умолчанию в проводнике отображается определенный набор объектов ActiveX: Избранное, Библиотеки, Компьютер и Сеть или более расширенный, если у Вас в настройках элемента Параметры папок установлен флажок Показать все папки.

    Чтобы добавить какой-либо из системных объектов в область переходов, Вам необходимо знать его статистически уникальный 128-битный идентификатор - {GUID}.
    Список всех идентификаторов ({GUID}) находится в разделе реестра: HKEY_CLASSES_ROOT\CLSID\{GUID}. Из данного списка в в область переходов, добавить Вы можете, те ActiveX-объекты, которые имеют интерфейс IShellFolder (интерфейс для объектов, расширяющих пространство имен оболочки). Данный факт определяется наличием в {GUID} разделе реестра подраздела ShellFolder.
    Для экономии времени, необходимого на поиск нужного элемента Вы можете воспользоваться утилитой CSLID Dump, позволяющей получить список всех ActiveX-объектов, имеющих IShellFolder интерфейс.

    1) Скачайте CSLID Dump, распакуйте архив и запустите программу.
    2) Найдите в CLSID Dump, необходимый Вам {GUID} ActiveX-объекта и откройте его в реестре:
    2.1) Нажмите в самой программе на кнопку Open Regedit
    или
    2.2) Запустите редактор реестра (Win+R -> regedit -> ОК) и откройте раздел

    где вместо {GUID} вставьте найденное Вами значение.
    3) Откройте в данном разделе подраздел ShellFolder.

    Например: элементу "Все задачи" соответствует {GUID} равный {ED7BA470-8E54-465E-825C-99712043E01C}, следовательно необходимо открыть:

    4) Задайте полные права на доступ к разделу HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder.

    4.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    4.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    4.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    4.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    4.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    5) Если в разделе HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder присутствует строковый параметр WantsParseDisplayName, то удалите его.
    6) Если в разделе HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder отсутствует строковый параметр PinToNameSpaceTree, то создайте его с пустым значением.

    Включите отображение объекта для перечисления.

    7) Если необходимо, измените значение параметра Attributes таким образом, чтобы третья цифра стала равна 0. Например: вместо 20100004 задайте 20000004 .

    Добавьте Ваш ActiveX-объект в пространство имен Рабочего стола.

    8) Перейдите в раздел:

    9) Создайте здесь подраздел с названием идентичным Вашему {GUID}. Например:

    Разрешите отображение Вашего объекта только в области переходов проводника, исключая отображение его на Рабочем столе.

    11) Перейдите в раздел:

    12) Создайте здесь DWORD-параметр с названием идентичным Вашему {GUID} и задайте ему значение равное 1.
    13) Закройте редактор реестра.
    14) Выйдите из системы и войдите в неё заново или перезагрузите компьютер.

    Описанным выше способом, Вы можете добавить почти любой из ActiveX-объектов имеющих интерфейс IShellFolder.

    24. Изменение вида приглашения в командной строке.

    Вы можете изменить вид приглашения для командной строки. Как правило используется формат типа C:\> (текущий диск и угловая скобка).

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте раздел HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
    3) Создайте PROMPT типа REG_EXPAND_SZ (расширяемый строковый параметр)
    4) Присвойте ему любое из следующих значений (значения можно объединять):

    $B - | (вертикальная черта)
    $D - текущая дата
    $G - > (знак больше)
    $L - < (знак меньше)
    $N - текущий диск
    $P - текущий диск и путь
    $Q - = (знак равно)
    $T - текущее время
    $V - версия Windows
    $$ - $ (знак доллара)
    $A - & (амперсанд)
    $C - ( (левая скобка)
    $F - ) (правая скобка)
    $S - пробел
    [%computername%] - имя Вашего компьютера
    $_ - переход к началу новой строки экрана

    5) Перезагрузите компьютер.

    Например при введении знгачения:

    Вы увидите строку наподобие:

    25. Изменение языка интерфейса установленного по умолчанию (язык системы), для возможности его удаления или правильного определения программами.

    Иногда бывает, если у Вас установлена английская версия и сверху русский языковой пакет, то некоторые программы, имеющие встроенную функцию определения языка могут некорректно определить язык Вашей системы и автоматически запускаться с английским языком интерфейса.
    Также, если Вы решите удалить английский язык из системы после установки сверху русского языкового пакета, то система не позволит Вам этого сделать. Это происходит потому, что для Windows английский язык - это язык системы или язык интерфейса установленный по умолчанию, а русский язык - дополнительный язык интерфейса.

    Чтобы переключить язык интерфейса установленного по умолчанию создайте и примените reg-файл, после чего перезагрузите компьютер.

    Чтобы установить русский язык, в качестве языка используемого по умолчанию (язык системы):

    Чтобы установить английский язык, в качестве языка используемого по умолчанию (язык системы):

    26. Настройка вида, используемого по умолчанию для папок в проводнике и в диалоговом окне "Открыть/Сохранить файл".

    При нажатии правой кнопки мыши в любой папке в проводнике, система показывает контекстное меню. В данном меню есть пункт Вид, используя который Вы можете настроить для любой папки свой собственный вид. Но если же Вам необходимо изменить вид папки используемый по умолчанию для всех папок, то Вам необходимо внести соответствующие изменения в реестр.

    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами для хранения файлов, измените значения в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения вида папок по умолчанию во всех папках проводника добавьте или удалите значения во всех шаблонах.

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для настройки используемого по умолчанию вида папки, сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) В зависимости от того, для чего Вы хотите настроить используемый по умолчанию вид папки, откройте соответствующий раздел реестра.

    Для использования по умолчанию в проводнике:

    Для использования по умолчанию в стандартном диалоге "Открыть/Сохранить файл":

    3) Создайте раздел, соответствующий GUID выбранного Вами шаблона. Например, для настройки вида папок использующих наиболее часто встречающийся шаблон "Общие элементы" создайте:

    Для использования по умолчанию в проводнике:

    Для использования по умолчанию в стандартном диалоге "Открыть/Сохранить файл":

    4) Создайте в данном разделе три параметра DWORD: IconSize,LogicalViewMode и Mode и задайте им значения в соответствии с нижеследующей таблицей. Для удобства использования значения предоставлены в двух системах исчисления.

    Вид папки: | Система исчисления | IconSize | LogicalViewMode | Mode
Огромные значки | Десятичная | 256 | 3 | 1
 | Шестнадцатеричная | 100 | 3 | 1
Крупные значки | Десятичная | 96 | 3 | 1
 | Шестнадцатеричная | 60 | 3 | 1
Обычные значки | Десятичная | 48 | 3 | 1
 | Шестнадцатеричная | 30 | 3 | 1
Мелкие значки | Десятичная | 16 | 3 | 1
 | Шестнадцатеричная | 10 | 3 | 1
Список | Десятичная | 16 | 4 | 3
 | Шестнадцатеричная | 10 | 4 | 3
Таблица | Десятичная | 16 | 1 | 4
 | Шестнадцатеричная | 10 | 1 | 4
Плитка | Десятичная | 48 | 2 | 6
 | Шестнадцатеричная | 30 | 2 | 6
Содержимое | Десятичная | 32 | 5 | 8
 | Шестнадцатеричная | 20 | 5 | 8

    Например, чтобы установить вид папки Крупные значки создайте DWORD-параметры IconSize=60, LogicalViewMode=3 и Mode=1.

    5) Перезагрузите компьютер или перезайдите в систему.

    Примечание:

    Если Вы ранее в проводнике вручную изменяли вид для какой-либо папки, то система записала Ваши изменения в реестр, и чтобы желаемый Вами вид папки установился также и в них, то Вам необходимо, выполнить на выбор одно из предложенных действий:

    1) Удалить из раздела HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags все папки, кроме AllFolders
    2) Изменить параметры Mode, LogicalViewMode и IconSize на необходимые Вам значения в разделах:

    где XXX - номер папки (раздела), в который записаны значения измененных Вами параметров.
    {GUID} - данный GUID соответствует типу папки.

    27. Удаление открываемых путей из истории в адресной строке проводника.

    Когда Вы вводите путь в адресную строку проводника, то он сохраняется в журнал расположений. И если Вы в дальнейшем нажмете на стрелку вниз в конце адресной строки, то откроется список предыдущих расположений.
    Если Вам необходимо его очистить,то Вы можете либо полностью стереть историю открываемых путей или удалить отдельные записи.

    Чтобы очистить всю Вашу историю посещений в проводнике, щелкните правой кнопкой мыши на адресной строке и выберите из меню пункт Удалить журнал.

    Чтобы удалить отдельные записи:

    1) Запустите редактор реестра (Win+R->regedit->ОК)
    2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\TypedPaths
    3) Удалите параметры, в которых содержатся ненужные вам пути.
    4) Перезайдите в систему или закройте все процессы проводника и запустите его снова.

    28. Добавление отображения логотипа и сопутствующей информации.

    1) Создайте рисунок с нужным Вам логотипом.
    2) Сохраните его с разрешением 120x120 в формате .bmp (Например, в папке C:\Windows\System32 под именем OEMLogo.bmp).
    3) Запустите редактор реестра (Win+R -> regedit -> OK)
    4) Откройте раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\OEMInformation
    5) Создайте строковые параметры с необходимыми Вам значениями. Например:

    Model - Название модели
    Manufacturer - Название фирмы
    SupportPhone - Телефон поддержки
    SupportURL - Адрес сайта службы поддержки
    SupportHours - Время работы тех.поддержки
    Logo - Путь к Вашему логотипу.

    6) Перезагрузите компьютер.

    Также Вы можете создать и применить reg-файл.

    Пример:

    Твики Реестра - Дополнительная функциональность.

    1. Распаковка Хотфиксов(обновлений Microsoft с расширением EXE) из контекстного меню.

    Для распаковки инсталляций, удобно пользоваться Universal Extractor-ом, но последняя версия не все хотфиксы от MS распаковывает правильно и приходится пользоваться другими методами. Одним из вариантов является добавление в контекстное меню команды Unpack HotFix.
    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Чтобы добавить данный пункт в контекстное меню, создайте следующий reg-файл:

    Например, при распаковке Windows6.1-KB917607-x64.exe, на выходе получаем папку Windows6.1-KB917607-x64.exe_unpacked с извлечёнными файлами.
    Минус один - команда Unpack HotFix встраивается в контекстное меню всех exe-файлов, а не только файлов от Microsoft.

    Чтобы удалить данный пункт из контекстного меню, создайте следующий reg-файл:

    Готовые reg-файлы Вы можете скачать по ссылке: Unpack_HotFix.zip

    2. Добавление пункта "Открыть в блокноте" в контекстное меню файлов.

    1) Создайте reg-файл.
    1.1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    1.2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "Notepad.reg")
    1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    2) Примените полученный reg-файл. Щелкните на нем дважды и нажми кнопку Да.

    3. Добавление системных ярлыков в папку Компьютер.

    Создайте и примените reg-файлы следующего содержания:

    Администрирование

    Корзина

    Панель управления

    Принтеры и факсы

    Учетные записи пользователей

    4. Добавление произвольной команды в контекстное меню рабочего стола.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "fix.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    5) Примените его.

    Вместо Название команды укажите необходимое Вам название пункта, которое будет отображаться в контекстном меню. Например: Панель управления
    Вместо выполняемая команда укажите какая команда должна быть запущена при нажатии созданного Вами пункта в контекстном меню. Например: control
    Вместо путь к значку иконки укажите путь к иконке, отображаемой рядом с Вашим пунктом в контекстном меню.
    Вместо Расположение укажите месторасположение Вашего пункта в контекстном меню. Top - вверху, Bottom - внизу.

    Описанным выше способом можно добавить практически любую команду.
    Например, reg-файл для добавления пункта Панель управления в контекстное меню рабочего стола будет выглядеть так:

    5. Распаковка файлов и директорий из CAB-архивов (а так же упаковка в CAB-архивов) из контекстного меню "Отправить".
    Reg-файл добавляет в расширенное меню оболочки функции для упаковки и распаковки CAB. С папками, в пути к которым есть пробелы и спецсимволы, к сожалению, не работает.

    6. Добавление пункта "Удалить содержимое папки" в контекстное меню.

    Как добавить в контекстное меню папки команду для удаления содержимого папки без удаления самой папки? Вы можете создать себе пункт Удалить содержимое папки в контекстном меню и Вам достаточно будет его только выбрать. Вам не придется открывать папку, выделять все файлы и нажимать на клавишу Delete.

    Вариант 1.

    1) Запустите редактор реестра: Win+R -> regedit -> Ok
    2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
    3) Создайте в ней раздел DeleteFolderContent
    4) Создайте в нем строковый(String) параметр MUIVerb со строкой Удалить содержимое папки.
    5) В разделе DeleteFolderContent создайте подраздел command
    6) Измените значение параметра (По умолчанию) раздела command на следующее:

    Вариант 2.

    1) Запустите редактор реестра: Win+R -> regedit -> Ok
    2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
    3) Создайте в ней раздел Удалить содержимое папки
    4) В разделе Удалить содержимое папки создайте подраздел command
    6) Измените значение параметра (По умолчанию) раздела command на следующее:

    Вариант 3.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Вы можете скачать готовые reg-файлы: DeleteFolderContent.zip

    7. Добавление пунктов "Копировать в папку" и "Переместить в папку" в контекстное меню.

    По какой-то неизвестной причине, разработчики Microsoft решили не включать в контекстное меню Проводника пункты Копировать в папку (Copy To) и Переместить в папку (Move To). Используя их, можно легко и быстро скопировать или переместить файл или папку. Для этого, достаточно выбрать желаемое место их размещения в соответствующем диалоговом окне. Для того, чтобы добавить эти команды в контекстное меню, достаточно создать, соответствующие им параметры в реестре.

    Вариант 1

    1) Запустите Редактор Реестра (нажмите копку «Пуск» (Start), введите regedit в строке «Найти программы и файлы» и нажмите Enter).
    2) Откройте ветку реестра HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers
    3) Создайте в ней раздел со следующим именем (включая фигурные скобки):
    Для добавления в контекстное меню пункта Копировать в папку

    Для добавления в контекстное меню пункта Переместить в папку

    4) Нажмите Enter
    5) Перезагрузите Проводник Windows (Windows Explorer) или перезайдите в систему, и данные пункты появятся в контекстном меню.

    Вариант 2

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    8. Добавление своего ярлыка папки или программы в папку Компьютер.

    Если Вы часто пользуйтесь какой-либо программой, то помимо добавления её значка на рабочий стол, Вы также можете добавить его в папку Компьютер. Поскольку скопировать напрямую или создать ярлык в данной папке нельзя, то предлагаю Вам решение, как это возможно осуществить.

    1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот):

    2) Скачайте программу Microsoft Exchange Server GUID Generator
    3) Распакуйте архив и запустите программу (GUIDGEN.EXE)
    4) Установите переключатель на значение Registry Format
    5) Нажмите на кнопку New GUID, и программа сгенерирует Вам новый GUID
    6) Нажмите на кнопку Copy, и программа скопирует его в буфер обмена
    7) Вставьте вместо {GUID}, сгенерированный программой GUID.
    Теперь у Вас вместо {GUID}, должен быть цифровой идентификатор, например: {FF4A6226-C00B-409e-88A6-6C401C52BD98}
    8) Замените значения "Наименование папки или программы", "Путь к иконке для ярлыка" и "Путь к папке или файлу программы" на необходимые Вам.
    Внимание! При указывании пути к иконке и файлу объекта слэш должен быть двойным.
    Например, если путь к программе: C:\MyProgram\MyProgram.exe, то необходимо указать его как: C:\\MyProgram\\MyProgram.exe
    Так как, чаще всего икона программы встроена в саму программу, то значения "Путь к иконке для ярлыка" и "Путь к папке или файлу программы" могут совпадать.
    9) При добавлении ярлыка папки измените "Путь к иконке для ярлыка" на %SystemRoot%\\system32\\SHELL32.dll,4
    А значение "Путь к папке или файлу программы" на explorer /n, /e, C:\\ВашаПапка
    10) После указания всех необходимых значений, нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    10.1) Если Вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "GUID.reg")
    10.2) Если Вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    11) Примените получившийся reg-файл.

    Пример reg-файла для добавления программы WinDjView в папку Компьютер:

    Пример reg-файла для добавления папки Downloads в папку Компьютер:

    В итоге Вы получите тот же самый эффект, что был упомянут в совете 3 раздела "Твики Реестра - Дополнительная функциональность".

    9. Добавление в контекстное меню DLL- или OCX-файлов пунктов "Регистрация" и "Отмена регистрации".

    Если вам часто приходится работать с ocx-файлами или с dll-файлами, которые требуют регистрации в реестре с помощью Regsvr32.exe, то будет гораздо удобнее внести соответствующую запись в реестр, чем каждый раз использовать командную строку для каждого файла.

    Запустите редактор реестра (Win+R -> regedit -> Ok )

    Создание пункта "Регистрация" в меню DLL- или OCX-файлов.

    1) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell и HKEY_CLASSES_ROOT\dllfile\Shell
    2) Создайте раздел Регистрация, а в нем подраздел command
    3) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell\Регистрация\command и HKEY_CLASSES_ROOT\dllfile\Shell\Регистрация\command присвойте строковому параметру По умолчанию значение: regsvr32.exe "%1"

    Создание пункта "Отмена регистрации" в меню DLL- или OCX-файлов.

    1) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell и HKEY_CLASSES_ROOT\dllfile\Shell
    2) Создайте раздел Отмена регистрации, а в нем подраздел command
    3) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell\Отмена регистрации\command и HKEY_CLASSES_ROOT\dllfile\Shell\Отмена регистрации\command присвойте строковому параметру По умолчанию значение: regsvr32.exe /u "%1"

    Теперь при нажатии правой кнопкой мыши на DLL- или OCX-файле, в меню появятся пункты "Регистрация" и "Отмена регистрации".

    Также Вы можете создать reg-файл следующего содержания или скачать готовый Dll_Ocx_register-unregister.reg

    10. Увеличение кэша памяти для вида папок.

    Можно увеличить количество папок, для которых Windows будет запоминать настройки вида.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell
    3) Создайте параметр DWORD BagMRU Size и присвоить ему десятичное значение, например, 20000.

    Также Вы можете создать reg-файл.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: " folder_cache.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    11. Добавление опций "Выполнить", "Поиск" и "Очистить корзину" в контекстное меню.

    Для быстрого доступа к необходимой Вам системной опции, Вы можете добавить её в контекстное меню рабочего стола. Чтобы это осуществить, Вам необходимо создать и применить reg-файл следующего содержания.

    Добавление пункта Выполнить для вызова одноименного диалогового меню.

    Добавление пункта Поиск для вызова одноименного окна.

    Добавление пункта Очистить корзину.

    Готовые reg-файлы для добавления и удаления Вы можете скачать по ссылке: options in context menu.zip

    12. Создание меню с ярлыками избранных приложений в контекстном меню рабочего стола.

    Рисунок 1 из 3

    Добавление ссылок на избранные программы в контекстное меню рабочего стола Windows сводится к двум частям:

    Часть 1. Создание каскадных меню в контекстном и добавление ярлыков.
    Часть 2. Добавление функциональности ярлыкам путем их регистрации.

    Часть 1. Создание контекстных меню и добавление ярлыков.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_CLASSES_ROOT\DesktopBackground\Shell
    3) Создайте в данной ветке новый раздел. Нажмите правой кнопкой мыши на ключе "Shell" и выберите "Создать -> Раздел". (Например, Menu1)
    4) Выберите только что созданный раздел "Menu1" и в правой части окна создайте 4 строковых параметра:

    Icon - в значении данного параметра следует указать путь к значку меню.
    Position - данный параметр определяет позицию каскадного меню в контекстном. По умолчанию это середина контекстного меню, но Вы можете выбрать значения Top (сверху) или Bottom (снизу).
    MUIVerb - имя каскадного меню, которое будет отображаться в контекстном меню. Например, "Мои программы", "Браузеры" и т.д.
    SubCommands - содержит список команд, разделенных точкой с запятой (;). Эти команды будут показаны в каскадном меню. Вы не можете напрямую добавить ярлык приложения. Сначала в этом списке Вам нужно дать команде имя, а после этого зарегистрировать ее согласно инструкции во второй части статьи.

    Предположим, что Вы уже создали каскадное меню "Браузеры", и теперь Вы хотите добавить в него ярлыки Internet Explorer и Mozilla Firefox. В таком случае Вам нужно параметру SubCommands задать значение:

    Параметры Icon и Position Вы можете и не создавать, а вот MUIVerb и SubCommands — обязательны.

    Рисунок 2 из 3

    Часть 2. Добавление функциональности ярлыкам путем их регистрации.

    Как только Вы добавите ярлыки программ в каскадное меню, Вам необходимо будет их зарегистрировать следующим образом:

    1) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\CommandStore\Shell
    2) Создайте для каждой из команд, указанных ранее в строковом параметре SubCommands, собственный одноименный раздел. В нашем примере мы использовали две команды: firefox и iexplore, поэтому нам нужно создать два раздела с такими же именами.
    3) Выберите созданный раздел и в правой части окна редактора реестра задайте параметру Default (По умолчанию) имя, которые Вы хотите видеть в каскадном меню. Например, введите сюда Internet Explorer (для раздела iexplore) или Mozilla Firefox (для раздела firefox).
    4) Если Вы хотите добавить ярлыку иконку, создайте новый строковой параметр с именем Icon и установите его значением путь к EXE файлу приложения или любой другой иконке.
    Например, чтобы показать иконку Internet Explorer, Вы должны задать параметру Icon значение C:\Program Files\Internet Explorer\iexplore.exe
    5) В каждом из только что созданных разделов создайте новый раздел и назовите его command.
    Выберите его и в правой части окна установите значением Default (По умолчанию) путь к EXE-файлу необходимой программы. Например, если ярлык должен открывать Internet Explorer, то для должно быть установлено значение C:\Program Files\Internet Explorer\iexplore.exe

    Рисунок 3 из 3

    Готовый reg-файл контекстное меню рабочего стола (из описанного примера):

    Примечание: Если Вы хотите удалить созданное каскадное меню, просто удалите ключи, созданные Вами ключи из реестра.

    13. Ускорение выключения компьютера.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\
    3) Найдите параметр WaitToKillServiceTimeout
    4) Измените его значение на необходимое Вам. Данный параметр отвечает за задержку перед выключением.
    По умолчанию установлено значение (20000)=20 сек., но вы можете установить его значение, намного меньше номинального (минимум 100), и система будет закрываться намного быстрее.
    Рекомендуемые значения (2000-5000)=2-5 сек. (меньше не рекомендуется, иначе система будет понимать неадекватно отсутсвие откликов от служб, и завершать их в "неподходящий" момент времени, например когда они сохраняют свои последние настройки).

    14. Ускорение анимации всплывающего меню в меню Пуск.

    Если Вы желаете изменить время задержки до показа всплывающего меню в меню Пуск, проделайте следующее:

    1)Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
    2) Откройте раздел HKEY_CURRENT_USER\Control Panel\Desktop
    3) Создайте в нем(или измените) параметр MenuShowDelay
    4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
    5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
    6) Выберите желательное значение от 1 до 4000, означающее задержку в миллисекундах, до показа всплывающего меню в меню Пуск.
    7) Закройте regedit и перезагрузите систему.

    15. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows (реестр).

    Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
    Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

    1) Запустите редактор реестра (Нажмите Win+R, введите команду regedit.exe и нажмите Ок)
    2) Пройдите по следующему пути: HKEY_CURRENT_USER\Control Panel\Accessibility
    3) Измените значение параметра MessageDuration.

    16. Настройка параметров всплывающих эскизов окон в панели задач.

    Изменив несколько настроек в реестре Вы сможете придать своим всплывающим эскизам окон больше эффективности в работе.

    1) Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
    2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    3) Создайте в нем(или измените) параметры:

    ExtendedUIHoverTime - Задержка до появления всплывающего эскиза окна на экране, после наведения курсора мыши на иконку в панели задач.
    ThumbnailLivePreviewHoverTime - Задержка до появления окна программы, после наведения курсора мыши на всплывший эскиз окна.

    4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
    5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
    6) В графе Система исчисления установите значение параметра на Десятичная.
    7) Введите необходимое Вам значение. Значение 1000 = 1 секунде.

    8) Откройте в реестре раздел: HKEY_CLASSES_ROOT\SystemFileAssociations\image
    9) Сделайте двойной щелчок на параметре Treatment - Данный параметр изменяет вид бордюра всплывающего эскиза окна.
    10) Выберите необходимое Вам значение:

    0 - Без бордюра
    1 - Бордюр с тенью
    2 - Фоторамка (по умолчанию)
    3 - Видеорамка

    11) Закройте regedit и перезагрузите систему.

    17. Настройка скорости отображения рабочего стола при наведении курсора мыши в угол экрана.

    Когда Вы наводите курсор на крайнюю кнопку, находящуюся за часами на панели задач (обычно правый нижний угол экрана), система показывает Вам рабочий стол. При желании Вы можете ускорить или замедлить данный процесс.

    1) Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
    2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    3) Измените значение параметра DesktopLivePreviewHoverTime. Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
    4) В графе Система исчисления установите значение параметра на Десятичная.
    5) Введите необходимое Вам значение. Значение 1000 = 1 секунде.
    6) Закройте regedit, перезайдите в систему или перезагрузите систему.

    18. Добавление кнопки запуска необходимой программы на панель проводника Windows 7.

    Рисунок 1 из 2

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    На панели проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами для хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок.
    Для добавления кнопки запуска необходимой программы во все папки проводника - добавьте кнопку во все шаблоны.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для добавления кнопки запуска необходимой программы сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку необходимого Вам шаблона.
    Например: для добавления кнопки в обычную папку использующую шаблон типа папки «Общие элементы» откройте:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{5c4f28b5-f869-4e84-8e60-f11db97c5cc7}

    А для добавления кнопки в папку «Общие элементы», входящей в Библиотеки откройте:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{5f4eab9a-6833-4f61-899d-31cf46979d49}

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

    4.1) Откройте необходимый из указанных подразделов, если Вы добавляете кнопку в шаблоны Библиотек и/или в шаблонах поиска результатов в них.
    4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать -> Раздел.)

    TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
    TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

    5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Удалить.
    Выполняя данное действие Вы отказываетесь от набора стандартных кнопок, но позволяете использовать произвольные кнопки.

    6) В разделе TasksItemsSelected создайте подраздел с именем 0. Он будет содержать в себе параметры первой кнопки (отсчет начинается с нуля), все последующие кнопки должны создаваться в разделах 1, 2, и т.д.

    7) В разделе 0 создайте подраздел с уникальным GUID. (Например: {422299D4-C2DD-4e24-AAAB-FED22CC8E8DE})
    7.1) Скачайте и распакуйте архив GUIDGen.zip
    7.2) Запустите программу GUIDGEN.EXE, установите переключатель на Registry Format и нажмите кнопку New GUID, а затем Copy.

    8) Щелкните созданный раздел с уникальным GUID и создайте в нем два строковых параметра:

    Title – определяет название кнопки
    InfoTip – определяет название всплывающей подсказки к кнопке

    9) В разделе с уникальным GUID последовательно создайте подразделы:

    shell
    InvokeTask
    command

    10) В разделе command дважды щелкните параметр (По умолчанию) и измените его значение на путь к программе, которую Вы хотите запустить.

    Рисунок 2 из 2

    Примечание:

    Если Вы добавляете программу для открытия в ней файлов, то после указания пути к программе добавьте параметр %*
    Параметр %* указывает программе, что необходимо использовать одновременно несколько параметров: путь к отображаемой папке(%0) и путь к выделенному объекту(%1).
    Если Вы добавляете программу которая должна просто запускаться, без открытия в ней файлов, то параметр добавлять не надо.

    19. Добавление кнопки "Открыть в текстовом редакторе" на панель проводника Windows 7.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    На панели проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами для хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок.
    Для добавления кнопки "Открыть в текстовом редакторе" во все папки проводника - добавьте кнопку во все шаблоны.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для добавления кнопки "Открыть в текстовом редакторе" сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку необходимого Вам шаблона.
    Например: для добавления кнопки в обычную папку использующую шаблон типа папки «Документы» откройте:

    А для добавления кнопки в папку ««Документы»», входящей в Библиотеки откройте:

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

    4.1) Откройте необходимый из указанных подразделов, если Вы добавляете кнопку в шаблоны Библиотек и/или в шаблонах поиска результатов в них.
    4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать -> Раздел.)

    TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
    TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

    5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Удалить.
    Выполняя данное действие Вы отказываетесь от набора стандартных кнопок, но позволяете использовать произвольные кнопки.

    6) В разделе TasksItemsSelected создайте подраздел с именем 0. Он будет содержать в себе параметры первой кнопки (отсчет начинается с нуля), все последующие кнопки должны создаваться в разделах 1, 2, и т.д.

    7) В разделе 0 создайте подраздел с уникальным GUID. (Например: {433399D4-C2DD-4e24-AAAB-FED22CC8E8DE})
    7.1) Скачайте и распакуйте архив GUIDGen.zip
    7.2) Запустите программу GUIDGEN.EXE, установите переключатель на Registry Format и нажмите кнопку New GUID, а затем Copy.

    8) Щелкните созданный раздел с уникальным GUID и создайте в нем два строковых параметра:

    Title – определяет название кнопки
    InfoTip – определяет название всплывающей подсказки к кнопке

    9) В разделе с уникальным GUID последовательно создайте подразделы:

    shell
    InvokeTask
    command

    10) Скачайте файл архив со скриптом texteditor.zip и распакуйте его в любую папку. (Например: C:\Scripts)

    10.1) Вы можете создать его самостоятельно. Для этого скопируйте нижеследующий текст в текстовый редактор и сохраните файл с именем texteditor и расширением *.js .

    11) В разделе command дважды щелкните параметр (По умолчанию) и измените его значение на путь к скрипту:

    Примечание:

    Параметр %* указывает программе, что необходимо использовать одновременно несколько параметров: путь к отображаемой папке(%0) и путь к выделенному объекту(%1).

    20. Добавление кнопок "Копировать в папку" и "Переместить в папку" на панель проводника Windows 7.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    На панели проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами для хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок.
    Для добавления кнопок "Копировать в папку" и "Переместить в папку" во все папки проводника - добавьте кнопки во все шаблоны.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для добавления кнопок "Копировать в папку" и "Переместить в папку" сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку необходимого Вам шаблона.
    Например: для добавления кнопки в обычную папку использующую шаблон типа папки «Общие элементы» откройте:

    А для добавления кнопки в папку «Общие элементы», входящей в Библиотеки откройте:

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

    4.1) Откройте необходимый из указанных подразделов, если Вы добавляете кнопку в шаблоны Библиотек и/или в шаблонах поиска результатов в них.
    4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать -> Раздел.)

    TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
    TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

    5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Удалить.
    Выполняя данное действие Вы отказываетесь от набора стандартных кнопок, но позволяете использовать произвольные кнопки.

    6) В разделе TasksItemsSelected создайте подраздел с именем 0. Он будет содержать в себе параметры первой кнопки (отсчет начинается с нуля), все последующие кнопки должны создаваться в разделах 1, 2, и т.д.

    7) В разделе 0 создайте подраздел с уникальным GUID. (Например: {455599D4-C2DD-4e24-AAAB-FED22CC8E8DE})
    7.1) Скачайте и распакуйте архив GUIDGen.zip
    7.2) Запустите программу GUIDGEN.EXE, установите переключатель на Registry Format и нажмите кнопку New GUID, а затем Copy.

    8) Щелкните созданный раздел с уникальным GUID и создайте в нем два строковых параметра:

    Title – определяет название кнопки
    InfoTip – определяет название всплывающей подсказки к кнопке

    9) В разделе с уникальным GUID последовательно создайте подразделы:

    shell
    InvokeTask
    command

    10) Скачайте файл архив со скриптом ExplorerBarUtilities.zip и распакуйте его в любую папку. (Например: C:\Scripts)

    11) В разделе command дважды щелкните параметр (По умолчанию) и измените его значение на путь к скрипту: Для создания кнопки "Копировать в папку" измените значение на:

    Для создания кнопки "Переместить в папку" измените значение на:

    Примечание:

    Параметр %* указывает программе, что необходимо использовать одновременно несколько параметров: путь к отображаемой папке(%0) и путь к выделенному объекту(%1).

    21. Добавление собственной папки в Рабочий стол области переходов проводника.

    Если Вы часто пользуйтесь какой-либо папкой, то Вы можете добавить ее в Рабочий стол области переходов проводника. Поскольку копирование папки напрямую или создание ярлыка на рабочем столе не добавляет её в область переходов, то предлагаю Вам решение, как это возможно осуществить.

    1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот):

    2) Скачайте программу Microsoft Exchange Server GUID Generator
    3) Распакуйте архив и запустите программу (GUIDGEN.EXE)
    4) Установите переключатель на значение Registry Format
    5) Нажмите на кнопку New GUID, и программа сгенерирует Вам новый GUID
    6) Нажмите на кнопку Copy, и программа скопирует его в буфер обмена
    7) Вставьте вместо {GUID}, сгенерированный программой GUID.
    Теперь у Вас вместо {GUID}, должен быть цифровой идентификатор, например: {1a51a488-17d4-4169-a212-a2cf152268b6}
    8) Замените значения "Название папки" и "Путь к папке" на необходимые Вам.
    Внимание! При указывании пути к папке слеш должен быть двойным.
    Например, если путь к папке: C:\My Folder\Downloads, то необходимо указать его как: C:\\My Folder\\Downloads
    9) После указания всех необходимых значений, нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
    9.1) Если Вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "GUID.reg")
    9.2) Если Вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    10) Примените получившийся reg-файл.

    Пример reg-файла для добавления папки Downloads в Рабочий стол области переходов проводника.

    22. Скрытие апплетов отображаемых в Панели управления.

    Существует много способов, чтобы скрыть элементы в Панели Управления. Ниже приводятся, наиболее часто используемые.

    1) Создайте reg-файл используя шаблон в одном из предложенных ниже вариантов.
    2) Примените его.
    3) Перезагрузите систему.

    Вариант 1. Показать все кроме.

    Созданный reg-файл позволяет Вам отобразить все апплеты в Панели управления, исключая те которые добавлены в ветку: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowCpl
    Чтобы исключить определенные апплеты из Панели управления, создайте в данном разделе строковые параметры (REG_SZ).
    Имена параметров должны быть - непрерывные номера начинающиеся с 1: 1, 2, 3, …
    Значения - имя апплета точно таким же, как оно отображается в Панели Управления в зависимости от выбранного языка интерфейса. Пример reg-файла для русской Windows:

    Пример reg-файла для английской Windows:

    Вариант 2. Скрыть все кроме.

    Созданный reg-файл позволяет Вам скрыть все апплеты в Панели управления, исключая те которые добавлены в ветку: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictCpl
    Чтобы отобразить определенные апплеты в Панели управления, создайте в данном разделе строковые параметры (REG_SZ).
    Имена параметров должны быть непрерывные - номера начинающиеся с 1: 1, 2, 3, …
    Значения - имя апплета точно таким же, как оно отображается в Панели Управления в зависимости от выбранного языка интерфейса. Пример reg-файла для русской Windows:

    Пример reg-файла для английской Windows:

    Русское название элемента | Английское название элемента
Windows CardSpace | Windows CardSpace
Windows SideShow | Windows SideShow
Автозапуск | AutoPlay
Автономные файлы | Offline Files
Администрирование | Administrative Tools
Архивация и восстановление | Backup and Restore
Биометрические устройства | Biometric Devices
Брандмауэр Windows | Windows Firewall
Восстановление | Recovery
Гаджеты рабочего стола | Desktop Gadgets
Дата и Время | Date and Time
Датчик расположения и другие датчики | Location and Other Sensors
Диспетчер устройств | Device Manager
Диспетчер учетных данных | Credential Manager
Домашняя группа | HomeGroup
Защитник Windows | Windows Defender
Звук | Sound
Значки области уведомлений | Notification Area Icons
Игровые устройства | Game Controllers
Инфракрасная связь | Infrared
Клавиатура | Keyboard
Мышь | Mouse
Панель задач и меню ''Пуск'' (кавычки два раза одинарные) | Taskbar and Start Menu
Параметры индексирования | Indexing Options
Параметры папок | Folder Options
Параметры планшетного компьютера | Tablet PC Settings
Перо и сенсорные устройства | Pen and Touch
Персонализация | Personalization
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection
Получение программ | Get Programs
Приступая к работе | Getting Started
Программы и компоненты | Programms and Features
Программы по умолчанию | Default Programs
Распознавание речи | Speech Recognition
Расположение по умолчанию | Default Location
Родительский контроль | Parental Controls
Свойства обозревателя | Internet Options
Система | System
Сканеры и камеры | Scanners and Cameras
Счетчики и средства производительности | Performance Information and Tools
Телефон и модем | Phone and Modem
Управление цветом | Color Management
Устранение неполадок | Troubleshooting
Устройства и принтеры | Devices and Printers
Учетные записи пользователей | User Accounts
Центр мобильности Windows | Windows Mobility Center
Центр обновления Windows | Windows Update
Центр поддержки | Action Center
Центр синхронизации | Sync Center
Центр специальных возможностей | Ease of Access Center
Центр управления сетями и общим доступом | Network and Sharing Center
Шифрование диска BitLocker | BitLocker Drive Encryption
Шрифты | Fonts
Экран | Display
Электропитание | Power Options
Язык и региональные стандарты | Region and Language

    23. Увеличение пространства, отведенного в NTFS для главной таблицы файлов.

    В ядре файловой системы NTFS содержится файл, который называется главной таблицей файлов (MFT). MFT (Master File Table) — главная файловая таблица (база данных), в которой хранится информация о содержимом тома с файловой системой NTFS, представляющая собой таблицу, строки которой соответствуют файлам тома, а столбцы — атрибутам файлов.
    Поскольку средства дефрагментации томов NTFS не могут перемещать записи MFT, а также из-за того, что значительная фрагментация MFT может негативно влиять на быстродействие системы, NTFS резервирует для MFT дисковое пространство, чтобы по мере увеличения размера MFT подвергался минимальной фрагментации.
    По мере появления новых файлов в томе NTFS в файл MFT добавляются новые записи, и, таким образом, размер MFT увеличивается. При удалении файлов из тома NTFS соответствующие записи в файле MFT помечаются как свободные и могут использоваться повторно, однако размер MFT при этом не сокращается. Таким образом, дисковое пространство, используемое этими записями, остается недоступным.
    При переполнении зоны MFT пространство для новых записей MFT начинает выделяться из незарезервированного дискового пространства, что снова приводит к фрагментации MFT.

    Существует параметр реестра, позволяющий увеличить (зарезервировать) пространство, отведенное в NTFS для основной таблицы файлов. Для его добавления выполните следующие действия:

    1) Запустите редактор реестра (Win+R->regedit->ОК)
    2) Откройте раздел реестра HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem
    3) В меню Правка выберите Создать -> Параметр DWORD (32 бита).
    4) Задайте имя параметра NtfsMftZoneReservation
    5) Дважды щелкните на данном параметре и введите необходимое Вам значение от 1 до 4.
    6) Закройте редактор реестра и перезапустите компьютер.

    Если на ваших разделах NTFS мало файлов, но они большого размера, то наилучшим значением созданного параметра будет 1.
    Если у Вас среднее количество файлов на диске, то оптимальным значением является 2, если же их большое количество, то значение 3.
    Значение 4 (максимальное значение) следует использовать только в случае, если у вас на диске очень большое количество файлов.

    24. Увеличение процессорного времени, выделяемого программе, работающей на переднем плане.

    Для начала убедитесь, что параметр Распределение времени процессора настроен на оптимизацию работы программ. Для этого:

    1) Откройте меню Пуск
    2) Нажмите правой кнопкой мыши на пункт Компьютер и выберите Свойства
    3) В списке слева нажмите на ссылку Дополнительные параметры системы
    4) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
    5) Откройте вкладку Дополнительно и в разделе Распределение времени процессора установите переключатель в значение: программ.

    Теперь Вам необходимо изменить количество квантов выделяемых программе, работающей на переднем плане.
    Квантом называется единица процессорного времени, выделяемая конкретной программе для работы. По истечении квантов, выделенных одной программе, управление будет передано другой программе, ожидающей в очереди (а программа, которая только что работала, будет помещена в конец очереди) — и эта программа будет работать до тех пор, пока не истекут кванты, выделенные для нее. После этого управление перейдет следующей программе из очереди.
    Особенностью Windows является увеличенное количество квантов, которое выделяется программе, работающей в данный момент на переднем плане. То есть, программа переднего плана будет работать быстрее всех программ, работающих в данный момент в фоновом режиме.
    Так реализована многозадачность операционной системы Windows.

    Для изменения количества квантов, выделяемых программе, работающей на переднем плане, сделайте следующее:

    1) Запустите редактор реестра (Win+R->regedit->ОК)
    2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\PriorityControl
    3) Дважды щелкните на DWORD-параметре Win32PrioritySeparation и введите необходимое Вам значение.
    4) Закройте редактор реестра и перезапустите компьютер.

    По умолчанию значение равно 2.
    Максимальное значение равно 26 в шестнадцатеричной системе исчисления или 38 в десятичной системе.
    Необходимое Вам значение выясняется экспериментальным путем.
    Не ставьте сразу большое значение, постепенно увеличивайте значение пока не найдете оптимальное.
    Например: На одних машинах улучшения в работе системы с программами будут видны при максимальном значении 26, на других же оптимальным значением может оказаться 12.

    25. Отключение выгрузки драйверов режима ядра и системного кода режима ядра из оперативной памяти на диск.

    Если у Вас на компьютере большое количество оперативной памяти, то приложения будут быстрее откликаться на Ваши действия, если драйвера режима ядра и системный код режима ядра будут оставаться в оперативной памяти.

    За данное действие отвечает параметр реестра DisablePagingExecutive, который определяет, могут ли драйвера режима ядра и системный код режима ядра быть выгружены из оперативной памяти на диск, когда они не используется.

    Значение 0 указывает, что при необходимости драйвера режима ядра и системный код режима ядра могут быть выгружены из оперативной памяти на диск, когда они не используется.
    Значение 1 указывает, что драйвера режима ядра и системный код режима ядра должны оставаться в оперативной памяти.

    Для изменения данного параметра сделайте следующее:

    1) Запустите редактор реестра (Win+R->regedit->ОК)
    2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
    3) Дважды щелкните на параметре DisablePagingExecutive и введите значение 1.
    4) Закройте редактор реестра и перезапустите компьютер.

    Если же у Вас такой параметр отсутствует, то создайте в данном разделе реестра DWORD-параметр с указанным именем и значением.

    26. Удаление пункта "Восстановить прежнюю версию" из контекстного меню проводника.

    Чтобы удалить пункт "Восстановить прежнюю версию" из контекстного меню проводника, сделайте следующее:

    1) Запустите редактор реестра (Win+R->regedit->ОК)
    2) Откройте раздел реестра: HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\
    3) Удалите раздел {596AB062-B4D2-4215-9F74-E9109B0A8153}
    4) Откройте раздел реестра: HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers\
    5) Удалите раздел {596AB062-B4D2-4215-9F74-E9109B0A8153}
    6) Закройте все процессы проводника и запустите его заново или перезайдите в систему.

    Твики Реестра - Устройства и Сети.

    1. Автоматическое VPN-подключение к интернет при запуске Windows (реестр).

    1. Создайте ваше VPN-подключение, но не подключайтесь к интернету или если подключились, то не отключайтесь от интернета до окончания описанных ниже действий.
    2. В реестре Windows (Пуск->Выполнить->"regedit") найдите следующую ветку:

    (если хотите сделать автозапуск только для текущего пользователя) или

    (если хотите сделать автозапуск для всех пользователей)
    В этой ветке создайте "строковый параметр" (правой кнопкой мыши -> «Создать» -> «строковый параметр») с произвольным именем.
    2. В качестве значения созданного параметра внесите строку вида:

    3. Закройте реестр и перезагрузите компьютер.

    2. Конвертирование reg файлов в inf формат из контекстного меню, с помощью утилиты.

    1) Скачайте утилиту Reg2inf (необходим Framework 2 или 3)
    2) Скопируйте её в C:\Windows\System32
    3) Создайте и примените reg-файл следующего содержания:

    В контекстное меню reg-файлов добавится пункт reg2inf при нажатии которого созданный Вами reg-файл переконвертируется в inf-файл. Например, файл test.reg переконвертируется в test.reg.inf

    3. Включение клавиш-индикаторов Num Lock, Caps Lock, Scroll Lock при загрузке.

    Если у Вас при входе в систему выключен переключатель клавиатуры Num Lock, то для его включения сделайте следующее.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_CURRENT_USER\Control Panel\Keyboard
    3) Щелкните на параметре InitialKeyboardIndicators правой кнопкой мыши и нажмите Изменить.
    4) Выберите и установите необходимое Вам значение.

    0 – все переключатели выключены.
    1 – Caps Lock включен.
    2 – Num Lock включен.
    3 – Caps Lock и Num Lock включены.
    4 – Scroll Lock включен.
    5 – Caps Lock и Scroll Lock включены.
    6 – Num Lock и Scroll Lock включены.
    7 – Caps Lock, Num Lock и Scroll Lock включены.

    Если же Вам необходимо изменить состояние клавиш-индикаторов до входа в систему, в экране приветствия, то для управления ими измените значение параметра InitialKeyboardIndicators в разделе HKEY_USERS\.DEFAULT\Control Panel\Keyboard

    4. Отмена автозапуска для носителей и устройств.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр DWORD с именем NoDriveTypeAutoRun

    Допустимые значения ключа:

    0x1 - отключить автозапуск на приводах неизвестных типов
    0x4 - отключить автозапуск съемных устройств
    0x8 - отключить автозапуск НЕсъемных устройств
    0x10 - отключить автозапуск сетевых дисков
    0x20 - отключить автозапуск CD-приводов
    0x40 - отключить автозапуск RAM-дисков
    0x80 - отключить автозапуск на приводах неизвестных типов
    0xFF - отключить автозапуск вообще всех дисков.

    Также параметр NoDriveTypeAutoRun автоматически добавляется в реестр при установке программы VMware Workstation, используемой для создания виртуальной машины.

    5. Уменьшение фрагментируемости больших файлов на диске.

    Для того чтобы операционная система при записи файла на диск сначала нашла для него наиболее подходящее по размеру место и поместила его туда, как можно меньше дробя на части сделайте следующее:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem
    3) Создайте DWORD-параметр ContigFileAllocSize
    4) Щелкните на нем правой кнопкой мыши и выберите Изменить.
    5) Установите значение 00000200 и нажмите Ок

    Данный параметр определяет максимальный размер нефрагментируемого блока данных на диске. При желании размер такого блока можно еще увеличить. Данная настройка может быть очень полезной при работе с мультимедиа (уменьшается нагрузка на диск и процессор при записи и воспроизведении видео или звуковых файлов).
    Эта настройка полезна тем, у кого много файлов большого размера, при большом количестве маленьких файлов - она становится менее актуальной.

    6. Изменение состояния встроенного динамика персонального компьютера.

    1) Запустите редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_CURRENT_USER\Control Panel\Sound
    3) Измените значение параметра Beep на "No" чтобы отключить и на "Yes" чтобы включить.

    Также Вы можете включить/отключить его в Диспетчере устройств:

    1) Откройте меню Пуск -> Панель управления и запустите Диспетчер устройств
    2) В меню Вид установите флажок на Показать скрытые устройства
    3) Откройте Драйверы несамонастраиваемых устройств
    4) Щелкните правой кнопкой мыши на Beep и выберите пункт Свойства
    5) Перейдите на вкладку Драйвер и установите тип автозагрузки на Отключено чтобы отключить и на Авто чтобы включить.
    6) Для изменения текущего состояния нажмите на Остановить чтобы отключить и на Запустить чтобы включить.
    7) Нажмите кнопку ОК для применения настроек.

    7. Переназначение гнезд звуковой карты Realtek используя реестр.
    На некоторых материнских платах, отсутствует возможность переназначения гнезд встроенной звуковой карты Realtek. А это значит, что каждое гнездо четко привязано к определенному устройству и определяется только автоматически при включении его в гнездо.
    Например, если Вы включите Микрофон или Наушники в гнездо, предназначенное для устройства Боковые динамики, то Realtek будет по-прежнему считать, что у Вас подключены Боковые динамики, а не Микрофон или Наушники.
    Однако из данной ситуации есть выход. Вы можете переназначить гнезда вручную, при помощи реестра.

    1) Установите драйвера звуковой карты
    2) Запустите редактор реестра (Win+К -> regedit -> Ok)
    3) Пройдите к папке

    4) Откройте папку Drv6278_DevType_0888_SS10438357 или с аналогичным названием (DrvXXXX_DevType_XXXX_SSXXXXXXXX, где вместо X могут быть любые цифры, зависящие от версии драйвера и номера вашего устройства)
    5) Создайте двоичный параметр(Binary-Параметр) задаете ему необходимое имя и значение из списка указанного ниже или отредактируйте уже имеющийся.

    Рисунок 1 из 2

    Имя(вставлять без кавычек):

    "Pin01" = Заднее зеленое гнездо
    "Pin02" = Заднее черное гнездо
    "Pin03" = Заднее коричневое гнездо
    "Pin04" = Заднее серое гнездо
    "Pin05" = Заднее розовое гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Микрофон)
    "Pin07" = Заднее синее гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Линейный вход)

    "Pin06" = Переднее розовое гнездо
    "Pin08" = Переднее зеленое гнездо

    Значение(вставлять без кавычек):

    "00 00 00 00" = Линейный вход
    "01 00 00 00" = Микрофон
    "02 00 00 00" = Наушники
    "04 00 00 00" = Передние динамики
    "05 00 00 00" = Тыловые динамики
    "06 00 00 00" = Центральный канал/Сабвуфер
    "07 00 00 00" = Боковые динамики

    Если у Вас после перезагрузки компьютера сбрасываются настройки, то сразу после изменения настроек установите значение параметра ChannelConfig равным 00 00 00 00

    Также вы можете создать reg-файл наподобие указанного ниже, заменив значения на необходимые:

    Drv6278_DevType_0888_SS10438357 - на версию вашего драйвера
    (имя папки по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\)
    Pin04 - на любое значение из списка Имя
    hex:02,00,00,00 - на любое значение из списка Значение(просто исправьте 2 на соответствующую цифру) Reg-файл для настройки устройства Наушники вместо устройства Боковые динамики

    Рисунок 2 из 2

    8. Замена компонента Устройства и принтеры в Панели управления на папку Принтеры.

    1) Откройте Редактор групповой локальной политики (Win+R -> gpedit.msc - Ok)
    2) Перейдите в раздел Конфигурация пользователя\Административные шаблоны\Панель управления.
    3) Выберите команду Скрыть указанные элементы панели управления
    4) Установите переключатель в значение Включить.
    5) Нажмите на кнопку Показать.
    6) Добавьте новую запись: Microsoft.DevicesAndPrinters и нажмите Ok.
    7) Запустите редактор реестра (Win+R -> regedit.exe -> Ok).
    8) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace
    9) Создайте в ней новый раздел {2227a280-3aea-1069-a2de-08002b30309d}.
    10) Присвойте параметру По умолчанию значение - Принтеры (Printers).

    Данную папку Вы сможете увидеть в Панели управления в контекстном меню Пуск, если у Вас установлено значение "Отображать как меню" или при просмотре полного списка всех элементов при её открытии.

    9. Удаление цифры при пересоздании адаптера сети в Диспетчере устройств.

    Вариант 1

    1) Удалите драйвер сетевого адаптера
    2) В ветке реестра

    установите значение адаптера сети на 0.
    3) Создайте драйвер сетевого адаптера

    Вариант 2

    1) Удалите драйвер сетевого адаптера
    2) В ветке реестра

    удалите ваш сетевой адаптер.
    3) Создайте драйвер сетевого адаптера.

    10. Отключение или переназначение клавишы Caps Lock.

    Если вы не используете клавишу Caps Lock по назначению, то вы можете отключить или переназначить клавишу, путем редактирования параметра реестра. Для этого необходимо изменить значение параметра Scancode Map, который расположен в разделе реестра

    Ниже представлены reg-файлы для переназначения и отключения клавиши Caps Lock.

    Клавиша Caps Lock будет выполнять действие клавиши Ctrl

    Клавиша Caps Lock будет выполнять действие клавиши Shift

    Отключает Caps Lock и переназначает действие клавиши Scroll Lock на выполнение Caps Lock

    Отключает клавишу Caps Lock

    Отменяет все предыдущие переназначения клавиш(возвращает значение по умолчанию)

    11. Отключение USB порта после Безопасного извлечения устройства.

    Если Вы присоединили USB-устройство к компьютеру с запущенной Windows 7, а затем Отключаете устройство в "Диспетчере устройств" или в "Безопасное Извлечение устройств и дисков", используя иконку в системном трее, то Вы можете наблюдать один из следующих симптомов:
  • USB-устройство показывает продолжающееся признаки деятельности (такие, как остающийся гореть LED-индикатор)
  • USB-устройство продолжает получать USB-пакеты и продолжает потреблять энергию соответствующую состоянию активного устройства.
  • Физическое отсоединение Отключенного или Безопасно Удаленного USB-устройства может, в некоторых случаях, вызывать ошибку в активной передаче на другое USB-устройство.

    • Чтобы исправить данную ошибку Вам необходимо сделать следующее:

    Для определенного устройства.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags
    3) Откройте в данной ветке раздел соответствующий, подключенному к Вашему компьютеру USB-устройству.
    4) Если неоходимого Вам раздела нет, то создайте его.

    4.1) Щелкните правой кнопкой мыши на usbflags
    4.2) Выберите пункты Создать -> Раздел
    4.3) Задайте имя нового раздела в следующем виде: vvvvpppprrrr
    где vvvv - 4-значный шестнадцатеричный номер, обозначающий Vendor ID устройства
    pppp - 4-значный шестнадцатеричный номер, обозначающий Product ID устройства
    rrrr - 4-значный бинарно-закодированный десятиричный номер, обозначающий Revision number устройства

    Данные сведения Вы можете узнать воспользовавшись Диспетчером устройств.
    4.3.1) Откройте Пуск -> Панель управления -> Диспетчер устройств
    4.3.2) Нажмите правой кнопкой мыши на необходимом Вам устройстве и выберите пункт Свойства
    4.3.3) Перейдите на вкладку Сведения и в ниспадающем списке выберите ИД оборудования.

    5) Создайте в открытом разделе HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\usbflags\vvvvpppprrrr параметр DWORD (32 бита) с именем DisableOnSoftRemove
    6) Щелкните правой кнопкой мыши по параметру DisableOnSoftRemove и выберите пункт Изменить...
    7) В текстовом поле Значение: введите 1 и нажмите ОК.

    Для всех устройств:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\usbhub\hubg Если данной ветки нет, то создайте ее.
    3) Щелкните правой кнопкой мыши и создайте параметр DWORD (32 бита) с именем DisableOnSoftRemove
    4) Щелкните правой кнопкой мыши по параметру DisableOnSoftRemove и выберите пункт Изменить...
    5) В текстовом поле Значение: введите 1 и нажмите ОК.

    12. Отключение сообщения: "Хотите выполнить проверку и исправление ошибок на ..." для съемных дисков.

    Вариант 1

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\AutoCheckSelect
    3) Щелкните на параметре CheckedValue правой кнопкой мыши и нажмите Изменить.
    4) Установите значение 0 и нажмите ОК

    Вариант 2

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
    3) Щелкните на параметре BootExecute правой кнопкой мыши и нажмите Изменить.
    4) По умолчанию значение данного параметра должно быть autocheck autochk *.
    * означает, что все диски выбраны для проверки. Чтобы добавить исключение проверки для определенного диска, добавьте перед звездочкой параметр /K:<Буква_диска>. Параметр /K отключает проверку диска при его автозапуске. Например для съемного диска H: значение ключа BootExecute примет вид:

    Если Вы желаете добавить несколько дисков в исключения (например: H и I диски), то значение ключа BootExecute примет вид:

    Вариант 3

    1) Откройте меню Пуск
    2) Введите в диалоговом окне Выполнить (Win+R) или в строке поиска команду msconfig и нажмите Enter.
    3) Перейдите на вкладку Службы и уберите флажок: Определение оборудования оболочки
    4) Откройте меню Пуск
    5) Введите в диалоговом окне Выполнить (Win+R) или в строке поиска команду services.msc и нажмите Enter.
    6) В открывшейся оснастке Службы щелкаете правой кнопкой мыши на Определение оборудования оболочки и выбираете пункт Свойства
    7) Выбираете Тип запуска - Отключена и нажимаете кнопку Остановить
    8) Нажимаете ОК.

    Данное действие также отключит автозагрузку со съемных носителей.


1. Запуск Редактора реестра, создание и применение reg-файла.

Запуск Редактора Реестра:

Вариант 1.

1.1) Откройте меню Пуск -> Все программы -> Стандартные -> Выполнить (или нажмите сочетание клавиш Win+R)
1.2) Введите команду regedit и нажмите ОК

Вариант 2.

2.1) Откройте меню Пуск
2.2) В строке поиска введите regedit и нажмите Enter

Вариант 3.

3.1) Запустите Проводник Windows (Explorer)
3.2) Откройте папку C:\Windows и дважды щелкните по файлу regedit.exe

Создание reg-файла.

Вариант 1.

1.1) Откройте Блокнот (Notepad).
1.1.1) Откройте меню Пуск -> Все программы -> Стандартные -> Блокнот (или нажмите сочетание клавиш Win+R -> введите notepad -> нажмите ОК).
1.2) Скопируйте необходимый Вам код в окно программы Блокнот.
1.3) В меню программы нажмите Файл и выберите пункт Сохранить.
1.4) В открывшемся окне:
1.4.1) Укажите место сохранения файла.
1.4.2) Укажите имя файла и расширение .reg (Например: Demo.reg)
1.4.3) Выберите тип файла: Все файлы (*.*).

Внимание:
Если Вы оставите тип файла: Текстовые файлы (*.txt), то имя файла обязательно нужно взять в кавычки. (Например: "Demo.reg")

1.5) Нажмите на кнопку Сохранить.

Вариант 2.

Если у Вас убран флажок Скрывать расширения для зарегистрированных типов файлов в Параметры папок (Панель управления\Оформление и персонализация\Параметры папок -> Вкладка Вид), то Вы можете создать reg-файл следующим способом:

2.1) В папке, где Вы хотите создать reg-файл, щелкните правой кнопкой мыши.
2.2) Во всплывшем меню выберите Создать -> Текстовый документ.
2.3) Сотрите имя и расширение файла .txt, укажите необходимое Вам имя файла и расширение .reg, нажмите клавишу Enter, а затем кнопку Да.
2.4) Щелкните на созданном Вами файле правой кнопкой мыши и выберите пункт Изменить.
2.5) Скопируйте необходимый Вам код в окно программы Блокнот.
2.6) Нажмите сочетание клавиш CTRL+S.

Вариант 3.

3.1) Возьмите любой готовый reg-файл.
3.2) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить.
3.3) Скопируйте необходимый Вам код в окно программы Блокнот.
3.4) В меню программы нажмите Файл и выберите пункт Сохранить Как.
3.5) В открывшемся окне:
3.5.1) Укажите место сохранения файла.
3.5.2) Укажите имя файла и расширение .reg (Например: Demo.reg)
3.5.3) Выберите тип файла: Все файлы (*.*).
3.6) Нажмите на кнопку Сохранить

Применение reg-файла.

Вариант 1.

1) Щелкните два раза левой кнопкой мыши на reg-файле и нажмите кнопку Да.

Вариант 2.

2.1) Щелкните правой кнопкой мыши на reg-файле.
2.2) Выберите пункт Слияние и нажмите кнопку Да.

Назад на страницу раздела Твики Реестра.


2. Создание и переименование раздела или параметра, а также изменение параметра в редакторе реестра.

Вы запустили программу "Редактор реестра" как описано в Запуск программы "Редактор реестра", создание и применение reg-файла.. Используя дерево папок открыли нужный Вам раздел, и теперь, Вам необходимо создать, переименовать параметр (раздел), либо изменить значение параметра реестра. Существует несколько способов сделать это.

Создание раздела или параметра в редакторе реестра.

Вариант 1.

1) Щелкните в главном меню пункт Правка.
2) Наведите курсор мыши на пункт меню Создать.
3) В раскрывающемся меню выберите раздел или тип параметра, который Вы желаете добавить.

Вариант 2.

1) Щелкните правой кнопкой мыши в любом пустом месте области параметров (правая часть окна).
2) Наведите курсор мыши на пункт меню Создать.
3) В раскрывающемся меню выберите раздел или тип параметра, который Вы желаете добавить.

Переименование раздела или параметра в редакторе реестра.

Вариант 1.

1) Выберите раздел или параметр, который Вы желаете переименовать.
2) Щелкните в главном меню пункт Правка, а затем на пункт Переименовать.

Вариант 2.

1) Щелкните правой кнопкой мыши на раздел или параметр, который Вы желаете переименовать.
2) Щелкните левой кнопкой мыши на пункт Переименовать.

Изменение значения параметра в редакторе реестра.

Вариант 1.

1) Выберите параметр, который Вы желаете изменить.
2) Щелкните в главном меню пункт Правка, а затем на пункт Изменить.

Вариант 2.

1) Щелкните правой кнопкой мыши на параметр, который Вы желаете изменить.
2) Щелкните левой кнопкой мыши на пункт Изменить

Вариант 3.

Щелкните дважды на параметре, который Вы желаете изменить.

Назад на страницу раздела Твики Реестра.


3. Аббревиатуры используемые для обозначения веток реестра.

Для обозначения пути к разделу или ключу реестра могут использоваться следующие аббревиатуры:

Наименование раздела | Используемая аббревиатура
HKEY_CLASSES_ROOT | HKCR
HKEY_CURRENT_USER | HKCU
HKEY_LOCAL_MACHINE | HKLM
HKEY_USERS | HKU
HKEY_CURRENT_CONFIG | HKCC

Назад на страницу раздела Твики Реестра.


4. Быстрый переход в необходимый раздел реестра.

Если для работы с реестром Вы предпочитаете не использовать программы: RegEditX, Registry Workshop или Reg Organizer, то для быстрого перехода в необходимый Вам раздел реестра Вы можете воспользоваться одним из указанных ниже вариантов.

Вариант 1.

1) Скачайте маленькую бесплатную утилиту от Microsoft: RegJump
2) Распакуйте архив в любую папку и скопируйте файл regjump.exe в папку C:\Windows\System32
3) Теперь любую ветку реестра можно открыть прямо из диалогового меню Выполнить или из строки поиска в меню Пуск.
3.1) В диалоговом меню Выполнить (Win+R), либо в строке поиска из меню Пуск введите команду regjump и путь к разделу, указав его в кавычках.

Например:

3.2) Нажмите клавишу Enter, при вводе из окна Выполнить или Shift+Enter при вводе в строку поиска:

Вариант 2

1) Создайте специальный скрипт.

1.1) Скопируйте указанный код в любой текстовый редактор (например, Блокнот).
1.2) Нажмите Ctrl+S и сохраните файл с любым именем и расширением .vbs
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "regkey.vbs")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
2) Переместите созданный Вами скрипт в любую удобную Вам папку.
Теперь для открытия раздела реестра:
3) Скопируйте в буфер обмена(Ctrl+C или Щелчок правой кнопкой мыши -> Копировать) необходимую Вам ветку реестра.
4) Щелкните на созданный Вами скрипт-файл.

Минусом использования данного скрипта является отсутствие поддержки аббревиатур.

Назад на страницу раздела Твики Реестра.


5. Отключение вывода диалогового окна при применении reg-файла.

При запуске reg-файла, система выводит диалоговое окно в котором пользователь должен подтвердить достоверность источника, откуда получены импортируемые в реестр сведения. Для отключения данного окна выполните указанные ниже действия:

1) Запустите редактор реестра (Win+R -> regedit -> ОК)
2) Откройте раздел реестра HKEY_CLASSES_ROOT\regfile\shell\open\command
3) Дважды щелкните на параметре По умолчанию и введите значение:

4) Закройте редактор реестра и перезапустите компьютер.

Минусом данного решения является то, что помимо указанного диалогового окна запроса подтверждения, также не будет выводиться окно об успешном импортировании в реестр данных.

Назад на страницу раздела Твики Реестра.


1. Получение полного доступа к разделу реестра, используя программу regedit или командную строку.

Для поддержания безопасности системы, после внесения изменений в реестр верните исходные права и восстановите владельца.

Изменение разрешений и владельца для получения полного доступа к разделу реестра.

1) Нажмите кнопку Пуск и введите в строке поиска regedit
2) Щелкните на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора.
3) Откройте раздел реестра, права которого Вы желаете изменить.
4) В списке слева, щелкните на данном разделе реестра правой кнопкой мыши и выберите пункт Разрешения.
5) Щелкните левой кнопкой мыши на группу Администраторы:
6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.
7) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
8) Щелкните левой кнопкой мыши на свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
9) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

Восстановление настроек, если владельцем являлись служба TrustedInstaller или учетная запись Система.

1) Щелкните правой кнопкой мыши на разделе реестра, права которого Вы желаете восстановить и выберите пункт Разрешения.
2) Щелкните левой кнопкой мыши на группу Администраторы:
3) Снимите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку Применить.
4) Нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
5) Нажмите кнопку Другие пользователи или группы... и в качестве имени объекта в текстовом поле введите:
  • NT SERVICE\TrustedInstaller , если владельцем являлась служба TrustedInstaller
  • система , если владельцем являлась учетная запись Система (в английской Windows 7 нужно вводить System)
    • 6) В окне Изменить владельца на: выберите TrustedInstaller или система .
    7) Установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.

    Далее рассказывается как можно изменить разрешения, используя командную строку запущенную от имени администратора.
    Если после использовании команды, разрешения не сменятся, то возможно Вам придется зайти в систему под встроенной учётной записью "Администратор" для их выполнения заново.

    Изменение разрешений используя командную строку.

    1) Создайте в любом месте txt-файл (Например в папке D:\Reg создайте файл regperm.txt)
    2) Добавьте в данный файл разделы реестра и присваиваемые им разрешения в следующем формате:

    где куст – имя куста реестра, раздел – имя раздела реестра, а [разрешения] – двоичный числовой формат разрешений.

    Обозначения используемые для кустов реестра:

    Наименование куста реестра | Следует указывать
HKEY_CLASSES_ROOT | \Registry\machine\software\classes
HKEY_CURRENT_USER | \Registry\user\user_sid где user_sid — идентификатор безопасности пользователя.
HKEY_LOCAL_MACHINE | \Registry\machine
HKEY_USERS | \Registry\user
HKEY_CURRENT_CONFIG | \Registry\machine\SYSTEM\CurrentControlSet\Hardware Profiles\0001

    Если Вы не знаете свой SID, то узнать его Вы сможете введя в командной строке команду:

    Двоичные числовые представления разрешений имеют следующий вид (выборочно):

    Значение | Задаваемое разрешение
1 | Администратор, полный доступ
2 | Администратор, чтение
3 | Администратор, чтение и запись
4 | Администратор, чтение, запись и удаление
5 | СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ, полный доступ
6 | СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ, чтение и запись
7 | Все, полный доступ
8 | Все, чтение
9 | Все, чтение и запись
10 | Все, чтение, запись и удаление
11 | Опытные пользователи, полный доступ
12 | Опытные пользователи, чтение и запись
13 | Опытные пользователи, чтение, запись и удаление
17 | Система, полный доступ
18 | Система, чтение и запись
19 | Система, чтение

    Пример:

    Чтобы задать полный доступ группам и пользователям Администратор, СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ и Система для раздела реестра:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer в txt-файл необходимо добавить

    3) В командной строке запущенной от имени администратора (Win+R -> cmd -> OK) выполните команду:

    Например:

    Назад на страницу раздела Твики Реестра.
    Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


2. Удаление сведений об использованном USB-флэш диске.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку:

Здесь Вы увидите список разделов, обозначающих подключаемые когда-либо флеш-диски к Вашей системе.
3) Найдите раздел соответствующий, флеш диску, упоминание о котором Вы хотите удалить из реестра. (Например: Disk&Ven_Corsair&Prod_Flash_Voyager&Rev_1100)

4) Откройте данный раздел.
Путь к данной ветке, в моем примере:

5) В данной ветке Вы увидите подраздел (Например: AB00000000005136&0)
Путь к данной ветке, в моем примере:

6) Откройте ветку реестра:

7) Отрывая поочередно каждый из разделов данной ветки, найдите подраздел содержащий в названии AB00000000005136
Путь к данной ветке, в моем примере:

8) Удалите найденные в результате анализа ветки реестра. В моем примере, необходимо удалить следующие ветки:

9) Перезагрузите компьютер.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


3. Удаление программ в Безопасном Режиме, использующих установщик Windows Installer.

В большинстве случаев при попытке удаления программы в Безопасном Режиме, если программа не использует собственный инсталлятор (Например: Winamp) Вы получите предупреждающее сообщение:

Для включения возможности удаления программ в Безопасном Режиме сделайте следующее:

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal
3) Создайте здесь раздел MSIService
4) Присвойте строковому параметру По умолчанию значение Service.
5) Перезагрузите компьютер.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


4. Отмена ограничения использования команд в контекстном меню, при выделении более 15 файлов.

Как известно, при выделении более 15 файлов команды контекстного меню, такие как "Открыть/Печать/Редактировать" становятся недоступны.
Для отмены данного ограничения проделайте следующее:

1) Запустите редактор реестра ( Win+R -> regedit -> OK)
2) Откройте ветку HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
3) Создайте в ней параметр MultipleInvokePromptMinimum типа DWORD.
4) Установите значение данного параметра равным 16.

Для уменьшения количества файлов на которых действует ограничение применения команд, введите значение от 1 до 15.
При выделении файлов выше выбранного Вами значения команды в контекстном меню применяться не будут. При указании значения 0 произойдет полное отключение команд, включая команду "Открыть".

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


5. Отключение проверки подписи для загруженных программ.

Избавляет от этого:

1) Откройте Панель управления -> Свойства обозревателя -> вкладка Дополнительно
2) Уберите флажок "Проверка подписи для загруженных программ" и поставьте флажок "Разрешать выполнение или установку программы, имеющую недопустимую подпись".
3) Создайте и примените reg-файл следующего содержания.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


6. Удаление устаревших значков из области уведомления панели задач.

После установки/запуска программ, которые размещаются в области уведомлений, данный список все время растет.
С помощью следующего твика реестра, можно оставить в текущем диалоге отображаться только те значки, которые расположены в области уведомлений на данный момент.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

Скачать готовый reg-файл Вы можете по ссылке: Clean_TrayNotify.zip

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


7. Очистка истории расположений фонов рабочего стола в Windows 7.

В окне настроек фонового рисунка рабочего стола (ПКМ на рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) есть пункт Расположение изображения, содержащий список папок, в которых хранятся картинки, которые можно использовать в качестве обоев рабочего стола. По умолчанию в этом списке всегда есть указания на четыре папки:

1. Фоны рабочего стола Windows;
2. Библиотека изображений;
3. Самые популярные фотографии;
4. Сплошные цвета.

Если Вы добавляете картинку из папки, которой нет в списке, то она(папка) автоматически добавится в данный список. Со временем, этот список будет увеличиваться, дополняясь новыми папками. При чём, в списке будут указаны папки, которых на диске физически уже нет, а запись о них осталась.

Чтобы очистить список Расположение изображения от ненужных записей и оставить только стандартные названия, нужно в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\Images удалить все параметры ID под номерами от 0 до 9, которые содержат в зашифрованном виде пути нахождения изображений, выбранных пользователем.

Теперь при повторном открытии окна настроек фонового рисунка рабочего стола (ПКМ на рабочем столе -> Персонализация -> Фоновый рисунок рабочего стола) в пункте Расположение изображения Вы увидите список, содержащий только записи по умолчанию.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


8. Удаление папки Общие Документы и пользовательского профиля Общие.

Для спокойного удаления папки Общие Документы и пользовательского профиля Общие указанные ниже действия рекомендуется выполнять на чистой установленной системе. Если же у Вас система уже установлена, и на ней уже установлены программы, то прежде чем выполнять инструкции ниже скопируйте все папки из C:\Users\Public\* в C:\Users\ВашПрофиль\*

Вариант 1.

1) Запустите редактор реестра ( Win+R -> regedit -> OK)
2) Откройте ветку

3) Затем нажмите правой кнопкой мыши на правой панели и выберите Создать -> Параметр "DWORD".
4) Дайте этому параметру имя NoSharedDocuments и присвойте ему значение 1
5) Перезагрузите компьютер

Вариант 2.

1) Пройдите к ветке реестра

2) Удалите следующую ветку:

3) Пройдите к ветке реестра

4) Удалите следующую ветку(если есть):

Вариант 3.

1) Откройте Панель управления\Все элементы панели управления\Система(или Пуск -> Компьютер -> Свойства)
2) Откройте Дополнительные параметры системы
3) Пройдите на вкладку Имя Компьютера и нажмите Идентификация...
4) Выберите пункт Компьютер предназначен для домашнего использования.
5) Нажмите Далее, затем Готово, затем Ок
6) Перезагрузите компьютер

После того, как воспользуйтесь решением одного из вариантов проделайте следующие действия:

1) В ветке реестра:

замените значения с C:\Users\Public\ на C:\Users\ВашПрофиль\

2) В ветке реестра:

замените значения с %PUBLIC%\ на %USERPROFILE%\

3) Удалите папки (если они остались):

Диск С: -> Пользователи -> Общие (C:\Users\Public\)
Библиотеки -> Документы -> Общие Документы

Внимание: Если не хотите, чтобы у Вас на рабочем столе появились дублирующиеся иконки файлов, не устанавливайте значение параметра Common Desktop, идентичное рабочему столу Вашего профиля. Например, вместо C:\Users\ВашПрофиль\Desktop укажите C:\Users\ВашПрофиль\Public\Desktop, а вместо %USERPROFILE%\Desktop укажите %USERPROFILE%\Public\Desktop.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


9. Запрет запуска контекстного меню Проводника при нажатии правой кнопкой мыши.

1) Запустите редактор реестра (Regedit).
2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр DWORD
4) Переименуйте его в NoViewContextMenu
5) Измените значение на 1.
6) Перезагрузите компьютер.

Вы можете также создать и применить reg-файл следующего содержания:

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


10. Удаление пункта меню Файл из Проводника.

1) Запустите редактор реестра (Regedit).
2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр DWORD
4) Переименуйте его в NoFileMenu
5) Измените значение на 1.
6) Перезагрузите компьютер.

Вы можете также создать и применить reg-файл следующего содержания:

Данный пункт будет также удален из всех мест, использующих оболочку Windows.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


11. Запрещение запуска программ.

1) Запустите редактор реестра (Regedit).
2) Откройте следующий раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр DWORD
4) Переименуйте его в RestrictRun
5) Измените значение на 1.
6) Перезагрузите компьютер.
7) Создайте подраздел с аналогичным именем RestrictRun
8) Создайте в разделе (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictRun) список разрешенных к запуску программ для текущего пользователя.
8.1) Создайте строковые(String) параметры
8.2) Укажите названия для создаваемый строковых параметров, начиная с 1 и далее
8.3) Установите в значениях параметров пути к Вашим приложениям и их имена. Файлы должны указываться с расширением. Например:

1 REG_SZ regedit.exe
2 REG_SZ calc.exe
3 REG_SZ Iexplore.exe

Не забудьте указать файл regedit.exe, чтобы Вы могли зайти в него и отменить установленные Вами ограничения!
Для сброса ограничения на запуск программ надо установить значение ключа RestrictRun в 0 или удалить его.

Если Вы забыли указать regedit.exe в списке или не создали подраздел RestrictRun, чтобы запретить запуск всех программ. Для отмены запрета проделайте следующее:

1) Перезапустите компьютер.
2) До начала запуска Windows нажмите на клавишу F8 и выберите пункт Безопасный режим с поддержкой командной строки
3) В командной строке введите regedit и нажмите Enter.
4) Пройдите в ветку HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
5) Удалите ключ RestrictRun или установите его значение на 0.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


12. Удаление записей из истории диалогового окна "Выполнить".

Если Вы используете диалоговое окно "Выполнить" в меню "Пуск" (Win+R), то для удаления записей из его истории проделайте следующее.

1) Запустите редактор реестра: Win+R --> regedit
2) Откройте следующую ветку реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU

Команды, введенные вами ранее, хранятся в виде значений параметров a,b,c,d и так далее используя буквы английского алфавита.

3) Для удаления записи - удалите параметр с ненужной командой, и она пропадет из истории диалога "Выполнить".

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


13. Удаление/восстановление предупреждающего окна о внесении изменений в msconfig(Конфигурация системы).

При внесении изменений в утилиту msconfig (Конфигурация системы), появляется окно Настройка системы, в котором Вам предлагается на выбор: либо перезагрузить компьютер, либо выйти без перезагрузки.

Чтобы отключить данное предупреждение установите флажок Больше не показывать это предупреждение, и окно больше появляться не будет.

Для восстановления данного окна:

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKCU\Software\Microsoft\Shared Tools\MsConfig
3) Удалите параметр NoRebootUI.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


14. Удаление лишних записей из утилиты msconfig (Конфигурация системы).

Если в окне утилиты msconfig (Конфигурация системы) скопилось много записей и Вы хотели бы удалить ненужные. То сделайте следующее:

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKLM\SOFTWARE\Microsoft\Shared Tools\MSConfig
3) Просмотрите все подразделы данной ветки и удалите ненужные Вам записи.
4) Также записи могут храниться в файле mscfgtlc.xml, находящимся в папке C:\Windows\system32\. В 64-битных Windows данный файл также находится в папке C:\Windows\SysWOW64\.
5) Откройте данный файл Блокнотом, удалите ненужные записи и сохраните. Если Вы хотите удалить все лишние записи, то просто удалите файл mscfgtlc.xml.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


15. Отключение напоминания о необходимости перезагрузки после установки обновлений.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU.
3) Создайте параметр NoAutoRebootWithLoggedOnUsers типа DWORD и присвойте ему значение 1.

или

откройте диалоговое меню Выполнить (Win+R) и введите команду:

Для вступления изменений в силу перезайдите в систему или перезагрузите компьютер.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


16. Запуск нескольких копий редактора реестра одновременно.

Пользователи, которые работают с редактором реестра Windows наверняка сталкивались с ситуацией, когда необходимо сверить содержимое веток реестра. Весьма удобно было бы открыть два редактора реестра, разместить их рядом и сравнить. Однако при повторной попытке запуска программы, система переключает Вас на открытое окно программы. Запуск с удерживанием клавиши Shift тоже не работает.

Для запуска второй копии редактора реестра:

1) Откройте диалоговое меню "Выполнить" (Win+R)
2) Введите команду regedit, используя параметр -m и нажмите Enter.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


17. Дополнительные параметры для настройки функций "Защита системы" и "Восстановление системы".

В Windows 7 для функций "Защита системы" и "Восстановление системы" существуют дополнительные настройки, которые скрыты от обычных пользователей. Чтобы их изменить Вам необходимо создать соответствующий настройке параметр в реестре.

1) Откройте диалоговое меню "Выполнить" (Win+R)
2) Введите команду regedit и нажмите Enter.
3) Откройте раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore\Cfg
4) Создайте параметр типа DWORD с именем из списка указанного ниже
5) Щелкните правой кнопкой мыши на созданном параметре и выберите пункт Изменить.
6) Установите переключатель в положение Десятичная и введите необходимое Вам значение.

DiskPersent - указывает, какой объем дискового пространства в процентах будет использовать система для точек восстановления.

CompressionBurst - указывает время сжатия данных в секундах при простое системы. При простое системы в течение времени, указанного в данном параметре System Restore будет упаковывать данные, после чего прекратит свою работу до следующего периода простоя системы.

DSMin - указывает минимальное количество свободного дискового пространства, которое требуется System Restore. В случае уменьшения свободного дискового пространства до указанного размера точки восстановления системы перестанут создаваться.

1 день(сутки) равен 86400 секунд, 1 час равен 3600 секунд, 1 минута равна 60 секунд.

RPGlobalInterval - указывает количество времени в секундах, в течение которого System Restore ожидает перед созданием новой контрольной точки.

RPLifeInterval - указывает время в секундах, в течение которого будут храниться точки восстановления перед удалением их с компьютера.

RPSessionlnterval - указывает количество времени в секундах, в течение которого System Restore ожидает перед созданием новой системной контрольной точки при включенном компьютере. Значением по умолчанию является ноль, что означает, что эта функция выключена. Вы можете установить свое значение (например, интервал в один час), чтобы программа создавала контрольные точки автоматически через заданный интервал.

ThawInterval - указывает количество времени в секундах, в течение которого System Restore ожидает перед тем, как возобновить свою работу после того, как появилось достаточное количество дискового пространства.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Администрирование и Безопасность.


1. Включение скрытых настроек электропитания.

Чтобы настроить в Windows 7 параметры электропитания, необходимо открыть Панель управления\Система и безопасность\Электропитание. Там можно выбрать нужный план электропитания и при необходимости более детально настроить параметры, перейдя в Настройка плана электропитания -> Изменить дополнительные параметры питания.
Однако более детально настроить параметры электропитания помогает консольная утилита Powercfg. Но работать в командной строке, разбираясь с каждым параметром может занять продолжительное время. Для того чтобы функции предоставляемые powercfg стали доступны Вам в графической оболочке, необходимо внести некоторые изменения в ветке реестра:

В данной ветке содержатся разделы, отвечающие за определенную группу настроек.
Например, раздел 0012ee47-9041-4b5d-9b77-535fba8b1442 относится к настройкам управления питанием жесткого диска, а 54533251-82be-4824-96c1-47b60b740d00 к настройкам управления питанием процессора.
В свою очередь, в каждом из данных разделов есть подразделы, отвечающие за какую-либо настройку электропитания. Описание каждой из настроек указано в значении параметра Description, а её отображение в графической оболочке в значении параметра Attributes. По умолчанию, многие настройки имеют значение параметра Attributes равное «1», для того, чтобы необходимая Вам настройка был виден в графической оболочке, необходимо заменить его на «0». Доступные для отображения настройки, на ноутбуке и стационарном компьютере могут отличаться, в связи с особенностью их систем электропитания.

Для отображения политики простоя устройств, создайте и примените reg-файл следующего содержания:

Для отображения скрытых параметров по настройке работы жесткого диска, создайте и примените reg-файл следующего содержания:

Для отображения скрытых параметров по настройке кнопок питания, создайте и примените reg-файл следующего содержания:

Для отображения скрытых параметров по настройке управления питания процессора, создайте и примените reg-файл следующего содержания:

Импортированное значение реестра позволяет увидеть только малую часть параметров, доступных для настройки управлением процессора. Всего их более 30.

Для отображения скрытых параметров по настройке спящего режима, создайте и примените reg-файл следующего содержания:

Для отображения скрытых параметров по настройке экрана, создайте и примените reg-файл следующего содержания:

Также к этому разделу относится настройка параметров графического адаптера, но доступность конкретных настроек будет определяется драйвером.

У себя в системе я обнаружил 54 скрытых настройки электропитания. Для включения сразу всех скрытых настроек электропитания: экспортируйте всю ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings в reg-файл. Отредактируйте полученный reg-файл: оставьте в нем только наименование веток реестра и их параметры Attributes и присвойте им значения «0».
Также Вы можете скачать и применить, готовый reg-файл PowerSettings.reg

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


2. Добавление классического всплывающего меню Программы (Programs) в меню Пуск.

Для быстрого доступа к элементам списка Все программы (All Programs), Вы можете добавить его как всплывающее меню взамен меню Избранное (Favorites) или меню Файлы для загрузки (Downloads)

Вариант 1. Вместо меню Файлы для загрузки (Downloads).

Если Вы для загрузки файлов из интернета используете собственную папку или сохраняете на Рабочий стол, а также в качестве интернет-браузера используете Internet Explorer, то Вам подойдет данный вариант.

1) Включите меню Файлы для загрузки (Downloads)
1.1) Щелкните правой кнопкой мыши на кнопке Пуск, затем нажмите Свойства (Properties).
1.2) Откройте вкладку Меню "Пуск" (Start Menu) и нажмите кнопку Настроить (Customize)
1.3) Прокрутите список до пункта Файлы для загрузки (Downloads)
1.4) Установите переключатель в значение Отображать как меню (Display as a menu), затем нажмите OK.
2) Нажмите кнопку Пуск, в поле поиска введите regedit и нажмите Enter.
3) Откройте ветку:

4) Щелкните дважды на параметр {374DE290-123F-4565-9164-39C4925E467B} и замените текущий путь на этот:

5) Откройте ветку:

6) Щелкните дважды на параметр {374DE290-123F-4565-9164-39C4925E467B} и замените текущий путь на этот:

7) Закройте regedit, и перезагрузите Ваш компьютер.

Вариант 2. Вместо меню Избранное (Favorites)

Если Вы в качестве интернет-браузера используете альтернативный браузер: Mozilla Firefox, Opera или Google Chrome, то Вам подойдет данный вариант.

1) Установите любой понравившийся Вам браузер Mozilla Firefox, Opera или Google Chrome
2) При его установке импортируйте закладки из Internet Explorer(если необходимо)
3) Включите меню Избранное (Favorites)
3.1) Щелкните правой кнопкой мыши на кнопке Пуск, затем нажмите Свойства (Properties).
3.2) Откройте вкладку Меню "Пуск" (Start Menu) и нажмите кнопку Настроить (Customize)
3.3) Прокрутите список до пункта Избранное (Favorites) и установите на него флажок, затем нажмите OK.
4) Нажмите кнопку Пуск, в поле поиска введите regedit и нажмите Enter.
5) Откройте ветку:

6) Щелкните дважды на параметр Favorites и замените текущий путь на этот:

7) Откройте ветку:

8) Щелкните дважды на параметр Favorites и замените текущий путь на этот:

9) Закройте regedit, и перезагрузите Ваш компьютер.

Теперь, когда Вы нажмете Пуск, в правой его части Вы увидите меню Программы (Programs), наподобие меню в предыдущих версиях Windows.

Для исключения дублирования, Вы также можете убрать стандартный пункт меню Все программы (All Programs) из меню Пуск.
Для этого создайте и примените reg-файл следующего содержания:

Для возвращения стандартного пункта меню Все программы (All Programs) из меню Пуск.
Для этого создайте и примените reg-файл следующего содержания:

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


3. Добавление функции произвольного выравнивания иконок в Проводнике.

В Windows 7 возможность отключения автоматического выравнивания иконок в Проводнике недоступна. В контекстном меню "Вид" в Проводнике, пункт "Упорядочить значки автоматически" отсутствует, соответственно Вы не можете располагать значки произвольным образом.
Предложенный ниже твик включает возможность произвольного выравнивания иконок в Проводнике и добавляет в контекстное меню "Вид" в Проводнике пункты "Выравнивать автоматически" и "Выровнять по сетке".
В виду сложившейся необходимости, для работы данного твика режимы "Плитка" и "Содержимое" были объединены в режим "Расширенная плитка".

Чтобы воспользоваться твиком Вы можете скачать и применить готовое решение: disable-auto-arrange.zip

disableautoarrange.reg - reg-файл вносящий изменения в контекстное меню Проводника
undo.reg - reg-файл возвращающий все настройки Проводника "по умолчанию".

Также Вы можете создать данные reg-файлы самостоятельно.

Для внесения изменений создайте и примените reg-файл следующего содержания:

Для отмены изменений создайте и примените reg-файл следующего содержания:

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


4. Использование Windows Media Player х64 по умолчанию (для Windows 7 х64).

Microsoft до сих пор использует 32-битную версию Windows Media Player в 64-битной версии ОС, но есть способ это изменить.
Преимущество использования WMP х64 заключается лишь в том, что установив 64-битную версию кодеков, вы получите гораздо более чистую и легко управляемую систему.

1) Запустите меню Выполнить(Win+R) или командную строку от имени Администратора
2) Введите команду

(команда чувствительна к регистру)
3) Откройте редактор реестра: Win+R --> regedit
4) Перейдите к ветке

и кликните два раза по значению Path
5) Измените

на

6) Закройте реестр и наслаждайтесь Windows Media Player х64

Готовые bat-файлы Вы можете скачать по ссылке: Windows_Media_Player_x64.zip

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


5. Настройка диалога переключения между окнами ("Alt"+"Tab").

1) Запустите Редактор Реестра (Win+R -> Regedit -> Ok)
2) Откройте ветку реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab, если она отсутствует, то создайте её (щелкните на папке Explorer правой кнопкой мыши, выберите Создать -> Раздел и назовите её AltTab).
В данной папке создайте или измените указанные ниже параметры. Все параметры, которые будут создаваться или изменятся имеют тип REG_DWORD. Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

Для создания твика, воспользуйтесь инструкцией:

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Параметры, отвечающие за количество отображаемых столбцов и строк

Columns - данный параметр отвечает за количество столбцов, из которых состоит диалог переключения между окнами.
Rows - данный параметр отвечает за количество строк, из которых состоит диалог переключения между окнами.

Пример твика реестра с использованием этих параметров:

Параметры, отвечающие за отступы в диалоге переключения между окнами

Упомянутые ниже параметры указываются в пикселях.

TopMarginPx - величина верхнего поля, добавляемого в диалог
SideMarginPx - величина бокового поля, добавляемого в диалог
BottomMarginPx - величина нижнего поля, добавляемого в диалог
MinWidthPx - минимальная возможная ширина диалога AltTab
ThumbSpacingXPx - интервал между эскизами смежных окон по горизонтали
ThumbSpacingYPx - интервал между эскизами смежных окон по вертикали

Пример твика реестра с использованием этих параметров:

Параметры, отвечающие за значки эскизов окон

Упомянутые ниже параметры указываются в пикселях.

OverlayIconDXPx - величина смещения значка, вправо от эскиза окна
OverlayIconDYPx - величина смещения значка, вниз от эскиза окна
OverlayIconPx - размер значков, отображаемых в правом нижнем углу эскиза окна в диалоге переключения между окнами

Пример твика реестра с использованием этих параметров:

Параметры, отвечающие за размер эскизов окон и заголовок диалога переключения между окнами

Упомянутые ниже параметры указываются в пикселях.
MaxThumbSizePx - максимальный размер эскизов окон
MinThumbSizePcent - минимальный размер эскизов окон в процентах, относительно максимального размера установленного в MaxThumbSizePx
TextButtomPx - высота заголовка диалога переключения между окнами

Пример твика реестра с использованием этих параметров:

Параметры, изменяющие задержку времени в отображении диалога и управляющие его прозрачностью

FadeOut_ms - количество миллисекунд, в течении которого окно будет исчезать
FadeIn_ms - количество миллисекунд, в течении которого окно будет появляться
FadeOutThreshold_ms Используется для мгновенного исчезновения диалога(присвойте данному параметру значение 0x1000).

StartAlpha - начальная прозрачность диалога переключения между окнами
FinalAlpha - конечная прозрачность диалога переключения между окнами

Пример твика реестра с использованием этих параметров:

Для включения классического диалога переключения между окнами, используемого в предыдущих версиях Windows при нажатии Alt+Tab, создайте DWORD-параметр AltTabSettings в ветви реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer и присвойте данному параметру значение 1.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


6. Настройка диалогового окна "Выбор программы".

Когда Вы щелкаете на файле с незарегистрированным в системе расширением, то появляется окно “Выбор программы”, в котором вам предлагается выбрать из предложенного списка программу, способную обработать неизвестный тип файла.
В данном окне по умолчанию установлен флажок “Использовать выбранную программу для всех файлов такого типа”. Чтобы убрать флажок и заблокировать возможность его установки, Вам необходимо изменить запись в реестре.

1) Запустите редактор реестра (Win+R -> regedit -> OK)
2) Откройте раздел HKEY_CLASSES_ROOT\Unknown\shell\opendlg\command
3) Измените значение параметра По умолчанию (Default)

Список программ, которые выводятся в диалоговом окне выбора программы, формируется при помощи списка подразделов раздела HKEY_CLASSES_ROOT\Applications.
В данном разделе вы можете видеть, что имена подразделов соответствуют именам программ, установленных на вашем компьютере. Если вы хотите, чтобы какая-то из этих программ никогда не выводилась в диалоговом окне выбора программы, то в подразделе этой программы создайте строковый параметр NoOpenWith без какого-либо значения.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


7. Включение окна выбора начальных параметров при запуске проигрывателя Windows Media.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Удалите полностью следующую ветку реестра со всем содержимым:

Вместо XXXXXX-XXXXXX-XXXXXX-XXXX у Вас будет собственное значение.
Например: S-1-5-21-83440259-2036283413-1691820529-1000 или S-1-5-21-2717813001-1445373200-4062485642-500

3) Перезайдите в систему или перезагрузите компьютер.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


8. Изменение действия по умолчанию при перетаскивании файлов между папками в Проводнике.

При перетаскивании любого файла между двумя папками-окнами Проводника, в Windows 7 по умолчанию выполняется его перемещение. Вы можете самостоятельно настроить действие, которое будет выполняться при перетаскивании файла между папками: копирование; перемещение; создание ярлыка.

Действие по умолчанию при перетаскивании конкретного типа файлов.

1) Запустите редактор реестра (Win+R -> regedit -> ОК)
2) Перейдите в раздел HKEY_CLASSES_ROOT
3) Найдите раздел интересующего Вас расширения. Для примера возьмем раздел .exe:
4) Обратите внимание на значение параметра По умолчанию, которое служит идентификатором расширения.
Для .exe файла данным значением будет exefile, следовательно все параметры необходимо создавать в разделе с идентичным именем.
5) Перейдите в ветку HKEY_CLASSES_ROOT\exefile.
6) Создайте новый параметр типа DWORD (32 бита) c именем DefaultDropEffect
7) Щелкните правой кнопкой мыши по параметру DefaultDropEffect и выберите пункт Изменить...
8) В текстовом поле Значение: задайте необходимое Вам значение:

1 - копирование;
2 - перемещение;
4 - создание ярлыка.

Действие по умолчанию для всех файлов при перетаскивании.

1) Запустите редактор реестра (Win+R -> regedit -> ОК)
2) Откройте ветку HKEY_CLASSES_ROOT\*.
3) Создайте новый параметр типа DWORD c именем DefaultDropEffect
4) Создайте новый параметр типа DWORD (32 бита) c именем DefaultDropEffect
5) Щелкните правой кнопкой мыши по параметру DefaultDropEffect и выберите пункт Изменить...
6) В текстовом поле Значение: задайте необходимое Вам значение:

1 - копирование;
2 - перемещение;
4 - создание ярлыка.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


9. Отключение пункта "Исправление неполадок совместимости" из контекстного меню ярлыков и исполняемых файлов.

Для отключения пункта "Исправление неполадок совместимости" из контекстного меню ярлыков и исполняемых файлов создайте и примените reg-файл следующего содержания:

Для возвращения пункта "Исправление неполадок совместимости" обратно, создайте и примените reg-файл следующего содержания:

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


10. Удаление и восстановление стрелок на ярлыках Windows.

Готовые файлы для убирания стрелок вы можете скачать по ссылке:
Shortcut_Arrows.zip
1) Распакуйте и откройте папку нужного вам варианта
2) Для удаления стрелок с ярлыков запустите Remove_Shortcut_Arrow.bat или Remove_Shortcut_Arrow.reg
3) Для восстановления стрелок на ярлыках запустите Restore_Shortcut_Arrow.bat или Restore_Shortcut_Arrow.reg

Вариант 1

Для удаления стрелок с ярлыков:

1) Запустите диалоговое окно "Выполнить" (Win + R)
2) Скопируйте код указанный ниже и нажмите OK

Для восстановления стрелок на ярлыках:

Или в ручную удалите данную ветку.

Вариант 2

Для удаления стрелок с ярлыков:

1) Создайте пустой файл иконки назовите его Blank.ico
2) Скопируйте его в папку C:\Windows
3) Запустите диалоговое окно "Выполнить" (Win + R)
4) Скопируйте код указанный ниже и нажмите OK

Для восстановления стрелок на ярлыках:

1) Удалите файл Blank.ico из папки C:\Windows
2) Запустите диалоговое окно "Выполнить" (Win + R)
3) Скопируйте код указанный ниже и нажмите OK

Или в ручную удалите данную ветку.

Побочным эффектом при использовании данного варианта является, появление черных квадратиков вместо стрелочек, если в папке Windows у Вас будет отсутствовать файл Blank.ico.

Вариант 3

1) Скопируйте текст в блокнот.
2) Сохраните как Remove_Shortcut_Arrow.reg (для удаления) или Restore_Shortcut_Arrow.reg (для восстановления).
3) Выполните файл, чтобы его содержание было внесено в реестр.
4) Обратите внимание на знак минуса в команде "IsShortCut"=-. Вокруг него нет кавычек. Эта команда удаляет значение IsShortCut и сам ключ IsShortCut. Если вы введёте команду "IsShortCut"="-", то тогда ключ удалён не будет, а его значение поменяется на минус. "IsNotShortCut"="" создаёт ключ и присваивает ему нулевое значение.

Файл .reg для удаления стрелок с ярлыков

Файл .reg для восстановления стрелок на ярлыках

Побочным эффектом при использовании данного варианта является, исчезновение пункта "Закрепить программу в панели задач". Если Вам необходимо будет закрепить какую-либо программу в Панели задач, то воспользуйтесь reg-файлом для восстановления стрелок на ярлыках, закрепите программу, а затем снова воспользуйтесь reg-файлом для удаления стрелок с ярлыков.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


11. Удаление папок из Рабочего стола в области переходов проводника.

Если Вы хотите, удалить папки из рабочего стола в области переходов проводника, воспользуйтесь одним из предложенных ниже вариантов.

Вариант 1

1) Нажмите Win+R
2) Введите regedit и нажмите Ок
3) Пройдите к ветке реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace
4) Сделайте себе её экспорт, на случай восстановления(ПКМ на данной ветке-Экспортировать).
5) Удалите следующие ветки:

Favorites(Избранное) | {323CA680-C24D-4099-B94D-446DD2D7249E}
Libraries(Библиотеки) | {031E4825-7B94-4dc3-B131-E946B44C8DD5}
Homegroup(Домашняя группа) | {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}
Shared Documents(Общие Документы) | {59031a47-3f72-44a7-89c5-5595fe6b30ee}
Computer(Компьютер) | {20D04FE0-3AEA-1069-A2D8-08002B30309D}
Network(Сеть) | {F02C1A0D-BE21-4350-88B0-7367FC96EF3C}
Control Panel(Панель управления) | {26EE0668-A00A-44D7-9371-BEB064C98683}
Recycle Bin(Корзина) | {645FF040-5081-101B-9F08-00AA002F954E}

Вариант 2

Создайте и примените reg-файлы следующего содержания:

Для удаления Favorites(Избранное):

Для восстановления Favorites(Избранное) по умолчанию:

Для удаления Libraries(Библиотеки):

Для восстановления Libraries(Библиотеки) по умолчанию:

Для удаления Homegroup(Домашняя группа):

Для восстановления Homegroup(Домашняя группа) по умолчанию:

Для удаления Computer(Компьютер):

Для восстановления Computer(Компьютер) по умолчанию:

Для удаления Network(Сеть):

Для восстановления Network(Сеть) по умолчанию:

Для удаления Recycle Bin(Корзина):

Для восстановления Recycle Bin(Корзина) по умолчанию:

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


12. Отключение суффикса "-Ярлык" при создании новых ярлыков.

1) Запустите редактор реестра (Regedit).
2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
3) В правой части окна, дважды щелкните на параметр реестра "link".
4) Измените значение на 00 00 00 00.
5) Перезагрузите компьютер.

Вы можете также создать и применить reg-файл следующего содержания:

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


13. Отключение всплывающих подсказок для элeмeнтoв paбoчeгo cтoлa.

1) Запустите редактор реестра (Regedit).
2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) В правой части окна, дважды щелкните на параметр реестра "ShowInfoTip".
4) Измените значение на 0.
5) Перезагрузите компьютер.

Вы можете также создать и применить reg-файл следующего содержания:

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


14. Отключение диалога "Не удалось открыть файл".

Если системе не знаком тип файла, который вы пытаетесь открыть, то сначала выводится диалоговое окно для поиска программы в интернете.

Система предлагает Вам:

Поиск соответствия в интернете. Если вы выберите этот вариант, то запускается веб-служба
shell. windows. com/fileassoc/0409/xml/redir. asp? Ext=fb2 (пример для случая с FB2-файлом).
Выбор программы из списка установленных программ. Открывает окно выбора программы для открытия файла на локальном компьютере.

Для того чтобы не выводить окно для поиска файла в интернете, а сразу открывать окно выбора программы, воспользуйтесь одним из предложенных решений:

1) Откройте редактор реестра (Win+R -> regedit)
2) Перейдите к ветке этого создайте параметр HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте DWORD-параметр NoInternetOpenWith и установите его значение равным 1.

или

1) Нажмите кнопку "Пуск", и в строке поиска напечатайте cmd.exe.
2) Щелкните на найденной программе правой кнопкой мыши и нажмите Запуск от имени администратора
3) В командой строке напечатайте следующее:

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


15. Максимально возможное отключение сглаживания шрифтов (ClearType) в Windows 7.

Если Вы хотите максимально возможно отключить использование ClearType в aero-темах Windows 7, то Вам необходимо сделать следующее.

Вариант 1.

1) Отключите ClearType в системе.
1.1) Откройте Панель управления -> Шрифты -> Настройка текста ClearType
1.2) Снимите флажок "Включить ClearType".
2) Отключите сглаживание любого типа шрифта.
2.1) Откройте Панель управления -> Система -> Дополнительные параметры системы
2.2) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры
2.3) На вкладке Визуальные эффекты в списке снимите флажок Сгладить неровности экранных шрифтов
3) Измените шрифт элементов окна.
3.1) Откройте Панель управления -> Персонализация -> Цвет окна ->Дополнительные параметры оформления
3.2) Установите для всех элементов вместо шрифта Segoe UI любой другой шрифт. Например: Tahoma; для всех элементов установите размер 8, для элементов "Заголовок активного окна" и "Заголовок неактивного окна", оставьте размер 9.
4) Запустите Редактор реестра (Win+R -> regedit -> Ok)
5) Откройте ветку: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts
6) Удалите присвоенные значения для указанных ниже параметров:

Для изменения значения параметра щелкните на необходимом Вам параметре правой кнопкой мыши и нажмите Изменить.

7) Откройте ветку: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes
8) Создайте строковый (String) параметр с именем Segoe UI
9) Щелкните на нем правой кнопкой мыши и нажмите Изменить.
10) Установите значение параметра Tahoma и нажмите ОК.
11) Перезагрузите компьютер.

Примечание:

П.1) Если крупный шрифт покажется Вам с нечеткими краями установите снятый флажок Сгладить неровности экранных шрифтов обратно.
П.2) Если шрифт в проводнике и панели задач кажется расплывчатым, измените в ветке HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes значение параметра Segoe UI с Tahoma на MS Sans Serif
П.3) При выборе шрифтов Tahoma или MS Sans Serif в калькуляторе пропадает изображение стрелки на клавише стереть последнюю цифру.
П.4) Указанные действия применимы для 100% размера шрифта. Если у Вас стоит увеличение масштаба шрифта (чаще у широкоформатных мониторов), то проделайте следующее:
П.4.1) Верните масштаб шрифта в 100% значение.
П.4.2) Примените указанное в данном совете решение, включая перезагрузку.
П.4.3) Установите необходимый Вам масштаб

Вы можете скачать готовые reg-файлы, которые выполняют описанные выше действия: ClearType_on-off.zip
Описание содержимого архива:

ClearType-off.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов включен.
ClearType_off+FS.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов отключен.
ClearType_off+font.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов включен, изменен шрифт на MS Sans Serif.
ClearType_off+FS+font.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов отключен, изменен шрифт на MS Sans Serif.
ClearType-restore.reg - Восстановить исходные значения по умолчанию.

Вариант 2. Ручная установка и удаление Windows Aero (Tahoma Font).

Главным плюсом в отличие от предыдущего варианта является полное удаление привязки системы к шрифту Segoe UI и наличие изображения стрелки в калькуляторе.

Установка Windows Aero (Tahoma Font).

1) Скачайте и распакуйте в любую папку файл Windows Aero (Tahoma Font).zip
2) Откройте папку Manual и в соответствии с разрядностью Вашей системы запустите Universal Theme Patcher. Данное действие позволит использовать Вам неподписанные темы.
3) Нажмите кнопку Да (Yes), а затем напротив каждого из файлов кнопку Patch.
4) Переключите интерфейс Вашей системы на классическую тему.
5) Откройте папку C:\Windows\Resources\Themes\Aero\. Задайте полный доступ к файлу aero.msstyles для этого воспользуйтесь советом Администрирование: 1. Получение полного доступа к файлу или папке.
6) Переименуйте файл aero.msstyles в aero.msstyles.backup.
7) Скопируйте модифицированный файл aero.msstyles из папки Manual в папку C:\Windows\Resources\Themes\Aero\.
8) Примените reg-файл "NoSegoe - Tahoma.reg".
9) Откройте Панель управления -> Шрифты -> Настройка текста ClearType и снимите флажок "Включить ClearType". Нажмите несколько раз кнопку Далее, а затем кнопку Готово.
10) Перезагрузите компьютер.
11) Переключите обратно на Aero-тему.

Удаление Windows Aero (Tahoma Font).

1) Переключите интерфейс Вашей системы на классическую тему.
2) Откройте папку C:\Windows\Resources\Themes\Aero\. Задайте полный доступ к файлу aero.msstyles для этого воспользуйтесь советом Администрирование: 1. Получение полного доступа к файлу или папке.
3) Удалите файл aero.msstyles
4) Переименуйте файл aero.msstyles.backup обратно в aero.msstyles.
5) Откройте папку Manual из папки, где распакован архив и примените reg-файл "NoSegoe - Restore Segoe UI.reg".
6) В соответствии с разрядностью Вашей системы запустите Universal Theme Patcher. Данное действие позволит использовать Вам неподписанные темы.
7) Нажмите кнопку Да (Yes), а затем напротив каждого из файлов кнопку Restore.
8) Откройте Панель управления -> Шрифты -> Настройка текста ClearType и установите флажок "Включить ClearType". Нажмите несколько раз кнопку Далее, а затем кнопку Готово.
9) Перезагрузите компьютер.
10) Переключите обратно на Aero-тему.

Вариант 3. Автоматическая установка Windows Aero (Tahoma Font).

Установка Windows Aero (Tahoma Font).

1) Скачайте и распакуйте в любую папку файл Windows Aero (Tahoma Font).zip
2) Откройте папку Auto.
3) Нажмите правой кнопкой мыши на файле Windows Aero (Tahoma Font).exe и выберите пункт Запуск от имени администратора
4) Нажмите клавишу Next в первом окне, во втором окне установите переключатель в значение I accept the agreement и нажмите кнопку Next.
5) В окне Information также нажмите кнопку Next.
6) В окне Select Components установите все флажки и нажмите кнопку Next.
7) В окне Ready to Install нажмите кнопку Install и запустится установка.
8) В окне Windows Aero (Tahoma Font) Setup информирующем о переключении интерфейса на классическую тему нажмите кнопку ОК.
9) После того как программа переключится на классическую тему вернитесь обратно в программу.
10) В окне Windows Aero (Tahoma Font) Setup информирующем о необходимости нажатия кнопки Yes при запуске скриптов для данной программы нажмите кнопку ОК.
11) Установите переключатель в значение Yes, restart the computer now и нажмите кнопку Finish.
12) Компьютер перезагрузится и если у Вас включен Контроль учетных записей (UAC), то в окнах предлагающих запустить Microsoft Windows Based Script Host нажмите кнопку Да (Yes).

Удаление Windows Aero (Tahoma Font).

1) Откройте Панель управления -> Программы и компоненты и щелкните на Windows Aero (Tahoma Font)
2) В появившемся окне нажмите Да, а в следующем ОК.
3) В окне Windows Aero (Tahoma Font) Setup информирующем о необходимости нажатия кнопки Yes при запуске скриптов для данной программы нажмите кнопку ОК.
4) В окне предлагающем перезапустить компьютер нажмите Да
5) Компьютер перезагрузится и если у Вас включен Контроль учетных записей (UAC), то в окнах предлагающих запустить Microsoft Windows Based Script Host нажмите кнопку Да (Yes).

Примечание:

П. Если после установки или удаления программа не переключила обратно на Вашу aero-тему, то сделайте это вручную.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


16. Изменение набора кнопок на панели проводника Windows 7.

Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

На панели проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
В зависимости от месторасположения папок используемых Вами для хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения набора кнопок во всех папках проводника добавьте или удалите кнопки во все шаблоны.

Все шаблоны хранятся в разделах следующей ветки реестра:

Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

Для изменения отображаемых кнопок сделайте следующее:

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку необходимого Вам шаблона.
Например: для добавления или удаления кнопки в обычную папку использующую шаблон типа папки «Общие элементы» откройте:

А для добавления или удаления кнопки в папку «Общие элементы», входящей в Библиотеки откройте:

3) Задайте полные права на доступ к этому разделу реестра.

3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

4.1) Откройте необходимый из указанных подразделов, если Вы изменяете набор кнопок в шаблонах Библиотек и/или в шаблонах поиска результатов в них.
4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать -> Раздел.)

TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Изменить.
6) Добавьте к существующим значениям необходимые или удалите ненужные.
Порядок значений в списке соответствует порядку отображения кнопок на панели. Значения отделяются друг от друга точкой с запятой (;).
Например: Windows.Copy;Windows.Paste;Windows.Delete;

Список возможных кнопок для добавления Вы можете узнать из названий подразделов в ветке реестра:

В таблице ниже указаны значения наиболее часто используемых кнопок.

Кнопка | Действие | Использование
Windows.burn | Записать на оптический диск | TasksItemsSelected
Windows.closewindow | Закрыть (окно) <ALT+F4> | TasksItemsSelected, TasksNoItemsSelected
Windows.copy | Вырезать <CTRL+C> | TasksItemsSelected
Windows.cut | Копировать <CTRL+X> | TasksItemsSelected
Windows.delete | Удалить <Del> | TasksItemsSelected
Windows.email | Электронная почта | TasksItemsSelected
Windows.folderoptions | Параметры папок и поиска | TasksNoItemsSelected
Windows.includeinlibrary | Включить в библиотеку | TasksItemsSelected
Windows.layout | Представление (вкл. и выкл. областей проводника) | TasksNoItemsSelected
Windows.librarypane | Область библиотек (под панелью кнопок) | TasksNoItemsSelected
Windows.menubar | Строка меню (ALT) | TasksNoItemsSelected
Windows.navpane | Область переходов | TasksNoItemsSelected
Windows.newfolder | Создать новую папку | TasksNoItemsSelected
Windows.paste | Вставить (CTRL+V) | TasksItemsSelected, TasksNoItemsSelected
Windows.previewpane | Область сведений | TasksNoItemsSelected
Windows.print | Печать | TasksItemsSelected
Windows.properties | Свойства (файла, папки, библиотеки) <ALT+Enter> | TasksItemsSelected, TasksNoItemsSelected
Windows.readingpane | Область предпросмотра <Alt+P> | TasksNoItemsSelected
Windows.redo | Вернуть (возврат последнего отмененного действия) <CTRL+Y> | TasksNoItemsSelected
Windows.removeproperties | Удалить свойства (файла, папки, библиотеки) | TasksItemsSelected, TasksNoItemsSelected
Windows.rename | Переименовать <F2> | TasksItemsSelected
Windows.selectall | Выделить все <CTRL+A> | TasksNoItemsSelected
Windows.separator | Разделитель (кнопка без подписи и действия) | TasksItemsSelected, TasksNoItemsSelected
Windows.Share | Общий доступ | TasksItemsSelected
Windows.slideshow | Показ слайдов | TasksItemsSelected, TasksNoItemsSelected
Windows.undo | Отменить <CTRL+Z> | TasksNoItemsSelected

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


17. Изменение состава меню "Упорядочить" на панели Проводника Windows 7.

Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

На панели проводника почти везде присутствуют кнопка Упорядочить, при нажатии на которую появляется меню с определенным набором выполняемых команд и подменю Представление.

Для изменения пунктов отображающихся в данном меню сделайте следующее:

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку:

Для внесения изменений в меню Упорядочить:

Для внесения изменений в меню Представление:

3) Задайте полные права на доступ к выбранному разделу реестра.

3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

4) Щелкните правой кнопкой мыши на параметре SubCommands и выберите Изменить.
5) Добавьте к существующим значениям необходимые или удалите ненужные.
Порядок значений в списке соответствует порядку отображения пунктов списка. Значения отделяются друг от друга точкой с запятой (;) , символ | означает разделитель меню, после него также ставится точка с запятой.

Список значений параметра SubCommands для меню Упорядочить по умолчанию:

Список значений параметра SubCommands для подменю Упорядочить по умолчанию:

Список пунктов возможных для добавления Вы можете узнать из названий подразделов в ветке реестра:

В таблице ниже указаны значения наиболее часто используемых пунктов.

Кнопка | Действие | Использование
Windows.burn | Записать на оптический диск | TasksItemsSelected
Windows.closewindow | Закрыть (окно) <ALT+F4> | TasksItemsSelected, TasksNoItemsSelected
Windows.copy | Вырезать <CTRL+C> | TasksItemsSelected
Windows.cut | Копировать <CTRL+X> | TasksItemsSelected
Windows.delete | Удалить <Del> | TasksItemsSelected
Windows.email | Электронная почта | TasksItemsSelected
Windows.folderoptions | Параметры папок и поиска | TasksNoItemsSelected
Windows.includeinlibrary | Включить в библиотеку | TasksItemsSelected
Windows.layout | Представление (вкл. и выкл. областей проводника) | TasksNoItemsSelected
Windows.librarypane | Область библиотек (под панелью кнопок) | TasksNoItemsSelected
Windows.menubar | Строка меню (ALT) | TasksNoItemsSelected
Windows.navpane | Область переходов | TasksNoItemsSelected
Windows.newfolder | Создать новую папку | TasksNoItemsSelected
Windows.paste | Вставить (CTRL+V) | TasksItemsSelected, TasksNoItemsSelected
Windows.previewpane | Область сведений | TasksNoItemsSelected
Windows.print | Печать | TasksItemsSelected
Windows.properties | Свойства (файла, папки, библиотеки) <ALT+Enter> | TasksItemsSelected, TasksNoItemsSelected
Windows.readingpane | Область предпросмотра <Alt+P> | TasksNoItemsSelected
Windows.redo | Вернуть (возврат последнего отмененного действия) <CTRL+Y> | TasksNoItemsSelected
Windows.removeproperties | Удалить свойства (файла, папки, библиотеки) | TasksItemsSelected, TasksNoItemsSelected
Windows.rename | Переименовать <F2> | TasksItemsSelected
Windows.selectall | Выделить все <CTRL+A> | TasksNoItemsSelected
Windows.separator | Разделитель (кнопка без подписи и действия) | TasksItemsSelected, TasksNoItemsSelected
Windows.Share | Общий доступ | TasksItemsSelected
Windows.slideshow | Показ слайдов | TasksItemsSelected, TasksNoItemsSelected
Windows.undo | Отменить <CTRL+Z> | TasksNoItemsSelected

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


18. Изменение отображаемых по умолчанию свойств для файла в проводнике.

При выделении файла в проводнике, система отображает в области сведений соответствующую ему информацию. Также сведения отображаются при наведении на него курсора мыши или на вкладке Подробно в окне Свойства, вызываемом из контекстного меню.

Для настройки сведений, отображаемых для файла в проводнике, сделайте следующее:

1) 1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте раздел соответствующий наименованию необходимого Вам расширения файла в указанных ниже ветках реестра:

2.1) чтобы изменить отображаемые сведения для всех пользователей на компьютере (если Вы администратор компьютера):

2.2) чтобы изменить отображаемые сведения для текущей записи:

Например, для расширения .mp3 откройте:

3) Измените значения параметров:

InfoTip - отвечает за информацию отображаемую во всплывающей подсказке
PreviewDetails - отвечает за информацию отображаемую в области сведений проводника
FullDetails - отвечает за информацию отображаемую во вкладке Подробно в Свойствах файла

4) Щелкните правой кнопкой мыши на выбранном параметре и выберите Изменить.
5) После слова prop: добавьте к существующим значениям необходимые или удалите ненужные.
Порядок значений в списке соответствует порядку отображения пунктов в системе. Значения отделяются друг от друга точкой с запятой.

Например, для файлов с расширением .mp3 Вы можете выставить значение:

В таблице ниже, указаны значения наиболее часто используемых значений данных параметров.

Наименование значения параметра | Отображаемое значение
System.Audio.ChannelCount | Каналы, количество
System.Audio.EncodingBitrate | Скорость потока
System.Audio.EncodingBitrate | Скорость потока
System.Audio.SampleRate | Частота дискретизации
System.Author | Авторы
System.Comment | Комментарии
System.ComputerName | Компьютер
System.Copyright | Авторские права
System.DateCreated | Дата создания
System.DateModified | Дата изменения
System.FileAttributes | Атрибуты
System.FileOwner | Владелец
System.Image.BitDepth | Глубина цвета
System.Image.Dimensions | Размеры
System.Image.HorizontalResolution | Горизонтальное разрешение
System.Image.HorizontalSize | Ширина
System.Image.ResolutionUnit | Единица разрешения
System.Image.VerticalResolution | Разрешение по вертикали
System.Image.VerticalSize | Высота
System.ItemFolderPathDisplay | Путь к папке
System.ItemNameDisplay | Имя
System.ItemType | Тип элемента
System.Keywords | Ключевые слова
System.Media.DateEncoded | Дата создания мультимедиа
System.Media.Duration | Продолжительность
System.Media.SubTitle | Субтитры
System.Media.Year | Год
System.Music.Artist | Участвующие исполнители
System.Music.Genre | Жанр
System.Photo.DateTaken | Дата съемки
System.PropGroup.Audio | Группа Аудио
System.PropGroup.Content | Группа Содержание
System.PropGroup.Description | Группа Описание
System.PropGroup.FileSystem | Группа Файл
System.PropGroup.Image | Группа Изображение
System.PropGroup.Media | Группа Носитель
System.PropGroup.Origin | Группа Источник
System.PropGroup.Video | Группа Видео
System.Rating | Оценка
System.SharedWith | Общий доступ
System.Size | Размер
System.Subject | Тема
System.Title | Название
System.Video.EncodingBitrate | Скорость передачи данных
System.Video.FrameHeight | Высота кадра
System.Video.FrameRate | Частота кадров
System.Video.FrameWidth | Ширина кадра
System.Video.TotalBitrate | Общая скорость потока

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


19. Изменение используемых по умолчанию столбцов в проводнике для папок, при выборе отображения в виде таблицы.

Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

При выборе в проводнике вида отображения Таблица, система показывает определенные столбцы. Вы можете настроить для любой папки свой собственный набор столбцов, щелкнув правой кнопкой мыши на любом из них и во всплывающем меню выбрав пункт Подробнее..., если же Вам необходимо изменить столбцы отображаемые по умолчанию, то Вам необходимо внести соответствующие изменения в реестр.

Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
В зависимости от месторасположения папок используемых Вами для хранения файлов, измените набор столбцов в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения набора столбцов во всех папках проводника добавьте или удалите значения во всех шаблонах.

Все шаблоны хранятся в разделах следующей ветки реестра:

Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

Для настройки столбцов, используемых по умолчанию в проводнике, сделайте следующее:

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку необходимого Вам шаблона.
Например: для добавления или удаления столбцев в обычной папке использующей шаблон типа папки «Музыка» откройте:

А для добавления или удаления столбцев в папке «Музыка», входящей в Библиотеки откройте:

3) Задайте полные права на доступ к этому разделу реестра.

3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

4) Перейдите в раздел TopViews
5) Поочередно открывая подразделы типа {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX} измените значения параметра ColumnList (щелчок правой кнопкой мыши на параметре -> Изменить) стоящие после слова prop: .
6) Для включения необходимого Вам столбца измените значение стоящее перед ним на 0. Цифра 0 перед указанным Вами параметром сообщит системе, что данный столбец необходимо отобразить. Если необходимый Вам столбец отсутствует, то Вы можете добавить его самостоятельно, указав перед ним цифру 0. Значения отделяются друг от друга точкой с запятой (;). Например: для изменения столбцов как на рисунке, в начале совета значение параметра ColumnList примет вид:

В таблице ниже, указаны значения наиболее часто используемых значений данного параметра.

Наименование значения параметра | Отображаемое значение
System.Audio.ChannelCount | Каналы, количество
System.Audio.EncodingBitrate | Скорость потока
System.Audio.EncodingBitrate | Скорость потока
System.Audio.SampleRate | Частота дискретизации
System.Author | Авторы
System.Comment | Комментарии
System.ComputerName | Компьютер
System.Copyright | Авторские права
System.DateCreated | Дата создания
System.DateModified | Дата изменения
System.FileAttributes | Атрибуты
System.FileOwner | Владелец
System.Image.BitDepth | Глубина цвета
System.Image.Dimensions | Размеры
System.Image.HorizontalResolution | Горизонтальное разрешение
System.Image.HorizontalSize | Ширина
System.Image.ResolutionUnit | Единица разрешения
System.Image.VerticalResolution | Разрешение по вертикали
System.Image.VerticalSize | Высота
System.ItemFolderPathDisplay | Путь к папке
System.ItemNameDisplay | Имя
System.ItemType | Тип элемента
System.Keywords | Ключевые слова
System.Media.DateEncoded | Дата создания мультимедиа
System.Media.Duration | Продолжительность
System.Media.SubTitle | Субтитры
System.Media.Year | Год
System.Music.Artist | Участвующие исполнители
System.Music.Genre | Жанр
System.Photo.DateTaken | Дата съемки
System.PropGroup.Audio | Группа Аудио
System.PropGroup.Content | Группа Содержание
System.PropGroup.Description | Группа Описание
System.PropGroup.FileSystem | Группа Файл
System.PropGroup.Image | Группа Изображение
System.PropGroup.Media | Группа Носитель
System.PropGroup.Origin | Группа Источник
System.PropGroup.Video | Группа Видео
System.Rating | Оценка
System.SharedWith | Общий доступ
System.Size | Размер
System.Subject | Тема
System.Title | Название
System.Video.EncodingBitrate | Скорость передачи данных
System.Video.FrameHeight | Высота кадра
System.Video.FrameRate | Частота кадров
System.Video.FrameWidth | Ширина кадра
System.Video.TotalBitrate | Общая скорость потока

7) Перезагрузите компьютер
8) Для папок из библиотек, щелкните правой кнопкой мыши внутри основной папки (Видео, Документы, Изображения, Музыка) выберите Упорядочить -> Очистить изменения
9) Для обычных папок измените шаблон на другой вид в Свойства -> Настройка, а затем верните обратно.
10) Также очистите в реестре указанный ниже раздел, удалив все папки кроме AllFolders.

Очистка данного раздела реестра удалит все настройки для папок сделанные пользователями, до применения данного совета.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


20. Изменение пунктов контекстного меню "Сортировка" используемых по умолчанию в проводнике.

Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

При нажатии правой кнопки мыши в любой папке в проводнике, система показывает контекстное меню. В данном меню есть пункт Сортировка, содержащий свое собственное меню. Вы можете настроить для любой папки свой собственный вид меню Сортировка, выбрав в нем пункт Подробнее..., если же Вам необходимо изменить вид данного меню отображаемый по умолчанию для всех папок, то Вам необходимо внести соответствующие изменения в реестр.

Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
В зависимости от месторасположения папок используемых Вами для хранения файлов, измените вид меню Сортировка в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения набора пунктов во всех папках проводника добавьте или удалите значения во всех шаблонах.

Все шаблоны хранятся в разделах следующей ветки реестра:

Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

Для настройки меню Сортировка, используемого по умолчанию в проводнике, сделайте следующее:

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку необходимого Вам шаблона.
Например: для добавления или удаления пунктов в меню Сортировка для обычной папки использующей шаблон типа папки «Музыка» откройте:

А для добавления или удаления пунктов в меню Сортировка для папки «Музыка», входящей в Библиотеки откройте:

3) Задайте полные права на доступ к этому разделу реестра.

3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

4) Перейдите в раздел TopViews
5) Поочередно открывая подразделы типа {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX} измените значения параметра SortByList (щелчок правой кнопкой мыши на параметре -> Изменить) стоящие после слова prop: .
6) Добавьте к существующим значениям необходимые или удалите ненужные.
Порядок значений в списке соответствует порядку отображения пунктов в меню. Значения отделяются друг от друга точкой с запятой (;).
Например:

В таблице ниже, указаны значения наиболее часто используемых значений данного параметра.

Наименование значения параметра | Отображаемое значение
System.Audio.ChannelCount | Каналы, количество
System.Audio.EncodingBitrate | Скорость потока
System.Audio.EncodingBitrate | Скорость потока
System.Audio.SampleRate | Частота дискретизации
System.Author | Авторы
System.Comment | Комментарии
System.ComputerName | Компьютер
System.Copyright | Авторские права
System.DateCreated | Дата создания
System.DateModified | Дата изменения
System.FileAttributes | Атрибуты
System.FileOwner | Владелец
System.Image.BitDepth | Глубина цвета
System.Image.Dimensions | Размеры
System.Image.HorizontalResolution | Горизонтальное разрешение
System.Image.HorizontalSize | Ширина
System.Image.ResolutionUnit | Единица разрешения
System.Image.VerticalResolution | Разрешение по вертикали
System.Image.VerticalSize | Высота
System.ItemFolderPathDisplay | Путь к папке
System.ItemNameDisplay | Имя
System.ItemType | Тип элемента
System.Keywords | Ключевые слова
System.Media.DateEncoded | Дата создания мультимедиа
System.Media.Duration | Продолжительность
System.Media.SubTitle | Субтитры
System.Media.Year | Год
System.Music.Artist | Участвующие исполнители
System.Music.Genre | Жанр
System.Photo.DateTaken | Дата съемки
System.PropGroup.Audio | Группа Аудио
System.PropGroup.Content | Группа Содержание
System.PropGroup.Description | Группа Описание
System.PropGroup.FileSystem | Группа Файл
System.PropGroup.Image | Группа Изображение
System.PropGroup.Media | Группа Носитель
System.PropGroup.Origin | Группа Источник
System.PropGroup.Video | Группа Видео
System.Rating | Оценка
System.SharedWith | Общий доступ
System.Size | Размер
System.Subject | Тема
System.Title | Название
System.Video.EncodingBitrate | Скорость передачи данных
System.Video.FrameHeight | Высота кадра
System.Video.FrameRate | Частота кадров
System.Video.FrameWidth | Ширина кадра
System.Video.TotalBitrate | Общая скорость потока

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


21. Запрещение подмены функции кнопки "Завершения работы" при необходимости обновления системы.

При наличии обновлений, ожидающих установки, на кнопке завершения работы Windows появляется значок со щитом.

Если не применить данный твик реестра, то когда имеются обновления, доступные для установки, при выборе в меню Пуск команды Завершение работы по умолчанию выберется действие - Установить обновления и завершить работу.
Чтобы отключить данную функцию в диалоговом окне Завершение работы Windows и отобразить по умолчанию параметр, выбранный при последнем выключении (Гибернация, Перезагрузка и т. д.), вне зависимости от доступности параметра Установить обновления и завершить работу в списке создайте и примените reg-файл следующего содержания:

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


22. Постоянное отображение команд "Открыть окно команд" и "Копировать как путь" в контекстном меню проводника.

Если Вы будете удерживать клавишу Shift при нажатии правой кнопки мыши, то в контекстном меню появятся дополнительные пункты Открыть командную строку и Копировать как путь.

Чтобы пункт Открыть командную строку отображался без нажатия Shift создайте и примените нижеследующий reg-файл:

Чтобы заставить пункт Открыть командную строку снова отображаться только при нажатии Shift создайте и примените нижеследующий reg-файл:

Чтобы пункт Копировать как путь отображался без нажатия Shift создайте и примените нижеследующий reg-файл:

Минус такого решения - появляющееся на доли секунды окно командной строки.

Чтобы заставить пункт Копировать как путь снова отображаться только при нажатии Shift создайте и примените нижеследующий reg-файл:

Если Вам не нравится появляющееся на долю секунды окно командной строки, то Вы можете воспользоваться утилитой NirCmd
Данная утилита позволяет выполнять команды командной строки без отображения окна команд.
Для отображения пункта Копировать как путь без нажатия Shift, сделайте следующее:

1) Скачайте утилиту NirCmd в соответствии с разрядностью Вашей Windows
2) Распакуйте скаченный zip-архив в папку C:\NirCmd
3) Запустите Редактор реестра (Win+R -> regedit -> Ok)
4) Откройте раздел HKEY_CLASSES_ROOT\AllFilesystemObjects\shell\CopyAsPath\Command
5) Измените значение параметра По умолчанию на:

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


23. Добавление произвольного системного элемента ActiveX в Рабочий стол области переходов проводника.

23. Добавление произвольного системного ActiveX-элемента в Рабочий стол области переходов проводника.

По умолчанию в проводнике отображается определенный набор объектов ActiveX: Избранное, Библиотеки, Компьютер и Сеть или более расширенный, если у Вас в настройках элемента Параметры папок установлен флажок Показать все папки.

Чтобы добавить какой-либо из системных объектов в область переходов, Вам необходимо знать его статистически уникальный 128-битный идентификатор - {GUID}.
Список всех идентификаторов ({GUID}) находится в разделе реестра: HKEY_CLASSES_ROOT\CLSID\{GUID}. Из данного списка в в область переходов, добавить Вы можете, те ActiveX-объекты, которые имеют интерфейс IShellFolder (интерфейс для объектов, расширяющих пространство имен оболочки). Данный факт определяется наличием в {GUID} разделе реестра подраздела ShellFolder.
Для экономии времени, необходимого на поиск нужного элемента Вы можете воспользоваться утилитой CSLID Dump, позволяющей получить список всех ActiveX-объектов, имеющих IShellFolder интерфейс.

1) Скачайте CSLID Dump, распакуйте архив и запустите программу.
2) Найдите в CLSID Dump, необходимый Вам {GUID} ActiveX-объекта и откройте его в реестре:
2.1) Нажмите в самой программе на кнопку Open Regedit
или
2.2) Запустите редактор реестра (Win+R -> regedit -> ОК) и откройте раздел

где вместо {GUID} вставьте найденное Вами значение.
3) Откройте в данном разделе подраздел ShellFolder.

Например: элементу "Все задачи" соответствует {GUID} равный {ED7BA470-8E54-465E-825C-99712043E01C}, следовательно необходимо открыть:

4) Задайте полные права на доступ к разделу HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder.

4.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
4.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
4.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
4.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
4.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

5) Если в разделе HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder присутствует строковый параметр WantsParseDisplayName, то удалите его.
6) Если в разделе HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder отсутствует строковый параметр PinToNameSpaceTree, то создайте его с пустым значением.

Включите отображение объекта для перечисления.

7) Если необходимо, измените значение параметра Attributes таким образом, чтобы третья цифра стала равна 0. Например: вместо 20100004 задайте 20000004 .

Добавьте Ваш ActiveX-объект в пространство имен Рабочего стола.

8) Перейдите в раздел:

9) Создайте здесь подраздел с названием идентичным Вашему {GUID}. Например:

Разрешите отображение Вашего объекта только в области переходов проводника, исключая отображение его на Рабочем столе.

11) Перейдите в раздел:

12) Создайте здесь DWORD-параметр с названием идентичным Вашему {GUID} и задайте ему значение равное 1.
13) Закройте редактор реестра.
14) Выйдите из системы и войдите в неё заново или перезагрузите компьютер.

Описанным выше способом, Вы можете добавить почти любой из ActiveX-объектов имеющих интерфейс IShellFolder.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


24. Изменение вида приглашения в командной строке.

Вы можете изменить вид приглашения для командной строки. Как правило используется формат типа C:\> (текущий диск и угловая скобка).

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте раздел HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
3) Создайте PROMPT типа REG_EXPAND_SZ (расширяемый строковый параметр)
4) Присвойте ему любое из следующих значений (значения можно объединять):

$B - | (вертикальная черта)
$D - текущая дата
$G - > (знак больше)
$L - < (знак меньше)
$N - текущий диск
$P - текущий диск и путь
$Q - = (знак равно)
$T - текущее время
$V - версия Windows
$$ - $ (знак доллара)
$A - & (амперсанд)
$C - ( (левая скобка)
$F - ) (правая скобка)
$S - пробел
[%computername%] - имя Вашего компьютера
$_ - переход к началу новой строки экрана

5) Перезагрузите компьютер.

Например при введении знгачения:

Вы увидите строку наподобие:

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


25. Изменение языка интерфейса установленного по умолчанию (язык системы), для возможности его удаления или правильного определения программами.

Иногда бывает, если у Вас установлена английская версия и сверху русский языковой пакет, то некоторые программы, имеющие встроенную функцию определения языка могут некорректно определить язык Вашей системы и автоматически запускаться с английским языком интерфейса.
Также, если Вы решите удалить английский язык из системы после установки сверху русского языкового пакета, то система не позволит Вам этого сделать. Это происходит потому, что для Windows английский язык - это язык системы или язык интерфейса установленный по умолчанию, а русский язык - дополнительный язык интерфейса.

Чтобы переключить язык интерфейса установленного по умолчанию создайте и примените reg-файл, после чего перезагрузите компьютер.

Чтобы установить русский язык, в качестве языка используемого по умолчанию (язык системы):

Чтобы установить английский язык, в качестве языка используемого по умолчанию (язык системы):

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


26. Настройка вида, используемого по умолчанию для папок в проводнике и в диалоговом окне "Открыть/Сохранить файл".

При нажатии правой кнопки мыши в любой папке в проводнике, система показывает контекстное меню. В данном меню есть пункт Вид, используя который Вы можете настроить для любой папки свой собственный вид. Но если же Вам необходимо изменить вид папки используемый по умолчанию для всех папок, то Вам необходимо внести соответствующие изменения в реестр.

Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
В зависимости от месторасположения папок используемых Вами для хранения файлов, измените значения в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения вида папок по умолчанию во всех папках проводника добавьте или удалите значения во всех шаблонах.

Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

Для настройки используемого по умолчанию вида папки, сделайте следующее:

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) В зависимости от того, для чего Вы хотите настроить используемый по умолчанию вид папки, откройте соответствующий раздел реестра.

Для использования по умолчанию в проводнике:

Для использования по умолчанию в стандартном диалоге "Открыть/Сохранить файл":

3) Создайте раздел, соответствующий GUID выбранного Вами шаблона. Например, для настройки вида папок использующих наиболее часто встречающийся шаблон "Общие элементы" создайте:

Для использования по умолчанию в проводнике:

Для использования по умолчанию в стандартном диалоге "Открыть/Сохранить файл":

4) Создайте в данном разделе три параметра DWORD: IconSize,LogicalViewMode и Mode и задайте им значения в соответствии с нижеследующей таблицей. Для удобства использования значения предоставлены в двух системах исчисления.

Вид папки: | Система исчисления | IconSize | LogicalViewMode | Mode
Огромные значки | Десятичная | 256 | 3 | 1
 | Шестнадцатеричная | 100 | 3 | 1
Крупные значки | Десятичная | 96 | 3 | 1
 | Шестнадцатеричная | 60 | 3 | 1
Обычные значки | Десятичная | 48 | 3 | 1
 | Шестнадцатеричная | 30 | 3 | 1
Мелкие значки | Десятичная | 16 | 3 | 1
 | Шестнадцатеричная | 10 | 3 | 1
Список | Десятичная | 16 | 4 | 3
 | Шестнадцатеричная | 10 | 4 | 3
Таблица | Десятичная | 16 | 1 | 4
 | Шестнадцатеричная | 10 | 1 | 4
Плитка | Десятичная | 48 | 2 | 6
 | Шестнадцатеричная | 30 | 2 | 6
Содержимое | Десятичная | 32 | 5 | 8
 | Шестнадцатеричная | 20 | 5 | 8

Например, чтобы установить вид папки Крупные значки создайте DWORD-параметры IconSize=60, LogicalViewMode=3 и Mode=1.

5) Перезагрузите компьютер или перезайдите в систему.

Примечание:

Если Вы ранее в проводнике вручную изменяли вид для какой-либо папки, то система записала Ваши изменения в реестр, и чтобы желаемый Вами вид папки установился также и в них, то Вам необходимо, выполнить на выбор одно из предложенных действий:

1) Удалить из раздела HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags все папки, кроме AllFolders
2) Изменить параметры Mode, LogicalViewMode и IconSize на необходимые Вам значения в разделах:

где XXX - номер папки (раздела), в который записаны значения измененных Вами параметров.
{GUID} - данный GUID соответствует типу папки.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


27. Удаление открываемых путей из истории в адресной строке проводника.

Когда Вы вводите путь в адресную строку проводника, то он сохраняется в журнал расположений. И если Вы в дальнейшем нажмете на стрелку вниз в конце адресной строки, то откроется список предыдущих расположений.
Если Вам необходимо его очистить,то Вы можете либо полностью стереть историю открываемых путей или удалить отдельные записи.

Чтобы очистить всю Вашу историю посещений в проводнике, щелкните правой кнопкой мыши на адресной строке и выберите из меню пункт Удалить журнал.

Чтобы удалить отдельные записи:

1) Запустите редактор реестра (Win+R->regedit->ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\TypedPaths
3) Удалите параметры, в которых содержатся ненужные вам пути.
4) Перезайдите в систему или закройте все процессы проводника и запустите его снова.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


28. Добавление отображения логотипа и сопутствующей информации.

1) Создайте рисунок с нужным Вам логотипом.
2) Сохраните его с разрешением 120x120 в формате .bmp (Например, в папке C:\Windows\System32 под именем OEMLogo.bmp).
3) Запустите редактор реестра (Win+R -> regedit -> OK)
4) Откройте раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\OEMInformation
5) Создайте строковые параметры с необходимыми Вам значениями. Например:

Model - Название модели
Manufacturer - Название фирмы
SupportPhone - Телефон поддержки
SupportURL - Адрес сайта службы поддержки
SupportHours - Время работы тех.поддержки
Logo - Путь к Вашему логотипу.

6) Перезагрузите компьютер.

Также Вы можете создать и применить reg-файл.

Пример:

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Настройки и Интерфейс.


1. Распаковка Хотфиксов(обновлений Microsoft с расширением EXE) из контекстного меню.

Для распаковки инсталляций, удобно пользоваться Universal Extractor-ом, но последняя версия не все хотфиксы от MS распаковывает правильно и приходится пользоваться другими методами. Одним из вариантов является добавление в контекстное меню команды Unpack HotFix.
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Чтобы добавить данный пункт в контекстное меню, создайте следующий reg-файл:

Например, при распаковке Windows6.1-KB917607-x64.exe, на выходе получаем папку Windows6.1-KB917607-x64.exe_unpacked с извлечёнными файлами.
Минус один - команда Unpack HotFix встраивается в контекстное меню всех exe-файлов, а не только файлов от Microsoft.

Чтобы удалить данный пункт из контекстного меню, создайте следующий reg-файл:

Готовые reg-файлы Вы можете скачать по ссылке: Unpack_HotFix.zip

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


2. Добавление пункта "Открыть в блокноте" в контекстное меню файлов.

1) Создайте reg-файл.
1.1) Скопируйте код в любой текстовый редактор (например, Блокнот).
1.2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "Notepad.reg")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

2) Примените полученный reg-файл. Щелкните на нем дважды и нажми кнопку Да.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


3. Добавление системных ярлыков в папку Компьютер.

Создайте и примените reg-файлы следующего содержания:

Администрирование

Корзина

Панель управления

Принтеры и факсы

Учетные записи пользователей

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


4. Добавление произвольной команды в контекстное меню рабочего стола.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "fix.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

5) Примените его.

Вместо Название команды укажите необходимое Вам название пункта, которое будет отображаться в контекстном меню. Например: Панель управления
Вместо выполняемая команда укажите какая команда должна быть запущена при нажатии созданного Вами пункта в контекстном меню. Например: control
Вместо путь к значку иконки укажите путь к иконке, отображаемой рядом с Вашим пунктом в контекстном меню.
Вместо Расположение укажите месторасположение Вашего пункта в контекстном меню. Top - вверху, Bottom - внизу.

Описанным выше способом можно добавить практически любую команду.
Например, reg-файл для добавления пункта Панель управления в контекстное меню рабочего стола будет выглядеть так:

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


5. Распаковка файлов и директорий из CAB-архивов (а так же упаковка в CAB-архивов) из контекстного меню "Отправить".

Reg-файл добавляет в расширенное меню оболочки функции для упаковки и распаковки CAB.
С папками, в пути к которым есть пробелы и спецсимволы, к сожалению, не работает.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


6. Добавление пункта "Удалить содержимое папки" в контекстное меню.

Как добавить в контекстное меню папки команду для удаления содержимого папки без удаления самой папки? Вы можете создать себе пункт Удалить содержимое папки в контекстном меню и Вам достаточно будет его только выбрать. Вам не придется открывать папку, выделять все файлы и нажимать на клавишу Delete.

Вариант 1.

1) Запустите редактор реестра: Win+R -> regedit -> Ok
2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
3) Создайте в ней раздел DeleteFolderContent
4) Создайте в нем строковый(String) параметр MUIVerb со строкой Удалить содержимое папки.
5) В разделе DeleteFolderContent создайте подраздел command
6) Измените значение параметра (По умолчанию) раздела command на следующее:

Вариант 2.

1) Запустите редактор реестра: Win+R -> regedit -> Ok
2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
3) Создайте в ней раздел Удалить содержимое папки
4) В разделе Удалить содержимое папки создайте подраздел command
6) Измените значение параметра (По умолчанию) раздела command на следующее:

Вариант 3.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Вы можете скачать готовые reg-файлы: DeleteFolderContent.zip

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


7. Добавление пунктов "Копировать в папку" и "Переместить в папку" в контекстное меню.

По какой-то неизвестной причине, разработчики Microsoft решили не включать в контекстное меню Проводника пункты Копировать в папку (Copy To) и Переместить в папку (Move To). Используя их, можно легко и быстро скопировать или переместить файл или папку. Для этого, достаточно выбрать желаемое место их размещения в соответствующем диалоговом окне. Для того, чтобы добавить эти команды в контекстное меню, достаточно создать, соответствующие им параметры в реестре.

Вариант 1

1) Запустите Редактор Реестра (нажмите копку «Пуск» (Start), введите regedit в строке «Найти программы и файлы» и нажмите Enter).
2) Откройте ветку реестра HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers
3) Создайте в ней раздел со следующим именем (включая фигурные скобки):
Для добавления в контекстное меню пункта Копировать в папку

Для добавления в контекстное меню пункта Переместить в папку

4) Нажмите Enter
5) Перезагрузите Проводник Windows (Windows Explorer) или перезайдите в систему, и данные пункты появятся в контекстном меню.

Вариант 2

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


8. Добавление своего ярлыка папки или программы в папку Компьютер.

Если Вы часто пользуйтесь какой-либо программой, то помимо добавления её значка на рабочий стол, Вы также можете добавить его в папку Компьютер. Поскольку скопировать напрямую или создать ярлык в данной папке нельзя, то предлагаю Вам решение, как это возможно осуществить.

1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот):

2) Скачайте программу Microsoft Exchange Server GUID Generator
3) Распакуйте архив и запустите программу (GUIDGEN.EXE)
4) Установите переключатель на значение Registry Format
5) Нажмите на кнопку New GUID, и программа сгенерирует Вам новый GUID
6) Нажмите на кнопку Copy, и программа скопирует его в буфер обмена
7) Вставьте вместо {GUID}, сгенерированный программой GUID.
Теперь у Вас вместо {GUID}, должен быть цифровой идентификатор, например: {FF4A6226-C00B-409e-88A6-6C401C52BD98}
8) Замените значения "Наименование папки или программы", "Путь к иконке для ярлыка" и "Путь к папке или файлу программы" на необходимые Вам.
Внимание! При указывании пути к иконке и файлу объекта слэш должен быть двойным.
Например, если путь к программе: C:\MyProgram\MyProgram.exe, то необходимо указать его как: C:\\MyProgram\\MyProgram.exe
Так как, чаще всего икона программы встроена в саму программу, то значения "Путь к иконке для ярлыка" и "Путь к папке или файлу программы" могут совпадать.
9) При добавлении ярлыка папки измените "Путь к иконке для ярлыка" на %SystemRoot%\\system32\\SHELL32.dll,4
А значение "Путь к папке или файлу программы" на explorer /n, /e, C:\\ВашаПапка
10) После указания всех необходимых значений, нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
10.1) Если Вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "GUID.reg")
10.2) Если Вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
11) Примените получившийся reg-файл.

Пример reg-файла для добавления программы WinDjView в папку Компьютер:

Пример reg-файла для добавления папки Downloads в папку Компьютер:

В итоге Вы получите тот же самый эффект, что был упомянут в совете 3 раздела "Твики Реестра - Дополнительная функциональность".

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


9. Добавление в контекстное меню DLL- или OCX-файлов пунктов "Регистрация" и "Отмена регистрации".

Если вам часто приходится работать с ocx-файлами или с dll-файлами, которые требуют регистрации в реестре с помощью Regsvr32.exe, то будет гораздо удобнее внести соответствующую запись в реестр, чем каждый раз использовать командную строку для каждого файла.

Запустите редактор реестра (Win+R -> regedit -> Ok )

Создание пункта "Регистрация" в меню DLL- или OCX-файлов.

1) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell и HKEY_CLASSES_ROOT\dllfile\Shell
2) Создайте раздел Регистрация, а в нем подраздел command
3) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell\Регистрация\command и HKEY_CLASSES_ROOT\dllfile\Shell\Регистрация\command присвойте строковому параметру По умолчанию значение: regsvr32.exe "%1"

Создание пункта "Отмена регистрации" в меню DLL- или OCX-файлов.

1) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell и HKEY_CLASSES_ROOT\dllfile\Shell
2) Создайте раздел Отмена регистрации, а в нем подраздел command
3) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell\Отмена регистрации\command и HKEY_CLASSES_ROOT\dllfile\Shell\Отмена регистрации\command присвойте строковому параметру По умолчанию значение: regsvr32.exe /u "%1"

Теперь при нажатии правой кнопкой мыши на DLL- или OCX-файле, в меню появятся пункты "Регистрация" и "Отмена регистрации".

Также Вы можете создать reg-файл следующего содержания или скачать готовый Dll_Ocx_register-unregister.reg

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


10. Увеличение кэша памяти для вида папок.

Можно увеличить количество папок, для которых Windows будет запоминать настройки вида.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell
3) Создайте параметр DWORD BagMRU Size и присвоить ему десятичное значение, например, 20000.

Также Вы можете создать reg-файл.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: " folder_cache.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


11. Добавление опций "Выполнить", "Поиск" и "Очистить корзину" в контекстное меню.

Для быстрого доступа к необходимой Вам системной опции, Вы можете добавить её в контекстное меню рабочего стола. Чтобы это осуществить, Вам необходимо создать и применить reg-файл следующего содержания.

Добавление пункта Выполнить для вызова одноименного диалогового меню.

Добавление пункта Поиск для вызова одноименного окна.

Добавление пункта Очистить корзину.

Готовые reg-файлы для добавления и удаления Вы можете скачать по ссылке: options in context menu.zip

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


12. Создание меню с ярлыками избранных приложений в контекстном меню рабочего стола.

Добавление ссылок на избранные программы в контекстное меню рабочего стола Windows сводится к двум частям:

Часть 1. Создание каскадных меню в контекстном и добавление ярлыков.
Часть 2. Добавление функциональности ярлыкам путем их регистрации.

Часть 1. Создание контекстных меню и добавление ярлыков.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKEY_CLASSES_ROOT\DesktopBackground\Shell
3) Создайте в данной ветке новый раздел. Нажмите правой кнопкой мыши на ключе "Shell" и выберите "Создать -> Раздел". (Например, Menu1)
4) Выберите только что созданный раздел "Menu1" и в правой части окна создайте 4 строковых параметра:

Icon - в значении данного параметра следует указать путь к значку меню.
Position - данный параметр определяет позицию каскадного меню в контекстном. По умолчанию это середина контекстного меню, но Вы можете выбрать значения Top (сверху) или Bottom (снизу).
MUIVerb - имя каскадного меню, которое будет отображаться в контекстном меню. Например, "Мои программы", "Браузеры" и т.д.
SubCommands - содержит список команд, разделенных точкой с запятой (;). Эти команды будут показаны в каскадном меню. Вы не можете напрямую добавить ярлык приложения. Сначала в этом списке Вам нужно дать команде имя, а после этого зарегистрировать ее согласно инструкции во второй части статьи.

Предположим, что Вы уже создали каскадное меню "Браузеры", и теперь Вы хотите добавить в него ярлыки Internet Explorer и Mozilla Firefox. В таком случае Вам нужно параметру SubCommands задать значение:

Параметры Icon и Position Вы можете и не создавать, а вот MUIVerb и SubCommands — обязательны.

Часть 2. Добавление функциональности ярлыкам путем их регистрации.

Как только Вы добавите ярлыки программ в каскадное меню, Вам необходимо будет их зарегистрировать следующим образом:

1) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\CommandStore\Shell
2) Создайте для каждой из команд, указанных ранее в строковом параметре SubCommands, собственный одноименный раздел. В нашем примере мы использовали две команды: firefox и iexplore, поэтому нам нужно создать два раздела с такими же именами.
3) Выберите созданный раздел и в правой части окна редактора реестра задайте параметру Default (По умолчанию) имя, которые Вы хотите видеть в каскадном меню. Например, введите сюда Internet Explorer (для раздела iexplore) или Mozilla Firefox (для раздела firefox).
4) Если Вы хотите добавить ярлыку иконку, создайте новый строковой параметр с именем Icon и установите его значением путь к EXE файлу приложения или любой другой иконке.
Например, чтобы показать иконку Internet Explorer, Вы должны задать параметру Icon значение C:\Program Files\Internet Explorer\iexplore.exe
5) В каждом из только что созданных разделов создайте новый раздел и назовите его command.
Выберите его и в правой части окна установите значением Default (По умолчанию) путь к EXE-файлу необходимой программы. Например, если ярлык должен открывать Internet Explorer, то для должно быть установлено значение C:\Program Files\Internet Explorer\iexplore.exe

Готовый reg-файл контекстное меню рабочего стола (из описанного примера):

Примечание: Если Вы хотите удалить созданное каскадное меню, просто удалите ключи, созданные Вами ключи из реестра.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


13. Ускорение выключения компьютера.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\
3) Найдите параметр WaitToKillServiceTimeout
4) Измените его значение на необходимое Вам. Данный параметр отвечает за задержку перед выключением.
По умолчанию установлено значение (20000)=20 сек., но вы можете установить его значение, намного меньше номинального (минимум 100), и система будет закрываться намного быстрее.
Рекомендуемые значения (2000-5000)=2-5 сек. (меньше не рекомендуется, иначе система будет понимать неадекватно отсутсвие откликов от служб, и завершать их в "неподходящий" момент времени, например когда они сохраняют свои последние настройки).

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


14. Ускорение анимации всплывающего меню в меню Пуск.

Если Вы желаете изменить время задержки до показа всплывающего меню в меню Пуск, проделайте следующее:

1)Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
2) Откройте раздел HKEY_CURRENT_USER\Control Panel\Desktop
3) Создайте в нем(или измените) параметр MenuShowDelay
4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
6) Выберите желательное значение от 1 до 4000, означающее задержку в миллисекундах, до показа всплывающего меню в меню Пуск.
7) Закройте regedit и перезагрузите систему.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


15. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows (реестр).

Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Запустите редактор реестра (Нажмите Win+R, введите команду regedit.exe и нажмите Ок)
2) Пройдите по следующему пути: HKEY_CURRENT_USER\Control Panel\Accessibility
3) Измените значение параметра MessageDuration.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


16. Настройка параметров всплывающих эскизов окон в панели задач.

Изменив несколько настроек в реестре Вы сможете придать своим всплывающим эскизам окон больше эффективности в работе.

1) Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) Создайте в нем(или измените) параметры:

ExtendedUIHoverTime - Задержка до появления всплывающего эскиза окна на экране, после наведения курсора мыши на иконку в панели задач.
ThumbnailLivePreviewHoverTime - Задержка до появления окна программы, после наведения курсора мыши на всплывший эскиз окна.

4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
6) В графе Система исчисления установите значение параметра на Десятичная.
7) Введите необходимое Вам значение. Значение 1000 = 1 секунде.

8) Откройте в реестре раздел: HKEY_CLASSES_ROOT\SystemFileAssociations\image
9) Сделайте двойной щелчок на параметре Treatment - Данный параметр изменяет вид бордюра всплывающего эскиза окна.
10) Выберите необходимое Вам значение:

0 - Без бордюра
1 - Бордюр с тенью
2 - Фоторамка (по умолчанию)
3 - Видеорамка

11) Закройте regedit и перезагрузите систему.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


17. Настройка скорости отображения рабочего стола при наведении курсора мыши в угол экрана.

Когда Вы наводите курсор на крайнюю кнопку, находящуюся за часами на панели задач (обычно правый нижний угол экрана), система показывает Вам рабочий стол. При желании Вы можете ускорить или замедлить данный процесс.

1) Запустите редактор реестра: Пуск –> Выполнить –> regedit -> OK (или Win+R -> regedit -> OK)
2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) Измените значение параметра DesktopLivePreviewHoverTime. Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
4) В графе Система исчисления установите значение параметра на Десятичная.
5) Введите необходимое Вам значение. Значение 1000 = 1 секунде.
6) Закройте regedit, перезайдите в систему или перезагрузите систему.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


18. Добавление кнопки запуска необходимой программы на панель проводника Windows 7.

Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

На панели проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
В зависимости от месторасположения папок используемых Вами для хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок.
Для добавления кнопки запуска необходимой программы во все папки проводника - добавьте кнопку во все шаблоны.

Все шаблоны хранятся в разделах следующей ветки реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes

Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

Для добавления кнопки запуска необходимой программы сделайте следующее:

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку необходимого Вам шаблона.
Например: для добавления кнопки в обычную папку использующую шаблон типа папки «Общие элементы» откройте:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{5c4f28b5-f869-4e84-8e60-f11db97c5cc7}

А для добавления кнопки в папку «Общие элементы», входящей в Библиотеки откройте:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{5f4eab9a-6833-4f61-899d-31cf46979d49}

3) Задайте полные права на доступ к этому разделу реестра.

3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

4.1) Откройте необходимый из указанных подразделов, если Вы добавляете кнопку в шаблоны Библиотек и/или в шаблонах поиска результатов в них.
4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать -> Раздел.)

TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Удалить.
Выполняя данное действие Вы отказываетесь от набора стандартных кнопок, но позволяете использовать произвольные кнопки.

6) В разделе TasksItemsSelected создайте подраздел с именем 0. Он будет содержать в себе параметры первой кнопки (отсчет начинается с нуля), все последующие кнопки должны создаваться в разделах 1, 2, и т.д.

7) В разделе 0 создайте подраздел с уникальным GUID. (Например: {422299D4-C2DD-4e24-AAAB-FED22CC8E8DE})
7.1) Скачайте и распакуйте архив GUIDGen.zip
7.2) Запустите программу GUIDGEN.EXE, установите переключатель на Registry Format и нажмите кнопку New GUID, а затем Copy.

8) Щелкните созданный раздел с уникальным GUID и создайте в нем два строковых параметра:

Title – определяет название кнопки
InfoTip – определяет название всплывающей подсказки к кнопке

9) В разделе с уникальным GUID последовательно создайте подразделы:

shell
InvokeTask
command

10) В разделе command дважды щелкните параметр (По умолчанию) и измените его значение на путь к программе, которую Вы хотите запустить.

Примечание:

Если Вы добавляете программу для открытия в ней файлов, то после указания пути к программе добавьте параметр %*
Параметр %* указывает программе, что необходимо использовать одновременно несколько параметров: путь к отображаемой папке(%0) и путь к выделенному объекту(%1).
Если Вы добавляете программу которая должна просто запускаться, без открытия в ней файлов, то параметр добавлять не надо.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


19. Добавление кнопки "Открыть в текстовом редакторе" на панель проводника Windows 7.

Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

На панели проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
В зависимости от месторасположения папок используемых Вами для хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок.
Для добавления кнопки "Открыть в текстовом редакторе" во все папки проводника - добавьте кнопку во все шаблоны.

Все шаблоны хранятся в разделах следующей ветки реестра:

Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

Для добавления кнопки "Открыть в текстовом редакторе" сделайте следующее:

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку необходимого Вам шаблона.
Например: для добавления кнопки в обычную папку использующую шаблон типа папки «Документы» откройте:

А для добавления кнопки в папку ««Документы»», входящей в Библиотеки откройте:

3) Задайте полные права на доступ к этому разделу реестра.

3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

4.1) Откройте необходимый из указанных подразделов, если Вы добавляете кнопку в шаблоны Библиотек и/или в шаблонах поиска результатов в них.
4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать -> Раздел.)

TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Удалить.
Выполняя данное действие Вы отказываетесь от набора стандартных кнопок, но позволяете использовать произвольные кнопки.

6) В разделе TasksItemsSelected создайте подраздел с именем 0. Он будет содержать в себе параметры первой кнопки (отсчет начинается с нуля), все последующие кнопки должны создаваться в разделах 1, 2, и т.д.

7) В разделе 0 создайте подраздел с уникальным GUID. (Например: {433399D4-C2DD-4e24-AAAB-FED22CC8E8DE})
7.1) Скачайте и распакуйте архив GUIDGen.zip
7.2) Запустите программу GUIDGEN.EXE, установите переключатель на Registry Format и нажмите кнопку New GUID, а затем Copy.

8) Щелкните созданный раздел с уникальным GUID и создайте в нем два строковых параметра:

Title – определяет название кнопки
InfoTip – определяет название всплывающей подсказки к кнопке

9) В разделе с уникальным GUID последовательно создайте подразделы:

shell
InvokeTask
command

10) Скачайте файл архив со скриптом texteditor.zip и распакуйте его в любую папку. (Например: C:\Scripts)

10.1) Вы можете создать его самостоятельно. Для этого скопируйте нижеследующий текст в текстовый редактор и сохраните файл с именем texteditor и расширением *.js .

11) В разделе command дважды щелкните параметр (По умолчанию) и измените его значение на путь к скрипту:

Примечание:

Параметр %* указывает программе, что необходимо использовать одновременно несколько параметров: путь к отображаемой папке(%0) и путь к выделенному объекту(%1).

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


20. Добавление кнопок "Копировать в папку" и "Переместить в папку" на панель проводника Windows 7.

Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

На панели проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
В зависимости от месторасположения папок используемых Вами для хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок.
Для добавления кнопок "Копировать в папку" и "Переместить в папку" во все папки проводника - добавьте кнопки во все шаблоны.

Все шаблоны хранятся в разделах следующей ветки реестра:

Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

Для добавления кнопок "Копировать в папку" и "Переместить в папку" сделайте следующее:

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку необходимого Вам шаблона.
Например: для добавления кнопки в обычную папку использующую шаблон типа папки «Общие элементы» откройте:

А для добавления кнопки в папку «Общие элементы», входящей в Библиотеки откройте:

3) Задайте полные права на доступ к этому разделу реестра.

3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

4.1) Откройте необходимый из указанных подразделов, если Вы добавляете кнопку в шаблоны Библиотек и/или в шаблонах поиска результатов в них.
4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать -> Раздел.)

TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Удалить.
Выполняя данное действие Вы отказываетесь от набора стандартных кнопок, но позволяете использовать произвольные кнопки.

6) В разделе TasksItemsSelected создайте подраздел с именем 0. Он будет содержать в себе параметры первой кнопки (отсчет начинается с нуля), все последующие кнопки должны создаваться в разделах 1, 2, и т.д.

7) В разделе 0 создайте подраздел с уникальным GUID. (Например: {455599D4-C2DD-4e24-AAAB-FED22CC8E8DE})
7.1) Скачайте и распакуйте архив GUIDGen.zip
7.2) Запустите программу GUIDGEN.EXE, установите переключатель на Registry Format и нажмите кнопку New GUID, а затем Copy.

8) Щелкните созданный раздел с уникальным GUID и создайте в нем два строковых параметра:

Title – определяет название кнопки
InfoTip – определяет название всплывающей подсказки к кнопке

9) В разделе с уникальным GUID последовательно создайте подразделы:

shell
InvokeTask
command

10) Скачайте файл архив со скриптом ExplorerBarUtilities.zip и распакуйте его в любую папку. (Например: C:\Scripts)

11) В разделе command дважды щелкните параметр (По умолчанию) и измените его значение на путь к скрипту: Для создания кнопки "Копировать в папку" измените значение на:

Для создания кнопки "Переместить в папку" измените значение на:

Примечание:

Параметр %* указывает программе, что необходимо использовать одновременно несколько параметров: путь к отображаемой папке(%0) и путь к выделенному объекту(%1).

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


21. Добавление собственной папки в Рабочий стол области переходов проводника.

Если Вы часто пользуйтесь какой-либо папкой, то Вы можете добавить ее в Рабочий стол области переходов проводника. Поскольку копирование папки напрямую или создание ярлыка на рабочем столе не добавляет её в область переходов, то предлагаю Вам решение, как это возможно осуществить.

1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот):

2) Скачайте программу Microsoft Exchange Server GUID Generator
3) Распакуйте архив и запустите программу (GUIDGEN.EXE)
4) Установите переключатель на значение Registry Format
5) Нажмите на кнопку New GUID, и программа сгенерирует Вам новый GUID
6) Нажмите на кнопку Copy, и программа скопирует его в буфер обмена
7) Вставьте вместо {GUID}, сгенерированный программой GUID.
Теперь у Вас вместо {GUID}, должен быть цифровой идентификатор, например: {1a51a488-17d4-4169-a212-a2cf152268b6}
8) Замените значения "Название папки" и "Путь к папке" на необходимые Вам.
Внимание! При указывании пути к папке слеш должен быть двойным.
Например, если путь к папке: C:\My Folder\Downloads, то необходимо указать его как: C:\\My Folder\\Downloads
9) После указания всех необходимых значений, нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
9.1) Если Вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "GUID.reg")
9.2) Если Вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
10) Примените получившийся reg-файл.

Пример reg-файла для добавления папки Downloads в Рабочий стол области переходов проводника.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


22. Скрытие апплетов отображаемых в Панели управления.

Существует много способов, чтобы скрыть элементы в Панели Управления. Ниже приводятся, наиболее часто используемые.

1) Создайте reg-файл используя шаблон в одном из предложенных ниже вариантов.
2) Примените его.
3) Перезагрузите систему.

Вариант 1. Показать все кроме.

Созданный reg-файл позволяет Вам отобразить все апплеты в Панели управления, исключая те которые добавлены в ветку: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowCpl
Чтобы исключить определенные апплеты из Панели управления, создайте в данном разделе строковые параметры (REG_SZ).
Имена параметров должны быть - непрерывные номера начинающиеся с 1: 1, 2, 3, …
Значения - имя апплета точно таким же, как оно отображается в Панели Управления в зависимости от выбранного языка интерфейса. Пример reg-файла для русской Windows:

Пример reg-файла для английской Windows:

Вариант 2. Скрыть все кроме.

Созданный reg-файл позволяет Вам скрыть все апплеты в Панели управления, исключая те которые добавлены в ветку: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictCpl
Чтобы отобразить определенные апплеты в Панели управления, создайте в данном разделе строковые параметры (REG_SZ).
Имена параметров должны быть непрерывные - номера начинающиеся с 1: 1, 2, 3, …
Значения - имя апплета точно таким же, как оно отображается в Панели Управления в зависимости от выбранного языка интерфейса. Пример reg-файла для русской Windows:

Пример reg-файла для английской Windows:

Русское название элемента | Английское название элемента
Windows CardSpace | Windows CardSpace
Windows SideShow | Windows SideShow
Автозапуск | AutoPlay
Автономные файлы | Offline Files
Администрирование | Administrative Tools
Архивация и восстановление | Backup and Restore
Биометрические устройства | Biometric Devices
Брандмауэр Windows | Windows Firewall
Восстановление | Recovery
Гаджеты рабочего стола | Desktop Gadgets
Дата и Время | Date and Time
Датчик расположения и другие датчики | Location and Other Sensors
Диспетчер устройств | Device Manager
Диспетчер учетных данных | Credential Manager
Домашняя группа | HomeGroup
Защитник Windows | Windows Defender
Звук | Sound
Значки области уведомлений | Notification Area Icons
Игровые устройства | Game Controllers
Инфракрасная связь | Infrared
Клавиатура | Keyboard
Мышь | Mouse
Панель задач и меню ''Пуск'' (кавычки два раза одинарные) | Taskbar and Start Menu
Параметры индексирования | Indexing Options
Параметры папок | Folder Options
Параметры планшетного компьютера | Tablet PC Settings
Перо и сенсорные устройства | Pen and Touch
Персонализация | Personalization
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection
Получение программ | Get Programs
Приступая к работе | Getting Started
Программы и компоненты | Programms and Features
Программы по умолчанию | Default Programs
Распознавание речи | Speech Recognition
Расположение по умолчанию | Default Location
Родительский контроль | Parental Controls
Свойства обозревателя | Internet Options
Система | System
Сканеры и камеры | Scanners and Cameras
Счетчики и средства производительности | Performance Information and Tools
Телефон и модем | Phone and Modem
Управление цветом | Color Management
Устранение неполадок | Troubleshooting
Устройства и принтеры | Devices and Printers
Учетные записи пользователей | User Accounts
Центр мобильности Windows | Windows Mobility Center
Центр обновления Windows | Windows Update
Центр поддержки | Action Center
Центр синхронизации | Sync Center
Центр специальных возможностей | Ease of Access Center
Центр управления сетями и общим доступом | Network and Sharing Center
Шифрование диска BitLocker | BitLocker Drive Encryption
Шрифты | Fonts
Экран | Display
Электропитание | Power Options
Язык и региональные стандарты | Region and Language

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


23. Увеличение пространства, отведенного в NTFS для главной таблицы файлов.

В ядре файловой системы NTFS содержится файл, который называется главной таблицей файлов (MFT). MFT (Master File Table) — главная файловая таблица (база данных), в которой хранится информация о содержимом тома с файловой системой NTFS, представляющая собой таблицу, строки которой соответствуют файлам тома, а столбцы — атрибутам файлов.
Поскольку средства дефрагментации томов NTFS не могут перемещать записи MFT, а также из-за того, что значительная фрагментация MFT может негативно влиять на быстродействие системы, NTFS резервирует для MFT дисковое пространство, чтобы по мере увеличения размера MFT подвергался минимальной фрагментации.
По мере появления новых файлов в томе NTFS в файл MFT добавляются новые записи, и, таким образом, размер MFT увеличивается. При удалении файлов из тома NTFS соответствующие записи в файле MFT помечаются как свободные и могут использоваться повторно, однако размер MFT при этом не сокращается. Таким образом, дисковое пространство, используемое этими записями, остается недоступным.
При переполнении зоны MFT пространство для новых записей MFT начинает выделяться из незарезервированного дискового пространства, что снова приводит к фрагментации MFT.

Существует параметр реестра, позволяющий увеличить (зарезервировать) пространство, отведенное в NTFS для основной таблицы файлов. Для его добавления выполните следующие действия:

1) Запустите редактор реестра (Win+R->regedit->ОК)
2) Откройте раздел реестра HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem
3) В меню Правка выберите Создать -> Параметр DWORD (32 бита).
4) Задайте имя параметра NtfsMftZoneReservation
5) Дважды щелкните на данном параметре и введите необходимое Вам значение от 1 до 4.
6) Закройте редактор реестра и перезапустите компьютер.

Если на ваших разделах NTFS мало файлов, но они большого размера, то наилучшим значением созданного параметра будет 1.
Если у Вас среднее количество файлов на диске, то оптимальным значением является 2, если же их большое количество, то значение 3.
Значение 4 (максимальное значение) следует использовать только в случае, если у вас на диске очень большое количество файлов.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


24. Увеличение процессорного времени, выделяемого программе, работающей на переднем плане.

Для начала убедитесь, что параметр Распределение времени процессора настроен на оптимизацию работы программ. Для этого:

1) Откройте меню Пуск
2) Нажмите правой кнопкой мыши на пункт Компьютер и выберите Свойства
3) В списке слева нажмите на ссылку Дополнительные параметры системы
4) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
5) Откройте вкладку Дополнительно и в разделе Распределение времени процессора установите переключатель в значение: программ.

Теперь Вам необходимо изменить количество квантов выделяемых программе, работающей на переднем плане.
Квантом называется единица процессорного времени, выделяемая конкретной программе для работы. По истечении квантов, выделенных одной программе, управление будет передано другой программе, ожидающей в очереди (а программа, которая только что работала, будет помещена в конец очереди) — и эта программа будет работать до тех пор, пока не истекут кванты, выделенные для нее. После этого управление перейдет следующей программе из очереди.
Особенностью Windows является увеличенное количество квантов, которое выделяется программе, работающей в данный момент на переднем плане. То есть, программа переднего плана будет работать быстрее всех программ, работающих в данный момент в фоновом режиме.
Так реализована многозадачность операционной системы Windows.

Для изменения количества квантов, выделяемых программе, работающей на переднем плане, сделайте следующее:

1) Запустите редактор реестра (Win+R->regedit->ОК)
2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\PriorityControl
3) Дважды щелкните на DWORD-параметре Win32PrioritySeparation и введите необходимое Вам значение.
4) Закройте редактор реестра и перезапустите компьютер.

По умолчанию значение равно 2.
Максимальное значение равно 26 в шестнадцатеричной системе исчисления или 38 в десятичной системе.
Необходимое Вам значение выясняется экспериментальным путем.
Не ставьте сразу большое значение, постепенно увеличивайте значение пока не найдете оптимальное.
Например: На одних машинах улучшения в работе системы с программами будут видны при максимальном значении 26, на других же оптимальным значением может оказаться 12.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


25. Отключение выгрузки драйверов режима ядра и системного кода режима ядра из оперативной памяти на диск.

Если у Вас на компьютере большое количество оперативной памяти, то приложения будут быстрее откликаться на Ваши действия, если драйвера режима ядра и системный код режима ядра будут оставаться в оперативной памяти.

За данное действие отвечает параметр реестра DisablePagingExecutive, который определяет, могут ли драйвера режима ядра и системный код режима ядра быть выгружены из оперативной памяти на диск, когда они не используется.

Значение 0 указывает, что при необходимости драйвера режима ядра и системный код режима ядра могут быть выгружены из оперативной памяти на диск, когда они не используется.
Значение 1 указывает, что драйвера режима ядра и системный код режима ядра должны оставаться в оперативной памяти.

Для изменения данного параметра сделайте следующее:

1) Запустите редактор реестра (Win+R->regedit->ОК)
2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
3) Дважды щелкните на параметре DisablePagingExecutive и введите значение 1.
4) Закройте редактор реестра и перезапустите компьютер.

Если же у Вас такой параметр отсутствует, то создайте в данном разделе реестра DWORD-параметр с указанным именем и значением.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


26. Удаление пункта "Восстановить прежнюю версию" из контекстного меню проводника.

Чтобы удалить пункт "Восстановить прежнюю версию" из контекстного меню проводника, сделайте следующее:

1) Запустите редактор реестра (Win+R->regedit->ОК)
2) Откройте раздел реестра: HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\
3) Удалите раздел {596AB062-B4D2-4215-9F74-E9109B0A8153}
4) Откройте раздел реестра: HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers\
5) Удалите раздел {596AB062-B4D2-4215-9F74-E9109B0A8153}
6) Закройте все процессы проводника и запустите его заново или перезайдите в систему.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Дополнительная функциональность.


1. Автоматическое VPN-подключение к интернет при запуске Windows (реестр).

1. Создайте ваше VPN-подключение, но не подключайтесь к интернету или если подключились, то не отключайтесь от интернета до окончания описанных ниже действий.
2. В реестре Windows (Пуск->Выполнить->"regedit") найдите следующую ветку:

(если хотите сделать автозапуск только для текущего пользователя) или

(если хотите сделать автозапуск для всех пользователей)
В этой ветке создайте "строковый параметр" (правой кнопкой мыши -> «Создать» -> «строковый параметр») с произвольным именем.
2. В качестве значения созданного параметра внесите строку вида:

3. Закройте реестр и перезагрузите компьютер.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Устройства и Сети.


2. Конвертирование reg файлов в inf формат из контекстного меню, с помощью утилиты.

1) Скачайте утилиту Reg2inf (необходим Framework 2 или 3)
2) Скопируйте её в C:\Windows\System32
3) Создайте и примените reg-файл следующего содержания:

В контекстное меню reg-файлов добавится пункт reg2inf при нажатии которого созданный Вами reg-файл переконвертируется в inf-файл. Например, файл test.reg переконвертируется в test.reg.inf

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Устройства и Сети.


3. Включение клавиш-индикаторов Num Lock, Caps Lock, Scroll Lock при загрузке.

Если у Вас при входе в систему выключен переключатель клавиатуры Num Lock, то для его включения сделайте следующее.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKEY_CURRENT_USER\Control Panel\Keyboard
3) Щелкните на параметре InitialKeyboardIndicators правой кнопкой мыши и нажмите Изменить.
4) Выберите и установите необходимое Вам значение.

0 – все переключатели выключены.
1 – Caps Lock включен.
2 – Num Lock включен.
3 – Caps Lock и Num Lock включены.
4 – Scroll Lock включен.
5 – Caps Lock и Scroll Lock включены.
6 – Num Lock и Scroll Lock включены.
7 – Caps Lock, Num Lock и Scroll Lock включены.

Если же Вам необходимо изменить состояние клавиш-индикаторов до входа в систему, в экране приветствия, то для управления ими измените значение параметра InitialKeyboardIndicators в разделе HKEY_USERS\.DEFAULT\Control Panel\Keyboard

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Устройства и Сети.


4. Отмена автозапуска для носителей и устройств.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр DWORD с именем NoDriveTypeAutoRun

Допустимые значения ключа:

0x1 - отключить автозапуск на приводах неизвестных типов
0x4 - отключить автозапуск съемных устройств
0x8 - отключить автозапуск НЕсъемных устройств
0x10 - отключить автозапуск сетевых дисков
0x20 - отключить автозапуск CD-приводов
0x40 - отключить автозапуск RAM-дисков
0x80 - отключить автозапуск на приводах неизвестных типов
0xFF - отключить автозапуск вообще всех дисков.

Также параметр NoDriveTypeAutoRun автоматически добавляется в реестр при установке программы VMware Workstation, используемой для создания виртуальной машины.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Устройства и Сети.


5. Уменьшение фрагментируемости больших файлов на диске.

Для того чтобы операционная система при записи файла на диск сначала нашла для него наиболее подходящее по размеру место и поместила его туда, как можно меньше дробя на части сделайте следующее:

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem
3) Создайте DWORD-параметр ContigFileAllocSize
4) Щелкните на нем правой кнопкой мыши и выберите Изменить.
5) Установите значение 00000200 и нажмите Ок

Данный параметр определяет максимальный размер нефрагментируемого блока данных на диске. При желании размер такого блока можно еще увеличить. Данная настройка может быть очень полезной при работе с мультимедиа (уменьшается нагрузка на диск и процессор при записи и воспроизведении видео или звуковых файлов).
Эта настройка полезна тем, у кого много файлов большого размера, при большом количестве маленьких файлов - она становится менее актуальной.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Устройства и Сети.


6. Изменение состояния встроенного динамика персонального компьютера.

1) Запустите редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKEY_CURRENT_USER\Control Panel\Sound
3) Измените значение параметра Beep на "No" чтобы отключить и на "Yes" чтобы включить.

Также Вы можете включить/отключить его в Диспетчере устройств:

1) Откройте меню Пуск -> Панель управления и запустите Диспетчер устройств
2) В меню Вид установите флажок на Показать скрытые устройства
3) Откройте Драйверы несамонастраиваемых устройств
4) Щелкните правой кнопкой мыши на Beep и выберите пункт Свойства
5) Перейдите на вкладку Драйвер и установите тип автозагрузки на Отключено чтобы отключить и на Авто чтобы включить.
6) Для изменения текущего состояния нажмите на Остановить чтобы отключить и на Запустить чтобы включить.
7) Нажмите кнопку ОК для применения настроек.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Устройства и Сети.


7. Переназначение гнезд звуковой карты Realtek используя реестр.

На некоторых материнских платах, отсутствует возможность переназначения гнезд встроенной звуковой карты Realtek. А это значит, что каждое гнездо четко привязано к определенному устройству и определяется только автоматически при включении его в гнездо.
Например, если Вы включите Микрофон или Наушники в гнездо, предназначенное для устройства Боковые динамики, то Realtek будет по-прежнему считать, что у Вас подключены Боковые динамики, а не Микрофон или Наушники.
Однако из данной ситуации есть выход. Вы можете переназначить гнезда вручную, при помощи реестра.

1) Установите драйвера звуковой карты
2) Запустите редактор реестра (Win+К -> regedit -> Ok)
3) Пройдите к папке

4) Откройте папку Drv6278_DevType_0888_SS10438357 или с аналогичным названием (DrvXXXX_DevType_XXXX_SSXXXXXXXX, где вместо X могут быть любые цифры, зависящие от версии драйвера и номера вашего устройства)
5) Создайте двоичный параметр(Binary-Параметр) задаете ему необходимое имя и значение из списка указанного ниже или отредактируйте уже имеющийся.

Имя(вставлять без кавычек):

"Pin01" = Заднее зеленое гнездо
"Pin02" = Заднее черное гнездо
"Pin03" = Заднее коричневое гнездо
"Pin04" = Заднее серое гнездо
"Pin05" = Заднее розовое гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Микрофон)
"Pin07" = Заднее синее гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Линейный вход)

"Pin06" = Переднее розовое гнездо
"Pin08" = Переднее зеленое гнездо

Значение(вставлять без кавычек):

"00 00 00 00" = Линейный вход
"01 00 00 00" = Микрофон
"02 00 00 00" = Наушники
"04 00 00 00" = Передние динамики
"05 00 00 00" = Тыловые динамики
"06 00 00 00" = Центральный канал/Сабвуфер
"07 00 00 00" = Боковые динамики

Если у Вас после перезагрузки компьютера сбрасываются настройки, то сразу после изменения настроек установите значение параметра ChannelConfig равным 00 00 00 00

Также вы можете создать reg-файл наподобие указанного ниже, заменив значения на необходимые:

Drv6278_DevType_0888_SS10438357 - на версию вашего драйвера
(имя папки по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\)
Pin04 - на любое значение из списка Имя
hex:02,00,00,00 - на любое значение из списка Значение(просто исправьте 2 на соответствующую цифру) Reg-файл для настройки устройства Наушники вместо устройства Боковые динамики

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Устройства и Сети.


8. Замена компонента Устройства и принтеры в Панели управления на папку Принтеры.

1) Откройте Редактор групповой локальной политики (Win+R -> gpedit.msc - Ok)
2) Перейдите в раздел Конфигурация пользователя\Административные шаблоны\Панель управления.
3) Выберите команду Скрыть указанные элементы панели управления
4) Установите переключатель в значение Включить.
5) Нажмите на кнопку Показать.
6) Добавьте новую запись: Microsoft.DevicesAndPrinters и нажмите Ok.
7) Запустите редактор реестра (Win+R -> regedit.exe -> Ok).
8) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace
9) Создайте в ней новый раздел {2227a280-3aea-1069-a2de-08002b30309d}.
10) Присвойте параметру По умолчанию значение - Принтеры (Printers).

Данную папку Вы сможете увидеть в Панели управления в контекстном меню Пуск, если у Вас установлено значение "Отображать как меню" или при просмотре полного списка всех элементов при её открытии.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Устройства и Сети.


9. Удаление цифры при пересоздании адаптера сети в Диспетчере устройств.

Вариант 1

1) Удалите драйвер сетевого адаптера
2) В ветке реестра

установите значение адаптера сети на 0.
3) Создайте драйвер сетевого адаптера

Вариант 2

1) Удалите драйвер сетевого адаптера
2) В ветке реестра

удалите ваш сетевой адаптер.
3) Создайте драйвер сетевого адаптера.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Устройства и Сети.


10. Отключение или переназначение клавишы Caps Lock.

Если вы не используете клавишу Caps Lock по назначению, то вы можете отключить или переназначить клавишу, путем редактирования параметра реестра. Для этого необходимо изменить значение параметра Scancode Map, который расположен в разделе реестра

Ниже представлены reg-файлы для переназначения и отключения клавиши Caps Lock.

Клавиша Caps Lock будет выполнять действие клавиши Ctrl

Клавиша Caps Lock будет выполнять действие клавиши Shift

Отключает Caps Lock и переназначает действие клавиши Scroll Lock на выполнение Caps Lock

Отключает клавишу Caps Lock

Отменяет все предыдущие переназначения клавиш(возвращает значение по умолчанию)

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Устройства и Сети.


11. Отключение USB порта после Безопасного извлечения устройства.

Если Вы присоединили USB-устройство к компьютеру с запущенной Windows 7, а затем Отключаете устройство в "Диспетчере устройств" или в "Безопасное Извлечение устройств и дисков", используя иконку в системном трее, то Вы можете наблюдать один из следующих симптомов:
  • USB-устройство показывает продолжающееся признаки деятельности (такие, как остающийся гореть LED-индикатор)
  • USB-устройство продолжает получать USB-пакеты и продолжает потреблять энергию соответствующую состоянию активного устройства.
  • Физическое отсоединение Отключенного или Безопасно Удаленного USB-устройства может, в некоторых случаях, вызывать ошибку в активной передаче на другое USB-устройство.

    • Чтобы исправить данную ошибку Вам необходимо сделать следующее:

    Для определенного устройства.

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags
    3) Откройте в данной ветке раздел соответствующий, подключенному к Вашему компьютеру USB-устройству.
    4) Если неоходимого Вам раздела нет, то создайте его.

    4.1) Щелкните правой кнопкой мыши на usbflags
    4.2) Выберите пункты Создать -> Раздел
    4.3) Задайте имя нового раздела в следующем виде: vvvvpppprrrr
    где vvvv - 4-значный шестнадцатеричный номер, обозначающий Vendor ID устройства
    pppp - 4-значный шестнадцатеричный номер, обозначающий Product ID устройства
    rrrr - 4-значный бинарно-закодированный десятиричный номер, обозначающий Revision number устройства

    Данные сведения Вы можете узнать воспользовавшись Диспетчером устройств.
    4.3.1) Откройте Пуск -> Панель управления -> Диспетчер устройств
    4.3.2) Нажмите правой кнопкой мыши на необходимом Вам устройстве и выберите пункт Свойства
    4.3.3) Перейдите на вкладку Сведения и в ниспадающем списке выберите ИД оборудования.

    5) Создайте в открытом разделе HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\usbflags\vvvvpppprrrr параметр DWORD (32 бита) с именем DisableOnSoftRemove
    6) Щелкните правой кнопкой мыши по параметру DisableOnSoftRemove и выберите пункт Изменить...
    7) В текстовом поле Значение: введите 1 и нажмите ОК.

    Для всех устройств:

    1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
    2) Откройте ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\usbhub\hubg Если данной ветки нет, то создайте ее.
    3) Щелкните правой кнопкой мыши и создайте параметр DWORD (32 бита) с именем DisableOnSoftRemove
    4) Щелкните правой кнопкой мыши по параметру DisableOnSoftRemove и выберите пункт Изменить...
    5) В текстовом поле Значение: введите 1 и нажмите ОК.

    Назад на страницу раздела Твики Реестра.
    Назад на страницу подраздела Твики Реестра - Устройства и Сети.


12. Отключение сообщения: "Хотите выполнить проверку и исправление ошибок на ..." для съемных дисков.

Вариант 1

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\AutoCheckSelect
3) Щелкните на параметре CheckedValue правой кнопкой мыши и нажмите Изменить.
4) Установите значение 0 и нажмите ОК

Вариант 2

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
3) Щелкните на параметре BootExecute правой кнопкой мыши и нажмите Изменить.
4) По умолчанию значение данного параметра должно быть autocheck autochk *.
* означает, что все диски выбраны для проверки. Чтобы добавить исключение проверки для определенного диска, добавьте перед звездочкой параметр /K:<Буква_диска>. Параметр /K отключает проверку диска при его автозапуске. Например для съемного диска H: значение ключа BootExecute примет вид:

Если Вы желаете добавить несколько дисков в исключения (например: H и I диски), то значение ключа BootExecute примет вид:

Вариант 3

1) Откройте меню Пуск
2) Введите в диалоговом окне Выполнить (Win+R) или в строке поиска команду msconfig и нажмите Enter.
3) Перейдите на вкладку Службы и уберите флажок: Определение оборудования оболочки
4) Откройте меню Пуск
5) Введите в диалоговом окне Выполнить (Win+R) или в строке поиска команду services.msc и нажмите Enter.
6) В открывшейся оснастке Службы щелкаете правой кнопкой мыши на Определение оборудования оболочки и выбираете пункт Свойства
7) Выбираете Тип запуска - Отключена и нажимаете кнопку Остановить
8) Нажимаете ОК.

Данное действие также отключит автозагрузку со съемных носителей.

Назад на страницу раздела Твики Реестра.
Назад на страницу подраздела Твики Реестра - Устройства и Сети.


Устранение неполадок

Устранение неполадок - Администрирование и Интерфейс.

1. Компьютер не видит локальный диск с предыдущей ОС или диск отображается без буквы.

1) Щелкните правой кнопкой мыши на Компьютер (например в меню Пуск) и выберите Управление.
2) В левом окне выберите Управление дисками
3) Посередине вверху посмотрите, какие из томов не имеют букву.
Если среди томов присутствует раздел размером 200 МБ, то Вы ему букву не изменяете.
4) Присвойте букву тому диску, в котором находится предыдущая Windows (смотрим по размеру). Для этого щелкните на нем правой кнопкой мыши и в контекстном меню выберите пункт Изменить букву диска или путь к диску.
5) Нажмите Добавить, выберите букву и нажмите OK.
6) Через несколько секунд должно открыться окно автозапуска диска. А сам диск появится в Компьютере.
7) Откройте Панель управления -> Параметры папок
8) Перейдите на вкладку Вид и проверьте установлен ли флажок Отображать буквы дисков, если нет, то установите его.

2. Решение проблемы с анимацией DWM (Desktop Window Manager).

1) Нажимаете "Пуск" на панели задач
2) Нажимаете правой кнопкой на Компьютер
3) Выбираете Свойства -> Дополнительные параметры системы
4) В открытом окне выбираете вкладку Дополнительно-Быстродействие-Параметры
5) На вкладке Визуальные эффекты, уберите галочку - Анимация окон при свертывании и развертывании.

3. Решение проблемы с доступом к wim-файлу при работе с программой Dism.

При возникновении ошибок с доступом при работе с wim файлом в программе DISM, Вы можете воспользоваться одним из предложенных вариантов.

Вариант 1. Новые имена папок.

1) В командной строке запущенной от имени администратора (Win+R -> cmd -> OK), выполните следующую команду:

2) Создаете новую папку для wim-файла и переместите в нее Ваш wim-файл. (Например: вместо текущей папки mWim, создайте новую mWim1)
3) Создайте новую папку, куда Вы будете монтировать Ваш wim-файл для работы. (Например: вместо текущей папки Mount, создайте новую Mount1)
4) Продолжайте работу с новыми папками.

Вариант 2. Старые имена папок.

1) В командной строке запущенной от имени администратора (Win+R -> cmd -> OK), выполните следующую команду:

2) Переместите Ваш wim-файл в любую другую папку.
3) Удалите папки, которые Вы использовали для wim-файла и монтирования индекса.
4) Создайте заново папки с теми же названиями.
5) Верните wim-файл обратно.
6) Продолжайте работу с теми же папками, что и раньше.

4. Очистка или изменение размера кэша иконок, для решения проблем с их отображением.

Удаление кэша эскизов может понадобиться при возникновении проблем с их отображением. После удаления кэша эскизов они вновь будут записаны при обращении к папкам с обрабатываемыми типами файлов, таким образом пересоздастся кэш и возможно удастся решить проблему с отображением некоторых эскизов.
Для очистки кэша эскизов сделайте следующее.

1) Нажмите комбинацию клавиш Win+R, в поле Открыть напишите cleanmgr и нажмите OK.
2) Выберите диск на который у Вас установлена Windows (по умолчанию C:) и после оценки объема места, которое можно освободить, отметьте Эскизы и нажмите OK
3) В проводнике откройте папку %USERPROFILE%\AppData\Local\ и удалите файл IconCache.db

Вы можете сделать это автоматически используя программу Rebuild Icon Cache

Также Вы можете создать и применить reg-файл:

5. Причины перехода цветовой схемы на упрощенный стиль.

Отображение сообщения об отключении некоторых визуальных элементов, таких как прозрачность рамки окна, или о замене цветовой схемы на упрощенный стиль может быть вызвано одной из следующих причин:

1) Запущенная программа несовместима с темами Aero. В этом случае некоторые визуальные элементы автоматически отключаются. После завершения работы такой программы отключенные визуальные элементы автоматически включаются.
2) Возможно, уровень заряда батареи переносного компьютера очень низкий. Темы Aero или прозрачность окон в системе Windows могут быть отключены для экономии энергии батареи.
3) Было изменение конфигурации оборудования компьютера или разрешения экрана. После изменения разрешения экрана, параметров видеокарты или монитора компьютер, возможно, больше не соответствует минимальным требованиям для запуска тем Aero.
4) Недостаточный объем памяти компьютера для выполнения всех запущенных программ и использования темы Aero.

Если ОС Windows автоматически изменила тему на упрощенный стиль, но необходимо вернуться к теме Aero, закройте несколько окон, чтобы освободить память, а затем выполните следующие действия:

1) Используйте "Запуск средства устранения неполадок интерфейса Aero".
1.1) Откройте меню Пуск и введите команду в строке поиска, щелкните на ней и нажмите Enter
или
1.2) Нажмите Win+R и введите команду в диалоговом окне Выполнить

2) Нажмите Далее

6. Выбор настроек во время установки для предотвращения замены русских букв знаками вопросов.

На начальном этапе установки выводится окно, содержащее три строчки.
Первая строчка - язык, на котором работает система (английский US или русский RU). При возможности выберите русский.
Вторая строчка - месторасположение компьютера, для выбора страны (от Афганистана и до Ямайки). Выберите страну - Russian Federation.
Третья строчка - язык раскладки клавиатуры по умолчанию. При выборе во второй строчке страны (РФ), здесь автоматически устанавливается русский. Вы можете выбрать здесь любой используемый Вами язык раскладки клавиатуры.

7. Решение проблемы с неправильным отображением русских букв.

1.1) Запустите редактор реестра: Win+R -> regedit -> Ok или введите regedit в строке поиска меню Пуск и нажмите Enter.
1.2) Откройте ветку реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage
1.3) Измените значение параметра 1252 с "c_1252.nls" на "c_1251.nls"
1.4) Откройте папку C:\WINDOWS\system32\ и найдите файлы c_1251.nls и c_1252.nls и задайте полный доступ к данным файлам.
1.5) Переименуйте файл c_1252.nls в c_1252.bak.
1.6) Создайте здесь же копию файла c_1251.nls.
1.6.1) Щелкните правой кнопкой мыши на файле и выберите Копировать.
1.6.2) Щелкните правой кнопкой мыши в пустом месте папки C:\WINDOWS\system32\ и выберите Вставить.
1.7) Переименуйте c_1251 - копия.nls в c_1252.nls. В итоге файл c_1252.nls, должен быть переименованной копией c_1251.nls
1.8) Перезагрузите компьютер.

Если у Вас установлена Русская Windows или Английская+русский MUI, то проделайте также следующее:

2.1) Запустите редактор реестра: Win+R -> regedit -> Ok или введите regedit в строке поика меню Пуск и нажмите Enter.
2.2) Откройте ветку реестра HKEY_CURRENT_USER\Control Panel\International
2.3) Проверьте значение параметров Locale и LocaleName
Параметр Locale должен иметь значение 00000419, а параметр LocaleName должен иметь значение ru-RU
2.4) Если значения параметров другие: дважды щелкните на параметре, который необходимо изменить, введите необходимое значение параметра и нажмите OK.
2.5) Перезагрузите компьютер.

3.1) Откройте Язык и региональные стандарты.
Пуск -> Панель управления -> Язык и региональные стандарты (или Win+R -> control /name Microsoft.RegionAndLanguage -> Ок)
3.2) Перейдите на вкладку Дополнительно. Можете сразу открыть её: Win+R -> control intl.cpl,,3 -> Ок
3.3) В блоке Язык программ, не поддерживающих Юникод нажмите на кнопку Изменить язык системы
3.4) Выберите язык системы Русский (Россия) и нажмите ОК.

8. Запись последовательности действий пользователя для анализа их разработчиком.

Одной из встроенных диагностических утилит, чтобы отсылать отчеты об ошибках является "Средство записи действий по воспроизведению неполадок".
Эта функция, которая позволяет пользователям записывать свои действия в любом используемом приложении и предоставлять подробное представление действий со снимками экрана с соответствующими комментариями.
Для того, чтобы открыть приложение "Средство записи действий по воспроизведению неполадок" нужно нажать на кнопку меню «Пуск» и в поле поиска ввести psr.
Для того, чтобы начать запись действий, с которыми возникают проблемы или вопросы нужно просто нажать на кнопку "Начать запись". После этого можно выполнять любые действия с операционной системой и установленными приложениями для воспроизведения проблемы.
Чтобы приостановить на время запись действий, необходимо нажать на кнопку "Приостановить запись".
Для того, чтобы снова возобновить запись действий нажимаем на кнопку "Возобновить запись".
Сразу после остановки записи откроется диалоговое окно "Сохранить как", в котором нужно ввести имя файла и нажать на кнопку "Сохранить". После выполнения этих действий файл будет сохранен в указанной директории с расширением ZIP.

9. Решение проблемы с выходом из спящего/ждущего режима в черный экран.

Если при попытке выходе из спящего/ждущего режима Вы попадаете в черный экран или в BSOD (синий экран смерти) Вы можете попробовать несколько способов. Первым делом, скачайте и установите более новые версии драйверов для Вашей видеокарты, чем те что у Вас есть.

Вариант 1. Изменение настроек BIOS:

1) Во времени загрузки зайдите в BIOS (для этого нажмите клавишу Delete после начала загрузки компьютера)
2) В BIOS пройдите на вкладку Power
3) Попробуйте изменить значение параметра Suspend Mode (Auto, S1 (POS) Only, S3 Only) названия может отличаться, ищите похожие со значениями S1, S3.
4) Также попробуйте включить\отключить ACPI 2.0 Support -> Enabled\Disabled

Вариант 2. Запрет вывода из спящего режима используя USB мышь или USB клавиатуру.

Некоторые USB-устройства неправильно поддерживают спящий режим Windows. Два основных устройства с помощью которых Вы можете выйти из спящего режима - это клавиатура и мышь. Одно из них может блокировать Вам выход, в таком случае ему надо просто запретить это делать. Внимание: Не запрещайте одновременно клавиатуре и мыши, иначе Вы не сможете выйти из него.

1) Запустите Диспетчер устройств. Для этого пройдите в Пуск -> Выполнить (или Win+R) -> devmgmt.msc -> OK
2) В Диспетчере устройств разверните узел Мыши и иные указывающие устройства или Клавиатуры
3) Щелкните правой кнопкой на USB-мышь или USB-клавиатуру и выберите пункт Свойства.
4) Откройте вкладку Управление электропитанием.
5) Снимите флажок Разрешить устройству вывод компьютера из спящего режима и нажмите кнопку ОК.

Вариант 3. Отключение спящего/ждущего режима.

1) Пройдите в Пуск -> Выполнить (Win+R) -> powercfg.cpl -> OK
2) Выберите слева пункт Настройка перехода в спящий режим
3) Присвойте обоим параметрам: Отключать дисплей и Переводить компьютер в спящий режим, значение - Никогда.
Также можно отключить и функцию сна. Выберите пункт "Изменить дополнительные параметры питания". Найдите в окне режим Сон, разверните Сон после и установите значение находящихся там параметров на Никогда
Если несмотря на проделанное выше, компьютер по прежнему продолжает отключаться, то Вам необходимо выполнить ещё некоторые действия:
4) Скачайте reg-файл PowerSettings.reg и примените его.
5) Откройте вкладку Сон
6) Установите следующие значения параметрам, открыв их вкладки:
6.1) Сон после - значение равным 0, оно идентично значению Никогда
6.2) Разрешить политику требуемую системой - значение Да (это предотвратит автоматический переход в ждущий режим)
6.3) Разрешить таймеры пробуждения - Включить (позволит автоматически выводить компьютер из спящего режима при помощи заданных событий)
7) Если у Вас одно из устройств USB например мышь, а второе клавиатура PS/2, то Вы можете отключать USB порт на время работы спящего режима.
Откройте вкладку Параметры USB, а в ней вкладку Параметр временного отключения USB-порта и установите значение в Разрешено.
8) Нажмите OK

10. Восстановление загрузки Windows 7 без установочного диска.

Вариант 1. Автоматически - при помощи среды восстановления Windows RE в Windows 7.

Во время установки Windows 7 на жестком диске автоматически создается служебный раздел, обеспечивающий доступ в среду восстановления Windows RE (Recovery Environment). Используя данный служебный раздел, Вы можете:

- загрузиться в среду восстановления с жесткого диска
- создать компакт-диск, содержащий среду восстановления

1) Выполните загрузку в среду восстановления с жесткого диска или диска восстановления системы.
Для того чтобы войти в меню Дополнительные варианты загрузки, нажмите F8 после включения компьютера (но до загрузки операционной системы).
2) Выберите первый пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter.
3) Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи.
4) Введите пароль администратора. После ввода пароля вы увидите окно с вариантами восстановления.
5) Выберите пункт Восстановление запуска(Startup repair), также иногда может помочь пункт Восстановление системы (System Restore), позволяющий вернуться к точке, созданной до возникновения проблемы.

Вариант 2. Восстановление вручную, с созданием мультизагрузочного меню.

Здесь главное - это добраться до командной строки для введения дальнейших команд.

1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe)
2) Создайте папку Boot
3) Распакуйте скачанный архив и скопируйте файлы Bootsect.exe и Bcdedit.exe, нужной Вам битности в созданную Вами папку Boot.
4) Запустите среду необходимую для работы:
5) Загрузитесь в Windows, установленную на другой диск или в среду восстановления (На жестком диске запускается нажатием, клавиши F8. Если клавиша F8 используется материнской платой, после выбора диска нажмите F8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter)
6) Запустите командную строку.
В Windows: Win+R -> cmd -> Ok.
В среде восстановления: Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи. Введите пароль администратора. Выберите пункт Командная строка (Command Prompt)

Далее все команды вводимые в командную строку будут одинаковы как в Windows, так и в среде восстановления.

1) Windows 7 использует усовершенствованный метод загрузки - хранилище данных конфигурации загрузки. Это хранилище содержит все сведения обо всех операционных системах, установленных на компьютере. Следовательно, загрузчики более ранних операционных систем Windows, не могут быть использованы для ее запуска. Итак, для восстановления, загрузочного сектор Windows 7, перезаписываем загрузочный сектор на всех разделах:

где Х - буква диска, на котором содержится программа Bootsect.exe
2) Если у Вас вторая система Windows XP, то Вам необходимо выполнить ещё ряд действий:

Создайте в хранилище загрузки Windows 7 - хранилище для загрузки Windows XP.

Если же система откажется это делать, значит данное хранилище уже создано, поэтому необходимо его только переименовать:

Далее укажите загрузчику Windows 7 устройство расположения файлов загрузки Windows XP:

Затем укажите загрузчику Windows 7 путь к загрузчику Windows XP:

После добавьте строчку о выборе Windows XP в меню загрузки и расположив ее под остальными:

Также для работы с загрузчиками, Вы можете воспользоваться программой EasyBCD, позволяющей выполнять указанные выше действия, используя графический интерфейс.

Для информации:

Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

Вариант 3. Восстановление вручную, при помощи bootrec.exe.

1) Загрузитесь в среду восстановления (На жестком диске запускается нажатием, клавиши F8. Если клавиша F8 используется материнской платой, после выбора диска нажмите F8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter)
2) Выберите операционную систему, которую необходимо восстановить, и нажмите "Next"("Далее").
3) В окне Опции системы восстановления (System Recovery Options) выберите пункт Командная строка (Command Prompt).
4) Откроется окно интерпретатора командной строки cmd.exe, где следует ввести:

Параметр /FixMbr записывает в системный раздел основную загрузочную запись, совместимую с Windows 7. Этот параметр не перезаписывает существующую таблицу разделов. Данный параметр следует использовать для устранения проблем, связанных с повреждением основной загрузочной записи, или если необходимо удалить из основной загрузочной записи нестандартный код.

Параметр /FixBoot записывает в системный раздел новый загрузочный сектор с использованием загрузочного сектора, совместимого с Windows 7. Этот параметр следует использовать, если выполняется хотя бы одно из перечисленных ниже условий.

- Загрузочный сектор Windows 7 был заменен нестандартным загрузочным сектором
- Загрузочный сектор поврежден
- После установки Windows 7 на компьютер была установлена более ранняя версия операционной системы Windows. В данном случае для запуска компьютера вместо диспетчера загрузки Windows (Bootmgr.exe) используется загрузчик Windows NT (NTLDR).

Параметр /RebuildBcd выполняет поиск установленных операционных систем, совместимых с Windows 7, на всех дисках. Кроме того, этот параметр позволяет выбрать установленные системы, которые необходимо добавить в хранилище данных конфигурации загрузки. Этот параметр следует использовать в том случае, если необходимо выполнить полную перестройку данных конфигурации загрузки.

Если Вы не запомнили необходимого Вам значения Вы можете просто ввести:

и утилита выведет справку по доступным ключам командной строки.

11. Восстановление стандартного анимированного экрана загрузки Windows 7.

В некоторых случаях новый экран загрузки произвольно заменяется старым в стиле Vista. Чаще всего это происходит, после неудачно внесенных различного рода изменений в загрузчик ОС. Предлагаю Вам простые и действенные решения:

Вариант 1

Выполнить - C:\Windows\System32\sysprep\sysprep.exe выбрать OOBE и ОК.

Вариант 2

1. Откройте командную строку от имени администратора: Пуск -> Выполнить (или Win+R) -> cmd -> Ok
2. В открытом окне консоли введите команду:

Обратите внимание, что вышеуказанная команда предусмотрена для английской версии Windows, поэтому если вы используете другую языковую версию, необходимо заменить "en-US" на языковой идентификатор используемой вами версии.
3. Закройте окно командной строки.
4. Перезагрузите Ваш компьютер.

Вариант 3

1) Откройте диалоговое меню Выполнить: Пуск -> Выполнить (или Win+R)
2) В открытом окне консоли введите команду: msconfig и нажмите OK
3) Перейдите на вкладку "Загрузка" и проверьте не установлен ли флажок напротив значения "Без GUI". Если флажок установлен - снимите его.
4) Закройте окно Конфигурации системы.
5) Перезагрузите компьютер

12. Получение полного доступа к NTFS-томам, системному реестру, параметрам настройки и драйверам в случае тотального повреждения существующей на диске ОС или для перезаписи исправлений к русификации поверх оригинальных файлов?

Для этой функции можно использовать программу Microsoft ERD Commander входящую в состав Microsoft Diagnostics and Recovery Toolset.
Вы можете создать свой загрузочный образ на основе имеющегося у вас дистрибутива или скачать готовый образ Microsoft ERD Commander.
Программа для создания своего образа, на основе дистрибутива Windows 7. Запускается только в Windows 7.

ERD Commander для x86 или x64

13. Моргание игр в режиме OpenGL.

Переименуйте файлы: ..\windows\system32\glu.dll в glu32.dll ..\windows\system32\opengl.dll в opengl32.dll

14. Исправление невозможности запуска службы Центра обеспечения безопасности.

1) Отключены компоненты от которых зависит данная служба.

1.1) Откройте: Администрирование -> Службы
1.2) Проверьте включены ли следующие службы:

- Инструментарий управления Windows
- Удаленный вызов процедур (RPC)
- Модуль запуска процессов DCOM-сервера
- Сопоставитель конечных точек RPC

2) Восстановите начальные параметры в реестре, используя значения с компьютера, на котором данная служба работает.

2.1) Загрузите и примените готовый reg-файл. wscsvc.zip

15. Исправление отсутствия компонентов в окне "Включение или отключение компонентов Windows".

1.1) Запустите редактор реестра: Win+R -> regedit -> Ok
1.2) Откройте ветку реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows
1.3) Измените значение параметра CSDVersion на 0.
1.4) Перезагрузите компьютер

2) В соответствии с разрядностью и языком Вашей Windows, скачайте и установите обновление KB947821:

Windows6.1-KB947821-v5-x86.msu
Windows6.1-KB947821-v5-x64.msu

16. Исправление невозможности изменения настроек User Account Control (UAC).

В разделе Панели управления Системы и безопасность Вы можете изменить параметры контроля учетных записей User Account Control (UAC).
Если у Вас при работе в диалоговом окне Параметры управления учетными записями пользователей после перемещения ползунка управления и нажатия кнопки ОК или клавиши Enter, диалоговое окно не закрывается, и/или не вносятся никакие изменения, то вероятнее всего у Вас произошел сбой Реестра.
Вы можете восстановить нормальную работу User Account Control (UAC) одним из 2 способов.

Вариант 1. С помощью специального дополнения от Microsoft.

Скачайте и запустите файл: fixit_kb978591.diagcab

Вариант 2. При помощи созданного Вами reg-файла.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).

2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "UAC.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Примените полученный файл UAC.reg (Двойной щелчок -> Да)

Готовый reg-файл Вы можете скачать по ссылке: uac_repair.zip.

17. Диагностика проблемы высокой загрузки процессора и частых обращений к жесткому диску при запуске или выключении Windows.

Чтобы определить какая программа или драйвер больше всего загружает Ваш процессор, Вам понадобиться программа от Microsoft - Windows Performance Tools Kit и в дополнение к ней программа XPerfUI от Richard Macdonald, при координации Microsoft.

1) В соответствии с Вашей разрядностью, скачиваете архив: для x86 или для x64
2) Устанавливаете программу Windows Performance Tools Kit
3) Копируйте файл XPerfUI.exe в папку с установленной программой и запускаете его.

4) Используя всплывающее меню открываете Tools -> Trace Session -> Boot Trace
5) В блоке Trace Type выбираете, для какого действия Вы хотите провести диагностику: Boot (для анализа запуска) или Shutdown (для анализа выключения)
6) В блоке Trace Flags устанавливаете переключатель на значение Base, дополнительно отмечаете пункты CSWITCH, DRIVERS, POWER
7) В поле Result path указываете путь, куда будет сохранен результат анализа. (Например: C:\Temp )
8) Нажмите кнопку Start для начала диагностики.

Рисунок 1 из 2

Компьютер перезагрузится.
9) Если Вы выбрали Boot (для анализа запуска), то после перезапуска системы, программа запустит трассировку (процесс пошагового выполнения программы) для данного действия и сохранит результаты в указанную Вами папку.
Если Вы выбрали Shutdown (для анализа выключения), то после перезапуска системы, программа запустит трассировку, снова перезапустит компьютер, снова запустит трассировку и сохранит результаты в указанную Вами папку.

10) Запускаете программу Performance Analyzer. В появившемся окне нажимаете кнопку Да.
Пуск -> Все программы -> Microsoft Windows Performance Toolkit -> Performance Analyzer
или файл xperfview.exe из папки, где установлена программа.
11) Открываете в окне программы (File -> Open) etl-файл, являющийся созданным в процессе трассировки log-файлом с результатами анализа. Местом нахождения etl-файла будет папка, указанная Вами при запуске трассировки.
12) Программа загрузит графики.
13) В меню программы нажимаете Graphs и ставите флажок CPU Sampling by Process.
14) В меню программы нажимаете Trace и ставите флажок Load Symbols.
15) Находите график CPU Sampling by Process.
16) Чтобы вывести сводную таблицу, нажимаете на нем правой кнокой мыши и выбираете пункт Summary Table
Процесс с наибольшим значением Weight и будет тем самым процессом, который забирает ресурсы процессора при загрузке или выключении. При нажатии на значок +, рядом с наименованием процесса Вы сможете узнать какой именно файл потребляет больше всего ресурсов процессора.

Рисунок 2 из 2

17) Также Вы можете посмотреть какая программа больше всего делает обращений к жесткому диску. Для этого найдите график Disk I/O в основном окне графиков программы, нажмите на нем правой кнопкой мыши и выберите пункт Summary Table. Процесс с наибольшим значением Service Time и будет тем самым процессом, который больше всего делает обращений к жесткому диску.

18. Устранение проблемы открытия папок в отдельном окне, при установленном положении переключателя "Открывать папки в одном и том же окне".

1) Нажмите Пуск и введите в строке поиска cmd.exe
2) Нажмите на найденном правой кнопкой мыши и выберите пункт "Запуск от имени Администратора".
3) Поочередно введите команды, после написания каждой нажмите Enter.

19. Удаление лишних пунктов из Диспетчера загрузки Windows.

1) Нажмите кнопку Пуск
2) Наберите в строке поиска msconfig и нажмите Enter
3) Перейдите на вкладку Загрузка
4) Выделите строку которую Вы желаете удалить и нажмите кнопку Удалить
5) Нажмите кнопку ОК и перезагрузите компьютер

20. Извлечение файлов Windows 7 из установочного DVD и замена ими поврежденных системных файлов.

Если у Вас в Windows появились поврежденные системные файлы, то Вам нет необходимости сразу переустанавливать Windows, так как Вы можете просто восстановить поврежденный файл используя DVD-диск или образ установочного диска. Вам всего лишь надо удалить имеющийся системный файл и заменить его извлеченным.

Инструкция восстановления системных файлов:

1) Извлеките из установочного диска необходимый файл.
2) Удалите поврежденный файл.
3) Скопируйте на место удаленного файла извлеченный.
4) Перезагрузите компьютер.

Извлечение файлов с диска Windows 7.

Вариант 1. При помощи программы DISM.

Подключение образа в DISM.

1) Вставьте установочный диск Windows 7 в DVD-привод, или смонтируйте ISO-образ.
2) Откройте папку sources и скопируйте из нее файл install.wim на диск D.
Внимание: в качестве папки для подключения образа install.wim НЕЛЬЗЯ использовать корень диска C (тот на котором установлена Windows), так как install.wim содержит системные папки Windows, Program Files, Program Data, Users и др.
3) Создайте папку на диске D и назовите ее, например, Image. В эту папку будет подключен образ install.wim.
4) Откройте Пуск > Все программы > Стандартные, щелкните правой кнопкой мыши по значку командной строки и выберите Запуск от имени администратора.
5) Выполните команду:

Пояснения:

dism – встроенная в Windows 7 утилита командной строки, позволяющая подключать образы WIM и управлять ими.
Параметр /Mount-Wim подключает файл WIM.
Параметр /WimFile позволяет указать расположение и имя файла WIM, который нужно подключить.
Параметр /name позволяет указать название выпуска Windows 7, который будет смонтирован.
Параметр /MountDir: указывает папку, в которую будет смонтирован образ WIM.

6) Дождитесь, пока образ подключится. Это может занять несколько минут.
7) Откройте папку D:\Image, найдите в ней (в папках) нужный файл и скопируйте его в любое место на жестком диске.

После копирования нужных файлов образ можно отключить.

Отключение образа в DISM.

1) Закройте все папки и файлы.
2) Откройте Пуск > Все программы > Стандартные, щелкните правой кнопкой мыши по значку командной строки и выберите Запуск от имени администратора.
3) Выполните команду:

Пояснения:

Параметр /Unmount-Wim отключает образ.
Параметр /MountDir: указывает папку, в которую смонтирован образ, который нужно отключить.
Параметр /discard отменяет все внесенные в образ изменения.

4) Дождитесь отключения образа.
5) Удалите папку Image и файл install.wim с диска D.

Вариант 2. При помощи программы 7Zip.

1) Скачайте и установите программу 7Zip
2) Cмонтируете образ лицензионного диска с Windows 7 или вставьте установочный DVD-диск.
3) Используя программу 7Zip откройте файл H:\sources\install.wim
где (H:) - буква диска с установкой Windows
4) Откройте в данном файле папку, соответствующую идентичной в системе.
5) Скопируйте файл(простым переносом из программы 7Zip) в идентичную папку в реальной системе.

Способы удаления:

1) Обычное удаление.
Просто нажмите правой кнопкой мыши на файле и выберите пункт Удалить.

2.1) Скачайте и установите программу Unlocker
2.2) Нажмите правой кнопкой мыши на файле и выберите пункт Unlocker.
2.3) В выпадающем меню выберите пункт Удалить и нажмите на кнопку Разблокировать все.

3) Удаление в безопасном режиме.
3.1) Перезагрузите компьютер в безопасный режим(нажмите f4 в начале загрузки компьютера до начала загрузки системы).
3.2) Нажмите правой кнопкой мыши на файле и выберите пункт Удалить.

4) Загрузитесь в ERD Commander
4.1) Для сопоставления букв дисков целевой операционной системе нажмите Да (Yes).
4.2) В окне выбора опреационной системы не выбирайте никакую систему(должно сняться выделение с какой-либо системы) и нажмите кнопку Далее (Next).
4.3) Нажмите Micosoft Diagnostics and Recovery Toolset -> Explorer
4.4) Откройте папку файла, нажмите правой кнопкой мыши на нем и выберите пункт Удалить.

21. Настройка периодичности создания точек восстановления системы.

Чтобы изменить периодичность создания точек восстановления сделайте следующее:

1) Запустите Планировщик заданий. Пуск -> Панель управления -> Администрирование -> Планировщик заданий

2) В дереве слева откройте Библиотека планировщика задач -> Microsoft -> Windows -> SystemRestore

3) Щелкните правой кнопкой мыши в верхнем среднем окне на файл SR и выберите Свойства.

4) В открывшемся окне перейдите на вкладку Триггеры.

5) Нажмите Создать и задайте необходимые Вам временные параметры, либо выберите уже имеющийся триггер (Например, Ежедневно) и нажмите Изменить. Для удаления созданых триггеров выберите его и нажмите Удалить.

6) Нажмите на ОК для принятия изменений.

22. Восстановление веток реестра из резервных копий службы System Restore в Windows 7.

Большая часть системного реестра находится в следующих местах:

Раздел HKEY_CURRENT_USER - в файле C:\Users\ИМЯ_ПОЛЬЗОВАТЕЛЯ\NTUSER.dat.
Все остальные разделы - C:\Windows\system32\config

Если Вам необходимо восстановить какую-то определенную часть системного реестра Windows 7 или Вы хотите посмотреть, какие значения имел определенный ключ, некоторое время назад, то Вам необходимо сделать следующее:

Для примера, получим доступ к предыдущим значениям ключа HKEY_LOCAL_MACHINE\SOFTWARE.

1) Откройте папку C:\Windows\system32. Найдите в ней директорию Config.
2) Щелкните по папке Config правой кнопкой мыши, выберите пункт меню Свойства и перейдите на вкладку Предыдущие версии.
3) Два раза щелкните по папке, относящейся к интересующей вас дате. Вы увидите перечень файлов, для которых доступна предыдущая версия. В данном случае нас интересует файл SOFTWARE, так как именно в нем хранятся ключи раздела HKEY_LOCAL_MACHINE\SOFTWARE.
4) Скопируйте файл в любое удобное вам место, перетащив его в открытое окно Проводника, либо выбрав команду Копировать из контекстного меню файла SOFTWARE.
Предположим, вы поместили его в корень диска D:.
5) Запустите редактор реестра (Пуск -> Выполнить -> regedit.exe), установите курсор на корневой ключ HKEY_LOCAL_MACHINE и выполните команду главного меню Файл -> Загрузить куст...
6) Задайте имя, под которым будет смонтирован файл D:\SOFTWARE (Например: oldsoftware)
7) Доступ к значениям ключей и разделов реестра будет возможен по пути HKEY_LOCAL_MACHINE\oldsoftware.
8) Смонтированный куст представляет собой предыдущую версию HKEY_LOCAL_MACHINE\Software, где Вы можете посмотреть предыдущие значения нужных ключей.
Если значения Вам необходимо поместить в рабочий реестр системы, переходите к следующему пункту.
9) Найдите интересующий Вас ключ или параметр, и экспортируйте его в reg-файл:
10) Выделите ключ, и в его контекстном меню выберите команду Экспортировать.
11) Отредактируйте только что экспортированный файл Блокнотом, заменив все вхождения "\oldsoftware\" на "\SOFTWARE\".
12) Сохраните reg-файл и двойным щелчком мыши по нему импортируйте его в текущий реестр операционной системы.

23. Использование "чистой загрузки" для устранения неполадок в работе Windows.

"Чистая загрузка" - это безопасный режим, в котором компьютер запускается с минимальным количеством работающих программ и служб. Если при запуске компьютера в безопасном режиме ошибок не возникает, это означает, что проблема вызвана одной из программ или служб автозагрузки. В режиме "чистой загрузки" компьютер запускается с отключенными программами и службами автозагрузки, которые затем включаются и отключаются по одной до тех пор, пока источник проблемы не будет локализован.

Действие 1. "Чистая загрузка" системы

1) Войдите в систему с учетной записью, имеющей права администратора.
2) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter, чтобы запустить Конфигурация системы.
3) На вкладке Общие установите переключатель на Выборочный запуск
4) Снимите флажок Загружать элементы автозагрузки. (Флажок Использовать оригинальную конфигурацию загрузки недоступен.)
5) Перейдите на вкладку Службы
6) Установите флажок Не отображать службы Майкрософт и нажмите кнопку Отключить все.
7) Нажмите кнопку ОК и щелкните Перезагрузка.

Действие 2. Включите половину служб.

1) Войдите в систему с учетной записью, имеющей права администратора.
2) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter, чтобы запустить Конфигурация системы.
3) Откройте вкладку Службы и установите флажок Не отображать службы Майкрософт.
4) Установите флажки для половины служб в списке Службы.
5) Нажмите кнопку ОК и щелкните Перезагрузка.

Действие 3. Определите возможную причину неисправности.

Если неисправность осталась, повторите действия 1 и 2. В действии 2 снимите в списке Службы установленные флажки.
Если проблема исчезла, повторите действия 1 и 2. В действии 2 установите половину из еще не установленных флажков в списке Службы. Повторяйте эти действия, пока не будут установлены все флажки.
Если в списке Службы осталась выбранной только одна служба и проблема по-прежнему наблюдается, то именно эта служба ее и вызывает.
Если проблема вызвана одной из служб, перейдите к действию 6, в противоположном случае продолжайте поиск неисправности перейдя к действию 4.

Действие 4. Разрешите запуск половины элементов списка автозагрузки.

1) Выполните чистую загрузку, повторив действие 1.
2) Откройте вкладку Автозагрузка и установите флажки для половины элементов списка элементов автозагрузки.
3) Нажмите кнопку ОК и щелкните Перезагрузка.

Действие 5. Определите возможную причину неисправности.

Если неисправность осталась, повторите действия 1 и 4. В действии 4 снимите в списке элементов автозагрузки установленные флажки.
Если проблема исчезла, повторите действия 1 и 4. В действии 4 установите половину из еще не установленных флажков в списке элементов автозагрузки. Повторяйте эти действия, пока не будут установлены все флажки.
Если в списке элементов автозагрузки остался только один элемент и проблема по-прежнему наблюдается, то именно этот элемент ее и вызывает.
Если проблема вызвана одним из элементов автозагрузки, перейдите к действию 6.
Если неполадка не вызвана ни одним из элементов автозагрузки, вероятнее всего, ее вызывает одна из служб Майкрософт. Чтобы определить, какая именно служба вызывает неполадку, повторите действия 1 и 2, не устанавливая флажок Не отображать службы Майкрософт в действии 2.

Действие 6. Устраните проблему.

Определив программу или службу, являющуюся причиной проблемы сделайте одно из предложенным действий:

1) Установите более новую версию программы или удалите текущую.
2) Обратитесь к разработчикам программы в службу поддержки.
3) Используя Конфигурация системы снимите флажок проблемного элемента в списке Службы или в списке элементов автозагрузки.
4) Запустите командную строку (Win+R -> cmd -> ОК) и выполните команду sfc /scannow

Действие 7. Перезагрузите систему в обычнй режим Windows.

Завершив устранение неполадок, для перезагрузки в обычнй режим Windows выполните описанные далее действия:

1) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter, чтобы запустить Конфигурация системы.
2) На вкладке Общие установите переключатель на Обычный запуск
3) Нажмите кнопку ОК и щелкните Перезагрузка.

24. Определение устройства выведшего Windows 7 из спящего режима.

Если уходя от компьютера Вы оставили его в спящем режиме, а вернувшись обнаружили что он включен (разбужен), то для определения устройства выведшего Windows из спящего режима сделайте следующее:

1) Запустите командную строку от имени Администратора: Win+R -> cmd -> ОК.
2) Введите команду: powercfg -lastwake и нажмите ОК.
3) Результатом работы данной программы будет указание на идентификатор устройства.

Чтобы узнать, что это за устройство:

4) Запустите Редактор реестра (Win+R -> regedit -> Ok)
5) Откройте ветку: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\.
6) Найдите искомое Вами устройство, согласно полученному при выполнении powercfg результату.
Наименование устройства будет отображено в найденном Вами ключе в параметре DeviceDesc

25. Устранение неполадок с поиском и индексированием.

Если результаты поиска отображаются не полностью, а также поиск в системе происходит медленно независимо от установленных настроек, то сделайте следующее:

1) Откройте меню Пуск, введите в строке поиска Устранение неполадок и нажмите Enter.
2) Нажмите кнопку Просмотр всех категорий, а затем выберите раздел Поиск и индексирование.
3) Нажмите кнопку Далее, затем в диалоговых окнах выбирайте ответы для уточнения имеющейся у Вас проблемы и нажимайте соответствующие кнопки.

Если файлы из индексированной папки не отображаются в результатах поиска, то сделайте следующее:

Причиной могут быть параметры безопасности, установленные для этой папки. Для индексирования папки и ее содержимого для нее необходимо установить разрешение система. Для большинства папок данное разрешение уже настроено, но в некоторых случаях разрешение система для папки может отсутствовать.

Добавление для папки разрешения система.

1) Щелкните папку правой кнопкой мыши, выберите пункт Свойства и откройте вкладку Безопасность.
2) Если вариант система не отображается в списке Группы или пользователи, щелкните Изменить.
3) Щелкните Добавить, введите в открывшемся окне система, затем щелкните Проверить имена.
4) В разделе Введите имена выбираемых объектов щелкните система, затем нажимайте кнопку ОК, пока не будут закрыты все открытые диалоговые окна.
5) Откройте меню Пуск, введите в строке поиска Параметры индексирования и нажмите Enter.
6) Щелкните Дополнительно. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
7) В диалоговом окне Дополнительно перейдите на вкладку Параметры индексирования, а затем нажмите кнопку Перестроить. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.

Перестроение индекса может занять несколько часов, и до тех пор пока индекс не будет перестроен, результаты поиска могут быть неполными.

26. Исправление проблемы, когда автоматически не обновляется значок корзины, после ее очистки.

Вариант 1.

1) Запустите текстовый редактор, например «Блокнот».
2) Скопируйте в него текст указанный ниже:

3) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3.1) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DefaultIcon.reg")
3.2) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
4) Примените полученный reg-файл. Щелкните на нем дважды и нажми кнопку Да, а затем ОК.

Вариант 2.

1) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Персонализация.
2) Нажмите ссылку Изменение значков рабочего стола.
3) Выберите значок Корзина (полная) и нажмите кнопку Сменить значок.
4) В диалоговом окне Смена значка, выберите значок полной корзины и нажмите кнопку ОК.
5) Выберите значок Корзина (пустая) и нажмите кнопку Сменить значок.
6) В диалоговом окне Смена значка, выберите значок пустой корзины и нажмите кнопку ОК.
7) В диалоговом окне Параметры значков рабочего стола нажмите кнопку ОК.

27. Исправление ошибки из журнала событий: "Не удается найти описание для идентификатора события 1904 из источника HHCTRL.".

При запуске и использовании (чтение, переход по страницам) в Windows файла справки с расширением *.CHM в журнале событий может появляться сообщение:
"Не удается найти описание для идентификатора события 1904 из источника HHCTRL.".
Это происходит из-за неправильного задания уровня безопасности системой для Местной интрасети в контейнере файла-справки.

Чтобы узнать появляется ли у Вас данная ошибка:

1) Откройте оснастку Просмотр событий
1.1) В строке поиска меню Пуск введите команду eventvwr.msc и нажмите Enter
или
1.2) Пройдите Панель управления\Все элементы панели управления\Администрирование и откройте Просмотр событий.
2) Слева в древовидном списке оснастки Просмотр событий перейдите Просмотр событий (Локальный) -> Журналы Windows -> Приложение
3) В центральном окне будут описаны события произошедшие при работе с программами.

Для исправления данной ошибки, создайте и примените reg-файл следующего содержания:

28. Перезагрузка в Безопасный Режим при отсутствии данного пункта в меню Диспетчера загрузки.

Если у Вас в меню Диспетчера загрузки (вызывается нажатием клавиши F8 до появления экрана с логотипом Windows) отсутствует пункт для запуска Безопасного режима, то Вы можете попробовать перезагрузиться в Безопасный режим используя утилиту Windows - Настройка системы, для этого:

1) В строке поиска меню Пуск введите команду: msconfig
2) Перейдите на вкладку Загрузка
3) Установите флажок напротив пункта Безопасный режим.
4) Установите переключатель в нужное значение:

Минимальная - загрузка графического интерфейса пользователя ОС Windows (Проводника Windows) в безопасном режиме с запуском только самых важных системных служб. Сетевые компоненты отключены.
Другая оболочка - загрузка командной строки Windows в безопасном режиме с запуском только самых важных системных служб. Сетевые компоненты и графический интерфейс пользователя отключены.
Восстановление Active Directory - загрузка графического интерфейса пользователя Windows в безопасном режиме с запуском только самых важных системных служб и службы каталогов Active Directory.
Сеть - загрузка графического интерфейса пользователя Windows в безопасном режиме с запуском только самых важных системных служб. Сетевые компоненты включены.

5) Установите необходимые флажки:

Без GUI - во время загрузки Windows экран приветствия не отображается.
Журнал загрузки - вся информация, касающаяся процесса загрузки, сохранится в файле %SystemRoot%\Ntbtlog.txt.
Базовое видео - загрузка графического интерфейса пользователя Windows в минимальном режиме VGA. В этом режиме загружаются стандартные драйверы VGA вместо драйверов экрана, соответствующих видеооборудованию компьютера. Установка данного пункта позволяет загрузиться в безопасный режим при проблемах с драйверами видеокарты.
Информация об ОС - отображает имена загружаемых драйверов в процессе загрузки системы. Устанавливайте, если желаете самостоятельно определить проблемный драйвер или библиотеку мешающие загрузке.

6) Нажмите в текущем окне ОK, затем во всплывшем окне нажмите Перезагрузка.

29. Исправление ошибки 4201, возникающей при попытке запуска службы Журнал событий Windows (Windows Event Log).

Вариант 1.

1) В соответствии с разрядностью Вашего Windows скачайте и установите программу Unlocker
2) В проводнике откройте папку C:\Windows\System32\LogFiles\WMI
3) Нажмите правой кнопкой на папке RtBackup и в контекстном меню выберите пункт Unlocker.
4) В ниспадающем списке выберите пункт Удалить и нажмите на кнопку Разблокировать Все
5) Перезагрузите компьютер
6) Запустите службу Журнал событий Windows.

Вариант 2.

1) Перезагрузитесь в безопасный режим с полным отключением всех служб (для этого воспользуйтесь утилитой msconfig)
2) Откройте папку C:\Windows\System32\LogFiles\WMI
3) Удалите подпапку RtBackup со всем его содержимым.
Если необходимо, то задайте перед удалением для данной папки полные права. Иногда помогает сначала удаление файлов из папки, а затем самой папки.
4) Перезагрузитесь обратно в нормальный режим.
5) Запустите службу Журнал событий Windows.

Устранение неполадок - Рабочий стол, Проводник, Панель задач.

1. Исправление исчезновения панели быстрого запуска после перезагрузки.

Если Вы создаете панель быстрого запуска, но после перезагрузки она исчезает, то попробуйте любое из предложенных ниже решений.

1) Попробуйте создать панель быстрого запуска со значением отличающимся от Вашего:

%userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch
%appdata%\Microsoft\Internet Explorer\Quick Launch
C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

2) Установите ползунок контроля учетных записей (UAC) в предпоследнее значение.

3) Создайте и добавьте в реестр следующий reg-файл:

4) Откройте C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer
Добавьте на вкладке Свойства -> Безопасность пользователя Все и задайте ему полный доступ.

5) В диалоговом окне Выполнить из меню Пуск (Win+R) введите команду control userpasswords2 и нажмите Enter.
Поставьте флажок на "Требовать ввод имени пользователя и пароля"

6) В диалоговом окне Выполнить из меню Пуск (Win+R) введите команду gpedit.msc и нажмите Enter.
Откройте Конфигурация пользователя -> Административные Шаблоны -> Меню "Пуск" и панель задач
Измените параметр политики Отображение панели быстрый запуск на панели задач на значение Включить.

7) Закройте Языковую панель и установите вместо неё Punto Switcher.

2. Исправление сбоев возникающих при установке, обновлении или удалении программы с помощью установщика Windows (msiexec.exe).

Вариант 1

1) Перейдите Пуск->Все программы->Стандартные
2) Щелкните правой кнопкой мыши на пункт Командная строка и нажмите Запуск от имени Администратора
3) Скопируйте следующую строчку в окно команд и нажмите Enter:

Вариант 2

1) Откройте меню Пуск, введите в строке поиска regedit и нажмите Enter.
2) Перейдите в раздел HKLM\SOFTWARE\Microsoft\SQMClient\Windows
3) Щелкните правой кнопкой мыши на разделе DisabledSessions и нажмите Удалить.

3. Восстановление пункта "Выполнить" в меню "Пуск".

Если у Вас отмечен пункт Команда "Выполнить" в "Настройка меню Пуск" (На кнопке Пуск нажмите правую кнопку мыши и выберите пункт Свойства, нажмите кнопку Настроить), а меню "Выполнить" не показывает Вы можете восстановить его так:
1) В Меню "Пуск" в строке поиска наберите gpedit.msc и откройте найденный файл gpedit.msc (Редактор групповых политик)
2) В левой части открывшегося окна пройти к вкладке:
Политика "Локальный компьютер"\Конфигурация пользователя\Административные шаблоны\Меню «Пуск» и панель задач
3) Выделите в правой части строку Добавить команду "Выполнить" в меню "Пуск"
4) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

4. Убирание появляющейся в меню Пуск полоски, пропадающей при повторном открытии.

Данная ошибка исправлена в Сервисном Пакете 1 (Service Pack 1).

1) Переключаете язык интерфейса в английскую версию Windows: Панель управления->Язык и Региональные Стандарты->Языки и Клавиатуры->Язык интерфейса->выбираете английский
2) Перелогиниваетесь или перезапускаете компьютер
3) Задаёте полный доступ к файлу aero.msstyles.mui из папки C:\Windows\Resources\Themes\Aero\ru-RU
4) Копируете с заменой aero.msstyles.mui из C:\Windows\Resources\Themes\Aero\en-US в C:\Windows\Resources\Themes\Aero\ru-RU
5) Возвращаете язык интерфейса на русский
Для тех у кого изначально русская, выкладываю данный файл отдельно для x64: aero.msstyles.mui и для x86: aero.msstyles.mui

Также Вы можете скачать и запустить от имени Администратора готовый патч: MenuFix_Rus_x86_x64_Final.rar
После его применения понадобиться перезагрузить компьютер.

5. Восстановление ассоциации для *.cpl файлов.

Если какая-нибудь программа сбила Вам ассоциацию приложения Windows c файлами *.cpl.

1) Щелкните правой кнопкой мыши на любом файле *.cpl и выберите Свойства
2) На вкладке Общие напротив надписи Приложение нажмите кнопку Изменить.
3) В открывшемся окне нажмите кнопку Обзор
4) Зайдите в папку C:\Windows\System32 и выберите файл control.exe
5) Нажмите ОК

6. Исправление вылета проводника при нажатии правой кнопки мыши на файле или папке.

Скачайте небольшую утилиту ShellExView: с официального сайта или с зеркала.

Вариант 1.

Оптимальным решением проблемы может быть отключение расширения оболочки CmdLineExt.dll.
1) Запустите ShellExView.
2) Найдите среди выведенных ею расширений оболочки - расширение с именем CmdLineContextMenu Class
3) Выделите и нажмите клавишу F7 или через контекстное меню выберите опцию Disable Selected Items.
4) Перезагрузите компьютер.

или

1) Нажмите Пуск -> Выполнить (Win+R)
2) Введите команду regsvr32 /u CmdLineExt.dll и нажмите ОК.
3) Перезагрузите компьютер.

Вариант 2.

1) Запустите ShellExView.
2) Сделайте сортировку по столбцу Type (щелкните мышкой на названии столбца). Вас будут интересовать записи, где Type = Context Menu, а в столбце File Extensions есть звездочка.
3) Отключайте записи по очереди, начав с расширений, не принадлежащих Microsoft. Отключение выполняется щелчком правой кнопкой мыши -> Disable Selected Items или клавишей F7.
4) Отключив запись, проверьте работу проводника.

Если вы отключили все расширения, но проблема не решилась, то в командной строке (Win+R -> cmd -> OK) введите sfc /scannow и нажмите Enter.
Если данное действие не возымеет успеха, то перезагрузитесь в безопасный режим Windows.
Если в безопасном режиме данная проблема пропадает, тогда всё нормально, значит, проблема вызвана одной из установленных у вас программ, драйверов, кодеков или служб и Вам придется вручную искать причину вызвавшую сбой. Удалять по одной программе, отключать по одной службе или откатываться к предыдущим версиям установленных драйверов, либо используя точки восстановления возвращаться к предыдущим состояниям системы и наблюдать на каком этапе исчезла ошибка.

7. Восстановление исчезнувшей языковой панели.

Исчезновение языковой панели, чаще всего происходит после использования чистильщика или оптимизатора системы.
Перед использованием одного из предложенных вариантов, сделайте следующее:

1) Откройте редактор реестра (Win+R -> regedit -> OK )
2) Проверьте, не добавлен ли запрет на запуск языковой панели в следующую папку реестра:

3) Проверьте, присутствует ли в реестре ветки:

Region and Language

Keyboard

4) Проверьте значение параметров, в ветке реестра:

– значение REG_SZ-параметра AppName должно быть ctfmon.exe
– значение REG_SZ-параметра AppPath должно быть С:\Windows\system32.

Вариант 1

1) Идете в Панель управления - Язык и региональные стандарты
2) Делаете все по пунктам на скриншотах.

Рисунок 1 из 2

Установите переключатель на значение Закреплена в панели задач и отметьте флажок Отображать текстовые метки на языковой панели и нажмите OK
3) Щелкаете правой кнопкой на панели задач, выбираете Свойства.
4) В пункте Область уведомлений щелкаем кнопку Настроить

Рисунок 2 из 2

5) В открывшемся окне поставьте флажок напротив "Всегда показывать все значки и уведомления на панели задач" и нажмите OK

Вариант 2

В контекстном меню панели задач уберите флажок со значения Закрепить панель задач, расширьте границы для всех панелей, а затем снова поставьте флажок напротив Закрепить панель задач.

Вариант 3

Найдите файл ctfmon.exe и добавьте его в Автозагрузку или создайте reg-файл со следующим содержанием:

Вариант 4

1) Откройте Языки и службы текстового ввода
Так:

1.1.1) Откройте Пуск->Выполнить (или нажмите на клавиатуре Win+R)
1.1.2) Ввести: RunDll32.exe shell32.dll,Control_RunDLL C:\Windows\system32\input.dll
1.1.3) Нажать OK

Или так:

1.2.1) Открыть Панель управления\Часы, язык и регион
1.2.2) Нажать на ссылку Смена раскладки клавиатуры или других способов ввода
1.2.3) Нажать на кнопку Изменить клавиатуру
2) На вкладке Общие удалите все раскладки клавиатуры кроме Английский
3) На вкладке Языковая панель снимите все флажки и установите переключатель в значение Скрыта
4) Выгрузите вручную библиотеки.
4.1) Откройте Пуск->Выполнить (или нажмите на клавиатуре Win+R)
4.2) Выполните поочередно команды:

5) Перезагрузите компьютер.
6) Откройте Языки и службы текстового ввода
7) На вкладке Общие добавьте нужные Вам раскладки клавиатуры
8) На вкладке Языковая панель установите переключатель в значение Закреплена в панели задач и установите флажок напротив пункта Отображать текстовые метки на языковой панели.
9) Нажмите OK.

Как альтернативный вариант можете установить программу Punto Switcher, она добавляет собственную языковую панель и функцию автоматического переключения раскладки при неправильном её выборе.

8. Исправление ошибки, когда папки "Недавние места" и "Недавние документы" пустые.

1) Щелкните правой кнопкой мыши на кнопке Пуск и нажмите на Свойства
2) Установите флажки напротив пунктов:
"Хранить и отображать список недавно открывшихся программ в меню "Пуск"
"Хранить и отображать список недавно открывшихся элементов в меню "Пуск" и на панели задач"
3) Нажмите OK.

9. Удаление появившейся на рабочем столе папки "Недавние места".

1) Удалите папку C:\Users\Default\AppData\Roaming\Microsoft\Windows\Recent
2) Перезагрузите компьютер или перезапустите систему
3) Зайдите в C:\Users\Default\AppData\Roaming\Microsoft\Windows\
4) Если Windows 7 не восстановил папку Recent заново, создайте её самостоятельно.

10. Решение ошибки "Отсутствует исполняющее ядро для расширения имени файла js"
Иногда какое-то приложение может изменить ассоциацию к файлам ".js" (Например, текстовый редактор, использующий скрипты).
Что может привести к ошибке "Отсутствует исполняющее ядро для расширения имени файла js".
Переустановка Java от Sun Microsystems или компонентов с сайта Майкрософт, не всегда исправляет эту ошибку.

Необходимо восстановить через реестр значение по умолчанию "JSFile" .

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Запустите reg-файл.

11. Гаджеты или их настройки отказываются запускаться.

Для нормального функционирования гаджетов рекомендуется не отключать полностью контроль учетных записей (UAC), а выставить минимальный уровень.
Если Вам необходима работа гаджетов при отключенном контроле учетных записей (UAC):

1) Создайте reg-файл указанного ниже содержания.

2) Примените его и перезагрузите компьютер.

или

1) Запустите командную строку от имени Администратора (Win+R -> cmd -> ОК)
2) По очереди введите команды указанные ниже, нажимая после введения каждой Enter:

12. Восстановление пункта "Закрепить программу в панели задач".

Если у вас пропал пункт "Закрепить программу в панели задач":
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

13. Пользовательские папки отображаются обычными иконками.

Если у вас пользовательские папки, такие как Документы, Изображения и т.п., отображаются в проводнике с обычными иконками, как и любые другие папки, то это может быть вызвано отсутствием или повреждением файлов desktop.ini, расположенных в таких папках. Или же эти файлы имеют неправильные атрибуты.
Если файл desktop.ini присутствует в папке, его атрибуты должны быть Скрытый и Только чтение.
В случае если файла desktop.ini нет в папке, его необходимо создать с указанным ниже содержимым и с указанными выше атрибутами.
Для вступления в силу изменений необходимо завершение сеанса или перезагрузка.

Содержимое файлов desktop.ini для стандартных пользовательских папок

Документы

Изображения

Музыка

Видео

Поиски

Загрузка

Избранное

Контакты

Рабочий стол

Ссылки

Сохраненные игры

Общий рабочий стол

Общие документы

Общая музыка

Общие изображения

Общее видео

14. Исправление проблемы, с дублированием ярлыков на рабочем столе.

Если при создании, копировании или перемещении на рабочий стол любого документа/ярлыка/папки, после обновления экрана или перезагрузки компьютера, у Вас появляются их дубликаты (точная копия, без (2) в названии), то это означает, что Ваш собственный рабочий стол и общий рабочий стол прописаны в реестре в одной папке. Данная проблема решается указанием для них отдельных отличающихся между собою папок.

1) Запустите Редактор реестра. Для этого в строке поиска в меню Пуск введите regedit и нажмите Enter
2) Откройте раздел: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
3) Измените значение параметра Common Desktop на одно из предложенных ниже:

C:\Users\Public\Desktop - значение Windows по умолчанию
C:\Users\ВашПрофиль\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок.

4) Откройте раздел: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
5) Измените значение параметра Common Desktop на одно из предложенных ниже:

%Public%\Desktop - значение Windows по умолчанию
%USERPROFILE%\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок.

15. Восстановление поиска в Проводнике и в меню Пуск.

1) Используя Реестр (Win+R -> regedit)
1.1) Откройте ветку реестра:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
1.2) В случае обнаружения параметра NoFind, удалите его.

2) Используя Панель управления
2.1) Откройте Панель управления\Программы\Программы и компоненты
2.2) Запустите "Включение и отключение компонентов Windows" (или Win+R -> OptionalFeatures.exe)
2.3) Проверьте, включен ли у Вас компонент Windows Search (Поиск Windows).

3) Используя Редактор локальной групповой политики.
3.1) В диалоговом окне Выполнить из меню Пуск (Win+R) введите команду gpedit.msc и нажмите Enter.
3.2) Откройте Конфигурация пользователя -> Административные Шаблоны -> Меню "Пуск" и панель задач
3.3) Измените следующие параметры политики на значение Не задана:

- Добавить ссылку "Поиск в Интернете" в меню "Пуск"
- Удалить ссылку "Поиск" из меню "Пуск"

16. Исправление всплывающей подсказки оказывающейся за панелью задач Windows.

Если у Вас возникает ошибка, когда всплывающая подсказка оказывается за панелью задач Windows, и её видно частично или совсем не видно, то Вы можете воспользоваться небольшой программой ToolTipFixer, которая исправляет эту ошибку, возвращая на место всплывающую подсказку.

Скачайте и установите ToolTipFixer

17. Решение проблемы пропадания значков в панели задач.

Это происходит потому, что загружаемые программы пытаются установить иконки раньше, чем explorer успевает инициировать трей. Для установки задержки запуска программ, Вы можете воспользоваться менеджером автозагрузки Startup Delayer.

В дополнение к программе воспользуйтесь твиком реестра.

Скачайте и примените его: tray_icons.reg

18. Удаление ярлыков на отсутствующие в системе элементы в папке "Недавние места".
Для удаления ярлыков на отсутствующие в системе элементы из папки "Недавние места" предлагаю Вам следующие варианты решения.

Вариант 1.

1) Откройте в проводнике папку Недавние документы (%AppData%\Microsoft\Windows\Recent)
Просьба не путать с папкой Недавние места (это другая папка)
2) Щелкните правой кнопкой мыши ярлык на отсутствующий в системе элемент(папку или файл) и выберите пункт Удалить.
3) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Обновить. Данное действие необходимо, чтобы убрать появившуюся на рабочем столе папку Недавние места.

Вариант 2.

Для его выполнения необходима программа Registry Workshop - заменяющая стандартный редактор реестра.

1) Запустите Registry Workshop
2) Нажмите Search (Поиск) -> Find...(Поиск...)
3) В открывшемся окне установите переключатель на Search in key: (В разделе:)
4) Введите HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RecentDocs
5) В текстовом поле Find what: (Запрос:) введите наименование отсутствующего в системе элемента (папки или файла)
6) Нажмите кнопку Find (Поиск)
7) Выделите найденное с помощью левой кнопки мыши или нажмите комбинацию клавиш Ctrl+A, чтобы выделить все.
8) Щелкните на выделенном правой кнопкой мыши и выберите пункт Delete From Registry (Удалить из реестра)

19. При загрузке Windows автоматически открывается окно Проводника.

Варианты решений:

1) Открыть Пуск - Панель управления - Параметры папок - убрать флажок "Восстанавливать прежние окна папок при входе в систему".
2) В командной строке (Win+R -> cmd -> OK) введите sfc /scannow и нажмите Enter
3) Создайте и примените reg-файл:

20. Восстановление запуска Exe-файлов в системе.

Данные проблема связана с изменением какой-нибудь программой в реестре параметров отвечающих за ассоциации exe-файлов.
Для устранения данной проблемы попробуйте один из следующих вариантов.

Вариант 1.

1) Откройте папку C:\Windows\System32
2) Сделайте копию файла regedt32.exe
3) Переименуйте данную копию в regedt32.com
4) Щелкните на данном файле правой кнопкой мыши и выберите Запуск от имени администратора.
5) Откройте ветку HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe
6) Удалите раздел UserChoice

Вариант 2.

1) Скачайте файл exefix_win7.zip
2) Разархивируйте его и примените reg-файл.

или же создайте самостоятельно в блокноте reg-файл следующего содержания:

21. Исправление ошибки проводника "Не удалось найти этот элемент".

Если у Вас возникает данная ошибка, то скорее всего у Вас сбились описания папок. Для их восстановления:

1) Скачайте файл FolderDescriptions.zip
2) Распакуйте его в любую папку.
3) В соответствии с разрядностью Вашей Windows примените reg-файл, восстанавливающий настройки описания папок в изначальные.
4) Перезагрузите компьютер.

22. Исправление появляющегося окна предупреждения системы безопасности "Неизвестный издатель", при открытии программы из меню Пуск.

1) Запустите командную строку от имени Администратора
(Нажмите Пуск -> в строке поиска введите cmd -> щелкните правой кнопкой мыши по найденному файлу cmd.exe -> выберите пункт Запуск от имени Администратора)
2) Поочередно введите команды, нажимая для их выполнения клавишу Enter:

23. Если у вас при запуске файлов *.chm неправильно определяется кодировка.

Если при создании *.chm файла принудительно не указать на каждой странице кодировку, то при его чтении у некоторых людей могут возникнуть трудности с определением кодировки. Для решения данной проблемы:

1) Закройте *.chm файл
2) Зайдите в Internet Explorer
3) Нажмите правую кнопку мыши
4) В появившемся меню наведите указатель на слово Кодировка и поставьте галочку напротив пункта Автовыбор
5) Запустите ваш *.chm и система сама определит кодировку.

24. Перестали запускаться анимированые обои. Ошибка:"Windows DreamScene can only run when Windows Aero scheme is selected."

Вероятно, аэро - отключено.
Щелкаете правой кнопкой на монитор - Персонализация - выберите тему с прозрачными окнами (они вверху).
Или C:\Windows\Resources\Themes выбрать aero.

25. Создание ярлыка и комбинации клавиш для закрытия зависших приложений и перезапуска Проводника.

Создание ярлыка и комбинации клавиш для закрытия зависших приложений.

1) Щелкните по рабочему столу и выберите во всплывшем меню Создать -> Ярлык.
2) В поле Укажите расположение объекта введите команду

3) Щелкните правой кнопкой мыши на ярлыке и выберите Свойства
4) В поле Быстрый вызов назначьте комбинацию клавиш для использования.

Создание ярлыка и комбинации клавиш для перезапуска Проводника.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).

2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .cmd. Например: restart_explorer.cmd
3) Щелкните по рабочему столу и выберите во всплывшем меню Создать -> Ярлык.
4) В поле Укажите расположение объекта выберите созданный Вами командный файл.
5) Щелкните правой кнопкой мыши на ярлыке и выберите Свойства
6) В поле Быстрый вызов назначьте комбинацию клавиш для использования.

26. Восстановление в всплывающем меню "Создать" пункта "Папку".

Если у Вас из всплывающего меню Создать находящегося в основном контекстном меню(вызывается нажатием правой кнопки мыши) пропал пункт Папку, то Вы можете скачать и применить reg-файл содержащий изначальные настройки для данного пункта меню в реестре.

Чтобы применение reg-файла прошло успешно, воспользуйтесь небольшой инструкцией:

1) Измените разрешения (установите полный доступ) и владельца для раздела реестра: HKEY_CLASSES_ROOT\CLSID\{11dbb47c-a525-400b-9e80-a54615a090c0}

1.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
1.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
1.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
1.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
1.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

2) Скачайте и примените reg-файл. NewFolderFix.zip
3) Перезагрузите компьютер. Для желающих создать данный reg-файл самостоятельно его текст:

27. Исправление отсутствия в папке Все программы из меню Пуск папки "Стандартные".

Для исправления данной ситуации Вам необходимо создать новый профиль и скопировать из него необходимые папки.

1) В строке поиска меню Пуск введите lusrmgr.msc и нажмите Enter.
2) Перейдите в папку Пользователи
3) Щелкните правой кнопкой мыши в средней части окна и выберите Новый пользователь.
4) Введите любое имя пользователя (Например: Demo) и снимите флажок "Требовать смены пароля при следующем входе в систему"
5) Нажмите Создать, а когда кнопка станет не активной нажмите Закрыть.
6) Выйдите из системы и войдите в систему, используя только что созданную учётную запись.
7) Выйдите из системы и войдите в систему, используя Вашу учётную запись.
8) Откройте Проводник введите в адресной строке указанный ниже адрес папки и нажмите Enter.

где Demo - имя созданной Вами учетной записи.
9) Щелкните правой кнопкой мыши на папке Стандартные (Accessories) и выберите пункт Копировать
10) Откройте Проводник введите в адресной строке указанный ниже адрес папки и нажмите Enter.

где UserName - имя Вашей учетной записи (его можно узнать открыв папку C:\Users).
11) Щелкните правой кнопкой мыши в пустой части окна данной папки и выберите пункт Вставить
12) Перезагрузите компьютер.

Для удаления созданной Вами учетной записи пользователя:

1) В строке поиска меню Пуск введите lusrmgr.msc и нажмите Enter.
2) Перейдите в папку Пользователи
3) Щелкните правой кнопкой мыши в списке на имя созданной Вами учетной записи и выберите пункт Удалить
4) Нажмите во всплывшем окне кнопку Да и выйдите из оснастки "Локальные пользователи и группы"
5) Откройте в проводнике папку C:\Users и удалите папку с именем созданной Вами учетной записи.

Устранение неполадок - Устройства и BSOD.

1. При использовании сторонних плееров для видео, выкидывает в BSOD.

Данную проблему можно решишь, если установить в расширенных настройках видео: Режим рендеринга или фильтр рендеринга для DirectShow Video на "Улучшенный обработчик видео" или "Enhanced Video Renderer" (EVR).

В Media Player Classic данный параметр находится View - Options - Playback - Output - Directshow Video - EVR.
В Bsplayer Pro данный параметр находится Опции - Настройки - Видео - Вывод видео - Режим рендеринга - EVR (Enhanced Video Renderer).

2. В папке "Компьютер" не отображаются DVD-дисководы.

Уберите флажок в Панель управления-Параметры папок-Вид "Скрыть пустые диски в папке "Компьютер""

3. В Windows и Nero не стираются диски DVD RW и CD RW.

Если при попытке стереть данные диски вы получаете ответ "Не перезаписываемый диск" или "Диск защищён от записи". По всей видимости была сделана метка на диске и программы определяют его как DVD-R. Чтобы убрать эту метку зайдите в Alcohol 120% и уберите метки в пунктах Сервис -> Настройки -> Эмуляция -> Игнорировать тип носителя, в Daemon Tools Спрятать CD-R.
Значение этой опции: Bынудить дpугиe пpoгpaммы нe oпpeдeлять зaпиcывaeмый тип диcкa, пpинимaя eгo зa CD-ROM или DVD-ROM.
После этого заново сотрите эти диски в Alcohol 120% или в Daemon Tools.

4. Определение драйвера, вызвавшего BSOD.

Включение записи дампов памяти

1) Нажимаете комбинацию клавиш Win+Pause
2) Щелкаете ссылку Дополнительные параметры системы
3) Переходите на вкладку Дополнительно
4) Нажимаете кнопку Параметры в Загрузка и восстановление

Рисунок 1 из 2

5) По умолчанию они будут сохраняться в папку %SystemRoot%\Minidump

Рисунок 2 из 2

Анализ дампа памяти и определение драйвера, вызвавшего ошибку:

Вариант 1

1) Загрузите и установите Debugging Tools for Windows.
2) Загрузите командный файл kdfe.cmd (Kernel Debugger Front End) со скриптом для облегчения анализа дамп-файлов, создаваемых Windows при STOP ошибках (BSoD), оригинальный его код взят на ресурсе sysadmins.ru.
3) Распакуйте архив в любую папку.
Примечание: Если папка Debugging Tools for Windows находиться у вас не в папке Program Files, то в файле kdfe.cmd необходимо указать другой путь к папке, в которую установлены средства Debugging Tools for Windows.
Путь к папке указан после параметра set dbgpath=
4) Откройте командную строку и перейдите в папку, в которую вы распаковали kdfe.cmd.
5) Запустите файл, указав в качестве параметра путь к файлу дампа памяти (в примере ниже файл называется Mini1110307-01.dmp)

6) Дождитесь завершения анализа. По окончании вы увидите драйвер, послуживший причиной ошибки.

Вариант 2

1) Скачиваете утилиту BlueScreenView.
2) Устанавливаете BlueScreenView.
3) Распаковываете bluescreenview_russian.zip и кладете файл bluescreenview_lng.ini в туже папку куда установлена BlueScreenView.
4) Запускаете BlueScreenView.

Поиск дампов производится в папке %systemroot%\Minidump, также можно настроить и собственную папку (Options –> Advanced).
Для найденных дампов памяти утилита отображает:
  • В верхней панели – название файла, дату создания, название стоп-ошибки, код ошибки, параметры, а также драйвер, предположительно вызвавший проблему (Caused By Driver).
  • В нижней панели – (в зависимости от настроек в Options –> Lower Pane Mode) все драйверы, загруженные во время ошибки, или только драйверы, найденные в стеке. Среди всех драйверов - на розовом фоне отображаются предположительно вызвавшие проблему драйверы. Также, утилита может отображать синий экран, очень похожий на тот, который все так любят.
Примечание: При определении драйвера не нужно полагаться только на имя файла в столбце Caused by Driver. Следует рассмотреть драйверы в нижней панели (или только выделенные розовым цветом, если включено отображение всех драйверов), в первую очередь обращая внимание на несистемные драйверы.

5. Расшифровка значений ошибок синего экрана смерти (BSOD) и способы их устранения.

Если у Вас появляется какая-либо ошибка синего экрана смерти, и Вы задумываетесь из-за чего же она произошла, то Вы можете:

1) Скачать подборку наиболее часто встречающихся ошибок и способов устранения многих из них: BSOD.rar
2) Почитать на форуме Oszone.net темы входящие в состав темы: Устранение критических ошибок Windows

6. В Windows x64 стало показывать меньше памяти, чем есть.

Зайдите:
Панель управления->Администрирование->Конфигурация системы>вкладка Загрузка->Дополнительные параметры
Проверьте максимум памяти. Или уберите галочку или поставьте нужное вам значение.

Также посмотрите значение функций в BIOS:

1. HPET Mode должно быть 64-bit (если есть такая функция)
или
2. Memory Remap Feature должно быть Enabled
3. Memory Hole должно быть Disabled

7. Windows зависает после перезагрузки с ошибкой Verifying DMI Pool Data.

Попробуйте следующие варианты решений:

1) Попробуйте установить другую сборку или версию Windows 7.
2) Сбросьте настройки BIOS в стандартные и установите Windows заново.
3) Обнулите на материнской плате CMOS: либо переустановив и вернув перемычку, либо нажав на кнопку сброса на материнской плате.
4) Установите в списке загрузок с жестких дисков в BIOS, приоритет загрузки Вашего диска с Windows 7 на первое место.
5) Подключите диск выделенный для Windows 7, как Primary Master.

8. Восстановление работы дополнительных клавиш на мультимедиа-клавиатуре.
Если на Вашей мультимедиа или офисной клавиатуре перестали работать дополнительные клавиши расширяющие её функциональность, то сделайте следующее.
Во-первых, проверьте установлено ли у Вас программное обеспечение с диска идущего в комплекте к клавиатуре или с официального сайта.
Если же оно установлено, то одной из наиболее часто встречающихся причин может быть остановка службы Доступ к HID-устройствам.

1) Зайдите в Панель управления\Система и безопасность\Администрирование и запустите Службы или
Нажмите кнопку Пуск, щелкните в поле Начать поиск, введите services.msc и нажмите клавишу Enter.
2) Проверьте указано ли в колонке Состояние, напротив службы Доступ к HID-устройствам значение: Работает
Если данная служба отключена и не работает, сделайте следующее:
3) Нажмите на ней правой кнопкой мыши и в появившемся меню выберите Свойства
4) Для запуска службы нажмите на кнопку Запустить
5) Также Вы можете установить Тип запуска: Автоматически, и система будет автоматически запускать данную службу при старте Windows.
6) Перейдите на вкладку Восстановление и установите действия выполняющиеся при первом или втором сбое, а также при последующих сбоях на значение Перезапуск службы и нажмите OK.

9. Исправление появившихся красных крестиков на значках локальных дисков.

1) Откройте Панель Управления -> Диспетчер Устройств
1.1) Проверьте включены ли все IDE ATA/ATAPI контроллеры
1.2) Проверьте включены ли все Дисковые устройства
2) Если есть общий доступ, попробуйте его отключить
Щелкните ПКМ на диске -> Общий доступ -> Расширенная настройка общего доступа... -> Расширенная настройка...
3) Почистите кэш иконок: для этого в папке %USERPROFILE%\AppData\Local\ удалите файл IconCache.db
4) Воспользуйтесь специальными утилитами для оптимизации работы компьютера. Например:
4.1.) TuneUp Utilities

4.1.1) В колонке Customize Windows нажимаете All functions и выбираете Change Windows appearance
4.1.2) В меню слева в списке группы Icons выбираете Repair
4.1.3) Нажмите на кнопку Reload Icons, а после на кнопку Repair Icon Cache

4.2) Windows 7 Manager

4.2.1) В меню слева во вкладке Information выберите Repair Center
4.2.2) В меню слева в Repair Center нажмите Icon Repair
4.2.3) В разделе Rebuild Icon Cache нажмите Rebuild

10. Восстановление автозапуска для всех типов приводов и устройств.
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Запустите reg-файл.

Также параметр NoDriveTypeAutoRun автоматически добавляется в реестр при установке программы VMware Workstation, используемой для создания виртуальной машины.

11. Исправление ошибок 0x0000007A, 0x00000077 или 0x000000F4 для SATA дисков после выхода из ждущего или спящего режимов.
На подготовку к работе жесткого диска отводится 10 секунд. Если накопитель не успеет за это время сообщить о своей работоспособности, то операционная система воспримет это как ошибку. Такое может происходить с винчестерами с интерфейсом SATA. Для устранения данной ошибки Microsoft выпустила обновление KB977178. Если же в вашей системе на базе Windows 7 подобных ошибок не возникает, то устанавливать исправление не рекомендуется.
Скачать исправление KB977178 : для x86 или для x64

12. Cистема находит Bluetooth-адаптер, а Bluetooth-устройства его не обнаруживают.

1) Нажмите Win+R (или Пуск -> Выполнить)
2) Введите команду:

или

и нажмите Параметры Bluetooth

3) Установите необходимые Вам настройки.

Чтобы сделать компьютер обнаруживаемым устройствами с поддержкой Bluetooth, установите флажок Разрешить устройствам Bluetooth обнаруживать этот компьютер.
Чтобы разрешить добавление устройств с поддержкой Bluetooth на компьютер, установите флажок Разрешить устройствам Bluetooth подключаться к этому компьютеру.
Чтобы получать уведомления о попытках устройств с поддержкой Bluetooth подключиться к компьютеру, установите флажок Оповещать при подключении нового устройства Bluetooth.

13. Восстановление значка "Безопасное извлечение устройства".

1.1) Создайте и импортируйте в реестр reg-файл указанного ниже содержания. После чего перезагрузите компьютер.

1.2) Перезайдите в систему или перезагрузите компьютер.

2) Откройте Пуск -> Выполнить (Win+R) и запустите поочередно следующие команды

3.1) Щелкните по рабочему столу и выберите во всплывшем меню Создать -> Ярлык.
3.2) В поле Укажите расположение объекта введите команду

3.3) Перенесите созданный Вами ярлык на панель задач, чтобы закрепить его там.

Также Вы можете просто запустить окно "Безопасное извлечение устройства" введя команду в диалоговом окне Выполнить (Win+R) :

14. Решение проблемы пропадания места на системном жестком диске.

Прежде всего выполните проверку жесткого диска, если дело окажется в ошибках, то система поможет Вам их исправить:

1) Нажимаете кнопку Пуск и в строке поиска вводите cmd
2) Нажимаете правой кнопкой мыши на найденной команде и выбираете "Запустить от имени Администратора"
3) Вводите команду SFC /scannow и нажимаете Enter

Для увеличения свободного пространства Вы можете сделать следующее:

1) Запустите Очистка диска. Нажимаете кнопку Пуск -> Все программы -> Стандартные -> Служебные.
1.1) На вкладке Очистка диска Вы можете удалить временные файлы
1.2) На вкладке Дополнительно Вы можете удалить все точки восстановления, кроме самой последней.

2) Отключите функцию создания точек восстановления или уменьшите размер используемого дискового пространства.
2.1) Нажмите кнопку Пуск
2.2) Щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства (Панель управления\Система и безопасность\Система)
2.3) Слева нажмите ссылку Защита системы
2.4) В открывшемся окне нажмите кнопку Настроить
2.5) Отключите защиту системы или измените используемый ею размер дискового пространства.

4) Отключите режим гибернации.
Запустите командную строку с правами администратора (Win+R -> cmd -> Ok) и выполните в ней команду: powercfg /h off

5) Измените размер файла подкачки.
5.1) Нажмите кнопку Пуск
5.2) Щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства (Панель управления\Система и безопасность\Система)
5.3) Слева нажмите ссылку Дополнительные параметры системы
5.4) В разделе Быстродействие нажмите кнопку Параметры
5.5) Перейдите на вкладку Дополнительно и нажмите кнопку Изменить

6) Очистите папку кэша C:\Windows\rescache
7) Очистите временные папки (карантин) используемой Вами системы защиты (Norton, Kaspersky, Eset 32 и др.), в некоторых стоит отключить трассировки.
8) Скачайте программу Scanner by Steffen Gerlach для анализа содержимого жестких дисков. Эта программа поможет Вам увидеть, какая папка или файл занимает большую часть вашего диска.

15. Windows не определяет второй жесткий диск после установки.

Данное действие иногда происходит по причине неправильной установки скрытого раздела System Reserved (Зарезервировано системой).
Например, если у Вас один жесткий диск, то Windows 7 при инсталляции выделяет скрытый раздел System Reserved (Зарезервировано системой) для защиты загрузочных файлов операционной системы.
Если во время инсталляции были подключены два жестких диска, то иногда Windows может некорректно определить второй жесткий диск и использовать его как скрытый раздел System Reserved (Зарезервировано системой). В результате чего, у него будет отсутствовать буква диска.

Для добавления буквы диска сделайте следующее:

1) Запустите оснастку Управление дисками: Открываете меню Пуск, в поле поиска пишите diskmgmt.msc и нажимаете Enter
2) Находите Ваш диск, у него будет отсутствовать буква диска.
3) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить букву диска или путь к диску.
4) В открывшемся окне нажимаете кнопку Добавить выбираете необходимую Вам букву и нажимаете ОК.

Если диск не появился в Проводнике(Windows Explorer), то перезагрузите компьютер.

16. Не переименовывается диск (не меняется метка тома) в Windows 7.

Данная проблема может возникнуть, в результате появления в корне диска файла или папки с именем "Autorun.inf".
Если Вы не создавали его самостоятельно для защиты от вирусов использующих автозапуск, то файл (папка) мог создаться какой-либо программой.
Для исправления данной проблемы сделайте следующее:

1) Откройте Пуск - Панель управления и запустите "Параметры папок"
2) Перейдите на вкладку "Вид" и установите переключатель отвечающий за "Скрытые файлы и папки" в значение "Показывать скрытые папки, файлы и диски".
3) Удалите в корне диска файл или папку с именем "Autorun.inf".
4) Перезагрузите компьютер.
5) Измените метку диска (Win+R - label.exe - OK)
Если же Вы создали файл "Autorun.inf" сами, то просто добавьте в него следующее:

Вместо Метка тома подставьте необходимое Вам значение.

17. Отключение отображения внутренних жестких дисков в "Безопасное извлечение устройств и дисков".
В Windows 7 система использует универсальный драйвер как для SATA (интерфейс подключения внутренних устройств), так и eSATA (интерфейс подключения внешних устройств).
Поэтому, независимо от того к которому из них подключен жесткий диск система определяет поддерживает ли устройство функцию извлечения "на лету".
Если Ваша система использует режим AHCI, то в списке Безопасное извлечение устройств и дисков на панели задач появятся Ваши жесткие диски. Это обусловлено функциональными особенностями AHCI режима, а именно функцией "горячей" замены (HotPlug), означающей возможность извлечения оборудования в компьютерной системе во время работы.
Если Вы не используете мобильное шасси (Mobile Rack) для внутренних жестких дисков и не планируете их извлекать, то Вы можете отключить их отображение в списке Безопасное извлечение устройств и дисков.

Вариант 1. Установите родные драйвера для чипсета к которому подключены жесткие диски. Например для чипсета Intel, драйвера для технология хранения Intel® Rapid.

Вариант 2. Укажите системе, что устройство должно использовать внутренний порт. В диалоговом меню Выполнить (Win+R) или в командной строке запущенной от имени администратора () введите команду:

Где (n)- номер контроллера, на котором висит диск, а (N) - номер канала. В большинстве случаев по умолчанию это 0 в обоих случаях.

Повторите данное действие для каждого диска, заменив значения на необходимые. Номер контроллера в большинстве случаев по умолчанию равен 0 для каждого из Ваших дисков. Номер канала Вы можете посмотреть в диспетчере устройств, на вкладке Сведения, в свойствах Вашего жесткого диска. Значения каналов имеют порядковые номера, начинающиеся с цифры 0.
Например, если у Вас 2 жестких диска, то Вам, скорее всего, нужно будет ввести следующие команды:

Вариант 3. Использование стороннего программного обеспечения.

1) Скачайте и установите программу USB Safely Remove. Данная программа заменит встроенную в Windows функцию Безопасное извлечение устройств и дисков на собственную утилиту.
2) Для того, чтобы иконка пряталась, когда нет ни одного подключенного устройства, включите опцию "Hide icon when there are no devices to be stopped". Она располагается на закладке настроек "Look and Feel".

18. Проверка драйверов для выявления неполадок в работе Windows.

Если Вы предполагаете, что какой-либо из драйверов работает некорректно или, проанализировав дамп памяти, Вы определили драйвер вызвавший ошибку, то для более тщательной проверки работы драйверов Вы можете самостоятельно выполнить проверку драйверов с помощью встроенного в операционную систему средства проверки Verifier.exe.

Проверка неподписанных драйверов.

1) В строке поиска меню Пуск введите verifier и нажмите Enter.
2) Выберите пункт Создать нестандартные параметры (для кода программ) и нажмите кнопку Далее.
3) Установите переключатель в значение Выбрать отдельные параметры из полного списка и нажмите кнопку Далее.
4) Отметьте все флажки кроме флажка Имитация нехватки ресурсов и нажмите кнопку Далее.
5) Установите переключатель в значение Автоматически выбирать неподписанные драйверы и нажмите кнопку Далее.

Если неподписанные драйверы обнаружены, система отобразит Вам их список, в котором будут указаны файлы драйверов и их описание. Причем найденные драйвера могут принадлежать как устройствам, так и приложениям. Не закрывайте пока окно средства проверки драйверов и не нажимайте никаких кнопок.

Дальше возможно три варианта предпринимаемых Вами действий.

Вариант 1. Обновление программы или драйвера.

6) Посетите сайт производителя устройства или автора программы и скачайте более новую версию.
7) Переустановите программу или обновите драйвер.
8) После обновления приложения или драйвера закройте окно средства проверки драйверов, нажав кнопку Отмена.
9) Перезагрузите компьютер и продолжайте работу в операционной системе.
Если в системе не возникают ошибки связанной с данным драйвером, значит обновление драйвера или программы устранило её.

Вариант 2. Удаление программы или драйвера.

6.1) Удалите программу, которой принадлежит данный драйвер.
6.1.1) Откройте Панель управления\Все элементы панели управления\Программы и компоненты и удалите приложение, которому принадлежит драйвер.
Перед удалением программы убедитесь, что у Вас присутствует ее установочный диск или ее установка сохранена у Вас на диске.

6.2) Удалите драйвер в Диспетчере устройств.
6.2.1) В меню Пуск щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства.
6.2.2) Нажмите в списке слева на Диспетчер устройств.
6.2.3) В Диспетчере устройств найдите устройство, щелкните по нему правой кнопкой мыши и выберите из контекстного меню пункт Свойства.
6.2.4) Перейдите на вкладку Драйвер и нажмите кнопку Удалить.

7) После удаления приложения или драйвера закройте окно средства проверки драйверов, нажав кнопку Отмена.
8) Перезагрузите компьютер и продолжайте работу в операционной системе.

Если в системе не возникают ошибки связанной с данным драйвером, значит удаление драйвера или программы устранило её.

Вариант 3. Проверка неподписанных драйверов.

Внимание! После проверки неподписанных драйверов система может не загрузиться (прежде чем переходить к дальнейшим действиям, прочтите данный вариант до конца).

6) Нажмите кнопку Готово и перезагрузите компьютер.

Если же после перезагрузки появился синий экран с ошибкой, проблемный драйвер определен - его название будет включено в сообщение об ошибке. В таком случае:

7) Перезагрузите компьютер
8) До начала запуска Windows нажмите на клавишу F8. При появлении окна выбора дисков: выберите диск на котором у Вас установлена Windows, нажмите Enter, а затем сразу F8.
9) Выберите пункт Безопасный режим
10) Откройте диалоговое меню Выполнить: Пуск -> Выполнить или нажмите комбинацию Win+R
11) Введите команду verifier.exe /reset и нажмите Enter.

Если система загрузилась в обычном режиме, проверка неподписанных драйверов завершилась успешно - они не являются источником проблем.

Проверка подписанных драйверов.

1) В строке поиска меню Пуск введите verifier и нажмите Enter.
2) Выберите пункт Создать нестандартные параметры (для кода программ) и нажмите кнопку Далее.
3) Установите переключатель в значение Выбрать отдельные параметры из полного списка и нажмите кнопку Далее.
4) Отметьте все флажки кроме флажка Имитация нехватки ресурсов и нажмите кнопку Далее.
5) Установите переключатель в значение Выбрать имя драйвера из списка и нажмите кнопку Далее.
6) Нажмите на заголовок колонки Поставщик для сортировки драйверов по их поставщику.
7) Выберите первые 10-15 драйверов установив напротив них флажки в колонке Проверить.
Не выбирайте все драйверы сразу, так как их проверка займет много времени и ресурсов системы.
8) Нажмите кнопку Готово и перезагрузите компьютер. Если система загрузилась в обычном режиме, проверка выбранных драйверов завершилась успешно - они не являются источником проблем. В таком случае повторите описанные выше действия выбрав следующие 10-15 драйверов.

Если же после перезагрузки появился синий экран с ошибкой, проблемный драйвер определен - его название будет включено в сообщение об ошибке. В таком случае:

1) Перезагрузите компьютер
2) До начала запуска Windows нажмите на клавишу F8. При появлении окна выбора дисков: выберите диск на котором у Вас установлена Windows, нажмите Enter, а затем сразу F8.
3) Выберите пункт Безопасный режим
4) Откройте диалоговое меню Выполнить: Пуск -> Выполнить или нажмите комбинацию Win+R
5) Введите команду verifier.exe /reset и нажмите Enter. Если проверка всех драйверов завершилась успешно, то скорее всего, драйверы не являются причиной критической ошибки, возникающей в Вашей системе.

19. При установке Windows, в окне выбора раздела на диске создается раздел с нулевым размером.

В случае появления, при установке Windows, в окне выбора раздела на диске - пункта: Незанятое место на диске 0. Полный размер 0.0МБ, свободно 0.0МБ, выполните указанные ниже действия:

Если у Вас несколько дисков, то для выполнения указанной ниже инструкции оставьте подключенным только тот диск, для которого создается нулевой раздел. Остальные диски отключите.

1) Установите в BIOS режим для дисков на IDE.

Если Вы не можете войти в BIOS для изменения настроек (из-за того что компьютер висит), тогда: 1.1) Выключите компьютер, отсоедините SATA-кабель от диска
1.2) Включите компьютер и измените режим.
1.3) Выключите компьютер, подсоедините SATA-кабель к диску
1.4) Включите компьютер

2) Загрузитесь с Вашего Windows 7 DVD, выберите Установить.
3) Когда Вы окажетесь в окне выбора раздела для установки Windows, удалите все возможные разделы на диске. (Не обращая внимания, на то, что остались не удаленными нулевые разделы.)
4) Выйдите из программы установки Windows. Не продолжайте.
5) Перезапустите компьютер. При желании измените в BIOS режим для дисков с IDE на AHCI.
6) Опять загрузитесь с Вашего Windows 7 DVD, и снова выберите Установить.
7) Когда Вы окажетесь в окне выбора раздела для установки Windows, разделов с 0 размером быть не должно.
8) Укажите все доступное пространство для создание одного раздела.
9) Продолжите установку как обычно.

Устранение неполадок - Локальная сеть и Интернет.

1. Невозможно переместить Временные файлы Интернета на другой логический диск (D:\Cash).

Установите, как минимум, пониженный уровень UAC.

2. Если гаджет погоды пишет service unavailable for your region.

Для нормальной работы гаджетов не отключайте UAC полностью, а ставьте на минимум.
Если отключить UAC совсем (крайне нижнее положение - Never Notify), то гаджеты могут пропасть.
А панель настройки гаджетов может стать недоступной.

Вариант 1

Завершите процесс sidebar.exe и перезапустите его (правой кнопкой мыши на рабочем столе --> Gadgets)

Также добавьте в папке %WINDIR%\system32\driverc\etc в файл hosts следующие строки:

Вариант 2

Если перезапуск не помогает, то вы можете поставить другой гаджет погоды, например: AccuWeather.com® Forecast Gadget или HTC Home

3. В Windows Update при попытке обновления появляется error 80072ee7.

Если во время проверки наличия обновлений Центр обновления Windows выдает сообщение об ошибке 80072ee7, возможно, следует изменить или удалить статические IP-адреса для службы Центра обновления Windows . Адреса хранятся в файле операционной системы Hosts.

IP-адрес для службы Центра обновления Windows может изменяться во время каждой проверки наличия обновлений, однако некоторые программы-надстройки Windows добавляют в файл Hosts статические адреса. Статический IP-адрес для службы Центра обновления Windows не позволит компьютеру получать обновления.

Удаление статического IP-адреса для веб-сайта службы Центра обновления Windows

1. Откройте компонент Компьютер. Для этого нажмите кнопку Пуск и выберите пункт Компьютер.
2. Дважды щелкните значок локального жесткого диска, на котором установлена система Windows (обычно диск С).
3. Дважды щелкните папку Windows, а затем - папку System32.
4. Дважды щелкните папку драйверы, а затем - папку и т. д..
5. В папке etc щелкните правой кнопкой мыши файл hosts и нажмите Открыть. После того как вам будет предложено выбрать программу, с помощью которой следует открывать данный файл, выберите Блокнот.
6. Проверьте, стоит ли в файле hosts знак # около всех записей IP-адресов и имен узлов Центра обновления Windows. Если это не так, вставьте значок # или удалите запись целиком.
7. Откройте меню Файл, выберите команду Сохранить и повторно выполните проверку наличия обновлений.

4. Решение проблемы с punkbuster на Windows 7.

Вариант 1.

Решение проблемы вылетов игр (Например: COD 5 и Battlefield 2) с ошибкой: punkbuster kiked player *** for 0 minets. RESTRICTION: unknow windows APL function 131132 (131131, 131134, 131136).
1) Обновите PunkBuster:
1.1) Скачайте программу обновления PunkBuster
1.2) Установите программу и запустите ее.
1.3) Добавьте туда игру, для которой нужно обновить punkbuster и нажмите check for updates. По завершению появится сообщение об окончании обновления.
2) Откройте папки C:\Windows\System32 (для х86) и/или C:\Windows\SysWOW64 (для х64)
3) Установите в свойствах файлов PnkBstrA.exe и PnkBstrB.exe совместимость с Windows XP или Windows Vista и уровень прав администратора. (PnkBstrB.exe еще есть в папке с игрой. Например: C:\Users\*username*\AppData\Local\PunkBuster\BF2\pb).

Вариант 2.

1) Откройте папки C:\Windows\System32 (для х86) и/или C:\Windows\SysWOW64 (для х64)
2) Установите в свойствах файлов PnkBstrA.exe и PnkBstrB.exe совместимость с Windows XP или Windows Vista и уровень прав администратора.
3) На рабочем столе создайте bat-файл со следующим содержанием:

4) Запускайте данный bat-файл перед запуском игр.

5. Исправление длительного времени задержки (лагов) в компьютерных сетях.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\
3) Найдите в ней раздел соответствующий интерфейсу, по которому у Вас работает интернет. Если Вы его не нашли, то дальнейшие действия произведите во всех разделах.
4) Создайте DWORD-параметр и назовите его TcpAckFrequency
5) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить
6) Установите значение переключателя на Шестнадцатеричное, введите значение параметра 1 и нажмите ОК.
7) Откройте Пуск -> Панель управления -> Программы и Компоненты
8) В меню слева нажмите ссылку Включение и отключение компонентов Windows.
9) Найдите пункт Сервер очереди сообщений Майкрософт (MSMQ) (Microsoft Message Queue (MSMQ) Server) и установите на нем флажок. Также установите флажки на всех компонентах внутри.

10) Перезагрузите компьютер.
11) Запустите Редактор реестра (Win+R -> regedit -> Ok)
12) Откройте ветку: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters
13) Создайте DWORD-параметр и назовите его TCPNoDelay
14) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить
15) Установите значение переключателя на Шестнадцатеричное, введите значение параметра 1 и нажмите ОК.

6. При вызове справки пишет "Internet Explorer не удается загрузить / из help".

При вызове справки "Справка и поддержка" появляется сообщение об ошибке:

Это может происходить по причине неправильного сопоставления программам типа файлов .xml
Для исправления ошибки скопируйте код в новый текстовый файл, сохраните его, присвоив расширение .reg, запустите и согласитесь с внесением изменений в реестр.

7. Если при VPN соединении через bat-файл у вас появляется ошибка 623.

Переименуйте имя соединения на английский язык и всё должно заработать.

8. Не работают обновления, в центре обновления Windows надпись: Некоторые параметры задаёт системный администратор.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate]
3) Удалите параметр DisableWindowsUpdateAccess
4) Закройте Редактор реестра и перезагрузите компьютер.

9. Сетевой адаптер отключает сеть через каждые 5 минут.

1) Запустите Диспетчер устройств (Win+R -> devmgmt.msc -> ОК)
1.1) Откройте меню Пуск
1.2) Нажмите правой кнопкой на Компьютер и выберите пункт Свойства (Панель управления\Все элементы панели управления\Система)
1.3) Нажмите на ссылку Диспетчер устройств
2) Откройте Сетевые адаптеры
3) Щелкните правой кнопкой мыши на Вашем сетевом адаптере и выберите пункт Свойства
4) Перейдите на вкладку Управление электропитанием
5) Уберите флажок Разрешить отключение этого устройства для экономии энергии.

10. Восстановление иконок html-файлов, при использовании Mozilla Firefox.
Для восстановления иконок html-файлов - создайте и примените reg-файл следующего содержания.

11. Устранение "Ошибки 711".

Вариант 1.

Эта ошибка может возникнуть, если не запущены все или некоторые из перечисленных ниже служб.

Диспетчер автоматических подключений удаленного доступа
Диспетчер подключений удаленного доступа
Телефония

Для устранения этой ошибки выполните следующие действия для каждой из указанных выше служб.

1) Нажмите кнопку Пуск
2) Откройте Панель управления -> Администрирование -> Службы (или Win+R -> services.msc)
3) Щелкните правой кнопкой мыши на одну из указанных выше служб и затем щелкните Свойства.
4) На вкладке Общие в пункте Тип запуска выберите вариант Вручную.
5) Нажмите Применить, а затем нажмите Запустить.

Вариант 2.

Загрузитесь из Erd Commander (или любого LiveCD) и переименуйте папку ..\Windows\System32\Logfiles в Logfiles.old

Вариант 3.

Щелкните правой кнопкой мыши на папке Windows и выберите Свойства, перейдите на вкладку Безопасность, проверьте, чтобы в окне группы и пользователи обязательно были: "СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ", "система" и "TrustedInstaller" с разрешением полного доступа, дополнительно могут быть "Administrators", "Users"

Вариант 4.

1) Откройте меню Пуск и в строке поиска введите cmd
2) Щелкните правой кнопкой мыши на найденном файле и выберите строку "Запуск от имени администратора"
3) Введите указанную ниже команду и нажмите Enter:

12. Исправление ошибки Internet Explorer: "Internet Explorer has stopped working".

Вариант 1.

1) Нажмите кнопку Пуск
2) Откройте Панель управления и запустите Свойства обозревателя
3) Перейдите на вкладку Дополнительно
4) Нажмите кнопку Сброс...
5) Прочитайте информационное сообщение и нажмите кнопку Сброс

Вариант 2.

1) Нажмите кнопку Пуск
2) Откройте Панель управления и запустите Свойства обозревателя
3) Перейдите на вкладку Безопасность
4) Уберите флажок Включить защищенный режим.
5) Перезапустите Internet Explorer (если он был запущен).

Вариант 3.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKLM\SOFTWARE\Microsoft\SQMClient\Windows\DisabledSessions
3) Удалите все параметры, кроме параметра (По умолчанию)

Вариант 4.

1) Откройте меню Пуск.
2) В строке поиска введите gpedit.msc и нажмите Enter
3) Перейдите к Конфигурация компьютера\Административные шаблоны\Система\Управление связью через Интернет\Параметры связи через интернет
4) Щелкните дважды левой кнопкой мыши на Отключить программу по улучшению качества программного обеспечения Windows.
5) Установите переключатель в значение Включить и нажмите ОK.

13. Удаление временных файлов обновлений(+очистка журнала обновлений) для устранения ошибок, возникающих в Центре обновления Windows.

Если во время установки или проверки наличия обновлений Центр обновления Windows выдает Вам сообщения об ошибках, то возможно Вам необходимо удалить временные файлы, которые используются Windows для определения обновлений для компьютера.
Внимание: Удаление временных файлов обновлений, также приведет к удалению журнала Центра обновления Windows.

1) Остановите службу Центр обновления Windows
1.1) Откройте Пуск -> Панель управления -> Администрирование -> Службы. Щелкните на службе Центр обновления Windows правой кнопкой мыши и выберите пункт Остановить.
или
1.2) Введите в командной строке (Win+R -> cmd -> ОК) команду net stop wuauserv и нажмите Enter.

2) Удалите временные файлы обновлений, для этого полностью удалите содержимое папок:

%systemroot%\SoftwareDistribution\DataStore
%systemroot%\SoftwareDistribution\Download

3) Запустите службу Центр обновления Windows
3.1) Откройте Пуск -> Панель управления -> Администрирование -> Службы. Щелкните на службе Центр обновления Windows правой кнопкой мыши и выберите пункт Запустить.
или
3.2) Введите в командной строке (Win+R -> cmd -> ОК) команду net start wuauserv и нажмите Enter.

14. Не получается включить сетевое обнаружение в дополнительных параметрах общего доступа.

1) Откройте Панель управления\Сеть и Интернет\Центр управления сетями и общим доступом
2) Измените расположение для сети на Домашняя сеть щелкнув на ссылку Общественная сеть под Вашим подключением.
3) Откройте Панель управления -> Администрирование -> Службы и проверьте включены ли у Вас службы

4) Некоторые антивирусные программы также могут блокировать данные действия. Попробуйте отключить антивирусное обеспечение, затем измените настройку и проверьте сохранятся ли настройки.

15. Восстановление в Mozilla Firefox 4 окна "Выход из Firefox" с кнопками "Сохранить и Выйти", "Выйти" и "Отмена".

1) В главном меню откройте Инструменты -> Настройки
2) На вкладке Основные в разделе Запуск установите значение "При запуске Firefox: Показывать домашнюю страницу" и нажмите ОК.
3) В адрессной строке введите about:config и нажмите Enter.
4) В строке Фильтр введите browser.showQuitWarning
5) Дважды щелкните на найденном параметре, чтобы его значение переключилось на true.

16. Ftp-сервер при вводе адреса в проводнике открывается в Internet Explorer.

1) В Internet Explorer откройте Свойства обозревателя.
Если у Вас включена Строка меню, то данный пункт расположен в меню Сервис, если Строка меню отключена, то нажмите на значок шестеренки.
2) Перейдите на вкладку Дополнительно
3) Установите флажок: Разрешить просмотр FTP-папок (за пределами Internet Explorer)


1. Компьютер не видит локальный диск с предыдущей ОС или диск отображается без буквы.

1) Щелкните правой кнопкой мыши на Компьютер (например в меню Пуск) и выберите Управление.
2) В левом окне выберите Управление дисками
3) Посередине вверху посмотрите, какие из томов не имеют букву.
Если среди томов присутствует раздел размером 200 МБ, то Вы ему букву не изменяете.
4) Присвойте букву тому диску, в котором находится предыдущая Windows (смотрим по размеру). Для этого щелкните на нем правой кнопкой мыши и в контекстном меню выберите пункт Изменить букву диска или путь к диску.
5) Нажмите Добавить, выберите букву и нажмите OK.
6) Через несколько секунд должно открыться окно автозапуска диска. А сам диск появится в Компьютере.
7) Откройте Панель управления -> Параметры папок
8) Перейдите на вкладку Вид и проверьте установлен ли флажок Отображать буквы дисков, если нет, то установите его.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


2. Решение проблемы с анимацией DWM (Desktop Window Manager).

1) Нажимаете "Пуск" на панели задач
2) Нажимаете правой кнопкой на Компьютер
3) Выбираете Свойства -> Дополнительные параметры системы
4) В открытом окне выбираете вкладку Дополнительно-Быстродействие-Параметры
5) На вкладке Визуальные эффекты, уберите галочку - Анимация окон при свертывании и развертывании.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


3. Решение проблемы с доступом к wim-файлу при работе с программой Dism.

При возникновении ошибок с доступом при работе с wim файлом в программе DISM, Вы можете воспользоваться одним из предложенных вариантов.

Вариант 1. Новые имена папок.

1) В командной строке запущенной от имени администратора (Win+R -> cmd -> OK), выполните следующую команду:

2) Создаете новую папку для wim-файла и переместите в нее Ваш wim-файл. (Например: вместо текущей папки mWim, создайте новую mWim1)
3) Создайте новую папку, куда Вы будете монтировать Ваш wim-файл для работы. (Например: вместо текущей папки Mount, создайте новую Mount1)
4) Продолжайте работу с новыми папками.

Вариант 2. Старые имена папок.

1) В командной строке запущенной от имени администратора (Win+R -> cmd -> OK), выполните следующую команду:

2) Переместите Ваш wim-файл в любую другую папку.
3) Удалите папки, которые Вы использовали для wim-файла и монтирования индекса.
4) Создайте заново папки с теми же названиями.
5) Верните wim-файл обратно.
6) Продолжайте работу с теми же папками, что и раньше.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


4. Очистка или изменение размера кэша иконок, для решения проблем с их отображением.

Удаление кэша эскизов может понадобиться при возникновении проблем с их отображением. После удаления кэша эскизов они вновь будут записаны при обращении к папкам с обрабатываемыми типами файлов, таким образом пересоздастся кэш и возможно удастся решить проблему с отображением некоторых эскизов.
Для очистки кэша эскизов сделайте следующее.

1) Нажмите комбинацию клавиш Win+R, в поле Открыть напишите cleanmgr и нажмите OK.
2) Выберите диск на который у Вас установлена Windows (по умолчанию C:) и после оценки объема места, которое можно освободить, отметьте Эскизы и нажмите OK
3) В проводнике откройте папку %USERPROFILE%\AppData\Local\ и удалите файл IconCache.db

Вы можете сделать это автоматически используя программу Rebuild Icon Cache

Также Вы можете создать и применить reg-файл:

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


5. Причины перехода цветовой схемы на упрощенный стиль.

Отображение сообщения об отключении некоторых визуальных элементов, таких как прозрачность рамки окна, или о замене цветовой схемы на упрощенный стиль может быть вызвано одной из следующих причин:

1) Запущенная программа несовместима с темами Aero. В этом случае некоторые визуальные элементы автоматически отключаются. После завершения работы такой программы отключенные визуальные элементы автоматически включаются.
2) Возможно, уровень заряда батареи переносного компьютера очень низкий. Темы Aero или прозрачность окон в системе Windows могут быть отключены для экономии энергии батареи.
3) Было изменение конфигурации оборудования компьютера или разрешения экрана. После изменения разрешения экрана, параметров видеокарты или монитора компьютер, возможно, больше не соответствует минимальным требованиям для запуска тем Aero.
4) Недостаточный объем памяти компьютера для выполнения всех запущенных программ и использования темы Aero.

Если ОС Windows автоматически изменила тему на упрощенный стиль, но необходимо вернуться к теме Aero, закройте несколько окон, чтобы освободить память, а затем выполните следующие действия:

1) Используйте "Запуск средства устранения неполадок интерфейса Aero".
1.1) Откройте меню Пуск и введите команду в строке поиска, щелкните на ней и нажмите Enter
или
1.2) Нажмите Win+R и введите команду в диалоговом окне Выполнить

2) Нажмите Далее

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


6. Выбор настроек во время установки для предотвращения замены русских букв знаками вопросов.

На начальном этапе установки выводится окно, содержащее три строчки.
Первая строчка - язык, на котором работает система (английский US или русский RU). При возможности выберите русский.
Вторая строчка - месторасположение компьютера, для выбора страны (от Афганистана и до Ямайки). Выберите страну - Russian Federation.
Третья строчка - язык раскладки клавиатуры по умолчанию. При выборе во второй строчке страны (РФ), здесь автоматически устанавливается русский. Вы можете выбрать здесь любой используемый Вами язык раскладки клавиатуры.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


7. Решение проблемы с неправильным отображением русских букв.

1.1) Запустите редактор реестра: Win+R -> regedit -> Ok или введите regedit в строке поика меню Пуск и нажмите Enter.
1.2) Откройте ветку реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage
1.3) Измените значение параметра 1252 с "c_1252.nls" на "c_1251.nls"
1.4) Откройте папку C:\WINDOWS\system32\ и найдите файлы c_1251.nls и c_1252.nls и задайте полный доступ к данным файлам.
1.5) Переименуйте файл c_1252.nls в c_1252.bak.
1.6) Создайте здесь же копию файла c_1251.nls.
1.6.1) Щелкните правой кнопкой мыши на файле и выберите Копировать.
1.6.2) Щелкните правой кнопкой мыши в пустом месте папки C:\WINDOWS\system32\ и выберите Вставить.
1.7) Переименуйте c_1251 - копия.nls в c_1252.nls. В итоге файл c_1252.nls, должен быть переименованной копией c_1251.nls
1.8) Перезагрузите компьютер.

Если у Вас установлена Русская Windows или Английская+русский MUI, то проделайте также следующее:

2.1) Запустите редактор реестра: Win+R -> regedit -> Ok или введите regedit в строке поиска меню Пуск и нажмите Enter.
2.2) Откройте ветку реестра HKEY_CURRENT_USER\Control Panel\International
2.3) Проверьте значение параметров Locale и LocaleName
Параметр Locale должен иметь значение 00000419, а параметр LocaleName должен иметь значение ru-RU
2.4) Если значения параметров другие: дважды щелкните на параметре, который необходимо изменить, введите необходимое значение параметра и нажмите OK.
2.5) Перезагрузите компьютер.

3.1) Откройте Язык и региональные стандарты.
Пуск -> Панель управления -> Язык и региональные стандарты (или Win+R -> control /name Microsoft.RegionAndLanguage -> Ок)
3.2) Перейдите на вкладку Дополнительно. Можете сразу открыть её: Win+R -> control intl.cpl,,3 -> Ок
3.3) В блоке Язык программ, не поддерживающих Юникод нажмите на кнопку Изменить язык системы
3.4) Выберите язык системы Русский (Россия) и нажмите ОК.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


8. Запись последовательности действий пользователя для анализа их разработчиком.

Одной из встроенных диагностических утилит, чтобы отсылать отчеты об ошибках является "Средство записи действий по воспроизведению неполадок".
Эта функция, которая позволяет пользователям записывать свои действия в любом используемом приложении и предоставлять подробное представление действий со снимками экрана с соответствующими комментариями.
Для того, чтобы открыть приложение "Средство записи действий по воспроизведению неполадок" нужно нажать на кнопку меню «Пуск» и в поле поиска ввести psr.
Для того, чтобы начать запись действий, с которыми возникают проблемы или вопросы нужно просто нажать на кнопку "Начать запись". После этого можно выполнять любые действия с операционной системой и установленными приложениями для воспроизведения проблемы.
Чтобы приостановить на время запись действий, необходимо нажать на кнопку "Приостановить запись".
Для того, чтобы снова возобновить запись действий нажимаем на кнопку "Возобновить запись".
Сразу после остановки записи откроется диалоговое окно "Сохранить как", в котором нужно ввести имя файла и нажать на кнопку "Сохранить". После выполнения этих действий файл будет сохранен в указанной директории с расширением ZIP.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


9. Решение проблемы с выходом из спящего/ждущего режима в черный экран.

Если при попытке выходе из спящего/ждущего режима Вы попадаете в черный экран или в BSOD (синий экран смерти) Вы можете попробовать несколько способов. Первым делом, скачайте и установите более новые версии драйверов для Вашей видеокарты, чем те что у Вас есть.

Вариант 1. Изменение настроек BIOS:

1) Во времени загрузки зайдите в BIOS (для этого нажмите клавишу Delete после начала загрузки компьютера)
2) В BIOS пройдите на вкладку Power
3) Попробуйте изменить значение параметра Suspend Mode (Auto, S1 (POS) Only, S3 Only) названия может отличаться, ищите похожие со значениями S1, S3.
4) Также попробуйте включить\отключить ACPI 2.0 Support -> Enabled\Disabled

Вариант 2. Запрет вывода из спящего режима используя USB мышь или USB клавиатуру.

Некоторые USB-устройства неправильно поддерживают спящий режим Windows. Два основных устройства с помощью которых Вы можете выйти из спящего режима - это клавиатура и мышь. Одно из них может блокировать Вам выход, в таком случае ему надо просто запретить это делать. Внимание: Не запрещайте одновременно клавиатуре и мыши, иначе Вы не сможете выйти из него.

1) Запустите Диспетчер устройств. Для этого пройдите в Пуск -> Выполнить (или Win+R) -> devmgmt.msc -> OK
2) В Диспетчере устройств разверните узел Мыши и иные указывающие устройства или Клавиатуры
3) Щелкните правой кнопкой на USB-мышь или USB-клавиатуру и выберите пункт Свойства.
4) Откройте вкладку Управление электропитанием.
5) Снимите флажок Разрешить устройству вывод компьютера из спящего режима и нажмите кнопку ОК.

Вариант 3. Отключение спящего/ждущего режима.

1) Пройдите в Пуск -> Выполнить (Win+R) -> powercfg.cpl -> OK
2) Выберите слева пункт Настройка перехода в спящий режим
3) Присвойте обоим параметрам: Отключать дисплей и Переводить компьютер в спящий режим, значение - Никогда.
Также можно отключить и функцию сна. Выберите пункт "Изменить дополнительные параметры питания". Найдите в окне режим Сон, разверните Сон после и установите значение находящихся там параметров на Никогда
Если несмотря на проделанное выше, компьютер по прежнему продолжает отключаться, то Вам необходимо выполнить ещё некоторые действия:
4) Скачайте reg-файл PowerSettings.reg и примените его.
5) Откройте вкладку Сон
6) Установите следующие значения параметрам, открыв их вкладки:
6.1) Сон после - значение равным 0, оно идентично значению Никогда
6.2) Разрешить политику требуемую системой - значение Да (это предотвратит автоматический переход в ждущий режим)
6.3) Разрешить таймеры пробуждения - Включить (позволит автоматически выводить компьютер из спящего режима при помощи заданных событий)
7) Если у Вас одно из устройств USB например мышь, а второе клавиатура PS/2, то Вы можете отключать USB порт на время работы спящего режима.
Откройте вкладку Параметры USB, а в ней вкладку Параметр временного отключения USB-порта и установите значение в Разрешено.
8) Нажмите OK

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


10. Восстановление загрузки Windows 7 без установочного диска.

Вариант 1. Автоматически - при помощи среды восстановления Windows RE в Windows 7.

Во время установки Windows 7 на жестком диске автоматически создается служебный раздел, обеспечивающий доступ в среду восстановления Windows RE (Recovery Environment). Используя данный служебный раздел, Вы можете:

- загрузиться в среду восстановления с жесткого диска
- создать компакт-диск, содержащий среду восстановления

1) Выполните загрузку в среду восстановления с жесткого диска или диска восстановления системы.
Для того чтобы войти в меню Дополнительные варианты загрузки, нажмите F8 после включения компьютера (но до загрузки операционной системы).
2) Выберите первый пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter.
3) Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи.
4) Введите пароль администратора. После ввода пароля вы увидите окно с вариантами восстановления.
5) Выберите пункт Восстановление запуска(Startup repair), также иногда может помочь пункт Восстановление системы (System Restore), позволяющий вернуться к точке, созданной до возникновения проблемы.

Вариант 2. Восстановление вручную, с созданием мультизагрузочного меню.

Здесь главное - это добраться до командной строки для введения дальнейших команд.

1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe)
2) Создайте папку Boot
3) Распакуйте скачанный архив и скопируйте файлы Bootsect.exe и Bcdedit.exe, нужной Вам битности в созданную Вами папку Boot.
4) Запустите среду необходимую для работы:
5) Загрузитесь в Windows, установленную на другой диск или в среду восстановления (На жестком диске запускается нажатием, клавиши F8. Если клавиша F8 используется материнской платой, после выбора диска нажмите F8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter)
6) Запустите командную строку.
В Windows: Win+R -> cmd -> Ok.
В среде восстановления: Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи. Введите пароль администратора. Выберите пункт Командная строка (Command Prompt)

Далее все команды вводимые в командную строку будут одинаковы как в Windows, так и в среде восстановления.

1) Windows 7 использует усовершенствованный метод загрузки - хранилище данных конфигурации загрузки. Это хранилище содержит все сведения обо всех операционных системах, установленных на компьютере. Следовательно, загрузчики более ранних операционных систем Windows, не могут быть использованы для ее запуска. Итак, для восстановления, загрузочного сектор Windows 7, перезаписываем загрузочный сектор на всех разделах:

где Х - буква диска, на котором содержится программа Bootsect.exe
2) Если у Вас вторая система Windows XP, то Вам необходимо выполнить ещё ряд действий:

Создайте в хранилище загрузки Windows 7 - хранилище для загрузки Windows XP.

Если же система откажется это делать, значит данное хранилище уже создано, поэтому необходимо его только переименовать:

Далее укажите загрузчику Windows 7 устройство расположения файлов загрузки Windows XP:

Затем укажите загрузчику Windows 7 путь к загрузчику Windows XP:

После добавьте строчку о выборе Windows XP в меню загрузки и расположив ее под остальными:

Также для работы с загрузчиками, Вы можете воспользоваться программой EasyBCD, позволяющей выполнять указанные выше действия, используя графический интерфейс.

Для информации:

Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

Вариант 3. Восстановление вручную, при помощи bootrec.exe.

1) Загрузитесь в среду восстановления (На жестком диске запускается нажатием, клавиши F8. Если клавиша F8 используется материнской платой, после выбора диска нажмите F8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter)
2) Выберите операционную систему, которую необходимо восстановить, и нажмите "Next"("Далее").
3) В окне Опции системы восстановления (System Recovery Options) выберите пункт Командная строка (Command Prompt).
4) Откроется окно интерпретатора командной строки cmd.exe, где следует ввести:

Параметр /FixMbr записывает в системный раздел основную загрузочную запись, совместимую с Windows 7. Этот параметр не перезаписывает существующую таблицу разделов. Данный параметр следует использовать для устранения проблем, связанных с повреждением основной загрузочной записи, или если необходимо удалить из основной загрузочной записи нестандартный код.

Параметр /FixBoot записывает в системный раздел новый загрузочный сектор с использованием загрузочного сектора, совместимого с Windows 7. Этот параметр следует использовать, если выполняется хотя бы одно из перечисленных ниже условий.

- Загрузочный сектор Windows 7 был заменен нестандартным загрузочным сектором
- Загрузочный сектор поврежден
- После установки Windows 7 на компьютер была установлена более ранняя версия операционной системы Windows. В данном случае для запуска компьютера вместо диспетчера загрузки Windows (Bootmgr.exe) используется загрузчик Windows NT (NTLDR).

Параметр /RebuildBcd выполняет поиск установленных операционных систем, совместимых с Windows 7, на всех дисках. Кроме того, этот параметр позволяет выбрать установленные системы, которые необходимо добавить в хранилище данных конфигурации загрузки. Этот параметр следует использовать в том случае, если необходимо выполнить полную перестройку данных конфигурации загрузки.

Если Вы не запомнили необходимого Вам значения Вы можете просто ввести:

и утилита выведет справку по доступным ключам командной строки.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


11. Восстановление стандартного анимированного экрана загрузки Windows 7.

В некоторых случаях новый экран загрузки произвольно заменяется старым в стиле Vista. Чаще всего это происходит, после неудачно внесенных различного рода изменений в загрузчик ОС. Предлагаю Вам простые и действенные решения:

Вариант 1

Выполнить - C:\Windows\System32\sysprep\sysprep.exe выбрать OOBE и ОК.

Вариант 2

1. Откройте командную строку от имени администратора: Пуск -> Выполнить (или Win+R) -> cmd -> Ok
2. В открытом окне консоли введите команду:

Обратите внимание, что вышеуказанная команда предусмотрена для английской версии Windows, поэтому если вы используете другую языковую версию, необходимо заменить "en-US" на языковой идентификатор используемой вами версии.
3. Закройте окно командной строки.
4. Перезагрузите Ваш компьютер.

Вариант 3

1) Откройте диалоговое меню Выполнить: Пуск -> Выполнить (или Win+R)
2) В открытом окне консоли введите команду: msconfig и нажмите OK
3) Перейдите на вкладку "Загрузка" и проверьте не установлен ли флажок напротив значения "Без GUI". Если флажок установлен - снимите его.
4) Закройте окно Конфигурации системы.
5) Перезагрузите компьютер

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


12. Получение полного доступа к NTFS-томам, системному реестру, параметрам настройки и драйверам...

12. Получение полного доступа к NTFS-томам, системному реестру, параметрам настройки и драйверам в случае тотального повреждения существующей на диске ОС или для перезаписи исправлений к русификации поверх оригинальных файлов?

Для этой функции можно использовать программу Microsoft ERD Commander входящую в состав Microsoft Diagnostics and Recovery Toolset.
Вы можете создать свой загрузочный образ на основе имеющегося у вас дистрибутива или скачать готовый образ Microsoft ERD Commander.
Программа для создания своего образа, на основе дистрибутива Windows 7. Запускается только в Windows 7.

ERD Commander для x86 или x64

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


13. Моргание игр в режиме OpenGL.

Переименуйте файлы: ..\windows\system32\glu.dll в glu32.dll ..\windows\system32\opengl.dll в opengl32.dll

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


14. Исправление невозможности запуска службы Центра обеспечения безопасности.

1) Отключены компоненты от которых зависит данная служба.

1.1) Откройте: Администрирование -> Службы
1.2) Проверьте включены ли следующие службы:

- Инструментарий управления Windows
- Удаленный вызов процедур (RPC)
- Модуль запуска процессов DCOM-сервера
- Сопоставитель конечных точек RPC

2) Восстановите начальные параметры в реестре, используя значения с компьютера, на котором данная служба работает.

2.1) Загрузите и примените готовый reg-файл. wscsvc.zip

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


15. Исправление отсутствия компонентов в окне "Включение или отключение компонентов Windows".

1.1) Запустите редактор реестра: Win+R -> regedit -> Ok
1.2) Откройте ветку реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows
1.3) Измените значение параметра CSDVersion на 0.
1.4) Перезагрузите компьютер

2) В соответствии с разрядностью и языком Вашей Windows, скачайте и установите обновление KB947821:

Windows6.1-KB947821-v5-x86.msu
Windows6.1-KB947821-v5-x64.msu

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


16. Исправление невозможности изменения настроек User Account Control (UAC).

В разделе Панели управления Системы и безопасность Вы можете изменить параметры контроля учетных записей User Account Control (UAC).
Если у Вас при работе в диалоговом окне Параметры управления учетными записями пользователей после перемещения ползунка управления и нажатия кнопки ОК или клавиши Enter, диалоговое окно не закрывается, и/или не вносятся никакие изменения, то вероятнее всего у Вас произошел сбой Реестра.
Вы можете восстановить нормальную работу User Account Control (UAC) одним из 2 способов.

Вариант 1. С помощью специального дополнения от Microsoft.

Скачайте и запустите файл: fixit_kb978591.diagcab

Вариант 2. При помощи созданного Вами reg-файла.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).

2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "UAC.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Примените полученный файл UAC.reg (Двойной щелчок -> Да)

Готовый reg-файл Вы можете скачать по ссылке: uac_repair.zip.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


17. Диагностика проблемы высокой загрузки процессора и частых обращений к жесткому диску при запуске или выключении Windows.

Чтобы определить какая программа или драйвер больше всего загружает Ваш процессор, Вам понадобиться программа от Microsoft - Windows Performance Tools Kit и в дополнение к ней программа XPerfUI от Richard Macdonald, при координации Microsoft.

1) В соответствии с Вашей разрядностью, скачиваете архив: для x86 или для x64
2) Устанавливаете программу Windows Performance Tools Kit
3) Копируйте файл XPerfUI.exe в папку с установленной программой и запускаете его.

4) Используя всплывающее меню открываете Tools -> Trace Session -> Boot Trace
5) В блоке Trace Type выбираете, для какого действия Вы хотите провести диагностику: Boot (для анализа запуска) или Shutdown (для анализа выключения)
6) В блоке Trace Flags устанавливаете переключатель на значение Base, дополнительно отмечаете пункты CSWITCH, DRIVERS, POWER
7) В поле Result path указываете путь, куда будет сохранен результат анализа. (Например: C:\Temp )
8) Нажмите кнопку Start для начала диагностики.

Компьютер перезагрузится.
9) Если Вы выбрали Boot (для анализа запуска), то после перезапуска системы, программа запустит трассировку (процесс пошагового выполнения программы) для данного действия и сохранит результаты в указанную Вами папку.
Если Вы выбрали Shutdown (для анализа выключения), то после перезапуска системы, программа запустит трассировку, снова перезапустит компьютер, снова запустит трассировку и сохранит результаты в указанную Вами папку.

10) Запускаете программу Performance Analyzer. В появившемся окне нажимаете кнопку Да.
Пуск -> Все программы -> Microsoft Windows Performance Toolkit -> Performance Analyzer
или файл xperfview.exe из папки, где установлена программа.
11) Открываете в окне программы (File -> Open) etl-файл, являющийся созданным в процессе трассировки log-файлом с результатами анализа. Местом нахождения etl-файла будет папка, указанная Вами при запуске трассировки.
12) Программа загрузит графики.
13) В меню программы нажимаете Graphs и ставите флажок CPU Sampling by Process.
14) В меню программы нажимаете Trace и ставите флажок Load Symbols.
15) Находите график CPU Sampling by Process.
16) Чтобы вывести сводную таблицу, нажимаете на нем правой кнокой мыши и выбираете пункт Summary Table
Процесс с наибольшим значением Weight и будет тем самым процессом, который забирает ресурсы процессора при загрузке или выключении. При нажатии на значок +, рядом с наименованием процесса Вы сможете узнать какой именно файл потребляет больше всего ресурсов процессора.

17) Также Вы можете посмотреть какая программа больше всего делает обращений к жесткому диску. Для этого найдите график Disk I/O в основном окне графиков программы, нажмите на нем правой кнопкой мыши и выберите пункт Summary Table. Процесс с наибольшим значением Service Time и будет тем самым процессом, который больше всего делает обращений к жесткому диску.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


18. Устранение проблемы открытия папок в отдельном окне, при установленном положении переключателя "Открывать папки в одном и том же окне".

1) Нажмите Пуск и введите в строке поиска cmd.exe
2) Нажмите на найденном правой кнопкой мыши и выберите пункт "Запуск от имени Администратора".
3) Поочередно введите команды, после написания каждой нажмите Enter.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


19. Удаление лишних пунктов из Диспетчера загрузки Windows.

1) Нажмите кнопку Пуск
2) Наберите в строке поиска msconfig и нажмите Enter
3) Перейдите на вкладку Загрузка
4) Выделите строку которую Вы желаете удалить и нажмите кнопку Удалить
5) Нажмите кнопку ОК и перезагрузите компьютер

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


20. Извлечение файлов Windows 7 из установочного DVD и замена ими поврежденных системных файлов.

Если у Вас в Windows появились поврежденные системные файлы, то Вам нет необходимости сразу переустанавливать Windows, так как Вы можете просто восстановить поврежденный файл используя DVD-диск или образ установочного диска. Вам всего лишь надо удалить имеющийся системный файл и заменить его извлеченным.

Инструкция восстановления системных файлов:

1) Извлеките из установочного диска необходимый файл.
2) Удалите поврежденный файл.
3) Скопируйте на место удаленного файла извлеченный.
4) Перезагрузите компьютер.

Извлечение файлов с диска Windows 7.

Вариант 1. При помощи программы DISM.

Подключение образа в DISM.

1) Вставьте установочный диск Windows 7 в DVD-привод, или смонтируйте ISO-образ.
2) Откройте папку sources и скопируйте из нее файл install.wim на диск D.
Внимание: в качестве папки для подключения образа install.wim НЕЛЬЗЯ использовать корень диска C (тот на котором установлена Windows), так как install.wim содержит системные папки Windows, Program Files, Program Data, Users и др.
3) Создайте папку на диске D и назовите ее, например, Image. В эту папку будет подключен образ install.wim.
4) Откройте Пуск > Все программы > Стандартные, щелкните правой кнопкой мыши по значку командной строки и выберите Запуск от имени администратора.
5) Выполните команду:

Пояснения:

dism – встроенная в Windows 7 утилита командной строки, позволяющая подключать образы WIM и управлять ими.
Параметр /Mount-Wim подключает файл WIM.
Параметр /WimFile позволяет указать расположение и имя файла WIM, который нужно подключить.
Параметр /name позволяет указать название выпуска Windows 7, который будет смонтирован.
Параметр /MountDir: указывает папку, в которую будет смонтирован образ WIM.

6) Дождитесь, пока образ подключится. Это может занять несколько минут.
7) Откройте папку D:\Image, найдите в ней (в папках) нужный файл и скопируйте его в любое место на жестком диске.

После копирования нужных файлов образ можно отключить.

Отключение образа в DISM.

1) Закройте все папки и файлы.
2) Откройте Пуск > Все программы > Стандартные, щелкните правой кнопкой мыши по значку командной строки и выберите Запуск от имени администратора.
3) Выполните команду:

Пояснения:

Параметр /Unmount-Wim отключает образ.
Параметр /MountDir: указывает папку, в которую смонтирован образ, который нужно отключить.
Параметр /discard отменяет все внесенные в образ изменения.

4) Дождитесь отключения образа.
5) Удалите папку Image и файл install.wim с диска D.

Вариант 2. При помощи программы 7Zip.

1) Скачайте и установите программу 7Zip
2) Cмонтируете образ лицензионного диска с Windows 7 или вставьте установочный DVD-диск.
3) Используя программу 7Zip откройте файл H:\sources\install.wim
где (H:) - буква диска с установкой Windows
4) Откройте в данном файле папку, соответствующую идентичной в системе.
5) Скопируйте файл(простым переносом из программы 7Zip) в идентичную папку в реальной системе.

Способы удаления:

1) Обычное удаление.
Просто нажмите правой кнопкой мыши на файле и выберите пункт Удалить.

2.1) Скачайте и установите программу Unlocker
2.2) Нажмите правой кнопкой мыши на файле и выберите пункт Unlocker.
2.3) В выпадающем меню выберите пункт Удалить и нажмите на кнопку Разблокировать все.

3) Удаление в безопасном режиме.
3.1) Перезагрузите компьютер в безопасный режим(нажмите f4 в начале загрузки компьютера до начала загрузки системы).
3.2) Нажмите правой кнопкой мыши на файле и выберите пункт Удалить.

4) Загрузитесь в ERD Commander
4.1) Для сопоставления букв дисков целевой операционной системе нажмите Да (Yes).
4.2) В окне выбора опреационной системы не выбирайте никакую систему(должно сняться выделение с какой-либо системы) и нажмите кнопку Далее (Next).
4.3) Нажмите Micosoft Diagnostics and Recovery Toolset -> Explorer
4.4) Откройте папку файла, нажмите правой кнопкой мыши на нем и выберите пункт Удалить.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


21. Настройка периодичности создания точек восстановления системы.

Чтобы изменить периодичность создания точек восстановления сделайте следующее:

1) Запустите Планировщик заданий. Пуск -> Панель управления -> Администрирование -> Планировщик заданий

2) В дереве слева откройте Библиотека планировщика задач -> Microsoft -> Windows -> SystemRestore

3) Щелкните правой кнопкой мыши в верхнем среднем окне на файл SR и выберите Свойства.

4) В открывшемся окне перейдите на вкладку Триггеры.

5) Нажмите Создать и задайте необходимые Вам временные параметры, либо выберите уже имеющийся триггер (Например, Ежедневно) и нажмите Изменить. Для удаления созданых триггеров выберите его и нажмите Удалить.

6) Нажмите на ОК для принятия изменений.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


22. Восстановление веток реестра из резервных копий службы System Restore в Windows 7.

Большая часть системного реестра находится в следующих местах:

Раздел HKEY_CURRENT_USER - в файле C:\Users\ИМЯ_ПОЛЬЗОВАТЕЛЯ\NTUSER.dat.
Все остальные разделы - C:\Windows\system32\config

Если Вам необходимо восстановить какую-то определенную часть системного реестра Windows 7 или Вы хотите посмотреть, какие значения имел определенный ключ, некоторое время назад, то Вам необходимо сделать следующее:

Для примера, получим доступ к предыдущим значениям ключа HKEY_LOCAL_MACHINE\SOFTWARE.

1) Откройте папку C:\Windows\system32. Найдите в ней директорию Config.
2) Щелкните по папке Config правой кнопкой мыши, выберите пункт меню Свойства и перейдите на вкладку Предыдущие версии.
3) Два раза щелкните по папке, относящейся к интересующей вас дате. Вы увидите перечень файлов, для которых доступна предыдущая версия. В данном случае нас интересует файл SOFTWARE, так как именно в нем хранятся ключи раздела HKEY_LOCAL_MACHINE\SOFTWARE.
4) Скопируйте файл в любое удобное вам место, перетащив его в открытое окно Проводника, либо выбрав команду Копировать из контекстного меню файла SOFTWARE.
Предположим, вы поместили его в корень диска D:.
5) Запустите редактор реестра (Пуск -> Выполнить -> regedit.exe), установите курсор на корневой ключ HKEY_LOCAL_MACHINE и выполните команду главного меню Файл -> Загрузить куст...
6) Задайте имя, под которым будет смонтирован файл D:\SOFTWARE (Например: oldsoftware)
7) Доступ к значениям ключей и разделов реестра будет возможен по пути HKEY_LOCAL_MACHINE\oldsoftware.
8) Смонтированный куст представляет собой предыдущую версию HKEY_LOCAL_MACHINE\Software, где Вы можете посмотреть предыдущие значения нужных ключей.
Если значения Вам необходимо поместить в рабочий реестр системы, переходите к следующему пункту.
9) Найдите интересующий Вас ключ или параметр, и экспортируйте его в reg-файл:
10) Выделите ключ, и в его контекстном меню выберите команду Экспортировать.
11) Отредактируйте только что экспортированный файл Блокнотом, заменив все вхождения "\oldsoftware\" на "\SOFTWARE\".
12) Сохраните reg-файл и двойным щелчком мыши по нему импортируйте его в текущий реестр операционной системы.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


23. Использование "чистой загрузки" для устранения неполадок в работе Windows.

"Чистая загрузка" - это безопасный режим, в котором компьютер запускается с минимальным количеством работающих программ и служб. Если при запуске компьютера в безопасном режиме ошибок не возникает, это означает, что проблема вызвана одной из программ или служб автозагрузки. В режиме "чистой загрузки" компьютер запускается с отключенными программами и службами автозагрузки, которые затем включаются и отключаются по одной до тех пор, пока источник проблемы не будет локализован.

Действие 1. "Чистая загрузка" системы

1) Войдите в систему с учетной записью, имеющей права администратора.
2) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter, чтобы запустить Конфигурация системы.
3) На вкладке Общие установите переключатель на Выборочный запуск
4) Снимите флажок Загружать элементы автозагрузки. (Флажок Использовать оригинальную конфигурацию загрузки недоступен.)
5) Перейдите на вкладку Службы
6) Установите флажок Не отображать службы Майкрософт и нажмите кнопку Отключить все.
7) Нажмите кнопку ОК и щелкните Перезагрузка.

Действие 2. Включите половину служб.

1) Войдите в систему с учетной записью, имеющей права администратора.
2) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter, чтобы запустить Конфигурация системы.
3) Откройте вкладку Службы и установите флажок Не отображать службы Майкрософт.
4) Установите флажки для половины служб в списке Службы.
5) Нажмите кнопку ОК и щелкните Перезагрузка.

Действие 3. Определите возможную причину неисправности.

Если неисправность осталась, повторите действия 1 и 2. В действии 2 снимите в списке Службы установленные флажки.
Если проблема исчезла, повторите действия 1 и 2. В действии 2 установите половину из еще не установленных флажков в списке Службы. Повторяйте эти действия, пока не будут установлены все флажки.
Если в списке Службы осталась выбранной только одна служба и проблема по-прежнему наблюдается, то именно эта служба ее и вызывает.
Если проблема вызвана одной из служб, перейдите к действию 6, в противоположном случае продолжайте поиск неисправности перейдя к действию 4.

Действие 4. Разрешите запуск половины элементов списка автозагрузки.

1) Выполните чистую загрузку, повторив действие 1.
2) Откройте вкладку Автозагрузка и установите флажки для половины элементов списка элементов автозагрузки.
3) Нажмите кнопку ОК и щелкните Перезагрузка.

Действие 5. Определите возможную причину неисправности.

Если неисправность осталась, повторите действия 1 и 4. В действии 4 снимите в списке элементов автозагрузки установленные флажки.
Если проблема исчезла, повторите действия 1 и 4. В действии 4 установите половину из еще не установленных флажков в списке элементов автозагрузки. Повторяйте эти действия, пока не будут установлены все флажки.
Если в списке элементов автозагрузки остался только один элемент и проблема по-прежнему наблюдается, то именно этот элемент ее и вызывает.
Если проблема вызвана одним из элементов автозагрузки, перейдите к действию 6.
Если неполадка не вызвана ни одним из элементов автозагрузки, вероятнее всего, ее вызывает одна из служб Майкрософт. Чтобы определить, какая именно служба вызывает неполадку, повторите действия 1 и 2, не устанавливая флажок Не отображать службы Майкрософт в действии 2.

Действие 6. Устраните проблему.

Определив программу или службу, являющуюся причиной проблемы сделайте одно из предложенным действий:

1) Установите более новую версию программы или удалите текущую.
2) Обратитесь к разработчикам программы в службу поддержки.
3) Используя Конфигурация системы снимите флажок проблемного элемента в списке Службы или в списке элементов автозагрузки.
4) Запустите командную строку (Win+R -> cmd -> ОК) и выполните команду sfc /scannow

Действие 7. Перезагрузите систему в обычнй режим Windows.

Завершив устранение неполадок, для перезагрузки в обычнй режим Windows выполните описанные далее действия:

1) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter, чтобы запустить Конфигурация системы.
2) На вкладке Общие установите переключатель на Обычный запуск
3) Нажмите кнопку ОК и щелкните Перезагрузка.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


24. Определение устройства выведшего Windows 7 из спящего режима.

Если уходя от компьютера Вы оставили его в спящем режиме, а вернувшись обнаружили что он включен (разбужен), то для определения устройства выведшего Windows из спящего режима сделайте следующее:

1) Запустите командную строку от имени Администратора: Win+R -> cmd -> ОК.
2) Введите команду: powercfg -lastwake и нажмите ОК.
3) Результатом работы данной программы будет указание на идентификатор устройства.

Чтобы узнать, что это за устройство:

4) Запустите Редактор реестра (Win+R -> regedit -> Ok)
5) Откройте ветку: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\.
6) Найдите искомое Вами устройство, согласно полученному при выполнении powercfg результату.
Наименование устройства будет отображено в найденном Вами ключе в параметре DeviceDesc

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


25. Устранение неполадок с поиском и индексированием.

Если результаты поиска отображаются не полностью, а также поиск в системе происходит медленно независимо от установленных настроек, то сделайте следующее:

1) Откройте меню Пуск, введите в строке поиска Устранение неполадок и нажмите Enter.
2) Нажмите кнопку Просмотр всех категорий, а затем выберите раздел Поиск и индексирование.
3) Нажмите кнопку Далее, затем в диалоговых окнах выбирайте ответы для уточнения имеющейся у Вас проблемы и нажимайте соответствующие кнопки.

Если файлы из индексированной папки не отображаются в результатах поиска, то сделайте следующее:

Причиной могут быть параметры безопасности, установленные для этой папки. Для индексирования папки и ее содержимого для нее необходимо установить разрешение система. Для большинства папок данное разрешение уже настроено, но в некоторых случаях разрешение система для папки может отсутствовать.

Добавление для папки разрешения система.

1) Щелкните папку правой кнопкой мыши, выберите пункт Свойства и откройте вкладку Безопасность.
2) Если вариант система не отображается в списке Группы или пользователи, щелкните Изменить.
3) Щелкните Добавить, введите в открывшемся окне система, затем щелкните Проверить имена.
4) В разделе Введите имена выбираемых объектов щелкните система, затем нажимайте кнопку ОК, пока не будут закрыты все открытые диалоговые окна.
5) Откройте меню Пуск, введите в строке поиска Параметры индексирования и нажмите Enter.
6) Щелкните Дополнительно. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
7) В диалоговом окне Дополнительно перейдите на вкладку Параметры индексирования, а затем нажмите кнопку Перестроить. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.

Перестроение индекса может занять несколько часов, и до тех пор пока индекс не будет перестроен, результаты поиска могут быть неполными.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


26. Исправление проблемы, когда автоматически не обновляется значок корзины, после ее очистки.

Вариант 1.

1) Запустите текстовый редактор, например «Блокнот».
2) Скопируйте в него текст указанный ниже:

3) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3.1) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DefaultIcon.reg")
3.2) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
4) Примените полученный reg-файл. Щелкните на нем дважды и нажми кнопку Да, а затем ОК.

Вариант 2.

1) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Персонализация.
2) Нажмите ссылку Изменение значков рабочего стола.
3) Выберите значок Корзина (полная) и нажмите кнопку Сменить значок.
4) В диалоговом окне Смена значка, выберите значок полной корзины и нажмите кнопку ОК.
5) Выберите значок Корзина (пустая) и нажмите кнопку Сменить значок.
6) В диалоговом окне Смена значка, выберите значок пустой корзины и нажмите кнопку ОК.
7) В диалоговом окне Параметры значков рабочего стола нажмите кнопку ОК.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


27. Исправление ошибки из журнала событий: "Не удается найти описание для идентификатора события 1904 из источника HHCTRL.".

При запуске и использовании (чтение, переход по страницам) в Windows файла справки с расширением *.CHM в журнале событий может появляться сообщение:
"Не удается найти описание для идентификатора события 1904 из источника HHCTRL.".
Это происходит из-за неправильного задания уровня безопасности системой для Местной интрасети в контейнере файла-справки.

Чтобы узнать появляется ли у Вас данная ошибка:

1) Откройте оснастку Просмотр событий
1.1) В строке поиска меню Пуск введите команду eventvwr.msc и нажмите Enter
или
1.2) Пройдите Панель управления\Все элементы панели управления\Администрирование и откройте Просмотр событий.
2) Слева в древовидном списке оснастки Просмотр событий перейдите Просмотр событий (Локальный) -> Журналы Windows -> Приложение
3) В центральном окне будут описаны события произошедшие при работе с программами.

Для исправления данной ошибки, создайте и примените reg-файл следующего содержания:

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


28. Перезагрузка в Безопасный Режим при отсутствии данного пункта в меню Диспетчера загрузки.

Если у Вас в меню Диспетчера загрузки (вызывается нажатием клавиши F8 до появления экрана с логотипом Windows) отсутствует пункт для запуска Безопасного режима, то Вы можете попробовать перезагрузиться в Безопасный режим используя утилиту Windows - Настройка системы, для этого:

1) В строке поиска меню Пуск введите команду: msconfig
2) Перейдите на вкладку Загрузка
3) Установите флажок напротив пункта Безопасный режим.
4) Установите переключатель в нужное значение:

Минимальная - загрузка графического интерфейса пользователя ОС Windows (Проводника Windows) в безопасном режиме с запуском только самых важных системных служб. Сетевые компоненты отключены.
Другая оболочка - загрузка командной строки Windows в безопасном режиме с запуском только самых важных системных служб. Сетевые компоненты и графический интерфейс пользователя отключены.
Восстановление Active Directory - загрузка графического интерфейса пользователя Windows в безопасном режиме с запуском только самых важных системных служб и службы каталогов Active Directory.
Сеть - загрузка графического интерфейса пользователя Windows в безопасном режиме с запуском только самых важных системных служб. Сетевые компоненты включены.

5) Установите необходимые флажки:

Без GUI - во время загрузки Windows экран приветствия не отображается.
Журнал загрузки - вся информация, касающаяся процесса загрузки, сохранится в файле %SystemRoot%\Ntbtlog.txt.
Базовое видео - загрузка графического интерфейса пользователя Windows в минимальном режиме VGA. В этом режиме загружаются стандартные драйверы VGA вместо драйверов экрана, соответствующих видеооборудованию компьютера. Установка данного пункта позволяет загрузиться в безопасный режим при проблемах с драйверами видеокарты.
Информация об ОС - отображает имена загружаемых драйверов в процессе загрузки системы. Устанавливайте, если желаете самостоятельно определить проблемный драйвер или библиотеку мешающие загрузке.

6) Нажмите в текущем окне ОK, затем во всплывшем окне нажмите Перезагрузка.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


29. Исправление ошибки 4201, возникающей при попытке запуска службы Журнал событий Windows (Windows Event Log).

Вариант 1.

1) В соответствии с разрядностью Вашего Windows скачайте и установите программу Unlocker
2) В проводнике откройте папку C:\Windows\System32\LogFiles\WMI
3) Нажмите правой кнопкой на папке RtBackup и в контекстном меню выберите пункт Unlocker.
4) В ниспадающем списке выберите пункт Удалить и нажмите на кнопку Разблокировать Все
5) Перезагрузите компьютер
6) Запустите службу Журнал событий Windows.

Вариант 2.

1) Перезагрузитесь в безопасный режим с полным отключением всех служб (для этого воспользуйтесь утилитой msconfig)
2) Откройте папку C:\Windows\System32\LogFiles\WMI
3) Удалите подпапку RtBackup со всем его содержимым.
Если необходимо, то задайте перед удалением для данной папки полные права. Иногда помогает сначала удаление файлов из папки, а затем самой папки.
4) Перезагрузитесь обратно в нормальный режим.
5) Запустите службу Журнал событий Windows.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Администрирование и Интерфейс.


1. Исправление исчезновения панели быстрого запуска после перезагрузки.

Если Вы создаете панель быстрого запуска, но после перезагрузки она исчезает, то попробуйте любое из предложенных ниже решений.

1) Попробуйте создать панель быстрого запуска со значением отличающимся от Вашего:

%userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch
%appdata%\Microsoft\Internet Explorer\Quick Launch
C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

2) Установите ползунок контроля учетных записей (UAC) в предпоследнее значение.

3) Создайте и добавьте в реестр следующий reg-файл:

4) Откройте C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer
Добавьте на вкладке Свойства -> Безопасность пользователя Все и задайте ему полный доступ.

5) В диалоговом окне Выполнить из меню Пуск (Win+R) введите команду control userpasswords2 и нажмите Enter.
Поставьте флажок на "Требовать ввод имени пользователя и пароля"

6) В диалоговом окне Выполнить из меню Пуск (Win+R) введите команду gpedit.msc и нажмите Enter.
Откройте Конфигурация пользователя -> Административные Шаблоны -> Меню "Пуск" и панель задач
Измените параметр политики Отображение панели быстрый запуск на панели задач на значение Включить.

7) Закройте Языковую панель и установите вместо неё Punto Switcher.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


2. Исправление сбоев возникающих при установке, обновлении или удалении программы с помощью установщика Windows (msiexec.exe).

Вариант 1

1) Перейдите Пуск->Все программы->Стандартные
2) Щелкните правой кнопкой мыши на пункт Командная строка и нажмите Запуск от имени Администратора
3) Скопируйте следующую строчку в окно команд и нажмите Enter:

Вариант 2

1) Откройте меню Пуск, введите в строке поиска regedit и нажмите Enter.
2) Перейдите в раздел HKLM\SOFTWARE\Microsoft\SQMClient\Windows
3) Щелкните правой кнопкой мыши на разделе DisabledSessions и нажмите Удалить.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


3. Восстановление пункта "Выполнить" в меню "Пуск".

Если у Вас отмечен пункт Команда "Выполнить" в "Настройка меню Пуск" (На кнопке Пуск нажмите правую кнопку мыши и выберите пункт Свойства, нажмите кнопку Настроить), а меню "Выполнить" не показывает Вы можете восстановить его так:
1) В Меню "Пуск" в строке поиска наберите gpedit.msc и откройте найденный файл gpedit.msc (Редактор групповых политик)
2) В левой части открывшегося окна пройти к вкладке:
Политика "Локальный компьютер"\Конфигурация пользователя\Административные шаблоны\Меню «Пуск» и панель задач
3) Выделите в правой части строку Добавить команду "Выполнить" в меню "Пуск"
4) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


4. Убирание появляющейся в меню Пуск полоски, пропадающей при повторном открытии.

Данная ошибка исправлена в Сервисном Пакете 1 (Service Pack 1).

1) Переключаете язык интерфейса в английскую версию Windows: Панель управления->Язык и Региональные Стандарты->Языки и Клавиатуры->Язык интерфейса->выбираете английский
2) Перелогиниваетесь или перезапускаете компьютер
3) Задаёте полный доступ к файлу aero.msstyles.mui из папки C:\Windows\Resources\Themes\Aero\ru-RU
4) Копируете с заменой aero.msstyles.mui из C:\Windows\Resources\Themes\Aero\en-US в C:\Windows\Resources\Themes\Aero\ru-RU
5) Возвращаете язык интерфейса на русский
Для тех у кого изначально русская, выкладываю данный файл отдельно для x64: aero.msstyles.mui и для x86: aero.msstyles.mui

Также Вы можете скачать и запустить от имени Администратора готовый патч: MenuFix_Rus_x86_x64_Final.rar
После его применения понадобиться перезагрузить компьютер.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


5. Восстановление ассоциации для *.cpl файлов.

Если какая-нибудь программа сбила Вам ассоциацию приложения Windows c файлами *.cpl.

1) Щелкните правой кнопкой мыши на любом файле *.cpl и выберите Свойства
2) На вкладке Общие напротив надписи Приложение нажмите кнопку Изменить.
3) В открывшемся окне нажмите кнопку Обзор
4) Зайдите в папку C:\Windows\System32 и выберите файл control.exe
5) Нажмите ОК

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


6. Исправление вылета проводника при нажатии правой кнопки мыши на файле или папке.

Скачайте небольшую утилиту ShellExView: с официального сайта или с зеркала.

Вариант 1.

Оптимальным решением проблемы может быть отключение расширения оболочки CmdLineExt.dll.
1) Запустите ShellExView.
2) Найдите среди выведенных ею расширений оболочки - расширение с именем CmdLineContextMenu Class
3) Выделите и нажмите клавишу F7 или через контекстное меню выберите опцию Disable Selected Items.
4) Перезагрузите компьютер.

или

1) Нажмите Пуск -> Выполнить (Win+R)
2) Введите команду regsvr32 /u CmdLineExt.dll и нажмите ОК.
3) Перезагрузите компьютер.

Вариант 2.

1) Запустите ShellExView.
2) Сделайте сортировку по столбцу Type (щелкните мышкой на названии столбца). Вас будут интересовать записи, где Type = Context Menu, а в столбце File Extensions есть звездочка.
3) Отключайте записи по очереди, начав с расширений, не принадлежащих Microsoft. Отключение выполняется щелчком правой кнопкой мыши -> Disable Selected Items или клавишей F7.
4) Отключив запись, проверьте работу проводника.

Если Вы отключили все расширения, но проблема не решилась, то в командной строке (Win+R -> cmd -> OK) введите sfc /scannow и нажмите Enter.
Если данное действие не возымеет успеха, то перезагрузитесь в безопасный режим Windows.
Если в безопасном режиме данная проблема пропадает, тогда всё нормально, значит, проблема вызвана одной из установленных у вас программ, драйверов, кодеков или служб и Вам придется вручную искать причину вызвавшую сбой. Удалять по одной программе, отключать по одной службе или откатываться к предыдущим версиям установленных драйверов, либо используя точки восстановления возвращаться к предыдущим состояниям системы и наблюдать на каком этапе исчезла ошибка.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


7. Восстановление исчезнувшей языковой панели.

Исчезновение языковой панели, чаще всего происходит после использования чистильщика или оптимизатора системы.
Перед использованием одного из предложенных вариантов, сделайте следующее:

1) Откройте редактор реестра (Win+R -> regedit -> OK )
2) Проверьте, не добавлен ли запрет на запуск языковой панели в следующую папку реестра:

3) Проверьте, присутствует ли в реестре ветки:

Region and Language

Keyboard

4) Проверьте значение параметров, в ветке реестра:

– значение REG_SZ-параметра AppName должно быть ctfmon.exe
– значение REG_SZ-параметра AppPath должно быть С:\Windows\system32.

где C: - буква диска на который у Вас установлена Windows

Вариант 1

1) Идете в Панель управления - Язык и региональные стандарты
2) Делаете все по пунктам на скриншотах.

Установите переключатель на значение Закреплена в панели задач и отметьте флажок Отображать текстовые метки на языковой панели и нажмите OK
3) Щелкаете правой кнопкой на панели задач, выбираете Свойства.
4) В пункте Область уведомлений щелкаем кнопку Настроить

5) В открывшемся окне поставьте флажок напротив "Всегда показывать все значки и уведомления на панели задач" и нажмите OK

Вариант 2

В контекстном меню панели задач уберите флажок со значения Закрепить панель задач, расширьте границы для всех панелей, а затем снова поставьте флажок напротив Закрепить панель задач.

Вариант 3

Найдите файл ctfmon.exe и добавьте его в Автозагрузку или создайте reg-файл со следующим содержанием:

Вариант 4

1) Откройте Языки и службы текстового ввода
Так:

1.1.1) Откройте Пуск->Выполнить (или нажмите на клавиатуре Win+R)
1.1.2) Ввести: RunDll32.exe shell32.dll,Control_RunDLL C:\Windows\system32\input.dll
1.1.3) Нажать OK

Или так:

1.2.1) Открыть Панель управления\Часы, язык и регион
1.2.2) Нажать на ссылку Смена раскладки клавиатуры или других способов ввода
1.2.3) Нажать на кнопку Изменить клавиатуру
2) На вкладке Общие удалите все раскладки клавиатуры кроме Английский
3) На вкладке Языковая панель снимите все флажки и установите переключатель в значение Скрыта
4) Выгрузите вручную библиотеки.
4.1) Откройте Пуск->Выполнить (или нажмите на клавиатуре Win+R)
4.2) Выполните поочередно команды:

5) Перезагрузите компьютер.
6) Откройте Языки и службы текстового ввода
7) На вкладке Общие добавьте нужные Вам раскладки клавиатуры
8) На вкладке Языковая панель установите переключатель в значение Закреплена в панели задач и установите флажок напротив пункта Отображать текстовые метки на языковой панели.
9) Нажмите OK.

Как альтернативный вариант можете установить программу Punto Switcher, она добавляет собственную языковую панель и функцию автоматического переключения раскладки при неправильном её выборе.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


8. Исправление ошибки, когда папки "Недавние места" и "Недавние документы" пустые.

1) Щелкните правой кнопкой мыши на кнопке Пуск и нажмите на Свойства
2) Установите флажки напротив пунктов:
"Хранить и отображать список недавно открывшихся программ в меню "Пуск"
"Хранить и отображать список недавно открывшихся элементов в меню "Пуск" и на панели задач"
3) Нажмите OK.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


9. Удаление появившейся на рабочем столе папки "Недавние места".

1) Удалите папку C:\Users\Default\AppData\Roaming\Microsoft\Windows\Recent
2) Перезагрузите компьютер или перезапустите систему
3) Зайдите в C:\Users\Default\AppData\Roaming\Microsoft\Windows\
4) Если Windows 7 не восстановил папку Recent заново, создайте её самостоятельно.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


10. Решение ошибки "Отсутствует исполняющее ядро для расширения имени файла js"

Иногда какое-то приложение может изменить ассоциацию к файлам ".js" (Например, текстовый редактор, использующий скрипты).
Что может привести к ошибке "Отсутствует исполняющее ядро для расширения имени файла js".
Переустановка Java от Sun Microsystems или компонентов с сайта Майкрософт, не всегда исправляет эту ошибку.

Необходимо восстановить через реестр значение по умолчанию "JSFile" .

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Запустите reg-файл.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


11. Гаджеты или их настройки отказываются запускаться.

Для нормального функционирования гаджетов рекомендуется не отключать полностью контроль учетных записей (UAC), а выставить минимальный уровень.
Если Вам необходима работа гаджетов при отключенном контроле учетных записей (UAC):

1) Создайте reg-файл указанного ниже содержания.

2) Примените его и перезагрузите компьютер.

или

1) Запустите командную строку от имени Администратора (Win+R -> cmd -> ОК)
2) По очереди введите команды указанные ниже, нажимая после введения каждой Enter:

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


12. Восстановление пункта "Закрепить программу в панели задач".

Если у вас пропал пункт "Закрепить программу в панели задач":
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


13. Пользовательские папки отображаются обычными иконками.

Если у вас пользовательские папки, такие как Документы, Изображения и т.п., отображаются в проводнике с обычными иконками, как и любые другие папки, то это может быть вызвано отсутствием или повреждением файлов desktop.ini, расположенных в таких папках. Или же эти файлы имеют неправильные атрибуты.
Если файл desktop.ini присутствует в папке, его атрибуты должны быть Скрытый и Только чтение.
В случае если файла desktop.ini нет в папке, его необходимо создать с указанным ниже содержимым и с указанными выше атрибутами.
Для вступления в силу изменений необходимо завершение сеанса или перезагрузка.

Содержимое файлов desktop.ini для стандартных пользовательских папок

Документы

Изображения

Музыка

Видео

Поиски

Загрузка

Избранное

Контакты

Рабочий стол

Ссылки

Сохраненные игры

Общий рабочий стол

Общие документы

Общая музыка

Общие изображения

Общее видео

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


14. Исправление проблемы, с дублированием ярлыков на рабочем столе.

Если при создании, копировании или перемещении на рабочий стол любого документа/ярлыка/папки, после обновления экрана или перезагрузки компьютера, у Вас появляются их дубликаты (точная копия, без (2) в названии), то это означает, что Ваш собственный рабочий стол и общий рабочий стол прописаны в реестре в одной папке. Данная проблема решается указанием для них отдельных отличающихся между собою папок.

1) Запустите Редактор реестра. Для этого в строке поиска в меню Пуск введите regedit и нажмите Enter
2) Откройте раздел: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
3) Измените значение параметра Common Desktop на одно из предложенных ниже:

C:\Users\Public\Desktop - значение Windows по умолчанию
C:\Users\ВашПрофиль\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок.

4) Откройте раздел: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
5) Измените значение параметра Common Desktop на одно из предложенных ниже:

%Public%\Desktop - значение Windows по умолчанию
%USERPROFILE%\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


15. Восстановление поиска в Проводнике и в меню Пуск.

1) Используя Реестр (Win+R -> regedit)
1.1) Откройте ветку реестра:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
1.2) В случае обнаружения параметра NoFind, удалите его.

2) Используя Панель управления
2.1) Откройте Панель управления\Программы\Программы и компоненты
2.2) Запустите "Включение и отключение компонентов Windows" (или Win+R -> OptionalFeatures.exe)
2.3) Проверьте, включен ли у Вас компонент Windows Search (Поиск Windows).

3) Используя Редактор локальной групповой политики.
3.1) В диалоговом окне Выполнить из меню Пуск (Win+R) введите команду gpedit.msc и нажмите Enter.
3.2) Откройте Конфигурация пользователя -> Административные Шаблоны -> Меню "Пуск" и панель задач
3.3) Измените следующие параметры политики на значение Не задана:

- Добавить ссылку "Поиск в Интернете" в меню "Пуск"
- Удалить ссылку "Поиск" из меню "Пуск"

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


16. Исправление всплывающей подсказки оказывающейся за панелью задач Windows.

Если у Вас возникает ошибка, когда всплывающая подсказка оказывается за панелью задач Windows, и её видно частично или совсем не видно, то Вы можете воспользоваться небольшой программой ToolTipFixer, которая исправляет эту ошибку, возвращая на место всплывающую подсказку.

Скачайте и установите ToolTipFixer

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


17. Решение проблемы пропадания значков в панели задач.

Это происходит потому, что загружаемые программы пытаются установить иконки раньше, чем explorer успевает инициировать трей. Для установки задержки запуска программ, Вы можете воспользоваться менеджером автозагрузки Startup Delayer.

В дополнение к программе воспользуйтесь твиком реестра.

Скачайте и примените его: tray_icons.reg

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


18. Удаление ярлыков на отсутствующие в системе элементы в папке "Недавние места".

18. Удаление ярлыков на остутствующие в системе элементы в папке "Недавние места".

Для удаления ярлыков на отсутствующие в системе элементы из папки "Недавние места" предлагаю Вам следующие варианты решения.

Вариант 1.

1) Откройте в проводнике папку Недавние документы (%AppData%\Microsoft\Windows\Recent)
Просьба не путать с папкой Недавние места (это другая папка)
2) Щелкните правой кнопкой мыши ярлык на отсутствующий в системе элемент(папку или файл) и выберите пункт Удалить.
3) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Обновить. Данное действие необходимо, чтобы убрать появившуюся на рабочем столе папку Недавние места.

Вариант 2.

Для его выполнения необходима программа Registry Workshop - заменяющая стандартный редактор реестра.

1) Запустите Registry Workshop
2) Нажмите Search (Поиск) -> Find...(Поиск...)
3) В открывшемся окне установите переключатель на Search in key: (В разделе:)
4) Введите HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RecentDocs
5) В текстовом поле Find what: (Запрос:) введите наименование отсутствующего в системе элемента (папки или файла)
6) Нажмите кнопку Find (Поиск)
7) Выделите найденное с помощью левой кнопки мыши или нажмите комбинацию клавиш Ctrl+A, чтобы выделить все.
8) Щелкните на выделенном правой кнопкой мыши и выберите пункт Delete From Registry (Удалить из реестра)

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


19. При загрузке Windows автоматически открывается окно Проводника.

Варианты решений:

1) Открыть Пуск - Панель управления - Параметры папок - убрать флажок "Восстанавливать прежние окна папок при входе в систему".
2) В командной строке (Win+R -> cmd -> OK) введите sfc /scannow и нажмите Enter
3) Создайте и примените reg-файл:

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


20. Восстановление запуска Exe-файлов в системе.

Данные проблема связана с изменением какой-нибудь программой в реестре параметров отвечающих за ассоциации exe-файлов.
Для устранения данной проблемы попробуйте один из следующих вариантов.

Вариант 1.

1) Откройте папку C:\Windows\System32
2) Сделайте копию файла regedt32.exe
3) Переименуйте данную копию в regedt32.com
4) Щелкните на данном файле правой кнопкой мыши и выберите Запуск от имени администратора.
5) Откройте ветку HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe
6) Удалите раздел UserChoice

Вариант 2.

1) Скачайте файл exefix_win7.zip
2) Разархивируйте его и примените reg-файл.

или же создайте самостоятельно в блокноте reg-файл следующего содержания:

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


21. Исправление ошибки проводника "Не удалось найти этот элемент".

Если у Вас возникает данная ошибка, то скорее всего у Вас сбились описания папок. Для их восстановления:

1) Скачайте файл FolderDescriptions.zip
2) Распакуйте его в любую папку.
3) В соответствии с разрядностью Вашей Windows примените reg-файл, восстанавливающий настройки описания папок в изначальные.
4) Перезагрузите компьютер.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


22. Исправление появляющегося окна предупреждения системы безопасности "Неизвестный издатель", при открытии программы из меню Пуск.

1) Запустите командную строку от имени Администратора
(Нажмите Пуск -> в строке поиска введите cmd -> щелкните правой кнопкой мыши по найденному файлу cmd.exe -> выберите пункт Запуск от имени Администратора)
2) Поочередно введите команды, нажимая для их выполнения клавишу Enter:

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


23. Если у вас при запуске файлов *.chm неправильно определяется кодировка.

Если при создании *.chm файла принудительно не указать на каждой странице кодировку, то при его чтении у некоторых людей могут возникнуть трудности с определением кодировки. Для решения данной проблемы:

1) Закройте *.chm файл
2) Зайдите в Internet Explorer
3) Нажмите правую кнопку мыши
4) В появившемся меню наведите указатель на слово Кодировка и поставьте галочку напротив пункта Автовыбор
5) Запустите ваш *.chm и система сама определит кодировку.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


24. Перестали запускаться анимированые обои. Ошибка:"Windows DreamScene can only run when Windows Aero scheme is selected."

Вероятно, аэро - отключено.
Щелкаете правой кнопкой на монитор - Персонализация - выберите тему с прозрачными окнами (они вверху).
Или C:\Windows\Resources\Themes выбрать aero.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


25. Создание ярлыка и комбинации клавиш для закрытия зависших приложений и перезапуска Проводника.

Создание ярлыка и комбинации клавиш для закрытия зависших приложений.

1) Щелкните по рабочему столу и выберите во всплывшем меню Создать -> Ярлык.
2) В поле Укажите расположение объекта введите команду

3) Щелкните правой кнопкой мыши на ярлыке и выберите Свойства
4) В поле Быстрый вызов назначьте комбинацию клавиш для использования.

Создание ярлыка и комбинации клавиш для перезапуска Проводника.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).

2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .cmd. Например: restart_explorer.cmd
3) Щелкните по рабочему столу и выберите во всплывшем меню Создать -> Ярлык.
4) В поле Укажите расположение объекта выберите созданный Вами командный файл.
5) Щелкните правой кнопкой мыши на ярлыке и выберите Свойства
6) В поле Быстрый вызов назначьте комбинацию клавиш для использования.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


26. Восстановление в всплывающем меню "Создать" пункта "Папку".

Если у Вас из всплывающего меню Создать находящегося в основном контекстном меню(вызывается нажатием правой кнопки мыши) пропал пункт Папку, то Вы можете скачать и применить reg-файл содержащий изначальные настройки для данного пункта меню в реестре.

Чтобы применение reg-файла прошло успешно, воспользуйтесь небольшой инструкцией:

1) Измените разрешения (установите полный доступ) и владельца для раздела реестра: HKEY_CLASSES_ROOT\CLSID\{11dbb47c-a525-400b-9e80-a54615a090c0}

1.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
1.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
1.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
1.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
1.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

2) Скачайте и примените reg-файл. NewFolderFix.zip
3) Перезагрузите компьютер. Для желающих создать данный reg-файл самостоятельно его текст:

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


27. Исправление отсутствия в папке Все программы из меню Пуск папки "Стандартные".

Для исправления данной ситуации Вам необходимо создать новый профиль и скопировать из него необходимые папки.

1) В строке поиска меню Пуск введите lusrmgr.msc и нажмите Enter.
2) Перейдите в папку Пользователи
3) Щелкните правой кнопкой мыши в средней части окна и выберите Новый пользователь.
4) Введите любое имя пользователя (Например: Demo) и снимите флажок "Требовать смены пароля при следующем входе в систему"
5) Нажмите Создать, а когда кнопка станет не активной нажмите Закрыть.
6) Выйдите из системы и войдите в систему, используя только что созданную учётную запись.
7) Выйдите из системы и войдите в систему, используя Вашу учётную запись.
8) Откройте Проводник введите в адресной строке указанный ниже адрес папки и нажмите Enter.

где Demo - имя созданной Вами учетной записи.
9) Щелкните правой кнопкой мыши на папке Стандартные (Accessories) и выберите пункт Копировать
10) Откройте Проводник введите в адресной строке указанный ниже адрес папки и нажмите Enter.

где UserName - имя Вашей учетной записи (его можно узнать открыв папку C:\Users).
11) Щелкните правой кнопкой мыши в пустой части окна данной папки и выберите пункт Вставить
12) Перезагрузите компьютер.

Для удаления созданной Вами учетной записи пользователя:

1) В строке поиска меню Пуск введите lusrmgr.msc и нажмите Enter.
2) Перейдите в папку Пользователи
3) Щелкните правой кнопкой мыши в списке на имя созданной Вами учетной записи и выберите пункт Удалить
4) Нажмите во всплывшем окне кнопку Да и выйдите из оснастки "Локальные пользователи и группы"
5) Откройте в проводнике папку C:\Users и удалите папку с именем созданной Вами учетной записи.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


1. При использовании сторонних плееров для видео выкидывает синий экран.

Данную проблему можно решишь, если установить в расширенных настройках видео: Режим рендеринга или фильтр рендеринга для DirectShow Video на "Улучшенный обработчик видео" или "Enhanced Video Renderer" (EVR).

В Media Player Classic данный параметр находится View - Options - Playback - Output - Directshow Video - EVR.
В Bsplayer Pro данный параметр находится Опции - Настройки - Видео - Вывод видео - Режим рендеринга - EVR (Enhanced Video Renderer).

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


2. В папке "Компьютер" не отображаются DVD-дисководы.

Уберите флажок в Панель управления-Параметры папок-Вид "Скрыть пустые диски в папке "Компьютер""

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


3. В Windows и Nero не стираются диски DVD RW и CD RW.

Если при попытке стереть данные диски вы получаете ответ "Не перезаписываемый диск" или "Диск защищён от записи". По всей видимости была сделана метка на диске и программы определяют его как DVD-R. Чтобы убрать эту метку зайдите в Alcohol 120% и уберите метки в пунктах Сервис -> Настройки -> Эмуляция -> Игнорировать тип носителя, в Daemon Tools Спрятать CD-R.
Значение этой опции: Bынудить дpугиe пpoгpaммы нe oпpeдeлять зaпиcывaeмый тип диcкa, пpинимaя eгo зa CD-ROM или DVD-ROM.
После этого заново сотрите эти диски в Alcohol 120% или в Daemon Tools.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


4. Определение драйвера, вызвавшего BSOD.

Включение записи дампов памяти

1) Нажимаете комбинацию клавиш Win+Pause
2) Щелкаете ссылку Дополнительные параметры системы
3) Переходите на вкладку Дополнительно
4) Нажимаете кнопку Параметры в Загрузка и восстановление

5) По умолчанию они будут сохраняться в папку %SystemRoot%\Minidump

Анализ дампа памяти и определение драйвера, вызвавшего ошибку:

Вариант 1

1) Загрузите и установите Debugging Tools for Windows.
2) Загрузите командный файл kdfe.cmd (Kernel Debugger Front End) со скриптом для облегчения анализа дамп-файлов, создаваемых Windows при STOP ошибках (BSoD), оригинальный его код взят на ресурсе sysadmins.ru.
3) Распакуйте архив в любую папку.
Примечание: Если папка Debugging Tools for Windows находиться у вас не в папке Program Files, то в файле kdfe.cmd необходимо указать другой путь к папке, в которую установлены средства Debugging Tools for Windows.
Путь к папке указан после параметра set dbgpath=
4) Откройте командную строку и перейдите в папку, в которую вы распаковали kdfe.cmd.
5) Запустите файл, указав в качестве параметра путь к файлу дампа памяти (в примере ниже файл называется Mini1110307-01.dmp)

6) Дождитесь завершения анализа. По окончании вы увидите драйвер, послуживший причиной ошибки.

Вариант 2

1) Скачиваете утилиту BlueScreenView.
2) Устанавливаете BlueScreenView.
3) Распаковываете bluescreenview_russian.zip и кладете файл bluescreenview_lng.ini в туже папку куда установлена BlueScreenView.
4) Запускаете BlueScreenView.

Поиск дампов производится в папке %systemroot%\Minidump, также можно настроить и собственную папку (Options –> Advanced).
Для найденных дампов памяти утилита отображает:
  • В верхней панели – название файла, дату создания, название стоп-ошибки, код ошибки, параметры, а также драйвер, предположительно вызвавший проблему (Caused By Driver).
  • В нижней панели – (в зависимости от настроек в Options –> Lower Pane Mode) все драйверы, загруженные во время ошибки, или только драйверы, найденные в стеке. Среди всех драйверов - на розовом фоне отображаются предположительно вызвавшие проблему драйверы. Также, утилита может отображать синий экран, очень похожий на тот, который все так любят.
Примечание: При определении драйвера не нужно полагаться только на имя файла в столбце Caused by Driver. Следует рассмотреть драйверы в нижней панели (или только выделенные розовым цветом, если включено отображение всех драйверов), в первую очередь обращая внимание на несистемные драйверы.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


5. Расшифровка значений ошибок синего экрана смерти (BSOD) и способы их устранения.

Если у Вас появляется какая-либо ошибка синего экрана смерти, и Вы задумываетесь из-за чего же она произошла, то Вы можете:

1) Скачать подборку наиболее часто встречающихся ошибок и способов устранения многих из них: BSOD.rar
2) Почитать на форуме Oszone.net темы входящие в состав темы: Устранение критических ошибок Windows

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


6. В Windows x64 стало показывать меньше памяти, чем есть.

Зайдите:
Панель управления->Администрирование->Конфигурация системы>вкладка Загрузка->Дополнительные параметры
Проверьте максимум памяти. Или уберите галочку или поставьте нужное вам значение.

Также посмотрите значение функций в BIOS:

1. HPET Mode должно быть 64-bit (если есть такая функция)
или
2. Memory Remap Feature должно быть Enabled
3. Memory Hole должно быть Disabled

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


7. Windows зависает после перезагрузки с ошибкой Verifying DMI Pool Data.

Попробуйте следующие варианты решений:

1) Попробуйте установить другую сборку или версию Windows 7.
2) Сбросьте настройки BIOS в стандартные и установите Windows заново.
3) Обнулите на материнской плате CMOS: либо переустановив и вернув перемычку, либо нажав на кнопку сброса на материнской плате.
4) Установите в списке загрузок с жестких дисков в BIOS, приоритет загрузки Вашего диска с Windows 7 на первое место.
5) Подключите диск выделенный для Windows 7, как Primary Master.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


8. Восстановление работы дополнительных клавиш на мультимедиа-клавиатуре.

Если на Вашей мультимедиа или офисной клавиатуре перестали работать дополнительные клавиши расширяющие её функциональность, то сделайте следующее.
Во-первых, проверьте установлено ли у Вас программное обеспечение с диска идущего в комплекте к клавиатуре или с официального сайта.
Если же оно установлено, то одной из наиболее часто встречающихся причин может быть остановка службы Доступ к HID-устройствам.

1) Зайдите в Панель управления\Система и безопасность\Администрирование и запустите Службы или
Нажмите кнопку Пуск, щелкните в поле Начать поиск, введите services.msc и нажмите клавишу Enter.
2) Проверьте указано ли в колонке Состояние, напротив службы Доступ к HID-устройствам значение: Работает
Если данная служба отключена и не работает, сделайте следующее:
3) Нажмите на ней правой кнопкой мыши и в появившемся меню выберите Свойства
4) Для запуска службы нажмите на кнопку Запустить
5) Также Вы можете установить Тип запуска: Автоматически, и система будет автоматически запускать данную службу при старте Windows.
6) Перейдите на вкладку Восстановление и установите действия выполняющиеся при первом или втором сбое, а также при последующих сбоях на значение Перезапуск службы и нажмите OK.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


9. Исправление появившихся красных крестиков на значках локальных дисков.

1) Откройте Панель Управления -> Диспетчер Устройств
1.1) Проверьте включены ли все IDE ATA/ATAPI контроллеры
1.2) Проверьте включены ли все Дисковые устройства
2) Если есть общий доступ, попробуйте его отключить
Щелкните ПКМ на диске -> Общий доступ -> Расширенная настройка общего доступа... -> Расширенная настройка...
3) Почистите кэш иконок: для этого в папке %USERPROFILE%\AppData\Local\ удалите файл IconCache.db
4) Воспользуйтесь специальными утилитами для оптимизации работы компьютера. Например:
4.1.) TuneUp Utilities

4.1.1) В колонке Customize Windows нажимаете All functions и выбираете Change Windows appearance
4.1.2) В меню слева в списке группы Icons выбираете Repair
4.1.3) Нажмите на кнопку Reload Icons, а после на кнопку Repair Icon Cache

4.2) Windows 7 Manager

4.2.1) В меню слева во вкладке Information выберите Repair Center
4.2.2) В меню слева в Repair Center нажмите Icon Repair
4.2.3) В разделе Rebuild Icon Cache нажмите Rebuild

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


10. Восстановление автозапуска для всех типов приводов и устройств.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Запустите reg-файл.

Также параметр NoDriveTypeAutoRun автоматически добавляется в реестр при установке программы VMware Workstation, используемой для создания виртуальной машины.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


11. Исправление ошибок 0x0000007A, 0x00000077 или 0x000000F4 для SATA дисков после выхода из ждущего или спящего режимов.

На подготовку к работе жесткого диска отводится 10 секунд. Если накопитель не успеет за это время сообщить о своей работоспособности, то операционная система воспримет это как ошибку. Такое может происходить с винчестерами с интерфейсом SATA. Для устранения данной ошибки Microsoft выпустила обновление KB977178. Если же в вашей системе на базе Windows 7 подобных ошибок не возникает, то устанавливать исправление не рекомендуется.
Скачать исправление KB977178 : для x86 или для x64

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


12. Cистема находит Bluetooth-адаптер, а Bluetooth-устройства его не обнаруживают.

1) Нажмите Win+R (или Пуск -> Выполнить)
2) Введите команду:

или

и нажмите Параметры Bluetooth

3) Установите необходимые Вам настройки.

Чтобы сделать компьютер обнаруживаемым устройствами с поддержкой Bluetooth, установите флажок Разрешить устройствам Bluetooth обнаруживать этот компьютер.
Чтобы разрешить добавление устройств с поддержкой Bluetooth на компьютер, установите флажок Разрешить устройствам Bluetooth подключаться к этому компьютеру.
Чтобы получать уведомления о попытках устройств с поддержкой Bluetooth подключиться к компьютеру, установите флажок Оповещать при подключении нового устройства Bluetooth.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


13. Восстановление значка "Безопасное извлечение устройства".

1.1) Создайте и импортируйте в реестр reg-файл указанного ниже содержания. После чего перезагрузите компьютер.

1.2) Перезайдите в систему или перезагрузите компьютер.

2) Откройте Пуск -> Выполнить (Win+R) и запустите поочередно следующие команды

3.1) Щелкните по рабочему столу и выберите во всплывшем меню Создать -> Ярлык.
3.2) В поле Укажите расположение объекта введите команду

3.3) Перенесите созданный Вами ярлык на панель задач, чтобы закрепить его там.

Также Вы можете просто запустить окно "Безопасное извлечение устройства" введя команду в диалоговом окне Выполнить (Win+R) :

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


14. Решение проблемы пропадания места на системном жестком диске.

Прежде всего выполните проверку жесткого диска, если дело окажется в ошибках, то система поможет Вам их исправить:

1) Нажимаете кнопку Пуск и в строке поиска вводите cmd
2) Нажимаете правой кнопкой мыши на найденной команде и выбираете "Запустить от имени Администратора"
3) Вводите команду SFC /scannow и нажимаете Enter

Для увеличения свободного пространства Вы можете сделать следующее:

1) Запустите Очистка диска. Нажимаете кнопку Пуск -> Все программы -> Стандартные -> Служебные.
1.1) На вкладке Очистка диска Вы можете удалить временные файлы
1.2) На вкладке Дополнительно Вы можете удалить все точки восстановления, кроме самой последней.

2) Отключите функцию создания точек восстановления или уменьшите размер используемого дискового пространства.
2.1) Нажмите кнопку Пуск
2.2) Щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства (Панель управления\Система и безопасность\Система)
2.3) Слева нажмите ссылку Защита системы
2.4) В открывшемся окне нажмите кнопку Настроить
2.5) Отключите защиту системы или измените используемый ею размер дискового пространства.

4) Отключите режим гибернации.
Запустите командную строку с правами администратора (Win+R -> cmd -> Ok) и выполните в ней команду: powercfg /h off

5) Измените размер файла подкачки.
5.1) Нажмите кнопку Пуск
5.2) Щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства (Панель управления\Система и безопасность\Система)
5.3) Слева нажмите ссылку Дополнительные параметры системы
5.4) В разделе Быстродействие нажмите кнопку Параметры
5.5) Перейдите на вкладку Дополнительно и нажмите кнопку Изменить

6) Очистите папку кэша C:\Windows\rescache
7) Очистите временные папки (карантин) используемой Вами системы защиты (Norton, Kaspersky, Eset 32 и др.), в некоторых стоит отключить трассировки.
8) Скачайте программу Scanner by Steffen Gerlach для анализа содержимого жестких дисков. Эта программа поможет Вам увидеть, какая папка или файл занимает большую часть вашего диска.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


15. Windows не определяет второй жесткий диск после установки.

Данное действие иногда происходит по причине неправильной установки скрытого раздела System Reserved (Зарезервировано системой).
Например, если у Вас один жесткий диск, то Windows 7 при инсталляции выделяет скрытый раздел System Reserved (Зарезервировано системой) для защиты загрузочных файлов операционной системы.
Если во время инсталляции были подключены два жестких диска, то иногда Windows может некорректно определить второй жесткий диск и использовать его как скрытый раздел System Reserved (Зарезервировано системой). В результате чего, у него будет отсутствовать буква диска.

Для добавления буквы диска сделайте следующее:

1) Запустите оснастку Управление дисками: Открываете меню Пуск, в поле поиска пишите diskmgmt.msc и нажимаете Enter
2) Находите Ваш диск, у него будет отсутствовать буква диска.
3) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить букву диска или путь к диску.
4) В открывшемся окне нажимаете кнопку Добавить выбираете необходимую Вам букву и нажимаете ОК.

Если диск не появился в Проводнике(Windows Explorer), то перезагрузите компьютер.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


16. Не переименовывается диск (не меняется метка тома) в Windows 7.

Данная проблема может возникнуть, в результате появления в корне диска файла или папки с именем "Autorun.inf".
Если Вы не создавали его самостоятельно для защиты от вирусов использующих автозапуск, то файл (папка) мог создаться какой-либо программой.
Для исправления данной проблемы сделайте следующее:

1) Откройте Пуск - Панель управления и запустите "Параметры папок"
2) Перейдите на вкладку "Вид" и установите переключатель отвечающий за "Скрытые файлы и папки" в значение "Показывать скрытые папки, файлы и диски".
3) Удалите в корне диска файл или папку с именем "Autorun.inf".
4) Перезагрузите компьютер.
5) Измените метку диска (Win+R - label.exe - OK)
Если же Вы создали файл "Autorun.inf" сами, то просто добавьте в него следующее:

Вместо Метка тома подставьте необходимое Вам значение.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


17. Отключение отображения внутренних жестких дисков в "Безопасное извлечение устройств и дисков".

В Windows 7 система использует универсальный драйвер как для SATA (интерфейс подключения внутренних устройств), так и eSATA (интерфейс подключения внешних устройств).
Поэтому, независимо от того к которому из них подключен жесткий диск система определяет поддерживает ли устройство функцию извлечения "на лету".
Если Ваша система использует режим AHCI, то в списке Безопасное извлечение устройств и дисков на панели задач появятся Ваши жесткие диски. Это обусловлено функциональными особенностями AHCI режима, а именно функцией "горячей" замены (HotPlug), означающей возможность извлечения оборудования в компьютерной системе во время работы.
Если Вы не используете мобильное шасси (Mobile Rack) для внутренних жестких дисков и не планируете их извлекать, то Вы можете отключить их отображение в списке Безопасное извлечение устройств и дисков.

Вариант 1. Установите родные драйвера для чипсета к которому подключены жесткие диски. Например для чипсета Intel, драйвера для технология хранения Intel® Rapid.

Вариант 2. Укажите системе, что устройство должно использовать внутренний порт. В диалоговом меню Выполнить (Win+R) или в командной строке запущенной от имени администратора () введите команду:

Где (n)- номер контроллера, на котором висит диск, а (N) - номер канала. В большинстве случаев по умолчанию это 0 в обоих случаях.

Повторите данное действие для каждого диска, заменив значения на необходимые. Номер контроллера в большинстве случаев по умолчанию равен 0 для каждого из Ваших дисков. Номер канала Вы можете посмотреть в диспетчере устройств, на вкладке Сведения, в свойствах Вашего жесткого диска. Значения каналов имеют порядковые номера, начинающиеся с цифры 0.
Например, если у Вас 2 жестких диска, то Вам, скорее всего, нужно будет ввести следующие команды:

Вариант 3. Использование стороннего программного обеспечения.

1) Скачайте и установите программу USB Safely Remove. Данная программа заменит встроенную в Windows функцию Безопасное извлечение устройств и дисков на собственную утилиту.
2) Для того, чтобы иконка пряталась, когда нет ни одного подключенного устройства, включите опцию "Hide icon when there are no devices to be stopped". Она располагается на закладке настроек "Look and Feel".

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


18. Проверка драйверов для выявления неполадок в работе Windows.

Если Вы предполагаете, что какой-либо из драйверов работает некорректно или, проанализировав дамп памяти, Вы определили драйвер вызвавший ошибку, то для более тщательной проверки работы драйверов Вы можете самостоятельно выполнить проверку драйверов с помощью встроенного в операционную систему средства проверки Verifier.exe.

Проверка неподписанных драйверов.

1) В строке поиска меню Пуск введите verifier и нажмите Enter.
2) Выберите пункт Создать нестандартные параметры (для кода программ) и нажмите кнопку Далее.
3) Установите переключатель в значение Выбрать отдельные параметры из полного списка и нажмите кнопку Далее.
4) Отметьте все флажки кроме флажка Имитация нехватки ресурсов и нажмите кнопку Далее.
5) Установите переключатель в значение Автоматически выбирать неподписанные драйверы и нажмите кнопку Далее.

Если неподписанные драйверы обнаружены, система отобразит Вам их список, в котором будут указаны файлы драйверов и их описание. Причем найденные драйвера могут принадлежать как устройствам, так и приложениям. Не закрывайте пока окно средства проверки драйверов и не нажимайте никаких кнопок.

Дальше возможно три варианта предпринимаемых Вами действий.

Вариант 1. Обновление программы или драйвера.

6) Посетите сайт производителя устройства или автора программы и скачайте более новую версию.
7) Переустановите программу или обновите драйвер.
8) После обновления приложения или драйвера закройте окно средства проверки драйверов, нажав кнопку Отмена.
9) Перезагрузите компьютер и продолжайте работу в операционной системе.
Если в системе не возникают ошибки связанной с данным драйвером, значит обновление драйвера или программы устранило её.

Вариант 2. Удаление программы или драйвера.

6.1) Удалите программу, которой принадлежит данный драйвер.
6.1.1) Откройте Панель управления\Все элементы панели управления\Программы и компоненты и удалите приложение, которому принадлежит драйвер.
Перед удалением программы убедитесь, что у Вас присутствует ее установочный диск или ее установка сохранена у Вас на диске.

6.2) Удалите драйвер в Диспетчере устройств.
6.2.1) В меню Пуск щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства.
6.2.2) Нажмите в списке слева на Диспетчер устройств.
6.2.3) В Диспетчере устройств найдите устройство, щелкните по нему правой кнопкой мыши и выберите из контекстного меню пункт Свойства.
6.2.4) Перейдите на вкладку Драйвер и нажмите кнопку Удалить.

7) После удаления приложения или драйвера закройте окно средства проверки драйверов, нажав кнопку Отмена.
8) Перезагрузите компьютер и продолжайте работу в операционной системе.

Если в системе не возникают ошибки связанной с данным драйвером, значит удаление драйвера или программы устранило её.

Вариант 3. Проверка неподписанных драйверов.

Внимание! После проверки неподписанных драйверов система может не загрузиться (прежде чем переходить к дальнейшим действиям, прочтите данный вариант до конца).

6) Нажмите кнопку Готово и перезагрузите компьютер.

Если же после перезагрузки появился синий экран с ошибкой, проблемный драйвер определен - его название будет включено в сообщение об ошибке. В таком случае:

7) Перезагрузите компьютер
8) До начала запуска Windows нажмите на клавишу F8. При появлении окна выбора дисков: выберите диск на котором у Вас установлена Windows, нажмите Enter, а затем сразу F8.
9) Выберите пункт Безопасный режим
10) Откройте диалоговое меню Выполнить: Пуск -> Выполнить или нажмите комбинацию Win+R
11) Введите команду verifier.exe /reset и нажмите Enter.

Если система загрузилась в обычном режиме, проверка неподписанных драйверов завершилась успешно - они не являются источником проблем.

Проверка подписанных драйверов.

1) В строке поиска меню Пуск введите verifier и нажмите Enter.
2) Выберите пункт Создать нестандартные параметры (для кода программ) и нажмите кнопку Далее.
3) Установите переключатель в значение Выбрать отдельные параметры из полного списка и нажмите кнопку Далее.
4) Отметьте все флажки кроме флажка Имитация нехватки ресурсов и нажмите кнопку Далее.
5) Установите переключатель в значение Выбрать имя драйвера из списка и нажмите кнопку Далее.
6) Нажмите на заголовок колонки Поставщик для сортировки драйверов по их поставщику.
7) Выберите первые 10-15 драйверов установив напротив них флажки в колонке Проверить.
Не выбирайте все драйверы сразу, так как их проверка займет много времени и ресурсов системы.
8) Нажмите кнопку Готово и перезагрузите компьютер. Если система загрузилась в обычном режиме, проверка выбранных драйверов завершилась успешно - они не являются источником проблем. В таком случае повторите описанные выше действия выбрав следующие 10-15 драйверов.

Если же после перезагрузки появился синий экран с ошибкой, проблемный драйвер определен - его название будет включено в сообщение об ошибке. В таком случае:

1) Перезагрузите компьютер
2) До начала запуска Windows нажмите на клавишу F8. При появлении окна выбора дисков: выберите диск на котором у Вас установлена Windows, нажмите Enter, а затем сразу F8.
3) Выберите пункт Безопасный режим
4) Откройте диалоговое меню Выполнить: Пуск -> Выполнить или нажмите комбинацию Win+R
5) Введите команду verifier.exe /reset и нажмите Enter. Если проверка всех драйверов завершилась успешно, то скорее всего, драйверы не являются причиной критической ошибки, возникающей в Вашей системе.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


19. В окне выбора раздела на диске при установке Windows создается раздел с нулевым размером.

19. При установке Windows, в окне выбора раздела на диске создается раздел с нулевым размером.

В случае появления, при установке Windows, в окне выбора раздела на диске - пункта: Незанятое место на диске 0. Полный размер 0.0МБ, свободно 0.0МБ, выполните указанные ниже действия:

Если у Вас несколько дисков, то для выполнения указанной ниже инструкции оставьте подключенным только тот диск, для которого создается нулевой раздел. Остальные диски отключите.

1) Установите в BIOS режим для дисков на IDE.

Если Вы не можете войти в BIOS для изменения настроек (из-за того что компьютер висит), тогда: 1.1) Выключите компьютер, отсоедините SATA-кабель от диска
1.2) Включите компьютер и измените режим.
1.3) Выключите компьютер, подсоедините SATA-кабель к диску
1.4) Включите компьютер

2) Загрузитесь с Вашего Windows 7 DVD, выберите Установить.
3) Когда Вы окажетесь в окне выбора раздела для установки Windows, удалите все возможные разделы на диске. (Не обращая внимания, на то, что остались не удаленными нулевые разделы.)
4) Выйдите из программы установки Windows. Не продолжайте.
5) Перезапустите компьютер. При желании измените в BIOS режим для дисков с IDE на AHCI.
6) Опять загрузитесь с Вашего Windows 7 DVD, и снова выберите Установить.
7) Когда Вы окажетесь в окне выбора раздела для установки Windows, разделов с 0 размером быть не должно.
8) Укажите все доступное пространство для создание одного раздела.
9) Продолжите установку как обычно.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Устройства и BSOD.


1. Невозможно переместить Временные файлы Интернета на другой логический диск (D:\Cash).

Установите, как минимум, пониженный уровень UAC.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


2. Если гаджет погоды пишет service unavailable for your region.

Для нормальной работы гаджетов не отключайте UAC полностью, а ставьте на минимум.
Если отключить UAC совсем (крайне нижнее положение - Never Notify), то гаджеты могут пропасть.
А панель настройки гаджетов может стать недоступной.

Вариант 1

Завершите процесс sidebar.exe и перезапустите его (правой кнопкой мыши на рабочем столе --> Gadgets)

Также добавьте в папке %WINDIR%\system32\driverc\etc в файл hosts следующие строки:

Вариант 2

Если перезапуск не помогает, то вы можете поставить другой гаджет погоды, например: AccuWeather.com® Forecast Gadget или HTC Home

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


3. В Windows Update при попытке обновления появляется error 80072ee7.

Если во время проверки наличия обновлений Центр обновления Windows выдает сообщение об ошибке 80072ee7, возможно, следует изменить или удалить статические IP-адреса для службы Центра обновления Windows . Адреса хранятся в файле операционной системы Hosts.

IP-адрес для службы Центра обновления Windows может изменяться во время каждой проверки наличия обновлений, однако некоторые программы-надстройки Windows добавляют в файл Hosts статические адреса. Статический IP-адрес для службы Центра обновления Windows не позволит компьютеру получать обновления.

Удаление статического IP-адреса для веб-сайта службы Центра обновления Windows

1. Откройте компонент Компьютер. Для этого нажмите кнопку Пуск и выберите пункт Компьютер.
2. Дважды щелкните значок локального жесткого диска, на котором установлена система Windows (обычно диск С).
3. Дважды щелкните папку Windows, а затем - папку System32.
4. Дважды щелкните папку драйверы, а затем - папку и т. д..
5. В папке etc щелкните правой кнопкой мыши файл hosts и нажмите Открыть. После того как вам будет предложено выбрать программу, с помощью которой следует открывать данный файл, выберите Блокнот.
6. Проверьте, стоит ли в файле hosts знак # около всех записей IP-адресов и имен узлов Центра обновления Windows. Если это не так, вставьте значок # или удалите запись целиком.
7. Откройте меню Файл, выберите команду Сохранить и повторно выполните проверку наличия обновлений.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


4. Решение проблемы с punkbuster на Windows 7.

Вариант 1.

Решение проблемы вылетов игр (Например: COD 5 и Battlefield 2) с ошибкой: punkbuster kiked player *** for 0 minets. RESTRICTION: unknow windows APL function 131132 (131131, 131134, 131136).
1) Обновите PunkBuster:
1.1) Скачайте программу обновления PunkBuster
1.2) Установите программу и запустите ее.
1.3) Добавьте туда игру, для которой нужно обновить punkbuster и нажмите check for updates. По завершению появится сообщение об окончании обновления.
2) Откройте папки C:\Windows\System32 (для х86) и/или C:\Windows\SysWOW64 (для х64)
3) Установите в свойствах файлов PnkBstrA.exe и PnkBstrB.exe совместимость с Windows XP или Windows Vista и уровень прав администратора. (PnkBstrB.exe еще есть в папке с игрой. Например: C:\Users\*username*\AppData\Local\PunkBuster\BF2\pb).

Вариант 2.

1) Откройте папки C:\Windows\System32 (для х86) и/или C:\Windows\SysWOW64 (для х64)
2) Установите в свойствах файлов PnkBstrA.exe и PnkBstrB.exe совместимость с Windows XP или Windows Vista и уровень прав администратора.
3) На рабочем столе создайте bat-файл со следующим содержанием:

4) Запускайте данный bat-файл перед запуском игр.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


5. Исправление длительного времени задержки (лагов) в компьютерных сетях.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\
3) Найдите в ней раздел соответствующий интерфейсу, по которому у Вас работает интернет. Если Вы его не нашли, то дальнейшие действия произведите во всех разделах.
4) Создайте DWORD-параметр и назовите его TcpAckFrequency
5) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить
6) Установите значение переключателя на Шестнадцатеричное, введите значение параметра 1 и нажмите ОК.
7) Откройте Пуск -> Панель управления -> Программы и Компоненты
8) В меню слева нажмите ссылку Включение и отключение компонентов Windows.
9) Найдите пункт Сервер очереди сообщений Майкрософт (MSMQ) (Microsoft Message Queue (MSMQ) Server) и установите на нем флажок. Также установите флажки на всех компонентах внутри.

10) Перезагрузите компьютер.
11) Запустите Редактор реестра (Win+R -> regedit -> Ok)
12) Откройте ветку: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters
13) Создайте DWORD-параметр и назовите его TCPNoDelay
14) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить
15) Установите значение переключателя на Шестнадцатеричное, введите значение параметра 1 и нажмите ОК.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


6. При вызове справки пишет "Internet Explorer не удается загрузить / из help".

При вызове справки "Справка и поддержка" появляется сообщение об ошибке:

Это может происходить по причине неправильного сопоставления программам типа файлов .xml
Для исправления ошибки скопируйте код в новый текстовый файл, сохраните его, присвоив расширение .reg, запустите и согласитесь с внесением изменений в реестр.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


7. Если при VPN соединении через bat-файл у вас появляется ошибка 623.

Переименуйте имя соединения на английский язык и всё должно заработать.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


8. Не работают обновления, в центре обновления Windows надпись: Некоторые параметры задаёт системный администратор.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate]
3) Удалите параметр DisableWindowsUpdateAccess
4) Закройте Редактор реестра и перезагрузите компьютер.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


9. Сетевой адаптер отключает сеть через каждые 5 минут.

1) Запустите Диспетчер устройств (Win+R -> devmgmt.msc -> ОК)
1.1) Откройте меню Пуск
1.2) Нажмите правой кнопкой на Компьютер и выберите пункт Свойства (Панель управления\Все элементы панели управления\Система)
1.3) Нажмите на ссылку Диспетчер устройств
2) Откройте Сетевые адаптеры
3) Щелкните правой кнопкой мыши на Вашем сетевом адаптере и выберите пункт Свойства
4) Перейдите на вкладку Управление электропитанием
5) Уберите флажок Разрешить отключение этого устройства для экономии энергии.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


10. Восстановление иконок html-файлов, при использовании Mozilla Firefox.

Для восстановления иконок html-файлов - создайте и примените reg-файл следующего содержания.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


11. Устранение "Ошибки 711".

Вариант 1.

Эта ошибка может возникнуть, если не запущены все или некоторые из перечисленных ниже служб.

Диспетчер автоматических подключений удаленного доступа
Диспетчер подключений удаленного доступа
Телефония

Для устранения этой ошибки выполните следующие действия для каждой из указанных выше служб.

1) Нажмите кнопку Пуск
2) Откройте Панель управления -> Администрирование -> Службы (или Win+R -> services.msc)
3) Щелкните правой кнопкой мыши на одну из указанных выше служб и затем щелкните Свойства.
4) На вкладке Общие в пункте Тип запуска выберите вариант Вручную.
5) Нажмите Применить, а затем нажмите Запустить.

Вариант 2.

Загрузитесь из Erd Commander (или любого LiveCD) и переименуйте папку ..\Windows\System32\Logfiles в Logfiles.old

Вариант 3.

Щелкните правой кнопкой мыши на папке Windows и выберите Свойства, перейдите на вкладку Безопасность, проверьте, чтобы в окне группы и пользователи обязательно были: "СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ", "система" и "TrustedInstaller" с разрешением полного доступа, дополнительно могут быть "Administrators", "Users"

Вариант 4.

1) Откройте меню Пуск и в строке поиска введите cmd
2) Щелкните правой кнопкой мыши на найденном файле и выберите строку "Запуск от имени администратора"
3) Введите указанную ниже команду и нажмите Enter:

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


12. Исправление ошибки Internet Explorer: "Internet Explorer has stopped working".

Вариант 1.

1) Нажмите кнопку Пуск
2) Откройте Панель управления и запустите Свойства обозревателя
3) Перейдите на вкладку Дополнительно
4) Нажмите кнопку Сброс...
5) Прочитайте информационное сообщение и нажмите кнопку Сброс

Вариант 2.

1) Нажмите кнопку Пуск
2) Откройте Панель управления и запустите Свойства обозревателя
3) Перейдите на вкладку Безопасность
4) Уберите флажок Включить защищенный режим.
5) Перезапустите Internet Explorer (если он был запущен).

Вариант 3.

1) Запустите Редактор реестра (Win+R -> regedit -> Ok)
2) Откройте ветку HKLM\SOFTWARE\Microsoft\SQMClient\Windows\DisabledSessions
3) Удалите все параметры, кроме параметра (По умолчанию)

Вариант 4.

1) Откройте меню Пуск.
2) В строке поиска введите gpedit.msc и нажмите Enter
3) Перейдите к Конфигурация компьютера\Административные шаблоны\Система\Управление связью через Интернет\Параметры связи через интернет
4) Щелкните дважды левой кнопкой мыши на Отключить программу по улучшению качества программного обеспечения Windows.
5) Установите переключатель в значение Включить и нажмите ОK.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


13. Удаление временных файлов обновлений(+очистка журнала обновлений) для устранения ошибок, возникающих в Центре обновления Windows.

Если во время установки или проверки наличия обновлений Центр обновления Windows выдает Вам сообщения об ошибках, то возможно Вам необходимо удалить временные файлы, которые используются Windows для определения обновлений для компьютера.
Внимание: Удаление временных файлов обновлений, также приведет к удалению журнала Центра обновления Windows.

1) Остановите службу Центр обновления Windows
1.1) Откройте Пуск -> Панель управления -> Администрирование -> Службы. Щелкните на службе Центр обновления Windows правой кнопкой мыши и выберите пункт Остановить.
или
1.2) Введите в командной строке (Win+R -> cmd -> ОК) команду net stop wuauserv и нажмите Enter.

2) Удалите временные файлы обновлений, для этого полностью удалите содержимое папок:

%systemroot%\SoftwareDistribution\DataStore
%systemroot%\SoftwareDistribution\Download

3) Запустите службу Центр обновления Windows
3.1) Откройте Пуск -> Панель управления -> Администрирование -> Службы. Щелкните на службе Центр обновления Windows правой кнопкой мыши и выберите пункт Запустить.
или
3.2) Введите в командной строке (Win+R -> cmd -> ОК) команду net start wuauserv и нажмите Enter.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


14. Не получается включить сетевое обнаружение в дополнительных параметрах общего доступа.

1) Откройте Панель управления\Сеть и Интернет\Центр управления сетями и общим доступом
2) Измените расположение для сети на Домашняя сеть щелкнув на ссылку Общественная сеть под Вашим подключением.
3) Откройте Панель управления -> Администрирование -> Службы и проверьте включены ли у Вас службы

4) Некоторые антивирусные программы также могут блокировать данные действия. Попробуйте отключить антивирусное обеспечение, затем измените настройку и проверьте сохранятся ли настройки.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


15. Восстановление в Mozilla Firefox 4 окна "Выход из Firefox" с кнопками "Сохранить и Выйти", "Выйти" и "Отмена".

1) В главном меню откройте Инструменты -> Настройки
2) На вкладке Основные в разделе Запуск установите значение "При запуске Firefox: Показывать домашнюю страницу" и нажмите ОК.
3) В адрессной строке введите about:config и нажмите Enter.
4) В строке Фильтр введите browser.showQuitWarning
5) Дважды щелкните на найденном параметре, чтобы его значение переключилось на true.

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


16. Ftp-сервер при вводе адреса в проводнике открывается в Internet Explorer.

1) В Internet Explorer откройте Свойства обозревателя.
Если у Вас включена Строка меню, то данный пункт расположен в меню Сервис, если Строка меню отключена, то нажмите на значок шестеренки.
2) Перейдите на вкладку Дополнительно
3) Установите флажок: Разрешить просмотр FTP-папок (за пределами Internet Explorer)

Назад на страницу раздела Устранение неполадок.
Назад на страницу подраздела Устранение неполадок - Локальная сеть и Интернет.


Разное

1. Сравнение версий Windows 7.

Функция / Редакция | Начальная | Домашняя базовая | Домашняя расширенная | Профессиональная | Корпоративная | Максимальная
 | Продажа только по OEM-лицензиям | Продажа в розницу и по OEM-лицензиям (только на развивающихся рынках, включая российский) | Продажа в розницу и по OEM-лицензиям | Продажа в розницу, по OEM и корпоративным лицензиям | Продажа только под корпоративными лицензиями | Продажа в розницу и по OEM-лицензиям
Окончание поддержки | 13.01.2015 | 13.01.2015 | 13.01.2015 | 13.01.2020 | 13.01.2020 | 13.01.2015
Наличие 64-битной версии | Нет | Да | Да | Да | Да | Да
Максимальный размер оперативной памяти (для 64-битных версий) | 2 Гб (для 32-битной версии) | 8 Гб | 16 Гб | 128 Гб | 128 Гб | 128 Гб
Центр восстановления Windows | Нет поддержки домена | Нет поддержки домена | Нет поддержки домена | Да | Да | Да
Функция «Домашняя группа» (создание и присоединение к группе) | Только присоединение | Только присоединение | Да | Да | Да | Да
Интерфейс Windows Aero | Нет | Только базовая тема оформления | Да | Да | Да | Да
Поддержка нескольких мониторов | Нет | Да | Да | Да | Да | Да
Быстрое переключение между пользователями | Нет | Да | Да | Да | Да | Да
Возможность смены фонового рисунка рабочего стола | Нет | Да | Да | Да | Да | Да
Диспетчер рабочего стола | Нет | Да | Да | Да | Да | Да
Центр мобильности Windows | Нет | Да | Да | Да | Да | Да
Multitouch и улучшенное распознавание рукописного ввода | Нет | Нет | Да | Да | Да | Да
Windows Media Center | Нет | Нет | Да | Да | Да | Да
Дополнительные игры | Нет | Нет | Да | Отключены по умолчанию | Отключены по умолчанию | Да
Эмулятор Windows XP(Windows XP Mode) | Нет | Нет | Нет | Да | Да | Да
EFS (система шифрования данных) | Нет | Нет | Нет | Да | Да | Да
Печать с учетом информации о местоположении | Нет | Нет | Нет | Да | Да | Да
Возможность выступать в качестве хост-компьютера Удаленного рабочего стола | Нет | Нет | Нет | Да | Да | Да
Подключение к домену | Нет | Нет | Нет | Да | Да | Да
Возможность даунгрейда до Vista или XP | Нет | Нет | Нет | Да | Да | Да
Поддержка нескольких процессоров | Нет | Нет | Нет | Да | Да | Да
AppLocker | Нет | Нет | Нет | Нет | Да | Да
BitLocker и BitLocker To Go | Нет | Нет | Нет | Нет | Да | Да
Branch Cache | Нет | Нет | Нет | Нет | Да | Да
DirectAccess | Нет | Нет | Нет | Нет | Да | Да
Подсистема для запуска Unix-приложений | Нет | Нет | Нет | Нет | Да | Да
Мультиязычная пользовательская среда | Нет | Нет | Нет | Нет | Да | Да
Загрузка с VHD (файла-образа Microsoft Virtual PC) | Нет | Нет | Нет | Нет | Да | Да
Запуск оснастки lusrmgr.msc (Local Users and Groups) | Нет | Нет | Нет | Да | Да | Да
Запуск оснастки gpedit.msc (Local Group Policy Editor) | Нет | Нет | Нет | Да | Да | Да
Запуск оснастки secpol.msc (Local Security Policy) | Нет | Нет | Нет | Да | Да | Да

Windows Aero — анимация окон при открытии, закрытии, сворачивании, восстановления окна, делающая работу с операционной системой более понятной. Прозрачные элементы окон с размывкой заднего плана позволяют пользователю сконцентрироваться только на содержимом активного окна. Компоненты Windows Aero:

Aero Glass — прозрачные (с размывкой заднего плана) заголовки и панели в окнах.
Windows Flip — новый вид меню Alt + Tab, в котором показываются эскизы открытых окон и их значки.
Windows Flip 3D — замена Alt + Tab, вызываемая сочетанием Win + Tab, теперь все окна выстраиваются в ряд в 3D. При помощи стрелок клавиатуры или колесика мышки можно прокручивать окна.
Aero Shake — позволяет свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти».
Aero Peek — позволяет отображать уменьшенные копии окон при наведении мыши на значок панели задач, переключаться между окнами приложения простым кликом по значку, перетаскивать и фиксировать на панели задач различные окна и приложения, просматривать рабочий стол одним наведением в специальную область экрана и многое другое.
Aero Snap — позволяет движением мыши разворачивать окно на полэкрана, весь экран или только по вертикальной оси.

Диспетчер рабочего стола (англ. Desktop Window Manager, DWM), ранее Desktop Compositing Engine, DCE — система графического интерфейса рабочего стола в Windows Vista и Windows 7, который используется в графическом интерфейсе Windows Aero.

Центр мобильности Windows — объединяет настройки мобильного ПК в одном месте для обеспечения быстрого доступа к ним. Из одного и того же местоположения можно выполнять различные операции, например регулировать громкость мобильного ПК, проверять состояние беспроводного сетевого подключения или настраивать яркость дисплея.

Мультитач (англ. multitouch или multi-touch) — технология, по которой сенсорный экран или тачпад отслеживает одновременно несколько точек нажатия. Например, сближая пальцы рук, можно уменьшить картинку на дисплее, а раздвигая — увеличить. Кроме того, мультитач-экраны позволяют работать с устройством одновременно нескольким пользователям.

Windows Media Center (кодовое имя Freestyle) является приложением для проигрывания мультимедиаконтента (музыки, изображений и потокового телевидения) на домашнем медиацентре.

Encrypting File System (EFS) — система шифрования данных, реализующая шифрование на уровне файлов. Данная система предоставляет возможность «прозрачного шифрования» данных, хранящихся на разделах с файловой системой NTFS для защиты потенциально конфиденциальных данных от несанкционированного доступа при физическом доступе к компьютеру и дискам.

Домен Windows — группа компьютеров одной сети, имеющих единый центр (который называется контроллером домена), использующий единую базу пользователей (то есть учётные записи находятся не на каждом в отдельности компьютере, а на контроллере домена, т.н. сетевой вход в систему), единую групповую и локальную политики, единые параметры безопасности (применимо к томам с файловой системой NTFS), ограничение времени работы учётной записи и прочие параметры, значительно упрощающие работу системного администратора организации, если в ней эксплуатируется большое число компьютеров.

AppLocker — расширенная версия политик ограниченного использования программ. Позволяет разрешать или запрещать запуск программ при определенных условиях. Например, "Разрешить запуск Adobe Acrobat версии выше 7.0".

BitLocker и BitLocker To Go — позволяет защитить все данные, от документов до паролей, путем шифрования всего диска, на котором хранятся системные файлы Windows и данные пользователей. BitLocker используется для встроенных дисков, BitLocker To Go - для съемных запоминающих устройств, таких как внешние жесткие диски и USB-устройства флэш-памяти.

BranchCache — это технология кэширования на ресурсах локальной сети данных, расположенных на удаленных серверах. Если пользователю в локальной сети потребуется файл, который уже был загружен кем-то из пользователей его сети, — он сможет получить его из локального кэш-хранилища, а не использовать канал с ограниченной пропускной способностью.

DirectAccess — обеспечивает доступ пользователей к корпоративной сети при наличии выхода в Интернет. В отличие от большинства традиционных VPN соединений, которые должны быть запущены и прерваны явно действиями пользователя, подключения DirectAccess создаются автоматически компьютером, на котором работает пользователь.

Подсистема для UNIX-приложений — представляет собой многопользовательскую среду UNIX, которая предоставляет инструментарий и библиотеки API переноса приложений для работы на компьютерах под управлением операционной системы Windows.

Загрузка с VHD-файла — использование для загрузки операционной системы Windows - VHD-файла, содержащего в себе виртуальную операционную систему имеющую полную структуру и содержание сходные с жестким диском.

Мультиязычная пользовательская среда (MUI) — Выбор нужного языка интерфейса и возможность переключения между 35 доступными языками.

2. Открытие файлов справки с расширением .hlp.

Начиная с Windows Vista, компания Майкрософт отменила поддержку открытия данного типа файлов, с использованием системной программы WinHlp32.exe. Для открытия данного типа файлов установите обновление Windows6.1-KB917607-x86.msu или Windows6.1-KB917607-x64.msu, в зависимости от разрядности.
Официальная ссылка: здесь

3. Список программ Windows, запускаемых в диалоговом окне Выполнить.

Диалоговое окно Выполнить используется в Windows для открытия программы, папки или документа. Оно позволяет создать задание для запуска с правами администратора. Самые известные команды выполняемые в окне Выполнить это cmd (Командная строка) и regedit (Редактор реестра). Зная точное названия команды Вы можете запустить любое системное приложения или оснастку Windows.
Диалоговое меню Выполнить запускается либо Пуск -> Выполнить, либо нажатием клавиатуре Win+R.
Для выполнения команды введите её название и нажмите Enter.

Русское название элемента | Английское название элемента | Команда
Ftp-протокол (командная строка) | Ftp-protocol (command prompt) | ftp
Iexpress Wizard (не переведена) | Iexpress Wizard | iexpress
Internet Explorer | Internet Explorer | iexplore
Paint | Paint | mspaint
Wordpad | Wordpad | write
Администратор источников данных ODBC | ODBC Data Source Administrator | odbcad32
Администрирование | Administrative Tools | control admintools
Архивация и восстановление | Backup and Restore | sdclt
Блокнот | Notepad | notepad
Брандмауэр Windows | Windows Firewall | firewall.cpl
Включение и отключение компонентов Windows | Turn Windows features on or off | OptionalFeatures.exe
Восстановление системы | System Restore | rstrui
Выйти из системы | Log Out Of Windows | logoff
Дата и Время | Date and Time | timedate.cpl
Дефрагментация диска | Disk Defragmenter | dfrgui
Диспетчер авторизации | Authorization Manager | azman.msc
Диспетчер задач Windows | Windows Task Manager | taskmgr
Диспетчер проверки драйверов | Driver Verifier Manager | verifier
Диспетчер устройств | Device Manager | devmgmt.msc
Диспетчер устройств | Device Manager | hdwwiz.cpl
Дополнительные часы | Additional Clocks | control timedate.cpl,,1
Завершение работы Windows | Shuts Down Windows | shutdown /s
Записки | Sticky Note | StikyNot
Защита БД учетных записей Windows | Securing the Windows Account Database | syskey
Звук | Sound | mmsys.cpl
Звуки (звуковая схема) | Sounds (sound theme) | control mmsys.cpl,,2
Звукозапись | Sound Recorder | soundrecorder
Игровые устройства | Game Controllers | joy.cpl
Инициализация оборудования безопасности для TPM | Initialize the TMP security hardware | TpmInit
Калибровка цветов экрана | Display Color Calibration | dccw
Калькулятор | Calculator | calc
Командная строка | Command Prompt | cmd
Компоненты Windows | Windows Features | OptionalFeatures
Консоль управления(MMC) | Microsoft Management Console | mmc
Конфигурация системы | System Configuration | msconfig
Локальная политика безопасности | Local Security Policy | secpol.msc
Локальные пользователи и группы | Local Users and Groups | lusrmgr.msc
Мастер загрузки изображений Windows | Windows Picture Acquisition Wizard | wiaacmgr
Мастер создания общих ресурсов | Create A Shared Folder Wizard | shrpubw
Мастер установки драйверов устройств | Driver Package Installer | dpinst
Мастер установки оборудования | Add Hardware Wizard | hdwwiz
Микшер громкости | Sound Volume | sndvol
Монитор ресурсов | Resource Monitor | resmon
Настройка доступа программ и умолчаний | Set Program Access and Computer Defaults | control appwiz.cpl,,3
Настройка Контроля Учетных Записей | User Account Control Settings | UserAccountControlSettings
Ножницы | Snipping Tool | snippingtool
Общие папки | Shared Folders | fsmgmt.msc
Очистка диска | Disk Cleanup Utility | cleanmgr
Панель управления | Control Panel | control
Папка "Fonts" | Fonts Folder | fonts
Папка "Загрузки" | "Downloads" Folder | Downloads
Параметры папок | Folder Options | control folders
Перезагрузка | Restart Windows | shutdown /r
Перенос принтеров | Printer Migration | PrintBrmUi
Перо и сенсорные устройства | Pen and Touch | TabletPC.cpl
Персонализация | Personalization | control desktop
Планировщик заданий | Task Sheduler | control schedtasks
Подключение к удаленному рабочему столу | Remote Desktop Connection | mstsc
Получение программ | Get Programs | control appwiz.cpl,,1
Проверка диска | Check Disk Utility | chkdsk
Проверка и восстановление системных файлов | System File Checker (Scan and Repair) | sfc /scannow
Проверка подписи файла | File Signature Verification | sigverif
Проводник | Windows Explorer | explorer
Проводник: C:\ | Windows Explorer: C:\ | \
Проводник: С:\Users\Ваше_имя | Windows Explorer: С:\Users\Your_name | .
Проводник: С:\Users\ | Windows Explorer: С:\Users\ | ..
Программа DiskPart | Disk Partition Manager | diskpart
Программы и компоненты | Programms and Features | appwiz.cpl
Просмотр событий | Event Viewer | eventvwr.msc
Разрешение экрана | Screen Resolution | desk.cpl
Редактор личных знаков | Private Character Editor | eudcedit
Редактор локальной групповой политики | Local Group Policy Editor | gpedit.msc
Редактор реестра | Registry Editor | regedit
Редактор реестра | Registry Editor | regedt32
Редактор титульных страниц факсов | Fax Cover Sheet Editor | fxscover
Результирующая политика | Resultant Set of Policy | rsop.msc
Сведения о системе | System Information | msinfo32
Свойства системы | System Properties | sysdm.cpl
Свойства системы: Дополнительно | System Properties: Advanced | SystemPropertiesAdvanced
Свойства системы: Защита системы | System Properties: System Protection | SystemPropertiesProtection
Свойства системы: Оборудование | System Properties: Hardware | SystemPropertiesHardware
Свойства системы: Удаленный доступ | System Properties: Remote | SystemPropertiesRemote
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | iscsicpl
Свойства: Интернет | Internet Properties | inetcpl.cpl
Свойства: Клавиатура | Keyboard Properties | control keyboard
Свойства: Мышь | Mouse Properties | control mouse
Свойства: Мышь | Mouse Properties | main.cpl
Свойства: Мышь: Параметры указателя | Mouse Properties: Pointer Options | control main.cpl,,2
Свойства: Мышь: Указатели (схема) | Mouse Properties: Pointers | control main.cpl,,1
Сертификаты | Sertificates | certmgr.msc
Сетевые подключения | Network Connections | control netconnections
Сетевые подключения | Network Connections | ncpa.cpl
Системный монитор | Performance Monitor | perfmon
Служба индексирования | Indexing Service | ciadv.msc
Службы | Services | services.msc
Службы компонентов | Component Services | dcomcnfg
Службы компонентов | Component Services | comexp.msc
Совместимость программы | Program Compatibility | msdt.exe -id PCWDiagnostic
Создать диск восстановления системы | Create a system repair disk | recdisc
Соседние пользователи | People Near Me | collab.cpl
Сохранение имен пользователей и паролей | Stored User Names and Passwords | credwiz
Средство диагностики DirectX | Direct X Troubleshooter | dxdiag
Средство диагностики службы технической поддержки | Microsoft Support Diagnostic Tool | msdt
Средство калибровки дигитайзера | Ditilizer Calibration Tool | tabcal
Средство настройки текста ClearType | ClearType Text Tuner | cttune
Средство просмотра XPS | XPS Viewer | xpsrchvw
Стредство записи действий по воспроизведению неполадок | Problem Steps Recorder | psr
Таблица символов | Character Map | charmap
Телефон и модем | Phone and Modem | telephon.cpl
Удаленный помощник Windows | Windows Remote Assistance | msra
Управление дисками | Disk Management | diskmgmt.msc
Управление компьютером | Computer Management | compmgmt.msc
Управление печатью | Print Management | printmanagement.msc
Управление цветом | Color Management | colorcpl
Установка или удаление языков интерфейса | Install or uninstall display languages | lpksetup
Устройства и принтеры | Devices and Printers | control printers
Учетные записи пользователей | User Accounts | Netplwiz
Цвет и внешний вид окна | Window Color and Appearance | control color
Центр мобильности Windows | Windows Mobility Center | mblctr
Центр поддержки | Action Center | wscui.cpl
Центр синхронизации | Sync Center | mobsync
Центр специальных возможностей | Ease of Access Center | utilman
Шифрующая файловая система (EFS) | Encryption File System | rekeywiz
Шрифты (добавление или удаление) | Fonts | control fonts
Экран (размер текста) | Display (size of text) | dpiscaling
Экранная клавиатура | On-Screen Keyboard | osk
Экранная лупа | Magnifier | magnify
Экранный диктор | Microsoft Narrator | narrator
Электропитание | Power Options | powercfg.cpl
Электропитание: Дополнительные параметры | Power Options: Advanced Settings | control powercfg.cpl,,1
Элемент управления WMI | Windows Management Infrastructure | wmimgmt.msc
Язык и региональные стандарты | Region and Language | intl.cpl
Язык и региональные стандарты: Дополнительно | Region and Language: Administrative | control intl.cpl,,3
Язык и региональные стандарты: Языки и клавиатуры | Region and Language: Keyboards and Languages | control intl.cpl,,2

Если какой-либо из элементов списка не запускается, то скорее всего это означает что он неустановлен. Многие из компонентов Windows можно установить в Пуск -> Панель Управления -> Программы и Компоненты -> Включение и отключение компонентов Windows

4. Список клавиатурных сокращений.

Основные:

Alt+Tab - Переключение между окнами
Win+Tab - Переключение между окнами в режиме Flip3D
Win+Up - Развернуть окно
Win+Down - Восстановить / Минимизировать окно
Win+Left - Прикрепить окно к левому краю экрана
Win+Right - Прикрепить окно к правому краю экрана
Win+Shift+Left - Переключиться на левый монитор
Win+Shift+Right - Переключиться на правый монитор
Win+Home - Минимизировать / Восстановить все неактивные окна
Win+Break(или Pause) - Запустить элемент Система из Панели Управления (пункт Свойства при нажатии правой кнопкой мыши на Компьютер в меню Пуск)
Win+Space - Показать рабочий стол
Win+B - Переход в область уведомлений(трей)
Win+D - Свернуть окна или восстановить все окна
Win+E - Запустить Проводник(Explorer)
Win+F - Запустить встроенный диалог поиска Windows
Win+Ctrl+F - Запустить Поиск по компьютеру из домена
Win+F1 - Запустить встроенный диалог Windows: Справка и Поддержка
Win+G - Отобразить гаджеты поверх всех окон
Win+L - Блокировка рабочей станции(текущего сеанса пользователя)
Win+M - Минимизировать все окна
Win+P - Отобразить дополнительные опции дисплея (расширить рабочий стол на 2 монитор и т.п.)
Win+R - Запустить диалоговое окно Выполнить
Win+Т - Выбрать первый элемент в панели задач (Повторное нажатие переключает на следующий элемент, Win+Shift+T - прокручивает в обратном порядке)
Win+U - Запустить Центр специальных возможностей (Ease of Access Center)
Win+X - Запустить Mobility Center
Win+цифра- Запустить приложение с панели задач (Win+1 запускает первое приложения слева, Win+2, второе, и т.к.)
Win + "+" - Увеличить масштаб
Win + "-" - Уменьшить масштаб
Ctrl + колесо мыши (вверх\вниз) на рабочем столе - увеличить\уменьшить иконки рабочего стола.

В Проводнике (Explorer):
Alt+P - Показать / Скрыть Область предпросмотра

Панель задач:
Shift + щелчок на иконке - Открыть новое окно приложения
Ctrl + Shift + щелчок по иконке - Открыть новое окно приложения с привилегиями администратора
Shift + щелчок правой кнопкой на иконке - Показать меню приложения
Shift + щелчок правой кнопкой на группе иконок - Показать меню, восстановить все / свернуть все / Закрыть все
Ctrl + щелчок по группе иконок - Развернуть все окна группы

5. Перезагрузка компьютера в безопасный режим без использования клавиатуры.

Для того, чтобы перезагрузиться в Безопасный режим достаточно во время загрузки нажать клавишу F8 и выбрать пункт Safe Mode. А чтобы вернуться обратно в Нормальный режим достаточно всего лишь перезагрузить компьютер (не нажимая F8) и система вернется в своё стандартное состояние.
Но на некоторых материнских платах клавиша F8 используется для выбора физического устройства, с которого должен начать загрузку компьютер.
В этом случае необходимо выбрать жесткий диск, на котором установлена операционная система. После нажатия клавиши Enter необходимо сразу же снова нажимать клавишу F8 до тех пор, пока на экране не появится меню выбора вариантов загрузки ОС Windows. Вы должны успеть сделать это довольно быстро, а иначе начнется обычная загрузка Windows.
Если же нет желания играть на скорость, есть более легкий вариант решения:

1) Откройте Конфигурация системы (Пуск -> Выполнить -> msconfig -> Ok или Win+R -> msconfig -> Ok)
2) Перейдите на вкладку Загрузка
3) Поставьте галочку напротив значения Безопасный режим в разделе Параметры загрузки
4) Нажмите Ok и перезагрузите компьютер.
5) Чтобы вернуться обратно в Нормальный режим: находясь в Безопасном режиме уберите данную галочку и перезагрузите компьютер.

6. Определение букв назначенных дискам в среде восстановления или среде предустановки.

Загрузившись в среду восстановления или в среду предустановки Windows, Вы можете столкнуться с необходимостью определения буквы диска. Например, чтобы запустить приложения с флэш-диска или проверить диск на наличие ошибок.

Виртуальному диску создаваемому в среде восстановления или среде предустановки всегда соответствует буква Х:, а для определения букв остальных дисков Вы можете выбрать одно из предложенных решений.

Вариант 1. По размеру и типу диска.

1) Перейдите в папку X:\Sources; для этого в командной строке введите указанную ниже команду и нажмите Enter:

2) Запустите Блокнот (Notepad); для этого в командной строке введите указанную ниже команду и нажмите Enter:

3) В главном меню блокнота выберите Файл -> Открыть (или нажмите сочетание клавиш Ctrl+O) 4) Щелкните на значок Компьютер в области переходов слева

Примечание: Для лучшего отображения содержимого папки Компьютер, дважды щелкните по заголовку окна, чтобы его развернуть.

Вариант 2. По содержимому папки.

Также Вы можете определить буквы дисков напрямую из командной строки.

1) Переходите с диска на диск вводя его букву и нажимая Enter. Например:

Если Вам необходимо перейти к предполагаемой папке на диске, то переключайтесь используя команду:

Например:

2) Для отображения содержимого диска(папки) вводите команду:

7. Автоматическое переключение русской и английской раскладок клавиатуры.
Часто бывает, что напечатав какой-то текст, вы поднимаете глаза на монитор и вместо слова "Программа" видите слово "Ghjuhfvvf".
Для того чтобы сохранить ваше терпение и нервы, существуют две замечательные программы: Punto Switcher(если вы в основном работаете с русской или английской клавиатурой) и Key Switcher(если вы работаете с несколькими европейскими языками).

Данные программы предназначены для автоматического переключения между различными раскладками клавиатуры в операционных системах семейства Microsoft Windows.
Основное назначение данных программ — увеличение продуктивности и удобства при работе с компьютером. Работая в фоновом режиме, они проводят статистический анализ последовательностей вводимых символов слова, и, если сочетание букв оказывается нетипичным для языка, на котором вводятся символы, то переключают язык ввода, заменяя текст исправленным.
Каждая из программ является отдельным законченным продуктом и не требует запуска другой.

8. Удаление Windows 7 без форматирования раздела и без потери данных.

Для удаления Windows 7 описанным здесь способом вам потребуются:

а) ERD Commander;
б) Установочный диск Windows 7;

Шаг I. Удаление загрузочной информации Windows 7.

1) Загрузитесь в ERD Commader и вставьте установочный диск Windows 7 в свой DVD-привод.
2) Запустите Command Prompt
3) В открывшемся окне введите команду

Где, E: - Буква вашего DVD-привода, а C: - Буква вашего жесткого диска, с которого удаляется Windows 7

Шаг II. Удаление файлов и папок Windows 7.

1) Запустите Micosoft Diagnostics and Recovery Toolset -> Explorer
2) Как в обычном Explorer, тем же способом удалите следующие папки:
  • PerfLogs
  • Users
  • Windows
  • Recycle.Bin
  • Documents and Settings
  • ProgramData
  • Recovery

9. Создание образа и использование ERD Commander (необходим для получения полного доступа к файлам и папкам).

Скачиваете и устанавливаете сборщик образа ERD Commander для x86 или x64
Запускаете Пуск -> Все программы -> Microsoft Diagnostics and Recovery Toolset -> Мастер создания загрузочных носителей ERD Commander

По инструкции ниже создаете свой образ ERD Commander:

1) Монтируете образ дистрибутива Windows 7 в виртуальный дисковод
2) На вкладке Выбор образа загрузки указываете наш смонтированный виртуальный диск Windows 7

Рисунок 1 из 3

3) Щелкаете Ок, затем несколько раз кнопку Далее
4) На вкладке Выбор программных средств снова нажимаете Далее
5) В Мастер анализа сбоев выбираете Найти средства отладки для Windows в восстанавливаемой системе ...

Рисунок 2 из 3

6) На вкладке Загрузка определения автономного средства проверки системы Далее выбираете Нет, загрузить определения вручную позднее, затем Далее
7) На вкладке Дополнительные драйверы добавьте драйвера в образ, если необходимо, затем Далее
8) На вкладке Дополнительные файлы добавьте файлы в образ, если необходимо, затем Далее
9) На вкладке Создание образа загрузки укажите куда сохранить готовый образ ISO.
10) Оставляете галочку на пункте Записать готовый образ с помощью следующего устройства записи компакт-дисков, вставляете чистый диск в дисковод или убираете галочку с данного пункта, для дальнейшей записи на USB флеш-накопитель (флешку) и нажимаете Далее.

Рисунок 3 из 3

На USB флеш-накопитель (флешку) образ записывается через программу UltraISO так:
1) Открываете образ в UltraISO.
2) Выбираете Самозагрузка -> Записать образ жесткого диска...
3) Нажимаете Записать

11) Перезагружаемся в ERD Commander.
12) Would you like to initialize network connectivity in the background?
Если собираетесь восстанавливать настройки сети (Интернет или Локальной) выбираете Yes жмете Enter, если не собираетесь, то выбираете No и жмете Enter
13) Would you like to remap the drive letters to match the mappings from the target operating system?
Для сопоставления букв дисков целевой операционной системе выбираете Yes и жмете Enter, в противоположном случае выбираете No и жмете Enter
14) Select a keyboard input method
Выбираете нужную раскладку, нажимаете Next
15) В окне для выбора операционной системы:

Для работы с восстановительными программами Windows, выбирате пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. И выбираете вашу операционную систему.

Для работы с системными файлами и папками(удаление, переименование или их замена) не выбираете никакую систему(должно сняться выделение с какой-либо системы). Для этого выберите пункт: Restore your computer using a system image that you created earlier, а затем снова выберите пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. и выделение само снимется.
16) Нажимаете Next.

10. Активация Windows 7 по телефону, используя лицензионный ключ.

1) В меню Пуск нажмите правой кнопкой мыши на Компьютер и выберите пункт Свойства.
2) Нажмите на ссылку Изменить ключ продукта
3) Введите лицензионный ключ: XXXXX-XXXXX-XXXXX-XXXXX-XXXXX .
4) Нажмите Активировать.
5) Немного подождите, а затем выберите Другие способы активации - Активация по телефону. Выберите свой регион.
6) Позвоните по бесплатному номеру (можно через программу Skype) .
7) Робот начнет перечислять варианты активации.
8) Нажмите на телефоне 1 (Активировать продукт Майкрософт).
9) На вопрос на скольких компьютерах установлен продукт, нажмите 1.
10) Когда вас попросят ввести код, введите. В ответ робот продиктует 8 блоков по 6 цифр (каждый блок дважды для проверки).
11) Внесите цифры в окно активации.
12) Нажмите Далее. Интернет, может быть отключен (без разницы).
Windows 7 активирована.

11. Быстрое переключение с одного монитора на другой или с монитора на проектор.

Данное действие осуществляется нажатием клавиш Win+P. Вы также можете запустить DisplaySwitch.exe и выбрать предпочитаемый дисплей. Вызов данной утилиты не будет иметь результатов, если к компьютеру подключен только один монитор.

12. Где можно скачать справочник от Microsoft, содержащий полное описание утилит командной строки?

Вы можете скачать справочник от Microsoft (на английском языке), содержащий полное описание утилит командной строки.

1) Перейдите по ссылке http://www.microsoft.com/downloads/en/details.aspx?FamilyID=5fb255ff-72da-4b08-a504-1b10266cf72a
2) Нажмите Download.

13. Уточнение времени работы компьютера с момента последней загрузки.

Вариант 1.

Если Вам необходимо узнать сколько времени работает Ваш компьютер с момента последней загрузки, то Вы можете создать скрипт-файл и запускать его при необходимости.

1) Скопируйте указанный выше код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .vbs в любой папке (Например, на диске C:)
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "crp.vbs")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Чтобы узнать сколько времени работает компьютер, просто запустите созданный Вами скрипт, как обычную программу.

Вариант 2.

Скачайте и установите специальный гаджет.

systemuptime_sevengadgets.ru.zip

14. Автоматическая очистка временных папок при выходе из Windows.

Чтобы не чистить вручную временные папки: C:\Users\Administrator\AppData\Local\Temp или C:\Users\YourNickname\AppData\Local\Temp и C:\Windows\Temp, Вы можете автоматизировать данный процесс при выходе из системы.

1) Создайте командный файл сценария:

Инструкция:

1. Скопируйте код в любой текстовый редактор (например, Блокнот).
2. Нажмите CTRL+S и сохраните файл с любым именем и расширением .cmd
3. Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "tempdirclean.cmd")
4. Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

2) Скопируйте его для удобства в корневую папку диска С:
3) Запустите редактор групповых политик: Пуск -> Выполнить -> gpedit.msc или Win+R -> gpedit.msc
4) Откройте ветвь Конфигурация пользователя > Конфигурация Windows > Сценарии (вход/выход из системы).
5) В правой части два раза кликните по параметру Выход из системы или нажмите правую кнопку мыши и выберите пункт Свойства.
6) Нажмите кнопку Добавить, укажите месторасположение созданного Вами командного файла c:\tempdirclean.cmd
7) Нажмите Ок, затем снова Ок
Теперь при выходе из системы, а также при завершении работы временные папки очистятся автоматически.

Внимание: Если по указанной выше схеме Вы добавите командный файл сценария в свойства параметра Выход из системы, находящийся в ветке Конфигурация компьютера > Конфигурация Windows > Сценарии (запуск/завершение), то пользовательская временная папка очищена не будет, а очистится только временная папка самой Windows.

Готовый CMD-файл Вы можете скачать по ссылке: tempdirclean.zip

15. Где в Windows 7 хранятся значки (иконки)?

Если Вы хотите использовать одну из иконок (значков) Windows 7, то большую их часть Вы можете найти в следующих файлах:

C:\Windows\System32\shell32.dll
C:\Windows\System32\imageres.dll

Для извлечения необходимой Вам иконки:

1) Откройте один из предложенных файлов, с помощью программы Restorator.
2) В панели Дерево ресурсов откройте папку Иконка
3) Выберите любую из понравившихся Вам иконок.
4) В панели Дерево ресурсов щелкните правой кнопкой мыши на данном ресурсе и выберите Извлечь... > Извлечь как "имя_ресурса.ico"
5) Выберите папку для извлечения и нажмите Сохранить

Вы также можете извлечь все иконки сразу, для этого:
6) В панели Дерево ресурсов щелкните правой кнопкой мыши на папке Иконка и выберите Извлечь... > Извлечь все как тип "Иконка"
7) Выберите папку для извлечения и нажмите OK

16. Извлечение загрузочного MS-DOS образа из файла diskcopy.dll и дальнейшая работа с ним.

Многие используя в Windows функцию Форматировать, замечали пункт Создание загрузочного диска MS-DOS. Он используется для создания загрузочного диска MS-DOS на определенных типах устройств, для других же типов устройств он заблокирован.
Выясняя откуда Windows берет образ MS-DOS для записи, я узнал что он содержится в файле diskcopy.dll. Но тут появился другой вопрос, а как его оттуда извлечь? Предлагаю Вам несколько способов его извлечения.

Способ 1 Использование редакторов ресурсов.

Открываете файл diskcopy.dll любым редактором ресурсов и извлекаете(сохраняете) ресурс 1 из папки BINFILE как diskcopy.img

Способ 2 Программа Disk Extract

1) Указываете в поле File(s) to search and extract byte sequence (wildcards *.* accepted) - файл для поиска и извлечения необходимого количества байтов: C:\Windows\System32\diskcopy.dll
2) Указываете в поле Byte sequence to find - с какого байта искать: EB3C90
3) Указываете в поле Bytes to copy - сколько байт скопировать: 1474560
4) Указываете в поле Save as - куда и под каким именем сохранить (например так): D:\Temp\diskcopy\diskcopy.img
5) Нажимаете на кнопку Play
6) В появившемся окне Confirm нажимаете Yes

Способ 3 Программа GETBTDSK со скриптом

Запускаете файл GETBTDSK.bat и получаете в итоге готовый файл diskcopy.img
Некоторые антивирусные программы могут воспринять попытку её обращения к системному файлу как разновидность вируса, поэтому для работы скрипта либо изолируйте файл GETBTDSK.EXE, или папку где он находится из поиска антивирусной программой, либо воспользуйтесь первым способом.

Хорошо, образ мы извлекли и у нас есть готовый файл diskcopy.img. Что же дальше, спросите Вы. А дальше, Вы можете:

1) Распаковать полученный файл с помощью программы архиватора 7zip и дальше работать с файлами по-своему усмотрению.

2) Записать загрузочный MS-DOS образ diskcopy.img на USB флеш-накопитель (флешку).

1. Открываете файл diskcopy.img в программе UltraISO
2. Выбираете Самозагрузка -> Записать образ жесткого диска...
3. Метод записи оставляете USB-HDD+
4. Нажимаете Записать

Чтобы не искать в интернете эти программы, Вы можете скачать архив с ними: msdosboot.zip

17. Термины и сокращения используемые Microsoft для маркировки своих продуктов.

Скачивая какой-либо продукт Microsoft в интернете, помимо его названия Вы можете увидеть дополнительные обозначения в наименовании. Если Вам интересно, что означает "CTP", "Escrow", "LDR", "RC", "RTM" и тому подобное - предлагаю Вам, расшифровку особо часто встречающихся из них.

BBT - Basic Block Tools или Binary Profile Feedback Optimization framework
BBT - пакет инструментов оптимизации, помогающий уменьшить требования к рабочему набору Win32 приложения. Для этого применяется дополнительный статический анализ и эвристика кода. Также в результате мониторинга потока выполнения программы происходит интеграция профиля данных. Для дополнительной компрессии страниц памяти, BBT реорганизовывает статистические данные и секции ресурсов.
BBT - специальный анализатор, оптимизирующий величину кода, путем игнорирования не используемой части, и архивации оставшейся.
Другое значение BBT - это “Black Box Testing”, тестирование "чёрного ящика" или что-то в этом духе.

BVT - Build Verification Test
Небольшой набор тестов, проверяющих уровень качества сборки, на этапе её создания. Например, BVT для Блокнота может выглядеть как: "Запустить, напечатать текст, сохранить, выйти". Если сборка не проходит данный тест, то во избежание дальнейших ошибок при тестировании, она отправляется на доработку. Порядок действий BVT редко меняется, а результаты - тщательно контролируются.

CPP - Customer Preview Program
Программа предварительного ознакомления.

CTP - Community Technology Preview
Предварительный технологический релиз для сообщества, впервые использован для сборки Vista build 5219, так называемый январский CTP.

DNSRV - .NET (DotNet) Server
Раннее кодовое имя Windows Server 2003.

EBS - Essential Business Server
Серверное решение от Microsoft, имеет в своей основе ядро Windows Small Business Server 2008, ориентировано на рынок среднего бизнеса.

EDW - External Developer Workstation
Этот термин, использовался во времена разработки Windows Vista, для обозначения сборок выпущенных между RC и RTM сборками.

Escrow
Сборки, не имеющие серьёзных ошибок. Они, как правило, становятся в итоге Релиз-кандидатами или RTM (после того, как сборка подписана к выпуску).

Exit Criteria
Набор тестов, проверяющих наиболее важные аспекты корректной работы основных функций приложения. Как выглядит тот или иной тест, определяется командой-разработчиком функции, результаты прохождения теста должны точно совпадать с ожидаемыми. Полное прохождение таких тестов ознаменует переход к следующему этапу разработки.

FBL - Feature build lab
Группа разработки какого-либо функционала.

FVT - Feature Verification Tests
Тоже самое, что и BVT, только для конкретной функции.

GA - General Availability
Означает, что програмное обеспечение доступно на основном рынке через Интернет или на каком-либо физическом носителе.

GDR - General Distribution Release
Используется для обновлений и хотфиксов, содержащих только заплатки критических ошибок и исправления, влияющие на стабильность.

HSBS - Home and Small Business Server

IDS - Internal Developer Server

IDW - Internal Developer Workstation

IDX - Internal Developer Client/Server

LCTP - Limited Community Technology Preview
Ограниченный предварительный технологический релиз.

LDR - Limited Distribution Release
Используется для обновлений и хотфиксов, содержащих “прочие” исправления, как правило, для ошибок, возникающих у весьма специфической группы пользователей.

MMS - Mid-Market Server
Раннее название Essential Business Server.

QFE - Quick Fix Engineering
Аналогично LDR.

QHSV - Q Home Server
Раннее название Windows Home Server.

RC - Release Candidate
Качество сборки на данной стадии разработки наиболее близко к стабильному, критические ошибки уже исправлены, однако, в ходе текущего тестирования могут быть найдены новые ошибки.

RDP - Rapid Deployment Program

RTM - Release To Manufacturing
Стабильная сборка, прошедшая все стадии тестирования, в которой исправлены все найденные ошибки, и готовая к применению.

RTW - Release To Web
Это RTM, предназначенный для распространения через Интернет.

SBS - Small Business Server

Self host
Сброки, прошедшие тесты Exit Criteria tests, готовые к более глубокому тестированию.

Self test
Сборки, прошедшие BVT и FVT тесты.

Self toast
Сборки, не прошедшие BVT.
Sign-off
Подписание, означает, что функция/продукт готова к продаже.

TAP - Technology Adoption Program
Программа технологического утверждения, в ходе которого собираются отзывы тестеров, в качестве которых могут выступать и заказчики компании.

TP - Technical Preview

VBL - Virtual Build Lab
Термин обозначает группу разработчиков объединенных в виртуальную лабораторию.

WHS - Windows Home Server

WSSG - Windows Server Solutions Group

WSUS - Windows Server Update Services

18. Удаление установленного обновления.
Если Вы установили обновление в Windows, для добавления дополнительной функции, а оно Вам не понравилось, то Вы можете спокойно его удалить.
Для удаления любого обновления сделайте следующее:

1) Откройте Панель управления\Программы
2) Нажмите на ссылку Просмотр установленных обновлений
3) Нажмите правой кнопкой на любом обновлении, которое желаете удалить и щелкните на появившемся слове Удалить.
4) В случае необходимости, перезагрузите компьютер.

19. Создание значков управления состоянием компьютера.

Для быстрого изменения состояния системы Вы можете создать на рабочем столе ярлыки позволяющие изменить его одним нажатием мыши.

Для создания ярлыков выполните следующие действия:
1) Нажмите правую клавишу мыши на рабочем столе, выберите пункт меню Создать -> Ярлык
2) В поле Укажите расположение объекта введите необходимую команду для создания ярлыка и нажмите OK.

Блокировка компьютера

Выход из системы

Завершение работы

Перезагрузка

Сон

20. Копирование текста из окон сообщений и всплывающих оповещений в буфер обмена.

Текст из окна сообщения Windows выделить для копирования невозможно, так как он заблокирован. Но Вы можете скопировать данный текст в буфер обмена.
Для того чтобы это нажмите комбинацию клавиш Ctrl+C, а затем вставьте текст из буфера в любой текстовый редактор используя комбинацию клавиш Ctrl+V. Окно, текст которого нужно скопировать, должно быть активным.
Например, попробуйте закрыть окно оснастки Службы при открытом окне свойств отдельной службы, и Вы увидите одно из таких сообщений Windows.

21. Удаление данных без возможности восстановления.

При удалении файла или папки, не происходит полного физического удаления информации, очищается лишь только «оглавление» файловой системы. С помощью утилиты cipher возможно частичное решение этой проблемы, так как существует возможность выполнить очистку свободного места на диске затиранием её.
Место, занимаемое содержимым папки, будет перезаписано нулями, потом единицами, а после этого - набором случайных символов в каждом секторе.

Для полного удаления данных:

1) Удалите необходимые файлы или папки из Вашего каталога, которые должны быть затерты.
2) Запустите командную строку с правами администратора
2.1) Нажмите кнопку Пуск
2.2) В строке поиска введите cmd
2.3) Щелкните на найденной программе правой кнопкой мыши и выберите Запуск от имени администратора
3) В командной строке введите:

каталог - путь к любой папке на разделе подлежащим очистке. (Например: cipher /w:c:\temp) Если Вы удалили папку или файл из корня диска, то Вы можете указать в качестве пути только букву диска. (Например: cipher /w:c:\)

22. Выполнение дефрагментации дисков в Windows 7 используя командную строку.

В Windows существует программа Дефрагментация диска. Данная программа производит упорядочение фрагментированной информации для более эффективной работы дисков и дисководов. Программа дефрагментации диска работает по заданному расписанию, но можно запускать анализ и дефрагментацию дисков вручную. В программе Вы можете увидеть время прошлого запуска, уровень фрагментированности дисков и запланированное время следующего запуска.
Если Вы не отключали планировщик заданий, значение уровня фрагментированности дисков будет равно 0%, а при нажатии кнопки Анализировать диск система покажет уровень фрагментированности не более 10%. При желании Вы можете запустить дефрагментацию вручную нажав кнопку Дефрагментация диска или настроить запуск по расписанию, в удобное для Вас время.

Графический интерфейс программы Вы можете запустить: Пуск -> Все программы -> Стандартные -> Служебные. Однако он весьма ограничен в возможностях, и их хватит начинающему или малоопытному пользователю, если же Вы продвинутый или опытный пользователь, то Вам будет интересен командный режим данной программы.

1) Нажмите кнопку Пуск и в строке поиска наберите cmd
2) Нажмите на найденной программе правой кнопкой мыши и выберите пункт Запуск от имени администратора.
3) Вы можете запустить утилиту defrag.exe используя следующие параметры командной строки:

Параметр | Описание
/A | Анализирует указанный том. Логично выполнить анализ перед ручной дефрагментацией. В результатах будет сказано, каким разделам она нужна.
/C | Выполняет операцию на всех томах. Этот параметр избавляет от необходимости перечислять все буквы разделов при анализе или дефрагментации.
/E | Выполняет операцию на всех томах, кроме указанных. Еще один параметр, экономящий время.
/H | Выполняет операцию с обычным приоритетом (по умолчанию используется низкий). Ускоряет процесс дефрагментации, но может замедлить работу других приложений, обращающихся к диску в это время.
/M | Выполняет операцию на всех томах одновременно в фоновом режиме. Стандартное поведение дефрагментатора – последовательная работа над томами.
/T | Отслеживает текущую операцию на указанном томе.
/U | Выводит прогресс текущей операции на указанном томе в процентном отношении.
/V | Выводит подробный отчет о томах, их фрагментированности, файлах и папках, а также о свободном пространстве и MFT.
/X | Объединяет свободное пространство на указанных томах.
/R | Выполняет частичную дефрагментацию (поведение по умолчанию), пытаясь объединять только фрагменты размером менее 64 Мб.
/W | Выполняет полную дефрагментацию, пытаясь объединять любые фрагменты вне зависимости от их размера.
/F | Выполняет принудительную дефрагментацию, даже если на диске недостаточно свободного пространства.

Примеры команд

Команда | Описание
defrag /A /C /U /V | Анализирует фрагментированность всех разделов, отображая ход операции, и выводит подробный отчет.
defrag C: /W /V | Выполняет полную дефрагментацию раздела C, а затем выводит подробный отчет.
defrag C: /E /H /F | Выполняет дефрагментацию всех разделов кроме C с обычным приоритетом вне зависимости от количества свободного пространства на них.

23. Уменьшение размера файла изображения без потери качества.

Если у Вас хранится большое количество файлов изображений на компьютере или Вы добавляете изображения в текстовые документы или Вы размещаете их в интернете, то данный совет поможет Вам уменьшить занимаемое ими место без потери качества.

1) Скачайте и разархивируйте в любую удобную Вам папку архив PictureBeaver.zip
2) Выделите необходимый Вам файл-изображение, группу файлов или папку с изображениями
3) Перетащите выделенное на файл optimize.wsf.
4) Откроется окно командной строки (процесс действий в окне отображаться не будет), по завершении процесса оптимизации оно само закроется .
5) Результаты появятся в той же папке, где и Ваши исходные файлы изображений. Оптимизированные файлы изображений будут в папке (папках) Optimized, отчёт о сэкономленном объеме в файле Optimization Report.html

Данный скрипт для оптимизации использует программы:

gifsicle - для оптимизации GIF изображений
jpegtran - для оптимизации JPG изображений
optipng - для оптимизации PNG изображений

24. Где можно скачать последнюю версию DirectX?

Официальный сайт для скачивания последних версий DirectX находится по ссылке ниже:

Официальный сайт DirectX
Полная версия: DirectX End-User Runtimes
Web версия(обновляется раньше, чем полная): DirectX End-User Runtime Web Installer

25. Запуск программы с определенной датой без изменения системных настроек.

Если Вы являетесь разработчиком программного обеспечения и по истечении тестового периода работы Ваша программа должна прекратить работу по причине выхода финальной версии или же Вам просто интересно как будет работать программа при изменении даты, то Вам нет необходимости изменять настройки системы.

Для запуска программы с определенной датой в прошлом или будущем Вы можете скачать программу RunAsDate

Вы можете запустить необходимую Вам программу непосредственно из программы RunAsDate или же создать ярлык для запуска с Рабочего Стола.

26. Изменение атрибутов и времени/даты создания, изменения и открытия (доступа) файла.

Если Вам необходимо изменить дату создания, дату изменения и дату открытия (доступа) файла, то для этого Вы можете воспользоваться программой BulkFileChanger, которую Вы можете скачать здесь.

Чтобы изменить атрибуты и/или любую из указанных времени/дат, сделайте следующее:

1) Добавьте Ваш файл в программу.
1.1) Воспользуйтесь методом тащи-и-бросай (drag-and-drop), просто перекиньте Ваш файл на окно программы.
или
1.2) В главном меню выберите Файл -> Добавить файлы (клавиша F2), выберите файл(ы) для добавления и нажмите Открыть.

2) Выделите файл(ы) и в главном меню выберите Действия -> Изменить время/атрибуты (клавиша F6)
3) Установите необходимые атрибуты и/или время/дату файла и нажмите кнопку Выполнить.

Примечание. Если Вы не живете в Великобритании, Гренландии, Ирландии, Исландии, Португалии или Канарских островах, то не забудьте снять флажок Время указано по Гринвичу.

27. Список всех обновлений вошедших в SP1 с краткими объяснениями и ссылками.

Если Вам необходимо узнать какие обновления вошли в Сервисный пакет обновлений 1, то Вы можете скачать с сайта Microsoft документ в котором описаны все обновления вошедшие в него, и также даны краткие пояснения и ссылки на страницы самих обновлений.

Скачать: Hotfixes and Security Updates included in Windows 7 and Windows Server 2008 R2 Service Pack 1.xls

Файл при запуске откроется на странице Legal Disclaimer, для прочтения кратких пояснений к каждому вошедшему в SP1 обновлению и уточнения принадлежащих им ссылок перейдите в xls-файле на страницу Update List.

28. Список горячих клавиш, используемых в окне команд Windows 7.

В окне командной строки также как и в других окнах Windows существует набор используемых горячих клавиш, которые Вы можете использовать.

Стрелка вверх - переход к раннее введенной команде.
Последовательно нажимая стрелку вверх, в командной строке будет появляться предыдущая введенная команда.

Стрелка вниз - переход к позднее введенной команде.
Перейдя стрелкой вверх к самой первой команде, можно вернуться к последней нажимая стрелку вниз.

ESC - очистка строки ввода.
При нажатии стрелок для перемещения, переход по истории команд продолжится с того же места, где Вы остановились.

Tab - автозавершение названия файла/папки.
Пример: Если находясь в корне диска C:, Вы введете команду cd prog и нажмете клавишу Tab, то у Вас автоматически отобразится cd "Program Files".
При наличии объектов с одинаково начинающимися названиями нажимайте Tab, до появления необходимого значения. Подстановка имен происходит в алфавитном порядке.
Если в 64-битной системе, учитывая предыдущий пример, Вы нажмете клавишу Tab снова, то у Вас автоматически отобразится cd "Program Files (x86)".

F1 - побуквенный ввод выбранной команды из истории команд.

F2 - скопировать в строку ввода часть командной строки, выбранной в истории, от начала строки до указанного Вами символа.
Копируется именно выбранная команда стрелочками, а не тот текст, что введен в данный момент.

Пример работы:
Выберите в истории, необходимую команду. Для примера: cd "Program Files"
Нажмите ESC. Строка очистится.
Нажмите F2. В появившемся диалоге нажмите m. В строке отобразится: cd "Progra

F3 - вставка текущей команды из истории.

F4 - удаление до указанного символа в текущем набранном тексте

F5 - вставка предыдущей команды из истории.

F7 - отображение нумерованного списка историю команд.

F8 - аналог клавиши "Стрелка вверх".

F9 - ввод команды из истории команд по ее номеру. Под номером понимается цифра, присвоенная команде в списке, отображаемом по F7.

Alt+F7 - очистка истории команд.

Ctrl+C - прекращение выполнения текущего командного файла или консольного приложения.


1. Сравнение версий Windows 7.

Функция / Редакция | Начальная | Домашняя базовая | Домашняя расширенная | Профессиональная | Корпоративная | Максимальная
 | Продажа только по OEM-лицензиям | Продажа в розницу и по OEM-лицензиям (только на развивающихся рынках, включая российский) | Продажа в розницу и по OEM-лицензиям | Продажа в розницу, по OEM и корпоративным лицензиям | Продажа только под корпоративными лицензиями | Продажа в розницу и по OEM-лицензиям
Окончание поддержки | 13.01.2015 | 13.01.2015 | 13.01.2015 | 13.01.2020 | 13.01.2020 | 13.01.2015
Наличие 64-битной версии | Нет | Да | Да | Да | Да | Да
Максимальный размер оперативной памяти (для 64-битных версий) | 2 Гб (для 32-битной версии) | 8 Гб | 16 Гб | 128 Гб | 128 Гб | 128 Гб
Центр восстановления Windows | Нет поддержки домена | Нет поддержки домена | Нет поддержки домена | Да | Да | Да
Функция «Домашняя группа» (создание и присоединение к группе) | Только присоединение | Только присоединение | Да | Да | Да | Да
Интерфейс Windows Aero | Нет | Только базовая тема оформления | Да | Да | Да | Да
Поддержка нескольких мониторов | Нет | Да | Да | Да | Да | Да
Быстрое переключение между пользователями | Нет | Да | Да | Да | Да | Да
Возможность смены фонового рисунка рабочего стола | Нет | Да | Да | Да | Да | Да
Диспетчер рабочего стола | Нет | Да | Да | Да | Да | Да
Центр мобильности Windows | Нет | Да | Да | Да | Да | Да
Multitouch и улучшенное распознавание рукописного ввода | Нет | Нет | Да | Да | Да | Да
Windows Media Center | Нет | Нет | Да | Да | Да | Да
Дополнительные игры | Нет | Нет | Да | Отключены по умолчанию | Отключены по умолчанию | Да
Эмулятор Windows XP(Windows XP Mode) | Нет | Нет | Нет | Да | Да | Да
EFS (система шифрования данных) | Нет | Нет | Нет | Да | Да | Да
Печать с учетом информации о местоположении | Нет | Нет | Нет | Да | Да | Да
Возможность выступать в качестве хост-компьютера Удаленного рабочего стола | Нет | Нет | Нет | Да | Да | Да
Подключение к домену | Нет | Нет | Нет | Да | Да | Да
Возможность даунгрейда до Vista или XP | Нет | Нет | Нет | Да | Да | Да
Поддержка нескольких процессоров | Нет | Нет | Нет | Да | Да | Да
AppLocker | Нет | Нет | Нет | Нет | Да | Да
BitLocker и BitLocker To Go | Нет | Нет | Нет | Нет | Да | Да
Branch Cache | Нет | Нет | Нет | Нет | Да | Да
DirectAccess | Нет | Нет | Нет | Нет | Да | Да
Подсистема для запуска Unix-приложений | Нет | Нет | Нет | Нет | Да | Да
Мультиязычная пользовательская среда | Нет | Нет | Нет | Нет | Да | Да
Загрузка с VHD (файла-образа Microsoft Virtual PC) | Нет | Нет | Нет | Нет | Да | Да
Запуск оснастки lusrmgr.msc (Local Users and Groups) | Нет | Нет | Нет | Да | Да | Да
Запуск оснастки gpedit.msc (Local Group Policy Editor) | Нет | Нет | Нет | Да | Да | Да
Запуск оснастки secpol.msc (Local Security Policy) | Нет | Нет | Нет | Да | Да | Да

Windows Aero — анимация окон при открытии, закрытии, сворачивании, восстановления окна, делающая работу с операционной системой более понятной. Прозрачные элементы окон с размывкой заднего плана позволяют пользователю сконцентрироваться только на содержимом активного окна. Компоненты Windows Aero:

Aero Glass — прозрачные (с размывкой заднего плана) заголовки и панели в окнах.
Windows Flip — новый вид меню Alt + Tab, в котором показываются эскизы открытых окон и их значки.
Windows Flip 3D — замена Alt + Tab, вызываемая сочетанием Win + Tab, теперь все окна выстраиваются в ряд в 3D. При помощи стрелок клавиатуры или колесика мышки можно прокручивать окна.
Aero Shake — позволяет свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти».
Aero Peek — позволяет отображать уменьшенные копии окон при наведении мыши на значок панели задач, переключаться между окнами приложения простым кликом по значку, перетаскивать и фиксировать на панели задач различные окна и приложения, просматривать рабочий стол одним наведением в специальную область экрана и многое другое.
Aero Snap — позволяет движением мыши разворачивать окно на полэкрана, весь экран или только по вертикальной оси.

Диспетчер рабочего стола (англ. Desktop Window Manager, DWM), ранее Desktop Compositing Engine, DCE — система графического интерфейса рабочего стола в Windows Vista и Windows 7, который используется в графическом интерфейсе Windows Aero.

Центр мобильности Windows — объединяет настройки мобильного ПК в одном месте для обеспечения быстрого доступа к ним. Из одного и того же местоположения можно выполнять различные операции, например регулировать громкость мобильного ПК, проверять состояние беспроводного сетевого подключения или настраивать яркость дисплея.

Мультитач (англ. multitouch или multi-touch) — технология, по которой сенсорный экран или тачпад отслеживает одновременно несколько точек нажатия. Например, сближая пальцы рук, можно уменьшить картинку на дисплее, а раздвигая — увеличить. Кроме того, мультитач-экраны позволяют работать с устройством одновременно нескольким пользователям.

Windows Media Center (кодовое имя Freestyle) является приложением для проигрывания мультимедиаконтента (музыки, изображений и потокового телевидения) на домашнем медиацентре.

Encrypting File System (EFS) — система шифрования данных, реализующая шифрование на уровне файлов. Данная система предоставляет возможность «прозрачного шифрования» данных, хранящихся на разделах с файловой системой NTFS для защиты потенциально конфиденциальных данных от несанкционированного доступа при физическом доступе к компьютеру и дискам.

Домен Windows — группа компьютеров одной сети, имеющих единый центр (который называется контроллером домена), использующий единую базу пользователей (то есть учётные записи находятся не на каждом в отдельности компьютере, а на контроллере домена, т.н. сетевой вход в систему), единую групповую и локальную политики, единые параметры безопасности (применимо к томам с файловой системой NTFS), ограничение времени работы учётной записи и прочие параметры, значительно упрощающие работу системного администратора организации, если в ней эксплуатируется большое число компьютеров.

AppLocker — расширенная версия политик ограниченного использования программ. Позволяет разрешать или запрещать запуск программ при определенных условиях. Например, "Разрешить запуск Adobe Acrobat версии выше 7.0".

BitLocker и BitLocker To Go — позволяет защитить все данные, от документов до паролей, путем шифрования всего диска, на котором хранятся системные файлы Windows и данные пользователей. BitLocker используется для встроенных дисков, BitLocker To Go - для съемных запоминающих устройств, таких как внешние жесткие диски и USB-устройства флэш-памяти.

BranchCache — это технология кэширования на ресурсах локальной сети данных, расположенных на удаленных серверах. Если пользователю в локальной сети потребуется файл, который уже был загружен кем-то из пользователей его сети, — он сможет получить его из локального кэш-хранилища, а не использовать канал с ограниченной пропускной способностью.

DirectAccess — обеспечивает доступ пользователей к корпоративной сети при наличии выхода в Интернет. В отличие от большинства традиционных VPN соединений, которые должны быть запущены и прерваны явно действиями пользователя, подключения DirectAccess создаются автоматически компьютером, на котором работает пользователь.

Подсистема для UNIX-приложений — представляет собой многопользовательскую среду UNIX, которая предоставляет инструментарий и библиотеки API переноса приложений для работы на компьютерах под управлением операционной системы Windows.

Загрузка с VHD-файла — использование для загрузки операционной системы Windows - VHD-файла, содержащего в себе виртуальную операционную систему имеющую полную структуру и содержание сходные с жестким диском.

Мультиязычная пользовательская среда (MUI) — Выбор нужного языка интерфейса и возможность переключения между 35 доступными языками.

Назад на страницу раздела Разное.


2. Открытие файлов справки с расширением .hlp.

Начиная с Windows Vista, компания Майкрософт отменила поддержку открытия данного типа файлов, с использованием системной программы WinHlp32.exe. Для открытия данного типа файлов установите обновление Windows6.1-KB917607-x86.msu или Windows6.1-KB917607-x64.msu, в зависимости от разрядности.
Официальная ссылка: здесь

Назад на страницу раздела Разное.


3. Список программ Windows, запускаемых в диалоговом окне Выполнить.

Диалоговое окно Выполнить используется в Windows для открытия программы, папки или документа. Оно позволяет создать задание для запуска с правами администратора. Самые известные команды выполняемые в окне Выполнить это cmd (Командная строка) и regedit (Редактор реестра). Зная точное названия команды Вы можете запустить любое системное приложения или оснастку Windows.
Диалоговое меню Выполнить запускается либо Пуск -> Выполнить, либо нажатием клавиатуре Win+R.
Для выполнения команды введите её название и нажмите Enter.

Русское название элемента | Английское название элемента | Команда
Ftp-протокол (командная строка) | Ftp-protocol (command prompt) | ftp
Iexpress Wizard (не переведена) | Iexpress Wizard | iexpress
Internet Explorer | Internet Explorer | iexplore
Paint | Paint | mspaint
Wordpad | Wordpad | write
Администратор источников данных ODBC | ODBC Data Source Administrator | odbcad32
Администрирование | Administrative Tools | control admintools
Архивация и восстановление | Backup and Restore | sdclt
Блокнот | Notepad | notepad
Брандмауэр Windows | Windows Firewall | firewall.cpl
Включение и отключение компонентов Windows | Turn Windows features on or off | OptionalFeatures.exe
Восстановление системы | System Restore | rstrui
Выйти из системы | Log Out Of Windows | logoff
Дата и Время | Date and Time | timedate.cpl
Дефрагментация диска | Disk Defragmenter | dfrgui
Диспетчер авторизации | Authorization Manager | azman.msc
Диспетчер задач Windows | Windows Task Manager | taskmgr
Диспетчер проверки драйверов | Driver Verifier Manager | verifier
Диспетчер устройств | Device Manager | devmgmt.msc
Диспетчер устройств | Device Manager | hdwwiz.cpl
Дополнительные часы | Additional Clocks | control timedate.cpl,,1
Завершение работы Windows | Shuts Down Windows | shutdown /s
Записки | Sticky Note | StikyNot
Защита БД учетных записей Windows | Securing the Windows Account Database | syskey
Звук | Sound | mmsys.cpl
Звуки (звуковая схема) | Sounds (sound theme) | control mmsys.cpl,,2
Звукозапись | Sound Recorder | soundrecorder
Игровые устройства | Game Controllers | joy.cpl
Инициализация оборудования безопасности для TPM | Initialize the TMP security hardware | TpmInit
Калибровка цветов экрана | Display Color Calibration | dccw
Калькулятор | Calculator | calc
Командная строка | Command Prompt | cmd
Компоненты Windows | Windows Features | OptionalFeatures
Консоль управления(MMC) | Microsoft Management Console | mmc
Конфигурация системы | System Configuration | msconfig
Локальная политика безопасности | Local Security Policy | secpol.msc
Локальные пользователи и группы | Local Users and Groups | lusrmgr.msc
Мастер загрузки изображений Windows | Windows Picture Acquisition Wizard | wiaacmgr
Мастер создания общих ресурсов | Create A Shared Folder Wizard | shrpubw
Мастер установки драйверов устройств | Driver Package Installer | dpinst
Мастер установки оборудования | Add Hardware Wizard | hdwwiz
Микшер громкости | Sound Volume | sndvol
Монитор ресурсов | Resource Monitor | resmon
Настройка доступа программ и умолчаний | Set Program Access and Computer Defaults | control appwiz.cpl,,3
Настройка Контроля Учетных Записей | User Account Control Settings | UserAccountControlSettings
Ножницы | Snipping Tool | snippingtool
Общие папки | Shared Folders | fsmgmt.msc
Очистка диска | Disk Cleanup Utility | cleanmgr
Панель управления | Control Panel | control
Папка "Fonts" | Fonts Folder | fonts
Папка "Загрузки" | "Downloads" Folder | Downloads
Параметры папок | Folder Options | control folders
Перезагрузка | Restart Windows | shutdown /r
Перенос принтеров | Printer Migration | PrintBrmUi
Перо и сенсорные устройства | Pen and Touch | TabletPC.cpl
Персонализация | Personalization | control desktop
Планировщик заданий | Task Sheduler | control schedtasks
Подключение к удаленному рабочему столу | Remote Desktop Connection | mstsc
Получение программ | Get Programs | control appwiz.cpl,,1
Проверка диска | Check Disk Utility | chkdsk
Проверка и восстановление системных файлов | System File Checker (Scan and Repair) | sfc /scannow
Проверка подписи файла | File Signature Verification | sigverif
Проводник | Windows Explorer | explorer
Проводник: C:\ | Windows Explorer: C:\ | \
Проводник: С:\Users\Ваше_имя | Windows Explorer: С:\Users\Your_name | .
Проводник: С:\Users\ | Windows Explorer: С:\Users\ | ..
Программа DiskPart | Disk Partition Manager | diskpart
Программы и компоненты | Programms and Features | appwiz.cpl
Просмотр событий | Event Viewer | eventvwr.msc
Разрешение экрана | Screen Resolution | desk.cpl
Редактор личных знаков | Private Character Editor | eudcedit
Редактор локальной групповой политики | Local Group Policy Editor | gpedit.msc
Редактор реестра | Registry Editor | regedit
Редактор реестра | Registry Editor | regedt32
Редактор титульных страниц факсов | Fax Cover Sheet Editor | fxscover
Результирующая политика | Resultant Set of Policy | rsop.msc
Сведения о системе | System Information | msinfo32
Свойства системы | System Properties | sysdm.cpl
Свойства системы: Дополнительно | System Properties: Advanced | SystemPropertiesAdvanced
Свойства системы: Защита системы | System Properties: System Protection | SystemPropertiesProtection
Свойства системы: Оборудование | System Properties: Hardware | SystemPropertiesHardware
Свойства системы: Удаленный доступ | System Properties: Remote | SystemPropertiesRemote
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | iscsicpl
Свойства: Интернет | Internet Properties | inetcpl.cpl
Свойства: Клавиатура | Keyboard Properties | control keyboard
Свойства: Мышь | Mouse Properties | control mouse
Свойства: Мышь | Mouse Properties | main.cpl
Свойства: Мышь: Параметры указателя | Mouse Properties: Pointer Options | control main.cpl,,2
Свойства: Мышь: Указатели (схема) | Mouse Properties: Pointers | control main.cpl,,1
Сертификаты | Sertificates | certmgr.msc
Сетевые подключения | Network Connections | control netconnections
Сетевые подключения | Network Connections | ncpa.cpl
Системный монитор | Performance Monitor | perfmon
Служба индексирования | Indexing Service | ciadv.msc
Службы | Services | services.msc
Службы компонентов | Component Services | dcomcnfg
Службы компонентов | Component Services | comexp.msc
Совместимость программы | Program Compatibility | msdt.exe -id PCWDiagnostic
Создать диск восстановления системы | Create a system repair disk | recdisc
Соседние пользователи | People Near Me | collab.cpl
Сохранение имен пользователей и паролей | Stored User Names and Passwords | credwiz
Средство диагностики DirectX | Direct X Troubleshooter | dxdiag
Средство диагностики службы технической поддержки | Microsoft Support Diagnostic Tool | msdt
Средство калибровки дигитайзера | Ditilizer Calibration Tool | tabcal
Средство настройки текста ClearType | ClearType Text Tuner | cttune
Средство просмотра XPS | XPS Viewer | xpsrchvw
Стредство записи действий по воспроизведению неполадок | Problem Steps Recorder | psr
Таблица символов | Character Map | charmap
Телефон и модем | Phone and Modem | telephon.cpl
Удаленный помощник Windows | Windows Remote Assistance | msra
Управление дисками | Disk Management | diskmgmt.msc
Управление компьютером | Computer Management | compmgmt.msc
Управление печатью | Print Management | printmanagement.msc
Управление цветом | Color Management | colorcpl
Установка или удаление языков интерфейса | Install or uninstall display languages | lpksetup
Устройства и принтеры | Devices and Printers | control printers
Учетные записи пользователей | User Accounts | Netplwiz
Цвет и внешний вид окна | Window Color and Appearance | control color
Центр мобильности Windows | Windows Mobility Center | mblctr
Центр поддержки | Action Center | wscui.cpl
Центр синхронизации | Sync Center | mobsync
Центр специальных возможностей | Ease of Access Center | utilman
Шифрующая файловая система (EFS) | Encryption File System | rekeywiz
Шрифты (добавление или удаление) | Fonts | control fonts
Экран (размер текста) | Display (size of text) | dpiscaling
Экранная клавиатура | On-Screen Keyboard | osk
Экранная лупа | Magnifier | magnify
Экранный диктор | Microsoft Narrator | narrator
Электропитание | Power Options | powercfg.cpl
Электропитание: Дополнительные параметры | Power Options: Advanced Settings | control powercfg.cpl,,1
Элемент управления WMI | Windows Management Infrastructure | wmimgmt.msc
Язык и региональные стандарты | Region and Language | intl.cpl
Язык и региональные стандарты: Дополнительно | Region and Language: Administrative | control intl.cpl,,3
Язык и региональные стандарты: Языки и клавиатуры | Region and Language: Keyboards and Languages | control intl.cpl,,2

Если какой-либо из элементов списка не запускается, то скорее всего это означает что он неустановлен. Многие из компонентов Windows можно установить в Пуск -> Панель Управления -> Программы и Компоненты -> Включение и отключение компонентов Windows

Назад на страницу раздела Разное.


4. Список клавиатурных сокращений.

Во многих статьях Вы можете увидеть текст наподобие: Win+R. Данное слово Win обозначает клавишу с логотипом Windows. Данная клавиша обычно находится на левой стороне клавиатуры, в нижней строке. Основные:

Alt+Tab - Переключение между окнами
Win+Tab - Переключение между окнами в режиме Flip3D
Win+Up - Развернуть окно
Win+Down - Восстановить / Минимизировать окно
Win+Left - Прикрепить окно к левому краю экрана
Win+Right - Прикрепить окно к правому краю экрана
Win+Shift+Left - Переключиться на левый монитор
Win+Shift+Right - Переключиться на правый монитор
Win+Home - Минимизировать / Восстановить все неактивные окна
Win+Break(или Pause) - Запустить элемент Система из Панели Управления (пункт Свойства при нажатии правой кнопкой мыши на Компьютер в меню Пуск)
Win+Space - Показать рабочий стол
Win+B - Переход в область уведомлений(трей)
Win+D - Свернуть окна или восстановить все окна
Win+E - Запустить Проводник(Explorer)
Win+F - Запустить встроенный диалог поиска Windows
Win+Ctrl+F - Запустить Поиск по компьютеру из домена
Win+F1 - Запустить встроенный диалог Windows: Справка и Поддержка
Win+G - Отобразить гаджеты поверх всех окон
Win+L - Блокировка рабочей станции(текущего сеанса пользователя)
Win+M - Минимизировать все окна
Win+P - Отобразить дополнительные опции дисплея (расширить рабочий стол на 2 монитор и т.п.)
Win+R - Запустить диалоговое окно Выполнить
Win+Т - Выбрать первый элемент в панели задач (Повторное нажатие переключает на следующий элемент, Win+Shift+T - прокручивает в обратном порядке)
Win+U - Запустить Центр специальных возможностей (Ease of Access Center)
Win+X - Запустить Mobility Center
Win+цифра- Запустить приложение с панели задач (Win+1 запускает первое приложения слева, Win+2, второе, и т.к.)
Win + "+" - Увеличить масштаб
Win + "-" - Уменьшить масштаб
Ctrl + колесо мыши (вверх\вниз) на рабочем столе - увеличить\уменьшить иконки рабочего стола.

В Проводнике (Explorer):
Alt+P - Показать / Скрыть Область предпросмотра

Панель задач:
Shift + щелчок на иконке - Открыть новое окно приложения
Ctrl + Shift + щелчок по иконке - Открыть новое окно приложения с привилегиями администратора
Shift + щелчок правой кнопкой на иконке - Показать меню приложения
Shift + щелчок правой кнопкой на группе иконок - Показать меню, восстановить все / свернуть все / Закрыть все
Ctrl + щелчок по группе иконок - Развернуть все окна группы

Назад на страницу раздела Разное.


5. Перезагрузка компьютера в безопасный режим без использования клавиатуры.

Для того, чтобы перезагрузиться в Безопасный режим достаточно во время загрузки нажать клавишу F8 и выбрать пункт Safe Mode. А чтобы вернуться обратно в Нормальный режим достаточно всего лишь перезагрузить компьютер (не нажимая F8) и система вернется в своё стандартное состояние.
Но на некоторых материнских платах клавиша F8 используется для выбора физического устройства, с которого должен начать загрузку компьютер.
В этом случае необходимо выбрать жесткий диск, на котором установлена операционная система. После нажатия клавиши Enter необходимо сразу же снова нажимать клавишу F8 до тех пор, пока на экране не появится меню выбора вариантов загрузки ОС Windows. Вы должны успеть сделать это довольно быстро, а иначе начнется обычная загрузка Windows.
Если же нет желания играть на скорость, есть более легкий вариант решения:

1) Откройте Конфигурация системы (Пуск -> Выполнить -> msconfig -> Ok или Win+R -> msconfig -> Ok)
2) Перейдите на вкладку Загрузка
3) Поставьте галочку напротив значения Безопасный режим в разделе Параметры загрузки
4) Нажмите Ok и перезагрузите компьютер.
5) Чтобы вернуться обратно в Нормальный режим: находясь в Безопасном режиме уберите данную галочку и перезагрузите компьютер.

Назад на страницу раздела Разное.


 6. Определение букв назначенных дискам в среде восстановления или среде предустановки.

6. Определение букв назначенных дискам в среде восстановления или среде предустановки.

Загрузившись в среду восстановления или в среду предустановки Windows, Вы можете столкнуться с необходимостью определения буквы диска. Например, чтобы запустить приложения с флэш-диска или проверить диск на наличие ошибок.

Виртуальному диску создаваемому в среде восстановления или среде предустановки всегда соответствует буква Х:, а для определения букв остальных дисков Вы можете выбрать одно из предложенных решений.

Вариант 1. По размеру и типу диска.

1) Перейдите в папку X:\Sources; для этого в командной строке введите указанную ниже команду и нажмите Enter:

2) Запустите Блокнот (Notepad); для этого в командной строке введите указанную ниже команду и нажмите Enter:

3) В главном меню блокнота выберите Файл -> Открыть (или нажмите сочетание клавиш Ctrl+O) 4) Щелкните на значок Компьютер в области переходов слева

Примечание: Для лучшего отображения содержимого папки Компьютер, дважды щелкните по заголовку окна, чтобы его развернуть.

Вариант 2. По содержимому папки.

Также Вы можете определить буквы дисков напрямую из командной строки.

1) Переходите с диска на диск вводя его букву и нажимая Enter. Например:

Если Вам необходимо перейти к предполагаемой папке на диске, то переключайтесь используя команду:

Например:

2) Для отображения содержимого диска(папки) вводите команду:

Назад на страницу раздела Разное.


7. Автоматическое переключение русской и английской раскладок клавиатуры.

Часто бывает, что напечатав какой-то текст, вы поднимаете глаза на монитор и вместо слова "Программа" видите слово "Ghjuhfvvf".
Для того чтобы сохранить ваше терпение и нервы, существуют две замечательные программы: Punto Switcher(если вы в основном работаете с русской или английской клавиатурой) и Key Switcher(если вы работаете с несколькими европейскими языками).

Данные программы предназначены для автоматического переключения между различными раскладками клавиатуры в операционных системах семейства Microsoft Windows.
Основное назначение данных программ — увеличение продуктивности и удобства при работе с компьютером. Работая в фоновом режиме, они проводят статистический анализ последовательностей вводимых символов слова, и, если сочетание букв оказывается нетипичным для языка, на котором вводятся символы, то переключают язык ввода, заменяя текст исправленным.
Каждая из программ является отдельным законченным продуктом и не требует запуска другой.

Назад на страницу раздела Разное.


8. Удаление Windows 7 без форматирования раздела и без потери данных.

Для удаления Windows 7 описанным здесь способом вам потребуются:

а) ERD Commander;
б) Установочный диск Windows 7;

Шаг I. Удаление загрузочной информации Windows 7.

1) Загрузитесь в ERD Commader и вставьте установочный диск Windows 7 в свой DVD-привод.
2) Запустите Command Prompt
3) В открывшемся окне введите команду

Где, E: - Буква вашего DVD-привода, а C: - Буква вашего жесткого диска, с которого удаляется Windows 7

Шаг II. Удаление файлов и папок Windows 7.

1) Запустите Micosoft Diagnostics and Recovery Toolset -> Explorer
2) Как в обычном Explorer, тем же способом удалите следующие папки:
  • PerfLogs
  • Users
  • Windows
  • Recycle.Bin
  • Documents and Settings
  • ProgramData
  • Recovery

Назад на страницу раздела Разное.


9. Создание образа и использование ERD Commander (необходим для получения полного доступа к файлам и папкам).

Скачиваете и устанавливаете сборщик образа ERD Commander для x86 или x64
Запускаете Пуск -> Все программы -> Microsoft Diagnostics and Recovery Toolset -> Мастер создания загрузочных носителей ERD Commander

По инструкции ниже создаете свой образ ERD Commander:

1) Монтируете образ дистрибутива Windows 7 в виртуальный дисковод
2) На вкладке Выбор образа загрузки указываете наш смонтированный виртуальный диск Windows 7

3) Щелкаете Ок, затем несколько раз кнопку Далее
4) На вкладке Выбор программных средств снова нажимаете Далее
5) В Мастер анализа сбоев выбираете Найти средства отладки для Windows в восстанавливаемой системе ...

6) На вкладке Загрузка определения автономного средства проверки системы Далее выбираете Нет, загрузить определения вручную позднее, затем Далее
7) На вкладке Дополнительные драйверы добавьте драйвера в образ, если необходимо, затем Далее
8) На вкладке Дополнительные файлы добавьте файлы в образ, если необходимо, затем Далее
9) На вкладке Создание образа загрузки укажите куда сохранить готовый образ ISO.
10) Оставляете галочку на пункте Записать готовый образ с помощью следующего устройства записи компакт-дисков, вставляете чистый диск в дисковод или убираете галочку с данного пункта, для дальнейшей записи на USB флеш-накопитель (флешку) и нажимаете Далее.

На USB флеш-накопитель (флешку) образ записывается через программу UltraISO так:
1) Открываете образ в UltraISO.
2) Выбираете Самозагрузка -> Записать образ жесткого диска...
3) Нажимаете Записать

11) Перезагружаемся в ERD Commander.
12) Would you like to initialize network connectivity in the background?
Если собираетесь восстанавливать настройки сети (Интернет или Локальной) выбираете Yes жмете Enter, если не собираетесь, то выбираете No и жмете Enter
13) Would you like to remap the drive letters to match the mappings from the target operating system?
Для сопоставления букв дисков целевой операционной системе выбираете Yes и жмете Enter, в противоположном случае выбираете No и жмете Enter
14) Select a keyboard input method
Выбираете нужную раскладку, нажимаете Next
15) В окне для выбора операционной системы:

Для работы с восстановительными программами Windows, выбирате пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. И выбираете вашу операционную систему.

Для работы с системными файлами и папками(удаление, переименование или их замена) не выбираете никакую систему(должно сняться выделение с какой-либо системы). Для этого выберите пункт: Restore your computer using a system image that you created earlier, а затем снова выберите пункт Use recovery tools that can help fix problems starting Windows. Select an operating system to repair. и выделение само снимется.
16) Нажимаете Next.

Назад на страницу раздела Разное.


10. Активация Windows 7 по телефону, используя лицензионный ключ.

1) В меню Пуск нажмите правой кнопкой мыши на Компьютер и выберите пункт Свойства.
2) Нажмите на ссылку Изменить ключ продукта
3) Введите лицензионный ключ: XXXXX-XXXXX-XXXXX-XXXXX-XXXXX .
4) Нажмите Активировать.
5) Немного подождите, а затем выберите Другие способы активации - Активация по телефону. Выберите свой регион.
6) Позвоните по бесплатному номеру (можно через программу Skype) .
7) Робот начнет перечислять варианты активации.
8) Нажмите на телефоне 1 (Активировать продукт Майкрософт).
9) На вопрос на скольких компьютерах установлен продукт, нажмите 1.
10) Когда вас попросят ввести код, введите. В ответ робот продиктует 8 блоков по 6 цифр (каждый блок дважды для проверки).
11) Внесите цифры в окно активации.
12) Нажмите Далее. Интернет, может быть отключен (без разницы).
Windows 7 активирована.

Назад на страницу раздела Разное.


11. Быстрое переключение с одного монитора на другой или с монитора на проектор.

Данное действие осуществляется нажатием клавиш Win+P. Вы также можете запустить DisplaySwitch.exe и выбрать предпочитаемый дисплей. Вызов данной утилиты не будет иметь результатов, если к компьютеру подключен только один монитор.

Назад на страницу раздела Разное.


12. Где можно скачать справочник от Microsoft, содержащий полное описание утилит командной строки?

Вы можете скачать справочник от Microsoft (на английском языке), содержащий полное описание утилит командной строки.

1) Перейдите по ссылке http://www.microsoft.com/downloads/en/details.aspx?FamilyID=5fb255ff-72da-4b08-a504-1b10266cf72a
2) Нажмите Download.

Назад на страницу раздела Разное.


13. Уточнение времени работы компьютера с момента последней загрузки.

Вариант 1.

Если Вам необходимо узнать сколько времени работает Ваш компьютер с момента последней загрузки, то Вы можете создать скрипт-файл и запускать его при необходимости.

1) Скопируйте указанный выше код в любой текстовый редактор (например, Блокнот).
2) Нажмите CTRL+S и сохраните файл с любым именем и расширением .vbs в любой папке (Например, на диске C:)
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "crp.vbs")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Чтобы узнать сколько времени работает компьютер, просто запустите созданный Вами скрипт, как обычную программу.

Вариант 2.

Скачайте и установите специальный гаджет.

systemuptime_sevengadgets.ru.zip

Назад на страницу раздела Разное.


14. Автоматическая очистка временных папок при выходе из Windows.

Чтобы не чистить вручную временные папки: C:\Users\Administrator\AppData\Local\Temp или C:\Users\YourNickname\AppData\Local\Temp и C:\Windows\Temp, Вы можете автоматизировать данный процесс при выходе из системы.

1) Создайте командный файл сценария:

Инструкция:

1. Скопируйте код в любой текстовый редактор (например, Блокнот).
2. Нажмите CTRL+S и сохраните файл с любым именем и расширением .cmd
3. Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "tempdirclean.cmd")
4. Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

2) Скопируйте его для удобства в корневую папку диска С:
3) Запустите редактор групповых политик: Пуск -> Выполнить -> gpedit.msc или Win+R -> gpedit.msc
4) Откройте ветвь Конфигурация пользователя > Конфигурация Windows > Сценарии (вход/выход из системы).
5) В правой части два раза кликните по параметру Выход из системы или нажмите правую кнопку мыши и выберите пункт Свойства.
6) Нажмите кнопку Добавить, укажите месторасположение созданного Вами командного файла c:\tempdirclean.cmd
7) Нажмите Ок, затем снова Ок
Теперь при выходе из системы, а также при завершении работы временные папки очистятся автоматически.

Внимание: Если по указанной выше схеме Вы добавите командный файл сценария в свойства параметра Выход из системы, находящийся в ветке Конфигурация компьютера > Конфигурация Windows > Сценарии (запуск/завершение), то пользовательская временная папка очищена не будет, а очистится только временная папка самой Windows.

Готовый CMD-файл Вы можете скачать по ссылке: tempdirclean.zip

Назад на страницу раздела Разное.


15. Где в Windows 7 хранятся значки (иконки)?

Если Вы хотите использовать одну из иконок (значков) Windows 7, то большую их часть Вы можете найти в следующих файлах:

C:\Windows\System32\shell32.dll
C:\Windows\System32\imageres.dll

Для извлечения необходимой Вам иконки:

1) Откройте один из предложенных файлов, с помощью программы Restorator.
2) В панели Дерево ресурсов откройте папку Иконка
3) Выберите любую из понравившихся Вам иконок.
4) В панели Дерево ресурсов щелкните правой кнопкой мыши на данном ресурсе и выберите Извлечь... > Извлечь как "имя_ресурса.ico"
5) Выберите папку для извлечения и нажмите Сохранить

Вы также можете извлечь все иконки сразу, для этого:
6) В панели Дерево ресурсов щелкните правой кнопкой мыши на папке Иконка и выберите Извлечь... > Извлечь все как тип "Иконка"
7) Выберите папку для извлечения и нажмите OK

Назад на страницу раздела Разное.


16. Извлечение MS-DOS образа из файла diskcopy.dll и дальнейшая работа с ним.

16. Извлечение загрузочного MS-DOS образа из файла diskcopy.dll и дальнейшая работа с ним.

Многие используя в Windows функцию Форматировать, замечали пункт Создание загрузочного диска MS-DOS. Он используется для создания загрузочного диска MS-DOS на определенных типах устройств, для других же типов устройств он заблокирован.
Выясняя откуда Windows берет образ MS-DOS для записи, я узнал что он содержится в файле diskcopy.dll. Но тут появился другой вопрос, а как его оттуда извлечь? Предлагаю Вам несколько способов его извлечения.

Способ 1 Использование редакторов ресурсов.

Открываете файл diskcopy.dll любым редактором ресурсов и извлекаете(сохраняете) ресурс 1 из папки BINFILE как diskcopy.img

Способ 2 Программа Disk Extract

1) Указываете в поле File(s) to search and extract byte sequence (wildcards *.* accepted) - файл для поиска и извлечения необходимого количества байтов: C:\Windows\System32\diskcopy.dll
2) Указываете в поле Byte sequence to find - с какого байта искать: EB3C90
3) Указываете в поле Bytes to copy - сколько байт скопировать: 1474560
4) Указываете в поле Save as - куда и под каким именем сохранить (например так): D:\Temp\diskcopy\diskcopy.img
5) Нажимаете на кнопку Play
6) В появившемся окне Confirm нажимаете Yes

Способ 3 Программа GETBTDSK со скриптом

Запускаете файл GETBTDSK.bat и получаете в итоге готовый файл diskcopy.img
Некоторые антивирусные программы могут воспринять попытку её обращения к системному файлу как разновидность вируса, поэтому для работы скрипта либо изолируйте файл GETBTDSK.EXE, или папку где он находится из поиска антивирусной программой, либо воспользуйтесь первым способом.

Хорошо, образ мы извлекли и у нас есть готовый файл diskcopy.img. Что же дальше, спросите Вы. А дальше, Вы можете:

1) Распаковать полученный файл с помощью программы архиватора 7zip и дальше работать с файлами по-своему усмотрению.

2) Записать загрузочный MS-DOS образ diskcopy.img на USB флеш-накопитель (флешку).

1. Открываете файл diskcopy.img в программе UltraISO
2. Выбираете Самозагрузка -> Записать образ жесткого диска...
3. Метод записи оставляете USB-HDD+
4. Нажимаете Записать

Чтобы не искать в интернете эти программы, Вы можете скачать архив с ними: msdosboot.zip

Назад на страницу раздела Разное.


17. Термины и сокращения используемые Microsoft для маркировки своих продуктов.

Скачивая какой-либо продукт Microsoft в интернете, помимо его названия Вы можете увидеть дополнительные обозначения в наименовании. Если Вам интересно, что означает "CTP", "Escrow", "LDR", "RC", "RTM" и тому подобное - предлагаю Вам, расшифровку особо часто встречающихся из них.

BBT - Basic Block Tools или Binary Profile Feedback Optimization framework
BBT - пакет инструментов оптимизации, помогающий уменьшить требования к рабочему набору Win32 приложения. Для этого применяется дополнительный статический анализ и эвристика кода. Также в результате мониторинга потока выполнения программы происходит интеграция профиля данных. Для дополнительной компрессии страниц памяти, BBT реорганизовывает статистические данные и секции ресурсов.
BBT - специальный анализатор, оптимизирующий величину кода, путем игнорирования не используемой части, и архивации оставшейся.
Другое значение BBT - это “Black Box Testing”, тестирование "чёрного ящика" или что-то в этом духе.

BVT - Build Verification Test
Небольшой набор тестов, проверяющих уровень качества сборки, на этапе её создания. Например, BVT для Блокнота может выглядеть как: "Запустить, напечатать текст, сохранить, выйти". Если сборка не проходит данный тест, то во избежание дальнейших ошибок при тестировании, она отправляется на доработку. Порядок действий BVT редко меняется, а результаты - тщательно контролируются.

CPP - Customer Preview Program
Программа предварительного ознакомления.

CTP - Community Technology Preview
Предварительный технологический релиз для сообщества, впервые использован для сборки Vista build 5219, так называемый январский CTP.

DNSRV - .NET (DotNet) Server
Раннее кодовое имя Windows Server 2003.

EBS - Essential Business Server
Серверное решение от Microsoft, имеет в своей основе ядро Windows Small Business Server 2008, ориентировано на рынок среднего бизнеса.

EDW - External Developer Workstation
Этот термин, использовался во времена разработки Windows Vista, для обозначения сборок выпущенных между RC и RTM сборками.

Escrow
Сборки, не имеющие серьёзных ошибок. Они, как правило, становятся в итоге Релиз-кандидатами или RTM (после того, как сборка подписана к выпуску).

Exit Criteria
Набор тестов, проверяющих наиболее важные аспекты корректной работы основных функций приложения. Как выглядит тот или иной тест, определяется командой-разработчиком функции, результаты прохождения теста должны точно совпадать с ожидаемыми. Полное прохождение таких тестов ознаменует переход к следующему этапу разработки.

FBL - Feature build lab
Группа разработки какого-либо функционала.

FVT - Feature Verification Tests
Тоже самое, что и BVT, только для конкретной функции.

GA - General Availability
Означает, что програмное обеспечение доступно на основном рынке через Интернет или на каком-либо физическом носителе.

GDR - General Distribution Release
Используется для обновлений и хотфиксов, содержащих только заплатки критических ошибок и исправления, влияющие на стабильность.

HSBS - Home and Small Business Server

IDS - Internal Developer Server

IDW - Internal Developer Workstation

IDX - Internal Developer Client/Server

LCTP - Limited Community Technology Preview
Ограниченный предварительный технологический релиз.

LDR - Limited Distribution Release
Используется для обновлений и хотфиксов, содержащих “прочие” исправления, как правило, для ошибок, возникающих у весьма специфической группы пользователей.

MMS - Mid-Market Server
Раннее название Essential Business Server.

QFE - Quick Fix Engineering
Аналогично LDR.

QHSV - Q Home Server
Раннее название Windows Home Server.

RC - Release Candidate
Качество сборки на данной стадии разработки наиболее близко к стабильному, критические ошибки уже исправлены, однако, в ходе текущего тестирования могут быть найдены новые ошибки.

RDP - Rapid Deployment Program

RTM - Release To Manufacturing
Стабильная сборка, прошедшая все стадии тестирования, в которой исправлены все найденные ошибки, и готовая к применению.

RTW - Release To Web
Это RTM, предназначенный для распространения через Интернет.

SBS - Small Business Server

Self host
Сброки, прошедшие тесты Exit Criteria tests, готовые к более глубокому тестированию.

Self test
Сборки, прошедшие BVT и FVT тесты.

Self toast
Сборки, не прошедшие BVT.
Sign-off
Подписание, означает, что функция/продукт готова к продаже.

TAP - Technology Adoption Program
Программа технологического утверждения, в ходе которого собираются отзывы тестеров, в качестве которых могут выступать и заказчики компании.

TP - Technical Preview

VBL - Virtual Build Lab
Термин обозначает группу разработчиков объединенных в виртуальную лабораторию.

WHS - Windows Home Server

WSSG - Windows Server Solutions Group

WSUS - Windows Server Update Services

Назад на страницу раздела Разное.


18. Удаление установленного обновления.

Если Вы установили обновление в Windows, для добавления дополнительной функции, а оно Вам не понравилось, то Вы можете спокойно его удалить.
Для удаления любого обновления сделайте следующее:

1) Откройте Панель управления\Программы
2) Нажмите на ссылку Просмотр установленных обновлений
3) Нажмите правой кнопкой на любом обновлении, которое желаете удалить и щелкните на появившемся слове Удалить.
4) В случае необходимости, перезагрузите компьютер.

Назад на страницу раздела Разное.


19. Создание значков управления состоянием компьютера.

Для быстрого изменения состояния системы Вы можете создать на рабочем столе ярлыки позволяющие изменить его одним нажатием мыши.

Для создания ярлыков выполните следующие действия:
1) Нажмите правую клавишу мыши на рабочем столе, выберите пункт меню Создать -> Ярлык
2) В поле Укажите расположение объекта введите необходимую команду для создания ярлыка и нажмите OK.

Блокировка компьютера

Выход из системы

Завершение работы

Перезагрузка

Сон

Назад на страницу раздела Разное.


20. Копирование текста из окон сообщений и всплывающих оповещений в буфер обмена.

Текст из окна сообщения Windows выделить для копирования невозможно, так как он заблокирован. Но Вы можете скопировать данный текст в буфер обмена.
Для того чтобы это нажмите комбинацию клавиш Ctrl+C, а затем вставьте текст из буфера в любой текстовый редактор используя комбинацию клавиш Ctrl+V. Окно, текст которого нужно скопировать, должно быть активным.
Например, попробуйте закрыть окно оснастки Службы при открытом окне свойств отдельной службы, и Вы увидите одно из таких сообщений Windows.

Назад на страницу раздела Разное.


21. Удаление данных без возможности восстановления.

При удалении файла или папки, не происходит полного физического удаления информации, очищается лишь только «оглавление» файловой системы. С помощью утилиты cipher возможно частичное решение этой проблемы, так как существует возможность выполнить очистку свободного места на диске затиранием её.
Место, занимаемое содержимым папки, будет перезаписано нулями, потом единицами, а после этого - набором случайных символов в каждом секторе.

Для полного удаления данных:

1) Удалите необходимые файлы или папки из Вашего каталога, которые должны быть затерты.
2) Запустите командную строку с правами администратора
2.1) Нажмите кнопку Пуск
2.2) В строке поиска введите cmd
2.3) Щелкните на найденной программе правой кнопкой мыши и выберите Запуск от имени администратора
3) В командной строке введите:

каталог - путь к любой папке на разделе подлежащим очистке. (Например: cipher /w:c:\temp) Если Вы удалили папку или файл из корня диска, то Вы можете указать в качестве пути только букву диска. (Например: cipher /w:c:\)

Назад на страницу раздела Разное.


22. Выполнение дефрагментации дисков в Windows 7 используя командную строку.

В Windows существует программа Дефрагментация диска. Данная программа производит упорядочение фрагментированной информации для более эффективной работы дисков и дисководов. Программа дефрагментации диска работает по заданному расписанию, но можно запускать анализ и дефрагментацию дисков вручную. В программе Вы можете увидеть время прошлого запуска, уровень фрагментированности дисков и запланированное время следующего запуска.
Если Вы не отключали планировщик заданий, значение уровня фрагментированности дисков будет равно 0%, а при нажатии кнопки Анализировать диск система покажет уровень фрагментированности не более 10%. При желании Вы можете запустить дефрагментацию вручную нажав кнопку Дефрагментация диска или настроить запуск по расписанию, в удобное для Вас время.

Графический интерфейс программы Вы можете запустить: Пуск -> Все программы -> Стандартные -> Служебные. Однако он весьма ограничен в возможностях, и их хватит начинающему или малоопытному пользователю, если же Вы продвинутый или опытный пользователь, то Вам будет интересен командный режим данной программы.

1) Нажмите кнопку Пуск и в строке поиска наберите cmd
2) Нажмите на найденной программе правой кнопкой мыши и выберите пункт Запуск от имени администратора.
3) Вы можете запустить утилиту defrag.exe используя следующие параметры командной строки:

Параметр | Описание
/A | Анализирует указанный том. Логично выполнить анализ перед ручной дефрагментацией. В результатах будет сказано, каким разделам она нужна.
/C | Выполняет операцию на всех томах. Этот параметр избавляет от необходимости перечислять все буквы разделов при анализе или дефрагментации.
/E | Выполняет операцию на всех томах, кроме указанных. Еще один параметр, экономящий время.
/H | Выполняет операцию с обычным приоритетом (по умолчанию используется низкий). Ускоряет процесс дефрагментации, но может замедлить работу других приложений, обращающихся к диску в это время.
/M | Выполняет операцию на всех томах одновременно в фоновом режиме. Стандартное поведение дефрагментатора – последовательная работа над томами.
/T | Отслеживает текущую операцию на указанном томе.
/U | Выводит прогресс текущей операции на указанном томе в процентном отношении.
/V | Выводит подробный отчет о томах, их фрагментированности, файлах и папках, а также о свободном пространстве и MFT.
/X | Объединяет свободное пространство на указанных томах.
/R | Выполняет частичную дефрагментацию (поведение по умолчанию), пытаясь объединять только фрагменты размером менее 64 Мб.
/W | Выполняет полную дефрагментацию, пытаясь объединять любые фрагменты вне зависимости от их размера.
/F | Выполняет принудительную дефрагментацию, даже если на диске недостаточно свободного пространства.

Примеры команд

Команда | Описание
defrag /A /C /U /V | Анализирует фрагментированность всех разделов, отображая ход операции, и выводит подробный отчет.
defrag C: /W /V | Выполняет полную дефрагментацию раздела C, а затем выводит подробный отчет.
defrag C: /E /H /F | Выполняет дефрагментацию всех разделов кроме C с обычным приоритетом вне зависимости от количества свободного пространства на них.

Назад на страницу раздела Разное.


23. Уменьшение размера файла изображения без потери качества.

Если у Вас хранится большое количество файлов изображений на компьютере или Вы добавляете изображения в текстовые документы или Вы размещаете их в интернете, то данный совет поможет Вам уменьшить занимаемое ими место без потери качества.

1) Скачайте и разархивируйте в любую удобную Вам папку архив PictureBeaver.zip
2) Выделите необходимый Вам файл-изображение, группу файлов или папку с изображениями
3) Перетащите выделенное на файл optimize.wsf.
4) Откроется окно командной строки (процесс действий в окне отображаться не будет), по завершении процесса оптимизации оно само закроется .
5) Результаты появятся в той же папке, где и Ваши исходные файлы изображений. Оптимизированные файлы изображений будут в папке (папках) Optimized, отчёт о сэкономленном объеме в файле Optimization Report.html

Данный скрипт для оптимизации использует программы:

gifsicle - для оптимизации GIF изображений
jpegtran - для оптимизации JPG изображений
optipng - для оптимизации PNG изображений

Назад на страницу раздела Разное.


24. Где можно скачать последнюю версию DirectX?

Официальный сайт для скачивания последних версий DirectX находится по ссылке ниже:

Официальный сайт DirectX
Полная версия: DirectX End-User Runtimes
Web версия(обновляется раньше, чем полная): DirectX End-User Runtime Web Installer

Назад на страницу раздела Разное.


25. Запуск программы с определенной датой без изменения системных настроек.

Если Вы являетесь разработчиком программного обеспечения и по истечении тестового периода работы Ваша программа должна прекратить работу по причине выхода финальной версии или же Вам просто интересно как будет работать программа при изменении даты, то Вам нет необходимости изменять настройки системы.

Для запуска программы с определенной датой в прошлом или будущем Вы можете скачать программу RunAsDate

Вы можете запустить необходимую Вам программу непосредственно из программы RunAsDate или же создать ярлык для запуска с Рабочего Стола.

Назад на страницу раздела Разное.


26. Изменение атрибутов и времени/даты создания, изменения и открытия (доступа) файла.

Если Вам необходимо изменить дату создания, дату изменения и дату открытия (доступа) файла, то для этого Вы можете воспользоваться программой BulkFileChanger, которую Вы можете скачать здесь.

Чтобы изменить атрибуты и/или любую из указанных времени/дат, сделайте следующее:

1) Добавьте Ваш файл в программу.
1.1) Воспользуйтесь методом тащи-и-бросай (drag-and-drop), просто перекиньте Ваш файл на окно программы.
или
1.2) В главном меню выберите Файл -> Добавить файлы (клавиша F2), выберите файл(ы) для добавления и нажмите Открыть.

2) Выделите файл(ы) и в главном меню выберите Действия -> Изменить время/атрибуты (клавиша F6)
3) Установите необходимые атрибуты и/или время/дату файла и нажмите кнопку Выполнить.

Примечание. Если Вы не живете в Великобритании, Гренландии, Ирландии, Исландии, Португалии или Канарских островах, то не забудьте снять флажок Время указано по Гринвичу.

Назад на страницу раздела Разное.


27. Список всех обновлений вошедших в SP1 с краткими объяснениями и ссылками.

Если Вам необходимо узнать какие обновления вошли в Сервисный пакет обновлений 1, то Вы можете скачать с сайта Microsoft документ в котором описаны все обновления вошедшие в него, и также даны краткие пояснения и ссылки на страницы самих обновлений.

Скачать: Hotfixes and Security Updates included in Windows 7 and Windows Server 2008 R2 Service Pack 1.xls

Файл при запуске откроется на странице Legal Disclaimer, для прочтения кратких пояснений к каждому вошедшему в SP1 обновлению и уточнения принадлежащих им ссылок перейдите в xls-файле на страницу Update List.

Назад на страницу раздела Разное.


28. Список горячих клавиш, используемых в окне команд Windows 7.

В окне командной строки также как и в других окнах Windows существует набор используемых горячих клавиш, которые Вы можете использовать.

Стрелка вверх - переход к раннее введенной команде.
Последовательно нажимая стрелку вверх, в командной строке будет появляться предыдущая введенная команда.

Стрелка вниз - переход к позднее введенной команде.
Перейдя стрелкой вверх к самой первой команде, можно вернуться к последней нажимая стрелку вниз.

ESC - очистка строки ввода.
При нажатии стрелок для перемещения, переход по истории команд продолжится с того же места, где Вы остановились.

Tab - автозавершение названия файла/папки.
Пример: Если находясь в корне диска C:, Вы введете команду cd prog и нажмете клавишу Tab, то у Вас автоматически отобразится cd "Program Files".
При наличии объектов с одинаково начинающимися названиями нажимайте Tab, до появления необходимого значения. Подстановка имен происходит в алфавитном порядке.
Если в 64-битной системе, учитывая предыдущий пример, Вы нажмете клавишу Tab снова, то у Вас автоматически отобразится cd "Program Files (x86)".

F1 - побуквенный ввод выбранной команды из истории команд.

F2 - скопировать в строку ввода часть командной строки, выбранной в истории, от начала строки до указанного Вами символа.
Копируется именно выбранная команда стрелочками, а не тот текст, что введен в данный момент.

Пример работы:
Выберите в истории, необходимую команду. Для примера: cd "Program Files"
Нажмите ESC. Строка очистится.
Нажмите F2. В появившемся диалоге нажмите m. В строке отобразится: cd "Progra

F3 - вставка текущей команды из истории.

F4 - удаление до указанного символа в текущем набранном тексте

F5 - вставка предыдущей команды из истории.

F7 - отображение нумерованного списка историю команд.

F8 - аналог клавиши "Стрелка вверх".

F9 - ввод команды из истории команд по ее номеру. Под номером понимается цифра, присвоенная команде в списке, отображаемом по F7.

Alt+F7 - очистка истории команд.

Ctrl+C - прекращение выполнения текущего командного файла или консольного приложения.

Назад на страницу раздела Разное.


История версий

Дополнительная информация об порядке внесения изменений:

Принципы добавления новых советов:

1) Если из раздела ничего не перемещалось, то каждый новый совет добавляется в конец списка соответствующего раздела.
2) Если из текущего раздела что-либо перемещалось в другой раздел сборника, то взамен перемещенного совета добавляется либо последний из текущего списка раздела, либо добавляется новый совет с соответствующей тематикой.
(За исключением рокировок - когда совет из текущего раздела меняется местом с советом из другого раздела.)

Размер дополнений различен от изменения нескольких букв в одном, до полного переписывания заново другого.

Принципы смыслового или стилистического обновления имеющихся советов:

1) Информация добавляется в конец существующего совета.
2) Информация исправляется внутри самого совета.
3) Информация перезаписывается полностью взамен имеющейся.
4) Изменяется структура совета - добавляется пошаговость.
5) Исправляются опечатки первого и второго типа.

Опечатки первого типа - не изменяющие смысловой нагрузки (пример):

введите комманду -> введите команду
запустите програму -> запустите программу

Опечатки второго типа - изменяющие смысловую нагрузку (пример):

taskkill /IM /F explorer.exe -> taskkill /F /IM explorer.exe
Опечатки второго типа почти не встречаются. Их исправление происходит ещё в процессе проверки совета перед добавлением в сборник, так как изначально создается черновой вариант совета в блокноте, а затем он вручную превращается в готовый htm-файл.

Поэтому, в связи с выше изложенным, обо всех изменениях указывается - обобщенно.

Так что, если Вам понадобилось решение, используйте встроенные мною в сборник вкладки: алфавитный Указатель - для поиска по названию совета или Поиск - для поиска по слову или фразе.

Изменения в версии 3.78.

Добавлен новый раздел в сборник Твики Реестра - Общие.
В "Историю версий" добавлена дополнительная информация о порядке внесения изменений
Исправленные найденные ошибки.
Некоторые советы дополнены.
Добавлено 11 новых советов.

Изменения в версии 3.67.

Некоторые советы дополнены.
Добавлено 9 новых советов.

Изменения в версии 3.58.

Некоторые советы дополнены.
Добавлено 13 новых советов.

Изменения в версии 3.45.

Изменен очень яркий фон текстового поля с желтого на более мягкий оливковый-зеленый.
Некоторые советы дополнены.
Изменено месторасположение советов и разделов
Добавлена Дополнительная информация в Инструкцию использования данного справочника.
Исправлены найденные ошибки.
Удален 1 совет.
Добавлено 29 новых советов.

Изменения в версии 3.17.

Переработана структура сборника, включая содержание и индекс
В разделе Твики Реестра созданы тематические подразделы.
Изменено наименование и месторасположение советов.
Многие советы переписаны и объединены с другими.
Дополнена инструкция использования данного справочника.
Заменены теги длинных цитат на теги текстового поля.
Обновлены ссылки на некоторые программы.
Заменены изображения в некоторых советах.
Заменен шрифт кнопки Показать/Скрыть.
Вид курсора при наведении на кнопку приобретает форму руки.
Оптимизирован код для уменьшения размера сборника
Исправлены найденные ошибки.
Добавлено 28 новых советов.

Изменения в версии 2.90.

Исправлены ошибки в html-коде и в индексе.
Некоторые советы обновлены.
Добавлено 10 новых советов.

Изменения в версии 2.80.

В раздел Интерфейс добавлены 2 подраздела: "Внешний вид" и "Взаимодействие"
Исправлены найденные ошибки
Изменено наименование и/или месторасположение некоторых советов.
Некоторые советы дополнены.
Добавлено 15 новых советов.

Изменения в версии 2.65.

Исправлены найденные ошибки
Изменено месторасположение некоторых советов.
Некоторые советы обновлены.
Добавлено 10 новых советов.

Изменения в версии 2.55.

Исправлены найденные ошибки.
Изменено наименование и/или месторасположение некоторых советов.
Некоторые советы дополнены или переписаны заново.
Добавлено 12 новых советов.
В том числе, переписан заново совет из раздела Тонкие настройки: 8. Использование всей оперативной памяти в 32-битных Windows.

Изменения в версии 2.43.

Подраздел Интерфейс и загрузка из раздела Устранение неполадок переименован в Администрирование и Интерфейс.
Изменено месторасположение некоторых советов.
Многие советы дополнены и/или переписаны заново.
Исправлены найденные ошибки
Добавлен 21 новый совет.

Изменения в версии 2.22.

Исправлены незначительные ошибки.
Некоторые советы дополнены и переписаны заново.
Добавлено 10 новых советов.

Изменения в версии 2.12.

Исправлена ошибка дублирования неотображенных советов в коде.
Часть советов дополнена.
Добавлено 4 новых совета.

Изменения в версии 2.08.

Исправлен порядок в Индексе.
Добавлено 4 новых совета.
Удален 1 совет.

Изменения в версии 2.05.

Переработана структура сборника.
Советы из раздела "Устранение неполадок" рассортированы на подразделы.
Советы из "Твики реестра - Восстановление" перемещены в подразделы "Устранение неполадок".
Для удобочитаемости переход к странице подраздела, заменен на переход к якорю внутри страницы раздела.
Некоторые советы переименованы и обновлены.
Информация об изображениях и ссылки на них изменены в соответствии с новой структурой сборника.
Добавлено 3 новых совета.

Изменения в версии 2.02.1.

Исправлена ошибка ссылок и нумерации нескольких советов в Содержании и Указателе.

Изменения в версии 2.02.

Добавлен эффект прокручивания изображений колесом мыши(курсор при прокручивании должен быть на изображении)
Некоторые советы обновлены.
Добавлено 12 новых советов.

Изменения в версии 1.90.

Удалено несколько советов.
Некоторые советы обновлены.
Добавлено 16 новых советов.
Исправлены незначительные ошибки.

Изменения в версии 1.77.

Многие советы обновлены и переписаны заново
Добавлен новый раздел Виртуализация, поэтому переработана структура сборника
Обновлены ссылки на некоторые программы
Произведен точный перерасчет количества советов.
Добавлено 28 новых советов

Изменения в версии 1.49.

Переработан индекс сборника, что позволяет осуществить более точный поиск, через вкладку Указатель или вкладку Поиск
Исправлены грамматические, орфографические и синтаксические ошибки
Обновлены несколько советов
Добавлено 9 советов

Изменения в версии 1.40.

Добавлен новый раздел Твики Реестра с подразделами, поэтому переработана структура сборника
Многие советы заменены или обновлены
Исправлена ошибка, при которой внешние ссылки указанные на отдельных страницах некоторых советов, открывались в самой справке. Теперь они открываются в новом окне интернет браузера.
Добавлен 1 совет

Изменения в версии 1.39.

Исправлены грамматические, орфографические и синтаксические ошибки
Добавлен 1 совет

Изменения в версии 1.38.

Обновлены ссылки на версии программ.
Исправлена ссылка на изображение в одном из советов
Добавлен 1 совет

Изменения в версии 1.37.8.

Исправлены грамматические, орфографические и синтаксические ошибки
Исправлены ссылки на некоторые страницы и изображения
Добавлен 1 совет

Изменения в версии 1.37.

Исправлены ошибки распознавания кодировки на некоторых страницах
Многие советы заменены или обновлены
Если в совете более одного изображения, то они сгруппированны в галерею
Добавлено 8 советов

Изменения в версии 1.29.

Добавлена функция предпросмотра для изображений(увеличение по клику) в общем списке и в страницах разделов
Добавлена История версий
Добавлено 4 совета

Изменения в версии 1.25.1.-1.25.3.

Исправлены грамматические и синтаксические ошибки

Изменения в версии 1.25.

Исправлены грамматические и синтаксические ошибки
Заменены некоторые ссылки
Добавлен 1 совет

Изменения в версии 1.24.

Переписан исходный код страниц
Улучшена (упрощена) навигация в сборнике
Советы сгруппированы по темам (разделам)
Спойлерам добавлен эффект слайда
Спойлеры оставлены только в общем списке и в списках разделов
Убраны спойлеры в отдельных страницах для каждого совета
Добавлены меняющиеся надписи на кнопках.
Исправлены старые и добавлены новые советы (14 штук)

Изменения в версии 1.10.

Исправлена невозможность выделения в общем списке после 49 совета
Исправлена невозможность выделения в 49 совете
Заменены ссылки на оригинальные скрипты
Добавлено принудительное определение кодировки как windows-1251
Добавлено 2 новых совета

Версия 1.08.

Первая версия